EP7402-0057 - EtherCAT device for controlling MDR conveyor

Documentation

EP7402-0057 | 2-channel motor controller box for roller conveyor systems

2020-11-02 | Version 1.0
More information: www.beckhoff.com/ep7402-0057/

© 2020 Beckhoff Automation


Foreword

Further Information
  • Notes on the documentation
  • Safety instructions
  • Documentation issue status

© 2020 Beckhoff Automation

EP7402-0057 | 2-channel motor controller box for roller conveyor systems


Notes on the documentation

Intended audience

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.

We reserve the right to revise and change the documentation at any time and without prior announcement.

No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.

Copyright

© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety regulations

Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.

Exclusion of liability

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.

Personnel qualification

This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of instructions

In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!

DANGER
Serious risk of injury!

Failure to follow this safety instruction directly endangers the life and health of persons.

WARNING
Risk of injury!

Failure to follow this safety instruction endangers the life and health of persons.

CAUTION
Personal injuries!

Failure to follow this safety instruction can lead to injuries to persons.

Note
Damage to environment/equipment or data loss

Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.

Tip or pointer

This symbol indicates information that contributes to better understanding.


Documentation issue status

Version

Comment

1.0

  • First release

Firmware and hardware versions

This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.

The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.

Documentation version | Firmware | Hardware
1.0 | 01 | 02

The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.

Syntax of the batch number (D-number)

D: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with D no. 29 10 02 01:

29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01

Further information on this topic: Version identification of EtherCAT devices.


Product overview

Further Information
  • Introduction
  • Technical data
  • Process image


Introduction

EP7402-0057

2-channel motor controller box for roller conveyor systems

The EP7402-0057 EtherCAT Box offers two outputs with integrated controller for the direct connection of 24 V DC conveyor roller motors or other BLDC motors with max. 3.5 A. Eight additional digital inputs/outputs enable connection of e.g. photoelectric switches and communication between the box modules in operation without PLC.

The EP7402-0057 takes over the complete control of a roller motor independently of the manufacturer of conveyor or motor. Maximum rated current, acceleration or deceleration ramps and various other parameters can be configured and allow for a wide range of adaptations to different applications. The control of the motors is sensorless.

The EtherCAT Box with IP 67 protection rating measures only 174 mm x 60 mm x 36.5 mm and can be easily mounted in standard C-channel or L-brackets on the conveyor frame. It requires no additional protective covering. Power supply and EtherCAT communication are realized via a B23 ENP connector with a current carrying capacity of 28 A/45 °C. In conveyor operation the EP7402-0057 can also be operated without PLC and provides functions such as ZPA (Zero Pressure Accumulation), single or block discharge. Further EtherCAT devices such as digital and analog I/Os, barcode readers or safety devices can be connected to the additional EtherCAT junction.

Quick links

Technical data
Process image
Dimensions
Quick start


Technical data

All values are typical values over the entire temperature range, unless stated otherwise.

Technical data

EP7402-0057

Fieldbus

Fieldbus

EtherCAT

Electrical isolation

500 V (fieldbus / IO)

Connectors

Input and forwarding: B23 hybrid connectors

Junction: M8 socket, green

Distributed Clocks

yes

Supply voltages

Connectors

B23 hybrid connectors

Control voltage US

Nominal voltage

24 VDC (-15 % / +20 %)

Sum current

max. 28 A at 45 °C 1)

Current consumption from US

150 mA at 24 VDC

Additional consumers

Loads on digital outputs

Peripheral voltage UP

Nominal voltage

24 VDC (-15 % / +20 %)

Sum current

max. 28 A at 45 °C 1)

Consumers

  • Motors
  • Motor brake

Undervoltage detection threshold

18 VDC

Overvoltage detection threshold

30 VDC

Motor output stage

Number of channels

2

Motor type

3-phase BLDC roller motors

Encoder

Encoder not required

Connectors

2x M8 socket, b-coded

Motor voltage

24 VDC from the peripheral voltage UP

Continuous current per channel

max. 3.5 A

Peak current per channel

max. 5 A (approx. 1 s)

Rotary field frequency

max. 72000 °/s = 12000 rpm 2)

Motor brake (digital output)

Rated voltage

24 VDC from peripheral voltage UP

Output current

max. 1 A

1) Sum current of consumers and power forwarding. This value corresponds to the
current carrying capacity of the connectors for the supply voltages.

2) Do not confuse the rotary field frequency with motor speed or roller speed.

Technical data | EP7402-0057
Digital in-/outputs
Number of inputs / outputs | 8
Connectors | 4x M8 socket
Input specification
Characteristics | Type 3 according to EN 61131-2, compatible with type 1
Input filter | 10 µs
Output specification
Nominal output voltage | 24 VDC (-15 % / +20 %) from control voltage US
Output current | max. 0.5 A per channel, short-circuit proof
Supply voltage output: US1 | 24 VDC from control voltage US max. 0.5 A, short-circuit protected
Mechanics
Weight | 750 g
Installation position | variable
Environmental conditions
Ambient temperature during operation | -25 .. +60 °C
Ambient temperature during storage | -40 .. +85 °C
Vibration / shock resistance | conforms to EN 600068-2-6 / EN600068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Approvals and conformity
Approvals | CE, UL in preparation


Process image

Process image

In the following the letter n serves as a placeholder for the channel number.

Screenshots that display process data objects of channel 1 are representative for both channels. The process data objects of channel 1 and 2 have the same structure.

DI Inputs

The input variables represent the logic level of the digital in/outputs.

Make sure that the value of the corresponding output variable is set to 0 (default) if you want to use a digital in/output as an input.

Assignment of connectors to process data

STM Status Channel n

The input variables “Status” contain the status bits of the motor channels.

Ready to enable

  • TRUE: all requirements are met for enabling the motor.
  • FALSE: The motor can not be enabled by the output variable “enable” due to an error.

Ready

  • TRUE: the motor is energized.

Warning

  • TRUE: The motor channel is in a borderline condition.

Error

  • TRUE: The motor was switched off due to an error.

Moving positive

  • TRUE: The motor velocity is above zero.

Moving negative

  • TRUE: The motor velocity is below zero.

TxPDO Toggle

This bit is inverted on each update of the status bits.

STM Synchron info data Channel n

The input variables “Info data x” contain measured values. You can choose which measured values are mapped to these variables in the CoE directory:

  • Select the measured values for Channel 1 in CoE object 8022.
  • Select the measured values for Channel 2 in CoE object 8032.

STM Inputs Device

The input variable „STM Inputs Device“ contains the Diagnosis bits that you can evaluate to isolate the reasons for warnings and errors.

DO Outputs

Output values for the digital in-/outputs.

STM Control Channel n

Enable

This bit activates the motor channel. It is without effect if the variable Ready to enable is FALSE.

Reset

Apply a rising egde to this bit to acknowledge an error.

Invert direction

If this bit is set, the target velocity is multiplied with "-1" to change the direction.

STM Target Velocity Channel n

Velocity

This is the target velocity for the velocity controller.
However, any value below parameter 80n0:09 start velocity is interpreted as zero.

Acceleration

This value specifies the maximum positive change in velocity. If the value is zero, acceleration is not limited.

Deceleration

This value specifies the maximum negative change in velocity. If the value is zero, deceleration is not limited.

Further Information
  • Assignment of connectors to process data


Assignment of connectors to process data

Connector |  |  | Process data
Name | Pin | Function | Input | Output
X01 | 2 | Digital in-/output | DI Inputs Input 2 | DO Outputs Output 2
 | 4 |  | DI Inputs Input 1 | DO Outputs Output 1
X02 | 2 | Digital in-/output | DI Inputs Control input 2 | DO Outputs Control output 2
 | 4 |  | DI Inputs Control input 1 | DO Outputs Control input 1
X05 | 2 | Digital in-/output | DI Inputs Input 4 | DO Outputs Output 4
 | 4 |  | DI Inputs Input 3 | DO Outputs Output 3
X06 | 2 | Digital in-/output | DI Inputs Control input 4 | DO Outputs Control output 4
 | 4 |  | DI Inputs Control input 3 | DO Outputs Control input 3
X20 |  | Motor | STM Status Channel 1 STM Synchron info data Channel 1 | STM Control Channel 1 STM Target Velocity Channel 1
X21 |  | Motor | STM Status Channel 2 STM Synchron info data Channel 2 | STM Control Channel 2 STM Target Velocity Channel 2


Mounting and cabling

Further Information
  • Mounting
  • Cabling


Mounting

Further Information
  • Dimensions
  • Fixing
  • Functional earth (FE)


Dimensions

Dimensions

All dimensions are given in millimeters.

Housing features

Housing material | PA66 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 4.5 mm for M4
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 30 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 174 x 60 x 36.5 mm (without connectors)


Fixing

Note
Dirt during assembly

Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.

  • Protect the plug connectors against dirt during the assembly.

Mount the module with two M4 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Earth the FE core of the supply line connected to X70.

The FE potential is passed through to the FE pin of X71. So if multiple devices are connected in series, only the FE core of the first supply line needs to be earthed.

Functional earth connection example

You can tap the FE potential at the housings of X70 and X71: use the nuts of X70 and X71 to screw on a sheet metal. So you can earth the machine part where the box is mounted.


Cabling

Further Information
  • Connector overview
  • Supply voltages and EtherCAT
  • Motors
  • Digital input/outputs


Connector overview

EP7402-0057 Connectors
Name | Function | Connector type | Tightening torque
X01 | Digital input/outputs | M8 socket | 0.4 Nm
X02 |  | M8 socket | 0.4 Nm
X05 |  | M8 socket | 0.4 Nm
X06 |  | M8 socket | 0.4 Nm
X20 | Motor connection | M8 socket, b-coded | 0.4 Nm
X21 |  | M8 socket, b-coded | 0.4 Nm
X40 | EtherCAT junction | M8 socket | 0.4 Nm
X60 | Supply voltage output | M8 socket | 0.4 Nm
X70 | Supply voltage and EtherCAT input | B23 ENP | -
X71 | Supply voltage and EtherCAT input | B23 ENP | -

Suitable connection cables can be found in the chapter Accessories.


Supply voltages and EtherCAT

The EtherCAT Box is supplied with two supply voltages. The supply voltages are electrically isolated in the EtherCAT Box.

  • Control voltage US
  • Peripheral voltage UP
Further Information
  • Input and forwarding
  • Conductor losses
  • Output


Input and forwarding

Multiple devices can be connected in series by forwarding the supply voltages and EtherCAT via X71.

Note
UP is not protected against reverse polarity

Defect possible through polarity reversal.

  • Make sure that the supply voltage UP is connected correctly.
B23 connectors
Pin | Core color 1) | Function
1 | yellow | EtherCAT Tx +
2 | white | EtherCAT Rx +
3 | blue | EtherCAT Rx -
4 | orange | EtherCAT Tx -
5 | green/yellow | FE
6 | grey | GNDP
7 | black | UP: 24 VDC
8 | blue | GNDS
9 | brown | US: 24 VDC

1) The wire colors apply to cables of the type ZK7314-3xxx-Axxx. See chapter Accessories.


Conductor losses

Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.

Variations in the voltage of the power supply unit must also be taken into account.

Voltage drop on the supply line

© 2020 Beckhoff Automation

EP7402-0057 | 2-channel motor controller box for roller conveyor systems


Output

Note
Risk of confusion

M8 connectors for supply voltages have the same design as M8 connectors for EtherCAT. Observe the color coding of the connectors in order to avoid incorrect insertion:

black: Supply voltages
green: EtherCAT

EtherCAT junction X40

M8 socket
EtherCAT | M8 connector | Core colors
Signal | Contact | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | 1 | yellow1) | orange/white | white/orange
Tx - | 4 | orange1) | orange | orange
Rx + | 2 | white1) | blue/white | white/green
Rx - | 3 | blue1) | blue | green
Shield | Housing | Shield | Shield | Shield

1) Core colors according to EN 61918

Adaptation of core colors for cables ZB9030, ZB9032 and ZK1090-3xxxx-xxxx

For standardization, the core colors of the ZB9030, ZB9032 and ZK1090-3xxx-xxxx cables have been changed to the EN61918 core colors: yellow, orange, white, blue. So there are different color codes in circulation. The electrical properties of the cables have been retained when the core colors were changed.

Suitable connection cables can be found in the chapter Accessories.

Power output X60

M8 socket
Contact | Function | Description | Core color 1)
1 | US | Control voltage | Brown
2 | UP | Peripheral voltage | White
3 | GNDS | GND to US | Blue
4 | GNDP | GND to UP | Black

1) The core colors apply to cables of the type ZK2020-3xxx. See chapter Accessories.


Motors

X20 and X21

M8 socket, b-coded
Pin | Wire color | Function
1 | brown | Motor phase U
2 | white | Motor phase V
3 | blue | Brake output
4 | black | Motor phase W
5 | grey | GNDP

Connection example

Motor connection example


Digital input/outputs

M8 sockets X01, X02, X05, X06

M8 socket
Pin | Core color 1) | Function
1 | brown | US1: 24 VDC output
2 | white | Input/output B 2)
3 | blue | GNDS
4 | black | Input/output A 2)

1) The core colors apply to cables of the type ZK2000-3xxx. See chapter Accessories.

2) Assignment to process data

Further Information
  • Connection examples


Connection examples

Digital sensor, 2-wire connection to channel A

Digital sensor, 2-wire connection

Digital sensor, 3-wire connection to channel A

Digital sensor, 3-wire connection


Commissioning

Further Information
  • Quick start
  • Determining the “Mechanical to electrical ratio” experimentally
  • Fine-tuning parameters
  • Automatic restart after error
  • Restoring the delivery state
  • Decommissioning


Quick start

Further Information
  • Step 1: Hardware Setup
  • Step 2: TwinCAT configuration
  • Step 3: Basic parameters
  • Step 4: Test run
  • Step 5: Final steps


Step 1: Hardware Setup

  1. Connect a roller motor to socket X20.
  2. Connect the supply voltages and EtherCAT to socket X70.
  • The LEDs next to X70 indicate whether both supply voltages are present:
    "24 V US"
    "24 V UP"
  • The "L/A" LED next to X70 lights up or flashes, depending on the state of the EtherCAT Master.


Step 2: TwinCAT configuration

  1. Integrate EP7402-0057 into a TwinCAT project. (Quick start guide)
  • A dialog box appears:
  2. Click "Cancel" to close the dialog box.
  3. Reset EP7402 to the factory settings:
    Change the value of the CoE parameter 1011:01 to 1684107116dec


Step 3: Basic parameters

Open the “CoE – Online” tab. Set the parameters as described below. Leave the default value for all other parameters.

Example parameters for a servo motor from Beckhoff:

AM8111-0F20-0000

Further Information
  • Index 8020 “STM Motor Settings Ch. 1”
  • Index 8023 "STM Controller Settings 4 Ch. 1"


Index 8020 “STM Motor Settings Ch. 1”

8020:01 "Peak current"

Unit: mA

The peak current, which may only flow for a short time.

8020:02 "Rated current"

Unit: mA

The rated current is the current that the motor draws when it is operated at the rated speed and rated torque.

8020:04 "Phase to phase resistance"

Unit: 0.01 Ω

DC resistance, measured between two motor phases.

8020:09 “Start velocity”

Unit: °/s (degrees per second)

There are two ways to find the value for this parameter:

  • If the nominal speed of the roller is known, use this formula:

nstart: value for parameter 8020:09 “Start velocity”

i: gear ratio. (i = 1 if no gear unit is used)

v: nom. speed in m/s (note: v[m/s] = v[fpm]/196,85)

d: roller diameter in m

  • If the nominal rotational speed of the roller motor is known, use this formula:

nstart: value for parameter 8020:09 “Start velocity”

nN: nominal speed of the motor in rpm

i: gear ratio. (i = 1 if no gear unit is used)

    • Make sure to use the nominal speed that is specified for 24 V operation.

8020:13 “Mechanical to electrical ratio”

You can calculate or experimentally determine the value for this parameter.

  • If the number of poles of the roller motor is known, use this formula:

p: value for parameter 8020:13 “Mechanical to electrical ratio”

i: gear ratio. (i = 1 if no gear unit is used)

    • Example:
      number of poles = 8
      gear ratio = 12:1
      → “Mechanical to electrical ratio” = (8 / 2) x 12 = 48
  • If the number of poles is not specified in the data sheet:
    Determine the number of pole pairs experimentally.

8020:14 "Rated velocity"

Unit: °/s

Rated speed of the roller motor.

8020:19 “Motor thermal time constant”

Unit: 1/10 s (1/10 of a second)


Index 8023 "STM Controller Settings 4 Ch. 1"

8023:03 “Disable motor diagnosis”

Set this parameter to TRUE. This disables the diagnosis feature during align phase.

8023:12 „Velocity loop proportional gain“

Set this parameter to zero. This disables the velocity controller. Reenable it after Step 4: Test run has been successfully completed.

8023:13 “Velocity feed forward”

Unit: %

Set this parameter to 100. This makes the target velocity value bypass the velocity controller.

8023:14 „Sensorless offset scaling“

Set this parameter to 80.

8023:19 “Rampup velocity”

Unit: °/s (degrees per second)

Set this parameter to the same value as parameter 8020:09 “Start velocity”.

8023:21 Rampup needed switchover events

Set this parameter to one.


Step 4: Test run

  • Requirement: all previous steps have been completed successfully.
  1. Remove any load from the conveyor roller.
  2. If the motor has a holding brake, release the holding brake:
    Set "Brake output" to 1.
  3. Set "Velocity" to 50% of the rated speed of the motor including gear unit:

n: value for output variable “Velocity”

nN: nominal speed of the motor in rpm

i: gear ratio (i = 1 if no gear unit is used)

  1. Set "Enable" to 1.
  • The rotor is aligned for 1 second.
  • The box then attempts to turn the motor.
  2. Assess the result.

Possible results of the test run

  • If the motor rotates continuously: jump to the next step of the commissioning.
  • If the motor does not rotate continuously:
    • Set the output variable "Enable" to 0
    • Check the status bits in the input variable "Device Diag"
    • Evaluate the status bits with the help of the table below.
    • Set the output variable "Reset" to 1 (this resets the status bits)
    • Set the output variable "Reset" to 0
    • Repeat the test run: Set the output variable "Enable" to 1

Set bit in "Device Diag" | Possible reasons | Solution
(none) | The output variable "Velocity" is smaller than the parameter 8020:09 "start velocity". | Check the calculations.
"Channel 1 motor overload I2T error" | The output current is too high. | Reduce the value of parameter 8023:14 "Sensorless offset scaling"
„Channel 1 commutation error“ | Too much load on the roller 1) | Remove any load from the roller during the test run.
 | The output current is too low. | Increase parameter 8023:14 “Sensorless offset scaling”
 | The ramp-up velocity is too high 1) | Check the calculation for parameter 8023:19 “Rampup velocity”. Decrease this parameter if the calculations are correct.
 | Parameter “Rampup needed switchover events” is too low. | Increase parameter 8023:21 “Rampup needed switchover events”
 | Incorrect motor settings | Check motor settings
 | Motor too weak 1) | Add a gear unit and re-calculate all parameters

1) Especially likely when the motor makes a sound with ascending pitch.


Step 5: Final steps

  1. Set the output variable "Enable" to 0.
  2. Set the parameter 8023:12 "Velocity loop proportional gain" to 100dec.
    (Any value above zero activates the velocity controller).
  • You can now control the motor with the process variables "Enable" and "Velocity".
  3. Fine-tuning of the parameters


Determining the “Mechanical to electrical ratio” experimentally

The parameter 8020:13 “Mechanical to electrical ratio“ is an essential parameter for the operation of EP7402-0057. You can calculate the parameter, if the number of poles and the gear ratio are known. Otherwise you must determine the parameter experimentally:

  1. Set the parameter 8023:03 "Disable motor diagnosis" to TRUE.
  2. Set "Velocity" to 0.
  3. Set "Enable" to 1.
  • A motor phase is powered.
  • You may hear a "click" noise from the roller motor.
  4. Rotate the conveyor roller by hand. Do you feel defined snap steps?
    - Yes: Continue below
    - No: Increase the value of parameter 8023:14 "Sensorless offset voltage" by 10dec and try again.
  5. Rotate the conveyor roller by 360° by hand and count the number of snap steps.
    Tip: Make a mark on the roller. This makes it easier to rotate the roller by exactly 360°.
  6. Set the output variable "Enable" to 0.
  7. Set the parameter 8023:03 "Disable motor diagnosis" back to FALSE.
  8. Enter the number of snap steps in parameter 8020:13 "Mechanical to electrical ratio".


Fine-tuning parameters

Further Information
  • Alignment phase and ramp-up phase
  • Velocity controller


Alignment phase and ramp-up phase

Use the following diagram to adjust the parameters of the alignment phase and the ramp-up phase. The CoE indexes of the parameters are shown in the diagram. n is the number of the motor channel.

Best practice for tuning a parameter:

  1. Set the output variable “Enable” to 0
  2. Adjust the desired parameter
  3. Set the output variable “Enable” to 1
  4. - Evaluate the result
    - Check the Diagnosis bits for warnings or errors
    - Try again if necessary.
Alignment phase and ramp-up phase parameters


Velocity controller

The velocity controller is a PI controller. The controller parameters are located in the CoE directory:

  • Proportional gain Kp: parameter 80n3:11hex “Velocity loop integral time”
  • Integral time Ti: CoE parameter 80n3:12hex “Velocity loop proportional gain”
  • Parameter 80n3:13hex “Feed forward gain”

You can disable the velocity controller by setting the proportional gain KP to zero.


Automatic restart after error

If a commutation error occurs, the motor channel affected is disabled. You can make settings so that the motor channel is automatically re-enabled and the motor restarted.

In the factory setting, the automatic restart is switched off.

Configuring automatic restart

There are two parameters with which the automatic restart can be configured:

Object |  | Parameter
80n3hex | STM Controller Settings 4 Ch. n | 25hex | Restart after error number of repetition
80n3hex | STM Controller Settings 4 Ch. n | 26hex | Restart after error delay
  • n = 2 for motor channel 1 (socket X20)
  • n = 3 for motor channel 2 (socket X21)


Restoring the delivery state

To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).

Selecting the Restore default parameters PDO

Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.

All backup objects are reset to the delivery state.

Entering a restore value in the Set Value dialog

Alternative restore value

In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164

An incorrect entry for the restore value has no effect.


Decommissioning

WARNING
Risk of electric shock!

Bring the bus system into a safe, de-energized state before starting disassembly of the devices!

Disposal

In order to dispose of the device, it must be removed.

In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.

Return the old devices with the note "for disposal" to:

Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Troubleshooting

Further Information
  • Common problems
  • Warnings and errors
  • Diagnosis bits


Common problems

Problems that may occur without a warning or an error:

Problem | Possible reasons | Possible solutions
The motor is not running | The corresponding motor channel is not enabled | Set the output variable “Enable” to TRUE.
 | The output variable “velocity” is smaller than CoE index 80n0:09hex “Start velocity”. | Compare the values.
The motor does not react to changes of the output variable “velocity”. It is running at a constant velocity. | The velocity controller was disabled by setting proportional gain to zero. | Set the CoE index 80n3:12hex “Velocity loop proportional gain” to a value greater than zero.


Warnings and errors

  • Warnings are temporary. They indicate that a measured variable lies outside of the nominal operating range.
    A warning is canceled if the measured variable returns to within the nominal operating range.
  • Errors are persistent.
    When an error occurs, the output stage of the corresponding channel is disabled until you reset the channel: Set the output variable “Reset” to 1 and back to 0.

Warnings and errors are indicated via the diagnosis variables.


Diagnosis bits

The diagnostic bits are located in the process data object "STM Inputs Device".

Bit name

Description

Possible causes

Possible Solutions

Device undervoltage

The peripheral voltage UP is lower than the undervoltage detection threshold.

Make sure that UP is within the nominal voltage range.

Device overvoltage

The peripheral voltage UP is higher than the overvoltage detection threshold.

Overtemperature warning

The internal temperature currently exceeds the warning threshold:

CoE index F80F:04
Default: 80 °C.

• The ambient temperature is too high.

• The connected motor does not meet the specifications

Operate the device only under the conditions specified in the Technical data.

Overtemperature error

The internal temperature has exceeded the error threshold:

CoE index F80F:05
Default: 100 °C.

General hardware error

The device is not able to initialize successfully.

The device is defective.

None.

Channel n openload

At least one motor phase is high-impedance.

  • A motor phase is not connected correctly.
  • A motor phase is burned out.

Check the motor connection.

Replace the motor if it is defective.

Channel n short circuit

At least one phase current has exceeded the value of the parameter “Maximal current”: CoE index 80n0:01.

The output stage was disabled.

  • A motor phase is shorted.
  • The motor is defective.

Channel n motor overload I2T warning

The calculated I2T value currently exceeds the warning threshold:

CoE index 80n0:16.
Default: 80 %.

If the warning occurs during the ramp-up phase:

The output current is too high.

Decrease the parameter “Sensorless offset scaling”: CoE index 80n3:14.

If the warning occurs during continuous operation:

Mechanical overload.

Reduce the load.

Channel n motor overload I2T error

The calculated I2T value has exceeded the error threshold:

CoE index 80n0:18.
Default: 110 %.

If the error occurs during the ramp-up phase:

The output current is too high.

Decrease the parameter “Sensorless offset scaling”: CoE index 80n3:14.

If the error occurs during continuous operation:

Mechanical overload.

Reduce the load.

Channel n amplifier overload I2T warning

The calculated I2T value of the amplifier currently exceeds the warning threshold:

Incorrect parameter setting: The thermal limit of motors that meet the specifications is usually much lower than the thermal limit of the amplifier.

Check the motor parameters: CoE index 80n0.

Channel n amplifier overload I2T error

The calculated I2T value has exceeded the error threshold:

(Continued on next page)

Bit name

Description

Possible causes

Possible Solutions

Channel n in limit

The current is currently being limited because the I2T value of the motor exceeds 97 %.

Mechanical overload

You can disable this protective function by setting the parameter 80n3:03 to TRUE.

Channel n commutation error

The commutation algorithm has detected that the rotary field and the rotor are out of sync.

If the error occurs during the ramp-up phase:

  • Mechanical overload 1)
    → Check the load
  • The output current is too low.
  • The ramp-up velocity is too low.

  • Check the roller load
  • Increase the parameter “Sensorless offset scaling”: CoE index 80n3:14.
  • Decrease parameter “Rampup velocity”: CoE index 80n3:19
  • …

If the error occurs during continuous operation:

The velocity is too low.

Retry with increased velocity.

Increase the parameter “Start velocity” (CoE index 80n0:09) to make sure that the motor will not run at too low a velocity.

1) Especially likely when the motor makes a sound with ascending pitch.


Application Notes

Further Information
  • Motor Diagnosis


Motor Diagnosis

You can use the I2T value for long-term diagnosis and wear-detection of the motor and attached mechanics.

  1. Map the I2T value to one of the “Info data” variables in “STM Synchron info data Channel n”. CoE index 80n2 “STM Features“.
  2. Monitor the “Info data” variable in a scope project.
  • This enables to recognize irregularities.

Example scope recording

© 2020 Beckhoff Automation

EP7402-0057 | 2-channel motor controller box for roller conveyor systems


CoE objects

Further Information
  • Register
  • Object descriptions


Register

Index (hex) | Name
1000 | Device type
1008 | Device name
1009 | Hardware version
100A | Software version
100B | Bootloader version
1011 | Restore default parameters
1018 | Identity
10F0 | Backup parameter handling
1600 | DO RxPDO-Map Outputs
1601 | STM RxPDO-Map Control Ch. 1
1602 | STM RxPDO-Map Target Velocity Ch. 1
1603 | STM RxPDO-Map Control Ch. 2
1604 | STM RxPDO-Map Target Velocity Ch. 2
1A00 | DI TxPDO-Map Inputs
1A01 | STM TxPDO-Map Status Ch. 1
1A02 | STM TxPDO-Map Synchron info data Ch. 1
1A03 | STM TxPDO-Map Status Ch. 1
1A04 | STM TxPDO-Map Synchron info data Ch. 1
1A05 | STM TxPDO-Map Inputs Device
1C00 | Sync manager type
1C12 | RxPDO assign
1C13 | TxPDO assign
1C32 | SM output parameter
1C33 | SM input parameter
6000 | DI Inputs
6020 | STM Inputs Ch. 1
6030 | STM Inputs Ch. 2
7010 | DO Outputs
7020 | STM Outputs Ch. 1
7030 | STM Outputs Ch. 2
8020 | STM Motor settings Ch. 1
8022 | STM Features Ch. 1
8023 | STM Controller Settings 4 Ch. 1
8030 | STM Motor settings Ch. 2
8032 | STM Features Ch. 2
8033 | STM Controller Settings 4 Ch. 2
F000 | Modular Device Profile
F008 | Code word
F010 | Module Profile List
F081 | Download revision
F600 | STM Device Diag data
F80F | STM Vendor data
F900 | STM Info data


Object descriptions

Further Information
  • Parameterization objects
  • Information objects
  • Standard objects


Parameterization objects

Adjust these parameters during commissioning.

Index 8020: STM Motor Settings Ch. 1
Index 8030: STM Motor Settings Ch. 2

Access rights: read/write

Subindex (hex) | Name | Description | Unit | Data type | Default value
01 | Peak current | If the motor current exceeds this value, the output stage of the affected channel is disabled and the diagnostic bit "Channel n short circuit" is set. | mA | UINT | 1000dec
02 | Rated current | The rated current of the motor. See motor data sheet. This parameter is used for the I2T calculation of the motor. (Thermal overload protection) | mA | UINT | 1000dec
03 | Rated voltage | The rated voltage of the motor. See motor data sheet. | 0.01 V | UINT | 2400dec
04 | Phase to phase resistance | The ohmic resistance between two motor phases. | 0.01 Ω | UINT | 100dec
09 | Start velocity | Threshold value: the motor is kept in align state if the value of the output variable “velocity” is lower than this value. If this value is too low, a commutation error may occur. | °/s | UINT | 3000dec
13 | Mechanical to electrical ratio | Set this parameter to the number of pole pairs of the motor multiplied by the gear ratio. The value for this parameter can also be determined experimentally. | - | UINT | 1
14 | Rated velocity |  |  |  | 5000dec
16 | I2T warn level | I2T limit monitoring: Warning threshold. If the I2T value exceeds this threshold, the “Channel n overload I2T warning” bit is set. | % | USINT | 80dec
18 | I2T error level | I2T limit monitoring: Error threshold. If the I2T value exceeds this threshold, the “Channel n overload I2T error” bit is set. The motor is switched torqueless. | % | USINT | 110dec
19 | Motor thermal time constant | I2T limit monitoring: Thermal time constant. The thermal time constant can be found in the motor datasheet. | 0.1 s | UINT | 15dec

Index 8022: STM Features Channel 1
Index 8032: STM Features Channel 2

Access rights: read/write

Subindex (hex)

Name

Description

Unit

Data type

Default

11

Select info data 1

Define the measured values to be mapped to the input variables in “STM Synchron info data Channel n“

Enum:

  • “Motor velocity” = 7
  • “Motor load” (I2T value) = 11dec
  • “Motor amplifier I2T load” = 12dec
  • “Motor dc current” = 13dec
  • “Motor back EMF” = 17dec
  • “Motor restart counter” = 18dec
  • “Internal temperature” = 101dec
  • “Motor supply voltage” = 104dec

-

USINT

7dec

19

Select info data 2

-

USINT

11dec

51

Select info data 3

-

USINT

13dec

Index 8023: STM Controller Settings 4 Ch. 1
Index 8033: STM Controller Settings 4 Ch. 2

Access rights: read/write

Subindex (hex) | Name | Description | Unit | Data type | Default value
02 | Disable stop after unsuccessful rampup | This prevents a commutation error after unsuccessful ramping up the motor. The commutation is continued at Rampup velocity. | - | BOOL | FALSE
03 | Disable motor diagnosis | This parameter disables the motor protection functions during the alignment phase. | - | BOOL | FALSE
04 | Disable I2T current limiting | This bit disables the I2T current limiting above a 97% limit. This could be unstable during low velocities. FALSE: The output current is limited when the motor I2T value exceeds 97 %. TRUE: no current limiting. | - | BOOL | FALSE
11 | Velocity loop integral time | Velocity controller parameter: Integral time Ti | 0.1 ms | UDINT | 500dec
12 | Velocity loop proportional gain | Velocity controller parameter: Proportional coefficient KP | µV (°/s) | UDINT | 100dec
13 | Velocity feed forward gain | Bypasses the velocity controller directly with its Target voltage. With correct Rated voltage and speed the Actual velocity will be close to the Target velocity at 100% Feed Forward. | % | USINT | 0
14 | Sensorless offset scaling | This parameter affects the output current during alignment and rampup phase. The output current is specified in percent of the nominal current, CoE index 80n0:02. | % | USINT | 50dec
15 | Align duration | Duration of the alignment phase | ms | UINT | 1000dec
18 | Rampup duration | Duration of the ramp-up phase | ms | UINT | 1000dec
19 | Rampup velocity | Target velocity for the roller at the end of the ramp-up phase. See also subindex 02hex. | °/s | UINT | 3000dec
21 | Rampup needed switchover events | The amount successful commutations which are needed to switch from forced commutation (ramp-up phase) to regulated commutation. | - | UINT | 20dec
22 | Commutation threshold | This value is to modify the commutation for different motors. | - | UINT | 50dec
23 | Current loop proportional gain | Proportional component of current controller | 0.1 V/A | UINT | 2
24 | Current loop integral time | Current controller integral action time (Tn) | 0.1 ms | UINT | 20dec
25 | Restart after error number of repetition | Automatic restart after error If a commutation error occurs, the motor can be restarted automatically. This parameter determines the number of commutation errors and restarts that may occur before the motor is finally switched off. If this parameter is zero, the motor will be switched off immediately after a commutation error in nominal operation. | - | UINT | 0
26 | Restart after error delay | This parameter determines the time span between a commutation error and the automatic restart. See also subindex 25. | ms | UINT | 1000dez


Information objects

Index F80F: STM Vendor data

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Value
04 | Warning temperature | Internal temperature: Warning threshold. | °C | USINT | 80dec
05 | Switch off temperature | Internal temperature: Error threshold. | °C | USINT | 100dec
09 | Amplifier rated current | The value of this parameter is the maximum continuous current that the output stage can provide. This parameter is used for the I2T calculation of the output stage. | mA | UINT | 4500dec
0A | Amplifier maximal current | If the output current exceeds the value of this parameter, the output stage is switched off. | mA | UINT | 18000dec
0B | Amplifier minimal voltage | Threshold value of the undervoltage detection. | 0.01 V | UINT | 1800dec
0C | Amplifier maximal voltage | Threshold value of the overvoltage detection. | 0.01 V | UINT | 3000dec
0D | Amplifier thermal time constant | I2T limit value monitoring: Thermal time constant of the output stage. | 0.1 s | UINT | 35dec

Index F900: STM Info data

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Default value
01 | Internal temperature | Internal temperature | °C | SINT | -
02 | Motor supply voltage | Current value of the peripheral voltage UP | 0.01 V | UINT | -


Standard objects

Index 1000 Device type

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Value
- | Device type | Bit 0 .. 15: Device profile number Bit 16 .. 31: Module profile number (Device profile number 5001: Modular Device Profile MDP) | - | UDINT | 5001dec

Index 1008 Device name

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Value
- | Device Name | Device Name | - | String | EP7402-0057

Index 1009 Hardware version

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Value
- | Hardware Version | Hardware revision | - | String | 1)

1) Refer to Firmware and hardware versions.

Index 100A Software version

Access rights: read only

Subindex (hex) | Name | Description | Unit | Data type | Value
- | Software Version | Firmware revision | - | tbd | 1)

1) Refer to Firmware and hardware versions.


Appendix

Further Information
  • Example motor parameters
  • General operating conditions
  • Accessories
  • Version identification of EtherCAT devices
  • Support and Service


Example motor parameters

Parameter |  | Beckhoff AM8111-0F20-0000
Index | Name
8020:01hex | Maximal current | 3500
8020:02hex | Nominal current | 2850
8020:09hex | Start velocity | 666
8020:13hex | Mechanical to electrical ratio | 3
8020:19hex | Motor thermal time constant | 15
8023:11hex | Velocity loop integral time | 300
8023:12hex | Velocity loop proportional gain | 100
8023:14hex | Align power | 53
8023:15hex | Align duration | 1000
8023:16hex | Rampup power | 60
8023:18hex | Rampup duration | 666
8023:19hex | Rampup velocity | 2000
8023:21hex | Rampup needed switchover events | 10
8023:22hex | Commutation threshold | 45


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant

Key

  • resistant: Lifetime several months
  • non inherently resistant: Lifetime several weeks
  • not resistant: Lifetime several hours resp. early decomposition


Accessories

Cables

A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.

Ordering information | Description
ZK1090-3xxx-xxxx | EtherCAT cable M8, green link to the website
ZK1093-3xxx-xxxx | EtherCAT cable M8, yellow link to the website
ZK2000-3xxx-xxxx | Sensor cable M8, 4-wire Link to website
ZK2020-3xxx-xxxx | Power cable M8, 4-pin link to the website
ZK7314-3xxx-Axxx | B23 ENP cable 5 G 4.0mm2 website

Protective caps for connectors

Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS7300-B001 | Protective cap for B23, plastic
ZS7300-B002 | Protective cap for B23, metal

Tools

Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8802-0003 | Assembly tool for B23 connectors

Further accessories

Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Designation

A Beckhoff EtherCAT device has a 14-digit designation, made up of

  • family key
  • type
  • version
  • revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000

Notes

  • The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
  • EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
  • The order identifier is made up of
    - family key (EL, EP, CU, ES, KL, CX, etc.)
    - type (3314)
    - version (-0000)
  • The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
    In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
    Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
    From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
  • The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.

Identification number

Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:

Production lot/batch number/serial number/date code/D number

The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.

Structure of the serial number: KK YY FF HH

KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02

Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):

Syntax: D ww yy x y z u

D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB

Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1

Unique serial number/ID, ID number

In addition, in some series each individual module has its own unique serial number.

See also the further documentation in the area

  • IP67: EtherCAT Box
  • Safety: TwinSafe
  • Terminals with factory calibration certificate and other measuring terminals

Examples of markings

EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201

Further Information
  • Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.

BIC as data matrix code (DMC, code scheme ECC200)

The BIC will be introduced step by step across all product groups.

Depending on the product, it can be found in the following places:

  • on the packaging unit
  • directly on the product (if space suffices)
  • on the packaging unit and the product

The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.

Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.

The following information is contained:

Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |

Further types of information and data identifiers are used by Beckhoff and serve internal processes.

Structure of the BIC

Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:

BTN

An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.

Note

This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH & Co. KG

Huelshorstweg 20
33415 Verl
Germany

Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com

Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com

Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com