MES - Version 1.0
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Intended use
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Intended use

Foreword [image] Intended use
Intended use
The Magnetic Encoder System (MES) provides the feedback signal for linear motors from the AL2xxx series and is to be operated exclusively on a servo drive.
Linear feedback systems are required for the commutation and the detection of the velocity and position of brushless linear motors. Such feedback systems consist of a reader head and a graduated rule installed parallel to the travel path. The AL2200 works directly on the magnetic plates of the linear motor, eliminating the need for an additional graduated rule. It detects the magnetic field of the permanent magnets of the magnetic plates and supplies the encoder signals to the servo drive. Since the MES is a semi-absolute feedback system, no wake & shake is required in order to determine the commutation angle at machine start-up. The MES supplies one sine oscillation per logical motor revolution. A logical motor revolution is equivalent to the distance between two homopolar magnets, i.e. between two north poles, for example. The attainable accuracy of ±0.1 mm is sufficient for simple positioning tasks and depends to a large extent on the mechanical accuracy and position of the magnets along the travel path. Since no graduated rule has to be installed, the MES is an inexpensive feedback solution for linear motors.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Issue | Comment
1.0 | First edition


Guidelines and Standards

Guidelines and Standards
Guidelines and Standards
CAUTION
Danger for persons, the environment or equipment
The Magnetic Encoder System (MES) is not a product within the meaning of the EC Machinery Directive. Operation of MES in machines or systems is only permitted once the machine or system manufacturers has provided evidence of CE conformity of the complete machine or system.


Properties

Properties
Properties
The Magnetic Encoder System (MES) consists of a reader head with integrated analog Hall sensors. The Hall sensors evaluate the magnetic field of the magnetic plates and convert the signal into an analog output signal.
Name
Value / property
Signal period
Pole pair spacing 24 mm
Output signal
Analog signal 1 Vss, sine-cosine
Termination resistor
R = 120 Ω
Accuracy
< 100 µm
The prerequisite is the precise installation of the magnetic plates with an accuracy of ± 20 µm and offset, phase and amplitude compensation.
Repeatability
< 50 µm
Resolution
5 – 10 µm
Power supply
5 VDC
Connection cable
▪
8-core
▪
with twisted pairs
▪
material PUR
▪
UL-certified
▪
diameter 3.2 mm
▪
length 3 m
Assignment (color code)
green | SIN +
yellow | SIN -
blue | COS +
red | COS -
brown | + 5 VDC
white | GND
pink | + 5 V sense
grey | GND sense
Shield | PE / GND
Pin assignment for AX2000 / AX2500 and AX5000
MES | MES – without connector | MES D-Sub (15-pin) | AX2000 / AX2500 | AX5000 (X11 / X21)
Signal | Color | Pin | Pin | Pin
SIN + | green | 8 | 11 | 1
SIN - | yellow | 15 | 3 | 9
COS + | blue | 6 | 9 | 3
COS - | red | 13 | 1 | 11
+ 5 VDC | brown | 5 | 4*1 | 4*1
+ 5 V sense | pink | 12 | 12*1 | 12*1
GND | white | 7 | 2*1 | 2*1
GND sense | grey | 14 | 10*1 | 10*1
*1)Pins 4 and 12 as well as 2 and 10 are bridged!
The appropriate signal coupling has the order number ZS4000-2051 (Service Pack). The AM2000/AM3000 encoder cables can then be used.
The feedback cable is connected to X1 on the AX2000 and to X2 on the AX2500.


Dimensions

Dimensions
Dimensions


Mounting

Mounting
Mounting
The MES is installed behind or in front of the primary part, so that it moves with the primary part over the secondary part.
 | Distance to the top side of the primary part. | Rotation with respect to the movement direction | Distance to the outside edge of the primary part | Screws | Locating pins
 | H in mm | deg | mm |  |
AL20xx | 0 | 0.5 | +/- 1 | M4 | Ø 5 F8
AL24xx | 0
AL28xx-0 | 1
AL28xx-1 | 3


Support and Service

Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com