Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Installation

TwinCAT SST-ControlNet-COM-Server

Erforderliche Installationen

Installation von TwinCAT

Zur Installation von TwinCAT wird auf die entsprechenden TwinCAT-Dokumente verwiesen.

Installation der SST-Programme

Im Verzeichnis Unsupported Utilities/Sst befinden sich die Installationsversionen des SST-DeviceDrivers für die 5136-CN-PC-Karte (Verzeichnis DeviceDriver) und des SST-Configurations-Tools (Verzeichnis ConfigTool). Bei der Installation sollte wie folgt vorgegangen werden:

Installation des SST-DeviceDrivers

Dazu ist das Setup-Programm aus dem Verzeichnis Unsupported Utilities/Sst/DeviceDriver aufzurufen und den Anweisungen des Programms zu folgen.

Installation des SST-Configuration-Tools

Dazu ist das Setup-Programm aus dem Verzeichnis Unsupported Utilities/Sst/ConfigTool aufzurufen und den Anweisungen des Programms zu folgen.

Einstellen der 5136-CN-Hardware Settings (bei der 5136-CN-PCI nicht nötig)

Dazu ist das Programm SST Card Configuration unter Programme->SST Card Config aufzurufen. Es erscheint in der Regel ein Fenster mit zwei Defaulteinträgen:

Ein Eintrag sollte gelöscht (Remove-Button), der Andere editiert (Properties) werden. Es erscheint ein neuer Dialog, in dem die IO-Adresse der 5136-CN entsprechend der DIP-Schalter einzustellen ist. Die Memory-Adresse und der Name können nun angepasst werden:

Einbinden der EDS-Dateien in das SST-Configuration-Tool

Es ist das Programm "CN Config Tool" unter "Programme->SST CN" aufzurufen. Wenn ein BK7000 verwendet werden soll, ist die EDS-Datei des BK7000 (BK7000B8.eds, auf der CD unter EDS Files) in das Verzeichnis "Programme/SST/CN/CN Config Tool/EDS" zu kopieren.

Mit dem Add-Icon (ganz links) können EDS-Files in die EDS-library hinzugefügt werden:

Es erscheint ein Datei-Auswahl-Dialog, in dem am besten alle Dateien ausgewählt werden:

Anschließend ist die EDS-Library geladen und es können Projekte erstellt werden:


TcSstCN-COM-Server installieren/ deinstallieren

Installation

In TwinCAT 2.7 muss der TcSstCN-COM-Server manuell angemeldet werden. Dazu ist zunächst die Datei TcSstCN\TcSstCN.exe von der CD in das WINNT/system32-Verzeichnis zu kopieren. Danach muss der Server registriert werden (Start -> Ausführen anwählen und TcSstCN /TcServer eintippen, dann Okay drücken):

Deinstallation

Um den TcSstCN-COM-Server zu deinstallieren ist ebenfalls "Start -> Ausführen" anzuwählen und TcSstCN /UnRegServer einzutippen, dann Okay drücken. Danach ist der Server deinstalliert.


Erstellen der ControlNet-Konfiguration

TwinCAT SST-ControlNet-COM-Server

Übersicht

Die ControlNet-Konfiguration muss mit dem SST-Configuration-Tool erstellt werden.

Dazu ist das Programm "CN Config Tool" unter "Programme->SST CN" aufzurufen.

Zunächst ist die 5136-CN-PC-Karte als Scanner einzutragen. Dazu ist mit der rechten Maustaste "The Network (Network Configuration)" anzuklicken und "New Scanner" auszuwählen:

Danach erscheint ein neuer Scanner im rechten Fenster:

Durch doppeltes Anklicken des Scanners können dessen Eigenschaften eingestellt werden. In der Regel ist nur die entsprechende Karte unter "Card Name" und die ggf. Mac-ID einzustellen.

Mit der linken Maustaste können jetzt ControlNet-Geräte aus der EDS-Library zum Scanner gezogen werden:


Konfiguration

TwinCAT SST-ControlNet-COM-Server

BK7000 Konfiguration

Der BK7000 befindet sich in der EDS-Library unter dem Eintrag "Unknown Device ID: 128". Der BK7000 wird mit der linken Maustaste aus der EDS-Library auf den Scanner im rechten Fenster gezogen und erscheint danach im rechten Fenster. Durch doppeltes Anklicken des BK7000 im rechten Fenster können dessen Eigenschaften eingestellt werden:

In dem Dialog ist die "O=>T Size" (Länge der Outputs in Words) und die "T=>O Size" (Länge der Inputs in Words + 2) entsprechend der Klemmenkonfiguration einzustellen. Zur Berechnung der Output- und Input-Längen unterstützt der BK7000 vier Mapping-Vorschriften, die er entsprechend der ausgewählten Größe selbständig einstellt:

Mapping kompakt: KL3xx2 benötigen 4 Bytes Inputs, KL3xx4 benötigen 8 Bytes Inputs, KL4xx2 benötigen 4 Bytes Outputs, KL4xx4 benötigen 8 Bytes Outputs, KL1501 benötigt 5 Bytes In- und Outputs, KL5001 benötigt 4 Bytes Inputs, KL2502 und KL51x1 benötigen 6 Bytes In- und Outputs, KL6xx1 benötigen im Alternativ-Format 4 Bytes In- und Outputs und im Standard-Format 6 Bytes In- und Outputs, bei den digitalen Klemmen wird nur die Summe berechnet und auf Word-Alignement aufgerundet

Mapping kompakt mit WORD-Alignement: KL3xx2 benötigen 4 Bytes Inputs, KL3xx4 benötigen 8 Bytes Inputs, KL4xx2 benötigen 4 Bytes Outputs, KL4xx4 benötigen 8 Bytes Outputs, KL1501 benötigt 6 Bytes In- und Outputs, KL5001 benötigt 4 Bytes Inputs, KL2502 und KL51x1 benötigten 8 Bytes In- und Outputs, KL6xx1 benötigen im Alternativ-Format 4 Bytes In- und Outputs und im Standard-Format 6 Bytes In- und Outputs, bei den digitalen Klemmen wird nur die Summe berechnet und auf Word-Alignement aufgerundet

Mapping komplex: KL3xx2 benötigen 6 Bytes In- und Outputs, KL3xx4 benötigen 12 Bytes In- und Outputs, KL4xx2 benötigen 6 Bytes In- und Outputs, KL4xx4 benötigen 12 Bytes In- und Outputs, KL1501 benötigt 5 Bytes In- und Outputs, KL5001 benötigt 5 Bytes In- und Outputs, KL2502 und KL51x1 benötigen 6 Bytes In- und Outputs, KL6xx1 benötigen im Alternativ-Format 6 Bytes In- und Outputs und im Standard-Format 6 Bytes In- und Outputs, bei den digitalen Klemmen wird nur die Summe berechnet und auf Word-Alignement aufgerundet

Mapping komplex mit WORD-Alignement: KL3xx2 benötigen 8 Bytes In- und Outputs, KL3xx4 benötigen 16 Bytes In- und Outputs, KL4xx2 benötigen 8 Bytes In- und Outputs, KL4xx4 benötigen 16 Bytes In- und Outputs, KL1501 benötigt 6 Bytes In- und Outputs, KL5001 benötigt 6 Bytes In- und Outputs, KL2502 und KL51x1 benötigen 6 Bytes In- und Outputs, KL6xx1 benötigen im Alternativ-Format 8 Bytes In- und Outputs und im Standard-Format 6 Bytes In- und Outputs, bei den digitalen Klemmen wird nur die Summe berechnet und auf Word-Alignement aufgerundet

Weiterhin ist ggf. noch die Mac-ID und das "O=>T RPI" bzw. das "T=>O RPI" einzustellen (diese Werte müssen größer gleich der Network-Einstellungen für das NUT-Intervall sein).


Konfiguration

TwinCAT SST-ControlNet-COM-Server

AB Flex I/O Device Konfiguration

Zunächst ist unter dem Eintrag "Chassis" der EDS-Library ein "Flex 8 Slot Chassis" mit der linken Maustaste zum Scanner im rechten Fenster zu ziehen. Das AB Flex-I/O-Chassis erscheint dann im rechten Fenster:

Anschließend ist aus dem Eintrag "Communication Adapter" in der EDS-Library der entsprechende Flex I/O-Adapter mit der linken Maustaste auf das Chassis im rechten Fenster zu ziehen (es erscheint ein Feld mit der auszuwählenden Slot-Number 0). Der Flex-I/O-Adapter erscheint dann im rechten Fenster:

Schließlich sind noch aus den Einträgen "General Purpose Analog IO" bzw. "General Purpose Digital IO" die entsprechenden Module des Flex-I/O-Gerätes, durch Ziehen mit der linken Maustaste auf das Chassis im rechten Fenster, anzufügen (es erscheint ein Feld mit der auszuwählenden Slot-Number):

Durch doppeltes Anklicken des Chassis kann in dem erscheinenden Dialog die Mac-Id eingestellt werden:

Durch doppeltes Anklicken des Flex I/O-Adapters kann das "O=>T RPI" bzw. das "T=>O RPI" eingestellt werden (diese Werte müssen größer gleich der Network-Einstellungen für das NUT-Intervall sein).


Konfiguration

TwinCAT SST-ControlNet-COM-Server

PLC 5 Konfiguration

Aus dem Eintrag "Programmable Logic Controller" ist die entsprechende PLC 5 mit der linken Maustaste auf den Scanner im rechten Bild zu ziehen. Die PLC5 erscheint dann im rechten Fenster:

Durch doppeltes Anklicken der PLC 5 erscheint ein Dialog, in dem die "T=>O Size" (Inputs, Sendedaten der PLC 5) in Words sowie ggf. noch die Mac-ID und das "O=>T RPI" bzw. das "T=>O RPI" eingestellt werden können (diese Werte müssen größer gleich der Network-Einstellungen für das NUT-Intervall sein):

Unter Parameter kann noch die Consume Buffer-ID eingestellt werden, die mit der in der PLC 5 eingestellten Produce Buffer ID übereinstimmen muss:

Die Outputs (Empfangsdaten der PLC 5) werden durch Ziehen eines 5136-CN-Send-Adapters aus dem Eintrag "Communication Adapter" in der EDS-Library mit der linken Maustaste auf den Scanner eingefügt:

Durch doppeltes Anklicken der eingefügten Send-Verbindung erscheint ein Dialog, in dem die T=>O Size (Outputs, Empfangsdaten der PLC 5) eingestellt wird:

Unter Parameter kann noch die Produce Buffer ID eingestellt werden, die mit der in der PLC 5 eingestellten Consume Buffer ID übereinstimmen muss. Diese Produce Buffer ID wird auch zum Adressieren der Prozessdaten aus TwinCAT benutzt (-> Prozessdaten Send-Verbindung)

Für die Einstellungen in RS Networx sei auf die PDF-Datei sstcn_schplc5.pdf verwiesen.


Konfiguration

TwinCAT SST-ControlNet-COM-Server

ControlLogix Konfiguration

Aus dem Eintrag "Chassis" ist das entsprechende Control-Logix-Chassis auszuwählen und mit der linken Maustaste auf den Scanner im rechten Bild zu ziehen. Das Control-Logix-Chassis erscheint dann im rechten Fenster:

Aus dem Eintrag "Programmable Logic Controller" ist die entsprechende Control-Logix-CPU mit der linken Maustaste auf das Chassis im rechten Bild zu ziehen. Dabei muss noch die Slot-Nummer der CPU (nicht des ControlNet-Interfaces) angewählt werden. Die Control-Logix-CPU erscheint dann im rechten Fenster:

Durch doppeltes Anklicken der Control-Logix-CPU erscheint ein Dialog, in dem die "T=>O Size" (Inputs, Sendedaten der Control-Logix (bei dem entsprechendem Tag muss Producer angeklickt sein)) in Words sowie ggf. noch die Mac-ID und das "O=>T RPI" bzw. das "T=>O RPI" eingestellt werden können (diese Werte müssen größer gleich der Network-Einstellungen für das NUT-Intervall sein):

Unter dem Button "Control Logix Tag Name" muss noch der Tag-Name des entsprechenden Output-Tags der Control-Logix angegeben werden:

Die Outputs (Empfangsdaten der Control-Logix) werden durch Ziehen eines 5136-CN-Send-Adapters aus dem Eintrag "Communication Adapter" in der EDS-Library mit der linken Maustaste auf den Scanner eingefügt:

Durch doppeltes Anklicken der eingefügten Send-Verbindung erscheint ein Dialog, in dem die T=>O Size (Outputs, Empfangsdaten der Control-Logix ( bei dem entsprechenden Tag muss Consumed angewählt sein)) eingestellt wird:

Unter Parameter kann noch die Produce Buffer ID eingestellt werden, die mit der in der Control-Logix eingestellten Instance des Input-Tags übereinstimmen muss. Diese Produce Buffer ID wird auch zum Adressieren der Prozessdaten aus TwinCAT benutzt (-> Prozessdaten Send-Verbindung):

Für die Einstellungen in RS Networx und RS Logix 5000 sei auf die PDF-Datei SstCn_SchCntLgx.pdf verwiesen.

Damit die ControlLogix die Send-Verbindung (SST-Karte ist Producer, Control-Logix Consumer) aufbaut, muss die Scheduling-Liste mit RS Networx geladen werden. Dazu ist das Netzwerk in RS Networx offline zu projektieren und dann downzuloaden. Falls es dann noch nicht funktioniert, sollte der PC neu gestartet und der Vorgang wiederholt werden.

Netzwerk Konfiguration

Durch doppeltes Anklicken der Network Configuration können das NUT-Intervall sowie die maximalen Scheduled und Unscheduled Mac-IDs eingestellt werden:

Speichern der Konfiguration auf der 5136-CN-PC-Karte

Durch Anklicken des Scanners im rechten Fenster mit der rechten Maustaste erscheint ein Pop-Up-Menü, mit dem unter "Send Config through SST CN Card" die aktuelle ControlNet-Konfiguration auf der 5136-CN-PC-Karte gespeichert wird:


Übersicht

Die verschiedenen ControlNet-Dienste werden auf ADS-Read und ADS-Write abgebildet. Als Net-ID ist die Net-ID des PCs als Port-Number die 16000 anzugeben. In der IndexGroup ist die anzusprechende Mac-ID (bzw. die Produce Buffer-ID) bei Send-Verbindungen (z.B. zu PLC5 oder ControlLogix)) sowie die gewünschten Daten anzugeben. Der IndexOffset bestimmt den Offset innerhalb der Daten.

IndexGroup | Daten
0x000000yy | Prozessdaten I/O- oder Receive-Verbindung (yy: Mac-ID)
0x000100yy | Prozessdaten Send-Verbindung (yy: Produce Buffer ID)
0x000001yy | ID_Object (nur Read, yy: Mac-ID)
0x000002yy | Diagnostic_Counter (nur Read, yy: Mac-ID)
0x000003yy | Keeper_Info (nur Read, yy: Mac-ID)
0x00000400 | CCO_Directory (nur Read)
0x00000500 | Card_State (nur Read)

Wenn keine 5136CN-Karte gefunden wurde, wird der ADS-Error-Code 0x70C (Files, etc. not found) zurückgegeben. Im NT-System32-Verzeichnis gibt es noch Debug-Dateien "sststartup.txt", "sstcyclic.txt" und "sstshutdown.txt", wobei die beiden letzten erst nach dem Stop des TwinCAT-Systems Daten enthalten.


Prozessdaten

Wenn sich der Scanner beim Zugriff auf die Prozessdaten noch nicht im RUN befindet (CCO-Directory, Offset 0x14), wird der Error-Code 0x0708 (Device not ready) zurückgegeben:

I/O-Verbindung

Eine I/O-Verbindung wird zu ControlNet-Adaptern aufgebaut (z.B. BK7000, AB-Flex-I/O).

Empfangsdaten (ADS-Read-Response)

Offset | Attribute
0x00 | General Status (0: ok, 1: error (Status der Verbindung)
0x01 | reserviert
0x02 | Extended Status (0: ok, > 0: error (Status der Verbindung)
0x04 | Update-Counter (wird jedesmal beim Sender inkrementiert, wenn neue Daten übergeben wurden)
0x06 | Adapter Status (wird übertragen)
0x0A | Input-Daten (s. Gerätebeschreibung)

Sendedaten (ADS-Write-Request)

Offset | Attribute
0x00 | Scanner-Status (wird übertragen)
0x04 | Output-Daten (s. Gerätebeschreibung)

Receive-Verbindung

Eine Receive-Verbindung wird zu anderen ControlNet-Scannern aufgebaut (z.B. ControlLogix, PLC5).

Empfangsdaten (ADS-Read-Response)

Offset | Attribute
0x00 | General Status (0: ok, 1: error (Status der Verbindung)
0x01 | reserviert
0x02 | Extended Status (0: ok, > 0: error (Status der Verbindung)
0x04 | Update-Counter (wird jedesmal beim Sender inkrementiert, wenn neue Daten übergeben wurden)
0x06 | Input-Daten (s. Gerätebeschreibung)

Send-Verbindung

Eine Send-Verbindung wird zu anderen ControlNet-Scannern aufgebaut (z.B. ControlLogix, PLC5).

Sendedaten (ADS-Write-Request)

Offset | Attribute
0x00 | Output-Daten

Empfangsdaten (ADS-Read-Response)

Offset | Attribute
0x00 | General Status (0: ok, 1: error (Status der Verbindung)
0x01 | reserviert
0x02 | Extended Status (0: ok, > 0: error (Status der Verbindung)


ID Object

Beim Lesen des ID-Objects werden die folgenden Daten in der ADS-Read-Response zurückgegeben:

Offset | Attribute
0x00 | Vendor-ID
0x02 | Device-Type
0x04 | Product-Code
0x06 | Major-Revision
0x07 | Minor-Revision
0x08 | Status
0x0A | Serial-Number
0x0E | Länge des Product-Name
0x10 | Product-Name


Diagnostic Counter

Beim Lesen der Diagnostic-Counter (ControlNet-Spec. Part 10, Kapitel 240 "ControlNet-Object", Tabelle 10-223, Attribute-ID 0x82) werden die folgenden Daten in der ADS-Read-Response zurückgegeben:

Offset | Attribute
0x00 | Number of Errors in Error-Log
0x02 | Error-Log[8]
0x0A | Good Tx-Counter
0x0D | Good Rx-Counter
0x10 | Framing-errors detected on active selected Channel
0x11 | Framing-errors detected on Channel A
0x12 | Framing-errors detected on Channel B
0x13 | Tx-Abort-Counter
0x14 | LLC transmit underflow and LLC receive overflow
0x15 | no unscheduled time in NUT
0x16 | more scheduled data queued for one NUT than allowed by the SchedMaxFrame-parameter
0x17 | single L_packet-size exceeds SchedMaxFrame-parameter
0x18 | two or more nodes could not agree whose turn it is to transmit
0x19 | Rx-Abort-Counter
0x1A | number of times nothing heard on the network for 8 or more NUTs
0x1B | Duplicate Node-Counter
0x1C | Noise-Hits-Counter
0x1D | Collision-Counter
0x1E | Mac ID of the current moderator node
0x1F | Moderator frames heard from non-lowman nodes
0x20 | rogue events detected
0x21 | MAC frames being heard but no no moderators being heard
0x22 | Reserved


Keeper Info

Beim Lesen der Keeper-Info (ControlNet-Spec. Part 10, Kapitel 241) werden die folgenden Daten in der ADS-Read-Response zurückgegeben:

Offset | Attribute
0x00 | Keeper-State (ControlNet-Spec. Part 10, Kapitel 241, Tabelle 10-229)
0x01 | Reserved
 | Current Network Parameters (ControlNet-Spec. Part 10, Kapitel 241, Tabelle 10-228, Attribute-ID 255)
0x02 | NUT-Interval
0x04 | Maximum Scheduled Mac ID
0x05 | Maximum Unscheduled Mac ID
0x06 | Slot-Time
0x07 | Blanking-Time
0x08 | Guard Band Start
0x09 | Guard Band Center
0x0A | Reserved
0x0C | Interval Count Modulus
0x0D | Guard Band Pre-Start
 | current Table Unique Identifier (ControlNet-Spec. Part 10, Kapitel 241, Tabelle 10-228, Attribute-ID 258)
0x0E | TUI-Unique ID
0x12 | TUI-Status flag (ControlNet-Spec. Part 10, Kapitel 241, Tabelle 10-231)
0x14 | MAC-Id of the node broadcasting the TUI
0x15 | reserved
0x16 | Vendor-Id of object holding the network resource
0x18 | Serial Number of object holding the network resource
0x1C | Class of object holding the network resource
0x20 | Instance of object holding the network resource


CCO Directory

Beim Lesen des CCO-Directories werden die folgenden Daten in der ADS-Read-Response zurückgegeben:

Eigener Scanner

Offset | Attribute
0x00 | Revision
0x02 | Status (Bit 0: all I/O and scheduled receive connections are ok, Bit 8: all scheduled send messgaes are ok)
0x04 | Maximum number of instances (127)
0x08 | Number of instances currently configured
0x0C | Implementation defined revision
0x0E | Number of Scanner Instances (O-T)
0x10 | Edit Signature for current CCO configuration
0x14 | Current Scanner State (0: no connections are active,1: the scanner is in Prog-Mode, 2: the scanner is in Run-Mode)
0x16 | Current Adapter State (0: all scheduled send messages are disabled, 1: scheduled sends are enabled)
0x18 | Total size in bytes of all Tx Data
0x1A | Total size in bytes of all Rx Data
0x1C | Next available offset for variable length parameters
0x1E | CCO/Scheduling Object Options (Bit 0: ALLOW_CCO_BREAK_IN_RUN, Bit 1: DISALLOW_CCO_OPEN, Bit 8: ALLOW_SCHED_BREAK_IN_RUN, Bit 9: DISALLOW_SCHED_OPEN, Bit 10: ALLOW_SCHED_REMOTE_SET_PROG)
0x20 | Schedule Object Connection Originator Password
0x24 | Flags Indicating various CCO conditions (Bit 0: CCO_FLAG_RES_HELD)
0x26 | Size of Implementation Defined Attribute (in bytes)
0x28 | Scanner Global User Handle
0x2C | Adapter Global User Handle

Fremder Scanner

Offset | Attribute
0x00 | Revision
0x02 | Maximum number of instances (127)
0x06 | Number of instances currently configured
0x0A | Format number
0x0C | Edit Signature for current CCO configuration


Card State

Beim Lesen des Status der CN-Karte werden die folgenden Daten in der ADS-Read-Response zurückgegeben (die Okay-Werte sind fett gedruckt):

Offset | Attribute
0x00 | Card-State: OFFLINE (0x41), ONLINE (0x42), FATAL ERROR (0xE1)
0x02 | NAM-State: GO_OFFLINE (0x00), BAD (0x01), WAIT_FOR_OFFLINE (0x02), GO_ONLINE (0x03), CHK_FOR_CABLE (0x04), WAIT_TO_ROGUE (0x05), WAIT_FOR_ONLINE (0x06), SEND_ALIVE (0x07), WATCH (0x08), LISTEN (0x09), ATTACHED (0x0C)
0x04 | Reserved


Status der Verbindung

Beim Lesen der Prozessdaten wird der Status der Verbindung (General Status und Extended Status) in den ersten vier Bytes zurückgegeben. Die folgenden Werte sind dabei möglich (entsprechen der ControlNet Spec V2.0 Kapitel 4.4):

General Status | Extended Status | Bedeutung
0x00 |  | Verbindung ist aufgebaut, alles okay
0x01 | 0x0100 | Verbindung bereits aufgebaut
0x01 | 0x0103 | Transport Class und Trigger-Kombination wird nicht unterstützt
0x01 | 0x0106 | Besitzer-Konflikt (z.B. wenn über eine zweite Verbindung versucht wird, auf die Ausgänge der ersten zuzugreifen)
0x01 | 0x0107 | Verbindung nicht vorhanden
0x01 | 0x0108 | ungültiger Connection Type
0x01 | 0x0109 | falsche Connection Size
0x01 | 0x0110 | Gerät ist noch nicht bereit
0x01 | 0x0111 | RPI-Überwachung wird nicht unterstützt
0x01 | 0x0113 | maximale Anzahl der Verbindungen erreicht
0x01 | 0x0114 | Vendor-ID oder Product Code im Electronic Key stimmen nicht überein
0x01 | 0x0115 | Product Type im Electronic Key stimmt nicht überein
0x01 | 0x0116 | Major oder Minor Revision im Electronic Key stimmen nicht überein
0x01 | 0x0117 | ungültiger Connection Point
0x01 | 0x0118 | ungültiges Configuration Format
0x01 | 0x0119 | keine Control-Verbindung verfügbar
0x01 | 0x011A | keine Verbindung mehr in Applikation des Geräts
0x01 | 0x0203 | Verbindungsüberwachung hat zugeschlagen, daher kein Verbindungsaufbau möglich
0x01 | 0x0204 | Timeout beim Unconnected Send
0x01 | 0x0205 | Parameter-Fehler bei Unconnected Send
0x01 | 0x0206 | Daten sind zu lang für Unconnected Send
0x01 | 0x0301 | kein Speicher mehr vorhanden
0x01 | 0x0302 | Netzwerk-Bandbreite reicht für die Daten der Verbindung nicht aus
0x01 | 0x0303 | keine Screener mehr vorhanden
0x01 | 0x0304 | Gerät kann keine Real Time Daten senden
0x01 | 0x0311 | Port im Path Segment ist nicht verfügbar
0x01 | 0x0312 | Link Address im Path Segment ist nicht verfügbar
0x01 | 0x0315 | falscher segment type oder segment value im Path
0x01 | 0x0316 | Path und Connection stimmen beim Schließen der Verbindung nicht überein
0x01 | 0x0317 | Segment nicht vorhanden oder Encoded Value im Network Segment ist ungültig (verschwindet meist nach TwinCAT-Restart)
0x01 | 0x0318 | Link Address, die auf das Gerät selbst zeigt, ist ungültig
0x01 | 0x0319 | Zweite Ressource im redundanten System ist nicht verfügbar
0x10 | 0x0206 | Tritt bei Consumer-Verbindung zu Control-Logix auf, wenn Netzwerk noch nicht mit RS Networx projektiert wurde