Technische Referenz: Übersicht

TwinCAT SPS Bibliotheken: Übersicht IEC 60870-5-10x

Technische Referenz

In der Fernwirktechnik müssen Geräte verschiedener Hersteller miteinander kommunizieren. Die IEC 60870-5-Familie definiert auf der Basis der fünf Grundnormen IEC 60870-5-1 (Telegrammformate), -2 (Übertragungsprozeduren/Verbindungsschicht), -3 (Strukturen/Anwendungsdaten), -4 (Informationselemente) und -5 (grundlegende Anwendungsfunktionen) die anwendungsbezogenen Normen IEC 60870-5-101, -102, -103 und 104. Durch die international genormten Fernwirkprotokolle IEC 60870-5-101/-102/-103 kann eine serielle bzw. über das Fernwirkprotokoll IEC 60870-5-104 eine TCP/IP-basierte Datenübertragung realisiert werden.

Die Hersteller sind nicht verpflichtet die komplette Norm in den Geräten zu implementieren. Aus diesem Grund kann es zu Inkompatibilitäten zwischen den Geräten bei der Inbetriebnahme kommen. Um dem vorzubeugen bieten Hersteller zu jedem Gerät eine passende Kompatibilitätsliste an. In dieser Liste sind die implementierten Funktionen aufgelistet bzw. markiert. Mit der Hilfe der Kompatibilitätsliste können die benötigten Funktionalitäten zweier Geräte im Vorfeld verglichen werden. Bitte beachten Sie auch die Kompatibilitätslisten zu den TwinCAT IEC 60870-5-10x-Bibliotheken.

Die SPS-Bibliotheken verfügen teilweise über zwei Software-Schnittstellen ("Low level"- und "High level"-Schnittstelle). Die Endapplikation setzt auf einer dieser Schnittstellen auf. Bei zwei verfügbaren Schnittstellen hängt die Wahl der Schnittstelle von den Anforderungen an die Endapplikation ab. Bitte lesen Sie dazu auch die Hinweise in der jeweiligen Produktinformation. Im Folgenden werden die wichtigsten Eigenschaften der Produkte kurz aufgelistet.

  • TwinCAT PLC IEC 60870-5-101 Master
  • TwinCAT PLC IEC 60870-5-101 Slave
  • TwinCAT PLC IEC 60870-5-102 Master
  • TwinCAT PLC IEC 60870-5-103 Master
  • TwinCAT PLC IEC 60870-5-104 Master
  • TwinCAT PLC IEC 60870-5-104 Slave

TwinCAT PLC IEC 60870-5-101 Master

  • Datenübertragung: Seriell;
  • Produktinformation:
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "High level"-Schnittstelle: IEC 60870-5-101 Zentralstation (implementiert in TcIEC870_5_101Master.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
    • "Low level"-Schnittstelle: IEC 60870-5-101 Serial Link Interface (implementiert in TcIEC870_5_101Link.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "High level": nur Zentralstation (master);
    • "Low level": Zentralstation und/oder Unterstation (master/slave);
  • Schnittstellendokumentation:
    • "High level": TwinCAT PLC Library: IEC 60870-5-101 Zentralstation;
    • "Low level": TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT PLC Library: Serielle Kommunikation;
  • Beispiele:
    • "High level": IEC 60870-5-101 Zentralstation;
    • "Low level": IEC 60870-5-101 Serial Link Interface;

TwinCAT PLC IEC 60870-5-101 Slave

  • Datenübertragung: Seriell;
  • Produktinformation;
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "High level"-Schnittstelle: IEC 60870-5-101 Unterstation (implementiert in TcIEC870_5_101Slave.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
    • "Low level"-Schnittstelle: IEC 60870-5-101 Serial Link Interface (implementiert in TcIEC870_5_101Link.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "High level": nur Unterstation (slave);
    • "Low level": Zentralstation und/oder Unterstation (master/slave);
  • Schnittstellendokumentation:
    • "High level": TwinCAT PLC Library: IEC 60870-5-101 Unterstation;
    • "Low level": TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT PLC Library: Serielle Kommunikation;
  • Beispiele:
    • "High level": IEC 60870-5-101 Unterstation;
    • "Low level": IEC 60870-5-101 Serial Link Interface;

TwinCAT PLC IEC 60870-5-102 Master

  • Datenübertragung: Seriell;
  • Produktinformation;
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "Low level"-Schnittstelle: IEC 60870-5-102 Serial Link Interface (implementiert in TcIEC870_5_102Link.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "Low level": nur Zentralstation (master);
  • Schnittstellendokumentation:
    • "Low level": TwinCAT PLC Library: IEC 60870-5-102 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT PLC Library: Serielle Kommunikation;
  • Beispiele:
    • "Low level": IEC 60870-5-102 Serial Link Interface;

TwinCAT PLC IEC 60870-5-103 Master

  • Datenübertragung: Seriell;
  • Produktinformation;
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "Low level"-Schnittstelle: IEC 60870-5-103 Serial Link Interface (implementiert in TcIEC870_5_103Link.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "Low level": nur Zentralstation (master);
  • Schnittstellendokumentation:
    • "Low level": TwinCAT PLC Library: IEC 60870-5-103 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT PLC Library: Serielle Kommunikation;
  • Beispiele:
    • "Low level": IEC 60870-5-103 Serial Link Interface;

TwinCAT PLC IEC 60870-5-104 Master

  • Datenübertragung: TCP/IP;
  • Produktinformation;
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "High level"-Schnittstelle: IEC 60870-5-104 Zentralstation (implementiert in TcIEC870_5_104Master.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
    • "Low level"-Schnittstelle: IEC 60870-5-104 Transport Interface (implementiert in TcIEC870_5_104.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "High level": nur Zentralstation (master);
    • "Low level": Zentralstation und/oder Unterstation (master/slave);
  • Schnittstellendokumentation:
    • "High level": TwinCAT PLC Library: IEC 60870-5-104 Zentralstation;
    • "Low level": TwinCAT PLC Library: IEC 60870-5-104 Transport Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT TCP/IP Connection Server;
  • Beispiele:
    • "High level": IEC 60870-5-104 Zentralstation;
    • "Low level": IEC 60870-5-104 Transport Interface;

TwinCAT PLC IEC 60870-5-104 Slave

  • Datenübertragung: TCP/IP;
  • Produktinformation;
    • Systemvoraussetzungen;
    • Produktkomponenten;
    • Installation;
  • Verfügbare Schnittstellen:
    • "High level"-Schnittstelle: IEC 60870-5-104 Unterstation (implementiert in TcIEC870_5_104Slave.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
    • "Low level"-Schnittstelle: IEC 60870-5-104 Transport Interface (implementiert in TcIEC870_5_104.Lib, diese Bibliothek muss in das SPS-Projekt eingebunden werden);
  • Realisierbare Endapplikationen:
    • "High level": nur Unterstation (slave);
    • "Low level": Zentralstation und/oder Unterstation (master/slave);
  • Schnittstellendokumentation:
    • "High level": TwinCAT PLC Library: IEC 60870-5-104 Unterstation;
    • "Low level": TwinCAT PLC Library: IEC 60870-5-104 Transport Interface;
    • TwinCAT PLC Library: IEC 60870-5-101 Common Data Types (gemeinsame Datentypen);
    • TwinCAT TCP/IP Connection Server;
  • Beispiele:
    • "High level": IEC 60870-5-104 Unterstation;
    • "Low level": IEC 60870-5-104 Transport Interface;