Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


TCPlcLibSystemCX1000_Overview

TwinCAT PLC Library: SystemCX1000

Übersicht

In dieser Bibliothek sind Funktionen enthalten, die spezielle Features auf dem Embedded PC CX1000 nutzen.

Funktionen

Name | Beschreibung
F_CX1000SetWatchdog | Aktiviert/Deaktiviert Hardware Watchdog (Auto-Reboot des CX1000 bei SPS-Problemen)
F_GetVersionTcSystemCX1000 | Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

Anforderungen

Komponente | Version
TwinCAT auf dem Entwicklungsrechner | 2.9 Build 959 oder höher
CX1000-Windows CE-Image | 1.75 oder höher
CX1000-Windows XP-Image | 1.14 oder höher


FUNCTION F_CX1000SetWatchdog

Die Funktion F_CX1000SetWatchdog aktiviert einen Hardware-Watchdog auf dem CX1000. Der Watchdog wird über bEnable = TRUE und die tTimeout-Zeit aktiviert. Die tTimeoutzeit kann minimal mehrere SPS-Taskzyklen (mehrfaches der Aufrufzeit der Funktion F_CX1000SetWatchdog) sein und maximal 65s und 535ms.

Wenn der Watchdog einmal aktiviert wurde, muß die Funktion zyklisch in kürzeren Abständen aufgerufen werden als tTimeOut, da bei Ablauf der tTimeOut-Zeit der CX1000 automatisch einen Neustart durchführt. Der Watchdog kann daher dafür eingesetzt werden um Systeme automatisch neu zu Booten, die in eine Endlosschleife gelaufen sind bzw. bei denen die PLC steht.

Der Watchdog kann über bEnable = FALSE bzw. die tTimeOut-Zeit = 0 deaktiviert werden.

Achtung:
Der Watchdog muß vor der Verwendung von Breakpoints, einem SPS-Reset bzw. Urlöschen und vor einem TwinCAT Stop, einem Wechsel in den Konfig-Mode oder dem Aktivieren der Konfiguration deaktiviert werden, da es sonst unmittelbar zum Reboot des CX1000 nach Ablauf der Timeoutzeit kommt!

FUNCTION F_CX1000SetWatchdog : BOOL

VAR_INPUT

VAR_INPUT
    tTimeout		: TIME;
    bEnable 		: BOOL;
END_VAR

tTimeOut : Watchdogzeit, nach deren Ablauf ein Neustart durchgeführt wird.

bEnable : Aktivieren bzw. Deaktivieren des Watchdogs.


FUNCTION F_GetVersionTcSystemCX1000

Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

FUNCTION F_GetVersionTcSystemCX1000 : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Versionselement, das gelesen werden soll. Mögliche Parameter:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | PC (i386) | TcSystemCX1000.Lib