Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Mit den SPS-Funktionen und -Funktionsbausteinen können Zentralstationen (Master) nach der IEC60870-5-103 Norm in TwinCAT SPS realisiert werden.

Die Endapplikation (Implementierung einer Zentralstation) wird auf der Software-Schnittstelle der SPS-Bibliothek aufgesetzt. Anders als bei den 101/104-TwinCAT Supplement Produkten steht dem SPS-Programmierer bei der IEC60870-5-103-Protokollimplementierung nur die sogenannte "Low level"-Schnittstelle zur Verfügung. Der Grund: Die meisten Unterstationen (Schutzgeräte) besitzen viele Herstellerspezifische oder Gerätespezifische Parameterdaten oder Informationen. Die "Low level"-Schnittstelle ermöglicht einen uneingeschränkten Zugriff auf all diese Daten. Im Folgenden werden die Eigenschaften dieser Schnittstelle kurz beschrieben.

"Low level"-Schnittstelle: IEC 60870-5-103 Serial Link Interface

Diese Schnittstelle setzt bei dem Protokollstack tiefer an und ermöglicht das Versenden und/oder Empfangen einzelner Frames (ASDU's).

Pro: Sehr flexibel; Alle Eigenschaften im ASDU-Frame können manipuliert werden (z.B. Funktionscodes, Informationsnummern usw); Weil nur die benötigten Dienste (abhängig vom Gerät) implementiert werden kann eine hohe Performance erreicht werden; Hohe Performace bei vielen Datenpunkten oder einem hohem Datenaufkommen;

Contra: Grösserer Programmieraufwand; Alle Dienste wie Generalabfrage, Zählerabfrage, Uhrzeitsynchronisation, Befehlsausführung usw. müssen von dem SPS-Programmierer selbst implementiert (ausprogrammiert) werden; Der SPS-Programmierer muss mit der Protokollnorm vertraut sein.

Kompatibilitätsliste

für TwinCAT SPS Bibliothek: IEC 60870-5-103 Zentralstation. Hier können Sie die Kompatibilitätsliste öffnen/abspeichern (gezipptes PDF).

Systemvoraussetzungen

  • Programmierumgebung:
    • Windows NT (XP, XPe/WES, Vista, W7, WES7, ...);
    • TwinCAT Installation Level: TwinCAT PLC oder höher;
    • TwinCAT System Version 2.10.0 Build >= 1313 oder höher;
  • Zielplattform:
    • Industrie PC oder Embedded PC/CX (x86, ARM);
    • Betriebssystem:
      • Windows NT (XP, XPe/WES, Vista, W7, WES7, ...);
      • Windows CE (x86, ARM) (image v2.16 oder höher);
    • TwinCAT SPS-Laufzeitsystem Version 2.10.0 oder höher;
    • Serielle COM Schnittstelle oder KL6xxx- oder EL6xxx-Klemmen (EL6xxx Unterstützung ab der Produktversion 1.0.11 und höher);

Produktkomponenten

  • TcIEC870_5_103Link.Lib (implementiert Übertragungsprozeduren für den Transport der ASDUs nach IEC 60870-5-103 Norm ); Diese Bibliothek muss in dem SPS-Projekt eingebunden werden. Alle anderen Bibliotheken werden automatisch hinzugefügt.
  • TcIEC870_5_101Link.Lib (Basisbibliothek, implementiert Übertragungsprozeduren für den Transport der ASDUs über die seriellen Schnittstellen des PCs und die Beckhoff KL6xxx-/EL6xxx-Klemmen);
  • TcIEC870_5_101.Lib (implementiert die Verbindungsfunktionen und gemeinsame Datentypen);
  • COMLibV2.Lib (implementiert die Funktionen für die serielle COM- oder KL6xxx-/EL6xxx-Kommunikation);

Installation

Windows NT (XP, XPe/WES, Vista, W7, WES7, ...)

Die SPS-Bibliotheken werden während der Installation auf der Programmierumgebung in den ..\TwinCAT\Plc\Lib-Ordner hineinkopiert:

Windows CE

Auf der CE Plattform werden keine zusätzlichen Komponenten installiert.

Hinweis: Dies ist nur eine kurze Produktinformation (kein vollständiges Handbuch). Bitte installieren Sie sich die vollständige Ausgabe des Beckhoff Information System.

Sie finden es

  • auf sämtlichen Beckhoff-Produkt-DVDs
  • auf unserem Web-Server http://www.beckhoff.com unter Download.

Beispiele

Beispiele befinden sich in der Beckhoff Information System Dokumentation der SPS-Bibliotheken.

Link zu "Low level" Beispiel-Übersichtsseite: IEC 60870-5-103 Serial Link Interface;

Weiterführende Dokumentation

  • Dokumentation zur TwinCAT PLC Library ("Low level"-Schnittstelle): IEC 60870-5-103 Serial Link Interface;
  • Dokumentation zur TwinCAT PLC Library: IEC 60870-5-101 Serial Link Interface;
  • Dokumentation zur TwinCAT PLC Library: IEC 60870-5-101 Common Data Types;
  • Dokumentation zur TwinCAT PLC Library: Serielle Kommunikation;
  • IEC 60870-5-1 Transmission frame formats;
  • IEC 60870-5-2 Link transmission procedures;
  • IEC 60870-5-3 General structure of application data;
  • IEC 60870-5-4 Definition and coding of application information elements;
  • IEC 60870-5-5 Basic application functions;
  • IEC 60870-5-101 Companion Standard for basic telecontrol tasks;
  • IEC 60870-5-101:1995/A1:2000 Companion Standard for basic telecontrol tasks. Amendment 1;
  • IEC 60870-5-101:1995/A2:2001 Companion Standard for basic telecontrol tasks. Amendment 2;
  • IEC 60870-5-103:1997 Transmission protocols - Companion Standard for the informative interface of protection equipment;