Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Das TwinCAT PLC HMI Web ist ein TwinCAT Supplement Produkt welches webbasierende Visualisierungsseiten aus der TwinCAT-SPS anbietet.

TwinCAT PLC HMI Web kann mit dem Setup nachinstalliert werden.

Als "HTML"-Editor steht die IEC1131-SPS "TwinCAT PLC-Control" zur Verfügung. Analog zur "TwinCAT Target Visualisierung" bzw. der "TwinCAT PLC HMI" Visualisierung werden die Visualisierungsseiten im TwinCAT PLC-Control erstellt.

Neben der Kompilierung des SPS-Codes werden auch die Visualisierungsseiten in HTML Seiten gewandelt und zusammen mit dem SPS-Projekt auf die Zielsteuerung übertragen.

Die nahtlose Integration in das TwinCAT PLC Control bietet den Vorteil, dass neben der IEC1131-SPS Code Erstellung für die Visualisierung direkt alle Variablen vom TwinCAT PLC -Steuerungsprogramms zur Verfügung stehen.

Lizenz

Eine Lizenz ist kostenpflichtig und pro Runtime (CE/XP) erforderlich. (Der Editor ist "kostenlos" im TwinCAT PLC Control enthalten).

Demoversion

Eine limitierte Demoversion steht nicht zur Verfügung.

Produkt-Komponenten:

  • Editor:

    Als Editor steht der IEC1131-SPS-Editor "TwinCAT PLC-Control" zur Verfügung.

  • Runtime CE:
    Als CE-Plattform stehen die von Beckhoff unterstützten CE Plattformen zur Verfügung: CE-X86 und CE-ARM.
  • Runtime XP:
    Das Produkt wurde für die Plattformen Windows XP / Windows XPE / Windows Standard getestet.
    Der Einsatz unter Vista und Windows Server wurde noch nicht im Systemtest bearbeitet.

Voraussetzungen:

  • Zur Erstellung der Webseiten:
    TwinCAT 2.10 Build 1326 (oder höher)
  • Runtime CE:
    • Beckhoff CE-X86 oder CE-ARM Gerät mit CE Image 2.18 (oder höher)
    • Minimum TwinCAT Level PLC
  • Runtime XP:
    • Minimum TwinCAT Level PLC
  • Anzeige der Webseiten:

    Ein Client (Browser) benötigt zur Anzeige der web basierten Visualisierung TwinCAT PLC HMI Web eine Java-VM.
    Für XP basierende Systeme steht diese von diversen Anbietern kostenlos zur Verfügung, z.B. von Firma Sun.
    Für CE basierende System ist eine kostenlose JavaVM aktuell nicht bekannt.


CE Runtime: Installation

TS1810 | TwinCAT PLC HMI Web

CE Runtime : Installation

Voraussetzung:

  • Auf dem Host-PC: Editor: TwinCAT 2.10 Build 1320
  • Auf dem CE-Gerät: CE-Image 2.18 (oder höher)

Installation:

  • Schritt 1:
     Installieren Sie die Supplement Software TwinCAT PLC HMI Web auf dem Host PC.
    Mit Eingabe des erforderlichen Lizenzkeys und der Zustimmung zu den Lizenzvereinbarungen wird die Supplement Software in den Unterordner ..\TwinCAT\CE auf Ihren PC installiert.

Beispiel: Installation des TwinCAT PLC HMI Web
Die Installation der Software auf dem Host PC erzeugt einen Ordner "..\TwinCAT\CE\TwinCAT PLC HMI Web", der die CE*.cab Installationsdateien enthält
Beispiel:
X86: TwinCAT_PLC_HMI_Web_CE.I586.CAB
ARM: TwinCAT_PLC_HMI_Web_CE.ARM.CAB

  • Schritt 2 :
     Transfer der CE-Cab Installationsdateien auf das CE Gerät (per memory stick/FTP/Public Folder/CF-Adapter...)

    Während das CE Gerät läuft, machen Sie einen Doppelklick auf die Cab Datei und bestätigen mit "OK".
    Nach Ende der Installation zerstört sich die Cab Datei von selbst.

    Rebooten Sie das Gerät einmalig per "Start -> Suspend" ( kein Power-Cycle ! ) erst jetzt werden alle Informationen auf das Flash bzw. die CF Karte gesichert.

Das Gerät ist nun für die Verwendung von TwinCAT PLC HMI Web konfiguriert.


Windows 7 Runtime: Installation und Konfiguration

TS1810 | TwinCAT PLC HMI Web

Windows 7 Runtime : Installation und Konfiguration

Voraussetzung:

  • Auf dem Host-PC: Editor: TwinCAT 2.10 Build 1326 oder höher

Installation:

TwinCAT PLC HMI Web steht als Supplement zur Verfügung und kann mit dem Setup nachinstalliert werden. Eine Lizenz ist kostenpflichtig und eine limitierte Demoversion steht nicht zur Verfügung.
Die Installation besteht einmalig aus drei Schritten:

1: Installation des Internet Information Servers IIS

  • Der Internet Information Server (IIS) ist bei Windows7 nicht standardmäßig mitinstalliert. Sie müssen die Funktionalität nachträglich installieren
  • Siehe http://technet.microsoft.com/de-de/library/cc725762%28v=ws.10%29.aspx
  • Achten Sie darauf, dass die ISAPI Filter und Erweiterungen (Extensions) mitinstalliert werden (siehe Bild)

2: Installation der Supplement Software auf dem Host PC

  • Mit Eingabe des erforderlichen Lizenzkeys und der Zustimmung zu den Lizenzvereinbarungen installieren Sie die Supplement Software mit der Win7 Runtime auf Ihrem PC

3: Konfiguration des Internet Information Server IIS

  • Legen Sie ein "Virtuelles Verzeichnis" mit dem Namen "UPnPDevice" mit Link auf das Verzeichnis ".\Programs\Beckhoff\UPnP\WebSite" an
  • Legen Sie ein "Virtuelles Verzeichnis" mit dem Namen "TcWebVisu" mit Link auf das Verzeichnis ".\TwinCAT\Boot\WebVisu" an

  • Unter "IIS/ISAPI und CGI Restriktionen" die folgenden DLLs hinzufügen und die Ausführung erlauben:

- C:\Program Files\Beckhoff\UPnP\WebSite\TcPlcDataServiceDa.dll

- C:\Program Files\Beckhoff\UPnP\WebSite\TcPlcDataService.dll

  • Unter "Handler Mappings" die Aktion "Ausführen" erlauben

  • Unter "IIS\Authentifikation\Anonyme Authentifizierung" "Identität des Anwendungspools" auswählen.

  • IIS Dienst neu starten

Damit ist die Installation abgeschlossen.


Editor

Voraussetzung:

  • Auf dem Host-PC: Editor: TwinCAT 2.10 Build 1320 oder höher (zur Erzeugung von Web Lösung für CE)
  • Auf dem Host-PC: Editor: TwinCAT 2.10 Build 1326 oder höher (zur Erzeugung von Web Lösung für XP)

Konfiguration:

Nach erfolgter Installation der Runtime für die TwinCAT PLC HMI Web Visualisierung auf dem Ziel-System muss im IEC1131-Editor TwinCAT PLC Control im PLC-Projekt einmalig die Web-Option angewählt werden:

Dazu wird im PLC-Control im Dialog "Project"-->"Options..."-->"TwinCAT" die Option "Enable Web Visualization" angewählt.

Mit dem nächsten Download des SPS-Projektes auf das Zielsystem werden auch die für die webbasierte Visualisierung notwendigen Dateien mit auf das Zielsystem transportiert und im Verzeichnis .\TwinCAT\Boot\WebVisu abgelegt. Eine Aktivierung der "Download Symbol description" ist nicht notwendig.

Mit dem Übergang der SPS in den "Run" Modus ist die webbasierte Visualisierung nun für Clients (Browser) verfügbar.

Hinweis
Eine Anwahl von "Download Symbol description" ist für den Einsatz von TwinCAT PC HMI Web nicht notwendig.


Aufruf Webseite

Voraussetzungen:

Ein Client (Browser) benötigt zur Anzeige der webbasierten Visualisierung TwinCAT PLC HMI Web eine Java-VM (Hinweis zu aktuellen Versionen siehe unten).

  • Für PC basierende Systeme steht diese von diversen Anbietern kostenlos zur Verfügung, z.B. www.sun.com
  • Für CE basierende Systeme steht keine kostenlose Java-VM zur Verfügung

Testversion: 1.6.0_12). Die aktuelle Version 1.6.0_14 der Java-VM befindet sich derzeit in der Testphase.

Start:

Der Client startet die Webseite mit dieser URL (unabhängig unter welchem Namen die VISU-Seite im TwinCAT PLC Control angelegt wurde):

http://<ip-or-hostname-of-device>/TcWebVisu/Index.htm

oder

http://<ip-or-hostname-of-device>/TcWebVisu/

Beispiele:

http://192.16.18.213/TcWebVisu/Index.htm

http://192.16.18.213/TcWebVisu/

http://CX_012345/TcWebVisu/Index.htm

http://CX_012345/TcWebVisu/

Sollten Sie einen Projekt-Wechsel vornehmen, während ein Browser noch das alte Projekt anzeigt, müssen Sie unter Umständen den Cache Ihres Browsers leeren, um die neue Seite an zu zeigen. Ein neues Browser-Fenster oder ein normaler Refresh hilft an dieser Stelle nicht. Zum Beispiel bei dem Internet Explorer 8: Shift-Taste + Seiten-Refresh-Button mit der Maus.

Hinweis
Für eine erfolgreiche Kommunikation bei Windows XP basierten Systemen müssen die IP-Adresse und die NetID des Host-Rechners gleich sein.
Das heißt bei einer IP-Adresse 192.16.18.213 muss die NetID 192.16.18.213.1.1 lauten.

Hinweis
Nicht funktionsfähig ist:
http://localhost/TcWebVisu/

Hinweis
Ab der Java-VM Version 1.6.0_14 müssen auf dem Host-Rechner folgende Einstellungen zusätzlich vorgenommen werden:

In Ihrer Systemsteuerung (Windows XP und XPe) finden Sie den Eintrag "Java". Wenn Sie diesen auswählen öffnet sich das Fenster "Java Control Panal", dort wählen Sie bitte, wie unten in der Abbildung dargestellt, den Button "Netzwerkeinstellungen" aus. Dort muss dann die Option "Direktverbindung" eingeschaltet werden.

Hinweis
Aufgrund von Java bezogenen Restriktionen in den anderen Browsern ist der Internet Explorer (aktuell Version 11) der einzige Browser, der die TwinCAT 2 PLC HMI Web unterstützt.


Übersicht

TS1810 | TwinCAT PLC HMI Web

Unterstütze Visualisierungselemente

Textplatzhalter

TwinCAT PLC HMI Web Visualisierung unterstützt aktuell folgende Textplatzhalter:

Platzhalter | Argument / Ausgabe als
%d | Dezimale Zahl
%o | Oktale Zahl ohne Vorzeichen (ohne führende Null)
%x | Hexadezimale Zahl ohne Vorzeichen (ohne führendes 0x)
%s | Zeichenkette
%f | REAL-Werte [-]m.<dddddd>, wobei die Genauigkeit die Anzahl der d festlegt (Voreinstellung ist 6). Das Plus- bzw. Minuszeichen definiert Rechts (Voreinstellung) bzw. Linksbündigkeit, m definiert die Anzahl der Stellen nach dem Komma.

Datums- und Zeitangaben (%t)

TwinCAT PLC HMI Web Visualisierung unterstützt aktuell folgende Datums- und Zeitangaben:

Platzhalter | Format
%a | Name des Wochentags, abgekürzt, z.B. "Wed"
%A | Name des Wochentags, volle Länge, z.B. "Wednesday"
%b | Monatsname, abgekürzt, z.B. "Feb"
%B | Monatsname, volle Länge, z.B. "February"
%c | Datum und Uhrzeit im Format <Monat>/<Tag>/<Jahr> <Stunden>:<Minuten>:<Sekunden>, z.B. "08/28/02 16:58:45"
%d | Monatstag als Zahl (01-31), z.B. "24"
%H | Stundenangabe, 24-Stundenformat (01-24), z.B. "16"
%I | Stundenangabe, 12-Stundenformat (01-12), z.B. "05" für 17 Uhr
%j | Tag des Jahres (001 – 366), z.B. "241"
%m | Monat (01 – 12), z.B. "3" für März
%M | Minuten (00 – 59), z.B. "13
%p | Aktueller Anzeiger AM (Stunden <12) bzw. PM (>12) für die Angabe im 12-Stundenformat, z.B. "AM", wenn es gerade 9 Uhr vormittags ist.
%S | Sekunden (00 – 59)
%U | Wochenangabe als Zahl, wobei Sonntag als erster Tag der Woche gerechnet wird) (00 – 53 für 53 mögliche Wochen eines Jahres)
%W | Wochenangabe als Zahl, wobei Montag als erster Tag der Woche gerechnet wird) (00 – 53 für 53 mögliche Wochen eines Jahres)
%x | Datum im Format <Monat>/<Tag>/<Jahr>, z.B. "08/28/02"
%X | Uhrzeit im Format <Stunden>:<Minuten>:<Sekunden>, z.B. "16:58:45"
%y | Jahresangabe ohne Jahrhunderte (00 – 99), z.B. "02"
%Y | Jahresangabe mit Jahrhunderten, z.B. "2002"
%z, %Z | Angabe der Zeitzone (keine Angabe, falls die Zeitzone nicht bekannt ist), z.B. "Westeuropäische Sommerzeit"
%% | Prozentzeichen

Allgemein

Bewegen von Elementen in der Web Visualisierung wird unterstützt.

ACHTUNG
Leerzeichen zwischen dem "%" und dem Symbol führen dazu, dass der Wert nicht mehr von der Web Visualisierung gelesen werden kann!

ACHTUNG
In der Web Visualisierung kann aktuell nicht gescrollt werden. Somit muss beim Design der Web Visualisierung die spätere Fenstergröße beachtet werden.

Einschränkungen und Besonderheiten

Eingabe

Texteingaben werden von der Web Visualisierung aktuell nur unterstützt, wenn 'Text' als Text Eingabe der Variable 'Textausgabe' ausgewählt ist.

Alarm-Tabellen

Alarm-Tabellen werden von der Web Visualisierung aktuell nicht unterstützt.

Trend-Funktion

Die Trend-Funktion wird von der Web Visualisierung aktuell nicht unterstützt.

Histogramm

Histogrammanzeigen werden von der Web Visualisierung aktuell nicht unterstützt.

Interne Befehle (siehe Kap. spezielle Eingabemöglichkeiten)

  • PRINT - Dieser Befehl zum Ausdrucken der aktuellen Visualisierung wird für die Web-Visualisierung nicht unterstützt.

  • Externes Programm ausführen - Der Befehl zum Ausführen eines externen Programms wird für die Web-Visualisierung nicht unterstützt.

  • LANGUAGEDIALOG - Der Befehl zum Aufrufen des Konfigurationsdialog für eine Visualisierung, der auch die Kategorie Sprache enthält, wird für die Web-Visualisierung nicht unterstützt.

  • EXITPROGRAM - Der Befehl zum Beenden des Programms wird für die Web-Visualisierung nicht unterstützt, findet aber Ersatz durch INTERN LINK.

  • TRACE - Der Befehl zum Öffnen des Fensters zur Traceaufzeichnung wird für die Web-Visualisierung nicht unterstützt.

  • SAVEPROJECT - Der Befehl zum Speichern des Projekts wird für die Web-Visualisierung nicht unterstützt.

Variablenzugriffe

  • Dynamische Indizierung innerhalb eines Arrays - „Array1[Index].a“ ist nicht möglich, „Array1[10].a“ dagegen schon.

  • Platzhalterersetzungen - Platzhalterersetzungen sind zur Zeit innerhalb der Web-Visualisierung nicht möglich.

  • Pointer - Pointervariablen wie MAIN.pdw2^ können nicht angezeigt werden.

Sonstiges

  • Transparente Bitmaps - Transparenten Bitmaps werden gegenwärtig noch nicht unterstützt.
  • Alarmbehandlung - Die Alarmbehandlung wird für die Web-Visualisierung nicht unterstützt.

  • IEC-Operatoren - Die folgenden IEC-Operatoren werden derzeit von der Web-Visualisierung nicht unterstützt:

    - Arithmetische Operatoren: MOVE, INDEXOF, SIZEOF

    - Bitstring Operatoren: XOR

    - Bitshift Operatoren: SHL, SHR, ROL, ROR

    - Auswahloperatoren: LIMIT, MUX

    - Vergleichsoperatoren: EQ, NE

    - Alle Adressoperatoren

    - Alle Aufrufoperatoren

    - Alle Konvertierungsoperatoren

    - Numerische Operatoren: SQRT, LN, LOG, EXP, ASIN, ACOS, ATAN, EXPT


Feature Overview

TS1800 | TwinCAT PLC HMI

Feature Übersicht der Visualisierung mit TwinCAT

Die folgende Tabelle gibt einen Überblick über die einzelnen Möglichkeiten der Visualisierung mit TwinCAT

 | PLC Control | PLC HMI | PLC HMI Web | PLC HMI CE | Comment
Current test version: | Build 1010 | 2.10.0.900 | 1.0.0.7 | 1.0.9.10 | Ab TwinCAT 2.10 Build 1334
Rectangle |  |  |  |  |
Rounded rectangle |  |  |  |  |
Ellipse |  |  |  |  |
Polygon |  |  |  |  |
Curve |  |  |  |  |
Pie |  |  |  |  |
Bitmap |  |  |  |  |
Visualisation |  |  |  |  |
Button |  |  |  |  |
WMF/JPG File |  |  |  |  |
Table |  |  |  |  |
ActiveX element |  |  |  |  |
Trend |  |  |  | / | HMI CE: Only online trend is available
Alarm table |  |  |  |  |
Meter |  |  |  |  |
Bar display |  |  |  |  |
Histogram |  |  |  |  |
Invisible elements |  |  |  |  |
Change color |  |  |  |  |
Background bitmap |  |  |  |  |
Button background |  |  |  |  |
Tooltip |  |  |  |  | HMI CE: Elements not too near to the edge or tooltip is outside the window
Security |  |  |  |  |
Placeholder |  |  | / | / | Web/HMI CE: Zoom to visu with placeholders in the zoom command is not possible
Print function |  |  |  |  |
Password change |  |  |  |  |
Change user level |  |  |  |  |
Language dialog |  |  |  |  |
Language automatic change |  |  |  |  |
Exit |  |  |  |  |
Trace |  |  |  |  |
Text input 'Text' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported
Text input 'Numpad' |  |  |  |  | HMI CE: The hidden function is not supported
Text input 'Keypad' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported

Restrictions