Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Übersicht

Das TwinCAT PLC HMI ist ein System zur Ausführung von Visualisierungen, die mit dem TwinCAT Programmiersystem erstellt wurden. Wenn ein Steuerungsprogramm entsprechende Visualisierungen enthält, werden diese nach dem Start von TwinCAT PLC HMI im Vollbildmodus dargestellt und der Benutzer kann darüber per Mausklick oder Tastatur die im zugrunde liegenden Projekt enthaltenen Steuer- und Überwachungsfunktionen bedienen. Dies ist auch möglich, wenn die TwinCAT PLC Projektdatei mit einem Leseschutz versehen ist. Der Anwender hat keine Möglichkeit, das Steuerungsprogramm zu editieren, Menüs und Funktionsleisten stehen nicht zur Verfügung, es handelt sich um eine reine 'Bedienung' der enthaltenen Visualisierungselemente.

Die wesentlichen Steuer- und Überwachungsfunktionen in einem Projekt müssen also beim Erstellen eines für die Bedienversion vorgesehenen Projektes auf Visualisierungselemente gelegt werden und damit im Online Modus bedient werden. Hierzu gibt es spezielle Eingabemöglichkeiten im Konfigurationsdialog eines Visualisierungselements.

Durch die nahtlose Integration in TwinCAT PLC Control bietet die Visualisierung mit TwinCAT PLC HMI folgende Vorteile:

• Es kann direkt mit den TwinCAT PLC Control Variablen des Steuerungsprogramms gearbeitet werden.

• Die Verwendung von Ausdrücken in der Visualisierungskonfiguration ist möglich (z.B. „Variable1+ Variable2" "12 + 5")

• Ein Platzhalterkonzept ermöglicht objektorientiertes Arbeiten.

• Die TwinCAT PLC Control Funktionen Trace und Rezepturen lesen/schreiben stehen auch in TwinCAT PLC HMI zur Verfügung


Installation, Start und Bedienung

Installation:

TwinCAT PLC HMI steht als Supplement zur Verfügung und kann mit dem Setup nachinstalliert werden. Eine Lizenz ist kostenpflichtig und eine limitierte Demoversion steht nicht zur Verfügung.

Start:

TwinCAT PLC HMI (TCatPlcCtrlHmi.exe) wird über eine Verknüpfung oder die Kommandozeile gestartet.

In jedem Fall muss mindestens das gewünschte TwinCAT PLC Control Projekt angegeben werden. Wenn der Aufruf keine weiteren Parameter enthält, startet TwinCAT PLC HMI automatisch mit dem Visualisierungsbaustein TC_VISU, vorausgesetzt, dass ein solcher im Projekt vorhanden ist, und auf dem Zielsystem wie es beim letzten Speichern des Projekts eingestellt war.

Es stehen jedoch zusätzlich sowohl die üblichen in TwinCAT verfügbaren Kommandozeilen- und Kommandodateibefehle (siehe TwinCAT Handbuch) als auch der folgende spezielle Parameter zur Verfügung:

/visu <Visualisierungsbaustein>

Wenn das Projekt einen Visualisierungsbaustein mit dem Namen TC_VISU enthält, wird automatisch mit diesem gestartet; soll ein anderer als Einsprungbaustein funktionieren, muss dieser mit einem Zusatz "/visu <Visualisierungsbaustein>" im Aufrufkommando genannt werden

Beispiel für einen Kommandozeilenaufruf:

C:\TwinCAT\Plc\TCatPlcCtrlHmi.exe D:\PROJECTS\PROJECT.PRO /visu v_firstvisupage

Das Projekt project.pro startet mit dem Visualisierungsbaustein 'v_firstvisupage'. Soll die Visualisierung mit TwinCAT automatisch gestartet werden, kann dieses über eine Verknüpfung im TwinCAT StartUp (All Users) auf die 'TCatPlcCtrlHmi.exe' und genannte Parameter erfolgen.

Achtung bei der Eingabe von Pfaden in der Kommandozeile:

Wenn im Pfad Leerzeichen enthalten sind, muss er in Hochkommas (") gefasst werden.

Bedienung:

Das Projekt startet im Vollbildmodus mit dem Start-Visualisierungsbaustein.

Die weitere Bedienung des Projekts erfolgt per Tastatur und Maus über die Visualisierungselemente.

Steht kein Visualisierungselement mit der entsprechenden Funktion zur Verfügung, kann TwinCAT PLC HMI jederzeit mit <Alt><F4> beendet werden.


Feature Overview

TS1800 | TwinCAT PLC HMI

Feature Übersicht der Visualisierung mit TwinCAT

Die folgende Tabelle gibt einen Überblick über die einzelnen Möglichkeiten der Visualisierung mit TwinCAT

 | PLC Control | PLC HMI | PLC HMI Web | PLC HMI CE | Comment
Current test version: | Build 1010 | 2.10.0.900 | 1.0.0.7 | 1.0.9.10 | Ab TwinCAT 2.10 Build 1334
Rectangle |  |  |  |  |
Rounded rectangle |  |  |  |  |
Ellipse |  |  |  |  |
Polygon |  |  |  |  |
Curve |  |  |  |  |
Pie |  |  |  |  |
Bitmap |  |  |  |  |
Visualisation |  |  |  |  |
Button |  |  |  |  |
WMF/JPG File |  |  |  |  |
Table |  |  |  |  |
ActiveX element |  |  |  |  |
Trend |  |  |  | / | HMI CE: Only online trend is available
Alarm table |  |  |  |  |
Meter |  |  |  |  |
Bar display |  |  |  |  |
Histogram |  |  |  |  |
Invisible elements |  |  |  |  |
Change color |  |  |  |  |
Background bitmap |  |  |  |  |
Button background |  |  |  |  |
Tooltip |  |  |  |  | HMI CE: Elements not too near to the edge or tooltip is outside the window
Security |  |  |  |  |
Placeholder |  |  | / | / | Web/HMI CE: Zoom to visu with placeholders in the zoom command is not possible
Print function |  |  |  |  |
Password change |  |  |  |  |
Change user level |  |  |  |  |
Language dialog |  |  |  |  |
Language automatic change |  |  |  |  |
Exit |  |  |  |  |
Trace |  |  |  |  |
Text input 'Text' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported
Text input 'Numpad' |  |  |  |  | HMI CE: The hidden function is not supported
Text input 'Keypad' |  |  |  |  | Web: Please don't exceed the maximum string length of your variable HMI CE: The hidden function is not supported

Restrictions