Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


TwinCAT Fehlercodes Übersicht

TwinCAT Diagnostics: TwinCAT Error Codes Overview

TwinCAT Error Codes

Offset | Beschreibung
0x0000 | ERR_GLOBAL
0x0500 | ERR_ROUTERERRS
0x0600 | ERR_TASKERRS
0x0700 | ERR_ADSERRS
0x0800 | ERR_SYSSMPLERRS
0x1000 | ERR_RTIMEERRS ERR_TRACEERRS (ERR_RTIMEERRS + 0x900)
0x2000 | ERR_IOERRS ERR_DPSLAVE (ERR_IOERRS+0x900) ERR_CP5412A2 (ERR_IOERRS+0xA00) ERR_ASP (ERR_IOERRS+0xB00) ERR_CANSLAVE (ERR_IOERRS+0xC00) ERR_CIF30 (ERR_IOERRS+0xD00) ERR_IBSSLAVE (ERR_IOERRS+0xE00)
0x3000 | ERR_SPSERRS
0x4000 | ERR_NCERRS
0x5000 | ERR_APPLERRS (Beckhoff application and supplement errors) 0x5000 ... 0x50FF: NC application errors (e.g. supplemental application libraries and products)
0x6000 | ERR_PLCERRS
0x7000 | ERR_STRKERRS
0x7800 | ERR_PRJSPECIFIC


ADS Return Codes

Error codes: 0x000..., 0x500..., 0x700..., 0x1000..., 0x274C...

Global Error Codes

Hex | Dec | Description | Possible Causes | Solution
0x0 | 0 | no error |  |
0x1 | 1 | Internal error |  |
0x2 | 2 | No Rtime |  |
0x3 | 3 | Allocation locked memory error |  |
0x4 | 4 | Insert mailbox error | No ADS mailbox was available to process this message. | Reduce the number of ADS calls (e.g ADS-Sum commands or Max Delay Parameter)
0x5 | 5 | Wrong receive HMSG |  |
0x6 | 6 | target port not found | ADS Server not started |
0x7 | 7 | target machine not found | Missing ADS routes |
0x8 | 8 | Unknown command ID |  |
0x9 | 9 | Bad task ID |  |
0xA | 10 | No IO |  |
0xB | 11 | Unknown ADS command |  |
0xC | 12 | Win 32 error |  |
0xD | 13 | Port not connected |  |
0xE | 14 | Invalid ADS length |  |
0xF | 15 | Invalid AMS Net ID |  |
0x10 | 16 | Low Installation level |  |
0x11 | 17 | No debug available |  |
0x12 | 18 | Port disabled |  |
0x13 | 19 | Port already connected |  |
0x14 | 20 | ADS Sync Win32 error |  |
0x15 | 21 | ADS Sync Timeout |  |
0x16 | 22 | ADS Sync AMS error |  |
0x17 | 23 | ADS Sync no index map |  |
0x18 | 24 | Invalid ADS port |  |
0x19 | 25 | No memory |  |
0x1A | 26 | TCP send error |  |
0x1B | 27 | Host unreachable |  |
0x1C | 28 | Invalid AMS fragment |  |

Router Error Codes

Hex | Dec | Description | Possible Causes | Solution
0x500 | 1280 | ROUTERERR_NOLOCKEDMEMORY | No locked memory can be allocated |
0x501 | 1281 | ROUTERERR_RESIZEMEMORY | The size of the router memory could not be changed |
0x502 | 1282 | ROUTERERR_MAILBOXFULL | The mailbox has reached the maximum number of possible messages. The current sent message was rejected | Check the connection between the communication partners
0x503 | 1283 | ROUTERERR_DEBUGBOXFULL | The mailbox has reached the maximum number of possible messages. The sent message will not be displayed in the debug monitor | Check the connection to the debug monitor
0x504 | 1284 | ROUTERERR_UNKNOWNPORTTYPE | The port type is unknown |
0x505 | 1285 | ROUTERERR_NOTINITIALIZED | Router is not initialised |
0x506 | 1286 | ROUTERERR_PORTALREADYINUSE | The desired port number is already assigned |
0x507 | 1287 | ROUTERERR_NOTREGISTERED | Port not registered |
0x508 | 1288 | ROUTERERR_NOMOREQUEUES | The maximum number of Ports reached |
0x509 | 1289 | ROUTERERR_INVALIDPORT | The port is invalid. |
0x50A | 1290 | ROUTERERR_NOTACTIVATED | TwinCAT Router not active |
0x50B | 1291 | ROUTERERR_FRAGMENTBOXFULL |  |
0x50C | 1292 | ROUTERERR_FRAGMENTTIMEOUT |  |
0x50D | 1293 | ROUTERERR_TOBEREMOVED |  |

General ADS Error Codes

Hex | Dec | Description | Possible Causes | Solution
0x700 | 1792 | error class <device error> |  |
0x701 | 1793 | Service is not supported by server |  |
0x702 | 1794 | invalid index group |  |
0x703 | 1795 | invalid index offset |  |
0x704 | 1796 | reading/writing not permitted |  |
0x705 | 1797 | parameter size not correct |  |
0x706 | 1798 | invalid parameter value(s) |  |
0x707 | 1799 | device is not in a ready state |  |
0x708 | 1800 | device is busy |  |
0x709 | 1801 | invalid context (must be in Windows) |  |
0x70A | 1802 | out of memory |  |
0x70B | 1803 | invalid parameter value(s) |  |
0x70C | 1804 | not found (files, ...) |  |
0x70D | 1805 | syntax error in command or file |  |
0x70E | 1806 | objects do not match |  |
0x70F | 1807 | object already exists |  |
0x710 | 1808 | symbol not found |  |
0x711 | 1809 | symbol version invalid | Onlinechange | Release handle and get a new one
0x712 | 1810 | server is in invalid state |  |
0x713 | 1811 | AdsTransMode not supported |  |
0x714 | 1812 | Notification handle is invalid | Onlinechange | Release handle and get a new one
0x715 | 1813 | Notification client not registered |  |
0x716 | 1814 | no more notification handles |  |
0x717 | 1815 | size for watch too big |  |
0x718 | 1816 | device not initialized |  |
0x719 | 1817 | device has a timeout |  |
0x71A | 1818 | query interface failed |  |
0x71B | 1819 | wrong interface required |  |
0x71C | 1820 | class ID is invalid |  |
0x71D | 1821 | object ID is invalid |  |
0x71E | 1822 | request is pending |  |
0x71F | 1823 | request is aborted |  |
0x720 | 1824 | signal warning |  |
0x721 | 1825 | invalid array index |  |
0x722 | 1826 | symbol not active | Onlinechange | Release handle and get a new one
0x723 | 1827 | access denied |  |
0x724 | 1828 | missing license |  | Activate license for TwinCAT 3 function
0x72c | 1836 | exception occured during system start |  | Check each device transistions
0x740 | 1856 | Error class <client error> |  |
0x741 | 1857 | invalid parameter at service |  |
0x742 | 1858 | polling list is empty |  |
0x743 | 1859 | var connection already in use |  |
0x744 | 1860 | invoke ID in use |  |
0x745 | 1861 | timeout elapsed |  | Check ADS routes of sender and receiver and your firewall setting
0x746 | 1862 | error in win32 subsystem |  |
0x747 | 1863 | Invalid client timeout value |  |
0x748 | 1864 | ads-port not opened |  |
0x750 | 1872 | internal error in ads sync |  |
0x751 | 1873 | hash table overflow |  |
0x752 | 1874 | key not found in hash |  |
0x753 | 1875 | no more symbols in cache |  |
0x754 | 1876 | invalid response received |  |
0x755 | 1877 | sync port is locked |  |

RTime Error Codes

Hex | Dec | Description | Possible Causes
0x1000 | 4096 | RTERR_INTERNAL | Internal fatal error in the TwinCAT real-time system
0x1001 | 4097 | RTERR_BADTIMERPERIODS | Timer value not vaild
0x1002 | 4098 | RTERR_INVALIDTASKPTR | Task pointer has the invalid value ZERO
0x1003 | 4099 | RTERR_INVALIDSTACKPTR | Task stack pointer has the invalid value ZERO
0x1004 | 4100 | RTERR_PRIOEXISTS | The demand task priority is already assigned
0x1005 | 4101 | RTERR_NOMORETCB | No more free TCB (Task Control Block) available. Maximum number of TCBs is 64
0x1006 | 4102 | RTERR_NOMORESEMAS | No more free semaphores available. Maximum number of semaphores is 64
0x1007 | 4103 | RTERR_NOMOREQUEUES | No more free queue available. Maximum number of queue is 64
0x1008 | 4104 | TwinCAT reserved. |
0x1009 | 4105 | TwinCAT reserved. |
0x100A | 4106 | TwinCAT reserved. |
0x100B | 4107 | TwinCAT reserved. |
0x100C | 4108 | TwinCAT reserved. |
0x100D | 4109 | RTERR_EXTIRQALREADYDEF | An external synchronisation interrupt is already applied
0x100E | 4110 | RTERR_EXTIRQNOTDEF | No external synchronsiation interrupt applied
0x100F | 4111 | RTERR_EXTIRQINSTALLFAILED | The apply of the external synchronisation interrupt failed
0x1010 | 4112 | RTERR_IRQLNOTLESSOREQUAL | Call of a service function in the wrong context
0x1017 | 4119 | RTERR_VMXNOTSUPPORTED | Intel VT-x extension is not supported.
0x1018 | 4120 | RTERR_VMXDISABLED | Intel VT-x extension is not enabled in BIOS.
0x1019 | 4121 | RTERR_VMXCONTROLSMISSING | Missing feature in Intel VT-x extension.
0x101A | 4122 | RTERR_VMXENABLEFAILS | Enabling Intel VT-x fails.

TCP Winsock Error Codes

Hex | Dec | Description | Possible Causes | Solution
0x274c | 10060 | A socket operation was attempted to an unreachable host | Host unreachable | Check network connection via ping
0x274d | 10061 | A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. | Host unreachable | Check network connection via ping
0x2751 | 10065 | No connection could be made because the target machine actively refused it |  |
 |  | Further Winsock error codes: Win32 Error Codes |  |


Win32 Error Codes

The following table provides a list of Win32 error codes.

100, 200, 1001, 1100, 1200, 1400, 1600, 1800, 2000, 3000, 5000, 6000, 8000, 8500, 9001, 10004, 12000,

Code (dec) | Code (hex) | Description | Name
0 | 0x00000000 | The operation completed successfully. | ERROR_SUCCESS
1 | 0x00000001 | Incorrect function. | ERROR_INVALID_FUNCTION
2 | 0x00000002 | The system cannot find the file specified. | ERROR_FILE_NOT_FOUND
3 | 0x00000003 | The system cannot find the path specified. | ERROR_PATH_NOT_FOUND
4 | 0x00000004 | The system cannot open the file. | ERROR_TOO_MANY_OPEN_FILES
5 | 0x00000005 | Access is denied. | ERROR_ACCESS_DENIED
6 | 0x00000006 | The handle is invalid. | ERROR_INVALID_HANDLE
7 | 0x00000007 | The storage control blocks were destroyed. | ERROR_ARENA_TRASHED
8 | 0x00000008 | Not enough storage is available to process this command. | ERROR_NOT_ENOUGH_MEMORY
9 | 0x00000009 | The storage control block address is invalid. | ERROR_INVALID_BLOCK
10 | 0x0000000A | The environment is incorrect. | ERROR_BAD_ENVIRONMENT
11 | 0x0000000B | An attempt was made to load a program with an incorrect format. | ERROR_BAD_FORMAT
12 | 0x0000000C | The access code is invalid. | ERROR_INVALID_ACCESS
13 | 0x0000000D | The data is invalid. | ERROR_INVALID_DATA
14 | 0x0000000E | Not enough storage is available to complete this operation. | ERROR_OUTOFMEMORY
15 | 0x0000000F | The system cannot find the drive specified. | ERROR_INVALID_DRIVE
16 | 0x00000010 | The directory cannot be removed. | ERROR_CURRENT_DIRECTORY
17 | 0x00000011 | The system cannot move the file to a different disk drive. | ERROR_NOT_SAME_DEVICE
18 | 0x00000012 | There are no more files. | ERROR_NO_MORE_FILES
19 | 0x00000013 | The media is write protected. | ERROR_WRITE_PROTECT
20 | 0x00000014 | The system cannot find the device specified. | ERROR_BAD_UNIT
21 | 0x00000015 | The device is not ready. | ERROR_NOT_READY
22 | 0x00000016 | The device does not recognize the command. | ERROR_BAD_COMMAND
23 | 0x00000017 | Data error (cyclic redundancy check). | ERROR_CRC
24 | 0x00000018 | The program issued a command but the command length is incorrect. | ERROR_BAD_LENGTH
25 | 0x00000019 | The drive cannot locate a specific area or track on the disk. | ERROR_SEEK
26 | 0x0000001A | The specified disk or diskette cannot be accessed. | ERROR_NOT_DOS_DISK
27 | 0x0000001B | The drive cannot find the sector requested. | ERROR_SECTOR_NOT_FOUND
28 | 0x0000001C | The printer is out of paper. | ERROR_OUT_OF_PAPER
29 | 0x0000001D | The system cannot write to the specified device. | ERROR_WRITE_FAULT
30 | 0x0000001E | The system cannot read from the specified device. | ERROR_READ_FAULT
31 | 0x0000001F | A device attached to the system is not functioning. | ERROR_GEN_FAILURE
32 | 0x00000020 | The process cannot access the file because it is being used by another process. | ERROR_SHARING_VIOLATION
33 | 0x00000021 | The process cannot access the file because another process has locked a portion of the file. | ERROR_LOCK_VIOLATION
34 | 0x00000022 | The wrong diskette is in the drive. Insert %2 (Volume Serial Number: %3) into drive %1. | ERROR_WRONG_DISK
36 | 0x00000024 | Too many files opened for sharing. | ERROR_SHARING_BUFFER_EXCEEDED
38 | 0x00000026 | Reached the end of the file. | ERROR_HANDLE_EOF
39 | 0x00000027 | The disk is full. | ERROR_HANDLE_DISK_FULL
50 | 0x00000032 | The request is not supported. | ERROR_NOT_SUPPORTED
51 | 0x00000033 | The remote computer is not available. | ERROR_REM_NOT_LIST
52 | 0x00000034 | A duplicate name exists on the network. | ERROR_DUP_NAME
53 | 0x00000035 | The network path was not found. | ERROR_BAD_NETPATH
54 | 0x00000036 | The network is busy. | ERROR_NETWORK_BUSY
55 | 0x00000037 | The specified network resource or device is no longer available. | ERROR_DEV_NOT_EXIST
56 | 0x00000038 | The network BIOS command limit has been reached. | ERROR_TOO_MANY_CMDS
57 | 0x00000039 | A network adapter hardware error occurred. | ERROR_ADAP_HDW_ERR
58 | 0x0000003A | The specified server cannot perform the requested operation. | ERROR_BAD_NET_RESP
59 | 0x0000003B | An unexpected network error occurred. | ERROR_UNEXP_NET_ERR
60 | 0x0000003C | The remote adapter is not compatible. | ERROR_BAD_REM_ADAP
61 | 0x0000003D | The printer queue is full. | ERROR_PRINTQ_FULL
62 | 0x0000003E | Space to store the file waiting to be printed is not available on the server. | ERROR_NO_SPOOL_SPACE
63 | 0x0000003F | Your file waiting to be printed was deleted. | ERROR_PRINT_CANCELLED
64 | 0x00000040 | The specified network name is no longer available. | ERROR_NETNAME_DELETED
65 | 0x00000041 | Network access is denied. | ERROR_NETWORK_ACCESS_DENIED
66 | 0x00000042 | The network resource type is not correct. | ERROR_BAD_DEV_TYPE
67 | 0x00000043 | The network name cannot be found. | ERROR_BAD_NET_NAME
68 | 0x00000044 | The name limit for the local computer network adapter card was exceeded. | ERROR_TOO_MANY_NAMES
69 | 0x00000045 | The network BIOS session limit was exceeded. | ERROR_TOO_MANY_SESS
70 | 0x00000046 | The remote server has been paused or is in the process of being started. | ERROR_SHARING_PAUSED
71 | 0x00000047 | No more connections can be made to this remote computer at this time because there are already as many connections as the computer can accept. | ERROR_REQ_NOT_ACCEP
72 | 0x00000048 | The specified printer or disk device has been paused. | ERROR_REDIR_PAUSED
80 | 0x00000050 | The file exists. | ERROR_FILE_EXISTS
82 | 0x00000052 | The directory or file cannot be created. | ERROR_CANNOT_MAKE
83 | 0x00000053 | Fail on INT 24. | ERROR_FAIL_I24
84 | 0x00000054 | Storage to process this request is not available. | ERROR_OUT_OF_STRUCTURES
85 | 0x00000055 | The local device name is already in use. | ERROR_ALREADY_ASSIGNED
86 | 0x00000056 | The specified network password is not correct. | ERROR_INVALID_PASSWORD
87 | 0x00000057 | The parameter is incorrect. | ERROR_INVALID_PARAMETER
88 | 0x00000058 | A write fault occurred on the network. | ERROR_NET_WRITE_FAULT
89 | 0x00000059 | The system cannot start another process at this time. | ERROR_NO_PROC_SLOTS
100 | 0x00000064 | Cannot create another system semaphore. | ERROR_TOO_MANY_SEMAPHORES
101 | 0x00000065 | The exclusive semaphore is owned by another process. | ERROR_EXCL_SEM_ALREADY_OWNED
102 | 0x00000066 | The semaphore is set and cannot be closed. | ERROR_SEM_IS_SET
103 | 0x00000067 | The semaphore cannot be set again. | ERROR_TOO_MANY_SEM_REQUESTS
104 | 0x00000068 | Cannot request exclusive semaphores at interrupt time. | ERROR_INVALID_AT_INTERRUPT_TIME
105 | 0x00000069 | The previous ownership of this semaphore has ended. | ERROR_SEM_OWNER_DIED
106 | 0x0000006A | Insert the diskette for drive %1. | ERROR_SEM_USER_LIMIT
107 | 0x0000006B | The program stopped because an alternate diskette was not inserted. | ERROR_DISK_CHANGE
108 | 0x0000006C | The disk is in use or locked by another process. | ERROR_DRIVE_LOCKED
109 | 0x0000006D | The pipe has been ended. | ERROR_BROKEN_PIPE
110 | 0x0000006E | The system cannot open the device or file specified. | ERROR_OPEN_FAILED
111 | 0x0000006F | The file name is too long. | ERROR_BUFFER_OVERFLOW
112 | 0x00000070 | There is not enough space on the disk. | ERROR_DISK_FULL
113 | 0x00000071 | No more internal file identifiers available. | ERROR_NO_MORE_SEARCH_HANDLES
114 | 0x00000072 | The target internal file identifier is incorrect. | ERROR_INVALID_TARGET_HANDLE
117 | 0x00000075 | The IOCTL call made by the application program is not correct. | ERROR_INVALID_CATEGORY
118 | 0x00000076 | The verify-on-write switch parameter value is not correct. | ERROR_INVALID_VERIFY_SWITCH
119 | 0x00000077 | The system does not support the command requested. | ERROR_BAD_DRIVER_LEVEL
120 | 0x00000078 | This function is not supported on this system. | ERROR_CALL_NOT_IMPLEMENTED
121 | 0x00000079 | The semaphore timeout period has expired. | ERROR_SEM_TIMEOUT
122 | 0x0000007A | The data area passed to a system call is too small. | ERROR_INSUFFICIENT_BUFFER
123 | 0x0000007B | The filename, directory name, or volume label syntax is incorrect. | ERROR_INVALID_NAME
124 | 0x0000007C | The system call level is not correct. | ERROR_INVALID_LEVEL
125 | 0x0000007D | The disk has no volume label. | ERROR_NO_VOLUME_LABEL
126 | 0x0000007E | The specified module could not be found. | ERROR_MOD_NOT_FOUND
127 | 0x0000007F | The specified procedure could not be found. | ERROR_PROC_NOT_FOUND
128 | 0x00000080 | There are no child processes to wait for. | ERROR_WAIT_NO_CHILDREN
129 | 0x00000081 | The %1 application cannot be run in Win32 mode. | ERROR_CHILD_NOT_COMPLETE
130 | 0x00000082 | Attempt to use a file handle to an open disk partition for an operation other than raw disk I/O. | ERROR_DIRECT_ACCESS_HANDLE
131 | 0x00000083 | An attempt was made to move the file pointer before the beginning of the file. | ERROR_NEGATIVE_SEEK
132 | 0x00000084 | The file pointer cannot be set on the specified device or file. | ERROR_SEEK_ON_DEVICE
133 | 0x00000085 | A JOIN or SUBST command cannot be used for a drive that contains previously joined drives. | ERROR_IS_JOIN_TARGET
134 | 0x00000086 | An attempt was made to use a JOIN or SUBST command on a drive that has already been joined. | ERROR_IS_JOINED
135 | 0x00000087 | An attempt was made to use a JOIN or SUBST command on a drive that has already been substituted. | ERROR_IS_SUBSTED
136 | 0x00000088 | The system tried to delete the JOIN of a drive that is not joined. | ERROR_NOT_JOINED
137 | 0x00000089 | The system tried to delete the substitution of a drive that is not substituted. | ERROR_NOT_SUBSTED
138 | 0x0000008A | The system tried to join a drive to a directory on a joined drive. | ERROR_JOIN_TO_JOIN
139 | 0x0000008B | The system tried to substitute a drive to a directory on a substituted drive. | ERROR_SUBST_TO_SUBST
140 | 0x0000008C | The system tried to join a drive to a directory on a substituted drive. | ERROR_JOIN_TO_SUBST
141 | 0x0000008D | The system tried to SUBST a drive to a directory on a joined drive. | ERROR_SUBST_TO_JOIN
142 | 0x0000008E | The system cannot perform a JOIN or SUBST at this time. | ERROR_BUSY_DRIVE
143 | 0x0000008F | The system cannot join or substitute a drive to or for a directory on the same drive. | ERROR_SAME_DRIVE
144 | 0x00000090 | The directory is not a subdirectory of the root directory. | ERROR_DIR_NOT_ROOT
145 | 0x00000091 | The directory is not empty. | ERROR_DIR_NOT_EMPTY
146 | 0x00000092 | The path specified is being used in a substitute. | ERROR_IS_SUBST_PATH
147 | 0x00000093 | Not enough resources are available to process this command. | ERROR_IS_JOIN_PATH
148 | 0x00000094 | The path specified cannot be used at this time. | ERROR_PATH_BUSY
149 | 0x00000095 | An attempt was made to join or substitute a drive for which a directory on the drive is the target of a previous substitute. | ERROR_IS_SUBST_TARGET
150 | 0x00000096 | System trace information was not specified in your CONFIG.SYS file, or tracing is disallowed. | ERROR_SYSTEM_TRACE
151 | 0x00000097 | The number of specified semaphore events for DosMuxSemWait is not correct. | ERROR_INVALID_EVENT_COUNT
152 | 0x00000098 | DosMuxSemWait did not execute; too many semaphores are already set. | ERROR_TOO_MANY_MUXWAITERS
153 | 0x00000099 | The DosMuxSemWait list is not correct. | ERROR_INVALID_LIST_FORMAT
154 | 0x0000009A | The volume label you entered exceeds the label character limit of the target file system. | ERROR_LABEL_TOO_LONG
155 | 0x0000009B | Cannot create another thread. | ERROR_TOO_MANY_TCBS
156 | 0x0000009C | The recipient process has refused the signal. | ERROR_SIGNAL_REFUSED
157 | 0x0000009D | The segment is already discarded and cannot be locked. | ERROR_DISCARDED
158 | 0x0000009E | The segment is already unlocked. | ERROR_NOT_LOCKED
159 | 0x0000009F | The address for the thread ID is not correct. | ERROR_BAD_THREADID_ADDR
160 | 0x000000A0 | The argument string passed to DosExecPgm is not correct. | ERROR_BAD_ARGUMENTS
161 | 0x000000A1 | The specified path is invalid. | ERROR_BAD_PATHNAME
162 | 0x000000A2 | A signal is already pending. | ERROR_SIGNAL_PENDING
164 | 0x000000A4 | No more threads can be created in the system. | ERROR_MAX_THRDS_REACHED
167 | 0x000000A7 | Unable to lock a region of a file. | ERROR_LOCK_FAILED
170 | 0x000000AA | The requested resource is in use. | ERROR_BUSY
173 | 0x000000AD | A lock request was not outstanding for the supplied cancel region. | ERROR_CANCEL_VIOLATION
174 | 0x000000AE | The file system does not support atomic changes to the lock type. | ERROR_ATOMIC_LOCKS_NOT_SUPPORTED
180 | 0x000000B4 | The system detected a segment number that was not correct. | ERROR_INVALID_SEGMENT_NUMBER
182 | 0x000000B6 | The operating system cannot run %1. | ERROR_INVALID_ORDINAL
183 | 0x000000B7 | Cannot create a file when that file already exists. | ERROR_ALREADY_EXISTS
186 | 0x000000BA | The flag passed is not correct. | ERROR_INVALID_FLAG_NUMBER
187 | 0x000000BB | The specified system semaphore name was not found. | ERROR_SEM_NOT_FOUND
188 | 0x000000BC | The operating system cannot run %1. | ERROR_INVALID_STARTING_CODESEG
189 | 0x000000BD | The operating system cannot run %1. | ERROR_INVALID_STACKSEG
190 | 0x000000BE | The operating system cannot run %1. | ERROR_INVALID_MODULETYPE
191 | 0x000000BF | Cannot run %1 in Win32 mode. | ERROR_INVALID_EXE_SIGNATURE
192 | 0x000000C0 | The operating system cannot run %1. | ERROR_EXE_MARKED_INVALID
193 | 0x000000C1 | %1 is not a valid Win32 application. | ERROR_BAD_EXE_FORMAT
194 | 0x000000C2 | The operating system cannot run %1. | ERROR_ITERATED_DATA_EXCEEDS_64k
195 | 0x000000C3 | The operating system cannot run %1. | ERROR_INVALID_MINALLOCSIZE
196 | 0x000000C4 | The operating system cannot run this application program. | ERROR_DYNLINK_FROM_INVALID_RING
197 | 0x000000C5 | The operating system is not presently configured to run this application. | ERROR_IOPL_NOT_ENABLED
198 | 0x000000C6 | The operating system cannot run %1. | ERROR_INVALID_SEGDPL
199 | 0x000000C7 | The operating system cannot run this application program. | ERROR_AUTODATASEG_EXCEEDS_64k
200 | 0x000000C8 | The code segment cannot be greater than or equal to 64K. | ERROR_RING2SEG_MUST_BE_MOVABLE
201 | 0x000000C9 | The operating system cannot run %1. | ERROR_RELOC_CHAIN_XEEDS_SEGLIM
202 | 0x000000CA | The operating system cannot run %1. | ERROR_INFLOOP_IN_RELOC_CHAIN
203 | 0x000000CB | The system could not find the environment option that was entered. | ERROR_ENVVAR_NOT_FOUND
205 | 0x000000CD | No process in the command subtree has a signal handler. | ERROR_NO_SIGNAL_SENT
206 | 0x000000CE | The filename or extension is too long. | ERROR_FILENAME_EXCED_RANGE
207 | 0x000000CF | The ring 2 stack is in use. | ERROR_RING2_STACK_IN_USE
208 | 0x000000D0 | The global filename characters, * or ?, are entered incorrectly or too many global filename characters are specified. | ERROR_META_EXPANSION_TOO_LONG
209 | 0x000000D1 | The signal being posted is not correct. | ERROR_INVALID_SIGNAL_NUMBER
210 | 0x000000D2 | The signal handler cannot be set. | ERROR_THREAD_1_INACTIVE
212 | 0x000000D4 | The segment is locked and cannot be reallocated. | ERROR_LOCKED
214 | 0x000000D6 | Too many dynamic-link modules are attached to this program or dynamic-link module. | ERROR_TOO_MANY_MODULES
215 | 0x000000D7 | Cannot nest calls to LoadModule. | ERROR_NESTING_NOT_ALLOWED
216 | 0x000000D8 | The image file %1 is valid, but is for a machine type other than the current machine. | ERROR_EXE_MACHINE_TYPE_MISMATCH
230 | 0x000000E6 | The pipe state is invalid. | ERROR_BAD_PIPE
231 | 0x000000E7 | All pipe instances are busy. | ERROR_PIPE_BUSY
232 | 0x000000E8 | The pipe is being closed. | ERROR_NO_DATA
233 | 0x000000E9 | No process is on the other end of the pipe. | ERROR_PIPE_NOT_CONNECTED
234 | 0x000000EA | More data is available. | ERROR_MORE_DATA
240 | 0x000000F0 | The session was canceled. | ERROR_VC_DISCONNECTED
254 | 0x000000FE | The specified extended attribute name was invalid. | ERROR_INVALID_EA_NAME
255 | 0x000000FF | The extended attributes are inconsistent. | ERROR_EA_LIST_INCONSISTENT
258 | 0x00000102 | The wait operation timed out. | WAIT_TIMEOUT
259 | 0x00000103 | No more data is available. | ERROR_NO_MORE_ITEMS
266 | 0x0000010A | The copy functions cannot be used. | ERROR_CANNOT_COPY
267 | 0x0000010B | The directory name is invalid. | ERROR_DIRECTORY
275 | 0x00000113 | The extended attributes did not fit in the buffer. | ERROR_EAS_DIDNT_FIT
276 | 0x00000114 | The extended attribute file on the mounted file system is corrupt. | ERROR_EA_FILE_CORRUPT
277 | 0x00000115 | The extended attribute table file is full. | ERROR_EA_TABLE_FULL
278 | 0x00000116 | The specified extended attribute handle is invalid. | ERROR_INVALID_EA_HANDLE
282 | 0x0000011A | The mounted file system does not support extended attributes. | ERROR_EAS_NOT_SUPPORTED
288 | 0x00000120 | Attempt to release mutex not owned by caller. | ERROR_NOT_OWNER
298 | 0x0000012A | Too many posts were made to a semaphore. | ERROR_TOO_MANY_POSTS
299 | 0x0000012B | Only part of a ReadProcessMemory or WriteProcessMemory request was completed. | ERROR_PARTIAL_COPY
300 | 0x0000012C | The oplock request is denied. | ERROR_OPLOCK_NOT_GRANTED
301 | 0x0000012D | An invalid oplock acknowledgment was received by the system. | ERROR_INVALID_OPLOCK_PROTOCOL
302 | 0x0000012E | The volume is too fragmented to complete this operation. | ERROR_DISK_TOO_FRAGMENTED
303 | 0x0000012F | The file cannot be opened because it is in the process of being deleted. | ERROR_DELETE_PENDING
317 | 0x0000013D | The system cannot find message text for message number 0x%1 in the message file for %2. | ERROR_MR_MID_NOT_FOUND
487 | 0x000001E7 | Attempt to access invalid address. | ERROR_INVALID_ADDRESS
534 | 0x00000216 | Arithmetic result exceeded 32 bits. | ERROR_ARITHMETIC_OVERFLOW
535 | 0x00000217 | There is a process on other end of the pipe. | ERROR_PIPE_CONNECTED
536 | 0x00000218 | Waiting for a process to open the other end of the pipe. | ERROR_PIPE_LISTENING
994 | 0x000003E2 | Access to the extended attribute was denied. | ERROR_EA_ACCESS_DENIED
995 | 0x000003E3 | The I/O operation has been aborted because of either a thread exit or an application request. | ERROR_OPERATION_ABORTED
996 | 0x000003E4 | Overlapped I/O event is not in a signaled state. | ERROR_IO_INCOMPLETE
997 | 0x000003E5 | Overlapped I/O operation is in progress. | ERROR_IO_PENDING
998 | 0x000003E6 | Invalid access to memory location. | ERROR_NOACCESS
999 | 0x000003E7 | Error performing inpage operation. | ERROR_SWAPERROR
1001 | 0x000003E9 | Recursion too deep; the stack overflowed. | ERROR_STACK_OVERFLOW
1002 | 0x000003EA | The window cannot act on the sent message. | ERROR_INVALID_MESSAGE
1003 | 0x000003EB | Cannot complete this function. | ERROR_CAN_NOT_COMPLETE
1004 | 0x000003EC | Invalid flags. | ERROR_INVALID_FLAGS
1005 | 0x000003ED | The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted. | ERROR_UNRECOGNIZED_VOLUME
1006 | 0x000003EE | The volume for a file has been externally altered so that the opened file is no longer valid. | ERROR_FILE_INVALID
1007 | 0x000003EF | The requested operation cannot be performed in full-screen mode. | ERROR_FULLSCREEN_MODE
1008 | 0x000003F0 | An attempt was made to reference a token that does not exist. | ERROR_NO_TOKEN
1009 | 0x000003F1 | The configuration registry database is corrupt. | ERROR_BADDB
1010 | 0x000003F2 | The configuration registry key is invalid. | ERROR_BADKEY
1011 | 0x000003F3 | The configuration registry key could not be opened. | ERROR_CANTOPEN
1012 | 0x000003F4 | The configuration registry key could not be read. | ERROR_CANTREAD
1013 | 0x000003F5 | The configuration registry key could not be written. | ERROR_CANTWRITE
1014 | 0x000003F6 | One of the files in the registry database had to be recovered by use of a log or alternate copy. The recovery was successful. | ERROR_REGISTRY_RECOVERED
1015 | 0x000003F7 | The registry is corrupted. The structure of one of the files containing registry data is corrupted, or the system's memory image of the file is corrupted, or the file could not be recovered because the alternate copy or log was absent or corrupted. | ERROR_REGISTRY_CORRUPT
1016 | 0x000003F8 | An I/O operation initiated by the registry failed unrecoverably. The registry could not read in, or write out, or flush, one of the files that contain the system's image of the registry. | ERROR_REGISTRY_IO_FAILED
1017 | 0x000003F9 | The system has attempted to load or restore a file into the registry, but the specified file is not in a registry file format. | ERROR_NOT_REGISTRY_FILE
1018 | 0x000003FA | Illegal operation attempted on a registry key that has been marked for deletion. | ERROR_KEY_DELETED
1019 | 0x000003FB | System could not allocate the required space in a registry log. | ERROR_NO_LOG_SPACE
1020 | 0x000003FC | Cannot create a symbolic link in a registry key that already has subkeys or values. | ERROR_KEY_HAS_CHILDREN
1021 | 0x000003FD | Cannot create a stable subkey under a volatile parent key. | ERROR_CHILD_MUST_BE_VOLATILE
1022 | 0x000003FE | A notify change request is being completed and the information is not being returned in the caller's buffer. The caller now needs to enumerate the files to find the changes. | ERROR_NOTIFY_ENUM_DIR
1051 | 0x0000041B | A stop control has been sent to a service that other running services are dependent on. | ERROR_DEPENDENT_SERVICES_RUNNING
1052 | 0x0000041C | The requested control is not valid for this service. | ERROR_INVALID_SERVICE_CONTROL
1053 | 0x0000041D | The service did not respond to the start or control request in a timely fashion. | ERROR_SERVICE_REQUEST_TIMEOUT
1054 | 0x0000041E | A thread could not be created for the service. | ERROR_SERVICE_NO_THREAD
1055 | 0x0000041F | The service database is locked. | ERROR_SERVICE_DATABASE_LOCKED
1056 | 0x00000420 | An instance of the service is already running. | ERROR_SERVICE_ALREADY_RUNNING
1057 | 0x00000421 | The account name is invalid or does not exist, or the password is invalid for the account name specified. | ERROR_INVALID_SERVICE_ACCOUNT
1058 | 0x00000422 | The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. | ERROR_SERVICE_DISABLED
1059 | 0x00000423 | Circular service dependency was specified. | ERROR_CIRCULAR_DEPENDENCY
1060 | 0x00000424 | The specified service does not exist as an installed service. | ERROR_SERVICE_DOES_NOT_EXIST
1061 | 0x00000425 | The service cannot accept control messages at this time. | ERROR_SERVICE_CANNOT_ACCEPT_CTRL
1062 | 0x00000426 | The service has not been started. | ERROR_SERVICE_NOT_ACTIVE
1063 | 0x00000427 | The service process could not connect to the service controller. | ERROR_FAILED_SERVICE_CONTROLLER_CONNECT
1064 | 0x00000428 | An exception occurred in the service when handling the control request. | ERROR_EXCEPTION_IN_SERVICE
1065 | 0x00000429 | The database specified does not exist. | ERROR_DATABASE_DOES_NOT_EXIST
1066 | 0x0000042A | The service has returned a service-specific error code. | ERROR_SERVICE_SPECIFIC_ERROR
1067 | 0x0000042B | The process terminated unexpectedly. | ERROR_PROCESS_ABORTED
1068 | 0x0000042C | The dependency service or group failed to start. | ERROR_SERVICE_DEPENDENCY_FAIL
1069 | 0x0000042D | The service did not start due to a logon failure. | ERROR_SERVICE_LOGON_FAILED
1070 | 0x0000042E | After starting, the service hung in a start-pending state. | ERROR_SERVICE_START_HANG
1071 | 0x0000042F | The specified service database lock is invalid. | ERROR_INVALID_SERVICE_LOCK
1072 | 0x00000430 | The specified service has been marked for deletion. | ERROR_SERVICE_MARKED_FOR_DELETE
1073 | 0x00000431 | The specified service already exists. | ERROR_SERVICE_EXISTS
1074 | 0x00000432 | The system is currently running with the last-known-good configuration. | ERROR_ALREADY_RUNNING_LKG
1075 | 0x00000433 | The dependency service does not exist or has been marked for deletion. | ERROR_SERVICE_DEPENDENCY_DELETED
1076 | 0x00000434 | The current boot has already been accepted for use as the last-known-good control set. | ERROR_BOOT_ALREADY_ACCEPTED
1077 | 0x00000435 | No attempts to start the service have been made since the last boot. | ERROR_SERVICE_NEVER_STARTED
1078 | 0x00000436 | The name is already in use as either a service name or a service display name. | ERROR_DUPLICATE_SERVICE_NAME
1079 | 0x00000437 | The account specified for this service is different from the account specified for other services running in the same process. | ERROR_DIFFERENT_SERVICE_ACCOUNT
1080 | 0x00000438 | Failure actions can only be set for Win32 services, not for drivers. | ERROR_CANNOT_DETECT_DRIVER_FAILURE
1081 | 0x00000439 | This service runs in the same process as the service control manager. Therefore, the service control manager cannot take action if this service's process terminates unexpectedly. | ERROR_CANNOT_DETECT_PROCESS_ABORT
1082 | 0x0000043A | No recovery program has been configured for this service. | ERROR_NO_RECOVERY_PROGRAM
1083 | 0x0000043B | The executable program that this service is configured to run in does not implement the service. | ERROR_SERVICE_NOT_IN_EXE
1084 | 0x0000043C | This service cannot be started in Safe Mode. | ERROR_NOT_SAFEBOOT_SERVICE
1100 | 0x0000044C | The physical end of the tape has been reached. | ERROR_END_OF_MEDIA
1101 | 0x0000044D | A tape access reached a filemark. | ERROR_FILEMARK_DETECTED
1102 | 0x0000044E | The beginning of the tape or a partition was encountered. | ERROR_BEGINNING_OF_MEDIA
1103 | 0x0000044F | A tape access reached the end of a set of files. | ERROR_SETMARK_DETECTED
1104 | 0x00000450 | No more data is on the tape. | ERROR_NO_DATA_DETECTED
1105 | 0x00000451 | Tape could not be partitioned. | ERROR_PARTITION_FAILURE
1106 | 0x00000452 | When accessing a new tape of a multivolume partition, the current block size is incorrect. | ERROR_INVALID_BLOCK_LENGTH
1107 | 0x00000453 | Tape partition information could not be found when loading a tape. | ERROR_DEVICE_NOT_PARTITIONED
1108 | 0x00000454 | Unable to lock the media eject mechanism. | ERROR_UNABLE_TO_LOCK_MEDIA
1109 | 0x00000455 | Unable to unload the media. | ERROR_UNABLE_TO_UNLOAD_MEDIA
1110 | 0x00000456 | The media in the drive may have changed. | ERROR_MEDIA_CHANGED
1111 | 0x00000457 | The I/O bus was reset. | ERROR_BUS_RESET
1112 | 0x00000458 | No media in drive. | ERROR_NO_MEDIA_IN_DRIVE
1113 | 0x00000459 | No mapping for the Unicode character exists in the target multi-byte code page. | ERROR_NO_UNICODE_TRANSLATION
1114 | 0x0000045A | A dynamic link library (DLL) initialization routine failed. | ERROR_DLL_INIT_FAILED
1115 | 0x0000045B | A system shutdown is in progress. | ERROR_SHUTDOWN_IN_PROGRESS
1116 | 0x0000045C | Unable to abort the system shutdown because no shutdown was in progress. | ERROR_NO_SHUTDOWN_IN_PROGRESS
1117 | 0x0000045D | The request could not be performed because of an I/O device error. | ERROR_IO_DEVICE
1118 | 0x0000045E | No serial device was successfully initialized. The serial driver will unload. | ERROR_SERIAL_NO_DEVICE
1119 | 0x0000045F | Unable to open a device that was sharing an interrupt request (IRQ) with other devices. At least one other device that uses that IRQ was already opened. | ERROR_IRQ_BUSY
1120 | 0x00000460 | A serial I/O operation was completed by another write to the serial port. (The IOCTL_SERIAL_XOFF_COUNTER reached zero.) | ERROR_MORE_WRITES
1121 | 0x00000461 | A serial I/O operation completed because the timeout period expired. (The IOCTL_SERIAL_XOFF_COUNTER did not reach zero.) | ERROR_COUNTER_TIMEOUT
1122 | 0x00000462 | No ID address mark was found on the floppy disk. | ERROR_FLOPPY_ID_MARK_NOT_FOUND
1123 | 0x00000463 | Mismatch between the floppy disk sector ID field and the floppy disk controller track address. | ERROR_FLOPPY_WRONG_CYLINDER
1124 | 0x00000464 | The floppy disk controller reported an error that is not recognized by the floppy disk driver. | ERROR_FLOPPY_UNKNOWN_ERROR
1125 | 0x00000465 | The floppy disk controller returned inconsistent results in its registers. | ERROR_FLOPPY_BAD_REGISTERS
1126 | 0x00000466 | While accessing the hard disk, a recalibrate operation failed, even after retries. | ERROR_DISK_RECALIBRATE_FAILED
1127 | 0x00000467 | While accessing the hard disk, a disk operation failed even after retries. | ERROR_DISK_OPERATION_FAILED
1128 | 0x00000468 | While accessing the hard disk, a disk controller reset was needed, but even that failed. | ERROR_DISK_RESET_FAILED
1129 | 0x00000469 | Physical end of tape encountered. | ERROR_EOM_OVERFLOW
1130 | 0x0000046A | Not enough server storage is available to process this command. | ERROR_NOT_ENOUGH_SERVER_MEMORY
1131 | 0x0000046B | A potential deadlock condition has been detected. | ERROR_POSSIBLE_DEADLOCK
1132 | 0x0000046C | The base address or the file offset specified does not have the proper alignment. | ERROR_MAPPED_ALIGNMENT
1140 | 0x00000474 | An attempt to change the system power state was vetoed by another application or driver. | ERROR_SET_POWER_STATE_VETOED
1141 | 0x00000475 | The system BIOS failed an attempt to change the system power state. | ERROR_SET_POWER_STATE_FAILED
1142 | 0x00000476 | An attempt was made to create more links on a file than the file system supports. | ERROR_TOO_MANY_LINKS
1150 | 0x0000047E | The specified program requires a newer version of Windows. | ERROR_OLD_WIN_VERSION
1151 | 0x0000047F | The specified program is not a Windows or MS-DOS program. | ERROR_APP_WRONG_OS
1152 | 0x00000480 | Cannot start more than one instance of the specified program. | ERROR_SINGLE_INSTANCE_APP
1153 | 0x00000481 | The specified program was written for an earlier version of Windows. | ERROR_RMODE_APP
1154 | 0x00000482 | One of the library files needed to run this application is damaged. | ERROR_INVALID_DLL
1155 | 0x00000483 | No application is associated with the specified file for this operation. | ERROR_NO_ASSOCIATION
1156 | 0x00000484 | An error occurred in sending the command to the application. | ERROR_DDE_FAIL
1157 | 0x00000485 | One of the library files needed to run this application cannot be found. | ERROR_DLL_NOT_FOUND
1158 | 0x00000486 | The current process has used all of its system allowance of handles for Window Manager objects. | ERROR_NO_MORE_USER_HANDLES
1159 | 0x00000487 | The message can be used only with synchronous operations. | ERROR_MESSAGE_SYNC_ONLY
1160 | 0x00000488 | The indicated source element has no media. | ERROR_SOURCE_ELEMENT_EMPTY
1161 | 0x00000489 | The indicated destination element already contains media. | ERROR_DESTINATION_ELEMENT_FULL
1162 | 0x0000048A | The indicated element does not exist. | ERROR_ILLEGAL_ELEMENT_ADDRESS
1163 | 0x0000048B | The indicated element is part of a magazine that is not present. | ERROR_MAGAZINE_NOT_PRESENT
1164 | 0x0000048C | The indicated device requires reinitialization due to hardware errors. | ERROR_DEVICE_REINITIALIZATION_NEEDED
1165 | 0x0000048D | The device has indicated that cleaning is required before further operations are attempted. | ERROR_DEVICE_REQUIRES_CLEANING
1166 | 0x0000048E | The device has indicated that its door is open. | ERROR_DEVICE_DOOR_OPEN
1167 | 0x0000048F | The device is not connected. | ERROR_DEVICE_NOT_CONNECTED
1168 | 0x00000490 | Element not found. | ERROR_NOT_FOUND
1169 | 0x00000491 | There was no match for the specified key in the index. | ERROR_NO_MATCH
1170 | 0x00000492 | The property set specified does not exist on the object. | ERROR_SET_NOT_FOUND
1171 | 0x00000493 | The point passed to GetMouseMovePointsEx is not in the buffer. | ERROR_POINT_NOT_FOUND
1172 | 0x00000494 | The tracking (workstation) service is not running. | ERROR_NO_TRACKING_SERVICE
1173 | 0x00000495 | The Volume ID could not be found. | ERROR_NO_VOLUME_ID
1175 | 0x00000497 | Unable to remove the file to be replaced. | ERROR_UNABLE_TO_REMOVE_REPLACED
1176 | 0x00000498 | Unable to move the replacement file to the file to be replaced. The file to be replaced has retained its original name. | ERROR_UNABLE_TO_MOVE_REPLACEMENT
1177 | 0x00000499 | Unable to move the replacement file to the file to be replaced. The file to be replaced has been renamed using the backup name. | ERROR_UNABLE_TO_MOVE_REPLACEMENT_2
1178 | 0x0000049A | The volume change journal is being deleted. | ERROR_JOURNAL_DELETE_IN_PROGRESS
1179 | 0x0000049B | The volume change journal is not active. | ERROR_JOURNAL_NOT_ACTIVE
1180 | 0x0000049C | A file was found, but it may not be the correct file. | ERROR_POTENTIAL_FILE_FOUND
1181 | 0x0000049D | The journal entry has been deleted from the journal. | ERROR_JOURNAL_ENTRY_DELETED
1200 | 0x000004B0 | The specified device name is invalid. | ERROR_BAD_DEVICE
1201 | 0x000004B1 | The device is not currently connected but it is a remembered connection. | ERROR_CONNECTION_UNAVAIL
1202 | 0x000004B2 | The local device name has a remembered connection to another network resource. | ERROR_DEVICE_ALREADY_REMEMBERED
1203 | 0x000004B3 | No network provider accepted the given network path. | ERROR_NO_NET_OR_BAD_PATH
1204 | 0x000004B4 | The specified network provider name is invalid. | ERROR_BAD_PROVIDER
1205 | 0x000004B5 | Unable to open the network connection profile. | ERROR_CANNOT_OPEN_PROFILE
1206 | 0x000004B6 | The network connection profile is corrupted. | ERROR_BAD_PROFILE
1207 | 0x000004B7 | Cannot enumerate a noncontainer. | ERROR_NOT_CONTAINER
1208 | 0x000004B8 | An extended error has occurred. | ERROR_EXTENDED_ERROR
1209 | 0x000004B9 | The format of the specified group name is invalid. | ERROR_INVALID_GROUPNAME
1210 | 0x000004BA | The format of the specified computer name is invalid. | ERROR_INVALID_COMPUTERNAME
1211 | 0x000004BB | The format of the specified event name is invalid. | ERROR_INVALID_EVENTNAME
1212 | 0x000004BC | The format of the specified domain name is invalid. | ERROR_INVALID_DOMAINNAME
1213 | 0x000004BD | The format of the specified service name is invalid. | ERROR_INVALID_SERVICENAME
1214 | 0x000004BE | The format of the specified network name is invalid. | ERROR_INVALID_NETNAME
1215 | 0x000004BF | The format of the specified share name is invalid. | ERROR_INVALID_SHARENAME
1216 | 0x000004C0 | The format of the specified password is invalid. | ERROR_INVALID_PASSWORDNAME
1217 | 0x000004C1 | The format of the specified message name is invalid. | ERROR_INVALID_MESSAGENAME
1218 | 0x000004C2 | The format of the specified message destination is invalid. | ERROR_INVALID_MESSAGEDEST
1219 | 0x000004C3 | The credentials supplied conflict with an existing set of credentials. | ERROR_SESSION_CREDENTIAL_CONFLICT
1220 | 0x000004C4 | An attempt was made to establish a session to a network server, but there are already too many sessions established to that server. | ERROR_REMOTE_SESSION_LIMIT_EXCEEDED
1221 | 0x000004C5 | The workgroup or domain name is already in use by another computer on the network. | ERROR_DUP_DOMAINNAME
1222 | 0x000004C6 | The network is not present or not started. | ERROR_NO_NETWORK
1223 | 0x000004C7 | The operation was canceled by the user. | ERROR_CANCELLED
1224 | 0x000004C8 | The requested operation cannot be performed on a file with a user-mapped section open. | ERROR_USER_MAPPED_FILE
1225 | 0x000004C9 | The remote system refused the network connection. | ERROR_CONNECTION_REFUSED
1226 | 0x000004CA | The network connection was gracefully closed. | ERROR_GRACEFUL_DISCONNECT
1227 | 0x000004CB | The network transport endpoint already has an address associated with it. | ERROR_ADDRESS_ALREADY_ASSOCIATED
1228 | 0x000004CC | An address has not yet been associated with the network endpoint. | ERROR_ADDRESS_NOT_ASSOCIATED
1229 | 0x000004CD | An operation was attempted on a nonexistent network connection. | ERROR_CONNECTION_INVALID
1230 | 0x000004CE | An invalid operation was attempted on an active network connection. | ERROR_CONNECTION_ACTIVE
1231 | 0x000004CF | The network location cannot be reached. For information about network troubleshooting, see Windows Help. | ERROR_NETWORK_UNREACHABLE
1232 | 0x000004D0 | The network location cannot be reached. For information about network troubleshooting, see Windows Help. | ERROR_HOST_UNREACHABLE
1233 | 0x000004D1 | The network location cannot be reached. For information about network troubleshooting, see Windows Help. | ERROR_PROTOCOL_UNREACHABLE
1234 | 0x000004D2 | No service is operating at the destination network endpoint on the remote system. | ERROR_PORT_UNREACHABLE
1235 | 0x000004D3 | The request was aborted. | ERROR_REQUEST_ABORTED
1236 | 0x000004D4 | The network connection was aborted by the local system. | ERROR_CONNECTION_ABORTED
1237 | 0x000004D5 | The operation could not be completed. A retry should be performed. | ERROR_RETRY
1238 | 0x000004D6 | A connection to the server could not be made because the limit on the number of concurrent connections for this account has been reached. | ERROR_CONNECTION_COUNT_LIMIT
1239 | 0x000004D7 | Attempting to log in during an unauthorized time of day for this account. | ERROR_LOGIN_TIME_RESTRICTION
1240 | 0x000004D8 | The account is not authorized to log in from this station. | ERROR_LOGIN_WKSTA_RESTRICTION
1241 | 0x000004D9 | The network address could not be used for the operation requested. | ERROR_INCORRECT_ADDRESS
1242 | 0x000004DA | The service is already registered. | ERROR_ALREADY_REGISTERED
1243 | 0x000004DB | The specified service does not exist. | ERROR_SERVICE_NOT_FOUND
1244 | 0x000004DC | The operation being requested was not performed because the user has not been authenticated. | ERROR_NOT_AUTHENTICATED
1245 | 0x000004DD | The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist. | ERROR_NOT_LOGGED_ON
1246 | 0x000004DE | Continue with work in progress. | ERROR_CONTINUE
1247 | 0x000004DF | An attempt was made to perform an initialization operation when initialization has already been completed. | ERROR_ALREADY_INITIALIZED
1248 | 0x000004E0 | No more local devices. | ERROR_NO_MORE_DEVICES
1249 | 0x000004E1 | The specified site does not exist. | ERROR_NO_SUCH_SITE
1250 | 0x000004E2 | A domain controller with the specified name already exists. | ERROR_DOMAIN_CONTROLLER_EXISTS
1251 | 0x000004E3 | This operation is supported only when you are connected to the server. | ERROR_ONLY_IF_CONNECTED
1252 | 0x000004E4 | The group policy framework should call the extension even if there are no changes. | ERROR_OVERRIDE_NOCHANGES
1253 | 0x000004E5 | The specified user does not have a valid profile. | ERROR_BAD_USER_PROFILE
1254 | 0x000004E6 | This operation is not supported on a Microsoft Small Business Server. | ERROR_NOT_SUPPORTED_ON_SBS
1255 | 0x000004E7 | The server machine is shutting down. | ERROR_SERVER_SHUTDOWN_IN_PROGRESS
1256 | 0x000004E8 | The remote system is not available. For information about network troubleshooting, see Windows Help. | ERROR_HOST_DOWN
1257 | 0x000004E9 | The security identifier provided is not from an account domain. | ERROR_NON_ACCOUNT_SID
1258 | 0x000004EA | The security identifier provided does not have a domain component. | ERROR_NON_DOMAIN_SID
1259 | 0x000004EB | AppHelp dialog canceled thus preventing the application from starting. | ERROR_APPHELP_BLOCK
1260 | 0x000004EC | Access to the requested resource has been disabled by your administrator. | ERROR_ACCESS_DISABLED_BY_POLICY
1261 | 0x000004ED | A program attempt to use an invalid register value. Normally caused by an uninitialized register. This error is Itanium specific. | ERROR_REG_NAT_CONSUMPTION
1262 | 0x000004EE | The share is currently offline or does not exist. | ERROR_CSCSHARE_OFFLINE
1300 | 0x00000514 | Not all privileges referenced are assigned to the caller. | ERROR_NOT_ALL_ASSIGNED
1301 | 0x00000515 | Some mapping between account names and security IDs was not done. | ERROR_SOME_NOT_MAPPED
1302 | 0x00000516 | No system quota limits are specifically set for this account. | ERROR_NO_QUOTAS_FOR_ACCOUNT
1303 | 0x00000517 | No encryption key is available. A well-known encryption key was returned. | ERROR_LOCAL_USER_SESSION_KEY
1304 | 0x00000518 | The password is too complex to be converted to a LAN Manager password. The LAN Manager password returned is a NULL string. | ERROR_NULL_LM_PASSWORD
1305 | 0x00000519 | The revision level is unknown. | ERROR_UNKNOWN_REVISION
1306 | 0x0000051A | Indicates two revision levels are incompatible. | ERROR_REVISION_MISMATCH
1307 | 0x0000051B | This security ID may not be assigned as the owner of this object. | ERROR_INVALID_OWNER
1308 | 0x0000051C | This security ID may not be assigned as the primary group of an object. | ERROR_INVALID_PRIMARY_GROUP
1309 | 0x0000051D | An attempt has been made to operate on an impersonation token by a thread that is not currently impersonating a client. | ERROR_NO_IMPERSONATION_TOKEN
1310 | 0x0000051E | The group may not be disabled. | ERROR_CANT_DISABLE_MANDATORY
1311 | 0x0000051F | There are currently no logon servers available to service the logon request. | ERROR_NO_LOGON_SERVERS
1312 | 0x00000520 | A specified logon session does not exist. It may already have been terminated. | ERROR_NO_SUCH_LOGON_SESSION
1313 | 0x00000521 | A specified privilege does not exist. | ERROR_NO_SUCH_PRIVILEGE
1314 | 0x00000522 | A required privilege is not held by the client. | ERROR_PRIVILEGE_NOT_HELD
1315 | 0x00000523 | The name provided is not a properly formed account name. | ERROR_INVALID_ACCOUNT_NAME
1316 | 0x00000524 | The specified user already exists. | ERROR_USER_EXISTS
1317 | 0x00000525 | The specified user does not exist. | ERROR_NO_SUCH_USER
1318 | 0x00000526 | The specified group already exists. | ERROR_GROUP_EXISTS
1319 | 0x00000527 | The specified group does not exist. | ERROR_NO_SUCH_GROUP
1320 | 0x00000528 | Either the specified user account is already a member of the specified group, or the specified group cannot be deleted because it contains a member. | ERROR_MEMBER_IN_GROUP
1321 | 0x00000529 | The specified user account is not a member of the specified group account. | ERROR_MEMBER_NOT_IN_GROUP
1322 | 0x0000052A | The last remaining administration account cannot be disabled or deleted. | ERROR_LAST_ADMIN
1323 | 0x0000052B | Unable to update the password. The value provided as the current password is incorrect. | ERROR_WRONG_PASSWORD
1324 | 0x0000052C | Unable to update the password. The value provided for the new password contains values that are not allowed in passwords. | ERROR_ILL_FORMED_PASSWORD
1325 | 0x0000052D | Unable to update the password. The value provided for the new password does not meet the length, complexity, or history requirement of the domain. | ERROR_PASSWORD_RESTRICTION
1326 | 0x0000052E | Logon failure: unknown user name or bad password. | ERROR_LOGON_FAILURE
1327 | 0x0000052F | Logon failure: user account restriction. | ERROR_ACCOUNT_RESTRICTION
1328 | 0x00000530 | Logon failure: account logon time restriction violation. | ERROR_INVALID_LOGON_HOURS
1329 | 0x00000531 | Logon failure: user not allowed to log on to this computer. | ERROR_INVALID_WORKSTATION
1330 | 0x00000532 | Logon failure: the specified account password has expired. | ERROR_PASSWORD_EXPIRED
1331 | 0x00000533 | Logon failure: account currently disabled. | ERROR_ACCOUNT_DISABLED
1332 | 0x00000534 | No mapping between account names and security IDs was done. | ERROR_NONE_MAPPED
1333 | 0x00000535 | Too many local user identifiers (LUIDs) were requested at one time. | ERROR_TOO_MANY_LUIDS_REQUESTED
1334 | 0x00000536 | No more local user identifiers (LUIDs) are available. | ERROR_LUIDS_EXHAUSTED
1335 | 0x00000537 | The subauthority part of a security ID is invalid for this particular use. | ERROR_INVALID_SUB_AUTHORITY
1336 | 0x00000538 | The access control list (ACL) structure is invalid. | ERROR_INVALID_ACL
1337 | 0x00000539 | The security ID structure is invalid. | ERROR_INVALID_SID
1338 | 0x0000053A | The security descriptor structure is invalid. | ERROR_INVALID_SECURITY_DESCR
1340 | 0x0000053C | The inherited access control list (ACL) or access control entry (ACE) could not be built. | ERROR_BAD_INHERITANCE_ACL
1341 | 0x0000053D | The server is currently disabled. | ERROR_SERVER_DISABLED
1342 | 0x0000053E | The server is currently enabled. | ERROR_SERVER_NOT_DISABLED
1343 | 0x0000053F | The value provided was an invalid value for an identifier authority. | ERROR_INVALID_ID_AUTHORITY
1344 | 0x00000540 | No more memory is available for security information updates. | ERROR_ALLOTTED_SPACE_EXCEEDED
1345 | 0x00000541 | The specified attributes are invalid, or incompatible with the attributes for the group as a whole. | ERROR_INVALID_GROUP_ATTRIBUTES
1346 | 0x00000542 | Either a required impersonation level was not provided, or the provided impersonation level is invalid. | ERROR_BAD_IMPERSONATION_LEVEL
1347 | 0x00000543 | Cannot open an anonymous level security token. | ERROR_CANT_OPEN_ANONYMOUS
1348 | 0x00000544 | The validation information class requested was invalid. | ERROR_BAD_VALIDATION_CLASS
1349 | 0x00000545 | The type of the token is inappropriate for its attempted use. | ERROR_BAD_TOKEN_TYPE
1350 | 0x00000546 | Unable to perform a security operation on an object that has no associated security. | ERROR_NO_SECURITY_ON_OBJECT
1351 | 0x00000547 | Configuration information could not be read from the domain controller, either because the machine is unavailable, or access has been denied. | ERROR_CANT_ACCESS_DOMAIN_INFO
1352 | 0x00000548 | The security account manager (SAM) or local security authority (LSA) server was in the wrong state to perform the security operation. | ERROR_INVALID_SERVER_STATE
1353 | 0x00000549 | The domain was in the wrong state to perform the security operation. | ERROR_INVALID_DOMAIN_STATE
1354 | 0x0000054A | This operation is only allowed for the Primary Domain Controller of the domain. | ERROR_INVALID_DOMAIN_ROLE
1355 | 0x0000054B | The specified domain either does not exist or could not be contacted. | ERROR_NO_SUCH_DOMAIN
1356 | 0x0000054C | The specified domain already exists. | ERROR_DOMAIN_EXISTS
1357 | 0x0000054D | An attempt was made to exceed the limit on the number of domains per server. | ERROR_DOMAIN_LIMIT_EXCEEDED
1358 | 0x0000054E | Unable to complete the requested operation because of either a catastrophic media failure or a data structure corruption on the disk. | ERROR_INTERNAL_DB_CORRUPTION
1359 | 0x0000054F | An internal error occurred. | ERROR_INTERNAL_ERROR
1360 | 0x00000550 | Generic access types were contained in an access mask which should already be mapped to nongeneric types. | ERROR_GENERIC_NOT_MAPPED
1361 | 0x00000551 | A security descriptor is not in the right format (absolute or self-relative). | ERROR_BAD_DESCRIPTOR_FORMAT
1362 | 0x00000552 | The requested action is restricted for use by logon processes only. The calling process has not registered as a logon process. | ERROR_NOT_LOGON_PROCESS
1363 | 0x00000553 | Cannot start a new logon session with an ID that is already in use. | ERROR_LOGON_SESSION_EXISTS
1364 | 0x00000554 | A specified authentication package is unknown. | ERROR_NO_SUCH_PACKAGE
1365 | 0x00000555 | The logon session is not in a state that is consistent with the requested operation. | ERROR_BAD_LOGON_SESSION_STATE
1366 | 0x00000556 | The logon session ID is already in use. | ERROR_LOGON_SESSION_COLLISION
1367 | 0x00000557 | A logon request contained an invalid logon type value. | ERROR_INVALID_LOGON_TYPE
1368 | 0x00000558 | Unable to impersonate using a named pipe until data has been read from that pipe. | ERROR_CANNOT_IMPERSONATE
1369 | 0x00000559 | The transaction state of a registry subtree is incompatible with the requested operation. | ERROR_RXACT_INVALID_STATE
1370 | 0x0000055A | An internal security database corruption has been encountered. | ERROR_RXACT_COMMIT_FAILURE
1371 | 0x0000055B | Cannot perform this operation on built-in accounts. | ERROR_SPECIAL_ACCOUNT
1372 | 0x0000055C | Cannot perform this operation on this built-in special group. | ERROR_SPECIAL_GROUP
1373 | 0x0000055D | Cannot perform this operation on this built-in special user. | ERROR_SPECIAL_USER
1374 | 0x0000055E | The user cannot be removed from a group because the group is currently the user's primary group. | ERROR_MEMBERS_PRIMARY_GROUP
1375 | 0x0000055F | The token is already in use as a primary token. | ERROR_TOKEN_ALREADY_IN_USE
1376 | 0x00000560 | The specified local group does not exist. | ERROR_NO_SUCH_ALIAS
1377 | 0x00000561 | The specified account name is not a member of the local group. | ERROR_MEMBER_NOT_IN_ALIAS
1378 | 0x00000562 | The specified account name is already a member of the local group. | ERROR_MEMBER_IN_ALIAS
1379 | 0x00000563 | The specified local group already exists. | ERROR_ALIAS_EXISTS
1380 | 0x00000564 | Logon failure: the user has not been granted the requested logon type at this computer. | ERROR_LOGON_NOT_GRANTED
1381 | 0x00000565 | The maximum number of secrets that may be stored in a single system has been exceeded. | ERROR_TOO_MANY_SECRETS
1382 | 0x00000566 | The length of a secret exceeds the maximum length allowed. | ERROR_SECRET_TOO_LONG
1383 | 0x00000567 | The local security authority database contains an internal inconsistency. | ERROR_INTERNAL_DB_ERROR
1384 | 0x00000568 | During a logon attempt, the user's security context accumulated too many security IDs. | ERROR_TOO_MANY_CONTEXT_IDS
1385 | 0x00000569 | Logon failure: the user has not been granted the requested logon type at this computer. | ERROR_LOGON_TYPE_NOT_GRANTED
1386 | 0x0000056A | A cross-encrypted password is necessary to change a user password. | ERROR_NT_CROSS_ENCRYPTION_REQUIRED
1387 | 0x0000056B | A new member could not be added to or removed from the local group because the member does not exist. | ERROR_NO_SUCH_MEMBER
1388 | 0x0000056C | A new member could not be added to a local group because the member has the wrong account type. | ERROR_INVALID_MEMBER
1389 | 0x0000056D | Too many security IDs have been specified. | ERROR_TOO_MANY_SIDS
1390 | 0x0000056E | A cross-encrypted password is necessary to change this user password. | ERROR_LM_CROSS_ENCRYPTION_REQUIRED
1391 | 0x0000056F | Indicates an ACL contains no inheritable components. | ERROR_NO_INHERITANCE
1392 | 0x00000570 | The file or directory is corrupted and unreadable. | ERROR_FILE_CORRUPT
1393 | 0x00000571 | The disk structure is corrupted and unreadable. | ERROR_DISK_CORRUPT
1394 | 0x00000572 | There is no user session key for the specified logon session. | ERROR_NO_USER_SESSION_KEY
1395 | 0x00000573 | The service being accessed is licensed for a particular number of connections. No more connections can be made to the service at this time because there are already as many connections as the service can accept. | ERROR_LICENSE_QUOTA_EXCEEDED
1396 | 0x00000574 | Logon Failure: The target account name is incorrect. | ERROR_WRONG_TARGET_NAME
1397 | 0x00000575 | Mutual Authentication failed. The server's password is out of date at the domain controller. | ERROR_MUTUAL_AUTH_FAILED
1398 | 0x00000576 | There is a time difference between the client and server. | ERROR_TIME_SKEW
1399 | 0x00000577 | This operation can not be performed on the current domain. | ERROR_CURRENT_DOMAIN_NOT_ALLOWED
1400 | 0x00000578 | Invalid window handle. | ERROR_INVALID_WINDOW_HANDLE
1401 | 0x00000579 | Invalid menu handle. | ERROR_INVALID_MENU_HANDLE
1402 | 0x0000057A | Invalid cursor handle. | ERROR_INVALID_CURSOR_HANDLE
1403 | 0x0000057B | Invalid accelerator table handle. | ERROR_INVALID_ACCEL_HANDLE
1404 | 0x0000057C | Invalid hook handle. | ERROR_INVALID_HOOK_HANDLE
1405 | 0x0000057D | Invalid handle to a multiple-window position structure. | ERROR_INVALID_DWP_HANDLE
1406 | 0x0000057E | Cannot create a top-level child window. | ERROR_TLW_WITH_WSCHILD
1407 | 0x0000057F | Cannot find window class. | ERROR_CANNOT_FIND_WND_CLASS
1408 | 0x00000580 | Invalid window; it belongs to other thread. | ERROR_WINDOW_OF_OTHER_THREAD
1409 | 0x00000581 | Hot key is already registered. | ERROR_HOTKEY_ALREADY_REGISTERED
1410 | 0x00000582 | Class already exists. | ERROR_CLASS_ALREADY_EXISTS
1411 | 0x00000583 | Class does not exist. | ERROR_CLASS_DOES_NOT_EXIST
1412 | 0x00000584 | Class still has open windows. | ERROR_CLASS_HAS_WINDOWS
1413 | 0x00000585 | Invalid index. | ERROR_INVALID_INDEX
1414 | 0x00000586 | Invalid icon handle. | ERROR_INVALID_ICON_HANDLE
1415 | 0x00000587 | Using private DIALOG window words. | ERROR_PRIVATE_DIALOG_INDEX
1416 | 0x00000588 | The list box identifier was not found. | ERROR_LISTBOX_ID_NOT_FOUND
1417 | 0x00000589 | No wildcards were found. | ERROR_NO_WILDCARD_CHARACTERS
1418 | 0x0000058A | Thread does not have a clipboard open. | ERROR_CLIPBOARD_NOT_OPEN
1419 | 0x0000058B | Hot key is not registered. | ERROR_HOTKEY_NOT_REGISTERED
1420 | 0x0000058C | The window is not a valid dialog window. | ERROR_WINDOW_NOT_DIALOG
1421 | 0x0000058D | Control ID not found. | ERROR_CONTROL_ID_NOT_FOUND
1422 | 0x0000058E | Invalid message for a combo box because it does not have an edit control. | ERROR_INVALID_COMBOBOX_MESSAGE
1423 | 0x0000058F | The window is not a combo box. | ERROR_WINDOW_NOT_COMBOBOX
1424 | 0x00000590 | Height must be less than 256. | ERROR_INVALID_EDIT_HEIGHT
1425 | 0x00000591 | Invalid device context (DC) handle. | ERROR_DC_NOT_FOUND
1426 | 0x00000592 | Invalid hook procedure type. | ERROR_INVALID_HOOK_FILTER
1427 | 0x00000593 | Invalid hook procedure. | ERROR_INVALID_FILTER_PROC
1428 | 0x00000594 | Cannot set nonlocal hook without a module handle. | ERROR_HOOK_NEEDS_HMOD
1429 | 0x00000595 | This hook procedure can only be set globally. | ERROR_GLOBAL_ONLY_HOOK
1430 | 0x00000596 | The journal hook procedure is already installed. | ERROR_JOURNAL_HOOK_SET
1431 | 0x00000597 | The hook procedure is not installed. | ERROR_HOOK_NOT_INSTALLED
1432 | 0x00000598 | Invalid message for single-selection list box. | ERROR_INVALID_LB_MESSAGE
1433 | 0x00000599 | LB_SETCOUNT sent to non-lazy list box. | ERROR_SETCOUNT_ON_BAD_LB
1434 | 0x0000059A | This list box does not support tab stops. | ERROR_LB_WITHOUT_TABSTOPS
1435 | 0x0000059B | Cannot destroy object created by another thread. | ERROR_DESTROY_OBJECT_OF_OTHER_THREAD
1436 | 0x0000059C | Child windows cannot have menus. | ERROR_CHILD_WINDOW_MENU
1437 | 0x0000059D | The window does not have a system menu. | ERROR_NO_SYSTEM_MENU
1438 | 0x0000059E | Invalid message box style. | ERROR_INVALID_MSGBOX_STYLE
1439 | 0x0000059F | Invalid system-wide (SPI_*) parameter. | ERROR_INVALID_SPI_VALUE
1440 | 0x000005A0 | Screen already locked. | ERROR_SCREEN_ALREADY_LOCKED
1441 | 0x000005A1 | All handles to windows in a multiple-window position structure must have the same parent. | ERROR_HWNDS_HAVE_DIFF_PARENT
1442 | 0x000005A2 | The window is not a child window. | ERROR_NOT_CHILD_WINDOW
1443 | 0x000005A3 | Invalid GW_* command. | ERROR_INVALID_GW_COMMAND
1444 | 0x000005A4 | Invalid thread identifier. | ERROR_INVALID_THREAD_ID
1445 | 0x000005A5 | Cannot process a message from a window that is not a multiple document interface (MDI) window. | ERROR_NON_MDICHILD_WINDOW
1446 | 0x000005A6 | Popup menu already active. | ERROR_POPUP_ALREADY_ACTIVE
1447 | 0x000005A7 | The window does not have scroll bars. | ERROR_NO_SCROLLBARS
1448 | 0x000005A8 | Scroll bar range cannot be greater than MAXLONG. | ERROR_INVALID_SCROLLBAR_RANGE
1449 | 0x000005A9 | Cannot show or remove the window in the way specified. | ERROR_INVALID_SHOWWIN_COMMAND
1450 | 0x000005AA | Insufficient system resources exist to complete the requested service. | ERROR_NO_SYSTEM_RESOURCES
1451 | 0x000005AB | Insufficient system resources exist to complete the requested service. | ERROR_NONPAGED_SYSTEM_RESOURCES
1452 | 0x000005AC | Insufficient system resources exist to complete the requested service. | ERROR_PAGED_SYSTEM_RESOURCES
1453 | 0x000005AD | Insufficient quota to complete the requested service. | ERROR_WORKING_SET_QUOTA
1454 | 0x000005AE | Insufficient quota to complete the requested service. | ERROR_PAGEFILE_QUOTA
1455 | 0x000005AF | The paging file is too small for this operation to complete. | ERROR_COMMITMENT_LIMIT
1456 | 0x000005B0 | A menu item was not found. | ERROR_MENU_ITEM_NOT_FOUND
1457 | 0x000005B1 | Invalid keyboard layout handle. | ERROR_INVALID_KEYBOARD_HANDLE
1458 | 0x000005B2 | Hook type not allowed. | ERROR_HOOK_TYPE_NOT_ALLOWED
1459 | 0x000005B3 | This operation requires an interactive window station. | ERROR_REQUIRES_INTERACTIVE_WINDOWSTATION
1460 | 0x000005B4 | This operation returned because the timeout period expired. | ERROR_TIMEOUT
1461 | 0x000005B5 | Invalid monitor handle. | ERROR_INVALID_MONITOR_HANDLE
1500 | 0x000005DC | The event log file is corrupted. | ERROR_EVENTLOG_FILE_CORRUPT
1501 | 0x000005DD | No event log file could be opened, so the event logging service did not start. | ERROR_EVENTLOG_CANT_START
1502 | 0x000005DE | The event log file is full. | ERROR_LOG_FILE_FULL
1503 | 0x000005DF | The event log file has changed between read operations. | ERROR_EVENTLOG_FILE_CHANGED
1601 | 0x00000641 | The Windows Installer service could not be accessed. Contact your support personnel to verify that the Windows Installer service is properly registered. | ERROR_INSTALL_SERVICE_FAILURE
1602 | 0x00000642 | User cancelled installation. | ERROR_INSTALL_USEREXIT
1603 | 0x00000643 | Fatal error during installation. | ERROR_INSTALL_FAILURE
1604 | 0x00000644 | Installation suspended, incomplete. | ERROR_INSTALL_SUSPEND
1605 | 0x00000645 | This action is only valid for products that are currently installed. | ERROR_UNKNOWN_PRODUCT
1606 | 0x00000646 | Feature ID not registered. | ERROR_UNKNOWN_FEATURE
1607 | 0x00000647 | Component ID not registered. | ERROR_UNKNOWN_COMPONENT
1608 | 0x00000648 | Unknown property. | ERROR_UNKNOWN_PROPERTY
1609 | 0x00000649 | Handle is in an invalid state. | ERROR_INVALID_HANDLE_STATE
1610 | 0x0000064A | The configuration data for this product is corrupt. Contact your support personnel. | ERROR_BAD_CONFIGURATION
1611 | 0x0000064B | Component qualifier not present. | ERROR_INDEX_ABSENT
1612 | 0x0000064C | The installation source for this product is not available. Verify that the source exists and that you can access it. | ERROR_INSTALL_SOURCE_ABSENT
1613 | 0x0000064D | This installation package cannot be installed by the Windows Installer service. You must install a Windows service pack that contains a newer version of the Windows Installer service. | ERROR_INSTALL_PACKAGE_VERSION
1614 | 0x0000064E | Product is uninstalled. | ERROR_PRODUCT_UNINSTALLED
1615 | 0x0000064F | SQL query syntax invalid or unsupported. | ERROR_BAD_QUERY_SYNTAX
1616 | 0x00000650 | Record field does not exist. | ERROR_INVALID_FIELD
1617 | 0x00000651 | The device has been removed. | ERROR_DEVICE_REMOVED
1618 | 0x00000652 | Another installation is already in progress. Complete that installation before proceeding with this install. | ERROR_INSTALL_ALREADY_RUNNING
1619 | 0x00000653 | This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package. | ERROR_INSTALL_PACKAGE_OPEN_FAILED
1620 | 0x00000654 | This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package. | ERROR_INSTALL_PACKAGE_INVALID
1621 | 0x00000655 | There was an error starting the Windows Installer service user interface. Contact your support personnel. | ERROR_INSTALL_UI_FAILURE
1622 | 0x00000656 | Error opening installation log file. Verify that the specified log file location exists and that you can write to it. | ERROR_INSTALL_LOG_FAILURE
1623 | 0x00000657 | The language of this installation package is not supported by your system. | ERROR_INSTALL_LANGUAGE_UNSUPPORTED
1624 | 0x00000658 | Error applying transforms. Verify that the specified transform paths are valid. | ERROR_INSTALL_TRANSFORM_FAILURE
1625 | 0x00000659 | This installation is forbidden by system policy. Contact your system administrator. | ERROR_INSTALL_PACKAGE_REJECTED
1626 | 0x0000065A | Function could not be executed. | ERROR_FUNCTION_NOT_CALLED
1627 | 0x0000065B | Function failed during execution. | ERROR_FUNCTION_FAILED
1628 | 0x0000065C | Invalid or unknown table specified. | ERROR_INVALID_TABLE
1629 | 0x0000065D | Data supplied is of wrong type. | ERROR_DATATYPE_MISMATCH
1630 | 0x0000065E | Data of this type is not supported. | ERROR_UNSUPPORTED_TYPE
1631 | 0x0000065F | The Windows Installer service failed to start. Contact your support personnel. | ERROR_CREATE_FAILED
1632 | 0x00000660 | The temp folder is either full or inaccessible. Verify that the temp folder exists and that you can write to it. | ERROR_INSTALL_TEMP_UNWRITABLE
1633 | 0x00000661 | This installation package is not supported by this processor type. Contact your product vendor. | ERROR_INSTALL_PLATFORM_UNSUPPORTED
1634 | 0x00000662 | Component not used on this computer. | ERROR_INSTALL_NOTUSED
1635 | 0x00000663 | This patch package could not be opened. Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package. | ERROR_PATCH_PACKAGE_OPEN_FAILED
1636 | 0x00000664 | This patch package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer patch package. | ERROR_PATCH_PACKAGE_INVALID
1637 | 0x00000665 | This patch package cannot be processed by the Windows Installer service. You must install a Windows service pack that contains a newer version of the Windows Installer service. | ERROR_PATCH_PACKAGE_UNSUPPORTED.
1638 | 0x00000666 | Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel. | ERROR_PRODUCT_VERSION
1639 | 0x00000667 | Invalid command line argument. Consult the Windows Installer SDK for detailed command line help. | ERROR_INVALID_COMMAND_LINE
1640 | 0x00000668 | Only administrators have permission to add, remove, or configure server software during a Terminal Services remote session. If you want to install or configure software on the server, contact your network administrator. | ERROR_INSTALL_REMOTE_DISALLOWED
1641 | 0x00000669 | The requested operation completed successfully. The system will be restarted so the changes can take effect. | ERROR_SUCCESS_REBOOT_INITIATED
1642 | 0x0000066A | The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch. | ERROR_PATCH_TARGET_NOT_FOUND
1643 | 0x0000066B | The patch package is not permitted by system policy. It is not signed with an appropriate certificate. | ERROR_PATCH_PACKAGE_REJECTED
1644 | 0x0000066C | One or more customizations are not permitted by system policy. They are not signed with an appropriate certificate. | ERROR_INSTALL_TRANSFORM_REJECTED
1700 | 0x000006A4 | The string binding is invalid. | RPC_S_INVALID_STRING_BINDING
1701 | 0x000006A5 | The binding handle is not the correct type. | RPC_S_WRONG_KIND_OF_BINDING
1702 | 0x000006A6 | The binding handle is invalid. | RPC_S_INVALID_BINDING
1703 | 0x000006A7 | The RPC protocol sequence is not supported. | RPC_S_PROTSEQ_NOT_SUPPORTED
1704 | 0x000006A8 | The RPC protocol sequence is invalid. | RPC_S_INVALID_RPC_PROTSEQ
1705 | 0x000006A9 | The string universal unique identifier (UUID) is invalid. | RPC_S_INVALID_STRING_UUID
1706 | 0x000006AA | The endpoint format is invalid. | RPC_S_INVALID_ENDPOINT_FORMAT
1707 | 0x000006AB | The network address is invalid. | RPC_S_INVALID_NET_ADDR
1708 | 0x000006AC | No endpoint was found. | RPC_S_NO_ENDPOINT_FOUND
1709 | 0x000006AD | The timeout value is invalid. | RPC_S_INVALID_TIMEOUT
1710 | 0x000006AE | The object universal unique identifier (UUID) was not found. | RPC_S_OBJECT_NOT_FOUND
1711 | 0x000006AF | The object universal unique identifier (UUID) has already been registered. | RPC_S_ALREADY_REGISTERED
1712 | 0x000006B0 | The type universal unique identifier (UUID) has already been registered. | RPC_S_TYPE_ALREADY_REGISTERED
1713 | 0x000006B1 | The RPC server is already listening. | RPC_S_ALREADY_LISTENING
1714 | 0x000006B2 | No protocol sequences have been registered. | RPC_S_NO_PROTSEQS_REGISTERED
1715 | 0x000006B3 | The RPC server is not listening. | RPC_S_NOT_LISTENING
1716 | 0x000006B4 | The manager type is unknown. | RPC_S_UNKNOWN_MGR_TYPE
1717 | 0x000006B5 | The interface is unknown. | RPC_S_UNKNOWN_IF
1718 | 0x000006B6 | There are no bindings. | RPC_S_NO_BINDINGS
1719 | 0x000006B7 | There are no protocol sequences. | RPC_S_NO_PROTSEQS
1720 | 0x000006B8 | The endpoint cannot be created. | RPC_S_CANT_CREATE_ENDPOINT
1721 | 0x000006B9 | Not enough resources are available to complete this operation. | RPC_S_OUT_OF_RESOURCES
1722 | 0x000006BA | The RPC server is unavailable. | RPC_S_SERVER_UNAVAILABLE
1723 | 0x000006BB | The RPC server is too busy to complete this operation. | RPC_S_SERVER_TOO_BUSY
1724 | 0x000006BC | The network options are invalid. | RPC_S_INVALID_NETWORK_OPTIONS
1725 | 0x000006BD | There are no remote procedure calls active on this thread. | RPC_S_NO_CALL_ACTIVE
1726 | 0x000006BE | The remote procedure call failed. | RPC_S_CALL_FAILED
1727 | 0x000006BF | The remote procedure call failed and did not execute. | RPC_S_CALL_FAILED_DNE
1728 | 0x000006C0 | A remote procedure call (RPC) protocol error occurred. | RPC_S_PROTOCOL_ERROR
1730 | 0x000006C2 | The transfer syntax is not supported by the RPC server. | RPC_S_UNSUPPORTED_TRANS_SYN
1732 | 0x000006C4 | The universal unique identifier (UUID) type is not supported. | RPC_S_UNSUPPORTED_TYPE
1733 | 0x000006C5 | The tag is invalid. | RPC_S_INVALID_TAG
1734 | 0x000006C6 | The array bounds are invalid. | RPC_S_INVALID_BOUND
1735 | 0x000006C7 | The binding does not contain an entry name. | RPC_S_NO_ENTRY_NAME
1736 | 0x000006C8 | The name syntax is invalid. | RPC_S_INVALID_NAME_SYNTAX
1737 | 0x000006C9 | The name syntax is not supported. | RPC_S_UNSUPPORTED_NAME_SYNTAX
1739 | 0x000006CB | No network address is available to use to construct a universal unique identifier (UUID). | RPC_S_UUID_NO_ADDRESS
1740 | 0x000006CC | The endpoint is a duplicate. | RPC_S_DUPLICATE_ENDPOINT
1741 | 0x000006CD | The authentication type is unknown. | RPC_S_UNKNOWN_AUTHN_TYPE
1742 | 0x000006CE | The maximum number of calls is too small. | RPC_S_MAX_CALLS_TOO_SMALL
1743 | 0x000006CF | The string is too long. | RPC_S_STRING_TOO_LONG
1744 | 0x000006D0 | The RPC protocol sequence was not found. | RPC_S_PROTSEQ_NOT_FOUND
1745 | 0x000006D1 | The procedure number is out of range. | RPC_S_PROCNUM_OUT_OF_RANGE
1746 | 0x000006D2 | The binding does not contain any authentication information. | RPC_S_BINDING_HAS_NO_AUTH
1747 | 0x000006D3 | The authentication service is unknown. | RPC_S_UNKNOWN_AUTHN_SERVICE
1748 | 0x000006D4 | The authentication level is unknown. | RPC_S_UNKNOWN_AUTHN_LEVEL
1749 | 0x000006D5 | The security context is invalid. | RPC_S_INVALID_AUTH_IDENTITY
1750 | 0x000006D6 | The authorization service is unknown. | RPC_S_UNKNOWN_AUTHZ_SERVICE
1751 | 0x000006D7 | The entry is invalid. | EPT_S_INVALID_ENTRY
1752 | 0x000006D8 | The server endpoint cannot perform the operation. | EPT_S_CANT_PERFORM_OP
1753 | 0x000006D9 | There are no more endpoints available from the endpoint mapper. | EPT_S_NOT_REGISTERED
1754 | 0x000006DA | No interfaces have been exported. | RPC_S_NOTHING_TO_EXPORT
1755 | 0x000006DB | The entry name is incomplete. | RPC_S_INCOMPLETE_NAME
1756 | 0x000006DC | The version option is invalid. | RPC_S_INVALID_VERS_OPTION
1757 | 0x000006DD | There are no more members. | RPC_S_NO_MORE_MEMBERS
1758 | 0x000006DE | There is nothing to unexport. | RPC_S_NOT_ALL_OBJS_UNEXPORTED
1759 | 0x000006DF | The interface was not found. | RPC_S_INTERFACE_NOT_FOUND
1760 | 0x000006E0 | The entry already exists. | RPC_S_ENTRY_ALREADY_EXISTS
1761 | 0x000006E1 | The entry is not found. | RPC_S_ENTRY_NOT_FOUND
1762 | 0x000006E2 | The name service is unavailable. | RPC_S_NAME_SERVICE_UNAVAILABLE
1763 | 0x000006E3 | The network address family is invalid. | RPC_S_INVALID_NAF_ID
1764 | 0x000006E4 | The requested operation is not supported. | RPC_S_CANNOT_SUPPORT
1765 | 0x000006E5 | No security context is available to allow impersonation. | RPC_S_NO_CONTEXT_AVAILABLE
1766 | 0x000006E6 | An internal error occurred in a remote procedure call (RPC). | RPC_S_INTERNAL_ERROR
1767 | 0x000006E7 | The RPC server attempted an integer division by zero. | RPC_S_ZERO_DIVIDE
1768 | 0x000006E8 | An addressing error occurred in the RPC server. | RPC_S_ADDRESS_ERROR
1769 | 0x000006E9 | A floating-point operation at the RPC server caused a division by zero. | RPC_S_FP_DIV_ZERO
1770 | 0x000006EA | A floating-point underflow occurred at the RPC server. | RPC_S_FP_UNDERFLOW
1771 | 0x000006EB | A floating-point overflow occurred at the RPC server. | RPC_S_FP_OVERFLOW
1772 | 0x000006EC | The list of RPC servers available for the binding of auto handles has been exhausted. | RPC_X_NO_MORE_ENTRIES
1773 | 0x000006ED | Unable to open the character translation table file. | RPC_X_SS_CHAR_TRANS_OPEN_FAIL
1774 | 0x000006EE | The file containing the character translation table has fewer than 512 bytes. | RPC_X_SS_CHAR_TRANS_SHORT_FILE
1775 | 0x000006EF | A null context handle was passed from the client to the host during a remote procedure call. | RPC_X_SS_IN_NULL_CONTEXT
1777 | 0x000006F1 | The context handle changed during a remote procedure call. | RPC_X_SS_CONTEXT_DAMAGED
1778 | 0x000006F2 | The binding handles passed to a remote procedure call do not match. | RPC_X_SS_HANDLES_MISMATCH
1779 | 0x000006F3 | The stub is unable to get the remote procedure call handle. | RPC_X_SS_CANNOT_GET_CALL_HANDLE
1780 | 0x000006F4 | A null reference pointer was passed to the stub. | RPC_X_NULL_REF_POINTER
1781 | 0x000006F5 | The enumeration value is out of range. | RPC_X_ENUM_VALUE_OUT_OF_RANGE
1782 | 0x000006F6 | The byte count is too small. | RPC_X_BYTE_COUNT_TOO_SMALL
1783 | 0x000006F7 | The stub received bad data. | RPC_X_BAD_STUB_DATA
1784 | 0x000006F8 | The supplied user buffer is not valid for the requested operation. | ERROR_INVALID_USER_BUFFER
1785 | 0x000006F9 | The disk media is not recognized. It may not be formatted. | ERROR_UNRECOGNIZED_MEDIA
1786 | 0x000006FA | The workstation does not have a trust secret. | ERROR_NO_TRUST_LSA_SECRET
1787 | 0x000006FB | The security database on the server does not have a computer account for this workstation trust relationship. | ERROR_NO_TRUST_SAM_ACCOUNT
1788 | 0x000006FC | The trust relationship between the primary domain and the trusted domain failed. | ERROR_TRUSTED_DOMAIN_FAILURE
1789 | 0x000006FD | The trust relationship between this workstation and the primary domain failed. | ERROR_TRUSTED_RELATIONSHIP_FAILURE
1790 | 0x000006FE | The network logon failed. | ERROR_TRUST_FAILURE
1791 | 0x000006FF | A remote procedure call is already in progress for this thread. | RPC_S_CALL_IN_PROGRESS
1792 | 0x00000700 | An attempt was made to logon, but the network logon service was not started. | ERROR_NETLOGON_NOT_STARTED
1793 | 0x00000701 | The user's account has expired. | ERROR_ACCOUNT_EXPIRED
1794 | 0x00000702 | The redirector is in use and cannot be unloaded. | ERROR_REDIRECTOR_HAS_OPEN_HANDLES
1795 | 0x00000703 | The specified printer driver is already installed. | ERROR_PRINTER_DRIVER_ALREADY_INSTALLED
1796 | 0x00000704 | The specified port is unknown. | ERROR_UNKNOWN_PORT
1797 | 0x00000705 | The printer driver is unknown. | ERROR_UNKNOWN_PRINTER_DRIVER
1798 | 0x00000706 | The print processor is unknown. | ERROR_UNKNOWN_PRINTPROCESSOR
1799 | 0x00000707 | The specified separator file is invalid. | ERROR_INVALID_SEPARATOR_FILE
1800 | 0x00000708 | The specified priority is invalid. | ERROR_INVALID_PRIORITY
1801 | 0x00000709 | The printer name is invalid. | ERROR_INVALID_PRINTER_NAME
1802 | 0x0000070A | The printer already exists. | ERROR_PRINTER_ALREADY_EXISTS
1803 | 0x0000070B | The printer command is invalid. | ERROR_INVALID_PRINTER_COMMAND
1804 | 0x0000070C | The specified datatype is invalid. | ERROR_INVALID_DATATYPE
1805 | 0x0000070D | The environment specified is invalid. | ERROR_INVALID_ENVIRONMENT
1806 | 0x0000070E | There are no more bindings. | RPC_S_NO_MORE_BINDINGS
1807 | 0x0000070F | The account used is an interdomain trust account. Use your global user account or local user account to access this server. | ERROR_NOLOGON_INTERDOMAIN_TRUST_ACCOUNT
1808 | 0x00000710 | The account used is a computer account. Use your global user account or local user account to access this server. | ERROR_NOLOGON_WORKSTATION_TRUST_ACCOUNT
1809 | 0x00000711 | The account used is a server trust account. Use your global user account or local user account to access this server. | ERROR_NOLOGON_SERVER_TRUST_ACCOUNT
1810 | 0x00000712 | The name or security ID (SID) of the domain specified is inconsistent with the trust information for that domain. | ERROR_DOMAIN_TRUST_INCONSISTENT
1811 | 0x00000713 | The server is in use and cannot be unloaded. | ERROR_SERVER_HAS_OPEN_HANDLES
1812 | 0x00000714 | The specified image file did not contain a resource section. | ERROR_RESOURCE_DATA_NOT_FOUND
1813 | 0x00000715 | The specified resource type cannot be found in the image file. | ERROR_RESOURCE_TYPE_NOT_FOUND
1814 | 0x00000716 | The specified resource name cannot be found in the image file. | ERROR_RESOURCE_NAME_NOT_FOUND
1815 | 0x00000717 | The specified resource language ID cannot be found in the image file. | ERROR_RESOURCE_LANG_NOT_FOUND
1816 | 0x00000718 | Not enough quota is available to process this command. | ERROR_NOT_ENOUGH_QUOTA
1817 | 0x00000719 | No interfaces have been registered. | RPC_S_NO_INTERFACES
1818 | 0x0000071A | The remote procedure call was cancelled. | RPC_S_CALL_CANCELLED
1819 | 0x0000071B | The binding handle does not contain all required information. | RPC_S_BINDING_INCOMPLETE
1820 | 0x0000071C | A communications failure occurred during a remote procedure call. | RPC_S_COMM_FAILURE
1821 | 0x0000071D | The requested authentication level is not supported. | RPC_S_UNSUPPORTED_AUTHN_LEVEL
1822 | 0x0000071E | No principal name registered. | RPC_S_NO_PRINC_NAME
1823 | 0x0000071F | The error specified is not a valid Windows RPC error code. | RPC_S_NOT_RPC_ERROR
1824 | 0x00000720 | A UUID that is valid only on this computer has been allocated. | RPC_S_UUID_LOCAL_ONLY
1825 | 0x00000721 | A security package specific error occurred. | RPC_S_SEC_PKG_ERROR
1826 | 0x00000722 | Thread is not canceled. | RPC_S_NOT_CANCELLED
1827 | 0x00000723 | Invalid operation on the encoding/decoding handle. | RPC_X_INVALID_ES_ACTION
1828 | 0x00000724 | Incompatible version of the serializing package. | RPC_X_WRONG_ES_VERSION
1829 | 0x00000725 | Incompatible version of the RPC stub. | RPC_X_WRONG_STUB_VERSION
1830 | 0x00000726 | The RPC pipe object is invalid or corrupted. | RPC_X_INVALID_PIPE_OBJECT
1831 | 0x00000727 | An invalid operation was attempted on an RPC pipe object. | RPC_X_WRONG_PIPE_ORDER
1832 | 0x00000728 | Unsupported RPC pipe version. | RPC_X_WRONG_PIPE_VERSION
1898 | 0x0000076A | The group member was not found. | RPC_S_GROUP_MEMBER_NOT_FOUND
1899 | 0x0000076B | The endpoint mapper database entry could not be created. | EPT_S_CANT_CREATE
1900 | 0x0000076C | The object universal unique identifier (UUID) is the nil UUID. | RPC_S_INVALID_OBJECT
1901 | 0x0000076D | The specified time is invalid. | ERROR_INVALID_TIME
1902 | 0x0000076E | The specified form name is invalid. | ERROR_INVALID_FORM_NAME
1903 | 0x0000076F | The specified form size is invalid. | ERROR_INVALID_FORM_SIZE
1904 | 0x00000770 | The specified printer handle is already being waited on | ERROR_ALREADY_WAITING
1905 | 0x00000771 | The specified printer has been deleted. | ERROR_PRINTER_DELETED
1906 | 0x00000772 | The state of the printer is invalid. | ERROR_INVALID_PRINTER_STATE
1907 | 0x00000773 | The user's password must be changed before logging on the first time. | ERROR_PASSWORD_MUST_CHANGE
1908 | 0x00000774 | Could not find the domain controller for this domain. | ERROR_DOMAIN_CONTROLLER_NOT_FOUND
1909 | 0x00000775 | The referenced account is currently locked out and may not be logged on to. | ERROR_ACCOUNT_LOCKED_OUT
1910 | 0x00000776 | The object exporter specified was not found. | OR_INVALID_OXID
1911 | 0x00000777 | The object specified was not found. | OR_INVALID_OID
1912 | 0x00000778 | The object resolver set specified was not found. | OR_INVALID_SET
1913 | 0x00000779 | Some data remains to be sent in the request buffer. | RPC_S_SEND_INCOMPLETE
1914 | 0x0000077A | Invalid asynchronous remote procedure call handle. | RPC_S_INVALID_ASYNC_HANDLE
1915 | 0x0000077B | Invalid asynchronous RPC call handle for this operation. | RPC_S_INVALID_ASYNC_CALL
1916 | 0x0000077C | The RPC pipe object has already been closed. | RPC_X_PIPE_CLOSED
1917 | 0x0000077D | The RPC call completed before all pipes were processed. | RPC_X_PIPE_DISCIPLINE_ERROR
1918 | 0x0000077E | No more data is available from the RPC pipe. | RPC_X_PIPE_EMPTY
1919 | 0x0000077F | No site name is available for this machine. | ERROR_NO_SITENAME
1920 | 0x00000780 | The file can not be accessed by the system. | ERROR_CANT_ACCESS_FILE
1921 | 0x00000781 | The name of the file cannot be resolved by the system. | ERROR_CANT_RESOLVE_FILENAME
1922 | 0x00000782 | The entry is not of the expected type. | RPC_S_ENTRY_TYPE_MISMATCH
1923 | 0x00000783 | Not all object UUIDs could be exported to the specified entry. | RPC_S_NOT_ALL_OBJS_EXPORTED
1924 | 0x00000784 | Interface could not be exported to the specified entry. | RPC_S_INTERFACE_NOT_EXPORTED
1925 | 0x00000785 | The specified profile entry could not be added. | RPC_S_PROFILE_NOT_ADDED
1926 | 0x00000786 | The specified profile element could not be added. | RPC_S_PRF_ELT_NOT_ADDED
1927 | 0x00000787 | The specified profile element could not be removed. | RPC_S_PRF_ELT_NOT_REMOVED
1928 | 0x00000788 | The group element could not be added. | RPC_S_GRP_ELT_NOT_ADDED
1929 | 0x00000789 | The group element could not be removed. | RPC_S_GRP_ELT_NOT_REMOVED
1930 | 0x0000078A | The printer driver is not compatible with a policy enabled on your computer that blocks NT 4.0 drivers. | ERROR_KM_DRIVER_BLOCKED
2000 | 0x000007D0 | The pixel format is invalid. | ERROR_INVALID_PIXEL_FORMAT
2001 | 0x000007D1 | The specified driver is invalid. | ERROR_BAD_DRIVER
2002 | 0x000007D2 | The window style or class attribute is invalid for this operation. | ERROR_INVALID_WINDOW_STYLE
2003 | 0x000007D3 | The requested metafile operation is not supported. | ERROR_METAFILE_NOT_SUPPORTED
2004 | 0x000007D4 | The requested transformation operation is not supported. | ERROR_TRANSFORM_NOT_SUPPORTED
2005 | 0x000007D5 | The requested clipping operation is not supported. | ERROR_CLIPPING_NOT_SUPPORTED
2010 | 0x000007DA | The specified color management module is invalid. | ERROR_INVALID_CMM
2011 | 0x000007DB | The specified color profile is invalid. | ERROR_INVALID_PROFILE
2012 | 0x000007DC | The specified tag was not found. | ERROR_TAG_NOT_FOUND
2013 | 0x000007DD | A required tag is not present. | ERROR_TAG_NOT_PRESENT
2014 | 0x000007DE | The specified tag is already present. | ERROR_DUPLICATE_TAG
2015 | 0x000007DF | The specified color profile is not associated with any device. | ERROR_PROFILE_NOT_ASSOCIATED_WITH_DEVICE
2016 | 0x000007E0 | The specified color profile was not found. | ERROR_PROFILE_NOT_FOUND
2017 | 0x000007E1 | The specified color space is invalid. | ERROR_INVALID_COLORSPACE
2018 | 0x000007E2 | Image Color Management is not enabled. | ERROR_ICM_NOT_ENABLED
2019 | 0x000007E3 | There was an error while deleting the color transform. | ERROR_DELETING_ICM_XFORM
2020 | 0x000007E4 | The specified color transform is invalid. | ERROR_INVALID_TRANSFORM
2021 | 0x000007E5 | The specified transform does not match the bitmap's color space. | ERROR_COLORSPACE_MISMATCH
2022 | 0x000007E6 | The specified named color index is not present in the profile. | ERROR_INVALID_COLORINDEX
2108 | 0x0000083C | The network connection was made successfully, but the user had to be prompted for a password other than the one originally specified. | ERROR_CONNECTED_OTHER_PASSWORD
2202 | 0x0000089A | The specified username is invalid. | ERROR_BAD_USERNAME
2250 | 0x000008CA | This network connection does not exist. | ERROR_NOT_CONNECTED
2401 | 0x00000961 | This network connection has files open or requests pending. | ERROR_OPEN_FILES
2402 | 0x00000962 | Active connections still exist. | ERROR_ACTIVE_CONNECTIONS
2404 | 0x00000964 | The device is in use by an active process and cannot be disconnected. | ERROR_DEVICE_IN_USE
2500 | 0x000009C4 | The kerberos protocol encountered an error while validating the KDC certificate during smartcard logon. | ERROR_PKINIT_FAILURE
2501 | 0x000009C5 | The kerberos protocol encountered an error while attempting to utilize the smartcard subsystem. | ERROR_SMARTCARD_SUBSYSTEM_FAILURE
3000 | 0x00000BB8 | The specified print monitor is unknown. | ERROR_UNKNOWN_PRINT_MONITOR
3001 | 0x00000BB9 | The specified printer driver is currently in use. | ERROR_PRINTER_DRIVER_IN_USE
3002 | 0x00000BBA | The spool file was not found. | ERROR_SPOOL_FILE_NOT_FOUND
3003 | 0x00000BBB | A StartDocPrinter call was not issued. | ERROR_SPL_NO_STARTDOC
3004 | 0x00000BBC | An AddJob call was not issued. | ERROR_SPL_NO_ADDJOB
3005 | 0x00000BBD | The specified print processor has already been installed. | ERROR_PRINT_PROCESSOR_ALREADY_INSTALLED
3006 | 0x00000BBE | The specified print monitor has already been installed. | ERROR_PRINT_MONITOR_ALREADY_INSTALLED
3007 | 0x00000BBF | The specified print monitor does not have the required functions. | ERROR_INVALID_PRINT_MONITOR
3008 | 0x00000BC0 | The specified print monitor is currently in use. | ERROR_PRINT_MONITOR_IN_USE
3009 | 0x00000BC1 | The requested operation is not allowed when there are jobs queued to the printer. | ERROR_PRINTER_HAS_JOBS_QUEUED
3010 | 0x00000BC2 | The requested operation is successful. Changes will not be effective until the system is rebooted. | ERROR_SUCCESS_REBOOT_REQUIRED
3011 | 0x00000BC3 | The requested operation is successful. Changes will not be effective until the service is restarted. | ERROR_SUCCESS_RESTART_REQUIRED
3012 | 0x00000BC4 | No printers were found. | ERROR_PRINTER_NOT_FOUND
4000 | 0x00000FA0 | WINS encountered an error while processing the command. | ERROR_WINS_INTERNAL
4001 | 0x00000FA1 | The local WINS can not be deleted. | ERROR_CAN_NOT_DEL_LOCAL_WINS
4002 | 0x00000FA2 | The importation from the file failed. | ERROR_STATIC_INIT
4003 | 0x00000FA3 | The backup failed. Was a full backup done before? | ERROR_INC_BACKUP
4004 | 0x00000FA4 | The backup failed. Check the directory to which you are backing the database. | ERROR_FULL_BACKUP
4005 | 0x00000FA5 | The name does not exist in the WINS database. | ERROR_REC_NON_EXISTENT
4006 | 0x00000FA6 | Replication with a nonconfigured partner is not allowed. | ERROR_RPL_NOT_ALLOWED
4100 | 0x00001004 | The DHCP client has obtained an IP address that is already in use on the network. The local interface will be disabled until the DHCP client can obtain a new address. | ERROR_DHCP_ADDRESS_CONFLICT
4200 | 0x00001068 | The GUID passed was not recognized as valid by a WMI data provider. | ERROR_WMI_GUID_NOT_FOUND
4201 | 0x00001069 | The instance name passed was not recognized as valid by a WMI data provider. | ERROR_WMI_INSTANCE_NOT_FOUND
4202 | 0x0000106A | The data item ID passed was not recognized as valid by a WMI data provider. | ERROR_WMI_ITEMID_NOT_FOUND
4203 | 0x0000106B | The WMI request could not be completed and should be retried. | ERROR_WMI_TRY_AGAIN
4204 | 0x0000106C | The WMI data provider could not be located. | ERROR_WMI_DP_NOT_FOUND
4205 | 0x0000106D | The WMI data provider references an instance set that has not been registered. | ERROR_WMI_UNRESOLVED_INSTANCE_REF
4206 | 0x0000106E | The WMI data block or event notification has already been enabled. | ERROR_WMI_ALREADY_ENABLED
4207 | 0x0000106F | The WMI data block is no longer available. | ERROR_WMI_GUID_DISCONNECTED
4208 | 0x00001070 | The WMI data service is not available. | ERROR_WMI_SERVER_UNAVAILABLE
4209 | 0x00001071 | The WMI data provider failed to carry out the request. | ERROR_WMI_DP_FAILED
4210 | 0x00001072 | The WMI MOF information is not valid. | ERROR_WMI_INVALID_MOF
4211 | 0x00001073 | The WMI registration information is not valid. | ERROR_WMI_INVALID_REGINFO
4212 | 0x00001074 | The WMI data block or event notification has already been disabled. | ERROR_WMI_ALREADY_DISABLED
4213 | 0x00001075 | The WMI data item or data block is read only. | ERROR_WMI_READ_ONLY
4214 | 0x00001076 | The WMI data item or data block could not be changed. | ERROR_WMI_SET_FAILURE
4300 | 0x000010CC | The media identifier does not represent a valid medium. | ERROR_INVALID_MEDIA
4301 | 0x000010CD | The library identifier does not represent a valid library. | ERROR_INVALID_LIBRARY
4302 | 0x000010CE | The media pool identifier does not represent a valid media pool. | ERROR_INVALID_MEDIA_POOL
4303 | 0x000010CF | The drive and medium are not compatible or exist in different libraries. | ERROR_DRIVE_MEDIA_MISMATCH
4304 | 0x000010D0 | The medium currently exists in an offline library and must be online to perform this operation. | ERROR_MEDIA_OFFLINE
4305 | 0x000010D1 | The operation cannot be performed on an offline library. | ERROR_LIBRARY_OFFLINE
4306 | 0x000010D2 | The library, drive, or media pool is empty. | ERROR_EMPTY
4307 | 0x000010D3 | The library, drive, or media pool must be empty to perform this operation. | ERROR_NOT_EMPTY
4308 | 0x000010D4 | No media is currently available in this media pool or library. | ERROR_MEDIA_UNAVAILABLE
4309 | 0x000010D5 | A resource required for this operation is disabled. | ERROR_RESOURCE_DISABLED
4310 | 0x000010D6 | The media identifier does not represent a valid cleaner. | ERROR_INVALID_CLEANER
4311 | 0x000010D7 | The drive cannot be cleaned or does not support cleaning. | ERROR_UNABLE_TO_CLEAN
4312 | 0x000010D8 | The object identifier does not represent a valid object. | ERROR_OBJECT_NOT_FOUND
4313 | 0x000010D9 | Unable to read from or write to the database. | ERROR_DATABASE_FAILURE
4314 | 0x000010DA | The database is full. | ERROR_DATABASE_FULL
4315 | 0x000010DB | The medium is not compatible with the device or media pool. | ERROR_MEDIA_INCOMPATIBLE
4316 | 0x000010DC | The resource required for this operation does not exist. | ERROR_RESOURCE_NOT_PRESENT
4317 | 0x000010DD | The operation identifier is not valid. | ERROR_INVALID_OPERATION
4318 | 0x000010DE | The media is not mounted or ready for use. | ERROR_MEDIA_NOT_AVAILABLE
4319 | 0x000010DF | The device is not ready for use. | ERROR_DEVICE_NOT_AVAILABLE
4320 | 0x000010E0 | The operator or administrator has refused the request. | ERROR_REQUEST_REFUSED
4321 | 0x000010E1 | The drive identifier does not represent a valid drive. | ERROR_INVALID_DRIVE_OBJECT
4322 | 0x000010E2 | Library is full. No slot is available for use. | ERROR_LIBRARY_FULL
4323 | 0x000010E3 | The transport cannot access the medium. | ERROR_MEDIUM_NOT_ACCESSIBLE
4324 | 0x000010E4 | Unable to load the medium into the drive. | ERROR_UNABLE_TO_LOAD_MEDIUM
4325 | 0x000010E5 | Unable to retrieve status about the drive. | ERROR_UNABLE_TO_INVENTORY_DRIVE
4326 | 0x000010E6 | Unable to retrieve status about the slot. | ERROR_UNABLE_TO_INVENTORY_SLOT
4327 | 0x000010E7 | Unable to retrieve status about the transport. | ERROR_UNABLE_TO_INVENTORY_TRANSPORT
4328 | 0x000010E8 | Cannot use the transport because it is already in use. | ERROR_TRANSPORT_FULL
4329 | 0x000010E9 | Unable to open or close the inject/eject port. | ERROR_CONTROLLING_IEPORT
4330 | 0x000010EA | Unable to eject the media because it is in a drive. | ERROR_UNABLE_TO_EJECT_MOUNTED_MEDIA
4331 | 0x000010EB | A cleaner slot is already reserved. | ERROR_CLEANER_SLOT_SET
4332 | 0x000010EC | A cleaner slot is not reserved. | ERROR_CLEANER_SLOT_NOT_SET
4333 | 0x000010ED | The cleaner cartridge has performed the maximum number of drive cleanings. | ERROR_CLEANER_CARTRIDGE_SPENT
4334 | 0x000010EE | Unexpected on-medium identifier. | ERROR_UNEXPECTED_OMID
4335 | 0x000010EF | The last remaining item in this group or resource cannot be deleted. | ERROR_CANT_DELETE_LAST_ITEM
4336 | 0x000010F0 | The message provided exceeds the maximum size allowed for this parameter. | ERROR_MESSAGE_EXCEEDS_MAX_SIZE
4337 | 0x000010F1 | The volume contains system or paging files. | ERROR_VOLUME_CONTAINS_SYS_FILES
4338 | 0x000010F2 | The media type cannot be removed from this library since at least one drive in the library reports it can support this media type. | ERROR_INDIGENOUS_TYPE
4339 | 0x000010F3 | This offline media cannot be mounted on this system since no enabled drives are present which can be used. | ERROR_NO_SUPPORTING_DRIVES
4340 | 0x000010F4 | A cleaner cartridge is present in the tape library. | ERROR_CLEANER_CARTRIDGE_INSTALLED
4350 | 0x000010FE | The remote storage service was not able to recall the file. | ERROR_FILE_OFFLINE
4351 | 0x000010FF | The remote storage service is not operational at this time. | ERROR_REMOTE_STORAGE_NOT_ACTIVE
4352 | 0x00001100 | The remote storage service encountered a media error. | ERROR_REMOTE_STORAGE_MEDIA_ERROR
4390 | 0x00001126 | The file or directory is not a reparse point. | ERROR_NOT_A_REPARSE_POINT
4391 | 0x00001127 | The reparse point attribute cannot be set because it conflicts with an existing attribute. | ERROR_REPARSE_ATTRIBUTE_CONFLICT
4392 | 0x00001128 | The data present in the reparse point buffer is invalid. | ERROR_INVALID_REPARSE_DATA
4393 | 0x00001129 | The tag present in the reparse point buffer is invalid. | ERROR_REPARSE_TAG_INVALID
4394 | 0x0000112A | There is a mismatch between the tag specified in the request and the tag present in the reparse point. | ERROR_REPARSE_TAG_MISMATCH
4500 | 0x00001194 | Single Instance Storage is not available on this volume. | ERROR_VOLUME_NOT_SIS_ENABLED
5001 | 0x00001389 | The cluster resource cannot be moved to another group because other resources are dependent on it. | ERROR_DEPENDENT_RESOURCE_EXISTS
5002 | 0x0000138A | The cluster resource dependency cannot be found. | ERROR_DEPENDENCY_NOT_FOUND
5003 | 0x0000138B | The cluster resource cannot be made dependent on the specified resource because it is already dependent. | ERROR_DEPENDENCY_ALREADY_EXISTS
5004 | 0x0000138C | The cluster resource is not online. | ERROR_RESOURCE_NOT_ONLINE
5005 | 0x0000138D | A cluster node is not available for this operation. | ERROR_HOST_NODE_NOT_AVAILABLE
5006 | 0x0000138E | The cluster resource is not available. | ERROR_RESOURCE_NOT_AVAILABLE
5007 | 0x0000138F | The cluster resource could not be found. | ERROR_RESOURCE_NOT_FOUND
5008 | 0x00001390 | The cluster is being shut down. | ERROR_SHUTDOWN_CLUSTER
5009 | 0x00001391 | A cluster node cannot be evicted from the cluster unless the node is down. | ERROR_CANT_EVICT_ACTIVE_NODE
5010 | 0x00001392 | The object already exists. | ERROR_OBJECT_ALREADY_EXISTS
5011 | 0x00001393 | The object is already in the list. | ERROR_OBJECT_IN_LIST
5012 | 0x00001394 | The cluster group is not available for any new requests. | ERROR_GROUP_NOT_AVAILABLE
5013 | 0x00001395 | The cluster group could not be found. | ERROR_GROUP_NOT_FOUND
5014 | 0x00001396 | The operation could not be completed because the cluster group is not online. | ERROR_GROUP_NOT_ONLINE
5015 | 0x00001397 | The cluster node is not the owner of the resource. | ERROR_HOST_NODE_NOT_RESOURCE_OWNER
5016 | 0x00001398 | The cluster node is not the owner of the group. | ERROR_HOST_NODE_NOT_GROUP_OWNER
5017 | 0x00001399 | The cluster resource could not be created in the specified resource monitor. | ERROR_RESMON_CREATE_FAILED
5018 | 0x0000139A | The cluster resource could not be brought online by the resource monitor. | ERROR_RESMON_ONLINE_FAILED
5019 | 0x0000139B | The operation could not be completed because the cluster resource is online. | ERROR_RESOURCE_ONLINE
5020 | 0x0000139C | The cluster resource could not be deleted or brought offline because it is the quorum resource. | ERROR_QUORUM_RESOURCE
5021 | 0x0000139D | The cluster could not make the specified resource a quorum resource because it is not capable of being a quorum resource. | ERROR_NOT_QUORUM_CAPABLE
5022 | 0x0000139E | The cluster software is shutting down. | ERROR_CLUSTER_SHUTTING_DOWN
5023 | 0x0000139F | The group or resource is not in the correct state to perform the requested operation. | ERROR_INVALID_STATE
5024 | 0x000013A0 | The properties were stored but not all changes will take effect until the next time the resource is brought online. | ERROR_RESOURCE_PROPERTIES_STORED
5025 | 0x000013A1 | The cluster could not make the specified resource a quorum resource because it does not belong to a shared storage class. | ERROR_NOT_QUORUM_CLASS
5026 | 0x000013A2 | The cluster resource could not be deleted since it is a core resource. | ERROR_CORE_RESOURCE
5027 | 0x000013A3 | The quorum resource failed to come online. | ERROR_QUORUM_RESOURCE_ONLINE_FAILED
5028 | 0x000013A4 | The quorum log could not be created or mounted successfully. | ERROR_QUORUMLOG_OPEN_FAILED
5029 | 0x000013A5 | The cluster log is corrupt. | ERROR_CLUSTERLOG_CORRUPT
5030 | 0x000013A6 | The record could not be written to the cluster log since it exceeds the maximum size. | ERROR_CLUSTERLOG_RECORD_EXCEEDS_MAXSIZE
5031 | 0x000013A7 | The cluster log exceeds its maximum size. | ERROR_CLUSTERLOG_EXCEEDS_MAXSIZE
5032 | 0x000013A8 | No checkpoint record was found in the cluster log. | ERROR_CLUSTERLOG_CHKPOINT_NOT_FOUND
5033 | 0x000013A9 | The minimum required disk space needed for logging is not available. | ERROR_CLUSTERLOG_NOT_ENOUGH_SPACE
5034 | 0x000013AA | The cluster node failed to take control of the quorum resource because the resource is owned by another active node. | ERROR_QUORUM_OWNER_ALIVE
5035 | 0x000013AB | A cluster network is not available for this operation. | ERROR_NETWORK_NOT_AVAILABLE
5036 | 0x000013AC | A cluster node is not available for this operation. | ERROR_NODE_NOT_AVAILABLE
5037 | 0x000013AD | All cluster nodes must be running to perform this operation. | ERROR_ALL_NODES_NOT_AVAILABLE
5038 | 0x000013AE | A cluster resource failed. | ERROR_RESOURCE_FAILED
5039 | 0x000013AF | The cluster node is not valid. | ERROR_CLUSTER_INVALID_NODE
5040 | 0x000013B0 | The cluster node already exists. | ERROR_CLUSTER_NODE_EXISTS
5041 | 0x000013B1 | A node is in the process of joining the cluster. | ERROR_CLUSTER_JOIN_IN_PROGRESS
5042 | 0x000013B2 | The cluster node was not found. | ERROR_CLUSTER_NODE_NOT_FOUND
5043 | 0x000013B3 | The cluster local node information was not found. | ERROR_CLUSTER_LOCAL_NODE_NOT_FOUND
5044 | 0x000013B4 | The cluster network already exists. | ERROR_CLUSTER_NETWORK_EXISTS
5045 | 0x000013B5 | The cluster network was not found. | ERROR_CLUSTER_NETWORK_NOT_FOUND
5046 | 0x000013B6 | The cluster network interface already exists. | ERROR_CLUSTER_NETINTERFACE_EXISTS
5047 | 0x000013B7 | The cluster network interface was not found. | ERROR_CLUSTER_NETINTERFACE_NOT_FOUND
5048 | 0x000013B8 | The cluster request is not valid for this object. | ERROR_CLUSTER_INVALID_REQUEST
5049 | 0x000013B9 | The cluster network provider is not valid. | ERROR_CLUSTER_INVALID_NETWORK_PROVIDER
5050 | 0x000013BA | The cluster node is down. | ERROR_CLUSTER_NODE_DOWN
5051 | 0x000013BB | The cluster node is not reachable. | ERROR_CLUSTER_NODE_UNREACHABLE
5052 | 0x000013BC | The cluster node is not a member of the cluster. | ERROR_CLUSTER_NODE_NOT_MEMBER
5053 | 0x000013BD | A cluster join operation is not in progress. | ERROR_CLUSTER_JOIN_NOT_IN_PROGRESS
5054 | 0x000013BE | The cluster network is not valid. | ERROR_CLUSTER_INVALID_NETWORK
5056 | 0x000013C0 | The cluster node is up. | ERROR_CLUSTER_NODE_UP
5057 | 0x000013C1 | The cluster IP address is already in use. | ERROR_CLUSTER_IPADDR_IN_USE
5058 | 0x000013C2 | The cluster node is not paused. | ERROR_CLUSTER_NODE_NOT_PAUSED
5059 | 0x000013C3 | No cluster security context is available. | ERROR_CLUSTER_NO_SECURITY_CONTEXT
5060 | 0x000013C4 | The cluster network is not configured for internal cluster communication. | ERROR_CLUSTER_NETWORK_NOT_INTERNAL
5061 | 0x000013C5 | The cluster node is already up. | ERROR_CLUSTER_NODE_ALREADY_UP
5062 | 0x000013C6 | The cluster node is already down. | ERROR_CLUSTER_NODE_ALREADY_DOWN
5063 | 0x000013C7 | The cluster network is already online. | ERROR_CLUSTER_NETWORK_ALREADY_ONLINE
5064 | 0x000013C8 | The cluster network is already offline. | ERROR_CLUSTER_NETWORK_ALREADY_OFFLINE
5065 | 0x000013C9 | The cluster node is already a member of the cluster. | ERROR_CLUSTER_NODE_ALREADY_MEMBER
5066 | 0x000013CA | The cluster network is the only one configured for internal cluster communication between two or more active cluster nodes. The internal communication capability cannot be removed from the network. | ERROR_CLUSTER_LAST_INTERNAL_NETWORK
5067 | 0x000013CB | One or more cluster resources depend on the network to provide service to clients. The client access capability cannot be removed from the network. | ERROR_CLUSTER_NETWORK_HAS_DEPENDENTS
5068 | 0x000013CC | This operation cannot be performed on the cluster resource as it the quorum resource. You may not bring the quorum resource offline or modify its possible owners list. | ERROR_INVALID_OPERATION_ON_QUORUM
5069 | 0x000013CD | The cluster quorum resource is not allowed to have any dependencies. | ERROR_DEPENDENCY_NOT_ALLOWED
5070 | 0x000013CE | The cluster node is paused. | ERROR_CLUSTER_NODE_PAUSED
5071 | 0x000013CF | The cluster resource cannot be brought online. The owner node cannot run this resource. | ERROR_NODE_CANT_HOST_RESOURCE
5072 | 0x000013D0 | The cluster node is not ready to perform the requested operation. | ERROR_CLUSTER_NODE_NOT_READY
5073 | 0x000013D1 | The cluster node is shutting down. | ERROR_CLUSTER_NODE_SHUTTING_DOWN
5074 | 0x000013D2 | The cluster join operation was aborted. | ERROR_CLUSTER_JOIN_ABORTED
5075 | 0x000013D3 | The cluster join operation failed due to incompatible software versions between the joining node and its sponsor. | ERROR_CLUSTER_INCOMPATIBLE_VERSIONS
5076 | 0x000013D4 | This resource cannot be created because the cluster has reached the limit on the number of resources it can monitor. | ERROR_CLUSTER_MAXNUM_OF_RESOURCES_EXCEEDED
5077 | 0x000013D5 | The system configuration changed during the cluster join or form operation. The join or form operation was aborted. | ERROR_CLUSTER_SYSTEM_CONFIG_CHANGED
5078 | 0x000013D6 | The specified resource type was not found. | ERROR_CLUSTER_RESOURCE_TYPE_NOT_FOUND
5079 | 0x000013D7 | The specified node does not support a resource of this type. This may be due to version inconsistencies or due to the absence of the resource DLL on this node. | ERROR_CLUSTER_RESTYPE_NOT_SUPPORTED
5080 | 0x000013D8 | The specified resource name is supported by this resource DLL. This may be due to a bad (or changed) name supplied to the resource DLL. | ERROR_CLUSTER_RESNAME_NOT_FOUND
5081 | 0x000013D9 | No authentication package could be registered with the RPC server. | ERROR_CLUSTER_NO_RPC_PACKAGES_REGISTERED
5082 | 0x000013DA | You cannot bring the group online because the owner of the group is not in the preferred list for the group. To change the owner node for the group, move the group. | ERROR_CLUSTER_OWNER_NOT_IN_PREFLIST
5083 | 0x000013DB | The join operation failed because the cluster database sequence number has changed or is incompatible with the locker node. This may happen during a join operation if the cluster database was changing during the join. | ERROR_CLUSTER_DATABASE_SEQMISMATCH
5084 | 0x000013DC | The resource monitor will not allow the fail operation to be performed while the resource is in its current state. This may happen if the resource is in a pending state. | ERROR_RESMON_INVALID_STATE
5085 | 0x000013DD | A non locker code got a request to reserve the lock for making global updates. | ERROR_CLUSTER_GUM_NOT_LOCKER
5086 | 0x000013DE | The quorum disk could not be located by the cluster service. | ERROR_QUORUM_DISK_NOT_FOUND
5087 | 0x000013DF | The backup up cluster database is possibly corrupt. | ERROR_DATABASE_BACKUP_CORRUPT
5088 | 0x000013E0 | A DFS root already exists in this cluster node. | ERROR_CLUSTER_NODE_ALREADY_HAS_DFS_ROOT
5089 | 0x000013E1 | An attempt to modify a resource property failed because it conflicts with another existing property. | ERROR_RESOURCE_PROPERTY_UNCHANGEABLE
5890 | 0x00001702 | An operation was attempted that is incompatible with the current membership state of the node. | ERROR_CLUSTER_MEMBERSHIP_INVALID_STATE
5891 | 0x00001703 | The quorum resource does not contain the quorum log. | ERROR_CLUSTER_QUORUMLOG_NOT_FOUND
5892 | 0x00001704 | The membership engine requested shutdown of the cluster service on this node. | ERROR_CLUSTER_MEMBERSHIP_HALT
5893 | 0x00001705 | The join operation failed because the cluster instance ID of the joining node does not match the cluster instance ID of the sponsor node. | ERROR_CLUSTER_INSTANCE_ID_MISMATCH
5894 | 0x00001706 | A matching network for the specified IP address could not be found. Please also specify a subnet mask and a cluster network. | ERROR_CLUSTER_NETWORK_NOT_FOUND_FOR_IP
5895 | 0x00001707 | The actual data type of the property did not match the expected data type of the property. | ERROR_CLUSTER_PROPERTY_DATA_TYPE_MISMATCH
5896 | 0x00001708 | The cluster node was evicted from the cluster successfully. The node was not cleaned up because it does not support the evict cleanup functionality. | ERROR_CLUSTER_EVICT_WITHOUT_CLEANUP
6000 | 0x00001770 | The specified file could not be encrypted. | ERROR_ENCRYPTION_FAILED
6001 | 0x00001771 | The specified file could not be decrypted. | ERROR_DECRYPTION_FAILED
6002 | 0x00001772 | The specified file is encrypted and the user does not have the ability to decrypt it. | ERROR_FILE_ENCRYPTED
6003 | 0x00001773 | There is no valid encryption recovery policy configured for this system. | ERROR_NO_RECOVERY_POLICY
6004 | 0x00001774 | The required encryption driver is not loaded for this system. | ERROR_NO_EFS
6005 | 0x00001775 | The file was encrypted with a different encryption driver than is currently loaded. | ERROR_WRONG_EFS
6006 | 0x00001776 | There are no EFS keys defined for the user. | ERROR_NO_USER_KEYS
6007 | 0x00001777 | The specified file is not encrypted. | ERROR_FILE_NOT_ENCRYPTED
6008 | 0x00001778 | The specified file is not in the defined EFS export format. | ERROR_NOT_EXPORT_FORMAT
6009 | 0x00001779 | The specified file is read only. | ERROR_FILE_READ_ONLY
6010 | 0x0000177A | The directory has been disabled for encryption. | ERROR_DIR_EFS_DISALLOWED
6011 | 0x0000177B | The server is not trusted for remote encryption operation. | ERROR_EFS_SERVER_NOT_TRUSTED
6012 | 0x0000177C | Recovery policy configured for this system contains invalid recovery certificate. | ERROR_BAD_RECOVERY_POLICY
6013 | 0x0000177D | The encryption algorithm used on the source file needs a bigger key buffer than the one on the destination file. | ERROR_EFS_ALG_BLOB_TOO_BIG
6014 | 0x0000177E | The disk partition does not support file encryption. | ERROR_VOLUME_NOT_SUPPORT_EFS
6118 | 0x000017E6 | The list of servers for this workgroup is not currently available. | ERROR_NO_BROWSER_SERVERS_FOUND
6200 | 0x00001838 | The Task Scheduler service must be configured to run in the System account to function properly. Individual tasks may be configured to run in other accounts. | SCHED_E_SERVICE_NOT_LOCALSYSTEM
7001 | 0x00001B59 | The specified session name is invalid. | ERROR_CTX_WINSTATION_NAME_INVALID
7002 | 0x00001B5A | The specified protocol driver is invalid. | ERROR_CTX_INVALID_PD
7003 | 0x00001B5B | The specified protocol driver was not found in the system path. | ERROR_CTX_PD_NOT_FOUND
7004 | 0x00001B5C | The specified terminal connection driver was not found in the system path. | ERROR_CTX_WD_NOT_FOUND
7005 | 0x00001B5D | A registry key for event logging could not be created for this session. | ERROR_CTX_CANNOT_MAKE_EVENTLOG_ENTRY
7006 | 0x00001B5E | A service with the same name already exists on the system. | ERROR_CTX_SERVICE_NAME_COLLISION
7007 | 0x00001B5F | A close operation is pending on the session. | ERROR_CTX_CLOSE_PENDING
7008 | 0x00001B60 | There are no free output buffers available. | ERROR_CTX_NO_OUTBUF
7009 | 0x00001B61 | The MODEM.INF file was not found. | ERROR_CTX_MODEM_INF_NOT_FOUND
7010 | 0x00001B62 | The modem name was not found in MODEM.INF. | ERROR_CTX_INVALID_MODEMNAME
7011 | 0x00001B63 | The modem did not accept the command sent to it. Verify that the configured modem name matches the attached modem. | ERROR_CTX_MODEM_RESPONSE_ERROR
7012 | 0x00001B64 | The modem did not respond to the command sent to it. Verify that the modem is properly cabled and powered on. | ERROR_CTX_MODEM_RESPONSE_TIMEOUT
7013 | 0x00001B65 | Carrier detect has failed or carrier has been dropped due to disconnect. | ERROR_CTX_MODEM_RESPONSE_NO_CARRIER
7014 | 0x00001B66 | Dial tone not detected within the required time. Verify that the phone cable is properly attached and functional. | ERROR_CTX_MODEM_RESPONSE_NO_DIALTONE
7015 | 0x00001B67 | Busy signal detected at remote site on callback. | ERROR_CTX_MODEM_RESPONSE_BUSY
7016 | 0x00001B68 | Voice detected at remote site on callback. | ERROR_CTX_MODEM_RESPONSE_VOICE
7017 | 0x00001B69 | Transport driver error | ERROR_CTX_TD_ERROR
7022 | 0x00001B6E | The specified session cannot be found. | ERROR_CTX_WINSTATION_NOT_FOUND
7023 | 0x00001B6F | The specified session name is already in use. | ERROR_CTX_WINSTATION_ALREADY_EXISTS
7024 | 0x00001B70 | The requested operation cannot be completed because the terminal connection is currently busy processing a connect, disconnect, reset, or delete operation. | ERROR_CTX_WINSTATION_BUSY
7025 | 0x00001B71 | An attempt has been made to connect to a session whose video mode is not supported by the current client. | ERROR_CTX_BAD_VIDEO_MODE
7035 | 0x00001B7B | The application attempted to enable DOS graphics mode. DOS graphics mode is not supported. | ERROR_CTX_GRAPHICS_INVALID
7037 | 0x00001B7D | Your interactive logon privilege has been disabled. Please contact your administrator. | ERROR_CTX_LOGON_DISABLED
7038 | 0x00001B7E | The requested operation can be performed only on the system console. This is most often the result of a driver or system DLL requiring direct console access. | ERROR_CTX_NOT_CONSOLE
7040 | 0x00001B80 | The client failed to respond to the server connect message. | ERROR_CTX_CLIENT_QUERY_TIMEOUT
7041 | 0x00001B81 | Disconnecting the console session is not supported. | ERROR_CTX_CONSOLE_DISCONNECT
7042 | 0x00001B82 | Reconnecting a disconnected session to the console is not supported. | ERROR_CTX_CONSOLE_CONNECT
7044 | 0x00001B84 | The request to control another session remotely was denied. | ERROR_CTX_SHADOW_DENIED
7045 | 0x00001B85 | The requested session access is denied. | ERROR_CTX_WINSTATION_ACCESS_DENIED
7049 | 0x00001B89 | The specified terminal connection driver is invalid. | ERROR_CTX_INVALID_WD
7050 | 0x00001B8A | The requested session cannot be controlled remotely. This may be because the session is disconnected or does not currently have a user logged on. | ERROR_CTX_SHADOW_INVALID
7051 | 0x00001B8B | The requested session is not configured to allow remote control. | ERROR_CTX_SHADOW_DISABLED
7052 | 0x00001B8C | Your request to connect to this Terminal Server has been rejected. Your Terminal Server client license number is currently being used by another user. Please call your system administrator to obtain a unique license number. | ERROR_CTX_CLIENT_LICENSE_IN_USE
7053 | 0x00001B8D | Your request to connect to this Terminal Server has been rejected. Your Terminal Server client license number has not been entered for this copy of the Terminal Server client. Please contact your system administrator. | ERROR_CTX_CLIENT_LICENSE_NOT_SET
7054 | 0x00001B8E | The system has reached its licensed logon limit. Please try again later. | ERROR_CTX_LICENSE_NOT_AVAILABLE
7055 | 0x00001B8F | The client you are using is not licensed to use this system. Your logon request is denied. | ERROR_CTX_LICENSE_CLIENT_INVALID
7056 | 0x00001B90 | The system license has expired. Your logon request is denied. | ERROR_CTX_LICENSE_EXPIRED
7057 | 0x00001B91 | Remote control could not be terminated because the specified session is not currently being remotely controlled. | ERROR_CTX_SHADOW_NOT_RUNNING
8001 | 0x00001F41 | The file replication service API was called incorrectly. | FRS_ERR_INVALID_API_SEQUENCE
8002 | 0x00001F42 | The file replication service cannot be started. | FRS_ERR_STARTING_SERVICE
8003 | 0x00001F43 | The file replication service cannot be stopped. | FRS_ERR_STOPPING_SERVICE
8004 | 0x00001F44 | The file replication service API terminated the request. The event log may have more information. | FRS_ERR_INTERNAL_API
8005 | 0x00001F45 | The file replication service terminated the request. The event log may have more information. | FRS_ERR_INTERNAL
8006 | 0x00001F46 | The file replication service cannot be contacted. The event log may have more information. | FRS_ERR_SERVICE_COMM
8007 | 0x00001F47 | The file replication service cannot satisfy the request because the user has insufficient privileges. The event log may have more information. | FRS_ERR_INSUFFICIENT_PRIV
8008 | 0x00001F48 | The file replication service cannot satisfy the request because authenticated RPC is not available. The event log may have more information. | FRS_ERR_AUTHENTICATION
8009 | 0x00001F49 | The file replication service cannot satisfy the request because the user has insufficient privileges on the domain controller. The event log may have more information. | FRS_ERR_PARENT_INSUFFICIENT_PRIV
8010 | 0x00001F4A | The file replication service cannot satisfy the request because authenticated RPC is not available on the domain controller. The event log may have more information. | FRS_ERR_PARENT_AUTHENTICATION
8011 | 0x00001F4B | The file replication service cannot communicate with the file replication service on the domain controller. The event log may have more information. | FRS_ERR_CHILD_TO_PARENT_COMM
8012 | 0x00001F4C | The file replication service on the domain controller cannot communicate with the file replication service on this computer. The event log may have more information. | FRS_ERR_PARENT_TO_CHILD_COMM
8013 | 0x00001F4D | The file replication service cannot populate the system volume because of an internal error. The event log may have more information. | FRS_ERR_SYSVOL_POPULATE
8014 | 0x00001F4E | The file replication service cannot populate the system volume because of an internal timeout. The event log may have more information. | FRS_ERR_SYSVOL_POPULATE_TIMEOUT
8015 | 0x00001F4F | The file replication service cannot process the request. The system volume is busy with a previous request. | FRS_ERR_SYSVOL_IS_BUSY
8016 | 0x00001F50 | The file replication service cannot stop replicating the system volume because of an internal error. The event log may have more information. | FRS_ERR_SYSVOL_DEMOTE
8017 | 0x00001F51 | The file replication service detected an invalid parameter. | FRS_ERR_INVALID_SERVICE_PARAMETER
8200 | 0x00002008 | An error occurred while installing the directory service. For more information, see the event log. | ERROR_DS_NOT_INSTALLED
8201 | 0x00002009 | The directory service evaluated group memberships locally. | ERROR_DS_MEMBERSHIP_EVALUATED_LOCALLY
8202 | 0x0000200A | The specified directory service attribute or value does not exist. | ERROR_DS_NO_ATTRIBUTE_OR_VALUE
8203 | 0x0000200B | The attribute syntax specified to the directory service is invalid. | ERROR_DS_INVALID_ATTRIBUTE_SYNTAX
8204 | 0x0000200C | The attribute type specified to the directory service is not defined. | ERROR_DS_ATTRIBUTE_TYPE_UNDEFINED
8205 | 0x0000200D | The specified directory service attribute or value already exists. | ERROR_DS_ATTRIBUTE_OR_VALUE_EXISTS
8206 | 0x0000200E | The directory service is busy. | ERROR_DS_BUSY
8207 | 0x0000200F | The directory service is unavailable. | ERROR_DS_UNAVAILABLE
8208 | 0x00002010 | The directory service was unable to allocate a relative identifier. | ERROR_DS_NO_RIDS_ALLOCATED
8209 | 0x00002011 | The directory service has exhausted the pool of relative identifiers. | ERROR_DS_NO_MORE_RIDS
8210 | 0x00002012 | The requested operation could not be performed because the directory service is not the master for that type of operation. | ERROR_DS_INCORRECT_ROLE_OWNER
8211 | 0x00002013 | The directory service was unable to initialize the subsystem that allocates relative identifiers. | ERROR_DS_RIDMGR_INIT_ERROR
8212 | 0x00002014 | The requested operation did not satisfy one or more constraints associated with the class of the object. | ERROR_DS_OBJ_CLASS_VIOLATION
8213 | 0x00002015 | The directory service can perform the requested operation only on a leaf object. | ERROR_DS_CANT_ON_NON_LEAF
8214 | 0x00002016 | The directory service cannot perform the requested operation on the RDN attribute of an object. | ERROR_DS_CANT_ON_RDN
8215 | 0x00002017 | The directory service detected an attempt to modify the object class of an object. | ERROR_DS_CANT_MOD_OBJ_CLASS
8216 | 0x00002018 | The requested cross-domain move operation could not be performed. | ERROR_DS_CROSS_DOM_MOVE_ERROR
8217 | 0x00002019 | Unable to contact the global catalog server. | ERROR_DS_GC_NOT_AVAILABLE
8218 | 0x0000201A | The policy object is shared and can only be modified at the root. | ERROR_SHARED_POLICY
8219 | 0x0000201B | The policy object does not exist. | ERROR_POLICY_OBJECT_NOT_FOUND
8220 | 0x0000201C | The requested policy information is only in the directory service. | ERROR_POLICY_ONLY_IN_DS
8221 | 0x0000201D | A domain controller promotion is currently active. | ERROR_PROMOTION_ACTIVE
8222 | 0x0000201E | A domain controller promotion is not currently active | ERROR_NO_PROMOTION_ACTIVE
8224 | 0x00002020 | An operations error occurred. | ERROR_DS_OPERATIONS_ERROR
8225 | 0x00002021 | A protocol error occurred. | ERROR_DS_PROTOCOL_ERROR
8226 | 0x00002022 | The time limit for this request was exceeded. | ERROR_DS_TIMELIMIT_EXCEEDED
8227 | 0x00002023 | The size limit for this request was exceeded. | ERROR_DS_SIZELIMIT_EXCEEDED
8228 | 0x00002024 | The administrative limit for this request was exceeded. | ERROR_DS_ADMIN_LIMIT_EXCEEDED
8229 | 0x00002025 | The compare response was false. | ERROR_DS_COMPARE_FALSE
8230 | 0x00002026 | The compare response was true. | ERROR_DS_COMPARE_TRUE
8231 | 0x00002027 | The requested authentication method is not supported by the server. | ERROR_DS_AUTH_METHOD_NOT_SUPPORTED
8232 | 0x00002028 | A more secure authentication method is required for this server. | ERROR_DS_STRONG_AUTH_REQUIRED
8233 | 0x00002029 | Inappropriate authentication. | ERROR_DS_INAPPROPRIATE_AUTH
8234 | 0x0000202A | The authentication mechanism is unknown. | ERROR_DS_AUTH_UNKNOWN
8235 | 0x0000202B | A referral was returned from the server. | ERROR_DS_REFERRAL
8236 | 0x0000202C | The server does not support the requested critical extension. | ERROR_DS_UNAVAILABLE_CRIT_EXTENSION
8237 | 0x0000202D | This request requires a secure connection. | ERROR_DS_CONFIDENTIALITY_REQUIRED
8238 | 0x0000202E | Inappropriate matching. | ERROR_DS_INAPPROPRIATE_MATCHING
8239 | 0x0000202F | A constraint violation occurred. | ERROR_DS_CONSTRAINT_VIOLATION
8240 | 0x00002030 | There is no such object on the server. | ERROR_DS_NO_SUCH_OBJECT
8241 | 0x00002031 | There is an alias problem. | ERROR_DS_ALIAS_PROBLEM
8242 | 0x00002032 | An invalid dn syntax has been specified. | ERROR_DS_INVALID_DN_SYNTAX
8243 | 0x00002033 | The object is a leaf object. | ERROR_DS_IS_LEAF
8244 | 0x00002034 | There is an alias dereferencing problem. | ERROR_DS_ALIAS_DEREF_PROBLEM
8245 | 0x00002035 | The server is unwilling to process the request. | ERROR_DS_UNWILLING_TO_PERFORM
8246 | 0x00002036 | A loop has been detected. | ERROR_DS_LOOP_DETECT
8247 | 0x00002037 | There is a naming violation. | ERROR_DS_NAMING_VIOLATION
8248 | 0x00002038 | The result set is too large. | ERROR_DS_OBJECT_RESULTS_TOO_LARGE
8249 | 0x00002039 | The operation affects multiple DSAs | ERROR_DS_AFFECTS_MULTIPLE_DSAS
8250 | 0x0000203A | The server is not operational. | ERROR_DS_SERVER_DOWN
8251 | 0x0000203B | A local error has occurred. | ERROR_DS_LOCAL_ERROR
8252 | 0x0000203C | An encoding error has occurred. | ERROR_DS_ENCODING_ERROR
8253 | 0x0000203D | A decoding error has occurred. | ERROR_DS_DECODING_ERROR
8254 | 0x0000203E | The search filter cannot be recognized. | ERROR_DS_FILTER_UNKNOWN
8255 | 0x0000203F | One or more parameters are illegal. | ERROR_DS_PARAM_ERROR
8256 | 0x00002040 | The specified method is not supported. | ERROR_DS_NOT_SUPPORTED
8257 | 0x00002041 | No results were returned. | ERROR_DS_NO_RESULTS_RETURNED
8258 | 0x00002042 | The specified control is not supported by the server. | ERROR_DS_CONTROL_NOT_FOUND
8259 | 0x00002043 | A referral loop was detected by the client. | ERROR_DS_CLIENT_LOOP
8260 | 0x00002044 | The preset referral limit was exceeded. | ERROR_DS_REFERRAL_LIMIT_EXCEEDED
8261 | 0x00002045 | The search requires a SORT control. | ERROR_DS_SORT_CONTROL_MISSING
8262 | 0x00002046 | The search results exceed the offset range specified. | ERROR_DS_OFFSET_RANGE_ERROR
8301 | 0x0000206D | The root object must be the head of a naming context. The root object cannot have an instantiated parent. | ERROR_DS_ROOT_MUST_BE_NC
8302 | 0x0000206E | The add replica operation cannot be performed. The naming context must be writable in order to create the replica. | ERROR_DS_ADD_REPLICA_INHIBITED
8303 | 0x0000206F | A reference to an attribute that is not defined in the schema occurred. | ERROR_DS_ATT_NOT_DEF_IN_SCHEMA
8304 | 0x00002070 | The maximum size of an object has been exceeded. | ERROR_DS_MAX_OBJ_SIZE_EXCEEDED
8305 | 0x00002071 | An attempt was made to add an object to the directory with a name that is already in use. | ERROR_DS_OBJ_STRING_NAME_EXISTS
8306 | 0x00002072 | An attempt was made to add an object of a class that does not have an RDN defined in the schema. | ERROR_DS_NO_RDN_DEFINED_IN_SCHEMA
8307 | 0x00002073 | An attempt was made to add an object using an RDN that is not the RDN defined in the schema. | ERROR_DS_RDN_DOESNT_MATCH_SCHEMA
8308 | 0x00002074 | None of the requested attributes were found on the objects. | ERROR_DS_NO_REQUESTED_ATTS_FOUND
8309 | 0x00002075 | The user buffer is too small. | ERROR_DS_USER_BUFFER_TO_SMALL
8310 | 0x00002076 | The attribute specified in the operation is not present on the object. | ERROR_DS_ATT_IS_NOT_ON_OBJ
8311 | 0x00002077 | Illegal modify operation. Some aspect of the modification is not permitted. | ERROR_DS_ILLEGAL_MOD_OPERATION
8312 | 0x00002078 | The specified object is too large. | ERROR_DS_OBJ_TOO_LARGE
8313 | 0x00002079 | The specified instance type is not valid. | ERROR_DS_BAD_INSTANCE_TYPE
8314 | 0x0000207A | The operation must be performed at a master DSA. | ERROR_DS_MASTERDSA_REQUIRED
8315 | 0x0000207B | The object class attribute must be specified. | ERROR_DS_OBJECT_CLASS_REQUIRED
8316 | 0x0000207C | A required attribute is missing. | ERROR_DS_MISSING_REQUIRED_ATT
8317 | 0x0000207D | An attempt was made to modify an object to include an attribute that is not legal for its class | ERROR_DS_ATT_NOT_DEF_FOR_CLASS
8318 | 0x0000207E | The specified attribute is already present on the object. | ERROR_DS_ATT_ALREADY_EXISTS
8320 | 0x00002080 | The specified attribute is not present, or has no values. | ERROR_DS_CANT_ADD_ATT_VALUES
8321 | 0x00002081 | Multiple values were specified for an attribute that can have only one value. | ERROR_DS_SINGLE_VALUE_CONSTRAINT
8322 | 0x00002082 | A value for the attribute was not in the acceptable range of values. | ERROR_DS_RANGE_CONSTRAINT
8323 | 0x00002083 | The specified value already exists. | ERROR_DS_ATT_VAL_ALREADY_EXISTS
8324 | 0x00002084 | The attribute cannot be removed because it is not present on the object. | ERROR_DS_CANT_REM_MISSING_ATT
8325 | 0x00002085 | The attribute value cannot be removed because it is not present on the object. | ERROR_DS_CANT_REM_MISSING_ATT_VAL
8326 | 0x00002086 | The specified root object cannot be a subref. | ERROR_DS_ROOT_CANT_BE_SUBREF
8327 | 0x00002087 | Chaining is not permitted. | ERROR_DS_NO_CHAINING
8328 | 0x00002088 | Chained evaluation is not permitted. | ERROR_DS_NO_CHAINED_EVAL
8329 | 0x00002089 | The operation could not be performed because the object's parent is either uninstantiated or deleted. | ERROR_DS_NO_PARENT_OBJECT
8330 | 0x0000208A | Having a parent that is an alias is not permitted. Aliases are leaf objects. | ERROR_DS_PARENT_IS_AN_ALIAS
8331 | 0x0000208B | The object and parent must be of the same type, either both masters or both replicas. | ERROR_DS_CANT_MIX_MASTER_AND_REPS
8332 | 0x0000208C | The operation cannot be performed because child objects exist. This operation can only be performed on a leaf object. | ERROR_DS_CHILDREN_EXIST
8333 | 0x0000208D | Directory object not found. | ERROR_DS_OBJ_NOT_FOUND
8334 | 0x0000208E | The aliased object is missing. | ERROR_DS_ALIASED_OBJ_MISSING
8335 | 0x0000208F | The object name has bad syntax. | ERROR_DS_BAD_NAME_SYNTAX
8336 | 0x00002090 | It is not permitted for an alias to refer to another alias. | ERROR_DS_ALIAS_POINTS_TO_ALIAS
8337 | 0x00002091 | The alias cannot be dereferenced. | ERROR_DS_CANT_DEREF_ALIAS
8338 | 0x00002092 | The operation is out of scope. | ERROR_DS_OUT_OF_SCOPE
8339 | 0x00002093 | The operation cannot continue because the object is in the process of being removed. | ERROR_DS_OBJECT_BEING_REMOVED
8340 | 0x00002094 | The DSA object cannot be deleted. | ERROR_DS_CANT_DELETE_DSA_OBJ
8341 | 0x00002095 | A directory service error has occurred. | ERROR_DS_GENERIC_ERROR
8342 | 0x00002096 | The operation can only be performed on an internal master DSA object. | ERROR_DS_DSA_MUST_BE_INT_MASTER
8343 | 0x00002097 | The object must be of class DSA. | ERROR_DS_CLASS_NOT_DSA
8344 | 0x00002098 | Insufficient access rights to perform the operation. | ERROR_DS_INSUFF_ACCESS_RIGHTS
8345 | 0x00002099 | The object cannot be added because the parent is not on the list of possible superiors. | ERROR_DS_ILLEGAL_SUPERIOR
8346 | 0x0000209A | Access to the attribute is not permitted because the attribute is owned by the Security Accounts Manager (SAM). | ERROR_DS_ATTRIBUTE_OWNED_BY_SAM
8347 | 0x0000209B | The name has too many parts. | ERROR_DS_NAME_TOO_MANY_PARTS
8348 | 0x0000209C | The name is too long. | ERROR_DS_NAME_TOO_LONG
8349 | 0x0000209D | The name value is too long. | ERROR_DS_NAME_VALUE_TOO_LONG
8350 | 0x0000209E | The directory service encountered an error parsing a name. | ERROR_DS_NAME_UNPARSEABLE
8351 | 0x0000209F | The directory service cannot get the attribute type for a name. | ERROR_DS_NAME_TYPE_UNKNOWN
8352 | 0x000020A0 | The name does not identify an object; the name identifies a phantom. | ERROR_DS_NOT_AN_OBJECT
8353 | 0x000020A1 | The security descriptor is too short. | ERROR_DS_SEC_DESC_TOO_SHORT
8354 | 0x000020A2 | The security descriptor is invalid. | ERROR_DS_SEC_DESC_INVALID
8355 | 0x000020A3 | Failed to create name for deleted object. | ERROR_DS_NO_DELETED_NAME
8356 | 0x000020A4 | The parent of a new subref must exist. | ERROR_DS_SUBREF_MUST_HAVE_PARENT
8357 | 0x000020A5 | The object must be a naming context. | ERROR_DS_NCNAME_MUST_BE_NC
8358 | 0x000020A6 | It is not permitted to add an attribute which is owned by the system. | ERROR_DS_CANT_ADD_SYSTEM_ONLY
8359 | 0x000020A7 | The class of the object must be structural; you cannot instantiate an abstract class. | ERROR_DS_CLASS_MUST_BE_CONCRETE
8360 | 0x000020A8 | The schema object could not be found. | ERROR_DS_INVALID_DMD
8361 | 0x000020A9 | A local object with this GUID (dead or alive) already exists. | ERROR_DS_OBJ_GUID_EXISTS
8362 | 0x000020AA | The operation cannot be performed on a back link. | ERROR_DS_NOT_ON_BACKLINK
8363 | 0x000020AB | The cross reference for the specified naming context could not be found. | ERROR_DS_NO_CROSSREF_FOR_NC
8364 | 0x000020AC | The operation could not be performed because the directory service is shutting down. | ERROR_DS_SHUTTING_DOWN
8365 | 0x000020AD | The directory service request is invalid. | ERROR_DS_UNKNOWN_OPERATION
8366 | 0x000020AE | The role owner attribute could not be read. | ERROR_DS_INVALID_ROLE_OWNER
8367 | 0x000020AF | The requested FSMO operation failed. The current FSMO holder could not be reached. | ERROR_DS_COULDNT_CONTACT_FSMO
8368 | 0x000020B0 | Modification of a DN across a naming context is not permitted. | ERROR_DS_CROSS_NC_DN_RENAME
8369 | 0x000020B1 | The attribute cannot be modified because it is owned by the system. | ERROR_DS_CANT_MOD_SYSTEM_ONLY
8370 | 0x000020B2 | Only the replicator can perform this function. | ERROR_DS_REPLICATOR_ONLY
8371 | 0x000020B3 | The specified class is not defined. | ERROR_DS_OBJ_CLASS_NOT_DEFINED
8372 | 0x000020B4 | The specified class is not a subclass. | ERROR_DS_OBJ_CLASS_NOT_SUBCLASS
8373 | 0x000020B5 | The name reference is invalid. | ERROR_DS_NAME_REFERENCE_INVALID
8374 | 0x000020B6 | A cross reference already exists. | ERROR_DS_CROSS_REF_EXISTS
8375 | 0x000020B7 | It is not permitted to delete a master cross reference. | ERROR_DS_CANT_DEL_MASTER_CROSSREF
8376 | 0x000020B8 | Subtree notifications are only supported on NC heads. | ERROR_DS_SUBTREE_NOTIFY_NOT_NC_HEAD
8377 | 0x000020B9 | Notification filter is too complex. | ERROR_DS_NOTIFY_FILTER_TOO_COMPLEX
8378 | 0x000020BA | Schema update failed: duplicate RDN. | ERROR_DS_DUP_RDN
8379 | 0x000020BB | Schema update failed: duplicate OID | ERROR_DS_DUP_OID
8380 | 0x000020BC | Schema update failed: duplicate MAPI identifier. | ERROR_DS_DUP_MAPI_ID
8381 | 0x000020BD | Schema update failed: duplicate schema-id GUID. | ERROR_DS_DUP_SCHEMA_ID_GUID
8382 | 0x000020BE | Schema update failed: duplicate LDAP display name. | ERROR_DS_DUP_LDAP_DISPLAY_NAME
8383 | 0x000020BF | Schema update failed: range-lower less than range upper | ERROR_DS_SEMANTIC_ATT_TEST
8384 | 0x000020C0 | Schema update failed: syntax mismatch | ERROR_DS_SYNTAX_MISMATCH
8385 | 0x000020C1 | Schema deletion failed: attribute is used in must-contain | ERROR_DS_EXISTS_IN_MUST_HAVE
8386 | 0x000020C2 | Schema deletion failed: attribute is used in may-contain | ERROR_DS_EXISTS_IN_MAY_HAVE
8387 | 0x000020C3 | Schema update failed: attribute in may-contain does not exist | ERROR_DS_NONEXISTENT_MAY_HAVE
8388 | 0x000020C4 | Schema update failed: attribute in must-contain does not exist | ERROR_DS_NONEXISTENT_MUST_HAVE
8389 | 0x000020C5 | Schema update failed: class in aux-class list does not exist or is not an auxiliary class | ERROR_DS_AUX_CLS_TEST_FAIL
8390 | 0x000020C6 | Schema update failed: class in poss-superiors does not exist | ERROR_DS_NONEXISTENT_POSS_SUP
8391 | 0x000020C7 | Schema update failed: class in subclassof list does not exist or does not satisfy hierarchy rules | ERROR_DS_SUB_CLS_TEST_FAIL
8392 | 0x000020C8 | Schema update failed: Rdn-Att-Id has wrong syntax | ERROR_DS_BAD_RDN_ATT_ID_SYNTAX
8393 | 0x000020C9 | Schema deletion failed: class is used as auxiliary class | ERROR_DS_EXISTS_IN_AUX_CLS
8394 | 0x000020CA | Schema deletion failed: class is used as sub class | ERROR_DS_EXISTS_IN_SUB_CLS
8395 | 0x000020CB | Schema deletion failed: class is used as poss superior | ERROR_DS_EXISTS_IN_POSS_SUP
8396 | 0x000020CC | Schema update failed in recalculating validation cache. | ERROR_DS_RECALCSCHEMA_FAILED
8397 | 0x000020CD | The tree deletion is not finished. | ERROR_DS_TREE_DELETE_NOT_FINISHED
8398 | 0x000020CE | The requested delete operation could not be performed. | ERROR_DS_CANT_DELETE
8399 | 0x000020CF | Cannot read the governs class identifier for the schema record. | ERROR_DS_ATT_SCHEMA_REQ_ID
8400 | 0x000020D0 | The attribute schema has bad syntax. | ERROR_DS_BAD_ATT_SCHEMA_SYNTAX
8401 | 0x000020D1 | The attribute could not be cached. | ERROR_DS_CANT_CACHE_ATT
8402 | 0x000020D2 | The class could not be cached. | ERROR_DS_CANT_CACHE_CLASS
8403 | 0x000020D3 | The attribute could not be removed from the cache. | ERROR_DS_CANT_REMOVE_ATT_CACHE
8404 | 0x000020D4 | The class could not be removed from the cache. | ERROR_DS_CANT_REMOVE_CLASS_CACHE
8405 | 0x000020D5 | The distinguished name attribute could not be read. | ERROR_DS_CANT_RETRIEVE_DN
8406 | 0x000020D6 | A required subref is missing. | ERROR_DS_MISSING_SUPREF
8407 | 0x000020D7 | The instance type attribute could not be retrieved. | ERROR_DS_CANT_RETRIEVE_INSTANCE
8408 | 0x000020D8 | An internal error has occurred. | ERROR_DS_CODE_INCONSISTENCY
8409 | 0x000020D9 | A database error has occurred. | ERROR_DS_DATABASE_ERROR
8410 | 0x000020DA | The attribute GOVERNSID is missing. | ERROR_DS_GOVERNSID_MISSING
8411 | 0x000020DB | An expected attribute is missing. | ERROR_DS_MISSING_EXPECTED_ATT
8412 | 0x000020DC | The specified naming context is missing a cross reference. | ERROR_DS_NCNAME_MISSING_CR_REF
8413 | 0x000020DD | A security checking error has occurred. | ERROR_DS_SECURITY_CHECKING_ERROR
8414 | 0x000020DE | The schema is not loaded. | ERROR_DS_SCHEMA_NOT_LOADED
8415 | 0x000020DF | Schema allocation failed. Please check if the machine is running low on memory. | ERROR_DS_SCHEMA_ALLOC_FAILED
8416 | 0x000020E0 | Failed to obtain the required syntax for the attribute schema. | ERROR_DS_ATT_SCHEMA_REQ_SYNTAX
8417 | 0x000020E1 | The global catalog verification failed. The global catalog is not available or does not support the operation. Some part of the directory is currently not available. | ERROR_DS_GCVERIFY_ERROR
8418 | 0x000020E2 | The replication operation failed because of a schema mismatch between the servers involved. | ERROR_DS_DRA_SCHEMA_MISMATCH
8419 | 0x000020E3 | The DSA object could not be found. | ERROR_DS_CANT_FIND_DSA_OBJ
8420 | 0x000020E4 | The naming context could not be found. | ERROR_DS_CANT_FIND_EXPECTED_NC
8421 | 0x000020E5 | The naming context could not be found in the cache. | ERROR_DS_CANT_FIND_NC_IN_CACHE
8422 | 0x000020E6 | The child object could not be retrieved. | ERROR_DS_CANT_RETRIEVE_CHILD
8423 | 0x000020E7 | The modification was not permitted for security reasons. | ERROR_DS_SECURITY_ILLEGAL_MODIFY
8424 | 0x000020E8 | The operation cannot replace the hidden record. | ERROR_DS_CANT_REPLACE_HIDDEN_REC
8425 | 0x000020E9 | The hierarchy file is invalid. | ERROR_DS_BAD_HIERARCHY_FILE
8426 | 0x000020EA | The attempt to build the hierarchy table failed. | ERROR_DS_BUILD_HIERARCHY_TABLE_FAILED
8427 | 0x000020EB | The directory configuration parameter is missing from the registry. | ERROR_DS_CONFIG_PARAM_MISSING
8428 | 0x000020EC | The attempt to count the address book indices failed. | ERROR_DS_COUNTING_AB_INDICES_FAILED
8429 | 0x000020ED | The allocation of the hierarchy table failed. | ERROR_DS_HIERARCHY_TABLE_MALLOC_FAILED
8430 | 0x000020EE | The directory service encountered an internal failure. | ERROR_DS_INTERNAL_FAILURE
8431 | 0x000020EF | The directory service encountered an unknown failure. | ERROR_DS_UNKNOWN_ERROR
8432 | 0x000020F0 | A root object requires a class of 'top'. | ERROR_DS_ROOT_REQUIRES_CLASS_TOP
8433 | 0x000020F1 | This directory server is shutting down, and cannot take ownership of new floating single-master operation roles. | ERROR_DS_REFUSING_FSMO_ROLES
8434 | 0x000020F2 | The directory service is missing mandatory configuration information, and is unable to determine the ownership of floating single-master operation roles. | ERROR_DS_MISSING_FSMO_SETTINGS
8435 | 0x000020F3 | The directory service was unable to transfer ownership of one or more floating single-master operation roles to other servers. | ERROR_DS_UNABLE_TO_SURRENDER_ROLES
8436 | 0x000020F4 | The replication operation failed. | ERROR_DS_DRA_GENERIC
8437 | 0x000020F5 | An invalid parameter was specified for this replication operation. | ERROR_DS_DRA_INVALID_PARAMETER
8438 | 0x000020F6 | The directory service is too busy to complete the replication operation at this time. | ERROR_DS_DRA_BUSY
8439 | 0x000020F7 | The distinguished name specified for this replication operation is invalid. | ERROR_DS_DRA_BAD_DN
8440 | 0x000020F8 | The naming context specified for this replication operation is invalid. | ERROR_DS_DRA_BAD_NC
8441 | 0x000020F9 | The distinguished name specified for this replication operation already exists. | ERROR_DS_DRA_DN_EXISTS
8442 | 0x000020FA | The replication system encountered an internal error. | ERROR_DS_DRA_INTERNAL_ERROR
8443 | 0x000020FB | The replication operation encountered a database inconsistency. | ERROR_DS_DRA_INCONSISTENT_DIT
8444 | 0x000020FC | The server specified for this replication operation could not be contacted. | ERROR_DS_DRA_CONNECTION_FAILED
8445 | 0x000020FD | The replication operation encountered an object with an invalid instance type. | ERROR_DS_DRA_BAD_INSTANCE_TYPE
8446 | 0x000020FE | The replication operation failed to allocate memory. | ERROR_DS_DRA_OUT_OF_MEM
8447 | 0x000020FF | The replication operation encountered an error with the mail system. | ERROR_DS_DRA_MAIL_PROBLEM
8448 | 0x00002100 | The replication reference information for the target server already exists. | ERROR_DS_DRA_REF_ALREADY_EXISTS
8449 | 0x00002101 | The replication reference information for the target server does not exist. | ERROR_DS_DRA_REF_NOT_FOUND
8450 | 0x00002102 | The naming context cannot be removed because it is replicated to another server. | ERROR_DS_DRA_OBJ_IS_REP_SOURCE
8451 | 0x00002103 | The replication operation encountered a database error. | ERROR_DS_DRA_DB_ERROR
8452 | 0x00002104 | The naming context is in the process of being removed or is not replicated from the specified server. | ERROR_DS_DRA_NO_REPLICA
8453 | 0x00002105 | Replication access was denied. | ERROR_DS_DRA_ACCESS_DENIED
8454 | 0x00002106 | The requested operation is not supported by this version of the directory service. | ERROR_DS_DRA_NOT_SUPPORTED
8455 | 0x00002107 | The replication remote procedure call was cancelled. | ERROR_DS_DRA_RPC_CANCELLED
8456 | 0x00002108 | The source server is currently rejecting replication requests. | ERROR_DS_DRA_SOURCE_DISABLED
8457 | 0x00002109 | The destination server is currently rejecting replication requests. | ERROR_DS_DRA_SINK_DISABLED
8458 | 0x0000210A | The replication operation failed due to a collision of object names. | ERROR_DS_DRA_NAME_COLLISION
8459 | 0x0000210B | The replication source has been reinstalled. | ERROR_DS_DRA_SOURCE_REINSTALLED
8460 | 0x0000210C | The replication operation failed because a required parent object is missing. | ERROR_DS_DRA_MISSING_PARENT
8461 | 0x0000210D | The replication operation was preempted. | ERROR_DS_DRA_PREEMPTED
8462 | 0x0000210E | The replication synchronization attempt was abandoned because of a lack of updates. | ERROR_DS_DRA_ABANDON_SYNC
8463 | 0x0000210F | The replication operation was terminated because the system is shutting down. | ERROR_DS_DRA_SHUTDOWN
8464 | 0x00002110 | The replication synchronization attempt failed as the destination partial attribute set is not a subset of source partial attribute set. | ERROR_DS_DRA_INCOMPATIBLE_PARTIAL_SET
8465 | 0x00002111 | The replication synchronization attempt failed because a master replica attempted to sync from a partial replica. | ERROR_DS_DRA_SOURCE_IS_PARTIAL_REPLICA
8466 | 0x00002112 | The server specified for this replication operation was contacted, but that server was unable to contact an additional server needed to complete the operation. | ERROR_DS_DRA_EXTN_CONNECTION_FAILED
8467 | 0x00002113 | The version of the Active Directory schema of the source forest is not compatible with the version of Active Directory on this computer. You must upgrade the operating system on a domain controller in the source forest before this computer can be added as a domain controller to that forest. | ERROR_DS_INSTALL_SCHEMA_MISMATCH
8468 | 0x00002114 | Schema update failed: An attribute with the same link identifier already exists. | ERROR_DS_DUP_LINK_ID
8469 | 0x00002115 | Name translation: Generic processing error. | ERROR_DS_NAME_ERROR_RESOLVING
8470 | 0x00002116 | Name translation: Could not find the name or insufficient right to see name. | ERROR_DS_NAME_ERROR_NOT_FOUND
8471 | 0x00002117 | Name translation: Input name mapped to more than one output name. | ERROR_DS_NAME_ERROR_NOT_UNIQUE
8472 | 0x00002118 | Name translation: Input name found, but not the associated output format. | ERROR_DS_NAME_ERROR_NO_MAPPING
8473 | 0x00002119 | Name translation: Unable to resolve completely, only the domain was found. | ERROR_DS_NAME_ERROR_DOMAIN_ONLY
8474 | 0x0000211A | Name translation: Unable to perform purely syntactical mapping at the client without going out to the wire. | ERROR_DS_NAME_ERROR_NO_SYNTACTICAL_MAPPING
8475 | 0x0000211B | Modification of a constructed att is not allowed. | ERROR_DS_CONSTRUCTED_ATT_MOD
8476 | 0x0000211C | The OM-Object-Class specified is incorrect for an attribute with the specified syntax. | ERROR_DS_WRONG_OM_OBJ_CLASS
8477 | 0x0000211D | The replication request has been posted; waiting for reply. | ERROR_DS_DRA_REPL_PENDING
8478 | 0x0000211E | The requested operation requires a directory service, and none was available. | ERROR_DS_DS_REQUIRED
8479 | 0x0000211F | The LDAP display name of the class or attribute contains non-ASCII characters. | ERROR_DS_INVALID_LDAP_DISPLAY_NAME
8480 | 0x00002120 | The requested search operation is only supported for base searches. | ERROR_DS_NON_BASE_SEARCH
8481 | 0x00002121 | The search failed to retrieve attributes from the database. | ERROR_DS_CANT_RETRIEVE_ATTS
8482 | 0x00002122 | The schema update operation tried to add a backward link attribute that has no corresponding forward link. | ERROR_DS_BACKLINK_WITHOUT_LINK
8483 | 0x00002123 | Source and destination of a cross domain move do not agree on the object's epoch number. Either source or destination does not have the latest version of the object. | ERROR_DS_EPOCH_MISMATCH
8484 | 0x00002124 | Source and destination of a cross domain move do not agree on the object's current name. Either source or destination does not have the latest version of the object. | ERROR_DS_SRC_NAME_MISMATCH
8485 | 0x00002125 | Source and destination of a cross domain move operation are identical. Caller should use local move operation instead of cross domain move operation. | ERROR_DS_SRC_AND_DST_NC_IDENTICAL
8486 | 0x00002126 | Source and destination for a cross domain move are not in agreement on the naming contexts in the forest. Either source or destination does not have the latest version of the Partitions container. | ERROR_DS_DST_NC_MISMATCH
8487 | 0x00002127 | Destination of a cross domain move is not authoritative for the destination naming context. | ERROR_DS_NOT_AUTHORITIVE_FOR_DST_NC
8488 | 0x00002128 | Source and destination of a cross domain move do not agree on the identity of the source object. Either source or destination does not have the latest version of the source object. | ERROR_DS_SRC_GUID_MISMATCH
8489 | 0x00002129 | Object being moved across domains is already known to be deleted by the destination server. The source server does not have the latest version of the source object. | ERROR_DS_CANT_MOVE_DELETED_OBJECT
8490 | 0x0000212A | Another operation which requires exclusive access to the PDC PSMO is already in progress. | ERROR_DS_PDC_OPERATION_IN_PROGRESS
8491 | 0x0000212B | A cross domain move operation failed such that the two versions of the moved object exist - one each in the source and destination domains. The destination object needs to be removed to restore the system to a consistent state. | ERROR_DS_CROSS_DOMAIN_CLEANUP_REQD
8492 | 0x0000212C | This object may not be moved across domain boundaries either because cross domain moves for this class are disallowed, or the object has some special characteristics, eg: trust account or restricted RID, which prevent its move. | ERROR_DS_ILLEGAL_XDOM_MOVE_OPERATION
8493 | 0x0000212D | Can't move objects with memberships across domain boundaries as once moved, this would violate the membership conditions of the account group. Remove the object from any account group memberships and retry. | ERROR_DS_CANT_WITH_ACCT_GROUP_MEMBERSHPS
8494 | 0x0000212E | A naming context head must be the immediate child of another naming context head, not of an interior node. | ERROR_DS_NC_MUST_HAVE_NC_PARENT
8495 | 0x0000212F | The directory cannot validate the proposed naming context name because it does not hold a replica of the naming context above the proposed naming context. Please ensure that the domain naming master role is held by a server that is configured as a global catalog server, and that the server is up to date with its replication partners. (Applies only to Windows 2000 Domain Naming masters) | ERROR_DS_CR_IMPOSSIBLE_TO_VALIDATE
8496 | 0x00002130 | Destination domain must be in native mode. | ERROR_DS_DST_DOMAIN_NOT_NATIVE
8497 | 0x00002131 | The operation can not be performed because the server does not have an infrastructure container in the domain of interest. | ERROR_DS_MISSING_INFRASTRUCTURE_CONTAINER
8498 | 0x00002132 | Cross-domain move of non-empty account groups is not allowed. | ERROR_DS_CANT_MOVE_ACCOUNT_GROUP
8499 | 0x00002133 | Cross-domain move of non-empty resource groups is not allowed. | ERROR_DS_CANT_MOVE_RESOURCE_GROUP
8500 | 0x00002134 | The search flags for the attribute are invalid. The ANR bit is valid only on attributes of Unicode or Teletex strings. | ERROR_DS_INVALID_SEARCH_FLAG
8501 | 0x00002135 | Tree deletions starting at an object which has an NC head as a descendant are not allowed. | ERROR_DS_NO_TREE_DELETE_ABOVE_NC
8502 | 0x00002136 | The directory service failed to lock a tree in preparation for a tree deletion because the tree was in use. | ERROR_DS_COULDNT_LOCK_TREE_FOR_DELETE
8503 | 0x00002137 | The directory service failed to identify the list of objects to delete while attempting a tree deletion. | ERROR_DS_COULDNT_IDENTIFY_OBJECTS_FOR_TREE_DELETE
8504 | 0x00002138 | Security Accounts Manager initialization failed because of the following error: %1. Error Status: 0x%2. Click OK to shut down the system and reboot into Directory Services Restore Mode. Check the event log for detailed information. | ERROR_DS_SAM_INIT_FAILURE
8505 | 0x00002139 | Only an administrator can modify the membership list of an administrative group. | ERROR_DS_SENSITIVE_GROUP_VIOLATION
8506 | 0x0000213A | Cannot change the primary group ID of a domain controller account. | ERROR_DS_CANT_MOD_PRIMARYGROUPID
8507 | 0x0000213B | An attempt is made to modify the base schema. | ERROR_DS_ILLEGAL_BASE_SCHEMA_MOD
8508 | 0x0000213C | Adding a new mandatory attribute to an existing class, deleting a mandatory attribute from an existing class, or adding an optional attribute to the special class Top that is not a backlink attribute (directly or through inheritance, for example, by adding or deleting an auxiliary class) is not allowed. | ERROR_DS_NONSAFE_SCHEMA_CHANGE
8509 | 0x0000213D | Schema update is not allowed on this DC because the DC is not the schema FSMO Role Owner. | ERROR_DS_SCHEMA_UPDATE_DISALLOWED
8510 | 0x0000213E | An object of this class cannot be created under the schema container. You can only create attribute-schema and class-schema objects under the schema container. | ERROR_DS_CANT_CREATE_UNDER_SCHEMA
8511 | 0x0000213F | The replica/child install failed to get the objectVersion attribute on the schema container on the source DC. Either the attribute is missing on the schema container or the credentials supplied do not have permission to read it. | ERROR_DS_INSTALL_NO_SRC_SCH_VERSION
8512 | 0x00002140 | The replica/child install failed to read the objectVersion attribute in the SCHEMA section of the file schema.ini in the system32 directory. | ERROR_DS_INSTALL_NO_SCH_VERSION_IN_INIFILE
8513 | 0x00002141 | The specified group type is invalid. | ERROR_DS_INVALID_GROUP_TYPE
8514 | 0x00002142 | Cannot nest global groups in a mixed domain if the group is security-enabled. | ERROR_DS_NO_NEST_GLOBALGROUP_IN_MIXEDDOMAIN
8515 | 0x00002143 | Cannot nest local groups in a mixed domain if the group is security-enabled. | ERROR_DS_NO_NEST_LOCALGROUP_IN_MIXEDDOMAIN
8516 | 0x00002144 | A global group cannot have a local group as a member. | ERROR_DS_GLOBAL_CANT_HAVE_LOCAL_MEMBER
8517 | 0x00002145 | A global group cannot have a universal group as a member. | ERROR_DS_GLOBAL_CANT_HAVE_UNIVERSAL_MEMBER
8518 | 0x00002146 | A universal group cannot have a local group as a member. | ERROR_DS_UNIVERSAL_CANT_HAVE_LOCAL_MEMBER
8519 | 0x00002147 | A global group cannot have a cross-domain member. | ERROR_DS_GLOBAL_CANT_HAVE_CROSSDOMAIN_MEMBER
8520 | 0x00002148 | A local group cannot have another cross-domain local group as a member. | ERROR_DS_LOCAL_CANT_HAVE_CROSSDOMAIN_LOCAL_MEMBER
8521 | 0x00002149 | A group with primary members cannot change to a security-disabled group. | ERROR_DS_HAVE_PRIMARY_MEMBERS
8522 | 0x0000214A | The schema cache load failed to convert the string default SD on a class-schema object. | ERROR_DS_STRING_SD_CONVERSION_FAILED
8523 | 0x0000214B | Only DSAs configured to be Global Catalog servers should be allowed to hold the Domain Naming Master FSMO role. (Applies only to Windows 2000 servers) | ERROR_DS_NAMING_MASTER_GC
8524 | 0x0000214C | The DSA operation is unable to proceed because of a DNS lookup failure. | ERROR_DS_LOOKUP_FAILURE
8525 | 0x0000214D | While processing a change to the DNS Host Name for an object, the Service Principal Name values could not be kept in sync. | ERROR_DS_COULDNT_UPDATE_SPNS
8526 | 0x0000214E | The Security Descriptor attribute could not be read. | ERROR_DS_CANT_RETRIEVE_SD
8527 | 0x0000214F | The object requested was not found, but an object with that key was found. | ERROR_DS_KEY_NOT_UNIQUE.
8528 | 0x00002150 | The syntax of the linked attributed being added is incorrect. Forward links can only have syntax 2.5.5.1, 2.5.5.7, and 2.5.5.14, and backlinks can only have syntax 2.5.5.1. | ERROR_DS_WRONG_LINKED_ATT_SYNTAX
8529 | 0x00002151 | Security Account Manager needs to get the boot password. | ERROR_DS_SAM_NEED_BOOTKEY_PASSWORD
8530 | 0x00002152 | Security Account Manager needs to get the boot key from floppy disk. | ERROR_DS_SAM_NEED_BOOTKEY_FLOPPY
8531 | 0x00002153 | Directory Service cannot start. | ERROR_DS_CANT_START
8532 | 0x00002154 | Directory Services could not start. | ERROR_DS_INIT_FAILURE
8533 | 0x00002155 | The connection between client and server requires packet privacy or better. | ERROR_DS_NO_PKT_PRIVACY_ON_CONNECTION
8534 | 0x00002156 | The source domain may not be in the same forest as destination. | ERROR_DS_SOURCE_DOMAIN_IN_FOREST
8535 | 0x00002157 | The destination domain must be in the forest. | ERROR_DS_DESTINATION_DOMAIN_NOT_IN_FOREST
8536 | 0x00002158 | The operation requires that destination domain auditing be enabled. | ERROR_DS_DESTINATION_AUDITING_NOT_ENABLED
8537 | 0x00002159 | The operation couldn't locate a DC for the source domain. | ERROR_DS_CANT_FIND_DC_FOR_SRC_DOMAIN
8538 | 0x0000215A | The source object must be a group or user. | ERROR_DS_SRC_OBJ_NOT_GROUP_OR_USER
8539 | 0x0000215B | The source object's SID already exists in destination forest. | ERROR_DS_SRC_SID_EXISTS_IN_FOREST
8540 | 0x0000215C | The source and destination object must be of the same type. | ERROR_DS_SRC_AND_DST_OBJECT_CLASS_MISMATCH
8541 | 0x0000215D | Security Accounts Manager initialization failed because of the following error: %1. Error Status: 0x%2. Click OK to shut down the system and reboot into Safe Mode. Check the event log for detailed information. | ERROR_SAM_INIT_FAILURE
8542 | 0x0000215E | Schema information could not be included in the replication request. | ERROR_DS_DRA_SCHEMA_INFO_SHIP
8543 | 0x0000215F | The replication operation could not be completed due to a schema incompatibility. | ERROR_DS_DRA_SCHEMA_CONFLICT
8544 | 0x00002160 | The replication operation could not be completed due to a previous schema incompatibility. | ERROR_DS_DRA_EARLIER_SCHEMA_CONLICT
8545 | 0x00002161 | The replication update could not be applied because either the source or the destination has not yet received information regarding a recent cross-domain move operation. | ERROR_DS_DRA_OBJ_NC_MISMATCH
8546 | 0x00002162 | The requested domain could not be deleted because there exist domain controllers that still host this domain. | ERROR_DS_NC_STILL_HAS_DSAS
8547 | 0x00002163 | The requested operation can be performed only on a global catalog server. | ERROR_DS_GC_REQUIRED
8548 | 0x00002164 | A local group can only be a member of other local groups in the same domain. | ERROR_DS_LOCAL_MEMBER_OF_LOCAL_ONLY
8549 | 0x00002165 | Foreign security principals cannot be members of universal groups. | ERROR_DS_NO_FPO_IN_UNIVERSAL_GROUPS
8550 | 0x00002166 | The attribute is not allowed to be replicated to the GC because of security reasons. | ERROR_DS_CANT_ADD_TO_GC
8551 | 0x00002167 | The checkpoint with the PDC could not be taken because there are too many modifications being processed currently. | ERROR_DS_NO_CHECKPOINT_WITH_PDC
8552 | 0x00002168 | The operation requires that source domain auditing be enabled. | ERROR_DS_SOURCE_AUDITING_NOT_ENABLED
8553 | 0x00002169 | Security principal objects can only be created inside domain naming contexts. | ERROR_DS_CANT_CREATE_IN_NONDOMAIN_NC
8554 | 0x0000216A | A Service Principal Name (SPN) could not be constructed because the provided hostname is not in the necessary format. | ERROR_DS_INVALID_NAME_FOR_SPN
8555 | 0x0000216B | A Filter was passed that uses constructed attributes. | ERROR_DS_FILTER_USES_CONTRUCTED_ATTRS
8556 | 0x0000216C | The unicodePwd attribute value must be enclosed in double quotes. | ERROR_DS_UNICODEPWD_NOT_IN_QUOTES
8557 | 0x0000216D | Your computer could not be joined to the domain. You have exceeded the maximum number of computer accounts you are allowed to create in this domain. Contact your system administrator to have this limit reset or increased. | ERROR_DS_MACHINE_ACCOUNT_QUOTA_EXCEEDED
8558 | 0x0000216E | For security reasons, the operation must be run on the destination DC. | ERROR_DS_MUST_BE_RUN_ON_DST_DC
8559 | 0x0000216F | For security reasons, the source DC must be NT4SP4 or greater. | ERROR_DS_SRC_DC_MUST_BE_SP4_OR_GREATER
8560 | 0x00002170 | Critical Directory Service System objects cannot be deleted during tree delete operations. The tree delete may have been partially performed. | ERROR_DS_CANT_TREE_DELETE_CRITICAL_OBJ
8561 | 0x00002171 | Directory Services could not start because of the following error: %1. Error Status: 0x%2. Please click OK to shutdown the system. You can use the recovery console to diagnose the system further. | ERROR_DS_INIT_FAILURE_CONSOLE
8562 | 0x00002172 | Security Accounts Manager initialization failed because of the following error: %1. Error Status: 0x%2. Please click OK to shutdown the system. You can use the recovery console to diagnose the system further. | ERROR_DS_SAM_INIT_FAILURE_CONSOLE
8563 | 0x00002173 | This version of Windows is too old to support the current directory forest behavior. You must upgrade the operating system on this server before it can become a domain controller in this forest. | ERROR_DS_FOREST_VERSION_TOO_HIGH
8564 | 0x00002174 | This version of Windows is too old to support the current domain behavior. You must upgrade the operating system on this server before it can become a domain controller in this domain. | ERROR_DS_DOMAIN_VERSION_TOO_HIGH
8565 | 0x00002175 | This version of Windows no longer supports the behavior version in use in this directory forest. You must advance the forest behavior version before this server can become a domain controller in the forest. | ERROR_DS_FOREST_VERSION_TOO_LOW
8566 | 0x00002176 | This version of Windows no longer supports the behavior version in use in this domain. You must advance the domain behavior version before this server can become a domain controller in the domain. | ERROR_DS_DOMAIN_VERSION_TOO_LOW
8567 | 0x00002177 | The version of Windows is incompatible with the behavior version of the domain or forest. | ERROR_DS_INCOMPATIBLE_VERSION
8568 | 0x00002178 | The behavior version cannot be increased to the requested value because Domain Controllers still exist with versions lower than the requested value. | ERROR_DS_LOW_DSA_VERSION
8569 | 0x00002179 | The behavior version value cannot be increased while the domain is still in mixed domain mode. You must first change the domain to native mode before increasing the behavior version. | ERROR_DS_NO_BEHAVIOR_VERSION_IN_MIXEDDOMAIN
8570 | 0x0000217A | The sort order requested is not supported. | ERROR_DS_NOT_SUPPORTED_SORT_ORDER
8571 | 0x0000217B | Found an object with a non unique name. | ERROR_DS_NAME_NOT_UNIQUE
8572 | 0x0000217C | The machine account was created pre-NT4. The account needs to be recreated. | ERROR_DS_MACHINE_ACCOUNT_CREATED_PRENT4
8573 | 0x0000217D | The database is out of version store. | ERROR_DS_OUT_OF_VERSION_STORE
8574 | 0x0000217E | Unable to continue operation because multiple conflicting controls were used. | ERROR_DS_INCOMPATIBLE_CONTROLS_USED
8575 | 0x0000217F | Unable to find a valid security descriptor reference domain for this partition. | ERROR_DS_NO_REF_DOMAIN
8576 | 0x00002180 | Schema update failed: The link identifier is reserved. | ERROR_DS_RESERVED_LINK_ID
8577 | 0x00002181 | Schema update failed: There are no link identifiers available. | ERROR_DS_LINK_ID_NOT_AVAILABLE
8578 | 0x00002182 | An account group can not have a universal group as a member. | ERROR_DS_AG_CANT_HAVE_UNIVERSAL_MEMBER
8579 | 0x00002183 | Rename or move operations on naming context heads or read-only objects are not allowed. | ERROR_DS_MODIFYDN_DISALLOWED_BY_INSTANCE_TYPE
8580 | 0x00002184 | Move operations on objects in the schema naming context are not allowed. | ERROR_DS_NO_OBJECT_MOVE_IN_SCHEMA_NC
8581 | 0x00002185 | A system flag has been set on the object and does not allow the object to be moved or renamed. | ERROR_DS_MODIFYDN_DISALLOWED_BY_FLAG
8582 | 0x00002186 | This object is not allowed to change its grandparent container. Moves are not forbidden on this object, but are restricted to sibling containers. | ERROR_DS_MODIFYDN_WRONG_GRANDPARENT
8583 | 0x00002187 | Unable to resolve completely, a referral to another forest is generated. | ERROR_DS_NAME_ERROR_TRUST_REFERRAL
8584 | 0x00002188 | The requested action is not supported on standard server. | ERROR_NOT_SUPPORTED_ON_STANDARD_SERVER
8585 | 0x00002189 | Could not access a partition of the Active Directory located on a remote server. Make sure at least one server is running for the partition in question. | ERROR_DS_CANT_ACCESS_REMOTE_PART_OF_AD
8586 | 0x0000218A | The directory cannot validate the proposed naming context (or partition) name because it does not hold a replica nor can it contact a replica of the naming context above the proposed naming context. Please ensure that the parent naming context is properly registered in DNS, and at least one replica of this naming context is reachable by the Domain Naming master. | ERROR_DS_CR_IMPOSSIBLE_TO_VALIDATE
8587 | 0x0000218B | The thread limit for this request was exceeded. | ERROR_DS_THREAD_LIMIT_EXCEEDED
8588 | 0x0000218C | The Global catalog server is not in the closet site. | ERROR_DS_NOT_CLOSEST
9001 | 0x00002329 | DNS server unable to interpret format. | DNS_ERROR_RCODE_FORMAT_ERROR
9002 | 0x0000232A | DNS server failure. | DNS_ERROR_RCODE_SERVER_FAILURE
9003 | 0x0000232B | DNS name does not exist. | DNS_ERROR_RCODE_NAME_ERROR
9004 | 0x0000232C | DNS request not supported by name server. | DNS_ERROR_RCODE_NOT_IMPLEMENTED
9005 | 0x0000232D | DNS operation refused. | DNS_ERROR_RCODE_REFUSED
9006 | 0x0000232E | DNS name that ought not exist, does exist. | DNS_ERROR_RCODE_YXDOMAIN
9007 | 0x0000232F | DNS RR set that ought not exist, does exist. | DNS_ERROR_RCODE_YXRRSET
9008 | 0x00002330 | DNS RR set that ought to exist, does not exist. | DNS_ERROR_RCODE_NXRRSET
9009 | 0x00002331 | DNS server not authoritative for zone. | DNS_ERROR_RCODE_NOTAUTH
9010 | 0x00002332 | DNS name in update or prereq is not in zone. | DNS_ERROR_RCODE_NOTZONE
9016 | 0x00002338 | DNS signature failed to verify. | DNS_ERROR_RCODE_BADSIG
9017 | 0x00002339 | DNS bad key. | DNS_ERROR_RCODE_BADKEY
9018 | 0x0000233A | DNS signature validity expired. | DNS_ERROR_RCODE_BADTIME
9501 | 0x0000251D | No records found for given DNS query. | DNS_INFO_NO_RECORDS
9502 | 0x0000251E | Bad DNS packet. | DNS_ERROR_BAD_PACKET
9503 | 0x0000251F | No DNS packet. | DNS_ERROR_NO_PACKET
9504 | 0x00002520 | DNS error, check rcode. | DNS_ERROR_RCODE
9505 | 0x00002521 | Unsecured DNS packet. | DNS_ERROR_UNSECURE_PACKET
9551 | 0x0000254F | Invalid DNS type. | DNS_ERROR_INVALID_TYPE
9552 | 0x00002550 | Invalid IP address. | DNS_ERROR_INVALID_IP_ADDRESS
9553 | 0x00002551 | Invalid property. | DNS_ERROR_INVALID_PROPERTY
9554 | 0x00002552 | Try DNS operation again later. | DNS_ERROR_TRY_AGAIN_LATER
9555 | 0x00002553 | Record for given name and type is not unique. | DNS_ERROR_NOT_UNIQUE
9556 | 0x00002554 | DNS name does not comply with RFC specifications. | DNS_ERROR_NON_RFC_NAME
9557 | 0x00002555 | DNS name is a fully-qualified DNS name. | DNS_STATUS_FQDN
9558 | 0x00002556 | DNS name is dotted (multi-label). | DNS_STATUS_DOTTED_NAME
9559 | 0x00002557 | DNS name is a single-part name. | DNS_STATUS_SINGLE_PART_NAME
9560 | 0x00002558 | DSN name contains an invalid character. | DNS_ERROR_INVALID_NAME_CHAR
9561 | 0x00002559 | DNS name is entirely numeric. | DNS_ERROR_NUMERIC_NAME
9601 | 0x00002581 | DNS zone does not exist. | DNS_ERROR_ZONE_DOES_NOT_EXIST
9602 | 0x00002582 | DNS zone information not available. | DNS_ERROR_NO_ZONE_INFO
9603 | 0x00002583 | Invalid operation for DNS zone. | DNS_ERROR_INVALID_ZONE_OPERATION
9604 | 0x00002584 | Invalid DNS zone configuration. | DNS_ERROR_ZONE_CONFIGURATION_ERROR
9605 | 0x00002585 | DNS zone has no start of authority (SOA) record. | DNS_ERROR_ZONE_HAS_NO_SOA_RECORD
9606 | 0x00002586 | DNS zone has no name server (NS) record. | DNS_ERROR_ZONE_HAS_NO_NS_RECORDS
9607 | 0x00002587 | DNS zone is locked. | DNS_ERROR_ZONE_LOCKED
9608 | 0x00002588 | DNS zone creation failed. | DNS_ERROR_ZONE_CREATION_FAILED
9609 | 0x00002589 | DNS zone already exists. | DNS_ERROR_ZONE_ALREADY_EXISTS
9610 | 0x0000258A | DNS automatic zone already exists. | DNS_ERROR_AUTOZONE_ALREADY_EXISTS
9611 | 0x0000258B | Invalid DNS zone type. | DNS_ERROR_INVALID_ZONE_TYPE
9612 | 0x0000258C | Secondary DNS zone requires master IP address. | DNS_ERROR_SECONDARY_REQUIRES_MASTER_IP
9613 | 0x0000258D | DNS zone not secondary. | DNS_ERROR_ZONE_NOT_SECONDARY
9614 | 0x0000258E | Need secondary IP address. | DNS_ERROR_NEED_SECONDARY_ADDRESSES
9615 | 0x0000258F | WINS initialization failed. | DNS_ERROR_WINS_INIT_FAILED
9616 | 0x00002590 | Need WINS servers. | DNS_ERROR_NEED_WINS_SERVERS
9617 | 0x00002591 | NBTSTAT initialization call failed. | DNS_ERROR_NBSTAT_INIT_FAILED
9618 | 0x00002592 | Invalid delete of start of authority (SOA) | DNS_ERROR_SOA_DELETE_INVALID
9619 | 0x00002593 | A conditional forwarding zone already exists for that name. | DNS_ERROR_FORWARDER_ALREADY_EXISTS
9651 | 0x000025B3 | Primary DNS zone requires datafile. | DNS_ERROR_PRIMARY_REQUIRES_DATAFILE
9652 | 0x000025B4 | Invalid datafile name for DNS zone. | DNS_ERROR_INVALID_DATAFILE_NAME
9653 | 0x000025B5 | Failed to open datafile for DNS zone. | DNS_ERROR_DATAFILE_OPEN_FAILURE
9654 | 0x000025B6 | Failed to write datafile for DNS zone. | DNS_ERROR_FILE_WRITEBACK_FAILED
9655 | 0x000025B7 | Failure while reading datafile for DNS zone. | DNS_ERROR_DATAFILE_PARSING
9701 | 0x000025E5 | DNS record does not exist. | DNS_ERROR_RECORD_DOES_NOT_EXIST
9702 | 0x000025E6 | DNS record format error. | DNS_ERROR_RECORD_FORMAT
9703 | 0x000025E7 | Node creation failure in DNS. | DNS_ERROR_NODE_CREATION_FAILED
9704 | 0x000025E8 | Unknown DNS record type. | DNS_ERROR_UNKNOWN_RECORD_TYPE
9705 | 0x000025E9 | DNS record timed out. | DNS_ERROR_RECORD_TIMED_OUT
9706 | 0x000025EA | Name not in DNS zone. | DNS_ERROR_NAME_NOT_IN_ZONE
9707 | 0x000025EB | CNAME loop detected. | DNS_ERROR_CNAME_LOOP
9708 | 0x000025EC | Node is a CNAME DNS record. | DNS_ERROR_NODE_IS_CNAME
9709 | 0x000025ED | A CNAME record already exists for given name. | DNS_ERROR_CNAME_COLLISION
9710 | 0x000025EE | Record only at DNS zone root. | DNS_ERROR_RECORD_ONLY_AT_ZONE_ROOT
9711 | 0x000025EF | DNS record already exists. | DNS_ERROR_RECORD_ALREADY_EXISTS
9712 | 0x000025F0 | Secondary DNS zone data error. | DNS_ERROR_SECONDARY_DATA
9713 | 0x000025F1 | Could not create DNS cache data. | DNS_ERROR_NO_CREATE_CACHE_DATA
9714 | 0x000025F2 | DNS name does not exist. | DNS_ERROR_NAME_DOES_NOT_EXIST
9715 | 0x000025F3 | Could not create pointer (PTR) record. | DNS_WARNING_PTR_CREATE_FAILED
9716 | 0x000025F4 | DNS domain was undeleted. | DNS_WARNING_DOMAIN_UNDELETED
9717 | 0x000025F5 | The directory service is unavailable. | DNS_ERROR_DS_UNAVAILABLE
9718 | 0x000025F6 | DNS zone already exists in the directory service. | DNS_ERROR_DS_ZONE_ALREADY_EXISTS
9719 | 0x000025F7 | DNS server not creating or reading the boot file for the directory service integrated DNS zone. | DNS_ERROR_NO_BOOTFILE_IF_DS_ZONE
9751 | 0x00002617 | DNS AXFR (zone transfer) complete. | DNS_INFO_AXFR_COMPLETE
9752 | 0x00002618 | DNS zone transfer failed. | DNS_ERROR_AXFR
9753 | 0x00002619 | Added local WINS server. | DNS_INFO_ADDED_LOCAL_WINS
9801 | 0x00002649 | Secure update call needs to continue update request. | DNS_STATUS_CONTINUE_NEEDED
9851 | 0x0000267B | TCP/IP network protocol not installed. | DNS_ERROR_NO_TCPIP
9852 | 0x0000267C | No DNS servers configured for local system. | DNS_ERROR_NO_DNS_SERVERS
9901 | 0x000026AD | The specified directory partition does not exist. | DNS_ERROR_DP_DOES_NOT_EXIST
9902 | 0x000026AE | The specified directory partition already exists. | DNS_ERROR_DP_ALREADY_EXISTS
9903 | 0x000026AF | The DS is not enlisted in the specified directory partition. | DNS_ERROR_DP_NOT_ENLISTED
9904 | 0x000026B0 | The DS is already enlisted in the specified directory partition. | DNS_ERROR_DP_ALREADY_ENLISTED
10004 | 0x00002714 | A blocking operation was interrupted by a call to WSACancelBlockingCall. | WSAEINTR
10009 | 0x00002719 | The file handle supplied is not valid. | WSAEBADF
10013 | 0x0000271D | An attempt was made to access a socket in a way forbidden by its access permissions. | WSAEACCES
10014 | 0x0000271E | The system detected an invalid pointer address in attempting to use a pointer argument in a call. | WSAEFAULT
10022 | 0x00002726 | An invalid argument was supplied. | WSAEINVAL
10024 | 0x00002728 | Too many open sockets. | WSAEMFILE
10035 | 0x00002733 | A non-blocking socket operation could not be completed immediately. | WSAEWOULDBLOCK
10036 | 0x00002734 | A blocking operation is currently executing. | WSAEINPROGRESS
10037 | 0x00002735 | An operation was attempted on a non-blocking socket that already had an operation in progress. | WSAEALREADY
10038 | 0x00002736 | An operation was attempted on something that is not a socket. | WSAENOTSOCK
10039 | 0x00002737 | A required address was omitted from an operation on a socket. | WSAEDESTADDRREQ
10040 | 0x00002738 | A message sent on a datagram socket was larger than the internal message buffer or some other network limit, or the buffer used to receive a datagram into was smaller than the datagram itself. | WSAEMSGSIZE
10041 | 0x00002739 | A protocol was specified in the socket function call that does not support the semantics of the socket type requested. | WSAEPROTOTYPE
10042 | 0x0000273A | An unknown, invalid, or unsupported option or level was specified in a getsockopt or setsockopt call. | WSAENOPROTOOPT
10043 | 0x0000273B | The requested protocol has not been configured into the system, or no implementation for it exists. | WSAEPROTONOSUPPORT
10044 | 0x0000273C | The support for the specified socket type does not exist in this address family. | WSAESOCKTNOSUPPORT
10045 | 0x0000273D | The attempted operation is not supported for the type of object referenced. | WSAEOPNOTSUPP
10046 | 0x0000273E | The protocol family has not been configured into the system or no implementation for it exists. | WSAEPFNOSUPPORT
10047 | 0x0000273F | An address incompatible with the requested protocol was used. | WSAEAFNOSUPPORT
10048 | 0x00002740 | Only one usage of each socket address (protocol/network address/port) is normally permitted. | WSAEADDRINUSE
10049 | 0x00002741 | The requested address is not valid in its context. | WSAEADDRNOTAVAIL
10050 | 0x00002742 | A socket operation encountered a dead network. | WSAENETDOWN
10051 | 0x00002743 | A socket operation was attempted to an unreachable network. | WSAENETUNREACH
10052 | 0x00002744 | The connection has been broken due to keep-alive activity detecting a failure while the operation was in progress. | WSAENETRESET
10053 | 0x00002745 | An established connection was aborted by the software in your host machine. | WSAECONNABORTED
10054 | 0x00002746 | An existing connection was forcibly closed by the remote host. | WSAECONNRESET
10055 | 0x00002747 | An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full. | WSAENOBUFS
10056 | 0x00002748 | A connect request was made on an already connected socket. | WSAEISCONN
10057 | 0x00002749 | A request to send or receive data was disallowed because the socket is not connected and (when sending on a datagram socket using a sendto call) no address was supplied. | WSAENOTCONN
10058 | 0x0000274A | A request to send or receive data was disallowed because the socket had already been shut down in that direction with a previous shutdown call. | WSAESHUTDOWN
10059 | 0x0000274B | Too many references to some kernel object. | WSAETOOMANYREFS
10060 | 0x0000274C | A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. | WSAETIMEDOUT
10061 | 0x0000274D | No connection could be made because the target machine actively refused it. | WSAECONNREFUSED
10062 | 0x0000274E | Cannot translate name. | WSAELOOP
10063 | 0x0000274F | Name component or name was too long. | WSAENAMETOOLONG
10064 | 0x00002750 | A socket operation failed because the destination host was down. | WSAEHOSTDOWN
10065 | 0x00002751 | A socket operation was attempted to an unreachable host. | WSAEHOSTUNREACH
10066 | 0x00002752 | Cannot remove a directory that is not empty. | WSAENOTEMPTY
10067 | 0x00002753 | A Windows Sockets implementation may have a limit on the number of applications that may use it simultaneously. | WSAEPROCLIM
10068 | 0x00002754 | Ran out of quota. | WSAEUSERS
10069 | 0x00002755 | Ran out of disk quota. | WSAEDQUOT
10070 | 0x00002756 | File handle reference is no longer available. | WSAESTALE
10071 | 0x00002757 | Item is not available locally. | WSAEREMOTE
10091 | 0x0000276B | WSAStartup cannot function at this time because the underlying system it uses to provide network services is currently unavailable. | WSASYSNOTREADY
10092 | 0x0000276C | The Windows Sockets version requested is not supported. | WSAVERNOTSUPPORTED
10093 | 0x0000276D | Either the application has not called WSAStartup, or WSAStartup failed. | WSANOTINITIALISED
10101 | 0x00002775 | Returned by WSARecv or WSARecvFrom to indicate the remote party has initiated a graceful shutdown sequence. | WSAEDISCON
10102 | 0x00002776 | No more results can be returned by WSALookupServiceNext. | WSAENOMORE
10103 | 0x00002777 | A call to WSALookupServiceEnd was made while this call was still processing. The call has been canceled. | WSAECANCELLED
10104 | 0x00002778 | The procedure call table is invalid. | WSAEINVALIDPROCTABLE
10105 | 0x00002779 | The requested service provider is invalid. | WSAEINVALIDPROVIDER
10106 | 0x0000277A | The requested service provider could not be loaded or initialized. | WSAEPROVIDERFAILEDINIT
10107 | 0x0000277B | A system call that should never fail has failed. | WSASYSCALLFAILURE
10108 | 0x0000277C | No such service is known. The service cannot be found in the specified name space. | WSASERVICE_NOT_FOUND
10109 | 0x0000277D | The specified class was not found. | WSATYPE_NOT_FOUND
10110 | 0x0000277E | No more results can be returned by WSALookupServiceNext. | WSA_E_NO_MORE
10111 | 0x0000277F | A call to WSALookupServiceEnd was made while this call was still processing. The call has been canceled. | WSA_E_CANCELLED
10112 | 0x00002780 | A database query failed because it was actively refused. | WSAEREFUSED
11001 | 0x00002AF9 | No such host is known. | WSAHOST_NOT_FOUND
11002 | 0x00002AFA | This is usually a temporary error during hostname resolution and means that the local server did not receive a response from an authoritative server. | WSATRY_AGAIN
11003 | 0x00002AFB | A non-recoverable error occurred during a database lookup. | WSANO_RECOVERY
11004 | 0x00002AFC | The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for. | WSANO_DATA
11005 | 0x00002AFD | At least one reserve has arrived. | WSA_QOS_RECEIVERS
11006 | 0x00002AFE | At least one path has arrived. | WSA_QOS_SENDERS
11007 | 0x00002AFF | There are no senders. | WSA_QOS_NO_SENDERS
11008 | 0x00002B00 | There are no receivers. | WSA_QOS_NO_RECEIVERS
11009 | 0x00002B01 | Reserve has been confirmed. | WSA_QOS_REQUEST_CONFIRMED
11010 | 0x00002B02 | Error due to lack of resources. | WSA_QOS_ADMISSION_FAILURE
11011 | 0x00002B03 | Rejected for administrative reasons - bad credentials. | WSA_QOS_POLICY_FAILURE
11012 | 0x00002B04 | Unknown or conflicting style. | WSA_QOS_BAD_STYLE
11013 | 0x00002B05 | Problem with some part of the filterspec or providerspecific buffer in general. | WSA_QOS_BAD_OBJECT
11014 | 0x00002B06 | Problem with some part of the flowspec. | WSA_QOS_TRAFFIC_CTRL_ERROR
11015 | 0x00002B07 | General QOS error. | WSA_QOS_GENERIC_ERROR
11016 | 0x00002B08 | An invalid or unrecognized service type was found in the flowspec. | WSA_QOS_ESERVICETYPE
11017 | 0x00002B09 | An invalid or inconsistent flowspec was found in the QOS structure. | WSA_QOS_EFLOWSPEC
11018 | 0x00002B0A | Invalid QOS provider-specific buffer. | WSA_QOS_EPROVSPECBUF
11019 | 0x00002B0B | An invalid QOS filter style was used. | WSA_QOS_EFILTERSTYLE
11020 | 0x00002B0C | An invalid QOS filter type was used. | WSA_QOS_EFILTERTYPE
11021 | 0x00002B0D | An incorrect number of QOS FILTERSPECs were specified in the FLOWDESCRIPTOR. | WSA_QOS_EFILTERCOUNT
11022 | 0x00002B0E | An object with an invalid ObjectLength field was specified in the QOS provider-specific buffer. | WSA_QOS_EOBJLENGTH
11023 | 0x00002B0F | An incorrect number of flow descriptors was specified in the QOS structure. | WSA_QOS_EFLOWCOUNT
11024 | 0x00002B10 | An unrecognized object was found in the QOS provider-specific buffer. | WSA_QOS_EUNKNOWNPSOBJ
11025 | 0x00002B11 | An invalid policy object was found in the QOS provider-specific buffer. | WSA_QOS_EPOLICYOBJ
11026 | 0x00002B12 | An invalid QOS flow descriptor was found in the flow descriptor list. | WSA_QOS_EFLOWDESC
11027 | 0x00002B13 | An invalid or inconsistent flowspec was found in the QOS provider-specific buffer. | WSA_QOS_EPSFLOWSPEC
11028 | 0x00002B14 | An invalid FILTERSPEC was found in the QOS provider-specific buffer. | WSA_QOS_EPSFILTERSPEC
11029 | 0x00002B15 | An invalid shape discard mode object was found in the QOS provider-specific buffer. | WSA_QOS_ESDMODEOBJ
11030 | 0x00002B16 | An invalid shaping rate object was found in the QOS provider-specific buffer. | WSA_QOS_ESHAPERATEOBJ
11031 | 0x00002B17 | A reserved policy element was found in the QOS provider-specific buffer. | WSA_QOS_RESERVED_PETYPE
12000 | 0x00002EE0 | The requested section was not present in the activation context. | ERROR_SXS_SECTION_NOT_FOUND
12001 | 0x00002EE1 | This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem. | ERROR_SXS_CANT_GEN_ACTCTX
12002 | 0x00002EE2 | The application binding data format is invalid. | ERROR_SXS_INVALID_ACTCTXDATA_FORMAT
12003 | 0x00002EE3 | The referenced assembly is not installed on your system. | ERROR_SXS_ASSEMBLY_NOT_FOUND
12004 | 0x00002EE4 | The manifest file does not begin with the required tag and format information. | ERROR_SXS_MANIFEST_FORMAT_ERROR
12005 | 0x00002EE5 | The manifest file contains one or more syntax errors. | ERROR_SXS_MANIFEST_PARSE_ERROR
12006 | 0x00002EE6 | The application attempted to activate a disabled activation context. | ERROR_SXS_ACTIVATION_CONTEXT_DISABLED
12007 | 0x00002EE7 | The requested lookup key was not found in any active activation context. | ERROR_SXS_KEY_NOT_FOUND
12008 | 0x00002EE8 | A component version required by the application conflicts with another component version already active. | ERROR_SXS_VERSION_CONFLICT
12009 | 0x00002EE9 | The type requested activation context section does not match the query API used. | ERROR_SXS_WRONG_SECTION_TYPE
12010 | 0x00002EEA | Lack of system resources has required isolated activation to be disabled for the current thread of execution. | ERROR_SXS_THREAD_QUERIES_DISABLED
12011 | 0x00002EEB | An attempt to set the process default activation context failed because the process default activation context was already set. | ERROR_SXS_PROCESS_DEFAULT_ALREADY_SET
12012 | 0x00002EEC | The encoding group identifier specified is not recognized. | ERROR_SXS_UNKNOWN_ENCODING_GROUP
12013 | 0x00002EED | The encoding requested is not recognized. | ERROR_SXS_UNKNOWN_ENCODING
12014 | 0x00002EEE | The manifest contains a reference to an invalid URI. | ERROR_SXS_INVALID_XML_NAMESPACE_URI
12015 | 0x00002EEF | The application manifest contains a reference to a dependent assembly which is not installed. | ERROR_SXS_ROOT_MANIFEST_DEPENDENCY_NOT_INSTALLED
12016 | 0x00002EF0 | The manifest for an assembly used by the application has a reference to a dependent assembly which is not installed. | ERROR_SXS_LEAF_MANIFEST_DEPENDENCY_NOT_INSTALLED
12017 | 0x00002EF1 | The manifest contains an attribute for the assembly identity which is not valid. | ERROR_SXS_INVALID_ASSEMBLY_IDENTITY_ATTRIBUTE
12018 | 0x00002EF2 | The manifest is missing the required default namespace specification on the assembly element. | ERROR_SXS_MANIFEST_MISSING_REQUIRED_ DEFAULT_NAMESPACE
12019 | 0x00002EF3 | The manifest has a default namespace specified on the assembly element but its value is not "urn:schemas-microsoft-com:asm.v1". | ERROR_SXS_MANIFEST_INVALID_REQUIRED_ DEFAULT_NAMESPACE
12020 | 0x00002EF4 | The private manifest probe has crossed the reparse-point-associated path. | ERROR_SXS_PRIVATE_MANIFEST_CROSS_PATH_ WITH_REPARSE_POINT
12021 | 0x00002EF5 | Two or more components referenced directly or indirectly by the application manifest have files by the same name. | ERROR_SXS_DUPLICATE_DLL_NAME
12022 | 0x00002EF6 | Two or more components referenced directly or indirectly by the application manifest have window classes with the same name. | ERROR_SXS_DUPLICATE_WINDOWCLASS_NAME
12023 | 0x00002EF7 | Two or more components referenced directly or indirectly by the application manifest have the same COM server CLSIDs. | ERROR_SXS_DUPLICATE_CLSID
12024 | 0x00002EF8 | Two or more components referenced directly or indirectly by the application manifest have proxies for the same COM interface IIDs. | ERROR_SXS_DUPLICATE_IID
12025 | 0x00002EF9 | Two or more components referenced directly or indirectly by the application manifest have the same COM type library TLBIDs. | ERROR_SXS_DUPLICATE_TLBID
12026 | 0x00002EFA | Two or more components referenced directly or indirectly by the application manifest have the same COM ProgIDs. | ERROR_SXS_DUPLICATE_PROGID
12027 | 0x00002EFB | Two or more components referenced directly or indirectly by the application manifest are different versions of the same component which is not permitted. | ERROR_SXS_DUPLICATE_ASSEMBLY_NAME
12028 | 0x00002EFC | A component's file does not match the verification information present in the component manifest. | ERROR_SXS_FILE_HASH_MISMATCH
12029 | 0x00002EFD | The policy manifest contains one or more syntax errors. | ERROR_SXS_POLICY_PARSE_ERROR
12030 | 0x00002EFE | Manifest Parse Error : A string literal was expected, but no opening quote character was found. | ERROR_SXS_XML_E_MISSINGQUOTE
12031 | 0x00002EFF | Manifest Parse Error : Incorrect syntax was used in a comment. | ERROR_SXS_XML_E_COMMENTSYNTAX
12032 | 0x00002F00 | Manifest Parse Error : A name was started with an invalid character. | ERROR_SXS_XML_E_BADSTARTNAMECHAR
12033 | 0x00002F01 | Manifest Parse Error : A name contained an invalid character. | ERROR_SXS_XML_E_BADNAMECHAR
12034 | 0x00002F02 | Manifest Parse Error : A string literal contained an invalid character. | ERROR_SXS_XML_E_BADCHARINSTRING
12035 | 0x00002F03 | Manifest Parse Error : Invalid syntax for an XML declaration. | ERROR_SXS_XML_E_XMLDECLSYNTAX
12036 | 0x00002F04 | Manifest Parse Error : An invalid character was found in text content. | ERROR_SXS_XML_E_BADCHARDATA
12037 | 0x00002F05 | Manifest Parse Error : Required white space was missing. | ERROR_SXS_XML_E_MISSINGWHITESPACE
12038 | 0x00002F06 | Manifest Parse Error : The character '>' was expected. | ERROR_SXS_XML_E_EXPECTINGTAGEND
12039 | 0x00002F07 | Manifest Parse Error : A semi colon character was expected. | ERROR_SXS_XML_E_MISSINGSEMICOLON
12040 | 0x00002F08 | Manifest Parse Error : Unbalanced parentheses. | ERROR_SXS_XML_E_UNBALANCEDPAREN
12041 | 0x00002F09 | Manifest Parse Error : Internal error. | ERROR_SXS_XML_E_INTERNALERROR
12042 | 0x00002F0A | Manifest Parse Error : White space is not allowed at this location. | ERROR_SXS_XML_E_UNEXPECTED_WHITESPACE
12043 | 0x00002F0B | Manifest Parse Error : End of file reached in invalid state for current encoding. | ERROR_SXS_XML_E_INCOMPLETE_ENCODING
12044 | 0x00002F0C | Manifest Parse Error : Missing parenthesis. | ERROR_SXS_XML_E_MISSING_PAREN
12045 | 0x00002F0D | Manifest Parse Error : A single or double closing quote character (\' or \") is missing. | ERROR_SXS_XML_E_EXPECTINGCLOSEQUOTE
12046 | 0x00002F0E | Manifest Parse Error : Multiple colons are not allowed in a name. | ERROR_SXS_XML_E_MULTIPLE_COLONS
12047 | 0x00002F0F | Manifest Parse Error : Invalid character for decimal digit. | ERROR_SXS_XML_E_INVALID_DECIMAL
12048 | 0x00002F10 | Manifest Parse Error : Invalid character for hexadecimal digit. | ERROR_SXS_XML_E_INVALID_HEXIDECIMAL
12049 | 0x00002F11 | Manifest Parse Error : Invalid Unicode character value for this platform. | ERROR_SXS_XML_E_INVALID_UNICODE
12050 | 0x00002F12 | Manifest Parse Error : Expecting white space or '?'. | ERROR_SXS_XML_E_WHITESPACEORQUESTIONMARK
12051 | 0x00002F13 | Manifest Parse Error : End tag was not expected at this location. | ERROR_SXS_XML_E_UNEXPECTEDENDTAG
12052 | 0x00002F14 | Manifest Parse Error : The following tags were not closed: %1. | ERROR_SXS_XML_E_UNCLOSEDTAG
12053 | 0x00002F15 | Manifest Parse Error : Duplicate attribute. | ERROR_SXS_XML_E_DUPLICATEATTRIBUTE
12054 | 0x00002F16 | Manifest Parse Error : Only one top level element is allowed in an XML document. | ERROR_SXS_XML_E_MULTIPLEROOTS
12055 | 0x00002F17 | Manifest Parse Error : Invalid at the top level of the document. | ERROR_SXS_XML_E_INVALIDATROOTLEVEL
12056 | 0x00002F18 | Manifest Parse Error : Invalid XML declaration. | ERROR_SXS_XML_E_BADXMLDECL
12057 | 0x00002F19 | Manifest Parse Error : XML document must have a top level element. | ERROR_SXS_XML_E_MISSINGROOT
12058 | 0x00002F1A | Manifest Parse Error : Unexpected end of file. | ERROR_SXS_XML_E_UNEXPECTEDEOF
12059 | 0x00002F1B | Manifest Parse Error : Parameter entities cannot be used inside markup declarations in an internal subset. | ERROR_SXS_XML_E_BADPEREFINSUBSET
12060 | 0x00002F1C | Manifest Parse Error : Element was not closed. | ERROR_SXS_XML_E_UNCLOSEDSTARTTAG
12061 | 0x00002F1D | Manifest Parse Error : End element was missing the character '>'. | ERROR_SXS_XML_E_UNCLOSEDENDTAG
12062 | 0x00002F1E | Manifest Parse Error : A string literal was not closed. | ERROR_SXS_XML_E_UNCLOSEDSTRING
12063 | 0x00002F1F | Manifest Parse Error : A comment was not closed. | ERROR_SXS_XML_E_UNCLOSEDCOMMENT
12064 | 0x00002F20 | Manifest Parse Error : A declaration was not closed. | ERROR_SXS_XML_E_UNCLOSEDDECL
12065 | 0x00002F21 | Manifest Parse Error : A CDATA section was not closed. | ERROR_SXS_XML_E_UNCLOSEDCDATA
12066 | 0x00002F22 | Manifest Parse Error : The namespace prefix is not allowed to start with the reserved string "xml". | ERROR_SXS_XML_E_RESERVEDNAMESPACE
12067 | 0x00002F23 | Manifest Parse Error : System does not support the specified encoding. | ERROR_SXS_XML_E_INVALIDENCODING
12068 | 0x00002F24 | Manifest Parse Error : Switch from current encoding to specified encoding not supported. | ERROR_SXS_XML_E_INVALIDSWITCH
12069 | 0x00002F25 | Manifest Parse Error : The name 'xml' is reserved and must be lower case. | ERROR_SXS_XML_E_BADXMLCASE
12070 | 0x00002F26 | Manifest Parse Error : The standalone attribute must have the value 'yes' or 'no'. | ERROR_SXS_XML_E_INVALID_STANDALONE
12071 | 0x00002F27 | Manifest Parse Error : The standalone attribute cannot be used in external entities. | ERROR_SXS_XML_E_UNEXPECTED_STANDALONE
12072 | 0x00002F28 | Manifest Parse Error : Invalid version number. | ERROR_SXS_XML_E_INVALID_VERSION
12073 | 0x00002F29 | Manifest Parse Error : Missing equals sign between attribute and attribute value. | ERROR_SXS_XML_E_MISSINGEQUALS
13000 | 0x000032C8 | The specified quick mode policy already exists. | ERROR_IPSEC_QM_POLICY_EXISTS
13001 | 0x000032C9 | The specified quick mode policy was not found. | ERROR_IPSEC_QM_POLICY_NOT_FOUND
13002 | 0x000032CA | The specified quick mode policy is being used. | ERROR_IPSEC_QM_POLICY_IN_USE
13003 | 0x000032CB | The specified main mode policy already exists. | ERROR_IPSEC_MM_POLICY_EXISTS
13004 | 0x000032CC | The specified main mode policy was not found. | ERROR_IPSEC_MM_POLICY_NOT_FOUND
13005 | 0x000032CD | The specified main mode policy is being used. | ERROR_IPSEC_MM_POLICY_IN_USE
13006 | 0x000032CE | The specified main mode filter already exists. | ERROR_IPSEC_MM_FILTER_EXISTS
13007 | 0x000032CF | The specified main mode filter was not found. | ERROR_IPSEC_MM_FILTER_NOT_FOUND
13008 | 0x000032D0 | The specified transport mode filter already exists. | ERROR_IPSEC_TRANSPORT_FILTER_EXISTS
13009 | 0x000032D1 | The specified transport mode filter does not exist. | ERROR_IPSEC_TRANSPORT_FILTER_NOT_FOUND
13010 | 0x000032D2 | The specified main mode authentication list exists. | ERROR_IPSEC_MM_AUTH_EXISTS
13011 | 0x000032D3 | The specified main mode authentication list was not found. | ERROR_IPSEC_MM_AUTH_NOT_FOUND
13012 | 0x000032D4 | The specified quick mode policy is being used. | ERROR_IPSEC_MM_AUTH_IN_USE
13013 | 0x000032D5 | The specified main mode policy was not found. | ERROR_IPSEC_DEFAULT_MM_POLICY_NOT_FOUND
13014 | 0x000032D6 | The specified quick mode policy was not found. | ERROR_IPSEC_DEFAULT_MM_AUTH_NOT_FOUND
13015 | 0x000032D7 | The manifest file contains one or more syntax errors. | ERROR_IPSEC_DEFAULT_QM_POLICY_NOT_FOUND
13016 | 0x000032D8 | The application attempted to activate a disabled activation context. | ERROR_IPSEC_TUNNEL_FILTER_EXISTS
13017 | 0x000032D9 | The requested lookup key was not found in any active activation context. | ERROR_IPSEC_TUNNEL_FILTER_NOT_FOUND
13018 | 0x000032DA | The Main Mode filter is pending deletion. | ERROR_IPSEC_MM_FILTER_PENDING_DELETION
13019 | 0x000032DB | The transport filter is pending deletion. | ERROR_IPSEC_TRANSPORT_FILTER_PENDING_DELETION
13020 | 0x000032DC | The tunnel filter is pending deletion. | ERROR_IPSEC_TUNNEL_FILTER_PENDING_DELETION
13021 | 0x000032DD | The Main Mode policy is pending deletion. | ERROR_IPSEC_MM_POLICY_PENDING_DELETION
13022 | 0x000032DE | The Main Mode authentication bundle is pending deletion. | ERROR_IPSEC_MM_AUTH_PENDING_DELETION
13023 | 0x000032DF | The Quick Mode policy is pending deletion. | ERROR_IPSEC_QM_POLICY_PENDING_DELETION
13801 | 0x000035E9 | IKE authentication credentials are unacceptable. | ERROR_IPSEC_IKE_AUTH_FAIL
13802 | 0x000035EA | IKE security attributes are unacceptable. | ERROR_IPSEC_IKE_ATTRIB_FAIL
13803 | 0x000035EB | IKE Negotiation in progress. | ERROR_IPSEC_IKE_NEGOTIATION_PENDING
13804 | 0x000035EC | General processing error. | ERROR_IPSEC_IKE_GENERAL_PROCESSING_ERROR
13805 | 0x000035ED | Negotiation timed out. | ERROR_IPSEC_IKE_TIMED_OUT
13806 | 0x000035EE | IKE failed to find valid machine certificate. | ERROR_IPSEC_IKE_NO_CERT
13807 | 0x000035EF | IKE SA deleted by peer before establishment completed. | ERROR_IPSEC_IKE_SA_DELETED
13808 | 0x000035F0 | IKE SA deleted before establishment completed. | ERROR_IPSEC_IKE_SA_REAPED
13809 | 0x000035F1 | Negotiation request sat in Queue too long. | ERROR_IPSEC_IKE_MM_ACQUIRE_DROP
13810 | 0x000035F2 | Negotiation request sat in Queue too long. | ERROR_IPSEC_IKE_QM_ACQUIRE_DROP
13811 | 0x000035F3 | Negotiation request sat in Queue too long. | ERROR_IPSEC_IKE_QUEUE_DROP_MM
13812 | 0x000035F4 | Negotiation request sat in Queue too long. | ERROR_IPSEC_IKE_QUEUE_DROP_NO_MM
13813 | 0x000035F5 | No response from peer. | ERROR_IPSEC_IKE_DROP_NO_RESPONSE
13814 | 0x000035F6 | Negotiation took too long. | ERROR_IPSEC_IKE_MM_DELAY_DROP
13815 | 0x000035F7 | Negotiation took too long. | ERROR_IPSEC_IKE_QM_DELAY_DROP
13816 | 0x000035F8 | Unknown error occurred. | ERROR_IPSEC_IKE_ERROR
13817 | 0x000035F9 | Certificate Revocation Check failed. | ERROR_IPSEC_IKE_CRL_FAILED
13818 | 0x000035FA | Invalid certificate key usage. | ERROR_IPSEC_IKE_INVALID_KEY_USAGE
13819 | 0x000035FB | Invalid certificate type. | ERROR_IPSEC_IKE_INVALID_CERT_TYPE
13820 | 0x000035FC | No private key associated with machine certificate. | ERROR_IPSEC_IKE_NO_PRIVATE_KEY
13822 | 0x000035FE | Failure in Diffie-Helman computation. | ERROR_IPSEC_IKE_DH_FAIL
13824 | 0x00003600 | Invalid header. | ERROR_IPSEC_IKE_INVALID_HEADER
13825 | 0x00003601 | No policy configured. | ERROR_IPSEC_IKE_NO_POLICY
13826 | 0x00003602 | Failed to verify signature. | ERROR_IPSEC_IKE_INVALID_SIGNATURE
13827 | 0x00003603 | Failed to authenticate using Kerberos. | ERROR_IPSEC_IKE_KERBEROS_ERROR
13828 | 0x00003604 | Peer's certificate did not have a public key. | ERROR_IPSEC_IKE_NO_PUBLIC_KEY
13829 | 0x00003605 | Error processing error payload. | ERROR_IPSEC_IKE_PROCESS_ERR
13830 | 0x00003606 | Error processing SA payload. | ERROR_IPSEC_IKE_PROCESS_ERR_SA
13831 | 0x00003607 | Error processing Proposal payload. | ERROR_IPSEC_IKE_PROCESS_ERR_PROP
13832 | 0x00003608 | Error processing Transform payload. | ERROR_IPSEC_IKE_PROCESS_ERR_TRANS
13833 | 0x00003609 | Error processing KE payload. | ERROR_IPSEC_IKE_PROCESS_ERR_KE
13834 | 0x0000360A | Error processing ID payload. | ERROR_IPSEC_IKE_PROCESS_ERR_ID
13835 | 0x0000360B | Error processing Cert payload. | ERROR_IPSEC_IKE_PROCESS_ERR_CERT
13836 | 0x0000360C | Error processing Certificate Request payload. | ERROR_IPSEC_IKE_PROCESS_ERR_CERT_REQ
13837 | 0x0000360D | Error processing Hash payload. | ERROR_IPSEC_IKE_PROCESS_ERR_HASH
13838 | 0x0000360E | Error processing Signature payload. | ERROR_IPSEC_IKE_PROCESS_ERR_SIG
13839 | 0x0000360F | Error processing Nonce payload. | ERROR_IPSEC_IKE_PROCESS_ERR_NONCE
13840 | 0x00003610 | Error processing Notify payload. | ERROR_IPSEC_IKE_PROCESS_ERR_NOTIFY
13841 | 0x00003611 | Error processing Delete Payload. | ERROR_IPSEC_IKE_PROCESS_ERR_DELETE
13842 | 0x00003612 | Error processing VendorId payload. | ERROR_IPSEC_IKE_PROCESS_ERR_VENDOR
13843 | 0x00003613 | Invalid payload received. | ERROR_IPSEC_IKE_INVALID_PAYLOAD
13844 | 0x00003614 | Soft SA loaded. | ERROR_IPSEC_IKE_LOAD_SOFT_SA
13845 | 0x00003615 | Soft SA torn down. | ERROR_IPSEC_IKE_SOFT_SA_TORN_DOWN
13846 | 0x00003616 | Invalid cookie received.. | ERROR_IPSEC_IKE_INVALID_COOKIE
13847 | 0x00003617 | Peer failed to send valid machine certificate. | ERROR_IPSEC_IKE_NO_PEER_CERT
13848 | 0x00003618 | Certification Revocation check of peer's certificate failed. | ERROR_IPSEC_IKE_PEER_CRL_FAILED
13849 | 0x00003619 | New policy invalidated SAs formed with old policy. | ERROR_IPSEC_IKE_POLICY_CHANGE
13850 | 0x0000361A | There is no available Main Mode IKE policy. | ERROR_IPSEC_IKE_NO_MM_POLICY
13851 | 0x0000361B | Failed to enabled TCB privilege. | ERROR_IPSEC_IKE_NOTCBPRIV
13852 | 0x0000361C | Failed to load SECURITY.DLL. | ERROR_IPSEC_IKE_SECLOADFAIL
13853 | 0x0000361D | Failed to obtain security function table dispatch address from SSPI. | ERROR_IPSEC_IKE_FAILSSPINIT
13854 | 0x0000361E | Failed to query Kerberos package to obtain max token size. | ERROR_IPSEC_IKE_FAILQUERYSSP
13855 | 0x0000361F | Failed to obtain Kerberos server credentials for ISAKMP/ERROR_IPSEC_IKE service. Kerberos authentication will not function. The most likely reason for this is lack of domain membership. This is normal if your computer is a member of a workgroup. | ERROR_IPSEC_IKE_SRVACQFAIL
13856 | 0x00003620 | Failed to determine SSPI principal name for ISAKMP/ERROR_IPSEC_IKE service (QueryCredentialsAttributes). | ERROR_IPSEC_IKE_SRVQUERYCRED
13857 | 0x00003621 | Failed to obtain new SPI for the inbound SA from Ipsec driver. The most common cause for this is that the driver does not have the correct filter. Check your policy to verify the filters. | ERROR_IPSEC_IKE_GETSPIFAIL
13858 | 0x00003622 | Given filter is invalid. | ERROR_IPSEC_IKE_INVALID_FILTER
13859 | 0x00003623 | Memory allocation failed. | ERROR_IPSEC_IKE_OUT_OF_MEMORY
13860 | 0x00003624 | Failed to add Security Association to IPSec Driver. The most common cause for this is if the IKE negotiation took too long to complete. If the problem persists, reduce the load on the faulting machine. | ERROR_IPSEC_IKE_ADD_UPDATE_KEY_FAILED
13861 | 0x00003625 | Invalid policy. | ERROR_IPSEC_IKE_INVALID_POLICY
13862 | 0x00003626 | Invalid DOI. | ERROR_IPSEC_IKE_UNKNOWN_DOI
13863 | 0x00003627 | Invalid situation. | ERROR_IPSEC_IKE_INVALID_SITUATION
13864 | 0x00003628 | Diffie-Hellman failure. | ERROR_IPSEC_IKE_DH_FAILURE
13865 | 0x00003629 | Invalid Diffie-Hellman group. | ERROR_IPSEC_IKE_INVALID_GROUP
13866 | 0x0000362A | Error encrypting payload. | ERROR_IPSEC_IKE_ENCRYPT
13867 | 0x0000362B | Error decrypting payload. | ERROR_IPSEC_IKE_DECRYPT
13868 | 0x0000362C | Policy match error. | ERROR_IPSEC_IKE_POLICY_MATCH
13869 | 0x0000362D | Unsupported ID. | ERROR_IPSEC_IKE_UNSUPPORTED_ID
13870 | 0x0000362E | Hash verification failed. | ERROR_IPSEC_IKE_INVALID_HASH
13871 | 0x0000362F | Invalid hash algorithm. | ERROR_IPSEC_IKE_INVALID_HASH_ALG
13872 | 0x00003630 | Invalid hash size. | ERROR_IPSEC_IKE_INVALID_HASH_SIZE
13873 | 0x00003631 | Invalid encryption algorithm. | ERROR_IPSEC_IKE_INVALID_ENCRYPT_ALG
13874 | 0x00003632 | Invalid authentication algorithm. | ERROR_IPSEC_IKE_INVALID_AUTH_ALG
13875 | 0x00003633 | Invalid certificate signature. | ERROR_IPSEC_IKE_INVALID_SIG
13876 | 0x00003634 | Load failed. | ERROR_IPSEC_IKE_LOAD_FAILED
13877 | 0x00003635 | Deleted via RPC call. | ERROR_IPSEC_IKE_RPC_DELETE
13878 | 0x00003636 | Temporary state created to perform reinit. This is not a real failure. | ERROR_IPSEC_IKE_BENIGN_REINIT
13879 | 0x00003637 | The lifetime value received in the Responder Lifetime Notify is below the Windows 2000 configured minimum value. Please fix the policy on the peer machine. | ERROR_IPSEC_IKE_INVALID_RESPONDER_LIFETIME_NOTIFY
13880 | 0x00003638 | SA reaped because QM limit was reached. | ERROR_IPSEC_IKE_QM_LIMIT_REAP
13881 | 0x00003639 | Key length in certificate is too small for configured security requirements. | ERROR_IPSEC_IKE_INVALID_CERT_KEYLEN
13882 | 0x0000363A | Max number of established MM SAs to peer exceeded. | ERROR_IPSEC_IKE_MM_LIMIT
13883 | 0x0000363B | IKE received a policy that disables negotiation. | ERROR_IPSEC_IKE_NEGOTIATION_DISABLED
13884 | 0x0000363C |  | ERROR_IPSEC_IKE_NEG_STATUS_END


Übersicht

Die aktuelle Version der NC Fehlercodes finden Sie hier.


Allgemeine NC-Fehler


Kanalfehler


Gruppenfehler


Achsfehler


Geberfehler


Reglerfehler


Antriebfehler


Tabellenfehler


NC-SPS-Fehler