Fehlerbeschreibung

FB-Fehler

Wert

Erläuterung

FB_ALL_OK

0

Kein Fehler aufgetreten

FB_ERR_MC_AXIS

1

Das AXSD einer Achse befindet sich im Zustand ERRORSTOP. Es ist ein Fehler auf der Achse aufgetreten. Der FB meldet den Achsfehler durch Ausgabe dieses FB-Fehler und wechselt intern in den FB-Fehler-Zustand FB_ERROR.

Die Kennung des Achsfehlers, die vom Motion Controller kommt, wird in einer Instanz des MC_ReadAxisError angezeigt.

FB_ERR_AXREF_CHG_WHILE_ACTIVE

2

Eine frühere Beauftragung eines FB ist aktiv, der FB hat noch keine Quittierung für diesen Auftrag erhalten. In der Zwischenzeit wurde diesem FB eine andere Achse zugeordnet (AXIS_REF hat sich geändert).

Dies ist nicht zulässig, da ansonsten der FB die Quittierung des Auftrags für die zuvor beauftragte Achse nicht erhält und damit weiterhin aktiv bleibt.

FB_ERR_TRANSITION_NOT_ALLOWED

3

Wird nicht mehr verwendet.

Fehler dieser Art werden nun granularer ausgegeben.
Siehe Fehlernummer 16 .. 30, 47.

FB_ERR_MC_DID_NOT_TAKE_ORDER

4

Ein FB konnte eine Achse nicht beauftragen, da die achsspezifische Schnittstelle belegt war. Wie oft daraufhin versucht wird diesen Auftrag abzusetzen, ist in der PLC-Applikation durch die globale Variable MAX_RETRIALS festgelegt. Ist die Anzahl der möglichen Versuche den Auftrag erfolgreich abzusetzen überschritten worden, ist dies der zugehörige Fehlercode. Diesen Fehler erhält man insbesondere wenn MAX_RETRIALS = 0 ist (=default) und man versucht mehr als eine FB-Beauftragung pro PLC-Zyklus abzusetzen.

FB_ERR_ANSWER_TIME_OUT

5

Spezifischer Fehler des FB MC_Reset.

Über den FB wurde ein Reset einer Achse beauftragt. Wenn mehr als eine definierte Anzahl von Versuchen fehlgeschlagen ist, von der MC eine Quittierung zu erhalten, dass der Reset abgeschlossen ist, ist dies der Fehlercode des FB.

FB_ERR_POSITION_OUT_OF_RANGE

6

Bei den FBs MC_Home, MC_MoveAbsolute wird der Wert der Eingangsvariable Position vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°] wird dieser Fehlercode ausgegeben.

FB_ERR_VELOCITY_OUT_OF_RANGE

7

Bei den FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed, MC_MoveVelocity und MC_Phasing wird der Wert der Eingangsvariable Velocity vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [1.0, 2147483647.0] [µm/s bzw. 10-3 °/s] wird dieser Fehlercode ausgegeben.

FB_ERR_ACCEL_OUT_OF_RANGE

8

Bei den FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn und MC_Phasing wird der Wert der Eingangsvariable Acceleration vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [0.0, 2147483647.0] [1mm/s2] bzw. 1°/s2] wird dieser Fehlercode ausgegeben.

FB_ERR_DECCEL_OUT_OF_RANGE

9

Bei den FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_Stop, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn und MC_Phasing wird der Wert der Eingangsvariable Deceleration vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [0.0, 2147483647.0] [1mm/s2] bzw. 1°/s2] wird dieser Fehlercode ausgegeben.

FB_ERR_HOMING_RE_TRIGGERD

10

Spezifische Fehlermeldung des FB MC_Home.

Es wurde ein Homing beauftragt, bevor der FB die Quittierung für einen zuvor abgesetzten Home-Auftrag erhalten hat.

FB_ERR_STOP_RE_TRIGGERD

11

Spezifische Fehlermeldung des FB MC_Stop.

Es wurde das Stoppen einer Achse beauftragt, bevor der FB die Quittierung für einen zuvor abgesetzten Stop-Auftrag erhalten hat.

FB_ERR_TPROBE_RETRIGGERED

12

Spezifische Fehlermeldung des FB MC_TouchProbe.

Es wurde ein Messung beauftragt, bevor der FB die Quittierung für eine zuvor beauftragte Messung erhalten hat.

FB_ERR_TPABORT_RETRIGGERED

13

Spezifische Fehlermeldung des FB MC_AbortTrigger.

Es wurde der Abbruch einer Messung beauftragt, bevor der FB die Quittierung für einen zuvor beauftragten Abbruch einer Messung erhalten hat

FB_ERR_INPREF_TPCH_CHW_ACTIVE

14

Spezifischer Fehler der FBs MC_TouchProbe und MC_AbortTrigger.

Eine Beauftragung ist noch aktiv, da der FB dafür noch keine Quittierung erhalten hat. Es erfolgt eine erneute Beauftragung des FB, wobei festgestellt wird, dass sich in der Eingangsvariable TriggerInput der Wert des Messkanals tp_channel geändert hat.

FB_ERR_INPREF_TPMD_CHW_ACTIVE

15

Spezifischer Fehler der FBs MC_TouchProbe und MC_AbortTrigger.

Eine Beauftragung ist noch aktiv, da der FB dafür noch keine Quittierung erhalten hat. Es erfolgt eine erneute Beauftragung des FB, wobei festgestellt wird , dass sich in der Eingangsvariable TriggerInput die Art der Messung tp_mode geändert hat.

FB_ERR_TNA_INIT_STATE

16

Dieser Wert wird ausgegeben, wenn sich das Achszustanddiagramm einer Achse beim Aufruf eines FB im Zustand 0 (ISG_INIT) befindet. Dies bedeutet, dass die Initialisierungsphase der achsspezifischen HLI-Schnittstelle noch nicht abgeschlossen ist, aber es wurde bereits versucht eine Beauftragung über einen FB an diese Schnittstelle abzusetzen.

FB_ERR_TNA_AXIS_STANDS_STILL

17

Achse konnte nicht beauftragt werden, weil sich die beauftragte Achse im Achszustand StandStill befindet.

FB_ERR_TNA_HOMING_STILL_ACTIVE

18

Achse konnte nicht beauftragt werden, weil die beauftragte Achse noch eine Justagebeauftragung abarbeitet.

FB_ERR_TNA_STOPPING_ACTIVE

19

Achse konnte nicht beauftragt werden, weil sich die Achse im Zustand STOPPING befindet. Falls die Achse physikalisch bereits stillsteht und trotzdem diese Meldung auftritt, dann ist der Grund hierfür, dass eine Instanz eines FB MC_Stop auf dieser Achse das Anhalten der Achse beauftragt hat und der Execute-Eingang dieser Instanz noch den Wert TRUE besitzt. Dies führt dazu, dass sich diese Achse dann solange im Zustand STOPPING befindet bis der Execute-Eingang dieser MC_Stop Instanz wieder auf FALSE zurückgesetzt wurde.

FB_ERR_TNA_AXIS_ERROR_ACTIVE

20

Achse konnte nicht beauftragt werden, weil ein Fehler auf der Achse aufgetreten ist.

FB_ERR_TNA_DISC_MOTION_ACTIVE

21

Achse konnte nicht beauftragt werden, weil für diese Achse noch ein Bewegungsauftrag aktiv ist, der durch eine Instanz eines FB MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed oder MC_CamTableSelect ausgelöst wurde. Dieser Auftrag wurde noch nicht mit Done = TRUE quittiert.

FB_ERR_TNA_CONT_MOTION_ACTIVE

22

Achse konnte nicht beauftragt werden, weil noch ein Bewegungsauftrag aktiv ist, der durch eine Instanz eines FB MC_MoveVelocity, MC_CamOut, MC_GearOut ausgelöst wurde. Dieser Auftrag wurde noch nicht mit Done = TRUE quittiert.

FB_ERR_TNA_SYNC_MOTION_ACTIVE

23

Achse konnte nicht beauftragt werden, weil noch ein Bewegungsauftrag aktiv ist, der durch eine Instanz eines FB MC_CamIn, MC_GearIn ausgelöst wurde. Dieser Auftrag wurde noch nicht mit Done = TRUE quittiert.

FB_ERR_TNA_AXSD_ERROR_ACTIVE

24

Achse konnte nicht beauftragt werden, weil der Wert für den Achszustand der Initialisierungswert 0 oder ein nicht definierter Wert ist.

Achse konnte nicht beauftragt werden, weil die Schnittstelle zum MC inkonsistent ist entweder bzgl. der Versionskennung, der Größe der achsspezifischen/kanalspezifischen Schnittstelle.

FB_ERR_TNA_UNKNOWN_AXSD_STATE

25

Achse konnte nicht beauftragt werden, weil der Wert, der den Achszustand beschreibt, einen nicht erlaubten Wert angenommen hat.

FB_ERR_TNA_TP_IDLE_ACTIVE

26

Ist definiert, darf aber nicht als Wert des Ausgangs ErrorID eines FB auftreten.

FB_ERR_TNA_TOUCHPROBING

27

Achse konnte nicht beauftragt werden, weil auf dem Messkanal noch ein Messauftrag aktiv ist, der durch einen FB MC_TouchProbe ausgelöst wurde.

FB_ERR_TNA_ABORTING_TP_TRIGGER

28

Achse konnte nicht beauftragt werden, weil auf dem Messkanal noch der Abbruch eines Messauftrags aktiv ist, der durch einen FB MC_AbortTrigger ausgelöst wurde.

FB_ERR_TNA_UNKNOWN_TPSD_STATE

29

Achse konnte nicht beauftragt werden, weil der Wert, der den Zustand eines Messkanals für das schnelle Messen (touch probing) beschreibt, einen nicht definierten Wert besitzt.

FB_ERR_TNA_ANY_STOP_EXEC_TRUE

30

Achse konnte nicht beauftragt werden, weil bei einem oder mehreren Instanzen des FB MC_Stop, die auf diese Achse einwirken, der Eingang Execute auf TRUE gesetzt ist.

FB_ERR_INIT_HLI_NO_VER

31

Im Fehlerfall zeigt jeder FB der eine AXIS_REF als Eingangsvariable besitzt diesen Fehlercode an.

In der Initialisierungsphase der ISG-MCP werden die Komponenten, von denen die Motion-Bibliothek abhängt, auf ihre Versionskennung überprüft. Tritt dieser Fehler auf, konnte die Versionsbezeichnung für die Nachbildung des HLI auf Seite des MC nicht vom HLI in den FB kopiert werden.

Seinen Ursprung hat dieser Fehlercode in dem FB MCV_ChkHLIVer der in der Bibliothek mit der PLC-seitigen HLI-Nachbildung definiert ist.

FB_ERR_INIT_HLI_INCNST

32

Im Fehlerfall zeigt jeder FB der eine AXIS_REF als Eingangsvariable besitzt diesen Fehlercode an.

Bei der Überprüfung der Versionsbezeichnung und Größe der Schnittstelle HLI auf Seiten der PLC und der MC wird festgestellt, dass entweder die Versionsbezeichnung oder die Größe der Schnittstelle zwischen PLC und MC unterschiedlich sind.

FB_ERR_INIT_HLI_LIB_INCNST

33

Im Fehlerfall zeigt jeder FB der eine AXIS_REF als Eingangsvariable besitzt diesen Fehlercode an.

Die Motion-Bibliothek ist abhängig von der PLC-seitigen HLI-Definition und überprüft deshalb in der Initialisierungsphase die Versionskennung dieser HLI-Definition mit der Kennung, die bei der Implementierung der Motion-Bibliothek zu Grunde lag. Stimmen diese nicht überein, wird dieser Fehler ausgegeben.

FB_ERR_JOB_NR_ZERO

34

Spezifischer Fehler des FB MCV_UTIL_ForceJobAck.

Die Eingangsvariable JobNr des FB MCV_UTIL_ForceJobAck besitzt den Wert 0. Ein Auftrag mit der Ordnungszahl 0 kann durch den Baustein MCV_UTIL_ForceJobAck nicht quittiert werden, weil diese eine ungültige Ordnungszahl für einen Auftrag ist, weshalb dieser Fehlercode ausgegeben wird.

FB_ERR_OTHER_JOB_NOTIFIED

35

Spezifischer Fehler des FB MCV_UTIL_ForceJobAck.

Der Auftrag mit der Ordnungszahl, die durch die Eingangsvariable JobNr vorgeben wurde, konnte nicht quittiert werden, da ein Auftrag mit einer anderen Ordnungszahl zur Quittierung am HLI ansteht.

FB_ERR_NO_JOB_NOTIFIED

36

Spezifischer Fehler des FB MCV_UTIL_ForceJobAck.

Der Auftrag mit der Ordnungszahl, die durch die Eingangsvariable JobNr vorgeben wurde, konnte nicht quittiert werden, da kein Auftrag zur Quittierung am HLI ansteht.

FB_ERR_CHK_BLOCK_ZERO_CYCLES

37

Spezifischer Fehler des FB MCV_UTIL_ChkJobAck.

Der Wert der Eingangsvariable NrChkCycles ist 0. Der Wert dieser Variablen muss größer 0 sein. Die Variable definiert die Anzahl der PLC-Zyklen in Folge, die ein Auftrag unquittiert am HLI anstehen muss, bevor er als Verstopfung des HLI gewertet wird.

FB_ERR_DISTANCE_OUT_OF_RANGE

38

Bei den FBs MC_MoveAdditive, MC_MoveRelative, MC_MoveSuperImposed wird der Wert der Eingangsvariable Distance vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°] wird dieser Fehlercode ausgegeben.

FB_ERR_JERK_OUT_OF_RANGE

39

Bei den FBs MC_MoveAbsolute, MC_MoveAdditive, MC_MoveRelative, MC_Stop, MC_MoveSuperImposed, MC_MoveVelocity, MC_GearIn und MC_Phasing wird der Wert der Eingangsvariable Jerk vor der Beauftragung überprüft. Liegt der Wert außerhalb des Intervalls von [0.0, 2147483647.0] wird dieser Fehlercode ausgegeben.

FB_ERR_MST_OFFS_OUT_OF_RANGE

40

Spezifische Fehlermeldung des FB MC_CamIn.

Liegt der Wert der Eingangsvariablen MasterOffset vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_SLV_OFFS_OUT_OF_RANGE

41

Spezifische Fehlermeldung des FB MC_CamIn.

Liegt der Wert der Eingangsvariablen SlaveOffset vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_MST_SCALE_OUT_OF_RANGE

42

Spezifische Fehlermeldung des FB MC_CamIn.

Liegt der Wert der Eingangsvariablen MasterScaling vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_SLV_SCALE_OUT_OF_RANGE

43

Spezifische Fehlermeldung des FB MC_CamIn.

Liegt der Wert der Eingangsvariablen SlaveScaling vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_PHASESHIFT_OUT_OF_RANGE

44

Spezifische Fehlermeldung des FB MC_Phasing.

Liegt der Wert der Eingangsvariablen PhaseShift vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_NOT_USED

45

Derzeit kein verwendeter Fehlercode.

FB_ERR_RATIO_DENOM_ZERO

46

Spezifische Fehlermeldung des FB MC_GearIn.

Der Wert der Eingangsvariablen RatioDenominator ist 0. Dieser Wert ist der Nenner des Bruches der Getriebeübersetzung und darf deshalb nicht 0 sein.

FB_ERR_TNA_HLI_VER

47

Dieser Fehlercode wird nicht mehr verwendet. Statt dessen werden die Fehlercodes 48 bis 50 verwendet, die detailliertere Auskunft darüber geben, was beim Prüfen der Versionsabhängigkeiten schief ging.

FB_ERR_CHK_LC_VER_CMD_FLAGS

48

Spezifische Fehlermeldung des FB MCV_ChkDpdcies.

Der MC soll durch die PLC beauftragt werden die Version der PLC-seitigen HLI-Definition zu überprüfen. Jedoch kann die PLC diesen Auftrag an die MC nicht absetzen, weil die Control-Unit belegt ist.

FB_ERR_CHK_LC_VER_ACK_STATE

49

Spezifische Fehlermeldung des FB MCV_ChkDpdcies.

Die PLC will das Ergebnis der PLC-seitigen HLI-Versionsüberprüfung quittieren. Zu diesem Zeitpunkt besitzen aber die Kommando- und Zustandflags der Control-Unit Werte, die eine Quittierung nicht zulassen.

FB_ERR_CHK_LC_VER_OTHER

50

Spezifische Fehlermeldung des FB MCV_ChkDpdcies.

Bei der Versionsüberprüfung der PLC-seitigen HLI-Definition durch die MC befindet sich ein untergeordneter FB in einem falschen Zustand oder die Versionskennung konnte nicht auf das HLI kopiert werden.

FB_ERR_STARTIGN_OUT_OF_RANGE

51

Spezifische Fehlermeldung des FB MC_TouchProbe

Liegt der Wert der Eingangsvariablen start_ignore vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_STOPIGN_OUT_OF_RANGE

52

Spezifische Fehlermeldung des FB MC_TouchProbe

Liegt der Wert der Eingangsvariablen stop_ignore vor der Beauftragung außerhalb des Intervalls [-2147483648.0, 2147483647.0] [0,1µm bzw. 10-4°], wird dieser Fehlercode ausgegeben.

FB_ERR_GEAR_NR_IS_ZERO

53

Reserved

FB_ERR_SHIFT_GEAR_RETRIGGERED

54

Reserved

FB_ERR_INVALID_LOG_AXIS_NUMBER

55

Achse existiert nicht.

In der Initialisierungsphase der Motion Control Plattform wird geprüft, ob eine Achse vorhanden ist, indem die logische Achsnummer auf ihre Gültigkeit (>0) geprüft wird.

Ist eine Achse nicht vorhanden wird die Fehlernummer 55 ausgegeben und die Achse geht in den Zustand FINAL_ERROR_STATE, der nicht mehr verlassen werden kann.

FB_ERR_CPY_STR_TO_BUF_FAILED

56

Fehler im Baustein STRING_TO_BUF.

Das Kopieren eines IEC-Strings in den Buffer ist fehlgeschlagen.

FB_ERR_CPY_BUF_TO_STR_FAILED

57

Fehler im Baustein BUF_TO_STRING.

Das Kopieren aus dem Buffer in einen IEC-String ist fehlgeschlagen.

FB_ERR_INTERNAL_PARAM_ERR

58

Spezifischer Fehler der Parameter-FBs.

FB_ERR_INTERNAL_PARAM_WARN

59

Spezifische Warnung der Parameter-FBs.

FB_ERR_INCONSISTENT_PARAMETER

60

Inkonsistenter Parameter in den FBs MCV_ActivateParamChg oder MCV_ChgParamSet

FB_ERR_INVALID_DRIVE_MODE

61

Unzulässige Betriebsart

Es wurde eine nicht zulässige Betriebsart ausgewählt. Zulässige Betriebsarten sind:

(0) Lageregelung

(1) Geschwindigkeitsregelung

(2) Momentenregelung

(3) Lageregelung mit Vorsteuerung

FB_ERR_TNA_TORQUE_CTRL_ACTIVE

62

Aus diesem Zustand heraus kann nicht in die Betriebsart (2) Momentenregelung gewechselt werden.

FB_ERR_FOLLOW_UP_NOT_ALLOWED

63

Während einer aktiven Interpolation kann der Nachführbetrieb nicht aktiviert werden.

FB_ERR_TNA_DISABLED_ACTIVE

64

Achse konnte nicht beauftragt werden, da die beauftragte Achse deaktiviert (Achszustand DISABLED) ist.

FB_ERR_INIT_TABMGR_ADDRESS

65

Spezifischer Fehler des FB MCV_TableManager.

Sollen in einer PLC-Applikation Kurventabellen angewendet werden, muss eine Instanz des FB MCV_TableManager aufgerufen werden, der den Tabellenspeicher anlegt, in dem die Tabellen abgelegt werden. Wird der Tabellenspeicher nicht bereitgestellt, gibt der FB diesen Fehlerwert aus.

FB_ERR_INIT_CH_HLI_ADDRESS

66

Wird während der Initialisierungsphase der MCP festgestellt, dass eine Achsgruppenreferenz auf eine HLI-Schnittstelle verweist, die nicht belegt ist, wird dieser Fehler in der Referenz eingetragen. Ein FB, der über diese Referenz kommandieren will, detektiert den vorliegenden Fehler und gibt diesen am FB aus.

FB_ERR_INIT_AX_HLI_ADDRESS

67

Wird während der Initialisierungsphase der MCP festgestellt, dass eine Achsreferenz auf eine HLI-Schnittstelle verweist, die nicht belegt ist, wird dieser Fehler in der Referenz eingetragen. Ein FB, der über diese Referenz kommandieren will, detektiert den vorliegenden Fehler und gibt diesen am FB aus.

FB_ERR_INIT_IS_NO_MOTION_AXIS

68

Während der Initialisierungsphase wird überprüft, ob sich die über eine Achsreferenz ansprechbare Achse durch die in der Bibliothek McpPLCopenP1.lib definierten FBs beauftragen lässt (FB MCV_AxisInit). Ist dies nicht der Fall wird dieser Fehler in die Achsreferenz eingetragen und jeder FB, der über diese Referenz eine Achse beauftragen will, detektiert diesen Fehler und zeigt ihn an seinem Fehlerausgang an.

FB_ERR_INIT_HLI_CONTROL_UNITS

69

Während der Initialisierungsphase meldet sich die PLC an den notwendigen Control-Units der über Referenzen angesprochenen HLI-Schnittstellen an (FB Ax_HLI_Init). Gelingt dies nicht wird dieser Fehlerwert in die Referenz eingetragen und jeder FB, der über diese Referenz beauftragen will, detektiert diesen Fehler und zeigt ihn an seinem Fehlerausgang an.

FB_ERR_STUP_MC_DOESNT_RUN

70

Während der Hochlaufphase der MCP wird im FB MCV_InitPlatform überprüft, ob der MC schon im zyklischen Betrieb ist. Die Prüfung wird erfolgreich abgeschlossen, wenn die PLC 10 mal hintereinander detektiert, dass sich der Wert des Zykluszähler des MC im Vergleich zur vorherigen Überprüfung geändert hat.

Ist dies nicht der Fall, wird erneut untersucht ob in den folgenden 10 dieses Kriterium erfüllt wird.

Wenn dieses Kriterium verletzt wurde zeigt der FB diesen Fehlerwert an, solange bis es erfüllt wird.

FB_ERR_STUP_MC_NOT_STARTED

71

Während der Hochlaufphase der MCP wird im FB MCV_InitPlatform überprüft, ob der MC schon im zyklischen Betrieb und seinen Hochlauf abgeschlossen hat. Dies signalisiert der MC durch ein Flag, welches vom FB überprüft wird.

Besitzt dieses Flag nicht den Wert TRUE, zeigt der FB diesen Fehlerwert an und es wird erneut der Hochlauf der MCP durchlaufen.

FB_ERR_NO_SERCOS_DRIVE_AVAIL

72

Spezifischer Fehler des FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_SERCOS_PHASE_VALUE

73

Spezifischer Fehler des FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_SERCOS_PHASE_SERVICE

74

Spezifischer Fehler des FB MCV_SercosGetPhase, MCV_SercosSetPhase.

FB_ERR_TRCK_RELEVANT_MC_ERR

75

Spezifischer Fehler des FB MCV_PartTracker.

FB_ERR_NR_OF_TRCK_PARTS_EXCD

76

Maximale Anzahl der zu verfolgenden Teile wurde überschritten.

FB_ERROR_NO_TRACKED_PARTS

77

Es sind keine (weiteren) Teile im Array gespeichert.

FB_ERR_INIT_HLI_IFC_ADDRESS

78

Wird während der Initialisierungsphase der MCP festgestellt, dass eine Referenz auf eine HLI-Schnittstelle verweist, die nicht belegt ist, wird dieser Fehler in der Referenz eingetragen. Ein FB, der über diese Referenz kommandieren will, detektiert den vorliegenden Fehler und gibt diesen am FB aus.

FB_ERR_INPUT_EMPTY_STR

79

Spezifischer Fehler des FB MCV_GetParamType.

Der Eingangsvariablen Param wurde eine leere Zeichenkette übergeben.

FB_ERR_AXREF_TYPE_1

80

Ein FB, der eine Achsreferenz des Typs REF_SAI_AXIS oder REF_TO_REF benötigt, hat eine Achsreferenz erhalten, die nicht von diesem Typ ist.

FB_ERR_AXREF_TYPE_2

81

Ein FB, der eine Achsreferenz des Typs REF_SAI_AXIS oder REF_AXGRP_AXIS oder REF_IO_STATION benötigt, hat eine Achsreferenz erhalten, die nicht von diesem Typ ist.

FB_ERR_AXREF_TYPE_3

82

Spezifischer Fehler von FBs, die 2 Achsreferenzen als Eingang besitzen.

Der FB benötigt folgende Kombination von Achsreferenzen:

· entweder sind beide Referenzen vom Typ REF_SAI_AXIS

· oder die Masterachse ist vom Typ REF_ENC_AXIS und die Slaveachse vom Typ REF_TO_REF

FB_ERR_SERCOS_GET_IDENT

83

Der FB versucht SERCOS-Parameter zu lesen. Dabei tritt ein Fehler im MC auf. Weitere Einzelheiten zum Fehler können über eine Instanz des MC_ReadAxisError angezeigt werden.

FB_ERR_SERCOS_SET_IDENT

84

Der FB versucht SERCOS-Parameter zu schreiben. Dabei tritt ein Fehler im MC auf. Weitere Einzelheiten zum Fehler können über eine Instanz des MC_ReadAxisError angezeigt werden.

FB_ERR_HLI_AXIS_IFC_IDX

85

Der in einer Achsreferenz abgelegte Index für die Adressierung einer achsspezifischen HLI-Schnittstelle liegt ausserhalb des zulässigen Bereiches und würde eine Schnittstelle adressieren, die nicht existiert.

FB_ERR_HLI_AXIS_IFC_ADDRESS

86

Eine Achsreferenz verweist auf eine achsspezifische HLI-Schnittstelle, die nicht belegt ist. Wird über einen FB, der diese Referenz nutzt um eine Achse zu beauftragen, ein Kommando abgesetzt, detektiert dieser die ungültige Referenz und gibt diesen Fehler aus. Unmittelbar danach wird der FB verlassen.

FB_ERR_HLI_CHAN_IFC_IDX

87

Der in einer Achsgruppenreferenz abgelegte Index für die Adressierung einer kanalspezifischen HLI-Schnittstelle liegt außerhalb des zulässigen Bereiches und würde eine Schnittstelle adressieren, die nicht existiert.

FB_ERR_HLI_CHAN_IFC_ADDRESS

88

Eine Achsgruppenreferenz verweist auf eine kanalspezifische HLI-Schnittstelle, die nicht belegt ist. Wird über einen FB, der diese Referenz nutzt um einen Kanal zu beauftragen, ein Kommando abgesetzt, detektiert dieser die ungültige Referenz und gibt diesen Fehler aus. Unmittelbar danach wird der FB verlassen.

FB_ERR_AXREF_TYPE_4

89

Ein FB, der eine Achsreferenz des Typs REF_SAI_AXIS oder REF_AXGRP_AXIS benötigt, hat eine Achsreferenz erhalten, die nicht von diesem Typ ist.

FB_ERR_IS_NO_SPINDLE

90

Die Achsreferenz, die an einen FB angelegt wurde referenziert eine Achse, die nicht als Spindel konfiguriert ist. Der FB kann seine Kommandos jedoch nur an eine solche Achse absetzen.

FB_ERR_CO_BUS_NOT_RDY

91

Spezifischer Fehler des FB MC_Power.

Der Leistung für den CANopen-Antrieb kann nicht eingeschalten werden, da ein Fehler am Antriebsbus vorliegt.

FB_ERR_CO_NOT_RDY_SWITCH_ON

92

Spezifischer Fehler des FB MC_Power.

Der CANopen-Antrieb ist für die Zuschaltung der Leistung nicht bereit.

FB_ERR_CO_NO_DRV_RELEASE

93

Spezifischer Fehler des FB MC_Power.

Die Leistung kann für den CANopen-Antrieb nicht eingeschalten werden, da die Hardwarefreigabe nicht gesetzt ist.

FB_ERR_CO_INV_STATE_TRANS

94

Spezifischer Fehler des FB MC_Power.

Der Zustandsautomat im CANopen-Antrieb für die Leistungszuschaltung reagiert nicht wie erwartet.

FB_ERR_CO_DRV_ERR

95

Spezifischer Fehler des FB MC_Power.

Der CANopen-Antrieb meldet einen Antriebsfehler. Die Leistung kann erst nach Beseitigen des Fehlers eingeschalten werden.

FB_ERR_GEARIN_MODE

96

Spezifischer Fehler des MC_GearIn.

Der Eingangsvariablen Mode einer Instanz des MC_GearIn wurde ein ungültiger Wert zugewiesen. Der Wert der Eingangsvariable Mode muss einem Wert des Typs MC_GearInMode entsprechen. Erlaubte Werte sind:

0: (16#0) | Kopplungsart zwischen Master- und Slaveachse: Sollwertseitige-Kopplung. Automatischer Phasenausgleich: aus.
128: (16#80) | Kopplungsart zwischen Master- und Slaveachse: Istwertseitige-Kopplung.
256: (16#100) | Automatischer Phasenausgleich: ein. Darf nur für Testzwecke verwendet werden!

FB_ERR_TNA_NO_ACTIVE_MOTION

97

MC_GroupStop konnte nicht beauftragt werden, da sich die aktuelle Achsgruppe in keinem Bewegungszustand (GroupDiscreteMotion oder GroupSynchronizedMotion) befindet.

FB_ERR_TNA_NO_GROUP_ERROR_STOP

98

MC_GroupReset konnte nicht beauftragt werden, da sich die aktuelle Achsgruppe nicht im Fehlerzustand (GroupErrorStop) befindet.

FB_ERR_ILLEGAL_INTERNAL_STATE

99

Der FB befindet sich in einem unzulässigen Zustand.

FB_ERR_RESET_ALREADY_ACTIVE

100

Spezifischer Fehler des FB MC_Reset.

Eine FB-Instanz des Typs MC_Reset detektiert an seinem Execute-Eingang eine steigende Flanke und will deshalb einen Reset über die durch die AXIS_REF definierte achsspezifische Schnittstelle an den Motion-Controller absetzen. Dies ist aber nicht möglich, da die Schnittstelle bereits belegt ist, weil eine andere Instanz dieses Typs bereits einen Reset abgesetzt hat und nun auf die Quittierung wartet. Erst dann ist die entsprechende achsspezifische Schnittstelle wieder frei und kann erneut beauftragt werden.

FB_ERR_NOT_IMPLEMENTED

101

Die Funktionalität des FBs, Programms oder der Funktion sind nicht implementiert.

FB_ERR_AXREF_TYPE_5

102

Ein FB, der eine Achsreferenz des Typs REF_SAI_AXIS benötigt, hat eine Achsreferenz erhalten, die nicht von diesem Typ ist.
Besitzt dieser FB einen Eingang für eine Slaveachse, liegt der Fehler in der Achsreferenz am Slave-Eingang vor.

FB_ERR_AXREF_TYPE_6

103

Ein FB, der am Eingang für die Masterachse eine Achsreferenz des Typs REF_SAI_AXIS benötigt, hat eine Achsreferenz erhalten, die nicht von diesem Typ ist.

FB_ERR_SERCOS_IDENT_SERVICE

104

Beim Lesen oder Schreiben einer SERCOS-Ident ist ein Fehler aufgetreten.

FB_ERR_IIG_ALREADY_USED

105

Spezifische Fehlermeldung des FB MC_AddAxisToGroup.

Eine Instanz dieses FBs wird beauftragt eine Achse an einer durch den Eingang IdentInGroup (IIG) bestimmten Position in einer Achsgruppe einzuordnen. Der FB prüft daher, ob diese Position verfügbar ist. Im Falle dieser Meldung stellt der FB fest, dass an dieser Position bereits eine andere Achse eingefügt wurde.

FB_ERR_TO_MUCH_ACTIVE_JOBS

106

Jede Achsgruppe kann eine bestimmte Anzahl Aufträge parallel in Bearbeitung haben. Wenn ein FB nun einen Auftrag abschickt und festgestellt wird, dass die maximale Anzahl Aufträge bereits in Bearbeitung ist, wird diese Fehlermeldung ausgegeben. Der Auftrag wird dann nicht an den Motion-Controller abgesetzt.

FB_ERR_AXGRP_REF_CHW_ACTIVE

107

Eine frühere Beauftragung eines FB ist aktiv, der FB hat noch keine Quittierung für diesen Auftrag erhalten. In der Zwischenzeit wurde diesem FB eine andere Achsengruppe zugeordnet (AXES_GROUP_REF hat sich geändert).

Dies ist nicht zulässig, da ansonsten der FB die Quittierung des Auftrags für die zuvor beauftragte Achsengruppe nicht erhält und damit weiterhin aktiv bleibt.

108

Nutzbar für zukünftige Meldungen.

109

Nutzbar für zukünftige Meldungen.

FB_ERR_PLCIO_ADDRESS

110

Ein FB will auf die Daten einer SERCOS-IO-Station zugreifen. Dazu benötigt er Zugriff auf den zugeordneten Speicher. Vor dem Zugriff überprüft der FB ob dieser Speicher vorhanden ist und zeigt diese Meldung im Falle der Speicher nicht existiert.

Abhilfe: Motion-Controller zuerst starten, dann die PLC-Applikation.

FB_ERR_INP_STATION_IDX

111

Input-Stations Index überschreitet die erlaubten Grenzen.

FB_ERR_INP_SLOT_IDX

112

Input-Stations Slot-Index überschreitet die erlaubten Grenzen.

FB_ERR_INP_DATA_IDX

113

Input-Slots Datenwort Index überschreitet die erlaubten Grenzen.

FB_ERR_OUTP_STATION_IDX

115

Output-Stations Index überschreitet die erlaubten Grenzen.

FB_ERR_OUTP_SLOT_IDX

115

Output-Stations Slot-Index überschreitet die erlaubten Grenzen.

FB_ERR_OUTP_DATA_IDX

116

Output-Slots Datenwort-Index überschreitet die erlaubten Grenzen.

FB_ERR_TNA_AXGRP_UNDEF

117

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe noch in einem undefinierten Zustand befindet.

FB_ERR_TNA_AXGRP_STDBY

118

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe im Zustand GroupStandby befindet.

FB_ERR_TNA_AXGRP_ERRSTOP

119

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe im Zustand GroupErrorStop befindet.

FB_ERR_TNA_AXGRP_STOPPING

120

Die Achsgruppe konnte nicht beauftragt werden, weil sich die Achsgruppe im Zustand GroupStopping befindet. Falls alle Achsen der Achsgruppe physikalisch bereits stillstehen und trotzdem diese Meldung auftritt, dann ist der Grund hierfür, dass eine Instanz eines FB MC_GroupStop auf dieser Achsgruppe das Anhalten der Achsen beauftragt hat und der Execute-Eingang dieser Instanz noch den Wert TRUE besitzt. Dies führt dazu, dass sich diese Achsgruppe dann solange im Zustand GroupStopping befindet bis der Execute-Eingang dieser MC_GroupStop-Instanz wieder auf FALSE zurückgesetzt wurde.

FB_ERR_TNA_AXGRP_MOVING

121

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe im Zustand GroupMoving befindet.

FB_ERR_TNA_AXGRP_SYNCMOTION

122

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe im Zustand GroupSynchronizedMotion befindet.

FB_ERR_TNA_AXGRP_DISABLED

123

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe im Zustand GroupDisabled befindet.

FB_ERR_TNA_AXGRP_INIT

124

Achsgruppe konnte nicht beauftragt werden, weil sich die beauftragte Achsgruppe noch in der Initialisierungsphase befindet.

FB_ERR_TNA_AXGRP_HOMING

125

Achsgruppe konnte nicht beauftragt werden, weil die beauftragte Achsgruppe noch eine Justagebeauftragung abarbeitet.

FB_ERR_TNA_AXGRP_UNKNOWN_STATE

126

Achsgruppe konnte nicht beauftragt werden, weil der Wert, der den Achsgruppenzustand beschreibt, einen nicht erlaubten Wert angenommen hat.

FB_ERR_DEACTIVATE_NOT_ALLOWED

127

Die Achse kann nur deaktiviert (Achszustand DISABLED) werden, wenn sie sich im Zustand STANDSTILL befindet.

FB_ERR_MODE_ADDCMDVALUES

128

Spezifischer Fehler des FB MCV_AddCmdValues.

Der Eingangsvariable Mode einer Instanz des MCV_AddCmdValues wurde ein ungültiger Wert zugewiesen. Diese Eingangsvariable legt fest, wie der Wert an Eingangsvariable Value zu interpretieren ist. Gültige Werte sind:

· 1 (*ADD_POS_VALUE*):
Wert an Value ist ein Positionswert

· 2 (*ADD_SPEED_VALUE*):
Wert an Value ist ein Geschwindigkeitswert

FB_ERR_NR_REDSPEEDZONE

129

Spezifischer Fehler des FB MCV_RedSpeedZone.

Der Eingangsvariable ZoneNr einer Instanz des MCV_RedSpeedZone wurde ein ungültiger Wert zugewiesen. Mit diesem Eingang wird eine der in den Achsparametern konfigurierten Zonen ausgewählt, in der mit reduzierter Geschwindigkeit verfahren werden soll.

Gültige Werte für ZoneNr: 1, 2

FB_ERR_NR_DRIVEWORD

130

Spezifischer Fehler des FB MCV_DriveWord.

Der Eingangsvariable DriveWordNr einer Instanz des MCV_DriveWord wurde ein ungültiger Wert zugewiesen.

Gültige Werte für DriveWordNr: 1 - 4

FB_ERR_NR_MODE

131

Spezifischer Fehler des FB MCV_Mode.

Der Eingangsvariable ModeNr einer Instanz des MCV_Mode wurde ein ungültiger Wert zugewiesen.

Gültige Werte für ModeNr: 0 - 2

FB_ERR_HLI_PFORM_IFC_ADDRESS

132

Funktionsblöcke, die zur Behandlung von plattformspezifischen Daten implementiert sind, prüfen vor dem Zugriff auf die Schnittstelle, ob ein gültiger Wert für den Zeiger auf diese Schnittstelle vorhanden ist. Wird diese Fehlermeldung ausgegeben, ist der Zeiger 0 und damit ungültig.

FB_ERR_NR_GRPREDSPEEDZONE

133

Spezifischer Fehler des FB MCV_GrpRedSpeedZone.

Der Eingangsvariable ZoneNr einer Instanz des MCV_GrpRedSpeedZone wurde ein ungültiger Wert zugewiesen. Mit diesem Eingang wird eine der in den Achsparametern konfigurierten Zonen ausgewählt, in der mit reduzierter Geschwindigkeit verfahren werden soll.

Gültige Werte für ZoneNr: 1, 2

FB_ERR_NOT_USED

134

Derzeit kein verwendeter Fehlercode.

FB_ERRS_FBSTATE

135

Systemfehler: Zeigt ein Funktionsblock diese Fehlermeldung, hat der im Funktionsblock verwaltete Zustand einen nicht definierten Wert angenommen. Der Funktionsblock wird dann in einen Zustand gebracht, in dem er keine Aufträge mehr annehmen kann.

Bitte setzen Sie sich mit dem Steuerungshersteller in Verbindung.

FB_ERRS_STATE_JOB_ACK

136

Systemfehler : Zeigt ein Funktionsblock diese Fehlermeldung, dann wurde vom Motion Controller ein nicht definierter Wert für die Quittierung eines Auftrags zurückgegeben. Der Funktionsblock wird dann in einen Zustand gebracht, in dem er keine Aufträge mehr annehmen kann.

Bitte setzen Sie sich mit dem Steuerungshersteller in Verbindung.

FB_ERR_STRTOBUF_01

137

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 1.

Hinweis von KW-Software:

Die VAR_IN_OUT-Beschreiber für die Parameter SRC und BUFFER sind ungültig. Es handelt sich hierbei um einen internen Fehler.

FB_ERR_STRTOBUF_02

138

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 2.

Hinweis von KW-Software:

Die Länge des Quellpuffers passt nicht. Die Anzahl der zu kopierenden Bytes (definiert an BUF_CNT) überschreitet die verfügbare Größe des SRC.

FB_ERR_STRTOBUF_03

139

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 3.

Hinweis von KW-Software:

Die Länge des Quellpuffers passt nicht. Die Anzahl der zu kopierenden Bytes (definiert an BUF_CNT) und der an BUF_OFFS festgelegte Offset im Byte-Strom überschreiten die Länge des angeschlossenen Byte-Stroms.

FB_ERR_STRTOBUF_04

140

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 4.

Hinweis von KW-Software:

Dieser Datentyp wird nicht unterstützt.

FB_ERR_STRTOBUF_05

141

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 5.

Hinweis von KW-Software:

Die Ausrichtung passt nicht zu diesem Datentyp. Die durch BUF_CNT definierte Größe, die kopiert werden soll, muß ohne Rest durch die Größe des Datentyps teilbar sein.

FB_ERR_STRTOBUF_06

142

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 6.

Hinweis von KW-Software:

Die Konvertierung INTEL/MOTOROLA ist fehlgeschlagen.

FB_ERR_STRTOBUF_07

143

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 7.

Hinweis von KW-Software:

Die Länge der Zeichenfolge passt nicht. Für den Datentyp STRING sind zusätzliche Prüfabläufe notwendig. Weitere Informationen hierzu finden Sie im Thema 'Eigenschaften bei Zeichenfolgen' der Multiprog-Hilfe von KW-Software.

FB_ERR_STRTOBUF_08

144

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 8.

Hinweis von KW-Software:

Der Zielpuffer hat einen falschen Datentyp. In manchen Fällen wird der Datentyp geprüft. Weitere Informationen hierzu finden Sie jeweils in den speziellen Kapiteln für jeden Datentyp.

FB_ERR_STRTOBUF_09

145

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 9.

Hinweis von KW-Software:

Der Offset-Wert ist nicht korrekt. In manchen Fällen wird der Offset geprüft. Weitere Informationen hierzu finden Sie jeweils in den speziellen Kapiteln für jeden Datentyp.

FB_ERR_STRTOBUF_10

146

Spezifischer Fehler von STR_TO_BUF.

Ausgang Status des FB hat den Wert 10.

Hinweis von KW-Software:

Der Parameter BUF_CNT passt nicht. In manchen Fällen wird die zu kopierende Größe geprüft. Weitere Informationen hierzu finden Sie jeweils in den speziellen Kapiteln für jeden Datentyp.

FB_ERR_STRTOBUF_11

147

Spezifischer Fehler von STR_TO_BUF11.

Ausgang Status des FB hat den Wert 1.

Hinweis von KW-Software:

Die Adresse der Quelle und des Ziels ist die gleiche.

FB_ERR_STRTOBUF_UNKNOWN

148

Systemfehler : nicht definierter Wert am Ausgang Status einer STR_TO_BUF Funktionsblockinstanz.

Bitte setzen Sie sich mit dem Steuerungshersteller in Verbindung.

FB_ERR_TRIGGER_DISMISSED

149

Ein Funktionsblock mit dieser Meldung hat einen neuen Auftrag erhalten, ist aber noch mit einem zu einem früheren Zeitpunkt abgesetzten Auftrag beschäftigt. Der zuvor abgesetzte Auftrag wird weiter durchgeführt, die neue Beauftragung wird verworfen.

FB_ERR_LREALDINT_RANGE

150

Der Funktionsblock hat einen Eingangswert vom Typ LREAL erhalten der außerhalb des erlaubten Wertebereichs von

-2147483648.0 < Wert < 2147483647.0

liegt.

FB_ERR_NR_FB_INSTANCES

151

Systemfehler : Diese Meldung wird dann angezeigt, wenn in einer SPS-Applikation mehr PLCopen-Funktionsblockinstanzen angelegt wurden, als die Auftragsverwaltung behandeln kann.

Bitte setzen Sie sich mit dem Steuerungshersteller in Verbindung.

FB_ERR_MODE_INVALID

152

Spezifischer Fehler eines MC_GearIn oder MC_GearInPos.

Bei der Beauftragung des Funktionsblocks wird festgestellt, dass am Eingang Mode ein ungültiger Wert anliegt. Die Beauftragung wird deshalb verworfen.

Gültige Werte am Eingang Mode sind:

0: (16#0) | Sollwertseitige-Kopplung.
128: (16#80) | Istwertseitige-Kopplung.

FB_ERR_MASTER_START_DIST

153

Spezifischer Fehler eines MC_GearInPos.

Bei der Beauftragung des Funktionsblocks wird festgestellt, dass am Eingang MasterStartDistance der ungültige Wert 0.0 anliegt. Die Beauftragung wird deshalb verworfen.

FB_ERR_SYNC_MODE

154

Spezifischer Fehler eines MC_GearInPos.

Bei der Beauftragung des Funktionsblocks wird festgestellt, dass am Eingang SyncMode ein ungültiger Wert anliegt. Die Beauftragung wird deshalb verworfen.

Gültige Werte am Eingang SyncMode sind:

0: | Synchronisation in negativer Richtung
1: | Synchronisation in positiver Richtung

FB_ERR_BUFFERMODE

155

Bei der Beauftragung des Funktionsblocks wird festgestellt, dass am Eingang BufferMode ein ungültiger Wert anliegt. Die Beauftragung wird deshalb verworfen.

FB_ERR_NO_AXIS_NAME

156

Spezifische Fehlermeldung des FB MC_AddAxisToGroup.

Es wurde keine Bezeichnung einer Achse verwendet.

FB_ERR_WRONG_AXIS_NAME

157

Spezifische Fehlermeldung des FB MC_AddAxisToGroup.

Es wurde eine fehlerhafte Bezeichnung für eine Achse verwendet.

FB_ERR_CAMTAB_NOT_FOUND

158

Eine Camming-Tabelle mit der angelegten CamTableID konnte nicht gefunden werden.

FB_ERR_CAMTAB_COLUMNS

159

Die Camming-Tabelle besitzt weniger Spalten. Der Zugriff auf die Camming-Tabelle wird verhindert.

FB_ERR_CAMTAB_ELEM

160

Am Eingang Mode wurde ein Wert für ein nicht definiertes Camming-Tabellen-Element angegeben.

Definierte Wert für Camming-Tabellen-Elemente sind:

0: HLI_CAM_TABLE_VALUE Tabellenwert

1: HLI_CAM_TABLE_TYPE Tabellentyp

2: HLI_CAM_TABLE_FCT_TYPE Interpolationstyp

3: HLI_CAM_TABLE_LINES Zeilenanzahl

FB_ERR_CAMTAB_FUNCTYPE

161

In der Camming-Tabelle wurde ein nicht definierter Interpolationstyp vorgefunden.

Definierte Werte für den Interpolationstyp in Camming-Tabellen sind:

0 STEP_DIRECT (default)

1 LINEAR

2 POLYNOM_3

3 POLYNOM_3_KOEFF

4 LINE_POLY5

5 POLY5_LINE

6 TABLE_DEFINED

FB_ERR_CAMTAB_LINES

162

Die Camming-Tabelle enthält weniger Zeilen, als am Eingang CamTableLine angegeben wurden. Der Zugriff auf die Camming-Tabelle wird verhindert.

FB_ERR_CAMTAB_TYPE

163

In der Camming-Tabelle wurde ein nicht definierter Tabellentyp vorgefunden.

Definierte Werte für Camming-Tabellen sind:

0 TABLE_NONE (defaut)

1 TABLE_ONE_COLUMN_SGN16

2 TABLE_ONE_COLUMN_SGN32

3 TABLE_ONE_COLUMN_REAL64

4 TABLE_4_COLUMN_SGN32

5 TABLE_4_COLUMN_REAL64

6 TABLE_MOTION_PATTERN

7 TABLE_2_COLUMN_SGN32

FB_ERR_CAMTAB_ELEM_NH

164

Am Eingang Mode wurde ein definiertes Camming-Tabellen-Element angegeben, das in dem FB nicht behandelt wird.

FB_ERR_CAMTAB_TYPE_NH

165

Der in der Tabelle vorgefundene Tabellentyp ist definiert, wird aber in diesem FB nicht behandelt.

FB_ERR_TRACE_RE_TRIGGERD

166

Spezifische Fehlermeldung des FB MCV_TRACE.

Es wurde ein Trace beauftragt, bevor der FB die Quittierung für einen zuvor abgesetzten Trace-Auftrag erhalten hat.

FB_ERR_TRACE_WRITE_FILE

167

Spezifische Fehlermeldung des FB MCV_TRACE.

Das Tracefile kann erst geschrieben werden, wenn der Trace-Auftrag angehalten wurde.

FB_ERR_AX_TECHFCT_NR

10001

Spezifische Fehlermeldung eines FBs des Typs

· MCV_MFctAxis

· MCV_HFctAxis

· MCV_SFctAxis

· MCV_TFctAxis

der die jeweilige achsspezifisch ausgegebene M/H/S/T-Technologiefunktion behandelt.

Dieser Fehler tritt auf, wenn der am Eingang Nr angelegte Wert eine Technologiefunktion bezeichnet, die von der PLC nicht verwaltet wird.

FB_ERR_CH_TECHFCT_NR

10002

Spezifische Fehlermeldung eines FBs des Typs

· MCV_MFctChannel

· MCV_HFctChannel

· MCV_SFctChannel

· MCV_TFctChannel

der die jeweilige kanalspezifisch ausgegebene M/H/S/T-Technologiefunktion behandelt.

Dieser Fehler tritt auf, wenn der am Eingang Nr angelegte Wert eine Technologiefunktion bezeichnet, die von der PLC nicht verwaltet wird.

FB_ERR_HLI_HMI_IFC_IDX

10003

Spezifische Fehlermeldung eines FBs des Typs

· MCV_PlcKey

· MCV_PlcParam

· MCV_PlcString

über den Daten mit der PLC ausgetauscht werden können.

Durch den am Eingang Idx angelegte Wert greift der FB auf eine HLI-Schnittstelle zu, die nicht existiert.

Der Wert von Idx muss zwischen

· 0 <= Idx <= HLI_HMI_PLC_KEY_MAXIDX,
bei FBs des Typ MCV_PlcKey

· 0 <= Idx <= HLI_HMI_PLC_PAR_MAXIDX,
bei FBs des Typ MCV_PlcParam

· 0 <= Idx <= HLI_HMI_PLC_STR_MAXIDX,
bei FBs des Typ MCV_PlcString

liegen.

FB_ERR_HLI_HMI_IFC_ADDRESS

10004

Spezifische Fehlermeldung eines FBs des Typs

· MCV_PlcKey

· MCV_PlcParam

· MCV_PlcString

Das HLI-Interface zum Austausch von Daten mit der PLC existiert nicht.

FB_ERR_CHAX_AXISREF

10005

Spezifischer Fehler des FB MC_GroupReadConfiguration.

Es wird die Achsreferenz einer Achse in einem Kanal gesucht, die über eine Struktur des Typs IDENT_IN_GROUP_REF beschrieben wurde. Diese Achse ist aber im Kanal nicht vorhanden.