Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Einleitung

Da bestehende Backup-Systeme, welche die Festplattenimages zur Wiederherstellung nutzen in vielen Fällen unzureichend sind, weil sich z.B. die IO-Geräte vom Sicherungs-PC und dem Wiederherstellungs-PC unterscheiden, wurde TwinCAT Backup entwickelt.

Mit TwinCAT-Backup können, neben Dateien, Verzeichnissen und Einstellungen, auch TwinCAT-Konfigurationen gesichert werden. Der Anwender kann auch zusätzlich zu sichernde Teile ergänzen. Außerdem werden notwendige betriebssystemspezifische Informationen gesichert. Hierzu zählen Usereinstellungen, Profile, Netzwerkeinstellungen und vieles andere mehr. Die Sicherung kann auf allen am PC angeschlossenen Medien durchgeführt werden. Dies kann eine Festplatte, eine Diskette, ein CD-Brenner oder ein Netzwerklaufwerk sein.

Im Restore-Fall werden alle Dateien und Einstellungen auf einen neuen Rechner, auf dem sich schon ein Betriebssystem befindet, zurückgespielt. Zusätzlich wird TwinCAT installiert und konfiguriert. Dazu gehört auch die automatische Erstellung einer System-Manager-Konfiguration und das Erstellen eines Bootprojektes. Anwenderspezifische Installationen können ausgeführt werden.
Sind Feldbuskarten unterschiedlich (stecken z. B. die Karten auf unterschiedlichen PCI-Slots), so versucht das Backup-Tool eine automatische Anpassung durchzuführen. Zwischen bestimmten Feldbuskarten kann sogar ein automatisches Update durchgeführt werden. Die Konfiguration des Backups erfolgt in XML.

Die folgende Dokumentation erläutert die Konfiguration des TwinCAT Backup Systems.

Grundsätzlich besteht das TwinCAT Backup System aus zwei Komponenten:

  • einem TcBackupServer Dienst
  • und einer Konfigurations- bzw. Restore Oberfläche zur Einstellung des TcBackupServers.

Der Konfigurator dient zur Einstellung der Backup Informationen und zum Zurückladen (Restore) der Sicherung.
Der Server Dienst ist die Komponente, welche die mit dem Einlesen der Backup Konfiguration zu sichernden Daten zu einem TwinCAT Backup Storage sammelt.


Profil-Update

Zur Ansicht von erstellten und vorhanden Backup Profil-Daten wird im Kontext-Menü "Update profiles" die Baumstruktur neu aufgebaut.

Sind Profile vorhanden, so werden die unterhalb des Konfigurations-Eintrages dargestellt. Anschließend erhält man die Möglichkeit die Profile zu editieren und zu verwalten.

Create profile: Neues Profil erstellen

Delet profile: Profil löschen

Enable/Disable profile:Profil aktivieren/deaktivieren

View/change profile: Profile ansehen/ändern


Neue Konfiguration erstellen

Um Daten vom einem System sichern zu können, muß zunächst ein Profil konfiguriert werden, dass die Informationen über Optionen der Sicherung enthält.

Eine neues Backup Profil wird über den Kontext der "TwinCAT Backup Configuration - Create profile" erstellt.

Die Konfiguration erfolgt über Wizards, die die gewünschten Backup Daten einsammeln.
Der Benutzername und das Passwort sollte über Administratoren Rechte verfügen,damit ausreichende Zugriffsrechte zur Wiederherstellung und zum System Reboot zur Verfügung stehen.


Konfigurationsoptionen

Im folgenden werden die Konfigurationsoptionen während der Wizard-Einstellung beschrieben.

Benutzerdaten

Zur Möglichkeit von Autoboot-Vorgängen des Betriebssystems (um beispielsweise bootfähige Setups einzubinden) sind gültige Nutzerdaten vom System notwendig. Diese Einstellungen werden für die Windows Autoboot Optionen genutzt.

Geben Sie hier Ihren Windows Benutzernamen, sowie das Passwort an. Bestätigen Sie das Passwort und wählen Sie "Weiter >".

Profilname und Verzeichnispfad

Zur Identifizierung der Backup Konfigurationen sind symbolische Namen erforderlich. Mit der Pfadangabe wird bestimmt, in welchen Verzeichnis das Backup Archiv (welches nach der Ausführungen verfügbar ist) abgelegt wird.

Geben Sie den Pfadnamen ein und bestätigen Sie mit "Weiter >".

Typauswahl

Die Typauswahl bestimmt mit welcher Zeiteinstellung Backups ausgeführt werden sollen. Zur Verfügung stehen:

  • Backup on interval: Zyklisches Backup nach einem gewählten Intervall
  • Backup on every day: Tägliches Backup
  • Backup on every week: Wöchentliches Backup
  • Backup on every month: Monatliches Backup

Wählen Sie einen Typ aus.

Diese Einstellung bildet die Basis für die Startauswahl unter der Rubrik "Zeiteinstellung".

Vorwahl der Backupdaten

Mit diesem Wizard werden Informationen über die Sicherungsdaten gesammelt.

Möglich an dieser Stelle ist die Sicherung von:

  • Files and directories: Auswahl für Verzeichnisse und Dateien

Note:

Wichtig hierbei ist, dass die Auswahl der Kopier- und Kopierpfadoptionen zwingend vor der Auswahl der Verzeichnisse und Dateien erfolgen muss! Ansonsten sind diese Dateien nur im Backuparchiv vorhanden.

  • Registry keys: Einstellung der Windows Registrierung
  • Operating system user infos: Windows Benutzerkonten
  • Operating system group info: Windows Benutzergruppen
  • TwinCAT system data: TwinCAT relevante Daten wie
    Bootprojekt, Retain Daten, Persistente Daten, System Manager Konfiguration, TwinCAT Net ID, Sicherung des SPS Projektes kompatibel mit TwinCAT 2.8, TwinCAT Registry Einträge.

  • Network infos:
  • Enable logging: Mitschreiben von Meldungen während des Backups
  • Enable silent restore mode:
  • Store OS autologin:
  • Store OS autologinuser:
  • Backup AutoStart folder:

Setups und DLL Registrierung einbinden

Setups und die Möglichkeit zur DLL Registrierung können in das Backup eingebunden werden. Diese Informationen werden zum Zeitpunkt der Zurückspeicherung ausgeführt.

  • Setup wie zum Beispiel InstallShield Installationen

Nach Auswahl des Setups und Bestätigung mit OK öffnet sich folgender Dialog:

Zur benutzerunabhängigen Ausführung von Installationen Bedarf es einiger Parameter wie am Beispiel gezeigt. Auch an dieser Stelle müssen die Optionen vor der Auswahl der Datei ("Setup.exe") erfolgen. Benutzerunabhängig sind Installationen, die ohne Eingaben ausführbar sind. Viele Installationsprogramme bieten derartige Möglichkeiten. Die Parametrierung erfolgt über Kommandozeilen-Parameter. Folgende Optionen sind möglich:

  • Reboot required: Durch diese Option wird signalisiert, dass beim Restore und nach Ausführung der Installation ein System-Neustart erforderlich ist.
  • Register DLL: Die DLL Registrierung ist über "DLL register" ähnlich wie bei Setup-Routinen einstellbar. Die Auswahl der DLL erfolgt über den Auswahlbaum
  • Execution after file restore:
  • TwinCAT Installation: TwinCAT beim Restore installieren
  • Time scale on setup process:

Zeiteinstellung

Die Auswahl der Zeiteinstellung schließt ein neues Backup Profil ab.

Lediglich der Startzeitpunkt ist einzustellen:

  • Service start date und time: Starttag und Startzeit des Backup

Die weitere Skalierung wird über den Backup Typ eingestellt (hier wurde Backup on interval gewählt), kann jedoch geändert werden:

  • Interval: Zeitintervall in Minuten, nach dem das Backup erneut durchgeführt wird.
  • Delete storages older than "xx" days: Löscht Storages, die älter als "xx" Tage sind.
  • Keep the min. number of "xx" storages: Definiert, wie viele Storages minimal erhalten bleiben sollen.


Konfiguration löschen

Gelöscht wird eine nicht mehr genutzte Backup Konfiguration über den Kontext des entsprechenden Profiles.


Konfiguration anzeigen und ändern

Die Konfiguration lässt sich über "View/change profile" ändern und anzeigen. Die entsprechenden Informationen stellen die Karteireiter 'General', 'Options', 'Backup' und 'Scheduled settings', zur Verfügung.

Eine genauere Beschreibung dieser Informationen finden Sie unter Konfigurationsoptionen.


TwinCAT zum Restore installieren

TS1150 | TwinCAT Backup

TwinCAT beim Restore installieren

Soll ein TwinCAT Build zu einem Restorevorgang installiert werden, so muss dieses im TcBackup konfiguriert werden. Damit eine vollständige Installation möglich wird, müssen einige Randbedingungen erfüllt sein:

  • Es muss eine automatische Installationsscript-Datei ("*.iss") zur Verfügung stehen. In der Defaulteinstellung wird eine TwinCAT Version auf Festplatte C:\ entsprechend dem Level installiert.
  • Auf der CD müssen die extrahierten TwinCAT "OneFile" Versionen wie folgt abgelegt sein:

1. Zufügen der TwinCAT Installation in die Backup Konfiguration über 'Add...':

2. Browsen nach der 'Setup.exe' der Installation:

3. Setzen der Parameter wie folgt:


OnDemand

Über den Kontext "Backup OnDemand" lässt sich ein Backup unmittelbar anstoßen. Alle erstellten Profile werden dabei nacheinander ohne Berücksichtigung der Zeiteinstellungen ( in Scheduled Settings) abgearbeitet.

Bedienung über die Toolbar:

Startet den Backup Dienst OnDemand.


Service Start/Stop

Im Kontextmenü "TwinCAT Backup OnDemand" ist der Status des Backup Server Dienstes sichtbar. Der Dienst lässt sich je nach Wunsch starten und stoppen. Im Stopp werden keine Backup Dienste ausgeführt.

Bedienung über die Toolbar:

Stoppt den Backup Dienst

Startet den Backup Dienst. Das Backup wird zu dem unter Scheduled Settings festgelegten Zeitpunkt ausgeführt.


Restore

Mit dem Restore werden alle Daten und Einstellungen zurückgespielt.

Ein Restore benötigt ein zuvor gesichertes Backup Archiv ( TwinCAT Backup Storage *.tbs). Dieses Archiv öffnen Sie mit "Scan backup storages":

Die Archive sind jetzt unter TwinCAT Restore verknüpft.

Zur Anzeige der Einstellungen wählen Sie "View backup storage".

Um das Restore zu starten, wählen Sie "Restore backup storage".

Die TwinCAT Recovery CD erstellen Sie mit "Create TwinCAT recovery CD".

Das Backup Archiv *.tbs kann mit "Delete backup Storage" gelöscht werden.

Wenn Sie "View backup storage" gewählt haben, können Sie die Daten des Archivs in den Karteireitern ablesen. Üblicherweise sind die Storages in dem dazu eingestellten Verzeichnis abgelegt. Gegebenenfalls muss der Pfad im Kontext auf dem Karteireiter 'General' angepasst werden.

Nachdem Sie das Restore gestartet haben, ist die Abarbeitungsreihenfolge wie folgt, sofern die Daten verfügbar sind:

  • Ausführen von Installationen und DLL Registrierungen
  • Zurückspeichern von Verzeichnissen und Dateien
  • Zurückspeichern der System Registry
  • Zurückspeichern der der Benutzer- und Gruppendaten
  • Wiederherstellen der TwinCAT Systemdaten


Restore von CD

Ein Rückspeichern eines Archives kann auch von einer CD erfolgen. Im Auslieferungsumfang ist eine Datei "TcBackupCD.zip" enthalten, welche extrahiert als Template zur Erstellung einer AutoPlay CD-ROM verwendet werden kann. In dem CD Root-Verzeichnis müssen folgende Dateien abgelegt sein:

<CD-ROM Drive Root:\>

  • AUTORUN.INF
  • TcBackupRestoreCfg.exe
  • TcBackupRestoreCfg.ico
  • zlib.dll
  • AdsDll.dll
  • "TwinCAT Backup Storagename".tbs

Das TwinCAT Sicherungsarchiv "TwinCAT Backup Storagename".tbs" muss zunächst konfiguriert und erstellt werden. Anschließend wird das Archiv mit in das CD-Root kopiert. Das TcBackup sucht beim Einlegen der CD automatisch nach einem Backup Storage, sofern die AutoPlay Funktion des Betriebssystems eingeschaltet ist.