Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem Zeitpunkt veröffentlichte Dokumentation zu verwenden.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.

Copyright

© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


ADS Communication Library: Übersicht

TS6000 | TwinCAT ADS Communication Library

Übersicht

Die "TwinCAT ADS Communication Library" wird mit der TwinCAT Installation ausgeliefert. Es ermöglicht eigene Anwendungen (z.B. Visualisierungen, Messwerterfassung) zu entwickeln, die mit TwinCAT Geräten (z.B. SPS, NC oder IO-Geräten) kommunizieren können.

Alternativ stellen Ihnen unser kostenloses TC1000 | TC3 ADS Setup die Bibliotheken und den ADS Router bereit, falls Sie nur die ADS Funktionalitäten benötigen.

Komponenten der "TwinCAT ADS API"

Nach erfolgreicher Installation befinden sich die Komponenten im Verzeichnis "..\TwinCAT\AdsApi".

Es stehen für folgende Zielsysteme und Technologien ADS Bibliotheken bereit:

Windows (32-Bit/64-Bit)

Windows CE

WebServices

Windows (32-Bit/64-Bit)

Name | Programmiersprache / Technologie | Betriebssystem | Beschreibung | Pfad | Referenz | Samples
TwinCAT.Ads.dll | .NET (C#, VB .Net) | Windows XP, Vista, 7, 8 | ADS.NET Komponenten für die verschiedenen Versionen des .NET Frameworks (1.0 / 1.1 / 2.0/ 4.0) | ..\TwinCAT\AdsApi\.NET | Link | C# Delphi VB LabVIEW MeasurementStudio WPF C# WPF VB
TcAdsDll | C/C++ | Windows XP, Vista, 7, 8 | Die ADS Komponenten (DLL / Header / Library) zum Erstellen von C/C++ Applikationen | ..\TwinCAT\AdsApi\TcAdsDll | Link | C++ LabVIEW VB Delphi
AdsOcx | VB, VBA, COM | Windows XP, Vista, 7, 8 | Das ADS-OCX wurde als ActiveX-Steuerelement realisiert und basiert auf der COM-Technologie von Microsoft. | ..\TwinCAT\AdsApi\AdsOcx | Link | VB Delphi LabVIEW
AdsToJava | Java | Windows XP, Vista, 7, 8 | TcJavaToAds.jar Bibliothek welche den AdsToJava.dll-Wrapper für x86 und x64 Systeme nutzt. | ..\TwinCAT\AdsApi\AdsToJava | Link | Java

Windows CE

Name | Programmiersprache / Technologie | Betriebssystem | Beschreibung | Pfad | Referenz | Samples
TwinCAT.Ads.dll | .NET Windows CE | Windows CE | ADS.NET Komponenten für die verschiedenen Versionen des .NET Compact Frameworks (1.0 / 2.0) für Windows CE | ..\TwinCAT\AdsApi\.NET\CompactFramework | Link | C#
TcAdsDllCe | C/C++ | Windows CE | CE basierende ADS-Installationen (cab-Dateien) für den Einsatz unter CE mit den Headern und Libraries für die verschiedenen CE Plattformen | ..\TwinCAT\AdsApi\TcAdsDll\CE | Link | C++ Silverlight

WebServices

Name | Programmiersprache / Technologie | Betriebssystem | Beschreibung | Pfad | Referenz | Samples
TcAdsWcf | .NET, HTML, JavaScript | Windows XP, Vista, 7, 8 | Windows Communications Foundation (WCF) Webservice der Teil des .NET Frameworks ist. | ..\TwinCAT\AdsApi\TcAdsWcf | Link | C#
TcAdsWebService | HTML, Javascript | Windows XP, Vista, 7, 8, CE | Erweiterung für den Internet Information Server (IIS) | ..\TwinCAT\AdsApi\TcAdsWebService | Link | JavaScript Java C# Delphi

Weiterführende Infos:

ADS Einführung

ADS-Spezifikation