KM6551-0000 - Terminal module for wireless data exchange

BECKHOFF Fieldbus Components

Documentation for

KM6551-0000

Terminal module for wireless data exchange

Version: 1.2.0
Date: 2009-10-22


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


KM6551-0000 - Documentation issue status

BECKHOFF KM6551-0000: Foreword

Documentation issue status

Version | Comment
1.2.0
  • Included TwinCAT library updated to version 1.7.0
  • Description of KS2000 Configuration Software updated
1.1.0
  • Register description expanded
  • Notes on interference caused by other radio systems expanded
  • Notes on mounting expanded
  • Antenna ZS6201-0500 added
  • Antenna descriptions updated
1.0.0 | First publication

Firmware and hardware versions

Documentation, version | Firmware version | Hardware version
1.2.0 | 1E | 01
1.1.0 | 1E | 00
1.0.0 | 1B | 00

The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal module.

Syntax of the serial number

Structure of the serial number: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 35 05 00 01:

35 - week of production 35
05 - year of production 2005
00 - firmware version 00
01 - hardware version 01


KM6551-0000 - Introduction

BECKHOFF KM6551-0000: Product overview

Introduction

Wireless data exchange terminal

The KM6551-0000 terminal module is a data exchange unit based on radio technology. It uses the IEEE 802.15.4 standard. Data is exchanged or transmitted between two independent controllers via radio, independent of the higher-level fieldbus. The free-field distance between two KM6551-0000 units can be up to 300 m.

The KM6551-0000 terminal module has a reverse SMA plug (Straight Medium Adapter), to which various radio antennas can be connected, which are to be procured from Beckhoff. The directional characteristic can be adapted to the surroundings by means of specifically selecting the antenna. Status and data exchange are displayed via LEDs, thereby offering fast and simple diagnostics. A TwinCAT library is available for the use of the KM6551-0000 terminal module with TwinCAT.


KM6551-0000 - Technical data

BECKHOFF KM6551-0000: Product overview

Technical data

Technical data | KM6551-0000
Frequency band | 2.4 GHz
Transmission Rates | 250 kbit
Output power | 0 dBm (1 mW)
Reception sensitivity | -87 dBm
Protocol | IEEE 802.15.4
Antenna connection | reverse SMA plug (RP_SMA)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 135 mA
Width of a bus terminal block | Maximum 64 standard Bus Terminals or 80 cm (one KM6551-0000 corresponds to 2 standard Bus Terminals here)
Data width in the input process image | 12 bytes
Data width in the output process image | 12 bytes
Dimensions without antenna (W x H x D) | approx. 26.5 mm x 100 mm x 55 mm (connected width: 24 mm)
Weight | approx. 100 g
Operating temperature | 0°C... + 55°C
Storage temperature | -25°C... + 85°C
Relative humidity | 95%, no condensation
Mounting | on a 35 mm mounting rail (e.g. DIN rail TH 35-7.5 conforming to EN 60715)
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4, EN 300-440-02
Protection class | IP 20
Installation position | variable
Approval | CE


KM6551-0000 - Basic function principles

BECKHOFF KM6551-0000: Product overview

Basic function principles

The KM6551-0000 data exchange module enables the wireless exchange of data between two or more controllers. It uses the IEEE 802.15.4 standard as its basis with a Beckhoff-specific protocol. 10 bytes of user data are transmitted per data packet. The DIP switch is used to set the operating mode of the KM6551-0000, i.e. whether the module functions as a master or slave and which communication mode is to be used.

The data is exchanged in the peer to peer and master-slave modes using the polling method. In broadcast mode, one module is the broadcast master that sends the data and all other modules are broadcast slaves that receive the data but cannot send data to the broadcast master themselves. Hence, they listen only to data from the broadcast master.

In master-slave mode you can decide via the software with which slave data should be exchanged. Up to 7 slaves can be addressed.

The data exchange module KM6551-000 supports 16 channels, which are freely selectable and can be used, for example, to establish several radio networks or for placement outside WLANs or other radio systems that also use 2.4 GHz.

The KM6551-0000 can scan the possible 16 channels. The energy is measured here in the frequency range, in order to see in advance whether and on which frequencies any other systems are active. Furthermore, the so-called LQI (Link of Quality Index) is transmitted with each data telegram. This makes it possible to determine the quality of the signal. A high LQI value indicates a good connection, a low value a poor connection. In order to improve the LQI value, a larger antenna or an antenna with a correspondingly larger transmission factor can be used.

Communication mode

The KM6551-0000 data exchange module supports three different communication modes.

Mode 1: Peer to peer – data exchange between two modules.

Enables the exchange of data between two KM6551-0000. A maximum of 10 bytes of data can be transmitted per cycle. In one cycle (typically < 20 ms), module 1 sends data to module 2 and module 2 sends data back to module 1.

Mode 2: Master-slave – data exchange between a master and up to 7 slaves

In master-slave mode the master can communicate with up to seven KM6551-0000 using the polling method. To do this, set the corresponding slave addresses using the DIP switch. From the PLC you can inform the master which slave it should communicate with, how often and for how long. Approx. 20 ms are required per slave. For seven slaves this results in a minimum cycle time of 140 ms which the master requires in order to address all 7 slaves once each.

Mode 3: Broadcast to any number of slaves

In broadcast mode only the broadcast master transmits. All other modules (broadcast slaves) can only receive and cannot send any data themselves. Any number (x) of broadcast slaves can listen in.

Note 		Support of the KM6551-0000 using Bus Couplers, Bus Terminal Controllers and TwinCAT
The KM6551-0000 is supported from TwinCAT 2.10 Build 1326 onwards.

The Bus Couplers BK1120, BK1250, BK2020, BK3120, BK3150, BK9000 and BK9050 are supported (further Bus Couplers on enquiry).
All Bus Terminal Controllers from the BCxxxx, BXxxxx and BXxxxx series are supported.

Attention 		CE conformity
The CE conformity of the KM6551-0000 is only guaranteed if it is operated with original Beckhoff accessories (antennas, coaxial cable)!


KM6551-0000 – LED displays

BECKHOFF KM6551-0000: Product overview

LED displays

KM6551-0000

LED | Display
Run (green) | off | Data transmission on the K-bus is not active
 | on | Data transmission on the K-bus is active
Rx (green) | on | Data being received via radio
Tx (green) | on | Data being sent via radio
Link (green, orange, red) | on | Green - good signal quality Orange - moderate signal quality Red - poor signal quality or watchdog has triggered


KM6551-0000 – DIP switch

BECKHOFF KM6551-0000: Product overview

DIP switch

You can activate the different modes of the KM6551-0000 using the DIP switch. This enables the simple exchange of the modules without additional configuration software.

  • DIP switch in right position: ON
  • DIP switch in left position: OFF

The picture illustrates the setting for Slave 5.

DIP switch | A | B | C | D
Master mode | OFF | OFF | OFF | OFF
Slave 1 | ON | OFF | OFF | OFF
Slave 2 | OFF | ON | OFF | OFF
Slave 3 | ON | ON | OFF | OFF
Slave 4 | OFF | OFF | ON | OFF
Slave 5 | ON | OFF | ON | OFF
Slave 6 | OFF | ON | ON | OFF
Slave 7 | ON | ON | ON | OFF
Broadcast slave | OFF | OFF | OFF | ON


KM6551-0000 - IEEE802.15.4 - introduction

BECKHOFF KM6551-0000: IEEE 802.15.4

IEEE 802.15.4

Introduction

The terms IEEE 802.15.4 and ZigBee are used in many places as synonyms, although there is a clear demarcation between them, which will be briefly explained at this point.

The 802.15.4 standard, which was elaborated by the Institute of Electrical and Electronics Engineers (IEEE), specifies the Physical Layer (PHY) and the Medium Access Control (MAC), which correspond to the two lowest levels of the OSI layer model. The IEEE 802 802.15.4 standard was ratified at the beginning of May 2004 [1]. Therefore, apart from a few expected amendments and clarifications, work on it is deemed to be complete.

The ZigBee Alliance [2] was founded by several large firms from the semiconductor industry with the aim of developing a complete protocol suite on the basis of IEEE 802.15.4 for wireless communication extending up to the application interface. However, it is worth mentioning in this respect that the IEEE 802.15.4 standard is in no way linked to the ZigBee Alliance.

Note 		No ZigBee!
The KM6551-0000 data transmission module is based on IEEE 802.15.4, but it is not a ZigBee product and is also not ZigBee-compatible!
Technical data | KM6551
Data transmission band | 2,4 GHz
Channels | 16
Channel separation | 5 MHz
Channel width | 2 MHz
Available | Worldwide
Data transfer rate | 250 kbit
Protocol | IEEE 802.15.4

16 channels, each with a gross data rate of 250 kB/s, are available in the worldwide available 2.4 GHz band.

[1] Institute of Electrical and Electronics Engineers (Ed.): IEEE Standard for Information technology -- Telecommunication and information exchange between systems -- Local and metropolitan area networks -- Specific requirements. Part 15.4: Wireless Medium Access Control (MAC) and Physical Layer (PHY) Specifications for Low-Rate Wireless Personal Area Networks (LR-WPANs).IEEE Computer Society, New York, NY, USA, October 2003

[2] ZigBee Alliance, http://www.zigbee.org


KM6551-0000 - Interference caused by other radio systems

BECKHOFF KM6551-0000: IEEE 802.15.4

Interference caused by other radio systems

Note 		Check frequency ranges
If other radio systems (e.g. WLAN) are in use in a building in parallel with the KM6551-0000 (IEEE 802.15.4), check which frequencies they are using!
Possible sources of interference are:
  • WLAN networks on adjacent or the same channels
  • Microwave ovens

WLAN

If the IEEE 802.15.4 channel used by the KM6551-0000 and the frequency range of a neighboring WLAN network overlap, this can lead to disruptions in the KM6551-0000 communication.

Select an IEEE 802.15.4 channel for the KM6551-0000 that uses the gaps between neighboring WLAN networks as shown in the diagram below.

Even if the maximum possible three non-overlapping WLAN channels are used adjacently, four IEEE 802.15.4 channels remain that the KM6551-0000 can use without interference.

  1. Three non-overlapping WLAN networks in the WLAN channels permitted in North America (IEEE 802.11b)
  2. Three non-overlapping WLAN networks in the WLAN channels permitted in Europe (IEEE 802.11b)
  3. Placement of IEEE 802.15.4 channels (2400 MHz PHY) in the gaps between the WLAN networks

Microwave ovens

Since microwave ovens typically operate at a frequency of 2.455 GHz, neighboring poorly screened ovens can interfere with the transmission between the KM6551-0000.

In this case, remove the interfering devices or use only well-screened microwave ovens in the direct vicinity of the KM6551-0000.


Terminal Modules - Recommended mounting rails

BECKHOFF Terminal Modules: Mounting and wiring

Recommended mounting rails

Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:

  • DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
  • DIN Rail TH 35-15 with 1,5 mm material thickness

Note 		Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


Terminal Modules - Mounting and Demounting

BECKHOFF Terminal Modules: Mounting and Wiring

Mounting and demounting

The terminal modules are fastened to the assembly surface with the aid of a 35 mm mounting rail (e.g. DIN rail TH 35-7.5 according to EN 60715a).

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Mounting
  • Fit the mounting rail to the planned assembly location.

    and press (1) the terminal module against the mounting rail until it latches in place on the mounting rail (2).
  • Attach the cables.
Demounting
  • Remove all the cables. Thanks to the KM/EM connector, it is not necessary to remove all the cables separately for this, but for each KM/EM connector simply undo 2 screws so that you can pull them off (fixed wiring)!
  • Lever the unlatching hook on the left-hand side of the terminal module upwards with a screwdriver (3). As you do this
    • an internal mechanism pulls the two latching lugs (3a) from the top hat rail back into the terminal module,
    • the unlatching hook moves forwards (3b) and engages

  • In the case 32 and 64 channel terminal modules (KMxxx4 and KMxxx8 or EMxxx4 and EMxxx8) you now lever the second unlatching hook on the right-hand side of the terminal module upwards in the same way.
  • Pull (5) the terminal module away from the mounting surface.


KM6551-0000 - Dimensions

BECKHOFF KM6551-0000: Mounting and wiring

Dimensions


KM6551-0000 - Connection

BECKHOFF KM6551-0000: Mounting and wiring

Connection

The antennas are connected via a reverse SMA screw plug. Please screw the cable, the coaxial cable or the antenna hand tight to this screw plug.

Coaxial cable
Designation | Description
ZK6000-0102-0020 | Coaxial cable, characteristic impedance 50 Ω, preassembled plug connectors (SMA plug and reverse SMA socket), black, 2 m
ZK6000-0102-0040 | Coaxial cable, characteristic impedance 50 Ω, preassembled plug connectors (SMA plug and reverse SMA socket), black, 4 m


KM6551-0000 - Antenna alignment

BECKHOFF KM6551-0000: Mounting and wiring

Antenna alignment

Please pay attention to the directional characteristics and polarization of the antennas in order to mount and align them to each another optimally!

Directional characteristic

Omni directional antennas

ZS6201-0410, ZS6201-0500

Design form | Side view (vertical directional characteristic) | Top view (horizontal directional characteristic)

ZS6200-0400

Predestined for mounting below the ceiling.

Design form | Side view (vertical directional characteristic) | Top view (horizontal directional characteristic)

Directional antennas

ZS6100-0900

Design form | Side view (vertical directional characteristic) | Top view (horizontal directional characteristic)

ZS6100-1800

Design form | Side view (vertical directional characteristic)
 | Top view (horizontal directional characteristic)

Alignment examples

Align the antennas so that each lies within the radiation cone of the opposite antenna.

Omni directional antennas

Two ZS6201-0410 or ZS6201-0500

Directional antennas

Two ZS6100-0900 or ZS6100-1800

Mixed operation

e.g. one ZS6201-0410 and two ZS6100-1800

Polarization

For optimum transmission, the antennas of all of the KM6551-0000 used must have the same polarization.

Omni directional antennas

Care must also be taken when using omni directional antennas that the antennas of all of the KM6551-0000 used have the same polarization.

Omni directional antennas such as the ZS6201-0410, ZS6201-0500 or ZS6200-0400 are mostly mounted for vertical polarization.

Directional antennas

Arrows marked with the letters H and V are located on the rear side of the housing of the ZS6100-0900 directional antenna in order to identify the polarization (ZS6100-1800 is being prepared).

Mount the directional antennas such that the marked arrows of all the antennas used correspond to one another.

Placement of the antennas

Mount the antennas such that they can radiate freely!

There must be no obstructions in the direct vicinity of the antenna that could hinder the development of the Fresnel zone. Metal obstacles such as control cabinets, machine parts, pipelines, iron beams etc. particularly hinder the development of the Fresnel zone!

The connection of the antennas to the KM6551-0000 via the RSMA plug and coaxial cable enables the antenna to be mounted remotely, so that you can position the antenna optimally.


KM6551-0000 - Attenuation and range

BECKHOFF KM6551-0000: Mounting and wiring

Attenuation and range

Fresnel zone

In radio transmission, the space between the transmitting and receiving antennas is known as the Fresnel zone. The Fresnel zone is a notional spheroid between the antennas.

The main portion of the energy is transmitted in the area of the Fresnel zone.

This zone should be free of obstructions (e.g. objects, houses, trees etc.). Metal obstacles such as control cabinets, machine parts, pipelines, iron beams etc. particularly hinder the development of the Fresnel zone!

Each hindrance of the Fresnel zone attentuates the transmission. If the Fresnel zone is half obscured, for example, the additional attenuation is 6 dB, i.e. the field strength is reduced to half of the free field value. Reception may then be disturbed or completely interrupted under certain circumstances.

If the Fresnel zone is free from obstructions, the propagating wave is only attenuated by the free field attenuation.

Radius r of the Fresnel zone in relationship to the distance s

Attenuation in practice

With an attenuation of 6 dB the range is shortened to half of the value for an unobstructed connection, with 12 dB it is shortened to a quarter.

Material | Attenuation | Range approx. | Example for an unobstructed range of 280 m
Thin wall | 2-5 dB | (free field range)/1.5 - (free field range)/2 | 180 m - 140 m
Wooden wall | 5 dB | (free field range)/2 | 140 m
Masonry wall | 6-12 dB | (free field range)/2 - (free field range)/4 | 140 m - 70 m
Concrete wall | 10-20 dB | (free field range)/4 - (free field range)/8 | 70 m - 5 m
Concrete ceiling | 20 dB | (free field range)/8 | < 35 m

Ranges for a selection of the following antenna combinations

The given ranges are based on an unobstructed view and adherence to the Fresnel zone.

Two omni directional antennas

Omni directional antennas combined with a directional antenna

Two directional antennas


KM6551-0000 - Antennas

BECKHOFF KM6551-0000: Antennas

Antennas

Overview

Designation | Description
ZS6100-0900 | Directional antenna (gain 9 dBi), without cable
ZS6100-1800 | Directional antenna (gain 18 dBi), without cable
ZS6200-0400 | Omni directional antenna (gain 4 dBi), without cable
ZS6201-0410 | Rod antenna (gain 4 dBi), with cable (1 m)
ZS6201-0500 | Rod antenna (gain 5 dBi), without cable

Attention 		CE conformity
The CE conformity of the KM6551-0000 is only guaranteed if it is operated with original Beckhoff accessories (antennas, coaxial cable)!


ZS6100-0900

Technical data

Technical data | ZS6100-0900
Frequency range | 2400...2485 MHz
Transmission factor | 9 dBi
3 dB bandwidth, horizontal | 65°
3 dB bandwidth, vertical | 65°
Connection | SMA socket
Dimensions (W x H x D) | 93 mm x 93 mm x 25 mm
Weight (incl. accessories and packaging) | approx. 190 g
Operating temperature | -40°C... + 80°C
Relative humidity | 95%, no condensation
Protection class | IP20
Installation position | variable
Approval | CE
Mounting | Bracket mounting, included in scope of supply
Suitable coaxial cable | ZS6000-0102-0020, ZS6000-0102-0040


ZS6100-1800

Technical data

Technical data | ZS6100-1800
Frequency range | 2400...2485 MHz
Transmission factor | 18 dBi
3 dB bandwidth, horizontal | 20°
3 dB bandwidth, vertical | 20°
Connection | SMA socket
Dimensions (W x H x D) | 360 mm x 360 mm x 30 mm
Weight (incl. accessories and packaging) | approx. 3640 g
Operating temperature | -40°C... + 80°C
Relative humidity | 95%, no condensation
Protection class | IP20
Installation position | variable
Approval | CE
Mounting | Bracket mounting, included in scope of supply
Suitable coaxial cable | ZS6000-0102-0020, ZS6000-0102-0040


ZS6200-0400

Technical data

Technical data | ZS6200-0400
Frequency range | 2400...2485 MHz
Transmission factor | 4 dBi
3 dB bandwidth, horizontal | 360°
3 dB bandwidth, vertical | 70°
Connection | SMA socket
Dimensions | Diameter 110 mm, height 45 mm
Weight (incl. accessories and packaging) | approx. 210 g
Operating temperature | -40°C... + 80°C
Relative humidity | 95%, no condensation
Protection class | IP20
Installation position | variable, predestined for mounting below the ceiling.
Approval | CE
Suitable coaxial cable | ZS6000-0102-0020, ZS6000-0102-0040


ZS6201-0410

Technical data

Technical data | ZS6201-0410
Frequency range | 2400...2485 MHz
Transmission factor | 4 dBi
3 dB bandwidth, horizontal | 360°
3 dB bandwidth, vertical | 70°
Connection | Reverse SMA socket (with 1 m cable, permanently connected to antenna)
Dimensions | Height 202 mm, foot diameter 35 mm
Weight (incl. cable, accessories and packaging) | approx. 220 g
Operating temperature | -40°C... + 80°C
Relative humidity | 95%, no condensation
Mounting | Cap nut M14
Protection class | IP20
Installation position | variable
Approval | CE
Coaxial cable | 1 m, included in scope of supply


ZS6201-0500

Technical data

Technical data | ZS6201-0500
Frequency range | 2400...2485 MHz
Transmission factor | 5 dBi
3 dB bandwidth, horizontal | 360°
3 dB bandwidth, vertical | 70°
Connection | Reverse SMA socket
Dimensions | Height 195 mm, foot diameter 12 mm
Weight (incl. packaging) | approx. 40 g
Operating temperature | -40°C... + 80°C
Relative humidity | 95%, no condensation
Mounting | Direct connection with hinged joint
Protection class | IP20
Installation position | variable
Approval | CE
Suitable coaxial cable | Not required, direct connection


KM6551-0000 - Application examples - Overview

BECKHOFF KM6551-0000: Application examples

Application examples - Overview

  • Peer-to-Peer mode
  • Master-Slave mode
  • Broadcast mode
  • Energy scan


KM6551-0000 - Peer to peer mode

BECKHOFF KM6551-0000: Application examples

Peer to peer mode

Application

The simplest type of communication between two KM65551-0000 is the peer to peer mode. In order to do this, set the DIP switch

  • of the master module to master mode and
  • that of the second module to slave address 1.

Now you have to set bit 0 (start bit) in the control byte CB1 of both modules to TRUE. The modules acknowledge this bit in bit 0 of their status byte SB1. The establishment of communication and the communication itself then begin automatically.

Now 10 bytes are always exchanged between the modules. This continues until a start bit is reset to FALSE. It does not matter which side resets the start bit.

If the connection is disturbed or if the start bit is not set on the opposite side, the module reports an error with bit 6 in the status byte SB1. The error code is output at the same time in status byte SB2 (see ErrorID).


KM6551-0000 - Master-Slave mode

BECKHOFF KM6551-0000: Application examples

Master-Slave mode

Application

A further possibility is the exchange of data between a master and up to 7 slaves. The address of the slave is set accordingly with the DIP switch. The address may only be used once per channel. Bit 0 of control byte 1 CB1 must be set to TRUE as ‘start bit’ here also. The slave address of the target device is set with bits 3 – 5. The terminal then sends telegrams to the respective slave. If the terminal receives a reply, it will be shown in the status.

Example: Task – you want to speak to slave 2.

Set bit 0 to true in order to start data exchange. Bit 3 must then be set in order to speak to slave 2. As soon as the reply from slave 2 is received (after approx. 20 ms), the master terminal confirms this in the status byte by setting bit 4. The address is always counted +1 in the status byte (see table).

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 1

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 1
Address | Control byte bits 3 - 5 |  | Status byte bits 3 - 5
Slave 1 | 0dec | 000bin | 1dec | 001bin
Slave 2 | 1dec | 001bin | 2dec | 010bin
Slave 3 | 2dec | 010bin | 3dec | 011bin
Slave 4 | 3dec | 011bin | 4dec | 100bin
Slave 5 | 4dec | 100bin | 5dec | 101bin
Slave 6 | 5dec | 101bin | 6dec | 110bin
Slave 7 | 6dec | 110bin | 7dec | 111bin

Hence, you can now poll the terminals at any desired speed and in any desired rhythm. If you only send data very rarely to a slave, remember that the watchdog in the slave terminal can trigger. The watchdog time in the slave is approx. 400 ms and can be set in register R38. The default value is 20 and must be multiplied by 20 ms.

If a slave does not answer, then either the radio connection is disturbed or bit 0 of the control byte on the slave side is not set; the master terminal sets the error bit 6. The error code is contained in the high nibble in SB2.

If you want to address a new slave, make sure at the same time that data bytes 0 - 9 on the new slave are updated. When the slave replies, you should only accept the data from the new slave if the new slave address appears in the status and the error bit is not set.


KM6551-0000 - Broadcast mode

BECKHOFF KM6551-0000: Application examples

Broadcast mode

Application

Broadcast mode enables data to be sent from a master to any number of slaves. Data is thereby sent to the slaves. The slaves receive the data, but the master does not receive any reply from the slaves.

For broadcast mode, the master must be set to master operation with the aid of the DIP switch and register 39 must be set to broadcast mode before setting data communication. It is sufficient for the slave to be set to broadcast-slave mode via the DIP switch.

The sequence for setting the master module to broadcast-master mode is as follows:

  1. Remove the write protection R31
  2. Write broadcast master mode to R39
  3. Read out R39 to check that master mode has really been set
  4. Set the start bit in CB1
Example: Task – start the data exchange (same for master and slave)

Set bit 0 to TRUE in order to start data exchange.

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1


KM6551-0000 – Energy scan

BECKHOFF KM6551-0000: Application examples

Energy scan

Application

The energy scan enables the 16 IEEE 802.15.4 channels to be monitored in order to detect other radio systems. The energy in a frequency band is determined and displayed. Each channel is measured for approx. 5 seconds before moving to the next channel. Care must be taken that a channel does not communicate during these 5 seconds. It therefore makes sense to repeat the scanning of the channels a couple of times in order to obtain a more accurate statement as to whether or not a channel is occupied. The energy is displayed from 0 to 0xF, where "0" means no energy and "0xF" or 16dec corresponds to very high energy.

Set bit 1 in CB1 to TRUE. The KM6551-0000 confirms this in the status with bit 1, which is then also set to TRUE. The scan is finished when bit 1 of SB1 goes to FALSE. The result is then available in the input data byte 0 to 7. Each channel then corresponds to a nibble, i.e. half of a byte.

Example

Byte number | Description | Value (hex) | Meaning
1 | SB1 | - | Status byte 1
2 | SB2 | - | Status byte 2
3 | Data IN[0] | 0x3F | 3 - channel 1 low energy, F - channel 2 very high energy
4 | Data IN[1] | 0x01 | 0 - channel 3 no energy, 1 - channel 4 very low energy
5 | Data IN[2] | 0x7F | 7 - channel 5 moderate energy, F - channel 5 very high energy
6...9 | ... | ... | ... (not considered in this example for reasons of simplicity)
10 | Data IN[8] | 0x10 | 1 - channel 15 low energy, 0 - channel 16 no energy
11...12 | Data IN[8...9] | - | not required

The result is to be interpreted as follows. Channels 2 and 5 are to be avoided at all costs, but channels 3 and 16 look very good. No energy was measured here. Please note that these are momentary values. You can exclude channels with a high energy from further searches for free channels, but channels with no or only moderate energy may lead under certain circumstances to entirely different results.

Example: activation of the energy scan

Set bit 1 to TRUE in order to start data exchange.

CB1

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reserve | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0

The terminal sets bit 1 of the status byte SB1 to TRUE as long as the scan is active.

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0

The terminal resets bit 1 of the status byte SB1 to FALSE once the scan is finished. You can now evaluate the input data bytes 0 – 7 (bytes 8 and 9 have no meaning and should not be evaluated).

The scan takes approx. 80 seconds.

SB1

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Add3 | Add2 | Add1 | Scan | EnergyScan | Start
Value | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0


TwinCAT

PLC and Motion Control on the PC

TwinCAT - The Windows Control and Automation Technology

The automation software TwinCAT turns any compatible PC into a real-time controller with a multi-PLC, NC axis control, programming environment and operating station. TwinCAT replaces conventional PLC and NC/CNC controllers as well as operating devices with:

  • open, compatible PC hardware
  • embedded IEC 61131-3 software PLC, software NC and software CNC in Windows NT/2000/XP, NT/XP Embedded, CE
  • programming and run-time systems optionally together on one PC or separated
  • connection to all common fieldbus systems
  • PC interfaces are supported
  • data communication with user interfaces and other programs by means of open Microsoft standards (OPC, OCX, DLL, etc.)

TwinCAT architecture

TwinCAT consists of run-time systems that execute control programs in real-time and the development environments for programming, diagnostics and configuration. Any Windows programs, for instance visualization programs or Office programs, can access TwinCAT data via Microsoft interfaces, or can execute commands.

A practically oriented software solution

TwinCAT offers a precise time-base in which programs are executed with the highest deterministic features, independently of other processor tasks. The real-time load on a PC is set with TwinCAT; defined operating behavior is achieved in this way. TwinCAT indicates the system load for programs that are running. A load threshold can be set in order to assure a defined computing capacity for the operating programs and for Windows NT/2000/XP. If this threshold is exceeded, a system message is generated.

TwinCAT supports system diagnosis

The general use of hardware and software from the open PC world requires some checking: Unsuitable components can upset the PC system. Beckhoff have integrated a practical indicator of the real-time jitter into their product, giving administrators an easy way to evaluate the hardware and software. A system message during operation can draw attention to incorrect states.

Start/stop behavior

Depending on the setting, TwinCAT is started and stopped manually or automatically. Since TwinCAT is integrated into Windows NT/2000/XP as a service, an operator is not needed to start the system: switching on is enough.

Restarting and data backup

When a program is started or restarted, TwinCAT loads programs and remanent data. To back up data, and to shut down Windows NT/2000/XP correctly, a UPS (uninterruptible power supply) is of great value.

TwinCAT and „Blue Screen“

The TwinCAT system can be configured such that real-time capability is maintained in the event of a BSOD (Blue Screen of Death) operating system crash. Real-time tasks such as PLC and NC can therefore continue to run and bring the controlled process into a safe state. Ultimately, it is the decision of the programmer whether or not to utilize this feature, bearing in mind that data or programs may already have been destroyed by the BSOD.

World-wide connection through message routing - "remote" connection is inherent to the system

According to the requirement for operating resources, the TwinCAT software devices can be distributed: TwinCAT PLC programs can run on the PCs or on Beckhoff Bus Terminal Controllers. A "message router" manages and distributes all the messages, both in the system and via TCP/IP connections. PC systems can be connected with each other via TCP/IP; Bus Terminal Controllers are integrated via serial interfaces and fieldbus systems (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP).

World-wide access

Since standard TCP/IP services of NT/2000/XP can be used, this data can be exchanged across the world. The system offers scalable communication capacity and timeout periods for the supervision of communications. OPC provides a standardized means for accessing many different SCADA packets. The SOAP (Simple Object Access Protocol) enables a connection between two computers to be established by means of an internet connection via standard HTTP. A TwinCAT component is available for this purpose.

Beckhoff Information System

You may find further information about the automation software TwinCAT in the Beckhoff-Information System.

The setup for the Beckhoff Information System is available on the Beckhoff DVD Products & Solutions and for download on our internet pages.

Furthermore the online version of the Beckhoff Information System may be found under http://infosys.beckhoff.com.


KM6551-0000 - TwinCAT libraries

BECKHOFF KM6551-0000: Programming

TwinCAT libraries

A TwinCAT library is available for all Beckhoff controller families (BC, BX, CX and IPC) for the operation of the KM6551-0000 under TwinCAT. This library takes care of communication with the terminal. It sets parameters in or reads parameters from the terminal. The use of the library simplifies communication with the terminal for the user.

ZIP file TC_KM6551.zip:

Copy the libraries into the TwinCAT\PLC\Lib directory.

Other required libraries:

For Bus Terminal Controllers from the BCxx00 series

  • Standard.lb6
  • PlcHelper.lb6

For Bus Terminal Controllers from the BCxx20 and BCxx50 series

  • Standard.lbx
  • TcBaseBCxx50.lbx
  • TcSystemBCxx50.lbx

For Bus Terminal Controllers from the BXxxxx series

  • Standard.lbx
  • TcBaseBX.lbx
  • TcSystemBX.lbx

For 386-based systems such as Industrial PCs, Embedded PCs (CX)

  • Standard.lib
  • TcBase.lib
  • TcSystem.lib

The user can write his own function blocks for the operation of the KM6551-0000 under other controllers.


KM6551-0000 – TwinCAT examples

BECKHOFF KM6551-0000: Programming

TwinCAT examples

For the examples you need one CX9000 with K-bus, one BC9050, two KM6551-0000, two KL9010 end terminals and one KL2xx4 (optional).

Example of master-slave communication [image] (ZIP file - right mouse button- save as...)

A KM6551-0000 is plugged into the CX9000 as a master module and optionally the KL2xx4 Bus Terminal. A KM6551-0000 is plugged into the BC9050 as a slave module.

Example of broadcast communication [image] (ZIP file - right mouse button- save as...)

A KM6551-0000 is plugged into the CX9000 as a master module and optionally the KL2xx4 Bus Terminal. A KM6551-0000 is plugged into the BC9050 as a broadcast slave module.

Example of energy scan [image] (right mouse button- save as...)

One BX9000, one KL6551-0000 and one KL9010 are required.


KM6551-0000 - Function block FB_KM6551_MAIN

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_MAIN

This function block takes care of communication to the KM6651-000 and takes care of and makes settings in the module by means of register communication. Only one FB_KM6551_MAIN block is permitted per KM6551-0000.

VAR_INPUT

bActivate :BOOL;
bBroadcast :BOOL;
iChannel_Set :INT;
uiSlaveTM :UINT;
KM6551_IN :ARRAY[1..12] of BYTE;
KM6551_OUT :ARRAY[1..12] of BYTE;

Legend

bActivate: Positive edge activates the block and writes parameters to the KM6551-0000.
bBroadcast: Can only be activated in master mode. TRUE – sets the KM6651-0000 to broadcast master mode (see register 39).
iChannel_Set: The IEEE 802-15.4 channel is set here. Permitted values are 0 - 15 (see register 32/33).
uiSlaveTM: Only usable in slave mode; setting of the watchdog for the slave mode (see register 38).
KM6551_IN: Is connected to the INPUT data of the KM6551-0000.
KM6551_OUT: Is connected to the OUTPUT data of the KM6551-0000.

VAR_OUTPUT

bActive :BOOL;
bError :BOOL;
iErrorID :E_KM6551_ERRORID;
bBusy :BOOL;
strLinkData :KM6551_Data;

Legend

bActive: The block has successfully transmitted the parameters to the KM6551-0000 and can now commence data communication with the other KM6551-0000 blocks.
bError: The block has an error.
iErrorID: Contains the error code.
bBusy: The block is still working as long as bBusy is set, i.e. is TRUE; wait until bBusy changes to FALSE.
strLinkData: Data required by the higher-level function blocks. Connect this data to the additional function blocks that they call.


KM6551-0000 - Function block FB_KM6551_MASTER_10BYTE

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_MASTER_10BYTE

This function block takes care of communication to the individual slaves. Only one block can be called per slave. A maximum of 7 slaves are allowed, for which reason a maximum of 7 blocks of this type may be called per master terminal. A positive edge on bStart activates communication to the slave that is stored in the variable iSlaveAddr. bBusy goes to TRUE as long as the block is active. If bBusy changes to FALSE, the block has finished. If bError is FALSE, then communication was successful and the input data is valid. If the bError bit is TRUE, an error has occurred. A precise error cause can be read out in iErrorID. ptData_IN is a pointer address for the input data (ADR command to determine the pointer address) and iLenData_IN is the length of the data. The length can be determined with SIZEOF and must not be larger than 10 bytes. The same applies to the output data. The strLinkData variable is linked to the FB_KM6551_MAIN block (the variable has exactly the same name). The FB_KM6551_MAIN should be finished before the FB_KM6551_MASTER_10BYTE block is called, (see bActive in this block).

VAR_INPUT

bStart :BOOL;
iSlaveAddr :INT;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;
ptData_OUT :DWORD;
iLenData_OUT :INT;

Legend

bStart: A positive edge activates the block.
iSlaveAddr: The address of the slave is entered here (see DIP switch on your slave module)
strLinkData: Is linked with strLinkData from FB_KM6551_MAIN.
ptData_IN: Pointer to the variable into which the device data should be copied (pointer address is determined with ADR(Variable_name)).
iLenData_IN: Length of the variable (the length can be determined with SIZEOF (variable_name))
ptData_OUT: Pointer to the variable into which the master terminal should transmit to the slave (pointer address is determined with ADR(Variable_name)).
iLenData_OUT: Length of the variable (the length can be determined with SIZEOF (variable_name))

VAR_OUTPUT

bError :BOOL;
bBusy :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legend

bError: The block has an error.
bBusy: The block is still working as long as bBusy is set, i.e. is TRUE; wait until bBusy changes to FALSE.
iErrorID: Contains the error code.
iSignalQuality: LQI value, quality of the signal received; 100 very good transmission, 0 very poor transmission - the LQI value should be as high as possible and should have a minimum value of 10 - 20. You can improve the LQI value by the use of better antennas or shorter cables or better alignment of the antennas.
E_Addr: Reads out the DIP switch setting of the KM6551-0000 module and displays it.


KM6551-0000 - Function block FB_KM6551_SLAVE_10BYTE

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_SLAVE_10BYTE

This function block takes care of communication to the slave module. Only one block can be called per slave. A positive edge on bStart activates communication to the slave. If bError is FALSE, then communication was successful and the input data is valid. If the bError bit is TRUE, an error has occurred. A precise error cause can be read out in iErrorID. ptData_IN is a pointer address for the input data (ADR command to determine the pointer address) and iLenData_IN is the length of the data. The length can be determined with SIZEOF and must not be larger than 10 bytes. The same applies to the output data. The strLinkData variable is linked to the FB_KM6551_MAIN block (the variable has exactly the same name). The FB_KM6551_MAIN should be finished before the FB_KM6551_SLAVE_10BYTE block is called, (see bActive in this block).

VAR_INPUT

bStart :BOOL;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;
ptData_OUT :DWORD;
iLenData_OUT :INT;

Legend

bStart: A positive edge activates the block.
strLinkData: Is linked with strLinkData from FB_KM6551_MAIN.
ptData_IN: Pointer to the variable into which the device data should be copied (pointer address is determined with ADR(Variable_name)).
iLenData_IN: Length of the variable (the length can be determined with SIZEOF (variable_name))
ptData_OUT: Pointer to the variable into which the master terminal should transmit to the slave (pointer address is determined with ADR(Variable_name)).
iLenData_OUT: Length of the variable (the length can be determined with SIZEOF (variable_name))

VAR_OUTPUT

bError :BOOL;
bBusy :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legend

bError: The block has an error.
bBusy: The block is still working as long as bBusy is set, i.e. is TRUE; wait until bBusy changes to FALSE.
iErrorID: Contains the error code.
iSignalQuality: LQI value, quality of the signal received; 100 very good transmission, 0 very poor transmission - the LQI value should be as high as possible and should have a minimum value of 10 - 20. You can improve the LQI value by the use of better antennas or shorter cables or better alignment of the antennas.
E_Addr: Reads out the DIP switch setting of the KM6651-0000 module and displays it.


KM6551-0000 - Function block FB_KM6551_MASTERBROADCAST_10BYTE

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_MASTERBROADCAST_10BYTE

This function block takes care of communication to the individual slaves in broadcast mode. The number of data telegrams can be reduced with the time tPolling. Data will then only be sent within the time tPolling. If the tPolling time is high for the broadcast slaves, make sure that you also enter a higher watchdog time, as otherwise the slave will display a watchdog error. A positive edge on bStart activates communication. If the bError bit is TRUE, an error has occurred. A precise error cause can be read out in iErrorID. ptData_OUT is a pointer address for the input data (ADR command to determine the pointer address) and iLenData_OUT is the length of the data. The length can be determined with SIZEOF and must not be larger than 10 bytes. The strLinkData variable is linked to the FB_KM6551_MAIN block (the variable has exactly the same name). The FB_KM6551_MAIN should be finished before the FB_KM6551_MASTER_10BYTE block is called, (see bActive in this block).

VAR_INPUT

bStart :BOOL;
iSlaveAddr :INT;
strLinkData :KM6551_Data;
ptData_OUT :DWORD;
iLenData_OUT :INT;
tPolling :TIME;

Legend

bStart: A positive edge activates the block.
iSlaveAddr: The address of the slave is entered here (see DIP switch on your slave module)
strLinkData: Is linked with strLinkData from FB_KM6551_MAIN.
ptData_OUT: Pointer to the variable into which the master terminal should transmit to the slave (pointer address is determined with ADR(Variable_name)).
iLenData_OUT: Length of the variable (the length can be determined with SIZEOF (variable_name))
tPolling: Time cycle in which the data should be sent to the slaves.

VAR_OUTPUT

bError :BOOL;
bActive :BOOL;
iErrorID :E_KM6551_ERRORID;
E_Addr :E_KM6551_DIP;

Legend

bError: The block has an error.
bActive: Indicates whether or not the block is working.
iErrorID: Contains the error code.
E_Addr: Reads out the DIP switch setting of the KM6551-0000 and displays it.


KM6551-0000 - FB_KM6551_SLAVEBROADCAST_10BYTE

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_SLAVEBROADCAST_10BYTE

This function block takes care of communication to the broadcast slave module. Only one block can be called per slave. A positive edge on bStart activates communication to the slave. If bError is FALSE, then communication was successful and the input data is valid. If the bError bit is TRUE, an error has occurred. A precise error cause can be read out in iErrorID. ptData_IN is a pointer address for the input data (ADR command to determine the pointer address) and iLenData_IN is the length of the data. The length can be determined with SIZEOF and must not be larger than 10 bytes. The same applies to the output data. The strLinkData variable is linked to the FB_KM6551_MAIN block (the variable has exactly the same name). The FB_KM6551_MAIN should be finished before the FB_KM6551_MASTER_10BYTE block is called, (see bActive in this block).

VAR_INPUT

bStart :BOOL;
strLinkData :KM6551_Data;
ptData_IN :DWORD;
iLenData_IN :INT;

Legend

bStart: A positive edge activates the block.
strLinkData: Is linked with strLinkData from FB_KM6551_MAIN.
ptData_IN: Pointer to the variable into which the device data should be copied (pointer address is determined with ADR(Variable_name)).
iLenData_IN: Length of the variable (the length can be determined with SIZEOF (variable_name))

VAR_OUTPUT

bError :BOOL;
bActive :BOOL;
iErrorID :E_KM6551_ERRORID;
iSignalQuality :INT;
E_Addr :E_KM6551_DIP;

Legend

bError: The block has an error.
bActive: Indicates whether or not the block is working.
iErrorID: Contains the error code.
iSignalQuality: LQI value, quality of the signal received; 100 very good transmission, 0 very poor transmission - the LQI value should be as high as possible and should have a minimum value of 10 - 20. You can improve the LQI value by the use of better antennas or shorter cables or better alignment of the antennas.
E_Addr: Reads out the DIP switch setting of the KM6651-0000 module and displays it.


KS2000 Configuration Software

The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler/Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.

Configuration

You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.

Parameterization

KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.

Commissioning

The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.

The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.

  • Thus, the coupler's input and output images can be observed by monitoring.
  • Process values can be specified in the output image for commissioning of the output modules.

All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


KM6551-0000 - Parameterization using KS2000

BECKHOFF KM6551-0000: KS2000 Configuration software

Parameterization using KS2000

Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.

Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
  • Bus Coupler for Ethernet BK9000
  • a KL1002 input terminal
  • a KM6551-0000 data exchange terminal
  • a KL9010 bus end terminal

The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.

In the tree structure of the left-hand window, click on the plus-sign next to the module whose parameters you wish to change (pos. 2 in the example).

The tree branches Register, Settings and ProcData are displayed for the KM6551-0000:

  • Register allows direct access to the registers of the KM6551-0000.
  • Under settings you will find dialog masks for parameterizing the KM6551-000.
  • Proccess Data shows the process data for the KM6551-0000.


KM6551 - KS2000 settings

BECKHOFF KM6551: KS2000 Configuration Software

Settings

Dialog mask to parameterize the KM6551.

Settings

Radio-channel for KM6551 (R33)

You can specify the Radio-channel here (default: 5, valid values: 0 to 15).

Scan Settings

Number of Slaves

Shows the quantity of found slaves (R40).

Slaves (R40)

Shows the slave numbers of the found slaves.


KM6551 - KS2000-Register

BECKHOFF KM6551: KS2000 Configuration Software

Register

You can directly access the registers of the KM6551 Terminal Module under Register. The meaning of the register is explained in the Register Overview.


KS2000 - Process Data

BECKHOFF Fieldbus Components: KS2000 Configuration Software

Process Data

The status byte (State), the control byte (Ctrl) and the process data (Data) are displayed as a tree structure under ProcData.

The spectacles mark the data that is presently being displayed graphically in the History box.

The current value is displayed numerically in the Value field.

Initial values can be modified through direct input or by means of the fader.

CAUTION 		Hazard to individuals, environment and materials!
Note that changing initial values (forcing them) can have a direct effect on your automation application.
Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!

After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.


KM6551-0000 - Process image

BECKHOFF KM6551-0000: Access from the user program

Process image

The KM6551-0000 terminal module represents itself in the process image with a maximum of 12 bytes of input data and 12 bytes of output data. These are organized as follows:

Format | Input data | Output data
Byte | SB1 | CB1
Byte | SB2 | CB2
Array of Byte (0...9) | DataIN | DataOUT
Legend

SBn: status byte n
CBn: control byte n

DataIN: Array of 10 input bytes (0 - 9)
DataOUT: Array of 10 input bytes (0 - 9)

The meaning of the control and status bytes is explained in Control and status bytes.

In process data operation, the input data is transmitted in the DataIN array and the output data in the DataOUT array.

Note 		Use of the data arrays
The input and output data arrays can be used freely in order to transmit any data. You can
  • use them, for example, to transmit the process data from analog input or output channels.
  • also use the 10 bytes in order to transmit larger amounts of data in several cycles using a self-defined protocol (e.g. 2 bytes for the header, 8 bytes for the user data).


KM6551-0000 – Control and status bytes

BECKHOFF KM6551-0000: Access from the user program

Control and status bytes

Process data mode

Control bytes (for process data mode)

The control bytes are located in the output image and are transmitted from the controller to the terminal module.

CB1: Low byte

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | Address |  |  | Scan | EnergyScan | Start

CB2: High byte

Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | - | - | - | - | - | - | - | -
Legend
Bit | Name | Description
CB2.0 to CB2.7 | Reserve | 0bin | reserved
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 | Reserve | 0bin | reserved
CB1.3 to CB1.5 | Address | 0..7dec | In master mode, with whichever device the connection is running 0 - Slave 1 1 - Slave 2 ... 6 - Slave 7
CB1.2 | Scan | 1bin | Activates scanning of the connected slaves (only possible in master mode). The scanned slaves can be found in register R38.
CB1.1 | EnergyScan | 1bin | Activates the energy measurement for the 16 channels of the 2.4 GHz band. EnergyScan may not be activated in data exchange or scan mode.
CB1.0 | Start | 1bin | Activates communication

Status byte (for process data mode)

The status bytes are located in the input image and are transmitted from terminal module to the controller.

SB1: Low byte:

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Address |  |  | Scan | EnergyScan | Start

SB2: High byte:

Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | ErrorID |  |  |  | LQI
Legend
Bit | Name | Description
SB2.7 to SB2.4 | ErrorID | 0..Fhex | Error message 1 - DIP Switch setting not allow 2 - Watchdog error 3..F reserved
SB2.3 to SB2.0 | LQI | 0..Fhex | Quality of the radio signal
SB1.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | Error | 1bin | an internal error has occurred (current process data is no longer valid)
SB1.5 to SB1.3 | Address | 1..7dec | Slave address 1: Slave 1 2: Slave 2 ... 7: Slave 7
SB1.2 | Scan | 1bin |
SB1.1 | EnergyScan | 1bin | TRUE if energy scanning is active; will be reset to FALSE when the terminal is finished.
SB1.0 | Start | 1bin |

Register communication

Control byte 2 and status byte 2 have no function in the case of register communication.

Control byte 1 (in register communication)

Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal module.

Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.

Status byte 1 (in register communication)

Status byte 1 (SB1) is located in the input image and is transmitted from terminal module to the controller.

Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.


KM6551-0000 – Register overview

BECKHOFF KM6551-0000: Access from the user program

Register overview

These registers are used to parameterize the terminal module. They can be read or written by means of register communication.

Register no. | Comment | Default value |  | R/W | Memory
R0 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R7 | reserved | 0x0000 | 0dec | - | -
R8 | Terminal type | 0x1997 | 6551dec | R | ROM
R9 | Firmware version | e.g. 0x3144 | e.g. 1DASCI | R | ROM
R10 | Multiplex shift register | 0x0118 | 280dec | R | ROM
R11 | Signal channels | 0x0218 | 280dec | R | ROM
R12 | minimum data length of a channel | 0x0098 | 152dec | R | ROM
R13 | Data structure | 0x0000 | 0dec | R | ROM
R14 | reserved | 0x0000 | 0dec | - | -
R15 | Alignment register | typically 0x7F80 | typically 32640dec | R/W | RAM
R16 | DIP switch setting | e.g. 0x0000 | e.g. 0dec | R | RAM
R17 | internal use | typically 0x0000 | typically 0dec | R | EEPROM
R18 | reserved | 0x0000 | 0dec | R | EEPROM
R19 | reserved | 0x0000 | 0dec | R | EEPROM
R20 | reserved for internal use | 0x0001 | 1dec | R | EEPROM
R21 | reserved for internal use | 0x0500 | 1280dec | R | EEPROM
R22 | reserved for internal use | 0x0000 | 0dec | R | EEPROM
R23 | reserved for internal use | 0x00FF | 255dec | R | EEPROM
R24 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R30 | reserved | 0x0000 | 0dec | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | EEPROM
R32 | IEEE 802.15.4 channel | 0x0005 | 5dec | R/W | EEPROM
R33 | Control register for R32 | 0x0000 | 0dec | R | RAM
R34 | reserved | 0x0000 | 0dec | R/W | EEPROM
R35 | reserved | 0x0000 | 0dec | R/W | EEPROM
R36 | reserved | 0x0000 | 0dec | R/W | EEPROM
R37 | reserved | 0x0000 | 0dec | R/W | EEPROM
R38 | Watchdog for slave mode | 0x0014 | 20dec | R/W | EEPROM
R39 | Broadcast mode | 0x0000 | 0dec | R/W | EEPROM
R40 | Scan register | - | - | R | RAM
R41 | Network ID | 0x0000 | 0dec | R/W | RAM
R42 | Wrong channel (internal) | - | - | R | EEPROM
R43 | reserved | 0x0000 | 0dec | R | EEPROM
R44 | Reset counter (internal) | - | - | R | EEPROM
R45 | reserved | 0x0000 | 0dec | R | EEPROM
R46 | Attenuation of the transmission power | 0x0000 | 0dec | R/W | EEPROM
R47 | reserved | 0x0000 | 0dec | R | EEPROM
... | ... | ... | ... | ... | ...
R63 | reserved | 0x0000 | 0dec | R | EEPROM


KM6551-0000 – Register description

BECKHOFF KM6551-0000: Access from the user program

Register description

These registers are used to parameterize the terminal module. They can be read or written by means of register communication.

R8: Module ID

Register R8 contains the ID for the terminal module.
KM6551-0000: 0x1997 (6551dec)

R9: Firmware version

Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.

R12: Minimum data length of a channel

Bits 0 to 6 of the high-order byte indicate the minimum number of output data in bits: 000.0000bin = 0dec so 0 bytes.

Bits 0 to 6 of the low-order byte indicate the minimum number of input data in bits: 001.1000bin = 24dec so 3 bytes.
The fact that bit 7 is set indicates that the control and status byte are not mandatory for the terminal function and are not transferred in compact mode.

R16: DIP switch setting

The DIP switch setting is stored in register R16.

Value (hex) | String (ASCII) | Operation Mode
0x414D | MA | Master
0x4253 | SB | Slave for broadcast reception
0x3153 | S1 | Slave with address 1
0x3253 | S2 | Slave with address 2
0x3353 | S3 | Slave with address 3
0x3453 | S4 | Slave with address 4
0x3553 | S5 | Slave with address 5
0x3653 | S6 | Slave with address 6
0x3753 | S7 | Slave with address 7
0xFFFF | - | Unknown DIP switch

R31: Code word register

  • If you write into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
  • If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.

The code word is reset if the terminal is restarted.

R32: Channel register (read/write)

IEEE 802.15.4 allows the use of one of 16 available channels. These frequency ranges work without influencing one another. The bandwidth of the signal is 2 MHz and the channel separation is 5 MHz. The channel should be selected such that it does not collide with WLAN or other systems that transmit in the 2.4 GHz range. Permitted settings in register 0 - 15.
It is permitted to change the channel during operation. The terminal displays the channel change in R33. The frequency channel has been accepted if R32 and R33 are identical.

R33: Channel register (read only)

The terminal acknowledges the acceptance of the channel in this channel. When accepting the new channel in R32, the terminal confirms this by entering the channel in R33.

R38: Watchdog (only activated in slave mode)

The watchdog for the slave is set in register R38. If the value is 0, the watchdog is deactivated. Therefore, no error bit will be set in the event of interrupted communication. The default value is 20dec. The value from R38 must be multiplied by approx. 20 ms.
Example: R38 = 100 (100 x 20 ms = 2000 ms or 2 sec).

R39: Broadcast mode

Broadcast mode for the broadcast master is activated in register R39. The register is not evaluated by the broadcast slaves. The slaves are “made into” broadcast slaves via the DIP switch.
0x0000: Master-slave- or peer to peer mode (default)
0x4342: Broadcast mode (master)

R40: Scan (only possible in master mode)

The slaves found are entered here if the scan has been activated with the bit CB1.2. Each bit represents a found slave address.

R41: Network ID

Using the network ID you can distinguish between up to 255 radio networks. The KM6551-0000 only accepts telegrams from modules with the same network ID.
Permissible value range: 0...255dec. The default value is 0dec.

Note 		Operation of several radio networks
If you wish to operate different radio networks within the range (e.g. inside a factory hall), distinguishing the networks by the use of different channel numbers guarantees more freedom from interference than if you operate networks with different network IDs on the same channel!

Use the network ID to distinguish between different radio networks only if no more free channels are available!

R46: Attenuation of the transmission power

You can attenuate the transmission power of the KM6551-0000 using bits 0 to 7 of register R46. The setting is active, if you restart the KL6551, power off/on.

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8
Name | - | - | - | - | - | - | - | -
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Large Scale |  | Small Scale |  |  | - | - | -
Legend
Bit | Name | Description |  | default
15...8 | - | reserved |  | 00bin
7...6 | Large Scale | 11bin | minus 30 dB | 00bin
 |  | 10bin | minus 20 dB
 |  | 01bin | minus 10 dB
 |  | 00bin | minus 0.0 dB
5...3 | Small Scale | 111bin | minus 6.3 dB | 000bin
 |  | 110bin | minus 4.9 dB
 |  | 101bin | minus 3.7 dB
 |  | 100bin | minus 2.8 dB
 |  | 011bin | minus 1.9 dB
 |  | 010bin | minus 1.2 dB
 |  | 001bin | minus 0.5 dB
 |  | 000bin | minus 0.0 dB
2...0 | - | reserved |  | 000bin


Examples of Register Communication

In the examples, the numbering of the bytes is according to the description without Word-Alignment.

Example 1: Reading the Firmware Issue Status from Register 9 of a Terminal

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 00 1001bin the register number 9.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access. If you want to change a register, you have to write the desired value into the output data word.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the Firmware Issue Status 0x3341 in ASCII code, in the input data word (Byte 1 and Byte 2). This has to be interpreted as ASCII code:
    - ASCII code 0x33 stands for the cipher 3
    - ASCII code 0x41 stands for the letter A
    Therefore the firmware version is 3A.

Example 2: Writing to an user register

NOTE 		Code word
At normal operation all user registers other than register 31are write protected.
In order to deactivate write protection, you have to write the password (0x1235) into register 31. Write protection is activated again by writing any value other than 0x1235
Note that some of the settings that can be made in registers only become active after the next power restart (power-off/power-on) of the terminal.

I. Writing the code word (0x1235) to Register 31

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35

Explanation:

  • Bit 0.7 set indicates: register communication active.
  • Bit 0.6 set indicates: writing to the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 and Byte 2) contains the code word 0x1235) to deactivate the write protection.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!

II. Reading Register 31 (verifying the set code word)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the current value of the code word register in the input data word (Byte 1 and Byte 2).

III. Writing into Register 32 (changing the content of the feature register)

Output Data
Byte 0: Control Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 set indicates: writing to the register
  • Bit 0.5 to Bit 0.0 indicates with 10 0000bin the register number 32.
  • The output data word (Byte 1 and Byte 2) contains the new value for the feature register.

    CAUTION     		Pay attention to the register description!
    The given value 0x0002 is only an example!
    The bits of the feature register change the properties of the terminal und and have different meanings, depending on the terminal type. Please check the description of the feature register of your terminal type (chapter register description) about the meanings of the bits in detail, before changing the values!
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!

IV. Reading Register 32 (verifying the changed feature register)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 10 0000bin the register number 32.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the current value of the feature register in the input data word (Byte 1 and Byte 2).

V. Writing to Register 31 (setting the code word back)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 set indicates: writing to the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 und Byte 2) contains 0x0000 to activate the write protection again.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!


KM6551-0000 - General operating conditions

BECKHOFF KM6551-0000: Appendix

General Operating Conditions

Approval and use

The KM6551-0000 module satisfies the requirements of EN 300-440-02 V1.1.2.

Operation of the KM6551-0000 module is permitted in all EU countries as well as in Switzerland and Liechtenstein. Other countries on enquiry.

The use of the KM6551-0000 is permitted with the following antennas:

Designation | Description
ZS6100-0900 | Directional antenna (gain 9 dBi), without cable
ZS6100-1800 | Directional antenna (gain 18 dBi), without cable
ZS6200-0400 | Omni directional antenna (gain 4 dBi), without cable
ZS6201-0410 | Rod antenna (gain 4 dBi), with cable (1 m)
ZS6201-0500 | Rod antenna (gain 5 dBi), without cable

Attention 		CE conformity
The CE conformity of the KM6551-0000 is only guaranteed if it is operated with original Beckhoff accessories (antennas, coaxial cable)!

Environmental conditions

The following conditions must be met in order to ensure flawless operation of the fieldbus components.

Operation

The components may not be used without additional protection in the following locations:

  • in difficult environments, such as where there are corrosive vapors or gases, or high dust levels
  • in the presence of high levels of ionizing radiation
Condition | Permissible range
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during operation | -25°C... +85°C
Installation position | any
Vibration resistance | conforms to EN 60068-2-6
Shock resistance | conforms to EN 60068-2-27, EN 60068-2-29
EMC immunity | conforms to EN 61000-6-2
Emission | conforms to EN 61000-6-4, EN 300-440-02 V1.1.2
Safety of persons in electromagnetic fields | conforms to EN 50371:2002

Transport and storage

Condition | Permissible range
Permissible ambient temperature during storage | -25°C... +85°C
Relative humidity | 95 %, no condensation
Free fall | up to 1 m in the original packaging

Protection classes and types

Condition | Permissible range
Protection class in accordance with IEC 536 (VDE 0106, Part 1) | A protective conductor connection to the mounting rail is necessary!
Protection class conforms to IEC 529 | IP20 (protection against contact with a standard test finger)
Protection against foreign objects | Less than 12 mm in diameter
Protection against water | no protection


KM6551-0000 - EC Declaration of Conformity

BECKHOFF KM6551-0000: Appendix

EC Declaration of Conformity


Calculating with decibels

In communication technology power is expressed in decibels (dB), a tenth of the unit Bel. It is the logarithmic ratio between two quantities with the same unit.

A reference variable (P1), e.g. a milliwatt (mW) is compared with the measured variable (P2). The logarithmic correlation was discovered by Alexander Graham Bell, in whose honor the unit Bel was named.

Since the number values would be too unwieldy if the Bel was used, it was agreed to use 1/10 of the value, i.e. the decibel.

Definition of the level difference: Level difference [dB] = 10 log ([P1] / [P2]).

Definition of a power ratio: power ratio = 10level difference/10

The advantage of expressing the powers and losses (attenuations) in dB is that the calculation method for power ratios can be replaced by a lower calculation method for the dB calculation.

Power ratio | dB calculation
Multiplication or division | Addition or subtraction
Exponent | Factor
Examples of power ratios
Factor | Amplification [dB]
x 1 | +0 dB
x 1.25 | +1 dB
x 2 | +3 dB
x 4 | +6 dB
x 10 | +10 dB
x 16 | +12 dB
x 100 | +20 dB
x 1000 | +30 dB

Factor | Attenuation [dB]
x 1 | -0 dB
x 0.8 | -1 dB
x 0.5 | -3 dB
x 0.25 | -6 dB
x 0.1 | -10 dB
x 0.6 | -12 dB
x 0.01 | -20 dB
x 0.001 | -30 dB
Examples of calculations with decibels
Change | in dB
10 / 2 = 5 | 10 - 3 = 7
2 x 2 x 2 = 8 | 3 + 3 + 3 = 9
2 x 100 = 200 | 3 + 20 = 23
1000 / 2 = 500 | 30 - 3 = 27


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


KM6551-0000 - FB_KM6551_ENERGIE_SCAN

BECKHOFF KM6551-0000: Function blocks

Function block FB_KM6551_ENERGY_SCAN

This function block scans the 16 channels of the 2.5 GHz band. A positive edge on bStart activates the scan. Two scan methods can be selected using iMode. If iMode = 0, a simple scan of the 16 channels will be performed. This scan takes approx. 90 seconds. If iMode = 1, the scan will be repeated 10 times. In the simple scan, each channel is observed for approx. 5 seconds. Please note that it may be the case that a WLAN, for example, is not transmitting precisely at this moment and that the scan can therefore contain a very low value. The values of the scanned channels lie in the array arEnergie from 0 - 15. The values are 0 – 100 %. The lower the value, the lower the energy concentration at a frequency. bBusy is TRUE as long as the block is working. If bBusy changes to FALSE, the block has either finished or has an error, which is displayed by bError . The type of error can then be read out with iErrorID.

VAR_INPUT

bStart :BOOL;
iMode :INT;
strLinkData :KM6551_Data;

Legend

bStart: A positive edge activates the block.
iMode: Simple scan iMode = 0, 10 x scan iMode = 1
strLinkData: Is linked with strLinkData from FB_KM6551_MAIN.

VAR_OUTPUT

bBusy :BOOL;
arEnergie :ARRAY [0..15] OF UDINT;
bError :BOOL;
iErrorID :E_KM6551_ERRORID;

Legend

bBusy: The block is still working as long as bBusy is set, i.e. is TRUE; wait until bBusy changes to FALSE.
arEnergie: Contains the energy value for the individual channels. "0 %" low energy, "100 %" high energy.
bError: The block has an error.
iErrorID: Error code