KM4602 - Two Channel Analog Output Module with Manual and Automatic Operation
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.2.0
▪
Update Technical data
▪
Update structure
2.1.0
▪
Description of Control Byte corrected
2.0.0
▪
Migration
1.0.0
▪
First publication
Firmware and hardware versions
Documentation, version | Firmware version | Hardware version
2.2.0 | 1C | 03
2.1.0 | 1C | 03
2.0.0 | 1C | 02
1.0.0 | 1C | 01
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal module.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Sample with ser. no.: 35 05 00 01:
35 - week of production 35
05 - year of production 2005
00 - firmware version 00
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] Introduction
Introduction
KM4602
The KM4602 analog output terminal has two potential-free analog outputs (0 to 10 VDC). Both outputs are internally connected to a common ground.
For each channel a switch enables selection between automatic and manual mode:
▪
In automatic mode, an analog value is output as a function of the process data.
▪
In manual mode, the value set via the potentiometer is applied to the output.
The 24 VDC (UL) Bus Coupler supply voltage is also required for manual mode.
The state of the switches can be read by the controller (bit 0 of the status bytes).


Technical data

Product overview [image] Technical data
Technical data
Technical data | KM4602-0000
Number of outputs | 2
Connection technology | Single ended
Output voltage | 0 to 10 VDC
Load | > 5 kΩ (short-circuit-proof)
Resolution | 12 bit
Output error | < ±0.1% (based on the end value)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 175 mA
Width of a bus terminal block | Maximum 64 standard Bus Terminals or 80 cm (one KM4602-0000 corresponds to 2 standard Bus Terminals here)
Data width in the input process image | 8 bit status, 16 bit data
Data width in the output process image | 8 bit control, 16 bit data
Configuration | no address or configuration settings
Operation modes | Manual or automatic operating mode
Electrical isolation | 500 V (K-Bus/signal voltage)
Dimensions without antenna (W x H x D) | approx. 26.5 mm x 100 mm x 55 mm (width aligned: 24 mm)
Weight | approx. 85 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Mounting | on a 35 mm mounting rail (e.g. DIN rail TH 35-7.5 conforming to EN 60715)
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4, EN 300-440-02
Protection class | IP20
Installation position | variable
Approval | CE


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Recommended mounting rails
•
Mounting and demounting - terminals with front unlocking
•
Dimensions
•
Connection


Recommended mounting rails

Mounting and wiring [image] Recommended mounting rails
Recommended mounting rails
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:
▪
DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
▪
DIN Rail TH 35-15 with 1,5 mm material thickness
Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


Mounting and demounting - terminals with front unlocking

Mounting and wiring [image] Mounting and demounting - terminals with front unlocking
Mounting and demounting - terminals with front unlocking
The terminal modules are fastened to the assembly surface with the aid of a 35 mm mounting rail (e.g. mounting rail TH 35-15).
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the recommended mounting rails under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Mounting
▪
Fit the mounting rail to the planned assembly location.

and press (1) the terminal module against the mounting rail until it latches in place on the mounting rail (2).
▪
Attach the cables.
Demounting
▪
Remove all the cables.
▪
Lever the unlatching hook back with thumb and forefinger (3). An internal mechanism pulls the two latching lugs (3a) from the top hat rail back into the terminal module.
▪
Pull (4) the terminal module away from the mounting surface.
Avoid canting of the module; you should stabilize the module with the other hand, if required.


Dimensions

Mounting and wiring [image] Dimensions
Dimensions
KM4602 dimensions


Connection

Mounting and wiring [image] Connection
Connection
KM4602 connection
Terminal point | Description
Channel 1 | Signal connection for channel 1
Ground | Earth connection for channel 1
Shield | Shield connection for channel 1
Channel 2 | Signal connection for channel 2
Ground | Earth connection for channel 3
Shield | Shield connection for channel 2
Internal KM4602 configuration
Internal KM4602 configuration


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Mapping
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The KM4602 terminal module represents itself in the process image with a maximum of 6 bytes of input data and 6 bytes of output data. These are organized as follows:
Format | Input data | Output data
Byte | SB1 | CB1
Word | DataIN1 | DataOUT1
Byte | SB2 | CB2
Word | DataIN2 | DataOUT2
Legend
SB n: Status byte for channel n
CB n: Control byte for channel n
DataIN n: Input data word channel n
DataOUT n: Output data word channel n
▪
Please refer to the Mapping page for the allocation of the bytes and words to the addresses of the controller.
▪
The meaning of the control and status bytes is explained in Control and status bytes.
▪
In process data mode the analog values are transferred in output data words DataOUT1 and DataOUT4. Input data words DataIN1 and DataIN4 are not used.
Data format
Process data |  | Output voltage
hexadecimal | decimal
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V


Mapping

Access from the user program [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of the process data (input and output data) and parameterization data (control and status bytes) to the controller addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions) such as
–
compact or full evaluation.
–
Intel or Motorola format.
–
word alignment switched on or off.
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.
Compact evaluation
With compact evaluation, the analog output terminals only occupy addresses in the output process image. Control and status bytes cannot be accessed.
Compact evaluation in Intel format
Default mapping for CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
Compact evaluation in Motorola format
Default mapping for PROFIBUS and Interbus coupler
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
Complete evaluation
For complete evaluation, the analog output terminals occupy addresses in the input and output process image. Control and status bytes can be accessed.
Complete evaluation in Intel format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Complete evaluation in Motorola format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Complete evaluation in Intel format with word alignment
Default mapping for Lightbus, Ethernet and EtherCAT coupler as well as Bus Terminal Controllers (BCxxxx, BXxxxx)
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Complete evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Legend
Complete evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the channel address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.
SB n: Status byte for channel n (appears in the input process image).
CB n: Control byte for channel n (appears in the output process image).
Ch n D0: channel n, lower-value data byte
Ch n D1: channel n, higher-value data byte
Reserved: This byte occupies process data memory, although it has no function.
"-": This byte is not assigned or used by the terminal/module.


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal module.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Legend
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 to CB1.1 | - | 0bin | reserved
... | ... | ... | ...
CB1.0 | - | 0bin | reserved
Status byte 1 (for process data mode)
Status byte 1 (SB1) is located in the input image and is transmitted from terminal module to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | - | - | - | - | - | - | OperationMode
Legend
Bit | Name | Description
SB1.6 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | - |  | reserved
... | ... | ... | ...
SB1.1 | - | 0bin | reserved
SB1.0 | OperationMode | 0bin | Manual mode is enabled for this channel.
 |  | 1bin | Automatic mode is enabled for this channel.
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal module.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.
Status byte 1 (in register communication)
Status byte 1 (SB1) is located in the input image and is transmitted from terminal module to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user program [image] Register overview
Register overview
The following registers are used for parameterization of the KM4602. Each signal channel of the analog terminal has one register that can be read or written to with the aid of control, status and data bytes via register communication.
Register no. | Comment | Default value |  | R/W | Memory
R0 | Process data for D/A-C | - | - | R | RAM
R1 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R5 | reserved | - | - | - | -
R6 | Diagnostic register (not used) | - | - | R | RAM
R7 | Command register (not used) | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x11FA | 4602dec | R | ROM
R9 | Firmware version | e.g. 0x3141 | e.g. 1AASCI | R | ROM
R10 | Data length (multiplex shift register) | 0x0218 | 536dec | R | ROM
R11 | Signal channels | 0x0218 | 536dec | R | ROM
R12 | Minimum data length | 0x9800 | 38912dec | R | ROM
R13 | Data structure (data type register) | 0x0000 | 0dec | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | e.g. 0x7F80 | e.g. 32640dec | R/W | RAM
R16 | Hardware version number | e.g. 0x0000 | e.g. 0dec | R/W | SEEPROM
R17 | Hardware compensation: offset (Ba) | 0x0001 | 1dec | R/W | SEEPROM
R18 | Hardware compensation: gain (Aa) | typ. 0x0E99 | typ. 3737dec | R/W | SEEPROM
R19 | Manufacturer scaling: Offset (Bh) | 0x0000 | 0dec | R/W | SEEPROM
R20 | Manufacturer scaling: Gain (Ah) | typ. 0x0020 | typ. 32dec | R/W | SEEPROM
R21 | Manufacturer's switch-on value | 0x0000 | 0dec | R/W | SEEPROM
R22 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserved | - | - | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0006 | 6dec | R/W | SEEPROM
R33 | User scaling: offset (Bw) | 0x0000 | 0dec | R/W | SEEPROM
R34 | User scaling: gain (Aw) | 0x0100 | 256dec | R/W | SEEPROM
R35 | User's switch-on value (Y2) | 0x0000 | 0dec | R/W | SEEPROM
R36 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserved | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
The following registers are used for parameterization of the KM4602. Each signal channel of the analog terminal has one register that can be read or written to with the aid of control, status and data bytes via register communication.
R0: Process data for D/A-C
Process data, which are transferred to the D/A converter.
R6: Diagnostic register
The diagnostics register of the KM4602 is currently not used.
R7: Command register
The command register of the KM4602 is currently not used.
R8: Terminal description
The description of the terminal is contained in register R8.
KM4602: 0x11FA (4602dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 (1AASCII). '0x31' corresponds to the ASCII character '1' and '0x41' to the ASCII character 'A'. This value cannot be changed.
R10: Data length (multiplex shift register)
R10 contains the number of multiplexed shift registers and their length in bits.
R11: Signal channels
Unlike R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
R13: Data structure (data type register)
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure: 1 byte, n bytes
0x03 | Word array
0x04 | Structure: 1 byte, n words
0x05 | Double word array
0x06 | Structure: 1 byte, n double words
0x07 | Structure: 1 byte, 1 double word
0x08 | Structure: 1 byte, 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure: 1 byte, n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure: 1 byte, n words with variable logical channel length
0x15x | Double word array with variable logical channel length
0x16 | Structure: 1 byte, n double words with variable logical channel length
R15: Alignment register
Via the alignment register bits, the Bus Coupler arranges the address range of an analog terminal such that it starts at a byte boundary.
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal; this value cannot be changed.
R17: Hardware compensation - offset (Ba)
This register is used for the offset compensation of the terminal (see equation 1.1). Register value (16 bit signed integer). Default: 0x0001 (1dec)
R18: Hardware compensation - gain (Aa)
This register is used for the gain compensation of the terminal (see equation 1.1). Register value (16 bit unsigned integer x 2-12). Default: typically 0x0E99 (3737dec)
R19: Manufacturer scaling - offset (Bh)
This register contains the offset for the manufacturer scaling (see equation 1.3). Register value (16 bit signed integer). Default: 0x0000 (0dec)
Manufacturer scaling can be activated via bit R32.1 of the feature register.
R20: Manufacturer scaling - gain (Ah)
This register contains the gain for manufacturer scaling (see equation 1.3). Register value (16 bit unsigned integer x 2-8). Default: typically 0x0020 (32dec)
Manufacturer scaling can be activated via bit R32.1 of the feature register.
R21: Manufacturer's switch-on value
The terminal applies the manufacturer switch-on value to its output after a system reset or a watchdog timer overflow (terminal has received no process data for 100 ms). Register value (16 bit signed integer).
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset with each restart of the terminal.
R32: Feature register
The feature register specifies the terminal's configuration. Default: 0x0006 (6dec)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | enUserActValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | enSignRepr | - | enSignAmRepr | enWdTimer | enManScal | enUsrScal
Legend
Bit | Name | Description |  | default
R32.15 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.9 | - | reserved |  | 0bin
R32.8 | enUserActValue | 0bin | Manufacturer switch-on value active | 0bin
 |  | 1bin | User switch-on value active
R32.7 | - | reserved |  | 0bin
R32.6 | - | reserved |  | 0bin
R32.5 | enSignRepr | 0bin | Absolute value calculation not active | 0bin
 |  | 1bin | Absolute value calculation active
R32.4 | - | reserved |  | 0bin
R32.3 | enSignAmRepr | 0bin | Two's complement representation is active | 0bin
 |  | 1bin | The arithmetic sign of numerical quantities is active (-1dec = 0x8001)
R32.2 | enWdTimer | 0bin | Watchdog timer is not active | 1bin
 |  | 1bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms)
R32.1 | enManScal | 0bin | Manufacturer scaling is active | 1bin
 |  | 1bin | Manufacturer scaling is not active
R32.0 | enUsrScal | 0bin | User scaling is not active | 0bin
 |  | 1bin | User scaling is active
R33: User scaling - offset (Bw)
This register contains the offset of the user scaling.
User scaling can be activated in the feature register via bit R32.0.
R34: User scaling - gain (Aw)
This register contains the gain of the user scaling. Default: 0x0100 (256dec)
User scaling can be activated in the feature register via bit R32.0.
R35: User's switch-on value
If the user switch-on value has been activated with bit R32.8 of the feature register, the terminal sets its output to the user switch-on value in place of the manufacturer switch-on value on the occurrence of a system reset or a watchdog timer overflow (terminal has not received any process data for 100 ms).


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com