KM37xx - Pressure measuring modules
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Corrections
▪
First public issue as PDF
1.2.0
▪
Technical data updated
▪
Installation and wiring extended
▪
Process data corrected
▪
KM3701-0340 added
1.1.1
Application examples update
1.1.0
Technical data updated
1.0.0
First release
Firmware and hardware versions
Documentation Version | KM3701-0000, KM3701-0340 |  | KM3702-0000 |  | KM3712-0000
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.0.0 | 1G | 09 | 1D | 07 | 1E | 09
1.2.0 | 1C | 01 | 1B | 01 | 1B | 01
1.1.1 | 1C | 00 | 1B | 00 | 1B | 00
1.1.0 | 1B | 00 | 1A | 00 | 1A | 00
1.0.0 | 1B | 00 | 1A | 00 | 1A | 00
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal module.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 35 05 00 01:
35 - week of production 35
05 - year of production 2005
00 - firmware version 00
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
KM3701 - Introduction
•
KM3702 - Introduction
•
KM3712 - Introduction
•
Technical data
•
Basic function principles
•
LED displays


KM3701 - Introduction

Product overview [image] KM3701 - Introduction
KM3701 - Introduction
KM3701
Single-channel differential pressure measuring module
The KM3701 differential pressure measuring module enables direct measurement of pressure differences between two hose connections. The pressure difference is available in the fieldbus with 16-bit resolution. The measuring range is between -100 hPa and +100 hPa (-100 mbar to +100 mbar). The status LEDs indicate proper function or errors such as range exceedance.
Two variants are available:
▪
KM3701-0000: Measuring range -100 to +100 hPa (-100 to +100 mbar)
▪
KM3701-0340: Measuring range -340 to +340 hPa (-340 to +340 mbar)
Quick links
▪
Mounting and wiring
▪
Access from the user program
▪
Application examples


KM3702 - Introduction

Product overview [image] KM3702 - Introduction
KM3702 - Introduction
KM3702
Two-channel relative pressure measuring module for 0 to 7500 hPa (0 to 7.5 bar)
The relative pressure measuring module KM3702 enables direct measurement of two pressure values at the hose connections. The pressure is determined as the difference to the environment of the KM3702 and is available in the fieldbus with 16 bit resolution. The status LEDs indicate proper function or errors such as range exceedance.


KM3712 - Introduction

Product overview [image] KM3712 - Introduction
KM3712 - Introduction
KM3712
Dual channel relative pressure measuring module for -1,000 hPa to +1,000 hPa (-1 bar to +1 bar)
The relative pressure measuring module KM3712 allows the direct measurement of two negative pressure values on the hose connections. The pressure is determined as the difference to the environment of the KM3712 and is available in the fieldbus with 16 bit resolution. The status LEDs indicate proper function or errors such as range exceedance.


Technical data

Product overview [image] Technical data
Technical data
Technical Data | KM3701-0000 | KM3701-0340 | KM3702-0000 | KM3712-0000
Number of inputs | 1 (differential pressure) |  | 2 | 2
Measuring range | -100 to +100 hPa (-100 to +100 mbar) | -340 to +340 hPa (-340 to +340 mbar) | 0 to 7500 hPa (0 to 7.5 bar) | -1000 to +1000 hPa (-1 to +1 bar)
Permissible overpressure | max. ±500 hPa differential max. +5000 hPa relative to ambient |  | +10000 hPa | +5000 hPa
permissible media | non-aggressive gases
Resolution | 0.1 hPa (0.1 mbar) per digit |  | 1 hPa (1 mbar) per digit | 1 hPa (1 mbar) per digit
Measuring accuracy | 3% (of the full scale value)
Measuring speed | typically 5 ms
Pressure connectors | screwing plug, M12 x 1
Power supply for the electronics | via the K-bus
Current consumption from the K-bus | typically 15 mA
Width of a bus terminal block | Maximum 64 standard Bus Terminals or 80 cm (a KM37xx is equivalent to 2 standard Bus Terminals)
Electrical isolation | 500 V (K-bus/signal voltage)
Bit width in the input process image | 3 byte | 3 byte | 6 byte | 6 byte
Bit width in the output process image | 3 byte | 3 byte | 6 byte | 6 byte
Dimensions without tubes (w x h x d) | approx. 26.5 mm x 100 mm x 69 mm (width aligned: 24 mm)
Weight | approx. 100 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95 %, no condensation
Mounting | on a 35 mm mounting rail (e.g. DIN rail TH 35-7.5 conforming to EN 60715)
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Bus Terminal block with pressure measuring modules
The pressure measuring modules KM3701 and KM3712 directly record differential and relative pressures in non-aggressive gases. As in electronic signal acquisition the pressure measurement takes place via a terminal module. The pressure measuring modules convert the measured pressure into an electrical signal and make it available to the higher-level controller with a resolution of 16 bits. The measuring principle is based on the most up-to-date on-chip sensor technology. In addition to just measuring, the semiconductor also executes other functions, such as temperature compensation and avoidance of long-term drift. The status LEDs indicate proper function or errors such as range exceedance.
KM3701 single-channel differential pressure measuring module
KM3701 - Single-channel differential pressure measurement
The KM3701 terminal module can measure pressure differences between 0 and 100 hPa (0 and 100 mbar) between two hose connections. The differential pressure can be measured up to an ambient pressure of 7500 hPa (7 bar) between any points.
KM3702 - Two-channel relative pressure measuring module (0 hPa to 7500 hPa)
KM3702 - Two-channel relative pressure measurement
The KM3702 terminal module can measure pressure values between 0 and 7000 hPa (0 and 7 bar) at each hose connection. Pressure measurement takes place relative to the actual current ambient pressure.
KM3712 - Two-channel relative pressure measuring module (-1000 hPa to +1000 hPa)
KM3712 - Two-channel relative pressure measurement
The KM3712 terminal module can measure pressure values between -1000 hPa and +1000 hPa (-1 bar and +1 bar) at each hose connection. Pressure measurement takes place relative to the actual current ambient pressure.
Installation and connection technique
The pressure measuring terminal samples the pressure values directly. Additional measuring devices are unnecessary. This avoids connection systems and saves available space compared with the use of conventional measuring devices. The installation of the pressure measuring terminals is simple and fast and can be carried out without any additional mounting tools. The measuring hoses are connected directly to the quick couplings of the pressure measuring terminal. Standard commercial plastic hoses can be used as measuring hoses. In terms of connections and installation space the pressure measuring terminals are designed like a "normal" 24 mm Bus Terminal and can be installed with minimum space requirement directly in the Bus Terminal system.


LED displays

Product overview [image] LED displays
LED displays
KM3701
KM3701 - LEDs
LED | Display
Run (green) | off | Data transmission on the K-bus is not active
 | on | Data transmission on the K-bus is active
Over-range (red) | on | The differential pressure is above the permitted measuring range
Under-range (red) | on | The differential pressure is below the permitted measuring range
KM3702, KM3712
KM3702, KM3712 - LEDs
LED | Display
Run (green) | off | Data transmission on the K-bus is not active
 | on | Data transmission on the K-bus is active
Error X1 (red) | on | The pressure at connection X1 is below (under-range) or above (over-range) the permitted measuring range
Error X2 (red) | on | The pressure at connection X2 is below (under-range) or above (over-range) the permitted measuring range


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Recommended mounting rails
•
Mounting and demounting - terminals with front unlocking
•
Connection


Recommended mounting rails

Mounting and wiring [image] Recommended mounting rails
Recommended mounting rails
Terminal Modules and EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:
▪
DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
▪
DIN Rail TH 35-15 with 1,5 mm material thickness
Note
Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


Mounting and demounting - terminals with front unlocking

Mounting and wiring [image] Mounting and demounting - terminals with front unlocking
Mounting and demounting - terminals with front unlocking
The terminal modules are fastened to the assembly surface with the aid of a 35 mm mounting rail (e.g. mounting rail TH 35-15).
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the recommended mounting rails under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Mounting
▪
Fit the mounting rail to the planned assembly location.

and press (1) the terminal module against the mounting rail until it latches in place on the mounting rail (2).
▪
Attach the cables.
Demounting
▪
Remove all the cables.
▪
Lever the unlatching hook back with thumb and forefinger (3). An internal mechanism pulls the two latching lugs (3a) from the top hat rail back into the terminal module.
▪
Pull (4) the terminal module away from the mounting surface.
Avoid canting of the module; you should stabilize the module with the other hand, if required.


Connection

Mounting and wiring [image] Connection
Connection
The air hoses are connected to push-in fittings.
Technical Data | Threaded push-in fitting
Type | QSS-4-F
Outer hose diameter | 4 mm
Nominal diameter | 2.6 mm
Thread | M12 x 1
Width across flats | 14 mm


Application examples

Application examples
Application examples
The pressure measuring modules can be used in any applications requiring logging and monitoring of differential and dynamic pressures in non-aggressive gases, e.g. pressure vessels, pressure cabins or pneumatic, filter, suction, packaging and positioning systems.
They measure operating pressures, monitor filters and sieves, check the seal tightness of tanks and assist in position testing of construction elements or monitoring the level of liquids. If flow rates are calculated from the measured pressures, then the pressure measuring terminals can also be used for flow measurement. They can therefore be applied in areas such as process engineering, systems engineering, building services and heating, ventilating and air conditioning.
▪
Application examples for KM3701
▪
Application example for KM3702
▪
Application example for KM3712
Additional information
•
KM3701 - Application examples
•
KM3702 - Application example
•
KM3712 - Application example


KM3701 - Application examples

Application examples [image] KM3701 - Application examples
KM3701 - Application examples
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Tank systems
KM3701 - Application example for the fill level of tanks
▪
Monitors tank filling levels and activates topping up when the level falls below a defined filling value
▪
The pressure difference is an indicator for the filling level
▪
No additional pressure gauges, switches and associated connection equipment are required
Filter systems, pipe constrictions
KM3701 - Application example for filter systems, pipe restrictions
▪
Monitors the operating state of filters and screens
▪
The pressure difference indicates the level of contamination


KM3702 - Application example

Application examples [image] KM3702 - Application example
KM3702 - Application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Pneumatic systems
KM3702 - Application example for pneumatic systems
▪
Checking the filling level of stores
▪
Monitoring the operating pressure of equipment
▪
enables monitoring and avoidance of overpressure


KM3712 - Application example

Application examples [image] KM3712 - Application example
KM3712 - Application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Packaging plant for eggs
EM3712 - Application example Packging plant for eggs
▪
controls suction
▪
Pressure deviations indicate leakages or positioning inaccuracies


KS2000 Configuration software

KS2000 Configuration software
KS2000 Configuration software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Process Data


KS2000 - Introduction

KS2000 Configuration software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 Digital Input Terminal
▪
a KM3701 differential pressure measuring module
▪
a KL9010 Bus End Terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the module whose parameters you wish to change (pos. 2 in the example).
KS2000 branch for channel 1 of the KM3701
For the KM3701, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KM3701 registers.
▪
ProcData shows the process data of the KM3701.


Register

KS2000 Configuration software [image] Register
Register
Under Register you can directly access the registers of the terminal module (KM3701 in this example). The meaning of the register is explained in the Register Overview.
Register view in KS2000


Process Data

KS2000 Configuration software [image] Process Data
Process Data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
Process Data field
The spectacles mark the data that are currently graphically displayed in the History field.
History field
The current input value is displayed numerically in the Value field.
Value field
Output values can be modified through direct input or by means of the fader control.
Value field
CAUTION
Danger for persons, the environment or devices!
Note that changing output values (forcing them) can have a direct effect on your automation application. Only modify these output values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Setting the display


Access from the user programm

Access from the user programm
Access from the user programm
Additional information
•
KM3701 - Process image
•
KM3702, KM3712 - Process image
•
Control and Status Byte
•
Register overview
•
Register description
•
Examples of Register Communication


KM3701 - Process image

Access from the user programm [image] KM3701 - Process image
KM3701 - Process image
The KM3701 terminal module is represented in the process image with a maximum of 3 bytes of input data and 3 bytes of output data. These are organized as follows:
Format | Input data | Output data
Byte | SB | CB
Word | DataIN | DataOUT
Key
SB: Status byte
CB: Control byte
DataIN: Input data word
DataOUT: Output data word
▪
The meaning of the control and status bytes is explained in Control and status bytes.
▪
In process data mode, the analog value is transferred in the input data word DataIN. The output data word DataOUT is not used.
Representation of the analog values
The terminal module displays the analog input values as follows:
KM3701-0000
Differential pressure | Decimal | Hexadecimal
-100 hPa | -1000 | 0xFC18
0 hPa | 0 | 0x0000
+100 hPa | +1000 | 0x03E8
KM3701-0340
Differential pressure | Decimal | Hexadecimal
-340 hPa | -3400 | 0xF2B8
0 hPa | 0 | 0x0000
+340 hPa | +3400 | 0x0D48


KM3702, KM3712 - Process image

Access from the user programm [image] KM3702, KM3712 - Process image
KM3702, KM3712 - Process image
The KM3702 and KM3712 terminal modules are represented in the process image with a maximum of 6 bytes of input data and 6 bytes of output data. These are organized as follows:
Format | Input data | Output data
Byte | SB1 | CB1
Word | DataIN1 | DataOUT1
Byte | SB2 | CB2
Word | DataIN2 | DataOUT2
Key
SB n: Status byte for channel n
CB n: Control byte for channel n
DataIN n: Input data word channel n
DataOUT n: Output data word channel n
▪
The meaning of the control and status bytes is explained in Control and status bytes.
▪
In process data mode the analog values are transferred in output data words DataIN1 and DataIN2. Input data words DataOUT1 and DataOUT2 are not used.
Representation of the analog values
The analog input values are represented by the terminal modules as follows:
KM3702-0000
Pressure | Decimal | Hexadecimal
0 hPa | 0 | 0x0000
7500 hPa | 7500 | 0x1D4C
KM3712-0000
Pressure | Decimal | Hexadecimal
-1000 hPa | -1000 | 0xFC18
0 hPa | 0 | 0x0000
+1000 hPa | +1000 | 0x03E8


Control and Status Byte

Access from the user programm [image] Control and Status Byte
Control and Status Byte
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal module.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 to CB1.1 | - | 0bin | reserved
... | ... | ... | ...
CB1.0 | - | 0bin | reserved
Status byte 1 (for process data mode)
Status byte 1 (SB1) is located in the input image and is transmitted from terminal module to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | StateThreshold2 |  | StateThreshold1 |  | Overload | Underload
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgment for process data mode
SB1.6 | Error | 1bin | an internal error has occurred (current process data is no longer valid)
SB1.5 / SB1.4 | StateThreshold2 | 0bin | Threshold 2 is not enabled via bit R32.10 of the feature register
 |  | 01bin | Process data is greater than threshold 2
 |  | 10bin | Process data is less than threshold 2
 |  | 11bin | Process data equals threshold 2
SB1.3 / SB1.2 | StateThreshold1 | 0bin | Threshold 1 is not enabled via bit R32.9 of the feature register
 |  | 01bin | Process data is greater than threshold 1
 |  | 10bin | Process data is less than threshold 1
 |  | 11bin | Process data equals threshold 1
SB1.1 | Overload | 1bin | Process data is greater than specified in register R21. The red error LED of this channel is lit.
SB1.0 | Underload | 1bin | Process data are less than specified in register R22. The red error LED of this channel is lit. (The calibration is active if SB1.0 and SB1.1 are set simultaneously).
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal module.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.
Status byte 1 (in register communication)
Status byte 1 (SB1) is located in the input image and is transmitted from terminal module to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgment for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2 (only KM3702 and KM3712)
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user programm [image] Register overview
Register overview
The registers are used for the parameterization of the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Raw ADC value |  | variable | variable | R | RAM
R1 | reserved |  | 0x0000 | 0dec | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserved |  | 0x0000 | 0dec | - | -
R6 | Diagnostic register |  | 0x0000 | 0dec | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KM3701: | 0x0E75 | 3701dec | R | ROM
 |  | KM3702: | 0x0E76 | 3702dec
 |  | KM3712: | 0x0E80 | 3712dec
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0118 | 280dec | R | ROM
R11 | Signal channels |  | 0x0218 | 280dec | R | ROM
R12 | minimum data length of a channel |  | 0x0098 | 152dec | R | ROM
R13 | Data structure |  | 0x0000 | 0dec | R | ROM
R14 | reserved |  | 0x0000 | 0dec | - | -
R15 | Alignment register |  | typically 0x7F80 | typically 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | Vendor calibration: Offset | KM3701, KM3712: | typically 0xF800 | typically 63488dec | R/W | EEPROM
 |  | KM3702: | typically 0xFE66 | typically 65126dec
R18 | Vendor calibration: Gain |  | 0x0000 | 0dec | R/W | EEPROM
R19 | Manufacturer scaling: Offset |  | 0x0000 | 0dec | R/W | EEPROM
R20 | Manufacturer scaling: Gain | KM3701, KM3712: | 0x00A2 | 162dec | R/W | EEPROM
 |  | KM3702: | 0x021B | 539dec
R21 | Overrange limit | KM3701, KM3712: | 0x03E8 | 1000dec | R/W | EEPROM
 |  | KM3702: | 0x1D4C | 7500dec
R22 | Under range limit | KM3701, KM3712: | 0xFC18 | -1000dec | R/W | EEPROM
 |  | KM3702: | 0xFF9C | -100dec
R23 | internal use |  | 0x0000 | 0dec | R/W | EEPROM
R24 | internal use |  | 0x1004 | 4100dec | R/W | EEPROM
R25 | reserved |  | 0x0000 | 0dec | - | -
... | reserved |  | - | - | - | -
R30 | reserved |  | 0x0000 | 0dec | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0202 | 514dec | R/W | EEPROM
R33 | User offset |  | 0x0000 | 0dec | R/W | EEPROM
R34 | User gain |  | 0x0100 | 256dec | R/W | EEPROM
R35 | Threshold 1 |  | 0x0000 | 0dec | R/W | EEPROM
R36 | Threshold 2 |  | 0x0000 | 0dec | R/W | EEPROM
R37 | reserved |  | - | - | - | -
... | reserved |  | - | - | - | -
R63 | reserved |  | - | - | - | -


Register description

Access from the user programm [image] Register description
Register description
The registers are used for the parameterization of the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
R0: Raw ADC value
Register R0 contains the raw value of the analog/digital converter. This is the unchanged analog value prior to any scaling.
R6: Diagnostic register
Status byte SB1 is placed into register R6.
R7: Command register
Note
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31!
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the factory settings for the following registers of both channels:
KM3701, KM3712:
R21: 0x03E8 (1000dec)
R22: 0xFC18 (-1000dec)
R32: 0x0202 (514dec)
R33: 0x0000 (0dec)
R34: 0x0100 (256dec)
R35: 0x0000 (0dec)
R36: 0x0000 (0dec)
KM3702:
R21: 0x1D4C (7500dec)
R22: 0xFF9C (-100dec)
R32: 0x0202 (514dec)
R33: 0x0000 (0dec)
R34: 0x0100 (256dec)
R35: 0x0000 (0dec)
R36: 0x0000 (0dec)
Note
Delivery state for all channels
The command Restore Factory Settings simultaneously resets all module channels to the delivery state, irrespective of which register set it is called from!
R8: Module ID
Register R8 contains the ID for the terminal module.
KM3701: 0x0C64 (3701dec)
KM3702: 0x0C6E (3702dec)
KM3712: 0xC3C (3712dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value cannot be changed.
R12: Minimum data length of a channel
Bits 0 to 6 of the high-order byte specify the minimum number of output data in bits: 000.0000bin = 0dec, hence 0 bytes.
Bits 0 to 6 of the low-order byte specify the minimum number of input data in bits: 001.1000bin = 24dec, hence 3 bytes.
The fact that bit 7 is set indicates that the control and status byte are not mandatory for the terminal function and are not transferred in compact mode.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R17: Vendor calibration - offset
This register contains the vendor calibration offset (16 bit signed integer).
R18: Vendor calibration - gain
This register contains the vendor calibration gain (16 bit unsigned integer x 2-16 + 1). Samples:
0x0000 means factor 1
0xFFFF means factor 2
R19: Manufacturer scaling - offset
This register contains the offset of the manufacturer scaling. Can be activated via R32.1 in the feature register (16 bit signed integer).
R20: Manufacturer scaling - gain
This register contains the gain of the manufacturer scaling. Can be activated via R32.1 in the feature register (16 bit unsigned integer x 2-8 + 1). Samples:
0x0100 means factor 1.
0x0080 means factor 0.5
R21: Upper measuring range limit
This register contains the upper measuring range limit. It can be activated by R32.8 in the feature register.
R22: Lower measuring range limit
This register contains the lower measuring range limit. It can be activated by R32.8 in the feature register.
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32: Feature register
The feature register defines the module configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | enTh2 | enTh1 | enOverProt | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | enSiemens Format | enAverage Format | disWdTimer | enManScal | enUsrScal
Bit | Name | Description |  | default
R32.15 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.12 | - | reserved |  | 0bin
R32.11 | enTh2 | 0bin | Threshold 2 not active | 0bin
 |  | 1bin | Threshold 2 active
R32.10 | enTh1 | 0bin | Threshold 1 not active | 0bin
 |  | 1bin | Threshold 1 active
R32.9 | enOverProt | 0bin | Measuring range limitation not active | 1bin
 |  | 1bin | Overrange protection active
R32.8 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.5 | - | reserved |  | 0bin
R32.4 | enSiemensFormat | 0bin | Siemens output format not active | 0bin
 |  | 1bin | Siemens output format active
R32.3 | enAverageFormat | 0bin | Signed amount representation not active | 0bin
 |  | 1bin | Signed amount representation active
R32.2 | disWdTimer | 0bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms) | 0bin
 |  | 1bin | Watchdog timer is not active
R32.1 | enManScal | 0bin | Manufacturer scaling is not active | 1bin
 |  | 1bin | Manufacturer scaling is active
R32.0 | enUsrScal | 0bin | User scaling is not active | 0bin
 |  | 1bin | User scaling is active
R33: User scaling - offset
This register contains the offset of the user scaling. The user scaling can be activated in the feature register through bit R32.0 (16 bit signed integer).
R34: User scaling - gain
This register contains the gain of the user scaling. The user scaling can be activated in the feature register through bit R32.0 (16 bit unsigned integer x 2-8 + 1, 1dec corresponds to 0x0100).
R35: Threshold 1
Threshold 1 is entered in register R35. The threshold can be activated in the feature register through bit R32.10.
R36: Threshold 2
Threshold 2 is entered in register R36. The threshold can be activated in the feature register through bit R32.11.


Examples of Register Communication

Access from the user programm [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user programm [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user programm [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com