KM2774-0000 - Terminal Module for jalousie motors

BECKHOFF Fieldbus Components

Documentation for

KM2774-0000

Terminal Module for jalousie motors

Version: 1.0.0
Date: 2010-08-18


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


KM2774-0000 - Documentation issue status

BECKHOFF KM2774-0000: Foreword

Documentation issue status

Version | Comment
1.0.0 | first release

Firm and hardware versions

Documentation Version | Firmware version | Hardware version
1.0.0 | 1E | 04

The firm and hardware version can be taken from the serial number on the label at the bottom of the terminal module.

Syntax of the serial number

Structure of the serial number: WW YY FF HH

WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version (n/a for digital modules)
HH - hardware version

Example with Ser. No.: 12 10 1E 04

12 - week of production 12
10 - year of production 2010
1E - firmware version 1E
04 - hardware version 04


KM2774-0000 - Introduction

BECKHOFF KM2774-0000: Product overview

Introduction

The KM2774-0000 terminal module is used for controlling up to four motors for blinds and for connecting the associated push buttons.

Each of the 4 channels has three mutually interlocked triac outputs (230 V), three digital inputs (24 V) and one negatively switching output (24 V, 20 mA) for the connection, for instance of a pushbutton LED. The outputs are protected against overload. An adjustable overcurrent limit protects the motor from damage.

LEDs indicate the status is of the digital inputs and of the triac outputs. There are also LEDs indicating the flow of data traffic on the K-Bus (RUN), for indicating overtemperature (Error) in the terminal module, and for the presence of the supply voltages (24 VDC, 230 VAC).

The triac outputs, the LED outputs and the status LEDs are not driven if the power supply voltage (230 V) is not present, or if the temperature is too high.


KM2774-0000 - Technical data

BECKHOFF KM2774-0000: Product overview

Technical data

Technical data | KM2774-0000
Number of power outputs | 12 (3 per channel)
Rated voltage of the power outputs | 80 ... 230 VAC
Over-voltage protection at the power outputs | > 275 V
Output current from the power outputs | 1,5 A (0.6 mA idling current)
Surge current | 40 A (16 ms), 3 A (30s)
Overcurrent limit | adjustable
Switch-on time | 0,1 ... 10 ms, zero crossing
Switch-off time | T/2
Residual voltage | maximum 1.5 V (60 mA 1 A, 150 O (< 60 mA)
Number of digital outputs | 4 (1 per channel), switching to ground
Nominal voltage | 24 VDC
Output current | maximum 20 mA, short-circuit proof
"0" signal voltage | -3 V ... 5 V
"1" signal voltage | -15 V ... 30 V
Number of digital inputs | 12 (4 x 3)
Nominal voltage | 24 VDC (-15%/+20%)
"0" signal voltage | -3 V ... 5 V (IEC 61132-2, type 1)
"1" signal voltage | -15 V ... 30 V (IEC 61132-2, type 1)
Input filter | 3,0 ms
Input current | typically 3 mA (IEC 61132-2, type 1)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 30 mA
Electrical isolation | 500 Veff (K-Bus/field potential), 3750 VAC (1 minute)
Bit width in the input process image | 24 bit
Dimensions with terminals (W x H x D) | approx. 135mm x 100 mm x 40mm (aligned width: 132mm), see dimensional drawing
Weight | approx. 270 g
Permissible ambient temperature during operation | 0°C... + 55°C
Permissible ambient temperature during storage | -25°C... + 85°C
Permissible relative humidity | 95%, no condensation
Permissible contamination level | 1
Assembly | on 35 mm mounting rail according to EN 50022
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation pos. | variable
Approval | CE


Terminal Modules - Mounting and Demounting

BECKHOFF Terminal Modules: Mounting and Wiring

Mounting and demounting

The terminal modules are fastened to the assembly surface with the aid of a 35 mm mounting rail (e.g. DIN rail TH 35-7.5 according to EN 60715a).

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Mounting
  • Fit the mounting rail to the planned assembly location.

    and press (1) the terminal module against the mounting rail until it latches in place on the mounting rail (2).
  • Attach the cables.
Demounting
  • Remove all the cables. Thanks to the KM/EM connector, it is not necessary to remove all the cables separately for this, but for each KM/EM connector simply undo 2 screws so that you can pull them off (fixed wiring)!
  • Lever the unlatching hook on the left-hand side of the terminal module upwards with a screwdriver (3). As you do this
    • an internal mechanism pulls the two latching lugs (3a) from the top hat rail back into the terminal module,
    • the unlatching hook moves forwards (3b) and engages

  • In the case 32 and 64 channel terminal modules (KMxxx4 and KMxxx8 or EMxxx4 and EMxxx8) you now lever the second unlatching hook on the right-hand side of the terminal module upwards in the same way.
  • Pull (5) the terminal module away from the mounting surface.


Terminal Modules - Recommended mounting rails

BECKHOFF Terminal Modules: Mounting and wiring

Recommended mounting rails

Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series can be snapped onto the following recommended mounting rails:

  • DIN Rail TH 35-7.5 with 1 mm material thickness (according to EN 60715)
  • DIN Rail TH 35-15 with 1,5 mm material thickness

Note 		Pay attention to the material thickness of the DIN Rail
Terminal Modules und EtherCAT Modules of KMxxxx and EMxxxx series, same as the terminals of the EL66xx and EL67xx series does not fit to the DIN Rail TH 35-15 with 2,2 to 2,5 mm material thickness (according to EN 60715)!


KM2774 - Wiring

BECKHOFF KM2774: Monting and Wiring

Wiring

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Connection of power supply (24 V)

CAUTION 		Earth the 0 V potentials of the 24 V power supply!
Connect
  • the 0 V potential of power supply (Us) for the Bus Coupler that controls the KM2774-1001 and
  • the 0 V potential of power supply for KM2774-1001 (X0, terminal point 3, 4 or 5)

to protection earth!

terminal strip | terminal point | indication | function
X0: 24V | 0 | 24 V | feeding 24 V for module electronic
 | 1 | 24 V | feeding 24 V for module electronic
 | 2 | 0 V | feeding 0 V for module electronic
 | 3 | 0 V | feeding 0 V for module electronic
 | 4 | 0 V | feeding 0 V for module electronic

Connection of buttons for channel 1 to 4

terminal strip | terminal point | indication | function
X1: Ch1 | 0 | 24 V | channel 1: 24 V for Taster
 | 1 | IN1 | channel 1: input for Taster 1
 | 2 | IN2 | channel 1: input for Taster 2
 | 3 | IN3 | channel 1: input for Taster 3
 | 4 | LED | channel 1: switched ground for button LED
X2: Ch2 | 0 | 24 V | channel 2: 24 V for Taster
 | 1 | IN1 | channel 2: input for Taster 1
 | 2 | IN2 | channel 2: input for Taster 2
 | 3 | IN3 | channel 2: input for Taster 3
 | 4 | LED | channel 2: switched ground for button LED
X3: Ch3 | 0 | 24 V | channel 3: 24 V for Taster
 | 1 | IN1 | channel 3: input for Taster 1
 | 2 | IN2 | channel 3: input for Taster 2
 | 3 | IN3 | channel 3: input for Taster 3
 | 4 | LED | channel 3: switched ground for button LED
X4: Ch4 | 0 | 24 V | channel 4: 24 V for Taster
 | 1 | IN1 | channel 4: input for Taster 1
 | 2 | IN2 | channel 4: input for Taster 2
 | 3 | IN3 | channel 4: input for Taster 3
 | 4 | LED | channel 4: switched ground for button LED

Connection motors for channel 1 to 4

terminal strip | terminal point | indication | function
X11: Ch1 | 0 | L1 | channel 1: phase L1 for motor 1
 | 1 | L2 | channel 1: phase L2 for motor 1
 | 2 | L3 | channel 1: phase L3 for motor 1
 | 3 | N | channel 1: neutral conductor for motor 1 (internally connected with the neutral terminal points of the other channels)
 | 4 | PE | channel 1: protection earth for motor 1
X12: Ch2 | 0 | L1 | channel 2: phase L1 for motor 2
 | 1 | L2 | channel 2: phase L2 for motor 2
 | 2 | L3 | channel 2: phase L3 for motor 2
 | 3 | N | channel 2: neutral conductor for motor 2 (internally connected with the neutral terminal points of the other channels)
 | 4 | PE | channel 2: protection earth for motor 2
X13: Ch3 | 0 | L1 | channel 3: phase L1 for motor 3
 | 1 | L2 | channel 3: phase L2 for motor 3
 | 2 | L3 | channel 3: phase L3 for motor 3
 | 3 | N | channel 3: neutral conductor for motor 3 (internally connected with the neutral terminal points of the other channels)
 | 4 | PE | channel 3: protection earth for motor 3
X14: Ch4 | 0 | L1 | channel 4: phase L1 for motor 4
 | 1 | L2 | channel 4: phase L2 for motor 4
 | 2 | L3 | channel 4: phase L3 for motor 4
 | 3 | N | channel 4: neutral conductor for motor 4 (internally connected with the neutral terminal points of the other channels)
 | 4 | PE | channel 4: protection earth for motor 4

Connection of power supply (230 V)

terminal strip | terminal point | indication | function
X10: 230V | 0 | L | feeding of load voltage (230 V)
 | 1 | L | forwarding of load voltage (230 V)
 | 2 | N | feeding of load voltage (0 V)
 | 3 | N | forwarding of load voltage (0 V)
 | 4 | PE | protection earth
 | 4 | PE | protection earth


KM2774 - Dimensions

BECKHOFF KM2774: Mounting and Wiring

Dimensions


KS2000 Configuration Software

The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler/Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.

Configuration

You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.

Parameterization

KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.

Commissioning

The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.

The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.

  • Thus, the coupler's input and output images can be observed by monitoring.
  • Process values can be specified in the output image for commissioning of the output modules.

All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


KM2774-0000 - Parametrizing with KS2000

BECKHOFF KM2774-0000: KS2000 Configuration Software

Parameterizing with KS2000

Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.

Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
  • a BK9000 Bus Coupler for Ethernet
  • a KL1xx2 Digital Input Terminal
  • a KM2774-0000 Terminal Module for blind motors
  • a KL9010 Bus End Terminal

The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.

In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).

For the KM2774-1001, the branches Register, Settings and ProcData are displayed:

  • Register permits direct access to the registers of the KM2774-0000.
  • Under Settings you find dialog boxes for parameterizing the KM2774-1001.
  • ProcData displays the KM2774-0000 process data.


KM2774-0000 - KS2000 settings

BECKHOFF KM2774-0000: KS2000 Configuration Software

Settings

A dialog mask for the parameterization KM2774-0000 can be found under Settings.

Current Limit

Channel 1 (R34)

You can specify the current limit for channel 1 here (default: 1500 mA).
Permissible value range: 50 to 1500 mA

Channel 2 (R35)

You can specify the current limit for channel 2 here (default: 1500 mA).
Permissible value range: 50 to 1500 mA

Channel 3 (R36)

You can specify the current limit for channel 3 here (default: 1500 mA).
Permissible value range: 50 to 1500 mA

Channel 4 (R37)

You can specify the current limit for channel 4 here (default: 1500 mA).
Permissible value range: 50 to 1500 mA

Reaction Time

Channel 1 (R38)

You can specify the reaction time until overcurrent cutoff for channel 1 here (default: 400 ms).
Permissible value range: 10 to 2560 ms in steps of 10 ms.
If you enter 0 ms the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

Channel 2 (R39)

You can specify the reaction time until overcurrent cutoff for channel 2 here (default: 400 ms).
Permissible value range: 100 to 2560 ms in steps of 10 ms.
If you enter 0 ms the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

Channel 3 (R40)

You can specify the reaction time until overcurrent cutoff for channel 3 here (default: 400 ms).
Permissible value range: 100 to 2560 ms in steps of 10 ms.
If you enter 0 ms the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

Channel 4 (R41)

You can specify the reaction time until overcurrent cutoff for channel 4 here (default: 400 ms).
Permissible value range: 100 to 2560 ms in steps of 10 ms.
If you enter 0 ms the reaction time is switched off. The output switches off immediately if the current runs over the current limit.


KM2774 - Process image

BECKHOFF KM2774: Access from the user program

Process image

The terminal module KM2774 is shown at the process image with 2 or 3 byte input and 2 or 3 byte output data. These are divided as follows:

format | input data | output data
byte | SB | CB
word | DataIN | DataOUT

*) Word alignment: The Bus Coupler places values on even byte addresses

Key

SB: status byte (not applicable at compact evaluation)
CB: control byte (not applicable at compact evaluation)

DataIN: input process data
DataOUT: output process data

  • The mapping of the bytes and words to the addresses of the controlling system can be found on the mapping page.
  • The meaning of control und status bytes can be found on the page control and status byte.
  • The description of the process data words can be found on the pages input process data (DataIN) and output process data (DataOUT).


KM2774 - Mapping

BECKHOFF KM2774: Access from the user program

Mapping

The KM2774 terminal module occupies input and output addresses in the controller's process image. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:

  • the fieldbus system used

  • the terminal type

  • the parameterization of the bus coupler (conditions) such as
    - compact or complex evaluation
    - Intel or Motorola format
    - word alignment switched on or off

The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).

The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.

Compact evaluation

Under compact evaluation, the KM2774 occupies addresses in the input and output process image. Control and status bytes cannot be accessed.

Compact evaluation in Intel format

Default mapping for CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: no Motorola format: no Word alignment: don't care | 0 | D1 | D0 | D1 | D0

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus coupler

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: no Motorola format: yes Word alignment: don't care | 0 | D0 | D1 | D0 | D1

Complex evaluation

Under compact evaluation, the KM2774 occupies addresses in the input and output process image. Control and status bytes can be accessed.

Complex evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: no | 0 | D0 | SB | D0 | CB
 | 1 | - | D1 | - | D1

Complex evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: no | 0 | D1 | SB | D1 | CB
 | 1 | - | D0 | - | D0

Complex evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and EtherCAT couplers (BK1120) and for Bus Terminal Controllers (BCxxxx, BXxxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D1 | D0 | D1 | D0

Complex evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D0 | D1 | D0 | D1
Key

Complex evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the channel address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.

SB status byte (appears in the input process image)
CB: Control byte (appears in the output process image)

D0: low-order byte of the data word
D1: high-order byte of the data word

reserved: This byte occupies process data memory, although it has no function.
"-": This byte is not assigned or used by the module.


KM2774 - Control- and Status-Byte

BECKHOFF KM2774: Access from the user program

Control and status byte

Process data mode

Control byte (for process data mode)

The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
Name | RegAccess | Reset | - | - | - | - | - | -
Legend
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | Reset | 1bin | All errors that may have occurred are reset by setting this bit (rising edge)
CB.5 to CB.3 | - | 000bin | reserved
CB.2 to CB.0 | - | 000bin | reserved

Status byte (for process data mode)

The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | - | OverTemp | Err230V | Err24V
Legend
Bit | Name | Description
SB.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB.6 | Error | 0bin | No error
 |  | 1bin | An error has occurred:
SB.5 to SB.3 | - | 000bin | reserved
SB.2 | OverTemp | 1bin | The internal temperature of the terminal is above 80°C
SB.1 | Err230V | 1bin | The 230 V power supply voltage is not present
SB.0 | Err24V | 1bin | The 24 V power supply voltage is not present

Register communication

Control byte (for register communication)

The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.3 | CB.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.

Status byte (for register communication)

The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgement for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


KM2774 - Prozesseingangsdaten (DataIN)

BECKHOFF KM2774: Access from the user programm

Process input data (DataIN)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Channel | Ch4 |  |  |  | Ch3 |  |  |  | Ch2 |  |  |  | Ch1
Name | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1 | curr | IN3 | IN2 | IN1
Key
Bit | Channel/Name | Description
15 | Ch4 curr | 0bin | current is lower than threshold specified for channel 4
 |  | 1bin | current is bigger than threshold specified for channel 4
14 | Ch4 IN3 | Channel 4, input 3
13 | Ch4 IN2 | Channel 4, input 2
12 | Ch4 IN1 | Channel 4, input 1
11 | Ch3 curr | 0bin | current is lower than threshold specified for channel 3
 |  | 1bin | current is bigger than threshold specified for channel 3
10 | Ch3 IN3 | Channel 3, input 3
9 | Ch3 IN2 | Channel 3, input 2
8 | Ch3 IN1 | Channel 3, input 1
7 | Ch2 curr | 0bin | current is lower than threshold specified for channel 2
 |  | 1bin | current is bigger than threshold specified for channel 2
6 | Ch2 IN3 | Channel 2, input 3
5 | Ch2 IN2 | Channel 2, input 2
4 | Ch2 IN1 | Channel 2, input 1
3 | Ch1 curr | 0bin | current is lower than threshold specified for channel 1
 |  | 1bin | current is bigger than threshold specified for channel 1
2 | Ch1 IN3 | Channel 1, input 3
1 | Ch1 IN2 | Channel 1, input 2
0 | Ch1 IN1 | Channel 1, input 1


KM2774 - Process output data (DataOUT)

BECKHOFF KM2774: Access from the user programm

Process output data (DataOUT)

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Channel | Ch4 |  |  |  | Ch3 |  |  |  | Ch2 |  |  |  | Ch1
Name | LED | L3 | L2 | L1 | LED | L3 | L2 | L1 | LED | L3 | L2 | L1 | LED | L3 | L2 | L1
Key
Bit | Channel/Name | Description
15 | Ch4 LED | 0bin | Ground for button LED is not switched
 |  | 1bin | Ground for button LED is switched
14 | Ch4 L3 | Channel 4, output L3
13 | Ch4 L2 | Channel 4, output L2
12 | Ch4 L1 | Channel 4, output L1
11 | Ch3 LED | 0bin | Ground for button LED is not switched
 |  | 1bin | Ground for button LED is switched
10 | Ch3 L3 | Channel 3, output L3
9 | Ch3 L2 | Channel 3, output L2
8 | Ch3 L1 | Channel 3, output L1
7 | Ch2 LED | 0bin | Ground for button LED is not switched
 |  | 1bin | Ground for button LED is switched
6 | Ch2 L3 | Channel 2, output L3
5 | Ch2 L2 | Channel 2, output L2
4 | Ch2 L1 | Channel 2, output L1
3 | Ch1 LED | 0bin | Ground for button LED is not switched
 |  | 1bin | Ground for button LED is switched
2 | Ch1 L3 | Channel 1, output L3
1 | Ch1 L2 | Channel 1, output L2
0 | Ch1 L1 | Channel 1, output L1


KM2774-0000 - Register overview

BECKHOFF KM2774-0000: Access from the user programm

Register overview

These registers are used for the parameterization of the terminal module. They can be read or written by means of register communication.

Register No. | Comment | Default value |  | R/W | Memory
R0 | Channel 1, analog value | - | - | R | RAM
R1 | Channel 2, analog value | - | - | R | RAM
R2 | Channel 3, analog value | - | - | R | RAM
R3 | Channel 4, analog value | - | - | R | RAM
R4 | reserved | 0x001A | 26dec | R | RAM
R5 | reserved | - | - | R | RAM
R6 | reserved | 0x0000 | 0dec | R/W | RAM
R7 | Commando register (without functionality) | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x0AD6 | 2774dec | R | ROM
R9 | Firmware-Stand | e.g. 0x3144 | e.g. 1DASCII | R | ROM
R10 | Multiplex shift register | 0x0118 | 280dec | R | ROM
R11 | Signal channels | 0x0118 | 280dec | R | ROM
R12 | minimum data length | 0x9898 | 39064dec | R | ROM
R13 | Data structure | 0x0004 | 4dez | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | 0x7F80 | 32640 | R/W | RAM
R16 | Hardware revision number | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R28 | reserved | - | - | - | -
R29 | Terminal type - special identifier | 0x0000 | 0000 | R | EEPROM
R30 | reserved | - | - | - | -
R31 | Codeword register | 0x0000 | 0dec | R/W | RAM
R32 | reserved | 0x0000 | 0dec | R/W | RAM
R33 | Minimum current limit | 0x005 | 5dec | R/W | RAM
R34 | Channel 1, current limit | 0x0096 | 150dec | R/W | RAM
R35 | Channel 2, current limit | 0x0096 | 150dec | R/W | RAM
R36 | Channel 3 current limit | 0x0096 | 150dec | R/W | RAM
R37 | Channel 4, current limit | 0x0096 | 150dec | R/W | RAM
R38 | Channel 1, reaction time | 0x0004 | 4dec | R/W | RAM
R39 | Channel 2, reaction time | 0x0004 | 4dec | R/W | RAM
R40 | Channel 3, reaction time | 0x0004 | 4dec | R/W | RAM
R41 | Channel 4, reaction time | 0x0004 | 4dec | R/W | RAM
R42 | reserved | 0x0000 | 0dec | R/W | RAM
... | ... | ... | ... | ... | ...
R63 | reserved | 0x0000 | 0dec | R/W | RAM


KM2774-0000 - Register description

BECKHOFF KM2774-0000: Access from the user program

Register description

These registers are used to parameterize the terminal module. They can be read or written by means of register communication.

R0: Analog value of Channel 1

Contains the current analog value for Channel 1.

R1: Analog value of Channel 2

Contains the current analog value for Channel 2.

R2: Analog value of Channel 3

Contains the current analog value for Channel 3.

R3: Analog value of Channel 4

Contains the current analog value for Channel 4.

R7: Command register

The command register in the KM2774-0000 has no function.

R8: Terminal type

The terminal identifier is contained in register R8: 0x0AD6 (2774dec)

R9: Firmware revision level

Register R9 contains the ASCII coding of the terminal's firmware revision level, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.

R16: Hardware version number

Register R16 contains the hardware version of the terminal.

R29: Terminal type - special identification

The terminal special identification is contained in register R29: 0x0000 (0dec)

R31: Code word register

  • If you write into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
  • If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are written into the RAM registers and in the EEPROM registers and are therefore retained if the terminal is restarted.

The code word is reset if the terminal is restarted.

R34: Channel 1, current limit

You can specify the current limit for channel 1 here (default: 150dec).
Scaling: 150dec is equal to 1500 mA.
Permissible value range: 5 to 150dec

R35: Channel 2, current limit

You can specify the current limit for channel 2 here (default: 150decA).
Scaling: 150dec is equal to 1500 mA.
Permissible value range: 5 to 150dec

R36: Channel 3, current limit

You can specify the current limit for channel 3 here (default: 150dec).
Scaling: 150dec is equal to 1500 mA.
Permissible value range: 5 to 150dec

R37: Channel 4, current limit

You can specify the current limit for channel 4 here (default: 150dec).
Scaling: 150dec is equal to 1500 mA.
Permissible value range: 5 to 150dec

R38: Channel 1, reaction time

You can specify the reaction time until overcurrent cutoff for channel 1 here (default: 40dec).
Scaling: 40dec is equal to 400 ms.
Permissible value range: 10 to 256dec
If you enter 0 the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

R39: Channel 2, reaction time

You can specify the reaction time until overcurrent cutoff for channel 1 here (default: 40dec).
Scaling: 40dec is equal to 400 ms.
Permissible value range: 10 to 256dec
If you enter 0 the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

R40: Channel 3, reaction time

You can specify the reaction time until overcurrent cutoff for channel 1 here (default: 40dec).
Scaling: 40dec is equal to 400 ms.
Permissible value range: 10 to 256dec
If you enter 0 the reaction time is switched off. The output switches off immediately if the current runs over the current limit.

R41: Channel 4, reaction time

You can specify the reaction time until overcurrent cutoff for channel 1 here (default: 40dec).
Scaling: 40dec is equal to 400 ms.
Permissible value range: 10 to 256dec
If you enter 0 the reaction time is switched off. The output switches off immediately if the current runs over the current limit.


Examples of Register Communication

In the examples, the numbering of the bytes is according to the description without Word-Alignment.

Example 1: Reading the Firmware Issue Status from Register 9 of a Terminal

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 00 1001bin the register number 9.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access. If you want to change a register, you have to write the desired value into the output data word.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the Firmware Issue Status 0x3341 in ASCII code, in the input data word (Byte 1 and Byte 2). This has to be interpreted as ASCII code:
    - ASCII code 0x33 stands for the cipher 3
    - ASCII code 0x41 stands for the letter A
    Therefore the firmware version is 3A.

Example 2: Writing to an user register

NOTE 		Code word
At normal operation all user registers other than register 31are write protected.
In order to deactivate write protection, you have to write the password (0x1235) into register 31. Write protection is activated again by writing any value other than 0x1235
Note that some of the settings that can be made in registers only become active after the next power restart (power-off/power-on) of the terminal.

I. Writing the code word (0x1235) to Register 31

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35

Explanation:

  • Bit 0.7 set indicates: register communication active.
  • Bit 0.6 set indicates: writing to the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 and Byte 2) contains the code word 0x1235) to deactivate the write protection.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!

II. Reading Register 31 (verifying the set code word)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the current value of the code word register in the input data word (Byte 1 and Byte 2).

III. Writing into Register 32 (changing the content of the feature register)

Output Data
Byte 0: Control Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 set indicates: writing to the register
  • Bit 0.5 to Bit 0.0 indicates with 10 0000bin the register number 32.
  • The output data word (Byte 1 and Byte 2) contains the new value for the feature register.

    CAUTION     		Pay attention to the register description!
    The given value 0x0002 is only an example!
    The bits of the feature register change the properties of the terminal und and have different meanings, depending on the terminal type. Please check the description of the feature register of your terminal type (chapter register description) about the meanings of the bits in detail, before changing the values!
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!

IV. Reading Register 32 (verifying the changed feature register)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 not set indicates reading the register.
  • Bit 0.5 to Bit 0.0 indicates with 10 0000bin the register number 32.
  • The output data word (Byte 1 and Byte 2) has no function at the reading access.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02

Explanation:

  • The terminal returns the value of the Control Byte in the Status Byte, as an acknowledgement.
  • The terminal returns the current value of the feature register in the input data word (Byte 1 and Byte 2).

V. Writing to Register 31 (setting the code word back)

Output Data
Byte 0: Control Byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00

Explanation:

  • Bit 0.7 set indicates register communication active.
  • Bit 0.6 set indicates: writing to the register.
  • Bit 0.5 to Bit 0.0 indicates with 01 1111bin the register number 31.
  • The output data word (Byte 1 und Byte 2) contains 0x0000 to activate the write protection again.
Input Data (answer of the bus terminal)
Byte 0: Status Byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX

Explanation:

  • In the Status Byte, the terminal returns a value, that differs only at bit 0.6 from the value of the of the Control Byte.
  • The input data word (Byte 1 and Byte 2) has no function after the writing access. Values that might be shown are not valid!


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com