KL8001 - Power terminal
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
▪
Chapter Mounting rail installation revised
▪
Structural update
1.2.0
▪
Introduction and annex updated
▪
Ordering information updated
▪
Technical data updated
▪
Description of feature register updated
▪
Description of command register added
▪
Parameter registers PR33, PR40, PR46: resolution corrected
▪
Description of the Data registers corrected
1.1
▪
Technical data updated
▪
Description of the parameter registers extended
1.0
▪
Description of the parameter registers updated
▪
English version available
0.3
▪
Product overview revised
▪
Description of control and status byte revised
▪
Register description revised
▪
Ordering information extended
0.2
▪
Functional description revised
▪
Technical data updated
▪
Information about mounting and wiring added
▪
Application examples added
▪
Description of parameterization with KS2000 software added
▪
Description of the process image revised
▪
Register description amended
▪
Ordering information added
0.1
▪
First preliminary version
Firmware and hardware versions
Documentation Version | KL8001 |  |  |  | KL9060
 | Measuring PCB |  | K-bus PCB |  | Firmware | Hardware
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | 5 (=3C) | 5 | 7 (=3D) | 4 | 00 | 02
1.2.0 | 5 (=3C) | 4 | 6 (=3C) | 1 | 00 | 01
1.1 | 2 (=2A) | 3 | 3 (=1C) | 0 | 00 | 00
1.0 | 1 (=1B) | 1 | 1 (=1B) | 0 | 00 | 00
0.3 |  |  |  |  | 00 | 00
0.2 |  |  |  |  | 00 | 00
0.1 |  |  |  |  | 00 | 00
▪
The firmware and hardware versions (delivery state) of the KL9060 can be found in the serial number printed at the side of the terminal.
▪
The firmware version of the measuring PCB of the KL8001 can be read from data register DR37.
▪
The firmware version of the K-bus PCB of the KL8001 is shown in the header of the KS2000 Settings dialog for KL8001
▪
The hardware version of the measuring and K-bus PCB of the KL8001 is coded in the serial number of the KL8001.
Syntax of the serial number for KL9060
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. No.: 02 06 00 01:
02 - week of production 02
06 - year of production 2006
00 - firmware version 00
01 - hardware version 01
Syntax of the serial number for KL8001
Structure of the serial number: KK YY FH fh
KK - week of production (CW, calendar week)
YY - year of production
FH - firmware version (F) and hardware version (H) of the measuring PCB (coded)
f h - firmware version (f) and hardware version (h) of the K-bus PCB (coded)
Example with ser. No.: 02 06 54 61:
02 - week of production 02
06 - year of production 2006
54 - measuring PCB: firmware version 5 (=3C), hardware version 4
61 - K-bus PCB: firmware version 6 (=3C), hardware version 1


Product Overview

Product Overview
Product Overview
Additional information
•
KL8001 Power terminal - Introduction
•
KL8001 Power terminal - Functional description
•
Power terminal KL8001 - Technical data
•
KL9060 Adapter terminal - Introduction
•
Adapter terminal KL9060 - Technical data


KL8001 Power terminal - Introduction

Product Overview [image] KL8001 Power terminal - Introduction
KL8001 Power terminal - Introduction
The KL8001 power terminal is specially constructed for Siemens contactors from the Sirius 3RT10 series, size S00. It is fitted to the contactor in the same way as a standard motor protection relay. The power terminal switches the installed contactor and takes over all the functions of the motor protection relay. Apart from its purely protective function of switching off the motor when overloaded, the power terminal can carry out numerous diagnostic functions on the motor and make the diagnostic data available to the controller via the fieldbus.
KL8001
Name | Description
K-Bus In | Pin contact strip for the incoming K-bus.
K-Bus Out | Pin contact strip for the outgoing K-bus. Insert the bus end plug here, included with the KL9060, in the last power terminal of your bus terminal block.
L1, L2, L3 | Connection terminals for the load circuit from the mains.
L1', L2', L3' | Connection pins for the load circuit to the contactor.
13, 13' | Connections for feeding through the auxiliary contact.
Out1 | Connection pin for the contactor's operating coil (right motion in reversing contactor connection)
Out2 | Connection terminal for the contactor's operating coil (left motion in reversing contactor connection)
1A | Rotary switch for manual adjustment of the rated current (resolution 1 A)
0.1A | Rotary switch for manual adjustment of the rated current (resolution 0.1 A)
on (motor) | LED for motor diagnostics: indicates whether the motor is switched on
overload (motor) | LED for motor diagnostics: indicates motor overload
run (fieldbus) | LED for K-bus diagnostics: indicates that data is being transferred on the K-bus
stop (fieldbus) | LED for K-bus diagnostics: indicates that data transmission on the K-bus has been interrupted
Lugs | Lugs for mounting the KL8001 on Siemens contactors


KL8001 Power terminal - Functional description

Product Overview [image] KL8001 Power terminal - Functional description
KL8001 Power terminal - Functional description
Rotary switches for adjusting the rated current
You can set the motor's rated current manually using the two rotary switches on the power terminal. The upper rotary switch operates in 1 A steps, while the lower switch provides 0.1 A steps. You can thus set values between 0.9 A and 9.9 A. The value set then applies to all three phases.
If you set the two rotary switches to zero, you must specify the rated motor current using the three parameter registers PR33, PR39 and PR45. You can then:
▪
set the rated current separately for each phase, if three different single-phase motors are connected, for example.
▪
use the extended setting range of 10.0 A to 15.0 A, which cannot be set via the rotary switches.
KL8001 - rotary switch for setting the rated current
LEDs
KL8001 - LEDs
The power terminal has 4 LEDs for status display to enable rapid diagnosis. The possible states are listed in the following table.
LED | State | Description
on (motor) | on | Motor is running, either to the right or left
 | off | Motor is switched off, or overload protection has triggered
overload (motor) | on | Motor has been switched off due to overload
 | flashes (2 Hz) | Power has fallen below minimum load threshold
 | flashes (5 Hz) | Overload threshold has been exceeded
 | off | Nominal operation (load neither below minimum and or above maximum), or motor is switched off
run (fieldbus) | on | Communication with the terminal bus is taking place without errors
 | off | No communication with the terminal bus (watchdog timer has triggered after 100 ms)
stop (fieldbus) | on | No communication with the terminal bus
 | flashes | Error code and error argument are indicated as flashing code
 | off | Communication with the terminal bus is taking place without errors
Flashing Code
If there is a fieldbus error, the stop LED indicates a flashing code that describes the fault more accurately:
The LED flickers for about 2 seconds before starting the error output. After a clearly visible pause, the error code is indicated through slow flashing, and the error argument is then indicated after a further pause. The following table allows you to determine the error more precisely with the aid of these two items of information.
Code
Argument
Description
Solution
1
0
No rated current set: both the two rotary switches and
▪
the register PR33 are zero (single-phase analysis not active) or
▪
at least one of registers PR33, PR39 or PR45 is zero (single-phase analysis is active)
▪
Use the rotary switches to set a rated current, or
▪
enter values for the rated current in registers PR33, PR39 and PR45.
2
n
Communication with the nth ADC is faulty
Contact your supplier.
3
n
Communication with the nth Hall sensor is faulty
Note
Changing the terminal registers
➢
To ensure that the new values are applied to the measuring unit after the terminal registers have been changed, you have to perform:
.
a power-off reset (switch the terminal off and back on again) or
.
a software reset (via the command register)!


Power terminal KL8001 - Technical data

Product Overview [image] Power terminal KL8001 - Technical data
Power terminal KL8001 - Technical data
KL8001 | Power Terminal
Number of power terminals per Bus Coupler | 10 max. | If you operate two contactors with each power terminal (reversing contactor connection) then you may only use 5 power terminals with each Bus Coupler. Observe also the maximum current that your Bus Coupler can supply to the K-bus!
Number of contactors per Bus Coupler | 10 max.
Type of fastening and mechanical connection | Suitable for Siemens contactors of the Sirius 3RT10 series, size S00
Type of connection power path | Screw terminals for core cross-sections up to 2 x 2.5 mm2
Power path current loading (back-up fuse) | 25 A max.
Power path short-circuit strength | up to 5000 A
Power path internal resistance | < 1 mΩ
Setting range of rated current | via rotary switch: 0.9 A to 9.9 A
 | via KS2000 or parameter registers: 0.9 A to 15.0 A
Selectable tripping classes | CLASS 5, 10, 15, 20, 25, 30 selectable
Measured values | Current, voltage, effective power, cos j, energy consumption, switching cycles, operating hours
Measuring accuracy (at balanced load) | 0.15 Arms; 2 Vrms; 5 W; 1 kWh
Crosstalk between the channels at unbalanced load | up to 3% from the difference
Measuring voltage | 500 V
Type of K-bus connection | 2 x flat plug socket, 10 pin
K-bus current consumption (5 VDC) | typically 150 mA Observe the maximum current that your Bus Coupler can supply to the K-bus!
Contactor control voltage current consumption (24 VDC) | When contactor switched off: typically 7 mA
 | When contactor switched on: typically 7 mA + current in the contactor coil
Dielectric strength | 500 V (power contact/K-bus), 6000 V (mains supply/K-bus)
Behavior under short-circuit conditions | conforms to EN 60947-4-1 (assignment type 2)/VDE 102
Triggering tolerance | conforms to IEC 947, as well as UL and CSA
Configuration options | Automatic over the fieldbus using the KS2000 configuration software, manual (rated current)
Width in the process image | 96 bits I/O (see description of the process image)
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Weight | approx. 90 g
Dimensions (W x H x D) | approx. 45 mm x 69 mm x 74 mm
Mounting | With lugs and connecting pins to Siemens contactors of the 3RT1016 series
Installation position | variable (although you must observe the permitted installation positions of the contactors)
Protection class | IP20
Approvals | CE


KL9060 Adapter terminal - Introduction

Product Overview [image] KL9060 Adapter terminal - Introduction
KL9060 Adapter terminal - Introduction
The KL9060 Adapter Terminal is used to connect power terminals to the K-bus of the Beckhoff bus terminal system.
KL9060
Name | Description
K-bus Out | Pin contact strip for the outgoing K-bus. Plug the long ribbon cable (approx. 10 cm) in here to the first power terminal.
ZS1010-1610 | Insert the ZS1010-1610 bus end plug into the K-bus Out pin contact strip on the last power terminal.
2 and 6 | Terminals for the connection of the power contact's +24 V
3 and 7 | Terminals for the connection of the power contact's 0 V
4 and 8 | Terminals for the connection to the power contact's PE
+24 VP | Power contact for +24 V
0 VP | Power contact for 0 V
PEP | Power contact for PE


Adapter terminal KL9060 - Technical data

Product Overview [image] Adapter terminal KL9060 - Technical data
Adapter terminal KL9060 - Technical data
KL9060
Adapter terminal
Power contacts voltage (ribbon cable)
24 VDC (-15%, +20%)
Power contacts current loading (ribbon cable)
maximum 1400 mA (short-circuit proof).
Observe the current consumption of the power terminals and the contactor coils!
Voltage of the K-bus power supply (ribbon cable)
5 VDC
Current consumption of the K-bus power supply (ribbon cable)
maximum 2000 mA
Observe the maximum current that your Bus Coupler can supply to the K-bus! Examples:
▪
Low Cost Coupler: 500 mA
▪
Economy Coupler: 500 mA
▪
Economy Plus Coupler: 1750 mA
▪
Standard Coupler: 1750 mA
▪
KL9400 Power Supply Terminal: 2000 mA
Use the KL9400 Power Supply Terminal if the current consumption of your terminals exceeds the maximum current that your Bus Coupler can feed to the K-bus supply.
Number of power terminals per KL9060
10 max.
If you operate two contactors with each power terminal (reversing contactor connection) then you may only use 5 power terminals with each KL9060.
Observe also the maximum current that your Bus Coupler can supply to the K-bus!
Number of contactors per KL9060
10 max.
Permissible ambient temperature range during operation
0°C ... +55°C
Permissible ambient temperature range during storage
-25°C ... +85°C
Permissible relative air humidity
95 %, no condensation
Vibration / shock resistance
conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission
conforms to EN 61000-6-2 / EN 61000-6-4
Weight
approx. 50 g
Dimensions (W x H x D)
approx. 33 mm x 100 mm x 70 mm
Mounting
on 35 mm mounting rail conforms to EN 60715
Installation position
variable
Protection class
IP20
Approvals
CE


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Mounting the KL8001
•
Connection
•
Application examples


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Mounting the KL8001

Mounting and wiring [image] Mounting the KL8001
Mounting the KL8001
Preparation for mounting
1.
Undo all 5 screw terminals (1L1, 3L2, 5L3, 13NO, A1+) on the mains connection side of the Siemens contactor.
2.
Suspend the power terminal by inserting the two lugs into the two rectangular openings at the foot of the Siemens contactor.
3.
Push the power terminal's 5 contact pins into the 5 opened screw terminals on the mains connection side of the Siemens contactor until the power terminal is located flush with the Siemens contactor. The power terminal's two lugs must not be allowed to slip out of the rectangular holes at the foot of the Siemens contactor!
4.
Firmly tighten all 5 screw terminals on the mains side of the Siemens contactor. The power terminal must sit tightly, flush with the Siemens contactor!
Attention
Intended use
Only use the KL8001 Power Terminal in combination with Siemens contactors of the SIRIUS 3RT10 series, size S00, as listed in the ordering information!
Installing a Bus Terminal block with power terminals
When mounting, observe the information in the chapter entitled Mounting rail installation.
1.
Ensure that the system is powered down and in a safe state.
2.
Install the Bus Terminal block, consisting of the fieldbus coupler and any Bus Terminals that may be desired, on a mounting rail.
Fit a KL9060 Adapter Terminal as the last Bus Terminal at the end of the Bus Terminal block instead of a standard end terminal (KL9010).
3.
Clip the Siemens contactor, with the power terminal mounted on it, about 3 cm away on the mounting rail next to the KL9060 Adapter Terminal.
4.
Use the ribbon cable, about 10 cm long, included with the KL9060 Adapter Terminal, to join the power terminal to the KL9060.
5.
Connect the power terminal to the next power terminal, using the ribbon cable (approx. 3 cm long) supplied with the power terminal.
or
connect the terminal connector supplied with the KL9060 Adapter Terminal to the continuation plug connector of the last power terminal.
Up to 10 type KL8001 Power Terminals can be operated from one Bus Terminal block.


Connection

Mounting and wiring [image] Connection
Connection
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
The first power terminal is connected to the end of the Bus Terminal block with the KL9060 Adapter Terminal. The K-bus, and the contactor control voltage (24 V) are brought from the KL9060 to the first power terminal via a ribbon cable about 10 cm in length. Other power terminals are connected using a ribbon cable about 3 cm. Insert the ZS1010-1610 bus end plug included with the KL9060 into the last power terminal!
KL8001, KL9060 - Connection
Power is supplied to the KL8001 electronics via the K-bus (through the ribbon cable).
The (24 V) contactor control voltage that is to be switched by the power terminals is also passed along the ribbon cable, but is electrically isolated from the K-bus. You may simply join the ground connection for the contactor coils (A2-) with the free ground terminals (0 V, contacts 3 and 7) on the KL9060 Adapter Terminal.
Attention
Rated current inadmissibly exceeded
The KL9060 Adapter Terminal can supply up to 1.4 A rated current to power the contactor coils (24 VDC). Make sure that this rated current is not exceeded.


Application examples

Mounting and wiring [image] Application examples
Application examples
WARNING
Protection of the load circuit
Ensure that the load circuit can be fused with up to a maximum of 25 A per phase.
Motor control
The following figure illustrates control of a three-phase AC motor utilizing a KL8001 and a Siemens contactor. The power terminal's Out1 output controls the Siemens contactor.
Application example: Motor control
Reversing contactor connection
The following figure illustrates a reversing contactor connection utilizing a KL8001 and two Siemens contactors. The power terminal's Out1 and Out2 outputs alternately control the two Siemens contactors.
Application example: Reversing contactor connection
Note
Installation notes for reversing contactor connection
•
Use the Siemens kit for reversing combinations to facilitate installation of the power terminal in the reversing contactor connection directly at the contactor (see diagram below).
⇨
To do this, remove the connections for the auxiliary contacts and for A1 at the mains-side bridge of the Siemens kit by breaking these connections at the locations provided for the purpose (red line).
⇨
The connections for the auxiliary contact and for A1 are not required for a reversing contactor connection controlled by a KL8001, because the KL8001 interlocks the two contactors.
Siemens kit for reversing combination


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Settings


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 digital input terminal
▪
a KL9060 Adapter Terminal for connecting power terminals (which is not yet displayed by some versions of KS2000)
▪
a KL8001 Power Terminal for connecting Siemens contactors of the Sirius R3 series
▪
a ZS1010-1610 bus end plug (some versions of KS2000 still show the bus end plug as the KL9010 End Terminal)
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branches for channel 1 of the KL8001
Click on Settings. You can modify the power terminal settings in the configuration mask which is then displayed.
▪
Operation mode
▪
Fast shut off
▪
Register values


Settings

KS2000 Configuration Software [image] Settings
Settings
Header
Settings via KS2000 - Header
Pos. | Position of the terminal in the terminal block
Type | Terminal type
Channel | Channel whose parameters are displayed in the configuration screen
Firmware | Firmware version of the K-bus PCB
Configuration screen
In the Settings screen you can set of the behavior of the KL8001 Power Terminal.
Settings via KS2000 - Configuration screen
Operation mode
Setting the operation mode via KS2000
Select from the various operation modes here.
Right motion enabled (PR32.0) Default: enabled | Enable for motor rotation to the right. Allows the motor to start rotating to the right using bit 5 in the extended control byte.
Left motion enabled (PR32.1) Default: not enabled | Enable for motor rotation to the left. Allows the motor to start rotating to the left using bit 6 in the extended control byte.
Watchdog timer active (PR32.2) Default: active | Activates the watchdog. If the power terminal does not receive any data from the fieldbus for 100 ms, the watchdog switches the motor off and stops data transmission.
Single phase analysis (PR32.3) Default: not active | Activates analysis of the single phases. The phases are each compared with their associated register values, and analyzed individually. If you switch single phase analysis off, then the values entered for phase L1 applies to all three phases.
Read rotary switches permanently (PR32.5) Default: active | In normal operation, the rotary switches for setting the rated current are read continuously. The transfer of modified values does not require a reset.
Fast shut off
Select here the motor states for which fast shut off should be triggered after 500 ms.
Selecting the condition for fast shut off
Asymmetric load (PR32.8) Default: not active | Activates fast shut off if the difference between the currents in L1, L2 or L3 exceeds the maximum permissible current difference.
Phase error (PR32.9) Default: active | Activates fast shut off if a phase fails.
Overvoltage* (PR32.10) Default: not active | Activates fast shut off in the presence of overvoltage. | *) The voltages of the three phases are measured with reference to an artificial star point.
Undervoltage* (PR32.11) Default: not active | Activates fast shut off in the presence of undervoltage.
Overload (PR32.12) Default: not active | Activates fast shut off in the presence of overload.
Underload (PR32.13) Default: not active | Activates fast shut off in the presence of underload.
Registerdata
Enter the various threshold values here. The range of values for some of the input fields is restricted (e.g. the rated current must be between 0.0 and 25.0 A), and is automatically limited during input.
Setting the register values; example: phase L1
Rated current (PR33, PR39, PR45) Default: 0 A permitted setting range: 0.9 A to 15.0 A | Specification of the rated current for the L1, L2 and L3 phases. These values are only used when both the rotary switches on the front of the KL8001 for setting the rated current are set to zero. Otherwise the value set with the rotary switches applies to all three phases.
Switch-on threshold (PR34, PR40, PR46) Default: 0 | Specification of the switch-on threshold for the L1, L2 and L3 phases.
Overvoltage* (PR35, PR41, PR47) Default: 350 V | Specifying the threshold value for overvoltage for phases L1, L2 and L3. | *) The voltages of the three phases are measured with reference to an artificial star point.
Undervoltage* (PR36, PR42, PR48) Default: 150 V | Specifying the threshold value for undervoltage for phases L1, L2 and L3.
Overload (PR37, PR43, PR49) Default: 25 A | Specification of the overload thresholds for the L1, L2 and L3 phases.
Underload (PR38, PR44, PR50) Default: 0 A | Specification of the underload thresholds for the L1, L2 and L3 phases.
Setting the register values: max. current difference, tripping class, measuring cycle time
Max. current difference (PR51) Default 5 A | Specification of the maximum permitted current difference between the L1, L2 and L3 phases.
Tripping class (PR52) Default: 10 s | Specification of the tripping class.
Measuretime (PR53) Default: 50 ms | Specification of the measuring cycle time.


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Parameter registers (overview)
•
Data registers


Process image

Access from the user program [image] Process image
Process image
The power terminal is represented in the process image with 12 bytes of input and output data each. These are organized as follows:
Byte-Offset without Word-Alignment* | Byte-Offset with Word-Alignment* | Format | Input data | Output data
0 | 0 | Byte | Status-Byte 0 (SB0) | Control-Byte 0 (CB0)
1 | 2 | Word | DataIN0 | DataOUT0
3 | 4 | Byte | Status-Byte 1 (SB1) | Control-Byte 1 (CB1)
4 | 6 | Word | DataIN1 | DataOUT1
6 | 8 | Byte | Status-Byte 2 (SB2) | Control-Byte 2 (CB2)
7 | 10 | Word | DataIN2 | DataOUT2
9 | 12 | Byte | Extended Status-Byte (ESB) | Extended Control-Byte (ECB)
10 | 14 | Word | not used** | not used**
*) Word-Alignment: The Bus Coupler places values on even byte addresses
**) The process image is extended by an unused word in the input and output range, so that the power terminal appears like a four-channel analog terminal.
Additional information
•
Control and Status Bytes
•
Extended Control-Byte
•
Extended Status-Byte


Control and Status Bytes

Access from the user program [image] Process image [image] Control and Status Bytes
Control and Status Bytes
The control bytes 0 (CB0), 1 (CB1) and 2 (CB2) are in the output image and are transferred from the controller to the power terminal. Pay attention to the assignment of the control bytes to the process input data words in process data mode.
The status bytes 0 (SB0), 1 (SB1) and 2 (SB2) are in the input image and are transferred from the power terminal to the controller.
Since the structure and application of the control and status bytes are identical, they are described below using control byte 0 (CB0) and status byte 0 (SB0) as examples.
Additional information
•
Control and status byte 0 in process data mode
•
Control and status byte 0 for register communication


Control and status byte 0 in process data mode

Access from the user program [image] Process image [image] Control and Status Bytes [image] Control and status byte 0 in process data mode
Control and status byte 0 in process data mode
Control byte 0 in process data mode
Control byte 0 (CB0) is in the output image and is transferred from the controller to the power terminal.
Bit | CB0.7 | CB0.6 | CB0.5 | CB0.4 | CB0.3 | CB0.2 | CB0.1 | CB0.0
Name | RegAccess | R/W | DR no.
Key
Bit | Name | Description
CB0.7 | RegAccess | 0bin | Register communication off (process data mode)
CB0.6 | R/W | 0bin | Read access
 |  | (1bin) | Because the KL8001 data registers can only be read, write access is not useful.
CB0.5 to CB0.0 | DR no. | Data register number: Enter the number of the data register that you want to read with input data word 0 here.
Status byte 0 in process data mode
Status byte 0 (SB0) is located in the power terminal's input image, and is transmitted from the power terminal to the controller.
Bit | SB0.7 | SB0.6 | SB0.5 | SB0.4 | SB0.3 | SB0.2 | SB0.1 | SB0.0
Name | RegAccess | ES Error Info | DR no.
Key
Bit | Name | Description
SB0.7 | RegAccess | 0bin | Acknowledgement for process data access
SB0.6 | ES Error Info | 1bin | The lowest nibble (ES.3 to ES.0) in the extended status byte contains error information. Evaluate the extended status byte!
SB0.5 to SB0.0 | DR no. | The number of the data register that is to be read.


Control and status byte 0 for register communication

Access from the user program [image] Process image [image] Control and Status Bytes [image] Control and status byte 0 for register communication
Control and status byte 0 for register communication
Control byte 0 in register communication
Control byte 0 (CB0) is in the output image and is transferred from the controller to the power terminal.
Bit | CB0.7 | CB0.6 | CB0.5 | CB0.4 | CB0.3 | CB0.2 | CB0.1 | CB0.0
Name | RegAccess | R/W | PR no.
Key
Bit
Name
Description
CB0.7
RegAccess
1bin
Register communication switched on
CB0.6
R/W
0bin
Read access
1bin
Write access
CB0.5 to CB0.0
PR no.
Parameter register number:
Enter the number of the parameter register that you want to
▪
to read with input data word 0 or
▪
write to with output data word 0.
WARNING
Invalid process data during register communication!
It is not possible to access the data registers during register communication! Process data that may still be displayed is not valid!
Status byte 0 in register communication
Status byte 0 (SB0) is in the input image and is transferred from the power terminal to the controller.
Bit | SB0.7 | SB0.6 | SB0.5 | SB0.4 | SB0.3 | SB0.2 | SB0.1 | SB0.0
Name | RegAccess | R | PR no.
Key
Bit | Name | Description
SB0.7 | RegAccess | 1bin | Acknowledgment for register access
SB0.6 | R | 0bin | Read access
SB0.5 to SB0.0 | PR no. | The number of the parameter register that is to be read or written.


Extended Control-Byte

Access from the user program [image] Process image [image] Extended Control-Byte
Extended Control-Byte
The extended control byte (ECB) is transmitted in process data mode from the controller to the terminal, and controls a variety of functions within the power terminal.
Extended Control-Byte
Bit | ECB.7 | ECB.6 | ECB.5 | ECB.4 | ECB.3 | ECB.2 | ECB.1 | ECB.0
Name | - | Motor left motion | Motor right motion | - | - | - | - | Clear Imax
Key
Bit | Name | Value | Description
ECB.7 | - | 0bin | reserved
ECB.6 | Motor left motion* | 1bin | Switches the motor into rotation to left: The power terminal's output Out2 is set, in order so switch on the contactor connected through the Siemens kit for reversing combinations
ECB.5 | Motor right motion* | 1bin | Switches the motor into rotation to right: The power terminal's output Out1 is set, in order to switch on the contactor mounted directly on the power terminal.
ECB.4 to ECB.1 | - | 0bin | reserved
ECB.0 | Clear Imax | 1bin | The DR2 data registers are set to zero in all three register sets (they contain the peak values of the currents). Because locked-rotor currents of motors are much larger than the rated currents, the DR2 data registers indicate a high current each time a motor has started. In order to be able to detect any peak currents that might occur during nominal operation, you can set the DR2 data registers to zero at any time with this bit.
*) Notes:
▪
Rotation to the right or left must be enabled (with bits 0 and 1 respectively) in the feature register if it is to be possible to switch the motor to right-handed (bit 5) or left-handed (bit 6) rotation with the extended control byte.
▪
If the motor is running to the right (output Out1 is set), you must first switch this off (by resetting bit 5) before you can switch it to left-handed rotation with bit 6. If you set bit 6 while the motor is running to the right, the power terminal will switch the motor off.
▪
If the motor is running to the left (output Out2 is set), you must first switch this off (by resetting bit 6) before you can switch it to right-handed rotation with bit 5. If you set bit 5 while the motor is running to the left, the power terminal will switch the motor off.
▪
If you set bits 5 and 6 at the same time, the motor remains switched off.


Extended Status-Byte

Access from the user program [image] Process image [image] Extended Status-Byte
Extended Status-Byte
The extended status byte (ESB) contains information on the state of the KL8001, and is transmitted from the terminal to the controller in process data mode.
Extended Status-Byte
Bit | ESB.7 | ESB.6 | ESB.5 | ESB.4 | ESB.3 | ESB.2 | ESB.1 | ESB.0
Name | Rated operation | Motor Rotation to the left | Motor Rotation to the right | - | SW Error Info | Overload motor STOP | Underload | Overload
Key
Bit | Name | Value | Description
ESB.7 | Rated operation | 0bin | An overload or underload has occurred, or the motor has been switched off because of overloading.
 |  | 1bin | The power terminal is in nominal operation.
ESB.6 | Motor left motion | 1bin | The power terminal's Out2 output is set.
ESB.5 | Motor right motion | 1bin | The power terminal's Out1 output is set.
ESB.4 | - | 0bin | reserved
ESB.3 | SW error information | 1bin | The status word contains error information. Evaluate the status word!
ESB.2 | Overload motor STOP | 1bin | The power terminal has switched off the motor, because the current integral (data register DR7) has reached the maximum value. This bit will only be reset when the switch-on protection phase has elapsed, and the bits for motor control (ECB.5 and ECB.6) have been reset in the extended control byte.
ESB.1 | Underload | 1bin | The current in at least one of the phases has fallen below the specified underload threshold (parameter registers PR38, PR44, PR50).
ESB.0 | Overload | 1bin | The current in at least one of the phases has exceeded the specified overload threshold (parameter registers PR37, PR43, PR49).


Parameter registers (overview)

Access from the user program [image] Parameter registers (overview)
Parameter registers (overview)
These registers are used to parameterize the power terminal. They can be read or written by means of register communication.
Note
Transferring new values after a power-off reset
Carry out a power-off reset (switching the terminal off and then on again) each time the terminal registers are changed so that the new values are also adopted by the measurement unit!
PR no. | Comment | Default value |  | R/W | Memory
PR0 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
PR5 | reserved | - | - | - | -
PR6 | Diagnostic register | - | - | R | RAM
PR7 | Command register | 0x0000 | 0dec | - | -
PR8 | Terminal type | 0x1F41 | 8001dec | R | ROM
PR9 | Firmware version | e.g. 0x3141 | 12609dec | R | ROM
PR10 | Multiplex shift register | 0x0230 / 0x0418 | 560dec / 1048dec | R | ROM
PR11 | Signal channels | 0x0160 | 352dec | R | ROM
PR12 | Minimum data length | 0x6060 | 24672dec | R | ROM
PR13 | Data structure | 0x0007 | 7dec | R | ROM
PR14 | reserved | - | - | - | -
PR1 | Alignment register | - | - | R/W | RAM
PR16 | Hardware Version | e.g. 0x0000 | e.g. 0dec | R/W | Flash
PR17 | L1 voltage gain compensation | e.g. 0x0B00 | e.g. 2816dec | R/W | Flash
PR18 | L2 voltage gain compensation | e.g. 0x0B00 | e.g. 2816dec | R/W | Flash
PR19 | L3 voltage gain compensation | e.g. 0x0B00 | e.g. 2816dec | R/W | Flash
PR20 | L1 current gain compensation | e.g. 0x3000 | e.g. 12288dec | R/W | Flash
PR21 | L2 compensation gain current | e.g. 0x3000 | e.g. 12288dec | R/W | Flash
PR22 | L3 compensation gain current | e.g. 0x3000 | e.g. 12288dec | R/W | Flash
PR23 | Hall Sensor Sensitivity | 0x1FE3 | 8163dec | R/W | Flash
PR24 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
PR30 | reserved | - | - | - | -
PR31 | Code word register | - | - | R/W | RAM
PR32 | Feature-Register | 0x0221 | 545dec | R/W | Flash
PR33 | Rated current L1 | 0x0000 | 0dec | R/W | Flash
PR34 | Switch-on threshold L1 | 0x0000 | 0dec | R/W | Flash
PR35 | Overvoltage threshold L1 | 0x0DAC | 3500dec | R/W | Flash
PR36 | Undervoltage threshold L1 | 0x0096 | 150dec | R/W | Flash
PR37 | Overload threshold L1 | 0x09C4 | 2500dec | R/W | Flash
PR38 | Underload threshold L1 | 0x0000 | 0dec | R/W | Flash
PR39 | Rated current L2 | 0x0000 | 0dec | R/W | Flash
PR40 | Switch-on threshold L2 | 0x0000 | 0dec | R/W | Flash
PR41 | Overvoltage threshold L2 | 0x0DAC | 3500dec | R/W | Flash
PR42 | Undervoltage threshold L2 | 0x0096 | 150dec | R/W | Flash
PR43 | Overload threshold L2 | 0x09C4 | 2500dec | R/W | Flash
PR44 | Underload threshold L2 | 0x0000 | 0dec | R/W | Flash
PR45 | Rated current L3 | 0x0000 | 0dec | R/W | Flash
PR46 | Switch-on threshold L3 | 0x0000 | 0dec | R/W | Flash
PR47 | Overvoltage threshold L3 | 0x0DAC | 3500dec | R/W | Flash
PR48 | Undervoltage threshold L3 | 0x0096 | 150dec | R/W | Flash
PR49 | Overload threshold L3 | 0x09C4 | 2500dec | R/W | Flash
PR50 | Underload threshold L3 | 0x0000 | 0dec | R/W | Flash
PR51 | Maximum current difference | 0x01F4 | 500dec | R/W | Flash
PR52 | Tripping class | 0x000A | 10dec | R/W | Flash
PR53 | Measuring cycle time | 0x0032 | 50dec | R/W | Flash
PR54 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
PR63 | reserved | - | - | - | -
Additional information
•
Parameter registers (description)
•
Examples of Register Communication


Parameter registers (description)

Access from the user program [image] Parameter registers (overview) [image] Parameter registers (description)
Parameter registers (description)
These registers are used to parameterize the power terminal. They can be read or written by means of register communication.
PR7: Command register
In order to be able to call a command, you first have to enter the user codeword 0x1235 in register R31.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the delivery state for the following registers:
PR32: 545 (0x0221)
PR33: 0
PR34: 0
PR35: 3500
PR36: 150
PR37: 2500
PR38: 0
PR39: 0
PR40: 0
PR41: 3500
PR42: 150
PR43: 2500
PR44: 0
PR45: 0
PR46: 0
PR47: 3500
PR48: 150
PR49: 2500
PR50: 0
PR51: 500
PR52: 10
PR53: 50
Command 0x8000: Software reset
Entry 0x8000 in register R7 triggers a full software reset of the power terminal. All internal variables are cleared. The internal circuits (output driver) are reinitialized with a software reset.
WARNING
Risk of injury
During a software reset, the contactor connected to the power terminal is released. Ensure that your system state permits this and that hazards for persons or machinery have been ruled out!
PR8: Terminal description
Register PR8 contains the terminal identifier in hexadecimal coding: KL8001: 0x1F41 (8001dec)
PR9: Firmware version
Register PR9 contains the firmware version of the terminal in hexadecimal coding, e. g. 0x3141 (12609 dec).
PR17, PR18, PR19: Voltage gain compensation
These registers contain the compensation values determined at production, and cannot be changed.
PR20, PR21, PR22: Current gain compensation
These registers contain the compensation values determined at production, and cannot be changed.
PR23: Hall-Sensor sensitivity
The sensitivity of the Hall sensor is adjusted during production, and has a direct effect on the compensation values; it cannot be changed.
PR31: Code word register
▪
If you write values into the user registers without previously having entered the user code word (0x1235) in the code word register, these values are only stored in the RAM registers, but not in the EPROM registers and are therefore lost if the terminal is restarted.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the EPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
PR32: Feature-Register
A variety of KL8001 functions can be activated or enabled by means of the feature register.
Single phase analysis makes it possible to connect three single-phase motors to the power terminal. In this case, the current values for the detection of an overload are evaluated separately. This means that if an error state occurs in one of the three phases L1, L2, or L3, then the corresponding contactor is switched off.
Fast shut off is triggered after about 500 ms if one of the fast shut off functions has been activated and the corresponding error state occurs.
Bit | Name | Value | Description | Default
PR32.15 | - | 0bin | reserved | 0bin
PR32.14 | - | 0bin | reserved | 0bin
PR32.13 | enFsoUnderload | 1bin | Fast shut off in the event of underload is active | 0bin
PR32.12 | enFsoOverload | 1bin | Fast shut off in the event of overload is active | 0bin
PR32.11 | enFsoUndervoltage* | 1bin | Fast shut off in the event of undervoltage is active | 0bin
PR32.10 | enFsoOvervoltage* | 1bin | Fast shut off in the event of overvoltage is active | 0bin
PR32.9 | enFsoPhaseError | 1bin | Fast shut off in the event of a phase error is active | 1bin
PR32.8 | enFsoAsymmetricLoad | 1bin | Fast shut off if the load is asymmetric is active | 0bin
PR32.7 | - | 0bin | reserved | 0bin
PR32.6 | - | 0bin | reserved | 0bin
PR32.5 | enPermanent RotarySwitchEvaluation | 0bin | The rotary switches for the rated current are only read during a power reset. | 1bin
 |  | 1bin | The rotary switches for the rated current are continuously read during normal operation.
PR32.4 | enDcCurrentMeasurement | 1bin | DC current measurement is active: the upstream high-pass filter is switched off. | 0bin
PR32.3 | enSinglePhaseAnalysis | 0bin | Single-phase analysis is disabled: the values entered for the L1 phase applies to all three phases. | 0bin
 |  | 1bin | Single-phase analysis is active: the phases are each compared with their associated register values, and analyzed individually.
PR32.2 | disWatchdog | 0bin | Watchdog is active: If the power terminal does not receive any data from the fieldbus for 100 ms, the watchdog switches the motor off and stops data transmission. | 0bin
PR32.1 | enLeftMotion | 1bin | Allows the motor to start rotating to the left using bit 6 in the extended control byte. | 0bin
PR32.0 | enRightMotion | 1bin | Allows the motor to start rotating to the right using bit 5 in the extended control byte. | 1bin
*) The voltages of the three phases are measured with reference to an artificial star point.
PR33, PR39, PR45: Rated current
If you set both rotary switches for setting the rated current at the front of the KL8001 to zero, the values stored in registers PR33, PR39 and PR45 are used for overload control (resolution: 0.01 A, permitted setting range: 0.9 A to 15.0 A). This is useful when:
▪
different rated currents are required for single-phase evaluation, for example if three different single-phase motors are connected.
▪
you want to use the extended setting range of 10.0 A to 15.0 A, which cannot be set via the rotary switches.
PR34, PR40, PR46: Switch-on threshold
A switch-on protection phase is maintained before switching on again after the power terminal has switched off the motor because of overload. This time corresponds to the tripping class. In other words, with a tripping class of 50 the motor can only be switched on again after a period of 50 seconds. This time can be shortened by means of this register, which can be useful under some circumstances with large tripping classes.
The value to be entered is calculated in accordance with the following formula:
Example:
Switch-on time = 10 seconds, tripping class = 50 seconds
(1 - 10 sec / 50 sec) x 65535 = 52428
The switch-on threshold to be entered then is 0xCCCC (52428dec).
PR35: L1 overvoltage threshold*
If the mains voltage at L1 exceeds the overvoltage threshold stored (with a resolution of 0.1 V) in register PR35, bit SW.7 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR36: L1 undervoltage threshold*
If the mains voltage at L1 falls below the undervoltage threshold stored (with a resolution of 0.1 V) in register PR36, bit SW.4 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR37: Overload threshold L1
If the current in phase L1 exceeds the overload threshold stored in register PR37 (with a resolution of 0.01 A), the ESB.0 bit will be set in the extended status byte while the Overload LED will flash at about 5 Hz. If you set the overload threshold in register PR37 below the rated current, the motor can be switched off early in the event of excessive rated load, in order to prevent damage.
PR38: Underload threshold L1
If the current in phase L1 falls below the underload threshold stored in register PR38 (with a resolution of 0.01 A), the ESB.1 bit will be set in the extended status byte while the Overload LED will flash at about 2 Hz. If you set the value in register PR38 below the rated load that has been set, then the motor can be switched off in the event of, for instance, a broken shaft, in order to avoid more serious damage.
PR39
See PR33.
PR40
See PR34.
PR41: L2 overvoltage threshold*
If the mains voltage at L2 exceeds the overvoltage threshold stored (with a resolution of 0.1 V) in register PR41, bit SW.8 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR42: L2 undervoltage threshold*
If the mains voltage at L2 falls below the undervoltage threshold stored (with a resolution of 0.1 V) in register PR42, bit SW.5 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR43: Overload threshold L2
If the current in phase L2 exceeds the overload threshold stored in register PR43 (with a resolution of 0.01 A), the ESB.0 bit will be set in the extended status byte while the Overload LED will flash at about 5 Hz. If you set the overload threshold in register PR43 below the rated current, the motor can be switched off early in the event of excessive rated load, in order to prevent damage.
PR44: Underload threshold L2
If the current in phase L2 falls below the underload threshold stored in register PR44 (with a resolution of 0.01 A), the ESB.1 bit will be set in the extended status byte while the Overload LED will flash at about 2 Hz. If you set the value in register PR44 below the rated load that has been set, then the motor can be switched off in the event of, for instance, a broken shaft, in order to avoid more serious damage.
PR45
See PR33.
PR46
See PR34.
PR47: L3 overvoltage threshold*
If the mains voltage at L3 exceeds the overvoltage threshold stored (with a resolution of 0.1 V) in register PR47, bit SW.9 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR48: L3 undervoltage threshold*
If the mains voltage at L3 falls below the undervoltage threshold stored (with a resolution of 0.1 V) in register PR48, bit SW.6 will be set in the status word.
*) The voltages of the three phases are measured with reference to an artificial star point.
PR49: Overload threshold L3
If the current in phase L3 exceeds the overload threshold stored in register PR49 (with a resolution of 0.01 A), the ESB.0 bit will be set in the extended status byte while the Overload LED will flash at about 5 Hz. If you set the overload threshold in register PR49 below the rated current, the motor can be switched off early in the event of excessive rated load, in order to prevent damage.
PR50: Underload threshold L3
If the current in phase L3 falls below the underload threshold stored in register PR50 (with a resolution of 0.01 A), the ESB.1 bit will be set in the extended status byte while the Overload LED will flash at about 2 Hz. If you set the value in register PR50 below the rated load that has been set, then the motor can be switched off in the event of, for instance, a broken shaft, in order to avoid more serious damage.
PR51: Maximum permissible current difference
If the current difference between two phases exceeds the value stored in register PR51 (with a resolution of 0.01 A) then bit SW.0 is set in the status word.
PR52: Tripping class
The delay in the event of overload is set via the tripping class (resolution: 1 s). The value set corresponds to the release time in seconds (for an overcurrent that is precisely 7.2 times greater than the set rated current). If the overcurrent is more than 7.2 times the rated current, the release time becomes correspondingly shorter, and is extended if the current is below this value.
Example:
Tripping class = 10 s, rated current = 4.0 A
An overcurrent of 28.8 A (4.0 A x 7.2) results in a release time of 10 s.
PR53: Measuring cycle time
The conversion time of the A/D converter is set through this register directly (with a resolution of 1 ms).
Note
Accuracy of the measurement results
To obtain correct measurement results, a value of less than 30 ms must not be set!


Examples of Register Communication

Access from the user program [image] Parameter registers (overview) [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Parameter registers (overview) [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Parameter registers (overview) [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Data registers

Access from the user program [image] Data registers
Data registers
These registers are used to store the measured values. They can be read in process data mode, but not written.
The three sets of registers are loosely assigned to the mains phases, but to some extent also contain general measured values.
KL8001 data registers
DR no. | Register set 0 (access via DataIN0) |  | Register set 1 (access via DataIN1) |  | Register set 2 (access via DataIN2)
 | Contents | Unit | Contents | Unit | Contents | Unit
DR0 | Status word (1) | - | Status word (1) | - | Status word (1) | -
DR1 | Current (rms value) (average value of L1, L2 and L3) | 0.01 A | Voltage (rms value) (average value of L1, L2 and L3) | 0.1 V | Active power (sum of L1, L2 and L3) | 1 W
DR2 | Peak value(2) of current in L1 (since the KL8001 was switched on) | 0.01 A | Peak value(2) of current in L2 (since the KL8001 was switched on) | 0.01 A | Peak value(2) of current in L3 (since the KL8001 was switched on) | 0.01 A
DR3 | RMS value current L1 | 0.01 A | RMS value current L2 | 0.01 A | RMS value current L3 | 0.01 A
DR4 | RMS value voltage L1 | 0.1 V | RMS value voltage L2 | 0.1 V | RMS value voltage L3 | 0.1 V
DR5 | Active power L1 | 1 W | Active power L2 | 1 W | Active power L3 | 1 W
DR6 | Cosine j L1 | 0.01 | Cosine j L2 | 0.01 | Cosine j L3 | 0.01
DR7 | Motor loading L1 (L1-L2-L3) | 1 A2sec | Motor loading L2 | 1 A2 sec | Load motor L3 | 1 A2 sec
DR8 | Energy consumption(3) L1 | 1 kWh | Energy consumption(3) L2 | 1 kWh | Energy consumption(3) L3 | 1 kWh
DR9 | Energy consumption (sum of 3 phases) | 1 kWh | Maximum current difference between L1, L2 and L3 | 0.01 A | Cos phi (mean value of L1, L2 and L3) | 0.01
DR10 | Rated current set at the rotary switches | 0.01 A | Switching cycle counter | 1 | Motor operating hours counter(4) | 0.5 h
DR11- DR17 | reserved | - | reserved | - | reserved | -
DR18- DR36 | Internal register | - | Internal register | - | Internal register | -
DR37 | Software version of the measuring unit in ASCII code (e.g.: 0x3343 = 5167dec =3CASCII) | - | Software version of the measuring unit in ASCII code (e.g.: 0x3343 = 5167dec =3CASCII) | - | Software version of the measuring unit in ASCII code (e.g.: 0x3343 = 5167dec =3CASCII) |
DR38- DR63 | Internal register | - | Internal register | - | Internal register | -
(1) The status word can be read from any of the three sets of registers. It contains the status information for all three channels.
(2) The stored peak current values can be reset to zero at any time using bit 0 of the extended control byte.
(3) The energy consumption is stored in the registers every half-hour, and is retained even when the KL8001 is switched off.
(4) The operating hours are stored every 30 minutes in the register and are retained even if the KL8001 is switched off.
Reading a data register
If the register number of a data register is entered during process data mode in the associated control byte, then its contents will be returned in the corresponding process data word.
Data register assignments
Register set | corresponding control byte | Associated process data word
0 | Control byte 0 | DataIN0
1 | Control byte 1 | DataIN1
2 | Control byte 2 | DataIN2
Examples
Read the active power of phase L1:
▪
Enter data register number 5 into control byte 0.
▪
The content of register DR5 in register set 1 is returned in process data word DataIN0.
Read the energy consumption of phase L2:
▪
Enter data register number 8 into control byte 1.
▪
The content of register DR8 in register set 2 is returned in process data word DataIN1.
Read cos phi for phase L3:
▪
Enter data register number 6 into control byte 2.
▪
The content of register DR6 in register set 3 is returned in process data word DataIN2.
Additional information
•
Status word


Status word

Access from the user program [image] Data registers [image] Status word
Status word
The status word contains further information about the state of the KL8001. Under process data mode, it can be transmitted from the terminal to the controller using any of the DataIN0, DataIN1 or DataIN2 input words.
Status word
Bit
SW.15
SW.14
SW.13
SW.12
SW.11
SW.10
SW.9
SW.8
SW.7
SW.6
SW.5
SW.4
SW.3
SW.2
SW.1
SW.0
Key
Bit
Name
Value
Description
SW.15
Other errors
1bin
another error has occurred
SW.14
No rated current set
1bin
Both the two rotary switches and
▪
register PR33 is zero (single-phase analysis not active) or
▪
at least one of registers PR33, PR39 or PR45 is zero (single-phase analysis is active)
SW.13
Contactor fault
1bin
Current flow detected with contactor switched off
SW.12
reserved
-
-
SW.11
reserved
-
-
SW.10
reserved
-
-
SW.9
Overvoltage L3
1bin
Voltage > configured overvoltage limit (PR47)
SW.8
Overvoltage L2
1bin
Voltage > configured overvoltage limit (PR41)
SW.7
Overvoltage L1
1bin
Voltage > configured overvoltage limit (PR35)
SW.6
Undervoltage L3
1bin
Voltage < configured undervoltage limit (PR48)
SW.5
Undervoltage L2
1bin
Voltage < configured undervoltage limit (PR42)
SW.4
Undervoltage L1
1bin
Voltage < configured undervoltage limit (PR36)
SW.3
Phase failure in L3
1bin
Failure of phase L3
SW.2
Phase failure L2
1bin
Outage of phase L2
SW.1
Phase failure L1
1bin
Outage of phase L1
SW.0
Asymmetric load
1bin
Current difference > configured current difference (PR51)


TwinCAT

TwinCAT
TwinCAT
1.
Start the TwinCAT System Manager.
2.
Using the right mouse button, start searching for new devices under the branch I/O Configuration \ I/O devices.
or add the fieldbus card (device) and the Bus Coupler (box) manually.
3.
Click with the right mouse button on the Bus Coupler in the tree structure and add the desired Bus Terminal with the Add terminal menu item.
Insert a power terminal
The KL8001 is found in the Power Terminals (KL800x) group. You can insert up to 10 power terminals at the end of the terminal block with the KL9060 Adapter Terminal.
Adding a Bus Terminal in the TwinCAT System Manager
The KL8001 in the tree structure
The KL8001 is represented with 10 bytes of input data and 10 bytes of output data in the System Manager. The empty word (see process image) is present in the Bus Coupler mapping, but is not, however, displayed by the System Manager.
Tree structure of the KL8001 in the TwinCAT System Manager
Beckhoff Information System
For further information on configuration with the TwinCAT System Manager and programming with TwinCAT PLC Control please refer to the Beckhoff Information System. The Beckhoff Information System is a continuously growing reference system for TwinCAT products. It contains technical information, manuals, sample code, the BECKHOFF Knowledge Base and much more.
The setup for installing the Beckhoff Information System is available on the Beckhoff CD Products & Solutions and for download from our website under https://www.beckhoff.de. In addition, the online version of the Beckhoff Information System can be found at http://tcinfosys.beckhoff.com.


Appendix

Appendix
Appendix
Additional information
•
Ordering information
•
Support and Service


Ordering information

Appendix [image] Ordering information
Ordering information
Beckhoff
Power Terminal
Order identifier
Scope of supply
KL8001
▪
1 x power terminal for controlling Siemens contactors of the Sirius 3RT10 series of size S00
▪
1 x short (approx. 3 cm) ribbon cable for the bus connection between two power terminals
Accessories for the power terminal
Order identifier
Scope of supply
KL9060
▪
1 x adapter terminal for connecting power terminals to a Beckhoff Bus Terminal block
▪
1 x long (approx. 10 cm) ribbon cable for the bus connection between the adapter terminal and the first power terminal
▪
1 x bus end plug for the last power terminal
ZS1010-1610
▪
1 x bus end plug
ZK1010-8080-3003
▪
1 x short (approx. 3 cm) ribbon cable for the bus connection between two power terminals
ZK1010-8080-3005
▪
1 x medium-sized (approx. 5 cm) ribbon cable for the bus connection between two power terminals with a reversing contactor connection
ZK1010-8080-3010
▪
1 x long (approx. 10 cm) ribbon cable for the bus connection between the adapter terminal and the first power terminal or
KS2000
▪
1 x configuration software
▪
1 x serial configuration cable for the Beckhoff Bus Coupler
Siemens
Siemens contactors of the Sirius 3RT10 series
Order number | Product | Power section | Auxiliary contact | Size | Connection technology
3RT1015-1BB41 | Contactor, AC-3 | 3 kW, 400 V, 3-pin | 1 NO contact, 24 VDC | S00 | Screw connection
3RT1016-1BB41 | Contactor, AC-3 | 4 kW, 400 V, 3-pin | 1 NO contact, 24 VDC | S00 | Screw connection
3RT1017-1BB41 | Contactor, AC-3 | 5.5 kW, 400 V, 3-pin | 1 NO contact, 24 VDC | S00 | Screw connection
3RT1015-1BB42 | Contactor, AC-3 | 3 kW, 400 V, 3-pin | 1 NC contact, 24VDC | S00 | Screw connection
3RT1016-1BB42 | Contactor, AC-3 | 4 kW, 400 V, 3-pin | 1 NC contact, 24VDC | S00 | Screw connection
3RT1017-1BB42 | Contactor, AC-3 | 5.5 kW, 400 V, 3-pin | 1 NC contact, 24VDC | S00 | Screw connection
Siemens accessories for contactors of the Sirius 3RT10 series
Order number | Description
3RA1913-2A | Kit for reversing combination


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com