KL6831 and KL6841 - SMI Master Terminal

BECKHOFF Fieldbus Components

Documentation for

KL6831 and KL6841

SMI Master Terminal

Version: 1.1.0
Date: 2014-11-11


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Safety rules

Consider the following safety instructions and descriptions!
Product specific safety instructions are to be found on the following pages or in the areas mounting, wiring, commissioning etc.

Disclaimer

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel qualification

This description is only intended for the use of trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.

Description of symbols

The following symbols with a adjoining safety advise or notice are used in this documentation. You have to read the safety advices carefully and adhere them strictly!

DANGER 		Acute risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is immediate danger to life and health of individuals!

WARNING 		Risk of injury!
If you do not adhere the safety advise adjoining this symbol, there is danger to life and health of individuals!

CAUTION 		Hazard to individuals!
If you do not adhere the safety advise adjoining this symbol, there is obvious hazard to individuals!

Attention 		Hazard to devices and environment
If you do not adhere the notice adjoining this symbol, there is obvious hazard to materials and environment.

Note 		Note or pointer
This symbol indicates information that contributes to better understanding.


KL6831 und KL6841 - Documentation issue status

BECKHOFF KL6831 and KL6841: Foreword

Documentation issue status

Version | Comment
1.1.0
  • chapter Register Description updated
  • chapter Principle of Operation corrected
1.0.0 | first release

Firm and hardware versions

Documentation Version | KL6831 |  | KL6841
 | Firmware | Hardware | Firmware | Hardware
1.1.0 | 1C | 00 | 1C | 00
1.0.0 | 1C | 00 | 1C | 00

The firmware and hardware version (delivery status) can be found in the serial number printed at the side of the terminal.

Syntax of the serial number

Structure of the serial number: WW YY FF HH

WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version

Example with ser. no.: 44 13 B1 00:

44 - week of production 44
13 - year of production 2013
1C - firmware version 1C
00 - hardware version 00


KL6831 and KL6841 - Introduction

BECKHOFF KL6831 and KL6841: Product overview

Introduction

The SMI master terminals KL6831 and KL6841 enable direct connection to the SMI bus system.

The automation of roller shutters and sun blinds in building automation is simplified with the SMI-Bus system (Standard Motor Interface). With SMI drives roller shutters can drive to precise positions and blind drives can drive to angular positions with an accuracy of a degree. The SMI drives can return actual positions, error messages and service information to the SMI master terminal.

The KL6831 is designed for installations with 24 V LoVo SMI drives, the KL6841 for installations with 230 V AC SMI drives.

Attention 		Application of the KL6831 and KL6841
The KL6831 and KL6841 may only be operated at the designated SMI drives. Interchanging of 24 V LoVo SMI drives and 230 V AC SMI drives or mixed operation is not permitted, since it may lead to malfunctions and destruction of modules.

The wiring effort is reduced compared with standard drives, since each SMI master terminal can control up to 16 SMI drives.

Further information on the SMI bus and SMI drives are provided by the SMI Group under www.smi-group.com.

The KL6831 and KL6841 contain an integrated power supply unit for the electrically isolated SMI power supply. No further components are required for the operation of SMI drives. The KL6831 and KL6841 operate fieldbus-independent.

The TwinCAT PLC Lib SMI library, which is available free of charge (see TwinCAT Information System), is used to control the SMI master terminals directly from the PLC program. In addition, high-performance PLC blocks for room automation according to VDI 3813 are available in the TwinCAT HVAC library.

Note 		Support for KL6831 and KL6841
The KL6831 and KL6841 are only supported in conjunction with the TwinCAT library for the SMI master terminal!

If the KL6831 or KL6841 are used under another control system than TwinCAT, Bus Couplers (BK) are not supported.
In this case a Bus Terminal controller (BC or BX) would be required!

Without TwinCAT PLC, the KL6831 or KL6841 are not supported at an Embedded PC (CX).


KL6831 and KL6841 - Diagnostic LEDs

BECKHOFF KL6831 and KL6841: Product overview

Diagnostic LEDs

The LEDs indicate the operating state of the KL6831 and KL6841.

Meaning of the LED displays
LED | Color | State and significance
 |  | On | Off | Flashes
Run-LED | green | K-bus communication is OK | No K-bus communication | K-bus communication
Send LED | green | SMI telegrams are sent | No sending | Sending active
+ 24 V Power LED | green | Power supply OK | No 24 V power supply | -
Input 1 Status LED | green | DI 1 is switched on or was active and has not yet been acknowledged. | DI 1 is switched off | -
Error LED | red | Hardware error | No error | -
Receive LED | green | SMI telegrams are received | No reception | Reception active
Input 2 Status LED | green | DI 2 is switched on or was active and has not yet been acknowledged. | DI 2 is switched off | -


KL6831 and KL6841 - Technical data

BECKHOFF KL6831 and KL6841: Product overview

Technical data

Technical data | KL6831 | KL6841
Number of channels | 1
Number of SMI slaves | 16 max.
Electrical isolation (K-bus / SMI bus) | 1500 V
Bit width in the K-bus I/O | 2 x 22 bit input and output data, 1 x 16 bit control/status word
Bit width in the input process image | 22 bit input data, 16 bit control/status word
Bit width in the output process image | 22 bit output data, 16 bit control/status word
Configuration | Via function blocks of the TwinCAT automation software
Special features | 2 digital inputs for simplified commissioning, TwinCAT library available, can only be used with Beckhoff controller
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 55 mA
Short-circuit strength | Yes, automatic restart
Input voltage | 24 VDC (-15%/+ 20%)
Isolation voltage | SMI bus / K-bus: permanent 1500 VAC SMI bus / 24 V DC supply: permanent 1500 VAC K-bus / 24 V DC supply: permanent 500 VAC
SMI | standard-compliant, open circuit voltage approx. 18 VDC
Data transfer rates | 2400 baud
SMI system | LoVo | 230 VAC
Resistance to overvoltage (effective) | permanent 275 VAC
Weight | approx. 80 g
Dimensions (W x H x D) | approx. 15mm x 100mm x 70mm
Installation | on 35 mm mounting rail according to EN 50022
Power dissipation | 0.5 W + power dissipation caused by the connected SMI slaves
Permissible ambient temperature range during operation | 0°C ... +55°C
Permissible ambient temperature range during storage | -25°C ... +85°C
Permissible relative humidity | 95%, no condensation
Vibration / shock resistance | Conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | Conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | Variable
Approval | CE


ELxxxx, KLxxxx - Installation on mounting rails

BECKHOFF Fieldbus Components: Mounting and wiring

Installation on mounting rails

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Assembly

The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:

  1. First attach the Fieldbus Coupler to the mounting rail.
  2. The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
    If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.

Note 		Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail.
At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail.
To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).

Disassembly

Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
  1. Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
  2. Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.

Connections within a bus terminal block

The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:

  • The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
  • The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.

Note 		Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts.
Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.

PE power contact

The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.

Attention 		Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V).

For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.

WARNING 		Risk of electric shock!
The PE power contact must not be used for other potentials!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Connection system

BECKHOFF Fieldbus Components: Mounting and wiring

Connection system

WARNING 		Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!

Overview

The Bus Terminal system offers different connection options for optimum adaptation to the respective application:

  • The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
  • The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
  • The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.

Standard wiring

The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.

Pluggable wiring

The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring.
This reduces the installation time and eliminates the risk of wires being mixed up.

The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.

A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.

Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.

The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.

High Density Terminals (HD Terminals)

The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.

Note 		Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.

Ultrasonically "bonded" (ultrasonically welded) conductors

Note 		Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors.
In this case, please note the tables concerning the wire-size width below!

Wiring

Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx

Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:

  1. Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
  2. The wire can now be inserted into the round terminal opening without any force.
  3. The terminal closes automatically when the pressure is released, holding the wire securely and permanently.

Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm

High Density Terminals ELx8xx, KLx8xx (HD)

The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.

Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm

Shielding

Note 		Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


KL6831 and KL6841 - Connection

BECKHOFF KL6831 and KL6841: Mounting and wiring

Connection

Terminal point | No. | Connection for
+ 24 V DC | 1 | 24 V supply voltage
Input 1 | 2 | 24 V digital input for executing freely definable SMI commands. The default is "move all SMI drives up"
SMI+ | 3 | SMI bus line I+
SMI- | 4 | SMI bus line I-
0 V | 5 | Ground
Input 2 | 6 | 24 V digital input for executing freely definable SMI commands. The default is "move all SMI drives down"
SMI+ | 7 | SMI bus line I+
SMI- | 8 | SMI bus line I-

Note 		Input 1 and input 2
The digital inputs input 1 and input 2 (terminal points 2 and 6) only work if the 24 V supply voltage is connected and the K-bus voltage supplied is switched on.

Note 		Input 1 and input 2, effect on automatic mode
The digital inputs input 1 and input 2 (terminal points 2 and 6) have priority over automatic control through the PLC program. If the digital inputs are operated, other PLC-controlled SMI commands are blocked. To enable them a rising edge is required at the bResetInactiveProcessImage input of FB_KL6831KL6841Communication. See TwinCAT PLC Lib:SMI documentation.


Fieldbus Components - SMI overview

BECKHOFF Fieldbus Components: SMI

SMI - Overview

Introduction to SMI

The automation of roller shutters and sun blinds in building automation is simplified with the SMI-Bus system (Standard Motor Interface). With SMI drives roller shutters can drive to precise positions and blind drives can drive to angular positions with an accuracy of a degree. The SMI drives can return actual positions, error messages and service information to the SMI master terminal.

Major European manufacturers have joined forces in the SMI working group and have developed the digital interface. Drives are controlled by means of telegrams via this uniform interface. Using standard commands, functions can be implemented that are not so easy to realize with conventional drives. Examples are the precise movement to positions, the feedback of the current position and diagnosis. For the adjustment of louvers in shading systems, for example, angular resolutions of 2° can be achieved. Adjustment of the louvers in relation to the position of the sun is thus possible for constant light control.

Distances of up to 350 meters between the controller and the drive are possible. A normal 5-core power cable can be used for the cabling (with PE, N, L and the SMI-specific I+ and I-); I+ and I- are protected against pole reversal. Up to 16 drives can be connected in parallel and addressed individually. SMI drives are available for mains voltage (230 VAC)) and for low voltage (24 VDC).

In order to ensure the compatibility of the SMI products with one another, all products that are to be marked with the SMI logo must be certified. A positive certification can be read on the SMI Group’s homepage (www.smi-group.com). Further information on the SMI-Bus and SMI drives can also be found there.


KL6831 and KL6841 - Principle of operation

BECKHOFF KL6831 and KL6841: SMI

Principle of operation

The two SMI master terminals KL6831 and KL6841 enable the operation of 16 SMI drives (blinds/roller shutters) per terminal and support the complete SMI functionality. Ready-made blocks are used to realize up, down and stop commands, travel to any position, adjustment of the slat angle and feedback on the current position of the motor/blind in the PLC user program. The SMI master terminals implement the process data (movement commands in the PLC program) in the SMI protocol, including level conversion. The terminals require an external 24 V DV supply. The K-bus, the 24 V supply and the SMI connections are electrically isolated from each other.

Addressing of the SMI drives and programming of the SMI master terminal

Addressing of the SMI drives and programming of the SMI master terminal is described in the software documentation in the Beckhoff Information System:

TwinCAT 2: TwinCAT 2 PLC Lib: SMI

TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_SMI

Notes for commissioning with DI1 and DI2

The behavior of the digital inputs DI1 and DI2 can be modified via the library blocks.
To support commissioning the following default behavior is assigned.

Digital input | SMI command
Rising edge at DI1 | All SMI drives travel UP on rising edge at DI1 (factory setting)
Falling edge at DI1 | All SMI drives stop on falling edge at DI1 (factory setting)
Rising edge at DI2 | All SMI drives travel DOWN on rising edge at DI2 (factory setting)
Falling edge at DI2 | All SMI drives stop on falling edge at DI2 (factory setting)
Effect of actuating the digital inputs DI1 and DI2 on automatic mode

The digital inputs input 1 and input 2 (terminal points 2 and 6) have priority over automatic control through the PLC program. If the digital inputs are operated, other PLC-controlled SMI commands are blocked. To enable them a rising edge is required at the bResetInactiveProcessImage input of FB_KL6831KL6841Communication. See TwinCAT PLC Lib:SMI documentation.


KL6831 and KL6841 - Programming

BECKHOFF KL6831 and KL6841: Programming

TwinCAT libraries

Software documentation in the Beckhoff Information System:

TwinCAT 2: TwinCAT 2 PLC Lib: SMI

TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_SMI


KL6831, KL6841 - Register overview

BECKHOFF KL6831, KL6841: Access from the user program

Register overview

The registers are used for the parameterization of the interface terminals. They can be read or written by means of register communication.

Register no. | Comment |  | Default value |  | R/W | Memory
R0 | reserved |  | 0x0000 | 0dec | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserved |  | 0x0000 | 0dec | - | -
R6 | Diagnostic register |  | variable | variable | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL6831 | 0x1AAF | 6831dec | R | ROM
 |  | KL6841 | 0x1AB9 | 6841dec | R | ROM
R9 | Firmware version |  | variable | variable | R | ROM
R10 | reserved |  | 0x0000 | 0dec | - | -
... | ... |  | ... | ... | ... | ...
R15 | reserved |  | 0x0000 | 0dec | - | -
R16 | Hardware version |  | e.g. 0x0000 | e.g.: 0dec | ... | EEPROM
R17 | reserved |  | 0x0000 | 0dec | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserved |  | 0x0000 | 0dec | - | -
R29 | Terminal type - special identification |  | 0x0000 | 0dec | R | EEPROM
R30 | reserved |  | 0x0000 | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0000 | 0dec | R/W | EEPROM
R33 | Watchdog register |  | variable | variable | R/W | RAM
R34 | Watchdog register |  | variable | variable | R/W | RAM
R35 | Watchdog register |  | variable | variable | R/W | RAM
R36 | DI register |  | variable | variable | R/W | RAM
... | ... |  | ... | ... | ... | ...
R47 | DI register |  | variable | variable | R/W | RAM
... | ... |  | ... | ... | ... | ...
R63 | reserved |  | 0x0000 | 0dec | - | -


KL6831, KL6841 - Register description

BECKHOFF KL6831, KL6841: Access from the user program

Register description

All registers can be read or written via register communication. They are used for parameterizing the terminals.

The behavior in conjunction with a K-bus watchdog (R33 ... R35) and the behavior of the inputs DI1 and DI2 (R36 ... R47) can be modified via library blocks.

R6: Diagnostic register

Bit | Description |  | default
R6.5-15 | - | reserved | -
R6.4 | 1bin | Buffer is full | 0bin
R6.3 | 1bin | An overrun error has occurred | 0bin
R6.2 | 1bin | A framing error has occurred | 0bin
R6.1 | 1bin | A parity error has occurred | 0bin
R6.0 | 1bin | The receive buffer has overflowed, incoming data is lost | 0bin

R7: Command register

Note 		User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings

Entering 0x7000 in register R7 restores the factory settings for the following registers:

R33, 34 and 35: No SMI command with K-bus watchdog
R36, 37 and 38: All SMI drives travel UP on rising edge at DI1
R39, 40 and 41: All SMI drives stop on falling edge at DI1
R42, 43 and 44: All SMI drives travel DOWN on rising edge at DI2
R45, 46 and 47: All SMI drives stop on falling edge at DI2

R8: Terminal type

The terminal identifier is contained in register R8:
KL6831: 0x1AAF (6831dec)
KL6841: 0x1AB9 (6841dec)

R9: Firmware version

Register R9 contains the ASCII coding of the terminal's firmware revision level, e.g. 0x3143 = '1C'. The '0x31' corresponds here to the ASCII character '1', while the '0x43' represents the ASCII character 'C'.
This value can not be changed.

R16: Hardware version number

Register R16 contains the hardware version of the terminal.

R31-R47: User registers

R31: Code word register

  • If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
  • If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are written into the RAM registers and in the EEPROM registers and are therefore retained if the terminal is restarted.

The code word is reset if the terminal is restarted.

R32: Feature register

The feature register R32 is unassigned.

R33, R34 and R35: Watchdog

The R33, 34 and 35 determine the behavior of the terminal in the event of a K-bus watchdog.

The factory setting is: No SMI command if the K-bus watchdog is triggered.

The behavior can be changed via the library blocks.

R36 to R47: Behavior of DI1 and DI2

The behavior of the digital inputs DI1 and DI2 can be modified via the library blocks.

Digital input | SMI command
Rising edge at DI1 | All SMI drives travel UP on rising edge at DI1 (factory setting)
Falling edge at DI1 | All SMI drives stop on falling edge at DI1 (factory setting)
Rising edge at DI2 | All SMI drives travel DOWN on rising edge at DI2 (factory setting)
Falling edge at DI2 | All SMI drives stop on falling edge at DI2 (factory setting)


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com