KL6811/KS6811 Dali/DSI master terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.4.0
▪
Register description corrected
▪
Technical data updated
▪
Introduction and annex updated
1.3.0
▪
Screenshots for KS2000 updated
▪
Technical data updated
1.2.2
▪
Mounting rail installation updated
▪
Basic function principles updated
1.2.1
▪
LED descriptions updated
▪
Product overview restructured
1.2
▪
Parameterization description for KL6811 and DALI devices with KS2000 software expanded
▪
Status byte descriptions expanded
▪
Technical data updated
▪
Register description corrected
1.1
▪
Parameterization description for KL6811 and DALI devices with KS2000 software added
▪
Description of DALI commands expanded
▪
Examples for register communication added
1.0
▪
Description of LEDs and pin assignment expanded
▪
Information on further reading and the standard added
▪
English translation available
0.2
Technical data updated
0.1
First preliminary version
Firmware and hardware versions
Documentation Version | KL6811
 | Firmware | Hardware
1.4.0 | 2H | 10
1.3.0 | 2F | 07
1.2.2 | 1J | 04
1.2.1 | 1J | 04
1.2 | 1J | 03
1.1 | 1G | 03
1.0 |  | 01
0.2 |  | 01
0.1 |  | 01
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 35 04 1B 01:
35 - week of production 35
04 - year of production 2004
1B - firmware version 1B
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Basic function principles
•
LED indicators


Introduction

Product overview [image] Introduction
Introduction
KL6811
The KL6811 enables the connection of up to 64 DALI slaves. The KS2000 configuration software facilitates parameterization via a PC. The PC is directly coupled with the Bus Coupler via an RS232 interface or via the fieldbus. The KL6811 features an integrated power supply unit (24 VDC) with electrically isolated output voltage. No further components are required for operation of the DALI slaves. The KL6811 operates fieldbus-independent.


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL6811, KS6811
Data transfer channels | 1
DALI slaves / groups | maximum 64 / maximum 16
Bit width in the K-bus I/O | 2 x 8 bit user data, 1 x 8 bit control/status
Bit width in the input process image | 1 data word, 1 status byte
Bit width in the output process image | 1 data word, 1 control byte
Configuration | with KS2000 configuration software via - Bus Coupler and configuration cable - Fieldbus
Power supply for electronic | via the K-bus
Current consumption from K-bus | typically 55 mA
Current consumption from the power contacts | typically 30 mA + load
Short-circuit strength | yes, automatic re-starting
Input voltage | 24 VDC (-15%/+ 20%)
Isolation voltage | DALI bus / K-Bus: permanent 1500 VAC DALI bus / power contacts: permanent 1500 VAC K-Bus / power contacts: permanent 500 VAC
DALI / DSI | standards-conform, open-circuit voltage 11.5 ... 15 VDC
Max. high/low level | current 130 mA / 250 mA
Pluggable wiring | for all KSxxxx terminals
Weight | approx. 80 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Power loss | 0.5 W + power dissipation caused by the connected DALI slaves
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Coupling to price-sensitive actuators in a controller system is a challenge for a universal gateway. A building's illumination is typically implemented through a large number of devices. The price of a lamp, and therefore of the connection to a control system, is thus of great significance.
DALI
The Digital Addressable Lighting Interface (DALI) is a simple bus system for building automation that transmits the signals for the digital operation of lighting devices. The lamp, sensor, button and switching elements are wired in parallel, and are linked through the controller. Other actuators, such as heating control valves or the motors for operating blinds are increasingly being put under digital control.
DALI offers the following advantages:
▪
an inexpensive interface with simple installation
▪
fully digital switching of lamps and similar equipment.
▪
all main manufacturers of ballasts support DALI
The KL6811 DALI Master Terminal from Beckhoff closes the gap between lighting controller and lamp and enables the connection of up to 64 DALI devices (DALI slaves). The KL6811 is integrated into the BECKHOFF Bus Terminal system as a normal Bus Terminal and is therefore fieldbus-independent. The higher-level Bus Coupler transfers the data from the DALI master terminal to the controller. The DALI power supply unit integrated in the KL6811 supplies the DALI bus. No further components are required for the operation of the DALI line.
During the start-up phase, the KL6811 searches for connected DALI slaves and supports the user during commissioning of the system. The KS2000 configuration software can be used to parameterize the DALI master terminal from a PC. The parameterization takes place via the fieldbus or via a RS232 interface, which are connected to the configuration interface of the higher-level Bus Coupler.
DSI
The KL6811 can also be operated as a DSI master. The Digital Serial interface (DSI) is an even simpler bus system for lighting control. The DSI master sends digital light intensity values serially to the DSI slaves. The brightness of the slaves can be set between 1% and 100%. The assignment of the brightness to the control values is logarithmic, so that a human observer sees a uniform increase in brightness when the control values are increased linearly. The slaves can be switched to dark by setting the control value to 0, without having to switch off the mains voltage.


LED indicators

Product overview [image] LED indicators
LED indicators
KL6811 LEDs
LED | No. | Meaning
RUN | A | on | Data transmission on the K-bus
Bus | B | flashing | Activity: Data transfer on the DALI/DSI bus
 |  | on | No power supply (24 VDC) for the power contacts
DALI / DSI | C | on | Operating mode: DALI mode
 |  | off | Operating mode: DSI mode
Error | D | on | in DALI mode: Overload of the internal DALI power supply in DSI mode: DSI feedback


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection system
•
Connection
•
ATEX - Special conditions (standard temperature range)
•
Continuative documentation about explosion protection


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection system

Mounting and wiring [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded” conductors
It is also possible to connect the Standard and High Density terminals with ultrasonically “bonded” (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


Connection

Mounting and wiring [image] Connection
Connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL6811 pin assignment
Pin assignment
Terminal point | No. | Connection for
DALI + | 1 | DALI/DSI control cable (internally connected to terminal point no. 4)
+24 V | 2 | Power contact +24 V
0 V | 3 | Power contact 0 V
DALI + | 4 | DALI/DSI control cable (internally connected to terminal point no. 1)
DALI - | 5 | DALI/DSI control cable (internally connected to terminal point no. 8)
+24 V | 6 | Power contact +24 V
0 V | 7 | Power contact 0 V
DALI - | 8 | DALI/DSI control cable (internally connected to terminal point no. 5)
Note
No mains voltage at the power contacts
The terminal points for the power contacts (+24 V, 0 V) must not be connected to 230 V mains voltage under any circumstances, since this would destroy the KL6811.
Contacts for the DALI control cable (DALI+, DALI-) and mains voltage
If the contacts for the DALI control line (DALI+, DALI-) are accidentally connected to 230 V mains voltage, the KL6811 is not destroyed, but switches off.
Line lengths in DALI mode
The DALI bus can be configured in a line or star topology, or in a mix of the two. The maximum cable length must not exceed 300 m!
Cable length | Wire cross section
up to 100 m | minimum 0.5 mm2
up to 150 m | minimum 0.75 mm2
up to 300 m | minimum 1.5 mm2
Further important boundary conditions derived from IEC 62386:
▪
The DALI cables must not be terminated with resistors.
▪
The maximum voltage drop between the sender and the receiver must not exceed 2 V.
▪
If the maximum cable length is utilized, it is not advisable to lay DALI in combination with the power cable.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
For dust (only the fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9): The equipment shall be installed in a suitable enclosure providing a degree of protection of IP54 according to EN 60079-0 for group IIIA or IIIB and IP6X for group IIIC, taking into account the environmental conditions under which the equipment is used.
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
▪
EN 60079-31:2013 (only for certificate no. KEMA 10ATEX0075 X Issue 9)
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:

II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: 0 ... +55°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)
or

II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C
II 3D KEMA 10ATEX0075 X Ex tc IIC T135°C Dc Ta: 0 ... +55°C
(only for fieldbus components of certificate no. KEMA 10ATEX0075 X Issue 9)


Continuative documentation about explosion protection

Mounting and wiring [image] Continuative documentation about explosion protection
Continuative documentation about explosion protection
Explosion protection for terminal systems
Pay also attention to the continuative documentation

Notes on the use of the Beckhoff terminal systems in hazardous areas according to ATEX and IECEx

that is available for download on the Beckhoff homepage https:\\www.beckhoff.com!


Configuration software KS2000

Configuration software KS2000
Configuration software KS2000
Additional information
•
KS2000 - Introduction
•
KL6811 configuration
•
Register
•
Settings
•
Process data


KS2000 - Introduction

Configuration software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


KL6811 configuration

Configuration software KS2000 [image] KL6811 configuration
KL6811 configuration
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 digital input terminal
▪
a KL6811 DALI Master Terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branches for channel 1 of the KL6811
For the KL6811, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL6811 registers.
▪
Under Settings you find dialog boxes for parameterizing the KL6811.
▪
ProcData displays the KL6811 process data.


Register

Configuration software KS2000 [image] Register
Register
You can access the registers of the KL6811 directly under Register. The meaning of the register is explained in the register overview.
Register view in KS2000


Settings

Configuration software KS2000 [image] Settings
Settings
Under Settings you will find the dialog masks for parameterization of the KL6811 and of the DALI/DSI devices connected to it.
KS2000 - parameterization of the KL6811 and the DALI/DSI devices
Device settings
You can change the settings of the DALI/DSI devices on this tab.
Addressing
You can carry out the addressing of the DALI devices on this tab.
Options
You can specify a number of options for the KL6811 on this tab.
Additional information
•
Setting up the DALI/DSI devices
•
Addressing the DALI devices
•
Options
•
Archive


Setting up the DALI/DSI devices

Configuration software KS2000 [image] Settings [image] Setting up the DALI/DSI devices
Setting up the DALI/DSI devices
Click the Scan devices button so that the KL6811 reads in the connected DALI/DSI devices. In this example, 6 DALI devices are shown.
Sending DALI commands
Click on Devices.
Commands to multiple DALI devices
Address type
In DALI operation you can use this mask to send a command to
▪
all the connected DALI devices (collective call/broadcast),
▪
a group of DALI devices (group), or
▪
to one specific DALI device (short address).
KS2000 - parameterization of the DALI/DSI devices - address-type
Command and data
Direct control of the lamp power
The first command in this menu is supported by means of an intensity slider:
▪
set the intensity slider to the desired value or
▪
enter a value into the Data field
and click the Send DALI command button. The KL6811 sends this value as a direct DALI command for the lamp power to all the selected DALI devices.
Further commands
The command number is shown in decimal format for all other commands. They are described under this number in the section covering indirect DALI commands for lamp power.
Settings for the individual DALI devices
Four dialog masks are available to control every recognized DALI device:
▪
Lighting control/query (click directly on Device #xx)
▪
Variables
▪
Groups
▪
Scenes
Visual selection feedback
KS2000 - parameterization of the DALI/DSI devices - visual selection feedback
If the option visual selection feedback is enabled, the selected device (in the example device #04) sets its current lamp power value to the parameterized maximum value.
Sending DSI commands
In DSI operation you can use this mask to send the same light intensity to all the connected DSI devices:
▪
set the intensity slider to the desired value or
▪
enter a value into the Data field
and click the Send DSI command button. The KL6811 sends this value to all the connected DSI devices.
KS2000 - parameterization of the DALI/DSI devices - sending of DSI commands
Additional information
•
Lighting control / query
•
Variables
•
Groups
•
Scenes


Lighting control / query

Configuration software KS2000 [image] Settings [image] Setting up the DALI/DSI devices [image] Lighting control / query
Lighting control / query
Click on the device number (in this example, Device #00). A dialog mask appears with areas for direct lamp control, indirect lamp control and query.
Direct light control (control via direct DALI commands for lamp power)
Sets the lamp intensity to the specified value.
KS2000 - parameterization of the DALI/DSI devices - lighting control / queries
Indirect light control (control via the indirect DALI commands for lamp power)
Buttons that send an associated DALI command to the selected device are available for the main functions.
Switching off
Switches off the lamp connected to the DALI device without fading (sends DALI command 0dec).
Down
Dims the DALI device over a period of 200 ms using the selected fade rate (sends DALI command 2dec)
Up
Brightens the DALI device over a period of 200 ms using the selected fade rate (sends DALI command 1dec)
Step Down
Lowers the current lamp power value by one graduation without fading (sends DALI command 4dec), assuming the lamp has not already been set to its parameterized minimum (MIN) value. If the lamp has already been set to its MIN value, it is not changed, and remains switched on. The minimum value can be parameterized on the Variables tab.
Step Up
Sets the current lamp power value one graduation higher without fading (sends DALI command 3dec), unless it is already switched on. If the lamp is switched off, it is not switched on.
Step Down and off
Sets the current lamp power value one step lower without fading (sends DALI command 7dec). If the lamp is already set to its parameterized minimum (MIN) value, it is switched off. The MIN value can be parameterized on the Variables tab.
On and Step Up
Sets the current lamp power value one step higher without fading (DALI command 8dec). If the lamp is switched off, it is switched on and is set to its parameterized minimum (MIN) value. The MIN value can be parameterized on the Variables tab.
Recall MIN LEVEL
Sets the lamp power value to the parameterized minimum (sends DALI command 6dec). If the lamp was switched off, it is switched on.
Recall MAX LEVEL
Sets the lamp power value to the parameterized maximum (sends DALI command 5dec). If the lamp was switched off, it is switched on.
Go to Scene
▪
Select a scene.
▪
Click the Go to scene button.
Sets the DALI device's lamp power value to the level parameterized for the selected scene (sends a DALI command between 16 and 31dec). This value can be parameterized on the Scenes tab.
Queries
This dialog allows you to inquire about information regarding the status of the DALI device:
▪
Select the desired query.
▪
Click the Send query button.
Query ballast
Asks whether the DALI device is ready for data exchange (DALI command 145dec).
Query lamp failure
Asks whether the DALI device has a lamp problem (DALI command 146dec).
Query lamp power supply switched on
Asks whether the power supply to the DALI device has been switched on (DALI command 147dec).
Query limit value error
Asks whether a limit value error has occurred on the DALI device (DALI command 148dec).
Query reset status
Asks whether the DALI device is in the reset state (DALI command 149dec).
Query missing short address
Asks whether the DALI device is missing the short address (DALI command 150dec).
Query DTR contents
Reads the content of the Data Transfer Register (DTR) from the DALI device (DALI command 152dec).
Query device type
Reads the type of the DALI device (DALI command 153dec). The following device types exist:
0: Standard device
1: Device for emergency lighting
2: Device for HID lamps
3: Device for dimming bulbs
5 to 255 are reserved for future device types. You may find further information in the DIN EN 60929 standard.
Query power supply fault
Asks whether a fault in the power supply has occurred at the DALI device (DALI command 155dec).


Variables

Configuration software KS2000 [image] Settings [image] Setting up the DALI/DSI devices [image] Variables
Variables
The intelligence in the DALI system is not 100% centralized. This means that a large number of settings and light values are stored in the form of variables in the ballasts.
Click on Variables. A dialog mask in which you can inspect and edit the variables for the selected DALI device appears.
KS2000 - parameterization of the DALI/DSI devices - variables
Actual dim level
This variable contains the power currently applying to the lamp.
Power ON level
This variable specifies the lamp power that the DALI device is to adopt after the power supply has been switched on, if the DALI bus is already under power and is idle.
System failure level
This variable specifies the lamp power that the DALI device is to adopt in the event of a system error.
MIN level
You specify the minimum lamp power that the DALI device is to adopt here, so that the illuminance does not fall below a level that you want. The MIN value cannot be less than the smallest physically possible value specified by the manufacturer of the DALI device.
MAX level
You specify the maximum lamp power that the DALI device is to adopt here, so that the illuminance does not exceed a level that you want.
Fade rate
Enter the velocity in steps per second (step/s), with which the DALI device dims for 200 ms when the commands Brighter (DALI command 1dec) or Darker (DALI command 2dec) are issued. The absolute fade rate is not entered directly, but it is calculated according to the following formula:
T = absolute fade rate
n = value that is stored in the Fade rate variable
The following values result:
n | absolute fade rate
0 | Not permitted
1 | 357.796 steps/s
2 | 253.000 steps/s
3 | 178.898 steps/s
4 | 126.500 steps/s
5 | 89.449 steps/s
6 | 63.250 steps/s
7 | 44.725 steps/s
8 | 31.625 steps/s
9 | 22.362 steps/s
10 | 15.813 steps/s
11 | 11.181 steps/s
12 | 7.906 steps/s
13 | 5.591 steps/s
14 | 3.953 steps/s
15 | 2.795 steps/s
Fade time
Enter here the time in seconds that the DALI device is to take to change the brightness when, for instance, changing a scene, or to execute direct DALI commands for lamp power. This time is independent of the size of the change, so that all the lamps complete their change over the same period. In the case of a lamp that is switched off, the pre-heating and ignition time is not included in the fade time.
The absolute fade time is not entered directly, but it is calculated according to the following formula:
T = absolute fade time
n = value that is stored in the Fade time variable
The following values result:
n | absolute fade time
0 | < 0.707 s
1 | 0.707 s
2 | 1.000 s
3 | 1.414 s
4 | 2.000 s
5 | 2.828 s
6 | 4.000 s
7 | 5.657 s
8 | 8.000 s
9 | 11.314 s
10 | 16.000 s
11 | 22.627 s
12 | 32.000 s
13 | 45.255 s
14 | 64.000 s
15 | 90.510 s
Direct address
This variable contains the DALI device's short address. A valid short address lies in the range between 0dec and 63dec. If 255dec is written into the variable, the short address is deleted.
Status information
This variable can only be read. It contains the DALI device's status byte. The bits in the status byte have the following significance:
Bit | Name |  | Meaning
7 | Power supply fault | 0bin | No
6 | Missing short address | 0bin | No
5 | Reset status | 0bin | No
4 | Fading done | 0bin | Fading has been completed
 |  | 1bin | Fading in progress
3 | Limit value error | 0bin | The most recently requested lamp power value was between the MIN and MAX values, or was OFF.
2 | Lamp power | 0bin | OFF
 |  | 1bin | ON
1 | Lamp failure | 0bin | OK
0 | Status of the DALI device | 0bin | OK
Version number
Displays the DALI device's version number. This variable is entered by the device manufacturer, and can only be read!
Physical minimum level
Indicates the lowest physically possible lamp power that the DALI device can adopt. This variable is entered by the device manufacturer, and can only be read!


Groups

Configuration software KS2000 [image] Settings [image] Setting up the DALI/DSI devices [image] Groups
Groups
Click on Groups. The dialog mask for assigning the DALI device to a group appears.
In this dialog you can add each DALI device to up to 16 groups. If a DALI device receives a command associated with a group number for which the device has been parameterized, it will execute the command.
KS2000 - parameterization of the DALI/DSI devices - groups


Scenes

Configuration software KS2000 [image] Settings [image] Setting up the DALI/DSI devices [image] Scenes
Scenes
The light intensities for 16 different scenes can be stored at each DALI device through this mask. If a DALI device receives a scene number for which it has been parameterized (e.g. in the context of a broadcast), it will set the intensity specified for this scene. If the value 255 (mask) is specified for this scene, the DALI device retains its previous value.
KS2000 - parameterization of the DALI/DSI devices - scenes


Addressing the DALI devices

Configuration software KS2000 [image] Settings [image] Addressing the DALI devices
Addressing the DALI devices
Physical selection
KS2000 - addressing of the DALI device - physical selection
Do not interrupt the addressing process
The addressing procedure must not be interrupted by other DALI commands. Make sure of this by, for instance, interrupting your PLC program or the K-Bus cycle before starting the addressing.
Sequence of actions for physical addressing
1.
Click the Start button in order to begin the addressing procedure.
Addresses
If you have selected Complete new installation, all previous addresses will be deleted. Otherwise you can add further devices to the existing addressing scheme. If you have not selected Delete all group assignments, the assignment of addresses to groups is retained. Bear this in mind when reassign in the addresses!
2.
The following instruction now appears in the status line:
Wait for a device to be selected. Remove the lamp!
3.
After the lamp has been removed, the instruction that appears in the status line is as follows:
The device was addressed. Add the lamp again!
After reinserting the lamp, it flashes three times in order to indicate that the address assignment has been successful.
The newly addressed device is now shown in the list of short addresses.
4.
Repeat Point 2 and Point 3 for every DALI device that is to be re-addressed.
5.
When you have assigned all the addresses, complete the addressing procedure by clicking the Cancel button.
The newly addressed devices will be shown in the list of short addresses:
KS2000 - addressing of the DALI device - displaying the physical addressing
Random addressing
With this method, addresses are assigned randomly.
KS2000 - addressing of the DALI device - random addressing
The operator has no influence on the order of the address assignment. The order can, however, be modified retrospectively via the Modify addresses tab.
KS2000 - addressing the DALI devices - displaying the randomly assigned addresses
Single assignment
With this method, all DALI slaves connected to the KL6811 are assigned the same new address. In practice, only the one DALI slave, which is to be assigned this address, will therefore be connected, before the Start button is pressed.
KS2000 - addressing of the DALI devices - single assignment
Modify addresses
In the list on the right select the device, whose address you want to change. Via the New Address selection box you can select a new address for the selected device.
Once you have selected all new addresses, click on Start to allocate the addresses to the devices.
KS2000 - addressing of the DALI devices - Modify addresses
Visual selection feedback
If the option visual selection feedback is enabled, the selected device (in the example device #04) sets its current lamp power value to the parameterized maximum value.


Options

Configuration software KS2000 [image] Settings [image] Options
Options
This mask allows you to specify a variety of options for the KL6811.
KS2000 - Options for the KL6811
Operating mode (R32.12-15)
You can specify the KL6811 operating mode here:
▪
DALI: The KL6811 operates as a DALI master
▪
DSI: The KL6811 operates as a DSI master
Power supply unit (R32.3)
You can switch off the DALI/DSI power supply unit here.
Count DALI devices (R32.4)
Here you can disable the counting of the DALI devices after the KL6811 startup.
Firmware version (R9)
Displays the firmware version of the KL6811 .


Archive

Configuration software KS2000 [image] Settings [image] Archive
Archive
These masks provide clearly arranged tables to facilitate the following tasks for DALI slaves connected to the KL6811:
▪
specify association with 16 groups;
▪
specify the light values for 16 scenes.
Additional information
•
Groups
•
Scenes


Groups

Configuration software KS2000 [image] Settings [image] Archive [image] Groups
Groups
KS2000 - archive - groups
Here you specify the association for up to 16 groups (listed horizontally) for up to 64 DALI slaves (listed vertically).
The following entries are valid:
▪
1: DALI slave belongs to a group
▪
0: DALI slave does not belong to a group
In the example shown,
▪
DALI slave 1 is assigned to groups 7, 9 and 11;
▪
DALI slave 8 is assigned to groups 2, 8 and 10;
▪
DALI slave 18 is assigned to groups 2, 7, 8, 9, 10 and 11;
Visual selection feedback
If the option visual selection feedback is enabled and you click on a group number, the brightness of all DALI slaves of this group is set to maximum.
This also requires Online Monitoring to be enabled under Options in the KS2000, and the I/O Run LED on the Bus Coupler must be on.
Options
Options
Open
Opens a configuration stored on the hard disk of the PC (*.xml).
Save
Saves the configuration in a file (*.xml) on the hard disk of the PC.
Download
Saves the configuration in the connected DALI slaves.
Upload
Loads the configuration from the connected DALI slaves.


Scenes

Configuration software KS2000 [image] Settings [image] Archive [image] Scenes
Scenes
KS2000 - archive - scenes
Here you specify the light values for up to 16 scenes (listed horizontally) for up to 64 DALI slaves (listed vertically).
The following entries are valid:
▪
0 to 254: light values (0: off, 254: maximum brightness)
▪
255: Mask (on changing to the new scene, the slave retains its existing value).
In the example shown, for
▪
DALI slave 1 the light value 50 is assigned for scene 3, the light value 100 for scene 5, and the light value 250 for scene 10;
▪
DALI slave 8 the light value 200 is assigned for scene 4, the light value 150 for scene 6, and the light value 20 for scene 12;
▪
DALI slave 18 the light value 254 is assigned for scenes 3, 4, 5, 6, 10 and 12.
Visual selection feedback
If the option visual selection feedback is enabled and you click in the scene column, all DALI slaves for this scene are assigned the light values entered in this column.
This also requires Online Monitoring to be enabled under Options in the KS2000, and the I/O Run LED on the Bus Coupler must be on.


Process data

Configuration software KS2000 [image] Process data
Process data
The process data is represented graphically under ProcData.


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
In the process image, the KL6811 is represented with 3 bytes of input and output data. These are organized as follows:
Byte offset (without word alignment*) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | Status byte (SB) | Control byte (CB)
1 | 2 | Word | DataIN | DataOUT
*) Word alignment: The Bus Coupler places values on even byte addresses
Process data words in DALI mode
Process output word (DataOUT)
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Y | Address bits (A) |  |  |  |  |  | S | Command (X)
Legend
Bit | Name | Description
15 | Y | 0bin | Address bits 9 to 14 contain a DALI short address.
 |  | 1bin | Address bits 9 to 14 contain a DALI group address or a DALI collective call.
14 to 9 | Address bits (A) | 0bin | DALI short address, DALI group address or DALI collective call
8 | Selection bit (S) | 0bin | Bits 0 to 7 contain a lamp power value.
 |  | 1bin | Bits 0 to 7 contain a DALI command.
7 to 0 | Command (X) | Lamp power value or DALI command*
*) A list of DALI commands can be found in Chapter DALI commands.
Commands received by the DALI slaves
Please note that DALI slaves can only receive commands once their load side is supplied with power (230 V), since the PIC (single-chip micro-controller) of a DALI slave is typically supplied via the load voltage.
Process input word (DataIN)
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserved |  |  |  |  |  |  | OK | Parameter
Legend
Bit | Name | Description
15 to 9 | - | reserved
8 | OK | 0bin | Bits 0 to 7 do not contain valid data
 |  | 1bin | Bits 0 to 7 contain the valid response of a DALI slave
7 to 0 | Parameter | Response of a DALI slave
Process data words in DSI mode
Process output word (DataOUT)
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserved |  |  |  |  |  |  |  | DSI dimming value
Legend
Bit | Name | Description
15 to 8 | - | reserved
7 to 0 | DSI dimming value | Here you can specify the 8-bit dimming value for all DSI slaves.
Process input word (DataIN)
In DSI mode, the process input word has no function.
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | reserved


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Process data mode
Control byte in process data mode
The control byte (CB) is located in the output image, and is transmitted from the controller to the KL6811.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess |  | - | - | - | - | RepeatASC | Toggle
Legend
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | R/W | 0bin | Read access
CB.5 to CB.2 | - | reserved
CB.1 | RepeatASC | 0bin | The KL6811 does not repeat the application-related expansion commands (224dec-255dec) not.
 |  | 1bin | The KL6811 also repeats the application-related expansion commands (224dec-255dec).
CB.0 | Toggle | With each edge change of the toggle bit, the KL6811 sends a DALI or DSI telegram. The telegrams can be transmitted at intervals of 25 ms, i.e. within 100 ms the KL6811 can send a maximum of 4 telegrams. Depending on the content (with or without return channel), the duration of a DALI telegram cycle is between 25 and 43.34 ms. The end of a DALI telegram cycle is indicated by an edge of the toggle bit in the status byte (SB.0).
Status byte in process data mode
The status byte (SB) is located in the input image, and is transmitted from KL6811 to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | - | BC Collision | FC Collision | Toggle
Legend
Bit
Name
Description
SB.7
RegAccess
0bin
Acknowledgement for process data mode
SB.6
Error
0bin
No error
1bin
Error:
▪
In DALI mode if the internal DALI power supply unit of the KL6811 is used: overload of the internal DALI power supply unit of the KL6811 (bus under-voltage)
▪
In DSI mode: error message from one (or several) of the DSI devices
SB.5 to SB.3
-
reserved
SB.2
BC Collision (only in DALI
mode)
0bin
no collision
1bin
DALI collision detected on the backward channel: during the transfer of a DALI telegram, a collision with the send data of another DALI slave was detected. The bit SB.2 is reset with the next edge of the bit SB.0, unless another DALI collision has occurred.
SB.1
FC Collision (only in DALI
mode)
0bin
no collision
1bin
DALI collision detected on the forward channel: during the transfer of a DALI telegram, a collision with the send data of another DALI master was detected. The bit SB.1 is reset with the next edge of the bit SB.0, unless another DALI collision has occurred.
SB.0
Toggle
An edge of SB.0 is the acknowledgement for the end of the telegram cycle initiated with the toggle bit of the control byte (CB.0). The telegram was sent via the DALI/DSI bus. In DALI mode, the collision bit (SB.1) provides information about any collisions that may have occurred.
Register communication
Control byte for register communication
The control byte (CB) is located in the output image, and is transmitted from the controller to the KL6811.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter the number of the register that you want to - read with input data word 0 here. - write to with output data word 0.
SmallWarningYellow CAUTION
Invalid process data during register communication!
It is not possible to access the data registers during register communication! Process data that may still be displayed is not valid!
Status byte for register communication
The status byte (SB) is located in the input image, and is transmitted from KL6811 to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R | Reg. no.
Legend
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgement for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user program [image] Register overview
Register overview
Register | Comment | Default value |  | R/W | Memory
R0 | reserved | - | - | - | -
R1 | DALI-Slave-Counter | - | - | R | RAM
R2 to R5 | reserved | - | - | - | -
R6 | Diagnostic register | - | - | R | RAM
R7 | Command register | 0x0000 | 0dec | R/W | RAM
R8 | Terminal description | 0x1A9B | 6811dec | R | ROM
R9 | Firmware version | e.g. 0x3143 | e.g. 12611dec | R | ROM
R10 | Multiplex shift register | 0x0118 | 280dec | R | ROM
R11 | Signal channels | 0x0118 | 280dec | R | ROM
R12 | Minimum data length | 0x1818 | 6168dec | R | ROM
R13 | Data structure | 0x0000 | 0dec | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | - | - | R/W | RAM
R16 | Hardware version | e.g. 0x0000 | e.g. 0dec | R/W | SEEROM/RAM
R17 to R30 | reserved | - | - | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0000 | 0dec | R/W | SEEROM/RAM
R33 to R63 | reserved | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
R1: DALI-Slave-Counter
After the startup of the KL6811, the number of DALI slaves found is stored here. This function can be disabled with bit 4 of the feature register (R32.4).
R6: Diagnostic register
In a later firmware version, the diagnostic register will be used to provide diagnostic information about the state of the DALI master terminal.
R7: Command register
This register can be used to transfer commands to the DALI master terminal.
R8: Terminal description
Register R8 contains the terminal identifier in hexadecimal coding: 0x1A9B (6811dec)
R9: Firmware version
Register R9 contains the firmware revision level of the terminal in hexadecimal coding, e. g. 0x3144 (12612 dec).
R10: Shift register length
0x0118
R11: Number of signal channels
0x0118
R12: Minimum data length
0x1818
R13: Data type
Register R13 contains the data type of the Bus Terminal. 0x0004 represents a special function.
R15: Alignment register
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal in hexadecimal coding, e.g. 0x0000 (0dec).
User register
The user registers of the terminal can be written by the user program in order to change the characteristics of the terminal at run-time.
R31: Code word register
▪
If you write values into the user registers without previously having entered the user code word (0x1235) in the code word register, these values are only stored in the RAM registers, but not in the EPROM registers and are therefore lost if the terminal is restarted.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the EPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's operating mode.
Bit | Feature | Value | Explanation | Default
R32.15 R32.14 R32.13 R32.12 | Operation mode | 0000bin | DALI | 0000bin
 |  | 0001bin | DSI
 |  | further | reserved
R32.11 | - | - | reserved | 0bin
... | ... | ... | ... | ...
R32.5 | - | - | reserved | 0bin
R32.4 | Disable counting of DALI devices | 0bin | The DALI devices are not counted after the KL6811 startup. | 0bin
 |  | 1bin | After the KL6811 startup, the DALI devices are counted, and the result is stored in register 1 (R1).
R32.3 | Deactivation of the internal DALI power supply unit | 0bin | Supply of the DALI bus via the internal power supply unit of the KL6811. | 0bin
 |  | 1bin | Internal DALI power supply unit deactivated: an external DALI power supply unit is required.
R32.2 | - | - | reserved | 0bin
R32.1 | - | - | reserved | 0bin
R32.0 | - | - | reserved | 0bin


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Programming

Programming
Programming
Additional information
•
TwinCAT libraries


TwinCAT libraries

Programming [image] TwinCAT libraries
TwinCAT libraries
See software documentation in the Beckhoff Information System.
TwinCAT 2
Web: TwinCAT 2PLC Lib DALI
Local: TwinCAT 2 PLC Lib: DALI
TwinCAT 3
Web: TwinCAT 3 PLC Lib: Tc2 DALI
Local: TwinCAT 3 PLC Lib: Tc2 DALI


Appendix

Appendix
Appendix
Additional information
•
DALI commands
•
Bibliography
•
Support and Service


DALI commands

Appendix [image] DALI commands
DALI commands
In accordance with the DIN EN 60929 standard, addresses and commands are transmitted as numbers with a length of two bytes.
These commands take the form YAAA AAAS xxxx xxxx. Each letter here stands for one bit.
▪
Y: type of address
0bin: Short address
1bin: group address or collective call
▪
A: significant address bit
▪
S: selection bit (specifies the significance of the following eight bits):
0bin: the 8 xxxx xxxx bits contain a value for direct control of the lamp power
1bin: The 8 xxxx xxxx bits contain a command number.
x: a bit in the lamp power or in the command number
Direct DALI commands for lamp power
These commands take the form YAAA AAA0 xxxx xxxx.
xxxx xxxx: the value representing the lamp power is transmitted in these 8 bits. It is calculated according to this formula:
253 values from 1dec to 254dec are available for transmission in accordance with this formula.
There are also 2 direct DALI commands with special meanings:
Command | Command no. | Description | Answer
00hex | 0dec | The DALI device dims using the current fade time down to the parameterized MIN value, and then switches off. | -
FFhex | 254dec | Mask (no change): this value is ignored in what follows, and is therefore not loaded into memory. | -
Indirect DALI commands for lamp power
These commands take the form YAAA AAA1 xxxx xxxx.
xxxx xxxx: These 8 bits transfer the command number. The available command numbers are listed and explained in the following tables in hexadecimal and decimal formats.
Command | Command no. | Description | Answer
00hex | 0dec | Switch off lamp immediately (without fading). | -
01hex | 1dec | Turn brighter for 200 ms with selected step speed. | -
02hex | 2dec | Turn darker for 200 ms with selected step speed. | -
03hex | 3dec | Increase the current lamp power value by one step (without fading). If the lamp is switched off, it is not switched on. | -
04hex | 4dec | Reduce the current lamp power value by one step (without fading), if the lamp is not already at its parameterized minimum value. If the lamp is already at its minimum value, it is not changed and remains switched on. | -
05hex | 5dec | Set the current lamp power value to the parameterized maximum value. If the lamp is switched off, it is switched on. | -
06hex | 6dec | Set the current lamp power value to the parameterized minimum value. If the lamp was switched off, it is switched on. | -
07hex | 7dec | Reduce the current lamp power value by one step (without fading). If the lamp is already at its minimum value, it is switched off. | -
08hex | 8dec | Increase the current lamp power value by one step (without fading). If the lamp was switched off, it is switched on and set to its parameterized minimum value. | -
09hex ... 0Fhex | 9dec ... 15dec | reserved | -
1nhex (n: 0hex ... Fhex) | 16dec … 31dec | Set the lamp power value to the value stored for the specified scene (n). | -
Configuration commands
Command | Command no. | Description | Answer
20hex | 32dec | Reset all parameters to the delivery state. | -
21hex | 33dec | Save the current brightness value in the DTR (data transfer register). | -
22hex... 29hex | 34dec... 41dec | reserved | -
2Ahex | 42dec | Save the current DTR value as maximum lamp power value. | -
2Bhex | 43dec | Save the current DTR value as minimum lamp power value. | -
2Chex | 44dec | Save the current DTR value as fault condition lamp power value. | -
2Dhec | 45dec | Save the current DTR value as switch-on lamp power value. | -
2Ehex | 46dec | Save the current DTR value as step time. | -
2Fhex | 47dec | Save the current DTR value as step speed. | -
30hex ... 3Fhex | 48dec ... 63dec | reserved | -
4nhex (n: 0hex ... Fhex) | 64dec ... 79dec | Save the current DTR value as selected scene (n). | -
5nhex (n: 0hex ... F hex) | 80dec ... 95dec | Delete the selected scene (n) from the DALI slave. | -
6nhex (n: 0hex ... F hex) | 96dec ... 111dec | Add the DALI slave to the selected group (n). | -
7nhex (n: 0hex ... F hex) | 112dec ... 127dec | Delete the DALI slave from the selected group (n). | -
80hex | 128dec | Save the current DTR value as short address. | -
81hex ... 8Fhex | 129dec ... 143dec | reserved | -
90hex | 144dec | Return the state (XX) of the DALI slave. | XX
91hex | 145dec | Check whether the DALI slave is working. | yes/no
92hex | 146dec | Check whether a lamp has failed. | yes/no
93hex | 147dec | Check whether the power supply of the lamp is switched on. | yes/no
94hex | 148dec | Check whether the slave has received an invalid value. | yes/no
95hex | 149dec | Check whether the DALI slave is in reset state. | yes/no
96hex | 150dec | Check whether the DALI slave is missing a short address. | yes/no
97hex | 151dec | Return the version number (XX). | XX
98hex | 152dec | Return the content (XX) of the DTR. | XX
99hex | 153dec | Return the devices type (XX). | XX
9Ahex | 154dec | Return the physical minimum (XX). | XX
9Bhex | 155dec | Check whether there is a supply error at the DALI slave. | yes/no
9Chex ... 9Fhex | 156dec ... 159dec | reserved | -
A0hex | 160dec | Return the current lamp power value (XX). | XX
A1hex | 161dec | Returns the maximum permitted lamp power value (XX). | XX
A2hex | 162dec | Returns the minimum permitted lamp power value (XX). | XX
A3hex | 163dec | Returns the switch-on lamp power value (XX). | XX
A4hex | 164dec | Returns the fault condition lamp power value (XX). | XX
A5hex | 165dec | Returns the step speed (X) and the step speed (Y). | XY
A6hex ... AFhex | 166dec ... 175dec | reserved | -
Bnhex (n: 0hex ... Fhex) | 176dec ... 191dec | Returns the lamp power value (XX) for the specified scene (n). | XX
C0hex | 192dec | Returns a bit pattern, which indicates which group (0-7) the DALI slave belongs to. | XX
C1hex | 193dec | Returns a bit pattern, which indicates which group (8-15) the DALI slave belongs to. | XX
C2hex | 194dec | Returns the upper bits of the optional address (HH). | HH
C3hex | 195dec | Returns the middle bits of the optional address (MM). | MM
C4hex | 196dec | Returns the lower bits of the optional address (LL). | LL
C5hex ... DFhex | 197dec ... 223dec | reserved | -
E0hex ... FFhex | 224dec ... 255dec | Query of the application-related extended commands. |
Repetition of DALI commands
•
The DALI master terminal KL6811 automatically repeats the commands 32dec to 128dec, 258dec and 259dec (shown in bold) in order to save you having to call them again in the user program.
•
The DALI master terminal KL6811 also repeats the commands 224dec to 255dec, if this option is enabled with bit 1 of the control byte (CB.1).
Special commands
You may find the special commands and further information in the DIN EN 60929 standard.


Bibliography

Appendix [image] Bibliography
Bibliography
Books
▪
DALI manual published by DALI AG (DALI Activity Group, see http://www.dali-ag.org).
Standards
▪
DIN EN 60929: Standard for AC-supplied electronic ballasts for tubular fluorescent lamps (IEC 60929), Annex E.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com