KL6581, KL6583 - EnOcean Bus Terminal and Transceiver
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Translation


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
▪
Technical data updated
▪
Wiring updated
1.2.0
▪
Product overview updated
▪
Technical data updated
▪
Description of LED display updated
▪
KL6583-0100 Transceiver for 315 MHz added
1.1.0
Notes on the admissibility of EnOcean wireless technology added
1.0.0
First public issue
Firmware and hardware versions
Documentation Version | KL6581-0000 |  | KL6583-0000 |  | KL6583-0100
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
2.0.0 | B3 | 01 | B2 | 02 | B2 | 02
1.2.0 | B3 | 00 | B2 | 02 | B2 | 02
1.1.0 | B2 | 00 | B1 | 01 | - | -
1.0.0 | B1 | 00 | B1 | 00 | - | -
The firmware and hardware versions (delivery state) can be found in the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year
FF - firmware version
HH - hardware version
Example with ser. No.: 35 04 B1 00:
35 - week of production 35
04 - year of production 2004
B1 - firmware version B1
00 - hardware version 00


Translation

Foreword [image] Translation
Translation
Translation
This documentation has been prepared in German. All documents in other languages are derived from this. If you require a translation for a specific language, please contact Beckhoff Support.


Product overview

Product overview
Product overview
Additional information
•
KL6581-0000 - Introduction
•
KL6581-0000 - Technical data
•
KL6581-0000 - Diagnostic LEDs
•
KL6583 - Introduction
•
KL6583 - Technical Data
•
KL6583 diagnostic LEDs


KL6581-0000 - Introduction

Product overview [image] KL6581-0000 - Introduction
KL6581-0000 - Introduction
KL6581-0000 - EnOcean Master Terminal
The bidirectional EnOcean technology receives signals from battery-less sensors or transmits data to actuators. With a radio signal range of at least 30 m, the wiring of buildings can be simplified significantly. The KL6581 EnOcean master terminal is the link between the KL6583 EnOcean transceiver and the application. Up to eight KL6583 EnOcean transceivers may be connected to a KL6581 EnOcean master terminal. The EnOcean data are transmitted via the corresponding fieldbus system or the controller. The KL6583 EnOcean transceivers are connected to the KL6581 via two wires for the power supply and two wires for the data bus, which transmits the EnOcean telegrams. The maximum total length of the data bus is 500 m.
EnOcean GmbH
For more information about EnOcean, see .


KL6581-0000 - Technical data

Product overview [image] KL6581-0000 - Technical data
KL6581-0000 - Technical data
Technical data | KL6581-0000
Number of outputs | 1
Number of connectable KL6583s | 8
Transmission standard | CAN
CAN connection cable | Beckhoff ZB5100 (sold by the meter)
Permitted cable length from the KL6581 to the last KL6583 | maximum 500 m (line topology only)
Data transfer rate | 125 kbyte
Electrical isolation | 500 V (K-bus/CAN)
Power supply for the electronics | via the K-bus and through the power contacts
Current consumption from K-bus | typically 60 mA
Bit width in process image | Output: 12 bytes data, input: 12 bytes data
Weight | approx. 85 g
Dimensions (W x H x D) | approx. 15mm x 100mm x 70mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus


KL6581-0000 - Diagnostic LEDs

Product overview [image] KL6581-0000 - Diagnostic LEDs
KL6581-0000 - Diagnostic LEDs
The LEDs indicate the operating state of the KL6581-0000.
KL6581-0000 - Diagnostic LEDs
Meaning of the LED displays
LED | Color | State and significance
 |  | On | off | flashes briefly | flashes at 1-second intervals
K-Bus Run | green | Lit, either weakly or strongly: K-bus communication is OK | No K-bus communication | K-bus communication | -
Error | red | Fault occurred: see status bytes SB.1 to SB.6 for error description | No error | - | -
Send | green | Communication with the KL6583 works properly when the Send and Receive LEDs light up continuously. | - | Data are being sent to a KL6583. | If the Send and Receive LEDs flash at 1-second intervals, the communication with the KL6583 is faulty.
Receive | green |  | - | Data are being received from a KL6583.
Wiring check via LEDs
The wiring between the KL6581-0000 and the KL6583 devices is OK when
•
the Receive and Send LEDs of the KL6581-0000 light up continuously, and
•
LED 3 lights up continuously on all connected KL6583 devices.


KL6583 - Introduction

Product overview [image] KL6583 - Introduction
KL6583 - Introduction
KL6583 - EnOcean transceiver
The EnOcean transceivers enable sending and receiving of EnOcean data. The antenna is integrated in the transceivers.
Two versions are available:
▪
KL6583-0000 (868.35 MHz) with approval for the European Union and Switzerland
▪
KL6583-0100 (315 MHz) with approval for the USA and Canada
Note
Check the admissibility of the operation in your country
Permission for use in other countries must be clarified explicitly!
The KL6583 EnOcean transceivers can be operated in following countries without registration or fee:
•
KL6583-0000: European Union and Switzerland
•
KL6583-0100: USA and Canada (see KL6583-0100 for USA and Canada)
The transceivers are connected to the KL6581-0000 EnOcean master terminal via a bus connection and supplied from it with 24 V.
Up to eight KL6583 devices may be connected to one KL6581.
The maximum length of the data bus is 500 meters. The transceivers are addressed via an address selection switch.
Up to eight transceivers can be connected to one KL6581-0000.
The data is transferred from the transceivers to the KL6581-0000 via the CAN protocol and is therefore available to the higher-level controller.
EnOcean GmbH
For more information about EnOcean, see .


KL6583 - Technical Data

Product overview [image] KL6583 - Technical Data
KL6583 - Technical Data
Technical data | KL6583-0000 | KL6583-0100
Connection | 2 x 2-wire directly at the KL6581-0000 Bus Terminal
Transmission standard | CAN
CAN connection cable | Beckhoff ZB5100 (sold by the meter)
Permitted cable length from the KL6581 to the last KL6583 | maximum 500 m (line topology only)
Data transfer rate | 125 kbyte
Electrical isolation | none
Power supply for the electronics | from the power contacts of the KL6581 (24 VDC)
Current consumption from the power contacts of the KL6581-0000 | typical 20 mA (24 VDC)
Center frequency | 868.3 mHz | 315 MHz
Occupied frequency band | 868.0 … 868.6 MHz (600 kHz) | -
Maximum transmission power (permissible) | 25 mW e.r.p. | -
Transmission power | 2 mW (3 dBm) | -
Receiver category | 2 | -
Transfer range | 300 m in free field, 30 m in buildings
Radio telegram | depending on sensor type (32-bit sensor ID number, number of user bytes unlimited), sending and receiving
Antenna | integrated in the housing
Weight | approx. 90 g
Housing | round upper section for installation (ceiling/wall) with flange connection for main housing, upper section with cable opening; color: grey-white (RAL 9002)
Dimensions (W x H x D) | Height: 57 mm, Diameter: 72 mm (round upper section for installation); Diameter: 110 mm (main housing with flange connection)
Mounting | variable
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP40
Installation position | variable
Approval | CE | FCC
Permission for operation in | European Union and Switzerland | USA and Canada


KL6583 diagnostic LEDs

Product overview [image] KL6583 diagnostic LEDs
KL6583 diagnostic LEDs
The LEDs indicate the operating state of the KL6583.
KL6583 - Diagnostic LEDs
Meaning of the LED displays
LED
Color
State and significance
On
off
flashes
LED 1
green
24 V present
Power supply not connected
-
LED 2
green
-
No error (no EnOcean telegrams being sent)
Lights up briefly each time an EnOcean Frame is sent
LED 3
green
No error
-
▪
200 ms incorrect node address (valid addresses: 1 to 8)
▪
1 second no communication with the KL6581
▪
goes out briefly, EnOcean data being received or sent
Wiring check via LEDs
The wiring between the KL6581 and the KL6583 devices is OK when
•
the Receive and Send LEDs of the KL6581 light up continuously, and
•
LED 3 of all connected KL6583 devices lights up continuously.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Connection
•
Cabling between KL6581-0000 and KL6583


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Connection

Mounting and wiring [image] Connection [image] Connection
Connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
KL6581-0000 - Connection
Terminal point | No. | Connection for
CAN + (A) | 1 | A (CAN +)
+ 24 VDC | 2 | 24 V power contacts
GND | 3 | GND power contacts
Shield | 4 | Shield, internally connected with terminal point 6
CAN - (B) | 5 | B (CAN -)
+ 24 VDC | 6 | 24 V power contacts
GND | 7 | GND power contacts
Shield | 8 | Shield, internally connected with terminal point 4


Cabling between KL6581-0000 and KL6583

Mounting and wiring [image] Connection [image] Cabling between KL6581-0000 and KL6583
Cabling between KL6581-0000 and KL6583
Note
Cabling instructions:
•
The KL6583 must always be supplied with power from the KL6581-0000. Operation with any other power supply is not permissible!
•
The termination resistor must be switched on in the last device; set S1 and S2 to ON.
•
Use only the Beckhoff CAN cable with the order identifier ZB5100. Order quantity: in meters.
•
The total cable length (from the KL6581-0000 to the last KL6583) must not exceed 500 meters.
•
The topology is line; stubs may not be used.
•
The line must always begin with a KL6581-0000. The KL6581-0000 must not be installed within the line!
•
The maximum number of KL6583 devices that may be connected to a KL6581-0000 is eight.
Terminal points of the KL6583
Meaning | KL6581-0000 | KL6583 X1 or X2
CAN + | 1 | CAN +
CAN - | 5 | CAN -
24 V DC | 2 or 6 | 24 V
GND | 3 or 7 | GND
Node address KL6583
Setting the node address with switch S3
S3 is for setting the node address. Only one address may ever be used in the line (valid addresses: 1...8).
Termination resistor
The termination resistor must be activated in the last module!
To do this, both DIP switches S1 and S2 must be set to ON.
Termination resistor ON
Termination resistor OFF
Risk of confusion
The number ‘1’ on the DIP switch is only for numbering:
The ‘1’ does not mean ON.
If a switch is set to ‘1’ it is OFF!
Cabling example
KL6581-0000, KL6583 - cabling example


EnOcean

EnOcean
EnOcean
Additional information
•
EnOcean - overview
•
Range planning
•
Approval of EnOcean radio technology


EnOcean - overview

EnOcean [image] EnOcean - overview
EnOcean - overview
Technology
The EnOcean radio technology makes a far-reaching signal with low quantities of ambient energy possible. With 50 µWs, a standard EnOcean radio module can easily transmit a signal over a distance of 300 m (in the free field). The signal period for an EnOcean telegram is approx. 1 thousandth of second.
▪
License-free 868 MHz frequency band with 1% duty cycle
▪
Multiple telegram transmission with checksum
▪
Short telegrams (approx. 1 ms) lead to a small probability of collision
▪
Long range: 30 m inside buildings or 300 m in the free field
▪
Repeater available for extensions
▪
Unidirectional and bidirectional communication
▪
High data transmission rates of 125 kbit/s
▪
Low ‘data overhead’
▪
ASK modulation
▪
Radio protocol is defined and integrated in modules
▪
Sensor profiles specified and adhered to by users
▪
Unique transmission ID (32-bit)
▪
No interference with DECT, WLAN, PMR systems etc.
▪
System design verified in industrial environment
Protocol structure
Protocol | Description | Length
ORG | Telegram type | 1 Byte
DB_3 | Data byte 3 | 1 Byte
DB_2 | Data byte 2 | 1 Byte
DB_1 | Data byte 1 | 1 Byte
DB_0 | Data byte 0 | 1 Byte
ID_3 | Transmitter ID byte 3 | 1 Byte
ID_2 | Transmitter ID byte 2 | 1 Byte
ID_1 | Transmitter ID byte 1 | 1 Byte
ID_0 | Transmitter ID byte 0 | 1 Byte
STATUS | Information status | 1 Byte


Range planning

EnOcean [image] Range planning
Range planning
Please follow the recommendations of the EnOcean Alliance (see www.enocean.org) when placing the EnOcean devices. Adherence to the recommendations is conducive to an optimum range and high noise immunity.
Attenuation of different materials
Material | Attenuation
Wood, plaster, uncoated glass (without metal) | 0...10 %
Brick, chipboard | 5...35 %
Concrete with iron reinforcement | 10...90 %
Metal, aluminum cladding | 90..100 %
Range
Material | Range
Line of sight | Typically 30 m in corridors, up to 100 m in halls
Plasterboard walls/wood | Typically 30 m, through max. 5 walls
Brick walls/aerated concrete | Typically 20 m, through max. 3 walls
Reinforced concrete walls/ceilings | Typically 10 m, through max. 1 wall/ceiling
Placement of the KL6583 module
The KL6583 module contains transmitter, receiver and antenna.
Distances
The distance to a reinforced concrete ceiling should be at least 50 cm and to a wall 10 cm.
Do not attach or screw the KL6583 module to a metal plate!
Environmental conditions
Furthermore, the environmental conditions are to be adhered to:
▪
Maximum air humidity 95% no condensation
▪
Ambient temperature 0...55 °C


Approval of EnOcean radio technology

EnOcean [image] Approval of EnOcean radio technology
Approval of EnOcean radio technology
Note
Check the admissibility of the operation in your country
Permission for use in other countries must be clarified explicitly!
The KL6583 EnOcean transceivers can be operated in following countries without registration or fee:
•
KL6583-0000: European Union and Switzerland
•
KL6583-0100: USA and Canada
KL6583-0100 for USA and Canada
Contains IC: 5731A-TCM320C
Contains FCC ID: SZV-TCM320C
The enclosed device complies with part15 of the FCC Rules.
Operation is subject to the following conditions:
▪
( i.) this device may not cause harmful interference and
▪
(ii.) this device must accept any interference received,
including interference that may cause undesired operation.


Programming

Programming
Programming
Additional information
•
TwinCAT libraries
•
Operation with other controllers


TwinCAT libraries

Programming [image] TwinCAT libraries
TwinCAT libraries
Software documentation in the Beckhoff Information System:
TwinCAT 2: TwinCAT 2 PLC Lib: EIB
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_EIB


Operation with other controllers

Programming [image] Operation with other controllers
Operation with other controllers
Additional information
•
Process image
•
Mapping
•
KL6581-0000 - control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Programming [image] Operation with other controllers [image] Process image
Process image
The KL6581 is represented in the process image with 12 bytes of input data and 12 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Format | Input data | Output data
0 | Byte | Status byte (SB1) | Control byte (CB1)
1 | Byte | CNODE | CNODE
2 | Byte | ORG | ORG
3 | Byte | DB0 | DB0
4 | Byte | DB1 | DB1
5 | Byte | DB2 | DB2
6 | Byte | DB3 | DB3
7 | Byte | ID0 | ID0
8 | Byte | ID1 | ID1
9 | Byte | ID2 | ID2
10 | Byte | ID3 | ID3
11 | Byte | STATUS | STATUS
CNODE
Bit | CNODE.7 | CNODE.6 | CNODE.5 | CNODE.4 | CNODE.3 | CNODE.2 | CNODE.1 | CNODE.0
Name | Message Type | Reserve | Reserve | Reserve | Module addr. 3 | Module addr. 2 | Module addr. 1 | Module addr. 0
Message Type:
▪
FALSE Radio Message
▪
TRUE Modul Massage
▪
See documentation for TCM120, available for download from www.enocean.de.
Module address 1-8, node number of the KL6583


Mapping

Programming [image] Operation with other controllers [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions) such as
–
Intel or Motorola format
–
word alignment switched on or off
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.
Complete evaluation
For complete evaluation, the analog input terminals occupy addresses in the input and output process image. Control and status bytes can be accessed. The terminal always occupies 12 bytes of input data and 12 bytes of output data. The KL6583 itself does not occupy any K-bus data, since it is addressed via the process data of the KL6581.
Complete evaluation
 | Address | Input data |  | Output data
Requirements | Word offset | High-Byte | Low-Byte | High-Byte | Low-Byte
Complete evaluation: any Motorola format: any Word alignment: any | 0 | CNODE | SB | CNODE | CB
 | 1 | DB0 | ORG | DB0 | ORG
 | 2 | DB2 | DB1 | DB2 | DB1
 | 3 | ID0 | DB3 | ID0 | DB3
 | 4 | ID2 | ID1 | ID2 | ID1
 | 5 | STATUS | ID3 | STATUS | ID3
Key
Complete evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the word address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.
SB : Status byte (appears in the input process image)
CB : Control byte (appears in the output process image)


KL6581-0000 - control and status byte

Programming [image] Operation with other controllers [image] KL6581-0000 - control and status byte
KL6581-0000 - control and status byte
Process data mode
Control byte in process data mode
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal. In process data mode it has no function.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | Addr Conflict | - | Buffer Full | RxC | TxC
Key
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | Error | 0bin | General error bit
CB.5 | - | 1bin | Reserve
CB.4 | Addr Conflict | 1bin | Address of a KL6583 doubly assigned
CB.3 | - | 1bin | Reserve
CB.2 | Buffer Full | 1bin | The internal data buffer has overflowed
CB.1 | RxC | 1bin | Toggle for the reception of data; if RxS <> RxC, then new data is present; toggling the bit signals to the terminal that the data have been fetched.
CB.0 | TxC | 1bin | Toggle for sending data; if TxC <> TxS, then data are transmitted from the KL6851 to the KL6853.
Status byte in process data mode
The status byte (SB) is located in the input image, and is transmitted from the terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Config Missmatch | Addr Conflict | Communication Error | Buffer Full | RxS | TxS
Key
Bit | Name | Description
SB.7 | RegAccess | 0bin | Acknowledgment for process data mode
SB.6 | Error | 1bin | General error bit
SB.5 | Config Missmatch | 1bin | Configuration error: Check the number of configured and connected KL6583 devices and their addresses. (see note below)
Enable display of ConfigMissmatch
The status bit SB.5 shows configuration errors once you have enabled the display by resetting bit R34.15 in the feature register.
Bit | Name | Description
SB.4 | AddrConflict | 1bin | Address of a KL6583 doubly assigned
SB.3 | Communication Error | 0bin | Communication OK
 |  | 1bin | The KL6581 has not found a KL6583 that is ready for operation. Check the cabling and the addresses.
SB.2 | Buffer Full | 1bin | The internal data buffer has overflowed,
SB.1 | RxS | 1bin | Toggle for the reception of data; if RxS <> RxC, then new data is present; toggling the bit signals to the terminal that the data have been fetched.
SB.0 | TxS | 1bin | Toggle for sending data; if TxC <> TxS, then data are transmitted from the KL6851 to the KL6853.
Register communication
Control byte for register communication
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIN1 or - want to write with output data word DataOUT1.
Status byte for register communication
The status byte (SB) is located in the input image, and is transmitted from the terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgment for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Programming [image] Operation with other controllers [image] Register overview
Register overview
The registers are used to parameterize the terminal. They can be read or written by means of register communication.
Register no. | Comment | Default value |  | R/W | Memory
R0 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R3 | reserved | 0x0000 | 0dec | - | -
R4 | Selection of the register page | 0x0000 | 0dec | R/W | ROM
R5 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R7 | reserved | 0x0000 | 0dec | - | -
R8 | Terminal type | 0x19B5 | 6581dec | R | ROM
R9 | Firmware version | e.g. 0xB100 |  | R | ROM
R10 | Multiplex shift register | 0x0160 | 352dec | R | ROM
R11 | Signal channels | 0x0160 | 352dec | R | ROM
R12 | minimum data length of a channel | 0x6060 | 24672dec | R | ROM
R13 | Data structure | 0x0000 | 0dec | R | ROM
R14 | reserved | 0x0000 | 0dec | - | -
R15 | Alignment register | typically 0x7F80 | typically 32640dec | R/W | RAM
R16 | reserved | 0x0000 | 0dec | - | -
R17 | internal use | typically 0x0000 | typically 0dec | R | EEPROM
R18 | reserved | 0x0000 | 0dec | R | EEPROM
R19 | reserved | 0x0000 | 0dec | R | EEPROM
R20 | reserved for internal use | 0x0001 | 1dec | R | EEPROM
R21 | reserved for internal use | 0x0500 | 1280dec | R | EEPROM
R22 | reserved for internal use | 0x0000 | 0dec | R | EEPROM
R23 | reserved for internal use | 0x00FF | 255dec | R | EEPROM
R24 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R30 | reserved | 0x0000 | 0dec | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | EEPROM
R32 | Register to show the register pages (see register 4) | variable | variable | R | RAM
... | ... | ... | ... | ... | ...
R63 | Register to show the register pages (see register 4) | variable | variable | R | RAM
Register page 1
Register no. | Comment | Default value |  | R/W | Memory
R32 | KL6583 found modules | variable | variable | R | RAM
R33 | Number of found modules | variable | variable | - | RAM
R34 | Feature register | 0x0000 | 0dec | R/W | RAM
R35 | reserved | 0x0000 | 0dec | - | -
... | ... | ... | ... | ... | ...
R63 | reserved | 0x0000 | 0dec | - | -
Register page 2
Register no. | Comment | Default value |  | R/W | Memory
R32/33 | EnOcean ID of the KL6583 with CAN address 1 | variable | variable | R | RAM
... | ... | ... | ... | ... | ...
R36/47 | EnOcean ID of the KL6583 with CAN address 8 | variable | variable | R | RAM
R48 | Firmware version of the KL6583 with CAN address 1 | variable | variable | R | RAM
... | ... | ... | ... | ... | ...
R55 | Firmware version of the KL6583 with CAN address 8 | variable | variable | R | RAM
R56 | Status of the KL6583 with CAN address 1 | variable | variable | - | RAM
... | ... | ... | ... | ... | ...
R63 | Status of the KL6583 with CAN address 8 | variable | variable | - | RAM


Register description

Programming [image] Operation with other controllers [image] Register description
Register description
The registers are used to parameterize the terminal. They can be read or written by means of register communication.
R4: Register page selection (read/write)
The KL6581-0000 has two register pages via which registers 32 to 63 can be addressed.
Using register 4, select which register page 32 to 63 is to be shown. Valid values:
0: Register page 1
1: Register page 2
R8: Terminal type
Register R8 contains the ID for the terminal module.
KL6581-0000: 0x19B5 (6581dec)
R9: Firmware version
Register R9 contains the firmware version of the terminal, e.g. 0xB100 = 'B1'.
This value cannot be changed.
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
Register page 1
R32: KL6583 found modules (read only)
If the bit is set, then a corresponding module has been found.
Example:
0x0001 only one module with CAN address 1 found.
0x0005 two modules with CAN address 1 and 3 found.
0x00FF eight KL6583 found from address 1 to 8
R33: Number of KL6583 modules (read only)
Number of KL6853 modules found. Maximum 8.
R34: Feature register
The feature register specifies a variety of properties for the terminal.
Bit | Feature | Value | Explanation | Default
R34.15 | EnableDisplay ConfigMissmatch | 0bin | The status bit SB5 does not show configuration errors. | 0bin
 |  | 1bin | The status bit SB5 shows configuration errors.
R34.14 | - | reserved |  | 0bin
... | ... | ... |  | ...
R34.0 | - | reserved |  | 0bin
Register page 2
R32/R33 to R46/R47: EnOcean IDs of the connected KL6583
R32/R33: EnOcean ID of the KL6583 with CAN address 1 (read only)
R34/R35: EnOcean ID of the KL6583 with CAN address 2 (read only)
R36/R37: EnOcean ID of the KL6583 with CAN address 3 (read only)
R38/R39: EnOcean ID of the KL6583 with CAN address 4 (read only)
R40/R41: EnOcean ID of the KL6583 with CAN address 5 (read only)
R42/R43: EnOcean ID of the KL6583 with CAN address 6 (read only)
R44/R45: EnOcean ID of the KL6583 with CAN address 7 (read only)
R46/R47: EnOcean ID of the KL6583 with CAN address 8 (read only)
R48 to R55: Firmware versions the connected KL6583
R48: Firmware version of the KL6583 with CAN address 1 (read only)
R49: Firmware version of the KL6583 with CAN address 2 (read only)
R50: Firmware version of the KL6583 with CAN address 3 (read only)
R51: Firmware version of the KL6583 with CAN address 4 (read only)
R52: Firmware version of the KL6583 with CAN address 5 (read only)
R53: Firmware version of the KL6583 with CAN address 6 (read only)
R54: Firmware version of the KL6583 with CAN address 7 (read only)
R55: Firmware version of the KL6583 with CAN address 8 (read only)
R56: State of the KL6583 with the CAN address 1 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R57: State of the KL6583 with the CAN address 2 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R58: State of the KL6583 with the CAN address 3 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R59: State of the KL6583 with the CAN address 4 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R60: State of the KL6583 with the CAN address 5 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R61: State of the KL6583 with the CAN address 6 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R62: State of the KL6583 with the CAN address 7 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)
R63: State of the KL6583 with the CAN address 8 (read only)
0: does not exist
8: KL6583 is in operational state (in data exchange)


Examples of Register Communication

Programming [image] Operation with other controllers [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Programming [image] Operation with other controllers [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Programming [image] Operation with other controllers [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com