KL6401 - LON Bus Terminal
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.0.0
▪
Migration
1.3.0
▪
Programming description moved to the Beckhoff Information System
▪
TwinCAT library TcLON (formerly TcKL6401) updated to version 2.2.0
▪
ATEX notes added
1.2.0
▪
TwinCAT library TcKL6401 updated to version 1.004.000
1.1.0
▪
Mounting description expanded
▪
Files updated:
- TwinCAT library
- XML file of SNVT types for KS2000 configuration software
1.0.0
First release
Firmware and hardware versions
Documentation Version | KL6401
 | Firmware | Hardware
2.0.0 | B1 | 04
1.3.0 | B1 | 02
1.2.0 | B1 | 01
1.1.0 | B1 | 01
1.0.0 | B1 | 00
The firmware and hardware versions (delivery state) can be found in the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year
FF - firmware version
HH - hardware version
Example with ser. No.: 35 04 B1 00:
35 - week of production 35
04 - year of production 2004
B1 - firmware version B1
00 - hardware version 00


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Diagnostic LEDs
•
Technical data


Introduction

Product overview [image] Introduction
Introduction
KL6401
The LON Bus Terminal KL6401 connects the LON bus system to the Beckhoff Bus Terminal system.
The KL6401 permits a maximum of 62 network variables (SNVT) to be configured. These 62 SNVTs can be configured as any mixture of inputs and/or outputs.
Configuration of the SNVTs is performed using the KS2000 configuration software. The KS2000 configuration software is required for the configuration and operation of the KL6401. You also require a LON tool (e.g. Echelon LonMaker) to perform the binding of the SNVTs involved. Beckhoff does not offer a LON tool.
Software required for use of the KL6401
1.
KS2000 configuration software to configure the network variables
2.
A LON tool to bind the network variables
3.
TwinCAT PLC and an appropriate library to communicate with the KL6401 from the application.
Note
Support for KL6401
The KL6401 is only supported in connection with the TwinCAT library for the LON Bus Terminal!
If the KL6401 is used under a control system other than TwinCAT, Bus Couplers (BC) are not supported. In this case a Bus Terminal controller (BC or BX) would be required!
Without TwinCAT PLC, the KL6401 is not supported at an Embedded PC (CX)!


Diagnostic LEDs

Product overview [image] Diagnostic LEDs
Diagnostic LEDs
The LEDs indicate the operating state of the KL6401.
LEDs
Meaning of the LED displays
LED | Color | Channel | State and significance
 |  |  | On | off | flashes
K-Bus Run | green | 1 | Lit, either weakly or strongly: K-bus communication is OK | No K-bus communication | K-bus communication
Error 1 | red |  | Hardware error | No error | -
LON service/status | red |  | Service PIN enabled or error in the LON controller | KL6401 commissioned and in operation | KL6401 not commissioned and not operational
LON ICom | green |  | Lit, either weakly or strongly: LON communication is OK | No LON communication | LON communication
Error 2 | red |  | LON error | No error | -


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL6401
Number of outputs | 1
Network variables | 62 max.
Transmission standard | FTT-10/LPT
Data transfer rate | 78 kbyte
Electrical isolation | 500 V (K-bus/LON)
Power supply for the electronics | via the K-bus and through the power contacts
Current consumption from the K-bus | typically 55 mA
Bit width in process image | Output: 36 bytes data, input: 36 bytes data
Weight | approx. 85 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection
•
Connection
•
Installation instructions for enhanced mechanical load capacity
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the ELxxxx and KLxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Note
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Connection

Mounting and wiring [image] Connection
Connection
Connection
Terminal point | No. | Connection for
Service | 1 | Service PIN
+ 24 VDC | 2 | 24 V supply voltage
0 V | 3 | Ground
LON | 4 | LON communication
Service | 5 | Service PIN
+ 24 VDC | 6 | 24 V supply voltage
0 V | 7 | Ground
LON | 8 | LON communication
Note
Service PINs
The service PINs (terminal points 2 and 6 or 3 and 7) only operate when 24 V is being supplied via the power contacts.
Note
Neuron ID via broadcast
Short circuiting terminal points 1 and 5 (rising edge) causes the KL6401 to broadcast its Neuron ID.


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Note
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


LON

LON
LON
Additional information
•
LON - Overview
•
Supported SNVTs
•
Principle of operation


LON - Overview

LON [image] LON - Overview
LON - Overview
LON - Overview
Each LON device provides network variables (SNVTs) for communication with other devices. The required variables are selected based on the device documentation or the Xif file (machine-readable representation of all SNVTs used) and entered in the KL6401 via the KS2000 configuration software. The KS2000 can now be used to create another Xif file. In this case, import both Xif files with a LON configuration tool (not offered by Beckhoff) and link them. For more information, see the documentation for the LON configuration tool.
For each SNVT entered in the KL6401, a suitable function block has to be programmed on the PLC side. These function blocks can then be used to access the SNVTs of the devices.


Supported SNVTs

LON [image] Supported SNVTs
Supported SNVTs
General information on SNVTs can be found online under http://types.lonmark.org/.
The KL6401 supports the following SNVTs (LonMark data types).
SNVT ID | SNVT NAME | Description | Additional information
1 | SNVT_amp | Electric current (ampere) |
2 | SNVT_amp_mil | Electric current (milliampere) |
3 | SNVT_angle | Angular distance (radian) |
4 | SNVT_angle_vel | Angular velocity (radian / second) |
5 | SNVT_btu_kilo | Thermal energy (kiloBtu) |
6 | SNVT_btu_mega | Thermal energy (megaBtu) |
7 | SNVT_char_ascii | ASCII character (8-bit ASCII character) |
8 | SNVT_count | Absolute number (items) |
9 | SNVT_count_inc | Increment counter (items(delta)) |
10 | SNVT_date_cal |  | SNVT outdated, not implemented
11 | SNVT_date_day | Day of the week |
12 | SNVT_date_time |  | SNVT outdated, not implemented
13 | SNVT_elec_kwh | Electric energy (kW/h) |
14 | SNVT_elec_whr | Electric energy (W/h) |
15 | SNVT_flow | Volume flow (liters / second) |
16 | SNVT_flow_mil | Volume flow (milliliters / second) |
17 | SNVT_length | Length (meter) |
18 | SNVT_length_kilo | Length (kilometer) |
19 | SNVT_length_micr | Length (micrometer) |
20 | SNVT_length_mil | Length (millimeter) |
21 | SNVT_lev_cont | Continuous change in value (% from maximum level) |
22 | SNVT_lev_disc |  | SNVT outdated, not implemented
23 | SNVT_mass | Mass (gram) |
24 | SNVT_mass_kilo | Mass (kilogram) |
25 | SNVT_mass_mega | Mass (metric ton) |
26 | SNVT_mass_mil | Mass (milligram) |
27 | SNVT_power | Power (watt) |
28 | SNVT_power_kilo | Power (kilowatt) |
29 | SNVT_ppm | Concentration (ppm) |
30 | SNVT_press | Pressure (overpressure) (kilopascal) |
31 | SNVT_res | Electric resistance (ohm) |
32 | SNVT_res_kilo | Electric resistance (kiloohm) |
33 | SNVT_sound_db | Sound pressure level (dB) |
34 | SNVT_speed | Linear velocity (meters / second) |
35 | SNVT_speed_mil | Linear velocity (millimeters / second) |
36 | SNVT_str_asc | String |
37 | SNVT_str_int | Wide Character String |
38 | SNVT_telcom | Telephone status (telephone status name) |
39 | SNVT_temp | Temperature (°C) |
40 | SNVT_time_passed |  | SNVT outdated, not implemented
SNVT ID | SNVT NAME | Description | Additional information
41 | SNVT_vol | Volume (liter) |
42 | SNVT_vol_kilo | Volume (kiloliter) |
43 | SNVT_vol_mil | Volume (milliliter) |
44 | SNVT_volt | Electrical voltage (volt) |
45 | SNVT_volt_dbmv | Electrical voltage (dB microvolt) |
46 | SNVT_volt_kilo | Electrical voltage (kilovolt) |
47 | SNVT_volt_mil | Electrical voltage (millivolt) |
48 | SNVT_amp_f | Electric current (ampere) |
49 | SNVT_angle_f | Angular distance (radian) |
50 | SNVT_angle_vel_f | Angular velocity (radian / second) |
51 | SNVT_count_f | Absolute number (items) |
52 | SNVT_count_inc_f | Increment counter (items(delta)) |
53 | SNVT_flow_f | Volume flow (liters / second) |
54 | SNVT_length_f | Length (meter) |
55 | SNVT_lev_cont_f | Continuous change in value (% from maximum level) |
56 | SNVT_mass_f | Mass (gram) |
57 | SNVT_power_f | Power (watt) |
58 | SNVT_ppm_f | Concentration (ppm) |
59 | SNVT_press_f | Pressure (overpressure) (pascal) |
60 | SNVT_res_f | Electric resistance (ohm) |
61 | SNVT_sound_db_f | Sound pressure level (dBspl) |
62 | SNVT_speed_f | Linear velocity (meters / second) |
63 | SNVT_temp_f | Temperature (°C) |
64 | SNVT_time_f | Elapsed time (seconds) |
65 | SNVT_vol_f | Volume (liter) |
66 | SNVT_volt_f | Electrical voltage (volt) |
67 | SNVT_btu_f | Thermal energy (Btu) |
68 | SNVT_elec_whr_f | Electric energy (Watt / hour) |
69 | SNVT_config_src | Configuration properties |
70 | SNVT_color | Color according to CIE standard |
71 | SNVT_grammage | American measure for paper weight and density |
72 | SNVT_grammage_f | American measure for paper weight and density |
73 | SNVT_file_req | File request | In preparation, please do not use for the time being.
74 | SNVT_file_status | File information |
SNVT ID | SNVT NAME | Description | Additional information
75 | SNVT_freq_f | Frequency (hertz) |
76 | SNVT_freq_hz | Frequency (hertz) |
77 | SNVT_freq_kilohz | Frequency (kilohertz) |
78 | SNVT_freq_milhz | Frequency (millihertz) |
79 | SNVT_lux | Illuminance (lux) |
80 | SNVT_ISO_7811 |  | SNVT outdated, not implemented
81 | SNVT_lev_percent | Percentage value |
82 | SNVT_multiplier | Multiplier |
83 | SNVT_state | Status information |
84 | SNVT_time_stamp | Time stamp |
85 | SNVT_zerospan | Zero point and proportionality factor |
86 | SNVT_magcard | ISO 7811 (40 hexadecimal numbers) |
87 | SNVT_elapsed_tm | Elapsed time |
88 | SNVT_alarm | Alarm status |
89 | SNVT_currency | Currency |
90 | SNVT_file_pos | File position |
91 | SNVT_muldiv | Gain factor/attenuation factor |
92 | SNVT_obj_request | Function selection |
93 | SNVT_obj_status | Object status |
94 | SNVT_preset | Preliminary setting |
95 | SNVT_switch | Switch |
96 | SNVT_trans_table | Conversion table |
97 | SNVT_override | Override mode |
98 | SNVT_pwr_fact | Power factor |
99 | SNVT_pwr_fact_f | Power factor |
100 | SNVT_density | Density (kg/m³) |
101 | SNVT_density_f | Density (kg/m³) |
102 | SNVT_rpm | Angular velocity (revolutions/minute (RPM)) |
103 | SNVT_hvac_emerg | HVAC emergency mode |
104 | SNVT_angle_deg | Angle indication |
105 | SNVT_temp_p | Temperature (°C) |
106 | SNVT_temp_setpt | Temperature (6 temperature values) |
107 | SNVT_time_sec | Elapsed time (second) |
108 | SNVT_hvac_mode | HVAC operating mode |
109 | SNVT_occupancy | Occupancy signal (states) |
110 | SNVT_area | Area (square meter) |
111 | SNVT_hvac_overid | HVAC override mode |
112 | SNVT_hvac_status | HVAC status |
113 | SNVT_press_p | Pressure (overpressure) (pascal) |
SNVT ID | SNVT NAME | Description | Additional information
114 | SNVT_address | Neuron address |
115 | SNVT_scene | Scenes |
116 | SNVT_scene_cfg | Scene setting |
117 | SNVT_setting | Settings |
118 | SNVT_evap_state | Evaporator status |
119 | SNVT_therm_mode | Thermostat mode |
120 | SNVT_defr_mode | Defrost mode |
121 | SNVT_defr_term | Completion of the defrost cycle |
122 | SNVT_defr_state | Defrost status (enumeration) |
123 | SNVT_time_min | Elapsed time (minutes) |
124 | SNVT_time_hour | Elapsed time (hour) |
125 | SNVT_ph | Acidity (pH) |
126 | SNVT_ph_f | Acidity (pH) |
127 | SNVT_chlr_status | Refrigeration unit status |
128 | SNVT_tod_event | Presence time |
129 | SNVT_smo_obscur | Darkening due to smoke |
130 | SNVT_fire_test | Request fire alarm system test |
131 | SNVT_temp_ror | Value of the temperature change/increase |
132 | SNVT_fire_init | Fire detector type |
133 | SNVT_fire_indcte | Fire alarm display |
134 | SNVT_time_zone | Time zone description |
135 | SNVT_earth_pos | Position on Earth |
136 | SNVT_reg_val | Register value |
137 | SNVT_reg_val_ts | Register value |
138 | SNVT_volt_ac | Alternating voltage (Volt AC) |
139 | SNVT_amp_ac | Alternating current |
143 | SNVT_turbidity | Turbidity |
144 | SNVT_turbidity_f | Turbidity |
145 | SNVT_hvac_type | HVAC plant type |
146 | SNVT_elec_kwh_l | Electric energy (kW / hour) |
147 | SNVT_temp_diff_p | Temperature difference (°C) |
148 | SNVT_ctrl_req | Control request |
149 | SNVT_ctrl_resp | Control response |
150 | SNVT_ptz | Camera PTZ (SNZ) |
151 | SNVT_privacyzone | Private zone |
152 | SNVT_pos_ctrl | Position setting for cameras in networks |
153 | SNVT_enthalpy | Enthalpy (kilojoules/kg) |
SNVT ID | SNVT NAME | Description | Additional information
154 | SNVT_gfci_status | Residual current circuit breaker status |
155 | SNVT_motor_state | Motor status (motor status designation) |
156 | SNVT_pumpset_mn | Pump group |
157 | SNVT_ex_control | Exclusive control |
158 | SNVT_pumpset_sn | Pump group sensor |
159 | SNVT_pump_sensor | Pump sensor |
160 | SNVT_abs_humid | Absolute humidity |
161 | SNVT_flow_p | Volume flow (cubic meters / hour) |
162 | SNVT_dev_c_mode | Device operating mode |
163 | SNVT_valve_mode | Valve state |
164 | SNVT_alarm_2 | Alarm status 2 |
165 | SNVT_state_64 | Status information (64 individual bit values) |
166 | SNVT_nv_type | Network variable type |
168 | SNVT_ent_opmode | Operating mode for access objects |
169 | SNVT_ent_state | State for access objects |
170 | SNVT_ent_status | Status of access objects |
171 | SNVT_flow_dir | Flow direction |
172 | SNVT_hvac_satsts | HVAC saturation status |
173 | SNVT_dev_status | Device status |
174 | SNVT_dev_fault | Error state |
175 | SNVT_dev_maint | Device maintenance status |
176 | SNVT_date_event | Event status |
177 | SNVT_sched_val | Calendar value |
178 | SNVT_sec_state |  | SNVT outdated, not implemented
179 | SNVT_sec_status |  | SNVT outdated, not implemented
180 | SNVT_sblnd_state | Blind status |
181 | SNVT_rac_ctrl | Sound function control |
182 | SNVT_rac_req | Sound function request |
183 | SNVT_count_32 | Absolute counter |
184 | SNVT_clothes_w_c | Washing machine / commands |
185 | SNVT_clothes_w_m | Washing machine /management status |
186 | SNVT_clothes_w_s | Washing machine / status |
187 | SNVT_clothes_w_a | Washing machine / alarm messages |
188 | SNVT_multiplier_s | Multiplier |
189 | SNVT_switch_2 | Switch for setting scenes and settings. |
SNVT ID | SNVT NAME | Description | Additional information
190 | SNVT_color_2 | Color |
191 | SNVT_log_status | Log status |
192 | SNVT_time_stamp_p | Precise time stamp |
193 | SNVT_log_fx_request | Log file transfer request |
194 | SNVT_log_fx_status | Log file transfer status |
195 | SNVT_log_request | Log status request |
196 | SNVT_enthalpy_d | Enthalpy difference (kJ/kg) |
197 | SNVT_amp_ac_mil | Electric current (milliampere) |
198 | SNVT_time_hour_p | Time in hours |
199 | SNVT_lamp_status | Lamp status |
200 | SNVT_environment | Environment |
201 | SNVT_geo_loc | Geographical location |


Principle of operation

LON [image] Principle of operation
Principle of operation
Sending
The KL6401 sends single SNVT variables. This means that an SNVT variable sent to the KL6401 is sent to the LON network individually. Only when this has successfully been sent can the next SNVT variable be transferred to the KL6401.
Receiving
The KL6401 has 2 buffers, the telegram buffer and the index buffer.
The input variables of a LON telegram that has been received are placed in the telegram buffer. The index number of the incoming telegram is also entered into the index buffer.
The TwinCAT LON function block evaluates the index buffer, transfers input variables that have been received to the application program, and removes them from the index buffer. If the function block does not read the data out of the telegram buffer quickly enough, it can save up to 62 entries (i.e. the maximum number of SNVT variables).
If a telegram that has already been received (which the function block has not yet transferred to the application program, and which therefore still has an entry in the index buffer) is received from the KL6401 again, then a new entry is not made in the index buffer, but the input variables in the telegram buffer are updated.


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Configuration with KS2000
•
SNVT variables (OFF)


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Configuration with KS2000

KS2000 Configuration Software [image] Configuration with KS2000
Configuration with KS2000
Commissioning procedure
1.
Install the configuration software KS2000, version 4.3.0.39 or higher.
2.
Plug the KL6401 into your Bus Coupler, and terminate the K-Bus with a KL9010.
3.
Log on. Should the dialog box Create new XML Device Files open, you should cancel the procedure at this point.
Canceling Create new XML Device Files
The terminal can now be configured under Settings [image].
Configuration of the KL6401
Enter the SNVTs in the table [image]. Use [image] to add a variable and [image] to remove a selected variable.
The Id column cannot be edited. It contains the NV index. This index is also required as input variable wNVIndex for the PLC function blocks (see TwinCAT Information System).
In column Nv Name any text can be entered. These descriptions are required in the LON configuration tool (not provided by Beckhoff) for identifying the respective variables.
Select the required SNVT in column SNVT Type.
Column Dir (Direction) indicates whether the variable is sent (out) or received (in).
Set a project name (click on PROJECT NAME).
Then edit the program ID (Prog ID) [image] . Do this by clicking Program ID, and selecting a Program ID. This program ID may only be issued once in your LON project. A maximum of 256 (0-255) program IDs can be used. This means that you can use 256 different configurations in one project.
NOTE: LON terminals with the same configuration also have the same program ID.
Use the button [image] to create the Xif file. This file is required in the LON configuration tool (not provided by Beckhoff).
Use the button [image] to save the configuration in a BLC file. This file can be used to load the configuration if a terminal is replaced or to use the same configuration in another terminal.
The data can now be written to the terminal. Use the buttons [>>>] or [<<<] to select the required slot and then the button WRITE to write the data to the terminal. The slot may not be activated (green) during this process.
NOTE regarding the slots: The terminal is supplied with slot 0 active (factory setting). This slot contains a fixed configuration and cannot be modified. To transfer other values a different slot has to be configured and activated. Only one slot at a time is active.
The project must be activated after the download has successfully been completed. Use the button SET ACTIVE PROJECT. Power must now be removed from the KL6401. After switching on the KL6401 (switching the power supply on again) the desired configuration is active.
Description of the editing functions
Deletes the table
Opens an existing SNVT configuration file (*.BLC) for the KL6401
Saves the current configuration as a BLC file
Edits an SNVT variable
Inserts an SNVT variable
Deletes an SNVT variable
Creates an XIF file for a LON configuration tool (not provided by Beckhoff)
Opens the Help
Info


SNVT variables (OFF)

KS2000 Configuration Software [image] SNVT variables (OFF)
SNVT variables (OFF)
XIF file ( )
KS2000 BLC file ( )
Implemented SNVT variables (KL6401_0FF)
Description | INPUT/OUTPUT | SNVT ID | Length | NV ID
nviSwitch00 | INPUT | 95 | 2 | 0
nviSwitch01 | INPUT | 95 | 2 | 1
nviSwitch02 | INPUT | 95 | 2 | 2
nviSwitch03 | INPUT | 95 | 2 | 3
nviSwitch04 | INPUT | 95 | 2 | 4
nviSwitch05 | INPUT | 95 | 2 | 5
nviSwitch06 | INPUT | 95 | 2 | 6
nviSwitch07 | INPUT | 95 | 2 | 7
nviSwitch08 | INPUT | 95 | 2 | 8
nviSwitch09 | INPUT | 95 | 2 | 9
nviSwitch10 | INPUT | 95 | 2 | 10
nviSwitch11 | INPUT | 95 | 2 | 11
nviSetting0 | INPUT | 117 | 4 | 12
nviSetting1 | INPUT | 117 | 4 | 13
nviSetting2 | INPUT | 117 | 4 | 14
nviSetting3 | INPUT | 117 | 4 | 15
nviTemp0 | INPUT | 105 | 2 | 16
nviTemp1 | INPUT | 105 | 2 | 17
nviTemp2 | INPUT | 105 | 2 | 18
nviTemp3 | INPUT | 105 | 2 | 19
nviTemp4 | INPUT | 105 | 2 | 20
nviHvacStatus0 | INPUT | 112 | 12 | 21
nviHvacStatus1 | INPUT | 112 | 12 | 22
nviHvacStatus2 | INPUT | 112 | 12 | 23
nviHvacStatus3 | INPUT | 112 | 12 | 24
nviHvacStatus4 | INPUT | 112 | 12 | 25
nvoSwitch00 | OUTPUT | 95 | 2 | 26
nvoSwitch01 | OUTPUT | 95 | 2 | 27
nvoSwitch02 | OUTPUT | 95 | 2 | 28
nvoSwitch03 | OUTPUT | 95 | 2 | 29
nvoSwitch04 | OUTPUT | 95 | 2 | 30
nvoSwitch05 | OUTPUT | 95 | 2 | 31
nvoSwitch06 | OUTPUT | 95 | 2 | 32
nvoSwitch07 | OUTPUT | 95 | 2 | 33
nvoSwitch08 | OUTPUT | 95 | 2 | 34
Description | INPUT/OUTPUT | SNVT ID | Length | NV ID
nvoSwitch09 | OUTPUT | 95 | 2 | 35
nvoSwitch10 | OUTPUT | 95 | 2 | 36
nvoSwitch11 | OUTPUT | 95 | 2 | 37
nvoSwitch12 | OUTPUT | 95 | 2 | 38
nvoSwitch13 | OUTPUT | 95 | 2 | 39
nvoSwitch14 | OUTPUT | 95 | 2 | 40
nvoSwitch15 | OUTPUT | 95 | 2 | 41
nvoSwitch16 | OUTPUT | 95 | 2 | 42
nvoSwitch17 | OUTPUT | 95 | 2 | 43
nvoSetting0 | OUTPUT | 117 | 4 | 44
nvoSetting1 | OUTPUT | 117 | 4 | 45
nvoSetting2 | OUTPUT | 117 | 4 | 46
nvoSetting3 | OUTPUT | 117 | 4 | 47
nvoLevP0 | OUTPUT | 81 | 2 | 48
nvoLevP1 | OUTPUT | 81 | 2 | 49
nvoLevP2 | OUTPUT | 81 | 2 | 50
nvoLevP3 | OUTPUT | 81 | 2 | 51
nvoLevP4 | OUTPUT | 81 | 2 | 52
nvoHvacMode0 | OUTPUT | 108 | 1 | 53
nvoHvacMode1 | OUTPUT | 108 | 1 | 54
nvoHvacMode2 | OUTPUT | 108 | 1 | 55
nvoHvacMode3 | OUTPUT | 108 | 1 | 56
nvoHvacMode4 | OUTPUT | 108 | 1 | 57


Programming

Programming
Programming
Additional information
•
TwinCAT libraries


TwinCAT libraries

Programming [image] TwinCAT libraries
TwinCAT libraries
Software documentation in the Beckhoff Information System:
TwinCAT 2: TwinCAT 2 PLC Lib: LON
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_LON


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com