KL62x1, KL952x - AS-i terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.5.0
▪
Chapter on Mounting rail installation updated
▪
Notes about Firmware Version of the Bus Couplers updated
▪
Description of the AS-i string parameters added (AS-i string parameters are supported from firmware version BA)
▪
Description of the AS-i command interface updated
▪
Description of the AS-i settings via KS2000 updated
▪
Mounting instructions updated
1.4
▪
Description of the KL6211 AS-i master terminal with power contacts added
▪
Description of the KL9520 AS-i potential feed terminal with filter added
▪
Mounting instructions for AS-i master terminals added
▪
Minor routine corrections (typing errors, spelling, etc.)
1.3
▪
Description of the acknowledgement to the AS-i command interface (AS-i parameter 0x100) extended
▪
Description of the process image updated and 6-byte process image added
▪
Description of the KL6201 operation under PROFIBUS updated
▪
Description of the KL6201 operation under CANopen updated
▪
Notes about Firmware Version of the Bus Couplers updated
1.2
▪
up to 62 AS-i slaves are now supported directly in the process image
▪
analog AS-i slaves are supported
▪
Description of KL6201 parameterization via KS2000 software added
▪
Description of the AS-i parameters revised
▪
Description of KL6201 operation under PROFIBUS updated
▪
Description of KL6201 operation under CANopen updated
▪
Description of the KL9528 AS-i power supply terminal added
1.1
▪
up to 62 AS-i slaves are supported (32 directly in the process image, a further 32 via parameter access)
▪
ID code 1 and 2 are now read during start-up
▪
during short-circuiting of the SET inputs, ID codes 1 and 2 are also saved
1.0
▪
Complete revision
▪
Description of KL6201 operation under CANopen added
0.9
▪
First preliminary version: Description of the KL6201 operation under PROFIBUS
Firmware and hardware versions
Documentation version | KL6201 |  | KL6211
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | D0 | 0I | D6 | 0J
1.5.0 | BA | 0D | BA | 0D
1.4 | B9 | 09 | B9 | 09
1.3 | B7 | 09 | - | -
1.2 | B4 | 09 | - | -
1.1 | B1-FE | 05 | - | -
1.0 | B0 | 04 | - | -
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 06 B9 09:
12 - week of production 12
06 - year of production 2006
B9 - Firmware version B9
09 - hardware version 09


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Functionality of the AS-i master
•
Commissioning instructions
•
KL9528: AS-i Power Supply Terminal
•
KL9520: AS-i potential feed terminal with filter


Introduction

Product overview [image] Introduction
Introduction
KL6201, KL6211
The AS Interface master terminal enables the direct connection of AS-i slaves. The AS-i compliant interface supports digital and analog slaves, versions 2.0 and 2.1. Process data exchange, parameterization and the diagnosis are fieldbus-independent. Together with the different Bus Couplers available from BECKHOFF, the KL6201 represents a universal fieldbus/AS-i gateway.
The size of the process image can be set to 6 bytes, 12 bytes (default), 22 bytes or 38 bytes, as required.
Since the usual register interface (with 64 registers per terminal or channel) is not sufficient for transferring all the information of the AS-i master terminal (terminal registers and AS-i parameters), a parameter interface was defined that can be accessed cyclically (via the process image) or acyclically (via fieldbus-specific acyclic services).


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL6201 | KL6211
AS-i channels | 1
AS-i versions | Automatic support of version 2.0 and version 2.1 (master profile M3)
Number of AS-i slaves | Version 2.0: 31 Version 2.1: 62
AS-i slave types | Digital or analog (conversion of analog data in the KL6201)
Diagnostics | Power failure, slave failure, parameterization fault
AS-i address assignment | via configuration or automatic
Cycle time | max. 5 ms (31 devices), 10 ms (62 devices)
Connection | 2 lines via spring force technology
Electrical isolation | 500 V (AS-Interface / K-bus)
Current consumption from K-bus | typ. 55 mA
Current consumption from the AS-Interface | typ. 60 mA
K-bus bit width | selectable: 12 bytes, 22 bytes, 38 bytes, of which 6 bytes represent the parameter interface, the rest represent the process data interface
Configuration | via fieldbus parameter interface, DP-V1 or Bus Coupler via Configuration software KS2000
Weight | approx. 55 g
Permissible ambient temperature during operation | 0 °C ... +55 °C (see chapter Installation positions) 0°C ... +55°C (ATEX) | 0 °C ... +55 °C (see chapter Installation positions)
Permissible ambient temperature during storage | -25°C ... +85°C
Permissible relative humidity | 95% no condensation
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 see also installation instructions for enhanced mechanical load capacity
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | optimum installation position (see chapter Installation positions)
Approval | CE, cULus, ATEX | CE, cULus


Functionality of the AS-i master

Product overview [image] Functionality of the AS-i master
Functionality of the AS-i master
Additional information
•
AS-i status machine
•
Lists
•
Operation modes
•
Details of the operating phases
•
Address assignment of the AS-i slaves
•
Automatic project design


AS-i status machine

Product overview [image] Functionality of the AS-i master [image] AS-i status machine
AS-i status machine
First, an overview of the status machine is provided. Details of the individual operating phases can be found below.
Status machine overview
Initialization
Offline phase: During initialization, there is no AS-i data traffic.
Start-up
Detection phase
In this phase the AS-i master initially looks for existing slaves, irrespective of whether or not they are currently projected. This phase is only exited once at least one slave has been found.
Activation phase
During this phase, the slaves that were found are activated depending on the operation mode:
▪
protected mode: All detected and currently projected slaves are activated, if the I/O ID and ID code of the detected slaves match the currently projected data.
▪
configuration mode: All detected slaves are activated by the master.
Normal operation
Data exchange phase
Cyclic data exchange between the AS-i master and the activated slaves.
Management phase
At the end of a cycle, the AS-i master enters the management phase, during which it can send a command to a specific slave (if required).
Inclusion phase
The AS-i master then enters the inclusion phase, during which it sends a command to a free slave address, in order to detect new slaves. If there is no response, the master immediately starts the next data exchange phase.


Lists

Product overview [image] Functionality of the AS-i master [image] Lists
Lists
Lists of the AS-i slaves in configuration and protected mode
LDS - list of detected slaves
This lists all slaves that physically exist in the network, have a valid address and were detected by the master.
LPS - list of currently projected slaves
This list comprises all slaves that the master expects to find in the network. In protected mode, the master only communicates with these slaves and issues a message as soon as additional slaves are detected, or if slaves are missing from this list.
LAS - list of activated slaves
All slaves with which the master communicates. In protected mode, this list corresponds to the LPS, in configuration mode it corresponds to the LDS.


Operation modes

Product overview [image] Functionality of the AS-i master [image] Operation modes
Operation modes
Protected Mode
In protected mode, only the AS-i slaves that are entered in the LPS are activated. Furthermore, their configuration (I/O ID and ID codes) must match the currently projected configuration comprising the parameters
- 0x40 to 0x47 (currently projected I/O IDs) or
- 0x48 to 0x4F (currently projected ID codes)
- 0xE0 to 0xE7 (currently projected extended ID codes 1) and
- 0xE8 to 0xEF (currently projected extended ID codes 2),
if verification of I/O ID or ID codes is enabled in parameters 0x60 to 0x61 or 0x68 to 0x69, 0x70 to 0x71 and 0x78 to 0x79.
Automatic addressing is possible, if I/O ID and ID code verification is enabled for all AS-i slaves listed in the LPS, and if precisely one currently projected AS-i slave is missing.
Configuration Mode
In configuration mode, all AS-i slaves that are found are activated. Automatic addressing is possible, with the next free address being assigned when a slave with address 0 is found. An AS-i address can also be set manually via the parameter 0x100 (AS-i command interface). All AS-i slaves that were found can be projected by setting the set input or via the parameter 0x108 (general command interface). In this case, the
▪
the corresponding I/O IDs and ID codes are entered in parameters 0x40 to 0x47 (currently projected I/O IDs) or 0x48 to 0x4F, 0xE0 to 0xE7 and 0xE8 to 0xEF (currently projected ID codes) and
▪
verification in parameters 0x60 to 0x61 (I/O IDs) or 0x68 to 0x69, 0x70 to 0x71 and 0x78 to 0x79 (ID codes) is enabled.


Details of the operating phases

Product overview [image] Functionality of the AS-i master [image] Details of the operating phases
Details of the operating phases
Offline
After power-on, the AS-i master goes into offline mode, i.e. there is no communication with the AS-i slaves.
During normal operation, the AS-i master can be put into offline mode (OFFLINE-flag is set) via the process data. The output data of all activated AS-i slaves are set to default value 1bin, and the input data of all activated AS-i slaves are set to default value 0bin. The AS-i master is then in offline mode and will send no further AS-i commands.
As soon as the OFFLINE flag is no longer set, the AS-i master copies the new list of currently projected slaves from parameters 0x58 and 0x59 to parameters 0xA8 and 0xA9 (LPS) and automatically returns to the detection phase. If an AS-i slave in the list of currently projected slaves (LPS) is activated, the AS-i master operates in protected mode (PRJ_ACTIVE flag is set in the process data ), otherwise it operates in configuration mode (PRJ_ACTIVE flag is reset in the process data).
Start-up
Detection phase
During the detection phase the I/O ID and ID codes of all AS-i slaves are queried and entered in parameters
- 0x90 to 0x97 (read I/O IDs) or
- 0x98 to 0x9F (read ID codes),
- 0xD0 to 0xD7 (read extended ID codes 1) and
- 0xD8 to 0xDF (read extended ID codes 2).
All AS-i slaves that were found are entered in the list of detected AS-i slaves (LDS, parameters 0xB0 and 0xB1). The AS-i master will only enter the activation phase once at least one slave was detected or found.
Activation phase
In protected mode, the AS-i master activates only the projected AS-i slaves from the list of currently projected slaves (LPS, parameters 0xA8 and 0xA9).
In configuration mode, all AS-i slaves that were found during the detection phase are activated. To this end, the AS-i master sends a parameterization request (activation parameter, parameters 0x50 to 0x57) and a data request (with default values 1bin as outputs). All activated slaves are entered in the list of activated slaves (LAS, parameters 0xB8 and 0xB9). Once all AS-i slaves have been processed, the AS-i master automatically enters the data exchange phase.
Normal operation
Data exchange phase
During the data exchange phase, the AS-i master exchanges data with each activated AS-i slave. If an AS-i slave does not respond in three consecutive data exchange phases, it is removed from the LAS and the LDS, and its inputs are set to the default value 0bin. Once a data cycle has been completed with all activated AS-i slaves, the AS-i master enters the management phase.
Management phase
During the management phase, an AS-i command is sent if an operating address is to be set via automatic address programming, or if an AS-i command was requested via the AS-i command interface (parameter 0x100). Otherwise the AS-i master enters the inclusion phase without issuing an AS-i command.
Inclusion phase
During the inclusion phase, only one command is sent. The system will attempt to find and activate new AS-i slaves, and the respective status is updated accordingly. The steps are the same as during the recognition or activation phase, except that they are now distributed over up to seven cycles.


Address assignment of the AS-i slaves

Product overview [image] Functionality of the AS-i master [image] Address assignment of the AS-i slaves
Address assignment of the AS-i slaves
Address assignment can be done via the AS-i master or via an addressing device. AS-i slaves are usually supplied with address 0. Slaves that were added later are searched under this address, and an address is then assigned. Address 0 is not permitted during the data exchange phase.
For AS-i Specification 2.1 slaves, addresses 33 to 63 are also permitted (AS-i slave address 32 is not permitted).
Normal address assignment
New AS-i slaves usually have address 0. An addressing call command can be triggered via the parameter 0x100 (AS-i command interface). However, the addressing call command only works if precisely one AS-i slave with address 0 is connected to the bus.
Automatic address assignment
Automatic address assignment has to be enabled with bit 6.1 of the output data.
Configuration Mode
In configuration mode, the next free address is automatically assigned if a slave with address 0 is found.
Protected Mode
In protected mode, an AS-i slave with address 0 is automatically programmed with its new address, if precisely one currently projected AS-i slave is missing, and if no other not currently projected AS-i slave is present at the bus. This enables a (no longer functioning) AS-i slave to be exchanged during operation.


Automatic project design

Product overview [image] Functionality of the AS-i master [image] Automatic project design
Automatic project design
The currently detected slaves (from the LDS) can automatically be projected via SET or via the parameter 0x108 (general command interface).


Commissioning instructions

Product overview [image] Commissioning instructions
Commissioning instructions
The following steps enable rapid commissioning of an AS-i network with the KL6201/KL6211 AS-i master terminal:
1.
Address the AS-i slaves.
2.
Connect the AS-i slaves to the KL6201/KL6211.
3.
In delivery state the KL6201/KL6211 is set to the 12-byte process image, which supports direct access to the process data of AS-i slaves 1 to 11. A larger process image is required for direct access to further AS-i addresses.
4.
Note
Enabling process data communication
For enabling process data communication, set bit 3 in the AS-i command nibble (ASI CN in byte 6) to 1bin.
Example for the 12-byte process image:
Parameter data block |  |  |  |  |  | Process data block
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut 0 | ParaOut1 | ParaOut2 | ParaOut3 | ASI CN + ASI Out Slave 1 | ASI Out Slave 2+3 | ASI Out Slave 4+5 | ASI Out Slave 6+7 | ASI Out Slave 8+9 | ASI Out Slave 10+11
0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x00 | 0x8p | 0xpp | 0xpp | 0xpp | 0xpp | 0xpp
Key
ASI CN: AS-i command nibble
p: process data nibbles (outputs) for the respective AS-i slaves
CB n: control byte n
Para Out n: Output parameter, byte n
5. Once the AS-i cycle is completed, the KL6201/KL6211 responds with the input data (delayed by one or several cycles, depending on the higher-level fieldbus system).
Note
Short-circuiting the two set inputs is not necessary for operation
Short-circuiting of the two set inputs is not required for operation. During the commissioning phase this would in fact be a hindrance, since the KL6201/KL6211 would then only include those AS-i slaves in the data exchange that were found during short-circuiting of the set inputs.


KL9528: AS-i Power Supply Terminal

Product overview [image] KL9528: AS-i Power Supply Terminal
KL9528: AS-i Power Supply Terminal
KL9528
The KL9528 power supply terminal generates a 30 VDC output voltage from the 24 VDC control voltage for operating an AS-i network. The output voltage is high-frequency decoupled, short-circuit-proof and limited to a current of 1.3 A. There is no electrical isolation between the input voltage and the output voltage.
The connection to the KL6211 AS-i master terminal is established by the power contacts during side-by-side plugging.
The KL6201 AS-i master terminal must be connected via cable bridges.
LEDs
LED | Meaning
AS-i power (green) | off | AS-i voltage is switched off.
 | on | AS-i voltage is switched on.
Error (red) | off | KL9528 OK
 | on | An error (e.g. undervoltage, overload) has occurred.
Technical data
Technical data |  | KL9528
Short-circuit strength |  | yes, restart after enable via rising edge of output bit 0
Input voltage |  | 21 to 28.8 VDC
Output voltage |  | 30 VDC (± 5%)
Output current |  | max. 1.25 A
Short circuit current limit |  | max. 1.3 A
Efficiency |  | approx. 95% (at nominal load)
Bit width in process image |  | 2 input bits, 2 output bits (see KL9528 process image)
Current consumption from K-bus |  | typ. 10 mA
AS interface current consumption |  | approx. 60 mA
Isolation voltage | input / output voltage | none
 | AS-i / K-bus | 1500 VAC (permanently)
Weight |  | app. 150 g
Permissible ambient temperature during operation |  | 0°C... +55°C
Permissible ambient temperature during storage |  | -25°C ... +85°C
Permissible relative humidity |  | 95 %, no condensation
Mounting |  | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27 see also installation instructions for enhanced mechanical load capacity
EMC resistance burst / ESD |  | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class |  | IP20
Installation position |  | variable
Approval |  | CE
Note
Mapping of the KL6201 and KL9528
Please note the following for addressing (mapping) of the KL6201 and KL9528:
- The KL6201 AS-i master terminal is a byte-oriented terminal!
- The KL9528 AS-i power supply terminal is a byte-orientated terminal.
The Bus Terminals are always mapped in the following order in the Bus Coupler:
- First, all byte-oriented Bus Terminals appear in the process image in the order they were connected.
- Then, all bit-oriented Bus Terminals appear in the process image in the order they were connected.
This means that the KL6201 and KL9528 do not necessarily follow each other in the process image, even if they are connected side by side!
KL9528 process image
Input data
Bit | Value | Name | Meaning
1 and 0 | 00bin | OK | No error
 | 01bin | Overload | Due to an AS-i overload, the KL9528 has switched off the voltage. It can be switched on again with a leading edge of output bit 0. If the overload is still present, the KL9528 is switched off again.
 | 10bin | reserved | -
 | 11bin | Under- voltage | The KL9528 has switched off the AS-i voltage, because the input voltage had fallen below 21 V. As soon as the input voltage rises above 21 V, the KL9526 automatically switches the AS-i voltage back on.
Output data
Bit | Meaning
0 | After a switch-off due to overload, a rising edge of this bit switches the AS-i voltage back on.
1 | reserved


KL9520: AS-i potential feed terminal with filter

Product overview [image] KL9520: AS-i potential feed terminal with filter
KL9520: AS-i potential feed terminal with filter
KL9520
The KL9520 enables AS-i networks to be supplied from standard power supply units or another AS-Interface network. The combination of KL9520 and AS-i master terminal can be repeated several times in a Bus Terminal block, thereby saving several AS-i power supply units.
The KL9520 potential feed terminal decouples the input and output voltage through an integrated filter. There is no short-circuit protection and no electrical isolation between the input voltage and the output voltage!
The connection to the KL6211 AS-i master terminal is established by the power contacts during side-by-side plugging.
The KL6201 AS-i master terminal must be connected via cable bridges.
LEDs
LED | Meaning
Power (green) | off | AS-i voltage is switched off.
 | on | AS-i voltage is switched on.
Technical data
Technical data |  | KL9520
Input voltage |  | up to 35 VDC
Output voltage |  | up to 35 VDC
Input current |  | max. 2 A
Output current |  | max. 2 A (not short-circuit-proof)
Current consumption from K-bus |  | 0 mA
Isolation voltage | AS-i / K-bus | 1500 VAC (permanently)
 | input / output voltage | none
Configuration |  | no address or configuration settings required
Bit width in process image |  | 0 input bits, 0 output bits
Weight |  | app. 90 g
Permissible ambient temperature during operation |  | 0°C ... +55°C
Permissible ambient temperature during storage |  | -25°C ... +85°C
Permissible relative humidity |  | 95 %, no condensation
Vibration / shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27 see also installation instructions for enhanced mechanical load capacity
EMC resistance burst / ESD |  | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class |  | IP20
Installation position |  | variable
Approval |  | CE


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Installation positions
•
Installation instructions for enhanced mechanical load capacity
•
AS-i installation
•
Connection system
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Attention
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


AS-i installation

Mounting and wiring [image] AS-i installation
AS-i installation
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Connection of the AS interface
Connection of the AS interface
Terminal | Use
Mode 1, Mode 2 | Reserved for future functional extensions.
ASi+ | ASi+ connection (brown). Both terminal points identified with ASi+ are connected internally.
ASi- | ASi- connection (blue). Both terminal points identified with ASi- are connected internally.
Set 1, Set 2 | The detected slaves from the list of detected slaves (LDS) can be projected for protected mode by short-circuiting the two set inputs. This corresponds to the functionality of parameter 0x108 (command interface), if the value 0x0210 is entered there.
Wiring of the AS interface
Wiring of the AS interface
Since the user data are modulated on the power supply line with the AS-Interface, a special AS-i power supply unit (30.5 VDC) is required. You can
▪
use the KL9528 AS-i power supply terminal with integrated data decoupling or
▪
the KL9520 AS-i potential feed terminal in conjunction with a standard power supply units.


Connection system

Mounting and wiring [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Note
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Note
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Configuration of the KL6201/KL6211
•
Register
•
KS2000 Settings
•
KS2000 - AS-i settings
•
KS2000 - AS-i system overview
•
KS2000 - AS-i slave parameters
•
Process data


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Configuration of the KL6201/KL6211

KS2000 Configuration Software [image] Configuration of the KL6201/KL6211
Configuration of the KL6201/KL6211
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Ethernet Coupler
▪
a KL9528 AS-i power supply terminal (double overall width)
▪
a KL6201 AS-i Master Terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 1 in the example).
KS2000 branches for channel 1 of the KL6201
For the KL6201/KL6211, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL6201/KL6211 registers.
▪
Dialog masks for the parameterization of the KL6201/KL6211 can be found under Settings.
▪
ProcData shows the process data of the KL6201/KL6211.


Register

KS2000 Configuration Software [image] Register
Register
Under Register you can directly access the registers of the KL6201/KL6211. The meaning of the register is explained in the register overview.
Register view in KS2000
The screenshot shows the registers of the KL6201.


KS2000 Settings

KS2000 Configuration Software [image] KS2000 Settings
KS2000 Settings
The dialog masks for parameterizing the KL6201/KL6211 and AS-i slaves connected to it can be found under Settings.
Settings for the KL6201 in the KS2000 configuration software
Settings
Under this tab you can change the settings of the KL6201/KL6211 and the connected AS-i slaves.
System overview
Select this tab for checking the projecting state of the connected AS-i slaves.
Slave parameters
Select this tab for modifying the Parameters of the connected AS-i slaves.


KS2000 - AS-i settings

KS2000 Configuration Software [image] KS2000 - AS-i settings
KS2000 - AS-i settings
Under this tab you can change the settings of the KL6201/KL6211 and the connected AS-i slaves.
KS2000 - AS-i settings
Process image
Here you can select the size of the process image of the KL6201/KL6211. It is stored in register R27 of the KL6201/KL6211.
▪
6-byte AS-i parameter interface = 6-byte process image:
no direct access to the process data of the AS-i slaves! The process data access must take place via the AS-i parameters 0x80 to 0x87 (digital slaves) or 0x204 to 0x27F (analog slaves).
▪
6-byte AS-i parameter interface + 6-byte AS-i process data (11 slaves) = 12-byte process image:
supports direct access to the process data of AS-i slaves 1 to 11 (default).
▪
6-byte AS-i parameter interface + 16-byte AS-i process data (32 slaves) = 22-byte process image:
supports direct access to the process data of AS-i slaves 1 to 21.
▪
6-byte AS-i parameter interface + 32-byte AS-i process data (64 slaves) = 38-byte process image:
supports direct access to the process data of AS-i slaves 1 to 31 and 33 (1B) to 63 (31B)
After changing the process image the Bus Coupler must be restarted for the modified process image to take effect.
Please refer to chapter Bus Coupler firmware version to ascertain whether your Bus Coupler/Bus Terminal Controller supports the required KL6201/KL6211 process image.
Offline phase
This checkbox can be used to switch the KL6201/KL6211 to the offline phase. The setting is transferred with bit 2 of the AS-i command nibble.
Actions
project all detected slaves:
When this button is pressed, the KL6201/KL6211 reconfigures all detected and currently projected AS-i slaves.
Factory settings:
Press this button to reset the KL6201/KL6211 to the delivery state. Any existing projection settings are deleted.
Slave addresses
Automatic addressing activated
Automatic addressing can be activated with this check box. The setting is transferred with bit 1 of the AS-i command nibble.
Change address
The AS-i slave addresses can be changed here. Enter the old address in the left field, enter the new address of the AS-i slave whose address you would like to change in the right field and press Change address. The address change can be verified via the System overview tab.
AS-i slaves whose address have been changed have to be re-projected (see actions: Project all detected slaves button).
Note
AS-i slaves
AS-i slaves 1 to 31 may also be identified as 1A to 31A (A addresses).
AS-i slave address 32 is not permitted.
AS-i slaves 33 to 63 may also be identified as 1B to 31B (B addresses).
AS-i slaves 33 to 63 (B addresses) are only supported by digital AS-i slaves (A/B slaves). Analog AS-i slaves, for example, do not support the B addresses!
The KS2000 software uses the AS-i command interface for addressing (AS-i parameter 0x100).
Result
▪
OK is displayed if the address change was successful.
▪
If the address could not be changed, an error code is displayed.
Code | Meaning
OK (0x00) | Address modification was successful.
0x11 | There is no slave with the address that was specified in the left field (old address).
0x22 | Address 0 is currently assigned to another slave. To change the address of an AS-i slave, the KL6201/KL6211 first has to assign the address 0 to it, before a new address can be assigned.
0x36 | A slave with the address that was specified in the right field (new address) already exists.
0x47 | After deleting the old address, no slave with address 0 exists.
0x58 | After deleting the old address, an error is generated during reading of the extended ID code 1 of slave 0. Address changes for A/B slaves also require the extended ID code 1.
0x69 | After writing of extended ID code 1, no slave with address 0 exists.
0x6B | After writing of the new address, the slave with the new address is not available during reading of the ID code.
0x6C | After writing of the new address, the slave with the new address is not available during reading of the status.
0x7D | The address could not be saved permanently (non-volatile).
0x7E | The extended ID code of an A/B slave could not be saved permanently (non-volatile).
0x7F | ID code 1 is invalid for A/B slaves
0x83 | The new address is a B address. If slaves are to be operated on two parallel addresses in address ranges A and B, e.g. 10A (10) and 10B (42), both slaves have to support B addressing. In this case, the parallel A address already contains a slave that does not support B addressing!
0x84 | The new address is a B address. The slave selected with the old address is not an A/B slave, i.e. it does not support the B addresses (33 to 63).
0x85 | The new address is an A address. Slave is not an A/B slave: the associated B slave for the new address exists.


KS2000 - AS-i system overview

KS2000 Configuration Software [image] KS2000 - AS-i system overview
KS2000 - AS-i system overview
This tab can be used to check the projecting state of the connected AS-i slaves.
KS2000 - AS-i system overview
The current projecting state corresponds to the color shown.
Note
AS-i slaves
AS-i slaves 1 to 31 may also be identified as 1A to 31A.
AS-i slave address 32 is not permitted.
AS-i slaves 33 to 63 may also be identified as 1B to 31B.


KS2000 - AS-i slave parameters

KS2000 Configuration Software [image] KS2000 - AS-i slave parameters
KS2000 - AS-i slave parameters
This tab shows information about the connected AS-i configuration.
KS2000 - AS-i slave parameters
Current configuration
Here you can check the parameters of the connected AS-i slaves.
Parameter
Select the required parameter in the check box. It is displayed for all AS-i slaves in the current configuration field.
I/O code
Displays the read I/O codes of the AS-i slaves (parameters 0x90 to 0x97).
ID code
Displays the read standard ID codes of the AS-i slaves (parameters 0x48 to 0x4F).
Parameter
Displays the activation parameters for the AS-i slaves (parameters 0x50 to 0x57).
Status
Displays the read states of the AS-i slaves (parameters 0xA0 to 0xA7).
Timeout
Displays the timeout counters of the AS-i slaves (parameters 0x160 to 0x17F) .
LeaveDataExch
Displays the LeaveDataExch counters of the AS-i slaves (parameters 0x1A0 to 0x1BF).
Physical Fault
Displays the physical fault counter of the AS-i slaves (parameters 0x140 to 0x15F).
Repeat 1 to 5
Displays one of the 5 repeat counters of the AS-i slaves (parameters 0x340 to 0x35F).
Info
Displays further information about the connected AS-i configuration.
Software
Shows the firmware version of the KL6201/KL6211.
Cycle time
Displays the cycle time of the AS-i bus:
▪
current: current AS-i cycle time
▪
max.: maximum cycle time so far
Timeouts/Cycle
Displays the timeouts on the AS-i bus:
▪
max.: maximum number of timeouts that have occurred during a cycle so far
▪
1/sec: timeouts relative to the number of AS-i telegrams


Process data

KS2000 Configuration Software [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
KS2000 - Process data
The reading glasses mark the data that are currently graphically displayed in the History field.
KS2000 - Process data chart
The current input values are displayed numerically in the Value field.
KS2000 - Current value of process data
Output values can be modified through direct input or by means of the fader control.
KS2000 - Output values
CAUTION
Danger for persons, the environment or devices!
Note that changing initial values (forcing them) can have a direct effect on your automation application. Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
KS2000 - Selecting the display format for process data


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Register overview
•
Register description
•
Examples of Register Communication
•
Register pages
•
AS-i parameters - overview
•
AS-i parameter description
•
Access to AS-i parameters
•
Mapping of analog AS-i slaves


Process image

Access from the user program [image] Process image
Process image
The process image of the AS-i master terminal always consists of a 6-byte parameter data block and a 0-, 6-, 16- or 30-byte process data block. The result is a 6-, 12-, 22-, or 38-byte process image. The size of the process image can be set via the KS2000 configuration software, or fieldbus-specific via the Bus Coupler.
If the KL6201/KL6211 is used in conjunction with Bus Couplers or Bus Terminal Controllers for PROFIBUS and CANopen, there are certain special characteristics which are described in chapters KL6201/KL6211 with PROFIBUS couplers and KL6201/KL6211 with CANopen coupler.
Description of the process images
Note
Dummy nibbles
Unused AS-i slave addresses are stored as a dummy nibble on the output side of the process image and are not evaluated. The associated entries in the input data are zeroed.
6-byte process image
The 6-byte process image only consists of the parameter data block. In contrast to the other process images, it does not support direct access to the process data of the AS-i slaves. The process data access must take place via the AS-i parameters 0x80 to 0x87 (digital slaves) or 0x204 to 0x27F (analog slaves).
Input data (KL6201/KL6211 -> PLC)
Parameter data block (6 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Output data (PLC -> KL6201/KL6211)
Parameter data block (6 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Key
See 12-byte process image.
12-byte process image
If only AS-i slave addresses lower than 12 are used, the 12-byte process image is sufficient. This selection saves bandwidth both on the fieldbus and on the K-bus. Since the 12 bytes for AS-i terminal can be transferred in one K-Bus cycle, this selection also provides optimum speed for the update rate of the other terminals. This setting is enabled in delivery state of the KL6201/KL6211.
Input data (KL6201/KL6211 -> PLC)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (6 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11
Output data (PLC -> KL6201/KL6211)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (6 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | Byte 9 | Byte 10 | Byte 11
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASiOut Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11
Key
CB n: control byte n
SB n: status byte n
Para In n: Input parameter, byte n
Para Out n: Output parameter, byte n
ASiSN: AS-i status nibble
ASiCN: AS-i command nibble
ASiIn Slave x+y: Input data of the AS-i slaves x and y (one nibble per slave)
ASiOut Slave x+y: Output data of the AS-i slaves x and y (one nibble per slave)
22-byte process image
For AS-i networks, in which slave addresses between 12 and 31 are used, the 22-byte process image is required for direct access to the process data of these AS-i slaves.
Input data (KL6201/KL6211 -> PLC)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (16 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 21
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slaves 2+3 | ASiIn Slaves 4+5 | ... | ASiIn Slaves 30+31
Output data (PLC -> KL6201/KL6211)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (16 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 21
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASiOut Slave 1 | ASiOut Slaves 2+3 | ASiOut Slaves 4+5 | ... | ASiOut Slaves 30+31
Key
See 12-byte process image.
38-byte process image
For AS-i networks, in which slave addresses greater than 32 are used, the 38-byte process image is required for direct access to the process data of these AS-i slaves.
Input data (KL6201/KL6211 -> PLC)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (32 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 37
SB0 | SB1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3 | ASiSN + ASiIn Slave 1 | ASiIn Slaves 2+3 | ASiIn Slaves 4+5 | ... | ASiIn Slaves 62+63
Output data (PLC -> KL6201/KL6211)
Parameter data block (6 bytes) |  |  |  |  |  | Process data block (32 bytes)
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7 | Byte 8 | ... | Byte 37
CB0 | CB1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3 | ASiCN + ASI Out Slave 1 | ASiOut Slaves 2+3 | ASiOut Slaves 4+5 | ... | ASiOut Slaves 62+63
Key
See 12-byte process image.
Description of the data blocks
Parameter data block (byte 0 to 5 of the process image)
All AS-i parameters of the KL6201/KL6211 can be accessed via bytes 0 to 5 of the process image interface. The output and input data are then assigned as follows:
Output parameters (PLC -> KL6201/KL6211)
A new task is detected, if one of the bits in the 6-byte parameter data block has changed.
Byte | Bit | Description
0 (CB0) | 0 to 5 | Parameter number bit 0 to 5
 | 6 | 0bin: Read 1bin: Write
 | 7 | Always 0 (due to compatibility with register communication)
1 (CB1) | 0 to 3 | Parameter number bit 6 to 9
 | 4 | Only relevant for write with masked access: 0bin: Low word (bit 0 to 15) is addressed 1bin: High word (bit 16 to 31) is addressed
 | 5 | Only relevant for write: 0bin: Normal 32-bit access 1bin: Masked 16-bit access with 16-bit mask (only those bits are changed whose mask is set to "1")
 | 6 | 0bin: Parameter access is locked 1bin: Parameter access:
 | 7 | always 0
2 (ParaOut0) | 0 to 7 | Read: free Write (normal): Parameter value bits 0 to 7 Write (masked): Parameter value bits 0 to 7
3 (ParaOut1) | 0 to 7 | Read: free Write (normal): Parameter value bits 8 to 15 Write (masked): Parameter value bits 8 to 15
4 (ParaOut2) | 0 to 7 | Read: free Write (normal): Parameter value bits 16 to 23 Write (masked): Mask bits 0 to 7
5 (ParaOut3) | 0 to 7 | Read: free Write (normal): Parameter value bits 24 to 31 Write (masked): Mask bits 8 to 15
Input parameters (KL6201/KL6211 -> PLC)
Byte
Bit
Description
0 (SB0)
0
Only relevant in protected mode:
1bin: The set configuration and the actual configuration match
1
1bin: A power failure has occurred
2
1bin: automatic addressing is enabled (protected mode must be active)
0bin: automatic addressing is locked:
▪
an AS-i slave with address 0 was found, but no projected AS-i slave is missing or
▪
a non-projected AS-i slave was found
3
1bin: automatic addressing is available (protected mode must be active and precisely one projected AS-i slave must be missing)
4
1bin: an AS-i slave with address "0" was found
5
reserved for extensions
6
Diagnostic bit, 1bin:
▪
a power failure has occurred
▪
in protected mode, the set configuration does not match the actual configuration, or
▪
an AS-i slave with the address 0 was found, or
▪
automatic address programming in the output data (byte 1, bit 5) was enabled by the controller but is locked at the AS-i master (input data byte 0, bit 2), or
7
always 0 (for compatibility with register communication)
1 (SB1)
0
0bin: the AS-i master responds to a read command
1bin: the AS-i master acknowledges a write command
1
0bin: the AS-i master operates in projecting mode
1bin: the AS-i master operates in protected mode
2
the AS-i master is set to offline phase (the outputs of the activated AS-i slaves are set to the default value (1bin), the inputs of the activated AS-i slaves in the controller were also set to the default value (0bin)
3
1bin: the AS-i master operates in normal mode (data exchange phase was reached, AS-i outputs and AS-i inputs have the current values)
4
Toggle bit, this bit toggles after each executed task
5
0bin: Parameter access was completed successfully
1bin: Error during parameter access
6
Acknowledges bit 6 of CB1:
0bin: Process data mode
1bin: Parameter access
7
always 0bin
2 (ParaIn0)
0 to 7
Read (without error): Parameter value bits 0 to 7
Write (without error): read parameter value bits 0 to 7
Read or write (with error): Error code bits 0 to 7
3 (ParaIn1)
0 to 7
Read (without error): Parameter value bits 8 to 15
Write (without error): read parameter value bits 8 to 15
Read or write (with error): Error code bits 8 to 15
4 (ParaIn2)
0 to 7
Read (without error): Parameter value bits 16 to 23
Write (without error): read parameter value bits 16 to 23
Read or write (with error): Error code bits 16 to 23
5 (ParaIn3)
0 to 7
Read (without error): Parameter value bits 24 to 31
Write (without error): read parameter value bits 24 to 31
Read or write (with error): Error code bits 24 to 31
Process data block (bytes 6 to 33 of the K-bus interface)
In delivery state the output and input data of the KL6201/KL6211 have the following meaning:
Input data (KL6201/KL6211 -> PLC)
Byte | Bit | Description
6 | 0 | AS-i SN (AS-i status nibble) | Only relevant in protected mode: 1bin: Set configuration matches actual configuration
 | 1 |  | 1bin: A power failure has occurred
 | 2 |  | the AS-i master is set to offline phase (the outputs of the activated AS-i slaves are set to the default value (1bin), the inputs of the activated AS-i slaves in the controller were also set to the default value (0bin)
 | 3 |  | 1bin: The AS-i master operates in normal mode (the data exchange phase was reached, AS-i outputs and AS-i inputs have the current values)
 | 4 to 7 | AS-i slave 1 (1A): digital inputs, valid flags* or safety flags**
7 | 0 to 3 | AS-i slave 2 (2A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 3 (3A): digital inputs, valid flags* or safety flags**
8 | 0 to 3 | AS-i slave 4 (4A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 5 (5A): digital inputs, valid flags* or safety flags**
9 | 0 to 3 | AS-i slave 6 (6A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 7 (7A): digital inputs, valid flags* or safety flags**
10 | 0 to 3 | AS-i slave 8 (8A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 9 (9A): digital inputs, valid flags* or safety flags**
11 | 0 to 3 | AS-i slave 10 (10A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 11 (11A): digital inputs, valid flags* or safety flags**
12 | 0 to 3 | AS-i slave 12 (12A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 13 (13A): digital inputs, valid flags* or safety flags**
13 | 0 to 3 | AS-i slave 14 (14A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 15 (15A): digital inputs, valid flags* or safety flags**
14 | 0 to 3 | AS-i slave 16 (16A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 17 (17A): digital inputs, valid flags* or safety flags**
15 | 0 to 3 | AS-i slave 18 (18A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 19 (19A): digital inputs, valid flags* or safety flags**
16 | 0 to 3 | AS-i slave 20 (20A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 21 (21A): digital inputs, valid flags* or safety flags**
17 | 0 to 3 | AS-i slave 22 (22A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 23 (23A): digital inputs, valid flags* or safety flags**
18 | 0 to 3 | AS-i slave 24 (24A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 25 (25A): digital inputs, valid flags* or safety flags**
19 | 0 to 3 | AS-i slave 26 (26A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 27 (27A): digital inputs, valid flags* or safety flags**
20 | 0 to 3 | AS-i slave 28 (28A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 29 (29A): digital inputs, valid flags* or safety flags**
21 | 0 to 3 | AS-i slave 30 (30A): digital inputs, valid flags* or safety flags**
 | 4 to 7 | AS-i slave 31 (31A): digital inputs, valid flags* or safety flags**
22 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | AS-i slave 33 (1B): digital inputs
23 | 0 to 3 | AS-i slave 34 (2B): digital inputs
 | 4 to 7 | AS-i slave 35 (3B): digital inputs
Byte | Bit | Description
24 | 0 to 3 | AS-i slave 36 (4B): digital inputs
 | 4 to 7 | AS-i slave 37 (5B): digital inputs
25 | 0 to 3 | AS-i slave 38 (6B): digital inputs
 | 4 to 7 | AS-i slave 39 (7B): digital inputs
26 | 0 to 3 | AS-i slave 40 (8B): digital inputs
 | 4 to 7 | AS-i slave 41 (9B): digital inputs
27 | 0 to 3 | AS-i slave 42 (10B): digital inputs
 | 4 to 7 | AS-i slave 43 (11B): digital inputs
28 | 0 to 3 | AS-i slave 44 (12B): digital inputs
 | 4 to 7 | AS-i slave 45 (13B): digital inputs
29 | 0 to 3 | AS-i slave 46 (14B): digital inputs
 | 4 to 7 | AS-i slave 47 (15B): digital inputs
30 | 0 to 3 | AS-i slave 48 (16B): digital inputs
 | 4 to 7 | AS-i slave 49 (17B): digital inputs
31 | 0 to 3 | AS-i slave 50 (18B): digital inputs
 | 4 to 7 | AS-i slave 51 (19B): digital inputs
32 | 0 to 3 | AS-i slave 52 (20B): digital inputs
 | 4 to 7 | AS-i slave 53 (21B): digital inputs
33 | 0 to 3 | AS-i slave 54 (22B): digital inputs
 | 4 to 7 | AS-i slave 55 (23B): digital inputs
34 | 0 to 3 | AS-i slave 56 (24B): digital inputs
 | 4 to 7 | AS-i slave 57 (25B): digital inputs
35 | 0 to 3 | AS-i slave 58 (26B): digital inputs
 | 4 to 7 | AS-i slave 59 (27B): digital inputs
36 | 0 to 3 | AS-i slave 60 (28B): digital inputs
 | 4 to 7 | AS-i slave 61 (29B): digital inputs
37 | 0 to 3 | AS-i slave 62 (30B): digital inputs
 | 4 to 7 | AS-i slave 63 (31B): digital inputs
Key
Digital inputs: 4 input bits of the digital AS-i slave
*) valid flags: 4 input flags, the value 1bin indicates that the analog value of the respective channel is valid (1bin).
Bit 0 or 4: validity of channel 1
Bit 1 or 5: validity of channel 2
Bit 2 or 6: validity of channel 3
Bit 3 or 7: validity of channel 4
**) Safety flags: Information about the state of an AS-i safety slave:
hex | binary |  |  |  | State
 | Bit 3 | Bit 2 | Bit 1 | Bit 0
0x7 | 0 | 1 | 1 | 1 | Sensor in correct on state
0xC | 1 | 1 | 0 | 0 | Sensor in off state; only contact 2 open
0xA | 1 | 0 | 1 | 0 | Sensor in off state; only contact 1 open
0x8 | 1 | 0 | 0 | 0 | Sensor in correct off state
DANGER
Evaluation of the safety flags is not permitted!
Evaluation of the safety flags shown in the process image of the KL6201/KL6211 for controlling safety functions is not permitted! They must not be used for protective functions such as emergency stop, access protection, secure room monitoring, robot range monitoring, press safety valve etc.!
Output data (PLC -> KL6201/KL6211)
Byte | Bit | Description
6 | 0 | AS-i CN (AS-i command nibble) | reserved
 | 1 |  | 0bin: automatic addressing locked. 1bin: automatic addressing enabled
 | 2 |  | 1bin: the AS-i master enters the offline phase 0bin: the AS-i master exits the offline phase. This bit is acknowledged in the input process data (byte 0, bit 2) and in the input parameter interface data (byte 1, bit 2).
 | 3 |  | Enabling of AS-i data exchange: 1bin: the current AS-i outputs are sent to the AS-i slaves, and the received AS-i inputs transferred to the controller. 0bin: the default values (1bin) are sent to the AS-i slaves, the received AS-i inputs are deleted, and the default values (0bin) are transferred to the controller. This bit is acknowledged in the input process data (byte 0, bit 3) and in the input parameter interface data (byte 1, bit 3).
 | 4 to 7 | AS-i slave 1 (1A): digital outputs
7 | 0 to 3 | AS-i slave 2 (2A): digital outputs
 | 4 to 7 | AS-i slave 3 (3A): digital outputs
8 | 0 to 3 | AS-i slave 4 (4A): digital outputs
 | 4 to 7 | AS-i slave 5 (5A): digital outputs
9 | 0 to 3 | AS-i slave 6 (6A): digital outputs
 | 4 to 7 | AS-i slave 7 (7A): digital outputs
10 | 0 to 3 | AS-i slave 8 (8A): digital outputs
 | 4 to 7 | AS-i slave 9 (9A): digital outputs
11 | 0 to 3 | AS-i slave 10 (10A): digital outputs
 | 4 to 7 | AS-i slave 11 (11A): digital outputs
12 | 0 to 3 | AS-i slave 12 (12A): digital outputs
 | 4 to 7 | AS-i slave 13 (13A): digital outputs
13 | 0 to 3 | AS-i slave 14 (14A): digital outputs
 | 4 to 7 | AS-i slave 15 (15A): digital outputs
14 | 0 to 3 | AS-i slave 16 (16A): digital outputs
 | 4 to 7 | AS-i slave 17 (17A): digital outputs
15 | 0 to 3 | AS-i slave 18 (18A): digital outputs
 | 4 to 7 | AS-i slave 19 (19A): digital outputs
16 | 0 to 3 | AS-i slave 20 (20A): digital outputs
 | 4 to 7 | AS-i slave 21 (21A): digital outputs
17 | 0 to 3 | AS-i slave 22 (22A): digital outputs
 | 4 to 7 | AS-i slave 23 (23A): digital outputs
18 | 0 to 3 | AS-i slave 24 (24A): digital outputs
 | 4 to 7 | AS-i slave 25 (25A): digital outputs
19 | 0 to 3 | AS-i slave 26 (26A): digital outputs
 | 4 to 7 | AS-i slave 27 (27A): digital outputs
20 | 0 to 3 | AS-i slave 28 (28A): digital outputs
 | 4 to 7 | AS-i slave 29 (29A): digital outputs
21 | 0 to 3 | AS-i slave 30 (30A): digital outputs
 | 4 to 7 | AS-i slave 31 (31A): digital outputs
22 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | AS-i slave 33 (1B): digital outputs
Byte | Bit | Description
23 | 0 to 3 | AS-i slave 34 (2B): digital outputs
 | 4 to 7 | AS-i slave 35 (3B): digital outputs
24 | 0 to 3 | AS-i slave 36 (4B): digital outputs
 | 4 to 7 | AS-i slave 37 (5B): digital outputs
25 | 0 to 3 | AS-i slave 38 (6B): digital outputs
 | 4 to 7 | AS-i slave 39 (7B): digital outputs
26 | 0 to 3 | AS-i slave 40 (8B): digital outputs
 | 4 to 7 | AS-i slave 41 (9B): digital outputs
27 | 0 to 3 | AS-i slave 42 (10B): digital outputs
 | 4 to 7 | AS-i slave 43 (11B): digital outputs
28 | 0 to 3 | AS-i slave 44 (12B): digital outputs
 | 4 to 7 | AS-i slave 45 (13B): digital outputs
29 | 0 to 3 | AS-i slave 46 (14B): digital outputs
 | 4 to 7 | AS-i slave 47 (15B): digital outputs
30 | 0 to 3 | AS-i slave 48 (16B): digital outputs
 | 4 to 7 | AS-i slave 49 (17B): digital outputs
31 | 0 to 3 | AS-i slave 50 (18B): digital outputs
 | 4 to 7 | AS-i slave 51 (19B): digital outputs
32 | 0 to 3 | AS-i slave 52 (20B): digital outputs
 | 4 to 7 | AS-i slave 53 (21B): digital outputs
33 | 0 to 3 | AS-i slave 54 (22B): digital outputs
 | 4 to 7 | AS-i slave 55 (23B): digital outputs
34 | 0 to 3 | AS-i slave 56 (24B): digital outputs
 | 4 to 7 | AS-i slave 57 (25B): digital outputs
35 | 0 to 3 | AS-i slave 58 (26B): digital outputs
 | 4 to 7 | AS-i slave 59 (27B): digital outputs
36 | 0 to 3 | AS-i slave 60 (28B): digital outputs
 | 4 to 7 | AS-i slave 61 (29B): digital outputs
37 | 0 to 3 | AS-i slave 62 (30B): digital outputs
 | 4 to 7 | AS-i slave 63 (31B): digital outputs


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for parameterization of the terminal and can be read or written via the register communication.
Register | Comment |  | Default value |  | R/W | Memory
R0 to R3 | reserved |  | 0x0000 | 0dec | - | -
R4 | Register page selection register |  | 0x0000 | 0dec | R/W |
R5 to R7 | reserved |  | 0x0000 | 0dec | - | -
R8 | Terminal description | KL6201 | 0x1839 | 6201dec | R | ROM
 |  | KL6211 | 0x1843 | 6211dec
R9 | Firmware version |  | e.g. 0x0100 | e.g. 256dec | R | ROM
R10 | Multiplex shift register |  | 0x0160 | 352dec | R | ROM
R11 | Signal channels |  | 0x0160 | 352dec | R | ROM
R12 | Minimum data length |  | 0x6060 | 24672dec | R | ROM
R13 | Data structure of the Bus Terminal |  | 0x0001 | 1dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | - | - | R/W | RAM
R16 to R26 | reserved |  | 0x0000 | 0dec | - | -
R27 | Size of the process image |  | 0x0001 | 1dec | R/W | SEEROM/RAM
R28 to R30 | reserved |  | 0x0000 | 0dec | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 to R63 | Register for displaying the register pages |  | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
The registers are used for parameterization of the terminal and can be read or written via the register communication.
R4: Register page selection register
This register is used to specify which register page is shown in registers R32 to R63 of the KL6201/KL6211 (default: 0x0000). The register pages provide access to the AS-i parameters of the KL6201/KL6211.
R8: Terminal description
Register R8 contains the terminal identifier in hexadecimal coding: 0x1839 (6201dec)
R9: Firmware version
Register R9 contains the firmware version of the terminal in hexadecimal coding, e. g. 0x0100 (256dec).
R10: Shift register length
0x0160
R11: Number of signal channels
0x0160
R12: Minimum data length
0x6060
R13: Data structure of the Bus Terminal
Register R13 contains the data structure of the Bus Terminal.
R15: Alignment register
R27: Size of the process image
This register specifies the size of the process image of the KL6201/KL6211.
Value | Process image | Default
0000hex | 6-byte process image | 0001hex
0001hex | 12-byte process image
0002hex | 22-byte process image
0003hex | 38-byte process image
further | reserved
After changing the process image the Bus Coupler must be restarted for the modified process image to take effect.
R31: Code word register
▪
If you write values into the user registers without previously having entered the user code word (0x1235) in the code word register, these values are only stored in the RAM registers, but not in the EPROM registers and are therefore lost if the terminal is restarted.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the EPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32 to R63
In these registers the KL6201/KL6211 shows the AS-i parameters of the register page selected with register R4.


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9 of a terminal
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9 of a terminal

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9 of a terminal
Example 1: reading the firmware version from Register 9 of a terminal
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Register pages

Access from the user program [image] Register pages
Register pages
The AS-i parameters of the KL6201/KL6211 can be accessed via register communication or via the KS2000 configuration software. The register model of the terminals is used as a basis. The KL6201/KL6211 has 64 registers (words). Registers 0 to 31 always have the same meaning. The content of registers 32 to 63 is specified via the register page selection register (R4).
A register page is 32 registers (64 bytes) long and can therefore address 16 AS-i parameters.
- In terminal registers 32 to 63, page 0 addresses AS-i parameters 0 to 15
- In terminal registers 32 to 63, page 1 addresses AS-i parameters 16 to 31
- etc.
Assignment of the AS-i parameters to a register page and a terminal register
Reg. page | KL6201/KL6211 registers | AS-i Parameters | Length | Description
0x02 | 48 to 49 | 0x28 | 4 bytes | General Information (byte 0 corresponds to bit 0 to 7 of parameter 0x28)
0x04 | 32 to 47 | 0x40 to 0x47 | 32 bytes | Projected I/O IDs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x40)
 | 48 to 63 | 0x48 to 0x4F | 32 bytes | Projected ID codes of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x48)
0x05 | 32 to 47 | 0x50 to 0x57 | 32 bytes | Activation parameters for the AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x50)
 | 48 to 51 | 0x58 to 0x59 | 8 bytes | List of the AS-i slaves that are projected at the next start (byte 0 corresponds to bit 0 to 7 of parameter 0x58)
0x06 | 32 to 35 | 0x60 to 0x61 | 8 bytes | List of I/O IDs of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x60)
 | 48 to 51 | 0x68 to 0x69 | 8 bytes | List of ID codes of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x68)
0x07 | 32 to 35 | 0x70 to 0x71 | 8 bytes | List of extended ID codes 1 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x70)
 | 48 to 51 | 0x78 to 0x79 | 8 bytes | List of extended ID codes 2 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x78)
0x08 | 32 to 47 | 0x80 to 0x87 | 32 bytes | Digital inputs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x80)
0x09 | 32 to 47 | 0x90 to 0x97 | 32 bytes | Read I/O IDs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x90)
 | 48 to 63 | 0x98 to 0x9F | 32 bytes | Read ID codes of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x98)
0x0A | 32 to 47 | 0xA0 to 0xA7 | 32 bytes | Read status of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xA0)
 | 48 to 51 | 0xA8 to 0xA9 | 8 bytes | List of currently projected AS-i slaves (LPS) (byte 0 corresponds to bit 0 to 7 of parameter 0xA8)
0x0B | 32 to 35 | 0xB0 to 0xB1 | 8 bytes | List of detected AS-i slaves (LDS) (byte 0 corresponds to bit 0 to 7 of parameter 0xB0)
 | 48 to 51 | 0xB8 to 0xB9 | 8 bytes | List of activated AS-i slaves (LAS) (byte 0 corresponds to bit 0 to 7 of parameter 0xB8)
0x0C | 32 to 35 | 0xC0 to 0xC1 | 8 bytes | List of slaves that support the extended ID codes (ID codes 1 and 2) (byte 0 corresponds to bit 0 to 7 of parameter 0xC0)
 | 48 to 49 | 0xC8 | 4 bytes | List of slaves that support extended addressing (as B slaves with AS-i addresses greater than 32) (byte 0 corresponds to bit 0 to 7 of parameter 0xC8)
Reg. page | KL6201/KL6211 registers | AS-i Parameters | Length | Description
0x0D | 32 to 47 | 0xD0 to 0xD7 | 32 bytes | Read extended ID codes 1 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xD0)
 | 48 to 63 | 0xD8 to 0xDF | 32 bytes | Read extended ID codes 2 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xD8)
0x0E | 32 to 47 | 0xE0 to 0xE7 | 32 bytes | Currently projected extended ID codes 1 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xE0)
 | 48 to 63 | 0xE8 to 0xEF | 32 bytes | Currently projected extended ID codes 2 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xE8)
0x0F | 32 to 33 | 0xF0 | 4 bytes | List of analog slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xF0)
 | 34 to 35 | 0xF8 | 4 bytes | List of safety slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xF8)
0x12 | 32 to 47 | 0x120 to 0x127 | 32 bytes | Status registers 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x120)
 | 48 to 63 | 0x128 to 0x12F | 32 bytes | Status registers 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x128)
0x14 | 32 to 47 | 0x140 to 0x147 | 32 bytes | Physical fault counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x140)
 | 48 to 63 | 0x148 to 0x14F | 32 bytes | Physical fault counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x148)
0x15 | 33 to 47 | 0x150 to 0x157 | 32 bytes | Physical fault counter, AS-i slave 33 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x150)
 | 48 to 63 | 0x158 to 0x15F | 32 bytes | Physical fault counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x158)
0x16 | 32 to 47 | 0x160 to 0x167 | 32 bytes | Timeout counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x160)
 | 48 to 63 | 0x168 to 0x16F | 32 bytes | Timeout counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x168)
0x17 | 33 to 47 | 0x170 to 0x177 | 32 bytes | Timeout counter, AS-i slave 33 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x170)
 | 48 to 63 | 0x178 to 0x17F | 32 bytes | Timeout counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x178)
0x18 | 32 to 47 | 0x180 to 0x187 | 32 bytes | Response counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x180)
 | 48 to 63 | 0x188 to 0x18F | 32 bytes | Response counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x188)
0x19 | 33 to 47 | 0x190 to 0x197 | 32 bytes | Response counter, AS-i slave 33 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x190)
 | 48 to 63 | 0x198 to 0x19F | 32 bytes | Response counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x198)
Reg. page | KL6201/KL6211 registers | AS-i Parameters | Length | Description
0x1A | 32 to 47 | 0x1A0 to 0x1A7 | 32 bytes | Leave data exchange counter, AS-i slaves 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A0)
 | 48 to 63 | 0x1A8 to 0x1AF | 32 bytes | Leave data exchange counter, AS-i slaves 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A8)
0x1B | 33 to 47 | 0x1B0 to 0x1B7 | 32 bytes | Leave data exchange counter, AS-i slaves 33 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B0)
 | 48 to 63 | 0x1B8 to 0x1BF | 32 bytes | Leave data exchange counter, AS-i slaves 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B8)
0x1C | 32 to 47 | 0x1C0 to 0x1C7 | 32 bytes | DataExch failed counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C0)
 | 48 to 63 | 0x1C8 to 0x1CF | 32 bytes | DataExch failed counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C8)
0x1D | 33 to 47 | 0x1D0 to 0x1D7 | 32 bytes | DataExch failed counter, AS-i slave 33 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D0)
 | 48 to 63 | 0x1D8 to 0x1DF | 32 bytes | DataExch failed counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D8)
0x20 | 40 to 63 | 0x200 to 0x20F | 64 bytes | Data of analog slaves 1 to 3 (byte 0 corresponds to bit 0 to 7 of parameter 0x204) | see mapping table
0x21 | 32 to 63 | 0x210 to 0x21F | 64 bytes | Data of analog slaves 4 to 7 (byte 0 corresponds to bit 0 to 7 of parameter 0x210)
... | ... | ... | ... | ...
0x27 | 32 to 63 | 0x270 to 0x27F | 64 bytes | Data of analog slaves 30 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x270)
0x30 | 32 to 33 | 0x300 | 4 bytes | Cycle times (byte 0 corresponds to bit 0 to 7 of parameter 0x300)
0x31 | 32 to 33 | 0x310 | 4 bytes | Statistics (byte 0 corresponds to bit 0 to 7 of parameter 0x310)
0x32 | 32 to 63 | 0x320 to 0x32F | 64 bytes | Timeout statistics for each AS-i slave (byte 0 corresponds to bit 0 to 7 of parameter 0x320)
0x34 | 32 to 63 | 0x340 to 0x35F | 64 bytes | Data exchange repeat counter for each AS-i slave (byte 0 corresponds to bit 0 to 7 of parameter 0x340)


AS-i parameters - overview

Access from the user program [image] AS-i parameters - overview
AS-i parameters - overview
All information contained in the AS-i master and the AS-i slaves are described in the following parameters, which are accessible via the cyclic parameter interface (process data mode), via acyclic services (e.g. PROFIBUS DPV1), or via the KS2000 configuration software.
Overview of the parameters
Parameter numbers | Access | stored in flash | Description
0x20 | R/W | yes | Width of the process image interface
0x28 | R | yes | General Information
0x30 | R/W | yes | AS-i string parameters
0x40 to 0x47 | R/W | yes | Projected I/O IDs of all AS-i slaves
0x48 to 0x4F | R/W | yes | Projected ID codes of all AS-i slaves
0x50 to 0x57 | R/W | yes | Activation parameters for the AS-i slaves
0x58 to 0x59 | R/W | yes | List of the AS-i slaves that are projected at the next start
0x60 to 0x61 | R/W | yes | List of I/O IDs of all AS-i slaves to be checked
0x68 to 0x69 | R/W | yes | List of ID codes of all AS-i slaves to be checked
0x70 to 0x71 | R/W | yes | List of extended ID codes 1 of all AS-i slaves to be checked
0x78 to 0x79 | R/W | yes | List of extended ID codes 2 of all AS-i slaves to be checked
0x80 to 0x87 | R | no | Data of digital AS-i slaves
0x90 to 0x97 | R | no | Read I/O IDs of all AS-i slaves
0x98 to 0x9F | R | no | Read ID codes of all AS-i slaves
0xA0 to 0xA7 | R | no | Read status of all AS-i slaves
0xA8 and 0xA9 | R | no | List of currently projected AS-i slaves (LPS)
0xB0 and 0xB1 | R | no | List of detected AS-i slaves (LDS)
0xB8 and 0xB9 | R | no | List of activated AS-i slaves (LAS)
0xC0 and 0xC1 |  |  | List of slaves that support the extended ID codes (ID codes 1 and 2)
0xC8 |  |  | List of slaves that support extended addressing (as B slaves with addresses greater than 32)
0xD0 to 0xD7 | R | no | Read extended ID codes 1 of all AS-i slaves
0xD8 to 0xDF | R | no | Read extended ID codes 2 of all AS-i slaves
0xE0 to 0xE7 | R/W | yes | Currently projected extended ID codes 1 of all AS-i slaves
0xE8 to 0xEF | R/W | yes | Currently projected extended ID codes 2 of all AS-i slaves
0xF0 |  |  | List of analog slaves
0xF8 |  |  | List of safety slaves
0x100 | W | - | AS-i command interface
0x108 | W | - | General command interface
0x120 to 0x12F | R | no | Status register
0x140 to 0x15F | R/W | no | Physical fault counter
0x160 to 0x17F | R/W | no | Timeout counter
0x180 to 0x19F | R/W | no | Response counter
0x1A0 to 0x1BF | R/W | no | Leave DataExch counter
0x1C0 to 0x1DF | R/W | no | DataExch failed counter
0x200 to 0x27F | R/W | no | Data of analog AS-i slaves
0x300 |  |  | Cycle times
0x310 |  |  | Statistics
0x320 to 0x32F |  |  | Timeout statistics for each AS-i slave
0x340 to 0x35F |  |  | Data exchange repeat counter for each AS-i slave


AS-i parameter description

Access from the user program [image] AS-i parameter description
AS-i parameter description
Parameter 0x20: Size of the process image
Parameter 0x20 contains the size of the process image. This parameter can be read or written. It is stored in the flash of the KL6201/KL6211 (i.e. it is still available after power off/on).
Parameter | Bit | Description | default
0x20 | 0 to 15 | 0dec: 6-byte interface 1dec: 12-byte interface 2dec: 22-byte interface 3dec: 38-byte interface | 1dec
 | 16 to 31 | reserved | -
After changing the process image the Bus Coupler must be restarted for the modified process image to take effect.
Parameter 0x28: General Information
Parameter 0x28 contains the number of the terminal (6201) and firmware version (this parameter is read only):
Parameter | Bit | Description
0x28 | 0 to 15 | Terminal identifier: 0x1839 (6201dec)
 | 16 to 31 | Firmware version of the terminal
Parameter 0x30: AS-i string parameters
Parameter 0x30 can be used to read or write AS-i strings. The whole AS-i string is transferred in triples. Parameter 0x30 is supported from firmware version BA.
Parameter | Bit | Description | Value
0x30 | 0 to 7 | Byte 0 of data triple m (byte m) | 0 to 255
 | 8 to 15 | Byte 1 of data triple m (byte m + 1) | 0 to 255
 | 16 to 23 | Byte 2 of data triple m (byte m + 2) | 0 to 255
 | 24 to 31 | Byte offset (m = multiple of 3) | m
Note
String transfer
A string transfer can be used to transfer up to 219 bytes of string data.
A string transfer consists of several parameter access operations, each of which transfers 4 bytes. These 4 bytes consist of three bytes (1 triple) of string data and 1 byte for the byte offset.
Parameters 0x40 to 0x47: Projected I/O ID (set configuration)
In protected mode, the I/O ID of the projected AS-i slaves is checked. The currently projected 4-bit I/O IDs of the AS-i slaves are located in parameters 0x40 to 0x47 (these parameters are read/write and are stored in the flash of the AS-i master (i.e. they are still available after power off/on)):
Parameter | Bit | Description
0x40 | 0 to 3 | reserved
 | 4 to 7 | projected I/O ID, AS-i slave 1 (1A)
 | 8 to 11 | projected I/O ID, AS-i slave 2 (2A)
 | 12 to 15 | projected I/O ID, AS-i slave 3 (3A)
 | 16 to 19 | projected I/O ID, AS-i slave 4 (4A)
 | 20 to 23 | projected I/O ID, AS-i slave 5 (5A)
 | 24 to 27 | projected I/O ID, AS-i slave 6 (6A)
 | 28 to 31 | projected I/O ID, AS-i slave 7 (7A)
Parameter | Bit | Description
0x41 | 0 to 3 | projected I/O ID, AS-i slave 8 (8A)
 | 4 to 7 | projected I/O ID, AS-i slave 9 (9A)
 | 8 to 11 | projected I/O ID, AS-i slave 10 (10A)
 | 12 to 15 | projected I/O ID, AS-i slave 11 (11A)
 | 16 to 19 | projected I/O ID, AS-i slave 12 (12A)
 | 20 to 23 | projected I/O ID, AS-i slave 13 (13A)
 | 24 to 27 | projected I/O ID, AS-i slave 14 (14A)
 | 28 to 31 | projected I/O ID, AS-i slave 15 (15A)
0x42 | 0 to 3 | projected I/O ID, AS-i slave 16 (16A)
 | 4 to 7 | projected I/O ID, AS-i slave 17 (17A)
 | 8 to 11 | projected I/O ID, AS-i slave 18 (18A)
 | 12 to 15 | projected I/O ID, AS-i slave 19 (19A)
 | 16 to 19 | projected I/O ID, AS-i slave 20 (20A)
 | 20 to 23 | projected I/O ID, AS-i slave 21 (21A)
 | 24 to 27 | projected I/O ID, AS-i slave 22 (22A)
 | 28 to 31 | projected I/O ID, AS-i slave 23 (23A)
0x43 | 0 to 3 | projected I/O ID, AS-i slave 24 (24A)
 | 4 to 7 | projected I/O ID, AS-i slave 25 (25A)
 | 8 to 11 | projected I/O ID, AS-i slave 26 (26A)
 | 12 to 15 | projected I/O ID, AS-i slave 27 (27A)
 | 16 to 19 | projected I/O ID, AS-i slave 28 (28A)
 | 20 to 23 | projected I/O ID, AS-i slave 29 (29A)
 | 24 to 27 | projected I/O ID, AS-i slave 30 (30A)
 | 28 to 31 | projected I/O ID, AS-i slave 31 (31A)
0x44 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | projected I/O ID, AS-i slave 33 (1B)
 | 8 to 11 | projected I/O ID, AS-i slave 34 (2B)
 | 12 to 15 | projected I/O ID, AS-i slave 35 (3B)
 | 16 to 19 | projected I/O ID, AS-i slave 36 (4B)
 | 20 to 23 | projected I/O ID, AS-i slave 37 (5B)
 | 24 to 27 | projected I/O ID, AS-i slave 38 (6B)
 | 28 to 31 | projected I/O ID, AS-i slave 39 (7B)
0x45 | 0 to 3 | projected I/O ID, AS-i slave 40 (8B)
 | 4 to 7 | projected I/O ID, AS-i slave 41 (9B)
 | 8 to 11 | projected I/O ID, AS-i slave 42 (10B)
 | 12 to 15 | projected I/O ID, AS-i slave 43 (11B)
 | 16 to 19 | projected I/O ID, AS-i slave 44 (12B)
 | 20 to 23 | projected I/O ID, AS-i slave 45 (13B)
 | 24 to 27 | projected I/O ID, AS-i slave 46 (14B)
 | 28 to 31 | projected I/O ID, AS-i slave 47 (15B)
0x46 | 0 to 3 | projected I/O ID, AS-i slave 48 (16B)
 | 4 to 7 | projected I/O ID, AS-i slave 49 (17B)
 | 8 to 11 | projected I/O ID, AS-i slave 50 (18B)
 | 12 to 15 | projected I/O ID, AS-i slave 51 (19B)
 | 16 to 19 | projected I/O ID, AS-i slave 52 (20B)
 | 20 to 23 | projected I/O ID, AS-i slave 53 (21B)
 | 24 to 27 | projected I/O ID, AS-i slave 54 (22B)
 | 28 to 31 | projected I/O ID, AS-i slave 55 (23B)
0x47 | 0 to 3 | projected I/O ID, AS-i slave 56 (24B)
 | 4 to 7 | projected I/O ID, AS-i slave 57 (25B)
 | 8 to 11 | projected I/O ID, AS-i slave 58 (26B)
 | 12 to 15 | projected I/O ID, AS-i slave 59 (27B)
 | 16 to 19 | projected I/O ID, AS-i slave 60 (28B)
 | 20 to 23 | projected I/O ID, AS-i slave 61 (29B)
 | 24 to 27 | projected I/O ID, AS-i slave 62 (30B)
 | 28 to 31 | projected I/O ID, AS-i slave 63 (31B)
Parameters 0x48 to 0x4F: Projected ID code (nominal configuration)
In protected mode, the ID code of the projected AS-i slaves is checked. The projected 4-bit ID codes of the AS-i slaves are located in parameters 0x48 to 0x4F (these parameters are read/write and are stored in the flash of the AS-i master (i.e. they are still available after power off/on)):
Parameter | Bit | Description
0x48 | 0 to 3 | reserved
 | 4 to 7 | projected ID code, AS-i slave 1 (1A)
 | 8 to 11 | projected ID code, AS-i slave 2 (2A)
 | 12 to 15 | projected ID code, AS-i slave 3 (3A)
 | 16 to 19 | projected ID code, AS-i slave 4 (4A)
 | 20 to 23 | projected ID code, AS-i slave 5 (5A)
 | 24 to 27 | projected ID code, AS-i slave 6 (6A)
 | 28 to 31 | projected ID code, AS-i slave 7 (7A)
0x49 | 0 to 3 | projected ID code, AS-i slave 8 (8A)
 | 4 to 7 | projected ID code, AS-i slave 9 (9A)
 | 8 to 11 | projected ID code, AS-i slave 10 (10A)
 | 12 to 15 | projected ID code, AS-i slave 11 (11A)
 | 16 to 19 | projected ID code, AS-i slave 12 (12A)
 | 20 to 23 | projected ID code, AS-i slave 13 (13A)
 | 24 to 27 | projected ID code, AS-i slave 14 (14A)
 | 28 to 31 | projected ID code, AS-i slave 15 (15A)
0x4A | 0 to 3 | projected ID code, AS-i slave 16 (16A)
 | 4 to 7 | projected ID code, AS-i slave 17 (17A)
 | 8 to 11 | projected ID code, AS-i slave 18 (18A)
 | 12 to 15 | projected ID code, AS-i slave 19 (19A)
 | 16 to 19 | projected ID code, AS-i slave 20 (20A)
 | 20 to 23 | projected ID code, AS-i slave 21 (21A)
 | 24 to 27 | projected ID code, AS-i slave 22 (22A)
 | 28 to 31 | projected ID code, AS-i slave 23 (23A)
0x4B | 0 to 3 | projected ID code, AS-i slave 24 (24A)
 | 4 to 7 | projected ID code, AS-i slave 25 (25A)
 | 8 to 11 | projected ID code, AS-i slave 26 (26A)
 | 12 to 15 | projected ID code, AS-i slave 27 (27A)
 | 16 to 19 | projected ID code, AS-i slave 28 (28A)
 | 20 to 23 | projected ID code, AS-i slave 29 (29A)
 | 24 to 27 | projected ID code, AS-i slave 30 (30A)
 | 28 to 31 | projected ID code, AS-i slave 31 (31A)
0x4C | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | projected ID code, AS-i slave 33 (1B)
 | 8 to 11 | projected ID code, AS-i slave 34 (2B)
 | 12 to 15 | projected ID code, AS-i slave 35 (3B)
 | 16 to 19 | projected ID code, AS-i slave 36 (4B)
 | 20 to 23 | projected ID code, AS-i slave 37 (5B)
 | 24 to 27 | projected ID code, AS-i slave 38 (6B)
 | 28 to 31 | projected ID code, AS-i slave 39 (7B)
0x4D | 0 to 3 | projected ID code, AS-i slave 40 (8B)
 | 4 to 7 | projected ID code, AS-i slave 41 (9B)
 | 8 to 11 | projected ID code, AS-i slave 42 (10B)
 | 12 to 15 | projected ID code, AS-i slave 43 (11B)
 | 16 to 19 | projected ID code, AS-i slave 44 (12B)
 | 20 to 23 | projected ID code, AS-i slave 45 (13B)
 | 24 to 27 | projected ID code, AS-i slave 46 (14B)
 | 28 to 31 | projected ID code, AS-i slave 47 (15B)
Parameter | Bit | Description
0x4E | 0 to 3 | projected ID code, AS-i slave 48 (16B)
 | 4 to 7 | projected ID code, AS-i slave 49 (17B)
 | 8 to 11 | projected ID code, AS-i slave 50 (18B)
 | 12 to 15 | projected ID code, AS-i slave 51 (19B)
 | 16 to 19 | projected ID code, AS-i slave 52 (20B)
 | 20 to 23 | projected ID code, AS-i slave 53 (21B)
 | 24 to 27 | projected ID code, AS-i slave 54 (22B)
 | 28 to 31 | projected ID code, AS-i slave 55 (23B)
0x4F | 0 to 3 | projected ID code, AS-i slave 56 (24B)
 | 4 to 7 | projected ID code, AS-i slave 57 (25B)
 | 8 to 11 | projected ID code, AS-i slave 58 (26B)
 | 12 to 15 | projected ID code, AS-i slave 59 (27B)
 | 16 to 19 | projected ID code, AS-i slave 60 (28B)
 | 20 to 23 | projected ID code, AS-i slave 61 (29B)
 | 24 to 27 | projected ID code, AS-i slave 62 (30B)
 | 28 to 31 | projected ID code, AS-i slave 63 (31B)
Parameters 0x50 to 0x57: Activation parameters for the AS-i slaves
During the activation phase (or during the inclusion phase - for AS-i slaves that are added later), 4-bit parameter data are sent once to each AS-i slave prior to the first data exchange. The activation parameters can be specified for each AS-i slave via parameters 0x50 to 0x57. The precise definition of the activation parameters for each individual AS-i slave can be found in the documentation associated with the slave.
Parameters 0x50 to 0x57 can be read or written and are stored in the flash of the AS-i master, i.e. they are still available after power off/on of the AS-i master.
Parameter | Bit | Description | default
0x50 | 0 to 3 | reserved | -
 | 4 to 7 | Activation parameter, AS-i slave 1 (1A) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 2 (2A) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 3 (3A) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 4 (4A) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 5 (5A) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 6 (6A) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 7 (7A) | 0x0F
0x51 | 0 to 3 | Activation parameter, AS-i slave 8 (8A) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 9 (9A) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 10 (10A) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 11 (11A) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 12 (12A) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 13 (13A) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 14 (14A) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 15 (15A) | 0x0F
0x52 | 0 to 3 | Activation parameter, AS-i slave 16 (16A) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 17 (17A) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 18 (18A) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 19 (19A) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 20 (20A) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 21 (21A) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 22 (22A) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 23 (23A) | 0x0F
Parameter | Bit | Description | default
0x53 | 0 to 3 | Activation parameter, AS-i slave 24 (24A) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 25 (25A) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 26 (26A) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 27 (27A) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 28 (28A) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 29 (29A) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 30 (30A) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 31 (31A) | 0x0F
0x54 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted) | -
 | 4 to 7 | Activation parameter, AS-i slave 33 (1B) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 34 (2B) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 35 (3B) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 36 (4B) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 37 (5B) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 38 (6B) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 39 (7B) | 0x0F
0x55 | 0 to 3 | Activation parameter, AS-i slave 40 (8B) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 41 (9B) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 42 (10B) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 43 (11B) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 44 (12B) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 45 (13B) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 46 (14B) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 47 (15B) | 0x0F
0x56 | 0 to 3 | Activation parameter, AS-i slave 48 (16B) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 49 (17B) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 50 (18B) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 51 (19B) | 0x0F
 | 16 to 19 | Activation parameter, AS-i slave 52 (20B) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 53 (21B) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 54 (22B) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 55 (23B) | 0x0F
0x57 | 0 to 3 | Activation parameter, AS-i slave 56 (24B) | 0x0F
 | 4 to 7 | Activation parameter, AS-i slave 57 (25B) | 0x0F
 | 8 to 11 | Activation parameter, AS-i slave 58 (26B) | 0x0F
 | 12 to 15 | Activation parameter, AS-i slave 59 (27B) | 0x0F
 | 16-19 | Activation parameter, AS-i slave 60 (28B) | 0x0F
 | 20 to 23 | Activation parameter, AS-i slave 61 (29B) | 0x0F
 | 24 to 27 | Activation parameter, AS-i slave 62 (30B) | 0x0F
 | 28 to 31 | Activation parameter, AS-i slave 63 (31B) | 0x0F
Parameters 0x58 and 0x59: List of the AS-i slaves that are projected at the next start
This list contains the AS-i slaves that are projected during the next start (transition from offline phase to detection phase). For each AS-i slave, parameters 0x58 to 0x59 contain a bit that indicates whether the associated AS-i slave is projected (this parameter is read/write and is stored in the flash of the AS-i master (i.e. it is still available after power off/on)):
Parameter | Bit | Description
0x58 | 0 | reserved
 | 1 | 0bin: AS-i slave 1 (1A) is not projected 1bin: AS-i slave 1 (1A) is projected
 | ... | ...
 | 31 | 0bin: AS-i slave 3 1 (31A) is not projected 1bin: AS-i slave 3 1 (31A) is projected
0x59 | 0 | reserved
 | 1 | 0bin: AS-i slave 33 (1B) is not projected 1bin: AS-i slave 33 (1B) is projected
 | ... | ...
 | 31 | 0bin: AS-i slave 63 (31B) is not projected 1bin: AS-i slave 63 (31B) is projected
Parameters 0x60 and 0x61: Verification of the I/O IDs of the AS-i slaves
This list defines whether the I/O IDs should be checked in protected mode (projecting active). For each AS-i slave, parameters 0x60 and 0x61 contain a bit that indicates whether the I/O ID of the associated AS-i slave should be checked (this parameter is read/write and is stored in the flash of the AS-i master (i.e. it is still available after power off/on)):
Parameter | Bit | Description
0x60 | 0 | reserved
 | 1 | 0bin: I/O ID of AS-i slave 1 (1A) is not checked in protected mode (0) 1bin: I/O ID of AS-i slave 1 (1A) is checked in protected mode (1)
 | ... | ...
 | 31 | 0bin: I/O ID of AS-i slave 31 (31A) is not checked in protected mode (0) 1bin: I/O ID of AS-i slave 31 (31A) is checked in protected mode (1)
0x61 | 0 | reserved
 | 1 | 0bin: I/O ID of AS-i slave 33 (1B) is not checked in protected mode (0) 1bin: I/O ID of AS-i slave 33 (1B) is checked in protected mode (1)
 | ... | ...
 | 31 | 0bin: I/O ID of AS-i slave 63 (31B) is not checked in protected mode (0) 1bin: I/O ID of AS-i slave 63 (31B) is checked in protected mode (1)
Parameters 0x68 and 0x69: Verification of the ID codes of the AS-i slaves
This list defines whether the ID codes should be checked in protected mode (projecting active). For each AS-i slave, parameters 0x68 and 0x69 contain a bit that indicates whether the ID code of the associated AS-i slave should be checked (this parameter is read/write and is stored in the flash of the AS-i master (i.e. it is still available after power off/on)):
Parameter | Bit | Description
0x68 | 0 | reserved
 | 1 | 0bin: ID code of AS-i slave 1 (1A) is not checked in protected mode 1bin: ID code of AS-i slave 1 (1A) is checked in protected mode
 | ... | ...
 | 31 | 0bin: ID code of AS-i slave 31 (31A) is not checked in protected mode 1bin: ID code of AS-i slave 31 (31A) is checked in protected mode
0x69 | 0 | reserved
 | 1 | 0bin: ID code of AS-i slave 33 (1B) is not checked in protected mode 1bin: ID code of AS-i slave 33 (1B) is checked in protected mode
 | ... | ...
 | 31 | 0bin: ID code of AS-i slave 63 (31B) is not checked in protected mode 1bin: ID code of AS-i slave 63 (31B) is checked in protected mode
Parameters 0x70 and 0x71: Verification of the extended ID codes 1 of the AS-i slaves
This list defines whether the extended ID codes 1 should be checked in protected mode (projecting active). For each AS-i slave, parameters 0x70 and 0x71 contain a bit that indicates whether the extended ID code 2 of the associated AS-i slave should be checked (this parameter is read/write and is stored in the flash of the AS-i master (i.e. it is still available after power off/on)):
Parameter | Bit | Description
0x70 | 0 | reserved
 | 1 | 0bin: Extended ID code 1 of AS-i slave 1 (1A) is not checked in protected mode 1bin: Extended ID code 1 of AS-i slave 1 (1A) is checked in protected mode
 | ... | ...
 | 31 | 0bin: Extended ID code 1 of AS-i slave 31 (31A) is not checked in protected mode 1bin: Extended ID code 1 of AS-i slave 31 (31A) is checked in protected mode
0x71 | 0 | reserved
 | 1 | 0bin: Extended ID code 1 of AS-i slave 33 (1B) is not checked in protected mode 1bin: Extended ID code 1 of AS-i slave 33 (1B) is checked in protected mode
 | ... | ...
 | 31 | 0bin: Extended ID code 1 of AS-i slave 63 (31B) is not checked in protected mode 1bin: Extended ID code 1 of AS-i slave 63 (31B) is checked in protected mode
Parameters 0x78 and 0x79: Verification of the extended ID codes 2 of the AS-i slaves
This list defines whether the ID codes should be checked in protected mode (projecting active). For each AS-i slave, parameters 0x78 and 0x79 contain a bit that indicates whether the extended ID code 2 of the associated AS-i slave should be checked (this parameter is read/write and is stored in the flash of the AS-i master (i.e. it is still available after power off/on)):
Parameter | Bit | Description
0x78 | 0 | reserved
 | 1 | 0bin: Extended ID code 2 of AS-i slave 1 (1A) is not checked in protected mode 1bin: Extended ID code 2 of AS-i slave 1 (1A) is checked in protected mode
 | ... | ...
 | 31 | 0bin: Extended ID code 2 of AS-i slave 3 1 (31A) is not checked in protected mode 1bin: Extended ID code 2 of AS-i slave 3 1 (31A) is checked in protected mode
0x79 | 0 | reserved
 | 1 | 0bin: Extended ID code 2 of AS-i slave 33 (1B) is not checked in protected mode 1bin: Extended ID code 2 of AS-i slave 33 (1B) is checked in protected mode
 | ... | ...
 | 31 | 0bin: Extended ID code 2 of AS-i slave 63 (31B) is not checked in protected mode 1bin: Extended ID code 2 of AS-i slave 63 (31B) is checked in protected mode
Parameters 0x80 to 0x87: Digital inputs and outputs
The digital process data of the AS-i slaves can also be read or written via the parameters. For the 12-byte KBus interface, digital outputs can only be written for the AS-i slaves from address 12 (the digital outputs of AS-i slaves 1-11 are overwritten by the process data), for the 22-byte KBus interface from address 33 (the digital outputs of AS-i slaves 1-31 are overwritten by the process data), and for the 30-byte KBus interface from address 48 (the digital outputs of AS-i slaves 1-47 are overwritten by the process data). The digital inputs (read access) or digital outputs (write access) of all AS-i slaves are stored in parameters 0x80 to 0x87 (these parameters are read/write (read for inputs, write for outputs)):
Parameter | Bit | Description
0x80 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 0
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 1 (1A)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 2 (2A)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 3 (3A)
 | 16-19 | Digital inputs (read) or digital outputs (write), AS-i slave 4 (4A)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 5 (5A)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 6 (6A)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 7 (7A)
Parameter | Bit | Description
0x81 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 8 (8A)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 9 (9A)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 10 (10A)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 11 (11A)
 | 16-19 | Digital inputs (read) or digital outputs (write), AS-i slave 12 (12A)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 13 (13A)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 14 (14A)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 15 (15A)
0x82 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 16 (16A)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 17 (17A)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 18 (18A)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 19 (19A)
 | 16-19 | Digital inputs (read) or digital outputs (write), AS-i slave 20 (20A)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 21 (21A)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 22 (22A)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 23 (23A)
0x83 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 24 (24A)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 25 (25A)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 26 (26A)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 27 (27A)
 | 16-19 | Digital inputs (read) or digital outputs (write), AS-i slave 28 (28A)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 29 (29A)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 30 (30A)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 31 (31A)
0x84 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 33 (1B)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 34 (2B)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 35 (3B)
 | 16 to 19 | Digital inputs (read) or digital outputs (write), AS-i slave 36 (4B)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 37 (5B)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 38 (6B)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 39 (7B)
0x85 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 40 (8B)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 41 (9B)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 42 (10B)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 43 (11B)
 | 16 to 19 | Digital inputs (read) or digital outputs (write), AS-i slave 44 (12B)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 45 (13B)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 46 (14B)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 47 (15B)
0x86 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 48 (16B)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 49 (17B)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 50 (18B)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 51 (19B)
 | 16 to 19 | Digital inputs (read) or digital outputs (write), AS-i slave 52 (20B)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 53 (21B)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 54 (22B)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 55 (23B)
0x87 | 0 to 3 | Digital inputs (read) or digital outputs (write), AS-i slave 56 (24B)
 | 4 to 7 | Digital inputs (read) or digital outputs (write), AS-i slave 57 (25B)
 | 8 to 11 | Digital inputs (read) or digital outputs (write), AS-i slave 58 (26B)
 | 12 to 15 | Digital inputs (read) or digital outputs (write), AS-i slave 59 (27B)
 | 16 to 19 | Digital inputs (read) or digital outputs (write), AS-i slave 60 (28B)
 | 20 to 23 | Digital inputs (read) or digital outputs (write), AS-i slave 61 (29B)
 | 24 to 27 | Digital inputs (read) or digital outputs (write), AS-i slave 62 (30B)
 | 28 to 31 | Digital inputs (read) or digital outputs (write), AS-i slave 63 (31B)
Parameters 0x90 to 0x97: Read I/O ID (actual configuration)
Each AS-i slave has a 4-bit I/O ID, which is stored in parameters 0x90 to 0x97 (these parameters are read only):
Parameter | Bit | Description
0x90 | 0 to 3 | read I/O ID, AS-i slave 0
 | 4 to 7 | read I/O ID, AS-i slave 1 (1A)
 | 8 to 11 | read I/O ID, AS-i slave 2 (2A)
 | 12 to 15 | read I/O ID, AS-i slave 3 (3A)
 | 16 to 19 | read I/O ID, AS-i slave 4 (4A)
 | 20 to 23 | read I/O ID, AS-i slave 5 (5A)
 | 24 to 27 | read I/O ID, AS-i slave 6 (6A)
 | 28 to 31 | read I/O ID, AS-i slave 7 (7A)
0x91 | 0 to 3 | read I/O ID, AS-i slave 8 (8A)
 | 4 to 7 | read I/O ID, AS-i slave 9 (9A)
 | 8 to 11 | read I/O ID, AS-i slave 10 (10A)
 | 12 to 15 | read I/O ID, AS-i slave 11 (11A)
 | 16 to 19 | read I/O ID, AS-i slave 12 (12A)
 | 20 to 23 | read I/O ID, AS-i slave 13 (13A)
 | 24 to 27 | read I/O ID, AS-i slave 14 (14A)
 | 28 to 31 | read I/O ID, AS-i slave 15 (15A)
0x92 | 0 to 3 | read I/O ID, AS-i slave 16 (16A)
 | 4 to 7 | read I/O ID, AS-i slave 17 (17A)
 | 8 to 11 | read I/O ID, AS-i slave 18 (18A)
 | 12 to 15 | read I/O ID, AS-i slave 19 (19A)
 | 16 to 19 | read I/O ID, AS-i slave 20 (20A)
 | 20 to 23 | read I/O ID, AS-i slave 21 (21A)
 | 24 to 27 | read I/O ID, AS-i slave 22 (22A)
 | 28 to 31 | read I/O ID, AS-i slave 23 (23A)
0x93 | 0 to 3 | read I/O ID, AS-i slave 24 (24A)
 | 4 to 7 | read I/O ID, AS-i slave 25 (25A)
 | 8 to 11 | read I/O ID, AS-i slave 26 (26A)
 | 12 to 15 | read I/O ID, AS-i slave 27 (27A)
 | 16 to 19 | read I/O ID, AS-i slave 28 (28A)
 | 20 to 23 | read I/O ID, AS-i slave 29 (29A)
 | 24 to 27 | read I/O ID, AS-i slave 30 (30A)
 | 28 to 31 | read I/O ID, AS-i slave 31 (31A)
0x94 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | read I/O ID, AS-i slave 33 (1B)
 | 8 to 11 | read I/O ID, AS-i slave 34 (2B)
 | 12 to 15 | read I/O ID, AS-i slave 35 (3B)
 | 16 to 19 | read I/O ID, AS-i slave 36 (4B)
 | 20 to 23 | read I/O ID, AS-i slave 37 (5B)
 | 24 to 27 | read I/O ID, AS-i slave 38 (6B)
 | 28 to 31 | read I/O ID, AS-i slave 39 (7B)
0x95 | 0 to 3 | read I/O ID, AS-i slave 40 (8B)
 | 4 to 7 | read I/O ID, AS-i slave 41 (9B)
 | 8 to 11 | read I/O ID, AS-i slave 42 (10B)
 | 12 to 15 | read I/O ID, AS-i slave 43 (11B)
 | 16 to 19 | read I/O ID, AS-i slave 44 (12B)
 | 20 to 23 | read I/O ID, AS-i slave 45 (13B)
 | 24 to 27 | read I/O ID, AS-i slave 46 (14B)
 | 28 to 31 | read I/O ID, AS-i slave 47 (15B)
Parameter | Bit | Description
0x96 | 0 to 3 | read I/O ID, AS-i slave 48 (16B)
 | 4 to 7 | read I/O ID, AS-i slave 49 (17B)
 | 8 to 11 | read I/O ID, AS-i slave 50 (18B)
 | 12 to 15 | read I/O ID, AS-i slave 51 (19B)
 | 16 to 19 | read I/O ID, AS-i slave 52 (20B)
 | 20 to 23 | read I/O ID, AS-i slave 53 (21B)
 | 24 to 27 | read I/O ID, AS-i slave 54 (22B)
 | 28 to 31 | read I/O ID, AS-i slave 55 (23B)
0x97 | 0 to 3 | read I/O ID, AS-i slave 56 (24B)
 | 4 to 7 | read I/O ID, AS-i slave 57 (25B)
 | 8 to 11 | read I/O ID, AS-i slave 58 (26B)
 | 12 to 15 | read I/O ID, AS-i slave 59 (27B)
 | 16 to 19 | read I/O ID, AS-i slave 60 (28B)
 | 20 to 23 | read I/O ID, AS-i slave 61 (29B)
 | 24 to 27 | read I/O ID, AS-i slave 62 (30B)
 | 28 to 31 | read I/O ID, AS-i slave 63 (31B)
Parameters 0x98 to 0x9F: Read standard ID code (actual configuration)
Each AS-i slave has a 4-bit standard ID code, which is stored in parameters 0x98 to 0x9F (these parameters are read only):
Parameter | Bit | Description
0x98 | 0 to 3 | read ID code, AS-i slave 0
 | 4 to 7 | read ID code, AS-i slave 1 (1A)
 | 8 to 11 | read ID code, AS-i slave 2 (2A)
 | 12 to 15 | read ID code, AS-i slave 3 (3A)
 | 16 to 19 | read ID code, AS-i slave 4 (4A)
 | 20 to 23 | read ID code, AS-i slave 5 (5A)
 | 24 to 27 | read ID code, AS-i slave 6 (6A)
 | 28 to 31 | read ID code, AS-i slave 7 (7A)
0x99 | 0 to 3 | read ID code, AS-i slave 8 (8A)
 | 4 to 7 | read ID code, AS-i slave 9 (9A)
 | 8 to 11 | read ID code, AS-i slave 10 (10A)
 | 12 to 15 | read ID code, AS-i slave 11 (11A)
 | 16 to 19 | read ID code, AS-i slave 12 (12A)
 | 20 to 23 | read ID code, AS-i slave 13 (13A)
 | 24 to 27 | read ID code, AS-i slave 14 (14A)
 | 28 to 31 | read ID code, AS-i slave 15 (15A)
0x9A | 0 to 3 | read ID code, AS-i slave 16 (16A)
 | 4 to 7 | read ID code, AS-i slave 17 (17A)
 | 8 to 11 | read ID code, AS-i slave 18 (18A)
 | 12 to 15 | read ID code, AS-i slave 19 (19A)
 | 16 to 19 | read ID code, AS-i slave 20 (20A)
 | 20 to 23 | read ID code, AS-i slave 21 (21A)
 | 24 to 27 | read ID code, AS-i slave 22 (22A)
 | 28 to 31 | read ID code, AS-i slave 23 (23A)
0x9B | 0 to 3 | read ID code, AS-i slave 24 (24A)
 | 4 to 7 | read ID code, AS-i slave 25 (25A)
 | 8 to 11 | read ID code, AS-i slave 26 (26A)
 | 12 to 15 | read ID code, AS-i slave 27 (27A)
 | 16 to 19 | read ID code, AS-i slave 28 (28A)
 | 20 to 23 | read ID code, AS-i slave 29 (29A)
 | 24 to 27 | read ID code, AS-i slave 30 (30A)
 | 28 to 31 | read ID code, AS-i slave 31 (31A)
Parameter | Bit | Description
0x9C | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | read ID code, AS-i slave 33 (1B)
 | 8 to 11 | read ID code, AS-i slave 34 (2B)
 | 12 to 15 | read ID code, AS-i slave 35 (3B)
 | 16 to 19 | read ID code, AS-i slave 36 (4B)
 | 20 to 23 | read ID code, AS-i slave 37 (5B)
 | 24 to 27 | read ID code, AS-i slave 38 (6B)
 | 28 to 31 | read ID code, AS-i slave 39 (7B)
0x9D | 0 to 3 | read ID code, AS-i slave 40 (8B)
 | 4 to 7 | read ID code, AS-i slave 41 (9B)
 | 8 to 11 | read ID code, AS-i slave 42 (10B)
 | 12 to 15 | read ID code, AS-i slave 43 (11B)
 | 16 to 19 | read ID code, AS-i slave 44 (12B)
 | 20 to 23 | read ID code, AS-i slave 45 (13B)
 | 24 to 27 | read ID code, AS-i slave 46 (14B)
 | 28 to 31 | read ID code, AS-i slave 47 (15B)
0x9E | 0 to 3 | read ID code, AS-i slave 48 (16B)
 | 4 to 7 | read ID code, AS-i slave 49 (17B)
 | 8 to 11 | read ID code, AS-i slave 50 (18B)
 | 12 to 15 | read ID code, AS-i slave 51 (19B)
 | 16 to 19 | read ID code, AS-i slave 52 (20B)
 | 20 to 23 | read ID code, AS-i slave 53 (21B)
 | 24 to 27 | read ID code, AS-i slave 54 (22B)
 | 28 to 31 | read ID code, AS-i slave 55 (23B)
0x9F | 0 to 3 | read ID code, AS-i slave 56 (24B)
 | 4 to 7 | read ID code, AS-i slave 57 (25B)
 | 8 to 11 | read ID code, AS-i slave 58 (26B)
 | 12 to 15 | read ID code, AS-i slave 59 (27B)
 | 16 to 19 | read ID code, AS-i slave 60 (28B)
 | 20 to 23 | read ID code, AS-i slave 61 (29B)
 | 24 to 27 | read ID code, AS-i slave 62 (30B)
 | 28 to 31 | read ID code, AS-i slave 63 (31B)
Parameters 0xA0 to 0xA7: read status
Each AS-i slave has a 4-bit status, which is stored in parameters 0xA0 to 0xA7 (these parameters are read only):
Parameter | Bit | Description
0xA0 | 0 to 3 | Status, AS-i slave 0
 | 4 to 7 | status, AS-i slave 1 (1A)
 | 8 to 11 | status, AS-i slave 2 (2A)
 | 12 to 15 | status, AS-i slave 3 (3A)
 | 16 to 19 | status, AS-i slave 4 (4A)
 | 20 to 23 | status, AS-i slave 5 (5A)
 | 24 to 27 | status, AS-i slave 6 (6A)
 | 28 to 31 | status, AS-i slave 7 (7A)
0xA1 | 0 to 3 | status, AS-i slave 8 (8A)
 | 4 to 7 | status, AS-i slave 9 (9A)
 | 8 to 11 | status, AS-i slave 10 (10A)
 | 12 to 15 | status, AS-i slave 11 (11A)
 | 16 to 19 | status, AS-i slave 12 (12A)
 | 20 to 23 | status, AS-i slave 13 (13A)
 | 24 to 27 | status, AS-i slave 14 (14A)
 | 28 to 31 | status, AS-i slave 15 (15A)
Parameter | Bit | Description
0xA2 | 0 to 3 | status, AS-i slave 16 (16A)
 | 4 to 7 | status, AS-i slave 17 (17A)
 | 8 to 11 | status, AS-i slave 18 (18A)
 | 12 to 15 | status, AS-i slave 19 (19A)
 | 16 to 19 | status, AS-i slave 20 (20A)
 | 20 to 23 | status, AS-i slave 21 (21A)
 | 24 to 27 | status, AS-i slave 22 (22A)
 | 28 to 31 | status, AS-i slave 23 (23A)
0xA3 | 0 to 3 | status, AS-i slave 24 (24A)
 | 4 to 7 | status, AS-i slave 25 (25A)
 | 8 to 11 | status, AS-i slave 26 (26A)
 | 12 to 15 | status, AS-i slave 27 (27A)
 | 16 to 19 | status, AS-i slave 28 (28A)
 | 20 to 23 | status, AS-i slave 29 (29A)
 | 24 to 27 | status, AS-i slave 30 (30A)
 | 28 to 31 | status, AS-i slave 31 (31A)
0xA4 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | Status, AS-i slave 33 (1B)
 | 8 to 11 | Status, AS-i slave 34 (2B)
 | 12 to 15 | Status, AS-i slave 35 (3B)
 | 16 to 19 | Status, AS-i slave 36 (4B)
 | 20 to 23 | Status, AS-i slave 37 (5B)
 | 24 to 27 | Status, AS-i slave 38 (6B)
 | 28 to 31 | Status, AS-i slave 39 (7B)
0xA5 | 0 to 3 | Status, AS-i slave 40 (8B)
 | 4 to 7 | Status, AS-i slave 41 (9B)
 | 8 to 11 | Status, AS-i slave 42 (10B)
 | 12 to 15 | Status, AS-i slave 43 (11B)
 | 16 to 19 | Status, AS-i slave 44 (12B)
 | 20 to 23 | Status, AS-i slave 45 (13B)
 | 24 to 27 | Status, AS-i slave 46 (14B)
 | 28 to 31 | Status, AS-i slave 47 (15B)
0xA6 | 0 to 3 | Status, AS-i slave 48 (16B)
 | 4 to 7 | Status, AS-i slave 49 (17B)
 | 8 to 11 | Status, AS-i slave 50 (18B)
 | 12 to 15 | Status, AS-i slave 51 (19B)
 | 16 to 19 | Status, AS-i slave 52 (20B)
 | 20 to 23 | Status, AS-i slave 53 (21B)
 | 24 to 27 | Status, AS-i slave 54 (22B)
 | 28 to 31 | Status, AS-i slave 55 (23B)
0xA7 | 0 to 3 | Status, AS-i slave 56 (24B)
 | 4 to 7 | Status, AS-i slave 57 (25B)
 | 8 to 11 | Status, AS-i slave 58 (26B)
 | 12 to 15 | Status, AS-i slave 59 (27B)
 | 16 to 19 | Status, AS-i slave 60 (28B)
 | 20 to 23 | Status, AS-i slave 61 (29B)
 | 24 to 27 | Status, AS-i slave 62 (30B)
 | 28 to 31 | Status, AS-i slave 63 (31B)
Parameters 0xA8 and 0xA9: List of currently projected AS-i slaves (LPS)
This list contains the currently projected AS-i slaves. As soon as at least one AS-i slave from this list is projected, the AS-i master is in protected mode. This list is only updated during the transition from the offline phase to the detection phase, with the list of the AS-i slaves projected at the next start being read. For each AS-i slave, parameters 0xA8 and 0xA9 contain a bit that indicates whether the respective AS-i slave is projected (this parameter is read only):
Parameter | Bit | Description
0xA8 | 0 | reserved
 | 1 | 0bin: AS-i slave 1 (1A) is not projected 1bin: AS-i slave 1 (1A) is projected
 | ... | ...
 | 31 | 0bin: AS-i slave 31 (31A) is not projected 1bin: AS-i slave 31 (31A) is projected
0xA9 | 0 | reserved
 | 1 | 0bin: AS-i slave 33 (1B) is not projected 1bin: AS-i slave 33 (1B) is projected
 | ... | ...
 | 31 | 0bin: AS-i slave 63 (31B) is not projected 1bin: AS-i slave 63 (31B) is projected
Parameters 0xB0 and 0xB1: List of currently detected AS-i slaves (LDS)
This list contains the AS-i slaves that are currently detected at the bus. For each AS-i slave, parameters 0xB0 and 0xB1 contain a bit that indicates whether the respective AS-i slave was detected (this parameter is read only):
Parameter | Bit | Description
0xB0 | 0 | reserved
 | 1 | 0bin: AS-i slave 1 (1A) was not detected 1bin: AS-i slave 1 (1A) was detected
 | ... | ...
 | 31 | 0bin: AS-i slave 31 (31A) was not detected 1bin: AS-i slave 31 (31A) was detected
0xB1 | 0 | reserved
 | 1 | 0bin: AS-i slave 33 (1B) was not detected 1bin: AS-i slave 33 (1B) was detected
 | ... | ...
 | 31 | 0bin: AS-i slave 63 (31B) was not detected 1bin: AS-i slave 63 (31B) was detected
Parameters 0xC0 and 0xC1: List of slaves that support the extended ID codes (ID codes 1 and 2)
Parameter | Bit | Description
0xC0 | 0 | Slave 0 supports extended ID codes
 | 1 | Slave 1 (1A) supports extended ID codes
 | ... | ...
 | 31 | Slave 31 (31A) supports extended ID codes
0xC1 | 0 | free
 | 1 | Slave 1 (1A) supports extended ID codes
 | ... | ...
 | 31 | Slave 31 (31A) supports extended ID codes
Parameter 0xC8: List of slaves that support extended addressing (as B slaves with addresses greater than 32)
Parameter | Bit | Description
0xC8 | 0 | Slave 0 supports extended addressing
 | 1 | Slave 1 (1A) supports extended addressing
 | ... | ...
 | 31 | Slave 31 (31A) supports extended addressing
Parameters 0xB8 and 0xB9: List of activated AS-i slaves (LAS)
This list contains the AS-i slaves that are currently activated on the bus. In projecting mode, all detected AS-i slaves are activated. In protected mode, only those projected AS-i slaves with matching ID code and I/O ID in the actual and set configuration are activated. For each AS-i slave, parameters 0xB8 and 0xB9 contain a bit that indicates whether the respective AS-i slave was activated (this parameter is read only):
Parameter | Bit | Description
0xB8 | 0 | reserved
 | 1 | 0bin: AS-i slave 1 (1A) was not activated 1bin: AS-i slave 1 (1A) was activated
 | ... | ...
 | 31 | 0bin: AS-i slave 31 (31A) was not activated 1bin: AS-i slave 31 (31A) was activated
0xB9 | 0 | reserved
 | 1 | 0bin: AS-i slave 33 (1B) was not activated 1bin: AS-i slave 33 (1B) was activated
 | ... | ...
 | 31 | 0bin: AS-i slave 63 (31B) was not activated 1bin: AS-i slave 63 (31B) was activated
Parameters 0xD0 to 0xD7: Read extended ID code 1 (actual configuration)
AS-i slaves optionally have a 4-bit extended ID code 1, which is stored in parameters 0xD0 to 0xD7 (these parameters are read only):
Parameter | Bit | Description
0xD0 | 0 to 3 | read extended ID code 1, AS-i slave 0
 | 4 to 7 | read extended ID code 1, AS-i slave 1 (1A)
 | 8 to 11 | read extended ID code 1, AS-i slave 2 (2A)
 | 12 to 15 | read extended ID code 1, AS-i slave 3 (3A)
 | 16 to 19 | read extended ID code 1, AS-i slave 4 (4A)
 | 20 to 23 | read extended ID code 1, AS-i slave 5 (5A)
 | 24 to 27 | read extended ID code 1, AS-i slave 6 (6A)
 | 28 to 31 | read extended ID code 1, AS-i slave 7 (7A)
0xD1 | 0 to 3 | read extended ID code 1, AS-i slave 8 (8A)
 | 4 to 7 | read extended ID code 1, AS-i slave 9 (9A)
 | 8 to 11 | read extended ID code 1, AS-i slave 10 (10A)
 | 12 to 15 | read extended ID code 1, AS-i slave 11 (11A)
 | 16 to 19 | read extended ID code 1, AS-i slave 12 (12A)
 | 20 to 23 | read extended ID code 1, AS-i slave 13 (13A)
 | 24 to 27 | read extended ID code 1, AS-i slave 14 (14A)
 | 28 to 31 | read extended ID code 1, AS-i slave 15 (15A)
0xD2 | 0 to 3 | read extended ID code 1, AS-i slave 16 (16A)
 | 4 to 7 | read extended ID code 1, AS-i slave 17 (17A)
 | 8 to 11 | read extended ID code 1, AS-i slave 18 (18A)
 | 12 to 15 | read extended ID code 1, AS-i slave 19 (19A)
 | 16 to 19 | read extended ID code 1, AS-i slave 20 (20A)
 | 20 to 23 | read extended ID code 1, AS-i slave 21 (21A)
 | 24 to 27 | read extended ID code 1, AS-i slave 22 (22A)
 | 28 to 31 | read extended ID code 1, AS-i slave 23 (23A)
Parameter | Bit | Description
0xD3 | 0 to 3 | read extended ID code 1, AS-i slave 24 (24A)
 | 4 to 7 | read extended ID code 1, AS-i slave 25 (25A)
 | 8 to 11 | read extended ID code 1, AS-i slave 26 (26A)
 | 12 to 15 | read extended ID code 1, AS-i slave 27 (27A)
 | 16 to 19 | read extended ID code 1, AS-i slave 28 (28A)
 | 20 to 23 | read extended ID code 1, AS-i slave 29 (29A)
 | 24 to 27 | read extended ID code 1, AS-i slave 30 (30A)
 | 28 to 31 | read extended ID code 1, AS-i slave 31 (31A)
0xD4 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | read extended ID code 1, AS-i slave 33 (1B)
 | 8 to 11 | read extended ID code 1, AS-i slave 34 (2B)
 | 12 to 15 | read extended ID code 1, AS-i slave 35 (3B)
 | 16 to 19 | read extended ID code 1, AS-i slave 36 (4B)
 | 20 to 23 | read extended ID code 1, AS-i slave 37 (5B)
 | 24 to 27 | read extended ID code 1, AS-i slave 38 (6B)
 | 28 to 31 | read extended ID code 1, AS-i slave 39 (7B)
0xD5 | 0 to 3 | read extended ID code 1, AS-i slave 40 (8B)
 | 4 to 7 | read extended ID code 1, AS-i slave 41 (9B)
 | 8 to 11 | read extended ID code 1, AS-i slave 42 (10B)
 | 12 to 15 | read extended ID code 1, AS-i slave 43 (11B)
 | 16 to 19 | read extended ID code 1, AS-i slave 44 (12B)
 | 20 to 23 | read extended ID code 1, AS-i slave 45 (13B)
 | 24 to 27 | read extended ID code 1, AS-i slave 46 (14B)
 | 28 to 31 | read extended ID code 1, AS-i slave 47 (15B)
0xD6 | 0 to 3 | read extended ID code 1, AS-i slave 48 (16B)
 | 4 to 7 | read extended ID code 1, AS-i slave 49 (17B)
 | 8 to 11 | read extended ID code 1, AS-i slave 50 (18B)
 | 12 to 15 | read extended ID code 1, AS-i slave 51 (19B)
 | 16 to 19 | read extended ID code 1, AS-i slave 52 (20B)
 | 20 to 23 | read extended ID code 1, AS-i slave 53 (21B)
 | 24 to 27 | read extended ID code 1, AS-i slave 54 (22B)
 | 28 to 31 | read extended ID code 1, AS-i slave 55 (23B)
0xD7 | 0 to 3 | read extended ID code 1, AS-i slave 56 (24B)
 | 4 to 7 | read extended ID code 1, AS-i slave 57 (25B)
 | 8 to 11 | read extended ID code 1, AS-i slave 58 (26B)
 | 12 to 15 | read extended ID code 1, AS-i slave 59 (27B)
 | 16 to 19 | read extended ID code 1, AS-i slave 60 (28B)
 | 20 to 23 | read extended ID code 1, AS-i slave 61 (29B)
 | 24 to 27 | read extended ID code 1, AS-i slave 62 (30B)
 | 28 to 31 | read extended ID code 1, AS-i slave 63 (31B)
Parameters 0xD8 to 0xDF: Read extended ID code 2 (actual configuration)
AS-i slaves optionally have a 4-bit extended ID code 2, which is stored in parameters 0xD8 to 0xDF (these parameters are read only):
Parameter | Bit | Description
0xD8 | 0 to 3 | read extended ID code 2, AS-i slave 0
 | 4 to 7 | read extended ID code 2, AS-i slave 1 (1A)
 | 8 to 11 | read extended ID code 2, AS-i slave 2 (2A)
 | 12 to 15 | read extended ID code 2, AS-i slave 3 (3A)
 | 16 to 19 | read extended ID code 2, AS-i slave 4 (4A)
 | 20 to 23 | read extended ID code 2, AS-i slave 5 (5A)
 | 24 to 27 | read extended ID code 2, AS-i slave 6 (6A)
 | 28 to 31 | read extended ID code 2, AS-i slave 7 (7A)
Parameter | Bit | Description
0xD9 | 0 to 3 | read extended ID code 2, AS-i slave 8 (8A)
 | 4 to 7 | read extended ID code 2, AS-i slave 9 (9A)
 | 8 to 11 | read extended ID code 2, AS-i slave 10 (10A)
 | 12 to 15 | read extended ID code 2, AS-i slave 11 (11A)
 | 16 to 19 | read extended ID code 2, AS-i slave 12 (12A)
 | 20 to 23 | read extended ID code 2, AS-i slave 13 (13A)
 | 24 to 27 | read extended ID code 2, AS-i slave 14 (14A)
 | 28 to 31 | read extended ID code 2, AS-i slave 15 (15A)
0xDA | 0 to 3 | read extended ID code 2, AS-i slave 16 (16A)
 | 4 to 7 | read extended ID code 2, AS-i slave 17 (17A)
 | 8 to 11 | read extended ID code 2, AS-i slave 18 (18A)
 | 12 to 15 | read extended ID code 2, AS-i slave 19 (19A)
 | 16 to 19 | read extended ID code 2, AS-i slave 20 (20A)
 | 20 to 23 | read extended ID code 2, AS-i slave 21 (21A)
 | 24 to 27 | read extended ID code 2, AS-i slave 22 (22A)
 | 28 to 31 | read extended ID code 2, AS-i slave 23 (23A)
0xDB | 0 to 3 | read extended ID code 2, AS-i slave 24 (24A)
 | 4 to 7 | read extended ID code 2, AS-i slave 25 (25A)
 | 8 to 11 | read extended ID code 2, AS-i slave 26 (26A)
 | 12 to 15 | read extended ID code 2, AS-i slave 27 (27A)
 | 16 to 19 | read extended ID code 2, AS-i slave 28 (28A)
 | 20 to 23 | read extended ID code 2, AS-i slave 29 (29A)
 | 24 to 27 | read extended ID code 2, AS-i slave 30 (30A)
 | 28 to 31 | read extended ID code 2, AS-i slave 31 (31A)
0xDC | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | read extended ID code 2, AS-i slave 33 (1B)
 | 8 to 11 | read extended ID code 2, AS-i slave 34 (2B)
 | 12 to 15 | read extended ID code 2, AS-i slave 35 (3B)
 | 16 to 19 | read extended ID code 2, AS-i slave 36 (4B)
 | 20 to 23 | read extended ID code 2, AS-i slave 37 (5B)
 | 24 to 27 | read extended ID code 2, AS-i slave 38 (6B)
 | 28 to 31 | read extended ID code 2, AS-i slave 39 (7B)
0xDD | 0 to 3 | read extended ID code 2, AS-i slave 40 (8B)
 | 4 to 7 | read extended ID code 2, AS-i slave 41 (9B)
 | 8 to 11 | read extended ID code 2, AS-i slave 42 (10B)
 | 12 to 15 | read extended ID code 2, AS-i slave 43 (11B)
 | 16 to 19 | read extended ID code 2, AS-i slave 44 (12B)
 | 20 to 23 | read extended ID code 2, AS-i slave 45 (13B)
 | 24 to 27 | read extended ID code 2, AS-i slave 46 (14B)
 | 28 to 31 | read extended ID code 2, AS-i slave 47 (15B)
0xDE | 0 to 3 | read extended ID code 2, AS-i slave 48 (16B)
 | 4 to 7 | read extended ID code 2, AS-i slave 49 (17B)
 | 8 to 11 | read extended ID code 2, AS-i slave 50 (18B)
 | 12 to 15 | read extended ID code 2, AS-i slave 51 (19B)
 | 16 to 19 | read extended ID code 2, AS-i slave 52 (20B)
 | 20 to 23 | read extended ID code 2, AS-i slave 53 (21B)
 | 24 to 27 | read extended ID code 2, AS-i slave 54 (22B)
 | 28 to 31 | read extended ID code 2, AS-i slave 55 (23B)
0xDF | 0 to 3 | read extended ID code 2, AS-i slave 56 (24B)
 | 4 to 7 | read extended ID code 2, AS-i slave 57 (25B)
 | 8 to 11 | read extended ID code 2, AS-i slave 58 (26B)
 | 12 to 15 | read extended ID code 2, AS-i slave 59 (27B)
 | 16 to 19 | read extended ID code 2, AS-i slave 60 (28B)
 | 20 to 23 | read extended ID code 2, AS-i slave 61 (29B)
 | 24 to 27 | read extended ID code 2, AS-i slave 62 (30B)
 | 28 to 31 | read extended ID code 2, AS-i slave 63 (31B)
Parameters 0xE0 to 0xE7: Projected extended ID code 1 (nominal configuration)
In protected mode, the extended ID code 1 of the currently projected AS-i slaves is checked. The currently projected 4-bit extended ID codes 1 of the AS-i slaves are located in parameters 0xE0 to 0xE7 (these parameters are read/write and are stored in the flash of the AS-i master (i.e. they are still available after power off/on)):
Parameter | Bit | Description
0xE0 | 0 to 3 | reserved
 | 4 to 7 | projected extended ID code 1, AS-i slave 1 (1A)
 | 8 to 11 | projected extended ID code 1, AS-i slave 2 (2A)
 | 12 to 15 | projected extended ID code 1, AS-i slave 3 (3A)
 | 16 to 19 | projected extended ID code 1, AS-i slave 4 (4A)
 | 20 to 23 | projected extended ID code 1, AS-i slave 5 (5A)
 | 24 to 27 | projected extended ID code 1, AS-i slave 6 (6A)
 | 28 to 31 | projected extended ID code 1, AS-i slave 7 (7A)
0xE1 | 0 to 3 | projected extended ID code 1, AS-i slave 8 (8A)
 | 4 to 7 | projected extended ID code 1, AS-i slave 9 (9A)
 | 8 to 11 | projected extended ID code 1, AS-i slave 10 (10A)
 | 12 to 15 | projected extended ID code 1, AS-i slave 11 (11A)
 | 16 to 19 | projected extended ID code 1, AS-i slave 12 (12A)
 | 20 to 23 | projected extended ID code 1, AS-i slave 13 (13A)
 | 24 to 27 | projected extended ID code 1, AS-i slave 14 (14A)
 | 28 to 31 | projected extended ID code 1, AS-i slave 15 (15A)
0xE2 | 0 to 3 | projected extended ID code 1, AS-i slave 16 (16A)
 | 4 to 7 | projected extended ID code 1, AS-i slave 17 (17A)
 | 8 to 11 | projected extended ID code 1, AS-i slave 18 (18A)
 | 12 to 15 | projected extended ID code 1, AS-i slave 19 (19A)
 | 16 to 19 | projected extended ID code 1, AS-i slave 20 (20A)
 | 20 to 23 | projected extended ID code 1, AS-i slave 21 (21A)
 | 24 to 27 | projected extended ID code 1, AS-i slave 22 (22A)
 | 28 to 31 | projected extended ID code 1, AS-i slave 23 (23A)
0xE3 | 0 to 3 | projected extended ID code 1, AS-i slave 24 (24A)
 | 4 to 7 | projected extended ID code 1, AS-i slave 25 (25A)
 | 8 to 11 | projected extended ID code 1, AS-i slave 26 (26A)
 | 12 to 15 | projected extended ID code 1, AS-i slave 27 (27A)
 | 16 to 19 | projected extended ID code 1, AS-i slave 28 (28A)
 | 20 to 23 | projected extended ID code 1, AS-i slave 29 (29A)
 | 24 to 27 | projected extended ID code 1, AS-i slave 30 (30A)
 | 28 to 31 | projected extended ID code 1, AS-i slave 31 (31A)
0xE4 | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | projected extended ID code 1, AS-i slave 33 (1B)
 | 8 to 11 | projected extended ID code 1, AS-i slave 34 (2B)
 | 12 to 15 | projected extended ID code 1, AS-i slave 35 (3B)
 | 16 to 19 | projected extended ID code 1, AS-i slave 36 (4B)
 | 20 to 23 | projected extended ID code 1, AS-i slave 37 (5B)
 | 24 to 27 | projected extended ID code 1, AS-i slave 38 (6B)
 | 28 to 31 | projected extended ID code 1, AS-i slave 39 (7B)
0xE5 | 0 to 3 | projected extended ID code 1, AS-i slave 40 (8B)
 | 4 to 7 | projected extended ID code 1, AS-i slave 41 (9B)
 | 8 to 11 | projected extended ID code 1, AS-i slave 42 (10B)
 | 12 to 15 | projected extended ID code 1, AS-i slave 43 (11B)
 | 16 to 19 | projected extended ID code 1, AS-i slave 44 (12B)
 | 20 to 23 | projected extended ID code 1, AS-i slave 45 (13B)
 | 24 to 27 | projected extended ID code 1, AS-i slave 46 (14B)
 | 28 to 31 | projected extended ID code 1, AS-i slave 47 (15B)
Parameter | Bit | Description
0xE6 | 0 to 3 | projected extended ID code 1, AS-i slave 48 (16B)
 | 4 to 7 | projected extended ID code 1, AS-i slave 49 (17B)
 | 8 to 11 | projected extended ID code 1, AS-i slave 50 (18B)
 | 12 to 15 | projected extended ID code 1, AS-i slave 51 (19B)
 | 16 to 19 | projected extended ID code 1, AS-i slave 52 (20B)
 | 20 to 23 | projected extended ID code 1, AS-i slave 53 (21B)
 | 24 to 27 | projected extended ID code 1, AS-i slave 54 (22B)
 | 28 to 31 | projected extended ID code 1, AS-i slave 55 (23B)
0xE7 | 0 to 3 | projected extended ID code 1, AS-i slave 56 (24B)
 | 4 to 7 | projected extended ID code 1, AS-i slave 57 (25B)
 | 8 to 11 | projected extended ID code 1, AS-i slave 58 (26B)
 | 12 to 15 | projected extended ID code 1, AS-i slave 59 (27B)
 | 16 to 19 | projected extended ID code 1, AS-i slave 60 (28B)
 | 20 to 23 | projected extended ID code 1, AS-i slave 61 (29B)
 | 24 to 27 | projected extended ID code 1, AS-i slave 62 (30B)
 | 28 to 31 | projected extended ID code 1, AS-i slave 63 (31B)
Parameters 0xE8 to 0xEF: Projected extended ID code 2 (nominal configuration)
In protected mode, the extended ID code 2 of the currently projected AS-i slaves is checked. The currently projected 4-bit ID codes of the AS-i slaves are located in parameters 0xE8 to 0xEF (these parameters are read/write and are stored in the flash of the AS-i master (i.e. they are still available after power off/on)):
Parameter | Bit | Description
0xE8 | 0 to 3 | reserved
 | 4 to 7 | projected extended ID code 2, AS-i slave 1 (1A)
 | 8 to 11 | projected extended ID code 2, AS-i slave 2 (2A)
 | 12 to 15 | projected extended ID code 2, AS-i slave 3 (3A)
 | 16 to 19 | projected extended ID code 2, AS-i slave 4 (4A)
 | 20 to 23 | projected extended ID code 2, AS-i slave 5 (5A)
 | 24 to 27 | projected extended ID code 2, AS-i slave 6 (6A)
 | 28 to 31 | projected extended ID code 2, AS-i slave 7 (7A)
0xE9 | 0 to 3 | projected extended ID code 2, AS-i slave 8 (8A)
 | 4 to 7 | projected extended ID code 2, AS-i slave 9 (9A)
 | 8 to 11 | projected extended ID code 2, AS-i slave 10 (10A)
 | 12 to 15 | projected extended ID code 2, AS-i slave 11 (11A)
 | 16 to 19 | projected extended ID code 2, AS-i slave 12 (12A)
 | 20 to 23 | projected extended ID code 2, AS-i slave 13 (13A)
 | 24 to 27 | projected extended ID code 2, AS-i slave 14 (14A)
 | 28 to 31 | projected extended ID code 2, AS-i slave 15 (15A)
0xE/A | 0 to 3 | projected extended ID code 2, AS-i slave 16 (16A)
 | 4 to 7 | projected extended ID code 2, AS-i slave 17 (17A)
 | 8 to 11 | projected extended ID code 2, AS-i slave 18 (18A)
 | 12 to 15 | projected extended ID code 2, AS-i slave 19 (19A)
 | 16 to 19 | projected extended ID code 2, AS-i slave 20 (20A)
 | 20 to 23 | projected extended ID code 2, AS-i slave 21 (21A)
 | 24 to 27 | projected extended ID code 2, AS-i slave 22 (22A)
 | 28 to 31 | projected extended ID code 2, AS-i slave 23 (23A)
0xEB | 0 to 3 | projected extended ID code 2, AS-i slave 24 (24A)
 | 4 to 7 | projected extended ID code 2, AS-i slave 25 (25A)
 | 8 to 11 | projected extended ID code 2, AS-i slave 26 (26A)
 | 12 to 15 | projected extended ID code 2, AS-i slave 27 (27A)
 | 16 to 19 | projected extended ID code 2, AS-i slave 28 (28A)
 | 20 to 23 | projected extended ID code 2, AS-i slave 29 (29A)
 | 24 to 27 | projected extended ID code 2, AS-i slave 30 (30A)
 | 28 to 31 | projected extended ID code 2, AS-i slave 31 (31A)
Parameter | Bit | Description
0xEC | 0 to 3 | Reserved (AS-i slave address 32 is not permitted)
 | 4 to 7 | projected extended ID code 2, AS-i slave 33 (1B)
 | 8 to 11 | projected extended ID code 2, AS-i slave 34 (2B)
 | 12 to 15 | projected extended ID code 2, AS-i slave 35 (3B)
 | 16 to 19 | projected extended ID code 2, AS-i slave 36 (4B)
 | 20 to 23 | projected extended ID code 2, AS-i slave 37 (5B)
 | 24 to 27 | projected extended ID code 2, AS-i slave 38 (6B)
 | 28 to 31 | projected extended ID code 2, AS-i slave 39 (7B)
0xED | 0 to 3 | projected extended ID code 2, AS-i slave 40 (8B)
 | 4 to 7 | projected extended ID code 2, AS-i slave 41 (9B)
 | 8 to 11 | projected extended ID code 2, AS-i slave 42 (10B)
 | 12 to 15 | projected extended ID code 2, AS-i slave 43 (11B)
 | 16 to 19 | projected extended ID code 2, AS-i slave 44 (12B)
 | 20 to 23 | projected extended ID code 2, AS-i slave 45 (13B)
 | 24 to 27 | projected extended ID code 2, AS-i slave 46 (14B)
 | 28 to 31 | projected extended ID code 2, AS-i slave 47 (15B)
0xEE | 0 to 3 | projected extended ID code 2, AS-i slave 48 (16B)
 | 4 to 7 | projected extended ID code 2, AS-i slave 49 (17B)
 | 8 to 11 | projected extended ID code 2, AS-i slave 50 (18B)
 | 12 to 15 | projected extended ID code 2, AS-i slave 51 (19B)
 | 16 to 19 | projected extended ID code 2, AS-i slave 52 (20B)
 | 20 to 23 | projected extended ID code 2, AS-i slave 53 (21B)
 | 24 to 27 | projected extended ID code 2, AS-i slave 54 (22B)
 | 28 to 31 | projected extended ID code 2, AS-i slave 55 (23B)
0xEF | 0 to 3 | projected extended ID code 2, AS-i slave 56 (24B)
 | 4 to 7 | projected extended ID code 2, AS-i slave 57 (25B)
 | 8 to 11 | projected extended ID code 2, AS-i slave 58 (26B)
 | 12 to 15 | projected extended ID code 2, AS-i slave 59 (27B)
 | 16 to 19 | projected extended ID code 2, AS-i slave 60 (28B)
 | 20 to 23 | projected extended ID code 2, AS-i slave 61 (29B)
 | 24 to 27 | projected extended ID code 2, AS-i slave 62 (30B)
 | 28 to 31 | projected extended ID code 2, AS-i slave 63 (31B)
Parameter 0xF0: List of analog slaves
(only up to address 31, because analog slaves do not support extended addressing)
Parameter | Bit | Description
0xF0 | 0 | Slave 0 is an analog slave
 | 1 | Slave 1 is an analog slave
 | ... | ...
 | 31 | Slave 31 is an analog slave
Parameter 0xF8: List of safety slaves
(only up to address 31, because safety slaves do not support extended addressing)
Parameter | Bit | Description
0xF8 | 0 | Slave 0 is a safety slave
 | 1 | Slave 1 is a safety slave
 | ... | ...
 | 31 | Slave 31 is a safety slave
Parameter 0x100: AS-i command interface
Commands can be sent to the AS-i slaves via parameter 0x100. This is possible both during the offline phase (no other commands on the AS-i bus) and during the management phase. During the management phase, only non-activated AS-i slaves can be addressed (this parameter is write only).
Parameter
Bit
Value
Description
0x100
0 to 7
0 to 255
must be unequal 0 in order for the command to be sent
8 to 15
1
ASI command for reading ID code
2
ASI command for reading the EA ID
3
ASI command for reading the status
4
AS-i command write parameter
5
ASI command for data exchange
6
ASI command for resetting an ASI slave
7
AS-i command addressing call
If an address in bits 16 to 23 is not equal 0, the AS-i command "Delete operating address" must be called first, because the address can only be set if it was previously 0.
8
AS-i command Delete operating address
16 to 23
0 to 31
Address of the AS-i slave for which the command is intended
24 to 31
0 to 31
AS-i command data:
▪
for AS-i command Write parameter: Parameter data
▪
for AS-i command Addressing call: new address
Acknowledge
If AS-i parameter 0x100 is written to the KL6201/KL6211 via register communication, the following information is returned as acknowledgement:
Parameter | Bit | Description
Acknowledgement to 0x100 | 7 to 0 | always 0
 | 14 to 8 | Corresponding to bits 0 to 14 of the command call.
 | 15 | Error bit: If bit 15 is set, an error occurred during command execution, and an error code is issued in bits 31 to 24!
 | 23 to 16 | Address of the AS-i slave to which the command was sent.
 | 31 to 24 | Acknowledgement of the AS-i command for parameter writing (bit 4 of the AS-i commands was set): Bits 31 to 24 return the data transferred when the AS-i command was called (bits 31 to 24 of the AS-i command). Acknowledgement of the AS-i command for addressing call (bit 7 of the AS-i command was set):addressing call If the error bit (bit 15) is not set, bits 31 to 24 contain the value 00hex. If the error bit (bit 15) is set, bits 31 to 24 contain an error code. This error code is also issued if AS-i addresses are modified via the KS2000 configuration software.
 |  | 0x00 | Address modification was successful.
 |  | 0x11 | No slave exists with an address that was specified as the old address.
 |  | 0x22 | Address 0 is currently assigned to another slave. To change the address of an AS-i slave, the KL6201/KL6211 first has to assign the address 0 to it, before a new address can be assigned.
 |  | 0x36 | A slave with the address that was specified as the new address already exists.
 |  | 0x47 | After deleting the old address, no slave with address 0 exists.
 |  | 0x58 | After deleting the old address, an error is generated during reading of the extended ID code 1 of slave 0. Address changes for A/B slaves also require the extended ID code 1.
 |  | 0x69 | After writing of extended ID code 1, no slave with address 0 exists.
 |  | 0x6B | After writing of the new address, the slave with the new address is not available during reading of the ID code.
 |  | 0x6C | After writing of the new address, the slave with the new address is not available during reading of the status.
 |  | 0x7D | The address could not be saved permanently (non-volatile).
 |  | 0x7E | The extended ID code of an A/B slave could not be saved permanently (non-volatile).
 |  | 0x7F | ID code 1 is invalid for A/B slaves
 |  | 0x83 | The new address is a B address. If slaves are to be operated on two parallel addresses in address ranges A and B, e.g. 10A (10) and 10B (42), both slaves have to support B addressing. In this case, the parallel A address contains a slave that does not support B addressing!
 |  | 0x84 | The new address is a B address. The slave selected with the old address is not an A/B slave, i.e. it does not support the B addresses (33 to 63).
 |  | 0x85 | The new address is an A address. Slave is not an A/B slave: the associated B slave for the new address exists.
Parameter 0x108: General command interface
Parameter 0x108 can be used to execute general commands (this parameter is write only):
Parameter | Bit | Value | Description
0x108 | 0 to 15 | 0x0210 | The detected AS-i slaves are automatically projected (all AS-i slaves from the LDS are entered in the LPS, including read ID codes and I/O IDs)
 | 16 to 31 | 0 | reserved
0x108 | 0 to 15 | 0x0301 | Specifies which data exchange repeat counter is addressed via parameters 0x340 to 0x35F.
 | 16 to 24 | 0x01 | Repeat counter for one repetition of the data exchange telegram
 |  | 0x02 | Repeat counter for two repetitions of the data exchange telegram
 |  | 0x03 | Repeat counter for three repetitions of the data exchange telegram
 |  | 0x04 | Repeat counter for four repetitions of the data exchange telegram
 |  | 0x05 | Repeat counter for five repetitions of the data exchange telegram
 | 25 to 31 | 0 | reserved
0x108 | 0 to 15 | 0x0C00 | Initialization of the string transfer to slave profile 7.4
 |  | 0x0C10 | Command Read_ID_String
 |  | 0x0C20 | Command Read_Diagnosis_String
 |  | 0x0C30 | Command Read_Parameter_String
 |  | 0x0C40 | Command Write_Parameter_String
 | 16 to 23 | 0...62 | Slave address
 | 24 to 31 | 0 | reserved
Parameters 0x120 to 0x12F: General status information
Parameter 0x120 ff contains general status information for the KL6201/KL6211 and the connected AS-i network.
Parameter | Bit | Description
0x120 | 0 to 15 | Startup status (0: no error)
 | 16 to 31 | Status of automatic project configuration (0: no error)
0x121 to 0x127 | in each case 0 to 31 | reserved
0x128 to 0x12F | in each case 0 to 31 | reserved
Parameters 0x140 to 0x15F: Physical fault counter
Each AS-i slave has a counter that is incremented if a response from the associated AS-i slave had a start bit, stop bit or parity bit error (this parameter is read/write):
Parameter | Bit | Description
0x140 | 0 to 15 | Physical fault counter, AS-i slave 0
 | 16 to 31 | Physical fault counter, AS-i slave 1 (1A)
0x141 | 0 to 15 | Physical fault counter, AS-i slave 2 (2A)
 | 16 to 31 | Physical fault counter, AS-i slave 3 (3A)
0x142 | 0 to 15 | Physical fault counter, AS-i slave 4 (4A)
 | 16 to 31 | Physical fault counter, AS-i slave 5 (5A)
0x143 | 0 to 15 | Physical fault counter, AS-i slave 6 (6A)
 | 16 to 31 | Physical fault counter, AS-i slave 7 (7A)
0x144 | 0 to 15 | Physical fault counter, AS-i slave 8 (8A)
 | 16 to 31 | Physical fault counter, AS-i slave 9 (9A)
0x145 | 0 to 15 | Physical fault counter, AS-i slave 10 (10A)
 | 16 to 31 | Physical fault counter, AS-i slave 11 (11A)
0x146 | 0 to 15 | Physical fault counter, AS-i slave 12 (12A)
 | 16 to 31 | Physical fault counter, AS-i slave 13 (13A)
0x147 | 0 to 15 | Physical fault counter, AS-i slave 14 (14A)
 | 16 to 31 | Physical fault counter, AS-i slave 15 (15A)
0x148 | 0 to 15 | Physical fault counter, AS-i slave 16 (16A)
 | 16 to 31 | Physical fault counter, AS-i slave 17 (17A)
Parameter | Bit | Description
0x149 | 0 to 15 | Physical fault counter, AS-i slave 18 (18A)
 | 16 to 31 | Physical fault counter, AS-i slave 19 (19A)
0x14A | 0 to 15 | Physical fault counter, AS-i slave 20 (20A)
 | 16 to 31 | Physical fault counter, AS-i slave 21 (21A)
0x14B | 0 to 15 | Physical fault counter, AS-i slave 22 (22A)
 | 16 to 31 | Physical fault counter, AS-i slave 23 (23A)
0x14C | 0 to 15 | Physical fault counter, AS-i slave 24 (24A)
 | 16 to 31 | Physical fault counter, AS-i slave 25 (25A)
0x14D | 0 to 15 | Physical fault counter, AS-i slave 26 (26A)
 | 16 to 31 | Physical fault counter, AS-i slave 27 (27A)
0x14E | 0 to 15 | Physical fault counter, AS-i slave 28 (28A)
 | 16 to 31 | Physical fault counter, AS-i slave 29 (29A)
0x14F | 0 to 15 | Physical fault counter, AS-i slave 30 (30A)
 | 16 to 31 | Physical fault counter, AS-i slave 31 (31A)
0x150 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | Physical fault counter, AS-i slave 33 (1A)
0x151 | 0 to 15 | Physical fault counter, AS-i slave 34 (2A)
 | 16 to 31 | Physical fault counter, AS-i slave 35 (3A)
0x152 | 0 to 15 | Physical fault counter, AS-i slave 36 (4A)
 | 16 to 31 | Physical fault counter, AS-i slave 37 (5A)
0x153 | 0 to 15 | Physical fault counter, AS-i slave 38 (6A)
 | 16 to 31 | Physical fault counter, AS-i slave 39 (7A)
0x154 | 0 to 15 | Physical fault counter, AS-i slave 40 (8A)
 | 16 to 31 | Physical fault counter, AS-i slave 41 (9A)
0x155 | 0 to 15 | Physical fault counter, AS-i slave 42 (10A)
 | 16 to 31 | Physical fault counter, AS-i slave 43 (11A)
0x156 | 0 to 15 | Physical fault counter, AS-i slave 44 (12A)
 | 16 to 31 | Physical fault counter, AS-i slave 45 (13A)
0x157 | 0 to 15 | Physical fault counter, AS-i slave 46 (14A)
 | 16 to 31 | Physical fault counter, AS-i slave 47 (15A)
0x158 | 0 to 15 | Physical fault counter, AS-i slave 48 (16A)
 | 16 to 31 | Physical fault counter, AS-i slave 49 (17A)
0x159 | 0 to 15 | Physical fault counter, AS-i slave 50 (18A)
 | 16 to 31 | Physical fault counter, AS-i slave 51 (19A)
0x15A | 0 to 15 | Physical fault counter, AS-i slave 52 (20A)
 | 16 to 31 | Physical fault counter, AS-i slave 53 (21A)
0x15B | 0 to 15 | Physical fault counter, AS-i slave 54 (22A)
 | 16 to 31 | Physical fault counter, AS-i slave 55 (23A)
0x15C | 0 to 15 | Physical fault counter, AS-i slave 56 (24A)
 | 16 to 31 | Physical fault counter, AS-i slave 57 (25A)
0x15D | 0 to 15 | Physical fault counter, AS-i slave 58 (26A)
 | 16 to 31 | Physical fault counter, AS-i slave 59 (27A)
0x15E | 0 to 15 | Physical fault counter, AS-i slave 60 (28A)
 | 16 to 31 | Physical fault counter, AS-i slave 61 (29A)
0x15F | 0 to 15 | Physical fault counter, AS-i slave 62 (30A)
 | 16 to 31 | Physical fault counter, AS-i slave 63 (31A)
Parameters 0x160 to 0x17F: Timeout counter
Each AS-i slave has a counter that is incremented if the associated AS-i slave has not responded (this parameter is read/write):
Parameter | Bit | Description
0x160 | 0 to 15 | Timeout counter, AS-i slave 0
 | 16 to 31 | Timeout counter, AS-i slave 1 (1A)
0x161 | 0 to 15 | Timeout counter, AS-i slave 2 (2A)
 | 16 to 31 | Timeout counter, AS-i slave 3 (3A)
0x162 | 0 to 15 | Timeout counter, AS-i slave 4 (4A)
 | 16 to 31 | Timeout counter, AS-i slave 5 (5A)
0x163 | 0 to 15 | Timeout counter, AS-i slave 6 (6A)
 | 16 to 31 | Timeout counter, AS-i slave 7 (7A)
0x164 | 0 to 15 | Timeout counter, AS-i slave 8 (8A)
 | 16 to 31 | Timeout counter, AS-i slave 9 (9A)
0x165 | 0 to 15 | Timeout counter, AS-i slave 10 (10A)
 | 16 to 31 | Timeout counter, AS-i slave 11 (11A)
0x166 | 0 to 15 | Timeout counter, AS-i slave 12 (12A)
 | 16 to 31 | Timeout counter, AS-i slave 13 (13A)
0x167 | 0 to 15 | Timeout counter, AS-i slave 14 (14A)
 | 16 to 31 | Timeout counter, AS-i slave 15 (15A)
0x168 | 0 to 15 | Timeout counter, AS-i slave 16 (16A)
 | 16 to 31 | Timeout counter, AS-i slave 17 (17A)
0x169 | 0 to 15 | Timeout counter, AS-i slave 18 (18A)
 | 16 to 31 | Timeout counter, AS-i slave 19 (19A)
0x16A | 0 to 15 | Timeout counter, AS-i slave 20 (20A)
 | 16 to 31 | Timeout counter, AS-i slave 21 (21A)
0x16B | 0 to 15 | Timeout counter, AS-i slave 22 (22A)
 | 16 to 31 | Timeout counter, AS-i slave 23 (23A)
0x16C | 0 to 15 | Timeout counter, AS-i slave 24 (24A)
 | 16 to 31 | Timeout counter, AS-i slave 25 (25A)
0x16D | 0 to 15 | Timeout counter, AS-i slave 26 (26A)
 | 16 to 31 | Timeout counter, AS-i slave 27 (27A)
0x16E | 0 to 15 | Timeout counter, AS-i slave 28 (28A)
 | 16 to 31 | Timeout counter, AS-i slave 29 (29A)
0x16F | 0 to 15 | Timeout counter, AS-i slave 30 (30A)
 | 16 to 31 | Timeout counter, AS-i slave 31 (31A)
0x170 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | Timeout counter, AS-i slave 33 (1B)
0x171 | 0 to 15 | Timeout counter, AS-i slave 34 (2B)
 | 16 to 31 | Timeout counter, AS-i slave 35 (3B)
0x172 | 0 to 15 | Timeout counter, AS-i slave 36 (4B)
 | 16 to 31 | Timeout counter, AS-i slave 37 (5B)
0x173 | 0 to 15 | Timeout counter, AS-i slave 38 (6B)
 | 16 to 31 | Timeout counter, AS-i slave 39 (7B)
0x174 | 0 to 15 | Timeout counter, AS-i slave 40 (8B)
 | 16 to 31 | Timeout counter, AS-i slave 41 (9B)
0x175 | 0 to 15 | Timeout counter, AS-i slave 42 (10B)
 | 16 to 31 | Timeout counter, AS-i slave 43 (11B)
0x176 | 0 to 15 | Timeout counter, AS-i slave 44 (12B)
 | 16 to 31 | Timeout counter, AS-i slave 45 (13B)
0x177 | 0 to 15 | Timeout counter, AS-i slave 46 (14B)
 | 16 to 31 | Timeout counter, AS-i slave 47 (15B)
0x178 | 0 to 15 | Timeout counter, AS-i slave 48 (16B)
 | 16 to 31 | Timeout counter, AS-i slave 49 (17B)
0x179 | 0 to 15 | Timeout counter, AS-i slave 50 (18B)
 | 16 to 31 | Timeout counter, AS-i slave 51 (19B)
Parameter | Bit | Description
0x17A | 0 to 15 | Timeout counter, AS-i slave 52 (20B)
 | 16 to 31 | Timeout counter, AS-i slave 53 (21B)
0x17B | 0 to 15 | Timeout counter, AS-i slave 54 (22B)
 | 16 to 31 | Timeout counter, AS-i slave 55 (23B)
0x17C | 0 to 15 | Timeout counter, AS-i slave 56 (24B)
 | 16 to 31 | Timeout counter, AS-i slave 57 (25B)
0x17D | 0 to 15 | Timeout counter, AS-i slave 58 (26B)
 | 16 to 31 | Timeout counter, AS-i slave 59 (27B)
0x17E | 0 to 15 | Timeout counter, AS-i slave 60 (28B)
 | 16 to 31 | Timeout counter, AS-i slave 61 (29B)
0x17F | 0 to 15 | Timeout counter, AS-i slave 62 (30B)
 | 16 to 31 | Timeout counter, AS-i slave 63 (31B)
Parameters 0x180 to 0x19F: Response counter
Each AS-i slave has a counter that is incremented if the associated AS-i slave has responded correctly (this parameter is read/write):
Parameter | Bit | Description
0x180 | 0 to 15 | Response counter, AS-i slave 0
 | 16 to 31 | Response counter, AS-i slave 1 (1A)
0x181 | 0 to 15 | Response counter, AS-i slave 2 (2A)
 | 16 to 31 | Response counter, AS-i slave 3 (3A)
0x182 | 0 to 15 | Response counter, AS-i slave 4 (4A)
 | 16 to 31 | Response counter, AS-i slave 5 (5A)
0x183 | 0 to 15 | Response counter, AS-i slave 6 (6A)
 | 16 to 31 | Response counter, AS-i slave 7 (7A)
0x184 | 0 to 15 | Response counter, AS-i slave 8 (8A)
 | 16 to 31 | Response counter, AS-i slave 9 (9A)
0x185 | 0 to 15 | Response counter, AS-i slave 10 (10A)
 | 16 to 31 | Response counter, AS-i slave 11 (11A)
0x186 | 0 to 15 | Response counter, AS-i slave 12 (12A)
 | 16 to 31 | Response counter, AS-i slave 13 (13A)
0x187 | 0 to 15 | Response counter, AS-i slave 14 (14A)
 | 16 to 31 | Response counter, AS-i slave 15 (15A)
0x188 | 0 to 15 | Response counter, AS-i slave 16 (16A)
 | 16 to 31 | Response counter, AS-i slave 17 (17A)
0x189 | 0 to 15 | Response counter, AS-i slave 18 (18A)
 | 16 to 31 | Response counter, AS-i slave 19 (19A)
0x18A | 0 to 15 | Response counter, AS-i slave 20 (20A)
 | 16 to 31 | Response counter, AS-i slave 21 (21A)
0x18B | 0 to 15 | Response counter, AS-i slave 22 (22A)
 | 16 to 31 | Response counter, AS-i slave 23 (23A)
0x18C | 0 to 15 | Response counter, AS-i slave 24 (24A)
 | 16 to 31 | Response counter, AS-i slave 25 (25A)
0x18D | 0 to 15 | Response counter, AS-i slave 26 (26A)
 | 16 to 31 | Response counter, AS-i slave 27 (27A)
0x18E | 0 to 15 | Response counter, AS-i slave 28 (28A)
 | 16 to 31 | Response counter, AS-i slave 29 (29A)
0x18F | 0 to 15 | Response counter, AS-i slave 30 (30A)
 | 16 to 31 | Response counter, AS-i slave 31 (31A)
0x190 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | Response counter, AS-i slave 33 (1B)
0x191 | 0 to 15 | Response counter, AS-i slave 34 (2B)
 | 16 to 31 | Response counter, AS-i slave 35 (3B)
0x192 | 0 to 15 | Response counter, AS-i slave 36 (4B)
 | 16 to 31 | Response counter, AS-i slave 37 (5B)
Parameter | Bit | Description
0x193 | 0 to 15 | Response counter, AS-i slave 38 (6B)
 | 16 to 31 | Response counter, AS-i slave 39 (7B)
0x194 | 0 to 15 | Response counter, AS-i slave 40 (8B)
 | 16 to 31 | Response counter, AS-i slave 41 (9B)
0x195 | 0 to 15 | Response counter, AS-i slave 42 (10B)
 | 16 to 31 | Response counter, AS-i slave 43 (11B)
0x196 | 0 to 15 | Response counter, AS-i slave 44 (12B)
 | 16 to 31 | Response counter, AS-i slave 45 (13B)
0x197 | 0 to 15 | Response counter, AS-i slave 46 (14B)
 | 16 to 31 | Response counter, AS-i slave 47 (15B)
0x198 | 0 to 15 | Response counter, AS-i slave 48 (16B)
 | 16 to 31 | Response counter, AS-i slave 49 (17B)
0x199 | 0 to 15 | Response counter, AS-i slave 50 (18B)
 | 16 to 31 | Response counter, AS-i slave 51 (19B)
0x19A | 0 to 15 | Response counter, AS-i slave 52 (20B)
 | 16 to 31 | Response counter, AS-i slave 53 (21B)
0x19B | 0 to 15 | Response counter, AS-i slave 54 (22B)
 | 16 to 31 | Response counter, AS-i slave 55 (23B)
0x19C | 0 to 15 | Response counter, AS-i slave 56 (24B)
 | 16 to 31 | Response counter, AS-i slave 57 (25B)
0x19D | 0 to 15 | Response counter, AS-i slave 58 (26B)
 | 16 to 31 | Response counter, AS-i slave 59 (27B)
0x19E | 0 to 15 | Response counter, AS-i slave 60 (28B)
 | 16 to 31 | Response counter, AS-i slave 61 (29B)
0x19F | 0 to 15 | Response counter, AS-i slave 62 (30B)
 | 16 to 31 | Response counter, AS-i slave 63 (31B)
Parameters 0x1A0 to 0x1BF: Leave data exchange counter
Each AS-i slave has a counter that is incremented if the associated AS-i slave was removed from the LAS, i.e. if it has not (or not correctly) responded three times in a row (this parameter is read/write):
Parameter | Bit | Description
0x1A0 | 0 to 15 | Leave data exchange counter, AS-i slave 0
 | 16 to 31 | Leave data exchange counter, AS-i slave 1 (1A)
0x1A1 | 0 to 15 | Leave data exchange counter, AS-i slave 2 (2A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 3 (3A)
0x1A2 | 0 to 15 | Leave data exchange counter, AS-i slave 4 (4A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 5 (5A)
0x1A3 | 0 to 15 | Leave data exchange counter, AS-i slave 6 (6A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 7 (7A)
0x1A4 | 0 to 15 | Leave data exchange counter, AS-i slave 8 (8A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 9 (9A)
0x1A5 | 0 to 15 | Leave data exchange counter, AS-i slave 10 (10A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 11 (11A)
0x1A6 | 0 to 15 | Leave data exchange counter, AS-i slave 12 (12A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 13 (13A)
0x1A7 | 0 to 15 | Leave data exchange counter, AS-i slave 14 (14A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 15 (15A)
0x1A8 | 0 to 15 | Leave data exchange counter, AS-i slave 16 (16A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 17 (17A)
0x1A9 | 0 to 15 | Leave data exchange counter, AS-i slave 18 (18A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 19 (19A)
0x1AA | 0 to 15 | Leave data exchange counter, AS-i slave 20 (20A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 21 (21A)
0x1AB | 0 to 15 | Leave data exchange counter, AS-i slave 22 (22A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 23 (23A)
Parameter | Bit | Description
0x1AC | 0 to 15 | Leave data exchange counter, AS-i slave 24 (24A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 25 (25A)
0x1AD | 0 to 15 | Leave data exchange counter, AS-i slave 26 (26A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 27 (27A)
0x1AE | 0 to 15 | Leave data exchange counter, AS-i slave 28 (28A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 29 (29A)
0x1AF | 0 to 15 | Leave data exchange counter, AS-i slave 30 (30A)
 | 16 to 31 | Leave data exchange counter, AS-i slave 31 (31A)
0x1B0 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | Leave data exchange counter, AS-i slave 33 (1B)
0x1B1 | 0 to 15 | Leave data exchange counter, AS-i slave 34 (2B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 35 (3B)
0x1B2 | 0 to 15 | Leave data exchange counter, AS-i slave 36 (4B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 37 (5B)
0x1B3 | 0 to 15 | Leave data exchange counter, AS-i slave 38 (6B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 39 (7B)
0x1B4 | 0 to 15 | Leave data exchange counter, AS-i slave 40 (8B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 41 (9B)
0x1B5 | 0 to 15 | Leave data exchange counter, AS-i slave 42 (10B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 43 (11B)
0x1B6 | 0 to 15 | Leave data exchange counter, AS-i slave 44 (12B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 45 (13B)
0x1B7 | 0 to 15 | Leave data exchange counter, AS-i slave 46 (14B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 47 (15B)
0x1B8 | 0 to 15 | Leave data exchange counter, AS-i slave 48 (16B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 49 (17B)
0x1B9 | 0 to 15 | Leave data exchange counter, AS-i slave 50 (18B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 51 (19B)
0x1BA | 0 to 15 | Leave data exchange counter, AS-i slave 52 (20B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 53 (21B)
0x1BB | 0 to 15 | Leave data exchange counter, AS-i slave 54 (22B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 55 (23B)
0x1BC | 0 to 15 | Leave data exchange counter, AS-i slave 56 (24B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 57 (25B)
0x1BD | 0 to 15 | Leave data exchange counter, AS-i slave 58 (26B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 59 (27B)
0x1BE | 0 to 15 | Leave data exchange counter, AS-i slave 60 (28B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 61 (29B)
0x1BF | 0 to 15 | Leave data exchange counter, AS-i slave 62 (30B)
 | 16 to 31 | Leave data exchange counter, AS-i slave 63 (31B)
Parameters 0x1C0 to 0x1DF: DataExch failed counter
Each AS-i slave has a counter that is incremented if the associated AS-i slave has not (or not correctly) responded to a DataExchange telegram (this parameter is read/write):
Parameter | Bit | Description
0x1C0 | 0 to 15 | DataExch failed counter, AS-i slave 0
 | 16 to 31 | DataExch failed counter, AS-i slave 1 (1A)
0x1C1 | 0 to 15 | DataExch failed counter, AS-i slave 2 (2A)
 | 16 to 31 | DataExch failed counter, AS-i slave 3 (3A)
0x1C2 | 0 to 15 | DataExch failed counter, AS-i slave 4 (4A)
 | 16 to 31 | DataExch failed counter, AS-i slave 5 (5A)
0x1C3 | 0 to 15 | DataExch failed counter, AS-i slave 6 (6A)
 | 16 to 31 | DataExch failed counter, AS-i slave 7 (7A)
0x1C4 | 0 to 15 | DataExch failed counter, AS-i slave 8 (8A)
 | 16 to 31 | DataExch failed counter, AS-i slave 9 (9A)
Parameter | Bit | Description
0x1C5 | 0 to 15 | DataExch failed counter, AS-i slave 10 (10A)
 | 16 to 31 | DataExch failed counter, AS-i slave 11 (11A)
0x1C6 | 0 to 15 | DataExch failed counter, AS-i slave 12 (12A)
 | 16 to 31 | DataExch failed counter, AS-i slave 13 (13A)
0x1C7 | 0 to 15 | DataExch failed counter, AS-i slave 14 (14A)
 | 16 to 31 | DataExch failed counter, AS-i slave 15 (15A)
0x1C8 | 0 to 15 | DataExch failed counter, AS-i slave 16 (16A)
 | 16 to 31 | DataExch failed counter, AS-i slave 17 (17A)
0x1C9 | 0 to 15 | DataExch failed counter, AS-i slave 18 (18A)
 | 16 to 31 | DataExch failed counter, AS-i slave 19 (19A)
0x1CA | 0 to 15 | DataExch failed counter, AS-i slave 20 (20A)
 | 16 to 31 | DataExch failed counter, AS-i slave 21 (21A)
0x1CB | 0 to 15 | DataExch failed counter, AS-i slave 22 (22A)
 | 16 to 31 | DataExch failed counter, AS-i slave 23 (23A)
0x1CC | 0 to 15 | DataExch failed counter, AS-i slave 24 (24A)
 | 16 to 31 | DataExch failed counter, AS-i slave 25 (25A)
0x1CD | 0 to 15 | DataExch failed counter, AS-i slave 26 (26A)
 | 16 to 31 | DataExch failed counter, AS-i slave 27 (27A)
0x1CE | 0 to 15 | DataExch failed counter, AS-i slave 28 (28A)
 | 16 to 31 | DataExch failed counter, AS-i slave 29 (29A)
0x1CF | 0 to 15 | DataExch failed counter, AS-i slave 30 (30A)
 | 16 to 31 | DataExch failed counter, AS-i slave 31 (31A)
0x1C0 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | DataExch failed counter, AS-i slave 33 (1B)
0x1D1 | 0 to 15 | DataExch failed counter, AS-i slave 34 (2B)
 | 16 to 31 | DataExch failed counter, AS-i slave 35 (3B)
0x1D2 | 0 to 15 | DataExch failed counter, AS-i slave 36 (4B)
 | 16 to 31 | DataExch failed counter, AS-i slave 37 (5B)
0x1D3 | 0 to 15 | DataExch failed counter, AS-i slave 38 (6B)
 | 16 to 31 | DataExch failed counter, AS-i slave 39 (7B)
0x1D4 | 0 to 15 | DataExch failed counter, AS-i slave 40 (8B)
 | 16 to 31 | DataExch failed counter, AS-i slave 41 (9B)
0x1D5 | 0 to 15 | DataExch failed counter, AS-i slave 42 (10B)
 | 16 to 31 | DataExch failed counter, AS-i slave 43 (11B)
0x1D6 | 0 to 15 | DataExch failed counter, AS-i slave 44 (12B)
 | 16 to 31 | DataExch failed counter, AS-i slave 45 (13B)
0x1D7 | 0 to 15 | DataExch failed counter, AS-i slave 46 (14B)
 | 16 to 31 | DataExch failed counter, AS-i slave 47 (15B)
0x1D8 | 0 to 15 | DataExch failed counter, AS-i slave 48 (16B)
 | 16 to 31 | DataExch failed counter, AS-i slave 49 (17B)
0x1D9 | 0 to 15 | DataExch failed counter, AS-i slave 50 (18B)
 | 16 to 31 | DataExch failed counter, AS-i slave 51 (19B)
0x1DA | 0 to 15 | DataExch failed counter, AS-i slave 52 (20B)
 | 16 to 31 | DataExch failed counter, AS-i slave 53 (21B)
0x1DB | 0 to 15 | DataExch failed counter, AS-i slave 54 (22B)
 | 16 to 31 | DataExch failed counter, AS-i slave 55 (23B)
0x1DC | 0 to 15 | DataExch failed counter, AS-i slave 56 (24B)
 | 16 to 31 | DataExch failed counter, AS-i slave 57 (25B)
0x1DD | 0 to 15 | DataExch failed counter, AS-i slave 58 (26B)
 | 16 to 31 | DataExch failed counter, AS-i slave 59 (27B)
0x1DE | 0 to 15 | DataExch failed counter, AS-i slave 60 (28B)
 | 16 to 31 | DataExch failed counter, AS-i slave 61 (29B)
0x1DF | 0 to 15 | DataExch failed counter, AS-i slave 62 (30B)
 | 16 to 31 | DataExch failed counter, AS-i slave 63 (31B)
Parameters 0x200 to 0x27F: Analog slave data
Parameter | Bit | Description
 |  | Channel | if analog output |  |  | if analog input
 |  |  | Write |  | Read | Read |  | Write
0x200 | Bit 0 to 31 | (Slave 0) | Since slave no. 0 is not designated for analog AS-i slaves, zeros are transferred to the process image in this instance.
0x201 | Bit 0 to 31
0x202 | Bit 0 to 31
0x203 | Bit 0 to 31
0x204 | Bit 0 to 15 | Slave 1, channel 1 | Analog value | - |  |  | Analog value | not possible
 | Bit 16 |  | V flag** (valid) | V flag (valid) |  |  | V flag (valid)
 | Bit 17 |  | - | - |  |  | O flag (overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle timeout |  |  | Toggle timeout
 | Bit 23 |  | - | Data exchange disabled* |  |  | Data exchange disabled*
0x205 | Bit 0 to 15 | Slave 1, channel 2 | Analog value | - |  |  | Analog value | not possible
 | Bit 16 |  | V flag** (valid) | V flag (valid) |  |  | V flag (valid)
 | Bit 17 |  | - | - |  |  | O flag (overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle timeout |  |  | Toggle timeout
 | Bit 23 |  | - | Data exchange disabled* |  |  | Data exchange disabled*
0x206 | Bit 0 to 15 | Slave 1, channel 3 | Analog value | - |  |  | Analog value | not possible
 | Bit 16 |  | V flag** (valid) | V flag (valid) |  |  | V flag (valid)
 | Bit 17 |  | - | - |  |  | O flag (overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle timeout |  |  | Toggle timeout
 | Bit 23 |  | - | Data exchange disabled* |  |  | Data exchange disabled*
0x207 | Bit 0 to 15 | Slave 1, channel 4 | Analog value | - |  |  | Analog value | not possible
 | Bit 16 |  | V flag** (valid) | V flag (valid) |  |  | V flag (valid)
 | Bit 17 |  | - | - |  |  | O flag (overflow)
 | Bit 21 |  | - | No Response |  |  | No Response
 | Bit 22 |  | - | Toggle timeout |  |  | Toggle timeout
 | Bit 23 |  | - | Data exchange disabled* |  |  | Data exchange disabled*
... | ... | ... | ... | ... |  |  | ... | ...
0x27C | ... | Slave 31, channel 1 | ... | ... |  |  | ... | ...
0x27D | ... | Slave 31, channel 2 | ... | ... (see mapping table) ... |  |  | ... | ...
0x27E | ... | Slave 31, channel 3 | ... |  |  |  | ... | ...
0x27F | ... | Slave 31, channel 4 | ... | ... |  |  | ... | ...
*) if ASI control bit 3 = 0bin
**) The V flag (valid) must be set by the controller in order for the AS-i slave to switch its outputs.
Parameter 0x300: Cycle times
Parameter | Bit | Description
0x300 | Bits 0-15 | current cycle time in µs
 | Bits 16-31 | maximum cycle time in µs
Parameter 0x310: Statistics
Parameter | Bit | Description
0x310 | Bits 0-7 | Max. number of data exchange errors per ASI cycle
 | Bits 8-15 | Timeouts/data exchange telegrams in %
 | Bits 16-31 | reserved
Parameters 0x320 to 0x32F: Timeout statistics for each AS-i slave
Parameter | Bit | Description
0x320 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 0
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 1 (1A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 2 (2A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 3 (3A)
0x321 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 4 (4A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 5 (5A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 6 (6A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 7 (7A)
0x322 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 8 (8A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 9 (9A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 10 (10A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 11 (11A)
0x323 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 12 (12A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 13 (13A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 14 (14A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 15 (15A)
0x324 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 16 (16A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 17 (17A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 18 (18A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 19 (19A)
0x325 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 20 (20A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 21 (21A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 22 (22A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 23 (23A)
0x326 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 24 (24A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 25 (25A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 26 (26A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 27 (27A)
0x327 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 28 (28A)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 29 (29A)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 30 (30A)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 31 (31A)
0x328 | Bit 0 to 7 | Reserved (AS-i slave address 32 is not permitted)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 33 (1B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 34 (2B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 35 (3B)
0x329 | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 36 (4B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 37 (5B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 38 (6B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 39 (7B)
0x32A | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 40 (8B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 41 (9B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 42 (10B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 43 (11B)
0x32B | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 44 (12B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 45 (13B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 46 (14B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 47 (15B)
0x32C | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 48 (16B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 49 (17B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 50 (18B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 51 (19B)
0x32D | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 52 (20B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 53 (21B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 54 (22B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 55 (23B)
Parameter | Bit | Description
0x32E | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 56 (24B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 57 (25B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 58 (26B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 59 (27B)
0x32F | Bit 0 to 7 | Timeouts/telegram in percent, AS-i slave 60 (28B)
 | Bit 8 to 15 | Timeouts/telegram in percent, AS-i slave 61 (29B)
 | Bit 16 to 23 | Timeouts/telegram in percent, AS-i slave 62 (30B)
 | Bit 24 to 31 | Timeouts/telegram in percent, AS-i slave 63 (31B)
Parameters 0x340 to 0x35F: Data exchange repeat counter for each AS-i slave
There are 5 repeat counters, since the data exchange telegram is sent up to six times before the slave is removed from the LAS - the maximum number of repeats is therefore five. The counters indicate how often one, two, three, four or five repetitions were required:
▪
If, for example, the slave started responding after the 4th repetition, the repeat counter will have been incremented three times.
▪
If the slave does not respond six times, it is removed from the LAS, and none of the repeat counter is incremented.
The general command interface (parameter 0x108) determines which of the 5 repeat counters is addressed via parameters 0x340 to 0x35F (switchover of x).
Parameter | Bit | Description
0x340 | 0 to 15 | reserved
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 1 (1A)
0x341 | 0 to 15 | Data exchange repeat counter x, AS-i slave 2 (2A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 3 (3A)
0x342 | 0 to 15 | Data exchange repeat counter x, AS-i slave 4 (4A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 5 (5A)
0x343 | 0 to 15 | Data exchange repeat counter x, AS-i slave 6 (6A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 7 (7A)
0x344 | 0 to 15 | Data exchange repeat counter x, AS-i slave 8 (8A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 9 (9A)
0x345 | 0 to 15 | Data exchange repeat counter x, AS-i slave 10 (10A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 11 (11A)
0x346 | 0 to 15 | Data exchange repeat counter x, AS-i slave 12 (12A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 13 (13A)
0x347 | 0 to 15 | Data exchange repeat counter x, AS-i slave 14 (14A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 15 (15A)
0x348 | 0 to 15 | Data exchange repeat counter x, AS-i slave 16 (16A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 17 (17A)
0x349 | 0 to 15 | Data exchange repeat counter x, AS-i slave 18 (18A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 19 (19A)
0x34A | 0 to 15 | Data exchange repeat counter x, AS-i slave 20 (20A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 21 (21A)
0x34B | 0 to 15 | Data exchange repeat counter x, AS-i slave 22 (22A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 23 (23A)
0x34C | 0 to 15 | Data exchange repeat counter x, AS-i slave 24 (24A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 25 (25A)
0x34D | 0 to 15 | Data exchange repeat counter x, AS-i slave 26 (26A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 27 (27A)
0x34E | 0 to 15 | Data exchange repeat counter x, AS-i slave 28 (28A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 29 (29A)
0x34F | 0 to 15 | Data exchange repeat counter x, AS-i slave 30 (30A)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 31 (31A)
0x340 | 0 to 15 | Reserved (AS-i slave address 32 is not permitted)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 33 (1B)
0x351 | 0 to 15 | Data exchange repeat counter x, AS-i slave 34 (2B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 35 (3B)
Parameter | Bit | Description
0x352 | 0 to 15 | Data exchange repeat counter x, AS-i slave 36 (4B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 37 (5B)
0x353 | 0 to 15 | Data exchange repeat counter x, AS-i slave 38 (6B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 39 (7B)
0x354 | 0 to 15 | Data exchange repeat counter x, AS-i slave 40 (8B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 41 (9B)
0x355 | 0 to 15 | Data exchange repeat counter x, AS-i slave 42 (10B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 43 (11B)
0x356 | 0 to 15 | Data exchange repeat counter x, AS-i slave 44 (12B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 45 (13B)
0x357 | 0 to 15 | Data exchange repeat counter x, AS-i slave 46 (14B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 47 (15B)
0x358 | 0 to 15 | Data exchange repeat counter x, AS-i slave 48 (16B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 49 (17B)
0x359 | 0 to 15 | Data exchange repeat counter x, AS-i slave 50 (18B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 51 (19B)
0x35A | 0 to 15 | Data exchange repeat counter x, AS-i slave 52 (20B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 53 (21B)
0x35B | 0 to 15 | Data exchange repeat counter x, AS-i slave 54 (22B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 55 (23B)
0x35C | 0 to 15 | Data exchange repeat counter x, AS-i slave 56 (24B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 57 (25B)
0x35D | 0 to 15 | Data exchange repeat counter x, AS-i slave 58 (26B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 59 (27B)
0x35E | 0 to 15 | Data exchange repeat counter x, AS-i slave 60 (28B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 61 (29B)
0x35F | 0 to 15 | Data exchange repeat counter x, AS-i slave 62 (30B)
 | 16 to 31 | Data exchange repeat counter x, AS-i slave 63 (31B)


Access to AS-i parameters

Access from the user program [image] Access to AS-i parameters
Access to AS-i parameters
The parameters of the KL6201/KL6211 AS-i master terminal can be accessed via the parameter data block. Write and read access are documented below, including examples.
Writing a parameter
The following sequence should be used for writing a parameter:
First check whether the previous access was fully completed. To do this, assess status byte 1: Bits 4 to 7 should be 0bin. If this is not the case, control bytes 0 and 1 should be set to 0, until bits 4 to 7 in status byte 1 are set to 0bin.
Write access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 01binA5A4 A3A2A1A0 | 0100bin A9A8A7A6 | P0...P7 | P8...P15 | P16...P23 | P24...P31
A0 to A9: bits of the parameter address
P0 to P31: bits of the parameter value
Response to write access (KL6201/KL6211->PLC): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status byte 0 | Status byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Value | xxxx xxxxbin | 01F1 xxx1bin | Error code | Error code | Error code | Error code
x: Bits can take on any value
F: Error bit.
F=0bin: Write access was successful.
F=1bin: Write access was not successful. Bytes 2 to 5 contain an error code providing information about the cause of the error.
The write sequence is completed by setting the control bytes to zero:
Conclusion of write access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 0000 0000bin | 0000 0000bin | x | x | x | x
x: The parameter values are not evaluated if the control bytes are 0x00.
Example
The list of currently projected slaves (LPS) is to be written. The AS-i master is to communicate specifically with the AS-i slaves with node numbers 1, 2, 3, 4, 12, 16, 17 and 30. In other words, the value 0x4003101E (0100 0000 0000 0011 0001 0000 0001 1110bin) is to be written to parameter 0xA8 (1010 1000bin).
Write access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 0110 1000bin (0x68) | 0100 0010bin (0x42) | 0x1E | 0x10 | 0x03 | 0x40
The byte order 0x68 42 1E 10 03 40 has to be written to parameter data block for the KL6201/KL6211.
The terminal responds with the following data:
Response to write access (KL6201/KL6211->PLC): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status byte 0 | Status byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Value | xxxx xxxxbin | 0101 xxx1bin | 0 | 0 | 0 | 0
The write sequence is completed with this byte sequence: 0x00 00 00 00 00 00
Reading a parameter
The following sequence should be used for reading a parameter:
First check whether the previous access was fully completed. This requires status 1 to be evaluated - bits 4 to 7 should be 0. If this is not the case, control bytes 0 and 1 should be set to 0, until bits 4 to 7 in status 1 are set to 0.
Read access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 00bin A5A4 A3A2A1A0 | 0100bin A9A8A7A6 | x | x | x | x
A0 to A9: bits of the parameter address
x: The parameter values are not evaluated
Response to read access (KL6201/KL6211->PLC): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status byte 0 | Status byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Value | xxxx xxxxbin | 01F1 xxx0bin | P0...P7 | P8...P15 | P16...P23 | P24...P31
x: Bits can take on any value
F: Error bit.
F=0bin: Read access was successful. Bytes 2 to 5 contain the parameter value.
F=1bin: Read access was not successful. Bytes 2 to 5 contain an error code providing information about the cause of the error.
P0 to P31: bits of the parameter value or error code
The read sequence is completed by setting the control bytes to zero:
Conclusion of read access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 0000 0000bin | 0000 0000bin | x | x | x | x
x: The parameter values are not evaluated if the control bytes are 0x00.
Example
The list of detected slaves (LDS) is to be determined. This requires the parameter 0xB0 (1011 0000bin) to be read.
Read access (PLC->KL6201/KL6211): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Control byte 0 | Control byte 1 | ParaOut0 | ParaOut1 | ParaOut2 | ParaOut3
Value | 0011 0000bin (0x30) | 0100 0010bin (0x42) | 0x00 | 0x00 | 0x00 | 0x00
The byte order 0x30 42 00 00 00 00 has to be written to parameter data block for the KL6201/KL6211. The terminal responds with the following data:
Response to write access (KL6201/KL6211->PLC): parameter data block
Byte | Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5
Name | Status byte 0 | Status byte 1 | ParaIn0 | ParaIn1 | ParaIn2 | ParaIn3
Value | xxxx xxxxbin | 0101 xxx0bin | 0x4C | 0x02 | 0x80 | 0x83
In this example, the AS-i master is assumed to have detected the slaves with the node numbers 2, 3, 6, 9, 23, 24, 25 and 31. It therefore responds with the parameter data 0x8380024C (1000 0011 1000 0000 0000 0010 0100 1100bin)
The read sequence is completed with the byte sequence 0x00 00 00 00 00 00.


Mapping of analog AS-i slaves

Access from the user program [image] Mapping of analog AS-i slaves
Mapping of analog AS-i slaves
The following table shows the assignment of the address areas to analog AS-i slaves,
▪
for register access (via register communication or via the KS2000 configuration software)
▪
for Profibus (access via DPV1)
Note
Addresses
Analog AS-i slaves support only address numbers 1 to 31!
Address numbers 33 (1B) to 63 (31B) are not supported by analog AS-i slaves!
*) Since AS-i address 0 is not designated for analog AS-i slaves, zeros are transferred to the process image for the areas identified with an asterisk.
register access |  | PROFIBUS |  | AS-i parameters | AS-i slave |  | Data
Register page | Register | DPV1 index | Byte |  | AS-i address | Channel
0x20 | 32 and 33 * | 0x40 | 0 to 3 * | 0x200 | (0)* | all zero* | 4 bytes
 | 34 and 35 * |  | 4 to 7 * | 0x201 |  |  | 4 bytes
 | 36 and 37 * |  | 8 to 11 * | 0x202 |  |  | 4 bytes
 | 38 and 39 * |  | 12 to 15 * | 0x203 |  |  | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x204 | 1 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x205 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x206 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x207 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x41 | 0 to 3 | 0x208 | 2 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x209 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x20A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x20B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x20C | 3 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x20D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x20E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x20F |  | Ch4 | 4 bytes
register access |  | PROFIBUS |  | AS-i parameters | AS-i slave |  | Data
Register page | Register | DPV1 index | Byte |  | AS-i address | Channel
0x21 | 32 and 33 | 0x42 | 0 to 3 | 0x210 | 4 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x211 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x212 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x213 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x214 | 5 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x215 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x216 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x217 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x43 | 0 to 3 | 0x218 | 6 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x219 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x21A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x21B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x21C | 7 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x21D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x21E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x21F |  | Ch4 | 4 bytes
0x22 | 32 and 33 | 0x44 | 0 to 3 | 0x220 | 8 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x221 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x222 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x223 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x224 | 9 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x225 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x226 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x227 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x45 | 0 to 3 | 0x228 | 10 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x229 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x22A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x22B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x22C | 11 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x22D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x22E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x22F |  | Ch4 | 4 bytes
0x23 | 32 and 33 | 0x46 | 0 to 3 | 0x230 | 12 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x231 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x232 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x233 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x234 | 13 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x235 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x236 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x237 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x47 | 0 to 3 | 0x238 | 14 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x239 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x23A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x23B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x23C | 15 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x23D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x23E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x23F |  | Ch4 | 4 bytes
Register access |  | PROFIBUS |  | AS-i parameters | AS-i slave |  | Data
Register page | Register | DPV1 index | Byte |  | AS-i address | Channel
0x24 | 32 and 33 | 0x48 | 0 to 3 | 0x240 | 16 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x241 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x242 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x243 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x244 | 17 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x245 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x246 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x247 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x49 | 0 to 3 | 0x248 | 18 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x249 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x24A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x24B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x24C | 19 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x24D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x24E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x24F |  | Ch4 | 4 bytes
0x25 | 32 and 33 | 0x4A | 0 to 3 | 0x250 | 20 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x251 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x252 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x253 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x254 | 21 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x255 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x256 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x257 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x4B | 0 to 3 | 0x258 | 22 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x259 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x25A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x25B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x25C | 23 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x25D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x25E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x25F |  | Ch4 | 4 bytes
0x26 | 32 and 33 | 0x4C | 0 to 3 | 0x260 | 24 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x261 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x262 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x263 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x264 | 25 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x265 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x266 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x267 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x4D | 0 to 3 | 0x268 | 26 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x269 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x26A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x26B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x26C | 27 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x26D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x26E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x26F |  | Ch4 | 4 bytes
Register access |  | PROFIBUS |  | AS-i parameters | AS-i slave |  | Data
Register page | Register | DPV1 index | Byte |  | AS-i address | Channel
0x27 | 32 and 33 | 0x4E | 0 to 3 | 0x270 | 28 | Ch1 | 4 bytes
 | 34 and 35 |  | 4 to 7 | 0x271 |  | Ch2 | 4 bytes
 | 36 and 37 |  | 8 to 11 | 0x272 |  | Ch3 | 4 bytes
 | 38 and 39 |  | 12 to 15 | 0x273 |  | Ch4 | 4 bytes
 | 40 and 41 |  | 16 to 19 | 0x274 | 29 | Ch1 | 4 bytes
 | 42 and 43 |  | 20 to 23 | 0x275 |  | Ch2 | 4 bytes
 | 44 and 45 |  | 24 to 27 | 0x276 |  | Ch3 | 4 bytes
 | 46 and 47 |  | 28 to 31 | 0x277 |  | Ch4 | 4 bytes
 | 48 and 49 | 0x4F | 0 to 3 | 0x278 | 30 | Ch1 | 4 bytes
 | 50 and 51 |  | 4 to 7 | 0x279 |  | Ch2 | 4 bytes
 | 52 and 53 |  | 8 to 11 | 0x27A |  | Ch3 | 4 bytes
 | 54 and 55 |  | 12 to 15 | 0x27B |  | Ch4 | 4 bytes
 | 56 and 57 |  | 16 to 19 | 0x27C | 31 | Ch1 | 4 bytes
 | 58 and 59 |  | 20 to 23 | 0x27D |  | Ch2 | 4 bytes
 | 60 and 61 |  | 24 to 27 | 0x27E |  | Ch3 | 4 bytes
 | 62 and 63 |  | 28 to 31 | 0x27F |  | Ch4 | 4 bytes


Operation at the fieldbus, overview

Operation at the fieldbus, overview
Operation at the fieldbus, overview
Additional information
•
KL6201/KL6211 at PROFIBUS couplers
•
KL6201/KL6211 at CANopen couplers
•
Firmware version of the Bus Couplers


KL6201/KL6211 at PROFIBUS couplers

Operation at the fieldbus, overview [image] KL6201/KL6211 at PROFIBUS couplers
KL6201/KL6211 at PROFIBUS couplers
Chapter overview
This chapter comprises the following sections:
▪
Selecting the size of the process image
▪
Mapping of the process data
▪
Parameter access via DPV1 services
–
DPV1 Read
–
DPV1 Write (normal write)
Selecting the size of the process image
The size of the process image of the AS-i master terminal can be set to 6, 12, 22 or 38 bytes. In the PROFIBUS couplers (BK3120, BK3150, BK3500, BK3520) the process image is selected by selecting the corresponding modules in the DP configuration. This is done automatically by the Bus Coupler.
Note
Process Images
If the 22-byte or 38-byte process image is to be used under PROFIBUS, the Bus Coupler may require a particular firmware version (see chapter Firmware version of the Bus Coupler). The delivered firmware version is shown on the back of the Bus Coupler (see example below). If required, the firmware can be updated via the serial interface (KS2000 cable required) or via the PROFIBUS (using the FC3101 fieldbus card, if firmware version B8 is already loaded on the Bus Coupler).
The current firmware versions and the program for the firmware update can be found at http://www.beckhoff.de. BK3120 devices with KL6201/KL6211 are supported in TwinCAT from version 2.8 (build 739).
Specification of the firmware version of the BK3120 PROFIBUS coupler
6-byte process image
Bytes 0 to 5 contain the parameter data block, bytes 6 to 11 contain the process data block. The following DP modules are available:
DP module | Hex code | Description
KL6201 - PRM PAB 6 | 0xF2, 0x35 | Only the 6 bytes of parameter data block are transferred via DP.
12-byte process image
Bytes 0 to 5 contain the parameter data block, bytes 6 to 11 contain the process data block. The following DP modules are available:
DP module | Hex code | Description
KL6201 - PRM PAB 6 | 0xF2, 0x35 | The full 12 bytes are transferred via DP (parameter data block and process data block)
KL6201 - PAB 6 | 0x35 | Only the 6 bytes of the process data block are transferred. Parameter access only via DPV1.
22-byte process image
Bytes 0 to 5 contain the parameter data block, bytes 6 to 21 contain the process data block. The following DP modules are available:
DP module | Hex code | Description
KL6201 - PRM PAB 16 | 0xF2, 0x3F | The parameter data block and the process data block are transferred.
KL6201 - PAB 16 | 0x3F | Only the process data block is transferred. Parameter access only via DPV1.
38-byte process image
Bytes 0 to 5 contain the parameter data block, bytes 6 to 37 contain the process data block. The following DP modules are available:
DP module | Hex code | Description
KL6201 - PRM PAB 32 | 0xF2, 0xC0, 0x1F | The parameter data block and the process data block are transferred.
KL6201 - PAB 32 | 0xC0, 0x1F | Only the process data block is transferred. Parameter access only via DPV1.
Mapping of the process data
With PROFIBUS, the process data are mapped linearly to the process image, i.e. the process image interface of the KL6201/KL6211 is located in the process image of the PROFIBUS master in the order as described.
Parameter access via DPV1
The parameters of the AS-i master terminal can be accessed via DPV1. The position of the terminal in the Terminal Bus should be specified as the slot number. The first non-digital terminal after the Bus Coupler is allocated slot number 1, the second non-digital terminal slot number 2, etc.
The parameters are addressed via the index. Up to 8 parameters are addressed as a group, i.e. the index is calculated from the parameter number divided by 8. Any length can be specified for reading (DPV1 read) of parameters. For writing (DPV1 write), parameters have to be specified as double words (length must be divisible by 4), or as 8 bytes for masked writing (length must by divisible by 8).
DPV1 Read
The following parameter can be read via DPV1:
Index | AS-i parameters | Length | Description
0x05 | 0x28 | 4 bytes | General Information (byte 0 corresponds to bit 0 to 7 of parameter 0x28)
0x08 | 0x40 to 0x47 | 32 bytes | Projected I/O IDs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x40)
0x09 | 0x48 to 0x4F | 32 bytes | Projected ID codes of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x48)
0x0A | 0x50 to 0x57 | 32 bytes | Activation parameters for the AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x50)
0x0B | 0x58 to 0x59 | 8 bytes | List of the AS-i slaves that are projected at the next start (byte 0 corresponds to bit 0 to 7 of parameter 0x58)
0x0C | 0x60 to 0x61 | 8 bytes | List of I/O IDs of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x60)
0x0D | 0x68 to 0x69 | 8 bytes | List of ID codes of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x68)
0x0E | 0x70 to 0x71 | 8 bytes | List of extended ID codes 1 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x70)
0x0F | 0x78 to 0x79 | 8 bytes | List of extended ID codes 2 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x78)
0x10 | 0x80 to 0x87 | 32 bytes | Digital inputs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x80)
0x12 | 0x90 to 0x97 | 32 bytes | Read I/O IDs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x90)
0x13 | 0x98 to 0x9F | 32 bytes | Read ID codes of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x98)
0x14 | 0xA0 to 0xA7 | 32 bytes | Read status of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xA0)
0x15 | 0xA8 to 0xA9 | 8 bytes | List of currently projected AS-i slaves (LPS) (byte 0 corresponds to bit 0 to 7 of parameter 0xA8)
0x16 | 0xB0 to 0xB1 | 8 bytes | List of detected AS-i slaves (LDS) (byte 0 corresponds to bit 0 to 7 of parameter 0xB0)
0x17 | 0xB8 to 0xB9 | 8 bytes | List of activated AS-i slaves (LAS) (byte 0 corresponds to bit 0 to 7 of parameter 0xB8)
0x18 | 0xC0 to 0xC1 | 8 bytes | List of slaves that support the extended ID codes (ID codes 1 and 2) (byte 0 corresponds to bit 0 to 7 of parameter 0xC0)
0x19 | 0xC8 | 4 bytes | List of slaves that support extended addressing (as B slaves with addresses greater than 32) (byte 0 corresponds to bits 0 to 7 of parameter 0xC8)
0x1A | 0xD0 to 0xD7 | 32 bytes | Read extended ID codes 1 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xD0)
0x1B | 0xD8 to 0xDF | 32 bytes | Read extended ID codes 2 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xD8)
0x1C | 0xE0 to 0xE7 | 32 bytes | Currently projected extended ID codes 1 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xE0)
0x1D | 0xE8 to 0xEF | 32 bytes | Currently projected extended ID codes 2 of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xE8)
0x1E | 0xF0 | 4 bytes | List of analog slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xF0)
0x1F | 0xF8 | 4 bytes | List of safety slaves (byte 0 corresponds to bit 0 to 7 of parameter 0xF8)
0x20 | 0x100 | 8 bytes | AS-i command interface, response (byte 0 corresponds to the response for parameter 0x100)
0x24 | 0x120 to 0x12F | 2 bytes | Startup status (0: no error)
 |  | 2 bytes | Status of automatic project configuration (0: no error)
 | 0x121 to 0x127 | 28 bytes | reserved
0x25 | 0x128 to 0x12F | 32 bytes | reserved
0x28 | 0x140 to 0x147 | 32 bytes | Physical fault counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x140)
0x29 | 0x148 to 0x14F | 32 bytes | Physical fault counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x148)
0x2A | 0x150 to 0x157 | 32 bytes | Physical fault counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x150)
Index | AS-i parameters | Length | Description
0x2B | 0x158 to 0x15F | 32 bytes | Physical fault counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x158)
0x2C | 0x160 to 0x167 | 32 bytes | Timeout counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x160)
0x2D | 0x168 to 0x16F | 32 bytes | Timeout counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x168)
0x2E | 0x170 to 0x177 | 32 bytes | Timeout counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x170)
0x2F | 0x178 to 0x17F | 32 bytes | Timeout counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x178)
0x30 | 0x180 to 0x187 | 32 bytes | Response counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x180)
0x31 | 0x188 to 0x18F | 32 bytes | Response counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x188)
0x32 | 0x190 to 0x197 | 32 bytes | Response counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x190)
0x33 | 0x198 to 0x19F | 32 bytes | Response counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x198)
0x34 | 0x1A0 to 0x1A7 | 32 bytes | Leave DataExch counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A0)
0x35 | 0x1A8 to 0x1AF | 32 bytes | Leave DataExch counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A8)
0x36 | 0x1B0 to 0x1B7 | 32 bytes | Leave DataExch counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B0)
0x37 | 0x1B8 to 0x1BF | 32 bytes | Leave DataExch counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B8)
0x38 | 0x1C0 to 0x1C7 | 32 bytes | DataExch failed counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C0)
0x39 | 0x1C8 to 0x1CF | 32 bytes | DataExch failed counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C8)
0x3A | 0x1D0 to 0x1D7 | 32 bytes | DataExch failed counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D0)
0x3B | 0x1D8 to 0x1DF | 32 bytes | DataExch failed counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D8)
0x40 | 0x200 to 0x207 | 32 bytes | 16 empty bytes and input data of AS-i analog slave 1 (byte 0 corresponds to bit 0 to 7 of parameter 0x200) | see mapping table
0x41 | 0x208 to 0x20F | 32 bytes | Input data, AS-i analog slaves 1 and 2 (byte 0 corresponds to bit 0 to 7 of parameter 0x208)
... | ... | ... | ...
0x4F | 0x278 to 0x27F | 32 bytes | Input data, AS-i analog slaves 30 and 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x278)
0x60 | 0x300 | 4 bytes | Cycle times (byte 0 corresponds to bit 0 to 7 of parameter 0x300)
0x62 | 0x310 | 8 bytes | Statistics (byte 0 corresponds to bit 0 to 7 of parameter 0x310)
0x64 | 0x320 to 0x327 | 32 bytes | Timeout statistics, AS-i slave 0 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x320)
0x65 | 0x328 to 0x32F | 32 bytes | Timeout statistics, AS-i slave 32 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x328)
0x68 | 0x340 to 0x347 | 32 bytes | Data exchange repeat counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x340)
0x69 | 0x348 to 0x34F | 32 bytes | Data exchange repeat counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x348)
0x6A | 0x350 to 0x357 | 32 bytes | Data exchange repeat counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x350)
0x6B | 0x358 to 0x35F | 32 bytes | Data exchange repeat counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x358)
DPV1 Write (normal write)
The following parameters can be written via DPV1:
Index | AS-i parameters | Length | Description
0x08 | 0x40 to 0x47 | 32 bytes | Projected I/O IDs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x40)
0x09 | 0x48 to 0x4F | 32 bytes | Projected ID codes of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x48)
0x0A | 0x50 to 0x57 | 32 bytes | Activation parameters for the AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x50)
0x0B | 0x58 to 0x59 | 8 bytes | List of the AS-i slaves that are projected at the next start (byte 0 corresponds to bit 0 to 7 of parameter 0x58)
0x0C | 0x60 to 0x61 | 8 bytes | List of I/O IDs of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x60)
0x0D | 0x68 to 0x69 | 8 bytes | List of ID codes of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x68)
0x0E | 0x70 to 0x71 | 8 bytes | List of extended ID codes 1 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x70)
0x0F | 0x78 to 0x79 | 8 bytes | List of extended ID codes 2 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0x78)
0x10 | 0x80 to 0x87 | 32 bytes | Digital outputs of all AS-i slaves (byte 0 corresponds to bit 0 to 7 of parameter 0x80)
0x1C | 0xE0 to 0xE7 | 32 bytes | List of extended ID codes 1 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0xE0)
0x1D | 0xE8 to 0xEF | 32 bytes | List of extended ID codes 2 of all AS-i slaves to be checked (byte 0 corresponds to bit 0 to 7 of parameter 0xE8)
0x20 | 0x100 | 4 bytes | AS-i command interface, request (byte 0 corresponds to the task for parameter 0x100)
0x21 | 0x108 | 4 bytes | General command interface (byte 0 corresponds to bit 0 to 7 of parameter 0x108)
0x28 | 0x140 to 0x147 | 32 bytes | Physical fault counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x140)
0x29 | 0x148 to 0x14F | 32 bytes | Physical fault counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x148)
0x2A | 0x150 to 0x157 | 32 bytes | Physical fault counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x150)
0x2B | 0x158 to 0x15F | 32 bytes | Physical fault counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x158)
0x2C | 0x160 to 0x167 | 32 bytes | Timeout counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x160)
0x2D | 0x168 to 0x16F | 32 bytes | Timeout counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x168)
0x2E | 0x170 to 0x177 | 32 bytes | Timeout counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x170)
0x2F | 0x178 to 0x17F | 32 bytes | Timeout counter, AS-i slave 48 to 4F (byte 0 corresponds to bit 0 to 7 of parameter 0x178)
0x30 | 0x180 to 0x187 | 32 bytes | Response counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x180)
0x31 | 0x188 to 0x18F | 32 bytes | Response counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x188)
0x32 | 0x190 to 0x197 | 32 bytes | Response counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x190)
0x33 | 0x198 to 0x19F | 32 bytes | Response counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x198)
0x34 | 0x1A0 to 0x1A7 | 32 bytes | Leave DataExch counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A0)
0x35 | 0x1A8 to 0x1AF | 32 bytes | Leave DataExch counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1A8)
0x36 | 0x1B0 to 0x1B7 | 32 bytes | Leave DataExch counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B0)
0x37 | 0x1B8 to 0x1BF | 32 bytes | Leave DataExch counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1B8)
0x38 | 0x1C0 to 0x1C7 | 32 bytes | DataExch failed counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C0)
0x39 | 0x1C8 to 0x1CF | 32 bytes | DataExch failed counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x1C8)
Index | AS-i parameters | Length | Description
0x3A | 0x1D0 to 0x1D7 | 32 bytes | DataExch failed counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D0)
0x3B | 0x1D8 to 0x1DF | 32 bytes | DataExch failed counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x1D8)
0x40 | 0x200 to 0x207 | 32 bytes | 16 empty bytes and output data of AS-i analog slave 1 (byte 0 corresponds to bit 0 to 7 of parameter 0x200) | see mapping table
0x41 | 0x208 to 0x20F | 32 bytes | Output data, AS-i analog slaves 1 and 2 (byte 0 corresponds to bit 0 to 7 of parameter 0x208)
... | ... | ... | ...
0x4F | 0x278 to 0x27F | 32 bytes | Output data, AS-i analog slaves 30 and 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x278)
0x60 | 0x300 | 4 bytes | Cycle times (byte 0 corresponds to bit 0 to 7 of parameter 0x300)
0x62 | 0x310 | 8 bytes | Statistics (byte 0 corresponds to bit 0 to 7 of parameter 0x310)
0x64 | 0x320 to 0x327 | 32 bytes | Timeout statistics, AS-i slave 0 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x320)
0x65 | 0x328 to 0x32F | 32 bytes | Timeout statistics, AS-i slave 32 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x328)
0x68 | 0x340 to 0x347 | 32 bytes | Data exchange repeat counter, AS-i slave 0 to 15 (byte 0 corresponds to bit 0 to 7 of parameter 0x340)
0x69 | 0x348 to 0x34F | 32 bytes | Data exchange repeat counter, AS-i slave 16 to 31 (byte 0 corresponds to bit 0 to 7 of parameter 0x348)
0x6A | 0x350 to 0x357 | 32 bytes | Data exchange repeat counter, AS-i slave 32 to 47 (byte 0 corresponds to bit 0 to 7 of parameter 0x350)
0x6B | 0x358 to 0x35F | 32 bytes | Data exchange repeat counter, AS-i slave 48 to 63 (byte 0 corresponds to bit 0 to 7 of parameter 0x358)


KL6201/KL6211 at CANopen couplers

Operation at the fieldbus, overview [image] KL6201/KL6211 at CANopen couplers
KL6201/KL6211 at CANopen couplers
Chapter overview
This chapter comprises the following sections:
▪
Selecting the size of the process image
▪
Mapping of the process data
–
6-byte process image
–
12-byte process image
–
22-byte process image
–
38-byte process image
▪
Accessing parameters
Selecting the size of the process image
The size of the process image of the AS-i master terminal can be set to 6, 12, 22 or 38 bytes. This can be done with the KS2000 configuration software or via the fieldbus. To this end, parameter 0x20 has to be modified via the parameter data block (see AS-i parameter 0x20). The Bus Coupler must then be reset, after which it starts with the last selected process image size.
Note
Process Images
If the 22-byte or 38-byte process image is to be used under CANopen, the Bus Coupler may require a particular firmware version (see chapter Firmware version of the Bus Coupler). The delivered firmware version is shown on the back of the Bus Coupler (see example below). If required, the firmware can be updated via the serial interface (KS2000 cable required) or via CANopen (using the FC5101 fieldbus card, if firmware version C2 is already loaded on the Bus Coupler).
The current firmware versions and the program for the firmware update can be found at http://www.beckhoff.de. BK5120 devices with KL6201/KL6211 are supported in TwinCAT from version 2.8 (build 739).
Specification of the firmware version of the BK5120 CANopen coupler
Mapping of the process data
Like for the CANopen Bus Couplers, the process image of the KL6201/KL6211 is mapped to several 8-byte data objects. The 8-byte data objects are located in the CANopen object directory at index 0x3000 (input data) or index 0x3100 (output data). The coupler automatically maps these objects to the first free PDO (from PDO3) during start-up.
6-byte process image
Parameter data block
The 6-byte process image only consists of the parameter data block, supplemented by 2 dummy bytes. This block is located at index 0x3000 and is fully mapped into a PDO.
In contrast to the other process images, the 6-byte process image does not support direct access to the process data of the AS-i slaves. The process data access must take place via the AS-i parameters 0x80 to 0x87 (digital slaves) or 0x204 to 0x27F (analog slaves).
The TxPDO (KL6201/KL6211 -> PLC) with the input data (index 0x3000) has following structure:
Parameter data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
SB0 | SB1 | Para In 0 | Para In 1 | Para In 2 | Para In 3 | reserved | reserved
The RxPDO (PLC -> KL6201/KL6211) with the output data (index 0x3100) has following structure:
Parameter data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
CB0 | CB1 | Para Out 0 | Para Out 1 | Para Out 2 | Para Out 3 | reserved | reserved
Key
SB n: status byte n
CB n: control byte n
Para Out n: Output parameter, byte n
Para In n: Input parameter, byte n
12-byte process image
Parameter data block
The first 8-byte object contains the parameter data block, complemented by 2 dummy bytes. This block is located at index 0x3000 and is fully mapped into a PDO.
The TxPDO (KL6201/KL6211 -> PLC) with the input data (index 0x3000) has following structure:
Parameter data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
SB0 | SB1 | Para In 0 | Para In 1 | Para In 2 | Para In 3 | reserved | reserved
The RxPDO (PLC -> KL6201/KL6211) with the output data (index 0x3100) has following structure:
Parameter data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
CB0 | CB1 | Para Out 0 | Para Out 1 | Para Out 2 | Para Out 3 | reserved | reserved
Key
SB n: status byte n
CB n: control byte n
Para Out n: Output parameter, byte n
Para In n: Input parameter, byte n
Process data block
The next 8-byte object contains the process data block with AS-i status nibble (ASI SN) and the AS-i input data. The next TxPDO (KL6201/KL6211 -> PLC) therefore has the following content:
Process data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11 | reserved | reserved
The next RxPDO (PLC -> KL6201/KL6211) contains the AS-i command nibble (ASI CN) and the AS-i output data:
Process data block |  |  |  |  |  | Dummy bytes
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | Byte 6 | Byte 7
ASiCN + ASiOut Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11 | reserved | reserved
Key
ASiSN: AS-i status nibble
ASi CN: AS-i command nibble
ASiIn Slave x+y: Input data of the AS-i slaves x and y (one nibble per slave)
ASiOut Slave x+y: Output data of the AS-i slaves x and y (one nibble per slave)
For the 12-byte process image, the AS-i data are therefore mapped to the CANopen process data objects (PDOs) as follows:
Mapping of the AS-i data to the CANopen process data objects for the 12-byte process image
22-byte process image
Parameter data block
See 12-byte process image.
Process data block
If the 22-byte process image was selected (AS-i slave addresses > 11 in use), dummy bytes are used for further process data (slave addresses 12 to 31). Furthermore, one further 8-byte object with process data is created for the slaves from 16 to 31 in index 0x3000 or 0x3100 and mapped into the next free PDO.
Process data block
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | ... | Byte 15
ASiSN + ASiIn Slave 1 | ASiIn Slave 2+3 | ASiIn Slave 4+5 | ASiIn Slave 6+7 | ASiIn Slave 8+9 | ASiIn Slave 10+11 | ... | ASiIn Slave 30+31
The next RxPDO (PLC -> KL6201/KL6211) contains the AS-i command nibble (ASI CN) and the AS-i output data:
Process data block
Byte 0 | Byte 1 | Byte 2 | Byte 3 | Byte 4 | Byte 5 | ... | Byte 15
ASiCN + ASI Out Slave 1 | ASiOut Slave 2+3 | ASiOut Slave 4+5 | ASiOut Slave 6+7 | ASiOut Slave 8+9 | ASiOut Slave 10+11 | ... | ASiOut Slave 30+31
Key
See 12-byte process image.
Accordingly, in the 22-byte process image the AS-i data are mapped to the CANopen process data objects (PDO) as follows:
Mapping of the AS-i data to the CANopen process data objects for the 22-byte process image
38-byte process image
Parameter data block
See 12-byte process image.
Process data block
If the 38-byte process image was selected (AS-i slave addresses > 32 are used), a further 8-byte object with process data for AS-i slaves 33 to 63 is created in index 0x3000 or 0x3100 and mapped to the next free PDO.
Mapping of the AS-i data for slave addresses greater than 32 to the additional CANopen PDO for the 38-byte process image looks as follows (PDO n, PDO n+1, PDO n+2 as for the 22-byte process image):
Mapping of the AS-i data to the CANopen process data objects for the 38-byte process image
Mapping example
A BK5120 (Bus Coupler for CANopen) has
▪
78 digital inputs and 48 digital outputs
▪
6 analog inputs and 4 analog outputs
▪
a KL5001 (SSI encoder interface: 4 byte inputs by default)
▪
a KL6001 (serial interface: 4 byte inputs and 4 byte outputs by default)
▪
a KL5111 (incremental encoder interface) (6-byte inputs and 6-byte outputs)
▪
A KL6201/KL6211 AS-i master terminal with default setting (22-byte process image)
PDO | Data contents (mapping) | Object directory | PDO | Data contents (mapping) | Object directory
RxPDO1 | 5-byte digital outputs 1..48 | 0x6200, SI 1...5 | TxPDO1 | 8-byte digital inputs 1...64 | 0x6000, SI 1...8
RxPDO2 | 8-byte analog outputs 1..4 | 0x6411, SI 1...4 | TxPDO2 | 4-byte analog inputs 1...4 | 0x6401, SI 1...4
RxPDO3 | 4-byte serial interface | 0x2900, SI 1 | TxPDO3 | 2-byte digital inputs 65...78 | 0x6000, SI 9...10
RxPDO4 | 6-byte encoder outputs | 0x2D00, SI 1 | TxPDO4 | analog inputs 5 and 6 | 0x6401, SI 5..6
RxPDO5 | 8-byte AS-i master 1: parameter data block | 0x3100, SI 1 | TxPDO5 | 8 bytes: 4-byte SSI and 4-byte serial interface | 0x2800, SI 1...2
RxPDO6 | 8-byte AS-i master 1: Process data block outputs ASI slave 1...15 | 0x3100, SI 2 | TxPDO6 | 6 bytes encoder input | 0x2C00, SI 1
RxPDO7 | 8-byte AS-i master 1: Process data block outputs AS-i slave 16...31 | 0x3100, SI 3 | TxPDO7 | 8-byte AS-i master 1: parameter data block | 0x3000, SI 1
 |  |  | TxPDO8 | 8-byte AS-i master 1: Process data block inputs AS-i slave 1...15 | 0x3000, SI 2
 |  |  | TxPDO9 | 8-byte AS-i master 1: Process data block inputs AS-i slave 16...31 | 0x3000, SI 3
Access to the parameters of the KL6201/KL6211
The KL6201/KL6211 parameters are accessible via the parameter data block in the first receive process data object (RxPDO) and transmit process data object (TxPDO).
General examples for parameter access can be found in Chapter Access to AS-i parameters.


Firmware version of the Bus Couplers

Operation at the fieldbus, overview [image] Firmware version of the Bus Couplers
Firmware version of the Bus Couplers
Note
Required firmware
A particular firmware version may be required for operating the KL6201/KL6211 AS-i master terminals on the Bus Coupler / Bus Terminal Controller (see table below).
In delivery state the KL6201/KL6211 is set to a process image of 12 bytes. Most Bus Couplers and Bus Terminal Controllers listed in the table support the 6-byte and 12-byte process images.
Bus Couplers / Bus Terminal Controllers that are not listed
▪
require a terminal firmware version from B7 for operating the 6-byte or 12-byte process image on the KL6201/KL6211;
▪
are not yet prepared for operating the 22-byte or 38-byte process image.
The delivered firmware version is shown on the back of the Bus Coupler (see example below for CANopen).
Specification of the firmware version on a Bus Coupler
If required, the firmware can be updated via the serial interface (KS2000 cable required) or - depending on the bus system - via the fieldbus. The current firmware versions and the program for the firmware update can be found on our home page at http://www.beckhoff.de.
Support of the different process images by the firmware versions of the Bus Couplers / Bus Terminals Controllers
Fieldbus system | Bus Coupler / Bus Terminal Controller | Firmware version required on the Bus Coupler / Bus Terminal Controller for the
 |  | 6-byte process image (no direct access to AS-i slaves) | 12-byte process image (AS-i slave addresses 1 to 11) | 22-byte process image (AS-i slave addresses 1 to 31) | 38-byte process image (AS-i slave addresses 1 to 62)
EtherCAT | BK1120 | These Bus Couplers and Bus Terminal Controller support the 6-byte and 12-byte process image of the KL6201/KL6211. |  | from 08 (B8) | from 08 (B8)
 | BK1250 |  |  | all | all
Lightbus | BK2020 |  |  | from B1 | in preparation
PROFIBUS | BK3120 |  |  | from B9 | from BB
 | BK3150 |  |  | all | all
 | BK3500 |  |  | from B9 | from BB
 | BK3520 |  |  | from B9 | from BB
 | BC3100 |  |  | from C3 | from C4
 | BC3150 |  |  | all | all
 | BX3100 |  |  | all | all
Interbus | BK4020 |  |  | from B0 | in preparation
 | BC4000 |  |  | from B3 | in preparation
CANopen | BK5120 |  |  | from C4 | from C5
 | BK5150 |  |  | all | all
 | BC5150 |  |  | all | all
 | BX5100 |  |  | all | all
DeviceNet | BK5220 |  |  | (from B3)* | in preparation
 | BC5250 |  |  | all | all
 | BX5200 |  |  | all | all
ControlNet | BK7000 |  |  | from BC | from BC
Modbus | BK7300 |  |  | from B2 | from B4
Fip IO | BK7420 |  |  | from B1 | from B1
RS485 | BK8000 |  |  | from C2 | in preparation
RS232 | BK8100 |  |  | from C2 | in preparation
 | BC8150 |  |  | all | all
 | BX8000 |  |  | all | all
Ethernet | BK9000 |  |  | from B7 | from BA
 | BK9100 |  |  | from B1 | from B1
 | BC9000 |  |  | from B9 | from BB
 | BC9100 |  |  | from B1 | from B1
 | BC9050 |  |  | all | all
 | BX9000 |  |  | all | all
PROFINET | BK9103 | in preparation |  | in preparation | in preparation
EtherNet/IP | BK9105 | all |  | all | all
USB | BK9500 | This Bus Coupler supports the 6-byte and 12-byte process image of the KL6201/KL6211. |  | (from B1)* | in preparation
*) only if the Bus Coupler is set to complete mapping of the Bus Terminals (e.g. via the KS2000 configuration software). On delivery, these Bus Couplers are set to compact mapping of the Bus Terminals.


Diagnostics

Diagnostics
Diagnostics
Additional information
•
LEDs


LEDs

Diagnostics [image] LEDs
LEDs
LEDs
LED indicators - meanings
LED
Position
Color
Meaning
K-bus diag
1st LED left
green
This LED comes on during each K-bus cycle. During regular operation, it therefore flashes.
AS-i Diag
2nd LED left
green
This LED is on during the AS-i data exchange phase. During regular operation, it therefore flashes.
-
3rd LED left
green
reserved
Set
4th LED left
green
This LED is on as long as both set inputs are short-circuited.
AS-i Power
1st LED right
green
This LED is on as long as the AS-i power supply is connected and at least one AS-i slave was found.
AS-i Error
2nd LED right
red
This LED flashes in (protected mode), if set and actual configuration do not match.
Possible causes:
▪
AS-i ID code of one or several slaves does not match the currently projected values.
▪
The AS-i I/O code of one or several slaves does not match the currently projected values.
▪
The currently projected AS-i slave was not found.
-
3rd LED right
green
reserved
Mode
4th LED right
green
This LED is on as long as the two mode inputs are short-circuited.


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com