KL6031, KL6041 - Serial Interface Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.2.0
▪
Technical data updated
▪
Extended temperature range
▪
ATEX notes added
1.1
▪
Correction - C/S word
1.0
▪
Supplement added to description of operation with TwinCAT
0.2
▪
Description added to operation with TwinCAT PLC software
0.1
▪
first provisional documentation for KL6031 and KL6041
Firmware and hardware versions
Documentation Version | KL6031-0000 |  | KL6041-0000
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | 3C | 03 | 3D | 05
1.2.0 | 2A | 00 | 2A | 00
1.1 | 2A | 00 | 2A | 00
1.0 | 2A | 00 | 2A | 00
0.2 | 2A | 00 | 2A | 00
0.1 | 2A | 00 | 2A | 00
The firmware and hardware versions (delivery state) of the terminal can be found in the serial number printed on the side.
Syntax of the serial number
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. No.: 12 06 3A 02:
12 - week of production 12
06 - year of production 2006
3A - firmware version 3A
02 - hardware version 02


Product overview

Product overview
Product overview
Additional information
•
KL6031 - Introduction
•
KL6031 - Technical data
•
KL6031 – Basic function principles
•
KL6041 - Introduction
•
KL6041 - Technical data
•
KL6041 – Basic function principles


KL6031 - Introduction

Product overview [image] KL6031 - Introduction
KL6031 - Introduction
KL6031
The KL6031 serial interface allows devices with RS232 interface to be connected. It operates in conformity with the CCITT V.28/DIN 66 259-1 standards. The device connected to the KL6031 terminal communicates with the automation device via the Bus Coupler. The active communication channel operates independently of the higher-level bus system in full duplex mode at up to 115.2 kbit/s. The RS232 interface guarantees high immunity to interference through electrically isolated signals.
LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | on | normal operation
 |  | off | A watchdog timer overflow has occurred. The RUN LED goes out if no process data is transmitted to the terminal from the Bus Coupler for 100 ms.
TxD | green | State of the transmit signal line
RxD | green | State of the receive signal line
Connections
Terminal point | Name | Signal
1 | TxD | Signal line (Transmit Data)
5 | RxD | Signal line (Receive Data)
2 | RTS | Control line (Request To Send)
6 | CTS | Control line (Clear To Send)
3 | GND | Ground (internally bridged with terminal 7)
7 | GND | Ground (internally bridged with terminal 3)
4 | Shield | Shield (internally bridged with terminal 8)
8 | Shield | Shield (internally bridged with terminal 4)


KL6031 - Technical data

Product overview [image] KL6031 - Technical data
KL6031 - Technical data
Technical data | KL6031-0000, KS6031-0000
Data transfer channels | 2 (1/1), TxD and RxD, full duplex
Data transfer rate | 9600 bit/s, 8 data bits, no parity and one stop bit are pre-set (max. 115200 bit/s)
Bit distortion | < 3%
RS232 cable length | max. 15 m
Signal voltage "low" | -18 V ... -3 V
Signal voltage "high" | 3 V ... 18 V
Power supply | via the K-bus
Electrical isolation | 500 V (K-bus/signal voltage)
Data buffer | 1024 byte receive buffer, 128 byte transmit buffer
Bit width in process image | input/output: 22 x 8 bit user data, 2 x 8 bit control/status (up to 22 bytes of user data possible)
Configuration | no address setting, configuration via bus coupler or controller
Current consumption from K-bus | 55 mA
Weight | approx. 50 g
Permissible ambient temperature range during operation | -25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -45 °C ... +85 °C
Permissible relative humidity | 95% no condensation
Mounting | on 35 mm mounting rail according to EN 60715
Pluggable wiring | for all KSxxxx terminals
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX, GL


KL6031 – Basic function principles

Product overview [image] KL6031 – Basic function principles
KL6031 – Basic function principles
The KL6031 serial interface terminal enables the connection of devices with an RS232 interface (e.g. bar code scanners). Data can be exchanged with the controller in full duplex mode, independent of the higher-level bus system. The receive buffer has 1024 bytes, the transmit buffer 16 bytes. The data transfer between terminal and controller is handled via a handshake in the status and control byte. The factory setting of the terminal is 9600 bit, 8 data bits, 1 stop bit, no parity, RTS/CTS control active.
LED display
The Run LED indicates the operating state of the terminal.
▪
On – normal operation
▪
Off – Watchdog timer overflow has occurred. If no process data is transmitted from the Bus Coupler for 100 ms, the green LED goes out.
The TxD and RxD LEDs indicate the states of the signal lines.
Process data - alternative output format
In the alternative output format, 4 or 5 bytes (3 bytes for data and 1 or 2 control/status byte(s)) are mapped in the Bus Coupler. The KL6031 is delivered in the alternative format. The mapping of the terminal in the alternative format is described in more detail in the chapter "Terminal configuration".
Process data - standard output format
In the standard output format, 4 bytes of user data (3 bytes of user data and 1 Control/Status byte) are mapped by default in the Bus Coupler. By changing the parameters of the KL6031, up to 5 bytes of user data can be transferred.
Reference
The chapter "Access from the user program" provides an overview of the possible mapping configurations depending on the adjustable parameters.


KL6041 - Introduction

Product overview [image] KL6041 - Introduction
KL6041 - Introduction
KL6041
The KL6041 serial interface enables the connection of devices with an RS422 or RS485 interface. The device connected to the KL6041 terminal communicates with the automation device via the Bus Coupler. The active communication channel operates independently of the higher-level bus system in full or half duplex mode at up to 115.2 kbit/s. The differential signal transmission according to RS422 guarantees high immunity to interference through electrically isolated signals.
LEDs
LED | Color | Meaning
RUN | green | This LED indicates the terminal's operating state:
 |  | on | normal operation
 |  | off | A watchdog timer overflow has occurred. The RUN LED goes out if no process data is transmitted to the terminal from the Bus Coupler for 100 ms.
TxD | green | State of the transmit signal line
RxD | green | State of the receive signal line
Connections
Terminal point | Name | Signal
1 | TxD+ | Signal line + (Transmit Data)
5 | TxD- | Signal line - (Transmit Data)
2 | RxD+ | Signal line + (Receive Data)
6 | RxD- | Signal line - (Receive Data)
3 | GND | Ground (internally bridged with terminal 7)
7 | GND | Ground (internally bridged with terminal 3)
4 | Shield | Shield (internally bridged with terminal 8)
8 | Shield | Shield (internally bridged with terminal 4)


KL6041 - Technical data

Product overview [image] KL6041 - Technical data
KL6041 - Technical data
Technical data | KL6041-0000, KS6041-0000
Data transfer channels | TxD and RxD, full/half duplex
Data transfer rate | 9600 bit/s, 8 data bits, no parity and one stop bit are pre-set (max. 115200 bit/s)
Bit transfer | with differential signal
Line impedance | 120 Ω
Transmission link | approx. 1000 m twisted-pair
Power supply | via the K-bus
Current consumption from K-bus | typ. 65 mA
Electrical isolation | 500 V (K-bus/signal voltage)
Data buffer | 1024 byte receive buffer, 128 byte transmit buffer
Bit width in process image | input/output: 22 x 8 bit user data, 2 x 8 bit control/status (up to 22 bytes of user data possible)
Configuration | no address setting, configuration via bus coupler or controller
Weight | approx. 50 g
Permissible ambient temperature range during operation | 25°C ... +60°C (extended temperature range)
Permissible ambient temperature range during storage | -45 °C ... +85 °C
Permissible relative humidity | 95% no condensation
Mounting | on 35 mm mounting rail according to EN 60715
Pluggable wiring | for all KSxxxx terminals
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX, GL


KL6041 – Basic function principles

Product overview [image] KL6041 – Basic function principles
KL6041 – Basic function principles
The KL6041 serial interface terminal enables the connection either
▪
of devices with an RS485 interface or
▪
of a device with an RS422 interface (peer to peer).
Depending on the higher-level fieldbus system, data can be exchanged with the controller in full-duplex or half-duplex mode. The size of the receive buffer is 1024 bytes, that of the transmit buffer 128 bytes. The data transfer between terminal and controller is handled via a handshake in the status and control byte. The factory setting of the terminal is 9600 bit, 8 data bits, 1 stop bit, no parity, full duplex mode.
LED display
The Run LED indicates the operating state of the terminal.
On – normal operation
Off – Watchdog timer overflow has occurred. If no process data is transmitted from the Bus Coupler for 100 ms, the green LED goes out.
The TxD and RxD LEDs indicate the states of the signal lines.
Process data - standard output format
In the standard output format, 22 bytes of user data and 1 Control/Status word are mapped in the Bus Coupler. By changing the parameters of the KL6041, up to 3 or 5 bytes of user data can be transmitted.
Connection for RS485 transfer
In RS485 mode, data are exchanged in half duplex mode. A bus structure can be created in this operation mode.
RS485
Connection for RS422 transfer
The data are transmitted in full duplex in the RS422 operation mode. Only peer-to-peer connections can be established.
RS422
Reference
The chapter on Access from the user program contains an overview of possible mapping configurations, depending on the configurable parameters.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
KL6031 - Common Settings
•
KL6041 - Common Settings
•
RS232(485) interface parameters
•
Process data


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 Digital Input Terminal
▪
a KL6041 single-channel serial interface terminal
▪
a KL6031 single-channel serial interface terminal
▪
a KL9010 Bus End Terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branch for channel 1 of the KL6031
For the KL6031 or KL6041, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL6031/KL6041 registers.
▪
Dialog masks for the parameterization of the KL6031/KL6041 can be found under Settings.
▪
ProcData displays the KL6031/KL6041 process data.


Register

KS2000 Configuration Software [image] Register
Register
Under Register you can directly access the registers of the KL6031/KL6041. The meaning of the register is explained in the Register Overview.
Register view in KS2000


KL6031 - Common Settings

KS2000 Configuration Software [image] KL6031 - Common Settings
KL6031 - Common Settings
Common Settings tab for parameterization of the KL6031.
Settings via KS2000
General
Take Settings for all channels of this terminal
The settings made are adopted for all channels of the terminal (default: deactivated).
Process Data Length (R34.7)
Here, you can set the user data length (3, 5 or 22 bytes) of the process data image (default: 22 bytes).
Set Factory Settings (R7)
Here, you can restore the terminal's factory settings and save them with "Apply".
Communication Parameters
▪
RTS/CTS activated (R34.0),
(default: activated)
▪
Alternative output format (R34.1),
(default: deactivated)
▪
Status byte one cycle later (R34.2),
(default: deactivated)
▪
XON/XOFF supported sending data (R34.3),
(default: deactivated)
▪
XON/XOFF supported receiving data (R34.4),
(default: deactivated)
▪
Send FIFO data continuously (R34.6),
(default: deactivated)
▪
Extended process data interface (R34.7),
(set automatically)
▪
Transfer rate optimization (R34.8),
(default: activated)


KL6041 - Common Settings

KS2000 Configuration Software [image] KL6041 - Common Settings
KL6041 - Common Settings
Common Settings tab for parameterization of the KL6041.
Settings via KS2000
General
Take Settings for all channels of this terminal
The settings made are adopted for all channels of the terminal (default: deactivated).
Process Data Length (R34.7)
Here, you can set the user data length (3, 5 or 22 bytes) of the process data image (default: 22 bytes).
Set Factory Settings (R7)
Here, you can restore the terminal's factory settings and save them with "Apply".
Communication Parameters (R34)
▪
Half duplex (R34.0),
(default: deactivated)
▪
Alternative output format (R34.1),
(default: deactivated)
▪
Status byte one cycle later (R34.2),
(default: deactivated)
▪
XON/XOFF supported sending data (R34.3),
(default: deactivated)
▪
XON/XOFF supported receiving data (R34.4),
(default: deactivated)
▪
Point to point connection (R34.5),
(default: deactivated)
▪
Send FIFO data continuously (R34.6),
(default: deactivated)
▪
Extended process data interface (R34.7),
(set automatically)
▪
Transfer rate optimization (R34.8),
(default: activated)


RS232(485) interface parameters

KS2000 Configuration Software [image] RS232(485) interface parameters
RS232(485) interface parameters
RS232(485) Interface Parameters tab for parameterizing the KL6031/KL6041.
(The example below shows the KL6031 tab).
Settings via KS2000
Baud rate (R32)
You can set the baud rate for the terminal here (default: 9600 bit/s).
Data format (R33)
Data format setting (default: 8 data bits, no parity).
Stop bits (R33.3)
Setting 1 or 2 stop bits via register R33, bit 3 (default: 1 stop bit).


Process data

KS2000 Configuration Software [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The spectacles mark the data that are currently graphically displayed in the History field.
History field
The current input value is displayed numerically in the Value field.
Value field
Output values can be modified through direct input or by means of the fader control.
Value field
SmallWarningYellow CAUTION
Danger for persons, the environment or devices!
Note that changing output values (forcing) can have a direct effect on your automation application. Only modify these output values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Control and status word
•
Register overview
•
Register description
•
Mapping
•
Examples of Register Communication
•
Operation with TwinCAT PLC software


Control and status word

Access from the user program [image] Control and status word
Control and status word
Control word
The control word (CW) is located in the output process image, and is transmitted from the controller to the terminal.
Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8 | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | OL7 | OL6 | OL5 | OL4 | OL3 | OL2 | OL1 | OL0 | - | OL2* | OL1* | OL0* | SC | IR | RA | TR
Bits CW.15 to CW.8 are only shown if the large process image is used.
If the small or medium process image is used, only bits CW.7 to CW.0 are shown as control bytes! The number of output bytes available for transfer from the controller to the terminal is displayed by bits OL2* ... OL0*.
Key
Bit | Name | Description
CW.15 ... CW8 | OL7 ... OL0 (OutLenght) | 1dec... 22dec | If the large process image is used: Number of output bytes () available for transfer from the controller to the terminal.
 |  | - | If the small/medium process image is used: not shown
CW.7 | - | 0bin | reserved
CW.6 … CW.4 | OL2* ... OL0* (OutLenght*) | 0 | If the large process image is used: reserved
 |  | 1 ... 6 | If the medium process image is used: Number of output bytes available for transfer from the controller to the terminal.
 |  | 1 ... 4 | If the small process image is used: Number of output bytes available for transfer from the controller to the terminal.
CW.3 | SC (SendContinious) | rise | Continuous sending of data from the FIFO. The send buffer is filled (up to 128 bytes) by the controller. The buffer content is sent with rising edge of bit SC. The terminal acknowledges the data transfer to the controller through setting of bit SW.2. SW.2 is cancelled with CW.3.
CW.2 | IR (InitRequest) | 1bin | The controller requests terminal for initialization. The send and receive functions are blocked, the FIFO pointers are reset and the interface is initialized with the values from the relevant registers (R32-R35, R18). The terminal acknowledges completion of the initialization via bit SW.2 (IA).
 |  | 0bin | The controller once again requests the terminal to prepare for serial data exchange.
CW.1 | RA (ReceiveAccepted) | toggle | The controller acknowledges receipt of data by changing the state of this bit. Only then new data can be transferred from the terminal to the controller.
CW.0 | TR (TransmitRequest) | toggle | Via a change of state of this bit the controller notifies the terminal that the DataOut bytes contain the number of bytes indicated via the OL bits. The terminal acknowledges receipt of the data in the status byte via a change of state of bit SW.0 (TA). Only now new data can be transferred from the controller to the terminal.
Status word
The status word (SW) is located in the input process image, and is transmitted from terminal to the controller.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | IL7 | IL6 | IL5 | IL4 | IL3 | IL2 | IL1 | IL0 | - | IL2* | IL1* | IL0* | BUF_F | IA | RR | TA
Bits SW.15 to SW.8 are only shown if the large process image is used.
If the small or medium process image is used, only bits SW.7 to SW.0 are shown as status bytes! The number of input bytes available for transfer from the terminal to the controller is displayed by bits IL2* ... IL0*.
Key
Bit | Name | Description
SW.15 ... SW8 | IL7 ... IL0 (InLenght*) | 1dec ... 22dec | If the large process image is used: Number of input bytes available for transfer from the terminal to the controller.
 |  | - | If the small/medium process image is used: not shown
SW.7 | - | 0bin | reserved
SW.6 ... SW.4 | IL2* ... IL0* (InLenght*) | 0 | If the large process image is used: reserved
 |  | 1 ... 6 | If the medium process image is used: Number of input bytes available for transfer from the terminal to the controller.
 |  | 1 ... 4 | If the small process image is used: Number of input bytes available for transfer from the terminal to the controller.
SW.3 | BUF_F | 1bin | The receive FIFO is full. All further incoming data will be lost!
SW.2 | IA (InitAccepted-Bit) | 1bin | Initialization was completed by the terminal.
 |  | 0bin | The terminal is ready again for serial data exchange.
SW.1 | RR (ReceiveRequest) | toggle | Via a change of state of this bit the terminal notifies the controller that the DataIn bytes contain the number of bytes indicated via the IL bits. The controller has to acknowledge receipt of the data in the control byte via a change of state of bit CW.1 (RA). Only then new data can be transferred from the terminal to the controller.
SW.0 | TA (TransmitAccepted) | toggle | The terminal acknowledges receipt of data by changing the state of this bit. Only now new data can be transferred from the controller to the terminal.
Data transfer examples
The examples use the large process image.
Data transfer from the controller to the terminal
Control word |  | Status word |  | Comment
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
0000 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | Start of data transmission
0000 0010bin | 0000 0001bin | xxxx xxxxbin | 0000 x0x0bin | The controller requests transmission of 2 bytes by the terminal
0000 0010bin | 0000 0001bin | xxxx xxxxbin | 0000 x0x1bin | Command is executed: Terminal has loaded 2 bytes into the transmission FIFO
0001 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x1bin | The controller requests transmission of 16 bytes by the terminal
0001 0000bin | 0000 0000bin | xxxx xxxxbin | 0000 x0x0bin | Command is executed: Terminal has loaded 16 bytes into the transmission FIFO
Data transfer from the terminal to the controller
Control word |  | Status word |  | Comment
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | 0000 000xbin | 0000 0000bin | 0000 000xbin | Start of data transmission
xxxx xxxxbin | 0000 000xbin | 0000 0011bin | 0000 001xbin | The terminal requests transfer of 3 bytes from the controller
xxxx xxxxbin | 0000 001xbin | 0000 0011bin | 0000 001xbin | Acknowledgement: Controller has received 3 bytes from the receive FIFO
xxxx xxxxbin | 0000 001xbin | 0001 0110bin | 0000 000xbin | The terminal requests transfer of 22 bytes from the controller
xxxx xxxxbin | 0000 000xbin | 0001 0110bin | 0000 000xbin | Acknowledgement: Controller has received 22 bytes from the receive FIFO
Initialization
Control word |  | Status word |  | Comment
CW.15 ... CW.8 | CW.7 ... CW.1 | SW.15 ... SW.8 | SW.7 ... SW.1
xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | xxxx xxxxbin | Start of data transmission
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0000bin | The controller requests terminal initialization
0000 0000bin | 0000 0100bin | 0000 0000bin | 0000 0100bin | Command is executed: Terminal initialization is complete
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0100bin | The controller requests the terminal to prepare for serial data exchange
0000 0000bin | 0000 0000bin | 0000 0000bin | 0000 0000bin | Command is executed: Terminal is ready for serial data exchange


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for the parameterization of the interface terminals. They can be read or written by means of the register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Number of data bytes in the send buffer |  | variable | - | R | RAM
R1 | Number of data bytes in the receive buffer |  | variable | - | R | RAM
R2 | reserved |  | 0x0000 | 0dec | R | -
R3 | reserved |  | 0x0000 | 0dec | R | -
R4 | reserved |  | 0x0000 | 0dec | R | -
R5 | reserved |  | 0x0000 | 0dec | R | -
R6 | Diagnostic register |  | variable | - | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R | -
R8 | Terminal type | KL6031: | 0x178F | 6031dec | R | ROM
 |  | KL6041: | 0x1799 | 6041dec
R9 | Firmware version |  | e.g. 0x3143 | e.g. 1CASCII | R | ROM
R10 | Multiplex shift register |  | variable | - | R | ROM
R11 | Signal channels |  | variable | - | R | ROM
R12 | Minimum data length |  | variable | - | R | ROM
R13 | Data structure |  | 0x0000 | 0dec | R | ROM
R14 | reserved |  | - | - | R | -
R15 | Alignment register |  | variable | - | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
R18 | Buffer full message |  | 0x0400 | 1024dec | R/W | EEPROM
... | ... |  | ... | ... | ... | ...
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | variable | - | R/W | RAM
R32 | Baud rate |  | 0x0006 | 6dec | R/W | EEPROM
R33 | Data Frame |  | 0x0003 | 3dec | R/W | EEPROM
R34 | Feature register |  | 0x0181 | 385dec | R/W | EEPROM
R35 | Number of data bytes to the Bus Coupler |  | 0x0017 | 23dec | R/W | EEPROM
R36 | reserved |  | 0x0000 | 0dec | R/W | EEPROM
... | ... |  | ... | ... | ... | ...
R63 | reserved |  | 0x0000 | 0dec | R/W | EEPROM


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for parameterizing the terminals.
R0: Number of data bytes in the send buffer
R0 contains the number of data in the transmission FIFO.
R1: Number of data bytes in the receive buffer
R0 contains the number of data in the receive FIFO.
R6: Diagnostic register
Bit | Description |  | default
R6.15 … R6.5 | - | reserved | -
R6.4 | 1bin | Buffer is full | 0bin
R6.3 | 1bin | An overrun error has occurred | 0bin
R6.2 | 1bin | A framing error has occurred | 0bin
R6.1 | 1bin | A parity error has occurred | 0bin
R6.0 | 1bin | The receive buffer has overflowed, incoming data is lost | 0bin
R7: Command register
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31!
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the delivery state for the following registers.
R18: 0x0400
R32: 0x0006
R33: 0x0003
R34: 0x0181
R35: 0x0017
R8: Terminal type
The terminal name is contained in register R8:
KL6031: 0x178F (6031dec)
KL6041: 0x1799 (6041dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3143 = '1C'. The '0x31' corresponds here to the ASCII character '1', while the '0x43' represents the ASCII character 'C'.
This value cannot be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R18: Buffer full
Register R18 defines the number of data in the input FIFO from which the BUF_F bit is set in the Status word
R31-R35: User registers
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are written into the RAM registers and in the EEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset when the terminal is restarted.
R32: Bit/s rate
R32 defines the bit/s rate of the terminal. The delivery state is 9600 bit/s.
Bit 15 … 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Baud rate
reserved | 1 | 0 | 1 | 0 | 115200 bit/s
reserved | 1 | 0 | 0 | 1 | 57600 bit/s
reserved | 1 | 0 | 0 | 0 | 38400 bit/s
reserved | 0 | 1 | 1 | 1 | 19200 bit/s
reserved | 0 | 1 | 1 | 0 | 9600 bit/s (default)
reserved | 0 | 1 | 0 | 1 | 4800 bit/s
R33: Data Frame
R33 defines the setting of the data format. The delivery state is 8 data bits, no parity.
Bit 15 … 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Meaning
reserved | 0bin: 1 stop bit; 1bin: 2 stop bits | 1 | 0 | 1 | 8 data bits, odd parity
reserved | 0bin: 1 stop bit; 1bin: 2 stop bits | 1 | 0 | 0 | 8 data bits, even parity
reserved | 0bin: 1 stop bit; 1bin: 2 stop bits | 0 | 1 | 1 | 8 data bits, no parity (default)
reserved | 0bin: 1 stop bit; 1bin: 2 stop bits | 0 | 1 | 0 | 7 data bits, odd parity
reserved | 0bin: 1 stop bit; 1bin: 2 stop bits | 0 | 0 | 1 | 7 data bits, even parity
R34: Feature register
R34 defines the operation mode of the terminal.
Bit | Description of the operation mode |  |  | default
R34.15 … R34.9 | - | reserved |  | -
R34.8 | 0bin | No transfer rate optimization The data are immediately placed on the bus. |  | 1bin
 | 1bin | Transfer rate optimization After receipt of a byte, the system waits for max. 4 ms for a further byte. If the receive buffer is full, the data are immediately placed on the bus.
R34.7 | 0bin | Small and medium process data image 3 or 5 bytes of user data (setting in R35) can be transferred. |  | 1bin
 | 1bin | Extended process data image Up to 22 bytes of user data (setting in R35) can be transferred. (Compatible couplers: BCxx50, BXxxxx, CXxxxx, BKxx20, BKxx50, BKxx50)
R34.6 | 0bin | Direct transmission from the FIFO The buffer contents are transmitted immediately. |  | 0bin
 | 1bin | Continuous transmission from the FIFO The send buffer is filled (up to 128 bytes) by the controller. The filled buffer contents will be transmitted on the rising edge of the bit "Control Byte (Word), Bit 3" (CB.3, CW.3). Once the data have been transferred, the terminal confirms this to the controller by setting the bit "Status Byte (Word), Bit 2" (SB.2, SW.2). SB.2 (SW.2) is canceled with CB3 (CW.3).
R34.5 | 0bin | KL6031: | reserved | -
 |  | KL6041: | Point to point connection disabled | 0bin
 | 1bin | KL6031: | reserved | -
 |  | KL6041: | Point to point connection enabled | -
R34.4 | 0bin | No support for the XON/XOFF protocol when receiving data |  | 0bin
 | 1bin | Support for the XON/XOFF protocol when receiving data The terminal sends the control character XOFF when the terminal buffer contains 1014 characters. XON is sent if XOFF was sent previously and the value falls below the lower buffer limit of 18 bytes.
R34.3 | 0bin | No support for the XON/XOFF protocol when transmitting data |  | 0bin
 | 1bin | Support for the XON/XOFF protocol when transmitting data The terminal transmits the data transferred by the controller until it receives from the controller the sign XOFF (DC3ASCII == 0x13) from the partner. Thereafter, transmission is prevented until the sign (DC1ASCII == 0x11) is received.
R34.2 | 0bin | No delayed Status byte |  | 0bin
 | 1bin | Delayed Status byte The Status byte is copied by the terminal into the shift register of the K-bus one cycle later than the higher-value data bytes. This reduces the rate of data transmission to the controller.
R34.1 | 0bin | Standard output format (note R35!) |  | 0bin
 | 1bin | Alternative output format In the alternative output format, 4 or 5 bytes (3 bytes for data and 1 or 2 control/status byte(s)) are mapped in the Bus Coupler.
R34.0 | 0bin | KL6031: | RTS, CTS deactivated | -
 |  | KL6041: | Full duplex | 0bin
 | 1bin | KL6031: | RTS, CTS activated | 1bin
 |  | KL6041: | Half duplex | -
R35: Number of data bytes mapped in the Bus Coupler
R35 defines the number of data bytes mapped in the Bus Coupler.
Bit 15 … 15 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0 | Data bytes
reserved | 1 | 0 | 1 | 1 | 1 | 22 bytes + 1 Control/Status word in the extended process data image (see R34.7)
reserved | 0 | 0 | 1 | 1 | 0 | 5 bytes + 1 Control/Status byte
reserved | 0 | 0 | 0 | 1 | 1 | 3 bytes + 1 Control/Status byte
R36 - 63: reserved


Mapping

Access from the user program [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions), such as
- compact or complex evaluation
- Intel or Motorola format
- word alignment activated or deactivated
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions.
Complex evaluation
In the case of complex evaluation, the serial interface terminals occupy addresses in the input and output process image. Control and Status words can be accessed.
22-byte process image
Complex evaluation in Intel format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: any | 0 | SW |  | CW
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | DataIn 3 | DataIn 2 | DataOut 3 | DataOut 2
 | 3 | DataIn 5 | DataIn 4 | DataOut 5 | DataOut 4
 | 4 | DataIn 7 | DataIn 6 | DataOut 7 | DataOut 6
 | 5 | DataIn 9 | DataIn 8 | DataOut 9 | DataOut 8
 | 6 | DataIn 11 | DataIn 10 | DataOut 11 | DataOut 10
 | 7 | DataIn 13 | DataIn 12 | DataOut 13 | DataOut 12
 | 8 | DataIn 15 | DataIn 14 | DataOut 15 | DataOut 14
 | 9 | DataIn 17 | DataIn 16 | DataOut 17 | DataOut 16
 | 10 | DataIn 19 | DataIn 18 | DataOut 19 | DataOut 18
 | 11 | DataIn 21 | DataIn 20 | DataOut 21 | DataOut 20
Complex evaluation in Motorola format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: any | 0 | SW |  | CW
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | DataIn 3 | DataOut 2 | DataOut 3
 | 3 | DataIn 4 | DataIn 5 | DataOut 4 | DataOut 5
 | 4 | DataIn 6 | DataIn 7 | DataOut 6 | DataOut 7
 | 5 | DataIn 8 | DataIn 9 | DataOut 8 | DataOut 9
 | 6 | DataIn 10 | DataIn 11 | DataOut 10 | DataOut 11
 | 7 | DataIn 12 | DataIn 13 | DataOut 12 | DataOut 13
 | 8 | DataIn 14 | DataIn 15 | DataOut 14 | DataOut 15
 | 9 | DataIn 16 | DataIn 17 | DataOut 16 | DataOut 17
 | 10 | DataIn 18 | DataIn 19 | DataOut 18 | DataOut 19
 | 11 | DataIn 20 | DataIn 21 | DataOut 20 | DataOut 21
5-byte process image
Complex evaluation in Intel format without word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: no | 0 | DataIn 0 | SB | DataOut 0 | CB
 | 1 | DataIn 2 | DataIn 1 | DataOut 2 | DataOut 1
 | 2 | DataIn 4 | DataIn 3 | DataOut 4 | DataOut 3
 | 3 | reserved | DataIn 5 | reserved | DataOut 5
Complex evaluation in Intel format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | DataIn 3 | DataIn 2 | DataOut 3 | DataOut 2
 | 3 | DataIn 5 | DataIn 4 | reserved | DataOut 4
Complex evaluation in Motorola format without word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: no | 0 | DataIn 1 | SB | DataOut 1 | CB
 | 1 | DataIn 3 | DataIn 0 | DataOut 3 | DataOut 0
 | 2 | DataIn 5 | DataIn 2 | DataOut 5 | DataOut 2
 | 3 | reserved | DataIn 4 | reserved | DataOut 4
Complex evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | DataIn 3 | DataOut 2 | DataOut 3
 | 3 | DataIn 4 | DataIn 5 | DataOut 4 | DataOut 5
3-byte process image
Complex evaluation in Intel format without word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: no | 0 | DataIn 0 | SB | DataOut 0 | CB
 | 1 | DataIn 2 | DataIn 1 | DataOut 2 | DataOut 1
Complex evaluation in Intel format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | DataIn 1 | DataIn 0 | DataOut 1 | DataOut 0
 | 2 | reserved | DataIn 2 | reserved | DataOut 2
Complex evaluation in Motorola format without word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: no | 0 | DataIn 1 | SB | DataOut 1 | CB
 | 1 | DataIn 2 | DataIn 0 | DataOut 2 | DataOut 0
Complex evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | DataIn 0 | DataIn 1 | DataOut 0 | DataOut 1
 | 2 | DataIn 2 | reserved | DataOut 2 | reserved
Compact evaluation
Operation with a compact process image is not possible
Operation of the KL6031 / KL6041 with a compact process image (without Control and Status bytes) is not possible, because Control and Status bytes are required for meaningful process data mode of the KL6031 / KL6041. Even if you set your Bus Coupler to the compact process image, the KL6031 / KL6041 will still be represented with a complete process image!
Key
Complex evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the channel address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.
SB / SW: Status byte / Status word for channel n (appears in the input process image)
CB / CW: Control byte for channel n (appears in the output process image)
reserved: This byte is assigned to the process data memory, although it has no function.


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Operation with TwinCAT PLC software

Access from the user program [image] Operation with TwinCAT PLC software
Operation with TwinCAT PLC software
Required TwinCAT version
These Bus Terminals are only supported from TwinCAT version 2.0 of the serial communication library (ComLibV2). In the case of Bus Terminals, the K-bus update time of the Bus Coupler must be considered when selecting the cycle time. Further information on configuration and operation with TwinCAT can be found in the Beckhoff Infosys at
http://infosys.beckhoff.com/.
KL6031 and KL6041 in 22-byte mode
The Beckhoff KL6031 und KL6041 serial Bus Terminals are operated in the delivered standard version with a 24-byte process image (22 bytes of user data + 1 Control/Status word), so that 22 data bytes can be transferred both from and to the terminal.
Three PLC cycles are required for the data exchange between the PLC and the Bus Terminal. The maximum effective data transfer rate (bps) depends on the cycle time T of the PLC and the number of bits necessary to transfer one data byte (LB):
bps = (LB x PA / 3) / T
LB = 1 start bit + n data bits + p parity bits + m stop bits
PA = number of user data in the process image
The maximum effective data transfer rate is upwardly limited by the physical bit/s rate configured in the Bus Terminal.
bps = (10 bits x 22/3) / 0.010 s ≈ 7333 bps
KL6031 and KL6041 in 5-byte mode
The serial Bus Terminal can also be reconfigured in such a way that 5 data bytes can be transferred both from and to the terminal in 5-byte mode (6-byte process image). 3 PLC cycles are still necessary for each exchange. The effective data rate for a given cycle time of the PLC is thus 5/3 greater than in 3-byte mode.
bps = (10 bits x 5/3) / 0.010 s ≈ 1666 bps
The Bus Terminals cannot be re-programmed while the PLC is running, since the 3-byte and 5-byte modes differ in the register mapping and in the TwinCAT System Manager configuration.
KL6031 and KL6041 in 3-byte mode
When operating the KL6031 + KL6041 in 3-byte mode, 3 data bytes (4-byte process image) can be transferred to and received by the terminal in a bus telegram. Since every data exchange between the PLC and the Bus Terminal requires 3 PLC cycles, the effective transfer rate is one byte per cycle.
bps = (10 bits x 3/3) / 0.010 s ≈ 1000 bps
Serial PC Interface
The serial PC interface (COM1, COM2 etc.) is handled by the TwinCAT system similarly to the serial bus terminal, but use larger data transfer buffers than the serial bus terminal. COMlib uses a 64-byte buffer, so up to 64 data bytes are transferred at once between the PLC and the interface driver. 3 PLC cycles are again needed for the exchange of a data block with the serial PC interface.
bps = (LB x 64/3) / T


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com