KL4132 - Dual-channel analog output terminal, -10 V to +10 V, 16 Bit
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
3.1
▪
Update chapter “Instructions for ESD protection”
▪
Chapter “Beckhoff Identification Code (BIC)” added
▪
Update Firmware and Hardware versions
3.0
▪
Migration
▪
Update Technical data
▪
Structure update
▪
Chapters KS2000 configuration software and Access from the user program added
Firmware (FW) and hardware (HW) versions
Documentation, version | KL4132
 | FW | HW
3.1 | 3D | 07
3.0 | 3A | 06
The firmware and hardware versions (delivery state) can be found in the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 35 04 1B 01:
35 - week of production 35
4 - year of production 2004
1B - firmware version 1B
1 - hardware version 1


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
KL4132 - Introduction
•
EL4132 - Technical data
•
Basic function principles


KL4132 - Introduction

Product overview [image] KL4132 - Introduction
KL4132 - Introduction
KL4132
The KL4132 analog output terminal generates signals in the range from -10 V to +10 V. The voltage is supplied to the process level with a resolution of 16 bits, and is electrically isolated. The output channels of a Bus Terminal have a common ground potential. The two RUN LEDs give an indication of the data exchange with the Bus Coupler.


EL4132 - Technical data

Product overview [image] EL4132 - Technical data
EL4132 - Technical data
Technical Data | KL4132
Number of outputs | 2
Power supply | via the K-Bus
Signal current | -10 V…+10 V
Load | > 5 kΩ
Accuracy | < ±0.1 % (of the full scale value)
Resolution | 16 bits
Electrical isolation | 500 V (K-Bus / signal voltage)
Conversion time | ~ 1.5 ms
Current consumption from the K-bus | typically 75 mA
Bit width in the K-bus I/O | Output: 2 x 16 bits of data (2 x 8 bits control/status optional)
Configuration | No address or configuration settings
Weight | approx. 85 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0 °C to + 55 °C
Permissible ambient temperature range during storage | -25 °C to +85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also Installation instructions for terminals with enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


Basic function principles

Product overview [image] Basic function principles
Basic function principles
The KL4132 analog output terminal generates signals in the range from -10 V to +10 V. The terminal supplies the output voltage with a resolution of up to 16 bits. The output voltage is output electrically isolated from the terminal bus level.
The LEDs indicate the operating state of the associated terminal channels.
▪
green Run LED:
–
On: Normal operation
–
Off: Watchdog timer overflow has occurred. If no process data are transmitted by the Bus Coupler for 100 ms, the green LEDs go out. The output assumes a user-specified voltage (see Feature register).
Process data input format
In the delivery state the process data are shown in two's complement form (integer -1 corresponds to 0xFFFF).
Output value | Process data
 | dec | hex
-10 V | -32767 | 0x8001
-5 V | -16383 | 0xC001
0 V | 0 | 0x0000
5 V | 16383 | 0x3FFF
10 V | 32767 | 0x7FFF
Process data
The process data arriving from the Bus Coupler are output to the process:
Y_0 = B_a + A_a*X
Y_dac = Y_0
(1.0)
Neither user nor manufacturer scaling is active.
Y_1 = B_h + A_h * X
Y_dac = Y_1
(1.1)
Manufacturer scaling active
Y_2 = B_w + A_w * X
Y_dac = Y_2
(1.2)
User scaling active
Y_1 = B_h + A_h * X
Y_dac = B_w + A_w * Y_1
(1.3)
(1.4)
Manufacturer and user scaling active
Key
Name | Name | Register
X | PLC process data | -
B_a | Hardware compensation offset | R17
A_a | Hardware compensation gain | R18
B_h | Manufacturer scaling: Offset | R19
A_h | Manufacturer scaling: Gain | R20
B_w | User scaling: Offset | R33
A_w | User scaling: Gain | R34
Y_dac | Output value for the D/A converter | -
The equations of the straight line are enabled via register R32


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
KL4132 - connection and LED description
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


KL4132 - connection and LED description

Mounting and wiring [image] KL4132 - connection and LED description
KL4132 - connection and LED description
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
KL4132 - connection and LEDs
Connection KL4132
Terminal point | No. | Comment
Output1 | 1 | + Output 1
n.c. | 2 | Not used
GND | 3 | Internal ground (internally connected to terminal point 7)
Shield | 4 | PE contact (internally connected to terminal point 8)
Output2 | 5 | + Output 2
n.c. | 6 | Not used
GND | 7 | Internal ground (internally connected to terminal point 3)
Shield | 8 | PE contact (internally connected to terminal point 4)
LED description KL4132
LED | Color | Description
Run1 LED Run2 LED | green | On: | Normal operation
 |  | Off: | Watchdog timer overflow has occurred. If no process data is transmitted to the bus coupler for 100 ms, the green LEDs go out. The output assumes a user-specified voltage (see Feature register).


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Configuration Software KS2000

Configuration Software KS2000
Configuration Software KS2000
Additional information
•
KS2000 - Introduction


KS2000 - Introduction

Configuration Software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Access from the user program

Access from the user program
Access from the user program
Additional information
•
KL4132 - Terminal configuration
•
Mapping in the Bus Coupler
•
Register overview
•
Register description
•
Control and status byte
•
Examples of Register Communication


KL4132 - Terminal configuration

Access from the user program [image] KL4132 - Terminal configuration
KL4132 - Terminal configuration
The terminal can be configured and parameterized via the internal register structure. Each terminal channel is mapped in the Bus Coupler. Mapping of the terminal data in the Bus Coupler memory may differ, depending on the Bus Coupler type and the set mapping configuration (e.g. Motorola/Intel format, word alignment etc.). For parameterizing a terminal, the control and status byte also has to be mapped.
BK2000 Lightbus Coupler
In the BK2000 Lightbus Coupler, the control/status byte is always mapped, in addition to the data bytes. This is always located in the low byte at the offset address of the terminal channel.
Mapping in the Interbus coupler – example for KL4132
BK3000 Profibus Coupler
For the BK3000 Profibus coupler, the master configuration should specify for which terminal channels the control and status byte is to be inserted. If the control and status byte are not evaluated, the KL4132 occupies 4 bytes input data:
Mapping in the Profibus coupler – example for KL4132
BK4000 Interbus Coupler
The BK4000 Interbus Coupler maps the KL4132 in delivery state with 4 bytes of output data (2 bytes of user data per channel). Parameterization via the fieldbus is not possible. If the control and status byte is to be used, the KS2000 configuration software is required.
Mapping in the Interbus coupler – example for KL4132
Other Bus Couplers and further information
Further information about the mapping configuration of Bus Couplers can be found in the Appendix of the respective Bus Coupler manual under Master configuration.
The chapter on Mapping in the Bus Coupler contains an overview of possible mapping configurations, depending on the configurable parameters.
Parameterization with KS2000
The KS2000 configuration software can be used for parameterizations via the serial interface of the Bus Coupler, independent of the fieldbus system.


Mapping in the Bus Coupler

Access from the user program [image] Mapping in the Bus Coupler
Mapping in the Bus Coupler
As already described in the Terminal Configuration section, each Bus Terminal is mapped in the Bus Coupler. This mapping is usually done with the default setting in the Bus Coupler / Bus Terminal. The KS2000 configuration software or a master configuration software (e.g. ComProfibus or TwinCAT System Manager) can be used to change this default setting.
If the terminals are fully evaluated, they occupy memory space in the input and output process image.
The following tables provide information about how the terminals map themselves in the Bus Coupler, depending on the parameters set.
Additional information
•
KL4132


KL4132

Access from the user program [image] Mapping in the Bus Coupler [image] KL4132
KL4132
Default mapping for: CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | - | -
 | 3 | - | -
Default mapping for: Profibus and Interbus Coupler
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | - | -
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | - | -
Default mapping for: Lightbus & Ethernet coupler and Bus Terminal Controller (BCxxxx, BXxxxx)
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | Res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | Res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | Res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | Res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1
Key
Complete evaluation | The terminal is mapped with control and status byte.
Motorola format | Motorola or Intel format can be set.
Word alignment | The terminal is positioned on a word boundary in the Bus Coupler.
Ch n CB | Control byte for channel n (appears in the process image of the outputs).
Ch n SB | Status byte for channel n (appears in the process image of the inputs).
Ch n D0 | Channel n, data byte 0 (byte with the lowest value)
Ch n D1 | Channel n, data byte 1 (byte with the highest value)
"-" | This byte is not used or occupied by the terminal.
Res. | Reserved: this byte is assigned to the process data memory, although it has no function.


Register overview

Access from the user program [image] Register overview
Register overview
These registers exist once for each channel
Address | Name | Default value | R/W | Storage medium
R0…R4 | reserved | 0x0000 | R | RAM
R5 | Raw DAC value | variable | R |
R6 | Diagnostic register | 0x0000 | R | RAM
R7 | Command register | 0x0000 | R |
R8 | Terminal type | 4132 | R | ROM
R9 | Software version number | 0x???? | R | ROM
R10 | Multiplex shift register | 0x0218 | R | ROM
R11 | Signal channels | 0x0218 | R | ROM
R12 | Minimum data length | 0x9800 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0x???? | R/W | SEEROM
R17 | Hardware compensation: Offset | specific | R/W | SEEROM
R18 | Hardware compensation: Gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x0000 | R/W | SEEROM
R22…R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0000 | R/W | SEEROM
R33 | User scaling: Offset | 0x0000 | R/W | SEEROM
R34 | User scaling: Gain | 0x0100 | R/W | SEEROM
R35 | User switch-on value | 0x0000 | R/W | SEEROM
R36…R47 | reserved | 0x0000 | R/W | SEEROM


Register description

Access from the user program [image] Register description
Register description
The registers can be read or written via the register communication. They are used for the parameterization of the terminal.
R0 to R7: Registers in the internal RAM of the terminal
The process variables can be used in addition to the actual process image. Their function is specific to the terminal.
▪
R0 to R4: reserved
▪
R5: Raw DAC value (Y_dac)
The 16-bit value transferred to the D/A converter is called raw DAC value. It is calculated from the process data via the manufacturer and user scaling.
▪
R6 to R7: reserved
R8 to R15: Registers in the internal ROM of the terminal
The type and system parameters are hard programmed by the manufacturer, and the user can read them but cannot change them.
▪
R8: Terminal type
The terminal type in register R8 is needed to identify the terminal.
▪
R9: Software version (X.y)
The software version can be read as a string of ASCII characters.
▪
R10: Data length
R10 contains the number of multiplexed shift registers and their length in bits.
The Bus Coupler sees this structure.
▪
R11: Signal channels
Related to R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data type register
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure 1 byte n bytes
0x03 | Word array
0x04 | Structure 1 byte n words
0x05 | Double word array
0x06 | Structure 1 byte n double words
0x07 | Structure 1 byte 1 double word
0x08 | Structure 1 byte 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure 1 byte n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure 1 byte n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure 1 byte n double words with variable logical channel length
▪
R14: reserved
▪
R15: Alignment bits (RAM)
The alignment bits are used to place the analog terminal in the Bus Coupler on a byte boundary.
R16 to R30: Manufacturer parameter area (SEEROM)
The manufacturer parameters are specific for each type of terminal. They are programmed by the manufacturer, but can also be modified by the controller. The manufacturer parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out.
These registers can only be altered after a code word has been set in R31.
▪
R17: Hardware compensation - offset (B_a)
This register is used for hardware offset compensation.
▪
R18: Hardware compensation - gain (A_a)
Gain hardware*2-16
This register is used for hardware gain compensation.
0xFFFF corresponds to 1
▪
R19: Manufacturer scaling - offset (B_h)
This register contains the offset of the manufacturer straight-line equation (equation 1.1). The straight-line equation is enabled via register R32.
▪
R20: Manufacturer scaling - gain (A_h)
16 bit unsigned integer*2-8 [0x0100]
This register contains the scale factor of the manufacturer's equation of the straight line (Eq. 1.1). The straight-line equation is enabled via register R32.
1 corresponds to register value 0x0100.
R31 to R47: User parameter area (SEEROM)
The user parameters are specific for each type of terminal. They can be modified by the programmer. The user parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out. The user area is write-protected by a code word.
• R31: Code word register in RAM
The code word 0x1235 must be entered here so that parameters in the user area can be modified. If any other value is entered into this register, the write-protection is active. When write protection is not active, the code word is returned when the register is read. If the write protection is active, the register contains a zero value.
▪
R32: Feature register
[0x0000]
This register specifies the operation modes of the terminal.
Feature bit no. |  | Description of the operation mode
Bit 0 | 1 | User scaling (R33, R34) active [0]
Bit 1 | 1 | Manufacturer scaling (R19, R20) active [0]
Bit 2 | 0 | Watchdog timer active [0] In the delivery state, the watchdog timer is switched on. In the event of a watchdog overflow, either the manufacturer or the user switch-on value is applied to the terminal output.
Bits 3 to 7 | - | Reserved, don't change
Bit 8 | 0/1 | 0bin: Manufacturer switch-on value [0] 1bin: User switch-on value
Bits 9 to 15 | - | Reserved, don't change
▪
R33: User scaling - offset (B_w)
16 bit signed integer [0x0000]
This register contains the offset of the user straight-line equation (Eq. 1.4). The straight-line equation is enabled via register R32.
▪
R34: User scaling - gain (A_w)
16 bit signed integer*2-8 [0x0100]
This register contains the scaling factor of the user straight-line equation (Eq. 1.4). The straight-line equation is enabled via register R32.
▪
R35: User switch-on value
16 bit signed integer [0x0000]
If the user switch-on value is enabled in register R32, this value is applied to the terminal output after a system reset or a watchdog timer overflow (terminal has not received any process data for 100 ms).


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
The control and status byte is transmitted from the controller to the terminal. It can be used
▪
in register mode (REG = 1bin) or
▪
in process data exchange (REG = 0bin).
Additional information
•
Process data exchange
•
Register communication


Process data exchange

Access from the user program [image] Control and status byte [image] Process data exchange
Process data exchange
Control byte in process data exchange (REG=0)
A gain and offset calibration of the terminal can be carried out with the control byte. The code word must be entered in R31 so that the terminal calibration can be carried out. The gain and offset of the terminal can then be calibrated. The parameter will only be saved permanently once the code word is reset!
Bit | Description
Bit 7 | 0bin
Bit 6 | 1bin: Terminal compensation function is enabled
Bit 5 | reserved
Bit 4 | 1bin: Gain calibration
Bit 3 | 1bin: Offset calibration
Bit 2 | 0bin: slow clock = 1000 ms 1bin: fast clock = 50 ms
Bit 1 | 1bin: up
Bit 0 | 1bin: down
Status byte in process data exchange (REG=0)
The status byte is transferred from the terminal to the controller. In the KL4132, the status byte has no function for the process data exchange.


Register communication

Access from the user program [image] Control and status byte [image] Register communication
Register communication
Register access via process data exchange
▪
Bit 7=1: Register mode
If bit 7 of the control byte is set, the first two bytes of the user data are not used for process data exchange but written into the register set of the terminal or read from it.
▪
Bit 6=0: read, bit 6=1: write
Bit 6 of the control bytes is used to specify whether a register should be read or written.
–
Bit 6=0: A register is read without changing it. The value can be found in the input process image.
–
Bit 6=1: The user data are written into a register. The process is complete once the status byte in the input process image has returned an acknowledgment (see example).
▪
Bit 0 to 5: Address
The address of the register to be addressed is entered in bits 0 to 5 of the control byte
Control byte in register mode (REG=1)
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
REG = 0bin: Process data exchange
REG = 1bin: Access to register structure
W/R = 0bin: Read register
W/R = 1bin: Write register
A5..A0 = register address
Addresses A5...A0 can be used to address a total of 64 registers.
Register mode control byte
The control or status byte occupies the lowest address of a logical channel. The corresponding register values are located in the following 2 data bytes. (The BK2000 is an exception: here, an unused data byte is inserted after the control or status byte, and the register value is therefore placed on a word boundary).
Sample 1:
Reading of register 8 in the BK2000 with a KL4132 and the end terminal:
If the following bytes are transferred from the controller to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Not used | Control byte
Value | 0xXX | 0xXX | 0xXX | 0x88
The terminal returns the following type identifier (0x1024 corresponds to unsigned integer 4132).
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Not used | Status byte
Value | 0x24 | 0x10 | 0x00 | 0x88
Sample 2:
Writing of register 31 in the BK2000 with an intelligent terminal and the end terminal:
If the following bytes (code word) are transferred from the controller to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Not used | Control byte
Value | 0x12 | 0x35 | 0xXX | 0xDF
The code word is set, and the terminal returns the register address with bit 7 for register access as acknowledgment.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Not used | Status byte
Value | 0x00 | 0x00 | 0x00 | 0x9F


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com