KL3681 - Multimeter Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
2.3.0
▪
Update chapter “Instructions for ESD protection”
▪
Chapter “Beckhoff Identification Code (BIC)” added
2.2.0
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Chapter Instructions for ESD protection added
▪
Example program added to chapter “KS2000 Configuration software“
2.1.0
▪
Update chapter Notes on the documentation
▪
Update chapter connection system -> connection
2.0.0
▪
migration (complete Document)
▪
LED Display: meaning of K-bus run led exchanged (off/ on)
1.0.0
▪
technical data updated
▪
description of parameterization via KS2000 configuration software extended
▪
description of control and status byte corrected
▪
description of process image added
0.5
▪
preliminary version (only German)
Firm and hardware versions
Documentation Version | KL3681-0000, KS3681-0000
 | Firmware | Hardware
2.2.0 | 1C | 01
2.1.0 | 1C | 01
2.0.0 | 1C | 01
1.0.0 | 1C | 01
0.5 | 1C | 01
The firmware and hardware version (delivery state) can be found in the serial number printed at the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 02 13 00 01:
02 - week of production 02
13 - year of production 2013
00 - firmware version 09
01 - hardware version 01


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Basic function principles
•
Process data
•
LED Display


Introduction

Product overview [image] Introduction
Introduction
KL3681-0000
Digital Multimeter Terminal
The KL3681 Bus Terminal enables measurement of currents and voltages in a wide input range. The measuring ranges are switched automatically, as usual in advanced digital multimeters. For current measurements, two current paths are available, one of which is a high-current path for up to 10 A. The current and the voltage measurement facility can be used for DC and AC. The alternating parameters are output as true RMS values. The measurement readings can be read and processed with commercially available fieldbus systems. At the same time, the KL3681 enables the measuring type and range to be set via the bus.
Excellent interference immunity is achieved through the fully electrically isolated design of the electronic measuring system and the dual-slope conversion system. High precision and simple, high-impedance measurement from 300 mV to 300 V allow the Bus Terminal to be used like a digital multimeter.
In measuring applications in particular, the voltage to be expected is often not yet known during the planning phase. Automatic adjustment of the measurement range simplifies use and reduces stock levels. The selected measuring type and overload are indicated by LEDs.


Technical data

Product overview [image] Technical data
Technical data
Technical data |  | KL3681 | KS3681
Number of inputs |  | 1, voltage or current (1 A / 10 A)
Technology |  | digital multimeter with automatic range selection
Measured values |  | current, voltage (AC/DC)
Measuring voltage |  | 300 mV, 3 V, 30 V, 300 V
Measuring current |  | 100 mA, 1 A and 10 A via high-current path
Resolution |  | 18 bit + sign in each measurement range
Internal resistance | Measuring range DC 300 mV to 300 V | 12,5 MΩ
 | Measuring range DC 100 mA to 1 A | 0,2 Ω
 | Measuring range DC 10 A | 3 mΩ
 | Measuring range AC 300 mV to 300 V | 1 MΩ, ca. 33 pF
 | Measuring range AC 100 mA to 1 A | 0,2 Ω
 | Measuring range AC 10 A | 3 mΩ
Measuring error |  | 0.01 % DC voltage measurement at 25°C
Measuring procedure |  | DC with arithmetic averaging, AC with true RMS value calculation TrueRMS, 0...1 kHz input signal, Crest factor < 3 allowed
Update time |  | 0.5 s, 1 s for measuring range selection
Electrical isolation |  | 1500 V (terminal / E-bus)
Supply voltage for internal circuit |  | via K-Bus
Current consumption from via E-bus |  | typically 100 mA
Configuration |  | via KS2000 Configuration Software
Pluggable wiring |  | no | yes
Weight |  | approx. 70 g
Permissible ambient temperature temperature for operation |  | 0°C ... + 55°C
Permissible ambient temperature temperature for storage |  | -25°C ... + 85°C
Permissible Relative humidity |  | 95 %, no condensation
Dimensions |  | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting |  | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD |  | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class |  | IP20
Installation pos. |  | variable
Approval |  | CE


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Features
The functionality of the KL3681 is similar to that of a commercial digital multimeter. The terminal offers the following features:
▪
Single-channel measurement
▪
AC/DC voltage measurement, automatic range selection: “Autorange” or specified via the controller
Measurement ranges: 300 mV, 3 V, 30 V, 300 V
▪
AC/DC current measurement in the 1 A path (internal fuse: 1.25 A) or 10 A path (no internal fuse)
Measurement ranges: 100 mA, 1 A, 10 A
▪
Formation of measured values:
Alternating current and alternating voltage are calculated as true RMS values, no DC component
Direct current and direct voltage are calculated as arithmetic average value
▪
Electrical isolation from the fieldbus
▪
Very good interference immunity through dual-slope conversion technique
▪
Display of measurement type (current/voltage) and overload through LED
▪
Typical update rate approx. two seconds, after measuring range change approx. one second
Quick start
The factory setting for the multimeter terminal enables voltages up to 300 VDC to be measured directly without additional settings. The Autorange function is active and selects the measuring range automatically.
The measured value is displayed with 1 bit per microvolt, i.e. no adjustment is required.
Functional description
Measuring ranges and output
The terminal starts measuring automatically. New measurement readings will be put out as soon as the calculation is complete. If the last used and the requested measuring range do not match, the bit “Data invalid” is set. In the event of an error (generally measuring range exceeded) the respective error bits are set. New measurement values are provided approx. every 0.5 seconds. The filter time is reset if the measuring range is changed via Autorange or by the user during the filter period. If the value fluctuates too much in Autorange mode, it may not be possible to determine a new measured value. As a remedy the filter can be deactivated.
The terminal has an extended measuring range, if a larger measuring range is available (Example: 30 V range, extended measuring range is 300 V). In Autorange mode the extended measuring range is used as a hysteresis range. In the extended measuring range overflow and underflow bits and the error bit are set at 115 % of the normal measuring range.
Please note
•
In AC mode only the RMS value of AC voltage is shown (no DC component).
•
Error bits are under-range, over-range and data invalid. The error bit is set together with these bits. In some cases several bits may be set simultaneously in the event of an error (e.g.: Overrange and Data invalid).
•
Since the terminal integrates the input value over an interval of 20 ms (16.66 ms in 60 Hz mode), superimposed interferences of the input values from the supply network can largely be compensated.
Measuring range selection
The measuring range is selected in process data mode via the control byte.
The Autorange function selects the best measuring range for the selected measurement type. In Autorange mode the 10 A measuring ranges are distinct types of measurement, i.e. it is not possible to switch from 1 A and 10 A or back (Causes: different input contacts as like fuse protection of the1 A range with 1.25 A).
The limits for changing the measuring ranges range are 10 % above the full scale value (extended measuring range, larger range) and 10 % of the full scale value (smaller range). If "Left aligned" view is selected, the limits are 100 % and 5 % of the full scale value.
Filter
The built-in filter averages the values for the last half second. If the measuring range is changed the filter is reset. The filter is active by default. If the filter is switched off the terminal supplies approx. 16 measured values per second.
Mains frequency
The integration times are adapted to the mains frequency (50, 60 Hz). The default is 50 Hz.
Presentation
The presentation of the values in the process data can be changed.
left aligned (0)
Left-justified presentation, full-scale value corresponds to 0x7FFFE000 (0x7FFFFFFF) or 0x80000000.
right aligned (1)
Right-aligned presentation: 18 bit resolution of the measuring range, end value corresponds to 0x0003FFFF (262143dec) or 0xFFFC0000 (-262144dec).
In the extended measuring range these limits are exceeded!
scaled (2)
Scaled presentation: this presentation corresponds to 1 bit per µV / µA. Examples:
- Mode 0, Autorange, 2.5 V: 2500000dec
- Mode 2, 800 mA: 800000dec
float (5)
Scaled presentation in floating-point format
Scaled presentation (2) is set as default.
Please note
•
Only in scaled presentation the factors 0.1/1/10/100 are taken into account between the measuring ranges.
•
In left aligned presentation the extended measuring range is not available.
Zero Compenzation Interval
The compensation function compensates the internal offset drift of the ADC. The interval length is selectable.
If setting 4 "Triggered by PDO" is used, the time for reading the internal offset can be selected manually via the "Start Calibration" process data bit.
50 Hz mode
In 50 Hz mode this function should not be used (0: off).
Calibration
The terminal features manufacturer and user calibration options, which can be switched on and off independently. The calibration always applies to all measuring ranges. Adaptation in 60 Hz mode and compensation of the AC system offset cannot be switched off.


Process data

Product overview [image] Process data
Process data
Calculation of process data
The process data are calculated in up to seven steps between reading of the ADC and the process data output.
Designation | Calculation formula | not active
Offset correction |  |
Filter for averaging over 8 values |  |
60 Hz mode adaptation |  |
Calibration active |  |
AC system offset | for | (condition not met)
Scaling |  | -
The scaling includes the powers of ten selected in the range.
All gain factors should therefore correspond to 1/8 in order to obtain a total factor of 1. The value 8192 (0x2000) results in a total factor of 1.
Designation | Meaning | Register | Designation | Meaning | Register
XADC | Output value of the A/D converter | R0 |  |  |
YZ | Measured value after ADC offset correction |  | BZ | Current ADC Zero value |
 |  |  | BZCal | ADC Zero at the time of calibration |
YF | Measured value after averaging |  |  |  |
Y60 | Measured value after adaptation of the 60 Hz integration time |  | BF | 60 Hz offset |
 |  |  | AF | 60 Hz gain |
YH | Measured value after manufacturer calibration |  | BK | Manufacturer offset |
 |  |  | AK | Manufacturer gain |
YA | Measured value after user calibration |  | BA | User offset |
 |  |  | AA | User gain |
Y | Measured value after AC system offset |  | XSO | AC system offset |
YScal | Measured value after scaling |  | FScal | End value in 1 bit per 1µV / 1µA |
Determining (user) gain values
The terminal has one user compensation value pair for each measuring range and measurement type, i.e. 14 pairs in total. "+1" (0x4000) is not used in order to increase the resolution of the gain value.
Since the gain values may be less than 1, a factor of 1/8 is multiplied to the gain value. For a gain of 1 the gain value must be 0x2000.
For gain G = 1 the following applies:
For other values G must be replaced with the required gain factor.
Before the compensation the value display option should be set to "right-aligned": Register R32.12 to R32.15 value assignment of 1dec.


LED Display

Product overview [image] LED Display
LED Display
KL3681-0000 - LED display
LED | Color | Meaning
RUN | green | off | K-Bus data transfer not active
 |  | on | K-Bus data transfer active
Term. Error | red | on | An error has occurred (see status byte)
Voltage | green | on | Indicates voltage measurement
Current | green | on | Indicates current measurement


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Connection
•
KL3681 - Connection


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


KL3681 - Connection

Mounting and wiring [image] KL3681 - Connection
KL3681 - Connection
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminal points of KL3681
Terminal point | No. | Comment
V | 1 | Terminal point for voltage measurement (internally connected with terminal point 5)
COM | 2 | Ground (internally connected with terminal point 6)
10 A | 3 | Terminal point for current measurement, 10 A range
Shield | 4 | Shield (internally connected with terminal point 8)
V | 5 | Terminal point for voltage measurement (internally connected with terminal point 1)
COM | 6 | Ground (internally connected with terminal point 2)
1 A | 7 | Terminal point for current measurement, 1 A range
Shield | 8 | Shield (internally connected with terminal point 4)
SmallWarningYellow WARNING
Danger for persons through electric shock!
For voltages greater than 25 VAC (42 V peak) or 60 VDC the fuse opening must be covered by an additional terminal or the EL9011 end terminal. Risk of electric shock!
Note
10 A branch is not fuse-protected
The current branch for 10 A is not fuse-protected. The device may be damaged if the current in the 10 A branch exceeds 10 A.


KS2000 Configuration software

KS2000 Configuration software
KS2000 Configuration software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

KS2000 Configuration software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station. In the example shown, this is
▪
a BK9000: Bus Coupler for Ethernet
▪
a KL1xx2: Digital Input Terminal
▪
a KL3681: Multimeter Terminal
▪
a KL9010: Bus End Terminal
View of fieldbus station within KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of KL3681
For the KL3404, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL3681 registers.
▪
A dialog mask for the parameterization of the KL3681 can be found under Settings.
▪
ProcData displays the KL3681 process data.


Register

KS2000 Configuration software [image] Register
Register
You can access the registers of the KL3681 directly under Register. The meaning of the register is explained in the register overview.
Register view within KS2000


Settings

KS2000 Configuration software [image] Settings
Settings
The dialog mask for the parameterization of the KL3681 can be found under Settings.
Settings via KS2000
Operating mode
▪
Watchdog timer active (register page 0, register R32.2)
Here you can deactivate the watchdog timer (default: active).
▪
Frequency 60 Hz (register page 0, register R32.7)
Here you can switch the terminal to a mains frequency of 60 Hz (default: 50 Hz).
▪
User calibration active (register page 0, register R32.8)
Here you can activate user calibration (default: inactive)
▪
Filter enable (register page 0, register R32.11)
Here you can disable the watchdog (default: enable).
Presentation
Here you can select the presentation format for the process data (default: scaled).
▪
Options (register page 0, registers R32.15 to R32.12)
–
Left aligned*
–
Right aligned
–
Scaled
–
Real
*) In left aligned presentation the extended measuring range is not available.
Zero Compensation Interval
Here you can specify the interval for zero compensation (default: deactivated).
▪
Options (register page 0, register R33)
–
deactivated
–
10 seconds
–
1 minute
–
10 minutes
–
automatic correction


Sample program for KL register communication via EtherCAT on KL3314 exemplary

KS2000 Configuration software [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the user programm

Access from the user programm
Access from the user programm
Additional information
•
Process image
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user programm [image] Process image
Process image
Complex mapping
The following 9 bytes are transferred bi-directionally between KL3681 and control:
Byte offset (without word alignment*) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | Status byte (SB) | Control byte (CB)
1 | 2 | Word | DataIN0 | DataOUT0
3 | 4 | Word | DataIN1 | DataOUT1
5 | 6 | Word | DataIN2 | DataOUT2
7 | 8 | Word | DataIN3 | DataOUT3
*) Word alignment: The Bus Coupler places values on even byte addresses
Compact mapping (from firmware version 1C)
The following 8 bytes are transferred bi-directionally between KL3681 and control:
Byte offset (with and without word alignment*) | Format | Input data | Output data
0 | Word | DataIN0 | DataOUT0
2 | Word | DataIN1 | DataOUT1
4 | Word | DataIN2 | DataOUT2
6 | Word | DataIN3 | DataOUT3
*) word alignment has no effect with compact mapping


Control and status byte

Access from the user programm [image] Control and status byte
Control and status byte
Process data mode
Control byte (in process data mode)
The control byte (CB) is located in the output image and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | StartCalibration | StartCalibration | disAutorange | Voltage/Current | DC/AC | Range
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 | StartCalibration | 1bin | initiates an automatic correction of the internal measuring range (only if register R33 = 4)
CB.4 | disAutorange | 0bin | auto range enabled
 |  | 1bin | auto range disabled
CB.3 | Voltage/Current | 0bin | Voltage
 |  | 1bin | Current
CB.2 | DC/AC | 0bin | DC
 |  | 1bin | AC
CB.1, CB.0 | Range | Measuring range (see also CB.2)
 |  | 00bin | 3 V or 1 A
 |  | 01bin | 30 V or 10 A
 |  | 10bin | 300 V
 |  | 11bin | 300 mV or 100 mA
Status byte (in process data mode)
The status byte (SB) is located in the input image and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | noAutorange | data Invalid | extended range | overrange | underrange
Bit | Name | Description
SB.7 | RegAccess | 0bin | Acknowledge for process data mode
SB.6 | Error | 1bin | measuring range exceeded, over or under range, the error LED shines or converting error or invalid measuring range
SB.5 | reserved | 0bin | reserved
SB.4 | - | 0bin | auto range is enabled
 |  | 1bin | auto range is disabled
SB.3 | data invalid | 1bin | invalidprocess data, e.g. invalid value, e.g. filter latency, start up
SB.2 | extended range* | 1bin | The extended measuring range (~10% of upper range value) is used (hysteresis area of auto range functionality).
SB.1 | overrange | 1bin | Exceeding of the electrical measuring range
SB.0 | underrange | 1bin | Undershooting of the electrical measuring range at DC mode (not displayed in AC mode
*) The extended range is only available for the measuring ranges 300 mV, 3 V, 30 V and 100 mA.
Register communication
Control byte (at register communication)
The control byte (CB) is located in the output image and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Register no.
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Register no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIN, or - to write with output data word DataOUT.
Status byte (at register communication)
The status byte (SB) is located in the input image and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Register no.
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledge for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Register no. | Number of the register that was read or written.


Register overview

Access from the user programm [image] Register overview
Register overview
All registers can be read or written via register communication.
Registers R0 to R31 (direct access)
These registers are used to parameterize the terminal KL3681.
Register no. | Comment | Default value |  | R/W | Memory
R0 | Raw value of the A/D converter | 0x0000 | 0dec | R | RAM
R1 | Current measuring range / mode | 0x0000 | 0dec | R | RAM
R2 | Internal calibration value | 0x0000 | 0dec | R | RAM
R3 | Sampling duration in milliseconds | 0x0000 | 0dec | R | RAM
R4 | Register page selection register | 0x0000 | 0dec | R/W | RAM
R5 | reserved | - | - | - | -
R6 | Diagnostic register | 0x0000 | 0dec | R | RAM
R7 | Command register | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x0E61 | 3681dec | R | ROM
R9 | Firmware version | e.g. | e.g. 1AASCI | R | ROM
R10 | Multiplex shift register, data length | 0x0130 | 304dec | R | ROM
R11 | Signal channels |  |  | R | ROM
R12 | Minimum data length |  |  | R | ROM
R13 | Data structure |  |  | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | typically | typically | R/W | RAM
R16 | Hardware version number |  |  | R/W | SEEPROM
R17 | reserved | - | - | - | -
... | reserved | - | - | - | -
R28 | reserved | - | - | - | -
R29 | Terminal type, version | 0x0000 | 0dec | R | ROM
R30 | reserved | - | - | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
Register page 0
These registers are also used for parameterization of the KL3681 (access selectable via register R4).
Register no. | Comment | Default value |  | R/W | Memory
R32 | Feature register | 0x2804 | 10244dec | R/W | SEEPROM
R33 | Zero Comp Interval | 0x0000 | 0dec | R/W | SEEPROM
R34 | reserved | - | - | - | -
R35 | reserved | - | - | - | -
R36 | User scaling, measuring range 300 mVDC, offset | 0x0000 | 0dec | R/W | SEEPROM
R37 | User scaling, measuring range 300 mVDC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R38 | User scaling, measuring range 3 VDC, offset | 0x0000 | 0dec | R/W | SEEPROM
R39 | User scaling, measuring range 3 VDC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R40 | User scaling, measuring range 30 VDC, offset | 0x0000 | 0dec | R/W | SEEPROM
R41 | User scaling, measuring range 30 VDC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R42 | User scaling, measuring range 300 VDC, offset | 0x0000 | 0dec | R/W | SEEPROM
R43 | User scaling, measuring range 300 VDC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R44 | User scaling, measuring range 300 mVAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R45 | User scaling, measuring range 300 mVAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R46 | User scaling, measuring range 3 VAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R47 | User scaling, measuring range 3 VAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R48 | User scaling, measuring range 30 VAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R49 | User scaling, measuring range 30 VAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R50 | User scaling, measuring range 300 VAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R51 | User scaling, measuring range 300 VAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R52 | User scaling, measuring range 100 mADC, offset | 0x0000 | 0dec | R/W | SEEPROM
R53 | User scaling, measuring range 100 mADC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R54 | User scaling, measuring range 1 ADC, offset | 0x0000 | 0dec | R/W | SEEPROM
R55 | User scaling, measuring range 1 ADC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R56 | User scaling, measuring range 10 ADC, offset | 0x0000 | 0dec | R/W | SEEPROM
R57 | User scaling, measuring range 10 ADC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R58 | User scaling, measuring range 100 mAAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R59 | User scaling, measuring range 100 mAAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R60 | User scaling, measuring range 1 AAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R61 | User scaling, measuring range 1 AAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
R62 | User scaling, measuring range 10 AAC, offset | 0x0000 | 0dec | R/W | SEEPROM
R63 | User scaling, measuring range 10 AAC, gain | 0x2000 | 8192dec | R/W | SEEPROM
Register page 1
These registers are used for calibration of the KL3681 (access selectable via register R4).
Register no. | Comment | Default value | R/W | Memory
R32 | Internal calibration data |  | R | SEEPROM
... | ... |  | ... | ...
R35 | Internal calibration data |  | R | SEEPROM
R36 | Manufacturer calibration |  | R | SEEPROM
... | ... |  | ... | ...
R63 | Manufacturer calibration |  | R | SEEPROM


Register description

Access from the user programm [image] Register description
Register description
The following registers are used for parameterization of the KL3681. They can be read or written via the register communication with the aid of control, status and data bytes.
▪
R0: Raw value A/D-C
Raw value of the A/D converter (XR)
▪
R1: Current measuring range / mode
▪
R2: Internal calibration value
▪
R3: Sampling duration
In milliseconds
▪
R4: Register page selection register
This register defines which register page is displayed in registers R32 to R63 (default: 0x0000).
The terminal supports two register pages.
–
Register page 0 is used to save the configuration data (see from register RP0.R32)
–
Register page 1 is used for internal calibration data and manufacturer calibration and must not be changed by the user!
▪
R6: Diagnostic register
The status byte is mapped to the low-order byte (bit 7 to bit 0) of register R6.
The high-order byte (bit 15 to bit 8) of register R6 is reserved.
▪
R7: Command register
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
▪
Command 0x7000: Restore Factory Settings
An entry of 0X7000 in register R7 sets the following registers for the two channels to the following default values:
–
RP0.R32: 0x2804 (10244dec)
–
RP0.R33: 0x0000 (0dec)
–
RP0.R34: 0x0000 (0dec)
–
RP0.R35: 0x0000 (0dec)
–
RP0.R36, RP0.R38 ... RP0.R62: 0x0000 (0dec)
–
RP0.R37, RP0.R39 ... RP0.R63: 0x2000 (8192dec)
▪
R8: Terminal description
The terminal identifier is contained in register R8: KL3681: 0x0E61 (3681dec).
▪
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware revision level, e.g. 0x3141 (1A)ASCII. '0x31' corresponds to the ASCII character '1' and '0x41' to the ASCII character 'A'. This value cannot be changed.
▪
R10: Data length (multiplex shift register)
R10 contains the number of multiplexed shift registers and their length in bits.
▪
R11: Signal channels
Unlike R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data structure (data type register)
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure: 1 byte, n bytes
0x03 | Word array
0x04 | Structure: 1 byte, n words
0x05 | Double word array
0x06 | Structure: 1 byte, n double words
0x07 | Structure: 1 byte, 1 double word
0x08 | Structure: 1 byte, 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure: 1 byte, n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure: 1 byte, n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure: 1 byte, n double words with variable logical channel length
▪
R15: Alignment register
Via the alignment register bits, the Bus Coupler arranges the address range of an analog terminal such that it starts at a byte boundary.
▪
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal; this value cannot be changed.
▪
R29: Terminal type, special version
The special terminal identifier is contained in register R8: KL3681-0000: 0x0000 (0)dec).
▪
R31: Code word register
–
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
–
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset with each restart of the terminal.
Register page 0
If register page 0 was selected with register R4, registers R32 to R63 have the following meaning.
▪
R32: Feature register
The feature register specifies the terminal's configuration. Default: 0x2804 (10244dec)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | presentation |  |  |  | enFilter | - | - | enUserCalli
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | frequency | - | - | - | - | enWdTimer | - | -
Bit | Name | Description |  | Default
R32.15 to R32.12 | presentation | 0dec | Left aligned (In left aligned presentation the extended measuring range is not available!) | 2dec
 |  | 1dec | right aligned
 |  | 2dec | scaled: 1 bit per µV/µA
 |  | 3dec | reserved
 |  | 4dec | reserved
 |  | 5dec | float: Scaled presentation in floating-point format
 |  | 6dec | reserved
 |  | 7dec | reserved
R32.12 | - | reserved |  | 0bin
R32.11 | enFilter | 0bin | Filter not active | 1bin
 |  | 1bin | filter active
R32.10 | enLimit2 | 0bin | Threshold 2 is not active | 0bin
 |  | 1bin | Threshold 2 is active
R32.9 | enLimit1 | 0bin | Threshold 1 is not active | 0bin
 |  | 1bin | Threshold 1 is active
R32.8 | enUserCalli | 0bin | User calibration not active | 0bin
 |  | 1bin | User calibration active
R32.7 | frequency | 0bin | 50 Hz mains frequency | 0bin
 |  | 1bin | 60 Hz mains frequency
R32.6 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.3 | - | reserved |  | 0bin
R32.2 | enWdTimer | 0bin | Watchdog timer is not active | 1bin
 |  | 1bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms)
R32.1 | - | reserved |  | 0bin
R32.0 | - | reserved |  | 0bin
▪
R33: Zero Comp Interval
▪
R36: User scaling, measuring range 300 mV DC, offset
(Default: 0x0000)
▪
R37: User scaling, measuring range 300 mV DC, gain
(Default: 0x2000)
▪
R38: User scaling, measuring range 3 V DC, offset
(Default: 0x0000)
▪
R39: User scaling, measuring range 3 V DC, gain
(Default: 0x2000)
▪
R40: User scaling, measuring range 30 V DC, offset
(Default: 0x0000)
▪
R41: User scaling, measuring range 30 V DC, gain
(Default: 0x2000)
▪
R42: User scaling, measuring range 300 V DC, offset
(Default: 0x0000)
▪
R43: User scaling, measuring range 300 V DC, gain
(Default: 0x2000)
▪
R44: User scaling, measuring range 300 mV AC, offset
(Default: 0x0000)
▪
R45: User scaling, measuring range 300 mV AC, gain
(Default: 0x2000)
▪
R46: User scaling, measuring range 3 V AC, offset
(Default: 0x0000)
▪
R47: User scaling, measuring range 3 V AC, gain
(Default: 0x2000)
▪
R48: User scaling, measuring range 30 V AC, offset
(Default: 0x0000)
▪
R49: User scaling, measuring range 30 V AC, gain
(Default: 0x2000)
▪
R50: User scaling, measuring range 300 V AC, offset
(Default: 0x0000)
▪
R51: User scaling, measuring range 300 V AC, gain
(Default: 0x2000)
▪
R52: User scaling, measuring range 100 mA DC, offset
(Default: 0x0000)
▪
R53: User scaling, measuring range 100 mA DC, gain
(Default: 0x2000)
▪
R54: User scaling, measuring range 1 A DC, offset
(Default: 0x0000)
▪
R55: User scaling, measuring range 1 A DC, gain
(Default: 0x2000)
▪
R56: User scaling, measuring range 10 A DC, offset
(Default: 0x0000)
▪
R57: User scaling, measuring range 10 A DC, gain
(Default: 0x2000)
▪
R58: User scaling, measuring range 100 mA AC, offset
(Default: 0x0000)
▪
R59: User scaling, measuring range 100 mA AC, gain
(Default: 0x2000)
▪
R60: User scaling, measuring range 1 A AC, offset
(Default: 0x0000)
▪
R61: User scaling, measuring range 1 A AC, gain
(Default: 0x2000)
▪
R62: User scaling, measuring range 10 A AC, offset
(Default: 0x0000)
▪
R63: User scaling, measuring range 10 A AC, gain
(Default: 0x2000)
Register page 1
If register page 1 was selected with register R4, registers R32 to R63 have the following meaning.
▪
R32 to R35: Internal calibration data
These registers contain internal calibration data and must not be changed by the user!
▪
R36 to R63: Manufacturer calibration
These registers are used for manufacturer calibration and must not be changed by the user!


Examples of Register Communication

Access from the user programm [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user programm [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user programm [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Accessories
•
Support and Service


Accessories

Appendix [image] Accessories
Accessories
Fuse
Spare fuses are available as accessories. The upper of the two built-in fuses in the EL3681 is designated as a spare fuse.
SmallWarningYellow WARNING
Danger for persons through electric shock!
The fuse may only be changed if the Bus Terminal is in a safe, de-energized state.
The fuse can be removed with pliers by pulling it upwards from its sockets (see Figure).
Replacing the fuse
Note
Pull the fuse evenly to avoid damaging the sockets!
An improper taking out of the fuses can result in damage to the sockets!
Order number for the fuse
ZB8000-0001, pack of 10 fuses, 1.25 A


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com