KL344x, KL345x - Analog Input Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
3.2.0
▪
Update chapter “Instructions for ESD protection”
▪
Chapter “Beckhoff Identification Code (BIC)” added
3.1.0
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Update Technical data
▪
Chapter Instructions for ESD protection added
▪
Example program added to chapter KS2000 Configuration software
▪
Update structure
3.0.0
▪
Migration
2.2.0
▪
Mounting and wiring updated
▪
Technical Data updated
▪
ATEX notes added
▪
Extended temperature range for KL3454-0000
2.1.2
▪
Connection corrected
2.1.1
▪
Introduction updated
▪
Technical Data updated
▪
Register description updated
▪
Description of the KS2000 settings updated
▪
Firmware and hardware versions updated
2.1.0
▪
Infinite Impulse Response filter (IIR) added
▪
Register description updated
▪
Description of the KS2000 configuration software updated
2.0.0
▪
Eight channel bus terminals added: KL3448 and KL3458
1.1
▪
Connection of reference ground corrected
1.0
▪
First release
0.1
▪
Internal proof copy
Firmware and hardware versions
Documentation Version | KL3444-0000 |  | KL3448-0000 |  | KL3454-0000 |  | KL3458-0000
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
3.1.0 | 1E | 07 | 1D | 06 | 1F | 07 | 1D | 06
3.0.0 | 1E | 07 | 1D | 06 | 1F | 07 | 1D | 06
2.2.0 | 1E | 01 | 1C | 01 | 1E | 01 | 1C | 01
2.1.2 | 1E | 01 | 1C | 01 | 1E | 01 | 1C | 01
2.1.1 | 1E | 01 | 1C | 01 | 1E | 01 | 1C | 01
2.1.0 | 1E | 00 | 1C | 00 | 1E | 00 | 1C | 00
2.0.0 | 1D | 00 | 1B | 00 | 1D | 00 | 1B | 00
The firmware and hardware versions (delivery state) can be found in the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 35 04 1B 01:
35 - week of production 35
04 - year of production 2004
1B - firmware version 1B
01 - hardware version 01


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


KL3444, KL3454 - Product Overview

KL3444, KL3454 - Product Overview
KL3444, KL3454 - Product Overview
Additional information
•
Introduction
•
Technical Data
•
Diagnostic LEDs


Introduction

KL3444, KL3454 - Product Overview [image] Introduction
Introduction
KL3444: 4-channel analog input terminal 0 ... 20 mA
KL3444
The EL3444 analog input terminal process signals in the range between 0 and 20 mA. The current is digitized to a resolution of 12 bits, and is transmitted, in an electrically isolated form, to the higher-level automation device.
In the KL3444 Bus Terminal, the four inputs are 2-wire versions and have a common ground potential. This reference ground of the inputs is electrically isolated from the 0 V power contact. The power contacts are connected through.
Overload is detected and the terminal status is forwarded to the controller via the K-bus. The Run LEDs indicate the data exchange with the Bus Coupler, while the Error LEDs indicate overload.
KL3454: 4-channel analog input terminal 4 ... 20 mA
KL3454
The EL3454 analog input terminal process signals in the range between 4 and 20 mA. The current is digitized to a resolution of 12 bits, and is transmitted, in an electrically isolated form, to the higher-level automation device.
In the KL3454 Bus Terminal, the four inputs are 2-wire versions and have a common ground potential. This reference ground of the inputs is connected to the 0 V power contact. The 24 V power contact is connected to the terminals, in order to enable the connection of 2-wire sensors without external supply. The power contacts are connected through.
Overload is detected and the terminal status is forwarded to the controller via the K-bus. The Run LEDs indicate the data exchange with the Bus Coupler, while the Error LEDs indicate overload.


Technical Data

KL3444, KL3454 - Product Overview [image] Technical Data
Technical Data
Technical Data | KL3444-0000, KS3444-0000 | KL3454-0000, KS3454-0000
Number of inputs | 4 | 4
Signal voltage | 0 ... 20 mA | 4 ... 20 mA
Internal resistance | < 85 Ω
Common-mode voltage UCM | max. 30 V | max. 30 V
Resolution | 12 Bit
Conversion time | approx. 2 ms
Measuring error (total measuring range) | < ±0.3% of the full scale value | < ± 0.3% (at 0 °C ... +55 °C, relative to the full scale value) < ± 0.75% (when the extended temperature range is used)
Surge voltage resistance | 30 VDC
Electrical isolation | 500 V (K-bus/signal voltage)
Power supply for the electronics | via the K-bus
Current consumption from the K-bus | typically 85 mA
Bit width in process image | Input: 4 x 16 bit user data, 4 x 8 bit control/status (optional)
Weight | approx. 55 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Assembly | on 35 mm mounting rail conforms to EN 60715
Pluggable wiring | for all KSxxxx terminals
Permissible ambient temperature range during operation | 0 °C ... + 55 °C | -25 °C ... +60 °C (extended temperature range)
Permissible ambient temperature range during storage | -25 °C ... + 85 °C | -40 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6/EN 60068-2-27, see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX, GL | CE, cULus, ATEX, GL


Diagnostic LEDs

KL3444, KL3454 - Product Overview [image] Diagnostic LEDs
Diagnostic LEDs
The four green RUN LEDs and the four red Error LEDs indicate the operating states of the terminal channels.
KL3444, KL3454 - Diagnostic LEDs
Meaning of the LED displays
LED | Color | Channel | State
 |  |  | on | off
Run1 | green | 1 | normal operation | A watchdog timer overflow has occurred. The green LEDs go out if no process data are transferred between the controller and the Bus Coupler for more than 100 ms.
Run2 |  | 2
Run3 |  | 3
Run4 |  | 4
Error1 | red | 1 | Channel current greater than 20.8 mA | normal operation
Error2 |  | 2
Error3 |  | 3
Error4 |  | 4


KL3448, KL3458 - Product Overview

KL3448, KL3458 - Product Overview
KL3448, KL3458 - Product Overview
Additional information
•
Introduction
•
Technical Data
•
KL3448 - Diagnostic LEDs
•
KL3458 - Diagnostic LEDs


Introduction

KL3448, KL3458 - Product Overview [image] Introduction
Introduction
KL3448: 8-channel analog input terminal 0 ... 20 mA
KL3448
The EL3448 analog input terminal process signals in the range between 0 and 20 mA. The current is digitized to a resolution of 12 bits, and is transmitted, in an electrically isolated form, to the higher-level automation device.
The KL3448 variant combines 8 channels in one housing and is particularly suitable for space-saving installation in control cabinets. The use of single conductor connection technology enables the connection of multi-channel sensor technology with minimum space requirements. In the KL3448, the power contacts of are connected through. The reference ground for all inputs is the 0 V power contact.
Overload is detected and the terminal status is forwarded to the controller via the K-bus. The Run LEDs give an indication of the data exchange with the Bus Coupler.
KL3458: 8-channel analog input terminal 4 ... 20 mA
KL3458
The EL3458 analog input terminal process signals in the range between 4 and 20 mA. The current is digitized to a resolution of 12 bits, and is transmitted, in an electrically isolated form, to the higher-level automation device.
The KL3458 variant combines 8 channels in one housing and is particularly suitable for space-saving installation in control cabinets. The use of single conductor connection technology enables the connection of multi-channel sensor technology with minimum space requirements. In the KL3458, the power contacts of are connected through. The reference ground for all inputs is the 0 V power contact.
Overload is detected and the terminal status is forwarded to the controller via the K-bus. The Error LEDs indicate overload and wire breakage.


Technical Data

KL3448, KL3458 - Product Overview [image] Technical Data
Technical Data
Technical Data | KL3448-0000, KS3448-0000 | KL3458-0000, KS3458-0000
Number of inputs | 8 | 8
Signal voltage | 0 ... 20 mA | 4 ... 20 mA
Internal resistance | < 85 Ω
Common-mode voltage UCM | max. 30 V | max. 30 V
Resolution | 12 Bit
Conversion time | approx. 4 ms
Measuring error (total measuring range) | < ±0.3% of the full scale value
Surge voltage resistance | 30 VDC
Electrical isolation | 500 V (K-Bus/signal voltage)
Power supply for the electronics | via the K-bus
Current consumption from the K-bus | typically 105 mA
Bit width in process image | Input: 8 x 16 bit user data, 8 x 8 bit control/status (optional)
Weight | approx. 55 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Assembly | on 35 mm mounting rail conforms to EN 60715
Pluggable wiring | for all KSxxxx terminals
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6/EN 60068-2-27, see also Installation instructions for enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX, GL


KL3448 - Diagnostic LEDs

KL3448, KL3458 - Product Overview [image] KL3448 - Diagnostic LEDs
KL3448 - Diagnostic LEDs
The eight green Run LEDs indicate the operating states of the terminal channels.
KL3448 - Diagnostic LEDs
Meaning of the LED displays
LED | Color | Channel | State
 |  |  | on | off
Run 1 | green | 1 | normal operation | A watchdog timer overflow has occurred. The green LEDs go out if no process data are transferred between the controller and the Bus Coupler for more than 100 ms.
Run 2 |  | 2
Run 3 |  | 3
Run 4 |  | 4
Run 5 |  | 5
Run 6 |  | 6
Run 7 |  | 7
Run 8 |  | 8


KL3458 - Diagnostic LEDs

KL3448, KL3458 - Product Overview [image] KL3458 - Diagnostic LEDs
KL3458 - Diagnostic LEDs
The eight red Error LEDs indicate the operating states of the terminal channels.
KL3458 - Diagnostic LEDs
Meaning of the LED displays
LED | Color | Channel | State
 |  |  | on | off
Error 1 | red | 1 | Channel current greater than 20.8 mA | normal operation
Error 2 |  | 2
Error 3 |  | 3
Error 4 |  | 4
Error 5 |  | 1
Error 6 |  | 2
Error 7 |  | 3
Error 8 |  | 4


Basic Function Principles

Basic Function Principles
Basic Function Principles
The analog input terminals
▪
KL3444 and KL3448 process signals in the range between 0 and 20 mA
▪
KL3454 and KL3458 process signals in the range between 4 and 20 mA
with a resolution of 12 bits (4095 steps). They can supply the sensors from voltage fed in via the power contacts. The power contacts can optionally be supplied via the standard supply or via a power feed terminal with electrical isolation.
Process data output format
In the delivery state the process data are shown in two's complement form (integer -1 corresponds to 0xFFFF). Other presentation types can be selected via the feature register R32 (e.g. signed amount representation, Siemens output format).
Measured value |  | Input data
KL3444, KL3448 | KL3454, KL3458 | decimal | hexadecimal
0 mA | 4 mA | 0 | 0x0000
10 mA | 12 mA | 16383 | 0x3FFF
20 mA | 20 mA | 32767 | 0x7FFF
Process data equations
The process data that are transferred to the Bus Coupler are calculated using the following equations:
Neither user nor manufacturer scaling is active
Ya = (Ba + XADC) x Aa | (1.0)
Yout = Ya |
Manufacturer scaling active (default setting)
Y1 = Bh + Ah x Ya | (1.1)
Yout = Y1 |
User scaling active
Y2 = Bw + Aw x Ya | (1.2)
Yout = Y2 |
Manufacturer and user scaling active
Y1 = Bh + Ah x Ya | (1.3)
Y2 = Bw + Aw x Y1 | (1.4)
Yout = Y2 |
Key
XADC: | Output values of the A/D converter |
Yout: | Process data to PLC |
Ba, Aa: | Manufacturer gain and offset compensation | (R17, R18)
Bh, Ah: | Manufacturer scaling | (R19, R20)
Bw, Aw: | User scaling | (R33, R34)
The equations of the straight line are enabled via register R32.
Signal processing


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding
•
KL3444 - Connection
•
KL3454 - Connection
•
KL3448, KL3458 - Connection


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


KL3444 - Connection

Mounting and wiring [image] Connection [image] KL3444 - Connection
KL3444 - Connection
KL3444 - Connection
Terminal point no. | Channel | Name | Connection for
1 | 1 | Input 1 | Input 1, signal
2 |  | GND | Input 1, ground
3 | 3 | Input 3 | Input 3, signal
4 |  | GND | Input 3, ground
5 | 2 | Input 2 | Input 2, signal
6 |  | GND | Input 2, ground
7 | 4 | Input 4 | Input 4, signal
8 |  | GND | Input 4, ground


KL3454 - Connection

Mounting and wiring [image] Connection [image] KL3454 - Connection
KL3454 - Connection
KL3454 - Connection
Terminal point no. | Channel | Name | Connection for
1 | 1 | Input 1 | Input 1, signal
2 |  | + 24 V | Input 1, 24 V
3 | 3 | Input 3 | Input 3, signal
4 |  | + 24 V | Input 3, 24 V
5 | 2 | Input 2 | Input 2, signal
6 |  | + 24 V | Input 2, 24 V
7 | 4 | Input 4 | Input 4, signal
8 |  | + 24 V | Input 4, 24 V


KL3448, KL3458 - Connection

Mounting and wiring [image] Connection [image] KL3448, KL3458 - Connection
KL3448, KL3458 - Connection
KL3448, KL3458 - Connection
Terminal point no. | Channel | Name | Connection for
1 | 1 | Input 1 | Input 1, signal
2 | 3 | Input 3 | Input 3, signal
3 | 5 | Input 5 | Input 5, signal
4 | 7 | Input 7 | Input 7, signal
5 | 2 | Input 2 | Input 2, signal
6 | 4 | Input 4 | Input 4, signal
7 | 6 | Input 6 | Input 6, signal
8 | 8 | Input 8 | Input 8, signal


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Settings
•
Register
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 Digital Input Terminal
▪
a KL3444 Analog Input Terminal
▪
a KL9010 Bus End Terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branch for channel 1 of the KL3444
For the KL3404, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL3444 registers.
▪
Dialog masks for the parameterization of the KL3444 can be found under Settings.
▪
ProcData displays the KL3444 process data (in preparation).


Settings

KS2000 Configuration Software [image] Settings
Settings
The dialog mask for the parameterization of the KL3444, KL3448, KL3454 or KL3458 can be found under Settings.
Settings via KS2000
Operation mode
▪
User scaling active (R32.0)
You can activate user scaling here (default: disabled).
▪
Manufacturer scaling active (R32.1)
You can deactivate manufacturer scaling here (default: enabled).
▪
Watchdog timer active (R32.2)
You can deactivate the watchdog timer here (default: enabled).
▪
Signed amount representation (R32.3)
Here you can enable the signed amount representation (default: disabled).
▪
Siemens output format (R32.4)
You can activate Siemens output format here (default: disabled).
▪
Overrange protection active (R32.8)
You can deactivate the overrange protection here (default: enabled).
▪
Threshold 1 active (R32.9)
You can activate the threshold 1 here (default: disabled).
▪
Threshold 2 active (R32.10)
You can activate the threshold 2 here (default: disabled).
▪
IIR filter active (R32.11)
You can deactivate the digital IIR filter (first order) here (default: enabled).
Register values
▪
User offset (R33)
You can specify the user offset here.
▪
User gain (R34)
You can specify the user gain here.
▪
Threshold 1 (R35)
You can specify threshold 1 here.
▪
Threshold 2 (R36)
You can specify threshold 2 here.
▪
IIR filter cut-off frequency (R37)
You can specify the cut-off frequency for the digital IIR filter here.
–
KL3444, KL3454: default 200 Hz
–
KL3448, KL3458: default 100 Hz


Register

KS2000 Configuration Software [image] Register
Register
Under Register you can directly access the Registers of the KL3444 or KL3454. The meaning of the register is explained in the Register Overview.
Register view in KS2000


Sample program for KL register communication via EtherCAT on KL3314 exemplary

KS2000 Configuration Software [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the User Program

Access from the User Program
Access from the User Program
Additional information
•
Process image
•
Mapping
•
Control and Status Bytes
•
Register Overview
•
Register description
•
Examples of Register Communication


Process image

Access from the User Program [image] Process image
Process image
KL3404 and KL3464 as well as KL3444 and KL3454
KL3404 and KL3464 as well as KL3444 and KL3454 represent themselves in the process image with up to 12 bytes of input data and 12 bytes of output data.
Format | Input data | Output data
Byte | SB1: | CB1
Word | DataIN1 | DataOUT1
Byte | SB2 | CB2
Word | DataIN2 | DataOUT2
Byte | SB3 | CB3
Word | DataIN3 | DataOUT3
Byte | SB4 | CB4
Word | DataIN4 | DataOUT4
Key
SB n: Status byte for channel n
CB n: Control byte for channel n
DataIN n: Input data word channel n
DataOUT n: Output data word channel n
▪
Please refer to the Mapping page for the assignment of the bytes and words to the addresses of the controller.
▪
The meaning of the control and status bytes is explained in Control and status bytes.
▪
In process data mode the analog values are transferred in input data words DataIN1 to DataIN4. Output data words DataOUT1 to DataOUT4 are not used.
KL3408 and KL3468 as well as KL3448 and KL3458
KL3408 and KL3468 as well as KL3448 and KL3458 represent a special case with regard to the process image:
Essentially, two four-channel terminals are accommodated in one terminal housing, which behave like two terminals for the K-bus.
Each of these eight channel analog terminals has the same process image like two four channel terminals of same signal type, plugged next to each other. The KS2000 configuration software and the TwinCAT System Manager display them like two separate four channel analog terminals.
Special treatment for 8-channel analog terminals
Regarding K-bus diagnosis for your Bus Coupler (e.g. for flashing codes, error code and error argument), note that these eight channel analog terminals are represented as two four channel terminals from a Bus Coupler perspective. If the Bus Coupler is the fault location in the event of an error, you must count each eight channel analog terminal as two terminals!


Mapping

Access from the User Program [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions) such as
–
compact or full evaluation
–
Intel or Motorola format
–
word alignment switched on or off
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.
Compact evaluation
For compact evaluation, the analog input terminals only occupy addresses in the input process image. Control and status bytes cannot be accessed.
Compact evaluation in Intel format
Default mapping for CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -
Compact evaluation in Motorola format
Default mapping for Profibus and Interbus coupler
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -
Complete evaluation:
For complete evaluation, the analog input terminals occupy addresses in the input and output process image. Control and status bytes can be accessed.
Complete evaluation in Intel format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0
Complete evaluation in Motorola format
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Complete evaluation in Intel format with word alignment
Default mapping for Lightbus and Ethernet coupler and Bus Terminal Controller (BCxxxx, BXxxxx)
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0
Complete evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key
Complete evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the channel address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.
SB n: Status byte for channel n (appears in the input process image).
CB n: Control byte for channel n (appears in the output process image).
Ch n D0: channel n, lower-order data byte
Ch n D1: channel n, higher-order data byte
reserved: This byte is assigned to the process data memory, although it has no function.
"-": This byte is not used or occupied by the terminal/module.


Control and Status Bytes

Access from the User Program [image] Control and Status Bytes
Control and Status Bytes
Channel 1
The control and status bytes (CB1 and SB1) for channel 1 in the process data mode and for register communication are described below.
Channel 2, channel 3 and channel 4
The control and status bytes of channels 2, 3 and 4 are structured like the control and status byte of channel 1.
Additional information
•
Process data mode
•
Register communication


Process data mode

Access from the User Program [image] Control and Status Bytes [image] Process data mode
Process data mode
Control byte 1 in process data mode
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal. In process data mode it has no function.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | -
Key
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 … CB1.0 | - | 0bin | reserved
Status byte 1 in process data mode
The status byte 1 (SB1) is located in the input image and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | LimitValue 2 State |  | LimitValue 1 State |  | Overrange | Underrange
Key
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgment for process data mode
SB1.6 | Error | 1bin | General error bit
SB1.5 … SB1.4 | LimitValue 2 State | 00bin | Limit value 2 not enabled
 |  | 01bin | Process data less than limit value 2
 |  | 10bin | Process data greater than limit value 2
 |  | 11bin | Process data equal limit value 2
SB1.3 … SB1.2 | LimitValue 1 State | 00bin | Limit value 1 not enabled
 |  | 01bin | Process data less than limit value 1
 |  | 10bin | Process data greater than limit value 1
 |  | 11bin | Process data equal limit value 1
SB1.1 | Overrange | 1bin | Permissible measuring range exceeded
SB1.0 | Underrange | 1bin | Lower measuring range limit violated


Register communication

Access from the User Program [image] Control and Status Bytes [image] Register communication
Register communication
Control byte 1 in register communication
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 … CB1.0 | Reg. no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIN1, or - to write with output data word DataOUT1.
Status byte 1 in register communication
The status byte 1 (SB1) is located in the input image and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgment for register access
SB1.6 | R | 0bin | Read access
SB1.5 … SB1.0 | Reg. no. | Number of the register that was read or written.


Register Overview

Access from the User Program [image] Register Overview
Register Overview
The following registers are used to parameterize the KL3444, KL3448, KL3454 and KL3458. Each signal channel of the analog terminal has one register that can be read or written to with the aid of control, status and data bytes via register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Raw value of the A/D converter (XR) |  | - | - | R | RAM
R1 | reserved |  | - |  | - | -
... | ... |  | ... | ... | ... | ...
R5 | reserved |  | - | - | - | -
R6 | Diagnostic register |  | - | - | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL3444: | 0x0D74 | 3444dec | R | ROM
 |  | KL3448: | 0x0D78 | 3448dec
 |  | KL3454: | 0x0D7E | 3454dec
 |  | KL3458: | 0x0D82 | 3458dec
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Data length (multiplex shift register) |  | 0x0230 | 560dec | R | ROM
R11 | Signal channels |  | 0x0418 | 1048dec | R | ROM
R12 | Minimum data length |  | 0x0098 | 152dec | R | ROM
R13 | Data structure (data type register) |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | e.g. 0x7F80 | e.g. 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | SEEPROM
R17 | Hardware compensation: Offset (Ba) |  | 0x0000 | 0dec | R/W | SEEPROM
R18 | Hardware compensation: Gain (Aa) |  | approx. 0x1350 | approx. 4944dec | R/W | SEEPROM
R19 | Manufacturer scaling: Offset (Bh) |  | 0x0000 | 0dec | R/W | SEEPROM
R20 | Manufacturer scaling: Gain (Ah) |  | typ. 0x2000 | typ. 8192dec | R/W | SEEPROM
R21 | Overrange limit |  | 0x0FFF | 4095dec | R/W | SEEPROM
R22 | Under range limit |  | 0x0000 | 0dec | R/W | SEEPROM
R23 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0906 | 2310dec | R/W | SEEPROM
R33 | User scaling: Offset (Bw) |  | 0x0000 | 0dec | R/W | SEEPROM
R34 | User scaling: Gain (Aw) |  | 0x0400 | 1024dec | R/W | SEEPROM
R35 | Threshold 1 in (Y2) |  | 0x0000 | 0dec | R/W | SEEPROM
R36 | Threshold 2 in (Y2) |  | 0x0000 | 0dec | R/W | SEEPROM
R37 | Cut-off frequency of the digital IIR filter |  | 0x0100 | 256dec | R/W | SEEPROM
R38 | reserved |  | - | - | - | -
... | reserved |  | ... | ... | ... | ...
R63 | reserved |  | - | - | - | -


Register description

Access from the User Program [image] Register description
Register description
The following registers are used to parameterize the KL3444, KL3448, KL3454 and KL3458. Each signal channel of the analog terminal has one register that can be read or written to with the aid of control, status and data bytes via register communication.
▪
R0: Raw value A/D-C
Raw value of the A/D converter (XR)
▪
R6: Diagnostic register
The status byte is mapped to the low-order byte (bit 7 to bit 0) of register R6.
The high-order byte (bit 15 to bit 8) of register R6 is reserved.
▪
R7: Command register
The command register of KL3444 and KL3454 is currently not used.
▪
R8: Terminal description
Register R8 contains the terminal identifier. e.g.:
–
KL3444: 0x0D74 (3444dec)) or
–
KL3454: 0x0D7E (3454dec))
▪
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 (1A)ASCII. '0x31' corresponds to the ASCII character '1' and '0x41' to the ASCII character 'A'. This value cannot be changed.
▪
R10: Data length (multiplex shift register)
R10 contains the number of multiplexed shift registers and their length in bits.
▪
R11: Signal channels
Unlike R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data structure (data type register)
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure: 1 byte, n bytes
0x03 | Word array
0x04 | Structure: 1 byte, n words
0x05 | Double word array
0x06 | Structure: 1 byte, n double words
0x07 | Structure: 1 byte, 1 double word
0x08 | Structure: 1 byte, 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure: 1 byte, n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure: 1 byte, n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure: 1 byte, n double words with variable logical channel length
▪
R15: Alignment register
Via the alignment register bits, the Bus Coupler arranges the address range of an analog terminal such that it starts at a byte boundary.
▪
R16: Hardware version number
Register R16 contains the hardware version of the terminal; this value cannot be changed.
▪
R17: Hardware compensation - offset (Ba)
This register is used for the offset compensation of the terminal (see equation 1.1). Register value (16 bit signed integer) 0x0000 (0dec)
▪
R18: Hardware compensation - gain (Aa)
This register is used for the gain compensation of the terminal (see equation 1.1). Register value (16 bit signed integer x 2-12): approx. 0x1350 (4944dec)
▪
R19: Manufacturer scaling - offset (Bh)
This register contains the offset for the manufacturer scaling (see equation 1.3). Register value (16 bit signed integer) 0x0000 (0dec)
Manufacturer scaling can be enabled via bit R32.1 of the feature register.
▪
R20: Manufacturer scaling - gain (Ah)
This register contains the gain for manufacturer scaling (see equation 1.3). Register value (16 bit signed integer x 2-10): typically 0x2000 (8192dec)
Manufacturer scaling can be enabled via bit R32.1 of the feature register.
▪
R21 over-range limit - OvRL (Ya)
This limit value limits the maximum measuring range of the input terminal (see equation 1.0). If it is exceeded, the associated status bit is set, and the maximum value is displayed. Register value (16 bit signed integer) 0x0FFF (4095dec)
▪
R22 Underrange limit - UnRL (Ya)
If the value falls below this limit, the associated status bit is set, and the minimum value is displayed (see equation 1.0). Register value (16 bit signed integer) 0x0000 (0dec)
▪
R31: Code word register
–
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
–
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset with each restart of the terminal.
▪
R32: Feature register
The feature register specifies the terminal's configuration. Default: 0x0906 (2310dec)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | enIIR | enLimit2 | enLimit1 | enOvRP
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | enSiemens | enSignRepr | enWdTimer | enManScal | enUsrScal
Key
Bit | Name | Description |  | Default
R32.15 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.12 | - | reserved |  | 0bin
R32.11 | enIIR | 0bin | digital IIR filter not active | 1bin
 |  | 1bin | digital IIR filter active
R32.10 | enLimit2 | 0bin | Threshold 2 not active | 0bin
 |  | 1bin | Threshold 2 active
R32.9 | enLimit1 | 0bin | Threshold 1 not active | 0bin
 |  | 1bin | Threshold 1 active
R32.8 | enOvRP | 0bin | Overrange protection is not active | 1bin
 |  | 1bin | Overrange protection is active: If the limit values of registers OvRL (R21) and UnRL (R22) are exceeded, the associated status bits are set and the measuring range is restricted accordingly.
R32.7 | - | reserved |  | 0bin
R32.6 | - | reserved |  | 0bin
R32.5 | - | reserved |  | 0bin
R32.4 | enSiemens | 0bin | Standard output format | 0bin
 |  | 1bin | Siemens output format The three bits with the lowest value are used for displaying status information (see below).
R32.3 | enSignRepr | 0bin | Two's complement representation is active | 0bin
 |  | 1bin | Signed amount representation is active (-1dec = 0x8001)
R32.2 | enWdTimer | 0bin | Watchdog timer is not active | 1bin
 |  | 1bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms)
R32.1 | enManScal | 0bin | Manufacturer scaling is active | 1bin
 |  | 1bin | Manufacturer scaling is not active
R32.0 | enUsrScal | 0bin | User scaling is not active | 0bin
 |  | 1bin | User scaling is active
Siemens output format
If the Siemens output format is selected, the lowest three bits are used for status evaluation. The process data is represented in bits 15 to 3, with bit 15 representing the sign bit. Scaling of the measured value according to the Siemens standard has to be done via user scaling (R33, R34).
KL3444
Measured value | Bit 15 ... 3 | Bit 2 X | Bit 1 Error | Bit 0 Overflow
Measured value < 20 mA | Process data | 0 | 0 | 0
Measured value > 20 mA | - | 0 | 0 | 1
KL3454
Measured value | Bit 15 ... 3 | Bit 2 X | Bit 1 wire breakage | Bit 0 under-/overflow
Measured value < 4 mA | - | 0 | 1 | 1
4 mA <measured value <20 mA | Process data | 0 | 0 | 0
Measured value > 20 mA | - | 0 | 0 | 1
▪
R33: User scaling - offset (Bw)
This register contains the offset of the user scaling.
User scaling can be enabled in the feature register via bit R32.0.
▪
R34: User scaling - gain (Aw)
This register contains the user scaling gain; 0x0400 (1024dec) corresponds to 1.
User scaling can be enabled in the feature register via bit R32.0.
▪
R35: Threshold 1 in Y2
If the process data are outside this threshold, the appropriate bits are set in the status byte.
▪
R36: Threshold 2 in Y2
If the process data are outside this threshold, the appropriate bits are set in the status byte.
▪
R37: Cut-off frequency of the digital IIR filter
This register determines the cut-off frequency of the digital IIR filter (first order). The IIR filter can be deactivated in the feature register with bit R32.11.
Value | Cut-off frequency
 | KL3444, KL3454 | KL3448, KL3458
0x0100 (default) | approx. 200 Hz | approx. 100 Hz
0x0200 | approx. 100 Hz | approx. 50 Hz
0x0300 | approx. 50 Hz | approx. 25 Hz
0x0400 | approx. 20 Hz | approx. 10 Hz
other | No filter active


Examples of Register Communication

Access from the User Program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the User Program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the User Program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com