KL336x - oscilloscope terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.2.0
▪
Update chapter “Instructions for ESD protection”
▪
Chapter “Beckhoff Identification Code (BIC)” added
2.1.0
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Update Technical data
▪
Chapter Instructions for ESD protection added
▪
Update chapter Connection system -> Connection
▪
Chapter Installation instructions for enhanced mechanical load capacity added
▪
Example program added to chapter KS2000 Configuration software
▪
Correction in chapter Register overview
▪
Update structure
2.0.0
▪
Migration
1.1.0
▪
Technical data updated
▪
Installation and wiring revised
1.0
▪
Description of the KL336x parameterization with the KS2000 software corrected (trigger logic details)
0.6
▪
Description of the KL336x parameterization with the KS2000 software updated (trigger logic details)
0.5
▪
Description of the process image revised
0.4
▪
Description of control and status byte extended
▪
Register description updated
▪
English version available
0.3
▪
Connection instructions extended
▪
Description of the KL336x parameterization with the KS2000 software updated
▪
Register description updated
▪
Description of control and status byte revised
0.2
▪
Connection instructions added
▪
Description of the KL336x parameterization with the KS2000 software extended
▪
Register description revised
0.1
▪
First provisional preliminary version
Firmware and hardware versions
Documentation version | KL3361 |  | KL3362
 | Firmware | Hardware | Firmware | Hardware
2.1.0 | 1D | 05 | 1J | 05
2.0.0 | 1D | 04 | 1J | 04
1.1.0 | 1D | 01 | 1I | 01
1.0 | 1D | 01 | 1F | 01
0.6 09.05.2003 | 1D | 01 | 1D | 01
0.5 11.11.2002 | 1D | 01 | 1D | 01
0.4 18.10.2002 | 1D | 01 | 1D | 01
0.3 23.09.2002 | 1D | 01 | 1D | 01
0.2 09.09.2002 | 1D | 01 | 1D | 01
0.1 23.08.2002 | 1B | 00 | 1D | 01
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: KK YY FF HH | Sample with ser. no.: 35 04 1F 01:
KK - week of production (calendar week) | 35 - week of production 35
YY - year of production | 04 - year of production 2004
FF - firmware version | 1F - firmware version 1F
HH - hardware version | 01 - hardware version 01


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
General
•
KL3361 - Single-channel oscilloscope terminal
•
Technical Data of the KL3361
•
KL3362 - two-channel oscilloscope terminal
•
Technical Data of the KL3362
•
Trigger units


General

Product overview [image] General
General
The KL3361 and KL3362 oscilloscope terminals enable decentralized pre-processing of analog input data. The input values are digitized with a 14-bit resolution and written into an internal memory. A powerful pre-processing processor can determine or monitor the following values, among others:
▪
Maximum value of a recording
▪
Minimum value of a recording
▪
RMS value of a recording
▪
Arithmetic mean of a recording
▪
Peak-peak value of a recording
▪
Envelope monitoring
▪
Cycle duration
▪
Most frequent value of a recording
▪
etc.
The result or all the measured values are transported to the higher-level automation unit.
Supported Bus Couplers
Not all bus couplers support the KL3361 and KL3362 oscilloscope terminals. These include BK2000, BK3000, BK3100, BK4000, BK4500, BK5000, BK7500.
KL3361
Single-channel oscilloscope terminal for an input voltage range of -16 mV to +16 mV.
Typical application:
Logging and pre-processing of the differential signal from strain gauges in a bridge circuit.
KL3362
Two-channel oscilloscope terminal for an input voltage range of -10 V to +10 V.
Typical application:
Logging and pre-processing of standard analog signals.


KL3361 - Single-channel oscilloscope terminal

Product overview [image] KL3361 - Single-channel oscilloscope terminal
KL3361 - Single-channel oscilloscope terminal
KL3361
The KL3361 analog input terminal makes it possible to perform non-central preliminary processing of analog values. The input values are digitized with a 14-bit resolution and written into an internal memory. An efficient processor can pre-process the values. Limit values, maximum and minimum values will be determined or monitored. The KL3361 can also carry out envelope monitoring. A trigger starts cyclical processes. The result or all the measured values are transported to the higher-level automation unit.
The supply voltage Uv can be drawn from the terminal or can be supplied from an external source. The terminal supplies 5 V. The maximum input voltage U is limited to 10 V.
LED indicators - meanings
LED | No. | Display
No wire (rot) | A | This LED is on if the wire breaks at the trigger input.
Output (green) | B | This LED is on if the digital output is set.
Error (red) | C | In preparation.
Trigger (green) | D | This LED is on if a signal is present at the trigger input.
For pin assignment see Connecting the KL3361.


Technical Data of the KL3361

Product overview [image] Technical Data of the KL3361
Technical Data of the KL3361
Single-channel oscilloscope terminal, -20 mV to +20 mV
Technical data | KL3361
Number of inputs | 1 analog, 1 trigger
Signal voltage UIN | -20 mV to +20 mV
Input resistance | > 1 MOhm (UIN)
Power supply for the measuring bridge UV | 5 VDC, 20 mA max.
Resolution | 14 bit (plus 1 sign bit)
Sampling rate (configurable) | minimum 100 µs, (minimum 10 µs for fast sampling)
Measuring error (full measuring range) | ±1% of the full scale value
Internal memory | 32 kbyte
Bit width in the input process image | 2 data words, 1 control byte
Bit width in the output process image | 2 data words, 1 status byte
Power supply for the electronics | via the K-bus
Current input from the K-Bus with external supply of the measuring bridge | typically 120 mA
Current consumption from the K-Bus with supply of the measuring bridge (4 x 350 Ohm) via KL3361 | typically 140 mA
Dielectric strength | 500 V (shielding, base plate / K-Bus)
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also Installation instructions for terminals with increased mechanical load cpacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Weight | approx. 55 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Installation position | variable
Protection class | IP20
Approvals | CE, ATEX, cULus


KL3362 - two-channel oscilloscope terminal

Product overview [image] KL3362 - two-channel oscilloscope terminal
KL3362 - two-channel oscilloscope terminal
KL3362
The KL3362 analog input terminal makes it possible to perform non-central preliminary processing of analog values. The input values are digitized with a 14-bit resolution and written into an internal memory. An efficient processor can pre-process the values. Limit values, maximum and minimum values will be determined or monitored. The KL3362 can also carry out envelope monitoring. A trigger starts cyclical processes. The result or all the measured values are transported to the higher-level automation unit.
LED indicators - meanings
LED | No. | Display
Error 1 (red) | A | in preparation
Output (green) | B | This LED is on if the digital output is set.
Error 2 (red) | C | in preparation
Trigger (green) | D | This LED is on if a signal is present at the trigger input.
For pin assignment see Connecting the KL3362.


Technical Data of the KL3362

Product overview [image] Technical Data of the KL3362
Technical Data of the KL3362
Two-channel oscilloscope terminal, -10 V to +10 V
Technical data | KL3362
Number of inputs | 2 analog, 1 trigger
Signal voltage UIN | -10 V to +10 V
Input resistance (IN1-GND, IN2-GND) | > 500 kOhm
Resolution | 14 bit (plus 1 sign bit)
Sampling rate (configurable) | minimum 100 µs, (minimum 10 µs for fast sampling)
Measuring error (full measuring range) | ±0,5% of the full scale value
Internal memory | 32 kbyte
Bit width in the input process image | Per channel: 2 data words, 1 control byte
Bit width in the output process image | Per channel: 2 data words, 1 status byte
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 120 mA
Dielectric strength | 500 V (shielding, base plate / K-Bus)
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95 %, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Weight | approx. 55 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Installation position | variable
Protection class | IP20
Approvals | CE, ATEX, cULus


Trigger units

Product overview [image] Trigger units
Trigger units
The oscilloscope terminals have two trigger units per signal channel. They are configured via sets of registers. The first trigger unit is configured via registers R40 to R45, the second one via registers R46 to R51.
Optionally, the following are used as a trigger source:
▪
an output word of the fieldbus
▪
a timer
▪
the analog inputs
▪
the digital input
▪
the output of trigger unit 1 for trigger unit 2
The following can be selected as a trigger event:
▪
rising or falling edge
▪
a positive or negative pulse that is greater or smaller than a specified pulse width (glitch)
The trigger can be enabled as follows:
▪
always, i.e. each trigger event is immediately enabled
▪
via the signal at the analog inputs or the digital input (each with positive or negative logic and associated switching thresholds).
Enabling of the trigger evens can prompt various actions:
▪
start of recording
▪
start of a timer (chronometer)
▪
setting of the digital output
▪
saving of the current timer value
▪
resetting of the timer
▪
starting of a further timer, which is associated with the Valid Trigger Time register
The trigger units can be cascaded. This enables extremely flexible triggering depending on the cause of events. For cascaded trigger units, the Valid Trigger Time register specifies a time window, during which the subsequent trigger event must occur. If this does not happen, everything is reset and the first trigger event is once again awaited.


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Connecting the KL3361
•
Connecting the KL3362
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Connecting the KL3361

Mounting and wiring [image] Connecting the KL3361
Connecting the KL3361
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Connecting the KL3361
The diagram shows the connection of four strain gauges (SG) as a bridge circuit, with supply of the measuring bridge
▪
through the oscilloscope terminal (left) or
▪
from an external voltage source Uext (right).
Terminal point | No. | Connection
+ 24 V | 1 | Supply voltage for digital output
OUT 24 V | 2 | Digital output
UB+ | 3 | Input for differential voltage of the measuring bridge
UV+ | 4 | 5 V supply voltage for the strain gauges in a bridge circuit or reference input for the external supply voltage of the measuring bridge
24 V Trigger | 5 | Trigger input
0V | 6 | Ground for trigger input
UB- | 7 | Input for differential voltage of the measuring bridge
UV- | 8 | 0 V supply voltage for the strain gauges in a bridge circuit or reference input for the external supply voltage of the measuring bridge
Supply of the measuring bridge via KL3361
The total resistance of the measuring bridge should be dimensioned in such a way that the current to be supplied by the oscilloscope terminal at the terminals UV+ and UV- never exceeds 20 mA.
Supply of the measuring bridge from an external voltage source
Note the following if the measuring bridge is supplied from an external voltage source:
The external supply voltage
▪
must also be applied to the UV+ and UV- connections for reference;
▪
must be within the range +5 V to +10 V;
▪
must not vary by more than ±5% during operation.
Fluctuations of the external supply voltage increase the measurement error!
After changing the external supply voltage, the oscilloscope terminal has to be restarted for re-balancing!
The internal voltage source switches off automatically, as soon as an external voltage of more than 5 V is applied to the UV+ and UV- terminals of the oscilloscope terminal.


Connecting the KL3362

Mounting and wiring [image] Connecting the KL3362
Connecting the KL3362
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Connecting the KL3362
The diagram shows the connection of two function generators (FG1, FG2) to the channels of the KL3362 oscilloscope terminal.
Terminal point | No. | Connection
+ 24V | 1 | Supply voltage for digital output
OUT 24V | 2 | Digital output
IN 1 | 3 | Oscilloscope input channel 1 ( -10 V to +10 V)
GND | 4 | Ground for oscilloscope input channel 1 (internally connected with terminal no. 8)
24V Trigger | 5 | Trigger input
0V | 6 | Ground for trigger input
IN 2 | 7 | Oscilloscope input channel 2 ( -10 V to +10 V)
GND | 8 | Ground for oscilloscope input channel 2 (internally connected with terminal no. 4)


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Configuration software KS2000

Configuration software KS2000
Configuration software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Masks for KL3361
•
Masks for KL3362
•
Settings in detail
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

Configuration software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the sample shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 digital input terminal
▪
a KL3661 oscilloscope terminal
▪
a KL9010 Bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the sample).
KS2000 tree branches for channel 1 of the KL3681
Click on Settings. You can now change the settings of the oscilloscope terminal.
KL3361:
▪
Trigger logic
▪
Operating mode and trigger values
▪
Process data
KL3362:
▪
Trigger logic
▪
Trigger values
▪
Operation mode
▪
Process data


Masks for KL3361

Configuration software KS2000 [image] Masks for KL3361
Masks for KL3361
Additional information
•
Trigger logic for KL3361
•
Trigger values for KL3361
•
Process data for KL3361


Trigger logic for KL3361

Configuration software KS2000 [image] Masks for KL3361 [image] Trigger logic for KL3361
Trigger logic for KL3361
In the Trigger logic tab, you can specify the trigger behavior of the KL3361 oscilloscope terminal.
Trigger logic for KL3361
▪
Source
Here you can select the trigger source (see Trigger logic in detail).
▪
Event
Here you can specify the trigger event (see Trigger logic in detail).
▪
Enable
Connect the lower input of the And gate with the desired function in order to specify when the And gate should switch through a trigger pulse (see Trigger logic in detail).
▪
Action
Connect the output of the And gate with the desired function in order to specify which task should be triggered (see Trigger logic in detail).


Trigger values for KL3361

Configuration software KS2000 [image] Masks for KL3361 [image] Trigger values for KL3361
Trigger values for KL3361
In the Trigger values tab, you can set the mode, the scaling and the switching thresholds, the pulse width and the valid trigger time for the two trigger units of the KL3361 oscilloscope terminal.
Trigger values for KL3361
▪
Operation mode
Here you can specify the trigger type (see General settings in detail).
▪
General
Here you can specify the general trigger settings (see General settings in detail).
▪
Scaling
Here you can specify the scaling (see General settings in detail).
▪
Trigger unit 1
Here you can specify the trigger values for trigger unit 1 (see Trigger values in detail).
▪
Trigger unit 2
Here you can specify the trigger values for trigger unit 2 (see Trigger values in detail).


Process data for KL3361

Configuration software KS2000 [image] Masks for KL3361 [image] Process data for KL3361
Process data for KL3361
In the Process data tab, you can specify which data are displayed in the process image of the KL3361 oscilloscope terminal.
Process data for KL3361
Output process image
▪
Data word 0
For trigger unit 1, select which trigger parameter you wish to specify with data word 0 (DataOUT0) of the KL3361 (see Output process data in detail).
▪
Data word 1
For trigger unit 2, select which trigger parameter you wish to specify with data word 1 (DataOUT1) of the KL3361 (see Output process data in detail).
Input process image
▪
Data word 0
Here you can specify which input value is transferred with data word 0 (DataIN0) from the KL3361 to the control (see Input process data in detail).
▪
Data word 1
Here you can specify which input value is transferred with data word 1 (DataIN1) from the KL3361 to the control (see Input process data in detail).


Masks for KL3362

Configuration software KS2000 [image] Masks for KL3362
Masks for KL3362
Additional information
•
Trigger logic for KL3362
•
General settings for KL3362
•
Trigger values for KL3362
•
Process data for KL3362


Trigger logic for KL3362

Configuration software KS2000 [image] Masks for KL3362 [image] Trigger logic for KL3362
Trigger logic for KL3362
In the Trigger logic tab, you can specify the trigger behavior of the KL3362 oscilloscope terminal.
Trigger logic for KL3362
▪
Source
Here you can select the trigger source (see Trigger logic in detail).
▪
Event
Here you can specify the trigger event (see Trigger logic in detail).
▪
Enable
Connect the lower input of the And gate with the desired function in order to specify when the And gate should switch through a trigger pulse (see Trigger logic in detail).
▪
Action
Connect the output of the And gate with the desired function in order to specify which task should be triggered (see Trigger logic in detail).


General settings for KL3362

Configuration software KS2000 [image] Masks for KL3362 [image] General settings for KL3362
General settings for KL3362
In the General settings tab, you can specify the operating mode, general settings and the scaling of both channels of the KL3362 oscilloscope terminal.
General settings for KL3362
▪
Operation mode
Here you can specify the trigger type (see General settings in detail).
▪
General
Here you can specify the general trigger settings (see General settings in detail).
▪
Scaling channel 1
Here you can specify the scaling for channel 1 (see General settings in detail).
▪
Scaling channel 2
Here you can specify the scaling for channel 2 (see General settings in detail).


Trigger values for KL3362

Configuration software KS2000 [image] Masks for KL3362 [image] Trigger values for KL3362
Trigger values for KL3362
In the Trigger values tab, you can specify the switching thresholds, the pulse width and the valid trigger time for the four trigger units of the KL3362 oscilloscope terminal.
Trigger values for KL3362
▪
Trigger unit 1
Here you can specify the trigger values for trigger unit 1 (see Trigger values in detail).
▪
Trigger unit 2
Here you can specify the trigger values for trigger unit 2 (see Trigger values in detail).
▪
Trigger unit 3
Here you can specify the trigger values for trigger unit 3 (see Trigger values in detail).
▪
Trigger unit 4
Here you can specify the trigger values for trigger unit 4 (see Trigger values in detail).


Process data for KL3362

Configuration software KS2000 [image] Masks for KL3362 [image] Process data for KL3362
Process data for KL3362
In the Process data tab, you can specify which data are displayed in the process image of the KL3362 oscilloscope terminal.
Process data for KL3362
Output process image
▪
Data word 0
For trigger unit 1, select which trigger parameter you wish to specify with data word 0 (DataOUT0, channel 1) of the KL3362 (see Output process data in detail).
▪
Data word 1
For trigger unit 2, select which trigger parameter you wish to specify with data word 1 (DataOUT1, channel 1) of the KL3362 (see Output process data in detail).
▪
Data word 2
For trigger unit 3, select which trigger parameter you wish to specify with data word 2 (DataOUT0, channel 2) of the KL3362 (see Output process data in detail).
▪
Data word 3
For trigger unit 4, select which trigger parameter you wish to specify with data word 3 (DataOUT1, channel 2) of the KL3362 (see Output process data in detail).
Input process image
▪
Data word 0
Here you can specify which input value is transferred with data word 0 (DataIN0, channel 1) from the KL3362 to the controller (see Input process data in detail).
▪
Data word 1
Here you can specify which input value is transferred with data word 1 (DataIN1, channel 1) from the KL3362 to the controller (see Input process data in detail).
▪
Data word 2
Here you can specify which input value is transferred with data word 2 (DataIN0, channel 2) from the KL3362 to the controller (see Input process data in detail).
▪
Data word 3
Here you can specify which input value is transferred with data word 3 (DataIN1, channel 2) from the KL3362 to the controller (see Input process data in detail).


Settings in detail

Configuration software KS2000 [image] Settings in detail
Settings in detail
Additional information
•
Trigger logic
•
General settings
•
Trigger values
•
Output process data
•
Input process data


Trigger logic

Configuration software KS2000 [image] Settings in detail [image] Trigger logic
Trigger logic
Source
You may select one of the following trigger sources (R40):
 | Shot | The trigger pulse is triggered by the fieldbus via a control word.
 | Timer | The trigger pulse is triggered at regular intervals by a timer. The frequency of the timer can be specified under General trigger settings.
 | Digital input | The trigger pulse is triggered by the trigger input (24 V trigger).
 | Analog input 1 | The trigger pulse is triggered by analog input 1.
(KL3362 only) | Analog input 2 | The trigger pulse is triggered by analog input 2.
Event
Here you can specify the event (R40) that triggers the trigger.
Rising edge (default) | The trigger unit responds to the rising edge of the input signal. The associated threshold level can be specified via the Trigger values tab.
Falling edge | The trigger unit responds to the falling edge of the input signal. The associated threshold level can be specified via the Trigger values tab.
Positive pulse longer than set pulse width | The trigger unit responds if the positive pulse width is longer than the configured pulse width, which can be specified via the Trigger values tab.
Positive pulse shorter than set pulse width | The trigger unit responds if the positive pulse width is shorter than the configured pulse width, which can be specified via the Trigger values tab.
Negative pulse longer than set pulse width | The trigger unit responds if the negative pulse width is longer than the configured pulse width, which can be specified via the Trigger values tab.
Negative pulse shorter than set pulse width | The trigger unit responds if the negative pulse width is shorter than the configured pulse width, which can be specified via the Trigger values tab.
Enable
Connect the lower input of the And gate with the desired function in order to specify when the And gate should switch through a trigger pulse (R40).
 | Always enabled | The trigger pulse is always switched through.
 | Digital input High | The trigger pulse is switched through, if the trigger input (24 V trigger) of the oscilloscope terminal is on High potential.
 | Analog input 1 above switching threshold | The trigger pulse is switched through, if the signal at analog input 1 of the oscilloscope terminal increases above the switching threshold 2. The threshold level can be specified via the Trigger values tab.
(KL3362 only) | Analog input 2 above switching threshold | The trigger pulse is switched through, if the signal at analog input 2 of the oscilloscope terminal increases above the switching threshold 2. The threshold level can be specified via the Trigger values tab.
 | Digital input Low | The trigger pulse is switched through, if the trigger input (24 V trigger) of the oscilloscope terminal is on Low potential.
 | Analog input 1 below switching threshold | The trigger pulse is switched through, if the signal at analog input 1 of the oscilloscope terminal decreases below the specified switching threshold 2. The threshold level can be specified via the Trigger values tab.
(KL3362 only) | Analog input 2 below switching threshold | The trigger pulse is switched through, if the signal at analog input 2 of the oscilloscope terminal decreases below the specified switching threshold 2. The threshold level can be specified via the Trigger values tab.
Action
Connect the output of the And gate with the desired function in order to specify which task should be triggered.
 | Reset the timer (chronometer) to zero (R40.2) | Resets the timer back to zero. The timer will start running again automatically immediately.
 | Save timer (chronometer) (R40.3) | Saves the current value of the running timer at the trigger instant.
 | Set digital output (R40.4) | Sets the digital output, e.g. to the synchronous triggers of the second oscilloscope channel of a KL3362. This function must be released with bit 2 of the control byte 1 (CB1.2)
 | Start recording (R40.5) | Starts the recording
 | Enable trigger unit 2 (R40.5) | If the output of the And gate in trigger unit 1 is connected with the function Enable trigger 2, the trigger signal is transferred to trigger unit 2, which can be accessed via the Unit 2 button in the Selection field for parameterization.
(KL3362 only) | Enable trigger unit 3 (R40.5) | If the output of the And gate in trigger unit 2 is connected with the function Enable trigger 3, the trigger signal is transferred to trigger unit 3, which can be accessed via the Unit 3 button in the Selection field for parameterization.
(KL3362 only) | Enable trigger unit 4 (R40.5) | If the output of the And gate in trigger unit 3 is connected with the function Enable trigger 4, the trigger signal is transferred to trigger unit 4, which can be accessed via the Unit 4 button in the Selection field for parameterization.


General settings

Configuration software KS2000 [image] Settings in detail [image] General settings
General settings
Operation mode
Pre-trigger (R32.8-10)
Recording ceases as soon as a trigger event occurs.
Mid-trigger (R32.8-10)
The trigger event is the center of the recording.
Post-trigger (R32.8-10)
default
Recording commences as soon as a trigger event occurs.
Fast sampling (R32.8-10)
Operation with increased sampling rate of up to 10 µs:
▪
The recording can only be started via the trigger input.
▪
The settings of the trigger units are not taken into account.
▪
Only the first channel is recorded, even for KL3362.
Trigger delay active (R32.4)
default: not activated
Switches the trigger delay on.
Trigger delay (R52)
default: 0
A trigger delay (tTD) can be specified here. The number of skipped samples (nSTD) is entered as the parameter. The trigger delay thus depends on the sample rate! Sample:
- Sample Rate: Ts = 200 µs
- Skipped Samples: nSTD=100
tTD = Ts x nSTD = 200 µs x 100 = 20 ms
Test mode active (R32.5)
default: not activated
Switches the test mode on. In test mode, a ramp is output instead of converted analog values. It runs from 0 to 0x3FFF and back again.
Auto-trigger active (R32.6)
default not activated
Switches the auto trigger function on. With auto trigger switched on, the trigger unit is automatically activated once the preceding event has been evaluated. To this end, bit 0 is toggled in status register 1 (SR1) with each new evaluation.
General
Sample rate (R35)
default: 200 µs
Interval (Ts) between two samples (scans) in microseconds.
The sampling speed is limited to Ts =100 µs (10 kHz) by the evaluation of the trigger detectors.
Only the mode enables sampling at Ts =10 µs (100 kHz).
Sample amount ( )
default: 100
Number of sampling values to be recorded. A maximum of 4,000 values can be recorded.
Trigger frequency (R56)
default: 0
Here you can specify the trigger frequency of the timer.
Scaling channel 1
User offset (R33) default: 0 | Here you can enter an offset. Scaling: offset = full scale value x parameter / resolution Sample for KL3361: 16 mV x 100 / 32767 = 0.049 mV
User gain (R34) default: 256 | Here you can enter the gain factor for scaling the input value by this factor.
Scaling channel 2 (KL3362 only)
User offset (R33) default: 0 | Here you can enter an offset. Scaling: offset = full scale value x parameter / resolution Sample for KL3361: 16 mV x 100 / 32767 = 0.049 mV
User gain (R34) default: 256 | Here you can enter the gain factor for scaling the input value by this factor.


Trigger values

Configuration software KS2000 [image] Settings in detail [image] Trigger values
Trigger values
Trigger unit 1
Switching threshold 1 (R41) default: 1000 | Here you can specify the switching threshold for the trigger source of trigger unit 1. Scaling: Threshold value = full scale value x parameter / resolution Sample for KL3361: 16 mV x 1000 / 32767 = 0,488 mV
Switching threshold 2 (R42) default: 1000 | Here you can specify the switching threshold for enabling the trigger of trigger unit 1. Scaling: see Switching threshold 1.
Pulse width (R43) default: 100 | Here you can specify the pulse width (tP) of trigger unit 1 for the glitch mode. The number of samples (nSP) is entered as the parameter. The pulse width thus depends on the sample rate! Sample: - Sample rate: Ts = 200 µs - Samples: nSP = 100 Pulse width: tP = Ts x nSP = 200 µs x 100 = 20 ms
valid trigger time (R44) default: | Here you can specify the valid trigger time (tVT) for trigger unit 1. The number of valid samples (nVS) is entered as the parameter. The valid trigger time thus depends on the sample rate! Sample: - Sample rate: Ts = 200 µs - valid samples: nVS=100 Valid trigger time: tVT = Ts x nVS =200 µs x 100 = 20 ms
Timeframe active (R40.6) default: not activated | Here you can switch on the timeframe for trigger unit 1.
Trigger unit 2
Switching threshold 1 (R47) default: 1000 | Here you can specify the switching threshold for the trigger source of trigger unit 2. Scaling: see Trigger unit 1.
Switching threshold 2 (R48) default: 1000 | Here you can specify the switching threshold for enabling the trigger of trigger unit 2. Scaling: see Trigger unit 1.
Pulse width (R49) default: 100 | Here you can specify the pulse width for trigger unit 2. Scaling: see Trigger unit 1.
valid trigger time (R50) default: | Here you can specify the valid trigger time for trigger unit 2. Scaling: see Trigger unit 1.
Timeframe active (R46) default: not activated | Here you can switch on the timeframe for trigger unit 2.
Trigger unit 3 (KL3362 only)
See Trigger unit 1.
Trigger unit 4 (KL3362 only)
See Trigger unit 2.


Output process data

Configuration software KS2000 [image] Settings in detail [image] Output process data
Output process data
Output process data in detail
Data word 0
Here you can choose which trigger parameter you wish to specify with data word 0 of the oscilloscope terminal for trigger unit 1.
Switching threshold 1 | Switching threshold 1 of trigger unit 1
Switching threshold 2 | Switching threshold 2 of trigger unit 1
Pulse width | Pulse width of trigger unit 1
Valid trigger time | Valid trigger time of trigger unit 1
Not indicated | No parameters set
Data word 1
Here you can choose which trigger parameter you wish to specify with data word 1 of the oscilloscope terminal for trigger unit 1.
Switching threshold 1 | Switching threshold 1 of trigger unit 2
Switching threshold 2 | Switching threshold 2 of trigger unit 2
Pulse width | Pulse width of trigger unit 2
Valid trigger time | Valid trigger time of trigger unit 2
Not indicated | No parameters set
Data word 2 (KL3362 only)
Here you can choose which trigger parameter you wish to specify with data word 2 of the oscilloscope terminal for trigger unit 3 (see Data word 0 for trigger parameters).
Data word 3 (KL3362 only)
Here you can choose which trigger parameter you wish to specify with data word 3 of the oscilloscope terminal for trigger unit 3 (see Data word 1 for trigger parameters).


Input process data

Configuration software KS2000 [image] Settings in detail [image] Input process data
Input process data
Input process data in detail
Data word 0
Here you can specify which input value is transferred with data word 0 from the oscilloscope terminal to the control.
Selecting the input value for data word 0
Input value
Comment
Current measurement reading
Current analog value
Maximum value
Maximum value of a recording
Minimum value
Minimum value of a recording
RMS value
RMS value of a recording: Sqrt((Sum (xn2))/n
Mean value
Arithmetic mean of a recording: (Sum (xn))/n
Peak-peak value
Peak-peak value of a recording
Cycle duration
Cycle duration of a recording
Pulse width HIGH
▪
four successive values have to be above the switching threshold for activating the start
▪
four successive values have to be below the switching threshold for activating the stop
Pulse width LOW
▪
four successive values have to be above the switching threshold for activating the start
▪
four successive values have to be below the switching threshold for activating the stop
Duty factor
Duty factor
Jitter Tmax
reserved
Jitter Tmin
reserved
Jitter Tmean
reserved
Histogram Max
Most frequent value of a recording
Read value timer 1
stored value of the timer (chronometer) from trigger unit 1*
*) for KL3362 also trigger unit 3 (via data word 2 or 3)
Current value timer 1
current value of the timer (chronometer) from trigger unit 1*
Read value timer 2
stored value of the timer (chronometer) from trigger unit 2**
**) for KL3362 also trigger unit 4 (via data word 2 or 3)
Current value timer 2
current value of the timer (chronometer) from trigger unit 2*
Error counter inner envelope curve
Error counter of the inner envelope curve
Error counter outer envelope curve
Error counter of the outer envelope curve
Number of samples up to analog value greater than switching threshold
Number of measurement points recorded up to the time when the analog value exceeded the switching threshold.
Number of samples up to analog value less than switching threshold
Number of measurement points recorded up to the time when the analog value was less than the switching threshold.
Data word 1
Here you can specify which input value is transferred with data word 1 from the oscilloscope terminal to the control.
Selecting the input value for data word 1
(input values see Data word 0).
Data word 2 (KL3362 only)
Here you can specify which input value is transferred with data word 2 from the oscilloscope terminal to the control.
Selecting the input value for data word 2 (KL3362 only)
(input values see Data word 0).
Data word 3 (KL3362 only)
Here you can specify which input value is transferred with data word 3 from the oscilloscope terminal to the control.
Selecting the input value for data word 3 (KL3362 only)
(input values see Data word 0).


Sample program for KL register communication via EtherCAT on KL3314 exemplary

Configuration software KS2000 [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the user program

Access from the user program
Access from the user program
The index registers R38 and R39 can be used to specify which process data are cyclically transferred from the oscilloscope terminal
▪
KL3361 with registers DataIN11 and DataIN12
▪
KL3362 with registers DataIN11 and DataIN12 (channel 1) or DataIN21 and DataIN22 (channel 2)
to the controller. Maximum values, minimum values, RMS values, mean values, individual sampling values (sample n after trigger event), rise times, pulse widths etc. can thus optionally be represented directly in the process data.
The index register R37 can be used to specify which process data are cyclically transferred to oscilloscope terminal
▪
KL3361 with registers DataOUT11 and DataOUT12
▪
KL3362 with registers DataOUT11 and DataOUT12 (channel 1) or DataOUT21 and DataOUT22 (channel 2)
. Switching thresholds, pulse widths etc. can thus optionally be specified via the process data channel.
Evaluation of a recording
A recording is requested via the bEnableTrigger bit. Current values are present in the memory if the bTriggerDone bit appears in the status byte of the terminal. If the memory is to be read or evaluated, the bEnableTrigger bit must remain set, otherwise the memory is continuously overwritten.
Evaluation of the memory is activated via the bEvalBuffer bit. Current values are present in the process data, as soon as the bEvalBufferDone bit appears. Multiple evaluation of the memory is thus possible. Mean value, maximum value, minimum value, RMS value of the recording can thus be read sequentially.
Reading the trace memory
Samples can be read via the Trace data registers R60 and R61. To this end, the offset within the memory can be specified via the Trace index register (R62).
The Zoom register (R63) can be used to specify a number nS of samples for which the maximum value, minimum value and mean value is calculated, or the sample interval nS at which the values are output. After each read access of R60 or R61, the Trace index register (R62) is incremented by nS.
Sample:
For calling up all values from the memory, enter the value 0x0000 in R62 and 0x0001 in R63. Then read R60 and R61 alternatively. If only every second value is to be read, enter the value 0x0002 in R63.
Envelope monitoring
Each recording can be monitored with a tight or a wide interval. The tight interval is subsequently referred to as inner envelope curve, the wide interval as outer envelope curve.
Application sample:
▪
Monitoring of an ageing process via the inner envelope curve
▪
Monitoring of malfunctions via the outer envelope curve
A reference curve can be placed in the flash memory of the terminal, which is copied to the RAM after a terminal reset.
If evaluation of the inner or outer error counter is activated, i.e. if the index register for process data (R38 or R39) contains the value 18 or 19, the difference between the respective actual value and the target value is compared with parameter x of the envelope curve (R53, R54). If the difference is greater, the respective counter is incremented.
The RAM area can be overwritten with current trace data (Teach-in) via the command register (R7) using the instruction WriteEnvCurvToRAM (0x0201), or it can be directly written and read from offset 0x8000. The command WriteEnvCurvToFLASH (0x0202) can then be used to place data in the flash memory, and are retained even if the voltage supply fails.
Additional information
•
Process image
•
RAM and ROM register


Process image

Access from the user program [image] Process image
Process image
Additional information
•
Process image of the KL3361
•
Process image of the KL3362
•
Control and status bytes


Process image of the KL3361

Access from the user program [image] Process image [image] Process image of the KL3361
Process image of the KL3361
The following 5 bytes are transferred bi-directionally between KL3361 and control:
Oscilloscope channel | Byte offset (without word alignment*) | Byte offset (with word alignment*) | Format | Input data | Output data
1 | 0 | 0 | Byte | Status byte 1 (SB1) | Control byte 1 (CB1)
 | 1 | 2 | Word | DataIN0 | DataOUT0
 | 3 | 4 | Word | DataIN1 | DataOUT1
*) Word alignment: The Bus Coupler places values on even byte addresses
Analog voltages are represented by the oscilloscope terminal KL3361 as follows:
Voltage | Decimal | Hexadecimal
+20 mV | 32767 | 0x7FFF
0 mV | 0 | 0x0000
-20 mV | -32767 | 0x8001


Process image of the KL3362

Access from the user program [image] Process image [image] Process image of the KL3362
Process image of the KL3362
The following 10 bytes are transferred bi-directionally between KL3362 and control:
Oscilloscope channel | Byte offset (without word alignment*) | Byte offset (with word alignment*) | Format | Input data | Output data
1 | 0 | 0 | Byte | Status byte 1 (SB1) | Control byte 1 (CB1)
 | 1 | 2 | Word | DataIN0 (channel 1) | DataOUT0 (channel 1)
 | 3 | 4 | Word | DataIN1 (channel 1) | DataOUT1 (channel 1)
2 | 5 | 8 | Byte | Status byte 2 (SB2) | Control byte 2 (CB2)
 | 6 | 10 | Word | DataIN0 (channel 2) | DataOUT0 (channel 2)
 | 8 | 12 | Word | DataIN1 (channel 2) | DataOUT1 (channel 2)
*) Word alignment: The Bus Coupler places values on even byte addresses
Analog voltages are represented by the oscilloscope terminal KL3362 as follows:
Voltage | Decimal | Hexadecimal
+10 V | 32767 | 0x7FFF
0 V | 0 | 0x0000
-10 V | -32767 | 0x8001


Control and status bytes

Access from the user program [image] Process image [image] Control and status bytes
Control and status bytes
Additional information
•
First channel
•
Second channel (KL3362 only)


First channel

Access from the user program [image] Process image [image] Control and status bytes [image] First channel
First channel
Additional information
•
Process data mode
•
Register communication


Process data mode

Access from the user program [image] Process image [image] Control and status bytes [image] First channel [image] Process data mode
Process data mode
Control byte 1 (CB1) in process data mode
The control byte of the first channel can be found in the output image of the oscilloscope terminal and is transferred from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | bRegAccess | - | - | - | bSetDigitalOut | bEnabIntFkt | bEvalBuffer | bEnableTrigger
Legend
Bit
Name
Description
CB1.7
bRegAccess
0bin
Register communication off (process data mode):
▪
Process data word DataIN0 is used to transfer the date specified with index register 1 for input data (R38)* from the terminal to the control.
▪
Process data word DataIN1 is used to transfer the date specified with index register 2 for input data (R39)* from the terminal to the control.
▪
Process data word DataOUT0 is used to transfer the parameter specified with the Low byte of the index register for output data (R37)* from the control to the terminal.
▪
Process data word DataOUT1 is used to transfer the parameter specified with the High byte of the index register for output data (R37)* from the control to the terminal.
*) These registers can be set via the register communication or with the KS2000 configuration software.
CB1.6
-
reserved
CB1.5
-
reserved
CB1.4
-
reserved
CB1.3
bSetDigitalOut
Setting the digital output.
CB1.2
bEnabIntFkt
Enabling direct setting of the digital output through the trigger unit:
0bin
The trigger unit must not set the digital output when triggered (default).
1bin
The trigger unit may set the digital output directly when triggered (SET DOUT).
CB1.1
bEvalBuffer
The recorded memory is to be evaluated.
CB1.0
bEnableTrigger
The rising edge of this bit activates the trigger in trigger mode Shot.
Status byte 1 (SB1) in process data mode
The status byte of the first channel can be found in the input image of the oscilloscope terminal and is transferred from the terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | bRegAccessQ | bError | - | - | bDigitalOutputStatus | bExtTriggerInput | bEvalBufferDone | bTriggerDone
Legend
Bit | Name | Description
SB1.7 | bRegAccessQ | 0bin | Process data mode acknowledgement
SB1.6 | bError | 0bin | No error
 |  | 1bin | An error has occurred
SB1.5 | - | reserved
SB1.4 | - | reserved
SB1.3 | bDigitalOutputStatus | State of the digital output
SB1.2 | bExtTriggerInput | State of the trigger input
SB1.1 | bEvalBufferDone | Evaluation of the memory is complete. There are valid current process data present.
SB1.0 | bTriggerDone | Acknowledgement for trigger event, values were recorded.


Register communication

Access from the user program [image] Process image [image] Control and status bytes [image] First channel [image] Register communication
Register communication
Control byte 1 (CB1) in register communication
The control byte of the first channel can be found in the output image of the oscilloscope terminal and is transferred from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | bRegAccess | R/W | Register number
Legend
Bit
Name
Description
CB1.7
bRegAccess
1bin
Register communication switched on.
CB1.6
R/W
0bin
Read access:
▪
The process data word DataIN0 is used to read the register specified with the register number (CB1.5-CB1.0).
▪
The process data word DataIN1 is not used for register communication and is not available for process data during register communication. See note below!
1bin
Write access:
▪
The process data word DataOUT0 is used to write the register specified with the register number (CB1.5-CB1.0).
▪
The process data word DataOUT1 is not used for register communication and is not available for process data during register communication.
CB1.5-CB1.0
Register number
Number of the register that is to be read or written.
SmallWarningYellow CAUTION
Invalid process data!
Process data that may still be displayed is not valid!
Status byte 1 (SB1) in register communication
The status byte of the first channel can be found in the input image of the oscilloscope terminal and is transferred from the terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | bRegAccessQ | R | Register number
Legend
Bit | Name | Description
SB1.7 | bRegAccessQ | 1bin | Register access acknowledgement
SB1.6 | R | 0bin | Read access
SB1.5-SB1.0 | Register number | Number of the register that was read or written.


Second channel (KL3362 only)

Access from the user program [image] Process image [image] Control and status bytes [image] Second channel (KL3362 only)
Second channel (KL3362 only)
Additional information
•
Process data mode
•
Register communication


Process data mode

Access from the user program [image] Process image [image] Control and status bytes [image] Second channel (KL3362 only) [image] Process data mode
Process data mode
Control byte 2 (CB2) in process data mode
The control byte of the second channel currently has no function in process data mode.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccess | - | - | - | - | - | - | -
Legend
Bit | Name | Description
SB2.7 | bRegAccess | 0bin | Register communication off (process data mode)
SB2.6-SB2.0 | - | reserved
Status byte 2 (SB2) in process data mode
The status byte of the second channel currently has no function in process data mode.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccessQ | - | - | - | - | - | - | -
Legend
Bit | Name | Description
SB2.7 | bRegAccessQ | 0bin | Process data mode acknowledgement
SB2.6-SB2.0 | - | reserved


Register communication

Access from the user program [image] Process image [image] Control and status bytes [image] Second channel (KL3362 only) [image] Register communication
Register communication
Control byte 2 (CB2) in register communication
The control byte of the second channel can be found in the output image of the oscilloscope terminal and is transferred from the controller to the terminal.
Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | bRegAccess | R/W | Register number
Legend
Bit
Name
Description
CB2.7
bRegAccess
1bin
Register communication switched on.
CB2.6
R/W
0bin
Read access:
▪
The process data word DataIN2 is used to read the register specified with the register number (CB2.5-CB2.0).
▪
The process data word DataIN3 is not used for register communication and is not available for process data during register communication. See note!
1bin
Write access:
▪
The process data word DataOUT2 is used to write the register specified with the register number (CB2.5-CB2.0).
▪
The process data word DataOUT3 is not used for register communication and is not available for process data during register communication.
CB2.5-CB2.0
Register number
Number of the register that is to be read or written.
SmallWarningYellow CAUTION
Invalid process data!
Process data that may still be displayed is not valid!
Status byte 2 (SB2) in register communication
The status byte of the second channel can be found in the input image of the oscilloscope terminal and is transferred from the terminal to the controller.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | bRegAccessQ | R | Register number
Legend
Bit | Name | Description
SB2.7 | bRegAccessQ | 1bin | Register access acknowledgement
SB2.6 | R | 0bin | Read access
SB2.5-SB2.0 | Register number | Number of the register that was read or written.


RAM and ROM register

Access from the user program [image] RAM and ROM register
RAM and ROM register
Additional information
•
Register overview
•
Register description
•
Examples of Register Communication


Register overview

Access from the user program [image] RAM and ROM register [image] Register overview
Register overview
The following registers exist for each signal channel of the oscilloscope terminal. This means these registers exist
▪
once on the KL3601.
▪
twice on the KL3602.
Register | Comment | Default value |  | R/W | Memory
R0 | Raw value of the A/D converter | - | - | R | RAM
R1 - R5 | reserved | 0x0000 | 0dec | R | RAM
R6 | Diagnostic register | - | - | R | RAM
R7 | Command register | 0x0000 | 0dec | R/W | RAM
R8 | Terminal description | KL3361: 0x0D21 KL3362: 0x0D22 | KL3361: 3361dec KL3362: 3362dec | R | ROM
R9 | Firmware version | e.g. 0x3143 | e.g. 12611dec | R | ROM
R10 | Multiplex shift register | KL3361: 0x0128 KL3362: 0x0228 | KL3361: 296dec KL3362: 552dec | R | ROM
R11 | Signal channels | KL3362: 0x0128 KL3362: 0x0228 | KL3361: 296dec KL3362: 552dec | R | ROM
R12 | Minimum data length | 0x2828 | 10280dec | R | ROM
R13 | Data structure | 0x0004 | 4dec | R | ROM
R14 | reserved | 0x0000 | 0dec | R | ROM
R15 | Alignment register | - | - | R/W | RAM
R16 | Hardware version number | e.g. 0x0000 | e.g. 0dec | R/W | SEEROM/RAM
R17 | Hardware compensation: Offset | typically 0x1FFF | typically 8191dec | R/W | SEEROM/RAM
R18 | Hardware compensation: Gain | typically 0x1000 | typically 4096dec | R/W | SEEROM/RAM
R19 | Manufacturer scaling: Offset | typically 0x0000 | typically 0dec | R/W | SEEROM/RAM
R20 | Manufacturer scaling: Gain | typically 0x0100 | typically 256dec | R/W | SEEROM/RAM
R21 - R30 | reserved | - | - | R/W | SEEROM/RAM
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0000 | 0dec | R/W | SEEROM/RAM
R33 | User offset | 0x0000 | 0dec | R/W | SEEROM/RAM
R34 | User gain | 0x0100 | 256dec | R/W | SEEROM/RAM
R35 | Sample rate | 0x00C8 | 200dec | R/W | SEEROM/RAM
R36 | Sample amount | 0x0064 | 100dec | R/W | SEEROM/RAM
R37 | Index register for output data | 0x0000 | 0dec | R/W | SEEROM/RAM
R38 | Index register 1 for input data | 0x0000 | 0dec | R/W | SEEROM/RAM
R39 | Index register 2 for input data | 0x8010 | 32784dec | R/W | SEEROM/RAM
R40 | Trigger unit 1, trigger logic | 0x0D21 | 3361dec | R/W | SEEROM/RAM
R41 | Trigger unit 1, threshold value 1 | 0x03E8 | 1000dec | R/W | SEEROM/RAM
R42 | Trigger unit 1, threshold value 2 | 0x03E8 | 1000dec | R/W | SEEROM/RAM
R43 | Trigger unit 1, pulse width | 0x0064 | 100dec | R/W | SEEROM/RAM
R44 | Trigger unit 1, valid trigger time | 0x0064 | 100dec | R/W | SEEROM/RAM
R45 | reserved | - | - | R/W | SEEROM/RAM
R46 | Trigger unit 2, trigger logic | 0x0D21 | 3361dec | R/W | SEEROM/RAM
R47 | Trigger unit 2, threshold value 1 | 0x03E8 | 1000dec | R/W | SEEROM/RAM
R48 | Trigger unit 2, threshold value 2 | 0x03E8 | 1000dec | R/W | SEEROM/RAM
R49 | Trigger unit 2, pulse width | 0x0064 | 100dec | R/W | SEEROM/RAM
R50 | Trigger unit 2, valid trigger time | 0x0064 | 100dec | R/W | SEEROM/RAM
R51 | reserved | - | - | R/W | SEEROM/RAM
R52 | Trigger delay | 0x0000 | 0dec | R/W | SEEROM/RAM
R53 | Parameter 1 envelope curve | 0x0000 | 0dec | R/W | SEEROM/RAM
Register | Comment | Default value |  | R/W | Memory
R54 | Parameter 2 envelope curve | 0x0000 | 0dec | R/W | SEEROM/RAM
R55 | Samples envelope curve | 0x0000 | 0dec | R/W | SEEROM/RAM
R56 | Trigger frequency | 0x0000 | 0dec | R/W | SEEROM/RAM
R57 - R59 | reserved | - | - | R/W | SEEROM/RAM
R60 | Trace data register 1 | 0x0000 | 0dec | R/W | RAM
R61 | Trace data register 2 | 0x0000 | 0dec | R/W | RAM
R62 | Trace index register | 0x0000 | 0dec | R/W | RAM
R63 | Zoom register | 0x0000 | 0dec | R/W | RAM


Register description

Access from the user program [image] RAM and ROM register [image] Register description
Register description
The following registers exist for each signal channel of the oscilloscope terminal. This means these registers exist
▪
once on the single-channel KL3361;
▪
twice on the two-channel KL3362.
R0: Raw ADC value
Raw value of the analog/digital converter.
R6: Diagnostic register
In a later firmware version, the diagnostic register will be used to provide diagnostic information about the state of the oscilloscope terminal.
R7: Command register
This register can be used to transfer commands to the oscilloscope terminal.
Commands
Command 0x0201: WriteEnvCurvToRAM
Writes the sampling values into the RAM envelope curve (Teach-in method).
Return value: 0x201
Command 0x0202: WriteEnvCurvToFLASH
Writes the sampling values into the RAM envelope curve and the flash envelope curve (Teach-in method).
Return value: 0x202
ROM register
The terminal uses two channels for assigning a byte/word/word data structure. This structure is not supported by couplers that do not have the BK200 switch functionality. In this case, read access to the second register set is not available.
The terminal always reports with a shift register length of 5 bytes (see general terminal documentation).
R8: Terminal description
Register R8 contains the terminal identifier in hexadecimal coding:
KL3361: 0x0D21 (3361dec)
KL3362: 0x0D22 (3362dec)
R9: Firmware version
Register R9 contains the firmware revision level of the terminal in hexadecimal coding, e. g. 0x3144 (12612dec).
R10: Shift register length
KL3361: 0x0128
KL3362: 0x0228
R11: Number of signal channels
KL3361: 0x0128
KL3362: 0x0228
R12: Minimum data length
KL3361: 0x2828
KL3362: 0x2828
R13: Data type
Register R13 contains the data type of the Bus Terminal. 0x0004 means analog input.
R15: Alignment register
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal in hexadecimal coding, e.g. 0x0000 (0dec).
User register
The user registers of the oscilloscope terminal can be written by the user program in order to change the characteristics of the oscilloscope terminal at run-time.
R31: Code word register
▪
If you write values into the user registers without previously having entered the user code word (0x1235) in the code word register, these values are only stored in the RAM registers, but not in the EPROM registers and are therefore lost if the terminal is restarted.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the EPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's operating mode.
Bit
Operation mode
Value
Explanation
Default
R32.15
-
-
reserved
0bin
...
-
-
reserved
0bin
R32.11
-
-
reserved
0bin
R32.10
R32.9
R32.8
Trigger type
000bin
Post-trigger. Recording commences as soon as a trigger event occurs.
000bin
001bin
Pre-trigger. Recording ceases as soon as a trigger event occurs.
010bin
Mid-trigger: The trigger event is the center of the recording.
011bin
FastSampling (from firmware version 1B'): Operation with increased sampling rate of up to 10 µs.
▪
The recording can only be started via the trigger input.
▪
The settings of the trigger units are not taken into account.
▪
Only the first channel is recorded, even for KL3362.
R32.7
-
-
reserved
0bin
R32.6
Auto trigger
0bin
not active
0bin
1bin
active: The trigger unit is automatically activated once the preceding event has been evaluated. To this end, bit 0 is toggled in status byte 1 (SB1) with each new evaluation.
R32.5
Test mode
0bin
not active
0bin
1bin
active: The oscilloscope terminal simulates a ramp of sampling values. The sampling value is incremented after each reading. The ramp thus runs from 0x0000 to 0x3FFF. From 0x3FFF, the sampling value after each reading is decremented, so that the ramp returns to 0x0000. The process is repeated cyclically.
R32.4
Trigger delay
0bin
not active
0bin
1bin
active: Samples skipped after the trigger event. The number of samples that are skipped is specified in the Trigger delay register (R52).
R32.3
-
-
reserved
0bin
...
-
-
reserved
0bin
R32.0
-
-
reserved
0bin
R33: User offset
Offset, can be changed by the user. Scaling:
offset = full scale value x parameter / resolution
Sample for KL3361: 16 mV x 100 / 32767 = 0,049 mV
R34: User gain
Gain factor, can be changed by the user.
R35: Sample rate
Interval (Ts) between two samples (scans) in microseconds.
The sampling speed is limited to Ts =100 µs (10 kHz) by the evaluation of the trigger detectors.
Only the Fast sampling mode enables sampling at Ts =10 µs (100 kHz).
Data transfer rate on the K-bus
The sample rate influences the transmission speed with which the oscilloscope terminal can be addressed by the K-Bus.
This must be taken into account when considering your PLC cycle time:
•
A sample rate of 100 µs can only accommodate bus cycles with a minimum duration of 3 ms!
•
A sample rate of 150 µs can only accommodate bus cycles with a minimum duration of 2 ms!
•
The Fast sampling mode can only accommodate K-bus cycles with a minimum duration of 2 ms!
R36: Sample amount
Number of sampling values to be recorded. A maximum of 4,000 values can be recorded (default 100).
R37: Index register for output data (terminal parameters)
▪
Low byte:
The content of the Low byte of this register determines which parameter of the oscilloscope terminal
–
KL3361 is assigned process data register DataOUT0
–
KL3362 is assigned process data register DataOUT0 (channel 1) or process data register DataOUT0 (channel 2)
is described. The decimal value of the indices corresponds to the register number of the parameter to be written.
The following indices are supported:
Index | Decimal | Parameter
0x00 | 00 | Default value
0x29 | 41 | Trigger unit 1, switching threshold 1
0x2A | 42 | Trigger unit 1, switching threshold 2
0x2B | 43 | Trigger unit 1, pulse width
0x2C | 44 | Trigger unit 1, valid trigger time
0x2F | 47 | Trigger unit 2, switching threshold 1
0x30 | 48 | Trigger unit 2, switching threshold 2
0x31 | 49 | Trigger unit 2, pulse width
0x32 | 50 | Trigger unit 2, valid trigger time
▪
High byte:
The content of the High byte of this register determines which parameter of the oscilloscope terminal
–
KL3361 is assigned process data register DataOUT1
–
KL3362 is assigned process data register DataOUT1 (channel 1) or process data register DataOUT1 (channel 2)
is described (see Low byte for indices).
R38: Index register 1 for input data
The content of this register (default value: 0x0000) determines which date is shown in the process data register
▪
DataIN0 of oscilloscope terminal KL3361
▪
DataIN0 (channel 1) or DataIN0 (channel 2) of oscilloscope terminal KL3362
The following indices are supported:
Index
Decimal
Date
0x0000
0
Current analog value
0x0001
1
Maximum value of a recording
0x0002
2
Minimum value of a recording
0x0003
3
RMS value of the recording: Sqrt((Sum (xn2))/n
0x0004
4
Mean value of the recording: (Sum (xn))/n
0x0005
5
Peak-peak value of the recording
0x0006
6
Cycle duration
0x0007
7
Pulse width - high: switching threshold is trigger level 1
▪
The trigger starts as soon as four successive values are above the switching threshold
▪
The trigger is stopped as soon as four successive values are below the switching threshold
0x0008
8
Pulse width - low: switching threshold is trigger level 1
▪
The trigger starts as soon as four successive values are below the switching threshold
▪
The trigger is stopped as soon as four successive values are above the switching threshold
0x0009
9
Duty factor
0x000A
10
reserved for jitter Tmax
0x000B
11
reserved for jitter Tmin
0x000C
12
reserved for jitter Tmean
0x000D
13
Histogram max, i.e. the value that has occurred most frequently.
0x000E
14
Timer1LatchValue
0x000F
15
Timer1Run (read/write)
0x0010
16
Timer2LatchValue
0x0011
17
Timer2Run (read/write)
0x0012
18
Error counter inner envelope curve
0x0013
19
Error counter outer envelope curve
0x0014
20
Number of samples up to analog value greater than switching threshold 1
0x0015
21
Number of samples up to analog value less than switching threshold 1
0x8000
First sampling value.
The recorded sampling values are available from here. The MSB has to be set to zero in order to determine the trace offset.
0x8001
Second sampling value.
0x8002
Third sampling value.
...
...
...
0x8063
Hundredth sampling value (in the delivery state, 100 values are stored).
...
...
...
0x8F9F
Four thousandth sampling value (a maximum of 4,000 values can be stored).
R39: Index register 2 for input data
The content of this register (default value: 0x8010) determines which date is shown in the process data register
▪
DataIN1 of oscilloscope terminal KL3361
▪
DataIN1 (channel 1) or DataIN1 (channel 2) of oscilloscope terminal KL3362
(see Index register 1 for process input data for indices).
R40: Trigger unit 1, trigger logic
Bit
Operation mode
Value
Explanation
Default
R40.15
-
-
reserved
0bin
R40.14,
R40.13,
R40.12
enableSource
000bin
Trigger always enabled
000bin
001bin
Trigger activated, if signal at analog input 1 above switching threshold 2
Analog input 1 is in
▪
KL3361: the input for differential voltage of the measuring bridge in KL3361 (UB+/UB-)
▪
KL3362: oscilloscope input channel 1 (IN 1)
010bin
Trigger activated, if signal at analog input 1 below switching threshold 2
011bin
Trigger activated, if signal at analog input 2 above switching threshold 2
Analog input 2 is in
▪
KL3361 not available
▪
KL3362: oscilloscope input channel 2 (IN 2)
100bin
Trigger activated, if signal at analog input 1 below switching threshold 2
101bin
Trigger enabled if trigger input (24 V trigger) on high potential.
110bin
Trigger enabled if trigger input (24 V trigger) on low potential.
R40.11,
R40.10
TriggerSource
00bin
Timer with switching threshold 1
11bin
01bin
first analog input (IN1), with switching threshold 1
10bin
second analog input (IN2), with switching threshold 1 (KL3362 only)
11bin
Digital input
R40.9,
R40.8
Trigger mode
00bin
Shot: The trigger is activated with an edge of bit bEnableTrigger of control byte 1 (CB1.0), if enableSource is set.
01bin
01bin
Edge: The trigger is triggered via the edge selected via TriggerSource and bLogic, if it is enabled via enableSource.
10bin
Glitch: The trigger is triggered via the pulse selected via TriggerSource, bLogic and bLarger, if it is enabled via enableSource.
R40.7
-
-
reserved
0bin
R40.6
bTriggerWinEn
1bin
The trigger condition for the following trigger unit must arrive within the valid trigger time for trigger unit 1. Otherwise everything is reset
0bin
R40.5
bStartScopeRec
0bin
The trigger event causes the downstream trigger unit to be enabled
0bin
1bin
The trigger event causes the recording to be started
R40.4
bTriggerOutEn
1bin
The trigger event causes the digital output to be set, if this is enabled through bit 2 of control byte 1 (CB1.2).
0bin
R40.3
bLatchtimer
1bin
The trigger event causes the current value of the running timer to be stored.
0bin
R40.2
bResetTimer
1bin
The trigger event causes the timer to be reset to zero. The timer will start running again automatically immediately.
0bin
R40.1
bLarger
0bin
in glitch mode: pulse width less than the pulse width specified for trigger unit 1
0bin
1bin
in glitch mode: pulse width greater than the pulse width specified for trigger unit 1
R40.0
bLogic
0bin
in edge mode (edge triggering): falling edge
in glitch mode: negative pulse
1bin
1bin
in edge mode (edge triggering): rising edge
in glitch mode: positive pulse
R41: Trigger unit 1, switching threshold 1
Switching threshold for the trigger source of trigger unit 1
R42: Trigger unit 1, switching threshold 2
Switching threshold for enabling the trigger (EnableSource) of trigger unit 1
R43: Trigger unit 1, pulse width
Here you can specify the pulse width (tP) of trigger unit 1 for the glitch mode. The number of samples (nSP) is entered as the parameter. The pulse width thus depends on the sample rate! Sample:
▪
Sample rate: Ts = 200 µs
▪
Samples: nSP = 100
Pulse width: tP = Ts x nSP = 200 µs x 100 = 20 ms
R44: Trigger unit 1, valid trigger time
Here you can specify the valid trigger time (tVT) for trigger unit 1. The number of valid samples (nVS) is entered as the parameter. The valid trigger time thus depends on the sample rate! Sample:
▪
Sample rate: Ts = 200 µs
▪
Valid samples: nVS=100
Valid Trigger Time: tVT = Ts x nVS =200 µs x 100 = 20 ms
R46: Trigger unit 2, trigger logic
see Trigger detector 1
R47: Trigger unit 2, switching threshold 1
Switching threshold for the trigger source (TriggerSource) of trigger unit 2
R48: Trigger unit 2, switching threshold 2
Switching threshold for enabling the trigger (EnableSource) of trigger unit 2
R49: Trigger unit 2, pulse width
Here you can specify the pulse width (tP) of trigger unit 2 for the glitch mode (see Trigger unit 1, pulse width).
R50: Trigger unit 2, valid trigger time
see Trigger unit 1, valid trigger time
R52: Trigger delay
A trigger delay (tTD) can be specified here. The number of skipped samples (nSTD) is entered as the parameter. The trigger delay thus depends on the sample rate! Sample: - Sample Rate: Ts = 200 µs, - Skipped Samples: nSTD=100
tTD = Ts x nSTD = 200 µs x 100 = 20 ms
R53: Parameter 1 envelope curve
e.g. distance of the inner envelope curve
After the trace recording, the envelope curve is evaluated.
R54: Parameter 2 envelope curve
e.g. distance of the outer envelope curve
After the trace recording, the envelope curve is evaluated.
R55: Samples envelope curve
Number of samples to be evaluated (512 max.).
R56: Trigger frequency
Frequency of the timer that can be used for triggering.
R60: Trace data register 1
Contains the sampling value from the register specified in the trace index register (R62).
After the end of the read access (change of register address), the trace index (R62) is incremented by the zoom distance nZ (see R63).
R61: Trace data register 2
Contains the sampling value from the register following the register specified in the trace index register (R62).
After the end of the read access (change of register address), the trace index (R62) is incremented by the zoom distance nZ (see R63).
R62: Trace index register
Writing: Sets the trace index to offset
Reading: Current value of the trace index.
The index is reset to zero at the start of a recording.
Offset zero to 0x3FFF contains the trace data.
From 0x8000, the envelope curve is given
R63: Zoom register
With the zoom register you can specify that
▪
only certain values or
▪
pre-processed values (maximum value , minimum value or arithmetic mean value)
are transferred to the control.
Bit | Name | Value | Explanation | Default
R63.15 R63.14 | Zoom mode | 00bin | Sample zoom - the trace index register is increased automatically after each reading by the zoom distance nZ. Therefore, only every nZth value is read. | -
 |  | 01bin | Max zoom - the highest of the read values is output
 |  | 10bin | Min zoom - the lowest of the read values is output
 |  | 11bin | Mean value zoom - the arithmetic mean of the read values is output
R63.13 R63.12 | - | - | reserved | -
R63.11 ... R63.0 | Zoom distance nZ | Number nZ of sampling values, by which the trace index register (R62) is increased in zoom mode Sample zoom after each reading. Samples: |  | -
 |  | 0x000 | The same value is always read.
 |  | 0x001 | All values are read.
 |  | 0x002 | Only every second value is read.
 |  | 0x00A | Only every tenth value is read.


Examples of Register Communication

Access from the user program [image] RAM and ROM register [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] RAM and ROM register [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] RAM and ROM register [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com