KL3356 - Accurate Terminal for Resistance Bridge
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.3.0
▪
Example program added to chapter “KS2000 Configuration software“
▪
Design of the safety instructions adapted to IEC 82079-1
2.2.0
▪
Chapter “Basic Function Principles” updated
2.1.0
▪
Technical data updated
2.0.0
▪
Migration
1.5.0
▪
Description of process image and mapping updated
▪
Register description updated and corrected
1.4
▪
Register description updated
▪
Installation instructions revised
1.3
▪
LED description adapted to redesign with new LED prism (8 LEDs in use)
▪
Register description corrected and extended
▪
Firmware and hardware versions updated
1.2
▪
Images adapted to redesign with LED prism (4 LEDs in use)
▪
Technical data updated
1.1
▪
Description of process data, control and status bytes revised
▪
Calibration stabilization added
▪
Wiring description (power contacts) updated and example added
▪
User calibration added
▪
Description of the KL3356 parameterization with the KS2000 software updated
1.0
▪
Technical data updated
▪
Basic function principles revised
▪
English translation available
0.4
▪
Register descriptions extended
0.3
▪
Technical data updated
▪
Description of KL3356 parameterization via KS2000 software added
▪
Register description extended
0.2
▪
Technical data added
▪
Examples for register communication added
▪
Information on installation and connection added
0.1
First preliminary version
Firmware and hardware versions
Documentation Version | KL3356, KS3356
 | Firmware | Hardware
2.3.0 | 2D | 06
2.2.0 | 2D | 06
2.1.0 | 2D | 06
2.0.0 | 2D | 06
1.5.0 | 2D | 05
1.4 | 2B | 03
1.3 | 2B | 02
1.2 | 2A | 01
1.1 | 1F | 00
1.0 | 1A | 00
0.4 | 1A | 00
0.3 | 1A | 00
0.2 | 1A | 00
0.1 | 1A | 00
The firmware and hardware versions (delivery state) can be found in the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year
FF - firmware version
HH - hardware version
Example with ser. no.: 35 04 1A 00:
35 - week of production 35
04 - year of production 2004
1A - firmware version 1A
00 - hardware version 00


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Basic function principles
•
LEDs


Introduction

Product overview [image] Introduction
Introduction
KL3356
The KL3356 analog input terminal permits direct connection of a resistance bridge. An improved input circuit makes the KL3356 significantly more accurate than the KL3351. The ratio between the bridge voltage UD and the supply voltage Uref is determined in the input circuit. In order to achieve good long-term stability, the complete circuit is re-calibrated at least every 3 minutes. This procedure can be synchronized by the control in order to prevent the calibration leading to a delay in the production process.


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL3356/KS3356
Inputs | 2, for one resistor bridge
Signal voltage UD | -20 mV ... +20 mV
Input resistance (UD) | >1 MΩ
Supply voltage for the measuring bridge (UV) | 5 V ... 12 V (recommended)
Reference voltage URef | max. 12 V
Input resistance (Uref) | > 200 kΩ
Resolution | 16 bits
Conversion time | < 250 ms, configurable
Measuring error (total measuring range) | ±0.01% of the full scale value, self-calibration
Bit width in the K-bus I/O | 2 x 16 bit user data, 2 x 8 bit control/status
Bit width in the input process image | 2 data words, 2 status byte
Bit width in the output process image | 2 data words, 2 control byte
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 85 mA
Weight | approx. 75 g
Dimensions (W x H x D) | approx. 15 mm x 100mm x 70mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Pluggable wiring | at all KSxxxx series terminals
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6/EN 60068-2-27, see also Installation instructions for enhanced mechanical load capacity
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


Basic function principles

Product overview [image] Basic function principles
Basic function principles
The KL3356 Analog Input Terminal is used to acquire the supply voltage to a load cell as a reference voltage, and simultaneously the differential voltage that is proportional to the force acting on the cell. The reference and the differential voltages are measured alternately by the same converter. The quotient of the differential and the reference voltages corresponds to the force that is acting on the load cell. Deviations in the analog input stages (temperature drift, long-term drift etc.) are checked by regular calibration, and compensated to bring the measurement within the permitted tolerance range.
Strain gauge measuring signal
The strain gauge measuring signal is acquired at fixed intervals with a resolution of 16 bits (+ sign). This value is saved as a data word, without sign, in register R2. The sign is represented in bit SW.0 of the status word.
The length of the sampling interval is directly determined by the filter constant in register R37.
Strain gauge reference signal
The strain gauge reference signal is also acquired with a resolution of 16 bits (+ sign) at longer intervals. This value is saved as a data word, without sign, in register R3. The sign is represented in bit SW.1 of the status word.
The length of the sampling interval is defined, in multiples of 100 ms, in register R39.
Calculating the weight
Every time the analog signal is acquired, the weight that it indicates is calculated. This is composed of the ratio between the measuring signal and the reference signal, and of a number of calibrations:
YR = (UDiff / URef) x (Emax / Cn) x 1000 / 500 | (1.0) | Calculation of the raw weight value
YS = YR x AS | (1.1) | Scale factor
YH = YS x AH + BH | (1.2) | Manufacturer scaling
YOUT = YH x AA + BA | (1.3.0) | User scaling (if R32.10=0bin)
YOUT = (YH + BA) x AA | (1.3.1) | User calibration (if R32.10=1bin)
Key
Name | Name | Unit | Register
UDiff | Measuring signal from the load cell | [1] | R2
URef | Reference signal from the load cell | [1] | R3
Emax | Nominal weight of the load cell | [1 kg] | R35
Cn | Nominal parameter of the load cell | [1 mV / V] | R36
AS | Scale factor (can be activated via bit R32.8 of the feature register) | [1] | R38
BH | Offset of the manufacturer scaling (can be activated via bit R32.1 of the feature register) | [1] | R19
AH | Gain of the manufacturer scaling (can be activated via bit R32.1 of the feature register) | [1] | R20
BA | Offset of the user's scaling (can be activated via bit R32.0 of the feature register) | [1] | R33
AA | Gain of the user's scaling (can be activated via bit R32.0 of the feature register) | [1] | R34
The factor of 1000 in formula 1.0 results from normalizing the units of the nominal weight [kg] and the nominal parameter [mV/V]. The factor 1/500 is specified through a voltage divider. The result is written into the terminal's process image with a resolution of 16 bits (+ sign). This value is saved as a data word, without sign, in register R1. The sign is represented in bit SB1.0 of the status byte.
Operation modes
The KL3356 provides different operation modes:
Operation mode | Comment
Normal operation | Measuring the force acting on the load cell
Zero calibration | The DC voltage potential at the inputs to the operational amplifier corresponds to that of normal operation. The differential voltage at the two operational amplifier inputs is 0 mV (determination of the zero points).
Final calibration | The DC voltage potential at the inputs to the operational amplifier corresponds to that of normal operation. The divided cell supply voltage (R114, R115, R151) is applied as a differential signal to both the operational amplifier inputs (determination of the amplification factors).
Null-test (0 V) | The DC voltage potential at the operational amplifier inputs is set to 0 V. The differential voltage at the two operational amplifier inputs is 0 mV (first stage in establishing the Common Mode Rejection of the operational amplifiers).
Null-test (2.5 V) | The DC voltage potential at the operational amplifier inputs is set to 2.5 V. The differential voltage at the two operational amplifier inputs is 0 mV (second stage in establishing the Common Mode Rejection of the operational amplifiers).
Reference test | The DC voltage potential at the inputs to the operational amplifier corresponds to that of half the reference voltage. The divided reference voltage (R114, R115, R151) is applied as a differential signal to the two operational amplifier inputs (measurement of the reference voltage).
Switch settings
The various operation modes are selected by means of internal switches:
▪
Switch SW1 is switched by bit R32.7 of the feature register, and is to be closed for all calibration processes:
- R32.7 = 0: SW1 open
- R32.7 = 1: SW1 closed
▪
If manual calibration mode is enabled in the command register R7 you can control switches SW2 to SW8 by means of the output data word RegOUT.
Operation mode | RegOUT | Switch settings
 |  | SW1 | SW2 | SW3 | SW4 | SW5 | SW6 | SW7 | SW8
Normal operation | 0dec | 0 / 1 | 1 | 1 | 0 | 1 | 0 | 1 | 0
Zero calibration | 1dec | 0 / 1 | 0 | 1 | 1 | 0 | 0 | 0 | 0
Final calibration | 2dec | 0 / 1 | 0 | 0 | 1 | 1 | 0 | 1 | 0
Null-test (0 V) | 3dec | 0 / 1 | 0 | 0 | 1 | 0 | 0 | 0 | 1
Null-test (2.5 V) | 4dec | 0 / 1 | 0 | 0 | 1 | 0 | 1 | 0 | 0
Reference test | 5dec | 0 / 1 | 0 | 0 | 1 | 0 | 1 | 0 | 1
Key
0: switch not connected
1: Switch connected
Calibrating the measuring amplifiers
The measuring amplifiers are periodically subjected to examination and calibration. For this purpose a total of eight analog switches are provided in order to be able to connect the various calibration signals. It is important for this process that the entire signal path, including all passive components, is examined at every phase of the calibration. Only the interference suppression elements (L/C combination) and the analog switches themselves cannot be examined.
The calibration interval is set in register R40 in steps of 100 ms. The test interval is specified in register R41 as a multiple of the calibration interval.
▪
In the first phase of the calibration, an input voltage of 0 mV is applied to both analog inputs (zero calibration). The zero points of both analog input stages can be determined in this way. This involves a system offset calibration of the A/D converter. In this measurement, both the respective absolute values and the mutual deviation of the channels are of interest.
▪
An input voltage of approx. 24 mV is applied to both analog inputs in the second phase of the calibration (final calibration). This is derived from the power supply to the load cell. At this point the absolute value of the measurements is no longer an interest, only any possible deviation of the values for the two analog inputs. The gain of the first channel is adjusted here to match that of the second channel. The important point is that the calibrations are carried out using the same DC voltage potential at the inputs to the operational amplifiers, as in a normal measuring operation.
Calibrating the input stages at both working points (the zero point and the final value) allows the straight lines of the two measuring channels to be adjusted to one another so that they are congruent.
Characteristic curves for calibration
If the terminal is carrying out a calibration, bit R0.2 is set in register 0 (the status word).
Testing the measuring amplifiers
In order to be able also to test the function of the analog input circuits and the source of the reference voltage, it is also possible, in addition to the calibration described, to connect the internal reference voltage signal of 2.5 V as the input signal. For this purpose, before measuring the reference voltage itself, a difference voltage signal of 0 V with a DC voltage potential of 0 V is applied. Measurement of the 0 V differential signal combined with a DC voltage potential of 2.5 V is then carried out. With the aid of the measured values resulting from this, the CommonMode effect of the two input stages at an input voltage of 1.25 V can be calculated, and can be taken into account in the subsequent measurement of the reference voltage. When measuring the source of the reference voltage, both operational amplifiers must deliver the same measuring signal, in addition to which it must also be possible to predict the value to within a very tight tolerance. If this tolerance is exceeded, the situation is classified as a hardware defect, and is indicated in bit SW.8 of the status word.
If the terminal is carrying out a test, bit R0.2 is set in register 0 (the status word).
Initiating the calibration or test
The calibration and test procedures are executed by the terminal automatically after the times specified in registers R39 to R41 have elapsed. Bit CB1.1 of the control byte can be used to block the automatic calibration (this command is acknowledged in bit SB1.1 of the status byte) in order to prevent calibration from taking place during a time-critical measurement. So that calibration is not completely suppressed in this way, the KL3356 monitors the calibration cycle, and autonomously starts a forced calibration if the block remains in place for too long. The time after which the terminal will carry out this forced calibration is specified in register R44 as a multiple of register R40. At each measurement, the reference voltage is compared with the contents of register R45 (in units of 1 mV). If it is found to be below this limit, bit R0.14 is set.
If it is necessary to initiate a test manually, it is started by bit CB1.0 of the control byte. Completion of a test is signaled by bit R0.4 in register R0 (the status word). The result of the last test is represented by a difference in the two analog inputs, and can be placed into registers R1 to R3 and R5 by bit CB1.2 of the control byte. Valid calibration data is present if bit R0.5 in register 0 (status word) is set to 1bin. Register write protection can be set by bit CB1.3 to prevent the calibration data from being modified (this is acknowledged by bit SB1.3)
Manual operation
▪
Under some circumstances it may be necessary to observe the values from the A/D converter directly. For this purpose the terminal can be switched to manual operation. To do this, first enter the user code word (1235hex) in the code word register R31 to clear write protection from the user register.
▪
Then enter the value 0401hex into the command register (R7) to switch to manual operation. If you enter the value 0 into register R7, manual operation is halted once more.
In manual operation, the value in the RegOUT output word returns the setting of the input switches (see table of Switch settings). You can use bit CB1.1 of the control byte to switch between OP1 and OP2 (CB1.1=0bin: OP1; CB1.1 =1bin: OP2).
A forced calibration is automatically carried out as soon as you return the terminal to normal operation again.
Error diagnosis
The KL3356 offers internal error diagnosis. The upper 8 bits of register R0 (the status word) indicate errors that have occurred.
So that the user does not have to keep reading register R0, any change in the error bits (if, for instance, a new error has occurred or if an existing error has been cleared) is indicated in bit SB1.6 of status byte 1. All errors that have occurred are temporarily stored, and are not cleared by the terminal on its own account. By setting bit CB1.6 in control byte 1 you can reset error bit SB1.6.
Measured value stabilization
During self-calibration, various signals are switched internally as described above. After the self-calibration has been completed, depending on the setting of R32.9 (stabilization of the calibration), the following behavior occurs:
- Stabilization active (R32.9 = 1): the terminal waits until the signal has stabilized as specified in register R47/R48 and only then outputs measured values to the bus again - this extends the pause until the terminal measures again and can cause the terminal to wait until measurement in the event of an unstable input signal.
- Stabilization inactive (R32.9 = 0): the terminal immediately switches the measuring signal back to the bus - this can lead to a swing-in process being observed in the measured value over several cycles.


LEDs

Product overview [image] LEDs
LEDs
LEDs
LED
Display
Power
(green)
ON
Power supply (5 V) available on the K-bus
OFF
No power supply (5 V) available on the K-bus
K-bus
(green)
ON
Data transmission on the K-bus is active
OFF
Data transmission on the K-bus is not active
Calibr.
(green)
ON
Calibration active
OFF
▪
Test active (if Measure LED not lit) or
▪
Measurement active (if Measure LED is lit)
Measure
(green)
ON
Measurement active (process data are valid)
OFF
▪
Calibration active (if LED Calibr. is lit) or
▪
Test active (if Calibr. LED not lit)
Diff.
(green)
ON
▪
Differential signal is calibrated (if Calibr. LED is lit) or
▪
Differential signal is checked (if LED Calibr. not lit)
Ref.
(green)
ON
▪
Reference signal is calibrated (if Calibr. LED is lit) or
▪
Reference signal is checked (if LED Calibr. not lit)
Err. Diff.
(red)
ON
▪
Channel 1 (strain gauge differential signal) is above the valid range (max. 0xFFFF)
▪
Internal reference voltage for channel 1 is missing
Err. Ref
(red)
ON
▪
Channel 2 (strain gauge reference signal) is above the valid range (max. 0xFFFF)
▪
Internal reference voltage for channel 2 is missing
▪
Channel 2 is less than about 1 V
▪
No communication with the A/D converter.
▪
Actual value from the test is outside the specified tolerance range


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Application example
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding
•
Connection


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Connection

Mounting and wiring [image] Connection [image] Connection
Connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Connection
Terminal point | No. | Connection for
+UD | 1 | Measuring signal
-UD | 2 | Measuring signal
-UV | 3 | Supply voltage, 0 V (from power contact)
Shield | 4 | PE contact
+Uref | 5 | Reference signal
+Uref | 6 | Reference signal
+UV | 7 | Supply voltage, 5 to 12 V (from power contact)
Shield | 8 | PE contact
The supply voltage (UV) for the measuring bridge can be fed by a power supply terminal (e.g. KL9510) into the power contacts and then is also available at terminal points 7 (+UV) and 3 (-UV) of the KL3356 for referencing at terminal points 5 and 6.


Application example

Mounting and wiring [image] Application example
Application example
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Connecting a load cell (e.g. 4 x 350 Ω) to the KL3356.
KL3356 - application example
In the example shown, the KL9510 power supply terminal (10 V) is used to supply the load cell.
Beckhoff offers various power supply terminals for the supply of power to the load cells of an KL3356:
Power supply terminal | Input voltage | Output voltage | Output current
KL9505 | 24 VDC | 5 VDC ±1% | 1.0 A
KL9510 | 24 VDC | 10 VDC ±1% | 0.5 A
KL9512 | 24 VDC | 12 VDC ±1% | 0.5 A


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Settings
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your Fieldbus Coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Ethernet Coupler
▪
a KL1xx2 digital input terminal
▪
a KL3356 accurate terminal for resistance bridge
▪
a KL9010 Bus End Terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of the KL3356
For the KL3356, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL3356.
▪
Under Settings you find dialog masks for parameterizing the KL3356.
▪
ProcData displays the KL3356 process data.


Settings

KS2000 Configuration Software [image] Settings
Settings
Under Settings you find the dialog masks for parameterizing the KL3356.
Settings via KS2000
Operation mode
User scaling active (R32.0)
You can activate user scaling here (default: disabled). Two variants (R32.10) are available for selection:
▪
Scaling (see formula 1.3.0)
▪
Calibration (see formula 1.3.1)
Manufacturer scaling active (R32.1)
You can activate manufacturer scaling here (default: disabled).
Scale factor active (R32.8)
You can deactivate the scale factor here (default: enabled).
Watchdog timer active (R32.2)
You can deactivate the watchdog timer here (default: enabled).
Cyclic calibration enabled (R32.4)
You can deactivate cyclic calibration here (default: enabled).
Cyclic reference measurement enabled (R32.6)
You can deactivate cyclic reference measurement here (default: enabled).
Cyclic test enabled (R32.5)
You can deactivate cyclic testing here (default: enabled).
Symmetric reference potential (R32.7)
You can deactivate the symmetric reference potential here (default: enabled).
Stabilization of calibration active (R32.9)
You can deactivate the stabilization of the calibration here (default: enabled). The stabilization of the calibration can be parameterized via the parameters "number of stable measured values" and "tolerance for measurement stability".
Resolution of nominal parameter 0.01 mV/V (R32.11)
Here you can enable a resolution of nominal parameter of 0.01 mV/V, instead of the resolution of nominal parameter of 1 mV/V (default: disabled).
After calibration wait for stable value (R32.12)
Here you can specify that, after calibration or measurement of the reference voltage, the KL3365 should wait until the weight value output is stable before outputting the measured value (default: disabled).
Register data
Nominal weight (R35)
You can specify the nominal weight of the connected load cell here in kg (default: 5 kg).
Nominal parameter (R36)
You can specify the nominal characteristic value of the connected load cell here (default: 2 mV / V).
Scale factor (R38)
You can specify the scale factor here (default: 1000).
Measure interval for the reference signal (R39)
You can specify the measuring interval for the reference signal here in steps of 100 ms (default: 360 s).
Calibration interval (R40)
You can specify the calibration interval for the reference signal here in steps of 100 ms (default: 180 s).
Forced calibration interval (R44)
You can specify the interval for the forced calibration here. This interval is always a multiple (default: 3dez) of the calibration interval. The interval for forced calibration when the terminal leaves the factory is therefore 3 x 180 s = 540 s.
Test interval (R41)
You can specify the test interval here. This interval is always a multiple (default: 10dez) of the calibration interval. The test interval when the terminal leaves the factory is therefore 10 x 180 s = 1800 s.
Nominal test value (R42)
Here you can specify the nominal test value of the terminal (e.g. 332Chex = 13100dec).
Test tolerance (R43)
You can specify the test tolerance for the terminal here (the default is 50dec).
Threshold reference voltage (R45)
You can specify the limit for the reference voltage test here in steps of one mV (default: 5000 mV). If the reference voltage is found to be below this limit, bit R0.14 is set in the status word.
Threshold correction factor (R46)
Here you can specify the limit value for the correction factor (for gain). A correction factor for the differential signal is determined in the course of calibration. This is derived from the quotient of reference and differential signal. To represent it more clearly, the result is normalized to 10000 (URef / UDiff x 10000), which means that 10000 corresponds to a factor of 1. If the difference between the correction factor and 10000 (10000 - correction factor) is greater than this limit, bit R0.15 is set in the status word.
Number of stable measured values (R47)
Here you can specify the number of measured values for the calibration stabilization that have to be within the set tolerance (R48). The default value is 50.
Tolerance for measurement stability (R48)
Here you can specify the tolerance (in digits) for the calibration stabilization, by which the measured values may be outside the reference value. The default value is 5 digits.
Manual calibration weight (R49)
Here you can specify the reference weight for the manual calibration. The default value is 2000 g.
Filter constant (R37.11-R37.4)
The filter constant SF specifies the 3 dB limit frequency of the sinc3 filter (default: 860dec).
Fast-Step Mode(TM) enabled (R37.0)
You can activate Fast Step Mode here (default: disabled). A fast reaction to jumps at the input follows in fast step mode, in spite of the filter stage being active. In this case the filter is bypassed!
FIR Filter enabled (R37.1)
You can deactivate the FIR filter here (default: enabled).


Sample program for KL register communication via EtherCAT on KL3314 exemplary

KS2000 Configuration Software [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Mapping
•
Control and status bytes
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
In the process image, the KL3356 is always represented with 6 bytes of input data and 6 bytes of output data.
Format | Input data | Output data
Byte | Status byte (SB1) | Control byte (CB1)
Word | DataIN1 | DataOUT1
Byte | Status byte (SB2) | Control byte (CB2)
Word | DataIN2 | DataOUT (this is not used and is not displayed by the TwinCAT System Manager)
▪
The input data word DataIN1 and the output data word DataOUT1 are only used for register communication.
▪
In process data mode, the input data word DataIN2 transmits the weight, and the output data word DataOUT2 is not used.
▪
Please refer to the Mapping page for the assignment of the bytes and words to the addresses of the controller.
▪
The meaning of the control and status bytes is explained in Control and status bytes.
Compact process image not possible
The KL3356 cannot be operated with compact process image (without control and status bytes), since control and status bytes are required for process data mode of the KL3356 to function correctly. Even if your Bus Coupler is set to compact process image, the KL3356 is represented with its complete process image!


Mapping

Access from the user program [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions) such as
–
Intel or Motorola format
–
word alignment switched on or off
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.
Compact evaluation
Compact process image not possible
The KL3356 cannot be operated with compact process image (without control and status bytes), since control and status bytes are required for process data mode of the KL3356 to function correctly. Even if your Bus Coupler is set to compact process image, the KL3356 is represented with its complete process image!
Complete evaluation
For complete evaluation, the analog input terminals occupy addresses in the input and output process image. Control and status bytes can be accessed.
Complete evaluation in Intel format
Default mapping for CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: any Motorola format: no Word alignment: no | 0 | DataIN1 D0 | SB1 | DataOUT1 D0 | CB1
 | 1 | SB2 | DataIN1 D1 | CB2 | DataOUT1 D1
 | 2 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
Complete evaluation in Motorola format
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: any Motorola format: yes Word alignment: no | 0 | DataIN1 D1 | SB1 | DataOUT1 D1 | CB1
 | 1 | SB2 | DataIN1 D0 | CB2 | DataOUT1 D0
 | 2 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Complete evaluation in Intel format with word alignment
Default mapping for Lightbus, EtherCAT and Ethernet coupler as well as Bus Terminal Controllers (BCxxxx, BXxxxx)
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: any Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | DataIN1 D1 | DataIN1 D0 | DataOUT1 D1 | DataOUT1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | DataIN2 D1 | DataIN2 D0 | DataOUT2 D1 | DataOUT2 D0
Complete evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: any Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | DataIN1 D0 | DataIN1 D1 | DataOUT1 D0 | DataOUT1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | DataIN2 D0 | DataIN2 D1 | DataOUT2 D0 | DataOUT2 D1
Key
Complete evaluation: In addition to the process data, the control and status bytes are also mapped in the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: To ensure that the address range of the words always begins on a word boundary, empty bytes are inserted into the process image.
SB n: status byte n (appears in the input process image)
CB n: control byte n (appears in the output process image)
DataIN n D0: input word n, low-order data byte
DataIN n D1: input word n, high-order data byte
DataOUT n D0: output word n, low-order data byte
DataOUT n D1: output word n, high-order data byte
reserved: This byte is assigned to the process data memory, although it is not used.
DataOUT2
The process data word DataOUT2 is not used and is not displayed by the TwinCAT System Manager.


Control and status bytes

Access from the user program [image] Control and status bytes
Control and status bytes
Register communication
Control byte 1 (for register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIN1 or - want to write with output data word DataOUT1.
Status byte 1 (for register communication)
The status byte 1 (SB1) is located in the input image and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Using control and status bytes
In contrast to other types of terminal, the process data provided when using a KL3356 is valid even during register communication!
The KL3356 uses
•
control byte 0 and status byte 0 exclusively for register communication
•
control byte 1 and status byte 1 exclusively for process data mode
Key
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgment for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Process data mode
Control byte 2 (for process data mode)
Control byte 2 (CB2) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB2.7 | CB2.6 | CB2.5 | CB2.4 | CB2.3 | CB2.2 | CB2.1 | CB2.0
Name | - | Quit Error | - | MapCaliCounter | RegLockReq | MapCaliData/ DisableSymm | CaliDisReq/ Channel | StartManCheck/ StartManCali
Key
Bit | Name | Description
CB2.7 | - | 0bin | reserved
CB2.6 | QuitError | 1bin | All errors are cleared
CB2.5 | - | 0bin | reserved
CB2.4 | MapCaliCounter | 0bin | The registers R2, R3 and R5 show the data selected with bit CB2.2.
 |  | 1bin | Registers R2, R3 and R5 show the calibration counters (in addition, bit CB2.3 must be set to 0bin for this purpose). (see note below)
The calibration counters are evaluated by the KL3356
The calibration counters are a measure for the quality of the self-calibration. In standard applications, it is not necessary for the user to evaluate these counters, since the KL3356 evaluates the counters itself and uses bit 0.8 or bit 0.15 of the status word (R0) to report when permitted tolerances have been exceeded.
Bit
Name
Description
CB2.3
RegLockReq
0bin
Register lock not active:
▪
The KL3356 can update the values in registers R1, R2, R3 and R5.
▪
Registers R2, R3 and R5 can be shown by setting bit CB2.4 to 1bin.
1bin
Register lock active:
▪
The KL3356 no longer updates the registers R1, R2, R3 and R5.
▪
Bit CB2.4 is not evaluated!
normal operation
manual operation*
CB2.2
MapCaliData/
DisableSymm
0bin
The measured value registers contain the mapped raw data from the converters:
▪
R1: the calculated weight
▪
R2: the strain gauge measuring signal
▪
R3: the strain gauge reference signal
▪
R5: the last actual test value
Symmetrical measurement is switched on if it has been enabled by bit R32.7 of the feature register.
1bin
The measurement registers contain the mapped calibration data:
▪
R1: reserved (register is empty)
▪
R2: the offset error of the measuring signal
▪
R3: the offset error of the reference signal
▪
R5: the correction factor for the differential signal
Symmetrical measurement is switched off even if it has been enabled by bit R32.7 of the feature register.
CB2.1
CaliDisReq/
Channel
0bin
The ForcedCali status bit (SB2.4) is cleared
Selection of the measuring channel, UDiff
1bin
Blocking automatic calibration
Selection of the measuring channel, URef
CB2.0
StartManCheck/
StartManCali
1bin
Start test
Start calibration and test
*) Manual operation can be enabled via the command register (R7).
Status byte 2 (for process data mode)
The status byte 2 (SB2) is located in the input image and is transmitted from terminal to the controller.
Bit | SB2.7 | SB2.6 | SB2.5 | SB2.4 | SB2.3 | SB2.2 | SB2.1 | SB2.0
Name | - | Error | - | ForcedCali | RegLockAck | NoActualValue | CaliDisAck/Channel | NegWeight
Key
Bit | Name | Description
SB2.7 | - | 0bin | reserved
SB2.6 | Error | 1bin | internal error
SB2.5 | - | 0bin | reserved
SB2.4 | ForcedCali | 1bin | Forced calibration is being carried out.
SB2.3 | RegLockAck | 1bin | Acknowledgement for the write protection of all registers
SB2.2 | NoActualValue | 1bin | The process data indicated is not valid.
SB2.1 | CaliDisAck/ Channel |  | normal operation | manual operation*
 |  | 0bin | - | selected measuring channel: Udiff
 |  | 1bin | Acknowledgement of calibration block | selected measuring channel: Uref
SB2.0 | NegWeight | 0bin | Process data is positive
 |  | 1bin | Process data is negative
*) Manual operation can be enabled via the command register (R7).


Register overview

Access from the user program [image] Register overview
Register overview
All registers can be read or written via register communication.
Registers R0 to R31 (direct access)
These registers are used to parameterize the KL3356.
Register no.
Comment
Default value
R/W
Memory
R0
Status word
0x0000
0dec
R
RAM
R1
measured value register 1*:
▪
calculated weight (raw value without scaling)
▪
none
0x0000
0dec
R
RAM
R2
measured value register 2*:
▪
strain gauge measuring signal or
▪
offset error of the measuring signal or
▪
calibration counter 0
0x0000
0dec
R
RAM
R3
measured value register 3*:
▪
strain gauge reference signal or
▪
offset error of the reference signal or
▪
calibration counter 1
typically 0xF618
typically 63000dec
R
RAM
R4
Register page selection register
0x0000
0dec
R/W
RAM
R5
measured value register 4*:
▪
last actual test value or
▪
correction factor for differential signal or (factor x 10000) or
▪
calibration counter 2
0x0000
0dec
R
RAM
R6
Diagnostic register
0x0000
0dec
R
RAM
R7
Command register
0x0000
0dec
R/W
RAM
R8
Terminal type
0x0D1C
3356dec
R
ROM
R9
Firmware version
e.g. 0x3141
e.g. 12609dec
R
ROM
R10
Multiplex shift register
0x0130
304dec
R
ROM
R11
Signal channels
0x0130
304dec
R
ROM
R12
Minimum data length
0x3030
18dec
R
ROM
R13
Data structure
0x0007
7dec
R
ROM
R14
reserved
-
-
-
-
R15
Alignment register
typically 0x7F80
typically 32640dec
R/W
RAM
R16
Hardware version number
e.g. 0x0000
e.g. 0dec
R/W
SEEPROM
R17
reserved
-
-
-
-
R18
reserved
-
-
-
-
R19
Manufacturer scaling: offset
typically 0x0000
typically 0dec
R/W
SEEPROM
R20
Manufacturer scaling: gain
typically 0x0100
typically 256dec
R/W
SEEPROM
R21
reserved
-
-
-
-
...
reserved
-
-
-
-
R30
reserved
-
-
-
-
R31
Code word register
0x0000
0dec
R/W
RAM
*) depending on bit CB2.2 and bit CB2.4 of control byte 2
Register page 0 (access selectable via register R4)
These registers are also used for parameterization of the KL3356.
Register no. | Comment | Default value |  | R/W | Memory
R32 | Feature register | 0x0380 | 896dec | R/W | SEEPROM
R33 | User offset | 0x0000 | 0dec | R/W | SEEPROM
R34 | User gain | 0x0800 | 2048dec | R/W | SEEPROM
R35 | Nominal weight | 0x0005 | 5dec | R/W | SEEPROM
R36 | Nominal parameter | 0x0002 | 2dec | R/W | SEEPROM
R37 | Filter constants of the A/D converter, and configuration bits for the filter | 0x35C0 | 13760dec | R/W | SEEPROM
R38 | Scale factor | 0x03E8 | 1000dec | R/W | SEEPROM
R39 | Measuring interval for the reference signal ****) | 0x0E10 | 3600dec | R/W | SEEPROM
R40 | Calibration interval ****) | 0x0708 | 1800dec | R/W | SEEPROM
R41 | Test interval *****) | 0x000A | 10dec | R/W | SEEPROM
R42 | Nominal test value | typically 0x332C | typically 13100dec | R/W | SEEPROM
R43 | Test tolerance | 0x0032 | 50dec | R/W | SEEPROM
R44 | Interval for forced calibration *****) | 0x0003 | 3dec | R/W | SEEPROM
R45 | Limit for reference voltage testing | 0x1388 | 5000dec | R/W | SEEPROM
R46 | Limit for reference correction factor | 0x0064 | 100dec | R/W | SEEPROM
R47 | Calibration stabilization: - number of stable measured values | 0x0032 | 50dec | R/W | SEEPROM
R48 | Calibration stabilization: - tolerance for measurement stability (in digits) | 0x0005 | 5dec | R/W | SEEPROM
R49 | Weight for manual calibration | 0x7D0 | 2000dec | R/W | SEEPROM
R50 | reserved | - | - | - | -
... | reserved | - | - | - | -
R63 | reserved | - | - | - | -
****) In multiples of 100 ms
*****) in multiples of register R40
Register page 1 (access selectable via register R4)
Freely available SEEPROM memory.
Register no. | Comment | Default value |  | R/W | Memory
R32 | freely available | - | - | R/W | SEEPROM
... | freely available | - | - | R/W | SEEPROM
R63 | freely available | - | - | R/W | SEEPROM
Register page 2 (access selectable via register R4)
Freely available SEEPROM memory.
Register no. | Comment | Default value |  | R/W | Memory
R32 | freely available | - | - | R/W | SEEPROM
... | freely available | - | - | R/W | SEEPROM
R63 | freely available | - | - | R/W | SEEPROM


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication.
Registers R0 to R31 (direct access)
These registers are used to parameterize the KL3356.
R0: status word
The status word contains information about internal signals, and provides an indication of errors that have occurred.
Bit | Name | Description
R0.15 | GainError | 1bin | The deviation of the gain correction factor is greater than specified in register R46.
R0.14 | LowVoltageCh2 | 1bin | The strain gauge reference signal is smaller than specified in register R45.
R0.13 | NoRefCh2 | 1bin | The internal reference voltage for channel 2 (strain gauge reference signal) is missing.
R0.12 | NoRefCh1 | 1bin | The internal reference voltage for channel 1 (strain gauge differential signal) is missing.
R0.11 | OverloadCh2 | 1bin | The strain gauge reference signal is above the valid range (max. 0xFFFF)
R0.10 | OverloadCh1 | 1bin | The strain gauge differential signal is above the valid range (max. 0xFFFF)
R0.9 | ADCError | 1bin | No communication with the A/D converter.
R0.8 | TestError | 1bin | Actual value from the test is outside the specified tolerance range.
R0.7 | - | reserved
R0.6 | MapCaliCounter | 1bin | Acknowledgement for CB2.4. The calibration counters are shown in registers R2, R3 and R5.
R0.5 | CaliDataMapped | 1bin | Acknowledgement for CB2.2. The last test results are shown in registers R2, R3 and R5.
R0.4 | ManCheckDone | 1bin | The manual test that was started with CB2.0 has been completed.
R0.3 | TestActive | 1bin | Manual testing is in progress.
R0.2 | CaliActive | 1bin | Calibration (manual or automatic) is active.
R0.1 | NegSignalCh2 | 1bin | The strain gauge reference signal is negative.
R0.0 | NegSignalCh1 | 1bin | The strain gauge differential signal is negative.
R1: measured value register 1
▪
Raw data of the converters:
If control bit CB2.2 is not set, then the weight calculated by means of formulae 1.0 and 1.1 is displayed in register R1.
▪
If control bit CB2.2 is set, register R1 is blank.
▪
If control bit CB2.4 is set, register R1 is blank.
R2: measured value register 2
▪
Raw data of the converters:
If the control bit CB2.2 is not set, register R2 shows the strain gauge measuring signal.
▪
Calibration data:
If control bit CB2.2 is set, register R2 shows the preload of the measuring signal input.
▪
Calibration counter 0:
If control bit CB2.4 is set, register R2 shows the number of measured values that were identical to the first measured value.
R3: measured value register 3
▪
Raw data of the converters:
If the control bit CB2.2 is not set, register R3 shows the strain gauge reference signal.
▪
Calibration data:
If control bit CB2.2 is set, register R3 shows the preload of the reference signal input.
▪
Calibration counter 1:
If control bit CB2.4 is set, register R3 shows the number of measured values that were smaller than the first measured value.
R4: register page selection register
Other register pages can be accessed by writing into register R4. The value entered into register R4 is accepted if the desired register page is present. If that is not the case, the previous value is retained.
Register content R4 | Register numbers R32 to R63 permit access to
0x0000 | Register page 0: Configuration registers R32 to R63
0x0001 | Register page 1: 32 words of freely available SEEPROM memory
0x0002 | Register page 2: 32 words of freely available SEEPROM memory
0x0003 to 0xFFFF | reserved
R5: measured value register 4
▪
Raw data of the converters:
If the control bit CB2.2 is not set, register R5 shows the most recent actual test value.
▪
Calibration data:
If control bit CB2.2 is set, register R5 shows the correction factor for the differential signal (factor x 10000).
▪
Calibration counter 2:
If control bit CB2.4 is set, register R5 shows the number of measured values that were greater than the first measured value.
R6: diagnostic register
Status byte SB2 is placed into register R6.
R7: command register
User code word
For a command to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x0101: user calibration - offset
The KL3356 uses the entry 0x0101 in register R7 to compensate the user offset. The calibration value is entered in register R33.
The calibration value is taken account in weight measuring if bit R32.0 is set.
Command 0x0102: user calibration - gain
The KL3356 uses the entry 0x0102 in register R7 to compensate the user gain. The calibration value is entered in register R34.
The calibration value is taken account in weight measuring if bit R32.0 is set.
Command 0x0401: manual calibration mode
Manual calibration mode is enabled by entering 0x0401 into register R7. When the terminal has accepted the value, then setting
▪
CB2.1 = 0 switches to analog converter Udiff
▪
CB2.1 = 1 switches to the analog converter URef
Output data word DataOUT1 can be used to change the operation mode of the KL3356.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the delivery state for the following registers:
R19: 0
R20: 0x0100
R32: 0x0380
R33: 0
R34: 0x0800
R35: 5
R36: 2
R37: 0x35C0
R38: 1000dec
R39: 3600dec
R40: 1800dec
R41: 10dec
R43: 50dec
R44: 3
R45: 5000dec
R46: 100dec
R47: 50dec
R48: 5
R49: 2000dec
R8: terminal designation
The name of the terminal is contained in register R8. KL3356: 0x0D1C (3356dec)
R9: firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value cannot be changed.
R16: hardware version number
Register R16 contains the hardware version of the terminal; this value cannot be changed.
R19: manufacturer scaling - offset
This register contains the offset of the manufacturer scaling. Manufacturer scaling can be enabled through R32.1 in the feature register.
R20: manufacturer scaling - gain
This register contains the gain of the manufacturer scaling (16 bit unsigned integer x 2-8 + 1).
Examples:
0x0080 (128dec) means factor 0.5
0x0100 (256dec) means factor 1.0
Manufacturer scaling can be enabled through R32.1 in the feature register.
R31: codeword register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
Register page 0 (access selectable via register R4)
These registers are also used for parameterization of the KL3356.
Feature register (R32)
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | WaitForStableValue | ScalingUnit | enUsrCali | enStabCali | enScaling
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | enSymm | disRef | disTest | disCali | - | disWdTimer | enManScal | enUsrScal
Key
Bit | Name | Description |  | Default
R32.15 | - | reserved |  | 0bin
... | ... | ... |  | ...
R32.13 | - | reserved |  | 0bin
R32.12 | WaitFor StableValue | 0bin | After a calibration or measurement of the reference voltage, the KL3365 outputs the measured value immediately. Small peaks may still be displayed. | 0bin
 |  | 1bin | After a calibration or measurement of the reference voltage, the KL3365 waits with the measured value output until the weight value has become stable.
R32.11 | ScalingUnit | 0bin | Unit of R35 = 1 mV/V | 0bin
 |  | 1bin | Unit of R35 = 0,01 mV/V
R32.10 | enUsrCali | 0bin | User scaling (see formula 1.3.0) is active if bit 32.0 is set. | 0bin
 |  | 1bin | User calibration (see formula 1.3.1) is active if bit 32.0 is set.
R32.9 | enStabCali | 0bin | Calibration stabilization not active | 1bin
 |  | 1bin | Calibration stabilization active
R32.8 | enScaling | 0bin | Scale factor is not active | 1bin
 |  | 1bin | Scale factor is active
R32.7 | enSymm | 0bin | Symmetrical measurement is not active | 1bin
 |  | 1bin | Symmetrical measurement is active
R32.6 | disRef | 0bin | Cyclic reference measurement is active | 0bin
 |  | 1bin | Cyclic reference measurement is not active
R32.5 | disTest | 0bin | Cyclic testing is active | 0bin
 |  | 1bin | Cyclic testing is not active
R32.4 | disCali | 0bin | Cyclic calibration of the A/D converter is active | 0bin
 |  | 1bin | Cyclic calibration of the A/D converter is not active
R32.3 | - | reserved |  | 0bin
R32.2 | disWdTimer | 0bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms) | 0bin
 |  | 1bin | Watchdog timer is not active
R32.1 | enManScal | 0bin | Manufacturer scaling is not active | 0bin
 |  | 1bin | Manufacturer scaling is active
R32.0 | enUsrScal | 0bin | User scaling and user calibration are not active | 0bin
 |  | 1bin | User scaling or user calibration (depending on bit 32.10) is active
R33: user scaling - offset
This register contains the offset of the user scaling. User scaling can be enabled in the feature register via bit R32.0.
R34: user scaling - gain
This register contains the gain of the user scaling (16 bit unsigned integer x 2-11 + 1).
Examples:
0x0100 (1024dec) means factor 0.5
0x0800 (2048dec) means factor 1.0
User scaling can be enabled in the feature register via bit R32.0.
R35: nominal weight of the load cell
The nominal weight of the connected load cell is entered into register R35. The unit is 1 kg.
R36: nominal parameter of the load cell
The nominal parameter of the connected load cell is entered into register R36. The unit is 1 mV / V.
R37: Filter constant of the A/D converter, and configuration bits for the filter
The KL3356 possesses two low-pass filter stages:
▪
The first stage consists of a sinc3 filter, and is always active.
▪
The second stage consists of a 22nd order FIR filter, which can be disabled
(FIR: finite impulse response, i.e. a non-recursive filter).
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Filter constants SF (SF.11 to SF.0) |  |  |  |  |  |  |  |  |  |  |  | Zero | Zero | SkipFIR | Fast
Key
Bit | Name | Description | Default
R37.15 | Filter constant SF (SF.11 - SF.0) | The filter constant SF specifies the 3dB limit frequency of the sinc3 filter. The value ranges from 150 to 2047. The 3 dB limit frequency FLimit and the 64.5 dB stop frequency FStop are calculated as follows: | 35Chex (860dec)
...
R37.4
SkipFIR = 0 | FLimit = 11981 / SF
 | FStop = 43008 / SF
SkipFIR = 1 | FLimit = 80486 / SF
Bit | Name | Description |  | Default
R37.3 | Zero | 0bin | (see note below) | 0bin
R37.2 | Zero | 0bin |  | 0bin
Do not change these bits
Bits R37.2 and R37.3 always have to be 0bin, in order to avoid errors in the A/D converter!
Bit | Name | Description |  | Default
R37.1 | SkipFIR | 0bin | FIR filter is enabled. | 0bin
 |  | 1bin | FIR filter is bypassed.
R37.0 | Fast | 0bin | Fast Step Mode is disabled. | 0bin
 |  | 1bin | Fast Step Mode is active: a fast reaction will follow jumps at the input, in spite of the filter stage being active. In this case the filter is bypassed!
Recommended values
Value in R37 | Fstop | Cycle time
0x35C0 | 50 Hz | 140 ms
0x2660 | 70 Hz | 100 ms
0x1330 | 140 Hz | 50 ms
0x7FF1 |  | 40 ms
0x3FF1 |  | 20 ms
0x1001 |  | <4 ms
Value in R37 | Flimit | Cycle time
0x7FF2 | 39.6 Hz | 40 ms
0x3FF2 | 77.36 Hz | 20 ms
0x1002 | 158 Hz | <4 ms
R38: scaling factor
This register contains the scale factor.
Examples:
0x0001 (01dec) means factor 1
0x000A (10dec) means factor 10
The scale factor can be enabled through bit R32.8 in the feature register.
R39: Measuring interval for reference signal
This register contains the measuring interval for the cyclic reference measurement. The unit is 100 ms. The cyclic reference measurement can be enabled through bit R32.6 in the feature register.
R40: Calibration interval
This register contains the calibration interval for the terminal's automatic calibration. The unit is 100 ms. The automatic calibration can be enabled through bit R32.4 in the feature register.
R41: Test interval
This register contains the test interval for the terminal's cyclic testing. This interval is always a multiple (default: 3dec) of the calibration interval (R40). The test interval when the terminal leaves the factory is therefore 10 x 180 s = 1800 s. The cyclic testing can be enabled through bit R32.5 in the feature register.
R42: nominal test value
This register contains the terminal's nominal test value.
During the production of the terminal, the actual test value is transferred from register 5 to the nominal test value register R42. This value provides information about a voltage resulting from an internal reference voltage source and a voltage divider.
During a calibration, the system checks whether the value is within the tolerance given by registers R42 and R43. This can be used to determine whether there is an internal defect (e.g. faulty analog switch).
This value may change slightly over time (due to ageing of the electrical components). If necessary, the actual test value of register R5 should therefore be transferred to register R42 from time to time. This can be done safely, because in case of an error the value will approach 0 or 65535.
R43: test tolerance
This register contains the test tolerance of the terminal (+/-).
R44: Forced calibration interval
This register contains the interval for the terminal's forced calibration. This interval is always a multiple (default: 3dec) of the calibration interval (R40). The interval for forced calibration when the terminal leaves the factory is therefore 3 x 180 s = 540 s. The forced calibration can be enabled through bit R32.4 in the feature register.
If register R44 is set to 0 set, forced calibration is switched off completely.
R45: threshold for reference voltage test
This register contains the limit for the reference voltage test. The unit is 1 mV. If the reference voltage is found to be below this limit, bit R0.14 is set in the status word.
R46: threshold for correction factor
This register contains the limit value for the correction factor. A correction factor for the differential signal is determined in the course of calibration. When measuring the internal reference, this results from the quotient of the reference and differential signal. To represent it more clearly, the result is normalized to 10000 (URef / UDiff x 10000), which means that 10000 corresponds to a factor of 1. In mapped calibration data, the correction factor is output in R5. If the difference between the correction factor and 10000 (10000 - correction factor) is greater than this limit, bit R0.15 is set in the status word.
R47: calibration stabilization - number of stable measured values
Default: 50
R48: calibration stabilization - tolerance for measurement stability
Default: 5
R49: manual calibration weight
Default: 2000 grams
Register page 1 (access selectable via register R4)
R32 to R63: freely allocatable SEEPROM memory
Registers R32 to R63 on register page 1 are freely available, non-volatile registers that can be used to store 2 x 32 words of user data. Because these values are stored in SEEPROM, they are retained when the terminal is restarted.
Register page 2 (access selectable via register R4)
R32 to R63: freely allocatable SEEPROM memory
Registers R32 to R63 on register page 2 are freely available, non-volatile registers that can be used to store 2 x 32 words of user data. Because these values are stored in SEEPROM, they are retained when the terminal is restarted.


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com