KL3214 - Analog HD input terminal Pt100 (RTD)
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation Issue Status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
1.2.0
▪
Update Chapter “Instructions for ESD protection”
▪
Chapter “Beckhoff Identification Code (BIC)” added
1.1.0
▪
Design of the safety instructions adapted to IEC 82079-1
▪
Update chapter Notes on the documentation
▪
Update Technical data
▪
Chapter Instructions for ESD protection added
▪
Chapter Installation instructions for enhanced mechanical load capacity added
▪
Example program added to chapter “KS2000 Configuration software“
▪
Correction chapter Register description
▪
Update chapter Connection system -> Connection
1.0.0
▪
First published
0.5
▪
Preliminary version (internal only)
Firmware and hardware versions
Documentation Version | KL3214
 | Firmware | Hardware
1.1.0 | 1A | 01
1.0.0 | 1A | 00
0.5 | 1A | 00
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 40 15 1A 00:
40 - week of production 40
15 - year of production 2015
1A - firmware version 1A
00 - hardware version 00


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] Introduction
Introduction
KL3214-0000
The KL3214 analog HD input terminal allows four resistance sensors to be connected directly on a width of 12 mm.
The Bus Terminal's circuitry can handle sensors using the 3-wire technique. A microprocessor handles linearization across the whole temperature range, which is freely selectable.
The Bus Terminal's standard settings are: resolution 0.1°C. Sensor malfunctions such as broken wires are indicated by error LEDs.


Technical data

Product overview [image] Technical data
Technical data
Technical data |  | KL3214-0000
Number of inputs |  | 4
Sensor types |  | PT100/200/500/1000, Ni100/120/1000, KTY sensors, Potentiometer (10 Ω … 1.2/4 kΩ)
Connection technology |  | 3-wire
Measuring range | Pt sensors | -200°C ... +850°C
 | Ni sensors | -60°C ... +250°C
Measuring current |  | typ. 0.5 mA (load-dependent)
Resolution |  | 0.1℃ per digit
Measuring error (total meas. range) |  | < ± 0.5°C (for PT sensors)
Conversion time |  | approx. 170 ms
Bit width in the input process image |  | 4 x 16 bit data, 4 x 8 bit status (optional)
Bit width in the output process image |  | 4 x 8 bit Control (optional)
Supply voltage for internal electronic |  | via the K-bus
Current consumption from K-bus |  | typically 120 mA
Electrical isolation |  | 500 V (K-bus/signal voltage)
Special features |  | Broken wire detection
Weight |  | approx. 60 g
Dimensions (W x H x D) |  | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting |  | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature during operation |  | 0°C ... +55°C
Permissible ambient temperature during storage |  | -25°C ... +85°C
Permissible relative humidity |  | 95 %, no condensation
Vibration/shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27, see also Installation instructions for terminals with increased mechanical load capacity
EMC immunity/emission |  | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position |  | variable
Protection class |  | IP20
Approvals |  | CE, cULus


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
Connection and LED displays


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Connection and LED displays

Mounting and wiring [image] Connection and LED displays
Connection and LED displays
KL3214 - terminal points and LEDs
Connection - KL3214
Terminal point | No. | Comment
+R1 | 1 | Input +R1
RL1 | 2 | Input RL1
+R2 | 3 | Input +R2
RL2 | 4 | Input RL2
+R3 | 5 | Input +R3
RL3 | 6 | Input RL3
+R4 | 7 | Input +R4
RL4 | 8 | Input RL4
-R1 | 9 | Input –R1
n.c. | 10 | reserved
-R2 | 11 | Input –R2
n.c. | 12 | reserved
-R3 | 13 | Input -R3
n.c. | 14 | reserved
-R4 | 15 | Input -R4
n.c. | 16 | reserved
LED indicators
LED | Display | Description
Run | Green illuminated | Normal operation:
 | Off | Watchdog-timer overflow has occurred. If no process data is transmitted to the bus coupler for 100 ms, the green LEDs go out
Error | red illuminated | The respective channel is affected by a short circuit or broken wire. The resistance is in the invalid range of the characteristic curve.
 | Off | The resistance is in the valid range of the characteristic curve.


KS2000 Configuration software

KS2000 Configuration software
KS2000 Configuration software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

KS2000 Configuration software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 digital input terminal
▪
a KL3214 multimeter terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branch for channel 1 of the KL3214
For the KL3214, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL3214 registers.
▪
A dialog mask for the parameterization of the KL3214 can be found under Settings.
▪
ProcData displays the KL3214 process data.


Register

KS2000 Configuration software [image] Register
Register
You can access the registers of the KL3214 directly under Register.– The meaning of the register is explained in the register overview.
Register view in KS2000


Settings

KS2000 Configuration software [image] Settings
Settings
The dialog mask for the parameterization of the KL3214 can be found under Settings.
Parameterization with the KS2000 configuration software
Operation mode
▪
User scaling active (R32.0)
You can activate user scaling here (default: deactivated).
▪
Watchdog timer active (R32.2)
Here you can activate the watchdog timer (default: deactivated).
▪
Siemens S5 format (R32.4)
Here you can activate the Siemens S5 format (default: deactivated).
▪
Resolution of 1/10 °C or 1/100 °C (R32.5)
Here you can select the resolution (default: 1/10 °C).
Filter settings (R37)
Here you can set the filter frequency (default: 50 Hz).
Permissible values:
5 Hz, 10 Hz, 50 Hz, 60 Hz, 100 Hz, 500 Hz, 1000 Hz, 2000 Hz, 3750 Hz, 7500 Hz, 15000 Hz, 30000 Hz
Resistance thermometer (R32.15 to R32.8)
Here you can adapt the channel to the connected thermocouple (default: PT100).


Sample program for KL register communication via EtherCAT on KL3314 exemplary

KS2000 Configuration software [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the user program

Access from the user program
Access from the user program
Different operating modes or functionalities may be set for the complex terminals. The General Description of Registers explains those register contents that are the same for all complex terminals.
The terminal-specific registers are explained in the following section.
Access to the internal terminal registers is described in the Register Communication section.
Additional information
•
Control and status bytes
•
Register overview
•
Register description
•
Examples of Register Communication
•
Process image
•
Mapping


Control and status bytes

Access from the user program [image] Control and status bytes
Control and status bytes
Additional information
•
Process data mode
•
Register communication


Process data mode

Access from the user program [image] Control and status bytes [image] Process data mode
Process data mode
Control byte (for process data mode)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | - | - | - | - | - | -
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 | - | reserved
CB.4 | - | reserved
CB.3 | - | reserved
CB.2 | - | reserved
CB.1 | - | reserved
CB.0 | - | reserved
Status byte (for process data mode)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | - | - | - | - | overrange | underrange
Bit | Name | Description
SB.7 | RegAccess | 0bin | Process data mode switched on
SB.6 | Error | 1bin | Measuring range exceeded, overrange or underrange; the Error LED lights up or conversion error or invalid measuring range
SB.5 | - | reserved
SB.4 | - | reserved
SB.3 | - | reserved
SB.2 | - | reserved
SB.1 | overrange | 1bin | Electrical measuring range exceeded
SB.0 | underrange | 1bin | Electrical measuring range undershot


Register communication

Access from the user program [image] Control and status bytes [image] Register communication
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg. no.
Bit
Name
Description
CB.7
RegAccess
1bin
Register communication switched on
CB.6
R/W
0bin
Read access
1bin
Write access
CB.5 to CB.0
Reg. no.
Register number:
Enter here the number of the register that you wish
▪
to read with input data word DataIN, or
▪
to write with output data word DataOUT.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgement for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for parametering the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
Register no. | Comment | Default value |  | R/W | Memory
 |  | hex | dec
R0 | Raw ADC value | variable |  | R | RAM
R1 | ADC raw value RL (of the conductor) | variable |  | R | RAM
R2 | Resistance RTD | variable |  | R | RAM
R3 | Resistance RL | variable |  | R | RAM
R4 | reserved | 0x0000 | 0dec | - | -
R5 | reserved | 0x0000 | 0dec | - | -
R6 | Diagnostic register (not used) | 0x0000 | 0dec | - | RAM
R7 | Command register (not used) | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x0C8E | 3214dec | R | ROM
R9 | Firmware version number | 0x3141 | 1AASCII | R | ROM
R10 | Multiplex shift register | 0x0230 | 560dec | R | ROM
R11 | Signal channels | 0x0418 | 1048dec | R | ROM
R12 | Minimum data length | 0x0098 | 152 dec | R | ROM
R13 | Data structure | 0x0004 | 4 dec | R | ROM
R14 | reserved | 0x0000 | 0dec | - | -
R15 | Alignment register | variable |  | R/W | RAM
R16 | Hardware version number | 0x0000 | 00ASCII | R | SEEROM
R17 | Vendor calibration: Offset PT100 | specific |  | R | SEEROM
R18 | Vendor calibration: Gain PT100 | specific |  | R | SEEROM
R19 | reserved | 0x0000 | 0dec | - | -
R20 | reserved | 0x0000 | 0dec | - | -
R21 | Vendor calibration: Offset PT1000 | specific |  | R | SEEROM
R22 | Vendor calibration: Gain PT1000 | specific |  | R | SEEROM
R23 | Vendor calibration: Offset RL | specific |  | R | SEEROM
R24 | Vendor calibration: Gain RL | specific |  | R | SEEROM
R25 | reserved | 0x0000 | 0dec | - | -
… | ... | ... | … | ... | ...
R28 | reserved | 0x0000 | 0dec | - | -
R29 | Terminal type, special identification | 0x0000 | 0dec | R | ROM
R30 | reserved | 0x0000 | 0dec | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0040 | 64dec | R/W | SEEROM
R33 | User scaling: Offset | 0x0000 | 0dec | R/W | SEEROM
R34 | User scaling: Gain | 0x0100 | 256dec | R/W | SEEROM
R35 | reserved | 0x0000 | 0dec | - | -
R36 | reserved | 0x0000 | 0dec | - | -
R37 | Filter setting | 0x0000 | 0dec | R/W | SEEROM
R38 | Compensation for the line resistance | 0x0000 | 0dec | R/W | SEEROM
R39 | reserved | 0x0000 | 0dec | - | -
… | ... | ... | … | ... | ...
R63 | reserved | 0x0000 | 0dec | - | -


Register description

Access from the user program [image] Register description
Register description
The following registers are used for parameterization of the KL3214. They can be read or written via the register communication with the aid of control, status and data bytes.
▪
R0: ADC raw value RTD
Raw value of the A/D converter (XR). The range is restricted to 16 bits; the three least significant bits are discarded.
▪
R1: ADC raw value RL
Raw value of the A/D converter for the line (XRL). The range is restricted to 16 bits; the three least significant bits are discarded.
▪
R2: Resistance RTD
Resistance RTD with a resolution of 1/32 ohm with PT100 and 1/8 ohm with PT1000.
▪
R3: Resistance RL
Resistance RL with a resolution of 1/32 ohm.
▪
R6: Diagnostic register
The diagnostic register has no function in the KL3214.
▪
R7: Command register
The command register has no function in the KL3214.
▪
R8: Terminal description
Register R8 contains the designation of the KL3214 terminal: 0x0C8E (3214dec).
▪
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 (1A)ASCII. '0x31' corresponds to the ASCII character '1' and '0x41' to the ASCII character 'A'. This value cannot be changed.
▪
R10: Data length (multiplex shift register)
R10 contains the number of multiplexed shift registers and their length in bits.
▪
R11: Signal channels
Unlike R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data structure (data type register)
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure: 1 byte, n bytes
0x03 | Word array
0x04 | Structure: 1 byte, n words
0x05 | Double word array
0x06 | Structure: 1 byte, n double words
0x07 | Structure: 1 byte, 1 double word
0x08 | Structure: 1 byte, 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure: 1 byte, n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure: 1 byte, n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure: 1 byte, n double words with variable logical channel length
▪
R15: Alignment register
Via the alignment register bits, the Bus Coupler arranges the address range of an analog terminal such that it starts at a byte boundary.
▪
R16: Hardware version number
Register R16 contains the hardware revision level of the terminal; this value cannot be changed.
▪
R17: Vendor calibration - offset PT100
This register contains the vendor calibration offset for PT100.
▪
R18: Vendor calibration - gain PT100
This register contains the vendor calibration gain for PT100.
▪
R21: Vendor calibration - offset PT1000
This register contains the vendor calibration offset for PT1000.
▪
R22: Vendor calibration - gain PT1000
This register contains the vendor calibration gain for PT1000.
▪
R23: Manufacturer compensation - offset RL
This register contains the vendor calibration offset for RL.
▪
R24: vendor calibration - gain RL
This register contains the vendor calibration gain for RL.
▪
R29: Terminal type, special version
Register R29 contains the special designation of the KL3214-0000 terminal: 0x0000 (0000dec).
▪
R31: Code word register
–
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
–
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset with each restart of the terminal.
▪
R32: Feature register
The feature register specifies the terminal's configuration. Default: 0x0040 (64dec)
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | SensorType
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | ConnectionTechnique |  | en1/100°C | enS5format | - | enWdTimer | - | enUserScaling
Bit | Name | Description |  | Default
R32.15 to R32.8 | SensorType | 0dec | RTD PT100 | 0dec
 |  | 1dec | RTD NI100
 |  | 2dec | RTD PT1000
 |  | 3dec | RTD PT500
 |  | 4dec | RTD PT200
 |  | 5dec | RTD NI1000
 |  | 6dec | RTD NI120
 |  | 7dec | RTD RS1000
 |  | 8dec… 13dec | reserved
 |  | 14dec | RTD RES16
 |  | 15dec | RTD RES64
 |  | 16dec | RTD KTSIEMENS2K
 |  | 17dec | KTY81110
 |  | 18dec | KTY81121
 |  | 19dec | KTY81122
 |  | 20dec | KTY81151
 |  | 21dec | KTY81152
 |  | 22dec | KTY81210
 |  | 23dec | KTY81221
 |  | 24dec | KTY81222
 |  | 25dec | KTY81251
 |  | 26dec | KTY81252
 |  | 27dec | KTY83110
 |  | 28dec | KTY83121
 |  | 29dec | KTY83122
 |  | 30dec | KTY83151
 |  | 31dec | KTY83152
 |  | 32dec | KTY84130
 |  | 33dec | KTY84151
 |  | 34dec | KTSIEMENS1K
 |  | 35dec | KTSIEMENS2K_5
 |  | 36dec | KTSIEMENS2K_7
 |  | 37dec | KTSIEMENS1K_5
 |  | 38dec | KTSIEMENS1K_7
R32.7 to R32.6 | Connection technique | 00bin | reserved | 01bin
 |  | 01bin | Three-wire connection technique
 |  | 10bin | reserved
 |  | 11bin | not connected
R32.5 | Resolution | 0bin | Resolution 1/10 °C | 0bin
 |  | 1bin | Resolution 1/100°C
R32.4 | enS5format | 0bin | Siemens S5 Format disabled | 0bin
 |  | 1bin | Siemens S5 Format enabled
R32.3 | - | reserved |  | 0bin
R32.2 | enWdTimer | 0bin | Watchdog timer is not active | 1bin
 |  | 1bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms)
R32.1 | - | reserved |  | 0bin
R32.0 | enUserScaling | 0bin | User scaling deactivated | 0bin
 |  | 1bin | User scaling activated |
▪
R33: user scaling offset (default: 0x0000)
Here you can specify the offset for the user scaling.
Scaling: 1/10 °C (default) or 1/100 °C, see bit R32.5 of the feature register.
The user scaling must be activated with bit R32.0 of the feature register.
▪
R34: user scaling gain (default: 0x0100)
Here you can specify the gain for the user scaling.
Scaling: Register value x 2-8. This means that 0x0100 (256dec) corresponds to the factor 1.
The user scaling must be activated with bit R32.0 of the feature register.
▪
R37: Filter settings (default: 0x0000)
0x0000: 50 Hz
0x0001: 60 Hz
0x0002: 100 Hz
0x0003: 500 Hz
0x0004: 1000 Hz
0x0005: 2000 Hz
0x0006: 3750 Hz
0x0007: 7500 Hz
0x0008: 15000 Hz
0x0009: 30000 Hz
0x000A: 5 Hz
0x000B: 10 Hz
▪
R38: Line resistance calibration (default: 0x0000)
1 ohm corresponds to 32 digits.
Also see about this
•
Register description


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Process image

Access from the user program [image] Process image
Process image
Complex mapping
The following 12 bytes are transferred bi-directionally between KL3214 and control:
Byte offset (without word alignment*) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | Status byte 0 (SB0) | Control byte 0 (CB0)
1 | 2 | Word | DataIN0 | DataOUT0
3 | 4 | Byte | Status byte 1 (SB1) | Control byte 1 (CB1)
4 | 6 | Word | DataIN1 | DataOUT1
6 | 8 | Byte | Status byte 2 (SB2) | Control byte 2 (CB2)
7 | 10 | Word | DataIN2 | DataOUT2
9 | 12 | Byte | Status byte 3 (SB3) | Control byte 3 (CB3)
10 | 14 | Word | DataIN3 | DataOUT3
*) Word alignment: The Bus Coupler places values on even byte addresses
Compact mapping
The following 8 bytes are transmitted bidirectionally between KL3414 and controller:
Byte offset (with and without word alignment*) | Format | Input data | Output data
0 | Word | DataIN0 | DataOUT0
2 | Word | DataIN1 | DataOUT1
4 | Word | DataIN2 | DataOUT2
6 | Word | DataIN3 | DataOUT3
*) word alignment has no effect with compact mapping


Mapping

Access from the user program [image] Mapping
Mapping
Each Bus Terminal is mapped in the Bus Coupler. In the delivery state, this mapping occurs with the default settings of the Bus Coupler for this terminal. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
If the terminals are complexly evaluated, they occupy memory space in the input and output process image.
The following tables provide information about the terminal mapping, depending on the conditions set in the Bus Coupler.
Default mapping for:
Lightbus, EtherCAT, Ethernet and Bus Terminal Controller (BCxxxx, BXxxxx)
Conditions | Word offset | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | r reserved | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Conditions | Word offset | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | reserved | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1
Key
▪
Complex evaluation:
The terminal is mapped with control and status byte.
▪
Motorola format:
Motorola or Intel format can be set.
▪
Word alignment:
The terminal is at word limit in the Bus Coupler.
▪
Ch n SB:
status byte for channel n (appears in the input process image).
▪
Ch n CB:
control byte for channel n (appears in the output process image).
▪
Ch n D0:
channel n, data byte 0 (byte with the lowest value)
▪
Ch n D1:
channel n, data byte 1 (byte with the highest value)
▪
reserved:
This byte occupies process data memory, although it is not used.
▪
"-":
This byte is not used or occupied by the terminal.
Default mapping for:
PROFIBUS, Interbus
Conditions | Word offset | High byte | Low byte
Complex evaluation: no Motorola format: yes Word alignment: don't care | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D0 | Ch3 D1
Conditions | Word offset | High byte | Low byte
Complex evaluation: yes Motorola format: no Word alignment: no | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | Ch2 D0 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D1
 | 5 | Ch3 D1 | Ch3 D0
Conditions | Word offset | High byte | Low byte
Complex evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | Ch2 D1 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D0
 | 5 | Ch3 D0 | Ch3 D1
Default mapping for:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Conditions | Word offset | High byte | Low byte
Complex evaluation: no Motorola format: no Word alignment: don't care | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D1 | Ch3 D0


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com