KL320x - Analog input terminals for Pt100 (RTD) or NTC10K
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documenation
•
Safety instructions
•
Documentation Issue Status


Notes on the documenation

Foreword [image] Notes on the documenation
Notes on the documenation
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation Issue Status

Foreword [image] Documentation Issue Status
Documentation Issue Status
Version
Comment
4.4
▪
Update Firmware and hardware versions
▪
Update chapter “Basic Function Principles”
4.3
▪
Update Firmware and hardware versions
▪
Update Technical data
▪
Chapter "Installation instructions for enhanced mechanical load capacity" added
▪
Chapter "TwinCAT" including Link to FB_KL320xConfig added
4.2
▪
KL3204-0030 added
4.1
▪
Update appendix
4.0
▪
Migration in ST4
▪
Update structure
Firmware and hardware versions
Documentation Version | KL3201
 | Firmware | Hardware
4.4 | 3G | 09
4.3 | 3G | 09
4.0 | 3G | 08
Documentation Version | KL3202
 | Firmware | Hardware
4.4 | 3G | 09
4.3 | 3G | 09
4.0 | 3G | 08
Documentation Version | KL3204
 | Firmware | Hardware
4.4 | 3E | 05
4.3 | 3E | 05
4.0 | 3E | 05
Documentation Version | KL3204-0030
 | Firmware | Hardware
4.4 | 42 | 05
4.3 | 42 | 05
4.2 | 42 | 05
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 47 15 1A 00:
47 - week of production 47
15 - year of production 2015
1A - firmware version 1A
00 - hardware version 00


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Basic function principles


Introduction

Product overview [image] Introduction
Introduction
KL3201, KL3202
KL3201
KL3202
The KL3201 and KL3202 analog input terminals allow resistance sensors to be connected directly. The Bus Terminal's circuitry can operate the sensors using 2-wire or 3-wire connection techniques.
Linearization over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The Bus Terminal's standard settings are: Resolution 0.1°C in the temperature range of PT100 sensors in 3-wire connection.
The two Run LEDs indicate data exchange with the Bus Coupler, the error LEDs show sensor faults (e.g. broken wire).
KL3204-0000
KL3204-0000
The KL3204-0000 analog input terminal allows resistance sensors to be connected directly. The Bus Terminal's circuitry can handle sensors using the 2-wire technique.
Linearization over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The Bus Terminal's standard settings are: Resolution 0.1°C over the temperature range of PT100 sensors.
The error LEDs indicate sensor faults (e.g. a broken wire). The KL3204-0000 combines four channels in a single housing.
KL3204-0030
KL3204-0030
The KL3204-0030 analog input terminal enables four NTC resistance sensors to be connected directly. The Bus Terminal's circuitry can handle sensors using the 2-wire technique. Linearization over the full temperature range is realised with the aid of a microprocessor. The standard setting of the Bus Terminal is a resolution of 0.1°C in the temperature range of the NTC 10 kΩ sensors. The error LEDs indicate sensor faults (e.g. a broken wire). The KL3204-0030 combines four channels in a single housing.


Technical data

Product overview [image] Technical data
Technical data
Technical data - KL3201, KL3202, KL3204, KL3204-0030
Technical data | KL3201 |  | KL3202 | KL3204-0000 | KL3204-0030
Number of inputs | 1 |  | 2 | 4
Power supply | via the K-bus
Sensor types | PT100, PT200, PT500, PT1000, Ni100, Ni120, Ni1000 resistance measurement (e.g. potentiometer connection) |  |  |  | NTC (10 kΩ)
Connection technology | 2 or 3-wire (pre-set to 3-wire) |  |  | 2-wire
Temperature range | -200°C ... +850°C (PT sensors); -60°C ... +250°C (Ni sensors)
Resolution | 0.1°C per digit (measuring range 10 to 5000 Ω: 0.5°C per digit)
Electrical isolation | 500 V (K-bus/signal voltage)
Conversion time | ~ 200 ms |  | ~ 250 ms
Measuring current | typically 0.5 mA |  |  |  | typically <0.5 mA
Measuring error (total meas. range) | < ± 1°C |  | < ± 1 C (at 0°C ... +55°C) < ± 1.5% (when the extended temperature range is used)
Bit width in process image | Input: 1 x 16 bit data (1 x 8 bit Control/ Status optional) |  | Input: 2 x 16 bit data (2 x 8 bit Control/ Status optional) | Input: 4 x 16 bit data (4 x 8 bit Control/ Status optional)
Current consumption from K-bus | typically 60 mA
Configuration | no address setting, configuration via bus coupler or controller
Special features | Wiring fail indication
Weight | approx. 70 g
Permissible ambient temperature range (operation) | 0°C ... +55°C |  | -25°C ... +60°C in operation (extended temperature range) |  | 0°C ... +55°C
Permissible ambient temperature range (storage) | -25°C ... +85°C |  | -40°C ... +85°C |  | -25°C ... +85°C
Relative humidity | 95%, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for enhanced mechanical load capacity |  |  |  | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Installation position | variable
Protection class | IP20
Approvals | CE, cULus, ATEX (standard temperature range), GL | CE, cULus, ATEX (extended temperature range), GL |  |  | CE


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Properties
The KL320x analog input terminals enable resistance sensors to be connected directly. A micro-controller within the terminal is used for converting and linearizing the resistance to a temperature value. The temperatures are displayed as follows:
▪
for KL3201, KL3202, KL3204, KL3204-0030:
–
Measuring range 10 to 5000 Ω: 1/2 °C (1 digit = 0.5 °C)
–
Measuring range 10 to 1200 Ω: 1/10 °C (1 digit = 0.1 °C)
–
All other measuring ranges: 1/10 °C (1 digit = 0.1 °C)
▪
for KL3204-0030:
–
Measuring range -40°C to 110°C: 1/10 °C (1 digit = 0.1 °C)
–
Resistor at 0°C: 27 280 Ω
Note: since there are different NTC10K types, this value characterizes the characteristic curve stored in the KL3204-0030.
In addition to this, a broken wire or short circuit is reported to the Bus Coupler or to the controller, and indicated by the ERROR LED.
PT100, NI100, PT200, PT500, NI120, NI1000 and PT1000 as well as NTC10K of the KL3204-0030 elements are implemented over their full measuring ranges as resistance sensors. The terminal can be fully configured over a fieldbus. A self-defined scaling of the output can, for instance, be performed, or the temperature conversion can be switched off. In the latter case, the measurement is output in the range from 10 Ω up to 1.2 kΩ with a resolution of 1/16 Ω (the internal resolution of the resistance value is 1/255 Ω).
Process data output format
In the delivery state, the measured value is displayed in increments of 1/10° C in two's complement format (integer). The complete measuring range is output for each resistance sensor. Other display types can be selected via the feature register (e.g. sign/amount representation, Siemens output format).
Measured value | Hexadecimal output | Signed integer output
-250.0°C | 0xF63C | -2500
-200.0°C | 0xF830 | -2000
-100.0°C | 0xFC18 | -1000
-0.1°C | 0xFFFF | -1
0.0°C | 0x0000 | 0
0.1°C | 0x0001 | 1
100.0°C | 0x03E8 | 1000
200.0°C | 0x07D0 | 2000
500.0°C | 0x1388 | 5000
850.0°C | 0x2134 | 8500
Resistance limit values
▪
R > 400 Ω: Bits 1 and 6 (over range and error bits) in the status byte are set.
The linearization of the characteristic curve is continued with the coefficients of the upper range limit up to the limit stop of the A/D converter (approx. 500 Ω for PT100).
▪
R<18 Ω: Bits 0 and 6 (under range and error bits) in the status byte are set.
The smallest negative number is displayed (0x8001 corresponds to -32767).
For over range or under range the red error LED is switched on.
Process data
The process data that are transferred to the terminal bus are calculated using the following equations:
Variable | Meaning
X_RL | ADC value of the supply cables
X_RTD | ADC value of the temperature sensor, including one supply cable
X_R | ADC value of the temperature sensor
A_a, B_a | Manufacturer gain and offset calibration (R17, R18)
A_h, B_h | Manufacturer scaling
A_w, B_w: | User scaling
Y_R | Temperature sensor resistance value
Y_T | measured temperature in 1/16 °C
Y_THS | Temperature after manufacturer scaling (1/10 °C)
Y_TAS | Temperature after user scaling
Y_AUS | Process data to PLC
a) Calculation of the resistance value:
X_R = X_RTD-X_RL (1.0)
Y_R = A_a * (X_R - B_a) (1.1)
b) Curve linearization:
Y_T = a1 * Y_R2 + b1* Y_R + c1 (1.2)
or
Y_T = Y_R if output in Ω (1.3)
c) Neither user nor manufacturer scaling are active:
Y_AUS = Y_T (1.4)
d) Manufacturer scaling active (factory setting):
Y_THS = A_h * Y_T + B_h (1.5)
Y_AUS = Y_THS
e) User scaling active:
Y_TAS = A_w * Y_T + B_w (1.6)
Y_AUS = Y_TAS
f) Manufacturer and user scaling active: (1.7)
Y_1 = A_h * Y_T + B_h
Y_2 = A_w * Y_1 + B_w
Y_AUS = Y_2
Data flow of the KL320x


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection system
•
Connection and LED description
•
ATEX - Special conditions (standard temperature range)
•
ATEX - Special conditions (extended temperature range)
•
ATEX Documentation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection system

Mounting and wiring [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


Connection and LED description

Mounting and wiring [image] Connection and LED description
Connection and LED description
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL3201
KL3201 – connection and LEDs
Terminal point | No. | Comment
+R1 | 1 | Input +R1
RL1 | 2 | Input RL
-R1 | 3 | Input -R1 (internally connected with terminal point 7)
Shield | 4 | Shield, FE (internally connected to terminal point 8)
n.c. | 5 | not connected
n.c. | 6 | not connected
-R1 | 7 | Input -R1 (internally connected with terminal point 3)
Shield | 8 | Shield, FE (internally connected to terminal point 4)
KL3202
KL3202 – connection and LEDs
Terminal point | No. | Comment
+R1 | 1 | Input +R1
RL1 | 2 | Input RL
-R1 | 3 | Input -R1 (internally connected with terminal point 7)
Shield | 4 | Shield, FE (internally connected to terminal point 8)
+R2 | 5 | Input +R2
RL2 | 6 | Input RL
-R2 | 7 | Input –R2 (internally connected with terminal point 3)
Shield | 8 | Shield, FE (internally connected to terminal point 4)
KL3204/ KL3204-0030
KL3204/ KL3204-0030 – connection and LEDs
Terminal point | No. | Comment
+R1 | 1 | Input +R1
-R1 | 2 | Input –R1
+R3 | 3 | Input +R3
-R3 | 4 | Input -R3
+R2 | 5 | Input +R2
-R2 | 6 | Input –R2
+R4 | 7 | Input +R4
-R4 | 8 | Input -R4
LED description
LED | Color | Description
Run**) | green | On: Normal operation Off: Watchdog-timer overflow has occurred. If no process data is transmitted to the bus coupler for 100 ms, the green LEDs go out
Error | red | On: The respective channel is affected by a short circuit or broken wire. The resistance is in the invalid range of the characteristic curve. Off: The resistance is in the valid range of the characteristic curve.
**) not KL3204, KL3204-0030


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Special conditions (extended temperature range)

Mounting and wiring [image] ATEX - Special conditions (extended temperature range)
ATEX - Special conditions (extended temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of -25 to 60°C for the use of Beckhoff fieldbus components with extended temperature range (ET) in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with extended temperature range (ET) certified according to the ATEX directive for potentially explosive areas bear the following marking:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


KS2000 Configuration software

KS2000 Configuration software
KS2000 Configuration software
Additional information
•
KS2000 - Introduction


KS2000 - Introduction

KS2000 Configuration software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Access from the user program

Access from the user program
Access from the user program
Different operating modes or functionalities may be set for the complex terminals. The General Description of Registers explains those register contents that are the same for all complex terminals.
The terminal-specific registers are explained in the following section.
Access to the internal terminal registers is described in the Register Communication section.
Additional information
•
Mapping
•
Terminal configuration
•
Register overview
•
General description of registers
•
Terminal-specific register description
•
Control and status byte
•
Register communication


Mapping

Access from the user program [image] Mapping
Mapping
As already described in the Terminal Configuration section, each Bus Terminal is mapped in the Bus Coupler. In the delivery state, this mapping occurs with the default settings of the Bus Coupler for this terminal. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
If the terminals are fully evaluated, they occupy memory space in the input and output process image.
The following tables provide information about the terminal mapping, depending on the conditions set in the Bus Coupler.
Key
▪
Complete evaluation:
The terminal is mapped with control and status byte.
▪
Motorola format:
Motorola or Intel format can be set.
▪
Word alignment:
The terminal is at word limit in the Bus Coupler.
▪
Ch n SB:
status byte for channel n (appears in the input process image).
▪
Ch n CB:
control byte for channel n (appears in the output process image).
▪
Ch n D0:
channel n, data byte 0 (byte with the lowest value)
▪
Ch n D1:
channel n, data byte 1 (byte with the highest value)
▪
"-":
This byte is not used or occupied by the terminal.
▪
res.: reserved:
This byte occupies process data memory, although it is not used.
Additional information
•
KL3201
•
KL3202
•
KL3204, KL3204-0030


KL3201

Access from the user program [image] Mapping [image] KL3201
KL3201
Default mapping for:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch0 D1 | Ch0 D0
 | 1 | - | -
 | 2 | - | -
 | 3 | - | -
Default mapping for:
PROFIBUS, Interbus
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | Ch0 D0 | Ch0 D1
 | 1 | - | -
 | 2 | - | -
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | - | Ch0 D1
 | 2 | - | -
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | - | Ch0 D0
 | 2 | - | -
 | 3 | - | -
Default mapping for:
Lightbus, EtherCAT, Ethernet and Bus Terminal Controller (BCxxxx, BXxxxx)
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | - | -
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | - | -
 | 3 | - | -


KL3202

Access from the user program [image] Mapping [image] KL3202
KL3202
Default mapping for:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | - | -
 | 3 | - | -
Default mapping for:
PROFIBUS, Interbus
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | - | -
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | - | -
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | - | -
Default mapping for:
Lightbus, EtherCAT, Ethernet and Bus Terminal Controller (BCxxxx, BXxxxx)
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1


KL3204, KL3204-0030

Access from the user program [image] Mapping [image] KL3204, KL3204-0030
KL3204, KL3204-0030
Default mapping for:
CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232, RS485
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch0 D1 | Ch0 D0
 | 1 | Ch1 D1 | Ch1 D0
 | 2 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D1 | Ch3 D0
Default mapping for:
PROFIBUS, Interbus
Conditions | Word offset | High byte | Low byte
Complete evaluation: no Motorola format: ja Word alignment: any | 0 | Ch0 D0 | Ch0 D1
 | 1 | Ch1 D0 | Ch1 D1
 | 2 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D0 | Ch3 D1
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch0 D0 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D1
 | 2 | Ch1 D1 | Ch1 D0
 | 3 | Ch2 D0 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D1
 | 5 | Ch3 D1 | Ch3 D0
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch0 D1 | Ch0 CB/SB
 | 1 | Ch1 CB/SB | Ch0 D0
 | 2 | Ch1 D0 | Ch1 D1
 | 3 | Ch2 D1 | Ch2 CB/SB
 | 4 | Ch3 CB/SB | Ch2 D0
 | 5 | Ch3 D0 | Ch3 D1
Default mapping for:
Lightbus, EtherCAT, Ethernet and Bus Terminal Controller (BCxxxx, BXxxxx)
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D1 | Ch0 D0
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D1 | Ch1 D0
Conditions | Word offset | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | res. | Ch0 CB/SB
 | 1 | Ch0 D0 | Ch0 D1
 | 2 | res. | Ch1 CB/SB
 | 3 | Ch1 D0 | Ch1 D1


Terminal configuration

Access from the user program [image] Terminal configuration
Terminal configuration
The terminal can be configured and parameterized via the internal register structure. Each terminal channel is mapped in the Bus Coupler. Depending on the type of the Bus Coupler and the mapping configuration (e.g. Motorola/Intel format, word alignment etc.) the terminal data are mapped in different ways to the Bus Coupler memory. For parameterizing a terminal, the control and status byte also has to be mapped.
BK2000 - Lightbus Coupler
In the BK2000 Lightbus coupler, the control and status byte is mapped in addition to the data bytes. This is always located in the low byte at the offset address of the terminal channel.
Example for KL3202:
Mapping BK2000
BK3000 - PROFIBUS coupler
For the BK3000 PROFIBUS coupler, the master configuration should specify for which terminal channels the control and status byte is to be inserted. If the control and status byte are not evaluated, the terminals occupy 2 bytes per channel:
▪
KL3201: 2 bytes of input data
▪
KL3202: 4 bytes of input data
▪
KL32x4: 8 bytes of input data
Example for KL3202:
Mapping BK3000
BK4000 - Interbus Coupler
The BK4000 Interbus Coupler maps the terminals in the delivery state with 2 bytes per channel:
▪
KL3201: 2 bytes of input data
▪
KL3202: 4 bytes of input data
▪
KL3204: 8 bytes of input data
Parameterization via the fieldbus is not possible. If the control and status byte is to be used, the KS2000 configuration software is required.
Example for KL3202:
Mapping BK4000
Overview of mapping configurations
The Appendix contains an overview of possible mapping configurations depending on the parameters that can be set.
Parameterization with KS2000
The parameterizations can be carried out independently of the fieldbus system with the KS2000 configuration software via the serial configuration interface in the Bus Coupler.


Register overview

Access from the user program [image] Register overview
Register overview
These registers exist once for each channel.
Address | Name | Default value | R/W | Storage medium
R0 | Raw ADC value | variable | R | RAM
R1 | Unprocessed ADC value for the leads | variable | R |
R2 | reserved | 0x0000 | R |
R3 | ... | ... | ... | ...
R5 | reserved | 0x0000 | R |
R6 | Diagnostic register | variable | R | RAM
R7 | Command register not used | 0x0000 | R |
R8 | Terminal type | e.g. 3202 | R | ROM
R9 | Software version number | 0x???? | R | ROM
R10 | Multiplex shift register | 0x0218/0130 | R | ROM
R11 | Signal channels | 0x0218 | R | ROM
R12 | Minimum data length | 0x0098 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0x???? | R/W | SEEROM
R17 | Hardware compensation: Offset | specific | R/W | SEEROM
R18 | Hardware compensation: Gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x00A0 | R/W | SEEROM
R21 | Offset register two-wire connection method | specific | R/W | SEEROM
R22 | reserved | 0x0000 | R/W | SEEROM
R3 | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0106 | R/W | SEEROM
R33 | User scaling: Offset | 0x0000 | R/W | SEEROM
R34 | User scaling: Gain | 0x0100 | R/W | SEEROM
R35 | reserved | 0x0000 | R/W | SEEROM
R36 | reserved | 0x0000 | R/W | SEEROM
R37 | Filter constant | 0x0138 | R/W | SEEROM
R38 | reserved | 0x0000 | R/W | SEEROM
R3 | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


General description of registers

Access from the user program [image] General description of registers
General description of registers
Complex terminals that possess a processor are able to exchange data bi-directionally with the higher-level controller. These terminals are referred to below as intelligent Bus Terminals. These include analog inputs, analog outputs, serial interface terminals (RS485, RS232, TTY etc.), counter terminals, encoder interface, SSI interface, PWM terminal and all other parameterizable terminals.
The main features of the internal data structure are the same for all the intelligent terminals. This data area is organized as words and comprises 64 registers. The important data and parameters of the terminal can be read and set through this structure. It is also possible for functions to be called by means of corresponding parameters. Each logical channel in an intelligent terminal has such a structure (4-channel analog terminals therefore have 4 sets of registers).
This structure is divided into the following areas:
(A detailed list of all registers can be found in the Appendix.)
Register | Use
0 to 7 | Process variables
8 to 15 | Type register
16 to 30 | Manufacturer parameters
31 to 47 | User parameters
48 to 63 | Extended user area
Additional information
•
Process variables
•
Type register
•
Manufacturer parameters
•
User parameters
•
Extended user area


Process variables

Access from the user program [image] General description of registers [image] Process variables
Process variables
R0 to R7: Registers in the internal RAM of the terminal
The process variables can be used in addition to the actual process image. Their function is specific to the terminal.
R0 to R5: Terminal-specific registers
The function of these registers depend on the respective terminal type (see terminal-specific register description).
▪
R6: Diagnostic register
The diagnostic register can contain additional diagnostic information. Parity errors, for instance, that occur in serial interface terminals during data transmission are indicated here.
▪
R7: Command register
High-Byte_Write = function parameter
Low-Byte_Write = function number
High-Byte_Read = function result
Low-Byte_Read = function number


Type register

Access from the user program [image] General description of registers [image] Type register
Type register
R8 to R15: Registers in the internal ROM of the terminal
The type and system parameters are hard programmed by the manufacturer, and the user can read them but cannot change them.
▪
R8: Terminal type
The terminal type in register R8 is needed to identify the terminal.
▪
R9: Software version (X.y)
The software version can be read as a string of ASCII characters.
▪
R10: Data length
R10 contains the number of multiplexed shift registers and their length in bits.
The Bus Coupler sees this structure.
▪
R11: Signal channels
Related to R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data type register
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure 1 byte n bytes
0x03 | Word array
0x04 | Structure 1 byte n words
0x05 | Double word array
0x06 | Structure 1 byte n double words
0x07 | Structure 1 byte 1 double word
0x08 | Structure 1 byte 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure 1 byte n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure 1 byte n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure 1 byte n double words with variable logical channel length
▪
R14: reserved
▪
R15: Alignment bits (RAM)
The alignment bits are used to place the analog terminal in the Bus Coupler on a byte boundary.


Manufacturer parameters

Access from the user program [image] General description of registers [image] Manufacturer parameters
Manufacturer parameters
R16 to R30: Manufacturer parameter area (SEEROM)
The manufacturer parameters are specific for each type of terminal. They are programmed by the manufacturer, but can also be modified by the controller. The manufacturer parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out.
These registers can only be altered after a code word has been set in R31.


User parameters

Access from the user program [image] General description of registers [image] User parameters
User parameters
R31 to R47: User parameter area (SEEROM)
The user parameters are specific for each type of terminal. They can be modified by the programmer. The user parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out. The user area is write-protected by a code word.
• R31: Code word register in RAM
The code word 0x1235 must be entered here so that parameters in the user area can be modified. If any other value is entered into this register, the write-protection is active. When write protection is not active, the code word is returned when the register is read. If the write protection is active, the register contains a zero value.
▪
R32: Feature register
This register specifies the terminal's operating modes. Thus, for instance, a user-specific scaling can be activated for the analog I/Os.
R33 to R47: Terminal-specific registers
The function of these registers depend on the respective terminal type (see terminal-specific register description).


Extended user area

Access from the user program [image] General description of registers [image] Extended user area
Extended user area
R47 to R63
This register specifies the terminal's operating modes. Thus, for instance, a user-specific scaling can be activated for the analog I/Os.


Terminal-specific register description

Access from the user program [image] Terminal-specific register description
Terminal-specific register description
Additional information
•
Process variables
•
Manufacturer parameters
•
User parameters
•
Output format


Process variables

Access from the user program [image] Terminal-specific register description [image] Process variables
Process variables
• R0: Raw ADC value X_R
This register contains the raw ADC value.
• R1: Raw ADC value of the line resistance between +R1 - RL1 or +R2 - RL2
• R2 to R5: Reserved
• R6: Diagnostic register
▪
High byte: not used
▪
Low byte: Status byte


Manufacturer parameters

Access from the user program [image] Terminal-specific register description [image] Manufacturer parameters
Manufacturer parameters
• R17: Hardware compensation - offset (B_a)
16 bit signed integer
This register is used for offset compensation of the terminal (Eq. 1.1).
Register value approx. 0xEDXX
• R18: Hardware compensation - gain (A_a)
16 bits * 16-5 (approx. 0.01907 Ω/digit)
This register is used for gain compensation of the terminal (Eq. 1.1).
Register value approx. 0x27XX
• R19: Manufacturer scaling - offset (B_h)
16 bit signed integer [0x0000]
This register contains the offset of the manufacturer's straight-line equation (1.5). The straight-line equation is activated via register R32.
• R20: Manufacturer scaling - gain (A_h)
16 bits signed integer *2-8 [0x00A0]
This register contains the scaling factor of the manufacturer's straight-line equation (1.5). The straight-line equation is activated via register R32.
• R21: Additional offset register for two-wire connection
The value of register 1 at short circuit +R1-RL1 or +R2-RL2
[approx. 0x01AX]


User parameters

Access from the user program [image] Terminal-specific register description [image] User parameters
User parameters
• R32: Feature register
[0x0106]
The feature register specifies the terminal's operating mode.
Feature bit no. |  | Description of the operating mode
Bit 0 | 1 | User scaling (R33, R44) active [0]
Bit 1 | 1 | Manufacturer scaling (R19, R20) active [1]
Bit 2 | 1 | Watchdog timer active [1] In the delivery state, the watchdog timer is switched on.
Bit 3 | 1 | Sign / amount representation [0] Sign / amount representation is active instead of two's-complement representation (-1 = 0x8001).
Bit 4 | 1 | Siemens output format [0] This bit is used for inserting status information on the lowest 3 bits (see below).
Bit 5,6 | - | reserved, do not change
Bit 7 | 1 | Activates filter constant in R37 [0]
Bit 8 | 1 | Over range Protection [1] If the temperature exceeds 850°C the status bits are correspondingly set and the output value is restricted to 850°C.
Bit 9 | - | reserved, do not change
Bit 10 | 1 | Two-wire connection [0]
Bit 11 | - | reserved, do not change
Bit 15,14,13,12 | Element | Valid measuring range
0 0 0 0 | PT100 | -200°C to 850°C
0 0 0 1 | NI100 | -60°C to 250°C
0 0 1 0 | PT1000 | -200°C to 850°C
0 0 1 1 | PT500 | -200°C to 850°C
0 1 0 0 | PT200 | -200° C to 850°C
0 1 0 1 | NI1000 | -200°C to 850°C
0 1 1 0 | NI120 | -80°C to 320°C
1 1 1 0 | Output in Ω | 10.0 Ω to 5000.0 Ω
1 1 1 1 | Output in Ω | 10.0 Ω to 1200.0 Ω


Output format

Access from the user program [image] Terminal-specific register description [image] Output format
Output format
If only manufacturer scaling via the feature register is active, the output format is as follows:
▪
1 digit corresponds to 1/10 °C or
▪
1 digit corresponds to 1/10 Ω
If no scaling is active, the output format is as follows:
▪
1 digit corresponds to 1/16 °C or
▪
1 digit corresponds to 1/16 Ω
If the Siemens output format is selected, the lowest three bits are used for status evaluation. The process data is represented in bits 3 to 15, with bit 15 representing the sign bit. Scaling of the measurement reading according to the Siemens standard has to be done via user scaling.
Bit Measured value | Bits 15-3 | Bit 2 X | Bit 1 Error | Bit 0 Overflow
out of range |  | 0 | 0 | 1
in range | Process data | 0 | 0 | 0
• R33: User scaling - offset (B_w)
16 bit signed integer
This register contains the offset of the user straight-line equation (1.6). The straight-line equation is activated via register R32.
• R34: User scaling (A_w)
16 bits signed integer* 2-8.
This register contains the scaling factor of the user straight-line equation (1.6). The straight-line equation is activated via register R32.
• R35 and R36: reserved
• R37: Filter constant
[0x0000]
Filter constants: | First notch [Hz] | Conversion time [ms]
0x0000 | 25 | 250
0x50 | 100 | 65
0xA0 | 50 | 125
0x140 | 25 | 250
0x280 | 12.5 | 500
• Validity of the documentation
This documentation applies to all terminals from firmware version 3x. The version number can be found within the serial number on the right-hand side face of the terminal: xxxx3xxx
Example: 52983A2A Þ The firmware version is 3A.


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Additional information
•
Control byte for process data exchange
•
Status byte for process data exchange
•
Compensation
•
Default setting of the registers
•
KL3202 as resistance input 0 to 1 kΩ


Control byte for process data exchange

Access from the user program [image] Control and status byte [image] Control byte for process data exchange
Control byte for process data exchange
The control byte is transmitted from the controller to the terminal. It can be used
▪
in register mode (REG = 1bin) or
▪
during process data exchange (REG = 0bin)
.
The control byte can be used to carry out gain and offset compensation for the terminal (process data exchange). This requires the code word to be entered in R31. The gain and offset of the terminal can then be compensated.
The parameter will only be saved permanently once the code word is reset!
Control byte:
▪
Bit 7 = 0bin
▪
Bit 6 = 1bin: Terminal compensation function is activated
▪
Bit 4 = 1bin: Calibration gain
▪
Bit 3 = 1 offset calibration
▪
Bit 2 = 0bin: slower cycle = 1000 ms
1bin: fast cycle = 50 ms
▪
Bit 1 = 1bin: up
▪
Bit 0 = 1bin: down


Status byte for process data exchange

Access from the user program [image] Control and status byte [image] Status byte for process data exchange
Status byte for process data exchange
The status byte is transmitted from the terminal to the controller. The status byte contains various status bits for the analog input channel:
Status byte:
▪
Bit 7 = 0bin
▪
Bit 6 = 1bin: Error (general error bit)
▪
Bit 5 to bit 2: reserved
▪
Bit 1 = 1bin: Overrange
▪
Bit 0 = 1bin: Underrange


Compensation

Access from the user program [image] Control and status byte [image] Compensation
Compensation
Implemented straight-line equation:
Y[Ω] = (X_Adc * G + B_h) * A_h + 100 Ω
Hence:
B_h consists of a component that depends on the gain of the A/D converter and a constant for calculating the axis offset of 100 Ω. The gain-dependent component calculates the offset of the external components (the offset of the component can be varied via adjustable amplification).
This procedure is necessary, because compensation at 0 Ω is technically not possible. The line is therefore compensated around the point 100 Ω (offset to the point and rotated around this point).
B_h: (B_off * G + B_100)
▪
Offset calibration should therefore be carried out for PT100 at 100 Ω (or PT1000 at 1000 Ω).
▪
Gain compensation is then carried out independently of the offset, e.g. at 300 Ω. 300 Ω corresponds to 557.7°C = 0x15C9


Default setting of the registers

Access from the user program [image] Control and status byte [image] Default setting of the registers
Default setting of the registers
▪
R17: 0xED68 corresponds to -90.8 Ω
▪
R18: 0x4E20 corresponds to 2000 * 16-5 = 0,01907 Ω/digit
▪
R19: 0x0000
▪
R20: 0x00A0
▪
R32: 0x0106
▪
R33: 0x0000
▪
R34: 0x0100
The gain and offset compensation only has to be carried out once, i.e. it does not have to be repeated or corrected for any of the other implemented elements.
For the two-wire connection, with short-circuited line resistance (+R1-Rl1) the raw ADC value of the line resistance (contained in R1) has to be entered in register R21.


KL3202 as resistance input 0 to 1 kΩ

Access from the user program [image] Control and status byte [image] KL3202 as resistance input 0 to 1 kΩ
KL3202 as resistance input 0 to 1 kΩ
If the KL3202 is used for resistance measurements, the following values should be written into the following registers:
• R32: Feature register: 0xF401
i.e. user scaling active with display of the measured value in Ohm and two-wire connection.
• R33: User scaling - offset (0x0000)
• R34: User scaling - gain (0x0010)
the display of the measured value follows:
Resistance in Ω | Output value
0 | 0
1000 | 1000


Register communication

Access from the user program [image] Register communication
Register communication
Additional information
•
Register access via process data exchange
•
Example 1
•
Example 2


Register access via process data exchange

Access from the user program [image] Register communication [image] Register access via process data exchange
Register access via process data exchange
Bit 7 = 1bin: Register mode
If bit 7 of the control byte is set, then the first two bytes of the user data are not used for exchanging process data, but are written into or read from the terminal's register set.
Bit 6 = 0bin: read
Bit 6 = 1bin: write
Bit 6 of the control byte specifies whether a register should be read or written. If bit 6 is not set, then a register is read out without modifying it. The value can then be taken from the input process image.
If bit 6 is set, then the user data is written into a register. As soon as the status byte has supplied an acknowledgement in the input process image, the procedure is completed (see example).
Bit 0 to 5: Address
The address of the register that is to be addressed is entered into bits 0 to 5 of the control byte.
Control byte in register mode
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
▪
REG = 0bin: Process data exchange
▪
REG = 1bin: Access to register structure
▪
W/R = 0bin: Read register
▪
W/R = 1bin: Write register
▪
A5...A0 = register address
Address bits A5 to A0 can be used to address a total of 64 registers.
Register-Modus Control Byte
The control or status byte occupies the lowest address of a logical channel. The corresponding register values are located in the following 2 data bytes. (The BK2000 is an exception: here, an unused (reserved) data byte is automatically inserted after the control or status byte, and the register value is therefore placed on a word boundary).


Example 1

Access from the user program [image] Register communication [image] Example 1
Example 1
Reading of register 8 in the BK2000 with a KL3202 and the end terminal:
If the following bytes are transferred from the control to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Not used | Control byte
Value | 0xXX | 0xXX | 0xXX | 0x88
the terminal returns the following type identifier (0x0C82 corresponds to unsigned integer 3202).
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Not used | Status byte
Value | 0x0C | 0x82 | 0x00 | 0x88


Example 2

Access from the user program [image] Register communication [image] Example 2
Example 2
Writing of register 31 in the BK2000 with an intelligent terminal and the end terminal:
If the following bytes (code word) are transferred from the control to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataOUT 1 | DataOUT 0 | Not used | Control byte
Value | 0x12 | 0x35 | 0xXX | 0xDF
the code word is set, and the terminal returns the register address with bit 7 for register access as acknowledgement.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | DataIN 1 | DataIN 0 | Not used | Status byte
Value | 0x00 | 0x00 | 0x00 | 0x9F


TwinCAT

TwinCAT
TwinCAT
PLC and Motion Control on the PC
TwinCAT - The Windows Control and Automation Technology
The TwinCAT automation software converts any compatible PC into a real-time controller with multi-PLC, NC axis control, programming environment and operating station. TwinCAT replaces conventional PLC and NC controllers as well as operating devices:
▪
open, compatible PC hardware
▪
Embedding of IEC 61131-3 software PLC, software NC and software CNC in Windows NT/2000/XP, NT/XP Embedded, CE
▪
Programming and runtime systems optionally together on one PC or separated
▪
Connection to all common fieldbus systems
▪
PC interfaces are supported
▪
Data communication with user interfaces and other programs by means of open Microsoft standards (OPC, OCX, DLL, etc.)
TwinCAT architecture
TwinCAT consists of runtime systems for real-time execution of control programs and development environments for programming, diagnosis and configuration. Any Windows programs, for instance visualization programs or Office programs, can access TwinCAT data via Microsoft interfaces, or can execute commands.
A practically oriented software solution
TwinCAT offers a precise time-base in which programs are executed with the highest deterministic features, independently of other processor tasks. The real-time load on a PC is set with TwinCAT: This achieves a defined operating behavior. TwinCAT displays the system load for running programs. A loading threshold can be set, in order to assure a defined computing capacity for the operating programs and for Windows NT/2000/XP. If this threshold is exceeded, a system message is generated.
TwinCAT supports system diagnosis
The general use of hardware and software from the open PC world requires some checking: Unsuitable components can upset the PC system. Beckhoff integrates a handy display of the real-time jitter in order to provide administrators with a simple means of evaluating hardware and software. A system message during operation can draw attention to error states.
Start/stop behavior
Depending on the setting, TwinCAT is started and stopped manually or automatically. Since TwinCAT is integrated into Windows NT/2000/XP as a service, an operator is not needed to start the system: switching on is enough.
Restarting and data backup
When a program is started or restarted, TwinCAT loads programs and remanent data. To backup data, and to shut down Windows NT/2000/XP correctly, a UPS (uninterruptible power supply) is of great value.
TwinCAT and "Blue Screen"
The TwinCAT system can be configured such that real-time capability is maintained in the event of a BSOD (Blue-Screen-of-Death) operating system crash. Real-time tasks such as PLC and NC can thus continue to run and place the controlled process in a safe state. Ultimately, it is the decision of the programmer whether or not to utilize this feature, bearing in mind that data or programs may already have been destroyed by the BSOD.
World-wide connection through message routing - "remote" connection is inherent to the system
According to the requirement for operating resources, the TwinCAT software devices can be distributed: TwinCAT PLC programs can be executed on PCs and on Beckhoff Bus Terminal controllers. A "message router" manages and distributes all the messages, both in the system and via TCP/IP connections. PC systems can be connected to one another by TCP/IP; Bus Terminal controllers are connected via serial interfaces and fieldbus systems (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP).
World-wide access
Since standard TCP/IP services from Windows NT/2000/XP are used, this data exchange can take place worldwide. The system offers scalable communication capacity and timeout periods for the monitoring of communications. OPC provides a standardized means for accessing many different SCADA packets. The SOAP (Simple Object Access Protocol) enables a connection between two computers to be established by means of an internet connection via standard HTTP. A TwinCAT component is available for this purpose.
Beckhoff Information System
Further information on the TwinCAT automation software can be found in the Beckhoff Information System.
The setup for installing the Beckhoff Information System is available to you on the Beckhoff Products & Solutions DVD and on our website for download.
In addition, the online version of the Beckhoff Information System can be found at https://infosys.beckhoff.com.
Additional information
•
Programming
•
Function block FB_KL320xConfig


Programming

TwinCAT [image] Programming
Programming
TwinCAT libraries
See software documentation in the Beckhoff Information System.
TwinCAT 2: TwinCAT PLC Lib: I/O functions
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_IoFunctions


Function block FB_KL320xConfig

TwinCAT [image] Function block FB_KL320xConfig
Function block FB_KL320xConfig
The function block FB-KL320xConfig can be used to configure the KL320x terminals. A more detailed description can be found in the Beckhoff Information System:
TwinCAT2: TwinCAT PLC Lib: I/O functions/Bus Terminal configuration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_I/O functions/Function blocks/Bus Terminal configuration


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com


Overview Analog Input Terminals

Overview Analog Input Terminals
Overview Analog Input Terminals
1-, 2- and 4 channel analog input terminals for Pt100 (RTD)
▪
KL3201
▪
KL3202
▪
KL3204-0000
4 channel analog input terminal for NTC10K
▪
KL3204-0030