KL31x2 - Two Channel Accurate Analog Terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.4.0
▪
Note on differential measurement added
2.3.0
▪
Example program added to chapter “KS2000 Configuration software“
2.2.0
▪
Update section “Technical data” (voltage measurement terminals only)
2.1.0
▪
Update section “Basic function principles”
2.0.0
▪
Migration
1.6.0
▪
Title page and introduction corrected
▪
Preface updated
▪
Technical data updated
1.5.0
▪
Register description updated (R32)
▪
Technical data updated
▪
KL3172-0500 and KL3172-1000 added
▪
ATEX notes added
1.4
▪
Control and status byte updated
▪
Mounting description expanded
1.3
▪
LED descriptions updated (prisms, new RUN LEDs)
▪
Connection description updated (power contacts, new pin assignment for terminal points)
▪
Channel switch-off added
▪
Technical data of the KL3142 and KL3152 updated
1.2.1
▪
Pin assignment corrected
1.2
▪
Register description extended (command 7000)
1.1
▪
Technical data updated
▪
Description of terminal points 3 and 7 adapted to final pin assignment
▪
KL3132, KL3142, KL3152, KL3162 and KL3182 added
1.0
First version (KL3172 only)
Firmware and hardware versions
Documen- tation, Version | KL3132-0000 |  | KL3142-0000 |  | KL3152-0000 |  | KL3162-0000 |  | KL3172-0000 |  | KL3172-0500, KL3172-1000 |  | KL3182-0000
 | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw | Firmw | Hardw
2.4.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 03 | 2D | 03
2.3.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
2.2.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
2.1.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
2.0.0 | 2D | 04 | 2E | 04 | 2D | 04 | 2D | 04 | 2D | 03 | 2D | 02 | 2D | 03
1.6.0 | 2D | 03 | 2E | 03 | 2D | 03 | 2D | 03 | 2D | 02 | 2D | 02 | 2D | 02
1.5.0 | 2D | 03 | 2E | 03 | 2D | 03 | 2D | 03 | 2D | 02 | 2D | 02 | 2D | 02
1.4 | 2A | 01 | 2B | 01 | 2A | 01 | 2A | 01 | 2A | 01 | - | - | 2A | 01
1.3 | 2A | 01 | 2A | 01 | 2A | 01 | 2A | 01 | 2A | 01 |  |  | 2A | 01
1.2.1 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.2 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.1 | 1A | 00 | 1A | 00 | 1A | 00 | 1A | 00 | 1B | 00 |  |  | 1A | 00
1.0 | - | - | - | - | - | - | - | - | B1 | 00 |  |  | - | -
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 35 04 1B 01:
35 - week of production 35
4 - year of production 2004
1B - firmware version 1B
1 - hardware version 1


Product overview

Product overview
Product overview
Additional information
•
KL3132, KL3162, KL3172, KL3182
•
KL3142, KL3152
•
Basic function principles
•
LEDs


KL3132, KL3162, KL3172, KL3182

Product overview [image] KL3132, KL3162, KL3172, KL3182
KL3132, KL3162, KL3172, KL3182
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] KL3132, KL3162, KL3172, KL3182 [image] Introduction
Introduction
KL3132
Two-channel analog terminals with voltage inputs (0.05% accuracy)
The analog input terminals KL3132, KL3162, KL3172 and KL3182 process signals in the range -10 V to +10 V. The voltage is digitized to a resolution of 16 bits, and is transmitted, electrically isolated, to the higher-level automation device. The input channels of one Bus Terminal have differential inputs and possess a common, internal ground potential. With their small measuring error of ±0.05% of the full scale value, these terminals are optimized for high-precision control processes, such as dosing, filling, or quality assurance. The Bus Terminals combine 2 channels in a single housing. Status and error LEDs indicate the terminal state.
Overview
KL3132-0000: -10 ... +10 V
KL3162-0000: 0 ... +10 V
KL3172-0000: 0.0 ... +2.0 V
KL3172-0500: 0.0 ... +0.5 V
KL3172-1000: 0.0 ... +1.0 V
KL3182-0000: -2.0 ... +2.0 V


Technical data

Product overview [image] KL3132, KL3162, KL3172, KL3182 [image] Technical data
Technical data
Technical data | KL3132-0000, KS3132-0000 | KL3162-0000, KS3162-0000 | KL3172-0000, KS3172-0000 | KL3172-0500, KS3172-0500 | KL3172-1000, KS3172-1000 | KL3182-0000, KS3182-0000
Number of inputs | 2
Input signal | -10 V ... +10 V | 0 ... 10 V | 0 ... 2 V | 0 ... 500 mV | 0 ... 1 V | -2 V ... +2 V
Input resistance | > 70 kΩ
Common-mode voltage UCM | ±10 V
Resolution | 16 bit
Conversion time | 140 ms, configurable
Measuring error (full measuring range) | ±0.05% of the full scale value, self-calibration
Bit width in the K-Bus I/O | 2 x 16 bit user data (optionally 2 x 8 bit control/status)
Bit width in the input process image | 2 data words, 2 status byte
Bit width in the output process image | 2 data words, 2 control byte
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 85 mA
Electrical isolation | 500 V (differential input / K-bus)
Connection | spring-loaded system
Pluggable wiring | for all KSxxxx terminals
Weight | approx. 70 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95%, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


KL3142, KL3152

Product overview [image] KL3142, KL3152
KL3142, KL3152
Additional information
•
Introduction
•
Technical data


Introduction

Product overview [image] KL3142, KL3152 [image] Introduction
Introduction
KL3142
Two-channel analog terminals with current inputs (0.05% accuracy)
The KL3142 and KL3152 analog input terminals handle signals in the range between 0 and 20 mA, and between 4 and 20 mA respectively. The current is digitized to a resolution of 16 bits (default: 15 bits), and is transmitted, in an electrically isolated form, to the higher-level automation device. The input channels of the Bus Terminals have differential inputs and possess a common, internal ground potential. With their small measuring error of ±0.05% of the full scale value, these terminals are optimized for high-precision control processes, such as dosing, filling, or quality assurance. The Bus Terminals combine 2 channels in a single housing. An open lead or overload condition are detected, and the terminal status is relayed to the controller via the K-bus. Status and error LEDs indicate the terminal state.
Overview
KL3142-0000: 0 ... 20 mA
KL3152-0000: 4 ... 20 mA


Technical data

Product overview [image] KL3142, KL3152 [image] Technical data
Technical data
Technical data | KL3142-0000, KS3142-0000 | KL3152-0000, KS3152-0000
Number of inputs | 2
Signal current | 0 ... 20 mA | 4 ... 20 mA
Internal resistance | 100 Ω measuring resistance
Common-mode voltage UCM | ±10 V
Resolution | 16 bit
Conversion time | 140 ms, configurable
Measuring error (full measuring range) | ±0.05% of the full scale value, self-calibration
Bit width in the K-Bus I/O | 2 x 16 bit user data (optionally 2 x 8 bit control/status)
Bit width in the input process image | 2 data words, 2 status byte
Bit width in the output process image | 2 data words, 2 control byte
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 85 mA
Surge voltage resistance | 35 VDC
Electrical isolation | 500 V (differential input / K-bus)
Connection | spring-loaded system
Pluggable wiring | for all KSxxxx terminals
Weight | approx. 70 g
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95%, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE, cULus, ATEX


Basic function principles

Product overview [image] Basic function principles
Basic function principles
The high-precision KL3172 analog input terminals can measure two voltages (KL3132, KL3162, KL3172, KL3182) or two currents (KL3142, KL3152) and display them with a resolution of 16 bits (65535 steps). High-precision measurements are ensured through cyclic self-calibration.
By default, the inputs are switched as differential inputs. In the terminals KL3132, KL3162, KL3172 and KL3182, the terminal point -E1 of the first channel can be connected to the internal analog ground with bit R32.6 of the feature register.
Process data
Analog values are represented as follows:
Input signal |  |  |  |  |  | Value
KL3142-0000 | KL3152-0000 | KL3162-0000 | KL3172-0000 | KL3172-0500 | KL3172-1000 | dec | hex
0 mA | 4 mA | 0 V | 0 V | 0 V | 0 V | 0 | 0x0000
20 mA | 20 mA | 10 V | 2 V | 500 mV | 1 V | 65535 | 0xFFFF
Input signal |  | Value
KL3132-0000 | KL3182-0000 | dec | hex
-10 V | -2 V | -32768 | 0x8000
+10 V | +2 V | +32767 | 0x7FFF
Calculation
The terminal continuously takes measured values and stores the raw values of its A/D converter in register R0 (RAM ). After each recording of the analog signal, a correction is calculated using the compensation and, if necessary, calibration values. This is followed by manufacturer and user scaling:
YA = (XADC + BA) x AA | (1.0) | Manufacturer compensation (if calibration inactive)
YA = ((XADC + BK) x AA) x (AGK / AK) | (1.1) | Manufacturer compensation / calibration (if calibration activated)
YH = YA x AH + BH | (1.2) | Manufacturer scaling
Yaus = YH x AW + BW | (1.3) | User scaling
Key
Name | Name | Unit | Register
XADC | Output value of the A/D converter | [1] | -
Yout | Process data for controller | [1] | -
BA | Vendor calibration: Offset (can be disabled via bit R32.5 of the feature register) | [1] | R17
AA | Vendor calibration: Gain (always active) | [1 x 2-16 + 1] | R18
BK | Calibration: Offset (can be enabled via bit R32.5 of the feature register) | [1] | R1
AK | Calibration: Gain (can be enabled via bit R32.5 of the feature register) | [1] | R2
AGK | Basic calibration: Gain (can be enabled via bit R32.5 of the feature register) | [1] | R23
BH | Manufacturer scaling: Offset (can be enabled via bit R32.1 of the feature register) | [1] | R19
AH | Manufacturer scaling: Gain (can be enabled via bit R32.1 of the feature register) | [1 x 2-8 + 1] | R20
BW | User scaling: Offset (can be enabled via bit R32.0 of the feature register) | [1] | R33
AW | User scaling: Gain (can be enabled via bit R32.0 of the feature register) | [1 x 2-8 + 1] | R34
Calibration
The analog channels are self‑calibrated periodically. Analog switches are provided for this purpose, so that the various calibration signals can be connected. It is important for this process that the entire signal path, including all passive components, is examined at every phase of the calibration. Only the interference suppression elements (L/C combination) and the analog switches themselves cannot be examined.
The calibration interval is set in register R40 in steps of 100 ms. During calibration, no current process data are present. Value 0 is present. The terminal indicates active calibration by setting bit SB1.6 in the status byte, and by switching off the associated RUN LED. Calibration can be disabled by the controller via control byte CB1.1 if necessary. If calibration is disabled over a prolonged period, the terminal carries out a forced calibration, in order to compensate any voltage drifts that may be caused by changes in temperature. The forced calibration interval is specified via register R44 as a multiple of the calibration interval. If a further calibration between two cycles is required, this can be started manually by setting bit CB1.0. The terminal then acts as if it had triggered a calibration itself.
Fluctuating measurement signals disturbing the self‑calibration
The terminal checks by a stabilization test while in calibration state whether the input signal is stable. Large variations of measurement signals prevent a completion of the self‑calibration; the terminal remains in Error=1 and overload/underload=1, see sections "Basic function principles/ Calibration" and "Access from the user program/ Status byte 1 (for process data mode)".
If such a signal will be expected on a system plant, you can optionally:
‑ lock the self‑calibration within the process via Control‑Bit CB 1.1 as long a smooth signal is present and the self‑calibration passes.
‑ disabling the stabilization test process via bit R32.7.
‑ disabling the indication of the stabilization error by bit R32.14.
‑ increase the tolerance window of the stabilization control by register R48.
The functionality of the calibration including all features invariably refers to both channels simultaneously! The channels cannot be calibrated individually. For this reason, the registers R40, R44, R47 and R48 are only implemented once for both channels.
▪
In the first phase of the calibration, an input voltage of 0 V is applied to both analog inputs (zero calibration). The zero points of both analog input stages can be determined in this way. For this measurement, the respective absolute value of the channels is of interest. The value is subsequently stored in the RAM (register R1).
▪
During the second calibration phase, an internal reference voltage of approx. 1.8 V (final calibration) is applied to both analog inputs. In this case, it is no longer the absolute value of the measurement result that is of interest, but only any deviation from the basic calibration value determined during production (register R23). The ratio between the two values is calculated and used in the next correction calculation. The value is subsequently stored in the RAM (register R2).
Stabilization of the calibration
During the calibration, a stabilization of the offset and gain values is carried out. The calibration values are only accepted once a certain number (specified via register R47) of measured values is inside a certain tolerance range (specified via register R48). This further increases the precision. This function can be deactivated via bit R32.7 .
Limit values
The terminal offers the option of monitoring two limit values per channel. Limit value 1 can be specified via register R35, and limit value 2 via register R36. They are activated via bits in the feature registers R32.9 and R32.10. The status of the current process data value is indicated to the controller via the status byte SB1. Possible states are: Process data equal limit value (3), process data less than limit value (2), process data greater than limit value (1).
Limiting the measuring range
The terminal indicates any violation of the measuring range to the higher-level controller via the status byte.
▪
If the current measured value is larger than 0xFFFF or 0x7FFF, bit SB1.1 is set.
▪
Is the current measured value is less than 0 or 0x8000, bit SB1.0 is set.
In both cases, the ERROR LED of the respective channel will be on. This function can be deactivated via bit R32.8.
Differential measurement
With the KL3132, KL3162, KL3172, KL3182, the differential measurement can be deactivated in R32.6. Then, for channels 1 and 2, the input is internally switched to GND at terminal point 3/7, which must then be wired externally accordingly.
Differential measuring


LEDs

Product overview [image] LEDs
LEDs
LEDs
LED
Display
K-bus power
(green)
ON
Power supply (5 V) available on the K-bus
OFF
No power supply (5 V) available on the K-bus
K-Bus Run
(green)
ON
Data transmission on the K-bus is active
OFF
Data transmission on the K-bus is not active
Run 1
(green)
ON
Channel 1 active:
▪
process data contain valid analog value
OFF
Channel 1 not active:
▪
Calibration is performed, analog value in the process data not current (frozen or zero)
▪
or channel 1 is switched off (if LED error 1 not lit)
Error 1
(red)
ON
▪
Analog value of channel 1 is above the valid measuring range, specified through register R21 of channel 1. Bit SB1.1 is set in the status byte of channel 1.
▪
Analog value of channel 1 is below the valid measuring range, specified through register R22 of channel 1. Bit SB1.0 is set in the status byte of channel 1.
▪
Calibration is in progress. The LED goes out when the calibration is complete.
OFF
▪
Analog value of channel 1 is within the valid measuring range (if LED Run 1 is lit)
▪
or channel 1 is switched off (if LED Run 1 is not lit)
Run 2
(green)
ON
Channel 2 active:
▪
process data contain valid analog value
OFF
Channel 2 not active:
▪
Calibration is performed, analog value in the process data not current (frozen or zero)
▪
or channel 2 is switched off (if LED error 2 not lit)
Error 2
(red)
ON
▪
Analog value of channel 2 is above the valid measuring range, specified through register R21 of channel 2. Bit SB2.1 is set in the status byte of channel 2.
▪
Analog value of channel 2 is below the valid measuring range, specified through register R22 of channel 2. Bit SB2.0 is set in the status byte of channel 2.
▪
Calibration is in progress. The LED goes out when the calibration is complete.
OFF
▪
Analog value of channel 2 is within the valid measuring range (if LED Run 2 is lit)
▪
or channel 2 is switched off (if LED Run 2 is not lit)
Limiting the measuring range
The terminal indicates any violation of the measuring range to the higher-level controller via the status byte. If the current measured value is:
▪
greater than specified in register R21, bit 1 is set in the status byte,
▪
smaller than specified in register R22, bit 0 is set in the status byte.
In both cases, the ERROR LED of the respective channel will be on. This display can be disabled through bit R32.8.


Fitting and wiring

Fitting and wiring
Fitting and wiring
Additional information
•
Installation on mounting rails
•
Connection
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation
•
Application example for KL3172-0000


Installation on mounting rails

Fitting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Fitting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding
•
Pin assignment


Connection system

Fitting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Fitting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Fitting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


Pin assignment

Fitting and wiring [image] Connection [image] Pin assignment
Pin assignment
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
KL3132 - pin assignment
KL3142 - pin assignment
Terminal point | No. | Connection for
Input 1+ | 1 | + input channel 1
Input 1- | 2 | - input channel 1
GND | 3 | Internal ground (internally connected to terminal point 7)
Shield | 4 | PE contact (internally connected to terminal point 8)
Input 2+ | 5 | + input channel 2
Input 2- | 6 | - input channel 2
GND | 7 | Internal ground (internally connected to terminal point 3)
Shield | 8 | PE contact (internally connected to terminal point 4)
Note
Power contacts connected to the next terminal
In hardware version 01 or higher, two power contacts are connected to the next terminal. However, they are not used by the KL31x2.
Please be aware of this when you update from hardware version 00.
The hardware version of your terminal is indicated by the serial number, which is printed on the side of the terminal.


ATEX - Special conditions (standard temperature range)

Fitting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 94/9/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60529! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX Documentation

Fitting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Application example for KL3172-0000

Fitting and wiring [image] Application example for KL3172-0000
Application example for KL3172-0000
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Monitoring the cell voltages of a battery with several KL3172.
KL3172-0000 - application example
Note
Do not exceed the dielectric strength!
Please note that the sum of the cell voltages (in the example UB = n x 1.5 V) must not exceed the dielectric strength (electrical isolation 500 V) of the KL3172!


Configuration Software KS2000

Configuration Software KS2000
Configuration Software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Sample program for KL register communication via EtherCAT on KL3314 exemplary


KS2000 - Introduction

Configuration Software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration Software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a Ethernet Coupler BK9000
▪
a digital input terminal KL1xx2
▪
a precise two-channel analog input terminal for signals between 0 and 2 V, KL3172
▪
a bus end terminal KL9010
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of the KL3172
For the KL3172, the branches Register, Settings and ProcData are displayed:
▪
Register enables direct access to the KL3172 registers.
▪
A dialog mask for the parameterization of the KL3172 can be found under Settings.
▪
ProcData displays the KL3172 process data.


Register

Configuration Software KS2000 [image] Register
Register
You can access the registers of the KL3172 directly under Register. The meaning of the register is explained in the register overview.
Register view in KS2000


Settings

Configuration Software KS2000 [image] Settings
Settings
The dialog mask for the parameterization of the KL3172 can be found under Settings.
Settings via KS2000
Operation mode
Channel disabled (R32.11)
Here you can disable this channel, in order facilitate a faster cycle time for the other channel (default: not disabled).
Disabling of a channel is indicated by its Run and error LEDs going out.
User scaling active (R32.0)
You can activate user scaling here (default: deactivated).
Manufacturer scaling active (R32.1)
You can activate manufacturer scaling here (default: deactivated).
Watchdog timer active (R32.2)
You can deactivate the watchdog timer here (default: activated).
Signed amount representation (R32.3)
You can activate the signed amount representation here (default: deactivated).
Siemens output format (R32.4)
You can activate Siemens output format here (default: deactivated).
Calibration active (R32.5)
You can deactivate the calibration here (default: activated).
Differential measurement (R32.6)
You can deactivate the differential measurement here (default: activated).
Stabilization of calibration active (R32.7)
You can deactivate the stabilization of the calibration here (default: activated).
Limitation of the measuring range active (R32.8)
You can deactivate the limitation of the measuring range here (default: activated).
Limit value 1 active (R32.9)
You can activate the limit value 1 here (default: deactivated).
Limit value 2 active (R32.10)
You can activate the limit value 2 here (default: deactivated).
Register values
User offset (R33)
You can specify the user offset between -32768 and 32767 here (default: 0).
User gain (R34)
You can specify the user gain between 0 and 65535 here (default: 256, corresponding to a factor of 1).
Calibration interval (R40)
You can specify the calibration interval for the reference signal here in steps of 100 ms (default: 300 s).
Forced calibration interval (R44)
You can specify the interval for the forced calibration here. This interval is always a multiple (default: 3dez) of the calibration interval. The interval for forced calibration when the terminal leaves the factory is therefore 3 x 180 s = 900 s.
Number of stable measured values (R47)
You can specify the number of measured values used for the calibration here (default: 50).
Tolerance for measured value stability (R48)
You can specify the stable measured value tolerance for the calibration here (default: 5).
Limit value 1 (R35)
You can specify the limit value 1 here (default: 0).
Limit value 2 (R36)
You can specify the limit value 2 here (default: 0).
Filter constant (R37.11-R37.4)
The filter constant SF specifies the 3dB limit frequency of the sinc3 filter (default: 860dec).
Fast-Step Mode(TM) enabled (R37.0)
You can activate Fast Step Mode here (default: deactivated). A fast reaction to jumps at the input follows in fast step mode, in spite of the filter stage being active. In this case the filter is bypassed!
FIR filter active (R37.1)
You can deactivate the FIR filter here (default: activated).


Sample program for KL register communication via EtherCAT on KL3314 exemplary

Configuration Software KS2000 [image] Sample program for KL register communication via EtherCAT on KL3314 exemplary
Sample program for KL register communication via EtherCAT on KL3314 exemplary
Using the sample programs
This document contains sample applications of our products for certain areas of application. The application notes provided here are based on typical features of our products and only serve as examples. The notes contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
Program description / function
This example program (TwinCAT 3) provides change of single register values of the KL3314 as selection of the element type, characteristical settings of the feature register R32 and user scaling offset and gain (R33/ R34) similar as per KS2000.
Settings of KL3314 via visualisation of TwinCAT 3
At least following configuration setup shall be present:
[coupler (e.g. BK1120) or embedded PC] + KL3314 + KL9010.
Download:
Preparations for starting the sample programs (tnzip file / TwinCAT 3)
▪
Click on the download button to save the Zip archive locally on your hard disk, then unzip the *.tnzip archive file in a temporary folder.
Opening the *. tnzip archive
▪
Select the .tnzip file (sample program).
▪
A further selection window opens. Select the destination directory for storing the project.
▪
For a description of the general PLC commissioning procedure and starting the program please refer to the terminal documentation or the EtherCAT system documentation.
▪
The EtherCAT device of the example should usually be declared your present system. After selection of the EtherCAT device in the “Solutionexplorer” select the “Adapter” tab and click on “Search...”:
Search of the existing HW configuration for the EtherCAT configuration of the example
▪
Checking NetId: the "EtherCAT" tab of the EtherCAT device shows the configured NetId: .
The first 4 numbers have to be identical with the project NetId of the target system. The project NetId can be viewed within the TwinCAT environment above, where a pull down menu can be opened to choose a target system (by clicking right in the text field). The number blocks are placed in brackets there next to each computer name of a target system.
▪
Modify the NetId: By right clicking on "EtherCAT device" within the solution explorer a context menu opens where "Change NetId..." have to be selected. The first 4 numbers of the NetId of the target computer have to be entered; the both last values are 4.1 usually.
Example:
–
NetId of project: myComputer (123.45.67.89.1.1)
–
Entry via „Change NetId...“: 123.45.67.89.4.1


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Mapping
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The terminals KL3132, KL3162, KL3142, KL3152 KL3172 and KL3148 are represented in the process image with a maximum of 6 bytes of input data and 6 bytes of output data. These are organized as follows:
Format | Input data | Output data
Byte | SB1 | CB1
Word | DataIN1 | DataOUT1
Byte | SB2 | CB2
Word | DataIN2 | DataOUT2
Key
SB n: Status byte for channel n
CB n: Control byte for channel n
DataIN n: Input data word channel n
DataOUT n: Output data word channel n
▪
Please refer to the Mapping page for the allocation of the bytes and words to the addresses of the controller.
▪
The meaning of the control and status bytes is explained in Control and status bytes.
▪
In process data mode the analog values are transferred in output data words DataIN1 and DataIN2. Input data words DataOUT1 and DataOUT2 are not used.
Representation of the analog values
The analog input values are represented by the terminals as follows:
KL3132-0000
Voltage | Decimal | Hexadecimal
-10 V | -32768 | 0x8000
+10 V | +32767 | 0x7FFF
KL3142-0000
Current | Decimal | Hexadecimal
0 mA | 0 | 0x0000
20 mA | 65535 | 0xFFFF
KL3152-0000
Current | Decimal | Hexadecimal
4 mA | 0 | 0x0000
20 mA | 65535 | 0xFFFF
KL3162-0000
Voltage | Decimal | Hexadecimal
0 V | 0 | 0x0000
10 V | 65535 | 0xFFFF
KL3172-0000
Voltage | Decimal | Hexadecimal
0 V | 0 | 0x0000
2 V | 65535 | 0xFFFF
KL3172-0500
Voltage | Decimal | Hexadecimal
0 V | 0 | 0x0000
500 mV | 65535 | 0xFFFF
KL3172-1000
Voltage | Decimal | Hexadecimal
0 V | 0 | 0x0000
1 V | 65535 | 0xFFFF
KL3182-0000
Voltage | Decimal | Hexadecimal
-2 V | -32768 | 0x8000
+2 V | +32767 | 0x7FFF


Mapping

Access from the user program [image] Mapping
Mapping
The Bus Terminals occupy addresses within the process image of the controller. The assignment of process data (input and output data) and parameterization data (control and status bytes) to the control addresses is called mapping. The type of mapping depends on:
▪
the fieldbus system used
▪
the terminal type
▪
the parameterization of the Bus Coupler (conditions) such as
–
compact or full evaluation
–
Intel or Motorola format
–
word alignment switched on or off
The Bus Couplers (BKxxxx, LCxxxx) and Bus Terminal Controllers (BCxxxx, BXxxxx) are supplied with certain default settings. The default setting can be changed with the KS2000 configuration software or with a master configuration software (e.g. TwinCAT System Manager or ComProfibus).
The following tables show the mapping depending on different conditions. For information about the contents of the individual bytes please refer to the pages Process image and Control and status byte.
Compact evaluation
For compact evaluation, the analog input terminals only occupy addresses in the input process image. Control and status bytes cannot be accessed.
Compact evaluation in Intel format
Default mapping for CANopen, CANCAL, DeviceNet, ControlNet, Modbus, RS232 and RS485 coupler
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: any | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
Compact evaluation in Motorola format
Default mapping for PROFIBUS and Interbus coupler
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: any | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
Complete evaluation
For complete evaluation, the analog input terminals occupy addresses in the input and output process image. Control and status bytes can be accessed.
Complete evaluation in Intel format
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Complete evaluation in Motorola format
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Complete evaluation in Intel format with word alignment
Default mapping for Lightbus, EtherCAT and Ethernet coupler as well as Bus Terminal Controllers (BCxxxx, BXxxxx)
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
Complete evaluation in Motorola format with word alignment
 | Address | Input data |  | Output data
Requirements | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Key
Complete evaluation: In addition to the process data, the control and status bytes are also mapped into the address space.
Motorola format: Motorola or Intel format can be set.
Word alignment: In order for the channel address range to commence at a word boundary, empty bytes are inserted into the process image as appropriate.
SB n: Status byte for channel n (appears in the input process image).
CB n: Control byte for channel n (appears in the output process image).
Ch n D0: channel n, lower-value data byte
Ch n D1: channel n, higher-value data byte
reserved: This byte is assigned to the process data memory, although it has no function.
"-": This byte is not assigned or used by the terminal/module.


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | CaliDisReq | StartManCali
Key
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 to CB1.2 | - | 0bin | reserved
CB1.1 | CaliDisReq | 1bin | Blocking automatic calibration
CB1.0 | StartManCali | 1bin | start manual calibration
Status byte 1 (for process data mode)
The status byte 1 (SB1) is located in the input image and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | StateThreshold2 |  | StateThreshold1 |  | Overload | Underload
Key
Bit
Name
Description
SB1.7
RegAccess
0bin
Acknowledgment for process data mode
SB1.6
Error
0bin
no error detected
1bin
KL3142 up to firmware 2B
▪
Overload (bit SB1.1 is set) or
▪
Underload (bit SB1.0 is set)
KL3142 with firmware 2C or higher
and R32.14 = 1bin
KL3132, KL3152, KL3162, KL3172, KL3182 up to firmware 2A
KL3132, KL3152, KL3162, KL3172, KL3182 with firmware 2B or higher
and R32.14 = 1bin
KL3142 with firmware 2C or higher
▪
The last calibration was terminated with an error (no stability)
KL3132, KL3152, KL3162, KL3172, KL3182 with firmware 2B or higher
SB1.5, SB1.4
StateThreshold2
00bin
Limit value 2 is not enabled via bit R32.10 of the feature register
01bin
Process data is less than limit value 2
10bin
Process data is greater than limit value 2
11bin
Process data equals limit value 2
SB1.3, SB1.2
StateThreshold1
00bin
Limit value 1 is not enabled via bit R32.9 of the feature register
01bin
Process data is less than limit value 1
10bin
Process data is greater than limit value 1
11bin
Process data equals limit value 1
SB1.1
Overload
1bin
Process data is greater than specified in register R21. The red error LED of this channel is lit.
The calibration is active if SB1.0 and SB1.1 are set simultaneously.
SB1.0
Underload
1bin
Process data are less than specified in register R22. The red error LED of this channel is lit.
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.
Status byte 1 (in register communication)
The status byte 1 (SB1) is located in the input image and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgment for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for the parameterization of the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Raw ADC value |  | 0x0000 | 0dec | R | RAM
R1 | Calibration value: Offset |  | typically 0x0046 | typically 70dec | R | RAM
R2 | Calibration value: Gain |  | typically 0xF1CC | typically 61900dec | R | RAM
R3 | reserved |  | - | - | - | -
R4 | reserved |  | - | - | - | -
R5 | reserved |  | - | - | - | -
R6 | Diagnostic register |  | 0x0000 | 0dec | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL3132: | 0xC3C | 3132dec | R | ROM
 |  | KL3142: | 0xC46 | 3142dec
 |  | KL3152: | 0xC50 | 3152dec
 |  | KL3162: | 0xC5A | 3162dec
 |  | KL3172: | 0x0C64 | 3172dec
 |  | KL3182: | 0x0C6E | 3182dec
R9 | Firmware version |  | e.g. 0x3141 | e.g. 12609dec | R | ROM
R10 | Multiplex shift register |  | 0x0218 / 0x0130 | 536dec / 304dec | R | ROM
R11 | Signal channels |  | 0x0218 | 536dec | R | ROM
R12 | minimum data length of a channel |  | 0x0098 | 152dec | R | ROM
R13 | Data structure |  | 0x0007 | 7dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | typically 0x7F80 | typically 32,640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | SEEPROM
R17 | Vendor calibration: Offset |  | typically 0x0046 | 70dec | R/W | SEEPROM
R18 | Vendor calibration: Gain |  | typically 0x5208 | typically 21000dec | R/W | SEEPROM
R19 | Manufacturer scaling: Offset |  | 0x0000 | 0dec | R/W | SEEPROM
R20 | Manufacturer scaling: Gain | KL3162, KL3172, KL3142, KL3152: | 0x0100 | 256dec | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x0080 | 128dec
R21 | Upper limitation of the measuring range | KL3162, KL3172, KL3142, KL3152: | 0xFFFF | 65535dec | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x7FFF | +32767dec
R22 | Lower limitation of the measuring range | KL3162, KL3172, KL3142, KL3152: | 0x0000 | 0dec | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x8000 | -32768dec
R23 | Reference calibration value: Offset |  | typically 0x0046 | typically 70dec | R/W | SEEPROM
R24 | Reference calibration value: Gain |  | typically 0xF1CC | typically 61900dec | R/W | SEEPROM
R25 | reserved |  | - | - | - | -
... | reserved |  | - | - | - | -
R28 | reserved |  | - | - | - | -
R29 | Terminal type, special identification | KL3132-0000 | 0x0000 | 0dec | R | ROM
 |  | KL3142-0000 | 0x0000 | 0dec
 |  | KL3152-0000 | 0x0000 | 0dec
 |  | KL3162-0000 | 0x0000 | 0dec
 |  | KL3172-0000 | 0x0000 | 0dec
 |  | KL3172-0500 | 0x01F4 | 500dec
 |  | KL3172-1000 | 0x03E8 | 1000dec
 |  | KL3182-0000 | 0x0000 | 0dec
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | KL3162, KL3172, KL3142, KL3152: | 0x0180 | 384dec | R/W | SEEPROM
 |  | KL3132, KL3182: | 0x0182 | 386dec
Register no. | Comment | Default value |  | R/W | Memory
R33 | User offset | 0x0000 | 0dec | R/W | SEEPROM
R34 | User gain | 0x0100 | 256dec | R/W | SEEPROM
R35 | Limit value 1 | 0x0000 | 0dec | R/W | SEEPROM
R36 | Limit value 2 | 0x0000 | 0dec | R/W | SEEPROM
R37 | Filter constants of the A/D converter, and configuration bits for the filter | 0x35C0 | 13760dec | R/W | SEEPROM
R38 | reserved | - | - | - | -
R39 | reserved | - | - | - | -
R40 | Calibration interval *) | 0x0708 | 1800dec | R/W | SEEPROM
R41 | reserved | - | - | - | -
... | reserved | - | - | - | -
R43 | reserved | - | - | - | -
R44 | Interval for forced calibration **) | 0x0003 | 3dec | R/W | SEEPROM
R45 | reserved | - | - | - | -
R46 | reserved | - | - | - | -
R47 | Number of stable measured values | 0x0032 | 50dec | R/W | SEEPROM
R48 | Tolerance for measured value stability | 0x0005 | 5dec | R/W | SEEPROM
R49 | reserved | - | - | - | -
... | reserved | - | - | - | -
R63 | reserved | - | - | - | -
*) In multiples of 100 ms
**) In multiples of register R40


Register description

Access from the user program [image] Register description
Register description
The registers are used for the parameterization of the Bus Terminals and are available for each channel. They can be read or written by means of register communication.
R0: Raw ADC value
Register R0 contains the raw value of the analog/digital converter. This is the unchanged analog value prior to any scaling.
R1: Calibration value - offset
After a calibration, the offset value that was determined is entered in register R1 and used for the correction calculation.
R2: Calibration value - gain
After a calibration, the gain value that was determined is entered in register R2 and used for the correction calculation.
R6: Diagnostic register
Status byte SB1 is placed into register R6.
R7: Command register
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the factory settings for the following registers of both channels:
KL3162, KL3172, KL3142, KL3152:
R32: 0x0180 (384dec)
R33: 0x0000 (0dec)
R34: 0x0100 (256dec)
R35: 0x0000 (0dec)
R36: 0x0000 (0dec)
R37: 0x35C0 (13760dec)
R40: 0x0708 (1800dec)
R44: 0x0003 (3dec)
R47: 0x0032 (50dec)
R48: 0x0005 (5dec)
KL3132, KL3182:
R32: 0x0182 (386dec)
R33: 0x0000 (0dec)
R34: 0x0100 (256dec)
R35: 0x0000 (0dec)
R36: 0x0000 (0dec)
R37: 0x35C0 (13760dec)
R40: 0x0708 (1800dec)
R44: 0x0003 (3dec)
R47: 0x0032 (50dec)
R48: 0x0005 (5dec)
Restore Factory Settings
The Restore Factory Settings command simultaneously resets both terminal channels to the delivery state, irrespective from which register it is called.
R8: Terminal description
The description of the terminal is contained in register R8.
KL3172: 0x0C64 (3172dec)
KL3182: 0x0C6E (3182dec)
KL3132: 0xC3C (3132dec)
KL3162: 0xC5A (3162dec)
KL3142: 0xC46 (3142dec)
KL3152: 0xC50 (3152dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.
R12: Minimum data length of a channel
Bits 0 to 6 of the high-order byte specify the minimum number of output data in bits: 000.0000bin = 0dec, so 0 bytes.
Bits 0 to 6 of the low-order byte specify the minimum number of input data in bits: 001.1000bin = 24dec, hence 3 bytes.
The fact that bit 7 is set indicates that the control and status byte are not mandatory for the terminal function and are not transferred in compact mode.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R17: Vendor calibration - offset
This register contains the vendor calibration offset (16 bit signed integer).
R18: Vendor calibration - gain
This register contains the vendor calibration gain (16 bit unsigned integer x 2-16 + 1). Examples:
0x0000 means factor 1
0xFFFF means factor 2
R19: Manufacturer scaling - offset:
This register contains the offset of the manufacturer scaling. Can be activated via R32.1 in the feature register (16 bit signed integer).
R20: Manufacturer scaling - gain:
This register contains the gain of the manufacturer scaling. Can be activated via R32.1 in the feature register (16 bit unsigned integer x 2-8 + 1). Examples:
0x0100 means factor 1.
0x0080 means factor 0.5
R21: Upper measuring range limit
This register contains the upper measuring range limit. It can be activated by R32.8 in the feature register.
R22: Lower measuring range limit
This register contains the lower measuring range limit. It can be activated by R32.8 in the feature register.
R23: Reference calibration value: Offset
This register contains the reference value of the calibration, which is determined during the vendor calibration.
R24: Reference calibration value: Gain
This register contains the reference value of the calibration, which is determined during the vendor calibration.
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | Callibration Display | Display StabilityError | - | - | disChannel | enTh2 | enTh1 | enOverProt
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | enStable | disDiff Measure | disCali | enSiemensFormat | enAverageFormat | disWd Timer | enManScal | enUsrScal
Key
Bit | Name | Description |  | default
R32.15* | CallibrationDisplay | 0bin | During the calibration, the terminal sets the overload bit SB1.1 and the underload bit SB1.0. | 0bin
 |  | 1bin | Compatibility mode: During calibration, the terminal sets the error bit SB1.6.
R32.14* | Display StabilityError | 0bin | Stability error is not displayed. | 0bin
 |  | 1bin | If no stabilization of the calibration values is achieved, the terminal indicates this by setting the error bit SB1.6. (see note below)
Fluctuating measuring signals
Strongly fluctuating measuring signals can make stabilization of the calibration values impossible. In this case, skip the stabilization and disable it with bit R32.7.
Bit | Name | Description |  |  | default
R32.13 | - | reserved |  |  | 0bin
R32.12 | - | reserved |  |  | 0bin
R32.11 | disChannel | 0bin | Channel switched on |  | 0bin
 |  | 1bin | Channel switched off
R32.10 | enTh2 | 0bin | Limit value 2 is not active |  | 0bin
 |  | 1bin | Limit value 2 is active
R32.9 | enTh1 | 0bin | Limit value 1 is not active |  | 0bin
 |  | 1bin | Limit value 1 is active
R32.8 | enOverProt | 0bin | Measuring range limitation not active |  | 1bin
 |  | 1bin | Measuring range limitation active
R32.7 | enStable | 0bin | Stabilization of the calibration value not active |  | 1bin
 |  | 1bin | Stabilization of the calibration value active
R32.6 | disDiffMeasure | 0bin | Differential measurement active |  | 0bin
 |  | 1bin | Differential measurement not active (only KL3132, KL3162, KL3172, KL3182)
R32.5 | disCali | 0bin | Cyclic calibration of the A/D converter active |  | 0bin
 |  | 1bin | Cyclic calibration of the A/D converter not active
R32.4 | enSiemensFormat | 0bin | Siemens output format not active |  | 0bin
 |  | 1bin | Siemens output format active
R32.3 | enAverageFormat | 0bin | Signed amount representation not active |  | 0bin
 |  | 1bin | Signed amount representation active
R32.2 | disWdTimer | 0bin | Watchdog timer is active (the watchdog is triggered if no process data are received for 100 ms) |  | 0bin
 |  | 1bin | Watchdog timer is not active
R32.1 | enManScal | 0bin | Manufacturer scaling is not active | KL3162, KL3172, KL3142, KL3152: | 0bin
 |  | 1bin | Manufacturer scaling is active | KL3132, KL3182: | 1bin
R32.0 | enUsrScal | 0bin | User scaling is not active |  | 0bin
 |  | 1bin | User scaling is active
*) Bit R32.14 and bit R32.15 are only available with the following firmware versions:
▪
KL3132, KL3152, KL3162, KL3172, KL3182: Firmware version 2B or higher
▪
KL3142: Firmware version 2C or higher
For lower firmware versions, bits R32.14 and R32.15 are not evaluated.
These terminals always set the error bit SB1.6 during the calibration and cannot indicate the stability error!
R33: User scaling - offset
This register contains the offset of the user scaling. The user scaling can be activated in the feature register through bit R32.0 (16 bit signed integer).
R34: User scaling - gain
This register contains the gain of the user scaling. The user scaling can be activated in the feature register through bit R32.0 (16 bit unsigned integer x 2-8 + 1. 1dec corresponds to 0x0100).
R35: Limit value 1
Limit value 1 is entered in register R35. The limit value can be activated in the feature register through bit R32.9.
R36: Limit value 2
Limit value 2 is entered in register R36. The limit value can be activated in the feature register through bit R32.10.
R37: Filter constants of the A/D converter, and configuration bits for the filter
(default value: 35C0hex)
The terminal has two low-pass filter stages:
▪
The first stage consists of a sinc3 filter, and is always active.
▪
The second stage consists of a 22nd order FIR filter. This can be deactivated.
Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Filter constants SF (SF.11 to SF.0) |  |  |  |  |  |  |  |  |  |  |  | Zero | Zero | SkipFIR | Fast
Key
Bit | Name | Description | Default
R37.15 | Filter constant SF (SF.11 - SF.0) | The filter constant SF specifies the 3dB limit frequency of the sinc3 filter. The value ranges from 150 to 2047. The 3 dB limit frequency FLimit and the 64.5 dB stop frequency FStop are calculated as follows: (see following table) | 35Chex (860dec)
...
R37.4
Skip = 0 | FLimit = 11981 / SF
 | FStop = 43008 / SF
Skip = 1 | FLimit = 80486 / SF
Bit | Name | Description |  | Default
R37.3 | Zero | 0bin | See note below | 0bin
R37.2 | Zero | 0bin |  | 0bin
Do not change
Bits R37.2 and R37.3 must always be ZERO, otherwise errors will occur in the A/D converter!
Bit | Name | Description |  | Default
R37.1 | SkipFIR | 0bin | FIR filter is active. | 0bin
 |  | 1bin | FIR filter is bypassed.
R37.0 | Fast | 0bin | Fast Step Mode is not active. | 0bin
 |  | 1bin | Fast Step Mode is active: a fast reaction will follow jumps at the input, in spite of the filter stage being active. In this case the filter is bypassed!
Examples
Value in R37 | FStop | Cycle time
0x35C0 | 50 Hz | 140 ms
0x2660 | 70 Hz | 100 ms
0x1330 | 140 Hz | 50 ms
0x7FF1 |  | 40 ms
0x3FF1 |  | 20 ms
0x1001 |  | <4 ms
Value in R37 | FLimit | Cycle time
0x7FF2 | 39.6 Hz | 40 ms
0x3FF2 | 77.36 Hz | 20 ms
0x1002 | 158 Hz | <4 ms
R40: Calibration interval
This register contains the calibration interval for the terminal's automatic calibration. The unit is 100 ms. The automatic calibration can be activated through bit R32.5 in the feature register.
R44: Forced calibration interval
This register contains the interval for the terminal's forced calibration. This interval is always a multiple (the default is 3dec) of the calibration interval. (R40). The interval for forced calibration when the terminal leaves the factory is therefore 3 x 180 s = 540 s. The forced calibration can be activated through bit R32.5 in the feature register.
R47: Number of stable measured values
This register contains the number of stable measured values recorded during the calibration.
R48: Tolerance for measured value stability
This register contains the specified stable measured value tolerance.


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com