KL2791 - single-channel speed controller terminal
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.2.0
▪
Set mode leading edge phase control added
▪
Installation and wiring updated
▪
Technical data updated
▪
Preface updated
1.1.0
Increased power rating of 200 VA for KL2791-0000 and KL2791-0011 approved
1.0.0
First public issue
0.1
First internal preliminary version
Firmware and hardware versions
Version of the documentation | KL2791-0000, KS2791-0000, KL2791-0011, KS2791-0011 |  | KL2791-1200
 | Firmware | Hardware | Firmware | Hardware
2.0.0 | 3A | 05 | 1B | 03
1.2.0 | 3A | 05 | 1B | 03
1.1.0 | 1B | 03 | 1B | 03
1.0.0 | 1A | 00 | 1A | 00
0.1 | 1A | 00 | - | -
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 24 08 1A 00:
24 - week of production 24
08 - year of production 2008
1A - firmware version 1A
00 - hardware version 00


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Basic function principles
•
Technical data
•
LED displays


Introduction

Product overview [image] Introduction
Introduction
KL2791
In many industrialized countries, electric motors account for more than the half the current consumption, which means there is huge energy-saving potential.
With the aid of speed control, it is quite easily possible to reduce the energy consumption to the level that is actually required, thereby avoiding energy waste.
Beckhoff has extended its Bus Terminal system for this purpose. The KL2791 Bus Terminal is suitable for use as a speed controller for single-phase AC motors up to 100 VA.
In addition to energy conservation speed reduction offers noise reduction and increased motor service life.
The speed controller is extremely compact and is housed in a standard bus terminal with a width of 12 mm.
The KL2791 Bus Terminal can be used in any bus system that is supported by the Beckhoff Bus Terminal system.
It is designed for direct connection of low-power, single-phase AC motors.
The KL2791 enables speed reduction of typical motors such as capacitor motors, universal motors and shaded-pole motors.
The KL2791-0011 is a version without power contacts (see ladder diagram on the right). This can be used for 230 V even without a special power feed terminal.
The KL2791-1200 is specifically designed for 120 V mains voltage.
Other KS2791 variants feature pluggable wiring.


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Basic KL2791 function principles
The motor is switched on and off with a practice-proven mains-synchronous pattern, so that the motor consumes less power and the speed falls significantly.
This method is well suited to motors with fixed loads, such as pumps and fans, in order to achieve a control range for the flow rate from 10% to 100%.
The KL2791 Bus Terminal enables direct connection of single-phase AC motors up to 100 VA.
In this way the speed of capacitor, universal and shaded-pole motors can be reduced simply.
The set values are specified via the process data. The required output power is specified via a 16 bit representation. 3 different setting modes are available:
▪
Full-wave control
▪
Leading edge phase control is ideal for smooth operation
▪
Mixed control
Full-wave control is used for targeted switching on and off at optimized points in time.
This protects the connected motor and is particularly suitable for drives with a quadratic load characteristic, such as fans or pumps.
Leading edge phase control is ideal for smooth operation.
Mixed control offers a compromise between smooth operation and motor protection.
Attention
Please follow the operation instructions
Also read the Notes on operation in the chapter Mounting and wiring.


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL2791-0000, KS2791-0000, KL2791-0011, KS2791-0011 | KL2791-1200
Mains voltage | 230 VAC | 120 VAC
Power rating | 200 VA (W), max. 0,9 A | 100 VA (W), max. 0,85 A
Load types | Single-phase AC motors
Types of control | Full-wave control, mixed control
Resolution | 1%
Leakage current (OFF state) | < 1 mA
Electrical isolation | 500 V (K-bus / field voltage), 3750 VAC (1 min.)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 95 mA
Bit width in the input process image | 1 x 16 bit data, 1 x 8 bit status
Bit width in the output process image | 1 x 16 bit data, 1 x 8 bit control
Configuration | via the Bus Coupler or the controller
Weight | approx. 60 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative air humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Pluggable wiring | for all KSxxxx terminals
Approval | CE


LED displays

Product overview [image] LED displays
LED displays
LEDs
LED
Display
K-Bus run (green)
off
no data transfer on the K-bus
on
Data transmission on the K-bus is active
Sync (green)
off
▪
Terminal is not synchronized with the mains*
on
▪
Terminal has synchronized itself with the mains*
ON (green)
off
Process data are zero
on
Process data are not zero
Error (red)
on
A load-side overcurrent was detected
*) Synchronization with the mains can only occur if a load is connected!
WARNING
Risk of electric shock!
With the Sync LED switched off mains voltage may still be present at the KL2791 output!
At this stage, the synchronization was not yet performed!


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection
•
Notes on operation


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Pin assignment


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the ELxxxx and KLxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Pin assignment

Mounting and wiring [image] Connection [image] Pin assignment
Pin assignment
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Pin assignment
Terminal point | No. | KL2791-0000, KL2791-1200, connection for | KL2791-0011, connection for
Output | 1 | Load (internally connected with terminal point 5) | Load (internally connected with terminal point 5)
L1 | 2 | Phase (internally connected with terminal point 6 and power contact for L1) | Phase (internally connected with terminal point 6)
N | 3 | Neutral conductor (internally connected with terminal point 7 and power contact for N) | Neutral conductor (internally connected with terminal point 7)
PE | 4 | Protective conductor (internally connected with terminal point 8 and power contact for PE) | Protective conductor (internally connected with terminal point 8)
Output | 5 | Load (internally connected with terminal point 1) | Load (internally connected with terminal point 1)
L1 | 6 | Phase (internally connected with terminal point 2 and power contact for L1) | Phase (internally connected with terminal point 2)
N | 7 | Neutral conductor (internally connected with terminal point 3 and power contact for N) | Neutral conductor (internally connected with terminal point 3)
PE | 8 | Protective conductor (internally connected with terminal point 4 and power contact for PE) | Protective conductor (internally connected with terminal point 4)
Power feed terminal
A power feed terminal can supply several speed controller terminals.
Attention
The mains voltage should only be supplied via a power feed terminal that is suitable for 230 VAC / 120 VAC!
To supply the mains voltage (230 VAC / 120 VAC) for the power contacts, it is essential to use a power feed terminal that is designed for 230 VAC / 120 VAC (e.g.: KL9150, KL9160, KL9250, KL9260)!
Bus Couplers, Bus Terminal controllers and power feed terminals for 24 V are not suitable for the supply of mains voltage into the power contacts!
They are specifically designed for voltages up to 24 V and would be destroyed if 230 VAC / 120 VAC was applied to their power contacts!
Note
Separation terminal
If 24 V and 230 VAC / 120 VAC are to be used on the power contacts in a Bus Terminal block, the KL9080 separation terminal can be used in order to clearly separate the potential blocks visually from each other.
Short-circuit limitation
The speed controller terminals feature short-circuit limitation. The current is limited to approx. 10 to 15 A. Normally triggering of the fuse is therefore prevented.
The short circuit current flows for less than 0.5 ms and is switched on automatically. After a short circuit was detected the KL2791 tries to switch the system on again and tests the line with a low voltage. Once the short circuit has been rectified, the speed controller terminal returns to the previous control value.
Short circuits on the line should always be avoided and never be induced deliberately! The short circuit puts the components in the speed controller terminal under stress. A high number of short circuits reduces the service life of the speed controller terminal!
Fuses
The speed controller terminal can be protected with fuses up to 10 A.
The speed controller terminal protects itself from damage due to short circuit or overload. This built-in protection is triggered in the event of a short circuit on the connecting line between the speed controller terminal and the load.
Attention
Use overload protection!
However, overload protection must still be provided. The fine-wire fuse often used in devices with transformers must not be bridged or changed in its value. This could lead to overheating of the transformer.


Notes on operation

Mounting and wiring [image] Notes on operation
Notes on operation
Intended use
Mains supply
The KL2791 speed controller terminal is designed for direct mains operation (230 VAC/120 VAC) without up-circuit transformer.
Attention
No upstream transformers!
Excessive inductances in the supply line for the speed controller terminal lead to destruction of the speed controller terminal in the event of a short circuit!
Automatic load detection does not operate reliably with an upstream transformer.
Attention
Do not mix capacitive and inductive loads!
Capacitive and inductive loads must not be mixed at a speed controller terminal!
Setting mode
Attention
Use the correct setting mode!
Full-wave control:
As a basic principle, full-wave control is suitable for single-phase rotary AC motors.
Leading edge phase control:
In motors that are very dynamic, full-wave control can lead to unbalance. The leading edge phase control operating mode is designed for such motors. It ensures smooth operation, although under certain circumstances it may adversely affect the service life of the motor.
Mixed control:
Mixed control provides strikes a balance between full-wave control and leading edge phase control and therefore offers a compromise between smooth operation and motor protection.
Minimum interruption of mains supply
Attention
Minimum mains interruption
Any interruption of the mains supply for the speed controller terminal may not be shorter than 3 seconds (e.g. switching off and on again of an automatic circuit-breaker)!
With shorter interruptions, the speed controller would not lose its mains synchronization and may operate the load with the wrong control mode (due to the switch-on edge).
With wound transformers, this may lead to destruction of the speed controller terminal!


Application examples - overview

Application examples - overview
Application examples - overview
▪
KL2791-0000: Speed controller terminal with power contacts
▪
KL2791-0011: Speed controller terminal without power contacts
Additional information
•
KL2791-0000 - application example
•
KL2791-0011 - application example


KL2791-0000 - application example

Application examples - overview [image] KL2791-0000 - application example
KL2791-0000 - application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
The example illustrates control of an AC motor through a KL2791-0000. The mains voltage (230 VAC) is supplied to the power contacts via the KL9160 power feed terminal.
KL2791-0000 - application example
Power feed terminal
A power feed terminal can supply several speed controller terminals.
Attention
The mains voltage should only be supplied via a power feed terminal that is suitable for 230 VAC / 120 VAC!
To supply the mains voltage (230 VAC / 120 VAC) for the power contacts, it is essential to use a power feed terminal that is designed for 230 VAC / 120 VAC (e.g.: KL9150, KL9160, KL9250, KL9260)!
Bus Couplers, Bus Terminal controllers and power feed terminals for 24 V are not suitable for the supply of mains voltage into the power contacts!
They are specifically designed for voltages up to 24 V and would be destroyed if 230 VAC / 120 VAC was applied to their power contacts!


KL2791-0011 - application example

Application examples - overview [image] KL2791-0011 - application example
KL2791-0011 - application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
The example illustrates control of a motor through a KL2791-0011. The mains voltage (230 VAC) is supplied directly to the speed controller terminal.
KL2791-0011 - application example
Attention
Risk of damage to the device!
Supply of the mains voltage without power feed terminal is only permitted for speed controller terminals without power contacts (KL2791-0011)!


Configuration Software KS2000

Configuration Software KS2000
Configuration Software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Process data


KS2000 - Introduction

Configuration Software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration Software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL9160 power feed terminal for 230 V with diagnostics
▪
a KL2791 speed controller terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of the KL2791
For the KL2791, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2791.
▪
Under Settings you find dialog boxes for parameterization the KL2791.
▪
ProcData displays the KL2791 process data.


Register

Configuration Software KS2000 [image] Register
Register
Under Register you can directly access the registers of the speed controller terminal. The meaning of the register is explained in the register overview.
The following picture shows the registers of the KL2791.
Register view in KS2000


Settings

Configuration Software KS2000 [image] Settings
Settings
The dialog mask for the parameterization of the KL2791 can be found under Settings.
Settings via KS2000
Operation mode
Watchdog timer active (R32.2)
Here you can deactivate the watchdog (default: active).
User scaling active (R32.0)
Here you can activate user scaling (default: inactive).
Register values
User offset (R33)
You can specify the offset for the user-scaling here (default: 0).
User gain (R34)
Here you can specify the user scaling gain (default: 1).
Timeout (R36)
Here you can specify the timeout time for detecting a fieldbus error (default: 100 ms).
Control value for timeout (On) (R37)
Here you can specify the control value for a timeout at which the load was switched on when it occurred (default: 50%).
Control value for timeout (Off) (R38)
Here you can specify the control value for a timeout at which the load was switched off when it occurred (default: 0%).
Setting mode (R39)
Here you can specify the setting mode for the speed controller:
▪
Full-wave control (default)
▪
Mixed control (for very dynamic motors, please read Notes on operation!)
▪
Leading edge phase control (firmware version 2 A or higher)
Behavior after short circuit (R40)
Here you can specify the behavior of the speed controller terminal after a short circuit at the load output.
The speed controller terminal features short-circuit limitation. The current is limited to approx. 10 to 15 A. Normally triggering of the fuse is therefore prevented. The short circuit current flows for less than 0.5 ms and is switched on automatically.
▪
Remains switched off:
The user has to switch the system on again after a short circuit.
▪
Switch on again (default):
After a short circuit was detected, the speed controller terminal tries to resume operation and tests the line with a low voltage. Once the short circuit has been rectified, the speed controller terminal returns to the previous control value.
Mains frequency (R41)
Here you can set the speed controller terminal to your mains frequency; default: 50 Hz


Process data

Configuration Software KS2000 [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field
Output values can be modified through direct input or by means of the fader control.
Value field
CAUTION
Danger for persons, the environment or devices!
Note that changing output values (forcing them) can have a direct effect on your automation application. Only modify these output values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status bytes
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The KL2791 is represented in the complex process image with 3 bytes of input data and 3 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB | CB
1 | 2 | Word | DataIN | DataOUT
The KL2791 is represented in the compact process image without input data and with 2 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Word | - | DataOUT
*) Word alignment: The Bus Coupler places values on even byte addresses
Key
SB: Status byte
CB: Control byte
DataIN: input word
DataOUT: output word
In process data mode, the output word DataOUT controls the output power of the speed controller terminal. Valid values are 0dec to 32767dec.


Control and status bytes

Access from the user program [image] Control and status bytes
Control and status bytes
Process data mode
Control byte (for process data mode)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | - | - | - | - | -
Key
Bit | Name | Description
CB.7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 to CB.0 | - | 0bin | reserved
Status byte (for process data mode)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | Temperature warning | Overload | Operation mode |  |  | Synchronous
Key
Bit | Name | Description
SB.7 | RegAccess | 0bin | Acknowledgment for process data mode
SB.6 | Error | 1bin | A load-side short circuit was detected
SB.5 | Temperature warning | 1bin | Overtemperature detected (> 80°C): The process data are limited to 20% (the limitation is automatically reset when the temperatures falls below 60°C)
SB.4 | Overload | 1bin | Overload detected (e.g. when switching higher loads on)
SB.3 to SB.1 | Operation mode | 0dec | Full-wave control
 |  | 1dec | Mixed control
SB.0 | Synchronous | 0bin | Terminal is not synchronized with the mains or a short circuit was detected on the load side
 |  | 1bin | Terminal has synchronized itself with the mains*
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOUT.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgment for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for parameterizing the speed controller terminal. They can be read or written by means of register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R6 | reserved |  | - | - | - | -
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2791-0000 | 0x0AE7 | 2791dec | R | ROM
 |  | KL2791-0011
 |  | KL2791-1200
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0118 | 280dec | R | ROM
R11 | Signal channels |  | 0x0118 | 280dec | R | ROM
R12 | Minimum data length |  | 0x9800 | 38912dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | 0x7F80 | 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserved |  | - | - | - | -
R29 | Terminal type, special version | KL2791-0000 | 0x0000 | 0dec | R | ROM
 |  | KL2791-0011 | 0x000B | 11dec
 |  | KL2791-1200 | 0x04B0 | 1200dec
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0000 | 0dec | R/W | EEPROM
R33 | User scaling - offset |  | 0x0000 | 0dec | R/W | EEPROM
R34 | User scaling - gain |  | 0x0100 | 256dec | R/W | EEPROM
R35 | reserved |  | - | - | - | -
R36 | Watchdog Timeout |  | 0x000A | 10dec | R/W | EEPROM
R37 | Control value for timeout (On) |  | 0x3FFF | 16383dec | R/W | EEPROM
R38 | Control value for timeout (Off) |  | 0x0000 | 0dec | R/W | EEPROM
R39 | Setting mode |  | 0x0000 | 0dec | R/W | EEPROM
R40 | Behavior after short circuit |  | 0x0001 | 1dec | R/W | EEPROM
R41 | Mains frequency | KL2791-0000 | 0x0000 | 0dec (50 Hz) | R/W | EEPROM
 |  | KL2791-0011
 |  | KL2791-1200 | 0x0001 | 1dec (60 Hz)
R42 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserved |  | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for the parameterization of the terminal.
R7: Command register
Note
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Default Settings
Entering 0x7000 in register R7 restores the delivery state for the following registers:
R33: 0dec
R34: 256dec
R35: 3dec
R36: 10dec
R37: 16383dec
R38: 0dec
R39: 0dec
R40: 1dec
R41: 0dec
R8: Terminal type
The terminal name is contained in register R8: KL2791
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R29: Terminal type, special version
Register R29 contains the special version of the terminal.
R31: Code word register
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data. The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | - | disWatchdog | - | enUserScale
Key
Bit | Name | Description |  | Default
R32.15 - R32.3 | - | reserved
R32.2 | disWatchdog | 1bin | Internal watchdog (time adjustable) deactivated | 0bin
R32.1 | - | reserved
R32.0 | enUserScale | 1bin | User scaling active (see R33+ R34) | 0bin
R33: User scaling - offset
The offset of the user scaling when the user scaling (R32.0=1bin) is enabled is entered in this register (default: 0).
R34: User scaling - gain
The gain of the user scaling when the user scaling (R32.0=1bin) is enabled is entered in this register.
Example values:
128dec = 0x80 = factor 0.5
256dec = 0x100 = factor 1.0 (default)
512dec = 0x200 = factor 2.0
R36: Watchdog Timeout
This register specifies the timeout in the event of a fieldbus error. The unit is 10 ms (default: 10dec = 100 ms).
R37: Control value for timeout (On)
This register specifies the light value that is output in the case of a fieldbus error and current process data > 0 (default: 16383dec).
The unit is 1. (R32.2=1bin).
R38: Control value for timeout (Off)
This register specifies the light value that is output in the case of a fieldbus error and current process data = 0 (default: 0dec).
The unit is 1. (R32.2=1bin).
R39: Setting mode
This register specified the setting mode (see Notes on operation):
0dec: Full-wave control (default)
1dec: Mixed control
2dec: Leading edge phase control (firmware version 2 A or higher)
R40: Behavior after short circuit
This register specifies the behavior after a short circuit:
0dec: Remains switched off:
1dec: switch on again (default):
R41: Mains frequency
This register specifies the mains frequency:
0dec: 50 Hz (default)
1dec: 60 Hz


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com