KL2751, KL2761 - Single channel universal dimmer terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation revision levels


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation revision levels

Foreword [image] Documentation revision levels
Documentation revision levels
Version
Comment
3.1.0
▪
Process data description corrected
▪
Downloadlink " FB_Dimmer1SwitchEco" corrected
3.0.0
▪
Migration
▪
Product overview updated
▪
Chapter "TwinCAT" including Link to FB_KL27x1Config added
2.6.0
▪
Technical data updated
▪
Preface updated
2.5.0
▪
The permissible installation position and ambient temperature range in operation are load-dependent
(refer to the chapter Mounting of terminals with increased thermal power dissipation!)
▪
Output of diagnostic data in the status byte and terminal internal temperature in the data input word DataIN also for KL2751-0000 from firmware 3B
2.4.0
▪
KS2751 and KS2761 added
▪
Notes on operation expanded
▪
Basic function principles updated
2.3.0
▪
Register description and description of the KS2000 configuration software updated
▪
Technical data updated
▪
Notes on operation expanded
2.2.0
▪
Description of the KL2751-0011 and KL2761-0011 added
▪
Product overview updated
▪
Application example for KL2751-0011 and KL2761-0011 added
▪
Notes on operation expanded
2.1.0
▪
Notes on operation added
2.0.0
▪
Description of the KL2761-0000 added
▪
Description of the TwinCAT function block FB_Dimmer1SwitchEco added
1.2.0
▪
Register description updated
▪
Description of the KS2000 configuration software updated
▪
Installation instructions revised
1.1.0
▪
Register description updated
▪
Description of the KS2000 configuration software updated
▪
Process data description updated
1.0.0
▪
Description of the KS2000 configuration software expanded
▪
Basic function principles corrected
▪
English translation available
0.1
First preliminary version
Firmware and hardware versions
Version of the documentation | KL2751-0000 KS2751-0000 |  | KL2751-0011 KS2751-0011 |  | KL2761-0000 KS2761-0000 |  | KL2761-0011 KS2761-0011
 | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware | Firmware | Hardware
3.0.0 | 4H | 09 | 4H | 09 | 4H | 06 | 4H | 06
2.6.0 | 4H | 09 | 4H | 09 | 4H | 06 | 4H | 06
2.5.0 | 3B | 05 | 3B | 05 | 3B | 02 | 3B | 02
2.4.0 | 2F | 03 | 2F | 03 | 1F | 02 | 1F | 02
2.3.0 | 2E | 01 | 2E | 01 | 1E | 00 | 1E | 00
2.2.0 | 2B | 01 | 2B | 01 | 1B | 00 | 1B | 00
2.1.0 | 2A | 01 | - | - | 1A | 00 | - | -
2.0.0 | 2A | 01 |  |  | 1A | 00
1.2.0 | 2A | 01 |  |  | - | -
1.1.0 | 1C | 00
1.0.0 | 1A | 00
0.1 | 1A | 00
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 38 06 01 00:
38 - week of production 38
06 - year of production 2006
1C - firmware version 1C
00 - hardware version 00


Product overview

Product overview
Product overview
Additional information
•
KL2751 - Introduction
•
KL2761 - Introduction
•
Basic function principles
•
Technical data
•
LED displays


KL2751 - Introduction

Product overview [image] KL2751 - Introduction
KL2751 - Introduction
KL2751
The KL2751-0000 / KS2751-0000 dimmer terminal is intended for the direct connection of resistive, inductive or capacitive AC lamp loads with a power rating of up to 300 VA (W). Typical lighting devices such as incandescent lamps, inductive and electronic ballasts are detected and controlled in the right operation mode. The dimmer terminal calculates the appropriate phase control angle in leading edge or trailing edge phase control from the brightness values specified via the process data. The output is short-circuit-proof and overload-proof.
The status of the load can be read in (from firmware version 3B).
A variant without power contacts (see contact Diagram, right) is also available in the KL2751-0011 / KS2751-0011. This can be used for 230 V even without a special power feed terminal.


KL2761 - Introduction

Product overview [image] KL2761 - Introduction
KL2761 - Introduction
KL2761
The KL2761-0000 / KS2761-0000 dimmer terminal is intended for the direct connection of resistive, inductive or capacitive AC lamp loads with a power rating of up to 600 VA (W). Typical lighting devices such as incandescent lamps, inductive and electronic ballasts are detected and controlled in the right operation mode. The dimmer terminal calculates the appropriate phase control angle in leading edge or trailing edge phase control from the brightness values specified via the process data. The output is short-circuit-proof and overload-proof.
The load status can be read.
A variant without power contacts (see contact diagram, right) is also available in the KL2761-0011 / KS2761-0011. This can be used for 230 V even without a special power feed terminal.


Basic function principles

Product overview [image] Basic function principles
Basic function principles
KL2751, KL2761
The KL2751 (300 VA) and KL2761 (600 VA) dimmer terminals are intended for the direct connection of different AC lamp loads. Typical lighting devices such as incandescent lamps, inductive and electronic ballasts are detected and controlled in the right operation mode. In addition to automatic load detection, the Bus Terminal offers a short-circuit-proof and overload-proof output.
The KL2751and KL2761 are extremely compact universal dimmers in Bus Terminal format and are aimed primarily at use in building services. The brightness values of the lighting system can be modified via the controller process data, based on any bus system supported by the Beckhoff I/O system. However, the universal dimmers can also be used as power switches for AC voltages. With a switchable power of 300 VA (W) or 600 VA (W), wear-free switching of numerous consumers is possible.
In the Automatic Recognition dimmer mode, the dimmer terminals can detect the load type and save the result. To do this the dimmer terminal switches the load on at low power for about 5 seconds after mains voltage is applied. The dimmer terminal cannot be controlled during this period.
The dimmer terminal is short-circuit-proof. It limits the current in the event of a short circuit, thereby protecting the load and preventing triggering of the main fuse.
Attention
Notes on operation
Also read the notes on operation in the chapter Mounting and wiring.


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL2751-0000, KS2751-0000, KL2751-0011, KS2751-0011 | KL2761-0000, KS2761-0000, KL2761-0011, KS2761-0011
Mains voltage | 230 VAC | 230 VAC
Power rating* | 300 VA (W), max. 1.35 A | 600 VA (W), max. 2.7 A
Permissible load types | Inductive (transformers only, no ballasts for fluorescent tubes), capacitive or resistive lamp loads No motors! Inductive and capacitive loads must not be mixed! Automatic load detection
Cable length | max. 100 m between dimmer terminal and lamp
Types of control | Leading edge phase control, trailing edge phase control, rectifier mode (positive or negative half-wave in leading edge phase control)
Resolution | max. 7 bit
Leakage current (OFF state) | < 2 mA
Electrical isolation | 500 V (K-bus / field voltage), 3750 VAC (1 min.)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 95 mA
Bit width in the input process image | 1 x 16 bit data, 1 x 8 bit status
Bit width in the output process image | 1 x 16 bit data, 1 x 8 bit control
Configuration | via the Bus Coupler or the controller
Weight | approx. 60 g
Permissible ambient temperature range during operation | 0 °C to + 55 °C (refer to the chapter Installation positions!)
Permissible ambient temperature range during storage | -25 °C ... + 85 °C
Permissible relative air humidity | 95 %, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforming to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | load-dependent (refer to the chapter Installation positions!)
Pluggable wiring | for all KSxxxx terminals
Approval | CE
*) Rated output = lamp power + ballast losses
The ballast losses are typically equivalent to:
▪
5 % of the rated output of the ballast in the case of electronic ballasts
▪
20 % of the rated output of the transformer in the case of inductive ballasts


LED displays

Product overview [image] LED displays
LED displays
KL2751, KL2761 - LEDs
LED
Display
K-Bus run (green)
off
No data transfer on the K-Bus
on
Data transmission on the K-bus is active
Mains (green)
off
▪
Terminal is not synchronized with the mains*
▪
With automatic load detection the load type has not yet been tested
on
▪
Terminal has synchronized itself with the mains*
▪
Load type was detected
ON (green)
off
Process data are zero
on
Process data are not zero
Error (red)
on
A load-side short circuit was detected
*) Synchronisation with the mains can only occur if a load is connected!
WARNING
Risk of electric shock!
With the Sync LED switched off mains voltage may still be present at the KL2751 output! At this time automatic load detection and synchronisation have not yet been carried out!
Automatic load detection display
After the load detection (shortly after the mains voltage has been switched on) the terminal signals the load type and the selected operation mode via the LEDs.
▪
LED sequence green / red: Trailing edge phase control for resistive or capacitive load
▪
LED sequence green / red: Leading edge phase control for inductive load


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Installation positions
•
Connection system
•
KL2751, KL2761 - Connection
•
Notes on operation – intended use


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation positions

Mounting and wiring [image] Installation positions
Installation positions
Attention
Constraints regarding installation position and operating temperature range
Please refer to the technical data for a terminal to ascertain whether any restrictions regarding the installation position and/or the operating temperature range have been specified. When installing high power dissipation terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Optimum installation position (standard)
The optimum installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances for standard installation position”). The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. “Recommended distances for standard installation position” is recommended.
Other installation positions
All other installation positions are characterized by different spatial arrangement of the mounting rail - see Fig “Other installation positions”.
The minimum distances to ambient specified above also apply to these installation positions.
Other installation positions


Connection system

Mounting and wiring [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Note
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


KL2751, KL2761 - Connection

Mounting and wiring [image] KL2751, KL2761 - Connection
KL2751, KL2761 - Connection
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Connection taking KL2751 as an example
Terminal point | No. | KL2751-0000, KL2761-0000, connection for | KL2751-0011, KL2761-0011, connection for
Output | 1 | Load (internally connected with terminal point 5) | Load (internally connected with terminal point 5)
L1 | 2 | Phase (internally connected with terminal point 6 and power contact for L1) | Phase (internally connected with terminal point 6)
N | 3 | Neutral conductor (internally connected with terminal point 7 and power contact for N) | Neutral conductor (internally connected with terminal point 7)
PE | 4 | Protective conductor (internally connected with terminal point 8 and power contact for PE) | Protective conductor (internally connected with terminal point 8)
Output | 5 | Load (internally connected with terminal point 1) | Load (internally connected with terminal point 1)
L1 | 6 | Phase (internally connected with terminal point 2 and power contact for L1) | Phase (internally connected with terminal point 2)
N | 7 | Neutral conductor (internally connected with terminal point 3 and power contact for N) | Neutral conductor (internally connected with terminal point 3)
PE | 8 | Protective conductor (internally connected with terminal point 4 and power contact for PE) | Protective conductor (internally connected with terminal point 4)
Power feed terminal
It is imperative that you use a power feed terminal (e.g.: KL9150, KL9160, KL9250, KL9260) designed for 230 VAC to supply mains voltage (230 VAC) into the power contacts!
Attention
Risk of damage to the device!
Bus Couplers, Bus Terminal controllers and power supply terminals for 24 V are not suitable for the supply of mains voltage into the power contacts! They are designed only for voltages up to 24 V and would be destroyed if 230 VAC is applied at their power contacts!
Several dimmer terminals can be operated on one power feed terminal.
Note
Separation terminal
If 24 V and 230 VAC are to be used on the power contacts in a Bus Terminal block, the KL9080 separation terminal can be used in order to clearly separate the potential blocks visually from each other.
Short-circuit limitation
The dimmer terminals are equipped with short-circuit current limitation. The current is limited to approx. 10 A to 15 A. Normally triggering of the fuse is therefore prevented.
The short circuit current flows for less than 0.5 ms and is switched on automatically. After a short circuit was detected the KL2751 tries to switch the system on again and tests the line with a low voltage. If the short circuit has been eliminated, the dimmer terminal returns to the previous dimmer value.
A short circuit on the line should always be avoided and never deliberately caused! The components in the dimmer terminal are stressed by short circuits. A large number of short circuits will shorten the service life of the dimmer terminal!
Fuses
The dimmer terminal may be protected with fuses up to 10 A.
The dimmer terminal protects itself against destruction due to short circuit and overload. This built-in protection acts on the connection line between dimmer terminal and load in the event of a short circuit.
Attention
Risk of damage to the device!
However, overload protection must still be provided. The fine-wire fuse often used in devices with transformers must not be bridged or changed in its value. This could lead to overheating of the transformer.


Notes on operation – intended use

Mounting and wiring [image] Notes on operation – intended use
Notes on operation – intended use
Supply
▪
Mains supply
Attention
No upstream transformers!
The KL2751 and KL2761 dimmer terminals are intended for direct operation on mains supplies (230 VAC) without upstream transformer.
Overly large inductances in the supply line to the dimmer terminal will lead to its destruction in the event of a short circuit!
Automatic load detection does not operate reliably with an upstream transformer.
Power feed terminals
It is imperative that you use a power feed terminal (e.g.: KL9150, KL9160, KL9250, KL9260) designed for 230 VAC to input mains voltage into the power contacts of the dimmer terminals
KL2751-0000, KL2761-0000,
KS2751-0000, KS2761-0000!
See application example for KL2751-0000.
The supply in of mains voltage without a power feed terminal is permissible only for dimmer terminals without power contacts:
KL2751-0011, KL2761-0011, KS2751-0011, KS2761-0011!
See application example for KL2751-0011.
Minimum interruption of the mains voltage supply
Any interruption in the mains voltage supply to the dimmer terminal may not be shorter than 3 seconds (e.g. an automatic circuit-breaker switching off and on again)!
In the case of shorter interruptions the dimmer does not lose its mains synchronization and can (depending on the starting edge) operate the load for a short while with the wrong type of control. In the case of operation of wound transformers this can lead to the destruction of the dimmer terminal!
▪
Ripple control pulses
Note
Malfunction due to ripple control pulses
External ripple control pulses on the mains supply can cause brightness fluctuations. Ripple control pulses with higher amplitudes can trigger the dimmer terminal's short circuit detection. The dimmer terminal then switches the load off and ramps up again. The light is switched off for several seconds.
Use audio frequency filters in the supply line to the dimmer terminal in order to avoid these effects.
Load
▪
Permissible loads
Attention
No motors!
Use the dimmer terminals for lamp loads only. Motor loads can fully destroy the terminal.
Please consider that the wiring of the dimmer terminal output to a power socket could lead to the use of any type of load.
For motor loads, please use the KL2791 (single-channel speed controller for AC motors).
Do not mix capacitive and inductive loads!
Capacitive and inductive loads must not be mixed on one dimmer terminal!
For example, an electronic ballast and a transformer must not be operated together on one dimmer terminal!
You may operate an ohmic load (e.g. an incandescent lamp) together with either a capacitive or an inductive load.
No additional switches!
Do not connect any additional switches between
•
the dimmer terminal and the load
•
the dimmer terminal and the ballast
•
the ballast and the lamp
▪
Operation modes
Attention
Use the right operation mode!
Use only the intended operation mode for each type of load
•
capacitive loads may only be controlled with trailing edge phase control.
•
inductive loads may only be controlled with leading edge phase control.
⇨
Even if the manufacturer, for example, of an electronic ballast allows this capacitive load to be controlled with leading edge phase control, we urgently recommend that you use trailing edge phase control for this!
⇨
If a load is controlled with the wrong operation mode, this can lead to the destruction of the dimmer terminal or the load!
A typical result is the overheating of the input capacitor of an electronic ballast that is controlled with leading edge phase control.
In addition, the operation modes Rectifier-positive and Rectifier-negative (both with leading edge phase control) are available for special applications (e.g. vibrator, vibrating conveyor).
Automatic load detection
▪
Long cable lengths
Note
Long cable lengths
The manual preselection of the operation mode (dimmer mode) is recommended if there are long cables between the dimmer terminal and load. Automatic load detection may fail, since inductive and capacitive line influences may lead to misinterpretation of the load.
In addition, please note the maximum permissible cable length!
▪
User program
Note
Parameterization of the dimmer terminal on starting the PLC
If you do not operate the dimmer terminal with the default values (e.g. for dimmer mode, ramp time, etc.) it is recommended to initialize the respective registers with the deviating values from the user program when starting the PLC. This saves the service personnel having to perform the complicated manual initialization when exchanging terminals and also helps to avoid undesirable error states.
▪
Wound transformer with no load on the secondary side
Attention
No open-circuit transformers!
The automatic load detection, which the dimmer terminal performs on the connected load when the mains voltage is switched on, fails if a wound transformer is connected that has no load connected to its secondary side.
Make sure when switching the mains voltage on that the terminal is not operated on an open-circuit transformer! Also pay attention to this when replacing lamps connected on the secondary side!
Gentle operation of low-voltage lamps
Note
Low-voltage, high-power lamps
For the operation of low-voltage, high-power lamps (e.g. halogen lamps, 12 V, 100 W, GY6.35 via ballast*), enter a higher ramp time for the dimming ramp than the default value of 500 ms!
Since the filament in these lamps is considerably thicker than in lamps with a lower power, it behaves quite sluggishly and must therefore bear the high starting current for a longer period. This effect leads to premature ageing of the lamp. You can counteract this premature ageing by setting a flatter dimming ramp.
*) The ballast must be connected between the dimmer terminal and the halogen lamp (see mains supply)!


Application examples - overview

Application examples - overview
Application examples - overview
▪
KL2751-0000, KL2761-0000: Dimmer terminals with power contacts
▪
KL2751-0011, KL2761-0011: Dimmer terminals without power contacts
▪
FB_Dimmer1SwitchEco function block
Additional information
•
KL2751-0000 - Application example
•
KL2751-0011 - Application example


KL2751-0000 - Application example

Application examples - overview [image] KL2751-0000 - Application example
KL2751-0000 - Application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Power feed terminal
It is imperative that you use a power feed terminal (e.g.: KL9150, KL9160, KL9250, KL9260) designed for 230 VAC to supply mains voltage (230 VAC) into the power contacts!
Attention
Risk of damage to the device!
Bus Couplers, Bus Terminal controllers and power supply terminals for 24 V are not suitable for the supply of mains voltage into the power contacts! They are designed only for voltages up to 24 V and would be destroyed if 230 VAC is applied at their power contacts!
The example shows the control of an incandescent lamp by a KL2751-0000. The mains voltage (230 VAC) is fed to the power contacts via the KL9160 power feed terminal.
Several dimmer terminals can be operated on one power feed terminal.
KL2751-0000 connection example


KL2751-0011 - Application example

Application examples - overview [image] KL2751-0011 - Application example
KL2751-0011 - Application example
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Supply in of the mains voltage without a power feed terminal
Attention
Risk of damage to the device!
The supply in of mains voltage without a power feed terminal is permissible only for dimmer terminals without power contacts:
KL2751-0011, KL2761-0011,
KS2751-0011, KS2761-0011
The example shows the control of an incandescent lamp by a KL2751-0011. The mains voltage (230 VAC) is fed directly to the KL2751-0011.
KL2751-0011 - Application example


Configuration software KS2000

Configuration software KS2000
Configuration software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Process data


KS2000 - Introduction

Configuration software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the sample shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL9160 power feed terminal for 230 V with diagnostics
▪
a KL2751 dimmer terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branches for channel 1 of the KL2535
For the KL5151, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2751.
▪
Under Settings you find dialog boxes for parameterization the KL2751.
▪
ProcData displays the KL2751 process data.


Register

Configuration software KS2000 [image] Register
Register
Under Register you can directly access the registers of the dimmer terminal. The meaning of the register is explained in the register overview.
The following picture shows the registers of the KL2751.
Register view in KS2000


Settings

Configuration software KS2000 [image] Settings
Settings
The dialog mask for the parameterization of the KL2751/KL2761 can be found under Settings.
Settings via KS2000
Operating mode
▪
Watchdog timer active (R32.2)
Here you can deactivate the watchdog (default: active).
▪
Watchdog timer active (R32.2)
Here you can activate user scaling (default: inactive).
▪
Dimming ramp absolute (R32.3)
Here you can switch the dimming ramp from relative (default) to absolute.
–
With the relative dimming ramp, the dimmer terminal requires the preset ramp time to ramp up the brightness from 0 to full scale control.
–
With the absolute dimming ramp the dimmer terminal requires the preset ramp time to perform the current specified brightness change.
Note
Absolute dimming ramp
The use of the absolute dimming ramp is useful, for example, when you want to control two lamps with two dimmer terminals synchronously.
Sample:
Lamp 1 is lit with 10 % brightness, lamp 2 with 30 % brightness.
Dimmer terminal 1 should now control lamp 1 and dimmer terminal 2 lamp 2 up to 50 % brightness.
With an absolute dimming ramp, both lamps reach 50 % brightness at the same time.
Register values
▪
User offset (R33)
You can specify the offset for the user-scaling here (default: 0).
▪
User gain (R34)
Here you can specify the user scaling gain (default: 1).
▪
Ramp time (R35)
You can select the ramp time here (default 500 ms).
Permissible values: 50 ms, 100 ms, 200 ms, 500 ms, 1 s, 2 s, 5 s and 10 s
▪
Timeout (R36)
Here you can specify the timeout time for detecting a fieldbus error (default: 100 ms).
▪
Light value for timeout (on) (R37)
Here you can specify the light value for a timeout at which the load was switched on when it occurred (default: 50 %).
▪
Light value for timeout (off) (R38)
Here you can specify the light value for a timeout at which the load was switched off when it occurred (default: 0 %).
▪
Dimmer mode (R39)
Here you can specify the dimmer mode:
–
Automatic recognition*: The dimmer terminal automatically detects the type of load (capacitive/resistive or inductive) and switches to trailing edge phase control or leading edge phase control (default).
–
Trailing edge control: typically used for capacitive loads (e.g. electronic ballasts) or ohmic loads (e.g. bulbs)
–
Leading edge control: typically used for inductive loads (e.g. transformers, conventional ballasts)
–
Rectifier, positive: only the positive half-wave is switched through to the load with leading edge phase control
Do not use this operation mode with firmware version 2E of the KL2751 or with firmware version 1E of the KL2761!
Instead, use the operation mode Rectifier mode, negative with these firmware versions!
–
Rectifier, negative: only the negative half-wave is switched through to the load with leading edge phase control
Note
*) Automatic recognition and long cable lengths
Manual preselection of the operation mode is recommended in the case of long cables between the dimmer terminal and the load.
Automatic load detection may fail, since inductive and capacitive line influences may lead to misinterpretation of the load.
▪
Behavior after short circuit (R40)
Here you can define the behavior of the dimmer terminal following a short circuit on the load output.
The dimmer terminal is equipped with short-circuit current limitation. The current is limited to approx. 10 A to 15 A. Normally triggering of the fuse is therefore prevented. The short circuit current flows for less than 0.5 ms and is switched on automatically.
–
Remains switched off:
The user has to switch the system on again after a short circuit.
–
Switch on again (default):
Following the detection of a short circuit, the dimmer terminal attempts to resume operation and tests the line with a low voltage. If the short circuit has been eliminated, the dimmer terminal returns to the previous dimmer value.
▪
Mains frequency (R41)
Here you can set the dimmer terminal to your mains frequency, default: 50 Hz


Process data

Configuration software KS2000 [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
Process Data field
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field - display of the input value
Output values can be modified through direct input or by means of the fader control.
Value field - modification of the output values
CAUTION
Danger for persons, the environment or devices!
Note that changing initial values (forcing them) can have a direct effect on your automation application.
Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Setting the display


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status bytes with diagnosis
•
Control and status bytes without diagnosis
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The KL2751 and KL2761 appear in the complex process image with 3 bytes of input data and 3 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB | CB
1 | 2 | Word | DataIN | DataOUT
The KL2751 and KL2761 appear in the compact process image with no input data and 2 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Word | - | DataOUT
*) Word alignment: The Bus Coupler places values on even byte addresses
Legend
SB: Status byte
CB: Control byte
DataIN: Input data word
DataOUT: Output data word
Process data
▪
DataOUT
In process data mode the output word DataOUT controls the output power of the dimmer terminal.
Valid values are 0dec to 32767dec.
▪
DataIN
In process data mode the input word DataIN contains the internal temperature of the dimmer terminal in degrees Celsius (KL2751/KS2751: only with firmware version 3B or higher)


Control and status bytes with diagnosis

Access from the user program [image] Control and status bytes with diagnosis
Control and status bytes with diagnosis
This description applies to
▪
KL2751-0000 / KS2751-0000 with firmware versions 3B or higher
▪
KL2751-0011 / KS2751-0011 with firmware versions 3B or higher
▪
KL2761-0000 / KS2761-0000
▪
KL2761-0011 / KS2761-0011
Process data mode
Control byte (for process data mode)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | - | - | - | - | - | - | ManualAutoDetect
Legend
Bit | Name | Description
CB17 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 to CB1.1 | - | 0bin | reserved
CB1.0 | ManualAutoDetect | 1bin | manually start automatic load type detection (rising edge)
Status byte (for process data mode)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Temperature warning | Overload | Operation mode |  |  | Synchronous
Legend
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | Error | 1bin | A load-side short circuit was detected
SB1.5 | Temperature warning | 1bin | Overtemperature detected (> 80 °C): the process data are limited to 20 % (the limit is reset automatically when the temperature falls below 60 °C)
SB1.4 | Overload | 1bin | Overload detected (e.g. when switching higher loads on)
SB1.3 to SB1.1 | Operation mode | manually set or automatically detected operation mode
 |  | 0dec | automatic load type detection active
 |  | 1dec | Trailing edge phase control
 |  | 2dec | Leading edge phase control
 |  | 3dec | Rectifier mode (positive half-wave with leading edge phase control)
 |  | 4dec | Rectifier mode (negative half-wave with leading edge phase control)
SB1.0 | Synchronous | 0bin | Terminal is not synchronized with the mains or a short circuit was detected on the load side
 |  | 1bin | Terminal has synchronized itself with the mains*
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit
Name
Description
CB1.7
RegAccess
1bin
Register communication switched on
CB1.6
R/W
0bin
Read access
1bin
Write access
CB1.5 to CB1.0
Reg. no.
Register number:
Enter the number of the register that you
▪
want to read with input data word DataIn or
▪
want to write with output data word DataOut.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.


Control and status bytes without diagnosis

Access from the user program [image] Control and status bytes without diagnosis
Control and status bytes without diagnosis
This description applies to
▪
KL2751-0000 / KS2751-0000 with firmware versions lower than 3B
▪
KL2751-0011 / KS2751-0011 with firmware versions lower than 3B
Process data mode
Control and status byte have no functionality in process data mode.
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit
Name
Description
CB1.7
RegAccess
1bin
Register communication switched on
CB1.6
R/W
0bin
Read access
1bin
Write access
CB1.5 to CB1.0
Reg. no.
Register number:
Enter the number of the register that you
▪
want to read with input data word DataIn or
▪
want to write with output data word DataOut.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used for the parameterization of the dimmer terminal. They can be read or written by means of register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R6 | reserved |  | - | - | - | -
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2751-0000 | 0x0ABF | 2751dec | R | ROM
 |  | KL2751-0011
 |  | KL2761-0000 | 0x0AC9 | 2761dec
 |  | KL2761-0011
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0118 | 280dec | R | ROM
R11 | Signal channels |  | 0x0118 | 280dec | R | ROM
R12 | Minimum data length |  | 0x9800 | 38912dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | 0x7F80 | 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R28 | reserved |  | - | - | - | -
R29 | Terminal type, special version | KL2751-0000 | 0x0000 | 0dec | R | ROM
 |  | KL2751-0011 | 0x000B | 11dec
 |  | KL2761-0000 | 0x0000 | 0dec
 |  | KL2761-0011 | 0x000B | 11dec
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0000 | 0dec | R/W | EEPROM
R33 | User scaling - offset |  | 0x0000 | 0dec | R/W | EEPROM
R34 | User scaling - gain |  | 0x0100 | 256dec | R/W | EEPROM
R35 | Ramp time |  | 0x0003 | 3dec | R/W | EEPROM
R36 | Watchdog Timeout |  | 0x000A | 10dec | R/W | EEPROM
R37 | Light value for timeout (on) |  | 0x3FFF | 16383dec | R/W | EEPROM
R38 | Light value for timeout (off) |  | 0x0000 | 0dec | R/W | EEPROM
R39 | Dimmer mode |  | 0x0000 | 0dec | R/W | EEPROM
R40 | Behaviour after short circuit |  | 0x0001 | 1dec | R/W | EEPROM
R41 | Mains frequency | KL2751-0000 | 0x0000 | 0dec (50 Hz) | R/W | EEPROM
 |  | KL2751-0011 | 0x0000 | 0dec (50 Hz)
 |  | KL2761-0000 | 0x0000 | 0dec (50 Hz)
 |  | KL2761-0011 | 0x0000 | 0dec (50 Hz)
R42 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R63 | reserved |  | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for the parameterization of the terminal.
Basic configuration is also possible via the PLC using the FB_KL27x1Config function block.
R7: Command register
Note
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
▪
Command 0x7000: Restore Factory Default Settings
Entering 0x7000 in register R7 restores the factory settings for the following registers:
R33: 0dec
R34: 256dec
R35: 3dec
R36: 10dec
R37: 16383dec
R38: 0dec
R39: 0dec
R40: 1dec
R41: 0dec (KL2751-0000, KL2751-0011, KL2761-0000, KL2761-0011)
R8: Terminal type
The terminal identifier is contained in register R8: KL2751 or KL2761.
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value cannot be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R29: Terminal type, special version
Register R29 contains the special version of the terminal.
R31: Code word register
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data. The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | - | - | - | - | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | DimRamp | disWatchdog | - | enUserScale
Legend
Bit | Name | Description |  | Default
R32.15 - R32.4 | - | reserved
R32.3 | DimRamp | 0bin | Dimming ramp relative: The time in register R35 relates to the entire process data range (0dec - 32767dec). This means that the dimmer terminal requires this time to control from "off" (0dec) to full scale control (32767dec). | 0bin
 |  | 1bin | Dimming ramp absolute: The time in register R35 relates to the current process data change. This means that the dimmer terminal requires this time in order to execute the current brightness change.
R32.2 | disWatchdog | 1bin | Internal watchdog (time adjustable) deactivated | 0bin
R32.1 | - | reserved
R32.0 | enUserScale | 1bin | User scaling active (see R33+ R34) | 0bin
R33: User scaling - offset
The offset of the user scaling when the user scaling (R32.0=1bin) is enabled is entered in this register (default: 0).
R34: User scaling - gain
The gain of the user scaling when the user scaling (R32.0=1bin) is enabled is entered in this register.
Example values:
128dec = 0x80 = factor 0.5
256dec = 0x100 = factor 1.0 (default)
512dec = 0x200 = factor 2.0
R35: Ramp time
This register specifies the time required
▪
to ramp up from 0 to 32767 (full scale control of the angle) (when R32.3 = 0bin) or
▪
to execute the current brightness change (when R32.3 = 1bin).
0dec: 50 ms
1dec: 100 ms
2dec: 200 ms
3dec: 500 ms (default)
4dec: 1 s
5dec: 2 s
6dec: 5 s
7dec: 10 s
R36: Watchdog Timeout
This register specifies the timeout in the event of a fieldbus error. The unit is 10 ms (default: 10dec = 100 ms).
R37: Light value for timeout (on)
This register specifies the light value that is output in the case of a fieldbus error and current process data > 0 (default: 16383dec).
The unit is 1. (R32.2=1bin).
R38: Light value for timeout (off)
This register specifies the light value that is output in the case of a fieldbus error and current process data = 0 (default: 0dec).
The unit is 1. (R32.2=1bin).
R39: Dimmer mode
This register specifies the dimmer mode:
0dec: automatic detection (default)
1dec: Trailing edge phase control
2dec: Leading edge phase control
3dec: Rectifier mode, positive (positive half-wave with leading edge phase control)
Do not use this operation mode with firmware version 2E of the KL2751 or with firmware version 1E of the KL2761!
Instead, use the operation mode Rectifier mode, negative with these firmware versions!
4dec: Rectifier mode, negative (negative half-wave with leading edge phase control)
R40: Behavior after short circuit
This register specifies the behavior after a short circuit:
0dec: Remains switched off:
1dec: switch on again (default):
R41: Mains frequency
This register specifies the mains frequency:
0dec: 50 Hz
1dec: 60 Hz
Default value: 50 Hz


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9 of a terminal
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9 of a terminal

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9 of a terminal
Example 1: reading the firmware version from Register 9 of a terminal
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output Data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example! The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


TwinCAT

TwinCAT
TwinCAT
PLC and Motion Control on the PC
TwinCAT - The Windows Control and Automation Technology
The TwinCAT automation software converts any compatible PC into a real-time controller with multi-PLC, NC axis control, programming environment and operating station. TwinCAT replaces conventional PLC and NC controllers as well as operating devices:
▪
open, compatible PC hardware
▪
Embedding of IEC 61131-3 software PLC, software NC and software CNC in Windows NT/2000/XP, NT/XP Embedded, CE
▪
Programming and runtime systems optionally together on one PC or separated
▪
Connection to all common fieldbus systems
▪
PC interfaces are supported
▪
Data communication with user interfaces and other programs by means of open Microsoft standards (OPC, OCX, DLL, etc.)
TwinCAT architecture
TwinCAT consists of runtime systems for real-time execution of control programs and development environments for programming, diagnosis and configuration. Any Windows programs, for instance visualization programs or Office programs, can access TwinCAT data via Microsoft interfaces, or can execute commands.
A practically oriented software solution
TwinCAT offers a precise time-base in which programs are executed with the highest deterministic features, independently of other processor tasks. The real-time load on a PC is set with TwinCAT: This achieves a defined operating behavior. TwinCAT displays the system load for running programs. A loading threshold can be set, in order to assure a defined computing capacity for the operating programs and for Windows NT/2000/XP. If this threshold is exceeded, a system message is generated.
TwinCAT supports system diagnosis
The general use of hardware and software from the open PC world requires some checking: Unsuitable components can upset the PC system. Beckhoff integrates a handy display of the real-time jitter in order to provide administrators with a simple means of evaluating hardware and software. A system message during operation can draw attention to error states.
Start/stop behavior
Depending on the setting, TwinCAT is started and stopped manually or automatically. Since TwinCAT is integrated into Windows NT/2000/XP as a service, an operator is not needed to start the system: switching on is enough.
Restarting and data backup
When a program is started or restarted, TwinCAT loads programs and remanent data. To backup data, and to shut down Windows NT/2000/XP correctly, a UPS (uninterruptible power supply) is of great value.
TwinCAT and "Blue Screen"
The TwinCAT system can be configured such that real-time capability is maintained in the event of a BSOD (Blue-Screen-of-Death) operating system crash. Real-time tasks such as PLC and NC can thus continue to run and place the controlled process in a safe state. Ultimately, it is the decision of the programmer whether or not to utilize this feature, bearing in mind that data or programs may already have been destroyed by the BSOD.
World-wide connection through message routing - "remote" connection is inherent to the system
According to the requirement for operating resources, the TwinCAT software devices can be distributed: TwinCAT PLC programs can be executed on PCs and on Beckhoff Bus Terminal controllers. A "message router" manages and distributes all the messages, both in the system and via TCP/IP connections. PC systems can be connected to one another by TCP/IP; Bus Terminal controllers are connected via serial interfaces and fieldbus systems (EtherCAT, Lightbus, PROFIBUS DP, PROFINET, Interbus, CANopen, DeviceNet, RS232, RS485, Ethernet TCP/IP, Ethernet/IP).
World-wide access
Since standard TCP/IP services from Windows NT/2000/XP are used, this data exchange can take place worldwide. The system offers scalable communication capacity and timeout periods for the monitoring of communications. OPC provides a standardized means for accessing many different SCADA packets. The SOAP (Simple Object Access Protocol) enables a connection between two computers to be established by means of an internet connection via standard HTTP. A TwinCAT component is available for this purpose.
Beckhoff Information System
Further information on the TwinCAT automation software can be found in the Beckhoff Information System.
The setup for installing the Beckhoff Information System is available to you on the Beckhoff Products & Solutions DVD and on our website for download.
In addition, the online version of the Beckhoff Information System can be found at https://infosys.beckhoff.com.
Additional information
•
Programming
•
FB_KL27x1Config function block
•
FB_Dimmer1SwitchEco function block
•
Importing a function block


Programming

TwinCAT [image] Programming
Programming
TwinCAT libraries
See software documentation in the Beckhoff Information System.
TwinCAT 2: TwinCAT PLC Lib: I/O functions
TwinCAT 3: TwinCAT 3 PLC Lib: Tc2_IoFunctions


FB_KL27x1Config function block

TwinCAT [image] FB_KL27x1Config function block
FB_KL27x1Config function block
The KL2751 and KL2761 terminals can be configured using the FB-KL27x1Config function block. A detailed description can be found in the Beckhoff Information System:
TwinCAT2: TwinCAT PLC Lib: IO functions/Bus Terminal configuration
TwinCAT3: TwinCAT 3 PLC Lib:Tc2_IoFunctions/Function blocks/Bus Terminal configuration


FB_Dimmer1SwitchEco function block

TwinCAT [image] FB_Dimmer1SwitchEco function block
FB_Dimmer1SwitchEco function block
FB_Dimmer1SwitchEco
Description
The FB_Dimmer1SwitchEco block is a variant of FB_Dimmer1Switch that saves memory space. It lacks the special functions Set brightness value and Disable memory function, which may not be required for many applications. Moreover, the values nOutMin and nOutMax of the FB_Dimmer1Switch are set internally here to 0 and 32767 respectively. This output span corresponds to the display range of an analog output terminal. The tPLCCycle input is important. This time is used to calculate internally the amount by which the nOut output must be increased per cycle - that saves additional time calculations.
Operating by means of the bSwitchDimm input
The light is switched on or off by a short signal at the bSwitchDimm input. Dimmer mode will be activated if the signal remains for longer than tSwitchOverTime (typical recommended value: 200 ms). The output signal moves cyclically between 0 and 32767. In order to be able to better adjust the maximum or minimum value, the output signal dwells at the minimum or maximum value for the time tCycleDelay. When the signal is once more removed, the output signal being generated at that time is retained. Another pulse at the input will set the output to 0.
Operation by means of the bOn and bOff inputs
The light is immediately switched on or off if a rising edge is applied to the bOn or bOff inputs. For example, for global on/off functions. The output value is set to 0 when switching off.
Memory function
Unlike FB_Dimmer1Switch, in which the memory function can be activated or deactivated via the bMemoryModeOn input, the memory function is always active in this version for saving memory space. This means that the last-set value is adopted as the brightness value when switching on. It is irrelevant, in this case, whether the light has been switched on by means of the bOn input or the bSwitchDimm input.
Comment on the tSwitchOverTime parameter
If a duration of 0 is specified for the parameter tSwitchOverTime, the bSwitchDimm input can only be used to dim the light. Switching on and off is only possible with the bOn and bOff inputs.
VAR_INPUT
bSwitchDimm : BOOL;
bOn : BOOL;
bOff : BOOL;
tSwitchOverTime : TIME;
tDimmTime : TIME;
tCycleDelay : TIME;
tPLCCycle : TIME;
bSwitchDimm: Switches or dims the output.
bOn: Switches the output to the last output value, or to the value specified by nOnValueWithoutMemoryMode.
bOff: Switches the output to 0.
tSwitchOverTime: Time for switching between the light on/off and dimming functions for the bSwitchDimm input.
tDimmTime Time required for dimming to go from its minimum value to its maximum value.
tCycleDelay: Delay time, if either the minimum or maximum value is reached.
tPLCCycle: the set PLC cycle time.
VAR_OUTPUT
nOut : UINT;
bLight : BOOL;
nOut: analog output value.
bLight: digital output value. This is set if nOut is greater than 0.
Download
Click on the following symbol to download the file with the FB_Dimmer1SwitchEco function block from this documentation.
FB_Dimmer1SwitchEco.exp.zip
Save the FB_Dimmer1SwitchEco.exp file contained in this zip file on your PC.
Note
Importing a function block
The import of a function block into your TwinCAT system is described in the chapter Importing a function block.


Importing a function block

TwinCAT [image] Importing a function block
Importing a function block
To import a function block into your TwinCAT, click on the menu item Project/Import in the TwinCAT PLC Control.
Importing a function block into TwinCAT PLC
Select the folder in which you have saved the exp file (DB_Dimmer1SwitchEco.exp in the example), select the file and click on the Open button.
Import Project dialog
Following successful import the PC Control reports Import complete.


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com