KL2692 - cycle monitoring terminal
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.0.1
▪
Process image corrected
▪
Information on basic function principles expanded
1.0
Description of KL2692 parameterization with the KS2000 configuration software expanded.
0.2
Preliminary Version
0.1
Preliminary version for internal use
Firmware and hardware versions
Documentation Version | KL2531
 | Firmware | Hardware
2.0.0 | 1C | 04
1.0.1 | 1B | 01
1.0 | 1B | 00
0.2 | - | 00
0.1 | - | 00
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. No.: 39 04 1B 01:
39 - week of production 39
04 - year of production 2004
1B - firmware version 1B
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Basic function principles
•
LEDs


Introduction

Product overview [image] Introduction
Introduction
KL2692
The KL2692 Bus Terminal monitors a bit that is toggled by the controller during each cycle. If the toggle signal fails, the terminal switches off two potential-free relays in order to prevent damage to the machine. Failure of the toggle signal may be caused by the PLC cycle stopping, by a fault in the bus cable or connector, or by a fault in a bus device. The cycle monitoring time can be parameterized. The Bus Terminal has an enable input that enables the relay to be switched on if a correct toggle signal is detected.
DANGER
No personal protection!
The KL2692 may only be used for cycle monitoring with the purpose of preventing machine damage!
The KL2692 must not be used for cycle monitoring for personal protection under any circumstances!
The KL2692 must not be used for protection functions such as emergency stop, access protection, secure room monitoring, robot range monitoring, press safety valves etc.!


Technical data

Product overview [image] Technical data
Technical data
Technical data | KL2692
Number of outputs | 2 potential-free relay outputs (make contacts)
Rated load voltage of the outputs | 230 VAC / 30 VDC
Ohmic switching current | 5 AAC / 5 ADC
Inductive switching current | 2 AAC / 2 ADC
Minimum permitted load | 10 mA at 5 VDC
Number of inputs | 2 digital inputs (24 V)
Rated voltage of the inputs | 24 VDC (-15% / +20%)
Signal voltage "0" | -3 V ... 5 V (EN 61131-3, type 1)
Signal voltage "1" | 15 V ... 30V (EN 61131-3, Type 1)
Input filter | 3.0 ms
Input current | typically 5 mA
Electrical isolation | 500 V (K-bus/field voltage)
Power supply for the electronics | via the K-bus
Current consumption from K-bus | typically 165 mA
Bit width in the input process image | 2 x 8 bit data, 1 x 8 bit status
Bit width in the output process image | 2 x 8 bit data, 1 x 8 bit control
Mechanical switching cycles | minimum 2 x 107
Electrical switching cycles | minimum 1 x 105 (5 A / 30 VDC)
Configuration | via the Bus Coupler or the controller
Weight | approx. 60 g
Permissible ambient temperature range during operation | 0 °C ... + 55 °C
Permissible ambient temperature range during storage | -25°C ... + 85 °C
Permissible relative air humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE


Basic function principles

Product overview [image] Basic function principles
Basic function principles
Pulse sequence monitoring (cycle)
1.
Monitoring is enabled with a falling edge at Input 1.
2.
If the pulse sequence is too slow (cycle time tP too long), the output relays switch off for a minimum switch-off time tAmin. The minimum switch-off time can be specified in register R36.
3.
If a pulse sequence (1 cycle) was recognized as correct, the output relays will only switch on again once monitoring is enabled again. This switching mode ensures that triggering of the watchdog remains recognizable.
4.
The two output contacts are looped into the control circuit of the switch-off relay.
Automatic self-start is prevented, since the switch-off function block has to be reset through an explicit manual intervention (monitoring enable).
Note
Monitoring enable with falling edge
Monitoring is enabled with a falling edge at Input 1. Therefore, monitoring cannot be enabled with a continuous signal (high) at Input 1!
Example
Signal sequence
Sequence
1.
Rising edge at input 1
2.
Toggle signal on the bus starts to toggle
3.
Falling edge at input 1 (monitoring enable)
4.
A full toggle cycle after the falling edge switches on the relays (Start)
5.
Toggle signal on the bus stops toggling and remains in low state
6.
The relays switch off after a missed toggle cycle (Stop)
7.
Toggle signal on the bus starts to toggle again
8.
Rising edge at input 1
9.
Falling edge at input 1 (monitoring enable)
10.
A full toggle cycle after the falling edge switches the relays back on again (Re-start)
11.
Toggle signal on the bus stops toggling and remains in high state
12.
The relays switch off after a missed toggle cycle (Stop)
13.
Toggle signal on the bus starts to toggle again
14.
Rising edge at input 1
15.
Falling edge at input 1 (monitoring enable)
16.
A full toggle cycle after the falling edge switches the relays back on again (Re-start)


LEDs

Product overview [image] LEDs
LEDs
LEDs
LED | Display
Relay 1 (green) | On | Relay contact 13/14 (make contact 1) closed
Relay 2 (green) | On | Relay contact 23/24 (make contact 2) closed
Watchdog OK (green) | On | The watchdog is triggered on a regular basis.
Error (red) | not used
- | not used
- | not used
Input 1 (green) | Status input 1 (watchdog enable)
Input 2 (green) | Status input 2


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection
•
Application example


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Connection


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the ELxxxx and KLxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Connection

Mounting and wiring [image] Connection [image] Connection
Connection
KL2692 connection
Terminal point | No. | Connection for
13 | 1 | Relay contact 13 (NO contact 1)
14 | 2 | Relay contact 14 (NO contact 2)
+24 V | 3 | 24 V power contact
Input 1 (Watchdog Enable) | 4 | Input 1 (24 VDC), watchdog enabled with negative edge
23 | 5 | Relay contact 23 (NO contact 1)
24 | 6 | Relay contact 24 (NO contact 2)
0 V | 7 | 0 V power contact
Input 2 | 8 | Input 2 (24 VDC)


Application example

Mounting and wiring [image] Application example
Application example
DANGER
No personal protection!
The KL2692 may only be used for cycle monitoring with the purpose of preventing machine damage!
The KL2692 must not be used for cycle monitoring for personal protection under any circumstances!
The KL2692 must not be used for protection functions such as emergency stop, access protection, secure room monitoring, robot range monitoring, press safety valves etc.!
Switching off the voltage for the power contacts
The NO contacts of the KL2692 control a contactor that switches the supply voltage (24 V) for the power contacts..
Application example
Function
1.
Monitoring can be enabled via push button S1 (negative edge) when the watchdog is triggered. The KL2692 relays are switched on, and contactor K1 switches on the supply voltage (24 V) for the power contacts.
2.
If the watchdog is not triggered over the watchdog time specified in register R35, the KL2692 relays are de-energized and contactor K1 switches off the supply voltage for the power contacts.
3.
If the watchdog is triggered again, monitoring has to be re-enabled via push button S1, so that the KL2692 relays switch on again!
4.
NC contacts S2 and S3 can be used for manually switching off contactor K1 and therefore the supply voltage for the power contacts.


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Process data


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 digital input terminal
▪
a KL2692 watchdog terminal
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of the KL2692
For the KL2692, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2692.
▪
Under Settings you find dialog boxes for parameterizing the KL2692.
▪
ProcData shows the process data of the KL2692.


Register

KS2000 Configuration Software [image] Register
Register
You can access the registers of the KL2692 directly under Register. The meaning of the register is explained in the register overview.
Register view in KS2000


Settings

KS2000 Configuration Software [image] Settings
Settings
The dialog mask for the parameterization of the KL2692 can be found under Settings.
Settings via KS2000
Watchdog time (R35)
This can be used for setting the watchdog time (default: 4 ms). Within the watchdog time, an edge change must occur on the toggle bit of the control bytes (CB.0), in order to prevent the drop-out of the output relays.
Minimum switch-off time (R36)
This can be used for setting the minimum time (default: 50 ms) for which the relays remain switched off after the watchdog has been triggered, even if, after a subsequent monitoring activation, the following pulse sequence is recognized as correct.


Process data

KS2000 Configuration Software [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field
Output values can be modified through direct input or by means of the fader control.
Value field
CAUTION
Danger for persons, the environment or devices!
Note that changing output values (forcing them) can have a direct effect on your automation application.
Only modify these output values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The KL2692 is represented in the process image with a minimum of 3 bytes of input data and 3 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB | CB
1 | 2 | Word | DataIN | DataOUT
*) Word alignment: The Bus Coupler places values on even byte addresses
Key
SB: Status byte
CB: Control byte
DataIN: input word
DataOUT: output word
Note
No compact process image
The KL2692 cannot be operated with compact process image (without control and status bytes), since control and status bytes are required for process data operation of the KL2692 to function correctly. Even if your Bus Coupler is set to compact process image, the KL2692 is represented with its complete process image!


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Process data mode
Control byte (for process data mode)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | - | - | - | - | - | - | Toggle
Key
Bit | Name | Description
CB7 | RegAccess | 0bin | Register communication off (process data mode)
CB.6 to CB.2 | - | 0bin | reserved
CB.0 | Toggle | Toggle bit
Status byte (for process data mode)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | - | - | - | IN_2 | IN_1 | WDT_Run | Toggle_St
Key
Bit | Name | Description
SB.7 | RegAccess | 0bin | Acknowledgment for process data mode
SB.6 to SB.4 | - | 0bin | reserved
SB.3 | IN_2 | Status input 2
SB.2 | IN_1 | Status input 1
SB.1 | WDT_Run | 0bin | Watchdog timer is not triggered. The outputs are not set.
 |  | 1bin | Watchdog timer is active and locked. The outputs are set.
SB.0 | Toggle_St | This bit follows the toggle bit in the control byte
Register communication
Control byte (for register communication)
The control byte (CB) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB.7 | RegAccess | 1bin | Register communication switched on
CB.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB.5 to CB.0 | Reg. no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIn, or - to write with output data word DataOut.
Status byte (for register communication)
The status byte (SB) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB.7 | RegAccess | 1bin | Acknowledgment for register access
SB.6 | R | 0bin | Read access
SB.5 to SB.0 | Reg. no. | Number of the register that was read or written.


Register overview

Access from the user program [image] Register overview
Register overview
All registers can be read or written via register communication. They are used for parameterizing the KL2692.
Register no. | Comment | Default value |  | R/W | Memory
R0 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R5 | reserved | - | - | - | -
R6 | Diagnostic register (not used) | 0x0000 | 0dec | R | RAM
R7 | Command register (not used) | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x0A84 | 2692dec | R | ROM
R9 | Firmware version | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register | 0x0118 | 280dec | R | ROM
R11 | Signal channels | 0x0118 | 280dec | R | ROM
R12 | Minimum data length | 0x1818 | 6168dec | R | ROM
R13 | Data structure | 0x0000 | 0dec | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | variable | variable | R/W | RAM
R16 | Hardware version number | e.g. 0x0000 | e.g. 0dec | R/W | SEEPROM
R17 | reserved | - | - | - | -
... | ... | - | - | - | -
R30 | reserved | - | - | - | -
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0000 | 0dec | R/W | SEEPROM
R33 | reserved | - | - | - | -
R34 | reserved | - | - | - | -
R35 | Watchdog time tP | 0x0004 | 4dec | - | SEEPROM
R36 | Minimum switch-off time tAmin | 0x0064 | 100dec | - | SEEPROM
R37 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R63 | reserved | - | - | - | -


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for parameterizing the KL2692.
R8: Terminal description
The description of the terminal is contained in register R8. KL2692: 0x0A84 (2692dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R31: Code word register
▪
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data.
▪
If you write values into the user registers and have previously entered the user code word (0x1235) in the code word register, these values are stored in the RAM registers and in the SEEPROM registers and are therefore retained if the terminal is restarted.
The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the configuration of the terminal (in preparation).
R35: Watchdog time tP
An edge change within the watchdog time is required to prevent the drop-out of the watchdog.
Scaling: 500 µs / bit
Default value: 8dec (4 ms).
R36: Minimum switch-off time tAmin
Minimum time for which the relays remain switched off after the watchdog has been triggered, even if, after a subsequent monitoring activation, the following pulse sequence is recognized as correct.
Scaling: 500 µs / bit
Default value: 100dec (50 ms).


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com