KL2542 - DC motor output stage terminal
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.0.0
▪
Register description expanded
0.5
▪
KL2532 removed
0.4
▪
Description of control and status byte updated
▪
Register description corrected
0.3
▪
Connection description added
▪
LED descriptions updated
▪
Technical data updated
0.2
▪
Information on KL2532 added
▪
Description of parameterization using the KS2000 configuration software added
0.1
First provisional documentation for KL2542
Firmware and hardware versions
Documentation Version | Firmware | Hardware
2.0.0 | 3A | 10
1.0.0 | 1C | 05
0.5 | 1C | 05
0.4 | 1B | 03
0.3 | 1B | 03
0.2 | 1A | 01
0.1 | 1A | 01
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Sample with ser. no.: 49 05 1B 03:
49 - week of production 49
05 - year of production 2005
1B - firmware version 1B
03 - hardware version 03


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
LEDs


Introduction

Product overview [image] Introduction
Introduction
KL2542
The two-channel KL2542 DC motor output stage enables direct operation of two DC motors. The set speed or the position is specified by the automation device through a 16-bit value. The output stage is protected against overload and short-circuit and is electrically isolated from the K-bus. Both channels indicate their state by LEDs, enabling fast on-the-spot diagnosis. A servo axis can easily be realized by connecting an incremental encoder.


Technical data

Product overview [image] Technical data
Technical data
Technical data |  | KL2542
Number of DC motor output stages |  | 2
Load type |  | DC brush motors, inductive
Supply for the output stage |  | via terminal points
Rated load voltage |  | 8 VDC to 50 VDC
Output current per channel |  | Rated current 3.5 A, peak current 5 A (short-circuit-proof, common thermal overload warning for both output stages)
PWM clock frequency |  | 36 kHz, channels out of phase by 180° relative to each other
Duty factor |  | 0 ... 100% (voltage-controlled)
Resolution | Current | 12 bit
 | Voltage (velocity) | 16 bit
Number of digital inputs |  | 2 (for end positions)
Rated voltage of the inputs |  | 24 VDC (-15% / +20%)
Signal voltage at digital input "0" |  | -3 V ... 2 V
Signal voltage at digital input "1" |  | 15 V ... 30 V
Input filter |  | 0.2 ms
Input current |  | typically 5 mA
Number of encoder inputs |  | 4 (for an encoder system)
Encoder voltage "0" |  | -3 V ... 1.5 V
Encoder voltage "1" |  | 2.5 V ... 24 V
Encoder frequency |  | max. 250 kHz
Electrical isolation |  | 500 V (K-bus/mains voltage)
Power supply for the electronics |  | via the K-bus
Current consumption from K-bus |  | typically: 100 mA
Current consumption from power contacts |  | typically: 20 mA
Bit width in the input process image |  | 2 x 16 bit data, 2 x 8 bit status
Bit width in the output process image |  | 2 x 16 bit data, 2 x 8 bit control
Configuration |  | via the Bus Coupler or the controller
Weight |  | approx. 100 g
Permissible ambient temperature range during operation |  | 0°C ... + 55°C
Permissible ambient temperature range during storage |  | -25 °C ... + 85 °C
Permissible relative air humidity |  | 95 %, no condensation
Dimensions (W x H x D) |  | approx. 27 mm x 100 mm x 70 mm (width aligned: 24 mm)
Mounting |  | on 35 mm mounting rail conforms to EN
Vibration / shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission |  | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class |  | IP 20
Installation position |  | variable
Approval |  | CE


LEDs

Product overview [image] LEDs
LEDs
KL2542 - LEDs
Left LED prism
LED | Display
Run (green) | on | Data transmission on the K-bus is active
Enc. A: A (green) | on | There is a signal at input A for encoder A.
Enc. B: A (green) | on | There is a signal at input A for encoder B.
Input 1 (green) | on | There is a signal at input 1.
- | reserved
Enc. A: B (green) | on | There is a signal at input B for encoder A.
Enc. B: B (green) | on | There is a signal at input B for encoder B.
Input 2 (green) | on | There is a signal at input 2.
Right LED prism
LED | Display
- | reserved
Enable A (green) | off | Channel 1 is either not enabled or not ready to operate.
 | on | Channel 1 is enabled and is ready to operate.
- | reserved
Error A (red) | on | There is an error at channel 1
Motor power (green) | off | The motor supply voltage is not available (less than 7 V).
 | on | The motor supply voltage is available (greater than 8 V).
Enable B (green) | off | Channel 2 is either not enabled or not ready to operate.
 | on | Channel 2 is enabled and is ready to operate.
Warning (yellow) | on | The internal temperature has risen to more than 80 °C, or the power supply voltage has dropped.
Error B (red) | on | There is an error at channel 2


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Connection


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Connection


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the ELxxxx and KLxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Connection

Mounting and wiring [image] Connection [image] Connection
Connection
WARNING
Risk of injury from electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
KL2542 connection
Terminal points
Left-hand section of the housing
Terminal point | No. | Connection for
Encoder A, A | 1 | Encoder A, connection A
Encoder B, A | 2 | Encoder B, connection A
Encoder power +24 V | 3 | Encoder supply (from positive power contact)
Input 1 | 4 | Digital input 1 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CB.1 is set in the control byte and a rising edge occurs at digital input 1.
Encoder A, B | 5 | Encoder A, connection B
Encoder B, B | 6 | Encoder B, connection B
Encoder Power 0 V | 7 | Encoder supply (from negative power contact)
Input 2 | 8 | Digital input 2 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CB.2 is set in the control byte and a rising edge occurs at digital input 2.
Right-hand section of the housing
Terminal point | No. | Connection for
Motor A, A1 | 1' | Motor A, connection A1
Motor B, B1 | 2' | Motor B, connection B1
n. c. | 3' | reserved
Power Motor 50 V | 4' | Motor supply feed (maximum +50 VDC)
Motor A, A2 | 5' | Motor A, connection A2
Motor B, B2 | 6' | Motor B, connection B2
n. c. | 7' | reserved
Power Motor 0 V | 8' | Motor supply feed (0 VDC)
CAUTION
Danger for persons, the environment or devices!
If the K-bus voltage (5 V, supplied via the Bus Coupler supply voltage Us) fails, the output drivers are not reset. This means that the motors are not stopped if they are in motion!
Power contacts
The voltage Up of the power contacts (+24 VDC) supplies the following consumers:
▪
Incremental encoder (terminal points 3 and 7)
▪
Digital inputs (terminal points 4 and 8)
▪
Output driver of the DC motor output stage
CAUTION
Please note the order of the supply voltages.
The voltage Up must already be present at the power contacts when the K-bus voltage is switched on so that the internal circuits (output stage drivers) can be initialized. If this is not possible due to the application (supply is switched, for example, via emergency stop circuit), the terminal performs a software reset after the system starts up. If the voltage Up at the power contacts fails, this is indicated in register 0 through bit R0.14. The return of the voltage is automatically detected and an initialization is performed.


KS2000 Configuration Software

KS2000 Configuration Software
KS2000 Configuration Software
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Settings
•
Register
•
Process data


KS2000 - Introduction

KS2000 Configuration Software [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

KS2000 Configuration Software [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 Configuration Software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
a BK9000 Bus Coupler for Ethernet
▪
a KL1xx2 Digital Input Terminal
▪
a two-channel KL2542 DC motor output stage
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 branch for channel 1 of the KL2542
For the KL2542, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2542.
▪
Under Settings you find dialog boxes for parameterizing the KL2542.
▪
ProcData displays the KL2542 process data.


Settings

KS2000 Configuration Software [image] Settings
Settings
KL2542 parameterization settings.
Settings via KS2000
Operation mode
Watchdog timer active (R32.2)
Here you can deactivate the watchdog (default: active). If the DC motor output stage fails to receive process data from the controller for 100 ms when the watchdog is active, the watchdog is triggered, and the motor stops.
Signed amount representation (R32.3)
Here you can activate the signed amount representation (default: inactive).
User switch-on value active (R32.8)
You can activate the user switch-on value here (the default is inactive).
Velocity control active (R32.15)
Here you can deactivate the velocity control (default: active).
I-controller active (R32.14)
Here you can deactivate the I-controller (default: active).
Inner window for I-controller active (R32.13)
Here you can deactivate the inner window for the I-controller (default: active).
Torque monitoring active (R32.9)
Here you can activate torque monitoring (default: inactive).
Overvoltage protection active (R32.10)
Here you can activate overvoltage protection (chopper resistor) for channel 2 (default: inactive).
User scaling active (R32.0)
Here you can activate user scaling (default: inactive).
Manufacturer scaling active (R32.1)
Here you can activate manufacturer scaling (default: inactive).
Register values
User switch-on value (R35)
Here you can specify the user switch-on value for the velocity (default: 0).
Switching threshold for MixedDecay (R41)
Here you can specify the automatic switch-off threshold for MixedDecay (default: 20%).
Rated motor current (R37)
Here you can specify the rated motor current.
The default is 3500 mA
Maximum motor current (R36)
Here you can specify the maximum motor coil current.
The default is 5000 mA
Internal motor resistance (R40)
Here you can specify the internal motor resistance (default: 1 ohm).
Kp factor (R42)
Here you can specify the Kp factor for the internal velocity control (default: 1).
Inner window for I-controller (R43)
Here you can specify the Kp factor for the internal velocity control (default: 1%).
The I-component of the velocity control is attenuated towards the zero point. This register specifies the value from which the attenuation is activated.
Maximum value for I-controller (R44)
Here you can specify the maximum value for the I-component (default: 5%).
Time constant Tn for I-controller (R45)
Here you can specify the time constant Tn (default: 100).
The time constant controls the time response of the I-controller.
Maximum torque (R38)
Here you can specify the maximum torque for the application (default: 10000), see description of register R2.
If the current value (register R2) exceeds this threshold, only a warning is issued if torque monitoring is disabled (SB1.5=1 and R0.13=1). If torque monitoring is active (R32.9=1), the motor is de-energized and an error is issued (SB1.6=1 and R0.13=1).
User offset (R33)
You can specify the offset for the user-scaling here (default: 0).
User gain (R34)
Here you can specify the user scaling gain (default: 1).


Register

KS2000 Configuration Software [image] Register
Register
You can access the registers of the KL2542 directly under Register. The meaning of the register is explained in the register overview.
Register view in KS2000


Process data

KS2000 Configuration Software [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field
Output values can be modified through direct input or by means of the fader control.
Value field
CAUTION
Danger for persons, the environment or devices!
Note that changing initial values (forcing them) can have a direct effect on your automation application. Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status byte
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
Complex mapping
In the complex process image the KL2542 is represented with at least 6 bytes of input data and 6 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB1: | CB1
1 | 2 | Word | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Word | DataIN2 | DataOUT2
Compact mapping
The KL2542 devices are represented in the compact process image with a minimum of 6 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | - | CB1
1 | 2 | Word | - | DataOUT1
3 | 4 | Byte | - | CB2
4 | 6 | Word | - | DataOUT2
*) Word alignment: The Bus Coupler places values on even byte addresses
Key
SB n: Status byte of channel n
CB n: Control byte of channel n
DataIN n: Input word of channel n
DataOUT n: Output word of channel n
Note
Control-Bytes
The KL2542 cannot be operated without control bytes, since the control bytes are required for enabling the channels. Even if your Bus Coupler is set to compact process image, the KL2542 is represented with its control bytes.


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetPos | disMixed DecayMan
Key
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 | Reset | 1bin | all errors that may have occurred are reset by setting this bit (rising edge)
CB1.5 | Enable | 1bin | Enables channel 1
CB1.4 | GetLatchData | 0bin | Show the current position in the input process data
 |  | 1bin | Show the current latch value in the input process data
CB1.3 | enLatch FallEdge | 1bin | External latch event is enabled (for latch inputs with falling edge, the terminal saves the current position)
CB1.2 | enLatch RiseEdge | 1bin | External latch event is enabled (for latch inputs with rising edge, the terminal saves the current position) ATTENTION: Higher priority than CB1.3 !
CB1.1 | SetPos | 1bin | Position value is set with register R1 (rising edge)
CB1.0 | disMixed DecayMan | 0bin | Motor control via 2 pulsed transistors per half-wave
 |  | 1bin | Motor control via one pulsed and one switched transistor per half-wave (manual deactivation. Automatic deactivation is triggered through a threshold that is specified with registerR41).
Status byte 1 (for process data mode)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetPos Ready | Input E1
Key
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | Error | 1bin | An error has occurred (is displayed in the status word in register R0)
SB1.5 | Warning | 1bin | The internal temperature exceeds 80 °C, the supply voltage has dropped, or the current torque exceeds the value specified in register R38 (with torque monitoring switched off).
SB1.4 | Ready | 0bin | Motor control is disabled or an error has occurred (SB.6=1)
 |  | 1bin | Motor control is enabled and no error has occurred (acknowledgement for enable, SB.6=0)
SB1.3 | LatchData | 0bin | The current position is mapped into the input process data
 |  | 1bin | The most recent latch value is mapped into the input process data, provided a valid latch value exists (acknowledgement for GetLatchData)
SB1.2 | LatchValid | 1bin | A latch event has occurred (with CB1.2=1 or CB1.3=1)
SB1.1 | SetPos Ready | 1bin | The current position has been set (acknowledgement for SetPos)
SB1.0 | Input E1 | Status of input E1
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter the number of the register that you - want to read with input data word DataIn or - want to write with output data word DataOut.
Status byte 1 (in register communication)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Key
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used to parameterize the DC motor output stages. They can be read or written by means of register communication.
Register no. | Comment | Default value |  | R/W | Memory
R0 | Status word | 0x0000 | 0dec | R | RAM
R1 | Set position | 0x0000 | 0dec | R/W | RAM
R2 | Torque | e.g. 0x015E | e.g. 350dec | R | RAM
R3 | Supply voltage | e.g. 0x0030 | e.g. 48dec | R | RAM
R4 | reserved | - | - | - | -
R5 | Temperature | e.g. 0x0023 | e.g. 35dec | R | RAM
R6 | Status byte | e.g. 0x0010 | e.g. 16dec | R | RAM
R7 | Command register | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | 0x09EE | 2542dec | R | ROM
R9 | Firmware version | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register | 0x0130 | 304dec | R | ROM
R11 | Signal channels | 0x0218 | 536dec | R | ROM
R12 | Minimum data length | 0x1800 | 6144dec | R | ROM
R13 | Data structure | 0x0004 | 4dec | R | ROM
R14 | reserved | - | - | - | -
R15 | Alignment register | 0x7F80 | 32640dec | R/W | RAM
R16 | Hardware version number | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved | - | - | - | -
... | ... | ... | ... | ... | ...
R30 | reserved | - | - | - | -
Register no. | Comment | Default value |  | R/W | Memory
R31 | Code word register | 0x0000 | 0dec | R/W | RAM
R32 | Feature register | 0x0000 | 0dec | R/W | EEPROM
R33 | User scaling - offset | 0x0000 | 0dec | R/W | EEPROM
R34 | User scaling - gain | 0x1000 | 4096dec | R/W | EEPROM
R35 | User's switch-on value | 0x0000 | 0dec | R/W | EEPROM
R36 | Maximum coil current of the motor | 0x1388 | 5000dec | R/W | EEPROM
R37 | Rated current of the motor | 0x0DAC | 3500dec | R/W | EEPROM
R38 | Maximum torque | 0x2710 | 10000dec | R/W | EEPROM
R39 | Chopper voltage (channel 2 only) | 0x0000 | 0dec | R/W | EEPROM
R40 | Internal resistance of the motor | 0x0064 | 100dec | R/W | EEPROM
R41 | Automatic switch-off threshold for MixedDecay | 0x0014 | 20dec | R/W | EEPROM
R42 | Kp factor | 0x1000 | 4096dec | R/W | EEPROM
R43 | Inner window of the I component | 0x0001 | 1dec | R/W | EEPROM
R44 | Maximum value of the I component | 0x0005 | 5dec | R/W | EEPROM
R45 | Time constant Tn of the I component | 0x0064 | 100dec | R/W | EEPROM
R46 | Time constant for deleting or limiting the maximum torque | 0x01F4 | 500dec | R/W | EEPROM
R47 | Time constant for limiting the rated motor current | 0x2710 | 10000dec | R/W | EEPROM
R48 | reserved |  |  |  |
... | ... | ... | ... | ... | ...
R61 | reserved |  |  |  |
R62 | Internal parameters for current control | 0x03E8 | 1000dec | R/W | EEPROM
R63 | Internal parameters for current control | 0x0064 | 100dec | R/W | EEPROM


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for the parameterization of the terminal.
R0: Status word
The status word contains information about internal states, and provides an indication of errors that have occurred.
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | - | NoControl Power | Torque Overload | Over Current | Under Voltage | Over Voltage | Low Voltage | Over Temperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | - | - | - | - | - | - | -
Key
Bit | Name | Description
R0.15 | - | reserved
R0.14 | NoControl Power | 1bin | The 24 V control voltage is not present at the power contacts
R0.13 | Torque Overload | 1bin | Torque is greater than specified in R38
R0.12 | Over Current | 1bin | Overcurrent in the driver stage
R0.11 | Under Voltage | 1bin | Supply voltage less than 7 V
R0.10 | Over Voltage | 1bin | Supply voltage greater than 15% of the switch-on voltage (with R39=0) or greater than specified in R39 (with R39<>0)
R0.9 | Low Voltage | 1bin | The supply voltage is 10 V less than the switch-on voltage
R0.8 | Over Temperature | 1bin | The internal temperature of the terminal is greater than 80 °C (see R5)
R0.0 - R0.7 | - | reserved
R1: Set position
You can specify the desired position, with which the terminal is to be loaded, here.
R2: Torque
This register always contains the last and maximum value of the previous milliseconds (register R46) for the current torque. This value is unitless, normalized relative to 1000, and always positive. It is calculated as follows:
1.0 | M = | E x 1000 / VC |
where |
1.1 | E = VC - VG
1.2 | VC = VS x DataOUT / 32767
with
M | Torque (magnitude) | [M] = 1
E | Control error | [E] = 1 V
VS | Supply voltage | [VS] = 1 V
VG | Countervoltage of the motor | [VG] = 1 V
VC | Set velocity (set voltage, relative to the process data) | [VC] = 1 V
R3: Supply voltage
Enables reading of the motor supply voltage. The unit is 1 mV (for example: 4800 = 48 V).
R5: Temperature register
The internal temperature of the terminal can be read, in °C, through register R6. The terminal will set bit SB.5 in the status byte as a warning if the temperature exceeds the threshold of 80°C. When the temperature falls back below 60°C, bit SB.5 will automatically be reset.
R6: Status byte
The status byte of the relevant channel is mapped here in addition.
R7: Command register
Note
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the factory settings for the following registers of both channels:
R32: 0dec
R33: 0dec
R34: 4096dec
R35: 0dec
R36: 5000dec
R37: 3500dec
R38: 10000dec
R39: 0dec
R40: 100dec
R41: 20dec
R42: 4096dec
R43: 1dec
R44: 5dec
R45: 100dec
R46: 500dec
R47: 10000dec
Note
Restore Factory Settings
The command Restore Factory Settings simultaneously resets both channels of the DC motor output stage terminal to the delivery state, irrespective of which register set it is called!
Command 0x8000: Software Reset
Entering 0x8000 in register R7 initiates a full software reset for the terminal. All internal variables (positions, latched values, errors, etc.) are cleared or are set to defined values that are read from the EEPROM. The internal circuits (D/A converter, output driver) are reinitialized during a software reset.
CAUTION
Danger to persons and machines!
During a software reset the motor is de-energized. Ensure that your system state permits this and that hazards for persons or machinery have been ruled out!
R8: Terminal type
The terminal name is contained in register R8:
0x09EE (2542dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value can not be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R31: Code word register
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data. The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | disVelocity Controller | disIPart | disIWindow | - | - | enChopper | enTorque Error | enUser StartValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | enAverage Notation | disWatchdog | enManu Scale | enUser Scale
Key
Bit | Name | Description |  | default
R32.15 | disVelocity Controller | 1bin | Velocity control is deactivated (proportional and integral component), see R42 | 0bin
R32.14 | disIPart | 1bin | I component of the velocity control is deactivated (see R44 + R45) | 0bin
R32.13 | disIWindow | 1bin | Inner window of the I component is deactivated (see R43) | 0bin
R32.11 - R32.12 | - | reserved
R32.10 | enChopper | 1bin | Chopper resistor is active (overvoltage protection, channel 2 only, see R39) | 0bin
R32.9 | enTorque Error | 1bin | Torque cutoff active (see R38) | 0bin
R32.8 | enUser StartValue | 1bin | User switch-on value active (see R35) | 0bin
R32.4 - R32.7 | - | reserved
R32.3 | enAverage Notation | 1bin | Signed amount representation active | 0bin
R32.2 | disWatchdog | 1bin | Internal 100 ms watchdog deactivated | 0bin
R32.1 | enManuScale | 1bin | Manufacturer scaling is active | 0bin
R32.0 | enUserScale | 1bin | User scaling active (see R33+ R34) | 0bin
R33: User scaling - offset
Here you can enter the user scaling offset, if user scaling is enabled (R32.0=1) (default: 0x0000). Examples:
hex | ... | 0xFFFD | 0xFFFE | 0xFFFF | 0x0000 | 0x0001 | 0x0002 | ...
Offset | ... | -3 | -2 | -1 | 0 | 1 | 2 | ...
R34: User scaling - gain
Here you can enter the user scaling gain, if user scaling is activated (R32.0=1) is (default 4096dec).
Examples:
hex | 0x0001 | 0x0800 | 0x0FFF | 0x1000 | 0x1001 | 0x1800 | 0x2000 | 0xFFFF
dec | 1dec | 2048dec | 4095dec | 4096 dec | 4097dec | 6144dec | 8192dec | 65535dec
Offset | 0.0002 | 0.5 | 0.0098 | 1 | 1.0002 | 1.5 | 2 | 15.9998
R35: User's switch-on value
If the activated watchdog (R32.2 = 0bin) is triggered after 100 ms due to a fieldbus or Terminal Bus error, this value becomes the output value.
R36: Maximum coil current of the motor
This register specifies the maximum coil current of the motor. The unit is 1 mA (example: 1500dec = 1.5 A).
5000 mA max.
R37: Rated current of the motor
This register specifies the rated current of the motor. The unit is 1 mA (example: 1,000dec = 1.0 A).
3500 mA max.
R38: Maximum torque
This register is used for configuring the maximum permitted torque for the application (default: 10000dec), see register description R2
If the current value (register R2) exceeds this threshold, with R32.9=0 only a warning is issued (SB1.5=1 and R0.13=1). If torque cutoff is active (R32.9=1), the motor is de-energized and an error is issued (SB1.6=1 and R0.13=1).
R39: Chopper voltage (channel 2 only)
If the supply voltage increases above the set chopper voltage due to feedback, the second channel (chopper resistor must be connected) is fully opened and the overvoltage reduced, provided the chopper function is activated (R32.10=1).
R40: Internal resistance of the motor
This register contains the internal resistance of the motor (default: 100dec).
The unit is 0.01 ohm (example: 100dec = 1.00 ohm).
R41: Automatic switch-off threshold for MixedDecay
MixedDecay: To avoid motor resonances at low speed, the motor is controlled via two pulsed transistors per half-wave.
This register contains the threshold at which the MixedDecay function of the motor controller chip is automatically deactivated (default: 20dec).
The unit is 1% (example: 20 = 20%).
R42: Kp factor
This register contains the Kp factor of the internal velocity control (default: 4096dec).
The unit is 1 / 4096 (example: 4096dec => Kp = 1.00).
R43: Inner window of the I component
The I-component of the velocity control is reduced towards zero (default: 1dec). This register specifies the value from which the attenuation is activated.
The unit is 1% (example: 1 = 1%).
R44: Maximum value of the I component
This register specifies the maximum value of the I-component (default: 5dec).
The unit is 1% (example: 5dec = 5%).
R45: Time constant Tn of the I component
This register controls the dynamic response of the I-controller (default: 100dec).
The unit is 1 (example: 100dec = 100).
R46: Time constant for deleting or limiting the maximum torque
The maximum torque is stored in register R2 for the time set in this register (default: 500dec).
The unit is 1 ms (example: 500 = 0.5 s).
The saved torque is then deleted and overwritten with the next larger value.
If torque cutoff is active, the motor is de-energized if the current torque for this time is greater than the value set in register R38.
R47: Time constant for limiting the rated motor current
The terminal energizes a connected motor with increasing mechanical load up to the current set in register R36. If this mechanical load is maintained, the motor current is reduced to the rated current via a 1/T function after this set time (default: 10,000dec).
The unit is 1 ms (example: 10000 = 10 s).
R62, R63: Internal parameters for current control
These registers are used internally by the terminal for current control and must not be modified!


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com