KL2535_KL2545 – Pulse width current terminals
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH & Co. KG.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.0.0
▪
Migration
1.5.0
▪
Technical data updated
1.4.0
▪
Product overview extended
1.3.0
▪
Mounting instructions updated
1.2.0
▪
Mounting instructions extended
▪
Technical data updated
▪
Register overview updated
1.1.0
▪
Connection description for the KL2535 corrected
▪
Basic function principles corrected
▪
Hardware version of the KL2535 corrected
1.0
First publication
0.1
Internal proof copy
Firmware and hardware versions
Documentation version | KL2535 |  | KL2545
 | Firmware | Hardware | Firmware | Hardware
1.5.0 | 1B | 04 | 2B | 08
1.4.0 | 1B | 01 | 1B | 05
1.3.0 | 1B | 01 | 1B | 05
1.2.0 | 1B | 01 | 1B | 05
1.1.0 | 1B | 00 | 1A | 02
1.0 | 1B | 00 | 1A | 02
0.1 | 1B | 00 | 1A | 02
The firmware and hardware versions (delivery state) can be taken from the serial number printed on the side of the terminal.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with ser. no.: 12 06 1A 02:
12 - week of production 12
06 - year of production 2006
1A - firmware version 1A
02 - hardware version 02


Product overview

Product overview
Product overview
Additional information
•
KL2535 - Introduction
•
KL2535 - Technical Data
•
KL2535 - LED displays
•
KL2545 - Introduction
•
KL2545 - Technical Data
•
KL2545 - LED displays
•
Pulse width modulation
•
Functions


KL2535 - Introduction

Product overview [image] KL2535 - Introduction
KL2535 - Introduction
KL2535
The KL2535 two-channel pulse width current terminal regulates an output current by means of pulse width control of the supply voltage. The current value (0 A to 1 A) is specified with 16-bit resolution by the automation device.
The output stage is protected against overload and short-circuit and is electrically isolated from the K-bus. Both channels indicate their state by LEDs, enabling fast on-the-spot diagnosis.
The Bus Terminal is available in the KL2535 version for standard wiring and the KS2535 for permanent wiring.


KL2535 - Technical Data

Product overview [image] KL2535 - Technical Data
KL2535 - Technical Data
Technical data | KL2535/KS2535
Number of output stages | 2
Load type | ohmic/inductive > 1 mH
Supply for the output stage | 24 VDC via power contacts
Output current per channel | 1 A (short-circuit-proof, common thermal overload warning for both output stages)
PWM clock frequency | 36 kHz
Resolution | max. 12 bit
Number of digital inputs | 2 digital inputs (24 V)
Nominal voltage of the inputs | 24 VDC (-15%/+20%)
Signal voltage “0” | -3 V... 2 V
Signal voltage “1” | 15 V... 30 V
Input filter | 0.2 ms
Input current | typically 5 mA
Electrical isolation | 500 V (K-bus/mains voltage)
Supply voltage for internal E-bus circuit | via the K-bus
Current consumption from K-bus | typically: 60 mA
Current consumption from the power contacts | typically: 10 mA
Bit width in the input process image | 2 x 16 bit data, 2 x 8 bit status
Bit width in the output process image | 2 x 16 bit data, 2 x 8 bit control
Configuration | via the Bus Coupler or the controller
Weight | approx. 55 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Correct installation position | see section Installation position
Approval | CE


KL2535 - LED displays

Product overview [image] KL2535 - LED displays
KL2535 - LED displays
LED indicators
KL2535 - LEDs
LED | Display
Run (green) | reserved | Data transmission on the K-bus is active
Enable A (green) | off | Channel 1 is either not enabled or not ready to operate.
 | on | Channel 1 is enabled and is ready to operate.
- | reserved
Error A (red) | on | There is an error at channel 1
Power (green) | off | The power supply voltage is absent (less than 7 V).
 | on | The power supply voltage is present (more than 8 V).
Enable B (green) | off | Channel 2 is either not enabled or not ready to operate.
 | on | Channel 2 is enabled and is ready to operate.
Warning (yellow) | on | The internal temperature has risen to more than 80°C, or the power supply voltage has dropped.
Error B (red) | on | There is an error at channel 2


KL2545 - Introduction

Product overview [image] KL2545 - Introduction
KL2545 - Introduction
KL2545
The KL2545 two-channel pulse width current terminal regulates an output current by means of pulse width control of the supply voltage. The current value (0 A to 3.5 A) is specified with 16-bit resolution by the automation device.
The output stage is protected against overload and short-circuit and is electrically isolated from the K-bus. Both channels indicate their state by LEDs, enabling fast on-the-spot diagnosis. An incremental encoder can be connected to each channel for the implementation of the position feedback directly in the terminal.
The Bus Terminal is available in the KL2545 version for standard wiring and the KS2545 for permanent wiring.


KL2545 - Technical Data

Product overview [image] KL2545 - Technical Data
KL2545 - Technical Data
Technical data | KL2545/KS2545
Number of output stages | 2
Load type | ohmic/inductive > 1 mH
Supply for the output stage | 8 VDC to 50 VDC, via terminal locations
Output current per channel | 3.5 A (short-circuit-proof, common thermal overload warning for both output stages)
PWM clock frequency | 36 kHz
Resolution | max. 12 bit
Number of digital inputs | 2 (for end positions)
Rated voltage of the digital inputs | 24 VDC (-15%/+20%)
Signal voltage “0” at digital inputs | -3 V ... 2 V
Signal voltage “1” at digital inputs | 15 V ... 30 V
Input filter | 0.2 ms
Input current | typically 5 mA
Number of encoder inputs | 4 (for an encoder system)
Encoder voltage "0" | -3 V ... 1.5 V
Encoder voltage "1" | 2.5 V ... 24 V
Electrical isolation | 500 V (K-bus/mains voltage)
Supply voltage for internal E-bus circuit | via the K-bus
Current consumption from K-bus | typically: 100 mA
Current consumption from the power contacts | typically: 20 mA
Power loss | typically: 4 W
Bit width in the input process image | 2 x 16 bit data, 2 x 8 bit status
Bit width in the output process image | 2 x 16 bit data, 2 x 8 bit control
Configuration | via the Bus Coupler or the controller
Weight | approx. 100 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 27 mm x 100 mm x 70 mm (width aligned: 24 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Correct installation position | see section Installation position
Approval | CE


KL2545 - LED displays

Product overview [image] KL2545 - LED displays
KL2545 - LED displays
KL2545 - LEDs
Left LED prism
LED | Display
Run (green) | on | Data transmission on the K-bus is active
Enc. A: A (green) | on | There is a signal at input A for encoder A.
Enc. B: A (green) | on | There is a signal at input A for encoder B.
Input 1 (green) | on | There is a signal at input 1.
- | reserved
Enc. A: B (green) | on | There is a signal at input B for encoder A.
Enc. B: B (green) | on | There is a signal at input B for encoder B.
Input 2 (green) | on | There is a signal at input 2.
Right LED prism
LED | Display
- | reserved
Enable A (green) | off | Channel 1 is either not enabled or not ready to operate.
 | on | Channel 1 is enabled and is ready to operate.
- | reserved
Error A (red) | on | There is an error at channel 1
Load Power (green) | off | The power supply voltage for the load is absent (less than 7 V).
 | on | The power supply voltage for the load is present (more than 8 V).
Enable B (green) | off | Channel 2 is either not enabled or not ready to operate.
 | on | Channel 2 is enabled and is ready to operate.
Warning (yellow) | on | The internal temperature has risen to more than 80°C, or the power supply voltage has dropped.
Error B (red) | on | There is an error at channel 2


Pulse width modulation

Product overview [image] Pulse width modulation
Pulse width modulation
The KL2535 and KL2545 pulse-width current terminals include an integrated PWM output stage (up to 175 W) in a very compact design.
By means of the PWM output stage the pulse width modulation (PWM) of the supply voltage is used to regulate the output current of a connected ohmic/inductive load. The full supply voltage, pulsating with a certain frequency, is thereby fed to the output. A load current only develops at the inductance at the high level. The load current is not changed by changing the voltage level, but by the duration of the switch-off (pulse width) in relation to the period duration. This results in a duty factor corresponding to the pulse width divided by the period duration of between 0 and 100% and is proportional to the load current.
Operation at load with adequate inductance
Operation at load inadequate inductance (near ohmic)
The figure "Operation at load with inadequate inductance" illustrates operation with an inadequate inductance. Continuous current flow is not reached. The current has "gaps". This mode of operation is not permitted.
Note
Pulse width current terminals require inductive loads
The load inductance should have a minimum inductance of 1 mH. Operation of the pulse width current terminals at loads with an inductance of less than 1 mH is not recommended, since the intermittent current flow prevents reference between the set value and the arithmetic mean of the current.


Functions

Product overview [image] Functions
Functions
The KL2535 and KL2545 pulse-width current terminals include an integrated PWM output stage (up to 175 W) in a very compact design.
General functions
Enable/Readiness for operation
The enable bit CB1.5 in the control byte must be set in order to activate the output stage. If the terminal is not subject to an error at this time, it acknowledges the command by setting the ready bit, SB1.4, in the status byte
Setting/deleting the position (KL2545 only)
The current position value of the encoder can be set or deleted by the user. Register R1 is the reference for this. A rising edge at bit CB1.1 sets the current position, and the acknowledgement is provided through status bit SB1.1.
Latch functions
The internal encoder offers the option of registering a latch event. A latch event can be generated via the digital input signals.
The terminal response to the latch events is activated as follows:
▪
Setting the control bit CB1.2 activates the rising edge at the digital input (highest priority)
▪
Setting the control bit CB1.3 activates the falling edge at the digital input (second-highest priority)
Once the user has enabled the function, during the next latch event, the terminal saves the current position value and indicates this by setting status bit SB1.2. Reading out the latch value must be started by setting CB1.4; this will map the latch value into the DataIN process data (the terminal indicates this through status bit SB1.3).
Note
Enable for latch values
The enable that was set previously must be retained while reading out the latch value. The latch values are lost if the enable is removed!
Digital inputs
The digital inputs are mapped into the status byte in bit SB1.0.
Error indication
The terminal offers the user a variety of diagnostic options. These messages are divided into hardware warnings and hardware errors.
Hardware warnings
When one of the following warning occurs, bit SB1.5 (Warning) is set in the status byte.
▪
OverTemperature R0.8
(If the temperature inside the terminal reaches 80°C, bit SB1.5 (Warning) is set. The bit is automatically reset if the temperature falls below 60°C.
▪
LowVoltage R0.9
Hardware error
If one of the following errors occurs, the load is de-energized and bit SB1.6 (Error) is set in the Status byte.
▪
UnderVoltage R0.11
▪
OverCurrent, R0.12
▪
Open load / broken wire (OpenLoad, R0.13)
▪
Failure of the 24 V control supply (NoControlPower, R0.14)
(The terminal is automatically reinitialized when the control voltage returns)
If an error occurs, it first has to be rectified and subsequently acknowledged and thus cancelled by setting bit CB1.6 in the control byte.
Dithering
Feature bit R32.5 and control bit CB1.0 must be set to activate the dither.
The purpose of this function is to eliminate magnetization effects. Dithering involves modulating a rectangular signal on top of the actual output value. The configuration required for this depends a lot on the particular application. It must be determined with the aid of the characteristic data of whatever actuator is connected.
The following parameters can be set:
Name | Register | Value range | Description
Frequency - f | R37 | 10 Hz to 500 Hz | The frequency of the rectangular signal; the resolution of the setting is 1 Hz.
Amplitude - i | R38 | 0% to 100% | The amplitude of the rectangular signal; the resolution is 1% (with reference to the output current that has been set in register R36)
Switch-off ramp - t | R39 | 0 ms to 32767 ms | When switched on, the dither signal jumps immediately to the amplitude set in R38. When switched off, the signal is attenuated linearly over the time configured here; the resolution is 1 ms.
Frequency - f / Amplitude - i
Switch-off ramp - t
Valve curve
Feature bit R32.4 must be set in order to activate the valve curve.
The following parameters can be set:
Name | Register | Value range | Description
Overlap threshold value - x1 | R40 | 0 to 1000 | The overlap range ends at this process data value; the resolution is 0.1% (as a fraction of 32767)
Overlap output value - y1 | R41 | 0 to 1000 | The maximum output current in the overlap region; the resolution is 0.1% (with reference to the output current that has been set in register R36)
Bend compensation -threshold value- x2 | R42 | 0 to 1000 | The bend compensation range ends at this process data value; the resolution is 0.1% (as a fraction of 32767)
Bend compensation - output value - y2 | R43 | 0 to 1000 | The maximum output current in the bend compensation region; the resolution is 0.1% (with reference to the output current that has been set in register R36)
Area compensation - threshold value - x3 | R44 | 0 to 1000 | The area compensation region ends at this process data value; the resolution is 0.1% (as a fraction of 32767)
The characteristic curve is divided into four regions:
I | Overlapping
II | Bend compensation
III, III' | Area compensation
IV | End region
Valve curve
Process data ramps
Feature bit R32.6 must be set in order to activate the process data ramps.
This function offers the facility for automatically changing the output current from the current process data value to the new one up or down along a linear ramp. The values of registers R45 and R46 here are related to the entire process data range, i.e. from 0 to 32767.
The following parameters can be set:
Name | Register | Value range | Description
Rising ramp - t1 | R45 | 0 to 32767 ms | The time, t1, required for the process data value to rise from 0 to 32767 (resolution: 1 ms).
Falling ramp - t2 | R46 | 0 to 32767 ms | The time, t2, required for the process data value to fall from 32767 to 0 (resolution: 1ms).
Process data ramps


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Installation on mounting rails
•
Prescribed installation position
•
Connection system
•
KL2535 - Connection
•
KL2545 - Connection


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Assembly
Attaching on mounting rail
The Bus Coupler and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the Fieldbus Coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the Terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Note
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Note
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Attention
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Prescribed installation position

Mounting and wiring [image] Prescribed installation position
Prescribed installation position
Attention
Constraints regarding installation position and operating temperature range
When installing the terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Prescribed installation position
The prescribed installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for standard installation position).
The terminals are ventilated from below, which enables optimum cooling of the electronics through convection. "From below" is relative to the acceleration of gravity.
Recommended distances for standard installation position
Compliance with the distances shown in Fig. Recommended distances for standard installation position is strongly recommended.


Connection system

Mounting and wiring [image] Connection system
Connection system
WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of KLxxxx and ELxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring
Standard wiring
The terminals of KLxxxx and ELxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring
Pluggable wiring
The terminals of KSxxxx and ESxxxx series feature a pluggable connection level.
The assembly and wiring procedure for the KS series is the same as for the KLxxxx and ELxxxx series.
The KS/ES series terminals enable the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for KSxxxx and ESxxxx series has been retained as known from KLxxxx and ELxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 connection points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Note
Wiring HD Terminals
The High Density (HD) Terminals of the KLx8xx and ELx8xx series doesn't support steady wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Note
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!
Wiring
Terminals for standard wiring ELxxxx / KLxxxx and terminals for steady wiring ESxxxx / KSxxxx
Mounting a cable on a terminal connection
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire securely and permanently.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width | 0.08 ... 2,5 mm2 | 0.08 ... 2.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals ELx8xx, KLx8xx (HD)
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the contact point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (conductors with a wire end sleeve) | 0.14... 0.75 mm2
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2 (see notice!)
Wire stripping length | 8 ... 9 mm
Shielding
Note
Shielding
Analog sensors and actors should always be connected with shielded, twisted paired wires.


KL2535 - Connection

Mounting and wiring [image] KL2535 - Connection
KL2535 - Connection
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL2535 Connection
Terminal point | No. | Connection
A1 | 1 | Load A, connection A1
B1 | 2 | Load B, connection B1
Sense A | 3 | Load A, sense
Input 1 | 4 | Digital input 1 (24 VDC).
A2 | 5 | Load A, connection A2
B2 | 6 | Load B, connection B2
Sense B | 7 | Load B, sense
Input 2 | 8 | Digital input 2 (24 VDC).


KL2545 - Connection

Mounting and wiring [image] KL2545 - Connection
KL2545 - Connection
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL2545 Connection
Left-hand section of the housing
Terminal point | No. | Connection for
Encoder A, A | 1 | Encoder A, connection A
Encoder B, A | 2 | Encoder B, connection A
Encoder Power +24 V | 3 | Encoder supply (from positive power contact)
Input 1 | 4 | Digital input 1 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CW.1 is set in the control word and a rising edge occurs at digital input 1.
Encoder A, B | 5 | Encoder A, connection B
Encoder B, B | 6 | Encoder B, connection B
Encoder Power 0 V | 7 | Encoder supply (from negative power contact)
Input 2 | 8 | Digital input 2 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CW.2 is set in the control word and a rising edge occurs at digital input 2.
Right-hand section of the housing
Terminal point (right) | No. | Connection for
Load A, A1 | 1' | Load A, connection A1
Load B, B1 | 2' | Load B, connection B1
Sense A | 3' | Load A, sense
Load Power 50 V | 4' | Power supply for supplying the load (maximum +50 VDC)
Load A, A2 | 5' | Load A, connection A2
Load B, B2 | 6' | Load B, connection B2
Sense B | 7' | Load B, sense
Load Power 0 V | 8' | Power supply for supplying the load (0 VDC)
Power contacts
The voltage Up of the power contacts (+24 VDC) supplies the following consumers:
▪
Incremental encoder (terminal points 3 and 7)
▪
Digital inputs (terminal points 4 and 8)
▪
Output stage driver of the pulse width current terminal
Note
Order of switch-on of the supply voltages
The voltage Up must already be present at the power contacts when the K-bus voltage is switched on so that the internal circuits (output stage drivers) can be initialized.
If this is not possible due to the application (supply is switched, for example, via emergency stop circuit), the terminal performs a software reset after the system starts up.
If the voltage Up at the power contacts fails, this is indicated by bit SW.14. The return of the voltage is automatically detected and an initialization is performed.
WARNING
Valves are not reset if the K-bus voltage fails!
If the K-bus voltage fails (5 V, supplied from the supply voltage Us of the Bus Coupler), the output drivers are not reset! This means that the valves are then not driven back to the initial position!


Configuration software KS2000

Configuration software KS2000
Configuration software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Settings
•
Register
•
Process data


KS2000 - Introduction

Configuration software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
Bus Coupler for Ethernet BK9000.
▪
a KL1xx2 digital input terminal.
▪
a KL2535 or KL2545 two-channel pulse width current terminal.
▪
a KL9010 bus end terminal.
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branches for channel 1 of the KL2535
For the KL2535, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2535.
▪
Under Settings you find dialog boxes for parameterizing the KL2535.
▪
ProcData displays the KL2535 process data.


Settings

Configuration software KS2000 [image] Settings
Settings
Settings for parameterization of the KL2535 and KL2545.
Settings via KS2000
Operation mode
Watchdog timer active (R32.2)
Here you can deactivate the watchdog (default: active). If the pulse-width current terminal fails to receive any process data from the controller for 100 ms while the watchdog is active, the watchdog triggers and the valve is switched off.
User scaling (R32.0)
You can activate user scaling here (the default is deactivated).
User switch-on value active (R32.8)
You can activate the user switch-on value here (the default is inactive).
Sign / amount representation (R32.3)
You can activate the sign / amount representation here (the default is inactive).
Dithering active (R32.5)
You can activate the dithering here (the default is inactive).
Valve curve (R32.4)
You can activate the valve curve here (the default is inactive).
Process data ramps active (R32.6)
You can activate the process data ramps here (the default is inactive).
Register values
User offset (R33)
You can specify the offset for the user-scaling here (the default is 0).
User gain (R34)
The gain for the user scaling can be set here (default: 4096dec).
User switch-on value (R35)
You can specify the offset for the user switch-on value for the speed here (the default is 0).
Max. output current (R36)
You can specify the maximum output current here.
KL2535: The default is 1000 mA
KL2545: The default is 3,500 mA
Dithering frequency (R37)
You can specify the frequency of the dither here (the default is 0).
Dithering amplitude (R38)
You can specify the amplitude of the dither here (the default is 0).
Dithering switch-off ramp (R39)
You can specify the switch-off ramp of the dither here (the default is 0).
Overlap threshold value (R40)
You can specify the threshold value of the overlap region here (the default is 0).
Overlap output value (R41)
You can specify the output value of the overlap region here (the default is 0).
Bend threshold value (R42)
You can specify the threshold value of the bend compensation region here (the default is 0).
Bend region output value (R43)
You can specify the output value of the bend compensation region here (the default is 0).
The I-component of the velocity control is attenuated towards the zero point. This register specifies the value from which the attenuation is activated.
Area compensation - threshold value (R44)
You can specify the threshold value of the area compensation region here (the default is 1000dec).
Process data ramp (rising) (R45)
You can specify the rising process data ramp here (the default is 0dec).
Process data ramp (falling) (R38)
You can specify the falling process data ramp here (the default is 0dec).


Register

Configuration software KS2000 [image] Register
Register
Under Register you can directly access the registers of the KL2535/KL2545. The meaning of the register is explained in the register overview.
Register view in KS2000


Process data

Configuration software KS2000 [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field
Initial values can be modified through direct input or by means of the fader.
Value field
CAUTION
Danger for persons, the environment or equipment!
Note that changing initial values (forcing them) can have a direct effect on your automation application.
Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status bytes
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
The KL2535 and KL2545 appear in the complex process image with at least 6 bytes of input and 6 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB1 | CB1
1 | 2 | Word | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Word | DataIN2 | DataOUT2
The KL2535 and KL2545 appear in the complex process image with at least 6 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | - | CB1
1 | 2 | Word | - | DataOUT1
3 | 4 | Byte | - | CB2
4 | 6 | Word | - | DataOUT2
*) Word alignment: The Bus Coupler places values on even byte addresses
Legend
SB n: status byte channel n
CB n: Control byte of channel n
DataIN n: Input word of channel n
DataOUT n: Output word of channel n
Note
Process image
It is not possible for the KL2535 or KL2545 to operate without control bytes, since the control bytes are required to enable the channels. Even if you adjust your bus coupler to the compact process image, the KL2535 and KL2545 will still be represented with their control bytes!
Process data
Output value | Output current
-32767dec | -100% of the maximum output current (see Register R36)
0dec | 0
+32767dec | +100% of the maximum output current (see Register R36)


Control and status bytes

Access from the user program [image] Control and status bytes
Control and status bytes
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetPos | enDithering
Legend
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 | Reset | 1bin | all errors that may have occurred are reset by setting this bit (rising edge)
CB1.5 | Enable | 1bin | Enables channel 1
CB1.4 | GetLatchData | 0bin | Show the current position in the input process data
 |  | 1bin | Show the current latch value in the input process data
CB1.3 | enLatch FallEdge | 1bin | External latch event is enabled (for latch inputs with falling edge, the terminal saves the current position)
CB1.2 | enLatch RiseEdge | 1bin | External latch event is enabled (for latch inputs with rising edge, the terminal saves the current position) ATTENTION: Higher priority than CB1.3 !
CB1.1 | SetPos | 1bin | Position value is set with register R1 (rising edge)
CB1.0 | enDithering | 1bin | Dithering is active (when R32.5=1)
Status byte 1 (for process data mode)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetPos Ready | Input E1
Legend
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | Error | 1bin | An error has occurred (is displayed in the status word in register R0)
SB1.5 | Warning | 1bin | The internal temperature has risen to more than 80 ℃, or the power supply voltage has dropped.
SB1.4 | Ready | 0bin | Motor control is disabled or an error has occurred (SB.6=1)
 |  | 1bin | Motor control is enabled and no error has occurred (acknowledgement for enable, SB.6=0)
SB1.3 | LatchData | 0bin | The current position is mapped into the input process data
 |  | 1bin | The most recent latch value is mapped into the process data, provided a valid latch value exists (acknowledgement for GetLatchData)
SB1.2 | LatchValid | 1bin | A latch event has occurred (when CB1.2=1 or CB1.3=1)
SB1.1 | SetPos Ready | 1bin | The current position has been set (acknowledgement for SetPos)
SB1.0 | Input E1 | Status of input E1
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIn, or - to write with output data word DataOut.
Status byte 1 (in register communication)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg. no.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user program [image] Register overview
Register overview
The registers serve the parameterization of the pulse width current terminal. They can be read or written by means of register communication.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Status word |  | 0x0000 | 0dec | R | RAM
R1 | Set position (only on the KL2545) |  | 0x0000 | 0dec | R/W | RAM
R2 | Coil voltage (only on the KL2545) |  | 0x0000 | 0dec | R | RAM
R3 | Power supply voltage (only on the KL2545) |  | e.g. 0x0030 | e.g. 48dec | R | RAM
R4 | reserved |  | - | - | - | -
R5 | Temperature (only on the KL2545) |  | e.g. 0x0023 | e.g. 35dec | R | RAM
R6 | Status byte |  | e.g. 0x0010 | e.g. 16dec | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2535: | 0x09E7 | 2535dec | R | ROM
 |  | KL2545: | 0x09F1 | 2545dec
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0130 | 304dec | R | ROM
R11 | Signal channels |  | 0x0218 | 536dec | R | ROM
R12 | Minimum data length |  | 0x1818 | 6168dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | 0x7F80 | 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
R32 | Feature register |  | 0x0000 | 0dec | R/W | EEPROM
R33 | User scaling - offset |  | 0x1000 | 4096dec | R/W | EEPROM
R34 | User scaling - gain |  | 0x0000 | 0dec | R/W | EEPROM
R35 | User's switch-on value |  | 0x0000 | 0dec | R/W | EEPROM
R36 | Maximum output current | KL2535: | 0x03E8 | 1000dec | R/W | EEPROM
 |  | KL2545: | 0x0DAC | 3500dec
R37 | Dithering - Frequency |  | 0x0000 | 0dec | R/W | EEPROM
R38 | Dithering amplitude |  | 0x0000 | 0dec | R/W | EEPROM
R39 | Dithering - Switch-off ramp |  | 0x0000 | 0dec | R/W | EEPROM
R40 | Overlap threshold value |  | 0x0000 | 0dec | R/W | EEPROM
R41 | Overlap output value |  | 0x0000 | 0dec | R/W | EEPROM
R42 | Bend compensation -threshold value |  | 0x0000 | 0dec | R/W | EEPROM
R43 | Bend compensation - output value |  | 0x0000 | 0dec | R/W | EEPROM
R44 | Area compensation - threshold value |  | 0x03E8 | 1000dec | R/W | EEPROM
R45 | Process data ramp (rising) |  | 0x0000 | 0dec | R/W | EEPROM
R46 | Process data ramp (falling) |  | 0x0000 | 0dec | R/W | EEPROM
R47 | reserved |  |  |  |  |
R63 | reserved |  |  |  |  |


Register description

Access from the user program [image] Register description
Register description
All registers can be read or written via register communication. They are used for parameterizing the terminal.
R0: Status word
The status word contains information about internal states, and provides an indication of errors that have occurred.
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | - | NoControlPower | OpenLoad | OverCurrent | UnderVoltage | - | LowVoltage | OverTemperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | - | - | - | - | - | - | -
Legend
Bit | Name | Description
R0.15 | - | reserved
R0.14 | NoControlPower | 1bin | The 24 V control voltage is not present at the power contacts
R0.13 | OpenLoad | 1bin | Open load / broken wire
R0.12 | OverCurrent | 1bin | Overcurrent in the driver stage
R0.11 | UnderVoltage | 1bin | Supply voltage less than 7 V (only on the KL2545)
R0.10 | - | reserved
R0.9 | LowVoltage | 1bin | The supply voltage is 10 V less than the switch-on voltage (only on the KL2545)
R0.8 | OverTemperature | 1bin | The internal temperature of the terminal is greater than 80℃ (see R5) (only on the KL2545)
R0.0-R0.7 | - | reserved
R1: Set position
You can specify the desired position, with which the terminal is to be loaded, here.
R2: Coil voltage
You can read the coil voltage here. The unit is 1 mV (for example: 4800 = 48 V).
R3: Supply voltage
You can read the power supply voltage here. The unit is 1 mV (for example: 4800 = 48 V).
R5: Temperature register
The internal temperature of the terminal can be read, in °C, through register R5. The terminal will set bit SB.5 in the status byte as a warning if the temperature exceeds the threshold of 80°C. When the temperature falls back below 60°C, bit SB.5 will automatically be reset.
R6: Status byte
The status byte of the relevant channel is mapped here in addition.
R7: Command register
Note
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the factory settings for the following registers of both channels:
R32: 0dec
R33: 0dec
R34: 4096dec
R35: 0dec
R36: KL2535: 1000dec, KL2545: 3500dec
R37: 0dec
R38: 0dec
R39: 0dec
R40: 0dec
R41: 0dec
R42: 0dec
R43: 0dec
R44: 1000dec
R45: 0dec
R46: 0dec
Note
Complete restore
The Restore Factory Settings command resets both channels in the pulse-width current terminal to the factory settings simultaneously, regardless of which register set it is called from!
Command 0x8000: Software Reset
Entering 0x8000 in register R7 initiates a full software reset for the terminal. All internal variables (positions, latched values, errors etc.) are cleared or are set to defined values that are read from the EEPROM. The internal circuits (D/A converter, output driver) are reinitialized during a software reset.
CAUTION
Software reset!
Power is removed from the output stage during a software reset. Ensure that your system state permits this and that hazards for persons or machinery have been ruled out!
R8: Terminal type
The terminal identifier is contained in register R8:
KL2535: 0x09E7 (2535dec)
KL2545: 0x09F1 (2545dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value cannot be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R31: Code word register
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data. The code word is reset if the terminal is restarted.
R32: Feature register
The feature register specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | disMixedDecay | - | - | - | - | - | - | enUserStartValue
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | enRamps | enDithering | enValveCurve | enAverageNotation | disWatchdog | enManuScale | enUserScale
Legend
Bit | Name | Description |  | default
R32.15 | disMixedDecay | 1bin | Mixed Decay is deactivated | 0bin
R32.14-R32.9 | - | reserved
R32.8 | enUserStartValue | 1bin | User switch-on value active (see R35) | 0bin
R32.7 | - | reserved
R32.6 | enRamps | 1bin | Process data ramps are active (see R45 + R46) | 0bin
R32.5 | enDithering | 1bin | Dithering is active (see R37, R38 + R39); bit CB1.0 = 1 must be set in addition | 0bin
R32.4 | enValveCurve | 1bin | Valve curve is active (see R40, R41, R42, R43 + R44) | 0bin
R32.3 | enAverageNotation | 0bin | Two’s complement representation is active | 0bin
 |  | 1bin | Signed amount representation active
R32.2 | disWatchdog | 1bin | Internal 100 ms watchdog deactivated | 0bin
R32.1 | enManuScale | 1bin | Manufacturer scaling is active | 0bin
R32.0 | enUserScale | 1bin | User scaling active (see R33+ R34) | 0bin
R33: User scaling - offset
If user-scaling is active (R32.0=1) this register specifies the offset for the user-scaling.
R34: User scaling - gain
If user-scaling is active (R32.0=1) this register specifies the gain for the user-scaling.
R35: User's switch-on value
If the user switch-on value is active (R32.8=1) and if the activated watchdog (R32.2=0bin) triggers following a fieldbus or terminal bus error continuing for 100 ms, the output will be set to this value.
R36: Maximum output current
This register specifies the maximum output current. The unit is 1 mA (for example: 1000dec = 1 A).
KL2535: maximum 1000 mA (default: 1000dec)
KL2545: maximum 3500 mA (default: 3500dec)
R37: Dithering - Frequency
When Dithering is active (R32.5=1) this register specifies the frequency of the dither.
Values from 10 to 500 Hz are permitted.
The unit is 1 Hz. (Example: 100dec = 100 Hz).
R38: Dithering amplitude
When Dithering is active (R32.5=1) this register specifies the amplitude of the dither.
The configured value refers to the set output current in register R36.
The unit is 1% (for example: 10dec = 10%).
R39: Dithering - Switch-off ramp
When Dithering is active (R32.5=1) this register specifies the switch-off ramp of the dither.
The unit is 1 ms (for example: 100dec = 100 ms).
R40: Overlap - Threshold value (valve curve)
When the valve curve is active (R32.4=1) this register specifies the threshold value for the overlap region.
The unit is 0.1%, and is expressed with reference to the final process data value (for example: 100dec = 10%).
R41: Overlap - Output value (valve curve)
When the valve curve is active (R32.4=1) this register specifies the output value for the overlap region.
The configured value refers to the set output current in register R36.
The unit is 0.1% (for example: 100dec = 10%).
R42: Bend compensation - Threshold value (valve curve)
When the valve curve is active (R32.4=1) this register specifies the threshold value for the bend compensation region.
The unit is 0.1%, and is expressed with reference to the final process data value (for example: 100dec = 10%).
R43: Bend compensation - Output value (valve curve)
When the valve curve is active (R32.4=1) this register specifies the output value for the bend compensation region.
The configured value refers to the set output current in register R36.
The unit is 0.1% (for example: 100dec = 10%).
R44: Area compensation - Threshold value (valve curve)
When the valve curve is active (R32.4=1) this register specifies the threshold value for the area compensation region.
The unit is 0.1%, and is expressed with reference to the final process data value (for example: 100dec = 10%).
R45: Process data ramp (rising)
When the process data ramps are active (R32.6=1), this register specifies the rising process data ramp.
The unit is 1 ms, and is expressed with reference to the final process data value (for example: 100dec = 100 ms).
R46: Process data ramp (falling)
When the process data ramps are active (R32.6=1), this register specifies the falling process data ramp.
The unit is 1 ms, and is expressed with reference to the final process data value (for example: 100dec = 100 ms).


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9 of a terminal
•
Example 2: Writing to a user register


Example 1: reading the firmware version from Register 9 of a terminal

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9 of a terminal
Example 1: reading the firmware version from Register 9 of a terminal
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to a user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to a user register
Example 2: Writing to a user register
Note
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
CAUTION
Observe the register description!
The value of 0x0002 given here is just an example! The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter "Register description") regarding the meaning of the individual bits before changing the values.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com