KL2532, KL2552 - DC motor output stages
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
3.2.0
▪
Update chapter Instructions for ESD protection
▪
Chapter “Beckhoff Identification Code (BIC)” added
3.1.0
▪
Update chapter "Notes on the documentation"
▪
Update chapter "Technical data"
▪
Chapter "Instructions for ESD protection" added
▪
Update chapter "Connection system" -> "Connection"
▪
Chapter "Installation instructions for enhanced mechanical load capacity" added
▪
Chapter "Prescribed installation position" replaced with chapter "Installation position with or without fan)"
▪
Update revision status
▪
Chapter "UL notice - Compact Motion" added
3.0.0
▪
Migration
▪
Update revision status
▪
Update structure
2.6.0
▪
LED displays of the KL2532/KS2532 updated
▪
Technical data updated
2.5.0
▪
Technical data updated
▪
Register overview corrected
▪
Register description expanded
2.4.0
▪
Basic function principles updated
▪
Register description expanded
▪
Technical data updated
▪
Mounting instructions updated
2.3.0
▪
Technical data updated
2.2.0
▪
Mounting instructions updated
2.1.0
▪
Introduction for KL2552 updated
▪
Register description updated
▪
Notes on connection methods extended
2.0.0
▪
KL2532 added
▪
Notes on connection methods added
1.1.0
▪
Register description expanded
▪
Description of the KS2000 configuration software expanded
▪
Description of KL2552-0005 added
▪
Technical data updated
▪
Description of chopper mode added
▪
Application example added
1.0.0
▪
English translation published
▪
Minor layout corrections
0.2
▪
Basic function principles added
▪
Description of control and status byte extended
▪
Register description corrected
0.1
First provisional documentation for KL2552-0000
Firmware and hardware versions
Documentation version | KL2532/KS2532 |  |  | KL2552-0000/KS2552-0000 |  |  | KL2552-0005/KS2552-0005
 | Firmware |  | Hardware | Firmware |  | Hardware | Firmware |  | Hardware
 | K-bus | Power Stage |  | K-Bus | Power Stage |  | K-Bus | Power Stage
3.1.0 | 3B | 3B | 07 | 2C | 2C | 09 | 2C | 2C | 09
3.0.0 | 3B | 3B | 07 | 1M | 1M | 07 | 1M | 1M | 07
2.6.0 |  |  |  |  |  |  |  |  |
2.5.0 | 3B | 3B | 05 | 1M | 1M | 03 | 1M | 1M | 04
2.4.0 | 3B | 3B | 05 | 1M | 1M | 03 | 1M | 1M | 04
2.3.0 | 3B |  | 05 | 1M |  | 03 | 1M |  | 04
2.2.0 | 1A | 1A | 02 | 1C | 1E | 00 | 1C | 1E | 00
2.1.0 | 1A | 1A | 02 | 1C | 1E | 00 | 1C | 1E | 00
2.0.0 | 1A | 1A | 00 | 1C | 1E | 00 | 1C | 1E | 00
1.1.0 | - | - | - | 1B | 1D | 00 | 1B | 1D | 00
1.0.0 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
0.2 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
0.1 |  |  |  | 1A | 1A | 00 | 1A | 1A | 00
The K-bus firmware and hardware version (delivery state) can be found on the terminal side on which the serial number is printed.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - K-bus firmware version
HH - hardware version
Example with ser. no.: 49 05 1B 03:
49 - week of production 49
05 - year of production 2005
1B - firmware version 1B
03 - hardware version 03


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
KL2532 - Introduction
•
KL2552 - Introduction
•
Technical data
•
KL2532 - LED displays
•
KL2552 - LED displays


KL2532 - Introduction

Product overview [image] KL2532 - Introduction
KL2532 - Introduction
KL2532
The two-channel KL2532/KS2532 Bus Terminal enables direct operation of two DC motors. The set speed is specified by the automation device with a resolution of 16 bit.
The output stage is protected against overload and short-circuit and is electrically isolated from the K-bus. Both channels indicate their signal state through LEDs, which enable quick on-site diagnosis.
The Bus Terminal is available in the KL2532 version for standard wiring and the KS2532 for permanent wiring.


KL2552 - Introduction

Product overview [image] KL2552 - Introduction
KL2552 - Introduction
KL2552
The two-channel KL2552/KS2552 Bus Terminal enables direct operation of two DC motors. The set speed is specified by the automation device with a resolution of 16 bit.
The output stage is protected against overload and short-circuit and is electrically isolated from the K-bus. A servo axis can easily be realized by connecting an incremental encoder.
Typical motor parameters can be set in order to avoid critical conditions of the DC motor. The load can be protected by limiting the maximum speed and torque values.
Both channels indicate their signal state through LEDs, which enable quick on-site diagnosis.
The Bus Terminal is available in the KL2552 version for standard wiring and the KS2552 for permanent wiring.


Technical data

Product overview [image] Technical data
Technical data
Technical data |  | KL2532-0000 KS2532-0000 | KL2552-0000 KS2552-0000 | KL2552-0005 KS2552-0005
Number of DC motor output stages |  | 2
Load type |  | DC brush motors, inductive
Supply for the output stage |  | via power contacts | via terminal points
Rated load voltage (motor power) |  | 24 VDC | 8 VDC to 50 VDC
Output current per channel |  | Rated current 1 A, Peak current 2.5 A | Rated current 5 A, peak current 8 A (short-circuit-proof, common thermal overload warning for both output stages)
PWM clock frequency |  | 30 kHz, channels out of phase by 180° relative to each other
Duty factor |  | 0 ... 100% (voltage-controlled)
Resolution | Current | 10 bit
 | Voltage (velocity) | 16 bit
Number of digital inputs |  | 2 (for end positions)
Input filter |  | 0.2 ms
Signal voltage at digital input "0" |  | -3 V ... 1.5 V
Signal voltage at digital input "1" |  | 30 V
Input current |  | typically: 5.5 mA
Number of encoder inputs |  | - | 4 (for an encoder system)
Encoder signal |  | - | 5...24 V, 5 mA single-ended | 5 V, 5 mA single-ended
Encoder supply |  | - | 24 V, max. 100 mA | 5 V, max. 80 mA
Pulse frequency |  | - | max. 400000 increments/s (with four-fold evaluation)
Encoder voltage "0" |  | - | -3 V ... 1.5 V
Encoder voltage "1" |  | - | 30 V
Electrical isolation |  | 500 V (K-bus/mains voltage)
Supply voltage for internal electronic |  | via the K-bus and through the power contacts
Current consumption from K-bus (5 V) |  | typ. 50 mA | typ. 70 mA | typ. 120 mA
Current consumption from the power contacts |  | typ. 30 mA + motor current | typ. 40 mA + sensor supply | typ. 120 mA
Bit width in the input process image |  | 2 x 16 bit data, 2 x 8 bit status
Bit width in the output process image |  | 2 x 16 bit data, 2 x 8 bit control
Configuration |  | via the Bus Coupler or the controller
Weight |  | approx. 55 g | approx. 100 g
Permissible ambient temperature range during operation |  | 0°C ... + 55°C
Permissible ambient temperature range during storage |  | -25°C ... + 85°C
Permissible relative humidity |  | 95 %, no condensation
Dimensions (W x H x D) |  | approx. 14 mm x 100 mm x 70 mm (width aligned: 12 mm) | approx. 27 mm x 100 mm x 70 mm (width aligned: 24 mm)
Mounting |  | on 35 mm mounting rail conforms to EN 60715
Vibration/shock resistance |  | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for terminals with increased mechanical load capacity
EMC immunity/emission |  | conforms to EN 61000-6-2 / EN 61000-6-4, EN 61800-6-33 * *) standard: category C3. Additional filters are required for categories C1 and C2!
Protection class |  | IP20
Installation position |  | without fan cartridge ZB8610: standard installing position with fan cartridge ZB8610: standard installing position, other installing positions (example 1 & 2) seenotice
Approval |  | CE, cULus


KL2532 - LED displays

Product overview [image] KL2532 - LED displays
KL2532 - LED displays
KL2532 - LEDs
LED | Display
Run (green) | reserved | Data transmission on the K-bus is active
Enable A (green) | off | Channel 1 is either not enabled or not ready to operate.
 | on | Channel 1 is enabled and is ready to operate.
Warning A (yellow) | on | The internal temperature has risen to more than 80 °C, or the power supply voltage has dropped.
Error A (red) | on | There is an error at channel 1
Power (green) | off | The power supply voltage is absent (less than 7 V).
 | on | The power supply voltage is present (more than 8 V).
Enable B (green) | off | Channel 2 is either not enabled or not ready to operate.
 | on | Channel 2 is enabled and is ready to operate.
Warning B (yellow) | on | The internal temperature has risen to more than 80 °C, or the power supply voltage has dropped.
Error B (red) | on | There is an error at channel 2


KL2552 - LED displays

Product overview [image] KL2552 - LED displays
KL2552 - LED displays
KL2552 - LEDs
Left LED prism
LED | Display
Run (green) | on | Data transmission on the K-bus is active
Enc. A: A (green) | on | There is a signal at input A for encoder A.
Enc. B: A (green) | on | There is a signal at input A for encoder B.
Input 1 (green) | on | There is a signal at input 1.
Enc. Rdy. (green) | on | Encoder evaluation ready to operate.
Enc. A: B (green) | on | There is a signal at input B for encoder A.
Enc. B: B (green) | on | There is a signal at input B for encoder B.
Input 2 (green) | on | There is a signal at input 2.
Right LED prism
LED | Display
Drv. Rdy. (green) | on | Motor driver ready to operate.
Enable A (green) | off | Channel 1 is either not enabled or not ready to operate.
 | on | Channel 1 is enabled and is ready to operate.
Warning A (yellow) | on | Warning of channel 1
Error A (red) | on | There is an error at channel 1
Power (green) | off | The motor supply voltage is not available.
 | on | The motor supply voltage is available.
Enable B (green) | off | Channel 2 is either not enabled or not ready to operate.
 | on | Channel 2 is enabled and is ready to operate.
Warning B (yellow) | on | Warning of channel 2
Error B (red) | on | There is an error at channel 2


Basic function principles

Basic function principles
Basic function principles
Additional information
•
Basic principles
•
Chopper operation


Basic principles

Basic function principles [image] Basic principles
Basic principles
The KL2532/KS2532 DC motor terminal integrates two compact DC motor output stages up to 24 W in a very compact design.
The KL2552/KS2552 DC motor terminal integrates two compact DC motor output stages up to 250 W in a very compact design.
General functions
Enable/Readiness for operation
For activating the output stage enable bit CB1.5 has to be set. If the terminal is in an error-free state at the time, it sets ready bit SB1.4 as acknowledgement. If the terminal is ready to operate, it indicates this by setting "Ready to Enable" (R0.2). Directions of rotation are indicated by bit R0.4 (Moving Positive) and R0.5 (Moving Negative).
Set / delete position
The user can set or delete the current position value. Register R5 is used as reference. A rising edge at bit CB1.1 sets the current position, and the acknowledgement is provided through status bit SB1.1.
Latch functions (only KL2552/KS2552)
The internal encoder offers the option of registering a latch event. A latch event can be generated via the digital input signals.
The terminal response to the latch events is activated as follows:
▪
Setting the control bit CB1.2 activates the rising edge at the digital input (highest priority)
▪
Setting the control bit CB1.3 activates the falling edge at the digital input (second-highest priority)
Once the user has enabled the function, during the next latch event, the terminal saves the current position value and indicates this by setting status bit SB1.2. Reading of latch values must be initiated by setting CB1.4, which causes the latch value to be mapped in the DataIN process data (the terminal indicates this via status bit SB1.3).
Reading the latch value
The enable that was set previously must be retained while reading out the latch value. The latch value is lost if enable is cancelled!
Manual and automatic torque reduction
A torque reduction can be achieved in two ways:
▪
R32.10 = 0: The torque is reduced (to the value in R41 or R49), if CB1.0 = 1. The terminal acknowledges this by setting SB1.1.
▪
R32.10 = 1: The torque is automatically reduced, if the process input data exceed the values configured in R45 or R48.The torque is reduced automatically if the process input data exceed the settings configured in R45 or R48. The reduction is deactivated, if the process input data fall below a value of R45 or R48 - 2%.
R41 (reduced torque) and R45 (torque threshold) are used for the positive direction of rotation.
R49 (reduced torque) and R48 (torque threshold) are used for the negative direction of rotation.
Digital inputs
The digital inputs are mapped into the status byte in bit SB1.0.
Error indication
The terminal offers the user a variety of diagnostic options. These messages are subdivided into hardware warnings and hardware errors.
Hardware warnings
The functionality of the terminal is retained if one of the following warnings occurs. In the status byte the bit SB1.5 (Warning) is set.
▪
Driver in saturation (Saturated R0.6)
–
This bit is set when the largest duty cycle is output (automatically cancelled)
▪
Overtemperature (R0.8)
–
The status bit is set if the internal terminal temperature exceeds 80 ℃. It is automatically cancelled if the temperature falls below 80 ℃.
▪
Overload (overcurrent, R0.9) (R32.9 = 0)
–
This bit is set if the motor current exceeds the value configured in register R35.
–
This bit is set if the motor current exceeds the value configured in register R41 or R49 when torque limiting is active (CB1.0 = 1)
▪
Undervoltage (R0.10)
–
This bit is set if the motor voltage falls below 8 V
▪
Overvoltage (R0.11)
–
This bit is set if the motor voltage exceeds a value that is 10 % greater than the value configured in register R36
If a warning occurs the cause has to be rectified and subsequently acknowledged and thus cancelled by setting bit CB1.6 in the control byte (unless specified otherwise above).
Hardware error
The motor power is switched off and bit SB1.6 in the status byte is set if one of the following errors occurs.
▪
Short Circuit (R0.12)
▪
Failure of the 24 V control voltage (No Control Power, R0.14)
–
This bit is set if the control voltage falls below 12 V (correct function of the driver stages can no longer be guaranteed if the control voltage is less than 12 V)
–
The terminal is automatically reinitialized when the control voltage returns
▪
Other errors (Misc Error, R0.15). The following errors are consolidated through this bit:
–
Overtemperature (internal terminal temperature exceeds 100 °C, "Overtemperature" bit is also set),
–
Initialization error (illogical register configuration)
–
Overload (only if R32.9 is enabled; set together with R0.9)
If an error occurs, it first has to be rectified and subsequently acknowledged and thus cancelled by setting bit CB1.6 in the control byte.


Chopper operation

Basic function principles [image] Chopper operation
Chopper operation
Instead of a DC motor, you can connect a brake resistor (chopper) to a channel of the KL2532/KL2552 and activate brake resistor mode for this channel (see KS2000 or registers R33.0 - R33.3).
The motor must actively brake for positioning tasks. The mechanical energy is thereby converted back into electrical energy. Small amounts of energy can be absorbed by a capacitor in the KL2532/KL2552. Further storage capacities, for example in the power supply, can also take up energy. The feedback leads in each case to a voltage increase.
In order to avoid overvoltage, a brake resistor can be connected to the KL2532/KL2552 in order to dissipate the excess energy in the form of heat. When the voltage reaches 110% of the rated voltage (register R36 , e.g. 55 V for KL2552), the correctly set output stage sends a fast-pulsed current through the brake resistor (see diagram).
Current through the brake resistor
UCH /UN | 20% | 40% | 60% | 80% | 100% | 110% | 130% | 160%
UCH at UN = 50 V | 10 V | 20 V | 30 V | 40 V | 50 V | 55 V | 65 V | 80 V
UCH at UN = 24 V | 4,8 V | 9,6 V | 14,4 V | 19,2 V | 24 V | 25,2 V | 31,2 V | 38,4 V
Note
Dimensioning of the brake resistor
The brake resistor should be dimensioned such that it can withstand the expected heat development without damage!
A brake resistance of 10 Ω is recommended for KL2552, which results in a pulse current of approx. 5.5 A to 6.5 A. The maximum expected continuous power is 125 W. However, the value typically lies significantly below that.
Load estimation (for KL2552)
PN = IN² x R
PN = (5A)² x 10 Ω
PN = 250 W
A maximum duty cycle of 50 % is possible. This results in a maximum continuous power of 125 W.
A motor efficiency of 80 % is usual in practice.
The motor thus converts 80 % of the rated electrical power into kinetic energy when accelerating.
Conversely, when braking, the motor (as a generator) converts 80 % of the kinetic energy into electrical power.
This results in a practical brake power of:
PCH = PN/2 x 80/100 x 80/100
PCH = 125W x 80/100 x 80/100
PCH = 80 W


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Installation position for operation with or without fan
•
Connection
•
UL notice - Compact Motion
•
KL2532/KS2532 - connection
•
KL2552-0000/KS2552-0000 - connection
•
KL2552-0005/KS2552-0005 - connection
•
KL2552 - application example


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Installation position for operation with or without fan

Mounting and wiring [image] Installation position for operation with or without fan
Installation position for operation with or without fan
Note
Constraints regarding installation position and operating temperature range
When installing the terminals ensure that an adequate spacing is maintained between other components above and below the terminal in order to guarantee adequate ventilation!
Prescribed installation position for operation without fan
The prescribed installation position requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. “Recommended distances of installation position for operating without fan“).
The terminals are ventilated from below, which enables optimum cooling of the electronics through convection.
Recommended distances of installation position for operating without fan
Compliance with the distances shown in Fig. “Recommended distances of installation position for operating without fan” is recommended.
For further information regarding the operation without fan refer to the Technical Data of the terminal.
Standard installation position for operation with fan
The standard installation position for operation with fan requires the mounting rail to be installed horizontally and the connection surfaces of the EL/KL terminals to face forward (see Fig. Recommended distances for installation position for operation with fan).
The terminals are ventilated fan supported (e.g. with fan cartridge ZB8610) from below.
Recommended distances for installation position for operation with fan
Other installation positions
Due to the enforced effect of the fan on the ventilation of the terminals, other installation positions (see Fig. “Other installation positions, example 1 + 2“) may be permitted where appropriate.
See corresponding notes in the Technical Data of the terminal.
Other installation positions, example 1
Other installation positions, example 2


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


UL notice - Compact Motion

Mounting and wiring [image] UL notice - Compact Motion
UL notice - Compact Motion
culus-logo
Application
Beckhoff EtherCAT modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
culus-logo
Notes on motion devices
•
Motor overtemperature
Motor overtemperature sensing is not provided by the drive.
•
Application for compact motion devices
The modules are intended for use only within Beckhoff’s Programmable Controller system Listed in File E172151.
•
Galvanic isolation from the supply
The modules are intended for operation within circuits not connected directly to the supply mains (galvanically isolated from the supply, i.e. on transformer secondary).
•
Requirement for environmental conditions
For use in Pollution Degree 2 Environment only.
Basic principles
UL certification according to UL508. Devices with this kind of certification are marked by this sign:
Application
If terminals certified with restrictions are used, then the current consumption at 24 VDC must be limited accordingly by means of supply
▪
from an isolated source protected by a fuse of max. 4 A (according to UL248) or
▪
from a voltage supply complying with NEC class 2.
A voltage source complying with NEC class 2 may not be connected in series or parallel with another NEC class 2compliant voltage supply!
These requirements apply to the supply of all EtherCAT bus couplers, power adaptor terminals, Bus Terminals and their power contacts.


KL2532/KS2532 - connection

Mounting and wiring [image] KL2532/KS2532 - connection
KL2532/KS2532 - connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL2532/KS2532 pin assignment
Terminal point | No. | Connection for
A1 | 1 | Motor A, connection A1
B1 | 2 | Motor B, connection B1
24 V | 3 | e.g. encoder supply (for positive power contact)
Input 1 | 4 | Digital input 1 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CB.1 is set in the control word and a rising edge occurs at digital input 1.
A2 | 5 | Motor A, connection A2
B2 | 6 | Motor B, connection B2
0 V | 7 | e.g. encoder supply (for negative power contact)
Input 2 | 8 | Digital input 2 (24 VDC). The current counter value is saved as a reference mark in the latch register if bit CB.2 is set in the control word and a rising edge occurs at digital input 2.


KL2552-0000/KS2552-0000 - connection

Mounting and wiring [image] KL2552-0000/KS2552-0000 - connection
KL2552-0000/KS2552-0000 - connection
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL2552/KS2552 pin assignment
Terminal points
Left-hand section of the housing
Terminal point | No. | Connection for
Encoder A, A | 1 | Encoder A, connection A
Encoder B, A | 2 | Encoder B, connection A
Encoder Power +24 V | 3 | Encoder supply (from positive power contact)
Input 1 | 4 | Digital input 1 (24 VDC). The current counter value is stored as reference mark in the latch register, if bit CB1.1 is set in control byte 1 and a rising edge occurs at digital input 1.
Encoder A, B | 5 | Encoder A, connection B
Encoder B, B | 6 | Encoder B, connection B
Encoder Power 0 V | 7 | Encoder supply (from negative power contact)
Input 2 | 8 | Digital input 2 (24 VDC). The current counter value is stored as reference mark in the latch register, if bit CB2.1 is set in control byte 2 and a rising edge occurs at digital input 2.
Right-hand section of the housing
Terminal point | No. | Connection for
Motor A, A1 | 1' | Motor A, connection A1
Motor B, B1 | 2' | Motor B, connection B1
Power Motor 50 V | 3' | Motor supply feed (maximum +50 VDC)
Power Motor 50 V | 4' | Motor supply feed (maximum +50 VDC)
Motor A, A2 | 5' | Motor A, connection A2
Motor B, B2 | 6' | Motor B, connection B2
Power Motor 0 V | 7' | Motor supply feed (0 VDC)
Power Motor 0 V | 8' | Motor supply feed (0 VDC)
Power contacts
The voltage Up of the power contacts (+24 VDC) supplies the following consumers:
▪
Incremental encoder (terminal points 3 and 7)
▪
Digital inputs (terminal points 4 and 8)
▪
Output driver of the DC motor output stage


KL2552-0005/KS2552-0005 - connection

Mounting and wiring [image] KL2552-0005/KS2552-0005 - connection
KL2552-0005/KS2552-0005 - connection
SmallWarningYellow WARNING
Risk of injury!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
KL2552-0005/KS2552-0005 pin assignment
Terminal points
Left-hand section of the housing
Terminal point | No. | Connection for
Encoder A, A | 1 | Encoder A, connection A
Encoder B, A | 2 | Encoder B, connection A
Encoder Power +5 V | 3 | Encoder supply (via switching controller of positive power contact)
Input 1 | 4 | Digital input 1 (24 VDC). The current counter value is stored as reference mark in the latch register, if bit CB1.1 is set in control byte 1 and a rising edge occurs at digital input 1.
Encoder A, B | 5 | Encoder A, connection B
Encoder B, B | 6 | Encoder B, connection B
Encoder Power 0 V | 7 | Encoder supply (via switching controller of negative power contact)
Input 2 | 8 | Digital input 2 (24 VDC). The current counter value is stored as reference mark in the latch register, if bit CB2.1 is set in control byte 2 and a rising edge occurs at digital input 2.
Right-hand section of the housing
Terminal point | No. | Connection for
Motor A, A1 | 1' | Motor A, connection A1
Motor B, B1 | 2' | Motor B, connection B1
Power Motor 50 V | 3' | Motor supply feed (maximum +50 VDC)
Power Motor 50 V | 4' | Motor supply feed (maximum +50 VDC)
Motor A, A2 | 5' | Motor A, connection A2
Motor B, B2 | 6' | Motor B, connection B2
Power Motor 0 V | 7' | Motor supply feed (0 VDC)
Power Motor 0 V | 8' | Motor supply feed (0 VDC)
Power contacts
The voltage Up of the power contacts (+24 VDC) supplies the following consumers:
▪
Incremental encoder (terminal points 3 and 7)
▪
Digital inputs (terminal points 4 and 8)
▪
Output driver of the DC motor output stage


KL2552 - application example

Mounting and wiring [image] KL2552 - application example
KL2552 - application example
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Brake resistor
The brake resistor connected to channel 2 of the second EL7342 uses the brake energy of the motors connected to the other three channels.
KL2552 application example
Note
Dimensioning of the brake resistor
The brake resistor should be dimensioned such that it can withstand the expected heat development without damage!


Configuration software KS2000

Configuration software KS2000
Configuration software KS2000
Additional information
•
KS2000 - Introduction
•
Parameterization with KS2000
•
Register
•
Settings
•
Process data


KS2000 - Introduction

Configuration software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Parameterization with KS2000

Configuration software KS2000 [image] Parameterization with KS2000
Parameterization with KS2000
Connect the configuration interface of your fieldbus coupler with the serial interface of your PC via the configuration cable and start the KS2000 configuration software.
Click on the Login button. The configuration software will now load the information for the connected fieldbus station.
In the example shown, this is
▪
A Bus Coupler for Ethernet BK9000
▪
a KL1xx2 digital input terminal
▪
a two-channel KL2552 DC motor output stage
▪
a KL9010 bus end terminal
Display of the fieldbus station in KS2000
The left-hand KS2000 window displays the terminals of the fieldbus station in a tree structure.
The right-hand KS2000 window contains a graphic display of the fieldbus station terminals.
In the tree structure of the left-hand window, click on the plus-sign next to the terminal whose parameters you wish to change (item 2 in the example).
KS2000 tree branches for channel 1 of the KL2552
For the KL2532, the branches Register, Settings and ProcData are displayed:
▪
Register permits direct access to the registers of the KL2552.
▪
Under Settings you find dialog boxes for parameterizing the KL2552.
▪
ProcData displays the KL2552 process data.


Register

Configuration software KS2000 [image] Register
Register
You can access the registers of the KL2552 directly under Register. The meaning of the register is explained in the register overview.
Register view in KS2000


Settings

Configuration software KS2000 [image] Settings
Settings
KL2552 parameterization settings.
Settings via KS2000
Operating mode (R33.0 - R33.3)
Here you can select the basic operating mode for the channels (default: "velocity, direct").
The terminal supports the following operating modes:
▪
Velocity, direct
▪
Velocity control
▪
Brake resistor (chopper)
General
Watchdog timer active (R32.2)
Here you can deactivate the watchdog (default: active). If the DC motor output stage fails to receive process data from the controller for 100 ms when the watchdog is active, the watchdog is triggered, and the motor stops.
Automatic current reduction active (R32.10)
Here you can activate automatic current reduction (default: inactive).
Automatic overload shutdown active (R32.9)
Here you can activate automatic overload shutdown (default: inactive).
Velocity controller
Kp factor (R37 only KL2552)
Here you can specify the Kp factor (proportional part) for the internal velocity control (default: 0.1).
Ki factor (R38 only KL2552)
Here you can specify the Ki factor (integral part) for the internal velocity control (default: 0).
Inner window for I-controller active (R33.4, R39 only KL2552)
Here you can activate the inner window for the I-controller (default: inactive) and the threshold from which the inner window is activated (default: 0 %).
External window for I-controller active (R33.5, R40 only KL2552)
Here you can activate the inner window for the I-controller (default: inactive) and the threshold up to which the inner window is activated (default: 0 %).
Ka factor (R54 only KL2552)
Here you can specify the Kp factor (a-part) for the internal velocity control (default: 0).
Kd factor (R55 only KL2552)
Here you can specify the Kd factor (differential part) for the internal velocity control (default: 0).
Encoder
Input filter active (R32.12)
Here you can deactivate the input filters for the encoder inputs disable (default: active).
increments per revolution (R42 only KL2552)
Here you can specify the number of increments per revolution for the connected encoder (default: 0).
Motor data
Maximum coil current (R34)
Here you can specify the maximum motor coil current (default: 8000 mA).
Reduced coil current (positive direction of rotation) (R41)
Here you can specify the reduced motor coil current (default: 5000 mA), see description of registers R32.10, R41 and R45.
Threshold for current reduction (positive direction of rotation) (R45)
Here you can specify the threshold from which automatic current reduction is enabled (default: 100 %).
Reduced coil current (negative direction of rotation) (R49)
Here you can specify the reduced motor coil current (default: 5000 mA), see description of registers R32.10, R49 and R48.
Threshold for current reduction (negative direction of rotation) (R48)
Here you can specify the threshold from which automatic current reduction is enabled (default: 100 %).
Rated current (R35)
Here you can specify the rated motor current (default: 5000 mA).
Rated voltage (R36)
Here you can specify the rated motor voltage (default: 50 V).
Rated speed (R43 only KL2552)
Here you can specify the rated motor speed (default: 0 rpm).
Internal motor resistance (R44)
Here you can specify the internal motor resistance (default: 0 ohm).
Time constant for current reduction (R46)
Here you can the specify time duration of the current reduction (default: 2000 ms).
Time for overload shutdown (R47)
Here you can specify the time after which the output stage is switched off, if overload occurs over the whole interval (default: 200 ms).


Process data

Configuration software KS2000 [image] Process data
Process data
The Status byte (Status), the Control byte (Ctrl) and the process data (Data) are displayed in a tree structure under ProcData.
ProcData
The reading glasses mark the data that are currently graphically displayed in the History field.
History field
The current input values are displayed numerically in the Value field.
Value field
Initial values can be modified through direct input or by means of the fader.
Value field
SmallWarningYellow CAUTION
Danger for persons, the environment or equipment!
Note that changing initial values (forcing them) can have a direct effect on your automation application.
Only modify these initial values if you are certain that the state of your equipment permits it, and that there will be no risk to people or to the machine!
After pressing the Settings button you can set the format of the numerical display to hexadecimal, decimal or binary.
Settings


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process image
•
Control and status bytes
•
Register overview
•
Register description
•
Examples of Register Communication


Process image

Access from the user program [image] Process image
Process image
Complex process image
In the complex process image the KL2532/KL2552 is represented with at least 6 bytes of input data and 6 bytes of output data. These are organized as follows:
Byte offset (without word alignment) | Byte offset (with word alignment*) | Format | Input data | Output data
0 | 0 | Byte | SB1 | CB1
1 | 2 | Word | DataIN1 | DataOUT1
3 | 4 | Byte | SB2 | CB2
4 | 6 | Word | DataIN2 | DataOUT2
*) Word alignment: The Bus Coupler places values on even byte addresses
Legend
SB n: status byte channel n
CB n: Control byte of channel n
DataIN n: Input word of channel n
DataOUT n: Output word of channel n
Complex process image
The KL2532/KL2552 cannot be operated without control bytes, since the control bytes are required for enabling the channels. Even if your Bus Coupler is set to compact process image, the KL2532/KL2552 is represented with its control bytes!


Control and status bytes

Access from the user program [image] Control and status bytes
Control and status bytes
Channel 1
Process data mode
Control byte 1 (for process data mode)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | Reset | Enable | GetLatchData | enLatch FallEdge | enLatch RiseEdge | SetCounter | Reduced Torque
Legend
Bit | Name | Description
CB1.7 | RegAccess | 0bin | Register communication off (process data mode)
CB1.6 | Reset | 1bin | all errors that may have occurred are reset by setting this bit (rising edge)
CB1.5 | Enable | 1bin | Enables channel 1
CB1.4 | GetLatchData | 0bin | Show the current position in the input process data
 |  | 1bin | Show the current latch value in the input process data
CB1.3 | enLatch FallEdge | 1bin | External latch event is enabled (for latch inputs with falling edge, the terminal saves the current position)
CB1.2 | enLatch RiseEdge | 1bin | External latch event is enabled (for latch inputs with rising edge, the terminal saves the current position) ATTENTION: higher priority than CB1.3!
CB1.1 | SetCounter | 1bin | The counter is set to the value specified by register R5 if a rising edge occurs at CB1.1.
CB1.0 | Reduced Torque | 1bin | Reduced torque (coil current) is active (specified via R41)
Status byte 1 (for process data mode)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | Error | Warning | Ready | LatchData | LatchValid | SetCounter Ready/ Reduced Torque Ready | Input E1
Legend
Bit | Name | Description
SB1.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB1.6 | Error | 1bin | An error has occurred (is explicitly indicated in the status word in register R0)
SB1.5 | Warning | 1bin | A warning has occurred (explicitly indicated in the status word in register R0)
SB1.4 | Ready | 0bin | Motor control is disabled or an error has occurred (SB.6=1)
 |  | 1bin | Motor control is enabled and no error has occurred (acknowledgement for enable, SB.6=0)
SB1.3 | LatchData | 0bin | The current position is mapped into the input process data
 |  | 1bin | The most recent latch value is mapped into the input process data, provided a valid latch value exists (acknowledgement for GetLatchData)
SB1.2 | LatchValid | 1bin | A latch event has occurred (when CB1.2=1 or CB1.3=1)
SB1.1 | SetCounter Ready/ Reduced Torque Ready | 1bin | - the counter was set (acknowledgement for SetCounter) or - the reduced torque is active (acknowledgement for Reduced Torque)
SB1.0 | Input E1 | Status of input E1
Register communication
Control byte 1 (in register communication)
Control byte 1 (CB1) is located in the output image, and is transmitted from the controller to the terminal.
Bit | CB1.7 | CB1.6 | CB1.5 | CB1.4 | CB1.3 | CB1.2 | CB1.1 | CB1.0
Name | RegAccess | R/W | Reg-Nr.
Legend
Bit | Name | Description
CB1.7 | RegAccess | 1bin | Register communication switched on
CB1.6 | R/W | 0bin | Read access
 |  | 1bin | Write access
CB1.5 to CB1.0 | Reg. no. | Register number: Enter here the number of the register that you wish - to read with input data word DataIn, or - to write with output data word DataOut.
Status byte 1 (in register communication)
The status byte 1 (SB1) is located in the input image, and is transmitted from terminal to the controller.
Bit | SB1.7 | SB1.6 | SB1.5 | SB1.4 | SB1.3 | SB1.2 | SB1.1 | SB1.0
Name | RegAccess | R/W | Reg-Nr.
Legend
Bit | Name | Description
SB1.7 | RegAccess | 1bin | Acknowledgement for register access
SB1.6 | R | 0bin | Read access
SB1.5 to SB1.0 | Reg. no. | Number of the register that was read or written.
Channel 2
The control and status bytes of channel 2 (CB2 and SB2) have the same structure as the control and status bytes of channel 1.


Register overview

Access from the user program [image] Register overview
Register overview
The registers are used to parameterize the DC motor output stages. They can be read or written via the register communication and there is one instance for each terminal channel.
Register no. | Comment |  | Default value |  | R/W | Memory
R0 | Status word |  | 0x0000 | 0dez | R | RAM
R1 | Selection for measured value 1 (low byte) and measured value 2 (high byte) | Channel 1 | 0x0602 | 1538dec | R/W | RAM
 |  | Channel 2 | 0x0703 | 1795dez | R/W | RAM
R2 | Measured value 1 |  | e.g. 0x0000 | e.g. 0dec | R | RAM
R3 | Measured value 2 |  | e.g. 0x0000 | e.g. 0dec | R | RAM
R4* | Register page selection |  | 0x0000 | 0dec | R/W | RAM
R5 | Counter specification register |  | 0x0000 | 0dec | R/W | RAM
R6 | Status byte |  | e.g. 0x0010 | e.g. 16dec | R | RAM
R7 | Command register |  | 0x0000 | 0dec | R/W | RAM
R8 | Terminal type | KL2532/KS2532 | 0x09E4 | 2532dec | R | ROM
 |  | KL2552/KS2552 | 0x09F8 | 2552dec
R9 | Firmware version |  | e.g. 0x3141 | e.g. 1AASCII | R | ROM
R10 | Multiplex shift register |  | 0x0130 | 304dec | R | ROM
R11 | Signal channels |  | 0x0218 | 536dec | R | ROM
R12 | Minimum data length |  | 0x1818 | 6168dec | R | ROM
R13 | Data structure |  | 0x0004 | 4dec | R | ROM
R14 | reserved |  | - | - | - | -
R15 | Alignment register |  | e.g. 0x7F80 | e.g. 32640dec | R/W | RAM
R16 | Hardware version number |  | e.g. 0x0000 | e.g. 0dec | R/W | EEPROM
R17 | DC link frequency |  | e.g. 0x7D00 | e.g. 32000dec | R | EEPROM
R18 | PWM dead time | KL2532/KS2532 | e.g. 0x0102 | e.g. 258dec | R | EEPROM
 |  | KL2552/KS2552 | e.g. 0x0604 | e.g. 1540 | R | EEPROM
R19 | Duty cycle limit |  | e.g. 0x0004 | e.g. 4dec | R | EEPROM
R20 | Temperature thresholds |  | e.g. 0x5064 | e.g. 20580dec | R | EEPROM
R21 | Sample time of the A/D converter |  | e.g. 0x000A | e.g. 10dec | R | EEPROM
R22 | reserved |  | - | - | - | -
... | ... |  | ... | ... | ... | ...
R30 | reserved |  | - | - | - | -
R31 | Code word register |  | 0x0000 | 0dec | R/W | RAM
*) Only the KL2552 supports these registers, not the KL2532
Register page 0
Register no. |  | Comment |  | Default value |  | R/W | Memory
R32 |  | Feature register 1 |  | 0x0000 | 0dec | R/W | EEPROM
R33 |  | Feature register 2 |  | 0x0000 | 0dec | R/W | EEPROM
R34 |  | Maximum permanent motor coil current | KL2532/KS2532 | 0x09C4 | 2500dec | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x1F40 | 8000dec | R/W | EEPROM
R35 |  | Rated current of the motor | KL2532/KS2532 | 0x05DC | 1500dec | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x1388 | 5000dec | R/W | EEPROM
R36 |  | Nominal voltage (supply voltage) of the motor | KL2532/KS2532 | 0x5DC0 | 24000dec | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0xC350 | 50000dec | R/W | EEPROM
R37* |  | Kp factor (velocity controller) |  | 0x0064 | 100dec | R/W | EEPROM
R38* |  | Ki factor (velocity controller) |  | 0x0000 | 0dec | R/W | EEPROM
R39* |  | Inner window of the I component (velocity controller) |  | 0x0000 | 0dec | R/W | EEPROM
R40* |  | Outer window of the I component (velocity controller) |  | 0x0000 | 0dec | R/W | EEPROM
R41 |  | Reduced torque (coil current in positive direction of rotation) | KL2532/KS2532 | 0x05DC | 1500dec | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x09C4 | 2500dec | R/W | EEPROM
R42* |  | Encoder increments |  | 0x0000 | 0dec | R/W | EEPROM
R43* |  | Rated motor speed at rated voltage |  | 0x0000 | 0dec | R/W | EEPROM
R44 |  | Internal resistance of the motor |  | 0x0000 | 0dec | R/W | EEPROM
R45 |  | Threshold for automatic torque reduction (in positive direction of rotation) |  | 0x0064 | 100dec | R/W | EEPROM
R46 | Time for current reduction on overload |  |  | 0x07D0 | 2000dec | R/W | EEPROM
R47 | Time for shutdown on overload |  |  | 0x00C8 | 200dec | R/W | EEPROM
R48 | Threshold for automatic torque reduction (in negative direction of rotation) |  |  | 0x0064 | 100dec | R/W | EEPROM
R49 | Reduced torque (coil current in negative direction of rotation) |  | KL2532/KS2532 | 0x05DC | 1500dec | R/W | EEPROM
 |  |  | KL2552/KS2552 | 0x09C4 | 2500dec | R/W | EEPROM
R50* | Kp factor (current controller) |  |  | 0x0190 | 400dec | R/W | EEPROM
R51* | Ki factor (current controller) |  |  | 0x0004 | 4dec | R/W | EEPROM
R52 | Inner window of the I component (current controller) |  |  | 0x0000 | 0dec | R/W | EEPROM
R53 | Outer window of the I component (current controller) |  |  | 0x0000 | 0dec | R/W | EEPROM
R54* | Ka factor (velocity controller) |  |  | 0x0000 | 0dec | R/W | EEPROM
R55* | Kd factor (velocity controller) |  |  | 0x0000 | 0dec | R/W | EEPROM
R56 | reserved |  |  | - | - | - | -
R63 | reserved |  |  | - | - | - | -
*) Only the KL2552 supports these registers, not the KL2532
Register page 1 (only KL2552, from firmware version 1M)
(see also selection for measured value 1 and measured value 2)
Register no. | Comment | Default value |  | R/W | Memory
R32 | Status word channel 1 | 0x0000 | 0dec | R | RAM
R33 | Status word channel 2 | 0x0000 | 0dec | R | RAM
R34 | Voltage of motor coil channel 1 (unit: 1 mV) | 0x0000 | 0dec | R | RAM
R35 | Voltage of motor coil channel 2 (unit: 1 mV) | 0x0000 | 0dec | R | RAM
R36 | Motor supply voltage (unit: 1 mV) | 0x0000 | 0dec | R | RAM
R37 | Control voltage (power contacts)(unit: 1 mV) | 0x0000 | 0dec | R | RAM
R38 | Current of motor coil channel 1 (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R39 | Current of motor coil channel 2 (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R40 | Internal temperature of the driver stage (unit: 1 °C) | 0x0000 | 0dec | R | RAM
R41 | Duty cycle channel 1 (unit: 1 %) | 0x0000 | 0dec | R | RAM
R42 | Duty cycle channel 2 (unit: 1 %) | 0x0000 | 0dec | R | RAM
R43 | Control error channel 1 (unit: 1 digit) | 0x0000 | 0dec | R | RAM
R44 | Control error channel 2 (unit: 1 digit) | 0x0000 | 0dec | R | RAM
R45 | Current limit channel 1 (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R46 | Current limit channel 2 (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R47 | Current of motor coil channel 1 (amount), (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R48 | Current of motor coil channel 2 (amount), (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R49 | Current of motor coil channel 1 (mean amount), (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R50 | Current of motor coil channel 2 (mean amount), (unit: 1 mA) | 0x0000 | 0dec | R | RAM
R51 | Current offset of motor coil channel 1 (synchronization), (unit: 1 digit) | 0x0000 | 0dec | R | RAM
R52 | Current offset of motor coil channel 2 (synchronization), (unit: 1 digit) | 0x0000 | 0dec | R | RAM
R53 | Duration of overload channel 1 (unit: 1 ms) | 0x0000 | 0dec | R | RAM
R54 | Duration of overload channel 2 (unit: 1 ms) | 0x0000 | 0dec | R | RAM
R55 | Reserved | - | - | - | -
R62 | reserved | - | - | - | -
R63 | Firmware version of the driver card | - | - | - | ROM


Register description

Access from the user program [image] Register description
Register description
The registers are used to parameterize the DC motor output stages. They can be read or written via the register communication and there is one instance for each terminal channel.
R0: Status word
The status word contains information about internal states, warnings and errors (see "Basic function principles" and "Status-Byte")
Bit | R0.15 | R0.14 | R0.13 | R0.12 | R0.11 | R0.10 | R0.9 | R0.8
Name | Misc Error | No Control Power | - | Short Circuit | Over Voltage | Under Voltage | Over Current | Over Temperature
Bit | R0.7 | R0.6 | R0.5 | R0.4 | R0.3 | R0.2 | R0.1 | R0.0
Name | - | Saturated | Moving Negative | Moving Positive | Ready | Ready to Enable | - | -
Legend
Bit
Name
Reaction
Description
R0.15
Misc Error
Error
1bin
Fault occurred
R0.14
No Control Power
Error
1bin
Control voltage at the power contacts is less than 12 V
R0.13
-
reserved
R0.12
Short Circuit
Error
1bin
Short circuit in the driver stage
R0.11
Over Voltage
Warning
1bin
Supply voltage 10 % higher than specified in R36
R0.10
Under Voltage
Warning
1bin
▪
Supply voltage 80 % lower than specified in register R36 (warning)
▪
Supply voltage less than 8 V (error; in addition, registers R0.15 and bit SB1.6 of the status register are set, and both channels are disabled)
R0.9
Over Current
Warning
1bin
The actual current was higher than the rated current over the time specified in register R47.
R0.8
Over Temperature
Warning
1bin
▪
Internal terminal temperature is higher than 80 °C (warning)
▪
Internal terminal temperature is higher than 100 °C (error; in addition, registers R0.15 and bit SB1.6 of the status register are set, and both channels are disabled)
R0.7
-
reserved
R0.6
Saturated
Warning
1bin
Driver stage is in saturation (max. output value reached)
R0.5
Moving Negative
1bin
Driver stage is activated in negative direction
R0.4
Moving Positive
1bin
Driver stage is activated in positive direction
R0.3
Ready
1bin
Driver stage is activated
R0.2
Ready to Enable
1bin
Driver stage ready for activation
R0.0 - R0.1
-
reserved
R1: Selection for measured value 1 and measured value 2
Preselection of the measured values shown in R2 and R3. The lower byte is allocated to register 2, the upper byte to register 3.
Example: R1 = 0x0602, lower byte = 2 (voltage of motor coil channel 1), upper byte = 6 (current of motor coil channel 1).
Each individual value can be shown in channel 1 and channel 2.
The values are based on the following table:
Selection | Name | Unit
0 | Internal status word channel 1 | -
1 | Internal status word channel 2 | -
2 | Voltage of motor coil channel 1 | 1 mV
3 | Voltage of motor coil channel 2
4 | Motor supply voltage
5 | Control voltage (power contacts)
6 | Current of motor coil channel 1 | 1 mA
7 | Current of motor coil channel 2
8 | Internal temperature of the driver stage | 1°C
9 | Duty cycle channel 1 | 1%
10 | Duty cycle channel 2
11 | Control error channel 1 | 1 digit
12 | Control error channel 2
13 | Current limit channel 1 | 1 mA
14 | Current limit channel 2
15 | reserved | -
... | reserved | -
254 | reserved | -
255 | Firmware version of the driver card | -
R2: Measured value 1
Output of measured value 1 (see R1).
R3: Measured value 2
Output of measured value 2 (see R1).
R4: Register page selection (only KL2552, from firmware version 1M)
This register defines which register page is displayed in registers R32 to R63 (default: 0x0000).
The terminal supports two register pages.
▪
Register page 0 is used for saving the configuration data (see from register R32)
▪
Register page 1 is used for reading internal measured values (additional mechanism for reading the measured values via registers R2 and R3)
R5: Counter specification register
Here you can specify the value to which the counter is set on rising edge at CB1.1 (SetCounter).
R6: Status byte
The status byte of the relevant channel is mapped here in addition.
R7: Command register
User code word
For the following commands to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings
KL2532
An entry of 0X7000 in register R7 sets the following registers for the two channels to the following default values:
R32: 0dec
R33: 0dec
R34: 2500dec
R35: 1500dec
R36: 24000dec
R41: 1500dec
R44: 0dec
R45: 100dcz
R46: 2000dec
R47: 200dec
R48: 100dec
R49: 1500dec
R50: 400dec
R51: 4dec
R52: 0dec
R53: 0dec
KL2552
An entry of 0X7000 in register R7 sets the following registers for the two channels to the following default values:
R32: 0dec
R33: 0dec
R34: 5000dec
R35: 1000dec
R36: 50000dec
R37: 100dec
R38: 0dec
R39: 0dec
R40: 0dec
R41: 2500dec
R42: 0dec
R43: 0dec
R44: 0dec
R45: 100dec
R46: 2000dec
R47: 200dec
R48: 100dec
R49: 2500dec
R50: 400dec
R51: 4dec
R52: 0dec
R53: 0dec
R54: 0dec
R55: 0dec
Restore Factory Settings resets both channels
The command Restore Factory Settings simultaneously resets both channels of the DC motor output stage terminal to the delivery state, irrespective of which register set it is called!
SmallWarningYellow WARNING
Risk of injury!
This command is used to de-energies the motor. Ensure that your system state permits this and that hazards for persons or machinery have been ruled out!
Command 0x8000: Software Reset
Entering 0x8000 in register R7 initiates a full software reset for the terminal. All internal variables (positions, latched values, errors, etc.) are cleared or are set to defined values that are read from the EEPROM. The internal circuits (ADC, output driver) are reinitialized with a software reset.
SmallWarningYellow WARNING
Risk of injury!
During a software reset the motor is switched current-free. Ensure that your system state permits this and that hazards for persons or machinery have been ruled out!
R8: Terminal type
The terminal identifier is contained in register R8: 0x09F8 (2552dec)
R9: Firmware version
Register R9 contains the ASCII coding of the terminal's firmware version, e.g. 0x3141 = '1A'. The '0x31' corresponds here to the ASCII character '1', while the '0x41' represents the ASCII character 'A'.
This value cannot be changed.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R17: DC link frequency
This is a manufacturer register and cannot be modified by the user.
The DC link frequency is configured here.
R18: PWM dead time
This is a manufacturer register and cannot be modified by the user.
The dead time of the high side and low side transistors is configured here.
R19: Duty cycle limit
This is a manufacturer register and cannot be modified by the user.
The minimum and maximum duty cycle in relation to the DC link frequency is configured here.
R20: Temperature thresholds
This is a manufacturer register and cannot be modified by the user.
The temperature thresholds for evaluating the internal temperature of the driver stage are configured here (warning output/shutdown of the driver stage).
R21: Sample time of the A/D converter
This is a manufacturer register and cannot be modified by the user.
The sample time in relation to the duty cycle is configured here.
R31: Code word register
If you write values into the user registers without first entering the user code word (0x1235) into the code word register, the terminal will not accept the supplied data. The code word is reset if the terminal is restarted.
Register page 0
Register page 0 is used for saving the configuration data.
R32: Feature register 1
The feature register 1 specifies the terminal's configuration.
Bit | R32.15 | R32.14 | R32.13 | R32.12 | R32.11 | R32.10 | R32.9 | R32.8
Name | - | - | - | disEncoder filter | - | enAutoReduce | enOverCurrentError | -
Bit | R32.7 | R32.6 | R32.5 | R32.4 | R32.3 | R32.2 | R32.1 | R32.0
Name | - | - | - | - | - | disWatchdog | - | -
Legend
Bit | Name | Description |  | default
R32.13 - R32.15 | - | reserved
R32.12 | disEncoder filter | 1bin | Input filter for encoder signals deactivated | 0bin
R32.11 | - | reserved
R32.10 | enAutoReduce | 0bin | The torque can be reduced manually with bit CB1.0 (see also R40, R49) | 0bin
 |  | 1bin | The torque is reduced automatically (see also R41, R45 or R49, R48)
R32.9 | enOverCurrentError | 0bin | Overload (R0.9 = 1) generates a warning (SB1.5) | 0bin
 |  | 1bin | Overload (R0.9 = 1) generates an error (SB1.6), and the channel is disabled
R32.3 - R32.8 | - | reserved
R32.2 | disWatchdog | 1bin | Internal 100 ms watchdog deactivated | 0bin
R32.0 - R32.1 | - | reserved
R33: Feature register 2
The feature register 2 specifies the terminal's configuration.
Bit | R33.15 | R33.14 | R33.13 | R33.12 | R33.11 | R33.10 | R33.9 | R33.8
Name | - | - | - | - | - | - | - | -
Bit | R33.7 | R33.6 | R33.5 | R33.4 | R33.3 | R33.2 | R33.1 | R33.0
Name | - | - | enOuter Window | enInner Window | Operation Mode
Legend
Bit | Name | Description |  |  | default
R33.6 - R33.15 | - | reserved
R33.5* | enOuter Window | 1bin | Outer window of the I component of the internal velocity control active |  | 0bin
R33.4* | enInner Window | 1bin | Inner window of the I component of the internal velocity control active |  | 0bin
R33.0 - R33.3 | Operation Mode | 0dez | DIRECT MODE | Direct duty cycle control proportional to the process data | 0dez
 |  | 1dez | VELOCITY MODE | Set velocity specification via the process data proportional to the set rated speed in R43
 |  | 3dez | reserved
 |  | 14dez | reserved
 |  | 15dez | CHOPPER MODE | Existing overvoltage (10% > rated voltage R36) is reduced via connected chopper resistor
*) These settings are only supported by the KL2552, not by the KL2532
R34: Maximum permanent motor coil current
This register reflects the maximum constant motor coil current specified by the motor manufacturer.
KL2532/KS2532: Default: 2500dec, range: 0 - 2500 mA
KL2552/KS2552: Default: 8000dec, range: 0 - 8000 mA
The unit is 0.001 A (example: 2500dec = 2.5 A).
R35: Rated current of the motor
This register reflects the rated motor current specified by the motor manufacturer.
KL2532/KS2532: Default: 1500dec, range: 0 - 1500 mA
KL2552/KS2552: Default: 05000dec, range: 0 - 5000 mA
The unit is 0.001 A (example: 1500dec = 1.5 A).
R36: Nominal voltage (supply voltage) of the motor
If the supply voltage increases above the set voltage due to feedback, the respective channel (chopper resistor must be connected) is fully opened and the overvoltage reduced, provided the chopper function (see R33) is activated.
KL2532/KS2532: Default: 24000dec, range: 0 V - 24 V
KL2552/KS2552: Default: 50000dec, range: 0 V - 50 V
The unit is 0.001 V (for example: 24000dec = 24 V).
R37: Kp factor (velocity controller, only KL2552)
This register contains the Kp factor for the proportional component of the internal velocity control (default: 100dec).
The unit is 0.001 (example: 1000dec => Kp = 1.00). Value range: 0 - 65535
R38: Ki factor (velocity controller, only KL2552)
This register contains the Ki factor for the integral component of the internal velocity control (default: 0dec).
The unit is 0.001 (example: 1000dec => Ki = 1.00). Value range: 0 - 65535
R39: Inner window of the I component (only KL2552)
The I component of the velocity control reduced linearly towards the zero point (default: 0dec). This register specifies the value from which the attenuation is activated (default: 0dec).
The unit is 1% (for example: 1 = 1%). Value range: 0% - 100 %
R40: Outer window of the I component (only KL2552)
This register specifies the maximum value of the I component (default: 0dec).
The unit is 1% (for example: 5dec = 5%). Value range: 0% - 100 %
R41: Reduced torque (coil current in positive direction of rotation)
This register contains the reduced torque (coil current) in positive direction of rotation. It is activated by CB1.0.
KL2532/KS2532: Default: 1500dec, range: 0 mA - 1500 mA
KL2552/KS2552: Default: 2500dec, range: 0 mA - 5000 mA
The unit is 0.001 A (for example: 500dec = 0.5 A).
R42: Encoder increments (KL2552 only)
This register contains the number of encoder increments per motor revolution (default: 0dec).
Value range: 0 - 65535
R43: Rated motor speed at rated voltage (only KL2552)
This register contains the rated motor speed at rated voltage (default: 0dec).
The unit is 1 RPM. Value range: 0 - 65535 RPM
R44: Internal resistance of the motor
This register contains the internal resistance of the motor (default: 0dec).
The unit is 0.01 Ohm (example: 206dec = 2.06 Ohm). Value range: 0 Ohm - 655,35 Ohm
R45: Threshold for automatic torque reduction (in positive direction of rotation)
This register contains the threshold at which automatic torque reduction is activated (R41) (default: 0dec). Deactivation occurs with a hysteresis of approx. 2% of the full scale (65 digit).
The unit is 1% (for example: 5dec = 5%). Value range: 0% - 100%
R46: Time for current reduction on overload
This register contains the time over which the motor current is reduced from the maximum value to the rated value. This happens based on an I²t function, i.e. the behavior is nonlinear. Depending on the actual motor current, it may take longer than the set time for the rated current to be reached (default: 2000dec).
The unit is 1 ms (for example: 2000dec = 2000 ms). Value range: 1 ms - 65535 ms (if 0 ms is configured, the terminal uses the default value of 2000 ms)
R47: Time to shutdown on overload
This register contains the time after which the output stage is switched off, if overload occurs over the whole interval. (Default: 200dec).
The unit is 1 ms (for example: 200dec = 200 ms). Value range: 0 ms - 65535 ms
R48: Threshold for automatic torque reduction (in negative direction of rotation)
This register contains the threshold (negative direction of rotation), from which the automatic torque reduction is enabled (R49) (default: 100dec). Deactivation occurs with a hysteresis of approx. 2% of the full scale (65 digit).
The unit is 1% (for example: 5dec = 5%). Value range: 0% - 100%
R49: Reduced torque (coil current in negative direction of rotation)
This register contains the reduced torque (coil current) in negative direction of rotation. It is activated by CB1.0.
KL2532/KS2532: Default: 1500dec, range: 0 mA - 1500 mA
KL2552/KS2552: Default: 2500dec, range: 0 mA - 5000 mA
The unit is 0.001 A (for example: 500dec = 0.5 A).
R50: Kp factor (current controller, only KL2552)
This register contains the Kp factor for the proportional component of the internal current control (default: 400dec).
The unit is 0.001 (example: 1000dec => Kp = 1.00). Value range: 0 - 65535
R51: Ki factor (current controller, only KL2552)
This register contains the Ki factor for the integral component of the internal current control (default: 4dec).
The unit is 0.001 (example: 1000dec => Ki = 1.00). Value range: 0 - 65535
R52: Inner window of the I component (current controller)
The I component of the velocity control reduced linearly towards the zero point (default: 0dec). This register specifies the value from which the attenuation is activated (default: 0dec).
The unit is 1% (for example: 1 = 1%). Value range: 0% - 100%
R53: Outer window of the I component (current controller)
This register specifies the maximum value of the I component (default: 0dec).
The unit is 1% (for example: 5dec = 5%). Value range: 0% - 100%
R54: Ka factor (velocity controller, only KL2552)
This register contains the Ka factor for the integral component of the internal velocity control (default: 0dec).
The unit is 0.001 (example: 1000dec => Ki = 1.00). Value range: 0 - 65535
R55: Kd factor (velocity controller, only KL2552)
This register contains the Kd factor of the differential component of the internal velocity control (default: 0dec).
The unit is 0.1 (example: 10dec => Kd = 1.00). Value range: 0 - 65535
Register page 1 (only KL2552, from firmware version 1M)
Register page 1 is used for reading internal measured values.
See register overview


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com