KL2521 - 1 channel pulse train output terminals, RS422 / 24 V DC
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status
•
Beckhoff Identification Code (BIC)


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
2.2
▪
Update chapter “Instructions for ESD protection”
▪
Update Firmware and hardware versions
▪
Chapter “Beckhoff Identification Code (BIC)” added
2.1
▪
KL2521-0010 added
2.0
▪
Migration
▪
Structure update
▪
Technical data updated
▪
Installation instructions for enhanced mechanical load capacity added
▪
Revision status updated
Firmware and hardware versions
Documentation Version | KL2521-0000 |  | KL2521-0010 |  | KL2521-0024
 | Firmware | Hardware | Firmware | Firmware | Firmware | Firmware
2.2 | 4F | 09 | - | - | 4F | 08
2.1 | 4F | 08 | 4A | 08 | 4F | 07
2.0 | 4F | 08 |  |  | 4F | 07
The firmware and hardware versions (delivery state) of the terminal can be found in the serial number printed on the side.
Syntax of the serial number
Structure of the serial number: WW YY FF HH
WW - week of production (calendar week)
YY – year of production
FF - firmware version
HH - hardware version
Example with ser. No.: 12 06 3A 02:
12 - week of production 12
06 - year of production 2006
3A - firmware version 3A
02 - hardware version 02


Beckhoff Identification Code (BIC)

Foreword [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Product overview

Product overview
Product overview
Additional information
•
KL2521-xxxx - Introduction
•
KL2521-xxxx - Technical data
•
Basic Function Principles


KL2521-xxxx - Introduction

Product overview [image] KL2521-xxxx - Introduction
KL2521-xxxx - Introduction
KL2521
1 Channel Pulse Train Output Terminal
The KL2521-xxxx output terminals change the frequency of a binary signal and output it (electrically isolated from the K-bus). The frequency is preset by a 16 bit value from the automation device.
The output stage of the KL2521-0000 is RS422-compatible. The outputs can be used both for connection to RS422 receivers and for the direct connection of an optocoupler (without external supply voltage) (default mode).
The terminal KL2521-0010 contains additional outputs (230 VAC/DC, 100 mA) instead of the additional inputs (+T, +Z) of the default variant.
The version KL2521-0024 was designed for connection to optocouplers (with external supply voltage). For connection to inputs with a large input resistance, an external supply voltage (up to 24 V) can be used (active mode).
The Bus Terminals indicate their signal state by means of light emitting diodes. The LEDs are clocked with the outputs and each displays an active output.


KL2521-xxxx - Technical data

Product overview [image] KL2521-xxxx - Technical data
KL2521-xxxx - Technical data
Technical Data | KL2521-0000 | KL2521-0010 | KL2521-0024
Number of outputs | 1 channel (2 differential outputs A, B) KL2521-0010: 2 additional outputs 230 VAC/DC, 100 mA (+T, +Z)
Load type* | Ohmic, optocoupler, differential inputs
Rated load voltage* | 5 VDC internal |  | 5 VDC - 24 VDC, external supply
Max. output current | 50 mA, RS485 specification |  | max. 0.5 A
Base frequency | 100 Hz ... 500 kHz, default: 50 kHz
Duty factor | 50 %
Resolution | 16 bits over one word in the fieldbus, 24 bits usable altogether
Ramp calculation | 2 ms / step
Output cycle time | 1 ms (synchronous to K-bus)
Dead time | 0.6 ms after K-bus cycle
Number of inputs | 2 (+T, +Z) | - | 2 (+T, +Z)
Input current | 2.3 mA to 2.8 mA at 5 V to 30 V
Electrical isolation | 500 V (K-bus/field voltage output / input)
Current consumption from the K-bus | typ. 50 mA, max. 120 mA (load-dependent)
Input process image | 24 bits (16 bits input data, 8 bits status)
Output process image | 24 bits (16 bits output data, 8 bits control)
Weight | approx. 50 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Dimensions (W x H x D) | approx. 15 mm x 100 mm x 70 mm (width aligned: 12 mm)
Mounting | on 35 mm mounting rail conforms to EN 60715
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, see also installation instructions for terminals with enhanced mechanical load capacity
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Installation position | variable
Approval | CE ATEX CULus |  | CE CULus
*) dependent on the hardware version of the terminal, see chapter Connection


Basic Function Principles

Product overview [image] Basic Function Principles
Basic Function Principles
The KL2521 output terminal generates a binary signal with a variable frequency. The peripheral side of the electronics is electrically isolated from the internal K-bus, and therefore also from the fieldbus. The output frequency can be adjusted. 16-bit values (signed integer) can be provided for this adjustment through the controller's process image. These values modify the output frequency from zero up to a pre-selected maximum frequency in equal increments -> there are 32767 (15 bits) steps in each direction (right/left).
In contrast to the KL2521, on the KL2521-0010 terminal the two inputs +T and +Z are not available any more. Instead of that, the KL2521-0010 is equipped with additional outputs.
The outputs T and Z can be set via the CONTROL byte (CONTROL.4 and CONTROL.5).
Afterwards, the signals can be read back from the terminal. They will be displayed in the STATUS byte and transmitted directly to the PLC (STATUS.4 and STATUS.6).
The outputs are realized by MOSFET switches and can switch AC and DC voltages. The maximum current is 100 mA. DC voltages can be switched positive and negative.
Process image
In the delivery state the KL2521 terminal occupies 3 bytes in the process image. The mapping of the KL2521 can be set by means of the controller or by the Bus Coupler's configuration interface using the Beckhoff KS2000 configuration software.
Operation modes
In addition to the FM (frequency modulation) operation mode, the KL2521 can also be used to control stepper motors with pulse-direction control (frq. cnt pulse mode). Incremental encoder simulation is another operation mode. It is possible to connect the terminal output directly to an incremental encoder input, with which many servo drives and frequency converters are equipped.
Default setting
The KL2521 is set to FM mode by default, with a base frequency of 50 kHz and a resolution of 15 bits. The number of pulses output is read back into a 16 bit register.
The counter overflows with a signal to the controller. This is displayed by Status.3 (overflow) or Status.2 (underflow). In parallel with these two bits, Status.6 is set as a general error bit. This makes the extension to more than 16 bits easier for the control software to handle. The overflow can also be read from register 3 (internal 32-bit extension).
The counter can be cleared by Control.5. The clearing of the counter takes place
▪
on a rising edge if Feature.4 = 1 (default)
▪
This function is level-controlled if Feature.4 = 0.
If Bit Feature.10 = 1, Bit Control.5 sets the counter to a value specified by register R0 (low word) and register 1 (high word).
Resolution
The base frequencies are specified with their resolution of 1 Hz per bit (GF1: registers 36, 37 or GF2: registers 38, 39). The terminal operates internally at 16 MHz with a resolution of 32 bits. This corresponds to a theoretical minimum step size of 0.0037 Hz/step over the entire frequency range. The output stage allows a maximum frequency of 500 kHz to be output
Additional information
•
Ramp function
•
Travel distance control
•
Output pattern


Ramp function

Product overview [image] Basic Function Principles [image] Ramp function
Ramp function
The terminal offers a facility for soft starting and stopping. The ramp gradient for starting can be set in register 40 with an accuracy of 10 or 1000 Hz/s (Feature.6). Register 41 performs the same function for stopping. The process data can be modified during transit of the ramp (Status.2), and the terminal then takes the new value as its target frequency.
The internal ramp function increases / lowers the current frequency up to a preset maximum frequency (register 2) with the preset parameters in register 40 / 41.
▪
The ramp function is activated with FeatureBit.5.
▪
The ramp base frequency is specified with FeatureBit.6.
▪
Status.1 is set while a ramp is being followed.
The deactivation of this function causes the release of Control.0. During operation this can also be done by Control.1. The user can change the base frequency quickly during operation with this.
▪
If Control.0 = 1 (confirmation by Status.0), the values in registers 38/39 are used.
▪
If Control.0 = 0, the values in registers 36/37 are used.
The input signals T and Z are transferred directly from the terminal to the controller in the status byte (Status.4 / Status.5). The signals are not given any internal pre-processing.


Travel distance control

Product overview [image] Basic Function Principles [image] Travel distance control
Travel distance control
If the travel distance control function is active (Feature.9), then a rising edge at Control.2 will result in drive to a fixed counter value. This value must previously be entered in register 0 (low word) and in register 1 (high word) at runtime.
Time t1 is specified by the ramp time constant in register 40.
The time t2 is driven through at the maximum frequency f1 (register 2).
Time t3 is determined by the ramp time constant in register 41 with which the slowing down frequency f2 (register 43) is achieved.
The specified counter value is reached on expiry of t5. The terminal switches the frequency to zero.
In order to travel to a destination with precision, it is necessary that the time constant for the falling ramp is greater than that of the rising ramp by a certain factor. This is necessary so that the slowing down frequency is reached before the final counter state, so that the terminal does not drive up to the end point at full speed.
To explain in more detail: the KL2521 calculates the number of steps that are still to be taken in time t2 from time t1 and from the number of steps that have been taken. The calculation for stopping assumes the same number of steps as that found for starting up. The downward ramp must be a little steeper, approx. 10%, so that it is possible to reach the destination exactly in the remaining time t3 + t4 + t5. This relationship changes with the maximum frequency.
Phases of the travel distance control


Output pattern

Product overview [image] Basic Function Principles [image] Output pattern
Output pattern
The pulse pattern is output through channels A and B. The operation mode is configured with the feature register R32.
The operation modes differ primarily between the positive logic (modes 0, 1, 2) and the negative logic (modes 4, 5, 6).
Operation modes 2 and 6 simulate an incremental encoder and enable the direct connection of an evaluation unit. This also includes a servo drive or a frequency converter with an incremental encoder input.
Operating mode | Function
 | Clockwise rotation Counter clockwise rotation
Frequency modulation positive logic (BA0) |
Pulse-direction control positive logic (BA1) |
Incremental encoder positive logic (BA2) |
Frequency modulation negative logic (BA4) |
Pulse-direction control negative logic (BA5) |
Incremental encoder negative logic (BA6) |


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Instructions for ESD protection
•
Installation on mounting rails
•
Installation instructions for enhanced mechanical load capacity
•
Connection
•
KL2521-xxxx - Connection and LED description
•
ATEX - Special conditions (standard temperature range)
•
ATEX Documentation


Instructions for ESD protection

Mounting and wiring [image] Instructions for ESD protection
Instructions for ESD protection
Note
Destruction of the devices by electrostatic discharge possible!
The devices contain components at risk from electrostatic discharge caused by improper handling.
•
Please ensure you are electrostatically discharged and avoid touching the contacts of the device directly.
•
Avoid contact with highly insulating materials (synthetic fibers, plastic film etc.).
•
Surroundings (working place, packaging and personnel) should by grounded probably, when handling with the devices.
•
Each assembly must be terminated at the right hand end with a KL9010 bus end terminal, to ensure the protection class and ESD protection.
Spring contacts of the Beckhoff I/O components


Installation on mounting rails

Mounting and wiring [image] Installation on mounting rails
Installation on mounting rails
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Assembly
Attaching on mounting rail
The bus coupler and bus terminals are attached to commercially available 35 mm mounting rails (DIN rails according to EN 60715) by applying slight pressure:
1.
First attach the fieldbus coupler to the mounting rail.
2.
The bus terminals are now attached on the right-hand side of the fieldbus coupler. Join the components with tongue and groove and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without tongue and groove, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
Fixing of mounting rails
The locking mechanism of the terminals and couplers extends to the profile of the mounting rail. At the installation, the locking mechanism of the components must not come into conflict with the fixing bolts of the mounting rail. To mount the mounting rails with a height of 7.5 mm under the terminals and couplers, you should use flat mounting connections (e.g. countersunk screws or blind rivets).
Disassembly
Disassembling of terminal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Pull the terminal by its orange-colored lugs approximately 1 cm away from the mounting rail. In doing so for this terminal the mounting rail lock is released automatically and you can pull the terminal out of the bus terminal block easily without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal out of the bus terminal block.
Connections within a bus terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the bus terminal block. The power contacts are supplied via terminals on the Bus Coupler (up to 24 V) or for higher voltages via power feed terminals.
Power Contacts
During the design of a bus terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx or EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labeled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on left side
Note
Possible damage of the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a nominal voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
SmallWarningYellow WARNING
Risk of electric shock!
The PE power contact must not be used for other potentials!


Installation instructions for enhanced mechanical load capacity

Mounting and wiring [image] Installation instructions for enhanced mechanical load capacity
Installation instructions for enhanced mechanical load capacity
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminal system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
Additional checks
The terminals have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 6 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 25 g, 6 ms
Additional installation instructions
For terminals with enhanced mechanical load capacity, the following additional installation instructions apply:
▪
The enhanced mechanical load capacity is valid for all permissible installation positions
▪
Use a mounting rail according to EN 60715 TH35-15
▪
Fix the terminal segment on both sides of the mounting rail with a mechanical fixture, e.g. an earth terminal or reinforced end clamp
▪
The maximum total extension of the terminal segment (without coupler) is:
64 terminals (12 mm mounting with) or 32 terminals (24 mm mounting with)
▪
Avoid deformation, twisting, crushing and bending of the mounting rail during edging and installation of the rail
▪
The mounting points of the mounting rail must be set at 5 cm intervals
▪
Use countersunk head screws to fasten the mounting rail
▪
The free length between the strain relief and the wire connection should be kept as short as possible. A distance of approx. 10 cm should be maintained to the cable duct.


Connection

Mounting and wiring [image] Connection
Connection
Additional information
•
Connection system
•
Wiring
•
Shielding


Connection system

Mounting and wiring [image] Connection [image] Connection system
Connection system
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the bus terminals!
Overview
The Bus Terminal system offers different connection options for optimum adaptation to the respective application:
▪
The terminals of ELxxxx and KLxxxx series with standard wiring include electronics and connection level in a single enclosure.
▪
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level and enable steady wiring while replacing.
▪
The High Density Terminals (HD Terminals) include electronics and connection level in a single enclosure and have advanced packaging density.
Standard wiring (ELxxxx / KLxxxx)
Standard wiring
The terminals of ELxxxx and KLxxxx series have been tried and tested for years.
They feature integrated screwless spring force technology for fast and simple assembly.
Pluggable wiring (ESxxxx / KSxxxx)
Pluggable wiring
The terminals of ESxxxx and KSxxxx series feature a pluggable connection level.
The assembly and wiring procedure is the same as for the ELxxxx and KLxxxx series.
The pluggable connection level enables the complete wiring to be removed as a plug connector from the top of the housing for servicing.
The lower section can be removed from the terminal block by pulling the unlocking tab.
Insert the new component and plug in the connector with the wiring. This reduces the installation time and eliminates the risk of wires being mixed up.
The familiar dimensions of the terminal only had to be changed slightly. The new connector adds about 3 mm. The maximum height of the terminal remains unchanged.
A tab for strain relief of the cable simplifies assembly in many applications and prevents tangling of individual connection wires when the connector is removed.
Conductor cross sections between 0.08 mm2 and 2.5 mm2 can continue to be used with the proven spring force technology.
The overview and nomenclature of the product names for ESxxxx and KSxxxx series has been retained as known from ELxxxx and KLxxxx series.
High Density Terminals (HD Terminals)
High Density Terminals
The Bus Terminals from these series with 16 terminal points are distinguished by a particularly compact design, as the packaging density is twice as large as that of the standard 12 mm Bus Terminals. Massive conductors and conductors with a wire end sleeve can be inserted directly into the spring loaded terminal point without tools.
Wiring HD Terminals
The High Density (HD) Terminals of the ELx8xx and KLx8xx series doesn't support pluggable wiring.
Ultrasonically "bonded" (ultrasonically welded) conductors
Ultrasonically “bonded" conductors
It is also possible to connect the Standard and High Density Terminals with ultrasonically "bonded" (ultrasonically welded) conductors. In this case, please note the tables concerning the wire-size width below!


Wiring

Mounting and wiring [image] Connection [image] Wiring
Wiring
SmallWarningYellow WARNING
Risk of electric shock and damage of device!
Bring the bus terminal system into a safe, powered down state before starting installation, disassembly or wiring of the Bus Terminals!
Terminals for standard wiring ELxxxx/KLxxxx and for pluggable wiring ESxxxx/KSxxxx
Connecting a cable on a terminal point
Up to eight terminal points enable the connection of solid or finely stranded cables to the Bus Terminal. The terminal points are implemented in spring force technology. Connect the cables as follows:
1.
Open a terminal point by pushing a screwdriver straight against the stop into the square opening above the terminal point. Do not turn the screwdriver or move it alternately (don't toggle).
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal point closes automatically when the pressure is released, holding the wire securely and permanently.
See the following table for the suitable wire size width.
Terminal housing | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Wire size width (single core wires) | 0.08 ... 2.5 mm2 | 0.08 ... 2.5 mm2
Wire size width (fine-wire conductors) | 0.08 ... 2.5 mm2 | 0,08 ... 2.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 1.5 mm2 | 0.14 ... 1.5 mm2
Wire stripping length | 8 ... 9 mm | 9 ... 10 mm
High Density Terminals (HD Terminals) with 16 terminal points
The conductors of the HD Terminals are connected without tools for single-wire conductors using the direct plug-in technique, i.e. after stripping the wire is simply plugged into the terminal point. The cables are released, as usual, using the contact release with the aid of a screwdriver. See the following table for the suitable wire size width.
Terminal housing | High Density Housing
Wire size width (single core wires) | 0.08 ... 1.5 mm2
Wire size width (fine-wire conductors) | 0.25 ... 1.5 mm2
Wire size width (conductors with a wire end sleeve) | 0.14 ... 0.75 mm2
Wire size width (ultrasonically “bonded" conductors) | only 1.5 mm2
Wire stripping length | 8 ... 9 mm


Shielding

Mounting and wiring [image] Connection [image] Shielding
Shielding
Shielding
Encoder, analog sensors and actors should always be connected with shielded, twisted paired wires.


KL2521-xxxx - Connection and LED description

Mounting and wiring [image] KL2521-xxxx - Connection and LED description
KL2521-xxxx - Connection and LED description
SmallWarningYellow WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals!
KL2521-xxxx - Connection and LEDs
Connection of KL2521-xxxx
Terminal point | No. | Comment
+A | 1 | Output +A
+B | 2 | Output +B
+T | 3 | Input T (KL2521-0010: Output T)
GND T, Z | 4 | Signal ground for the outputs
-A | 5 | Output -A
-B | 6 | Output -B
+Z | 7 | Input Z (KL2521-0010: Output Z)
Shield | 8 | Shield
KL2521-xxxx - LED description
LED | Color | Description
Signal LED A, B Input T, Z | green | The four LEDs light up with active signal levels of the inputs and outputs. The illumination of the LEDs for the active frequency outputs A or B at higher frequencies can only be perceived as a glow at half brightness. When the watchdog is active (Feature.2 = 0!!!) the terminal will switch the outputs off or will output a value stored in register 35 if no new process data is transferred to the terminal within 100 ms.
Connecting the inputs (KL2521-0000, KL2521-0024)
The optically isolated inputs are protected from overload by a current limiter. Without further external circuitry the operating voltage may lies between 5 V and 24 VDC. The GND connection is the common ground for the two inputs, T and Z. The circuit diagram shows the internal circuitry of the two inputs:
Internal circuit of the inputs T and Z
Connection of the outputs
Circuit examples for output to A. The same principles apply to output B.
KL2521-0000, KL2521-0010
The outputs A and B of the EL2521 can be used in different connection modes. An integrated DC/DC converter supplies the output stage of the two channels, A and B, with an electrically isolated 5 V power supply.
▪
Connection to RS485/RS232 receiver
The output can be operated as RS485 or as RS232 output. The circuit generates the necessary differential signals.
KL2521-0000 on the RS485/RS232 receiver
▪
Connection to optocoupler (without external supply voltage)
The outputs can be used for direct connection of an optocoupler. The output stage supplies the necessary output current using an internal 5 V supply voltage.
EL2521-0000, direct connection to an optocoupler
Connection to optocoupler (with external supply voltage)
For connection to inputs with a large input resistance, an external supply voltage (up to 24 V) can be used with the EL2521-0024 in order to create the necessary current.
Operation with an external supply voltage is dependent on the hardware version
The operation with an external supply voltage depends on the hardware version of the terminal:
•
You can use the standard variant KL2521-0000 for this up to hardware version 03.
•
From hardware version 04 this is only possible with the special variant KL2521-0024, which was specially optimized for this application!
However, since the KL2521-0024 has no internal supply voltage (5 V) it is not suitable for connection to RS485/RS232 receivers or optocouplers without an external supply voltage.
▪
KL2521-0000 up to hardware version 03
KL2521-0000 up to hardware version 03 - wiring with external power source
▪
Instead of hardware version 04 (or higher), use the special variant KL2521-0024
KL2521-0024 - wiring with external power source
See chapter Documentation issue status for the determination of the hardware version
KL2521-0024: Connection to external electronics
Note when connecting external electronics that terminal point A of the first channel and terminal point B of the second channel of a KL2521-0024 are connected to each other internally.
KL2521-0024 - connection to external electronics
This allows the dual-channel connection of external electronics if the KL2521-0024 switches the ground of the connected device as shown in example 1.
Notes on connection to external electronics
•
The Beckhoff KL5111, KL5121, KL5151 and KL5152 incremental encoder interface terminals require the switching of the positive voltage.
•
Because the terminal points A and B of the KL2521-0024 are bridged internally, the KL2521-0024 cannot switch the two inputs of the KL5151-0000 shown in example 2 independently of each other. This circuit crossed out in red is therefore of no use!
•
As shown in example 3, however, you can use one channel of the KL2521-0024 to switch one channel of the KL5151-0000.
KL2521-0010 Connection of additional outputs T, Z
The outputs are realized by MOSFET switches and can switch AC and DC voltages up to 230 V. The maximum current is 100 mA. DC voltages can be switched positive and negative.
Ausgang T, Z
KL2521-0010 - Output T, Z
Wiring
KL2521-0010 - Wiring


ATEX - Special conditions (standard temperature range)

Mounting and wiring [image] ATEX - Special conditions (standard temperature range)
ATEX - Special conditions (standard temperature range)
SmallWarningYellow WARNING
Observe the special conditions for the intended use of Beckhoff fieldbus components with standard temperature range in potentially explosive areas (directive 2014/34/EU)!
•
The certified components are to be installed in a suitable housing that guarantees a protection class of at least IP54 in accordance with EN 60079-15! The environmental conditions during use are thereby to be taken into account!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observe the permissible ambient temperature range of 0 to 55°C for the use of Beckhoff fieldbus components standard temperature range in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The individual terminals may only be unplugged or removed from the Bus Terminal system if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
The fuses of the KL92xx/EL92xx power feed terminals may only be exchanged if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
•
Address selectors and ID switches may only be adjusted if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Marking
The Beckhoff fieldbus components with standard temperature range certified according to the ATEX directive for potentially explosive areas bear one of the following markings:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
or
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX Documentation

Mounting and wiring [image] ATEX Documentation
ATEX Documentation
Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)
Pay also attention to the continuative documentation

Notes about operation of the Beckhoff terminal systems in potentially explosive areas (ATEX)

that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Configuration Software KS2000

Configuration Software KS2000
Configuration Software KS2000
Additional information
•
KS2000 - Introduction


KS2000 - Introduction

Configuration Software KS2000 [image] KS2000 - Introduction
KS2000 - Introduction
The KS2000 configuration software permits configuration, commissioning and parameterization of bus couplers, of the affiliated bus terminals and of Fieldbus Box Modules. The connection between bus coupler / Fieldbus Box Module and the PC is established by means of the serial configuration cable or the fieldbus.
KS2000 configuration software
Configuration
You can configure the Fieldbus stations with the Configuration Software KS2000 offline. That means, setting up a terminal station with all settings on the couplers and terminals resp. the Fieldbus Box Modules can be prepared before the commissioning phase. Later on, this configuration can be transferred to the terminal station in the commissioning phase by means of a download. For documentation purposes, you are provided with the breakdown of the terminal station, a parts list of modules used and a list of the parameters you have modified. After an upload, existing fieldbus stations are at your disposal for further editing.
Parameterization
KS2000 offers simple access to the parameters of a fieldbus station: specific high-level dialogs are available for all bus couplers, all intelligent bus terminals and Fieldbus Box modules with the aid of which settings can be modified easily. Alternatively, you have full access to all internal registers of the bus couplers and intelligent terminals. Refer to the register description for the meanings of the registers.
Commissioning
The KS2000 software facilitates commissioning of machine components or their fieldbus stations: Configured settings can be transferred to the fieldbus modules by means of a download. After a login to the terminal station, it is possible to define settings in couplers, terminals and Fieldbus Box modules directly online. The same high-level dialogs and register access are available for this purpose as in the configuration phase.
The KS2000 offers access to the process images of the bus couplers and Fieldbus Box modules.
▪
Thus, the coupler's input and output images can be observed by monitoring.
▪
Process values can be specified in the output image for commissioning of the output modules.
All possibilities in the online mode can be used in parallel with the actual fieldbus mode of the terminal station. The fieldbus protocol always has the higher priority in this case.


Access from the user program

Access from the user program
Access from the user program
Additional information
•
Process data
•
Register overview
•
Register description
•
Control and status byte
•
Examples of Register Communication


Process data

Access from the user program [image] Process data
Process data
Input format:
▪
Two's complement representation (integer-1 equals 0xFFFF) or
▪
Signed amount representation (Feature.3) (integer - 1 equals 0x8001)
The output frequency is specified within maximum resolution of 15 bits (the 16th bit is used to specify the direction).
Negative process data results in rotation in the opposite direction. In this case, the internal counter counts to decreasing values.
Relative data
The output frequency is based on the base frequency that is set in registers 36 – 39 and the process data (see table).
Output frequency = base frequency x process data / 32767
Highest resolution = 125 mHz
Example:
Base frequency = 100,000 Hz (maximum selected output frequency)
Process data = 0x00FF (255dec)
Output frequency = 778.22 Hz
Process data |  | Output value
 | 0x0000 (0dec) | 0% DC
 | 0x3FFF (16383dec) | 50% of the base frequency, rotation to the right
 | 0x7FFF (32767dec) | 100% of the base frequency, rotation to the right
Two's complement | 0xC000 (-16384dec) | 50% of the base frequency, rotation to the left
 | 0x8000 (-32768dec) | 100% of the base frequency, rotation to the left
Signed amount representation | 0xBFFF (-16383dec) | 50% of the base frequency, rotation to the left
 | 0xFFFF (-32767dec) | 100% of the base frequency, rotation to the left
Direct data
It is possible to enter the frequency directly (Feature.7). In this case the process data is multiplied by the factor contained in register 42, and directly written to the synthesis chip.
Output frequency = frequency factor x process data x 10 mHz
Highest resolution = 10 mHz
Example:
Frequency factor = 100
Process data = 0x00FF (255dec)
Output frequency = 255 Hz


Register overview

Access from the user program [image] Register overview
Register overview
These registers exist once for each channel
Address | Name | Default value | R/W | Storage medium
R0 | Target counter value (low word) | 0x0000 (0dec) | R/W | RAM
R1 | Target counter value (high word) | 0x0000 (0dec) | R/W | RAM
R2 | Maximum frequency | 0x0000 (0dec) | R/W | RAM
R3 | Counter extension (high word) | 0x0000 (0dec) | R | RAM
R4…R6 | reserved | 0x0000 (0dec) | R |
R7 | Command register - reserved | 0x0000 (0dec) | R/W | RAM
R8 | Terminal type | 0x09D9 (2521dec) | R | ROM
R9 | Software version number | 0x3446 (4FASCI) | R | ROM
R10 | Multiplex shift register | 0x0118 (280dec) | R | ROM
R11 | Signal channels | 0x0118 (280dec) | R | ROM
R12 | Minimum data length | 0x1818 (6468dec) | R | ROM
R13 | Data structure | 0x0004 (4dec) | R | ROM
R14 | reserved | 0x0000 (0dec) | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0x0003 (3dec) | R/W | EEPROM
R17…R30 | reserved | 0x0000 (0dec) | R/W |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0030 (48dec) | R/W | EEPROM
R33… R34 | reserved | 0x0000 (0dec) | R/W |
R35 | User switch-on value | 0x0000 (0dec) | R/W | EEPROM
R36* | Base frequency 1 (low word) | 0xC350 (50000dec) | R/W | EEPROM
R37* | Base frequency 1 (high word) | 0x0000 (0dec) | R/W | EEPROM
R38* | Base frequency 2 (low word) | 0x86A0 (34464dec) | R/W | EEPROM
R39* | Base frequency 2 (high word) | 0x0001 (1dec) | R/W | EEPROM
R40 | Ramp time constant (rising, see feature register) | 0x03E8 (1000dec) | R/W | EEPROM
R41 | Ramp time constant (falling, see feature register) | 0x03E8 (1000dec) | R/W | EEPROM
R42 | Frequency factor (direct input, digit x 10 mHz) | 0x0064 (100dec) | R/W | SEEROM
R43 | Run-out frequency (travel distance control) | 0x0032 (50dec) | R/W | SEEROM
R44… R61 | reserved | 0x0000 (0dec) | R/W |
*) The change of the base frequency requires a reset for activation.


Register description

Access from the user program [image] Register description
Register description
The registers can be read or written via the register communication. They are used for the parameterization of the terminal.
R0 to R7: Registers in the internal RAM of the terminal
The process variables can be used in addition to the actual process image. Their function is specific to the terminal.
▪
R0 target counter value (low word)
This register contains the low word of the target counter value.
▪
R1 target counter value (high word)
This register contains the high word of the target counter value.
▪
R2 maximum frequency
This register contains the high word of the target counter value.
▪
R3 counter extension high word
This register contains the overflow value (internal 32-bit extension).
▪
R4 to R6: Reserved
▪
R7: Command register [0x0000]
For a command to be executed, it is first necessary for the user code word, 0x1235, to be entered into register R31.
Command 0x7000: Restore Factory Settings
Entering 0x7000 in register R7 restores the delivery state for the following registers.
R32: | 0x0030 | (48dec) | R38: | 0x86A0 | (34464dec)
R33: | 0x0000 | (0dec) | R39: | 0x0001 | (1dec)
R34: | 0x0000 | (0dec) | R40: | 0x03E8 | (1000dec)
R35: | 0x0000 | (0dec) | R41: | 0x03E8 | (1000dec)
R36: | 0xC350 | (50000dec) | R42: | 0x0064 | (100dec)
R37: | 0x0000 | (0dec) | R43: | 0x0032 | (50dec)
R8 to R15: Registers in the internal ROM of the terminal
The type and system parameters are hard programmed by the manufacturer, and the user can read them but cannot change them.
▪
R8: Terminal type
The terminal type in register R8 is needed to identify the terminal.
▪
R9: Software version (X.y)
The software version can be read as a string of ASCII characters.
▪
R10: Data length
R10 contains the number of multiplexed shift registers and their length in bits.
The Bus Coupler sees this structure.
▪
R11: Signal channels
Related to R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.
▪
R12: Minimum data length
The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control and status byte is not necessarily required for the terminal function and is not transferred to the control, if the Bus Coupler is configured accordingly.
▪
R13: Data type register
Data type register | Meaning
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure 1 byte n bytes
0x03 | Word array
0x04 | Structure 1 byte n words
0x05 | Double word array
0x06 | Structure 1 byte n double words
0x07 | Structure 1 byte 1 double word
0x08 | Structure 1 byte 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure 1 byte n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure 1 byte n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure 1 byte n double words with variable logical channel length
▪
R14: reserved
▪
R15: Alignment bits (RAM)
The alignment bits are used to place the analog terminal in the Bus Coupler on a byte boundary.
R16 to R30: Manufacturer parameter area (SEEROM)
The manufacturer parameters are specific for each type of terminal. They are programmed by the manufacturer, but can also be modified by the controller. The manufacturer parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out.
These registers can only be altered after a code word has been set in R31.
R16: Hardware version number
Register R16 contains the hardware version of the terminal.
R31 to R47: User parameter area (SEEROM)
The user parameters are specific for each type of terminal. They can be modified by the programmer. The user parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out. The user area is write-protected by a code word.
• R31: Code word register in RAM
The code word 0x1235 must be entered here so that parameters in the user area can be modified. If any other value is entered into this register, the write-protection is active. When write protection is not active, the code word is returned when the register is read. If the write protection is active, the register contains a zero value.
▪
R32: Feature register
[0x0030]
This register specifies the operation modes of the terminal. Thus, for instance, a user-specific scaling can be enabled for the analog I/Os.
Feature bit no.
Description of the operation mode
Bit 0…Bit1
-
No function
Bit 2
0
[0] Watchdog timer active
In the delivery state, the watchdog timer is switched on. Either the manufacturer's of the user's switch-on value is output if the watchdog overflows.
Bit 3
1
[0] Signed amount representation
Signed amount representation is active instead of two's complement representation. (-1 = 0x8001).
Bit 4
1
[1] The counter is cleared on a positive edge of the Counter_Clear bit in the control byte (Control.5)
Bit 5
1
[1] Ramp function active
Bit 6
0/1
[0] Ramp base frequency
▪
0:10 Hz / s
▪
1: 1000 Hz / s
Bit 7
0/1
[0] Input mode
▪
0:relative
▪
1: direct
Bit 8
0/1
[0] Behavior when watchdog triggered
▪
0:Manufacturer's switch-on value
▪
1: User switch-on value
Bit 9
1
[0] Travel distance control active
Bit 10
0/1
[0] Counter
▪
0: delete
▪
1: set
Bit 11…12
-
No function
Bit 13…15
Pos. logic
Neg. logic
[000] Operation mode
Range of values
000
100
Frequency modulation
0 - 500 kHz
001
101
Pulse-direction control
010
110
Incremental encoder
▪
R35: User switch-on value
If the user switch-on value has been enabled with bit R32.8 of the feature register, the terminal sets its output to the user switch-on value in place of the manufacturer switch-on value on the occurrence of a system reset or a watchdog timer overflow (terminal has not received any process data for 100 ms).
▪
R36: Base frequency 1 (low word)
This register contains the low word of the base frequency 1.
The base frequency 1 is used if
–
the ramp function is deactivated and
–
the Frequency_Selection bit (Control.0) is 0.
▪
R37: Base frequency 1 (high word)
This register contains the high word of the base frequency 1.
The base frequency 1 is used if
–
the ramp function is deactivated and
–
the Frequency_Selection bit (Control.0) is 0.
▪
R38: Base frequency 2 (low word)
This register contains the low word of the base frequency 2.
The base frequency 2 is used if
–
the ramp function is deactivated and
–
the Frequency_Selection bit (Control.0) is 1.
▪
R39: Base frequency 2 (high word)
This register contains the high word of the base frequency 2.
The base frequency 2 is used if
–
the ramp function is deactivated and
–
the Frequency_Selection bit (Control.0) is 1.
▪
R40: Ramp time constant (rising)
The ramp gradient for starting can be set in register 40 with a accuracy of 10 or 1000 Hz/s (Feature.6).
▪
R41: Ramp time constant (falling)
The ramp gradient for stopping can be set with an accuracy of 10 or 1000 Hz / s (Feature.6) using register 41.
▪
R42: Frequency factor (direct input, digit x 10 mHz)
This register contains the frequency factor. If the frequency is entered directly (Feature7 = 1), the process data are multiplied by the frequency factor (see Process data).
▪
R43: Run-out frequency (travel distance control)
This register contains the run-out frequency (see travel distance control).


Control and status byte

Access from the user program [image] Control and status byte
Control and status byte
The control and status byte is transmitted from the controller to the terminal. It can be used
▪
in register mode (REG = 1bin) or
▪
in process data exchange (REG = 0bin).
Additional information
•
KL2521-0000, KL2521-0024 - Process data exchange
•
KL2521-0010 - Process data exchange
•
Register communication


KL2521-0000, KL2521-0024 - Process data exchange

Access from the user program [image] Control and status byte [image] KL2521-0000, KL2521-0024 - Process data exchange
KL2521-0000, KL2521-0024 - Process data exchange
Control byte in process data exchange (REG=0)
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | 0 | Cnt_Clr | 0 | 0 | Go_Counter | Ramp_Dis | Freq_Sel
Bit | Name | Description
Bit 7 | Reg_Access | 0bin: Register communication inactive (process data exchange)
Bit 5 | Cnt_Clr | The counter value is cleared or set by this bit (Feature.10). Any overflow/underflow bits that have been set are also cleared by this bit. This can be done with edge control or level control (Feature.4).
Bit 2 | Go_Counter | If travel distance control is active (Feature.9), then a pre-set counter value is approached when the bit is set.
Bit 1 | Ramp_Dis | The ramp function is disabled despite active Feature .5; if the travel distance control is active it is aborted by this bit.
Bit 0 | Freq_Sel | Fast toggling of the base frequency (only if ramp function is deactivated) 0: Base frequency 1 (registers 36 / 37) 1: Base frequency 2 (registers 38 / 39)
Status byte in process data exchange (REG=0)
The status byte is transferred from the terminal to the controller. The status byte contains various status bits for the analog input channel:
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | Error | Input_Z | Input_T | Overflow | Underflow | Ramp_Active | Sel_Ack/ End_Counter
Bit | Name | Description
Bit 7 | Reg_Access | 0bin: Acknowledgement for process data exchange
Bit 6 | Error | General error bit, included with overflow/underflow
Bit 5 | Input_Z | End position reached
Bit 4 | Input_T | The actual value when the device is connected does not agree with the set value of the connected device.
Bit 3 | Overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or as soon as an underflow occurs.
Bit 2 | Underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or as soon as an overflow occurs.
Bit 1 | Ramp_Active | Ramp is currently being followed
Bit 0 | Sel_Ack/ End_Counter | Confirms the change of base frequency. If travel distance control is activated: target counter value reached
The change of the base frequency requires a reset for activation.


KL2521-0010 - Process data exchange

Access from the user program [image] Control and status byte [image] KL2521-0010 - Process data exchange
KL2521-0010 - Process data exchange
Control byte in process data exchange (REG=0)
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | 0 | SET_Z | SET_T | Cnt_Clr | Go_Counter | Ramp_Dis | Freq_Sel
Bit | Name | Description
Bit 7 | Reg_Access | 0bin: Register communication inactive (process data exchange)
Bit 5 | SET_Z | Set output Z
Bit 4 | SET_T | Set output T
Bit 3 | Cnt_Clr | The counter value and eventually set overflow/underflow bits will be deleted by this bit This can be done with edge control or level control (Feature.4).
Bit 2 | Go_Counter | If travel distance control is active (Feature.9), then a pre-set counter value is approached when the bit is set.
Bit 1 | Ramp_Dis | The ramp function is disabled despite active Feature .5; if the travel distance control is active it is aborted by this bit.
Bit 0 | Freq_Sel | Fast toggling of the base frequency (only if ramp function is deactivated) 0: Base frequency 1 (registers 36 / 37) 1: Base frequency 2 (registers 38 / 39)
The change of the base frequency requires a reset for activation.
Status byte in process data exchange (REG=0)
The status byte is transferred from the terminal to the controller.
Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Reg_Access | Error | Out_Z_ACK | Out_T_ACK | Overflow | Underflow | Ramp_Active | Sel_Ack
Bit | Name | Description
Bit 7 | Reg_Access | 0bin: Acknowledgement for process data exchange
Bit 6 | Error | General error bit, included with overflow/underflow
Bit 5 | Out_Z_ACK | Output Z
Bit 4 | Out_T_ACK | Output T
Bit 3 | Overflow | This bit is set if the 16-bit counter overflows (65535 -> 0). It is reset when the counter exceeds one third of its measuring range (21845 -> 21846) or as soon as an underflow occurs.
Bit 2 | Underflow | This bit is set if the 16-bit counter underflows (0 -> 65535). It is reset when the counter drops below two thirds of its measuring range (43690 -> 43689) or as soon as an overflow occurs.
Bit 1 | Ramp_Active | Ramp is currently being followed
Bit 0 | Sel_Ack | Confirms the change of base frequency.


Register communication

Access from the user program [image] Control and status byte [image] Register communication
Register communication
Register access via process data exchange
▪
Bit 7=1: Register mode
If bit 7 of the control byte is set, the first two bytes of the user data are not used for process data exchange but written into the register set of the terminal or read from it.
▪
Bit 6=0: read, bit 6=1: write
Bit 6 of the control bytes is used to specify whether a register should be read or written.
–
Bit 6=0: a register is read without changing it. The value can be found in the input process image.
–
Bit 6=1: the user data are written to a register. The process is complete once the status byte in the input process image has returned an acknowledgment (see example).
▪
Bit 0 to 5: Address
The address of the register to be addressed is entered in bits 0 to 5 of the control byte.
Control byte in register mode (REG=1)
MSB
REG=1
W/R
A5
A4
A3
A2
A1
A0
REG = 0bin: Process data exchange
REG = 1bin: Access to register structure
W/R = 0bin: Read register
W/R = 1bin: Write register
A5..A0 = register address
Addresses A5...A0 can be used to address a total of 64 registers.
Register mode control byte
The control or status byte occupies the lowest address of a logical channel. The corresponding register values are located in the following 2 data bytes. (The BK2000 is an exception: here, an unused data byte is inserted after the control or status byte, and the register value is therefore placed on a word boundary).
Example 1:
Reading of register 8 in the BK2000 with a KL3022 and the end terminal:
If the following bytes are transferred from the controller to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Data out, low byte | Data out, high byte | Not used | Control byte
Value | 0xXX | 0xXX | 0xXX | 0x88
the terminal returns the following type identifier (0x0BBA corresponds to unsigned integer 3022).
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Data in, low byte | Data in, high byte | Not used | Status byte
Value | 0xCE | 0x0B | 0x00 | 0x88
Example 2:
Write register 31 in the BK2000 with an intelligent and the end terminal:
If the following bytes (code word) are transferred from the controller to the terminal,
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Data out, low byte | Data out, high byte | Not used | Control byte
Value | 0x35 | 0x12 | 0xXX | 0xDF
The code word is set, and the terminal returns the register address with bit 7 for register access as acknowledgment.
Byte | Byte 3 | Byte 2 | Byte 1 | Byte 0
Name | Data in, low byte | Data in, high byte | Not used | Status byte
Value | 0x00 | 0x00 | 0x00 | 0x9F


Examples of Register Communication

Access from the user program [image] Examples of Register Communication
Examples of Register Communication
The numbering of the bytes in the examples corresponds to the display without word alignment.
Additional information
•
Example 1: reading the firmware version from Register 9
•
Example 2: Writing to an user register


Example 1: reading the firmware version from Register 9

Access from the user program [image] Examples of Register Communication [image] Example 1: reading the firmware version from Register 9
Example 1: reading the firmware version from Register 9
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x89 (1000 1001bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 9 with 00 1001bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access. To change a register, write the required value into the output word.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x89 | 0x33 | 0x41
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the firmware version 0x3341 in the input data word (byte 1 and byte 2). This is to be interpreted as an ASCII code:
–
ASCII code 0x33 represents the digit 3
–
ASCII code 0x41 represents the letter A
The firmware version is thus 3A.


Example 2: Writing to an user register

Access from the user program [image] Examples of Register Communication [image] Example 2: Writing to an user register
Example 2: Writing to an user register
Code word
In normal mode all user registers are read-only with the exception of Register 31. In order to deactivate this write protection you must write the code word (0x1235) into Register 31. If a value other than 0x1235 is written into Register 31, write protection is reactivated. Please note that changes to a register only become effective after restarting the terminal (power-off/power-on).
I. Write the code word (0x1235) into Register 31.
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x12 | 0x35
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains the code word (0x1235) for deactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
II. Read Register 31 (check the set code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0x12 | 0x35
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the code word register in the input data word (byte 1 and byte 2).
III. Write to Register 32 (change contents of the feature register)
Output data
Byte 0: Control byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xE0 (1110 0000bin) | 0x00 | 0x02
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) contains the new value for the feature register.
SmallWarningYellow CAUTION
Observe the register description!
The value of 0x0002 given here is just an example!
The bits of the feature register change the properties of the terminal and have a different meaning, depending on the type of terminal. Refer to the description of the feature register of your terminal (chapter Register description) regarding the meaning of the individual bits before changing the values.
Input data (response from the Bus Terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!
IV. Read Register 32 (check changed feature register)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xA0 (1010 0000bin) | 0xXX | 0xXX
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 not set means: reading the register.
▪
Bits 0.5 to 0.0 indicate register number 32 with 10 0000bin.
▪
The output data word (byte 1 and byte 2) has no meaning during read access.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0xA0 (1010 0000bin) | 0x00 | 0x02
Explanation:
▪
The terminal returns the value of the control byte as a receipt in the status byte.
▪
The terminal returns the current value of the feature register in the input data word (byte 1 and byte 2).
V. Write Register 31 (reset code word)
Output Data
Byte 0: Control byte | Byte 1: DataOUT1, high byte | Byte 2: DataOUT1, low byte
0xDF (1101 1111bin) | 0x00 | 0x00
Explanation:
▪
Bit 0.7 set means: Register communication switched on.
▪
Bit 0.6 set means: writing to the register.
▪
Bits 0.5 to 0.0 specify the register number 31 with 01 1111bin.
▪
The output data word (byte 1 and byte 2) contains 0x0000 for reactivating write protection.
Input Data (answer of the bus terminal)
Byte 0: Status byte | Byte 1: DataIN1, high byte | Byte 2: DataIN1, low byte
0x9F (1001 1111bin) | 0xXX | 0xXX
Explanation:
▪
The terminal returns a value as a receipt in the status byte that differs only in bit 0.6 from the value of the control byte.
▪
The input data word (byte 1 and byte 2) is of no importance after the write access. Any values still displayed are invalid!


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com