FBB-x8x0 - Feldbus Box für RS232/RS485

BECKHOFF Feldbuskomponenten

Dokumentation zur

Feldbus Box für RS232 / RS485

Version 0.4
Datum: 30.10.2009


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Buskoppler als allgemeine Bezeichnung

Teile des vorliegenden Handbuches geben allgemeine Informationen über die Ethernet-Implementierung in Beckhoff Produkten.
Im folgenden wird daher oft der Begriff Buskoppler genutzt, der hier nicht nur die IP20-Produkte beschreibt, sondern auch die IP67-Module meint.


Das Feldbus Box System

Feldbus Box Module sind robuste Feldbusstationen für viele verschiedene Feldbus-Systeme. Sie verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Neben digitalen und analogen Ein- und Ausgängen samt Thermoelement- und RTD-Eingängen gibt es Inkrementalencoder-Interfaces für die Weg- und Winkelmessung sowie serielle Schnittstellen für die Lösung vielfältiger Kommunikationsaufgaben.

Signalanschluss in 3 Varianten

Die digitalen Ein-/Ausgänge können wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12-Variante vorgesehen.

Alle wichtigen Signalformen

Spezielle Ein-/Ausgangskanäle auf den Kombi-E/A-Module lassen sich wahlweise als Ein- oder Ausgang nutzen. Eine Konfiguration ist nicht erforderlich, da die Feldbusschnittstelle für jeden Kombikanal sowohl Eingangs- als auch Ausgangsdaten zur Verfügung stellt. Durch die Kombi-Module hat der Anwender alle Vorteile einer feinen Signal-Granularität.

Die Prozessor-Logik, die Eingangsbeschaltung sowie die Sensorversorgung werden aus der Steuerspannung gespeist. Die Lastspannung für die Ausgänge kann separat zugeführt werden. Bei Feldbus Boxen, in denen nur Eingänge zur Verfügung stehen, kann die Lastversorgung UP zur Weiterleitung optional angeschlossen werden.

Die Zustände der Feldbus Box, der Feldbusverbindung, der Spannungsversorgung sowie der Signale werden von LEDs angezeigt.

Die Beschriftungsstreifen lassen sich extern maschinell beschriften und können dann eingeschoben werden.

Kombinierbare Feldbus Boxen für mehr Flexibilität

Die Feldbus Box Serie umfasst neben der Kompakt Box auch erweiterbare Geräte, die Koppler Box und die Erweiterungsbox sowie intelligente Geräte, die SPS Boxen.

Kompakt Box

Die Kompakt Box stellt dem Feldbus die E/A-Daten der angeschlossenen digitalen und analogen Sensoren und Aktuatoren zur Verfügung.

Koppler Box

Die Koppler Box sammelt zusätzlich über eine störsichere LWL-Verbindung (IP-Link) E/A-Daten von den Erweiterungsboxen ein. Sie können bis zu 120 Erweiterungsboxen an eine Koppler Box anschließen. Es ergibt sich so ein verteiltes IP67 E/A-Netzwerk mit nur einer Feldbusschnittstelle.

Die Koppler Box erkennt die angeschlossenen Erweiterungsmodule selbsttätig in der Aufstart-Phase und mappt die E/A-Daten automatisch in das Feldbus-Prozessabbild – eine Konfiguration ist nicht erforderlich. Aus Sicht des Feldbusses stellt sich die Koppler Box samt allen vernetzten Erweiterungsboxen als ein einziger Busteilnehmer mit entsprechend vielen E/A-Signalen dar.

Die Koppler Box entspricht dem Buskoppler aus dem BECKHOFF Busklemmen-System. BECKHOFF Feldbus-Geräte der Schutzart IP 20 (Busklemmen) und IP 67 (Feldbus Box) können problemlos kombiniert werden - das Daten-Handling ist jeweils gleich.

IP-Link

IP-Link ist eine LWL-Verbindung mit 2 Megabit/s Übertragungsrate, die 1000 binäre E/A-Daten in ca. 1 ms schnell und sicher überträgt – kleinere Konfigurationen entsprechend schneller. Durch die hohe Nutzdatenrate ist gewährleistet, dass die Kopplung über IP-Link keine spürbare Einschränkung der Feldbus-Performance mit sich bringt.

Für die schnelle und einfache Konfektionierung der IP-Link-Kabel vor Ort wurden preisgünstige Steckverbinder in IP 67 Schutzart entwickelt. Der Anschluss erfordert kein Spezialwerkzeug und lässt sich schnell und einfach durchführen. Die IP-Link-Kabel sind alternativ auch mit vorkonfektionierten Steckern erhältlich.

Durch die getrennte Zuführung der Ausgangs-Spannungsversorgung lassen sich Ausgangsgruppen einzeln abschalten. Außerdem können problemlos unterschiedliche Potenziale innerhalb eines Erweiterungsringes aufgebaut werden, da IP-Link naturgemäß über eine optimale Potenzialtrennung verfügt.

Erweiterungsbox

Die Erweiterungsboxen decken wie die Kompakt Boxen das gesamte Spektrum der E/A-Signale ab und dürfen bis zu 15 m Abstand voneinander haben. Sie bauen hierbei besonders klein und führen zu besonders preiswerten E/A-Lösungen in hoher Schutzart. Auch hier sind die digitalen Ein-/Ausgänge wahlweise über 8 mm Schnapp-Steckverbinder, M8 Schraub-Steckverbinder oder M12 Schraub-Steckverbinder anschließbar. Analoge Signaltypen werden mit der M12-Variante ausgerüstet. Die Schnapp-Steckverbinder verriegeln formschlüssig und ergeben eine rüttelfeste Verbindung, während sich die Schraub-Steckverbinder durch eine hohe Zugfestigkeit auszeichnen.

SPS Box

Die SPS Box ist eine intelligentes Feldbus Box mit SPS-Funktionalität für dezentrale Vorverarbeitung der E/A-Signale. Hiermit lassen sich Applikationsteile aus der zentralen Steuerung auslagern. Deren CPU und der Feldbus werden entlastet. Dezentral Zählen, Regeln oder Schalten sind typische Anwendungen für die SPS-Box. Die Reaktionszeiten sind unabhängig von der Buskommunikation und der übergeordneten Steuerung.

Bei Bus- oder Steuerungsausfall ist ein Funktionserhalt (z.B. geordnete Überführung des Prozesses in einen sicheren Zustand) möglich.

Die Programmierung erfolgt mit TwinCAT nach IEC 61131-3. Fünf verschiedene Programmiersprachen stehen zur Verfügung:

  • Anweisungsliste (AWL)

  • Funktionsplan (FUP)

  • Kontaktplan (KOP)

  • Ablaufsprache (AS)

  • Strukturierter Text (ST).

Der Programm-Download erfolgt wahlweise über den Feldbus oder über die Programmierschnittstelle.

Es stehen umfangreiche Debug-Funktionalitäten (Breakpoint, Einzelschritt, Monitoring, etc.) zur Verfügung. SPS Box verfügt über einen leistungsfähigen 16 Bit Controller, 32/96 KByte Programmspeicher und 32/64 KByte Datenspeicher. Weiter stehen 512 Byte als nichtflüchtiger Speicher für remanente Merker zur Verfügung.

SPS Box mit IP-Link

Nahezu unbeschränkte E/A-Möglichkeiten ergeben sich durch die programmierbare SPS Box mit IP-Link. Aus dem SPS-Programm heraus lassen sich bis zu 120 Erweiterungsmodule mit über 2000 E/As direkt ansprechen. Die SPS Box eignet sich damit auch als autarke Kleinsteuerung zur Steuerung von Anlagenteilen oder kleiner Maschinen.


Feldbusübersicht

RS_Overview.jpg (123912 Byte)


Feldbus Box - Bezeichnungsübersicht

Die Bezeichnung der Feldbus Box Module ist wie folgt zu verstehen:
IXxxxy-zyyy

IX beschreibt die Bauform:

"IP" steht für die Bauform Kompakt Box.
"IL" steht für die Bauform Koppler Box (mit IP-Link).
"IE" steht für die Bauform Erweiterungsbox.

xxxy beschreibt die E/A-Beschaltung:

xxx bezeichnet die E/A-Eigenschaft:
"10x" - 8 x digitale Eingänge
"15x" - Zählermodul
"20x" - 8 x digitale Ausgänge
"23x" - 4 x digitale Eingänge und 4 x digitale Ausgänge
"24x" - 8 x digitale Eingänge und 8 x digitale Ausgänge
"25x" - PWM-Modul
"3xx" - 4 x analoge Eingänge
"4xx" - 4 x analoge Ausgänge
"5xx" - Inkremental-Encoder oder SSI-Geber
"6xx" - Gateway-Module RS232, RS422, RS485, TTY

y beschreibt den mechanischer Anschluss:
"0" steht für 8mm Schnappanschluss
"1" steht für M 8 Schraubanschluss
"2" steht für M 12 Schraubanschluss und
"9" steht für M23 Schraubanschluss

zyyy bezeichnet die Programmierbarkeit und das Feldbus-System:

z unterscheidet ob es sich um einen Slave oder einen programmierbare Slave handelt:
"B" - nicht programmierbar
"C" - programmierbar (SPS Box)

yyy steht für das Feldbus-System und den Bus-Anschluss:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS mit integriertem T-Stück
"400" - Interbus
"510" - CANopen
"518" - CANopen mit integriertem T-Stück
"520" - DeviceNet
"528" - DeviceNet mit integriertem T-Stück
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP mit RJ45 für den Bus-Anschluss
"901" - Ethernet TCP/IP mit M12 für den Bus-Anschluss
"903" - PROFINET
"905" - EtherNet/IP

Kompakt Box

Die Feldbus Boxe verfügen über vielfältige E/A-Funktionalität. Alle relevanten Industriesignale werden unterstützt. Die digitalen Ein-/Ausgänge können wahlweise über Ø 8 mm Schnapp-, M8 Schraub- oder über M12 Schraub-Steckverbinder angeschlossen werden. Für analoge Signale ist die M12 Variante verfügbar.

Je nach Modul kann der E/A-Teil und der Stromversorgungsteil unterschiedlich sein.

Koppler Box

Die Koppler Box gibt es in drei Varianten als IL230x-Bxxx. Diese unterscheidet sich von der Kompakt Box dadurch, dass diese Module eine Schnittstelle zu den sogenannten Erweiterungsboxen bietet. Diese Schnittstelle ist ein Sub-Bussystem auf LWL Basis den sogenannten IP-Link. Dieses leistungsfähige Sub-Bussytem kann bis zu 120 Erweiterungsboxen an einer Koppler Box verarbeiten.

Erweiterungsbox

Feldbusunabhängige Erweiterungsmodule, die nur an einer Koppler Box über IP-Link betrieben werden können.

SPS Box

Eine SPS Box unterscheidet sich von einer Koppler Box dadurch, dass sie in IEC 61131-3 programmierbar ist. Dadurch kann dieser Slave auch ohne Master autonom arbeiten, zum Beispiel für Steuerungs- oder Regelungsaufgaben.


Firm- und Hardware-Stand

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Hard- und Firmware-Stand. Die Eigenschaften werden weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben wie Module neue Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das diese Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand der Module können Sie anhand der mit einem D beginnenden Nummer auf der Seite des Moduls erkennen.

Syntax:

D . ww yy x y z u

ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel:

D.22081501

- Kalenderwoche 22
- des Jahres 2008
- Firmware-Stand Busplatine: 1
- Hardware Stand Busplatine: 5
- Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig)
- Hardware-Stand E/A-Platine: 1


Technische Daten

Technische Daten | IPxxxx-B800 | IL230x-B800
Erweiterungsmodule | - | max. 120 mit insgesamt 512 Bytes Ein- und 512 Byte Ausgänge
Digitale Peripheriesignale | entsprechend E/A-Variante | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale | entsprechend E/A-Variante | max. 252 Ein- und Ausgänge
Konfigurationsmöglichkeiten | über KS2000
Bus Teilnehmer | 69
Topologie | Linie
Übertragungsphysik | RS 485 (wie Profibus) abgeschirmtes, verdrilltes Kupferkabel
Max. Kabellänge | 1200 m
Protokoll | offenes dokumentiertes Protokoll
Softwaretool für das Protokoll | KS8000: stellt Active X Control, DLL oder Ni LabView Schnittstelle für Windows 95, 98, ME, NT, 2000, XP bereit
Baud-Rate | automatische Erkennung bis 38,4 kBaud
Stromversorgung | Steuerspannung: 24V DC (-15%/+20%); Lastspannung: entsprechend E/A Variante
Stromaufnahme Steuerspannung | 30 mA + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A- Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 1 x M12 5-polig Buchse (inverse Codierung)
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
Betriebstemperatur | 0°C ... +55°C
Lagertemperatur | -25°C ... +85°C
Vibrationsfestigkeit | gemäß IEC 68, Teil 2-6 / IEC 68, Teil 2-27
EMV | gemäß EN 50082-2 / EN 50081-2
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassung | UL E172151

Technische Daten | IPxxxx-B810 | IL230x-B810
Erweiterungsmodule | - | max. 120 mit insgesamt 512 Bytes Ein- und 512 Byte Ausgänge
Digitale Peripheriesignale | entsprechend E/A-Variante | max. 960 Ein- und Ausgänge
Analoge Peripheriesignale | entsprechend E/A-Variante | max. 252 Ein- und Ausgänge
Konfigurationsmöglichkeiten | über KS2000
Bus Teilnehmer | 1 (peer to peer)
Topologie | Linie
Übertragungsphysik | RS 232
Max. Kabellänge | 15 m
Protokoll | offenes dokumentiertes Protokoll
Softwaretool für das Protokoll | KS8000: stellt Active X Control, DLL oder Ni LabView Schnittstelle für Windows 95, 98, ME, NT, 2000, XP bereit
Baud-Rate | automatische Erkennung bis 38,4 kBaud
Stromversorgung | Steuerspannung: 24V DC (-15%/+20%); Lastspannung: entsprechend E/A Variante
Stromaufnahme Steuerspannung | 30 mA + Stromaufnahme Sensorversorgung, max. 0,5A
Stromaufnahme Lastspannung | entsprechend E/A- Variante
Anschluss Stromversorgung | Einspeisung: 1 x M8 Stecker 4-polig Weiterleitung: 1 x M8 Buchse 4-polig (außer IP/IE204x)
Anschluss Feldbus | 1 x M12 5-polig Buchse (inverse Codierung)
Potentialtrennung | Kanäle / Steuerspannung: nein zwischen den Kanälen: nein Steuerspannung / Feldbus: ja
Betriebstemperatur | 0°C ... +55°C
Lagertemperatur | -25°C ... +85°C
Vibrationsfestigkeit | gemäß IEC 68, Teil 2-6 / IEC 68, Teil 2-27
EMV | gemäß EN 50082-2 / EN 50081-2
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassung | UL E172151


Feldbusbox - Abmessungen

BECKHOFF Feldbus Box: Montage

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | Feldbus Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Zulassungen | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technische Daten | Kompakt- und Kopplerbox mit integriertem T-Stück
Abmessungen (H x B x T) | ca. 210 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm)
Gewicht | ca. 260 g - 290 g, je nach Modultyp

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technische Daten | Kompakt- und Kopplerbox
Abmessungen (H x B x T) | ca. 175 x 30 x 26,5 mm (Höhe bis Oberkante Feldbus-Buchse 30 mm, mit T-Stück ZS1031-2600 Höhe ca. 65 mm)
Gewicht | ca. 250 g - 280 g, je nach Modultyp

IExxxx

Technische Daten | Erweiterungsbox
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Gewicht | ca. 120 g - 200 g, je nach Modultyp


Befestigung

Achtung

Schützen Sie während der Montage der Module alle Anschlüsse, insbesondere die IP-Link-Anschlüsse vor Verschmutzung!

Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind!
Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden (Steckersets siehe Katalog)!

Die Feldbus Boxen werden mit zwei M3-Schrauben befestigt. Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher besitzen kein Gewinde. Beachten Sie bei der Montage, dass ein Y oder T-Stück für den Feldbusanschluss die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.

Der Abstand zwischen den Modulen sollte mindestens 4 cm betragen, damit der für das IP-Link-Kabel minimal zulässige Biegeradius von 50 mm nicht unterschritten wird. Die Erweiterungsmodule dürfen auch dicht aneinander gebaut werden, wenn Sie dabei folgendes beachten:

  • Der für das IP-Link-Kabel minimal zulässige Biegeradius darf nicht unterschritten werden.
  • Die Umgebungstemperatur darf 55°C nicht überschreiten.

Einbauvorschrift_IL_IE_Module.jpg (17147 Byte)

Montageschiene ZS5300-0001

Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Erweiterungs-Box-Module. Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3 Gewinden. Mittels M5 Schrauben (5,3 mm Langlöcher) kann die Schiene an der Maschine befestigt werden.

Die Schiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 Modulen. Sie kann applikationsspezifisch gekürzt werden.
Achtung Verwenden Sie zusammen mit Montageschiene ZS5300-0001 den IP-Link Direktsteckverbinder ZK1020-0101-1000 um den minimal zulässige Biegeradius (50 mm) des Standard-IP-Link-Kabels nicht zu unterscheiten.

IP-Link Direktsteckverbinder ZK1020-0101-1000

Der IP-Link Direktsteckverbinder ZK1020-0101-1000 ermöglicht die direkte Verbindung zweier Erweiterungs-Box-Module, zur einfachen Montage direkt nebeneinander.

Mit dem IP-Link Direktsteckverbinder kann der Montageabstand der Module zwischen 0 und 5 mm betragen.


Power Anschluss

Steuerspannung Us: 24V

Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.

Lastspannung UP: 24V

Die Lastspannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet (z.B. in Not-Aus-Fall), so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.

Weiterleitung der Versorgungsspannungen

Die Power-Anschlüsse IN und OUT sind im Modul gebrückt (nicht IP204x-Bxxx und IE204x). Somit können auf einfache Weise die Versorgungsspannungen Us und Up von Feldbus Box zu Feldbus Box weitergereicht werden.

Achtung Beachten Sie bei der Weiterleitung der Versorgungsspannung Us und Up jeweils, dass der maximal zulässige Strom von 4 A nicht überschritten wird!

Galvanische Trennung

Digitale Module

Bei den digitalen Ein-/Ausgabemodulen sind die Massen (GND) von Steuerspannung und Lastspannung verbunden!

Analoge Module

Bei den analogen Ein-/Ausgabemodulen sind diese Massen getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten. Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0...10V Eingängen eine beliebige Referenzspannung (0...30 V) an Up angeschlossen werden, diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer). Details der Spannungsversorgung bei Analogmodulen sind daher dem Kapitel Signalvarianten zu entnehmen.

Achtung Wenn Sie digitale und analoge Feldbus Boxen direkt über vierpolige Powerleitungen verbinden, so ist für die analogen Feldbus Boxen die galvanische Trennung der Analogsignale von der Steuerspannung nicht mehr gegeben!

Pinbelegung (nicht IP204x-Bxxx und IE204x)

Pinbelegung (IP204x-Bxxx und IE204x)

sbsupply2.gif (7053 Byte)

Siehe auch im Kapitel IP204x-Bxxx / IE204x Signalanschluss unter Potentialgruppen.


Zuleitung und Stromversorgung

Allgemein

Bei den Feldbus Boxen gilt für jedes Modul, das pro Pin nur maximal 4 A fließen dürfen. Dies gilt für sämtliche Anschlussvarianten S8, M 8 und M12.

Worauf müssen Sie achten

  • Stromverbrauch der Feldbus Boxen (siehe Kapitel Stromverbrauch)
  • Stromverbrauch der Sensoren
  • Stromverbrauch der Aktuatoren
  • Kabel Länge und Verluste auf den Leitungen (siehe Kapitel Leitungsverluste)
  • Wird die Powerleitung weitergeführt, ist darauf zu achten das der Strom nicht überschritten wird (siehe Punkte davor).

Hinweis:

Beispiel 1:

Werden zum Beispiel an einem IP2001-Bxxx alle 8 Ausgänge mit 0,5 A gleichzeitig belastet, darf in diesem Fall die Power-Weiterleitung nicht genutzt werden, da dies sonst zur Zerstörung des Anschlusses bzw. des Gerätes führen kann.

Beispiel 2:

An einem IP/IE204x die Kanäle 0...3 angeschlossen, so dürfen hier nur 2 der 4 Kanäle mit 2 A belastet werden.


Leitungsverluste

Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkablung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.

Beispiel:
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.


FBB E/A-Module - Stromverbrauch

BECKHOFF Feldbus Box: Verkabelung

Stromverbrauch

Für die Stromweiterleitung und der Absicherung der Module sowie bei der Betrachtung des Spannungsabfall auf der Powerleitungsversorgung ist es wichtig, den Stromverbrauch der einzelnen Module zu kennen. Die nachfolgende Tabelle enthält den Stromverbrauch bei 24 VDC.

Die Sensorversorgung bzw. der Strom für evtl. Ausgänge muss dazu addiert werden.

E/A-Type Kompakt-Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IP1000−Bxxx, IP1001−Bxxx, IP1002−Bxxx, IP1010−Bxxx, IP1011−Bxxx, IP1012−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP1502-Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2000−Bxxx, IP2001−Bxxx, IP2002−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2020−Bxxx, IP2021−Bxxx, IP2022−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2040−Bxxx, IP2041−Bxxx, IP2042−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2300−Bxxx, IP2301−Bxxx, IP2302−Bxxx, IP2310−Bxxx, IP2311−Bxxx, IP2312−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2320−Bxxx, IP2321−Bxxx, IP2322−Bxxx, IP2330−Bxxx, IP2331−Bxxx, IP2332−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2400−Bxxx, IP2401−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2512−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP3102−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3112−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3202−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP3312−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP4112−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP4132−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5009−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5109−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5209−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP6002−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6012−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6022−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
E/A−Type Koppler Box
Module | −B310 | −B510, −B520 | −B730, −B800, −B810
IL2300−Bxxx, IL2301−Bxxx, IL2302−Bxxx | Is = 100 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA
IL2300−Cxxx, IL2301−Cxxx, IL2302−Cxxx | Is = 100 mA Ip = 5 mA | − | −
E/A−Type Erweiterungsbox
Module |
IE1000, IE1001, IE1002, IE1010, IE1011, IE1012 | Is = 25 mA Ip = 5 mA
IE1502 | Is = 25 mA Ip = 5 mA
IE2000, IE2001, IE2002 | Is = 25 mA Ip = 5 mA
IE2020, IE2021, IE2022 | Is = 25 mA Ip = 5 mA
IE23xx, IE240x | Is = 25 mA Ip = 5 mA
IE2512 | Is = 25 mA Ip = 5 mA
IE2808 | Is = 40 mA Ip = 5 mA
IE3102 | Is = 55 mA Ip = 5 mA
IE3112 | Is = 55 mA Ip = 5 mA
IE3202 | Is = 40 mA Ip = 5 mA
IE3312 | Is = 40 mA Ip = 5 mA
IE4112 | Is = 40 mA Ip = 5 mA
IE4132 | Is = 40 mA Ip = 5 mA
IE5009 | Is = 55 mA Ip = 5 mA
IE5109 | Is = 55 mA Ip = 5 mA
IE6002 | Is = 40 mA Ip = 5 mA
IE6012 | Is = 40 mA Ip = 5 mA
IE6022 | Is = 40 mA Ip = 5 mA


RS232-Anschluss

Die M12-Buchse ist invers Codiert und besitzt 5 Pins. Pin 2, 3 und Pin 4 sind die Signale der RS232-Physik. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Pin 5 ist Shield, der kapazitiv mit der Masse der Feldbus Box verbunden ist.

Als Stecker kann der ZS1000-0610 verwendet werden.

Pinbelegung RS 232 Buchse

Bedeutung | M12 | 9 poliger D-Sub
n.c. | Pin 1 | Pin 1, 4, 6, 7, 8, 9
TxD | Pin 2 | Pin 2
GND | Pin 3 | Pin 5
RxD | Pin 4 | Pin 3
Shield | Pin 5 | D-Sub Buchse (Gehäuse)

RS485 Anschluss

Die M12-Buchse ist invers Codiert und besitzt 5 Pinne. Pin 2 und Pin 3 sind die Signale der RS485-Physik. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Pin 5 ist Shield, der kapazitiv mit der Masse der Feldbus Box verbunden ist.

Kabel und Stecker können aus dem Beckhoff Profibus Programm ausgewählt werden.

Pinbelegung RS485-Buchse

Bedeutung | M12 | 9 poliger D-Sub
+5 V DC | Pin 1 | Pin 6
TxD/RxD | Pin 2 | Pin 3
GND | Pin 3 | Pin 5
RxD/TxD | Pin 4 | Pin 8
Shield | Pin 5 | D-Sub Buchse (Gehäuse)


Verkabelung

RS 232 Verkabelung

Eine RS232-Verbindung besteht aus einem Master und einem Slave (Peer to Peer Verbindung). Als Kabel kann ein 3-adiges Kabel verwendet werden (plus Schirm). Der Anschluss der Feldbus Box erfordert einen Stecker ZS1000-0610. Die Gegenseite ist den den meisten Fällen ein Gerät mit D-Sub-Schnittstelle. Beachten Sie das RxD auf TxD und TxD auf RxD angeschlossen wird.

Längenausdehnungen

Baud-Rate in kBits/sec | 9,6 | 19,2 | 38,4
zulässige Leitungslänge in m | 15 | 15 | 15

RS 485 Verkabelung

Für die RS 485 Verkabelung können alle Profibus Kabel und Stecker eingesetzt werden.

Längenausdehnungen

Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.

Baud-Rate in kBits/sec | 9,6 | 19,2 | 38,4
zulässige Leitungslänge in m | 1200 | 1200 | 1200

Bussegment

Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem RS 485 Netzwerk sind 69 Teilnehmer erlaubt (als Repeater können Profibus-Repeater eingesetzt werden). Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen, dabei wird ein Repeater wie ein Teilnehmer angesehen.

IP-Link

Der IP-Link ist das Sub-Bussystem der Feldbus Boxen. Die Topologie ist eine Ringstruktur. Es gibt einen IP-Link Master, der in einem IP230x-Bxxx oder IP230x-Cxxx sich befindet. Die IE-Module sind Slaves. Es dürfen max. 120 Erweiterungsboxen angeschlossen werden. Der Abstand zwischen zwei Modulen darf 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass am letzten Modul wieder der IP-Link Master angeschlossen werden muss.


Verkabelung des IP-Link

IP-Link ist das Sub-Bussystem der Feldbus Boxen. Die Topologie ist eine Ringstruktur. In der Koppler Box (IL230x-Bxxx oder IL230x-Cxxx) befindet sich der IP-Link-Master. Die Erweiterungsboxen (IExxxx) sind Slaves. Es dürfen max. 120 Erweiterungsboxen angeschlossen werden. Berücksichtig werden muss aber auch der Adressraum, den der jeweilige Feldbus-Master zur Verfügung stellt. Der Abstand zwischen zwei Erweiterungsboxen darf 15 Meter nicht überschreiten. Beachten Sie bei Planung und Installation der Erweiterungsboxen, dass die letzte Erweiterungsbox des LWL-Rings wieder an der Koppler Box angeschlossen werden muss.

Aufbau/Topologie

Aufbau einer Linie

Hierbei wird nur jede zweite Erweiterungsboxen angeschlossen. Es ist hierbei zu beachten das sich die maximale Entfernung zwischen zwei Boxen halbiert.

Beispiel

Sie haben 4 Erweiterungsboxen (4 x 15 m = 60 m). Weil nur jede zweite Erweiterungsbox an der Hinleitung angeschlossen wird, ergibt sich für die letzte Erweiterungsbox eine maximale Entfernung von 30 Meter zum Koppler.

IL-Link Vekabelung Linie.jpg (13508 Byte)

Aufbau eines Rings

Hierbei dürfen die erste und die letzte Erweiterungsbox jeweils maximal 15 Meter von der Koppler Box entfernt sein.

IL-Link Vekabelung Ring.jpg (15983 Byte)

Technische Daten

IP-Link
 | IP-Link
Baud-Rate | 2 MBaud
Medium | Licht
Anzahl der Teilnehmer | max. 120
Länge zwischen zwei Stationen | 15 m
Kabel | Kunststoff-Lichtwellenleiter 1000 um - Kern 1-adrig, PU Schutzmantel mit Kevlarfaser Durchmesser 5,5 mm
IP-Link Stecker | zugelassen nur ZS1020-0010
Ausziehkräfte | 20 N - 30 N
IP-Link Kabel Z1101
 | Z1101
Außendurchmesser Nennwert | 5,5 mm
Mantelwanddicke | 1,4 mm
Faser | Kunststoff LWL 980/1000 µm aus PMMA
Ader | PE Aderhülle, Nenndurchmesser 2,2 mm
Temperatur | -20...+70°C
Außenmantelwerkstoff | PUR
Gewicht Nennwert kg/km | 25
Zugfestigkeit (DIN VDE 0888 Teil 100V erf.501) | dauernd 100 N kurzzeitig 400 N
Biegeradien | Radius minimal 50 mm
Wechselbiegefestigkeit (DIN VDE 0888 Teil100 Verf.509) | 30.000 Zyklen
Schleppkettenprüfung | Radius 10 X Dm., 2 Millionen Zyklen
Dämpfung bei 650 nm | < 200 dB/km


Konfektionierung des IP-Link-Kabels

Benötigtes Werkzeug:
  • Seitenschneider
  • Abiosolierwerkzeug
  • Schleifpapier (Körnung 600)
Hinweis Beachten Sie beim Abisolieren und bei der Montage,
  • das der Lichtwellenleiter nicht geknickt und
  • der minimale Biegeradius von 50 mm nicht unterschritten wird! Engere Biegeradien können den Lichtwellenleiter beschädigen.
  • während der Montage ist es hilfreich, die Ader gegen Verschieben zu fixieren. Dies geht am einfachsten, indem Sie die LWL-Leitung mittels einer Schlaufe in der Hand halten (siehe Bild). Die kurzzeitige Unterschreitung des Biegeradius führt zu keiner bleibenden Dämpfung der Leitung.

Verwenden Sie zusammen mit Montageschiene ZS5300-0001 den IP-Link Direktsteckverbinder ZK1020-0101-1000 um den minimal zulässige Biegeradius (50 mm) des Standard-IP-Link-Kabels nicht zu unterscheiten.

Fixierung der IP-Link-Leitung zur Abisolierung

IP-Link-Stecker

IP-Link-Stecker (1) mit Kappe (2)

Kabelende vorbereiten

IP-Link Stecker Kabel.jpg (36044 Byte)

  • Schieben Sie zuerst die Kappe des IP-Link-Steckers (2) auf das Lichtwellenleiterkabel.
  • Kürzen Sie den orange-farbenen Außenmantel (A) um ca. 23 mm, ohne dabei die darunter liegenden Kevlar-Fasern (K) zu beschädigen.
  • Kürzen Sie die Kevlar-Fasern (K) auf ca. 19 mm.
  • Legen Sie die gelbe Kevlar-Fasern (K) nach hinten über den Außenmantel (A) zurück.
  • Kürzen Sie den schwarzen Adernmantel (U) um ca. 17 mm, ohne dabei den darunter liegenden Lichtwellenleiter (L) zu beschädigen.

Montage des IP-Link-Steckers

  • Schieben Sie den IP-Link-Stecker (1) vorsichtig auf das Lichtwellenleiterkabel, bis er gegen die über den Außenmantel geschlagenen Kevlar-Fasern stößt.
  • Schrauben Sie den Stecker im Uhrzeigersinn so weit auf den Außenmantel, bis er sich von Hand nicht weiter weiter drehen lässt (handfest). Verwenden Sie dazu kein Werkzeug! Der Stecker ist so konzipiert, dass er dabei in den schwarzen Adernmantel (U) ein Gewinde schneidet.
    Bei exakter Abisolierung steht der Lichtwellenleiter jetzt ca. 8 mm vorne aus dem IP-Link-Stecker (1) heraus.
  • Schneiden Sie die evtl. hinten aus dem IP-Link-Stecker herausstehenden Kevlar-Fasern ab, ohne den Außenmantel zu beschädigen.
  • Schieben sie die Kappe (2) auf dem Lichtwellenleiterkabel von hinten gegen den IP-Link-Stecker (1), bis sie darauf einrastet.
  • Schneiden Sie den vorne aus dem IP-Link-Stecker herausstehenden Lichtwellenleiter ca. 2 mm vor der Steckerspitze ab. Achtung, nicht kürzer schneiden, da die Faser sehr spröde ist und bis in den Stecker hinein absplittern könnte!
  • Schleifen Sie den Lichtwellenleiter mit Schleifpapier von 600er-Körnung, bis er nur noch ca. 0,4 mm aus der Steckerspitze heraussteht. Schleifen dabei den Stecker nicht an!
  • Entfernen Sie vorhandenen Schleifstaub und evtl. den entstandenen Grat.

Faserenden prüfen (Sichtkontrolle)

Überprüfen Sie die geschliffenen Faserenden:

  • Das Ende des Lichtwellenleiters muss rechtwinkelig zur Steckerführung eine saubere, plane Fläche aufweisen, die ca. 0,4 mm aus der Steckerspitze heraussteht.

  • Richten Sie ein Kabelende auf eine Lichtquelle. Am anderen Kabelende dürfen in der leuchtenden Faser keine Kratze, Risse oder Absplitterungen zu sehen sein.

Bestellhinweis

ZS1020-0010: IP-Link-Stecker, Verpackungseinheit 1 Stück
ZS1021-0010: IP-Link-Stecker, Verpackungseinheit 10 Stück


Anlaufverhalten der Feldbus Box

Nach dem Einschalten prüft die Feldbus Box ihren Zustand, konfiguriert (wenn vorhanden) den IP-Link ist und erstellt anhand der Erweiterungsmodule eine Aufbauliste. Wenn die Feldbus Box eine dezentrale Steuerung besitzt (IL230x-C310) wird nach einer erfolgreichen Aufbauliste die lokale SPS gestartet.
Beim Hochlauf des Moduls leuchten und blinken die E/A LEDs. Im fehlerfreien Zustand sollte nach ca. 2-3 sec keine E/A LED mehr Blinken. Sollte ein Fehler vorliegen, hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose LEDs).

Start_List.gif (8211 Byte)


Adresse

Die Adresse der seriellen Feldbus Box wird über zwei Drehwahlschalter hinter der Klarsichtabdeckung eingestellt. Die Default-Einstellung beträgt 11. Es sind die Adressen von 01 bis 69 zulässig. Dabei darf jede Adresse im Netzwerk nur einmal vorkommen.

Die Adresse wird im ausgeschalteten Zustand der Feldbus Box geändert. Lösen Sie dafür die Abdeckung, und verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Achte Sie dabei darauf, dass die Schalter richtig einrasten. Der linke Schalter ist der Zehner Multiplikator und der rechte Schalter der Einer Multiplikator. Die Adressänderung wird aktiv, sobald das Gerät eingeschaltet wird.

Beispiel

Sie wollen Adresse 34 einstellen.
Linker Drehwahlschalter 3
Rechter Drehwahlschalter 4

AdressePB.jpg (19493 Byte)


Baud-Rate

Die Feldbus Box besitzt eine automatische Baudraten-Erkennung. Nach Einschalten der Versorgungsspannung sucht die Feldbus Box die anliegende Baudrate und speichert sie, solange die Versorgungsspannung anliegt.

Hinweis Wenn Sie die Baudrate ihres Masters ändern, müssen Sie die Feldbus Box einmal aus und wieder einschalten um die automatische Baudraten-Erkennung erneut zu starten.

Längenausdehnungen RS 232

Baudrate in kBits/sec | 9,6 | 19,2 | 93,75
zulässige Leitungslänge in m | 15 | 15 | 15

Längenausdehnungen RS 485

Baudrate in kBits/sec | 9,6 | 19,2 | 93,75
zulässige Leitungslänge in m | 1200 | 1200 | 1200


Mapping der Feldbus Boxen

Die Feldbus Boxen besitzen einen Speicher, in dem die Prozessdaten gespeichert werden und die vom Feldbusmaster ausgelesen bzw. beschrieben werden. Die Anzahl der Daten und die Art der Daten hängen von der Art der eingesetzten Feldbus Box ab. Die Kompakte Feldbus Boxen besitzt immer die gleiche Anzahl an Daten. Die Koppler Box hat ein variables Mapping, das von Art und Anzahl der verbundenen Erweiterungs-Boxen abhängt.

Bitorientierte Feldbus Boxen

Die bitorientierten Feldbus Boxen besitzen immer die gleiche Anzahl von Ein oder/und Ausgängen. Diese können nicht verändert werden und sind fix.

Modul | Eingänge [Bit] | Ausgänge [Bit]
IP10xx-B8x0 IE10xx | 8 | -
IP20xx-B8x0 IE20xx | - | 8
IP23xx-B8x0 IE23xx | 8 (wobei das High-Nibbel nicht benutzt wird, letzen 4 Bit) | 8 (wobei das High-Nibbel nicht benutzt wird, letzten 4 Bit)
IP240x-B8x0 IE240x | 8 | 8

Byteorientierte Feldbus Boxen

Die byteorientierten Feldbus Boxen können unterschiedlich parametriert werden. In der Tabelle ist der Default-Wert eingetragen.

Modul | Eingänge [Byte] | Ausgänge [Byte]
IP15xx-B8x0 IE15xx | 6 | 6
IP25xx-B8x0 IE25xx | 6 | 6
IP3xxx-B8x0 IE3xxx | 8 | -
IP41xx-B8x0 IE41xx | - | 8
IP5xxx-B8x0 IE5xxx | 6 | 6
IP6xxx-B8x0 IE6xxx | 4 | 4


Mapping einer IL230x-B310

BECKHOFF Feldbuskomponenten: Mapping

Mapping einer IL230x-B8x0

Die IP-Link Module beginnen immer mit einem IL230x-Bxxx und einer Anzahl (max.120) Erweiterungsmodule. Das Mapping hängt von der Art und Anzahl der angeschlossenen Erweiterungsmodule ab.

Regel:
In des Prozessabbild werden erst alle byteorientierten Module eingetragen in der Reihenfolge, wie sie im IP-Link Ring eingetragen sind. Als nächstes folgen die digitalen Module in der Reihenfolge wie diese im Ring liegen, die am Ende auf 8 Bit aufgerundet werden.

Beispiel 1:
  1. IL2301-B8x0
  2. IE1001
  3. IE1002
  4. IE2042
Modul | Position | Input | Output
IL2301-B8x0 | 1 | %IX0.0 - 0.3 | %QX0.0 - 0.3
IE1001 | 2 | %IX0.4 - 1.3 |
IE1002 | 3 | %IX1.4 - 2.3 |
IE2042 | 4 |  | %QX0.4 - 1.3
Aufrundung |  | %IX2.4 - 3.7 (keine Funktion) | %QX1.4 - 1.7 (keine Funktion)

Die seriellen Boxen arbeitet immer mit einer Größe von 16 Bit oder einem Wort. In diesem Beispiel wird ein Wort angefangen und wird leer aufgefüllt. Diese letzten Bits haben keine Funktion und sind immer "0", werden aber vom Protokoll übertragen.

Beispiel 2:
  1. IL2301-B8x0
  2. IE1001
  3. IE3312
  4. IE3112
  5. IE4112
  6. IE2302
  7. IE2042
Modul | Position | Input | Output
IE3312 | 3 | %IB0 - 7 |
IE3112 | 4 | %IB8 - 15 |
IE4112 | 5 |  | %QB0 - 7
IL2301-B8x0 | 1 | %IX16.0 - 16.3 | %QX8.0 - 8.3
IE1001 | 2 | %IX16.4 - 17.3 |
IE2302 | 6 | %IX17.4 - 17.7 | %QX8.4 - 8.7
IE2042 | 7 |  | %QX9.0 - 9.7


Konfigurations

BECKHOFF Feldbus Box: Konfiguration

Konfiguration

Buskoppler oder Feldbus Box ermitteln nach dem Einschalten die Konfiguration der angeschlossenen Ein-/Ausgangsklemmen. Die Zuordnung zwischen physikalischen Steckplätzen der Ein/Ausgangskanäle und den Adressen des Prozessabbilde wird vom Buskoppler / Feldbus Box automatisch durchgeführt. Unterschieden wird hier nach bitorientierter (digitale) und byteorientierter (analoge, bzw. komplexe) Signalverarbeitung. Der Buskoppler / Feldbus Box schreibt zuerst die byteorientierten und daran anschließend die bitorientierten Busklemmen in das Prozessabbild.

Kurzübersicht Busklemmen/Feldbus Boxen (Technische Änderungen und Ergänzungen vorbehalten)

Busklemmen
byteorientierte Busklemmen | bitorientierte Busklemmen
KL1501, KL2502, KL3XXX, KL4XXX, KL5XXX, KL6XXX | KL10XX, KL11XX, KL12XX, KL17XX, KL20XX, KL21XX, KL22XX, KL26XX, KL9110, KL9160, KL9210, KL9260
Feldbus Boxen
byteorientierte Feldbus Boxen / Feldbus Boxen | bitorientierte Feldbus Boxen
IP/IE1501, IP/IE25x2, IP/IE3xx2, IP/IE4xx2, IP/IE5xx2, IP/IE6xx2 | IP/IE1xxx, IPIE2xxx

Bei der Master-Konfiguration ist zu beachten, dass zuerst alle byteorientierte Busklemmen und Feldbus Boxen in der Reihenfolge wie sie physikalisch gesteckt sind einzutragen sind. Dabei wird nicht nach Eingangsklemmen und Ausgangsklemmen unterschieden. Als nächstes folgen dann die bitorientierten Busklemmen. Diese werden zu einem ganzen Wort aufgerundet, d.h. 12 digitale Signale entsprechend 12 Bit werden auf ein Wort aufgerundet.. Die restlichen vier Bit werden automatisch mit Nullen aufgefüllt.

Anzahl Bits (In-, Output-Kanäle) | Bedeutung im Prozessabbild
16 In | nur Nutzdaten
24 In / 8 Out | Nutzdaten zzgl. Control- und Status-Byte (nur bei KL3XXX)
8 In / 24 Out | Nutzdaten zzgl. Control- und Status-Byte (nur bei KL4XXX)
24 In / 24 Out | vollständiges Prozessabbild


Allgemeine Registerbeschreibung

Bei den komplexen Modulen können verschiedene Betriebsarten bzw. Funktionalitäten eingestellt werden. Die Allgemeine Registerbeschreibung erläutert den Inhalt der Register, die bei allen komplexen Modulen identisch sind. Die modulspezifischen Register werden in dem darauffolgendem Kapitel erklärt.
Der Zugriff auf die internen Register der Module wird im Kapitel Register-Kommunikation beschrieben.

Allgemeine Registerbeschreibung

Komplexe Module die einen Prozessor besitzen, sind in der Lage mit der übergeordneten Steuerung bidirektional Daten auszutauschen. Diese Module werden im folgenden als intelligente Module bezeichnet. Zu ihnen zählen die analogen Eingänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), die analogen Ausgänge (0 bis 10 V, -10 bis 10 V, 0 bis 20 mA, 4 bis 20 mA), serielle Schnittstellenmodule (RS485, RS232, TTY, Datenaustausch-Module), Zähler-Module, Encoder-Interface, SSI-Interface, PWM-Module und alle anderen parametrierbare Module.

Alle intelligenten Modulen besitzen intern eine in ihren wesentlichen Eigenschaften identisch aufgebaute Datenstruktur. Dieser Datenbereich ist wortweise organisiert und umfasst 64 Speicherplätze. Über diese Struktur sind die wesentlichen Daten und Parameter der Module les- und einstellbar. Zusätzlich sind Funktionsaufrufe mit entsprechenden Parametern möglich. Jeder logische Kanal einer intelligenten Module besitzt eine solche Struktur (4-Kanal analoge Module besitzen also 4 Registersätze).

Diese Struktur gliedert sich in folgende Bereiche:

Bereich | Adresse
Prozessvariablen | 0-7
Typ-Register | 8-15
Hersteller- Parameter | 16-30
Anwender- Parameter | 31-47
Erweiterter Anwenderbereich | 48-63

Register R0-R7 (im internen RAM des Moduls)

Die Prozessvariablen können ergänzend zum eigentlichen Prozessabbild genutzt werden und sind in ihrer Funktion Modulspezifisch.

R0-R5

Diese Register besitzen eine vom Modul-Typ abhängige Funktion.

R6

Diagnose-Register: Das Diagnose-Register kann zusätzliche Diagnose-Information enthalten. So werden z.B. bei seriellen Schnittstellenmodulen Paritäts-Fehler, die während der Datenübertragung aufgetreten sind, angezeigt.

R7

Kommandoregister

  • High-Byte_Write = Funktionsparameter
  • Low-Byte_Write = Funktionsnummer
  • High-Byte_Read = Funktionsergebnis
  • Low-Byte_ Read = Funktionsnummer

Register R8-R15 (im internen ROM des Moduls)

Die Typ- und Systemparameter sind fest vom Hersteller programmiert und können vom Anwender nur gelesen und nicht verändert werden.

R8

Feldbus Box Typ: Der Feldbus Box Typ in Register R8 wird zur Identifizierung der Feldbus Box benötigt.

R9

Softwareversion x.y.: Die Software-Version kann als ASCII-Zeichenfolge gelesen werden.

R10

Datenlänge: R10 beinhaltet die Anzahl der gemultiplexten Schieberegister und deren Länge in Bit. Der Buskoppler sieht diese Struktur.

R11

Signalkanäle: Im Vergleich zu R10 steht hier die Anzahl der logisch vorhandenen Kanäle. So kann z.B. ein physikalisch vorhandenes Schieberegister durchaus aus mehreren Signalkanälen bestehen.

R12

Minimale Datenlänge: Das jeweilige Byte enthält die minimal zu übertragene Datenlänge eines Kanals. Ist das MSB gesetzt, so ist das Control/Status-Byte für die Funktion des Moduls nicht zwingend notwendig, und wird bei entsprechender Konfiguration des Buskopplers nicht zur Steuerung übertragen. Die Information steht

  • bei einem Ausgangsmodul im High-Byte
  • bei einem Eingangsmodul im Low-Byte.
R13

Datentypregister

Datentypregister | Beschreibung
0x00 | Modul ohne gültigen Datentyp
0x01 | Byte-Array
0x02 | Struktur 1 Byte n Bytes
0x03 | Word-Array
0x04 | Struktur 1 Byte n Worte
0x05 | Doppelwort-Array
0x06 | Struktur 1 Byte n Doppelworte
0x07 | Struktur 1 Byte 1 Wort
0x08 | Struktur 1 Byte 1 Doppelwort
0x11 | Byte-Array mit variabler logischer Kanallänge
0x12 | Struktur 1 Byte n Bytes mit variabler logischer Kanallänge (z.B. 60xx)
0x13 | Word-Array mit variabler logischer Kanallänge
0x14 | Struktur 1 Byte n Worte mit variabler logischer Kanallänge
0x15 | Doppelwort-Array mit variabler logischer Kanallänge
0x16 | Struktur 1 Byte n Doppelworte mit variabler logischer Kanallänge
R14

reserviert

R15

Alignment-Bits (RAM): Mit den Alignment-Bits wird das Analogmodul im Prozessabbild auf eine Bytegrenze gelegt.

Register R16-R30 (Hersteller-Parameter, serielles EEPROM)

Die Hersteller-Parameter werden vom Hersteller für jeden Modultyp modulspezifisch festgelegt, können jedoch mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Hersteller-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Hersteller-Parameter müssen Sie zuvor in Register R31 ein Code-Wort setzen.

Register R31-R47 (Anwendungs-Parameter, serielles EEPROM)

Die Anwender-Parameter sind Modulspezifisch. Sie können mit der Konfigurations-Software KS2000 oder über Registerkommunikation durch die Steuerung geändert werden. Die Anwender-Parameter sind spannungsausfallsicher im seriellen EERPOM der Klemme gespeichert. Zu Änderung der Anwender-Parameter müssen Sie zuvor in Register R31 das Anwender-Code-Wort setzen.

R31

Code-Wort-Register im RAM: Damit Parameter im Anwender-Bereich geändert werden können muss hier das Code-Wort 0x1235 eingetragen werden. Wird ein abweichender Wert in dieses Register eingetragen, so wird der Schreibschutz gesetzt. Bei inaktivem Schreibschutz wird das Code-Wort beim Lesen des Register zurückgegeben, ist der Schreibschutz aktiv enthält das Register den Wert Null.

R32

Feature-Register: Dieses Register legt die Betriebsarten der Klemme fest. So kann z.B. bei den analogen E/A-Modulen eine anwenderspezifische Skalierung aktiviert werden.

R33 bis R63

Klemmenspezifische Register: Diese Register sind vom Klemmentyp abhängig.

Register R47 bis R63 (Registererweiterung für zusätzliche Funktionen)

Diese Register sind für zusätzliche Funktionen vorgesehen.


Aktivieren des komplexen Mappings

Um die Registerkommunikation nutzen zu können, muss diese bei den IPxxxx-B8x0 / IL230x-B8x0 mit der KS2000-Software eingestellt werden
(aktivieren Sie dazu Settings/ProzessData1/Auswertung komplexer Klemmen ).


Beispiel für Register-Kommunikation

Control-Byte

Das Control-Byte befindet sich im Ausgangsabbild und kann gelesen oder beschrieben werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Registerkommunikation eingeschaltet: Die ersten zwei Byte der Nutzdaten werden nicht für den Prozessdatenaustausch verwendet, sondern in den Registersatz der Feldbus Box geschrieben oder daraus gelesen.
6 | R/W | 0bin | Read: Das Register soll gelesen werden ohne es zu verändern.
 |  | 1bin | Write: Das Register soll beschrieben werden.
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben werden soll. Es sind 64 Register adressierbar.
Status-Byte

Das Status-Byte befindet sich im Eingangsabbild und kann nur gelesen werden.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | Registernummer
Bit | Name | Beschreibung
7 | REG | 1bin | Quittung Registerzugriff
6 | R | 0bin | Read
5-0 | Registernummer | Nummer des Registers, das gelesen oder beschrieben wurde.

Beispiel 1

Lesen des Registers 8 von KL3204 oder IP/IE3202
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 gesetzt bedeutet Register-Kommunikation aktiv
Bit 0.6 nicht gesetzt bedeutet lesen des Registers.
Bit 0.5 bis Bit 0.0 geben mit 001000bin die Registernummer 8 an.
Das Ausgangsdatenwort (Byte 1 und Byte 2) ist beim lesenden Zugriff ohne Bedeutung. Will man ein Register verändern, so schreibt man in das Ausgangswort den gewünschten Wert hinein.

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x88 | 0x0C | 0x84

Die Klemme/Box liefert im Eingangsdatenwort (Byte 1 und Byte 2) die Typ-Bezeichnung 0x0C84 (entspricht unsigned Integer 3204) zurück .

Besonderheit bei der Bezeichnung von Feldbus Boxen:
Die letzte Ziffer des zurückgegebenen unsigned Integer (3204) entspricht nicht der letzten Ziffer der Feldbus Box-Bezeichnung (3202), die für die Anschlussvariante (0 für S8, 1 für M8 und 2 für M12) steht. Sie gibt stattdessen die Anzahl der Kanäle wieder (IE3204 besitzt 4 Kanäle).

Hinweis Damit Register beschreiben werden können, müssen Sie zuvor das Codewort 0x1235 in Register 31 schreiben, um den Schreibschutz zu deaktivieren. Das Schreiben eines Wertes ungleich 0x1235 in Register 31 aktiviert den Schreibschutz wieder.
Beachten Sie das einige Einstellungen in den Registern erst nach einem Neustart (Power-Off/Power-ON) des Moduls übernommen werden.

Beispiel 2

Ablauf einer Register-Kommunikation zum ändern eines Register.

1. Schreiben des Register 31 (Codewort setzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x12 | 0x35

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX
2. Lesen des Register 31 (gesetztes Codewort überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0x9F | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0x12 | 0x35
3. Schreiben des Register 32 (Register ändern)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)e
0xE0 | 0x00 | 0x02

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0xXX | 0xXX
4. Lesen des Register 32 (geändertes Register überprüfen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xA0 | 0xXX | 0xXX

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0xA0 | 0x00 | 0x02
5. Schreiben des Register 31 (Codewort zurücksetzen)
Byte 0 (Control-Byte) | Byte 1 (Data Out, High-Byte) | Byte 2 (Data Out, Low-Byte)
0xDF | 0x00 | 0x00

Antwort des Moduls/Busklemme

Byte 0 (Status-Byte) | Byte 1 (Data In, High-Byte) | Byte 2 (Data In, Low-Byte)
0x9F | 0xXX | 0xXX


Datenrahmen

Beschreibung | Wert
Datenbits | 8
Stopbits | 1
Baudrate | automatische Erkennung 9600, 19200, 38400 Baud
Parity | gerade


Topologie

RS232-Topologie

RS 232 Master, über Kabel mit einem IP/ILxxxx-B810 Modul verbunden

RS232_topologie1.jpg (3421 Byte)

RS 232 Master, über eine Funkstation mit mehreren IP/ILxxxx-B810 Modulen verbunden

RS232_topologie2.jpg (11363 Byte)

RS485-Topologie

RS 485 Master, über Kabel mit mehren IP/ILxxxx-B800 Modulen verbunden

RS485_topologie1.jpg (11127 Byte)


Protokollbeschreibung

Übertragungsprotokoll

Die Datenkommunikation mit dem Buskoppler/Feldbus Box erfolgt über ein einfaches Übertragungsprotokoll. Im Prozessdatenaustausch mit BK8x00/IPxxxx-B8x0 wird immer das gesamte Prozessabbild übertragen, d.h. bei einem Request des Masters erhält der Buskoppler/Feldbus Box die gesamten Ausgangsdaten und sendet daraufhin in der Response die aktuellen Prozesseingangsdaten an den Master. Dabei erfolgt die Datenkommunikation

  • vom Buskoppler zu den einzelnen Busklemmen über den K-Bus.
  • von Koppler Box zu den einzelnen Erweiterungsmodulen über IP-Link.

Der Zugriff auf die E/A-Signale der Klemmen/Erweiterungsmodule geschieht in der Defaulteinstellung von Buskopplers/Feldbus Box asynchron (Betriebsart freilaufend). Mit der Konfigurationssoftware KS2000 können Sie die Betriebsart auf synchron umstellen. In der synchronen Betriebsart geschieht der Zugriff von Buskopplers/Feldbus Box auf die Busklemmen/Erweiterungsmodule synchron zum Zugriff der Steuerung auf den Buskoppler/Feldbus Box.

Die Datenpakete werden in einem festen Format als Binärstring übertragen. Der Datenrahmen ist fest auf 8 Datenbits, even Parity und 1 Stopbit eingestellt (8E1). Die Baudrate ist auf 38400 Baud voreingestellt.

Die Stationsadressen werden auf Buskoppler/Feldbus Box über zwei Drehschalter eingestellt. Ist die Adresse 0 eingestellt arbeitet der BK8x00/IPxxxx-B8x0 als Master und der Slave Buskoppler/Feldbus Box muss die Adresse 1 erhalten.

Request

Der Master sendet dem Slave im Request die zu übertragenen Prozessausgangsdaten. Der Slave überträgt in der Response seinen Status sowie seine Prozesseingangsdaten.

Byte | Beschreibung | zulässiger Wertebereich
0 | Startkennung | "P" (0 x 50 hex)
1 | Anzahl der Prozessdatenausgangsworte | 0..255
2 | Message Ident | 0..255
3 | Multipoint Adresse | 0..99 beim BK8x00 0..69 beim IP/ILxxxx-B8x0
4 + 2 x n n = 0...125 | Prozessdatenausgang: Low Byte | 0..255
5 + 2 x n | Prozessdatenausgang: High Byte | 0..255
6 + 2 x n +1 | Prüfsumme | 0..255

Startkennung

Die Startkennung besteht aus einem Byte und kennzeichnet den Beginn eines Datenpaketes.

Anzahl der Prozessdatenausgangsworte

Die Anzahl der Prozessdatenausgangsworte gibt die Größe des Ausgangsprozessabbilds des angesprochenen Buskopplers/Feldbus Box in Worten an. Ist die Byte-Anzahl des Prozessabbildes ungerade muss aufgerundet werden. Sollen nur die Prozesseingangsdaten des Buskopplers/Feldbus Box gelesen werden ist hier eine Null einzutragen.

Message Ident

Der Message Ident ist ein beliebiger Wert der vom Empfänger im Antwortstring zurückgeliefert wird, so dass der Sender empfangene Strings, den Gesendeten zuordnen kann.

Multipoint Adresse

Die Multipoint Adresse spezifiziert den Empfänger. Die Adresse muss einen Wert ungleich 0 haben, da 0 die Masteradresse ist. Bei den Feldbus Boxen ist darauf zu achten, dass Adressen größer 69 für eine Adressierung nicht zugelassen sind.

Prozessdatenausgang

Die Prozessdatenausgänge werden als Datenworte im Intel-Format eingetragen.

Prüfsumme

Die Prüfsumme wird durch Aufaddieren der Inhalte der einzelnen Bytes gebildet (gesamte Request String, ohne Prüfsummenbyte). Ein evtl. Überlauf wird nicht berücksichtigt.

Response

Der Buskoppler/Feldbus Box antwortet in seiner Response auf die Anforderung durch den Master.

Byte | Beschreibung | Wertebereich
0 | Startkennung | "p" (0 x 70 hex)
1 | Anzahl der Prozessdatenausgangsworte | 0..255
2 | Message Ident | 0..255
3 | Multipoint Adresse | 0..99 beim BK8x00 0..69 beim IP/ILxxxx-B8x0
4 | Status-Byte | 0..255
5 + 2 x n n = 0...125 | Prozessdatenausgang Low Byte | 0..255
6 + 2 x n | Prozessdatenausgang High Byte | 0..255
7 + 2 x n +1 | Prüfsumme | 0..255

Startkennung

Die Startkennung besteht aus einem Byte und kennzeichnet den Beginn eines Datenpaketes.

Anzahl der Prozessdatenausgangsworte

Die Anzahl der Prozessdatenausgangsworte gibt die Größe des Ausgangsprozessabbildes des angesprochenen Buskopplers/Feldbus Box in Worten an. Ist die Byte-Anzahl des Prozessabbildes ungerade muss aufgerundet werden. Sollen nur die Prozesseingangsdaten des Buskopplers/Feldbus Box gelesen werden ist hier eine Null einzutragen.

Message Ident

Der Message Ident ist ein beliebiger Wert der vom Empfänger im Antwortstring zurückgeliefert wird, so dass der Sender empfangene Strings den gesendeten zuordnen kann.

Multipoint Adresse

Die Multipoint Adresse spezifiziert den Empfänger. Die Adresse muss einen Wert ungleich 0 haben, da 0 die Masteradresse ist. Bei den Feldbus Boxen ist darauf zu achten, dass Adressen größer 69 für eine Adressierung nicht zugelassen sind.

Status-Byte (SB)

Bit | Bedeutung
SB.0 | 1bin | Es ist ein Fehler in der Datenkommunikation mit den Busklemmen/Erweiterungsmodulen aufgetreten.
SB.1 | 1bin | Konfigurationsfehler
SB.2 | - | reserviert
SB.3 | - | reserviert
SB.4 | 1bin | Falsche Prozessdatenausgangslänge: Die empfangene Anzahl der Prozessausgangswörter ist ungleich der physikalisch vorhandenen Datenlänge.
SB.5 | - | reserviert
SB.6 | - | reserviert
SB.7 | - | reserviert

Prozessdatenausgang

Die Prozessdateneingänge werden als Datenworte im Intel-Format eingetragen.

Prüfsumme

Die Prüfsumme wird durch Aufaddieren der Inhalte der einzelnen Bytes gebildet (gesamter Request String, ohne Prüfsummenbyte). Ein evtl. Überlauf wird nicht berücksichtigt.


Kommunikationssoftware KS8000

ks8000.gif (459 Byte)

Die Beckhoff Kommunikations-Library KS8000 stellt Funktionalitäten zur Verfügung, mit denen auf einfache Weise über eine serielle PC-Schnittstelle mit den seriellen Buskopplern (BK8000, BK8100, IP/ILxxxx-B8x0) kommuniziert werden kann. Die KS8000 ist in Form eines OCX mit sämtlichen Programmiersprachen einsetzbar, die mit den Spezifikationen des Component Object Modell (COM) von Microsoft arbeiten ( VC++, Visual Basic ab Vers 4.0, Delphi, Java, etc). Zusätzlich verfügt die KS8000-Library über eine DLL-Schnittstelle für beliebige C/C++ Programme.

Zugriff auf Prozessabbild

Die KS8000 ermöglicht über die serielle PC-Schnittstelle den Zugriff auf das Ein- und Ausgangsprozessabbild der BK8x00-Buskoppler oder der IP/ILxxxx-B8x0 Feldbus Boxen.

Pro serieller PC-Schnittstelle kann die Kommunikation zu
- einem BK8100-Koppler (RS232) oder
- einer Feldbus Box IP/ILxxxx-B810 (RS232) oder
- bis zu 99 BK8000-Kopplern (RS485) oder
- bis zu 69 Feldbus Boxen IP/ILxxxx-B800 (RS485)
aufgebaut werden. Bei der Kommunikation wird das gesamte Ein- und Ausgangsabbild übertragen. Die Kommunikationsdauer ist somit abhängig von der Größe des Prozessabbildes. Zum Beispiel ergibt sich für einen RS232-Koppler bei 38400 Baud und

  • einem Prozessabbild von einem Wort eine Kommunikationsdauer von ca. 6 ms.
  • einem Prozessabbild von 15 Worten eine Kommunikationsdauer von ca. 20 ms.

Schnittstelle für LabVIEW-Anwendungen

Die KS8000 enthält eine Schnittstelle für die Programmiersoftware LabVIEW von National Instruments. LabVIEW-Lösungen bestehen aus so genannten Front-Panels als Mensch/Maschine-Schnittstelle und aus einem Blockdiagramm als dem eigentlichen Steuerprogramm. Mit der KS8000 erhalten LabVIEW-Anwender einen stark vereinfachten Zugriff auf alle Prozessdaten.

Zum Betrieb von KS8000 oder TwinCAT über die RS485COM-Schnittstelle ist eine PC-Karte erforderlich, die ohne Echo automatisch von Senden zum Empfang umschaltet (zum Beispiel eine C9900-A440: RS 485 High Speed mit 2 serielle Schnittstellen, optisch entkoppelt, Überspannungsschutz, ISA-Bus).


Parametrierung über den Adresswählschalter

Adresse | Bedeutung | Einstellung
0 | Funktion | 00 | Datenaustausch Mode
70-71 | Baudraten- erkennung | 70 | Disable
 |  | 71 | Enable
80-83 | Baudrate | 80 | 38400 Baud
 |  | 81 | 19200 Baud
 |  | 82 | 9600 Baud
 |  | 83 | 57600 Baud, nur im Datenaustausch Mode benutzbar (Adresse 00 Master oder Adresse 01 Slave)
90-95 | Watchdog | 90 | Disable
 |  | 91 | 1000 ms
 |  | 92 | 2000 ms
 |  | 93 | 4000 ms
 |  | 94 | 8000 ms
 |  | 95 | max. ca. 65 sec
98 | Funktion | 98 | Herstellereinstellung
99 | Funktion | 99 | reserviert


Registerbeschreibung

BECKHOFF Feldbus Box: Kommunikation

Tabellen- und Registerbeschreibung

In Vorbereitung.


TwinCAT PLC

Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung des BCxxxx oder IL230x-Cxxx genutzt. Wenn Sie TwinCAT PLC (WinNT4, Win2000, XP) installiert haben, so können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.


Übertragung über die serielle Schnittstelle

Jeder Busklemmen-Controller kann über die RS232-Schnittstelle des PC programmiert werden. Verwenden Sie hierzu ein spezielles Kabel, das im Lieferumfang der Konfigurationssoftware KS2000 enthalten ist. Die Bestellbezeichnung des Kabels für die IP67 Feldbus Box lautet KS2000-Z3.

Wählen Sie im TwinCat PLC-Control die serielle Schnittstelle an.

Unter Online/Kommunikationsparameter finden Sie im PLC-Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw. Der Busklemmen Controller benötigt folgende Einstellung:
Baud-Rate: 19200 (beim IL230x-B8x0 kann die Baudrate bis 38400 Baud eingestellt werden, dieses Modul verfügt über eine automatische Baudratenerkennung)
Stop Bits: 1
Parity: Gerade


PLC Cycle Time

Die PLC Cycle Time bestimmt die Wiederholungssequenz des Programms. Diese Zeit ist nicht deterministisch. Das bedeutet, dass die PLC Cycle Time sich je nach Programm vergrößern und über die eingestellte Cycle Time hinweg ansteigen kann. Benötigt das Programm weniger Zeit als eingestellt, wird es mit der eingestellten Cycle Time wiederholt und der Rest der übrigen Zeit mit Background Time ausgefüllt.
In der Background Time läuft die Bearbeitung des Ethernets und der seriellen Schnittstelle. Diese sollte auf ca. 20 bis 50 % der PLC Cycle Time eingestellt sein.

Um das System zu optimieren misst man die Mittlere Zykluszeit. Dies finden Sie im PLC Control unter dem Menüpunkt Online/Koppler. Der dort ermittelt Zeit gibt man einen Aufschlag von 50% und trägt die Zeit als PLC Cycle Time ein. Stellen Sie die Background Time auf 20 bis 50% der PLC Cycle Time ein.

Task time 1.jpg (20375 Byte)

Die Programmlaufzeit besteht aus der Programmbearbeitung und der K-Bus-Zeit. Bevor das Programm aufgerufen wird, fährt der Busklemmen Controller ein K-Bus-Update und ließt die aktuellen Eingänge ein. Nach der Programmbearbeitung wird ein zweiter K-Bus-Update um die Ausgänge zu schreiben. Die K-Bus-Zeit ist abhängig von Anzahl und Art der gesteckten Busklemmen.

Man kann die Programmlaufzeit verkürzen in dem man nur einen K-Bus-Zyklus fährt und zwar entweder vor oder nach der Programmbearbeitung. Dann werden in einem K-Bus-Zyklus Eingänge gelesen und Ausgänge geschrieben. Sie können diese Einstellungen über die Konfigurationssoftware KS2000 oder per ADS vornehmen.

Tasktime_d.jpg (33560 Byte)


Remanente und persistente Daten

Feldbuskomponenten: Lokierte Merker

Lokierter Merkerbereich

Remanente Daten

Persistente Daten

Adresse auslesen

Cycle Tick Counter

Diagnose


Remanente und persistente Daten

Feldbuskomponenten: Lokierte Merker

Diagnose

Es gibt die Möglichkeit, die Diagnosedaten im Busklemmen Controller zu lesen. Diese Information liegen im lokierten Merkerbereich.

Merkerbyte | Bedeutung
%MB508-509 | Bit 0 | Watchdog Feldbus
 | Bit 1 | reserviert
 | Bit 1-14 | reserviert
 | Bit 15 | reserviert
%MB510-511 | Bit 0 | K-Bus-Fehler
 | Bit 1 | Konfigurationsfehler
 | Bit 2-15 | reserviert


Remanente und persistente Daten

Im höheren Speicherbereich gibt es spezielle Merker für remanente und persistente Daten.

Remanente Daten

Die remanenten Daten befinden sich im lokierten Merkerbereich. In der Default-Einstellung sind 64 Byte remanent, d.h. von %MB0 bis %MB63. Dieser Bereich lässt sich maximal bis auf 512 Byte vergrößern. Dabei ist darauf zu achten, das sich die Task-Zeit mit der Menge der remanenten Daten erhöht (512 Byte ca. 0,5 ms). Die Einstellungen für die remanenten Daten können Sie über den System-Manager (TwinCAT) oder mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1 Register 15 Default 64 max. 512 Byte).

Persistente Daten

Die persistenten Daten sind noch eine Stufe stabiler, d.h. diese Daten bleiben sogar bei einem Programmdownload erhalten. Die Anzahl der persistenten Daten muss kleiner oder gleich gleich der Anzahl der remanenten Daten sein! Die persistenten Daten liegen wie die remanenten Daten im lokierten Merkerbereich (%MBxx). Die Einstellungen für die persistenten Daten können Sie mit der Konfigurationssoftware KS2000 vornehmen (Tabelle 1 Register 18 Default 0 max. 512 Byte).

Beispiel

400 Byte remanente Daten, davon sollen 200 Byte persistent sein
Tabelle 1:
Register 15 400 (%MB200 - %MB399)
Register 18 200 (%MB0 - %MB199)


Remanente und persistente Daten

Feldbuskomponenten: Lokierte Merker

Adressschalter Auslesen

Im %MB502 [BYTE] wird die aktuell eingestellte Stationsadresse angezeigt, die mit den Adresswählschalter eingestellt wurde.

Zyklus Tick Zähler

In dem Merkerbereich befindet sich ein Zyklustick Counter mit einer Auflösung von einer Millisekunde pro Digit. Der Datentyp ist UDINT (unsigned double integer). Dieser Wert kann vom Programm überschrieben werden, um einen Abgleich zu einer Steuerung zu übernehmen. Der Überlauf geschieht nach ca. 48 Tagen.

Merkerbyte | Bedeutung
%MB504-507 | 4 Byte
 | Datentyp | UDINT
 |  | 0..4,22 Mrd ms / 0.. ca. 48 Tage
 | Auflösung | 1 ms / Digit


LEDs

BECKHOFF Feldbus Box: Fehlerdiagnose

Diagnose-LEDs

Fehlerdiagnose

Es gibt 2 Arten von Fehlern:

  • Feldbus Fehler
  • Lokaler Fehler auf Kompakt Box oder Koppler Box

Blink-Codes

Blinkfolge | Bedeutung
Schnelles Blinken | Anfang
erste langsame Sequenz | Fehler-Code
zweite langsame Sequenz | Fehlerargument

Flasching_codes.jpg (2840 Byte)

Anfang Fehler-Code Fehlerargument


Diagnose-LEDs für RS232/RS485

BECKHOFF Feldbus Box: Diagnose und Fehlerbehandlung

Diagnose-LEDs für RS 232/RS485

Diese werden von den beiden oberen LEDs beschrieben.

LED grün | LED rot | E/A RUN | Beschreibung | Abhilfe
schnelles blinken | schnelles blinken | keine Bedeutung | Modul sucht die Baudrate | Kommunikation starten
aus | aus | keine Bedeutung | Baudrate wurde befunden, Kommunikation unterbrochen | Kommunikation erneut starten
 |  |  | Fehlerhafte Datenlänge (siehe Status) | Datenlänge anpassen
aus | an oder blinkt | keine Bedeutung | Fehler in der Datenübertragung | mögliche Ursachen: Parity-Fehler Checksummen-Fehler zu viele Stopbits falsche Baudrate1
an | aus | an | kein Fehler, Modul im Datenaustausch | -

1) Wenn eine Baudrate gefunden wird, so bleibt diese in bis zu einem Neustart (Aus- und Wiedereinschalten) gespeichert.


Diagnose-LEDs für lokale Fehler

Lokale Fehler in einer Koppler Box (IL230x-Bxxx/Cxxx)

Unter den lokalen Fehlern ist gemeint, das ein Fehler in der Feldbus Box oder dem IP-Link aufgetreten ist. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

LED grün | LED rot |  |  | Beschreibung | Abhilfe
aus | aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
aus | 1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
aus | 2 |  |  | reserviert | -
aus | 3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
 | 3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
aus | 4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
aus | 5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
aus | 11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
aus | 12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
aus | 13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich
an | aus |  |  | Modul ist im Datenaustausch (kein Fehler) | -

Lokale Fehler in einer Erweiterungsbox

LED grün | LED rot | Beschreibung
aus | an | es werden kein Daten über den IP-Link empfangen
aus | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (sehr schlechte Datenverbindung)
blinkt, flackert | blinkt, flackert | es werden fehlerhafte IP-Link Protokolle empfangen (schlechte Datenverbindung), muss noch nicht zum Fehler führen
an | aus | es werden IP-Link Protokolle empfangen, kein Fehler

Fehlerhafte IP-Link Protokolle können entstehen durch:

  • schlecht konfektionierte IP-Link Steckverbinder
  • IP-Link Leitung mit erhöhter Dämpfung durch z.B. Knick o.ä.
  • defekte oder verschmutzte Sende LED (Modul vor dem fehlerhaften Modul)
  • defekter oder verschmutzter Empfänger

Der interne IP-Link-Fehlerzähler der Koppler Box kann mit der KS2000 Software ausgelesen werden.


Feldbus Box - Überprüfung der IP-Link-Verbindung

BECKHOFF Feldbus Box: Montage und Verkabelung

Überprüfung der IP-Link-Verbindung

Ein IP-Link-Kabel mit auf beiden Seiten korrekt konfektionierten IP-Link-Steckern garantiert eine fehlerfrei Übertragung.

Eine nachträgliche Prüfung der Übertragungsqualität und eine Fehlersuche ist mit der Konfigurationssoftware KS2000 möglich.

Hierzu sollte die Steuerung (z.B. ein PC mit Profibus-Karte) am Feldbus des Koppler Box angeschlossen sein und diese zyklisch mit Daten versorgen, oder die Koppler Box sollte mit der KS2000 auf freilaufend geschaltet werden.

Als Ergebnis sollte die I/O RUN LED auf dem Kopplermodul hellgrün leuchten. Dies zeigt, dass ein Datenaustausch mit den angeschlossenen Erweiterungsbox Modulen stattfindet. Eine rot flackernde I/O ERR LED zeigt fehlerhafte IP-Link-Telegramme an! Telegramme werden wie bei auch jedem Feldbussystem im Fehlerfall wiederholt, so dass eine Übertragung der Daten gewährleistet ist.

Fehlerzähler

In Tabelle 90, Offset 005 werden aufgetretene IP-Link-Fehler gezählt. Sporadisch auftretende Fehler bedeuten noch keine Probleme für die Kommunikation. Dieser Fehlerzähler wird nur durch ein Power ON/OFF zurückgesetzt.

Sollten in kurzer Zeit viel Fehler auftreten, wird eine schwere Störung diagnostiziert und das Koppler-Modul meldet diesen Fehler. Dies ist am Offset 006 oder 007 zu erkennen. Die beiden Werte stehen dann auf einem Wert > 200 und die I/O ERR LEDs des Koppler-Moduls blinken mit dem entsprechenden Fehler-Code.

Hinweis Die Konfigurations-Software KS2000 kommuniziert über einen seriellen Kanal mit der Koppler Box. Der Registerinhalt wird nicht andauernd aktualisiert, muss also manuell refreshed werden.

Fehlerort

Stellt das Koppler Modul einen Fehler fest, versucht es den Fehlerort aus dem Register der Erweiterungs-Box herauszulesen. Ist der Ring tatsächlich unterbrochen bzw. die Kommunikation stark gestört, ist dies nicht möglich. Dann wird nur der Ort des Bruchs dargestellt und zwar rückwärts vom Koppler gezählt (siehe IP-Link Fehlersuche).

Läuft die Kommunikation noch, kann in Tabelle 87 der Fehlerzähler je Erweiterungsmodul ausgelesen werden.

Hier bezieht sich der Offset auf die Position links im KS2000 Baum (siehe Grafik). d.h. in diesem Beispiel werden Fehler beim Offset 004 und 006 angezeigt.

Im IP-Link Aufbau ist der Fehler also bei der Übertragung zu Modul IE20xx und bei der Übertragung zu IE3112 zu suchen.

Der Fehler kann also liegen, an:

  • dem Sender-Modul
  • dem Empfänger-Modul
  • dem Kabel oder
  • den Steckern

Wird in Tabelle 90 ein Fehler angezeigt, aber in Tabelle 87 nicht, so ist die Fehlerursache in der Übertragungsstrecke zwischen dem letzten Erweiterungsmodul und dem Koppler zu suchen.

In fast allen Fällen sind Übertragungsfehler auf schlecht konfektionierte IP-Link-Stecker oder zu hohe Dämpfung im LWL-Kabel (durch scharfe Knicke o.ä.) zurückzuführen.

Tabelle 87 wird bei einer IP-Link-Unterbrechung nicht aktualisiert, da diese Werte direkt aus den Erweiterungs-Modulen kommen. Diese können dann über den IP-Link natürlich nicht mehr ausgelesen werden.

Hinweis Falls Sie eine Koppler-Box (z.B. IL2300-Bxxx, IL2301-Bxxx oder IL2302-Bxxx ) ganz ohne Erweiterungs-Box-Module (IExxxx) betreiben möchten, müssen Sie Sende- und Empfangs-Anschluss diese Koppler-Box über ein IP-Link-Kabel direkt miteinander verbinden! Hierfür eignet sich besonders der IP-Link-Verbindungsstecker ZK1020-0101-1000.


Feldbus Box Zubehör

Für die IP67 Module gibt es von Beckhoff das notwendige Zubehör für diese Schutzklasse.

Feldbuszubehör

Vorkonfektionierte Kabel

Stecker

Verteiler

Spannungsversorgung

Vorkonfektionierte Kabel

Stecker

Verteiler

Sensorsversorgung

Vorkonfektionierte Kabel

Stecker

Verteiler

IP-Link

Vorkonfektionierte Kabel

Stecker


RS232-Zubehör

Pinbelegung

Profibus_IP_Pins_FeMale.gif (3009 Byte)

Buchse auf dem Modul (oder bei Verwendung der Schaltschrank Durchführung notwendig)

Profibus_IP_Pins_Male.gif (3149 Byte)

Stecker

1 nc.
2 TxD
3 GND
4 RxD
5 Shield

Bestelldaten

Bestellbezeichnung | Beschreibung
ZS1000-0620 | Kupplung feldkonfektionierbar (nur bei Verwendung der Schaltschrank Durchführung notwendig)
ZS1000-0610 | Stecker feldkonfektionierbar
ZS1031-6610 | Schaltschrank Durchführung M12, Stecker-Kupplung

ZS1031-6610

Add Profibus ZS1031-6610.gif (6530 Byte)


Profibus-Zubehör

BECKHOFF Feldbus Box: Zubehör

Profibus-Zubehör (auch für RS 485 und Modbus)

Profibuskabel

Bestelldaten

Bestellbezeichnung | Feldbuskabel | Verbinder | Kontakte | Querschnitt | Länge | Abb.
ZK1031-6200-1020 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | A
ZK1031-6200-1050 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | A
ZK1031-6200-1100 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | A
ZK1031-6200-1150 | Buchse gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | A
ZK1031-6100-1020 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 2,00 | B
ZK1031-6100-1050 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 5,00 | B
ZK1031-6100-1100 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 10,00 | B
ZK1031-6100-1150 | Stecker gerade, offenes Ende | M12 schraubbar | 8-polig | 0,32 | 15,00 | B
ZK1031-6251-1003 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,30 | A und B
ZK1031-6251-1005 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 0,50 | A und B
ZK1031-6251-1010 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 1,00 | A und B
ZK1031-6251-1020 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 2,00 | A und B
ZK1031-6251-1050 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 5,00 | A und B
ZK1031-6251-1100 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 10,00 | A und B
ZK1031-6251-1150 | Stecker gerade, Buchse gerade | M12 schraubbar | 8-polig | 0,32 | 15,00 | A und B

Add PROFI cable.jpg (10647 Byte) cable PB cable.gif (6112 Byte)

Stecker

PB_Buchse_klein.gif (11264 Byte) PB_Stecker_klein.gif (13122 Byte)

Pinbelegung

Profibus_IP_Pins_FeMale.gif (3009 Byte) Profibus_IP_Pins_Male.gif (3149 Byte) 1 nc.
2 grün
3 nc.
4 rot
5 Shield

Technische Daten

Elektrische Daten |
Bemessungsdaten | 300 V, 80°C
Material | Außenmantel PUR, Innere Isolierung Polyethylen
Querschnitt | 0,32 mm²
DC Widerstand | 54,12 Ohm/km
Leitungskapazität | 26,9 pF/m
Nominal-Impedanz | 150 Ohm bei 1 MHz
Zulassung | UL-Zulassung, AWM, Typ 20233, 80°C, 300V; CSA AWM, I/II A/B, 80°C, 300V FT1

Zubehör Profibus

Bestelldaten

Bestellbezeichnung | Beschreibung
ZS1031-2600 | T-Stück, 12 MBaud
ZS1000-2600 | Y-Stück, 12 MBaud
ZS1000-1610 | Endwiderstand (Stecker)
ZS1000-0620 | Kupplung feldkonfektionierbar
ZS1000-0610 | Stecker feldkonfektionierbar
ZS1031-6610 | Schaltschrank Durchführung M12, Stecker-Kupplung

ZS1031-2600

PB T conector size.gif (37847 Byte) Add PROFI T-connector diag.gif (5258 Byte)

ZS1000-2600

Add PROFI Y-connector.gif (17718 Byte) Add PROFI Y-connector diag.gif (5090 Byte)

ZS1000-1610

Add Profibus End.gif (7936 Byte)

ZS1031-6610

Add Profibus ZS1031-6610.gif (6530 Byte)


Beschreibung des Feldbussystems

Feldbus Box: Zubehör

Konfigurationssoftware KS2000

Die Konfigurationssoftware KS2000 ermöglicht die Projektierung, Inbetriebnahme und Parametrierung der Buskoppler und den dazugehörigen Busklemmen sowie der Feldbus Box Module. Die Verbindung zwischen Buskoppler/Feldbus Box und PC wird über ein serielles Konfigurationskabel hergestellt.

Hinweis | Um mit der KS2000 Software eine Verbindung zu ermöglichen ist es wichtig, beim BK8000 oder IP/ILxxxx-B800 die richtige Multipoint Adresse (gleiche Adresse wie die Drehwahlschalter) einzustellen. Bei der KS2000 Software können Sie diese unter den Einstellungen der COM-Schnittstelle parametrieren.
Hinweis | Bei allen seriellen Geräten (BK8x00, IP/ILxxxx-B8x0) ist es nicht möglich gleichzeitig eine Verbindung zur KS2000 und einen zyklischen Datenaustausch zu betreiben.
Hinweis | Achten Sie darauf, dass die richtige Baudrate in der KS2000-Software eingestellt ist. Wenn Sie zuvor mit dem seriellen Modul einen zyklischen Datenaustausch bei 38,4 kBaud durchgeführt haben, müssen Sie in der KS2000 Software auch 38,4 kBaud einstellen (Default: 19,2 kBaud). Nach aus- und wieder einschalten gehen Buskoppler/Feldbus Box in die Betriebsart Baudrate Search und Sie können auch mit der Default-Einstellung der KS2000 Software arbeiten.


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zulassungen

UL E172151

Konformitätskennzeichnung

CE

Schutzart

IP65/66/67 gemäß EN60529


Prüfnormen für die Geräteprüfung

EMV

Festigkeit: EN 61000-6-2

Aussendung: EN 61000-6-4

Vibrationsfestigkeit

Schwingungsprüfung: EN 60068-2-2, Amplitude 2 g (Norm 1 g)

Schockprüfung: EN 60068-2-27, Schockanzahl 1000 (Norm 2)


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Verdrahtung der Signale

In Vorbereitung


Beschreibung des Feldbussystems

Die RS485/RS232 Ein-/Ausgabebaugruppen der Feldbus Box Serie verwenden ein einfaches offengelegtes serielles Kommunikationsprotokoll, das auf der Master/Slave Architektur basiert. Es ist sehr schnell auf beliebigen seriellen Schnittstellen zu implementieren, da es nur wenige Funktionen benötigt. Aufgrund der niedrigen Übertragungsrate von maximal 38,4 kBaud empfiehlt sich der Einsatz dieser Netzwerke vor allem für Applikationen mit geringen zeitlichen Anforderungen.

RS 232

Bei einem RS 232 System besteht der Bus in der Regel aus einem Master und einem Slave. Die RS 232 Verbindung ist eine Peer to Peer Verbindung. Das bedeutet an einer RS 232 Schnittstelle darf nur ein RS 232 Teilnehmer daran angeschlossen werden. Wird allerdings das Übertragungsmedium geändert zum Beispiel RS 232 auf Funk und dann wieder auf RS 232 können auch mehrere IP/ILxxxx-B810 an einem Master angeschlossen werden.

RS 485

Bei einem RS485 System besteht der Bus aus einer Master Station und mehreren Slave Stationen, wobei die Kommunikation ausschließlich durch den Master gesteuert wird. Der Master fragt zyklisch die Daten der Slaves ab (Polling). Beim Datenaustausch mit den Busknoten wird stets das gesamte Prozessabbild übertragen, d.h. der Master sendet die gesamten Ausgangsdaten an die Feldbus Box und erhält anschließend die gesamten Eingangsdaten im Antworttelegramm zurück. Bei 38,4 kBaud werden für 30 Byte Prozessdaten hierfür ca. 20 ms benötigt. Die Daten werden in einem festen Format als Binärstring übertragen und durch eine Prüfsumme gesichert.

 | RS485 IPxxxx-B800, IL230x-B800 | RS232 IPxxxx-B810, IL230x-B810
 | 69 | 1(Peer-to-peer-Verbindung)
Anzahl der E/A – Punkte | steuerungsabhängig
Übertragungsmedium | abgeschirmtes verdrilltes Kupferkabel 2 x 0,25 mm
Leitungslänge | max. 1200 m (baudratenabhängig) | 15 m
Übertragungsrate | 9,6 kBaud, 19,2 kBaud, 38,4 kBaud (Default)
Protokoll | offenes, dokumentiertes Protokoll
Softwaretool | KS8000: stellt Active X Control, DLL und Ni LabView Schnittstellen für Windows 95/NT bereit.

Multiplexer Funktion

Als zusätzliche Betriebsart kann zwischen zwei seriellen Feldbus Box Baugruppen eine autarke Master/Slave Kommunikation aufgebaut werden. Ohne zusätzlichen Master werden die Eingangsdaten des einen Gerätes direkt auf die Ausgänge des anderen abgebildet – und umgekehrt. Diese Betriebsart erfordert keine aufwendige Konfiguration – es müssen lediglich die Knotenadressen entsprechend gewählt werden.
00 - Für den Master
01 - Für den Slave

KS8000

Zur Kommunikation mit den Feldbus Box Modulen ist die KS8000 Kommunikations-Bibliothek für Windows 95/98/NT erhältlich. Die Bibliothek bietet Funktionalitäten, mit denen eine einfache Verbindung von PC Applikationen über die serielle PC-Schnittstelle zu den Feldbus Box Modulen herstellbar ist. Die OCX-Schnittstelle ist von sämtlichen Programmiersprachen einsetzbar, die mit den Spezifikationen des Component Object Model (COM) von Microsoft arbeiten (z.B. Visual Basic, Visual C, Delphi, Java etc.). Zusätzlich verfügt die KS8000 Bibliothek über eine DLL-Schnittstelle für beliebige C/C++ Programme. Mit KS8000 LV steht außerdem eine Schnittstelle für das graphische Programmiersystem LabVIEW von National Instruments zur Verfügung.

Multiplexer Funktion Als zusätzliche Betriebsart kann zwischen zwei seriellen Feldbus Box Baugruppen eine autarke Master/Slave Kommunikation aufgebaut werden. Ohne zusätzlichen Master werden die Eingangsdaten des einen Gerätes direkt auf die Ausgänge des anderen abgebildet - und umgekehrt. Diese Betriebsart erfordert keine aufwendige Konfiguration. Es müssen lediglich die Knotenadressen entsprechend gewählt werden.


Temperature °F/°C

Feldbus Box: Analoge Eingänge Temperatur

Anwenderskalierung

Um das Modul auf Fahrenheit umzustellen müssen Sie die Formel umrechnen und die Anwender-Register beschreiben.

Formel:
°F = 9/5 x °C + 32

Zur Einstellung der Skalierung auf 1/10 °F wird der konstante Teil (Offset) mit 10 multipliziert.
Das bedeutet :

  • für den Offset 32 *10 =320
  • für den Gain (9/5 *10/16 *256) = 288

Nötige Registereinstellungen:

  • R31 Codewort setzen = 0x1235
  • R32 Herstellerskalierung deaktivieren
  • R32 Anwenderskalierung aktivieren
  • R33 Anwender Offset = 320dez
  • R34 Anwender Gain = 288dez

Die Änderungen der Skalierung sind sofort gültig und sind für jeden Kanal separat einstellbar.


Gerätekonzept

Die Systemarchitektur von TwinCAT erlaubt es, einzelne Teile der Software (z.B. TwinCAT PLC, TwinCAT NC, ...) als eigenständige Geräte zu betrachten: Für jede Aufgabe gibt es ein Softwaremodul (Server oder Client). Die Server im System sind die ausführenden Arbeitsgeräte in Form von Software, welche in ihrem Betriebsverhalten genau einem Hardwaregerät entsprechen. Man kann daher von virtuellen Geräten in Softwareform sprechen. Die Clients sind Programme, welche die Dienste der Server anfordern, z.B. eine Visualisierung oder auch ein Programmiergerät in Form eines Programms. Auf diese Weise kann TwinCAT wachsen, indem immer neue Server und Clients entstehen, für Aufgaben, wie z.B. Nockenschaltwerk, Oszilloskop, SMS-Kommunikation, etc.

Der Nachrichtenaustausch zwischen diesen Objekten wird über eine einheitliche ADS-Schnittstelle (Automation Device Specification) vom Message-Router abgewickelt. Dieser verwaltet und verteilt alle Nachrichten im System und über TCP/IP-Verbindungen.

TwinCAT Message-Router existieren auf jedem TwinCAT-PC und auf jedem Busklemmen-Controller BCxxxx (z.B. BC3100, BC8100, ...). Auf diese Weise können PC Systeme (via TCP/IP) und auch Busklemmen-Controller (über serielle Schnittstellen und über Feldbusse) verbunden werden.

Somit können alle TwinCAT-Server und Client-Programme Befehle und Daten austauschen, Nachrichten versenden, Statusinformationen übermitteln etc.