FieldbusBox I/O Modules - Signal Types, Installation and Configuration

BECKHOFF Fieldbus Components

Documentation for

Fieldbus Box I/O-Modules

Signal Types, Installation and Configuration

Version: 2.0.0
Date: 2013-11-28


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

Disclaimer

The documentation has been prepared with care. The products described are, however, constantly under development.
For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics.
In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Trademarks

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® and XFC® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.

Patent Pending

The EtherCAT Technology is covered, including but not limited to the following patent applications and patents:
EP1590927, EP1789857, DE102004044764, DE102007017835
with corresponding applications or registrations in various other countries.

The TwinCAT Technology is covered, including but not limited to the following patent applications and patents:
EP0851348, US6167425 with corresponding applications or registrations in various other countries.

Copyright

© Beckhoff Automation GmbH.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


Fieldbus Box I/O-Modules - Documentation Issue Status

BECKHOFF Fieldbus Box I/O-Modules: Foreword

Documentation Issue Status

Version Comment
2.0.0
  • UL notes extended
  • Nut torque for connectors added
  • Accessories extended
  • Technical data updated
  • IP-Link LED diagnostic display updated
1.9.1
  • System overview updated
1.9.0
  • Introduction and signal Connection of IE2808 updated
  • Special type IE2808-0001 added
  • Block diagram of IP/IE5109 updated
  • Mounting instructions for ZS1022 added
1.8.1
  • Mapping of IP5209 corrected
  • Description of feature registers for IP/IE3312 updated
1.8.0
  • Extension Box IE2403added
1.7.4
  • IL230x-B110 added at the dimensions chapter
  • Third party products chapter updated
1.7.3
  • Mapping of IE2808 corrected
1.7.2
  • Technical Data of IE2808 updated
  • Block diagram of IE2808 corrected
1.7.1
  • IP/IE1502, Gate-Input is mapped to the Status-Byte
1.7.0
  • Extension Box IE2808 added
  • Mounting Rail ZS5300-0001 added
  • IP-Link Direct Connector added
1.6.2
  • Diagnostic Chapter enhanced
1.6.1
  • Technical Data of Fieldbus Box Modules updated
  • Minor routine corrections (typing errors, orthography etc.)
1.6.0
  • Register settings IP/IE5009 corrected
  • Minor routine corrections (typing errors, orthography etc.)
1.5
  • Numbering of channels at the mapping descriptions adapted to display in TwinCAT and KS2000
  • Minor routine corrections (typing errors, orthography etc.)
1.4
  • Description of the mappings extended for Ethernet
1.3
  • Expanding of the specification for IP-Link up to 15 meters
  • Chapter about IP-Link completed and over-worked
  • Description of IP/IE3202 register settings corrected
1.2
  • Description of control und status bytes for all modules over-worked
  • Description of mappings and configuration for the IP/IE2512 and IP/IE5009 modules updated
1.1
  • Description of the mappings adapted to the view of the registers in KS2000 Configuration Software
1.0
  • more Fieldbus Box Modules added
0.8
  • first preliminary Version


The Fieldbus Box System

Fieldbus box modules are robust fieldbus stations for a large number of different fieldbus systems. They offer a wide range of I/O functionality. All relevant industrial signals are supported. As well as digital and analog inputs and outputs including thermocouple and RTD inputs, there are also incremental encoder interfaces available for displacement and angle measurement as well as serial interfaces to solve a large number of communications tasks.

Three varieties of signal connection

The digital inputs and outputs can be connected with snap-on 8 mm diameter plugs, screw-in M8 connectors, or with screw-in M12 pendants. The M12 version is provided for analog signals.

All important signal types

Special input and output channels on the combination I/O modules can be used for either input or output. It is not necessary to configure them, since the fieldbus interface is available for every combination channel as well as for input and output data. The combination modules give the user all of the advantages of fine signal granularity.

The processor logic, the input circuitry and the power supply for the sensor are all fed from the control voltage. The load voltage for the outputs can be supplied separately. In those Fieldbus Boxes in which only inputs are available, the load power supply, UP, can optionally be connected in order to pass it on downstream.

The states of the Fieldbus Box, the fieldbus connection, the power supplies and of the signals are indicated by LEDs.

The label strips can be machine printed elsewhere, and then inserted.

Fieldbus Boxes can be combined for greater flexibility

In addition to the Compact Box, the Fieldbus Box series also includes extendable devices, namely the Coupler Box and the Extension Box, as well as intelligent devices, the PLC Boxes.

Compact Box

The Compact Box makes the I/O data from the connected digital and analog sensors and actuators available to the fieldbus.

Coupler Box

The Coupler Box also collects I/O data from the Extension Boxes via an interference-proof optical fiber connection (IP-Link). Up to 120 Extension Boxes can be connected to a Coupler Box. In this way a distributed IP67 I/O network is formed with only one fieldbus interface.

The Coupler Box is capable of automatically recognizing the extension modules connected to it during start-up, and maps the I/O data automatically into the fieldbus process image – a configuration is not necessary. The Coupler Box appears, from the fieldbus point of view, along with all of the networked Extension Boxes, as a single participating bus device with a corresponding number of I/O signals.

The Coupler Box corresponds to the Bus Coupler in the BECKHOFF Bus Terminal system. BECKHOFF fieldbus devices made to protection class IP 20 (Bus Terminals) and IP 67 (Fieldbus Box) can be combined without difficulty – the data is handled in the same way in either case.

IP-Link

The IP-Link is an optical fiber connection with a transmission rate of 2 MBits/s which is capable of transmitting 1000 items of binary I/O data in approx. 1 ms, rapidly and securely. Smaller configurations are correspondingly faster. Because of the high usable data rate, the coupling via IP-Link does not reduce the performance of the fieldbus at all.

Low-priced plug connectors made according to Protection Class IP 67 can be used for the rapid and simple preparation of the IP-Link cable, in situ. The connection does not require special tools, and can be performed quickly and simply. The IP-Link cables can also be obtained with prepared plugs if required.

The separate supply of the output voltage allows output groups to be switched off individually. Differing potentials can also be created within an extension ring without difficulty, since the IP-Link naturally has optimum electrical isolation.

Extension box

Like the Compact Boxes, the Extension Boxes cover the full spectrum of I/O signals, and may be up to 15 m apart. They are remarkably small in size, and lead to particularly economical I/O solutions with high levels of protection. Here again, the digital inputs and outputs may optionally be connected via snap-on 8 mm connectors, or via screw-in connectors (M8 and M12). Analog signal types are provided with the M12 version. The snap-on connectors lock in place positively, forming a shake-proof connection, while the screw-in connectors offer the advantage of high resistance to being pulled out.

PLC Box

The PLC Box is an intelligent Fieldbus Box with PLC functionality for distributed pre-processing of the I/O signals. This allows parts of the application to be farmed out from the central controller. This reduces the load on the CPU and the fieldbus. Distributed counting, controlling and switching are typical applications for the PLC Box. The reaction times are independent of the bus communication and of the higher-level controller.

In the event of a bus or controller failure, maintenance of function (e.g. bringing the process to a safe state in an orderly manner) is possible.

Programming is carried out with TwinCAT in accordance with IEC 61131-3. Five different programming languages are available:

  • Instruction List (IL)

  • Function Block Diagram (FBD)

  • Ladder Diagram (LD)

  • Sequential Function Chart (SFC)

  • Structured Text (ST)

The program download occurs either via the fieldbus or via the programming interface.

Extensive debugging functions (breakpoint, single step, monitoring, etc) are also available. The PLC Box contains a powerful 16 bit controller, 32/96 kByte program memory and 32/64 kByte data memory. A further 512 bytes of non-volatile memory are available for remanent flags.

PLC Box with IP-Link

The programmable PLC Box with IP-Link provides almost unlimited I/O possibilities. Up to 120 extension modules, with more than 2000 I/Os, can be directly addressed from the PLC program. The PLC Box is thus also suitable for use as a small, autonomous controller for the operation of parts of equipment or small machines.


Fieldbus Box - Naming conventions

The identifications of the Fieldbus Box modules are to be understood as follows:
IXxxxy-zyyy

IX describes the design:

"IP" stands for the Compact Box design
"IL" stands for the Coupler Box design (with IP-Link)
"IE" stands for the Extension Box design

xxxy describes the I/O connection:

xxx describes the I/O property:
"10x" - 8 x digital inputs
"15x" - counter module
"20x" - 8 x digital outputs
"25x" - PWM module
"23x" - 4 x digital inputs and 4 x digital outputs
"24x" - 8 x digital inputs and 8 x digital outputs
"3xx" - 4 x analog inputs
"4xx" - 4 x analog outputs
"5xx" - incremental encoder or SSI transducer
"6xx" - Gateway module for RS232, RS422, RS485, TTY

y represents the mechanical connection:
"0" stands for 8mm snap-on connection,
"1" stands for M8 bolted connection
"2" stands for M12 bolted connection and
"9" stands for M23 bolted connection

zyyy describes the programmability and the fieldbus system

z distinguishes whether the device is a slave or is a programmable slave:

"B" - not programmable
"C" - programmable (PLC Box)

"yyy" stands for the fieldbus system and the bus connection:
"110" - EtherCAT
"200" - Lightbus
"310" - PROFIBUS
"318" - PROFIBUS with integrated tee-connector
"400" - Interbus
"510" - CANopen
"518" - CANopen with integrated tee-connector
"520" - DeviceNet
"528" - DeviceNet with integrated tee-connector
"730" - Modbus
"800" - RS485
"810" - RS232
"900" - Ethernet TCP/IP with RJ45 for the bus connection
"901" - Ethernet TCP/IP with M12 for the bus connection
"903" - PROFINET
"905" - EtherNet/IP

Compact Box

The Compact Box modules offer a wide range of I/O functionality. All relevant industrial signals are supported. The digital inputs and outputs can be connected either with snap-on 8 mm diameter plugs, screw-in M8 connectors, or screw-in M12 connectors. The M12 version is made available for analog signals.

Depending on the module, the I/O section and the power supply section can differ.

Coupler Box

There are three versions of the coupler box named IL230x-Bxxx. It differs from the compact box in that this module offers an interface to what are known as extension boxes. This interface is a subsidiary bus system based on the optical fiber what is known as IP Link. This powerful subsidiary bus system can handle up to 120 extension boxes at one coupler box.

Extension Box

Extension Modules, that are independent of the fieldbus and that can only be operated together with a coupler box via IP Link.

PLC Box

A PLC Box differ from the Coupler Box in that this module can be programmed in IEC 61131-3. This means that this slave is also capable of working autonomously, without a master, for instance for control or regulation tasks.


Firmware and hardware issue status

The documentation refers to the hardware and software status that was valid at the time it was prepared. The properties are subject to continuous development and improvement. Modules having earlier production statuses cannot have the same properties as modules with the latest status. Existing properties, however, are always retained and are not changed, so that these modules can always be replaced by new ones.
The number beginning with a D allows you to recognize the firmware and hardware status of a module.

Syntax:

D . ww yy x y z u

ww - calendar week
yy - year
x - bus board firmware status
y - bus board hardware status
z - I/O board firmware status
u - I/O board hardware status

Example:

D.22081501

- Calendar week 22
- in the year 2008
- bus board firmware status: 1
- bus board firmware hardware status: 5
- I/O board firmware status: 0 (no firmware is necessary for this board)
- I/O board hardware status: 1


IP100x-Bxxx, IE100x

8 Channel Digital Input (Filter 3.0 ms) 24 VDC

The IP100x digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The state of the signals is indicated by light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP1000), screw-in M8 connectors (IP1001) or screw-in M12 connectors (IP1002). The sensors are supplied from the control voltage US. The load voltage UP is not used in the input module, but may be connected in order to be relayed downstream.

Technical data | IP1000-Bxxx, IE1000 | IP1001-Bxxx, IE1001 | IP1002-Bxxx, IE1002
Number of inputs | 8
Input connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 3.0 ms
Nominal input voltage | 24 VDC (20 V ... 29 V)
Signal voltage '0' | -3 V ... 5 V (EN61131-2, type 2)
Signal voltage '1' | 11 V ... 30 V (EN61131-2, type 2)
Input current | typical 6 mA (EN61131-2, type 2)
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits input
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP101x-Bxxx, IE101x

8 Channel Digital Input 24 VDC, Filter 0.2 ms

The IP101x digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The state of the signals is indicated by light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP1010), screw-in M8 connectors (IP1011) or screw-in M12 connectors (IP1012). The sensors are supplied from the control voltage US. The load voltage UP is not used in the input module, but may be connected in order to be relayed downstream.

Technical data | IP1010-Bxxx / IE1010 | IP1011-Bxxx / IE1011 | IP1012-Bxxx / IE1012
Number of inputs | 8
Input connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 0.2 ms
Nominal input voltage | 24 VDC (20 V ... 29 V)
Signal voltage '0' | -3 V ... 5 V (EN61131-2, type 2)
Signal voltage '1' | 11 V ... 30 V (EN61131-2, type 2)
Input current | typical 6 mA (EN61131-2, type 2)
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits input
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP200x-Bxxx, IE200x

8 Channel Digital Output 24 VDC, Imax = 0.5 A

The IP200x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2000), screw-in M8 connectors (IP2001) or screw-in M12 connectors (IP2002). The outputs are short-circuit proof and protected against inverse connection.

ip200x.jpg (29519 Byte)

Technical data | IP2000-Bxxx / IE2000 | IP2001-Bxxx / IE2001 | IP2002-Bxxx / IE2002
Number of outputs | 8
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Load type | ohmic, inductive, lamp load
Nominal voltage | 24 VDC (20 V ... 29 V)
Output current | max. 0.5 A on each channel, individually short-circuit proof
Short circuit current | typical 1.5 A
Load voltage current consumption | typical 20 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP202x-Bxxx, IE202x

8 Channel Digital Output 24 VDC, Imax = 2.0 A (total current max. 4 A)

The IP202x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 2 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all of the actuators draw 2 A signal current. The signal state is indicated by means of light emitting diodes.
The signals are optionally connected via 8 mm snap-in plugs (IP2020), screw-in M8 connectors (IP2021) or screw-in M12 connectors (IP2022). The outputs are short-circuit proof and protected against inverse connection.

ip200x.jpg (29519 Byte)

Technical data | IP2020-Bxxx / IE2020 | IP2021-Bxxx / IE2021 | IP2022-Bxxx / IE2022
Number of outputs | 8
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Load type | ohmic, inductive, lamp load
Nominal voltage | 24 VDC (20 V ... 29 V)
Output current | max. 2.0 A each channel, individually short-circuit proof, total current max. 4 A
Short circuit current | typical 4.0 A
Load voltage current consumption | typical 30 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401

BECKHOFF Fieldbus Box: Digital Output Modules

IP204x-Bxxx, IE204x

8 Channel Digital Output 24 VDC, Imax = 2.0 A (total current max. 12 A)

The IP204x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 2 A each, although the total current is limited to 12 A. The outputs are supplied by three load circuits; for this reason these modules do not relay the supply voltage. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs (IP2040), screw-in M8 connectors (IP2041) or screw-in M12 connectors (IP2042). The outputs are short-circuit proof and protected against inverse connection.

ip200x.jpg (29519 Byte)

Technical data | IP2040-Bxxx / IE2040 | IP2041-Bxxx / IE2041 | IP2042-Bxxx / IE2042
Number of outputs | 8
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Load type | ohmic, inductive, lamp load
Nominal voltage | 24 VDC (20 V ... 29 V)
Output current | max. 2.0 A per channel, individually short-circuit proof, total current 12 A: - channels 0...3: S 4 A - channels 4...5: S 4 A - channels 6...7: S 4 A
Short circuit current | typical 4.0 A
Load voltage current consumption | typical 50 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 2 x M8 connector, 4-pin; no downstream connection
Bits in process image | 8 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IE2808

16 Channel Digital Output 24 VDC, Imax = 2,0 A (total current max. 4A)

The IE2808 digital output module connects the binary control signals from the automation unit on to the actuators at the process level. The 16 outputs handle load currents of up to 0.5 A each, although the total current is limited to 4 A. This makes these modules particularly suitable for applications in which not all of the outputs are active at the same time, or in which not all of the actuators draw 0.5 A current. An output short-circuit is recognized and passed on to the controller. The signal state is indicated by means of light emitting diodes. The signal connection is realized by the 25-pin D-sub socket. The outputs are short-circuit safe and protected against inverse connection.

Via register R32 and R33 default values can be activated, this means these values are set when communication is lost.

With R32 this error handling can be activated. In register R33 the value (On or OFF) is specified for every output.

Technical data | IE2808-0000 | IE2808-0001
Number of outputs | 8
Output connection | D-sub socket, 25-pin, UNC tread
Load type | resistance, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 29 V)
Output current | max. 0,5 A per channel, individually short-circuit safe, total current max. 4 A
Short circuit current | maximal 1,5 A
Load voltage current consumption | typical 5 mA per channel
Power supply | Feed: 1 x M8 male socket, 4-pole downstream connection: 1 x M8 female socket, 4-pole
Bits in process image | 16 bit output, 16 bit input (diagnostic), optional: control/status byte
Reset of error display | manually | automatically
Electrical isolation | control voltage / fieldbus: yes, via IP-Link channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagramm for details of connection.

See the mapping description for details on the mapping.

See dimension page for weight and dimensions.


IP230x-Bxxx, IE230x

4 digital inputs (3.0 ms input filter) and 4 digital outputs, 24 VDC, Imax = 0.5 A

The IP230x digital I/O modules combine 4 digital inputs with a 3 ms input filter and four digital outputs in one device. The outputs handle load currents of up to 0.5 A, are short-circuit proof and protected against inverse polarity. The state of each signal is indicated by means of light emitting diodes. The signals are connected optionally via 8 mm snap-on plugs (IP2300), screw-in M8 connectors (IP2301) or screw-in M12 connectors (IP2302).

ip200x.jpg (29519 Byte)

Technical data | IP2300-Bxxx / IE2300 | IP2301-Bxxx / IE2301 | IP2302-Bxxx / IE2302
Number of outputs | 4 inputs and 4 outputs
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 3.0 ms
Signals „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Load type | ohmic, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 29 V)
Output current | max. 0.5 A on each channel, individually short-circuit proof
Short circuit current | typical 1.5 A
Load voltage current consumption | typical 20 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 4 bits input and 4 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no, between the channels: no,
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP231x-Bxxx, IE231x

4 digital inputs (0.2 ms input filter) and 4 digital outputs, 24 VDC, Imax = 0.5 A

The IP231x digital I/O modules combine 4 digital inputs with a 0.2 ms input filter and four digital outputs in one device. The outputs handle load currents of up to 0.5 A, are short-circuit proof and protected against inverse polarity. The state of each signal is indicated by means of light emitting diodes. The signals are connected optionally via 8 mm snap-on plugs (IP2310), screw-in M8 connectors (IP2311) or screw-in M12 connectors (IP2312).

ip200x.jpg (29519 Byte)

Technical data | IP2310-Bxxx / IE2310 | IP2311-Bxxx / IE2311 | IP2312-Bxxx / IE2312
Number of outputs | 4 inputs and 4 outputs
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 0.2 ms
Signals „0“ / „1“ | -3... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Load type | ohmic, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 9 V)
Output current | max. 0.5 A on each channel, individually short-circuit proof
Short circuit current | typical 1.5 A
Load voltage current consumption | typical 20 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 4 bits input and 4 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP232x-Bxxx, IE232x

4 digital inputs (3.0 ms input filter) and 4 digital outputs, 24 VDC, Imax = 2.0 A, total current 4 A

The IP232x digital I/O modules combine 4 digital inputs with a 3 ms input filter and four digital outputs in one device. The outputs handle load currents of up to 2.0 A, are short-circuit proof and protected against inverse polarity. The state of each signal is indicated by means of light emitting diodes. The signals are connected optionally via 8 mm snap-on plugs (IP2320), screw-in M8 connectors (IP2321) or screw-in M12 connectors (IP2322).

ip200x.jpg (29519 Byte)

Technical data | IP2320-Bxxx / IE2320 | IP2321-Bxxx / IE2321 | IP2322-Bxxx / IE2322
Number of outputs | 4 inputs and 4 outputs
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 3.0 ms
Signals „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Load type | ohmic, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 29 V)
Output current | max. 2.0 A each channel, individually short-circuit proof, total current 4 A
Short circuit current | typical 4.0 A
Load voltage current consumption | typical 30 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 4 bits input and 4 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP233x-Bxxx, IE233x

4 digital inputs (0.2 ms input filter) and 4 digital outputs 24 VDC, Imax = 2.0 A, total current 4 A

The IP233x digital I/O modules combine 4 digital inputs with a 0.2 ms input filter and four digital outputs in one device. The outputs handle load currents of up to 2.0 A, are short-circuit proof and protected against inverse polarity. The state of each signal is indicated by means of light emitting diodes. The signals are connected optionally via 8 mm snap-on plugs (IP2330), screw-in M8 connectors (IP2331) or screw-in M12 connectors (IP2332).

ip200x.jpg (29519 Byte)

Technical data | IP2330-Bxxx / IE2330 | IP2331-Bxxx / IE2331 | IP2332-Bxxx / IE2332
Number of outputs | 4 inputs and 4 outputs
Output connections | Ø 8 snap on | M8 screw-in | M12 screw-in
Input filter | 0.2 ms
Signals „0“ / „1“ | -3... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Load type | ohmic, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 29 V)
Output current | max. 2.0 A each channel, individually short-circuit proof, total current 4 A
Short circuit current | typical 4.0 A per channel
Load voltage current consumption | typical 30 mA
Sensor supply | derived from the control voltage, max. 2.0 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 4 bits input and 4 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP240x-Bxxx, IE240x

8 digital inputs (3.0 ms input filter) and 8 digital outputs 24 VDC, Imax = 0.5 A

The IP240x digital I/O modules have 8 channels that can be used either as inputs or as outputs. The device can therefore be flexibly adapted to the requirements of the application. The signals are connected optionally through snap-on 8 mm connectors (IP2400) or through screw-in M8 connectors (IP2401), both of which have 4 pins (with separate input and output pins). This makes it possible to connect antivalent sensors. Adapter cables are available for use in input-only or output-only cases, as well as connectors for field assembly. It is also possible to use the power supply cable directly as the sensor cable. The outputs handle load currents of up to 0.5 A, are short-circuit proof and protected against inverse polarity. The state of each signal is indicated by means of light emitting diodes.

ip200x.jpg (29519 Byte)

Technical data | IP2400-Bxxx / IE2400 | IP2401-Bxxx / IE2401
Number of outputs | 8 inputs and 8 outputs
Output connections | Ø 8 snap on | M8 screw-in
Input filter | 3.0 ms
Signals „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Load type | ohmic, inductive, lamp load
Rated load voltage | 24 VDC (20 V ... 29 V)
Output current | max. 0.5 A on each channel, individually short-circuit proof
Short circuit current | typical 1.5 A
Load voltage current consumption | typical 20 mA per channel
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits input and 8 bits output
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IE2403

8 digital inputs (3.0 ms input filter) and 8 digital outputs 24 VDC, Imax = 0.5 A

The digital IE2403 combi module has 16 channels with 8 inputs and 8 outputs. The device can therefore be flexibly adapted to the requirements of the application. The outputs handle load currents of up to 0.5 A. They are short-circuit-proof and protected against inverse polarity. KM-connectors with a spring-loaded system are used for the signal connection. These connectors are optionally available with 1 or 3 pins. The module is supplied without KM-connectors.

Attention

The IE2403 combi module conforms to protection class IP20. It is intended to be used within switch boards, control panels or switch cabinets to integrate their signals into IP link.

The IE2403 combi module conforms not to protection classes IP65/IP67!

Technical data | IE2403
Number of channels | 16 (8 inputs and 8 outputs)
Input connections | Via KM connector ZS2001 (not included in delivery of IE2403). Please order the desired type for single- or tree-wire technique (see ordering information and technical data).
Input filter | 3.0 ms
Signals „0“ / „1“ | -3 ... 5 V / 11 ... 30 V, 6 mA input current (EN61131-2, type 2)
Sensor supply | derived from the control voltage, max. 0.5 A per channel, fully short-circuit proof
Output connections | Via KM connector ZS2001 (not included in delivery of IE2403). Please order the desired type for single- or tree-wire technique (see ordering information and technical data).
Rated load voltage | 24 VDC (20 V ... 29 V)
Load type | ohmic, inductive, lamp load
Output current | max. 0.5 A on each channel, individually short-circuit proof
Short circuit current | typical 1.5 A
Load voltage current consumption | typical 20 mA per channel
Power supply | Feed: 1 x M8 connector, 4-pin downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 8 bits input and 8 bits output
Electrical isolation | control voltage / fieldbus: yes, via IP-Link channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP20
Mounting position | any

See the connection description for details of the connection.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP3102-Bxxx, IE3102

4 Channel Analog Input ± 10 V

The IP3102 analog input module handles signals in the range from -10 V to +10 V. The voltage is digitized to a resolution of 16 bits, and is transmitted, electrically isolated, to the higher-level automation device. The input channels have differential inputs and possess a common, internal ground potential. The applied load voltage (which can be any value up to 30 VDC) is fed through to supply the sensor. It is thus possible, for instance, to supply a measuring potentiometer with 10 VDC from an external voltage source. The module is quite versatile, but default settings have been selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. Parameterization may be carried out either via the fieldbus or using the KS2000 software tool.

ip200x.jpg (29519 Byte)

Technical data | IP3102-Bxxx / IE3102
Number of channels | 4 analog inputs
Output connections | M12 screw-in
Nominal input range | -10 V ... +10 V
Input resistance | > 100 kΩ
Common mode voltage | 35 V max.
Conversion time | 250 ms (default), configurable to 5 ms
Resolution | 15 bits + arithmetic sign
Relative measurement error | < ± 0,3% of the full scale value
Input filter | 10 variations inc. averaging, configurable
Sensor supply | from load supply voltage UP, DC, any value up to 30 V
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I: 4 x 16 bits, optional I/O: 4 x 8 bits control/state + 4 x 16 bits
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: 500 V between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the Connection diagram for details of the connection.

See the Parameterization description for details of the parameterization.

See the Mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP3112-Bxxx, IE3112

4 Channel Analog Input, from 0 to 20 mA

The IP3112 analog input module handles signals in the range from 0 to 20 mA. The input current is digitized to a resolution of 16 bits (the default is 15 bits), and is transmitted, electrically isolated, to the higher-level automation device. The input channels have differential inputs and possess a common, internal ground potential. The applied load voltage (which can be any value up to 30 VDC) is fed through to supply the sensor. The module is quite versatile, but default settings have been selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. Parameterization may be carried out either via the fieldbus or, using the KS2000 software tool, through the configuration interface. The parameters are stored in the module.

ip200x.jpg (29519 Byte)

Technical data | IP3112-Bxxx / IE3112
Number of channels | 4 analog inputs
Output connections | M12 screw-in
Nominal input range | 0 ... 20 mA
Input resistance | 80 Ω measuring resistance
Common mode voltage | max. 35 V
Conversion time | 140 ms
Resolution | 15 bits + arithmetic sign
Relative measurement error | < ± 0,3% of the full scale value
Input filter | 10 variations inc. averaging, configurable
Sensor supply | from load supply voltage Up, DC, any value up to 30 V
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I: 4 x 16 bits, optional I/O: 4 x 8 bits control/state + 4 x 16 bits
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: 500 V between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP3202-Bxxx, IE3202

4 Channel Analog Input PT100 (RTD)

The IP3202 analog input module allows resistance sensors to be connected directly. The module's circuitry can operate the sensors using 2-wire or 4-wire connection techniques. Linearization over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The module can also be used for resistance measurement, with the output in ohms. The module's standard settings are: Resolution 0.1 °C in the temperature range of PT100 sensors in 4-wire connection. Sensor malfunctions such as broken wires are indicated by error LEDs. The module is quite versatile, but default settings have been selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. Parameterization may be carried out either via the fieldbus or using the KS2000 software tool.

ip200x.jpg (29519 Byte)

Technical data | IP3202-Bxxx / IE3202
Number of channels | 4 analog inputs
Output connections | M12 screw-in
Nominal input range | PT100, PT200, PT500, PT1000, Ni100, Ni120, Ni1000, resistance measurement (e.g. potentiometer)
Resolution | 0.1°C per digit
Measuring current | typical 0.5 A
Conversion time | 260 ms
Measurement error | < +/-1°C
Input filter | 4 versions
Sensor supply | From the load voltage, US
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I: 4 x 16 bits, optional I/O: 4 x 8 bits control/state + 4 x 16 bits
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: 500 V between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP3312-Bxxx, IE3312

4 Channel Analog Input Thermocouple

The IP3312 analog input module permits four thermocouples to be directly connected. The module's circuit can operate thermocouple sensors using the 2-wire technique. Linearization over the full temperature range is realized with the aid of a microprocessor. The temperature range can be selected freely. The module can also be used for voltage measurements in the mV range. The module's standard settings are: Resolution 0.1 °C over the temperature range of type K sensors. Sensor malfunctions such as broken wires are indicated by error LEDs. Compensation for the cold junction is made through a temperature measurement in the connecting plug. This means that standard extension leads can be connected.

The module is quite versatile, but default settings have been selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range, and several data output formats may be chosen. The inputs can, if required, be scaled differently, and automatic limit monitoring is also available. Parameterization may be carried out either via the fieldbus or using the KS2000 software tool.

ip200x.jpg (29519 Byte)

Technical data | IP3312-Bxxx / IE3312
Number of channels | 4 analog inputs
Output connections | M12 screw-in
Nominal input range | Types J, K, L, B, E, N, R, S, T, U (default setting type K), mV measurement
Resolution | 0.1°C per digit
Conversion time | 260 ms
Measurement error | < +/- 0.5 % (of the full scale value)
Input filter | 4 versions
Cold junction compensation | via ZS2000-3712
Sensor supply | From the load voltage, US
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I: 4 x 16 bits, optional I/O: 4 x 8 bits control/state + 4 x 16 bits
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: 500 V between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP4112-Bxxx, IE4112

4 Channel Analog Output, from 0 to 20 mA

The IP/IE4112 analog output module generates analog output signals in the range from 0 to 20 mA. The power is supplied to the process level with a resolution of 15 bits (default), and is electrically isolated. If the input is transmitted without an arithmetical sign, 16 bit resolution may also be selected. If necessary, the output scaling can be altered.
Ground potential for the four output channels is common with the 24 VDC supply. The output drivers are powered by the control voltage. The applied load voltage (which can be any value up to 30 VDC) is fed through to supply the actuators.

ip200x.jpg (29519 Byte)

Technical data | IP4112-Bxxx, IE4112
Number of channels | 4
Output connections | M12 screw-in
Output range | 0 ... 20 mA
Load impedance | < 500 Ω
Resolution | 15 bit, configurable to 16 bit
Conversion time | < 4 ms
Accuracy | < ± 0.1% of the full scale value
Actuator power supply | from the load voltage, UP
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | O: 4 x 16 bits data, optional: 4 x 8 bits control/status
Electrical isolation | control voltage / fieldbus: depends on the bus system channels / control voltage: yes between the channels: no
Permissible ambient temperature during operation | 0 °C ... 55 °C
Permissible ambient temperature during storage | -25 °C ... + 85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See connections for connection details.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP4132-Bxxx, IE4132

4 Channel Analog Output, from -10 V to +10 V

The IP/IE4132 analog output module generates analog output signals in the range from -10 V to + 10 V. The voltage is supplied to the process level with a resolution of 16 bits, and is electrically isolated. If necessary, the output scaling can be altered.
Ground potential for the four output channels is common with the 24 VDC supply. The output drivers are powered by the control voltage. The applied load voltage (which can be any value up to 30 VDC) is available for supply of the actuators.

ip200x.jpg (29519 Byte)

Technical data | IP4132-Bxxx
Number of channels | 4
Output connections | M12 screw-in
Output range | -10 V / 0 ... 10 V
Load impedance | > 5 kΩ
Resolution | 16 bit
Conversion time | < 4 ms
Accuracy | < ± 0.1% of the full scale value
Actuator power supply | from the load voltage, UP
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | O: 4 x 16 bits data, optional: 4 x 8 bits control/status
Electrical isolation | control voltage / fieldbus: depends on the bus system channels / control voltage: yes between the channels: no
Permissible ambient temperature during operation | 0 °C ... 55 °C
Permissible ambient temperature during storage | -25 °C ... + 85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IIP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP1502-Bxxx, IE1502

Counter module

The counter module has two fast counters running at up to 100 kHz. It counts binary pulses, and transmits the counter state to the higher-level automation unit. The Up/Down input allows the counters to be switched between upwards and downwards counting (in 32 bits). The gate signals (gate inputs) allow the counters to be triggered: depending on the level at the gate input, the counting function is halted or enabled. The outputs can be switched or pulsed depending on the counter state, and can therefore be used as fast control signals for field devices. From the controller it is possible to set the counter state, to start or halt the counter functions, and to set the outputs. The module shows the states of the input and output signals by means of light emitting diodes.

ip1502.jpg (29519 Byte)

Technical data | IP1502-Bxxx / IE1502
Number of counters | 2, each with a depth of 32 bits
Switching frequency | 100 kHz (2 kHz when switching between up and down)
Signal connection | M12 screw-in
Number of inputs | 2 counter inputs, 2 gate inputs, 2 up/down changeovers
Nominal input voltage | 24 VDC (20 V ... 29 V)
Signal voltage "0" | -3 V ... 5 V (EN61131-2, type 2)
Signal voltage "1" | 11 V ... 30 V (EN61131-2, type 2)
Number of outputs | one output per counter, max. 0.5 A, short circuit proof
Sensor supply | derived from control voltage, max. 0.5 A over all, short-circuit proof
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 64 bits output (2 x 32) and 64 bits input (2 x 32) for process data, 8 bits output for Control Byte and 8 bits input for Status Byte
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the Parameterization description for details of the parameterization.

See the Mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP2512-Bxxx, IE2512

2-channel pulse width output 24 VDC

The outputs of the IP25x2 modules provide a pulse width modulated version of a binary signal. The mark/space ratio is prescribed by a 16 bit value from the automation unit. The output stage is protected against overload and short-circuit, the maximum output current is 2.5 A per channel. In addition to the pulse width modulation operating mode, the outputs can also be frequency modulated, or can be used to control stepper motors with specified pulses and direction. The modules contain two channels that indicate their signal state by means of light emitting diodes. The LEDs are driven in time with the outputs, and show the mark/space ratio by their brightness.

Technical data | IP2512-Bxxx / IE2512
Number of outputs | 2
Signal connection | M12 screw type
Load type | resistive, inductive
Rated load voltage | 24 VDC (-15%/+20%)
Output current | max. 2.5 A on each channel, individually short-circuit safe
Base frequency | 2 Hz ... 80 kHz, Default: 250 Hz
Keying ratio | 0 % ... 100 % (Ton > 750 ns, Toff > 500 ns)
Resolution | max. 10 bit
Freewheeling diode (output) | yes
Power supply connection | Feed: 1 x M8 male socket, 4-pin; downstream connection: 1 x M8 female socket, 4-pin
Bits width in process image | 2 x 16 output bits for process data, 2 x 8 output bits for control bytes and 2 x 8 input bits for status bytes
Electrical isolation | control voltage / fieldbus: yes channels / control voltage: no between the channels: no
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP5009-Bxxx, IE5009

1 channel SSI sensor interface

The IP5009 SSI interface module allows an SSI sensor to be connected directly. The sensor is powered via the SSI interface. The interface circuit generates a pulse for reading the sensor, and makes the incoming data stream available to the controller as a data word in the process image. The module can optionally provide the data as binary numbers or as a Gray code. Adaptation for the direction of rotation can be configured. Various operating modes, transmission frequencies and bit widths can be permanently stored in a control register.

Technical data | IP5009-Bxxx / IE5009
Number of channels | 1
Encoder connection | M23 screw-in, 12-pin
Signal type | Differential signal (RS485)
Sensor supply | 24 VDC, from load voltage
Data transfer rate | adjustable up to 1 MHz, 250 kHz preset
Serial input | 24 bits (adjustable)
Data direction | read
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | 32 input bits for process data, Optional: 8 output bits for control byte and 8 input bits for status byte
Electrical isolation | depends on the bus system
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See the derating description for details of the output current vs. frequency.

See dimension page for weight and dimensions.


IP5109-Bxxx, IE5109

1 channel Incremental Encoder Interface 1 MHz

The IP5109 module is an interface for the direct connection of incremental encoders with differential inputs (RS485/5V) or with single inputs. A 16 bit counter with a quadrature decoder and a 16 bit latch for the zero pulse can be read, set or enabled. The inputs can optionally be used as complementary or as single inputs.

The encoder's fault signal output, if there is one, can be connected to the status input of the interface. Interval measurement with a resolution of 200 ns is possible. The gate input allows the counter to be locked (high = stop).

A rising edge at the latch input from the encoder or an external sensor will store the current counter value.

Technical data | IP5109-Bxxx / IE5109
Number of channels | 1
Encoder connection | M23 screw-in, 12-pin
Gate/latch connection | M12 screw-in
Sensor supply | derived from control voltage, max. 0.5 A total, short-circuit safe
Counter | 16 bit binary
Sensor supply | 5 VDC
Limit frequency | 1 MHz (with 4-fold evaluation)
Quadrature decoder | 1, 2, or 4-fold evaluation
Zero pulse latch | 16 bit
Commands | Read, set, enable
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I/O: 2 x 16 bit data, 1 x 8 bit control/status
Electrical isolation | depends on the bus system
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Resistance to vibration | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP5209-Bxxx

1 channel SinCos encoder interface

The IP5209 Sinus/Cosinus module functions as a interface to the higher level fieldbus for direct connection of an measuring sensor, such as a sensing switch or encoder with 1Vss sinusoidal voltage output. The measuring signal is processed, interpolated and made available as a 32 bit value. The signal period resolution is 10 bit, i.e. 1024 steps. The interpolation rate can be changed via the register R35. The change of counting direction is set via R32. The reference mark (Latch) is also stored in a 32 bit value. The current value of the counter and the value of the reference mark can be read and can be set. The maximum frequency for the signal input is 100 kHz.

The input frequency and therefore the velocity of the sensor, can be checked against a preset limit. If this limit is exceeded, an error bit in the Status byte will be set!

Technical data | IP5209-Bxxx
Number of counters | 1
Encoder connection | M23 screw-in, 12-pin
Sensor supply | 5 VDC from the control voltage, max. 0.5 A
Limit frequency | 100 kHz (scanning of the input signals with 500 kHz)
Resolution | 10 bit, 1024 steps per period
Commands | Clear/set counter value, reference mark – latch, counting direction, scaling
Power supply | Feed: 1 x M8 connector, 4-pin; downstream connection: 1 x M8 socket, 4-pin
Bits in process image | I/O: 2(1) x 32 bit data (1 x 8 bit control/status)
Electrical isolation | depends on the bus system
Permissible ambient temperature during operation | 0°C ... +55°C
Permissible ambient temperature during storage | -25 °C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for the connector pin assignment.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP6002-Bxxx, IE6002

1 channel RS 232 gateway

The IP/IE6002 serial interface module allows the connection of devices with a RS232 interface. The interface operates in conformity with the CCITT V.28/DIN 66 259-1 standards. The module transmits the data in a fully transparent manner to the higher-level automation device. The data is transferred via the fieldbus using a simple handshake protocol. This does not have any effect on the protocol of the serial interface. The active serial communication channel functions independently of the higher-level bus system in full duplex mode at up to 19200 baud, while a 128 byte receive buffer and a 16 byte send buffer are available. The RS232 interface guarantees high immunity to interference through electrically isolated signals.

ip200x.jpg (29519 Byte)

Technical data | IP6002-Bxxx, IE6002
Number of channels | 1 TxD and RxD, full duplex
Data transfer rate | 1200 ... 19200 baud, 9600 baud (8 data bits, no parity, one stop bit)
RS 232 connection | 5 pin M12 socket, screw connection
Bit distortion | < 3 %
RS 232 cable length | max. 15 m
Signal voltage LOW | 3 V ... 18 V
Signal voltage HIGH | -18 V ... -3 V
Data buffer | 128 byte receive buffer and 16 byte send buffer
Bytes in the process image | I/O: 5 bytes user data, 1 byte control/status
Electrical isolation | control voltage / fieldbus: depends on the bus system RS232 / control voltage: 500 V
Permissible ambient temperature during operation | 0 °C ... 55 °C
Permissible ambient temperature during storage | -25 °C ... + 85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP6012-Bxxx, IE6012

1 channel TTY gateway

The IP/IE6012 module allows the connection of devices with a 20 mA current interface. The interface operates passively. The module transmits the data in a fully transparent manner to the higher-level automation device. The data is transferred via the fieldbus using a simple handshake protocol. This does not have any effect on the protocol of the serial interface. The active serial communication channel functions independently of the higher-level bus system in full duplex mode at up to 19200 baud, while a 128 byte receive buffer and a 16 byte send buffer are available.
The current interface guarantees high immunity to interference through electrically isolated signals with injected current.

ip200x.jpg (29519 Byte)

Technical data | IP6012-Bxxx, IE6012
Number of channels | 1
Data transfer rate | 1200 ... 19200 baud, 9600 baud (8 data bits, no parity, one stop bit)
TTY connection | 5 pin M12 socket, screw connection
Bit distortion | < 3 %
TTY cable length | max. 1000 m twisted pair
Signal voltage LOW | 0 ... 3 mA
Signal voltage HIGH | 14 ... 20 mA
Data buffer | 128 byte receive buffer and 16 byte send buffer
Bytes in the process image | I/O: 5 bytes user data, 1 byte control/status
Electrical isolation | control voltage / fieldbus: depends on the bus system TTY interface / control voltage: 500 V
Permissible ambient temperature during operation | 0 °C ... 55 °C
Permissible ambient temperature during storage | -25 °C ... + 85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


IP6022-Bxxx, IE6022

1 channel RS422/RS485 gateway

The IP/IE6022 module allows devices with an RS422 or RS485 interface to be connected. The module transmits the data in a fully transparent manner to the higher-level automation device. The data is transferred via the fieldbus using a simple handshake protocol. This does not have any effect on the protocol of the serial interface. The active serial communication channel functions independently of the higher-level bus system in full duplex mode at up to 19200 baud, while a 128 byte receive buffer and a 16 byte send buffer are available. The transmission of differential signals according to RS232 guarantees high immunity to interference through electrically isolated signals.

ip200x.jpg (29519 Byte)

Technical data | IP6022-Bxxx, IE6022
Number of channels | 1 RS 422 full duplex, RS 485 half duplex
Data transfer rate | 1200 ... 19200 baud, 9600 baud (8 data bits, no parity, one stop bit)
RS 422/485 connection | 5 pin M12 socket, screw connection
Bit transmission | using differential signal
Cable impedance | 120 Ω
RS 422/485 cable length | max. 500 m twisted pair
Data buffer | 128 byte receive buffer and 16 byte send buffer
Common mode voltage | -7 V ... 12 V to ground
Bytes in the process image | I/O: 5 bytes user data, 1 byte control/status
Electrical isolation | control voltage / fieldbus: depends on the bus system RS422/485 / control voltage: 500 V
Permissible ambient temperature during operation | 0 °C ... 55 °C
Permissible ambient temperature during storage | -25 °C ... + 85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable

See the connection diagram for details of the connection.

See the parameterization description for details of the parameterization.

See the mapping description for details of the mapping.

See dimension page for weight and dimensions.


Fieldbusbox - Dimensions

BECKHOFF Fieldbus Box: Mounting and wiring

Dimensions

All dimensions are given in millimeters.

General

Technical data | Fieldbus Box
Material | PA6 (polyamide), casting compound: polyurethane
Assembly | 2 x fixing holes for M3
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | according to EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
Permissible ambient temperature during operation | 0 ... 55°C
Permissible ambient temperature during storage | -25 ... + 85°C
Installation position | any
Type of protection | IP65/66/67 when screwed together
Approvals | CE, UL E172151

IPxxxx-Bxx8, IL230x-Bxx8, IL230x-B110, IXxxxx-B400, IXxxxx-B90x, IXxxxx-C900

Technical data | Compact and Coupler Box with integrated tee connector
Dimensions (H x W x D) | ca. 210 x 30 x 26,5 mm (height to upper edge of fieldbus socket: 30 mm)
Weight | ca. 260 g - 290 g, depending on module type

IPxxxx-Bxx0, IL230x-Bxx0, IL230x-Cxx0

Technical data | Compact and Coupler Box
Dimensions (H x W x D) | Approx. 175 x 30 x 26.5 mm (height to upper edge of fieldbus socket: 30 mm, with T- connector ZS1031-2600 height approx. 65 mm)
Weight | Approx. 250 g - 280 g, depending on module type

IExxxx

Technical data | Extension box
Dimensions (H x W x D) | Approx. 126 x 30 x 26.5 mm
Weight | Approx. 120 g - 200 g, depending on module type


Fixing

Attention

While mounting the modules, protect all connectors, especially the IP-Link, against contamination!

Only with connected cables or plugs the protection class IP67 is guaranteed!
Unused connectors have to be protected with the right plugs (see for plug sets in the catalogue)!

Fieldbus Boxes are fastened with two M3 bolts. The bolts must be longer than 15 mm. The fixing holes are not threaded. When assembling, remember that a Y or T piece for fieldbus connection increases the overall height. See chapter accessories.

The space between the modules should be at least 4 cm, so that the IP-Link cable is not bent to a radius smaller than 50 mm. The extension modules may be mounted close to one another, provided you observe the following:

  • The bending radius of the IP-Link cable must not be tighter than the permitted minimum.
  • The ambient temperature must not exceed 55°C.

Einbauvorschrift_IL_IE_Module.jpg (17147 Byte)

Mounting Rail ZS5300-0001

The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of Extension Box modules. The rail is made of stainless steel, 1.5 mm thick, with already premade M3 threads for the modules. The rail can be mounted at the machine with M5 screws (5.3mm slots).

The rail is 500 mm long, that way 15 modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.

Attention With mounting rail ZS5300-0001 use the IP-Link Direct Connector ZK1020-0101-1000 to avoid to fall below the minimum bending radius (50 mm) for standard IP-Link cable.

IP-Link Direct Connector ZK1020-0101-1000

The IP-Link direct connector allows the direct connection of two Extension Box modules for an easy side-by-side mounting.

With IP-Link Direct Connector, the mounting distance between the modules is from 0 to 5 mm.


Fieldbus Box - Nut tourque for connectors

BECKHOFF Fieldbus Box: Mounting and cabling

Nut torque for connectors

M8 connectors

It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm.

M12 connectors

It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.

Torque socket wrenches

Note
Ensure the right torque

Use the torque socket wrenches available by Beckhoff to pull the connectors tight (see accessories)!


Power Connection

Control voltage Us: 24V

Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.

Load voltage Up 24V

The load voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off (e.g. if the emergency off has been used) the fieldbus functions and the power supply and functionality of the inputs are retained.

Redirection of the supply voltages

The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from Fieldbus Box to Fieldbus Box.

Warning For the redirection of the supply voltage Us and Up, the maximum permissible current of 4 A must not be exceeded!

Electrical isolation

Digital modules

In the digital input/output modules, the grounds (GND) of the control voltage and the load voltage are connected!

Analog modules

In the analog input/output modules these grounds are separated in order to ensure electrical isolation of the analog signals from the control voltage. In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0..10V inputs, any reference voltage (0...30V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers). Details of the power supply to analog modules should therefore be consulted in the section on Signal types.

Warning If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes are no longer electrically isolated from the control voltage!

PIN assignment (not IP204x-Bxxx and IE204x)

PIN assignment (IP204x-Bxxx and IE204x)

sbsupply2.gif (7053 Byte)

See also potential groups in Chapter IP204x-Bxxx / IE204x signal connection.


Supply Line and Power Supplies

General

In Fieldbus Boxes, a maximum of 4 A may flow through each pin - this applies to every module, and to all the connection versions: S8, M8 and M12.

Points you must watch

  • Current consumption of the Fieldbus Boxes (see Current consumption)
  • Current consumption of the sensors
  • Current consumption of the actuators
  • Cable length, and losses in the leads (see Conductor losses)
  • If the power line is taken on to other devices, ensure that the maximum current is not exceeded (see previous points)

Note:

Example 1:

If, for example, all 8 outputs of an IP2001-Bxxx are loaded simultaneously with 0.5 A, then in this case the power continuation facility must not be used, as this could result in destruction of the connection or of the device.

Example 2:

Channels 0..3 of an IP/IE204x are connected, which means that only 2 of the 4 channels may be loaded with 2 A.


ZK2020 - Power cable conductor losses

BECKHOFF Fieldbus Components: Mounting and cabeling

Power cable conductor losses

The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.

Example

8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.


FBB I/O modules - Current Consumption

BECKHOFF Fieldbus Box: Cabeling

Current Consumption

It is important to know the current consumption of the individual modules in order to know how much current is available, and for fusing the modules as well as considering the voltage drop in the power lead supply. The following table contains the current consumption at 24 VDC. Current for supplying the sensors and that eventually required for the outputs must be added on to these figures.

I/O type Compact Box
Modules | −B310 | −B510, −B520 | −B730, −B800, −B810
IP1000−Bxxx, IP1001−Bxxx, IP1002−Bxxx, IP1010−Bxxx, IP1011−Bxxx, IP1012−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP1502-Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2000−Bxxx, IP2001−Bxxx, IP2002−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2020−Bxxx, IP2021−Bxxx, IP2022−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2040−Bxxx, IP2041−Bxxx, IP2042−Bxxx | Is = 90 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP2300−Bxxx, IP2301−Bxxx, IP2302−Bxxx, IP2310−Bxxx, IP2311−Bxxx, IP2312−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2320−Bxxx, IP2321−Bxxx, IP2322−Bxxx, IP2330−Bxxx, IP2331−Bxxx, IP2332−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2400−Bxxx, IP2401−Bxxx | Is = 90 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA | Is = 50 mA Ip = 5 mA
IP2512−Bxxx | Is = 85 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA | Is = 45 mA Ip = 5 mA
IP3102−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3112−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP3202−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP3312−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP4112−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP4132−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5009−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5109−Bxxx | Is = 140 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA | Is = 105 mA Ip = 5 mA
IP5209−Bxxx | Is = 110 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA | Is = 70 mA Ip = 5 mA
IP6002−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6012−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
IP6022−Bxxx | Is = 115 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA | Is = 85 mA Ip = 35 mA
I/O type Coupler Box
Modules | −B310 | −B510, −B520 | −B730, −B800, −B810
IL2300−Bxxx, IL2301−Bxxx, IL2302−Bxxx | Is = 100 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA | Is = 60 mA Ip = 5 mA
IL2300−Cxxx, IL2301−Cxxx, IL2302−Cxxx | Is = 100 mA Ip = 5 mA | − | −
I/O type Extension Box
Modules |
IE1000, IE1001, IE1002, IE1010, IE1011, IE1012 | Is = 25 mA Ip = 5 mA
IE1502 | Is = 25 mA Ip = 5 mA
IE2000, IE2001, IE2002 | Is = 25 mA Ip = 5 mA
IE2020, IE2021, IE2022 | Is = 25 mA Ip = 5 mA
IE23xx, IE240x | Is = 25 mA Ip = 5 mA
IE2512 | Is = 25 mA Ip = 5 mA
IE2808 | Is = 40 mA Ip = 5 mA
IE3102 | Is = 55 mA Ip = 5 mA
IE3112 | Is = 55 mA Ip = 5 mA
IE3202 | Is = 40 mA Ip = 5 mA
IE3312 | Is = 40 mA Ip = 5 mA
IE4112 | Is = 40 mA Ip = 5 mA
IE4132 | Is = 40 mA Ip = 5 mA
IE5009 | Is = 55 mA Ip = 5 mA
IE5109 | Is = 55 mA Ip = 5 mA
IE6002 | Is = 40 mA Ip = 5 mA
IE6012 | Is = 40 mA Ip = 5 mA
IE6022 | Is = 40 mA Ip = 5 mA


Wiring the IP-Link

IP-Link is the subsidiary bus system for Fieldbus Boxes. Topologically, it is a ring. The IP-Link master is located in the Coupler Box (IL230x-Bxxx or IL230x-Cxxx). The extension boxes (IExxxx) are slaves. A maximum of 120 extension boxes may be connected. Additionally the available address range of the according Fieldbus Box coupler has to be considered. The distance between two extension boxes may not exceed 15 meter. When planning and installing the extension boxes, note that the last extension box in the optical fiber ring must be connected to the coupler box.

Structure/Topology

Line structure

In this case only every second extension boxes is connected. Note here that the maximum distance of the last extension box is halved.

Example

You have 4 extension boxes (4 x 15 m = 60 m). Because only every second extension box is connected to the outward line, the maximum distance for the last extension box becomes 30 meter.

Ring structure

In this case the first and last extension box must each be no more than 15 meter from the Coupler Box.

IL-Link Vekabelung Ring.jpg (15983 Byte)

Technical Data

IP-Link
 | IP-Link
Baud Rate | 2 Mbaud
Medium | Light
Number of devices | max. 120
Distance between two stations | 15 m
Cable | Plastic optical fiber 1000 um - single fiber core, PUR cladding with Kevlar fiber, diameter 5.5 mm
IP link connector | only ZS1020-0010 is permitted
Extraction force | 20 N - 30 N
IP-Link Z1101 Cable
 | Z1101
Nominal external diameter | 5.5 mm
Cladding thickness | 1.4 mm
Fiber | Plastic fiber optic 980/1000 µm, PMMA
Core | PE cladding, 2.2 mm nominal diameter
Temperature | -20...+70°C
External cladding material | PUR
Nominal weight kg/km | 25
Tensile strength (DIN VDE 0888 Part 100 Procedure 501) | Continuous 100 N Momentary 400 N
Bending radius | Radius minimum 50 mm
Alternating bending strength (DIN VDE 0888 Part 100 Procedure 509) | 30,000 cycles
drag chain approval | Radius 10 x diameter, 2 Mio. cycles
Attenuation at 650 nm | < 200 dB/km


Preparing the IP-Link cable

Required tools:
  • Side cutter
  • Stripping tool
  • Abrasive paper (grain size 600)
Note During stripping of the insulation and installation please ensure that
  • the optical fiber is not kinked and
  • the bending radius is not below the minimum radius of 50 mm! Tighter bending radii my damage the optical fiber.
  • during the mounting, it is very helpful to fix the core against movement. This can be done by holding the fiber in a loop (picture). The smaller bending radius does not damage the cable, if it is only for short while.

With mounting rail ZS5300-0001 use the IP-Link Direct Connector ZK1020-0101-1000 to avoid to fall below the minimum bending radius (50 mm) for standard IP-Link cable.

Fixing the fiber core for preparing

IP Link Connector

IP-Link connector (1) with cap (2)

Preparing the cable end

IP-Link Stecker Kabel.jpg (36044 Byte)

  • First slide the cap of the IP-Link connector (2) onto the optical fiber cable.
  • Shorten the orange-colored outer sheath (A) by approximately 23 mm without damaging the Kevlar fibers (K) below.
  • Shorten the Kevlar (K) to approx. 19 mm.
  • Fold back the yellow Kevlar fibers (K) over the outer sheath (A).
  • Shorten the black fiber sheath (U) by approximately 17 mm without damaging the optical fiber (L) below.

Installation of the IP-Link connector

  • Slide the IP-Link connector (1) onto the optical fiber cable until it is in contact with the Kevlar fibers (4) that were folded over the outer sheath (3).
  • Screw the connector clockwise onto the outer sheath until it cannot be turned further by hand (hand-tight). Do not use any tools! The plug is designed to cut a thread into the black fiber sheath (5) during this process.
    If the cable was stripped correctly, the optical fiber (6) now protrudes approximately 8 mm from the IP-Link connector (1).
  • Cut the Kevlar fibers protruding from the back of the IP-Link connector without damaging the outer sheath.
  • Slide the cap (2) on the optical fiber cable against the IP-Link connector (1) from behind until it engages.
  • Cut the optical fiber protruding from the front of the IP-Link connector approximately 2 mm from the tip of the connector. Be careful not to cut shorter, since the fiber is very hard and can splitter.
  • Sand the optical fiber with abrasive paper, grain size 600, until only approximately 0.4 mm protrude from the tip of the connector. Avoid damaging the connector!
  • Remove any grinding dust and an eventual burr using a clean, lint-free cloth.

Checking the fiber ends (visual inspection)

Check the sanded fiber ends:

  • The end of the optical fiber cable must have a clean, level surface at right angles to the connector guide, protruding approximately 0.4 mm from the tip of the connector.

  • Point one cable end to a light source. At the other cable end, no scratches, cracks or splintering should be visible in the illuminated fiber.

Order information

ZS1020-0010: IP-Link connector, packaging unit 1 item
ZS1021-0010: IP-Link connector, packaging unit 10 items


Assembling of the ZS1022-0010 IP-Link Plug (clip type)

Preparation (Exploded view)

A: fiber optic
B: outer jacket
C: Kevlar fiber
D: fiber jacket
E: fiber core
F: locking cap
G: O-ring
H: sleeve
I: connector housing
  1. Strip cable jacket according to indicated lengths of outer and fiber jacket.
    ATTENTION:
    The fiber core should not be damaged!
  2. Cut the Kevlar fiber to the same length of the outer jacket.
    ATTENTION:
    In order to reach maximum clamping force outer and fiber jacket have to be free of deformation (scores, etc.) as well as of grease, oil and lubricant.

Assembly

  1. Pull the sleeve over the outer jacket and the O-ring over the locking cap.
  2. Insert the prepared fiber-optic in the connector housing until outer jacket hits L and fiber jacket hits K simultaneously.
  3. Align the connector housing as required in order to prevent a possible torsion of cable.
  4. Pull the sleeve over the connector housing until it radially latches.
  5. Press the locking cap into the connector housing until all 4 nibs latch. This operation can be implemented without tools or with corresponding pliers. Keep correct mounting position M of the locking cap. The correct mounting of the O-ring can be checked with the latching holes N.

Surface treatment

  1. Treat the fiber core with grinding gauge O up to the final dimension and intended quality.
    For this purpose take sand paper with grain size 600, and work on a smooth surface.
  2. Insert the mounted connector in the grinding gauge and treat the surface with a rotary movement.
  3. Remove grinding dust with a clean lint-free cloth.
  4. Check the quality of the grinded surface.
    The surface has to be smooth and free of scratches, grooves and splinters.

Disassembly

  1. Apply appropriate tool at cut-out P or Q.
  2. Lift out the locking cap from the closed connector housing.
    ATTENTION:
    Damaged or deformed components should not be applied again after disassembly.
  3. Prepare fiber-optic sensor after disassembly according to point 1 again.

Ordering note

ZS1022-0010: IP-Link connector (clip type), packaging unit 10 items


Examples for prepared IP-Link connectors

The photos were taken by using a white flash light shining into the opposite end of the cable.

Right:

A correct IP-Link connector should look like this:

The fiber is stays slightly above the connector tip and is almost rectangular. No damage of the fiber is visible.

Wrong:

This fiber was cut to short before the connector, it split into the connector and cannot be sanded correctly (dark part is visible).
This connector has be done over.

Wrong:

Here, the fiber was cut to short in the preassemble phase. the fiber does not even reach the connector tip.
This whole connector has to be done over.

Wrong:

The fiber was sanded correctly. It has a clean, undisturbed light emission.

But the fiber is to long. This way it could damage the optical elements of the modules.
It can very simply be corrected by sanding down the fiber carefully to the correct measurement.


Fieldbus Box - Check of the IP-Link connection

BECKHOFF Fieldbus Box: Mounting and wring

Check of the IP-Link connection

A correct assembled IP-Link cable will assure an error free transmission.

An additional testing of the transmission quality and error diagnostics is possible with the KS2000 configuration software.

For this test, the fieldbus master (e.g. a PROFIBUS PC Card) should be on the bus and it should transmit data cyclical. Another way to generate cyclic data is, to switch the coupler to free running via the KS2000 software.

The result should be, that the I/O RUN LED flashes in a bright green. This shows, that a data exchange with the connected extension boxes takes place. A red blinking I/O ERR LED shows faulty IP-Link telegrams. These faulty telegrams will be repeated automatically like in any other fieldbus system. This way a transmission of the data is guaranteed.

Error counter

Table 90, offset 005 shows possible IP-Link errors. Sporadic appearing errors do not mean any problem for the communication, as long as they do not reach a critical limit.

This error counter is only reset by the Power ON/OFF.

If lots of errors occur in a very short time, this will be interpreted as a heavy disturbance of the communication and the coupler box will report this error. This can be seen at offset 006 and 007. Both values will show a value > 200 and the I/O ERR LEDs of the coupler box will blink the according error code.

Note The KS2000 Configuration Software communicates with the Coupler Box via the serial channel. The content of the registers will not be refreshed automatically.

Position of the error

In case of an IP-Link error, the Coupler Box tries to read the error location from the register of the Extension Box. If the fiber optic ring is interrupted or the communication is heavily disturbed, this is not possible. Only the position of the last functioning Extension Box before the receiver of the Coupler Box can be recognized. The box will then flash this error code via the I/O ERR LED.

If the communication via IP-Link is still running, table 87 shows the error counter of each Extension Box.

The offset register corresponds to the position of the Extension Box in the KS2000 tree (left side of graphic). This example shows errors at offset 004 and 006.

In the "real" world the faulty IP-Link telegram was reported from the IE20xx and the IE3112, that means the problem has to looked for before these modules.

The error can be up to:

  • the sending module
  • the receiving module
  • the IP-Link cable
  • the connectors

If there is an error in table 90 and none in table 87, the faulty transmission is between the last Extension Box and the Coupler Box.

In most cases the transmission errors can be traced back to bad configured IP-Link connectors or a too high attenuation of the cable due to sharp bending.

The values of table 87 directly come from the extension boxes. In case of an IP-Link interruption these values will be set to zero and only table 90 can be used.

Note If you want to operate a Coupler Box (e.g. IL2300-Bxxx, IL2301-Bxxx or IL2302-Bxxx ) totally without Extension Box Modules (IExxxx), you have to connect the send and receive socket of this Coupler Box directly by using an IP Link Cable! For this the IP Link Jumper ZK1020-0101-1000 fits perfect.


IP100x-Bxxx, IE100x Signal Connection

8 Channel Digital Input 24 VDC, Filter 3.0 ms

The IP100x digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The state of the signals is indicated by light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP1000), screw-in M8 connectors (IP1001) or screw-in M12 connectors (IP1002). The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.

sb10xx.gif (12412 Byte)


IP101x-Bxxx, IE101x Signal Connection

8 Channel Digital Input 24 VDC, Filter 0.2 ms

The IP101x digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The state of the signals is indicated by light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP1010), screw-in M8 connectors (IP1011) or screw-in M12 connectors (IP1012). The sensors are supplied from the control voltage US. The load voltage UP is not used in the input module, but may be connected in order to be relayed downstream.


IP1502-Bxxx, IE1502 Signal Connection

2 Channel, up/down counter, 24 VDC, 100 kHz

The counter module is connected as follows:
The counting pulse for counters 1 and 2 is connected via socket A (counter connection). The counting direction (up/down) can be specified via socket B. At socket C (gate signal), the gate signal can freeze the counter state; the clock signals are ignored. The output is provided via socket D. The outputs are powered via UP. The Fieldbus Box and the signals for the sensor are controlled via US.


IP200x-Bxxx, IE200x Signal Connection

8 Channel Digital Output 24 VDC, Imax = 0.5 A

The IP200x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2000), screw-in M8 connectors (IP2001) or screw-in M12 connectors (IP2002). The outputs are short-circuit safe and protected against inverse connection.


IP202x-Bxxx, IE202x Signal Connection

8 Channel Digital Output 24 VDC, Imax = 2.0 A, total current 4 A

The IP202x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 2.0 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2020), screw-in M8 connectors (IP2021) or screw-in M12 connectors (IP2022). The outputs are short-circuit safe and protected against inverse connection.

Warning The total current must not be exceeded. This means that a maximum of two outputs with a load of 2 A each may be switched on at the same time.


IP204x-Bxxx, IE204x Signal Connection

8 Channel Digital Output 24 VDC, Imax = 2.0 A, total current 12 A

The IP204x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 2.0 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2040), screw-in M8 connectors (IP2041) or screw-in M12 connectors (IP2042). The outputs are short-circuit safe and protected against inverse connection.

Potential Groups

There are three inlets for this module's load voltage. UP1 for channels 0-3 (total current 4 A), UP2 for channels 4-5 (total current 4 A) and UP3 for channels 6-7 (total current 4 A).

The total current must not be exceeded. This means that a maximum of two outputs from channels 0-3 with a load of 2 A each may be switched on at the same time.

See also Chapter Technical data.


IP230x-Bxxx, IL230x-Bxxx, IL230x-Cxxx, IE230x, IE230x Signal Connection

BECKHOFF Fieldbus Box: Cabeling

IP230x-Bxxx, IL230x-Bxxx, IL230x-Cxxx, IE230x Signal Connection

4 Channel Digital Output 24 VDC, Imax = 0.5 A, 4 digital inputs, 3.0 ms filter

The IP230x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 4 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via Ø 8 mm snap-in plugs (IP2300), screw-in M8 connectors (IP2301) or screw-in M12 connectors (IP2302). The outputs are protected against short circuit and against inverse connection, and are located on the lower half of the Fieldbus Box. In the S8 and M8 these are the lower 4 sockets, and on the devices with M12 connections they are the bottom two; in the M12 version, 2 outputs are located at one socket.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs, screw-in M8 connectors or screw-in M12 connectors. The inputs are located on the upper half of the Fieldbus Box. In the S8 and M8 these are the upper 4 sockets, and on the devices with M12 connections they are the upper two; in the M12 version, 2 inputs are located at one socket.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If Up and US are used for passing the power on, the maximum current must not exceed 4 A.


IP231x-Bxxx, IE231x Signal Connection

4 Channel Digital Output 24 VDC, Imax = 0.5 A, 4 digital inputs, 0.2 ms filter

The IP231x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 4 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2300), screw-in M8 connectors (IP2301) or screw-in M12 connectors (IP2302). The outputs are short-circuit safe and protected against inverse connection. The outputs are located on the lower half of the Fieldbus Box. In the S8 and M8 these are the lower 4 sockets, and on the devices with M12 connections they are the bottom two; in the M12 version, 2 outputs are located at one socket.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The state of the signals is indicated by light emitting diodes. The signals are optionally connected via Ø 8 mm snap-in plugs, screw-in M8 connectors or screw-in M12 connectors. The inputs are located on the upper half of the Fieldbus Box. In the S8 and M8 these are the upper 4 sockets, and on the devices with M12 connections they are the upper two; in the M12 version, 2 inputs are located at one socket.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed 4 A.


IP232x-Bxxx, IE232x Signal Connection

4 Channel Digital Output 24 VDC, Imax = 2.0 A, 4 digital inputs, 3.0 ms filter

The IP232x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 4 outputs handle load currents of up to 2.0 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2320), screw-in M8 connectors (IP2321) or screw-in M12 connectors (IP2322). The outputs are protected against short circuit and against inverse connection, and are located on the lower half of the Fieldbus Box. In the S8 and M8 these are the lower 4 sockets, and on the devices with M12 connections they are the bottom two; in the M12 version, 2 outputs are located at one socket.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs, screw-in M8 connectors or screw-in M12 connectors. The inputs are located on the upper half of the Fieldbus Box. In the S8 and M8 these are the upper 4 sockets, and on the devices with M12 connections they are the upper two; in the M12 version, 2 inputs are located at one socket.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed 4 A.


IP233x-Bxxx, IE233x Signal Connection

4 Channel Digital Output 24 VDC, Imax = 2.0 A, 4 digital inputs, 0.2 ms filter

The IP233x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 4 outputs handle load currents of up to 2.0 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-in plugs (IP2330), screw-in M8 connectors (IP2331) or screw-in M12 connectors (IP2332). The outputs are short-circuit safe and protected against inverse connection. The outputs are located on the lower half of the Fieldbus Box. In the S8 and M8 these are the lower 4 sockets, and on the devices with M12 connections they are the bottom two; in the M12 version, 2 outputs are located at one socket.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs, screw-in M8 connectors or screw-in M12 connectors. The inputs are located on the upper half of the Fieldbus Box. In the S8 and M8 these are the upper 4 sockets, and on the devices with M12 connections they are the upper two; in the M12 version, 2 inputs are located at one socket.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed 4 A.


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401 Signal Connection

BECKHOFF Fieldbus Box: Cabeling

IP240x-Bxxx, IE240x Signal Connection

8 Channel Digital Output 24 VDC, Imax = 0.5 A, 8 digital inputs, 3.0 ms filter

The IP240x digital output modules connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs (IP2400) or screw-in M8 connectors (IP2400). The outputs are short-circuit safe and protected against inverse connection. One output is located together with one input on an S8 or M8 socket.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via 8 mm snap-on plugs or screw-in M8 connectors.
The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed 4 A.


IE2403 signal connection

8 Channel Digital Output 24 VDC, Imax = 0.5 A, 8 digital inputs, 3.0 ms filter

The IE2403 digital output module connect the binary control signals from the automation unit on to the actuators at the process level. The 8 outputs handle load currents of up to 0.5 A, and indicate their status through light emitting diodes. The signals are optionally connected via several KM connectors. The outputs are short-circuit safe and protected against inverse connection.

The digital inputs acquire the binary control signals from the process level and transmit them to the higher-level automation unit. The signal state is indicated by means of light emitting diodes. The signals are optionally connected via several KM-connectors.

The sensors are supplied from the control voltage US. The load voltage, UP, is required for the output drivers. If UP and US are used for passing the power on, the maximum current must not exceed 4 A.

Inputs

The picture shows connection of 8 sensors in single-wire and of respectively one sensor in two- and three-wire connection.
Please pay attention for KM connector ZS2001-0004: two bridges (24 V und 0 V) are necessary to feed the terminal points for two- and three-wire connection.

Outputs

The picture shows connection of 8 actuators in single-wire and of respectively one actuator in two- and three-wire connection.
Please pay attention for KM connector ZS2001-0004: two bridges (24 V und 0 V) are necessary to feed the terminal points for two- and three-wire connection.

Power supply

(See also chapter Power Connection)

The combi module IE2403 is fed via the left M8 screwing connector (IN).
The sensors are fed from control voltage US. The load voltage UP is needed for the output drivers.

The right M8 screwing connector (OUT) is for forwarding the supply voltages to the next IP module.
If UP and US are forewarded, the maximum current must not exceed 4 A.


IP2512-Bxxx, IE2512 Signal Connection

2 Pulse With Outputs, 24 VDC

The Pulse With Module has to be connected as follows:


IE2808 Signal Connection

8 digital outputs 24 VDC, Imax = 0,5 A

The IE2808 digital output module connects the binary control signals from the automation unit on to the actuators at the process level.

The 16 outputs deliver load currents of up to 0.5 A, although the total current of all outputs must not exceed 4 A.

The signal connection is realized by the 25-pin D-sub socket. The outputs are short-circuit safe and protected against inverse connection.


IP3102-Bxxx, IE3102 Signal Connection

4 Channel Analog Input, -10 to +10 V

The signal is measured using a differential signal. If two lines are not available for differential measurement at your sensor (e.g. 24 V, GND and signal), then GND must be short-circuited to Input.

Pin 5 (shield) is capacitatively coupled to the chassis of your Fieldbus Box.

Supply voltage

US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.

UP - Is not required for the function of the module, and does not have to be fed in.

Warning If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED indicates that there is an error (broken conductor, measured value outside the range).
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP3112-Bxxx, IE3112 Signal Connection

4 Channel Analog Input 0 to 20 mA

The signal is measured using a differential signal. If two lines are not available for differential measurement at your sensor (e.g. 24 V GND and signal), then GND must be short-circuited to Input.

Pin 5 (shield) is capacitatively coupled to the chassis of your Fieldbus Box.

Supply voltage

US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.

UP - Is not required for the function of the module, and does not have to be fed in.

Warning If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED indicates that there is an error (broken conductor, measured value outside the range).
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP3202-Bxxx, IE3202 Signal Connection

4 Channel Analog Input PT100 (RTD)

The advantage of four-wire technique is that the error resulting from the cable and contacts is included in the measurement and cancelled out. In the 3-wire technique, the conductor resistance to the resistance sensor is measured in one direction only, and is multiplied by two. This requires the outward and return lines to have approximately the same ohmic resistance. An error is present in the two-wire technique; temperature differences and cable cross-sections can make this error vary considerably.

Warning The connection type, 2-, 3- or 4-wire has to be the same for all four channels!

Pin 5 (shield) is capacitatively coupled to the chassis of your Fieldbus Box.

Supply voltage

US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.

UP - Is not required for the function of the module, and does not have to be fed in.

Warning If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED indicates that there is an error (broken conductor, measured value outside the range, temperature compensation outside the valid range).
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP3312-Bxxx, IE3312 Signal Connection

4 Channel Analog Input Thermocouple

The temperature compensation is brought to the outside in the IP/IE3312 modules. This means that in the connector the temperature compensation is measured directly at the connection point. This allows the temperature to be measured with significantly better accuracy. Beckhoff offer a connector (ZS2000-3712) for this. The temperature compensation can also be carried out at a location other than the Fieldbus Box. You must then wire a PT1000 between pins 1 and 3. The longer the cables you choose to use, the larger is the measurement error caused by the length of the conductor, conductor losses and interference.

Pin 5 (shield) is capacitatively coupled to the chassis of your Fieldbus Box.

Supply voltage

US - supplies the electronics for the fieldbus and for the sensor. It is electrically isolated from UP.

UP - Is not required for the function of the module, and does not have to be fed in.

Warning If you use UP to pass the power on, and you connect a module in which US and UP are not electrically isolated (e.g. any digital module) then the electrical isolation is removed by the downstream connection.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED indicates that there is an error (broken conductor, measured value outside the range, temperature compensation outside the valid range).
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP4112-Bxxx, IE4112 Signal Connection

4 Channel Analog Outputs, 0 to 20 mA

The actuator is connected via Output +/-. The actuator can also optionally be operated/supplied with 24 VDC. The shield his capacitatively coupled to the chassis. In order to ensure that interference is effectively dissipated, the chassis must be conductive and earthed through a low resistance.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED has no function, and only illuminates briefly during the start-up phase.
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP4132-Bxxx, IE4132 Signal Connection

4 Channel Analog Outputs -10 to +10 V

The actuator is connected via Output +/-. The actuator can also optionally be operated/supplied with 24 VDC. The shield his capacitatively coupled to the chassis. In order to ensure that interference is effectively dissipated, the chassis must be conductive and earthed through a low resistance.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The Run LED illuminates when data is being transferred to the D/A converter. The red Error LED has no function, and only illuminates briefly during the start-up phase.
The device is functioning correctly if the Run LED is lit and the Error LED is unlit.


IP5009-Bxxx, IE5009 Signal Connection

1 Channel SSI Sensor Interface

The module has a M23 female connector with an external thread.

The SSI Sensor Interface has to be connected as follows:

Meaning of the LEDs

The green LEDs show the operation mode of the module.


IP5109-Bxxx, IE5109 Signal Connection

1 channel Incremental Encoder Interface, 1 MHz

The module has a M23 female connector with an external thread and a M12 female connector with internal thread..

The incremental encoder interface is connected as follows:
The encoder is connected to the M23 via A, B and Null. If the encoder has an error signal output, this can be connected via Status input.

The encoder can be enabled by means of Gate on the M12 connector. Latch can be used, for instance, to connect an external sensor by means of which acquisition of the latched value can be enabled.

Meaning of the LEDs

The green LEDs show the status of the channels A, B and C.


IP5209-Bxxx Signal Connection

1 channel SinCos encoder interface

The module has a M23 female connector with an external thread.

  • the 1 Vss- version IP5209-Bxxx-0000 does have a 12-pin connector.
  • the 11 µAss version IP5209-Bxxx-1000 does have a 9-pin connector.
  • the model IP5209-Bxxx-0000 (version for 1 VSS) does have a 12-pin connector.
  • the model IP5209-Bxxx-1000 (version for 11 µASS) does have a 9-pin connector.

The sensing switch is connected via an M23 connector. This is usually directly hard-wired through a cable to the sensing switch, and contains adapting electronics. The sensing switch/encoder/sensor is supplied with the necessary voltage from the module!

The sine and cosine signals and the reference mark (zero point) are transmitted.


IP6002-Bxxx, IE6002 Signal Connection

1 channel RS 232 gateway

The RS 232 interface implements full duplex data transmission.

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The green Run LED lights up when data is being transmitted. The red Error LED lights when an error is detected in the data transmission.


IP6012-Bxxx, IE6012 Signal Connection

1 channel TTY gateway

Full duplex transmission is possible through the TTY interface. The module is entirely passive, and therefore current for the data transmission must be supplied by the connected device. If the connected device is also a passive current interface, then the current must be separately supplied (see Fig. 2).

Fig. 1: TTY interface connector pin assignment

Fig. 2: Connection to a passive TTY device

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The green Run LED lights up when data is being transmitted. The red Error LED lights when an error is detected in the data transmission.


IP6022-Bxxx, IE6022 Signal Connection

1 channel RS 422 / RS 485 Gateway

The module can be operated as an RS 422 full duplex device or as an RS 485 half duplex device. To operate it as an RS485 device, ensure that PIN 1 and 3 and PIN 2 and 4 are bridged. The shield is capacitatively coupled to the chassis. If the shield is to effectively suppress interference, the chassis to which the module is fastened must have a low-resistance connection to ground.

Connection example for RS 485 transmission

M12_Connector_6022.jpg (12378 Byte)

LED indicators - meanings

There is a green Run LED and a red Error LED for each channel. The green Run LED lights up when data is being transmitted. The red Error LED lights when an error is detected in the data transmission.


ZS2001 - Ordering Information

BECKHOFF ZS2001: Product Overview

Ordering information for KM plug-in connector

KM plug-in connector for single-wire connection (ZS2001-0001, ZS2001-0002) | KM plug-in connector for tree-wire connection (ZS2001-0004)
Ordering name | Signal LEDs | Wiring technique
 |  | single-wire | two-wire | three-wire
ZS2001-0001 | no | yes | no | no
ZS2001-0002 | yes | yes | no | no
ZS2001-0004 | yes | yes | yes | yes


ZS2001 - Technical Data

BECKHOFF ZS2001: Product Overview

Technical Data

Technical Data | ZS2001-0001 | ZS2001-0002 | ZS2001-0004
Number of terminal points | 10 | 10 | 30
Signal LEDs | no | yes | yes
Nominal voltage | 50 VDC | 24 VDC | 24 VDC
Nominal current | 2 A
Wire size with | 0,5 mm2 ... 1,5 mm2
Wire stripping length | 8 mm
Dimensions (w x h x d) | app. 42mm x 10,3mm x 26,9mm | app. 42mm x 12,7mm x 26,9mm | app. 42mm x 20,8mm x 26,9mm
Weight | app. 10 g | app. 10 g | app. 20 g
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20
Installation position | variable
Approval | CE


FBB I/O modules - Overview of the Block Diagrams

BECKHOFF Fieldbus Box: Block Diagrams

Overview of the Block Diagrams

Type | Description | Drawing
IP/IE1xxx | 8 digital inputs 24 VDC | Block Diagram
IP/IE1502 | Up/down counter, 24 VDC, 100 kHz | Block Diagram
IP/IE200x | 8 digital outputs 24 VDC, 0.5 A | Block Diagram
IP/IE202x | 8 digital outputs 24 VDC, 2.0 A, total = 4 A | Block Diagram
IP/IE204x | 8 digital outputs 24 VDC, 2.0 A, total = 12 A | Block Diagram
IP/IE23xx | 4 digital inputs 24 VDC, 4 digital outputs 24 VDC | Block Diagram
IP/IE2400, IP/IE2401 | 8 digital inputs 24 VDC, 8 digital outputs 24 VDC | Block Diagram
IE2403 (IP20) | 8 digital inputs 24 VDC, 8 digital outputs 24 VDC | Block Diagram
IP/IE2512 | 2 channel pulse-width output | Block Diagram
IE2808 | 16 digital outputs 24 VDC, 2,0 A, total = 4 A | Block Diagram
IP/IE3102 | 4 analog differential inputs, +-10V, 16 bit | Block Diagram
IP/IE3112 | 4 analog differential inputs, 0...20 mA, 16 bit | Block Diagram
IP/IE3202 | 4 analog differential inputs, RTD, 16 bit | Block Diagram
IP/IE3312 | 4 analog differential inputs, thermocouples, 16 bit | Block Diagram
IP/IE4112 | 4 analog differential outputs 0...20 mA, 16 bit | Block Diagram
IP/IE4132 | 4 analog differential outputs +- 10 V, 16 bit | Block Diagram
IP/IE5009 | SSI Sensor interface | Block Diagram
IP/IE5109 | Incremental encoder input | Block Diagram
IP5209 | Sin/cos encoder input | Block Diagram
IP/IE6002 | Serial interface RS232 | Block Diagram
IP/IE6012 | Serial interface 0...20 mA (TTY) | Block Diagram
IP/IE6022 | Serial interface RS485 | Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE1xxx Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE1502 Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE20xx Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE23xx Block Diagram


IP2400-Bxxx, IE2400, IP2401-Bxxx, IE2401 Block Diagram

BECKHOFF Fieldbus Box: Block Diagramms

IP/IE2400, IP/IE2401 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IE2403 Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE2512 Block Diagram


IE2808 Block Diagram

From hardware version 0012:

Untill hardware version 0011:


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE3102 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE3112 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE3202 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE3312 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE4112 Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE4132 Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE5009 Block Diagram


BECKHOFF Fieldbus Box: Block Diagramms

IP/IE5109 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE5209 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE6002 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE6012 Block Diagram


BECKHOFF Fieldbus Box: Block Diagrams

IP/IE6022 Block Diagram


Mapping of the Fieldbus Box Modules

The Fieldbus Box Modules have a memory for the image of the process data. This memory can be read from or written to by the fieldbus master. The size and the type of the process data image depends on the type of Fieldbus Box, the configuration, the fieldbus system and the fieldbus master.

  • bit oriented Fieldbus Box Modules (basically digital modules) have a fixed quantity of data.
  • Only in the case of the byte oriented Fieldbus Box Modules (e.g. analog modules und modules for special functions) some changes can be made:
    - compact and complete mapping
    - swapping the high and low bytes (Intel / Motorola format)
    - Word-Alignment (only LightBus and Ethernet)
  • A Coupler Box has a variable mapping that depends on the type and number of extension boxes that are connected.

Bit oriented Fieldbus Box Modules

Bit oriented Fieldbus Box Modules possess a specified number of inputs and/or outputs, that cannot be changed.

 | Input Data | Output Data
Module | Number of used bits | Number of used bits
IP10xx-Byyy IE10xx | 8 | 0
IP20xx-Byyy IE20xx | 0 | 8
IP23xx-Byyy IE23xx | 4 (although the 4 most significant bit are not used, they occupy space in the process data memory) | 4 (although the 4 most significant bit are not used, they occupy space in the process data memory)
IP2400-Byyy, IP2401-Byyy IE2400, IE2401, IE2403 | 8 | 8

"yyy" stands for the bus system and the bus connection (see chapter Naming Conventions).

Byte oriented Fieldbus Boxes

Byte oriented Fieldbus Box Modules can operate with compact or complete process image. The number of bytes for complete mapping are given in brackets.

 | Input Data | Output Data
Module | Number of used bytes | Number of used bytes
IP15xx-Byyy IE15xx | 6 (6) | 6 (6)
IP25xx-Byyy IE25xx | 6 (6) | 6 (6)
IE2808 | 2 (3) | 2 (3)
IP3xxx-Byyy IE3xxx | 8 (12) | 0 (12)
IP41xx-Byyy IE41xx | 0 (12) | 8 (12)
IP5009-Byyy IE5009 | 4 (6) | 4 (6)
IP5109-Byyy IE5109 | 6 (8) | 6 (8)
IE5209 | 10 (10) | 10 (10)
IP6xxx-Byyy IE6xxx | 6 (6) | 6 (6)

With activated Word-Alignment, the number of occupied bytes can increase because not used bytes may be added. Details can be taken from the module specific mapping descriptions.


IP/IE10xx Mapping

All IP/IE10xx are mapped with 8 bits inputs in the process image, and are the same for all bus systems.


IP/IE1502 Mapping

Evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | Ch1 D2 | Ch1 D1 | Ch1 D2 | Ch1 D1
 | 2 | SB2 | Ch1 D3 | CB2 | Ch1 D3
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | Ch2 D3 | Ch2 D2 | Ch2 D3 | Ch2 D2

Evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: no | 0 | Ch1 D3 | SB1 | Ch1 D3 | CB1
 | 1 | Ch1 D1 | Ch1 D2 | Ch1 D1 | Ch1 D2
 | 2 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 3 | Ch2 D2 | Ch2 D3 | Ch2 D2 | Ch2 D3
 | 4 | Ch2 D0 | Ch4 D1 | Ch2 D0 | Ch4 D1

Evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | Ch1 D3 | Ch1 D2 | Ch1 D3 | Ch1 D2
 | 3 | reserved | SB2 | reserved | CB2
 | 4 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 5 | Ch2 D3 | Ch2 D2 | Ch2 D3 | Ch2 D2

Evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D2 | Ch1 D3 | Ch1 D2 | Ch1 D3
 | 2 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 3 | reserved | SB2 | reserved | CB2
 | 4 | Ch2 D2 | Ch2 D3 | Ch2 D2 | Ch2 D3
 | 5 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, data byte 0 (lowest significant byte)
Ch n D1: channel n, data byte 1
Ch n D2: channel n, data byte 2
Ch n D3: channel n, data byte 3 (most significant byte)

reserved: Although this byte occupies space in the process data memory, it has no function
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE20xx Mapping

All IP/IE20xx are mapped with 8 bits outputs in the process image, and are the same for all bus systems.


IP/IE23xx Mapping

All IP/IE23xx are mapped with 4 bits inputs and 4 bits outputs in the process image, and are the same for all bus systems.

Under PROFIBUS, the mapping can be rounded to a byte (see byte align).


IP/IE240x Mapping

All IP/IE240x are mapped with 8 bits inputs and 8 bits outputs in the process image, and are the same for all bus systems.


IP/IE2512 Mapping

Evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: no | 0 | Ch1 Reg0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 Reg1 | CB2 | Ch1 D1
 | 2 | Ch2 Reg1 | Ch2 Reg0 | Ch2 D1 | Ch2 D0

Evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: no | 0 | Ch1 Reg1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 Reg0 | CB2 | Ch1 D0
 | 2 | Ch2 Reg0 | Ch2 Reg1 | Ch2 D0 | Ch2 D1

Evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 Reg1 | Ch1 Reg0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 Reg1 | Ch2 Reg0 | Ch2 D1 | Ch2 D0

Evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 Reg0 | Ch1 Reg1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 Reg0 | Ch2 Reg1 | Ch2 D0 | Ch2 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

Ch n Reg0: channel n, lower significant byte for register communication
Ch n Reg1: channel n, higher significant byte for register communication

reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IE2808 Mapping

Compact evaluation

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: don't care Word alignment: don't care | 0 | - | - | Out2 | Out1

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: don't care Word alignment: no | 0 | Diag1 | SB | Out1 | CB
 | 1 | - | Diag2 | - | Out2

Complete evaluation in Intel format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: don't care Word alignment: yes | 0 | Diag1 | SB | Out1 | CB
 | 1 | res. | Diag2 | res. | Out2
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB: Status Byte (appears in the process image of the inputs)
CB: Control Byte (appears in the process image of the outputs)

Out1: Input bits of channel 8 to 1
Out2: Input bits of channel 16 to 9

Diag1: Diagnostic bits of channel 8 to 1
Diag2: Diagnostic bits of channel 16 to 9

res.: reserved; Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE3102 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | D0 Ch4 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE3112 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE3202, KL3204 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE3312, KL3314 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | Ch1 D1 | Ch1 D0 | - | -
 | 1 | Ch2 D1 | Ch2 D0 | - | -
 | 2 | Ch3 D1 | Ch3 D0 | - | -
 | 3 | Ch4 D1 | Ch4 D0 | - | -

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | Ch1 D0 | Ch1 D1 | - | -
 | 1 | Ch2 D0 | Ch2 D1 | - | -
 | 2 | Ch3 D0 | Ch3 D1 | - | -
 | 3 | Ch4 D0 | Ch4 D1 | - | -

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB1 | reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | reserved | SB2 | reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | reserved | SB3 | reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | reserved | SB4 | reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE4112 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
 | 2 | - | - | Ch3 D1 | Ch3 D0
 | 3 | - | - | Ch4 D1 | Ch4 D0

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
 | 2 | - | - | Ch3 D0 | Ch3 D1
 | 3 | - | - | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | Reserved | SB1 | Reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | Reserved | SB2 | Reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | Reserved | SB3 | Reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | Reserved | SB4 | Reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | Reserved | SB1 | Reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | Reserved | SB2 | Reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | Reserved | SB3 | Reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | Reserved | SB4 | Reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

Reserved: Although this byte occupies space in the process data memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE4132, KL4132 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | - | - | Ch1 D1 | Ch1 D0
 | 1 | - | - | Ch2 D1 | Ch2 D0
 | 2 | - | - | Ch3 D1 | Ch3 D0
 | 3 | - | - | Ch4 D1 | Ch4 D0

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | - | - | Ch1 D0 | Ch1 D1
 | 1 | - | - | Ch2 D0 | Ch2 D1
 | 2 | - | - | Ch3 D0 | Ch3 D1
 | 3 | - | - | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | Ch1 D0 | SB1 | Ch1 D0 | CB1
 | 1 | SB2 | Ch1 D1 | CB2 | Ch1 D1
 | 2 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 3 | Ch3 D0 | SB3 | Ch3 D0 | CB3
 | 4 | SB4 | Ch3 D1 | CB4 | Ch3 D1
 | 5 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | Ch1 D1 | SB1 | Ch1 D1 | CB1
 | 1 | SB2 | Ch1 D0 | CB2 | Ch1 D0
 | 2 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 3 | Ch3 D1 | SB3 | Ch3 D1 | CB3
 | 4 | SB4 | Ch3 D0 | CB4 | Ch3 D0
 | 5 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | Reserved | SB1 | Reserved | CB1
 | 1 | Ch1 D1 | Ch1 D0 | Ch1 D1 | Ch1 D0
 | 2 | Reserved | SB2 | Reserved | CB2
 | 3 | Ch2 D1 | Ch2 D0 | Ch2 D1 | Ch2 D0
 | 4 | Reserved | SB3 | Reserved | CB3
 | 5 | Ch3 D1 | Ch3 D0 | Ch3 D1 | Ch3 D0
 | 6 | Reserved | SB4 | Reserved | CB4
 | 7 | Ch4 D1 | Ch4 D0 | Ch4 D1 | Ch4 D0

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | Reserved | SB1 | Reserved | CB1
 | 1 | Ch1 D0 | Ch1 D1 | Ch1 D0 | Ch1 D1
 | 2 | Reserved | SB2 | Reserved | CB2
 | 3 | Ch2 D0 | Ch2 D1 | Ch2 D0 | Ch2 D1
 | 4 | Reserved | SB3 | Reserved | CB3
 | 5 | Ch3 D0 | Ch3 D1 | Ch3 D0 | Ch3 D1
 | 6 | Reserved | SB4 | Reserved | CB4
 | 7 | Ch4 D0 | Ch4 D1 | Ch4 D0 | Ch4 D1
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB n: Status Byte for channel n (appears in the process image of the inputs)
CB n: Control Byte for channel n (appears in the process image of the outputs)

Ch n D0: channel n, lower significant data byte
Ch n D1: channel n, higher significant data byte

Reserved: Although this byte occupies space in the process data memory, it has no function
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE5009 Mapping

Compact evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: no Word alignment: don't care | 0 | D1 | D0 | - | -
 | 1 | D3 | D2 | - | -

Compact evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: no Motorola format: yes Word alignment: don't care | 0 | D2 | D3 | - | -
 | 1 | D0 | D1 | - | -

Complete evaluation in Intel format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: no | 0 | D0 | SB | Reg0 | CB
 | 1 | D2 | D1 | reserved | Reg1
 | 2 | - | D3 | - | reserved

Complete evaluation in Motorola format

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: no | 0 | D3 | SB | Reg1 | CB
 | 1 | D1 | D2 | reserved | Reg0
 | 2 | - | D0 | - | reserved

Complete evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D1 | D0 | Reg1 | Reg0
 | 2 | D3 | D2 | reserved | reserved

Complete evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: yes Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D2 | D3 | Reg0 | Reg1
 | 2 | D0 | D1 | reserved | reserved
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB: Status Byte (appears in the process image of the inputs)
CB: Control Byte (appears in the process image of the outputs)

D0 - D3 : Data Bytes 0 to 3

Reg0: lower significant byte for register communication
Reg1: higher significant byte for register communication

reserved: Although this byte occupies space in the process data memory, it has no function
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE5109 Mapping

Evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: no | 0 | D0 | SB | Reg0 | CB
 | 1 | D2 | D1 | reserved | Reg1
 | 2 | D4 | D3 | reserved | reserved

Evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: no | 0 | D1 | SB | Reg1 | CB
 | 1 | D2 | D0 | reserved | Reg0
 | 2 | D3 | D4 | reserved | reserved

Evaluation in Intel format with word alignment

Default mapping for Lightbus, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D1 | D0 | Reg1 | Reg0
 | 2 | reserved | D2 | reserved | reserved
 | 3 | D4 | D3 | reserved | reserved

Evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D0 | D1 | Reg0 | Reg1
 | 2 | reserved | D2 | reserved | reserved
 | 3 | D3 | D4 | reserved | reserved
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB: Status Byte (appears in the process image of the inputs)
CB: Control Byte (appears in the process image of the outputs)

D0: lower significant byte of the Counter word (read/write)
D1: higher significant byte of the Counter word (read/write)
D2: the status of A, B, C (latch), gate and latch input
D3: lower significant byte of the Latch word (read) / lower byte of period length
D4: higher significant byte of the Latch word (read) / higher byte of period length

Reg0: lower significant byte for register communication
Reg1: higher significant byte for register communication

reserved: Although this byte occupies space in the process data memory, it has no function
"-": This byte is not used or occupied by the Fieldbus Box.


IP5209 Mapping

Per default setting ex factory the module sends 8 byte process data and 1 byte status (Default: 8 byte process data, 9 byte overall). By changing the Feature Register R32 the process data can be set to 5 byte! In this case the data of the Latch will not be transmitted.

Evaluation in Intel format

Default mapping for CANopen, DeviceNet, Modbus, RS232 and RS485

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: no | 0 | D0 | SB | D0 | CB
 | 1 | D2 | D1 | D2 | D1
 | 2 | D4 | D3 | reserved | D3
 | 3 | D6 | D5 | reserved | reserved
 | 4 | reserved | D7 | reserved | reserved

Evaluation in Motorola format

Default mapping for PROFIBUS and Interbus

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: no | 0 | D3 | SB | D3 | CB
 | 1 | D1 | D2 | D1 | D2
 | 2 | D7 | D0 | reserved | D0
 | 3 | D5 | D6 | reserved | reserved
 | 4 | reserved | D4 | reserved | reserved

Evaluation in Intel format with word alignment

Default mapping for Lightbus and Ethernet

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: no Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D1 | D0 | D1 | D0
 | 2 | D3 | D2 | D3 | D2
 | 3 | D5 | D4 | reserved | reserved
 | 4 | D7 | D6 | reserved | reserved

Evaluation in Motorola format with word alignment

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: yes Word alignment: yes | 0 | reserved | SB | reserved | CB
 | 1 | D2 | D3 | D2 | D3
 | 2 | D0 | D1 | D0 | D1
 | 3 | D6 | D7 | reserved | reserved
 | 4 | D4 | D5 | reserved | reserved
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB: Status Byte (appears in the process image of the inputs)
CB: Control Byte (appears in the process image of the outputs)

D0, D1, D2, D3: Bytes for the Counter value (read)
D4, D5, D6, D7: Bytes for the Latch value (read)

reserved: Although this byte occupies space in the process memory, it has no function.
"-": This byte is not used or occupied by the Fieldbus Box.


IP/IE60x2 Mapping

Standard format

(Default: 5 bytes of user data, 6 bytes altogether)
As supplied, these modules use the standard format with 5 bytes of user data.

Default mapping for Lightbus, PROFIBUS, Interbus, CANopen, DeviceNet, Modbus, RS232, RS485, Ethernet and Controller Box (IL230x-Cxxx)

 | Address | Input data |  | Output data
Conditions | Word offset | High byte | Low byte | High byte | Low byte
Complete evaluation: don't care Motorola format: don't care Word alignment: don't care | 0 | D0 | SB | D0 | CB
 | 1 | D2 | D1 | D2 | D1
 | 2 | D4 | D3 | D4 | D3
Key

Complete evaluation: Additionally to the process data the control and status bytes are showed in the address area
Motorola format: Motorola or Intel format can be set.
Word alignment: in order that the address area of each channel starts always on a word boundary, dummy bytes are added to the process image

SB: Status byte (appears in the process image of the inputs)
CB: Control byte (appears in the process image of the outputs)

D0, D1, D2, D3, D4: Data bytes

reserved: Although this byte occupies space in the process data memory, it has no function
"-": This byte is not used or occupied by the Fieldbus Box.


General Register Description

Different operating modes or functionalities may be set for the complex modules. The General Description of Registers explains those register contents that are the same for all complex modules. The module-specific registers are explained in the following section.
Access to the module's internal registers is described in the section on Register Communication.

General Description of Registers

Complex modules that possess a processor are able to exchange data bi-directionally with the higher-level controller. These modules are referred to below as intelligent modules. These include the analog inputs (0-10 V, -10-10 V, 0-20 mA, 4-20 mA), the analog outputs (0-10 V, -10-10 V, 0-20 mA, 4-20 mA), the serial interface terminals (RS485, RS232, TTY, data exchange terminals), counter terminals, encoder interface and SSI interface terminals, PWM terminals and all the modules that can be parameterized.

The main features of the internal data structure are the same for all the intelligent modules. This data area is organized as words, and includes 64 memory locations. The important data and the parameters of the module can be read and set through this structure. It is also possible for functions to be called by means of corresponding parameters. Each logical channel in an intelligent module has such a structure (so a 4-channel analog module has 4 sets of registers).

This structure is divided into the following areas:

Range | Address
Process variables | 0-7
Type register | 8-15
Manufacturer parameters | 16-30
User parameters | 31-47
Extended user region | 48-63

Registers R0-R7 (in the terminal's internal RAM)

The process variables can be used in addition to the actual process image. Their function is specific to the terminal.

R0-R5

The function of these registers depends on the type of terminal.

R6

Diagnostic register. The diagnostic register can contain additional diagnostic information. Parity errors, for instance, that occur in serial interface terminals during data transmission are indicated here.

R7

Command register
- High-Byte_Write = function parameter
- Low-Byte_Write = function number
- High-Byte_Read = function result
- Low-Byte_Read = function number

Registers R8-R15 (in the terminal's internal ROM)

The type and system parameters are hard programmed by the manufacturer, and the user can read them but cannot change them.

R8

Fieldbus Box type: The Fieldbus Box type in register R8 is needed to identify the Fieldbus Box.

R9

Software version x.y.: The software version can be read as a string of ASCII characters.

R10

Data length: R10 contains the number of multiplexed shift registers and their length in bits. The Bus Coupler sees this structure.

R11

Signal channels: Related to R10, this contains the number of channels that are logically present. Thus for example a shift register that is physically present can perfectly well consist of several signal channels.

R12

Minimum data length: The particular byte contains the minimum data length for a channel that is to be transferred. If the MSB is set, the control/status byte is not absolutely necessary for the terminal's function, and if the Bus Coupler is appropriately configured it is not transferred to the controller. The information is located
- in the high byte of an output module
- in the low byte of an input module

R13

Data type register

Data type register | Description
0x00 | Terminal with no valid data type
0x01 | Byte array
0x02 | Structure 1 byte n bytes
0x03 | Word array
0x04 | Structure 1 byte n words
0x05 | Double word array
0x06 | Structure 1 byte n double words
0x07 | Structure 1 byte 1 word
0x08 | Structure 1 byte 1 double word
0x11 | Byte array with variable logical channel length
0x12 | Structure 1 byte n bytes with variable logical channel length (e.g. 60xx)
0x13 | Word array with variable logical channel length
0x14 | Structure 1 byte n words with variable logical channel length
0x15 | Double word array with variable logical channel length
0x16 | Structure 1 byte n double words with variable logical channel length
R14

reserved

R15

Alignment bits (RAM): The analog terminal is placed on a byte boundary in the K-Bus with the alignment bits.

Registers R16-R30 (manufacturer's parameters, serial EEPROM)

The manufacturer parameters are specific for each type of terminal. They are programmed by the manufacturer, but can also be modified by the controller. The manufacturer parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out. These registers can only be altered after a code-word has been set in R31.

Registers R31-R47 (application parameters, serial EEPROM)

The application parameters are specific for each type of terminal. They can be modified by the programmer. The application parameters are stored in a serial EEPROM in the terminal, and are retained in the event of voltage drop-out. The application region is write-protected by a code-word.

R31

Code-word register in RAM: The code-word 0x1235 must be entered here so that parameters in the user area can be modified. If any other value is entered into this register, the write-protection is active. If write protection is inactive, the code-word is returned when the register is read, but if write protection is active, then the register contains a null value.

R32

Feature register: This register specifies the terminal's operating modes. Thus, for instance, a user-specific scaling can be activated for the analog I/O modules.

R33-R47

Terminal-specific Registers: These registers depend on the type of terminal.

Registers R47-R63 (Register extension for additional functions)

These registers are provided for additional functions.


Example for Register Communication

Control Byte

The Control Byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R/W | register number
Bit | Name | Description
7 | REG | 1bin | Register Communication switched on: The first two Data Bytes are not used for process data exchange, but are written to the register set of the Fieldbus Box or are read from there.
6 | R/W | 0bin | Read: the register should be read without changing it.
 |  | 1bin | Write: the register should be written.
5-0 | register number | Number of the Registers, that should be read or written. 64 Registers are addressable.
Status Byte

The Status-Byte is located in the output image und can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | REG | R | register number
Bit | Name | Description
7 | REG | 1bin | receipt register number
6 | R | 0bin | Read
5-0 | register number | Number of the Registers, that was read or written.

Example 1

Reading register 8 of KL3204 or IP/IE3202
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0x88 (1000 1000bin) | 0xXX | 0xXX

Bit 0.7 set indicates register communication active
Bit 0.6 not set indicates reading the register.
Bit 0.5 to Bit 0.0 indicates with 001000bin the register number 8.
The output data word (Byte 1 and Byte 2) has no function at the reading access. If you want to change a register, you have to write the desired value into the output data word.

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0x88 | 0x0C | 0x84

The terminal/box returns the type name 0x0C84 (equivalent unsigned integer 3204) in the input data word (Byte 1 and Byte 2).

Special feature in the naming of Fieldbus Boxes:
The last figure of the delivered unsigned Integer (3204) is not the same like the last character of the Fieldbus Box name (3202), witch stands for the connector type (0 for S8, 1 for M8 and 2 for M12). It returns instead of that the number of channels (IE3204 owns 4 channels).

Note In order to write into registers, you have to write the password (0x1235) into register 31, so that write protection is deactivated. It is activated again by writing any value other than 0x1235.
Note that some of the settings that can be made in registers only become active after the next power restart (power-off/power-on) of the module.

Example 2

Process of register communication for writing into register.

1. Write register 31 (set code word)
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0xDF | 0x12 | 0x35

Answer of the module/terminal

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0x9F | 0xXX | 0xXX
2. Read register 31 (verify, if code word is set)
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0x9F | 0xXX | 0xXX

Answer of the module/terminal

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0x9F | 0x12 | 0x35
3. Write Register 32 (change register)
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0xE0 | 0x00 | 0x02

Answer of the module/terminal

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0xA0 | 0xXX | 0xXX
4. Read Register 32 (verify changed register)
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0xA0 | 0xXX | 0xXX

Answer of the module/terminal

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0xA0 | 0x00 | 0x02
5. Write Register 31 (set code word back)
Byte 0 (control byte) | Byte 1 (data out, high byte) | Byte 2 (data out, low byte)
0xDF | 0x00 | 0x00

Answer of the module/terminal

Byte 0 (status byte) | Byte 1 (data in, high byte) | Byte 2 (data in, low byte)
0x9F | 0xXX | 0xXX


Functioning IP/IE1502

The Ix1502 input module counts binary pulses, and transmits the current value to the higher level controller. Two fully independent, 32 bit, gated up/down counters are available. A low level or a high level at the GATE input halts the associated counter, depending on the setting in the feature register (Feature.8) for the channel. The counting direction can be controlled through separate inputs (low level = up, high level = down). Two digital outputs can also be set.
The maximum input frequency is limited to 100 kHz, the minimum pulse width for the input signal being about one microsecond. The counters react to a rising edge of the input signal.
The controller can use the control byte (CB) to set the counter state (CB.5), inhibit the module's counting function (CB.4) and to activate the outputs (CB.2). An internal function can also be activated (CB.0) permitting the outputs to be set automatically at defined counter states. The bit R32.2 in the feature register can also be used to determine whether counter setting is edge triggered or level triggered.

Internal Functions

Setting/resetting the outputs and resetting the counter

When the internal function is active (Control Byte, Bit 0) the outputs are set or reset, according to the settings in the feature register (R32.4 - R32.6) and the pre-set values in registers 35 - 38. This takes away the function of the bit (Control Byte, Bit 2) for setting the outputs. Registers 39 and 40 contain the values at which the counter will be reset to zero; this function is only activated by the associated bit R32.6 in the feature register, and is independent of the control byte.

Note The setting/resetting functions are only active in the up-counting modus!

On Startup of the module, the register data from the EEPROM will be transfered to the RAM.
If the values have to be changed during the run time, the new values have to be written into the RAM area (R0 - R5).

Pulse operation

If the pulse operating mode is active (R32.7 and CB.0) the associated output is set, according to the values in registers 35 and 36, for a specified pulse period (set in register 41, unit: 1µs/digit or 64 µs/digit (timer factor, Bit R32.9), shortest pulse: 250 µs, maximum pulse 4s). This means that bit R32.4 and R32.5 of the Feature Register do not have any function. The counters are reset in an identical fashion. Bit R32.10 of the feature register has influence on the way the outputs are switched off, namely whether the output is reset when the counter is reset, or not until after the pulse time has elapsed. The pre-set values in registers 35 - 41 are copied into registers 0 - 5 following a power on reset (see register table). They can be modified during operation. After the feature register, or other register values located in EEPROM, have been modified, a power on reset must follow so that these values are adopted.

Process Data

In the Ix1502 module, 5 bytes (4 bytes of user data and 1 control/status byte) are mapped. If no process data is exchanged within 100 ms (activated via bit R32.3 of Feature-Register), a watchdog switches the outputs off.

Conceptual circuit diagram

IPIE1502.jpg (45042 Byte)


Control and Status Byte IP/IE1502

Process data mode

Control-Byte

The Control byte is always visible in the process image. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | 0 | CNT_SET | CNT_INH | GATE_A | SET_A | 0 | EN_A

Name | Description
RegAccess | 0bin: Register Communication switched off (Process data mode)
CNT_SET | The module is set to the value specified by the process data. Setting the counter can be edge or level triggered (Feature register, bit 2). Level triggered: The counter module accepts the data provided, and the counter is locked until the CNT_SET bit is reset. Edge triggered: The counter module accepts the data present at a rising edge of the CNT_SET bit. The counter can then immediately continue counting.
CNT_INH | The counter is stopped as long as this bit is active. The previous counter state is retained.
GATE_A | State of the Gate-Input is activated in the Status-Byte. (from version D.xxxxxx11)
SET_A | Set the output
EN_A | This bit enables the internal functions in register 32.

Status-Byte

The status byte is always visible in the process image. The status byte is sent from the module to the controller.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | 0 | SET_ACC | INH_ACC | ST_GATE | ST_A | ST_V/R | 0

Name | Description
RegAccess | 0bin: Register Communication switched off (Process data mode)
SET_ACC | The data for setting the counter is accepted from the module.
INH_ACC | The counter is stopped for as long as this bit is set.
ST_GATE | The state of the Gate-input is given in this bit, if GATE_A is activated in the Control-Byte.
ST_A | The state of the output is given in this bit.
ST_V/R | The state of the up/down input is given in this bit.

Register Communication

Counter values cannot be transmitted during register communication.

Control Byte

The Control byte is always visible. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The status byte is always visible in the process image. The status byte is sent from the module to the controller.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE1502

The values of registers R35 - R40 will be mapped into R0 - R5 only after a power reset. The registers R0 - R5 can be written also directly, the values will then be valid immediately.

Attention: switch-on threshold < switch-off threshold < reset threshold!

Register | Description | Default value | Read/Write | Memory medium
R0 | Switch - on threshold value / low word | variable | R/W | RAM
R1 | Switch - on threshold value / high word | variable | R/W | RAM
R2 | Switch - off threshold value / low word Pulse length (1 us/digit) | variable | R/W | RAM
R3 | Switch - off threshold value / high word | variable | R/W | RAM
R4 | Reset threshold value / low word | variable | R/W | RAM
R5 | Reset threshold value/ high word | variable | R/W | RAM
R6 | reserved | 0000hex | R | RAM
R7 | reserved | 0000hex | R | RAM
R8 | Module type | 1502dec | R | ROM
R9 | Software version | XXXXhex | R | ROM
R10 | Multiplex shift register | 0228hex | R | ROM
R11 | Signal channels | 0228hex | R | ROM
R12 | Minimum data length | 2828hex | R | ROM
R13 | Data structure | 0006hex | R | ROM
R14 | reserved | 0000hex | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | XXXXhex | R/W | EEPROM
R17 | reserved | 0000hex | R/W |
... | ... | ... | ... | ...
R30 | reserved | 0000hex | R/W |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0104hex | R/W | EEPROM
R33 | reserved | 0000hex | R/W |
R34 | reserved | 0000hex | R/W |
R35 | Switch - on threshold value / low word | 0000hex | R/W | EEPROM
R36 | Switch - on threshold value / high word | 0000hex | R/W | EEPROM
R37 | Switch - off threshold value / low word | 0000hex | R/W | EEPROM
R38 | Switch - off threshold value / high word | 0000hex | R/W | EEPROM
R39 | Reset threshold value / low word | FFFFhex | R/W | EEPROM
R40 | Reset threshold value/ high word | FFFFhex | R/W | EEPROM
R41 | Pulse length (1µs or 64µs/digit) | 00FAhex | R/W | EEPROM
R42 | reserved | 0000hex | R/W |
... | ... | ... | ... | ...
R63 | reserved | 0000hex | R/W |


Feature Register (R32) IP/IE1502

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register. The settings in register 32 are only effective following a power on reset (the module being switched off and on again).
Default [0x0104]

Bit | Value | Description | Manufacturer’s setting
0-1 | 0 | no function | 0
2 | 0 | Watchdog is active | 0
 | 1 | Watchdog is inactive
3 | 0 | The counter is set as a result of a positive signal in the CNT_SET bit in the control byte | 1
 | 1 | The counter is set as a result of a rising edge at the CNT_SET bit in the control byte
4 | 0 | The function for setting the output is inactive | 0
 | 1 | The function for setting the output is active
5 | 0 | The function for resetting the output is inactive | 0
 | 1 | The function for resetting the output is active
6 | 0 | The function for resetting the counter is inactive | 0
 | 1 | The function for resetting the counter is active
7 | 0 | Pulse operating mode is inactive | 0
 | 1 | Pulse operating mode is active
8 | 0 | The counter is inhibited when the Gate input is low (0). | 1
 | 1 | The counter is inhibited when the Gate input is high (1).
9 | 0 | Timer basis (pulse length register 41) 1 µs/digit (250 µs - 65 ms) | 0
 | 1 | Timer basis (pulse length register 41) 64 µs/digit (10 ms - 4 s)
10 | 0 | The output is reset when the counter is reset | 0
 | 1 | The output is reset when the pulse time has elapsed
11-15 | 0 | no function | 0

Explanation of the watchdog
The watchdog timer is switched on by default. The output is reset if the watchdog overflows (> 100 ms).


Function Register IP/IE1502

On/Off/Reset operation (RAM)

Register | Meaning | Place | Memory
0 | Switch-on threshold value | Low word | RAM
1 | Switch-on threshold value | High word | RAM
2 | Switch-off threshold value | Low word | RAM
3 | Switch-off threshold value | High word | RAM
4 | Reset threshold value | Low word | RAM
5 | Reset threshold value | High word | RAM

On/Off/Reset operation (EEPROM)

Register | Meaning | Place | Memory
35 | Switch-on threshold value | Low word | EEPROM
36 | Switch-on threshold value | High word | EEPROM
37 | Switch-off threshold value | Low word | EEPROM
38 | Switch-off threshold value | High word | EEPROM
39 | Reset threshold value | Low word | EEPROM
40 | Reset threshold value | High word | EEPROM

Pulse/Reset operation (RAM)

Register | Meaning | Place | Memory
0 | Switch-on threshold value | Low word | RAM
1 | Switch-on threshold value | High word | RAM
2 | Pulse length | 1/64 µs/digit | RAM
3 | - | - | -
4 | Reset threshold value | Low word | RAM
5 | Reset threshold value | High word | RAM

Pulse/Reset operation (EEPROM)

Register | Meaning | Place | Memory
35 | Switch-on threshold value | Low word | EEPROM
36 | Switch-on threshold value | High word | EEPROM
37 | - | - | -
38 | - | - | -
39 | Reset threshold value | Low word | EEPROM
40 | Reset threshold value | High word | EEPROM
41 | Pulse length | 1/64 µs/digit | EEPROM

Notes:

  • The counter states are not reset when the counter underflows. In other words, the counter is only automatically set to zero if the reset value is reached from below.
  • The following ranges for the threshold values must be observed:
    Switch on threshold value < switch-off threshold value < reset threshold
  • Pulse length may be between 0.25 ms - 4000 ms
  • In pulse operation, the counter width must not exceed the counter runtime:
    max. pulse length < reset threshold/counter frequency


Functioning IP/IE2512

BECKHOFF Fieldbus Box: Configuration

IP/IE2512 Functioning

The special function module IP/IE2512 modulates a binary signal. Either the pulse width or the frequency is changed. The periphery side of the module electronics is electrically isolated from the fieldbus or IP-Link. The cycle (base frequency) and the pulse/pause ratio can be specified via 16-bit values in the process image of the control.
The IP/IE2512 module occupies 6 bytes in the process image. The IP/IE2512 mapping can be set via the control or via the KS2000 configuration software. In addition to PWM (pulse width modulation) mode, the IP/IE2512 can be operated in FM (frequency modulation) or, for stepper motor control, with pulse direction specification (Frq-Cnt pulse mode). The default setting of the terminal is PWM mode with a base frequency of 250 Hz and a resolution of 10 bit.

The module is temperature controlled. In case of over temperature the outputs are de-energized, an error bit in the STATUS Bytes is set an the error LED next to the M12 output is turned on (red).

Operating Modes

The different operating modes of the module are set via the Feature register (R32). Three parameters are configurable:

  • pulse width ratio
  • pulse length
  • frequency (period)

Depending on the type of operating mode, the parameters might influence each other.

Attention | There is no control of the frequency limits. If they are exceeded, outputs are not active!
Attention | using the stepper motor functions(Frq_Cnt_PWM, Frq_Cnt_Impuls, Cnt_Cnt_PWM) only channel 1 can be used!

PWM mode (frequency in the register, pulse width in the process data)

In PWMH and PWML mode, two channels can be operated. The operating mode and the period is identical for both channels. The ratio of duty cycle and period is specified via the process data (100 % duty cycle correspond to process data 0x7FFF). The period can be specified via register R2 during the operation. It is loaded after a system start-up from register R35 (SEEROM) and entered into register R2. Therefore R35 should be programmed in the applications default setting.

or

There are two different PWM frequency ranges that can be preselected via the Feature Register (R32).

PWMH mode
Parameter | Storage location
period | R2 (R35)
duty cycle | process data

The frequency range is from 1 kHz to 80 kHz .

The period is programmed in R2 (R35). 1 Digit = 0,25 µsec. Attention: this value differs from setting the IP20 terminal KL2502!

The duty cycle is chosen by the process data, 0x7FFF equals 100 %, 25 % therefore is 0x1FFF.

PWML mode
Parameter | Storage location
period | R2 (R35)
duty cycle | process data

The frequency range is from 8 Hz to 1 kHz .

The period is programmed in R2 (R35). 1 Digit = 2 µsec. Attention: this value differs from setting the IP20 terminal KL2502!

The duty cycle is chosen by the process data, 0x7FFF equals 100 %, 25 % therefore is 0x1FFF.

Frq-Cnt PWM mode (pulse with ratio in the register, frequency in the process data)

Parameter | Storage location
pulse width ratio | R36
frequency | process data

The frequency is specified in 8 Hz per digit via the process output data of the control. The control receives the number of periods that are output by the module as process input data. In this operating mode, the count direction is determined via the sign of the output data:

  • 8 Hz corresponds to the value 0x0001
  • -8 Hz corresponds to the value 0xFFFF (signed integer)

The frequency range is 8 Hz to 8 kHz.

The pulses are sent to output OUTPUT, the count direction to output UP/DOWN.

  • ascending count direction corresponds to signal level VCC
  • descending count direction corresponds to signal level GND

With rising edge of bit 0 in the control byte, the process input data is set to the value of the output data (process data mode, i.e. bit 7 of the control byte is 0). The pulse width ratio is specified via register R36.

Changes will be active only after a reset/power up.

Frq-Cnt pulse mode (pulse length in the register, frequency in the process data)

Parameter | Storage location
pulse width | R37
frequency | process data

The frequency is specified with 8 Hz per digit via the process output data of the control. The control receives the number of pulses that are output by the terminal as process input data. In this operating mode, the count direction is determined via the sign of the output data:

  • 8 Hz corresponds to the value 0x0001
  • -8 Hz corresponds to the value 0xFFFF (signed integer)

The frequency range is 8 Hz to 8 kHz.

The pulses are sent to output OUTPUT, the count direction to output UP/DOWN.

  • ascending count direction corresponds to signal level VCC
  • descending count direction corresponds to signal level GND

With rising edge of bit 0 in the control byte, the process input data is set to the value of the output data (control byte in process data mode, i.e. bit 7=0). The pulse width is fixed for all frequencies and is specified via R37.

Changes will be active only after a reset/power up.

Cnt-Cnt PWM mode

Parameter | Storage location
pulse width ratio | R36
number of pulses | process data
period | R35

The number of pulses is specified via the process output data. The control receives the number of periods that are output as process input data. The

  • pulse width ratio is specified via register R36 and the
  • period via register R35 (1 digit = 0.25 µsec).

The frequency ranges from 1 kHz to 32 kHz.

A rising edge of bit 0 in the control byte starts the pulse output. This can be re-triggered with every subsequent rising edge. The pulses are sent to output OUTPUT. Output UP/DOWN can be set via bit 2 of the control byte. In bit 0 of the status byte, the control receives the transfer and the simultaneous start of the pulse output as status information. Bit 1 of the status byte remains set as long as the output is active. Bit 2 of the status byte reports back the status of channel 1.

Pulse with ratio in the process data

Input format: Representation as complement on two (the integer value "-1" is represented as 0xFFFF).
The ratio of duty cycle/period is specified with a maximum resolution of 10 bit.

Process data | Output value
0x0000 | 0 % Duty Cycle
0x3FFF | 50 % Duty Cycle
0x7FFF | 100 % Duty Cycle


Output current (derating), IP/IE2512

When using the PWM modules, the power loss in the modules has to be taken in account.

The maximum current for the inductive case, e.g. using a proportional valve, is given in the following graph.

If pure ohmic loads are used, the line will be horizontally at 2.5 A, independent of the frequency.

Current versus Duty Cycle

Warning Modules with hardware revision D.xxxxxx00 (see hard-software revisions) do have a different derating behavior.


Control and Status Byte IP/IE2512

Process data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved | 0 | 0 | 0 | 0 | 0 | StartPulses

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)
StartPulses | When in Cnt_Cnt_PWM mode a rising edge of this bit starts the pulse output. This can be re-triggered with every subsequent rising edge.

Status-Byte

The status byte is only visible in the if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | ERROR | OVR_TEMP_ERR | - | 0 | StateCh1 | OUT | StartPulses

Name | Beschreibung
RegAccess | 0bin: Acknowledge for process data mode
ERROR | 0bin: general error bit, an error has happened
OVR_TEMP_ERR | 0bin: no error
 | 1bin: over temperature in the module, the outputs are set to 0
StateCh1 | When in Cnt_Cnt_PWM mode this bit reports back the status of channel 1.
OUT | When in Cnt_Cnt_PWM mode this bit shows the status of the output (1bin: Write).
StartPulses | When in Cnt_Cnt_PWM mode this bit shows the status of control byte bit 0.

Register Communication

Counter values cannot be transmitted during register communication.

Control Byte

The control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Register communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written.

Status Byte

The status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Acknowledge for register access
R/W | 0bin: Read
Register number | Number of the Register, that has been read or written.


Register Overview IP/IE2512

Register | Name | Default Value | Read/Write | Memory medium
R0 | reserved | 0x0000 | R | RAM
R1 | reserved | 0x0000 | R | RAM
R2 | Period | variable | R/W | RAM
R3 | fundamental frequency | variable | R/W | RAM
R4 | reserved | variable | R/W | RAM
R5 | Unprocessed PWM value | variable | R/W | RAM
R6 | Diagnostic register - not used | 0x0000 | R | RAM
R7 | Command register - not used | 0x0000 | R | RAM
R8 | Module type | 2502dec | R | ROM
R9 | Software version number | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0218 | R | ROM
R11 | Signal channels | 0x0218 | R | ROM
R12 | Minimum data length | 0x1818 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment-Register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | reserved | 0x0000 | R/W |
R18 | reserved | 0x0000 | R/W |
R19 | Manufacturer scaling: Offset | 0x0000 | R/W |
R20 | Manufacturer scaling: Gain | 0x0000 | R/W |
R21 | reserved | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W |
R31 | Codeword Register | variable | R/W | RAM
R32 | Feature Register | 0x0004 | R/W | SEEROM
R33 | User Offset | 0x0000 | R/W | SEEROM
R34 | User Gain | 0x0100 | R/W | SEEROM
R35 | Period PWM | 0x0FA0 | R/W | SEEROM
R36 | Duty-Cycle | 0x0000 | R/W | SEEROM
R37 | Pulse duration | 0x0000 | R/W | SEEROM
R38 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


Feature Register (R32) IP/IE2512

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default 0x0004

Bit | Value | Description |  | default
0 | 0bin | User scaling not active |  | 0bin
 | 1bin | User scaling active
1 | 0bin | Manufacturer scaling not active |  | 0bin
 | 1bin | Manufacturer scaling active
2 | 0bin | Watchdog not active |  | 1bin
 | 1bin | Watchdog active If the terminal receives no Data for 100 ms, the PWM Signal is set to 0% duty cycle.
12 - 3 | reserved |  |  | 0
15 - 13 |  | Operating Mode | Frequency range | 000bin
 | 000bin | PWMH-Mode | 250 Hz to 20 kHz
 | 001bin | PWML-Mode | 2Hz to 250 Hz
 | 011bin | Frq-Cnt-PWM-Mode | 2Hz to 2 kHz
 | 101bin | Frq-Cnt-Impuls-Mode | 2Hz to 2 kHz
 | 111bin | Cnt-Cnt-PWM-Mode | 250 Hz to 8 kHz


IE2808 functionality

The output module IE2808 has got 16 outputs with current carrying capacity of 0,5 A each. The total current of the module can have a maximum of 4,0 A.

Error display

Every channel can be diagnosed individually, this means at an error case an error bit is set for this channel in the process data input area.

For IE IE2808-0000 this error bit has to be reset manually by setting a bit within the control byte.
For IE IE2808-0001 this error bit is reset automatically after removing the error case.

LEDs

The module has got 4 LEDs. Us and Up show the existence of power supply for logic and the outputs.

ERR 1-8 und ERR 9-16 show the state of the outputs in groups.

LED | green | red
ERR 1-8 | at least one output of the group 1-8 is switched on | at least one output of the group 1-8 has got a short circuit
ERR 9-16 | at least one output of the group 9-16 is switched on | at least one output of the group 9-16 has got a short circuit


Control and Status Byte IE2808

Process data mode

Control Byte

The Control Byte (CB) is only visible if the Fieldbus Box is set to complete mode. It is located in the output image, and can be read or written.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | ResetErr | SetDefaultStatus | - | - | - | - | -

Bit | Name | description
CB.7 | RegAccess | 0bin | Register Communication switched off (Process data mode)
CB.6 | ResetErr | 1bin | Sets back errors, displayed at status byte
CB.5 | SetDefaultStatus | 1bin | Sets outputs to default status defined by Register R33
CB.4 | - | 0bin | reserved
... | ... | ... | ...
CB.0 | - | 0bin | reserved

Status Byte

The Status Byte (SB) is only visible if the Fieldbus Box is set to complete mode. It byte is located in the input image, and can only be read.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | Error | UnderVoltage | OvrCurrentGrp2 | OvrCurrentGrp1 | - | DefaultStatus | -

Bit | Name | description
SB.7 | RegAccess | 0bin | Acknowledgement for process data mode
SB.6 | Error | 0bin | general error bit: no error has occurred
 |  | 1bin | general error bit: an error has occurred
SB.5 | UnderVoltage | 0bin | Load voltage UL ≥ 18 V
 |  | 1bin | Load voltage UL < 18 V, UL-LED shines red, but the outputs stay switched
SB.4 | OvrCurrentGrp2 | 0bin | no error
 |  | 1bin | Short circuit detected at an output of group 2. The concerned output is displayed by the input byte Diag2. After repair this error display has to be set back by bit CB.6 of control byte.
SB.3 | OvrCurrentGrp1 | 0bin | no error
 |  | 1bin | Short circuit detected at an output of group 1. The concerned output is displayed by the input byte Diag1. After repair this error display has to be set back by bit CB.6 of control byte.
SB.2 | - | 0bin | reserved
SB.1 | DefaultStatus | 0bin | Outputs in operation
 |  | 1bin | Outputs have been set to default status, defined by R33
SB.0 | - | 0bin | reserved

Register Communication

Control Byte

The Control Byte (CB) is only visible if the Fieldbus Box is set to complete mode. It is located in the output image, and can be read or written.

Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | RegAccess | R/W | Register number

Bit | Name | description
CB.7 | RegAccess | 1bin | register access switched on
CB.6 | R/W | 0bin | Read
 |  | 1bin | Write
CB.5 - CB.0 | Register number | Number of the register that is to be read or written.

Status Byte

The Status Byte SB is only visible if the Fieldbus Box is set to complete mode. It byte is located in the input image, and can only be read.

Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | RegAccess | R/W | Register number

Bit | Name | description
SB.7 | RegAccess | 1bin | Acknowledgement for register access
SB.6 | R/W | 0bin | Read
SB.5 - SB.0 | Register number | Number of the register that has been read or written.


Register Overview IE2808

Register | Name | Default Value | Read/Write | Memory medium
R0 | reserved | 0x0000 | R/W | RAM
... | ... | ... | ... | ...
R5 | reserved | 0x0000 | R/W | RAM
R6 | Diagnose-Register - not used | 0x0000 | R | RAM
R7 | Command register - not used | 0x0000 | R | RAM
R8 | Module type | 2808dec | R | ROM
R9 | Firmware Version number | e.g. 0x3142 | R | ROM
R10 | Multiplex shift register | 0x0118 | R | ROM
R11 | Signal channels | 0x0118 | R | ROM
R12 | minimum Data length | 0x9898 | R | ROM
R13 | Data structure | 0x0001 | R | ROM
R14 | reserved | 0x0000 | R/W | RAM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | RAM
R31 | Code word register | variable | R/W | RAM
R32 | Enable Default Status register | 0x0000 | R/W | SEEROM
R33 | Default Status Register | 0x0000 | R/W | SEEROM
R34 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


IE2808 Watchdog feature (R32-R33)

BECKHOFF Fieldbus Box: Configuration

Watchdog feature (R32-R33) IE2808

Via the Enable Default Status Register R32 and the Default Status Register R33 the behavior of the outputs for communication breakdown can be set:

  • Register R32 activates or deactivates the watchdog feature.
  • Register R33 defines for each single channel the switching state of its output in error case (if watchdog was activated).

For changing the register at first the write protection must be disabled. This is done by writing the user code word (0x1235) into register R31.

Attention For using the watchdog feature pay attention, that at powering on the system no communication connection exists, that means the outputs are set to the pre-defined values.
Register | Description | Output | Description | default
32 | Watchdog active | 00 - 15 | 1 = activated; 0 = deactivated | 0xFFFF
Register | Description | Output | Description | default
33 | Output State | 00 - 15 | 1 = ON; 0 = OFF | 0x0000

In delivery state the watchdog is activated and the pre-defined output states are set to 0. So all outputs are switched off in error case!

Example

Register 32 = 1111 1111 1111 1111
Register 33 = 1000 0000 0000 0000
Process data from the higher level controller = ON for all outputs

Now at a communication breakdown all outputs except output 16 are set to OFF. Output 16 is set to ON.


Default Status register (R33) IE2808

The Default Status register defines the default status in case of communication error for every single output.

Bit | Value | Description | Manufacturer- setting
0 | 0bin | Default status for output 1 is OFF | 0bin
 | 1bin | Default status for output 1 is ON
1 | 0bin | Default status for output 2 is OFF | 0bin
 | 1bin | Default status for output 2 is ON
... | 0bin | ... | 0bin
 | 1bin | ...
15 | 0bin | Default status for output 16 is OFF | 0bin
 | 1bin | Default status for output 16 is ON


Enable Defaultstatus register (R32) IE2808

BECKHOFF Fieldbus Box: Configuration

Enable Default Status Register (R32) IE2808

The Enable Default Status register defines for every singe output, if this output is set to the it's default value (defined by Register R33) in case of communication error.

Bit | Value | Description | Manufacturer- setting
0 | 0bin | Default status disabled for output 1 | 0bin
 | 1bin | Default status enabled for output 1
1 | 0bin | Default status disabled for output 2 | 0bin
 | 1bin | Default status enabled for output 2
... | 0bin | ... | 0bin
 | 1bin | ...
15 | 0bin | Default status disabled for output 16 | 0bin
 | 1bin | Default status enabled for output 16


Functioning IP/IE3102

The analog input module handle signals from -10 V up to 10 V with a resolution of 16 bits. The filter constants and the associated conversion times can be adjusted over a wide range.

Process data (hex) | Process data (decimal) | Measured value
0x8000 | -32768 | -10 V
0xC001 | -16383 | -5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V

Representation corresponds to the integer number format (INT). The default setting is for the process data to be entered in twos complement (-1 corresponds to 0xFFFF).

Process data

The process data written by the controller is output as follows:
x_adc = output value from the A/D converter
y_aus = process data to the PLC controller
B_a, A_a = manufacturer scaling (registers 17, 18)
B_h, A_h = manufacturer scaling (registers 19, 20)
B_w, A_w = user scaling (registers 33, 34)
Y_dac = output value to the D/A converter

Neither user nor manufacturer scaling are active

Y_a = (B_a + x_adc)*A_a
Y_aus = Y_a

Manufacturer scaling active (default)

Y_1 = B_h + A_h * Y_a
Y_aus = Y_1

User scaling active

Y_2 = B_w + A_w * Y_a
Y_aus = Y_2

Manufacturer and user scaling active

Y_1 = B_h + A_h *Y_a
Y_2 = B_w + A_w * Y_1
Y-aus = Y_2

The linear equations are activated via register 32.

Conceptual circuit diagram


Control and Status Byte IP/IE3102

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | -

Key:

Bit | Name | description
7 | RegAccess | 0bin | Register Communication switched off (Process data mode)
6...0 | - | reserved

Status byte

The Status byte is only visible if the Fieldbus Box is set to complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | Limit value 2 |  | Limit value 1 |  | Over-Range | Under-Range

Key:

Bit | Name | description
7 | RegAccess | 0bin | Acknowledgement for process data mode
6 | Error | general error bit
5,4 | Limit value 2 | 00bin | Limit value 2 not active
 |  | 01bin | Process data > limit value 2
 |  | 10bin | Process data < limit value 2
 |  | 11bin | Process data = limit value 2
3,2 | Limit value 1 | 00bin | Limit value 1 not active
 |  | 01bin | Process data > limit value 1
 |  | 10bin | Process data < limit value 1
 |  | 11bin | Process data = limit value 1
1 | Over-Range | 1bin | if R32 Bit 4 = 0: Range of measurement exceeded (>0x7FFF)
 |  |  | if R32 Bit 4 = 1: Measured value ≥ 10.5 V
0 | Under-Range | 1bin | if R32 Bit 4 = 0: Measurement is below range (> 0x8000)
 |  |  | if R32 Bit 4 = 1: Measured value ≤ -10.5 V
Note

The user scaling must be modified in order to change the under/over range limits. Example:
You want to set an over range value of 10.6 V. You therefore have to activate the user scaling, and change the gain in register 34 to 0x00F0. The measuring range now goes up to 10.6 V (the maximum possible is 11.8 V).

Register Communication

Measured values cannot be transmitted during register communication.

Control Byte

The Control byte is only visible if the Fieldbus Box is set to complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Key:

Bit | Name | description
7 | RegAccess | 1bin: | Register Communication switched on
6 | R/W | 0bin | Read
 |  | 1bin | Write
5...0 | Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is set to complete mode. It byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Key:

Bit | Name | description
7 | RegAccess | 1bin | Acknowledgement for register access
6 | R/W | 0bin | Read
5...0 | Register number | Number of the register that has been read or written


Register Overview IP/IE3102

Register | Description | Default value | Read/Write | Memory medium
R0 | Unprocessed ADC value | variable | R | RAM
R1 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserved | 0x0000 | R |
R8 | Module type | 3102dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x0098 | R | ROM
R13 | Data structure | 0x0004 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | Hardware compensation: Offset | specific | R/W | SEEROM
R18 | Hardware compensation: Gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x0100 | R/W | SEEROM
R21 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0010 | R/W | SEEROM
R33 | User offset | 0x0000 | R/W | SEEROM
R34 | User gain | 0x0100 | R/W | SEEROM
R35 | Limit value 1 | 0x0000 | R/W | SEEROM
R36 | Limit value 2 | 0x0000 | R/W | SEEROM
R37 | Filter register | 0x3200 | R/W | SEEROM
R38 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


Feature Register (R32) IP/IE3102

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default [0x0010]

Bit | Value | Description | Manufacturer’s setting
0 | 0bin | User scaling is inactive | 0bin
 | 1bin | User scaling is active
1 | 0bin | Manufacturer scaling is inactive | 0bin
 | 1bin | Manufacturer scaling is active
2 | 0bin | reserved | 0bin
3 | 0bin | The arithmetic sign of numerical quantities is not represented | 0bin
 | 1bin | The arithmetic sign of numerical quantities is active (-1 = 0x8001)
4 | 0bin | Overflow offset is inactive: process data is monitored for to be greater than 0x7FFF (or 0xFFFF, depending on the manufacturer scaling) and the result is indicated in the status byte. | 1bin
 | 1bin | Overflow offset is active: the measured value (the actual voltage) is monitored and the result is indicated in the status byte.
5 | 0bin | reserved | 0bin
... | ... | ... | ...
8 | 0bin | reserved | 0bin
9 | 0bin | Limit value 1 is inactive | 0bin
 | 1bin | Limit value 1 is active (the limit value 1 is specified in Register R35)
10 | 0bin | Limit value 2 is inactive | 0bin
 | 1bin | Limit value 2 is active (the limit value 2 is specified in Register R36)
11 | 0bin | reserved | 0bin
... | ... | ... | ...
15 | 0bin | reserved | 0bin


Filter Register (R37) IP/IE3102

The IP/IE3102 possesses two low-pass filter stages. The first stage consists of a sin³ filter. This is always active. The second consists of a 22nd order FIR filter. This can be deactivated. The filter settings always apply to all the channels, and are set in the first register for channel 1. The settings are not effective until after a power on reset (switch the Fieldbus Box off and on again).

Bit | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | SF11 | SF10 | SF9 | SF8 | SF7 | SF6 | SF5 | SF4 | SF3 | SF2 | SF1 | SF0 | 0 | 0 | SKIP | Fast
FAST

1 - Active
0 - Inactive
When active there is a fast reaction to input steps (in spite of the filter stage being active); in this case the filter is being bypassed.

SKIP

0 - FIR filter active
1 - FIR filter is bypassed

Bits 2, 3

must be zero.

SF0-11

This is the filter constant itself. It specifies the 3dB limit frequency of the sin³ filter. The value ranges from 150 to 2,047. The 3 dB limit frequency and the 64.5 dB stop frequency Fstop are listed in the following table and are calculated as follows:

SKIP = 0
SF = 11981/ Flimit
SF = 43008/ Fstop

SKIP = 1
SF = 80486/ Flimit

Example: You want to set a limit frequency of 75 Hz
SF = 11981/ Flimit = 11981/75 = 160dec » 0000_1010_0000 bin + Low-Byte = 0000_1010_0000_0000bin = 0x0A00

Default register setting is 0x35C0.

 | Register 37 | Fstop [Hz] | Flimit [Hz] | Cycle time [ms]
SKIP =0 Fast = 0 | 0x0A00 | 270 | 75 | 50
 | 0x1400 | 135 | 38 | 100
 | 0x1E00 | 90 | 25 | 150
 | 0x2800 | 68 | 19 | 200
 | 0x3200 | 54 | 15 | 250
SKIP = 0 Fast =1 | 0x0781 |  |  | 5
 | 0x0F01 |  |  | 10
 | 0x1681 |  |  | 15
 | 0x1E01 |  |  | 20
 | 0x2581 |  |  | 25
SKIP = 1 Fast = x | 0x0782 |  | 671 | 5
 | 0x0F02 |  | 335 | 10
 | 0x1682 |  | 224 | 15
 | 0x1E02 |  | 168 | 20
 | 0x2582 |  | 134 | 15


Functioning IP/IE3112

The analog input module handles signals from 0 to 20 mA with a resolution of 16 bits. The filter constants and the associated conversion times can be adjusted over a wide range.

Process data (hex) | Process data (decimal) | Measured value
0x0000 | 0 | 0 mA
0x3FFF | 16383 | 10 mA
0x7FFF | 32767 | 20 mA

As from software version [IP3112-Bxxx "3"; IE3112 "0"] (see Appendix) it is also possible to set the range from 4..20 mA in register 32 (bit 5 = 1). This setting in the feature register can be set separately for each channel.

Process data (hex) | Process data (decimal) | Measured value
0x0000 | 0 | 4 mA
0x3FFF | 16383 | 12 mA
0x7FFF | 32767 | 20 mA

Representation corresponds to the INT (integer) number format. The default setting is for the process data to be entered in twos complement (-1 corresponds to 0xFFFF).

Process data

The process data written by the controller is output as follows:
x_adc = output value from the A/D converter
y_aus = process data to the PLC controller
B_a, A_a = manufacturer scaling (registers 17, 18)
B_h, A_h = manufacturer scaling (registers 19, 20)
B_w, A_w = user scaling (registers 33, 34)
Y_dac = output value to the D/A converter

Neither user nor manufacturer scaling are active

Y_a = (B_a + x_adc)*A_a
Y_aus = Y_a

Manufacturer scaling active (default)

Y_1 = B_h + A_h * Y_a
Y_aus = Y_1

User scaling active

Y_2 = B_w + A_w * Y_a
Y_aus = Y_2

Manufacturer and user scaling active

Y_1 = B_h + A_h * Y_a
Y_2 = B_w + A_w * Y_1
Y-aus = Y_2
The linear equations are activated via register 32.

Conceptual circuit diagram


Control and Status Byte IP/IE3112

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | Limit value 2 |  | Limit value 1 |  | Over-Range | Under-Range

Name | description
RegAccess | 0bin: Acknowledgement for process data mode
Error | general error bit (value >21mA or <3mA in 4...20mA mode)
Limit value 2 Limit value 1 | 00bin Limit value not active 10bin Process data < limit value 01bin Process data > limit value 11bin Process data = limit value
Over-Range | R32 Bit 4 = 0: Range of measurement exceeded >0x7FFF or 0xFFFF | R32 Bit 4 = 1: Measured value > 20 mA
Under-Range | R32 Bit 4 = 0 und R32 Bit 5 = 0: no function | R32 Bit 4 = 1 und R32 Bit 5 = 1: Measured value < 4 mA

Register Communication

Measured values cannot be transmitted during register communication.

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE3112

Register | Description | Default value | Read/Write | Memory medium
R0 | Unprocessed ADC value | variable | R | RAM
R1 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserved | 0x0000 | R |
R8 | Module type | 3112dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x0098 | R | ROM
R13 | Data structure | 0x0004 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | EEPROM
R17 | Hardware compensation offset | specific | R/W | EEPROM
R18 | Hardware compensation gain | specific | R/W | EEPROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | EEPROM
R20 | Manufacturer scaling: Gain | 0x0080 | R/W | EEPROM
R21 | reserved | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0012 | R/W | EEPROM
R33 | User offset | 0x0000 | R/W | EEPROM
R34 | User gain | 0x0100 | R/W | EEPROM
R35 | Limit value 1 | 0x0000 | R/W | EEPROM
R36 | Limit value 2 | 0x0000 | R/W | EEPROM
R37 | Filter register | 0x3200 | R/W | EEPROM
R38 | reserved | 0x0000 | R/W |
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W |


Feature register (R32) IP/IE3112

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default [0x0012]

Bit | Value | Description | Manufacturer’s setting
0 | 0bin | User scaling is inactive | 0bin
 | 1bin | User scaling is active
1 | 0bin | Manufacturer scaling is inactive | 1bin
 | 1bin | Manufacturer scaling is active
2 | 0bin | reserved | 0bin
3 | 0bin | The arithmetic sign of numerical quantities is not represented | 0bin
 | 1bin | The arithmetic sign of numerical quantities is active (-1 = 0x8001)
4 | 0bin | Overflow offset is inactive | 1bin
 | 1bin | Overflow offset is active
5 )1 | 0bin | 0..20 mA mode | 0bin
 | 1bin | 4..20 mA mode
6 | 0bin | reserved | 0bin
... | ... | ... | ...
8 | 0bin | reserved | 0bin
9 | 0bin | Limit value 1 is inactive | 0bin
 | 1bin | Limit value 1 is active (R35)
10 | 0bin | Limit value 2 is inactive | 0bin
 | 1bin | Limit value 2 is active (R36)
11 | 0bin | reserved | 0bin
... | ... | ... | ...
15 | 0bin | reserved | 0bin

Overflow offset

If this bit is set, the measured value (the actual current) is monitored and indicated in the status byte.
If this bit is not set, then process data greater than 0x7FFF (or 0xFFFF, depending on the manufacturer scaling) is indicated in the status byte.

)1 as from I/O circuit board software version IP3112-Bxxx "3" IE3112 "0"


Filter Register (R37) IP/IE3112

The IP/IE3112 possesses two low-pass filter stages. The first stage consists of a sin³ filter. This is always active. The second consists of a 22nd order FIR filter. This can be deactivated. The filter settings always apply to all the channels, and are set in the first register for channel 1. The settings are not effective until after a power on reset (switch the Fieldbus Box off and on again).

Bit | SF11 | SF10 | SF9 | SF8 | SF7 | SF6 | SF5 | SF4 | SF3 | SF2 | SF1 | SF0 | 0 | 0 | SKIP | Fast
Name | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
FAST

1 - active
0- inactive
When active there is a fast reaction to input steps (in spite of the filter stage being active); in this case the filter is being bypassed.

SKIP

0 - FIR filter active
1 - FIR filter is bypassed

Bits 2, 3

must be zero.

SF0-11

This is the filter constant itself. It specifies the 3dB limit frequency of the sin³ filter. The value ranges from 150 to 2,047. The 3 dB limit frequency and the 64.5 dB stop frequency Fstop are listed in the following table and are calculated as follows:

SKIP = 0
SF = 11981/ Flimit
SF = 43008/ Fstop

SKIP = 1
SF = 80486/ Flimit

Example: You want to set a limit frequency of 75 Hz
SF=11981/ Flimit = 11981/75 = 160dez » 0000_1010_0000bin + LowByte = 0000_1010_0000_0000 = 0x0A00

Default 0x3200

 | Register 37 | Fstop [Hz] | Flimit [Hz] | Cycle time [ms]
SKIP =0 Fast = 0 | 0x0A00 | 270 | 75 | 50
 | 0x1400 | 135 | 38 | 100
 | 0x1E00 | 90 | 25 | 150
 | 0x2800 | 68 | 19 | 200
 | 0x3200 | 54 | 15 | 250
SKIP = 0 Fast =1 | 0x0781 |  |  | 5
 | 0x0F01 |  |  | 10
 | 0x1681 |  |  | 15
 | 0x1E01 |  |  | 20
 | 0x2581 |  |  | 25
SKIP = 1 Fast = x | 0x0782 |  | 671 | 5
 | 0x0F02 |  | 335 | 10
 | 0x1682 |  | 224 | 15
 | 0x1E02 |  | 168 | 20
 | 0x2582 |  | 134 | 15


Functioning IP/IE3202

The IP3202-Bxxx or IE3202 analog input module allows four resistance sensors to be connected directly. The resistance sensors can be connected according to the 2, 3 or 4 wire connection method. Calculation and linearisation of the resistance value to obtain a temperature is performed by a microcontroller in the module.

Temperatures are output in 1/10 °C (1 digit = 0.1 °C). In addition to this, a broken wire or short circuit is reported to the slave or to the controller, and indicated by the error LED.

PT100, NI100, PT200, PT500, NI120, NI1000 and PT1000 elements are implemented over their full measuring ranges as resistance sensors. The module can be fully configured over a fieldbus. A self-defined scaling of the output can, for instance, be performed, or the temperature conversion can be switched off. In the latter case, the measurement is output is in the range from 10 ohm up to 1.2/5.0 kohm with a resolution of 1/10 resp. 1/2 ohm (the internal resolution of the resistance value is 1/255 ohm).

Process data output format

Process data (hex) | Process data Decimal (Integer) | Measured value
0xF63C | -2500 | -250°C
0xF830 | -2000 | -200°C
0xFC18 | -1000 | -100°C
0xFFFF | -1 | -0.1°C
0x0000 | 0 | 0.0°C
0x0001 | 1 | 0.1°C
0x03E8 | 1000 | 100°C
0x07D0 | 2000 | 200°C
0x1388 | 5000 | 500°C
0x2134 | 8500 | 850°C

Process data

The process data that is transmitted to the K-Bus is calculated from the following equations:

X_RL: ADC value of the supply cables
X_RTD: ADC value of the temperature sensor, including one supply cable
X_R: ADC value of the temperature sensor
A_a, B_a: Manufacturer, gain and offset compensation (R17, R18)
A_h, B_h: Manufacturer scaling
A_w, B_w: User scaling
Y_R: Temperature sensor resistance value
Y_T: Measured temperature in 1/16 °C
Y_THS: Temperature after manufacturer scaling (1/10 °C )
Y_TAS: Temperature after user scaling
Y_AUS: Process data to PLC controller

a) Calculation of the resistance value:
X_R = X_RTD-X_RL (1.0) Y_R = A_a * (X_R -B_a) (1.1)

b) Curve linearisation:
Y_T = a1 * Y_R^2 + b1* Y_R + c1 (1.2) or Y_T = Y_R if the output is in ohms (1.3)

c) Neither user nor manufacturer scaling are active:
Y_AUS = Y_T (1.4)

d) Manufacturer scaling active (factory setting):
Y_THS = A_h * Y_T + B_h (1.5) Y_AUS = Y_THS

e) User scaling active:
Y_TAS = A_w * Y_T + B_w (1.6) Y_AUS = Y_TAS

f) Manufacturer and user scaling active: (1.7)
Y_1 = A_h * Y_T + B_h Y_2 = A_w * Y_1 + B_w Y_AUS = Y_2

Conceptual circuit diagram


Control and Status Byte IP/IE3202

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | reserved |  | reserved |  | Over-Range | Under-Range

Name | description
RegAccess | 0bin: Acknowledgement for process data mode
Error | general error bit
Over-Range | R > 400 Ohm
Under-Range | R < 18 Ohm

Register Communication

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE3202

Register | Description | Default value | Read/Write | Memory medium
R0 | Unprocessed ADC value | variable | R | RAM
R1 | Unprocessed ADC value for the leads | variable | R | RAM
R2 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R5 | reserved | 0x0000 | R |
R6 | Diagnostic register | variable | R | RAM
R7 | reserved | 0x0000 | R |
R8 | Module type | 3202dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x0098 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | Hardware compensation offset | specific | R/W | SEEROM
R18 | Hardware compensation gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x00A0 | R/W | SEEROM
R21 | Offset register two-wire connection method | specific | R/W | SEEROM
R22 | Offset register three-wire connection method | specific | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0102 | R/W | SEEROM
R33 | User offset | 0x0000 | R/W | SEEROM
R34 | User gain | 0x0100 | R/W | SEEROM
R35 | reserved | 0x0000 | R/W | SEEROM
R36 | reserved | 0x0000 | R/W | SEEROM
R37 | Filter register | 0x0000 | R/W | SEEROM
R38 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


Feature register (R32) IP/IE3202

The module's fundamental settings can be modified in the feature register.

Write protection must first be cancelled in the code-word register before it is possible to write into this register (default: 0x0106).

Attention 2-, 3- or 4-wire connection has to be the same in the registers of all four channels.

Bit | Value | Description |  | Manufacturer’s setting
0 | 0bin | User scaling is inactive |  | 0bin
 | 1bin | User scaling is active (registers 33, 34)
1 | 0bin | Manufacturer scaling is inactive |  | 1bin
 | 1bin | Manufacturer scaling is active (registers 19, 20)
2 | 0bin | no function |  | 0bin
3 | 0bin | Sign-amount representation is inactive |  | 0bin
 | 1bin | Sign-amount representation is active
4 | 0bin | Hide Siemens extension bits |  | 0bin
 | 1bin | Reveal Siemens extension bits
5 | 0bin | no function |  | 0bin
6 | 0bin | no function |  | 0bin
7 | 0bin | Deactivate manual filter setting in register 37 |  | 0bin
 | 1bin | Activate manual filter setting in register 37
8 | 0bin | Deactivate over range protection |  | 1bin
 | 1bin | Activate over range protection If the temperature exceeds 850°C the status bits are correspondingly set and the output value is restricted to 850°C.
10... 9 | 00bin | Four-wire connection is activated (Attention: this has to be same for all four channels) |  | 00bin
 | 01bin | Three-wire connection is activated* (Attention: this has to be same for all four channels)
 | 10bin | Two-wire connection is activated (Attention: this has to be same for all four channels)
11 | 0bin | no function |  | 0bin
15...12 | 0hex | PT100 | -200°C - 850°C ± 0.3°C | 0hex
 | 1hex | NI100 | -60°C - 250°C ± 0.3°C
 | 2hex | PT1000 | -200°C - 850°C ± 0.3°C
 | 3hex | PT500 | -200°C - 850°C ± 0.5°C
 | 4hex | PT200 | -200°C - 850°C ± 0.3°C
 | 5hex | NI1000 | -200°C - 850°C ± 0.3°C
 | 6hex | NI120 | -80°C - 320°C ± 0.3°C
 | 7hex | RSNE1000 | Nickel 1000, special Siemens temperature curve
 | Ehex | Ohm | 10 - 5000 ohms (in 1/2 Ohm)
 | Fhex | Ohm | 10 -1200 ohms (in 1/10 Ohm)

*) as from I/O circuit board firmware version 2 of IP3202 resp. as from I/O circuit board firmware version 0 of IE3202

Explanation of the sign bit

The default representation is twos complement, i.e. -1 is represented as 0xFFFF

Sign-amount representation is active, i.e. -1 is represented by 0x8001

Scaling example

Manufacturers scaling active, user scaling active, output in ohms, 10-5000 ohms
Register 34 0x0500 0.100 ohm / digit
Register 34 0x0400 0.125 ohm / digit
Register 34 0x0200 0.250 ohm / digit
Register 34 0x0100 0.500 ohm / digit
Register 34 0x0080 1.000 ohm / digit

Siemens output format (S5)

If the Siemens output format is selected, the lowest three bits are used to assess the status. The process data is represented in bits 3-15, where bit 15 is the arithmetic sign bit.

Bit | Name | Description
0 | Overflow | 0bin | Value in Range
 |  | 1bin | Value out of range
1 | Error | 0bin | No error
 |  | 1bin | Error
2 | - | 0bin | reserverd
14...3 | Value | 0bin | process data
15 | Sign | 0bin | plus
 |  | 1bin | minus

Two-wire connection

A resistance can be measured directly through the two-wire connection. That proportion of the resistance represented by the connecting cables can be measured and entered in register 21. For two-wire connection, it is necessary to copy the raw ADC value from register 1 into register 22 while the conductor resistance is short-circuited (+RL -RL).

User scaling

Example of scaling to Fahrenheit


Filter Register (R37) IP/IE3202

The filter time of the A/D converter can be modified in the filter register. Write protection must first be cancelled in the code-word register before it is possible to write into this register. The conversion time of the A/D converter also changes when the filter time is changed. The two values depend directly upon one another. The filter settings always apply to all the channels, and are set in the first register for channel 1. The settings are not effective until after a power on reset (switch the Fieldbus Box off and on again).

Default 0x0000

Value | Filter First Notch [Hz] | Conversion time
0x0000 | 25 | 250 ms
0x0050 | 100 | 65 ms
0x00A0 | 50 | 125 ms
0x0140 | 25 | 250 ms
0x0280 | 12.5 | 500 ms


Functioning IP/IE3312

Thermocouples can be classified as active measuring sensors. They exploit the thermo-electric effect (Seebeck, Peltier, Thomson). Where two electrical conductors of different materials (e.g. iron and constantan) make contact, charge is transferred across the contact surface. A contact potential develops, and is strongly dependent on temperature. The thermally generated voltage is both a function of the temperature being measured, T, and of the comparison temperature, Tv, at the point where contact is made with the thermocouple. Since the coefficients are determined at a comparison temperature of 0°C, it is necessary to compensate for the effect of the comparison temperature. This is done by converting the comparison temperature into a comparison voltage that depends on the type of thermocouple, and adding this to the measured thermal voltage. The temperature is found from the resulting voltage and the corresponding curve.

Temperatures are measured 1/10°C (1 Digit = 0,1°C). A missing cold compensation sensor (PT1000) or wire break is reported and indicated by the Error LED.

Format of the process data

process data (hex) | process data decimal (integer) | temperature value
0xF63C | -2500 | -250°C
0xF830 | -2000 | -200°C
0xFC18 | -1000 | -100°C
0xFFFF | -1 | -0,1°C
0x0000 | 0 | 0,0°C
0x0001 | 1 | 0,1°C
0x03E8 | 1000 | 100°C
0x07D0 | 2000 | 200°C
0x1388 | 5000 | 500°C
0x2134 | 8500 | 850°C

Block diagram

fu3312.jpg (21063 Byte)

Conceptual circuit diagram


Control and Status Byte IP/IE3312

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | - | - | NoColdJunction | internal Error | Over-Range | Under-Range

Name | description
RegAccess | 0bin: Acknowledgement for process data mode
Error | general error bit
NoColdJunction | cold junction in the plug is lost: An error is reported if the cold junction is not in the range between -50 and +100°C.
internal Error | analog part of the Fieldbus Box is faulty
Over-Range | broken wire
Under-Range | value under minimum value of the chosen thermocouple (Bit R32.12 to Bit R32.12 of the Feature Register)

Register Communication

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE3312

Register | Description | Default value | Read/Write | Memory medium
R0 | Unprocessed ADC value | variable | R | RAM
R1 | Unprocessed comparison value | variable | R | RAM
R2 | Temperature comparison in 1/16°C | variable | R | RAM
R3 | reserved | 0x0000 | R |
R4 | reserved | 0x0000 | R |
R5 | reserved | 0x0000 | R |
R6 | Diagnostic register | variable | R | RAM
R7 | reserved | 0x0000 | R |
R8 | Module type | 3314dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x0098 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | Hardware compensation: Offset | specific | R/W | SEEROM
R18 | Hardware compensation: Gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x00A0 | R/W | SEEROM
R21 | Hardware compensation comparison temperature | specific | R/W | SEEROM
R22 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x1002 | R/W | SEEROM
R33 | User offset | 0x0000 | R/W | SEEROM
R34 | User gain | 0x0100 | R/W | SEEROM
R35 | reserved | 0x0000 | R/W | SEEROM
R36 | reserved | 0x0000 | R/W | SEEROM
R37 | Filter register | 0x0000 | R/W | SEEROM
R38 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


Feature Register (R32) IP/IE3312

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default: 0x1002

Bit | Value | Description |  |  |  | Manufacturer’s setting
0 | 0bin | User scaling is inactive |  |  |  | 0bin
 | 1bin | User scaling is active
1 | 0bin | Manufacturer scaling is inactive |  |  |  | 1bin
 | 1bin | Manufacturer scaling is active
2 | 0bin | reserved |  |  |  | 0bin
3 | 0bin | Sign-amount representation is inactive |  |  |  | 0bin
 | 1bin | Sign-amount representation is active
4 | 0bin | Hide Siemens extension bits |  |  |  | 0bin
 | 1bin | Reveal Siemens extension bits
5 | 0bin | Deactivate manual filter setting in register 37 |  |  |  | 0bin
 | 1bin | Activate manual filter setting in register 37
6 | 0bin | reserved |  |  |  | 0bin
7 | 0bin | reserved |  |  |  | 0bin
8 | 0bin | Comparison temperature is switched on |  |  |  | 0bin
 | 1bin | Comparison temperature is switched off
9 | 0bin | reserved |  |  |  | 0bin
10 | 0bin | reserved |  |  |  | 0bin
11 | 0bin | Do not use the comparison point for the first channel for all the other channels |  |  |  | 0bin
 | 1bin | Use the comparison point for the first channel for all the other channels
15-12 |  | Thermocouple type |  | minimal value | maximum value | 1hex
 | 0hex | Type L |  | -100 °C | 900 °C
 | 1hex | Type K |  | -100 °C | 1370 °C
 | 2hex | Type J |  | -100 °C | 1000 °C
 | 3hex | Type E |  | -100 °C | 800 °C
 | 4hex | Type T |  | -100 °C | 400 °C
 | 5hex | Type N |  | -100 °C | 1300 °C
 | 6hex | Type U |  | -100 °C | 600 °C
 | 7hex | Type B |  | 600 °C | 1800 °C
 | 8hex | Type R |  | 0 °C | 1700 °C
 | 9hex | Type S |  | 0 °C | 1700 °C
 |  | Millivolt measurement, resolution: |  | minimal value | maximum value
 | Dhex | 1 µV* | 1,6 µV** | -30 mV | +30 mV
 | Ehex | 2 µV* | 3,2 µV** | -60 mV | +60 mV
 | Fhex | 4 µV* | 6,4 µV** | -80 mV | +80 mV
Note For millivolt measurement please consider, witch scaling is activated:
*) no scaling active
**) only manufacturer scaling active

Explanation of the sign bit

The default representation is twos complement, i.e. -1 is represented as 0xFFFF

Sign-amount representation is active, i.e. -1 is represented by 0x8001

User scaling

See Example of scaling to Fahrenheit


Filter Register (R37) IP/IE3312

The filter time of the A/D converter can be modified in the filter register. Write protection must first be cancelled in the code-word register before it is possible to write into this register. The conversion time of the A/D converter also changes when the filter time is changed. The two values depend directly upon one another. The filter settings always apply to all the channels, and are set in the first register for channel 1. The settings are not effective until after a power restart (switch the Fieldbus Box off and on again).

Default 0x0000

Value | Filter First Notch [Hz] | Conversion time
0x0000 | 25 | 200 ms
0x0050 | 100 | 70 ms
0x00A0 | 50 | 120 ms
0x0140 | 25 | 200 ms
0x0280 | 12.5 | 400 ms


Functioning IP/IE4112

The analog output module generates output signals in the range from 0...20 mA. The module supplies the output current with a resolution of up to 16 bits.

Process data (hex) | Process data (decimal) | Output value
0x0000 | 0 | 0 mA
0x3FFF | 16383 | 10 mA
0x7FFF | 32767 | 20 mA

As from software version 2 (see Appendix) it is also possible to set a range from 4...20 mA in register 32 (bit 5 = 1). This setting in the feature register of the first channel then applies to all channels, and cannot be set separately for each channel.

Process data (hex) | Process data (decimal) | Output value
0x0000 | 0 | 4 mA
0x3FFF | 16383 | 12 mA
0x7FFF | 32767 | 20 mA

Representation corresponds to the integer number format (INT). The default setting is for the process data to be entered in twos complement (-1 corresponds to 0xFFFF).

Process data

The process data written by the controller is output as follows:
x = PLC process data (D0, D1)
B_a, A_a = manufacturer scaling (registers 17, 18)
B_h, A_h = manufacturer scaling (registers 19, 20)
B_w, A_w = user scaling (registers 33, 34)
Y_dac = output value to the D/A converter

Neither user nor manufacturer scaling are active
Y_0 = B_a + A_a * x
Y_dac = Y_0

Manufacturer scaling active (default)
Y_1 = B_h + A_h * Y_0
Y_dac = Y_1

User scaling active
Y_2 = B_w + A_w * Y_0
Y_dac = Y_2

Manufacturer and user scaling active
Y_1 = B_h + A_h *Y_0
Y_dac = B_w + A_w * Y_1

The linear equations are activated via register 32.

Conceptual circuit diagram

IPIE4112.gif (51976 Byte)


Control and Status Byte IP/IE4112

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status-Byte

The Control byte is only visible if the Fieldbus Box is set to complex mode. The byte is located in the Fieldbus Box's input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Name | Description
RegAccess | 0bin: Acknowledgement for Process Data Mode

Register Communication

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE4112

Register | Description | Default value | Read/Write | Memory medium
R0 | Manufacturer switch-on value | 0x0000 | R/W |
... | ... | ... | ... | ...
R4 | reserved | 0x0000 | R |
R5 | Raw DAC value | variable | R | RAM
R6 | reserved | 0x0000 | R |
R7 | reserved | 0x0000 | R |
R8 | Module type | 4112dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x9800 | R | ROM
R13 | Data structure | 0x0004 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | EEPROM
R17 | Hardware compensation offset | specific | R/W | EEPROM
R18 | Hardware compensation gain | specific | R/W | EEPROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | EEPROM
R20 | Manufacturer scaling: Gain | 0x0200 | R/W | EEPROM
R21 | reserved | 0x0000 | R/W |
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0002 | R/W | EEPROM
R33 | User offset | 0x0000 | R/W | EEPROM
R34 | User gain | 0x0100 | R/W | EEPROM
R35 | User switch-on value | 0x0000 | R/W |
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W |


Feature register (R32) IP/IE4112

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.

Bit | Value | Description | Manufacturer’s setting
0 | 0 | User scaling is inactive | 0
 | 1 | User scaling is active
1 | 0 | Manufacturer scaling is inactive | 1
 | 1 | Manufacturer scaling is active
2 | 0 | Watchdog timer active. | 0
 | 1 | Watchdog timer inactive.
3 | 0 | reserved | 0
4 | 0 | reserved | 0
5)1 | 0 | 0..20 mA mode | 0
 | 1 | 4..20 mA mode
8 | 0 | Manufacturer switch-on value [0] | 0
 | 1 | User switch-on value R35
9 | 0 | reserved | 0
... | ... | ... | ...
15 | 0 | reserved | 0

Explanation of the watchdog timer

The watchdog timer is switched on by default. If the watchdog overflows, then either the manufacturer's or the user's switch-on value is output by the module.

Attention | The 0..20mA / 4..20mA modus has to be selected in the register of the first channel and is valid for all four channels! The change will be performed after a POWER OFF/ON!
Note | For reasons of compatibility, 16 bit signed integer is selected as the standard output format. The range of positive values for 0..20 mA ranges from 0x0000 to 0x7FFF. This corresponds to 15 bits. Manufacturer scaling must be deactivated in order to exploit all 16 bits. )1 As from I/O circuit board software version IP4112-Bxxx "2" IE4112 "0"


Functioning IP/IE4132

The analog output module generates output signals in the range from -10...10 V. The module supplies the output voltage with a resolution of up to 16 bits.

Process data (hex) | Process data (decimal) | Output value
0x8001 | -32767 | -10 V
0xC001 | -16383 | - 5 V
0x0000 | 0 | 0 V
0x3FFF | 16383 | 5 V
0x7FFF | 32767 | 10 V

Representation corresponds to the integer number format (INT). The default setting is for the process data to be entered in twos complement (-1 corresponds to 0xFFFF).

Process data

The process data written by the controller is output as follows:
x = PLC process data (D0, D1)
B_a, A_a = manufacturer scaling (registers 17, 18)
B_h, A_h = manufacturer scaling (registers 19, 20)
B_w, A_w = user scaling (registers 33, 24)
Y_dac = output value to the D/A converter

Neither user nor manufacturer scaling are active
Y_0 = B_a + A_a * x
Y_dac = Y_0

Manufacturer scaling active (default)
Y_1 = B_h + A_h * Y_0
Y_dac = Y_1

User scaling active
Y_2 = B_w + A_w * Y_0
Y_dac = Y_2

Manufacturer and user scaling active
Y_1 = B_h + A_h *Y_0
Y_dac = B_w + A_w * Y_1

The linear equations are activated via register 32.

Conceptual circuit diagram

IPIE4132.jpg (48260 Byte)


Control and Status Byte IP/IE4132

BECKHOFF Fieldbus Box: Set-Up

Control and Status Bytes IP/IE4132

Process Data Mode

Control Byte

The Control byte is only visible, if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status-Byte

The Control byte is only visible if the Fieldbus Box is set to complex mode. The byte is located in the Fieldbus Box's input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Name | Description
RegAccess | 0bin: Acknowledgement for process data mode

Register Communication

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. The byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE4132

Register | Description | Default value | Read/Write | Memory medium
R0 | Manufacturer switch-on value | 0x0000 | R/W |
... | ... | ... | ... | ...
R4 | reserved | 0x0000 | R |
R5 | Raw DAC value | variable | R | RAM
R6 | reserved | 0x0000 | R |
R7 | reserved | 0x0000 | R |
R8 | Module type | 4132dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0418 | R | ROM
R11 | Signal channels | 0x0418 | R | ROM
R12 | Minimum data length | 0x9800 | R | ROM
R13 | Data structure | 0x0004 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | Hardware compensation: Offset | specific | R/W | SEEROM
R18 | Hardware compensation: Gain | specific | R/W | SEEROM
R19 | Manufacturer scaling: Offset | 0x0000 | R/W | SEEROM
R20 | Manufacturer scaling: Gain | 0x0100 | R/W | SEEROM
R21 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0000 | R/W | SEEROM
R33 | User offset | 0x0000 | R/W | SEEROM
R34 | User gain | 0x0100 | R/W | SEEROM
R35 | User switch-on value | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM


Feature Register (R32) IP/IE4132

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.

Bit | Value | Description | Manufacturer’s setting
0 | 0bin | User scaling is inactive | 0bin
 | 1bin | User scaling is active
1 | 0bin | Manufacturer scaling is inactive | 0bin
 | 1bin | Manufacturer scaling is inactive
2 | 0bin | Watchdog timer active. | 0bin
 | 1bin | Watchdog timer inactive.
3 | 0bin | reserved | 0bin
... | ... | ... | ...
7 | 0bin | reserved | 0bin
8 | 0bin | Manufacturer switch-on value [0] | 0
 | 1bin | User switch-on value R35
9 | 0bin | reserved | 0bin
... | ... | ... | ...
15 | 0bin | reserved | 0bin

Explanation of the watchdog timer

The watchdog timer is switched on by default. If the watchdog overflows, then either the manufacturer's or the user's switch-on value is output by the module.


Functioning IP/IE5009

The SSI sensor interface module IP/IE5009 enables the direct connection of a SSI sensor to the fieldbus or the Coupler Box. The sensor is powered via the SSI interface. The module generates a pulse for reading the sensor and makes the incoming adapted data stream available to the controller in the process image. Various operating modes, transfer frequencies, bit widths and code implementations can be selected. The individual configuration is permanently stored in a register set.

The SSI interface is supplied with a data width of 24 bits and activated Graycode conversion. The baud rate to the SSI sensor is set to 250 kHz. The process data are output in the input data bytes D0 - D3. The mapping module is described in more detail in Chapter Mapping.

Process data

Signals | Description
Outputs clock+ / clock- | Clock output for the SSI sensor
Inputs data+ / data- | Differential signal inputs (RS485)
+24 VDC US | Voltage output for the sensor supply
US | Power supply for the electronics and the encoder
UP, GND | In order for the module to operate, a power supply of 0 V and 24 V must be connected to these contacts.


Control and Status Byte IP/IE5009

Process data mode

Control Byte

The Control byte is only visible in the process image, if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | reserved

Bit | description
RegAccess | 0bin: Register Communication switched off (Process data mode)

Status byte

The status byte is only visible if the Fieldbus Box is operated in complex mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | Error | 0 | 0 | 0 | 0 | FRAME_E | SSI_IN_E

Name | Description
RegAccess | 0bin: Acknowledgement for process data mode
Error | A general fault has occurred. This bit is set if a fault has occurred in FRAME-E or SSI_IN-E
FRAME_E | The data frame is wrong, i.e. the data frame is not terminated with zero (perhaps wire breakage on clock cables).
SSI_IN_E | The SSI input of terminal is on low level, if no data transmission occurs. (SSI has no power supply or wire breakage on SSI data inputs D+ or D-, or data cables transposed)

Register Communication

Control Byte

The Control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Register Communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written

Status Byte

The Status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that has been read or written


Register Overview IP/IE5009

Register | Description | Default Value | Read/Write | Memory medium
R0 | reserved | 0000hex | R |
... | ... | ... | ... | ...
R7 | reserved | 0000hex | R |
R8 | Module type | 1391hex (5009dec) | R | ROM
R9 | Software version | XXXXhex | R | ROM
R10 | Multiplex shift register | 0218hex/0130hex | R | ROM
R11 | Signal channels | 0128hex | R | ROM
R12 | Minimum data length | 00A8hex | R | ROM
R13 | Data structure | 0000hex | R | ROM
R14 | reserved | 0000hex | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | XXXXhex | R/W | SEEROM
R17 | reserved | 0000hex | R |
... | ... | ... | ... | ...
R30 | reserved | 0000hex | R |
R31 | Codeword register | variable | R/W | RAM
R32 | Feature register | 0007hex | R/W | SEEROM
R33 | Baud rate | 0002hex | R |
R34 | Data length | 0018hex | R |
R35 | reserved | 0000hex | R |
... | ... | ... | ... | ...
R63 | reserved | 0000hex | R |
Note Changes of the register settings are not effective before a reboot of the Fieldbus Box.


Feature Register (R32) IP/IE5009

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default: 0x0001

Bit | Value | Description | default
0 | 0bin | Binary output | 1bin
 | 1bin | Graycode The numbers are output as graycode
1 | 1bin | reserved | 0bin
2 | 0bin | Free running | 0bin
 | 1bin | Synchronous mode The data are loaded synchronous to the read cycle of the Terminal Bus.
3 | 0bin | Multi-turn evaluation of the sensor | 0bin
 | 1bin | Single-turn evaluation of the encoder
4 | 0bin | Enable Frame Error | 0bin
 | 1bin | Disable Frame Error After the last valid bit, no check is carried out as to whether the data line supplies a zero signal.


Baud Rate Register (R33) IP/IE5009

The Baud Rate for the reading of the SSI data can be modified in the Baud Rate Register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
(Default: 0x0002)

Bit | Description
0 | reserved
1 | 1 MHz
2 | 250 kHz (Default)
3 | 125 kHz
4 | 100 kHz
5 | 83 kHz
6 | 71 kHz
7 | 62,5 kHz
8 | reserved
... | ...
15 | reserved


Data Length Register (R34) IP/IE5009

The data length, witch is displayed in the process image can be modified in the Data Length Register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.

Default: 0x0018 (24 bit data length)

Bit | Value | Description
0 to 7 | 0hex | 0 bit data length
 | 1hex | 1 bit data length
 | ... | ...
 | 20hex | 32 bit data length
 | 21hex | reserved
 | ... | ...
 | FFhex | reserved
8 to 15 | reserved


Functioning IP/IE5109

The IP/IE5109 incremental encoder interface module allows any 5 V incremental encoder to be connected to the Fieldbus or Coupler Box. A 16 bit counter with a quadrature decoder and a 16 bit latch can be read, set or enabled. In addition to the encoder inputs A, B and C, an additional latch input (24 V) and a gate input (24 V) for locking the counter are available.

It is also possible for the 16-bit up/down counter operating mode to be selected. In this mode, input A is the counter input, input B defines the direction.

The feature register permits measurement of periods. In this case, the length of the period between two positive edges in input signal A is determined with a resolution of 250 ns.

Single, double or quadruple evaluation of the encoder signals A, B and C in simple or complementary form can be parameterised via the fieldbus. The module is supplied set to function as a 4-fold quadrature decoder with complementary evaluation of the encoder signals A, B and C.

If the encoder has a fault signal output, it can be connected to the STATUS input of the module.

The encoder is supplied with the necessary 5 VDC power from the module.

Process data

Signals | Description
Inputs A, /A | Pulse input in the module's encoder and counter operating modes
Inputs B,/B | Phase-shifted pulse input in the module's encoder operating mode
Inputs C,/C | Zero point pulse input for the module's latch register This input is activated by means of the EN_LATC bit in the module's control byte
External latch 24 V | Additional latch input for the module This input is activated by means of the EN_LAT_EXT bit in the module's control byte. If this input is enabled, the counter value will be latched when the edge changes from 0 V to 24 V.
External gate 24 V | A high level at this contact halts counting in the terminal.
Status input | If the incremental encoder has a fault signal output, it can be connected to the status input (an active low input with internal pull up circuitry).
US | Power supply for the electronics and the encoder
UP, GND | In order for the module to operate, a power supply of 0 V and 24 V must be connected to these contacts.


Control and Status Byte IP/IE5109

Process data mode

Control byte

The control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | - | - | - | - | CNT_SET | EN_LAT_EXT / RD_PERIOD | EN_LATC

Name | Description
RegAccess | 0bin: Register communication off (process data mode)
CNT_SET | A rising edge at CNT_SET will set the counter to the value specified in the process data.
EN_LAT_EXT | The external latch input is activated. The value of the counter is entered into the latch register at the first external latch pulse after the EN_LAT_EXT bit becomes valid. When this bit is set, the subsequent pulses do not have any effect on the latch register. It is necessary to ensure that the corresponding latch-valid bit (LAT_EXT_VAL) is cleared by the module before activating the null pulse. This functionality can be set in the feature register (default setting).
RD_PERIOD | The length of the period between two positive edges at input A is measured with a resolution of 200 ns. When the bit is set, this duration is output in data bytes D3 and D4. This functionality can be set in the feature register.
EN_LATC | The null point latch (C input) is activated. The value of the counter is entered into the latch register at the first external latch pulse after the EN_LATC bid becomes valid (it has a higher priority than EN_LAT_EXT). When this bit is set, the subsequent pulses do not have any effect on the latch register. It is necessary to ensure that the corresponding latch-valid bit (LATC_VAL) is cleared by the module before activating the null pulse. (The LATC_VAL bit can only be reset by the module when the C pulse is at a low level.)

Status byte

The status byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the Fieldbus Box's input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | - | STATUS_INPUT | OVERFLOW | UNDERFLOW | CNTSET-ACC | LAT_EXT_VAL/ RD_PERIOD_Q | LATC_VAL

Name | Description
RegAccess | 0bin: Acknowledgement for process data mode
STATUS_INPUT | The state of the status input can be represented with this bit. (Can be set via the feature register.)
OVERFLOW | This bit is set if the 16-bit counter overflows (65535 to 0). It is reset when the counter exceeds one third of its measuring range (21845 to 21846) or immediately an underflow occurs.
UNDERFLOW | This bit is set if the 16-bit counter underflows (65535 to 0). It is reset when the counter drops below two thirds of its measuring range (43690 tp 43689) or immediately an overflow occurs.
CNTSET_ACC | The data for setting the counter is accepted from the module.
LAT_EXT_VAL | An external latch pulse has occurred. Data D3 and D4 in the process image corresponds to the current counter value when the bit is set. In order to reactivate the latch input, it is necessary for EN_LAT_EXT first be cleared and then to be set once more.
RD_PERIOD_Q | Data bytes 3 and 4 contain the length of the period.
LATC_VAL | A zero point latch has occurred. Data D3 and D4 in the process image corresponds to the current counter value when the bit is set. In order to reactivate the latch input, it is necessary for EN_LATC first be cleared and then to be set once more.

Register Communication

Measured values cannot be transmitted during register communication.

Control byte

The control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Register communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written.

Status byte

The status byte is only visible if the Fieldbus Box is operating in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that was read or written.


Register Overview IP/IE5109

Register | Denomination | Default value | Read/Write | Memory medium
R0 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserved | 0x0000 | R |
R8 | Module type | 5109dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0218/0130 | R | ROM
R11 | Signal channels | 0x0130 | R | ROM
R12 | Minimum data length | 0x3030 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x2020 | R/W | SEEROM
R33 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R |


Data Byte D2, IP/IE5109

Byte D2

In the up/down counter operating mode, the status of the encoder and gate/latch inputs are indicated in byte D2.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name |  |  | INPUT_A | INPUT_B | INPUT_C | INPUT_ERR | LATCH | GATE

Name | Description
INPUT_A | Status of input channel A
INPUT_B | Status of input channel B
INPUT_C | Status of input channel C
INPUT_ERR | Status of the error signal channel
LATCH | Status of the LATCH input at the M12 socket
GATE | Status of the GATE input at the M12 socket


Feature Register (R32) IP/IE5109

The module's fundamental settings can be modified in the feature register. Write protection must first be cancelled in the code-word register before it is possible to write into this register.
Default: 0x0000

Bit | Value | Description | default
0 | 0bin | not used | 0bin
1 | 0bin | Counter blocked with high level at gate input | 0
 | 1bin | Counter blocked with low level at gate input
3, 2 | 00bin | Status input (active low) is included in status byte 5 (ST.5). | 00
 | 10bin | ST.5 = Status input, ST.6 = status input
 | 11bin | ST.5 = Status input, ST.6 = !status input
 | 01bin | reserved
6, 5, 4 | 000bin | External latch function active | 000
 | 001bin | Period measurement active
 | Any other combination | Reserved, do not use
7 - 9 |  | Reserved, do not use |
11, 10 | 00bin | 4-fold evaluation of the encoder signals A, B and C, i.e. both rising and falling edges of the encoder signals A and B are counted. | 00
 | 01bin | Single evaluation of the encoder signals A, B and C, i.e. each period of encoder signal A is counted.
 | 10bin | 2-fold evaluation of the encoder signals A, B and C, i.e. each edge of encoder signal A is counted.
 | 11bin | 4-fold evaluation of encoder signals A, B and C
14 - 12 |  | Reserved, do not use |
15 | 0bin | Encoder interface | 0
 | 1bin | Counter mode is active. 16 bit up/down counter Input A: counter Inputs B: Counting direction (5 V or open = up, 0 V = down Input C: latch


Functioning IP5209

The IP5209-Bxxx-0000 input module evaluates the 1 VSS sine-cosine signals and
the IP5209-Bxxx-1000 input module evaluates the 11 µASS sine-cosine signals rom an appropriate sensing switch or encoder. One signal period is represented in 10 bits, i.e. 1024 steps. Thus, for instance, a shaft encoder with 1024 signal periods yields approx. 2 million measured steps in each rotation. This corresponds to a resolution of 21 bits.

In comparison with a conventional shaft encoder with digital rectangular signals there is a significant reduction in the transmission frequency for the same resolution. In place of transmission rates in the MHz range, the shaft encoder reaches no more than 100 kHz at 6000 rpm.

The IP5209-Bxxx Fieldbus Box allows a maximum input frequency of 100 kHz.

The module occupies 9 bytes of input data and 9 bytes of output data in the process image. Alternatively the process image can be set to 5 byte. The Latch value will not be transmitted in this case.

Process data

The signal period resolution is 10 bit, i.e. 1024 steps. It is represented as a 32 bit value. Bits 31 - 10 count the periods, Bit 9 and 8 the zero crossings and Bit 7-0 the interpolation within the quarter periods.

Bit | 31 ... 10 | 9 | 8 | 7 | 6 | 6 | 4 | 3 | 2 | 1 | 0
Name | Period counter | Zero crossings |  | Resolution within the quarter period
Comment | 4.194.304 periods | 1024 steps within a period

The reference mark is represented in the latch words in the same way (see IP5209 Mapping).

Internal Functions

Resetting/setting the counter

The value of the counter is reset/set by setting the CNT_SET bit in the Control byte. The counter is set to the value of D0 - D3 of the output process image.

Save reference mark value (null latch)

Acquisition of the reference marks is activated, and the counter value that is valid when the reference marks (R+ and R-) are reached is written into the latch.

Status displays

Exceeding of the frequency limit is indicated in its status byte.


Control and Status Byte IP5209

Process data mode

Control byte

The control byte is transmitted from the controller to the Fieldbus Box. It is located in the output image, and be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | RS_FRQ_ERR | RS_CNT_LAT |  |  | CNT_SET |  | EN_LATC

Name | Description
RegAccess | 0bin: Register communication off (process data mode)
RS_FRQ_ERR | FRQ_ERR bit in the Status byte is set to zero (as long as the RS_FRQ_ERR is set, no frequency check is performed).
RS_CNT_LAT | If RS_CNT_LAT and EN_LATC are set, the counter will be set to zero by the rising edge of the Latch (C-input).
CNT_SET | The counter is set to the values of D0 - D3 by a rising edge at CNT_SET.
EN_LATC | The reference mark signal (zero point latch R+, R- input) is activated. The current value of the counter is entered into the latch register the first time the signal occurs after EN_LATC has become valid. The data is available in D4 - D7 in the process image.

Status byte

The status byte is transmitted from the Fieldbus Box to the controller. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | ERROR | NO_SIGNAL |  | FRQ_ERR | CNTSET_ACC |  | LATC_VAL

Name | Description
RegAccess | 0bin: Register communication off (process data mode)
ERROR | General error bit, set if NO_SIGNAL is set
NO_SIGNAL | This bit is set if no sine-cosine signal is present at the inputs (if the magnitude of the sine-cosine signal is < 0.3V)
FRQ_ERR | This bit is set when the frequency limit counter in R37 is exceeded. The FRQ_ERR bit can only be reset by the RS_FRQ_ERR bit in the Control byte.
CNTSET_ACC | The data for setting the counter is accepted from the Fieldbus Box.
LATC_VAL | A reference signal (zero point latch) has occurred. The data in D4 - D7 in the process image corresponds to the value that has been saved if this function is active (EN_LATC in the CONTROL byte). In order to latch the value again, EN_LATC must first be reset, this reset must then be acknowledged, and after this the bit must be set once more.

Register communication

Measured values cannot be transmitted during register communication.

Control byte

The control byte is located in the output image, and be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Register communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written.

Status byte

The status byte is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Register communication switched on
R/W | 0bin: Read
Register number | Number of the register that was read or written.


Feature-Register (R32) IP5209

The Feature-Register sets the operating mode of the module.
Default: 0x0000

Bit | Value | Description | Default
0 | 0bin | standard counting direction | 0bin
 | 1bin | reverse counting direction
1 | 0bin | 9-Byte process data interface | 0bin
 | 1bin | 5-Byte process data interface (without Latch-value)
2 | 0bin | IP5209-Bxxx-0000 (Version for 1 VSS) | according to module type*
 | 1bin | IP5209-Bxxx-1000 (Version for 11 µASS)
Attention *) Bit 2 is predefined to the particular module type (IP5209-Bxxx-0000 or IP5209-Bxxx-1000) und must not be changed!


Scaling-Register (R35) IP5209

The scaling register sets the scaling or interpolation of the module. It should be adjusted to the used measuring hardware.

By scaling, the counter value can optimally be adapted to the application. Therefore a calculating in the user program is not needed.

The value in R35 sets the number of bits that are represented in the quarter period (Default: 0x0008).

The following graph shows the sinusoidal signal.

With the default setting R35 = 0x0008 the counter value D3/D2/D1/D0 of the sine/cosine input device is represented in the following way:

Bit | 31 ... 10 | 9 | 8 | 7 | 6 | 6 | 4 | 3 | 2 | 1 | 0
Name | Number of signal periods | zero crossings |  | resolution within the quarter period
Comment | 4.194.304 periods | 1024 steps within one period

e.g. the counter value with a R35 = 0x0004:

Bit | 31 ... 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | Number of signal periods | zero crossings |  | resolution within the quarter period
Comment | 67,108,864 periods | 64 steps within one period
Calculation sample

Sine/Cosine-measuring device 2 µm signal period,

Default setting R35: 0x0008

Counter value set to zero in the released status of the input device (Control-Byte = 0x0004),

Input device pushed over the whole measuring scale.

Result:

Byte | D3 | D2 | D1 | D0
Value | 0x00 | 0x63 | 0x34 | 0x00

Calculation into a "real world" value:

value = input data x input_device_period / (4 x 2R35)

value = 0x633400 x 2 µm / (4 x 28)

value = 6,501,376 x 2 µm / (4 x 256) = 0.012698 m = 12.698 mm

The measured value corresponds to the data of the input device, that gives an overall measuring range of 12 mm.


Frequency _limit-Register (R36, R37) IP5209

BECKHOFF Fieldbus Box: Configuration

Frequency - limit - Register (R36, R37) IP5209

To control the linear or rotary velocity of a sine/cosine input device, the input frequency can be checked.

The check consists of a time frame, represented in R36, and a limit value in R37. Within this certain time, the zero crossings of the signal are counted. If they exceed the parameterized value of R37, an error bit in the Status byte is set!

R36: Frequency time frame

Default: [1600]

This time frame has a resolution of 0,0625µs/digit. The default setting is 1600dec, therefore 1600 x 0,0625 µs = 100 µs = 0,1 ms.

R37: Max limit of quarter periods

Default: [41]

This register is set to he maximum number of quarter periods per time frame, that the user will allow. If the counted number reaches the register value, FRQ_ERR in the Status byte is set! The reset of the error bit can only be done via the RS_FRQ_ERR in the Control byte. The internal maximum counting frequency of the sine/cosine module is 400 kHz. Due to the quadrature evaluation this results in a maximum input device frequency of 100 kHz.

f = R37 / ( R36 x 0,0625µs x 4 )

e.g. per default

f = 41 / ( 1.600 x 0,0625µs x 4 ) = 102,500 Hz, that means 40 quarter periods are still ok, f = 40/ (1600 x 0,0625µs x 4) = 100 KHz. If 41 quarter periods are counted, it is a frequency of 102.5 KHz and therefore to much!

Example 1

The result should be the maximum speed with that the input device rod can be actuated.

Input device with a signal period of 2µm.

max. velocity = max_input_frequency x signal_period

max. V = 100 kHz x 2 µm = 0,2 m/s = 200 mm/s

The maximum speed for this input device is 200 mm/sec. With the registers set at default, the module will generate an error if the sensor is driven at a higher speed.

Example 2

At what value should the registers be set for a given sensor with a signal period of 10 µm and a maximum speed of 50 mm/s?

f = max_input_frequency = max. velocity / signal_period

f = 50mm/s / 10µm = 5000 Hz = 5 KHz

e.g. R36 = 25600 (just to make a reasonable time frame that gives room for more than a few zero crossings)

R37 = f x R36 x 0,0625µs x 4

R37 = 5000 Hz x 25600 x 0,0625µs x 4 = 32

R37 has to be set to the next higher value 33, R36 has to be set to 25600. Both values depend on each other, if you change one, recalculate the other.


Register Overview IP5209

Register | Denomination | Default value | Read/Write | Memory medium
R0 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R7 | reserved | 0x0000 | R |
R8 | Module type | 5209dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0228 | R | ROM
R11 | Signal channels | 0x0148 | R | ROM
R12 | Minimum data length | 0x4848 | R | ROM
R13 | Data structure | 0x0006 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R |
R31 | Code word register | variable | R/W | RAM
R32 | Feature register | 0x0000 | R/W | SEEROM
R33 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R |


Functioning IP/IE60x2

The KL60x1 serial interface terminals and IP/IE60x2 modules permit a device with a serial interface (such as barcode scanners) to be connected. Data can be exchanged in half or full duplex operation with the controller, independently of the higher level bus system. The receive buffer has a size of 128 bytes, while the send buffer is 16 bytes. Data transfer between the terminal/module and the controller is organised through a handshake in the status and control bytes. The factory setting of the terminal/module is 9600 baud, 8 data bits, 1 stop bit and no parity.

Description | Input %IB... | Output %QB...
Handshake byte | Status | Control
Data byte 0 | D0 | D0
Data byte 1 | D1 | D1
Data byte 2 | D2 | D2
Data byte 3 | D3 | D3
Data byte 4 | D4 | D4

IP/IE6002 conceptual circuit diagram

IPIE6002.gif (9164 Byte)

IP/IE6012, IP/IE6022 conceptual circuit diagram

IPIE6012.jpg (102010 Byte)


Control and Status Byte IP/IE60x2

Process data mode

For setting up data exchange (handshake), the control and the status byte are used in process data exchange.

Control Byte

The control byte is transmitted from the controller to the mopdule. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | OL2 | OL1 | OL0 | - | IR | RA | TR

Name | Description
RegAccess | 0bin: register communication switched off (Process data mode: Control and status byte in handshake)
OL2-OL1 | Count of the data sent
IR | Handshake bit for initialisation of the Bus Terminal/module If IR is high the Bus Terminal/module performs initialisation. The send and receive functions are blocked, the FIFO pointers are reset and the interface is initialised with the values from the relevant registers (R32-R35, R18). The Bus Terminal/module acknowledges execution of the initialisation with IA.
RA | Handshake bit for receiving data The Bus Terminal/module notifies the controller via a change of state in RR that the data set defined in IL0-IL1 is located in D0-D4. The data shift is acknowledged in the control byte using RA; only then will new data be transmitted by the Bus Terminal/module to the controller.
TR | Handshake bit for sending data The handshake for data transmission is provided via this bit. A change of state in TR causes the data set defined via OL0-OL2 (5 bytes maximum) to be loaded into the transmission FIFO buffer. The Bus Terminal/module uses TA to signal execution of this command.

Status byte

The status byte is transmitted from the module to the controller. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | IL2 | IL1 | IL0 | BUF_F | IA | RR | TA

Name | Description
RegAccess | 0bin: acknowledge for Process data mode (Control and status byte in handshake)
IL2-IL0 | Count of the data received
BUF_F | Receive buffer full, any data now received will be lost
IA | Handshake bit for initialisation of the Bus Terminal/module If IR is high the Bus Terminal/module performs initialisation. The send and receive functions are blocked, the FIFO pointers are reset and the interface is initialised with the values from the relevant registers (R32-R35, R18). The Bus Terminal/module acknowledges execution of the initialisation with IA.
RR | Handshake bit for receiving data The Bus Terminal/module notifies the controller via a change of state in RR that the data set defined in IL0-IL1 is located in D0-D4. The data shift is acknowledged in the control byte using RA; only then will new data be transmitted by the Bus Terminal/module to the controller.
TA | Handshake bit for sending data The handshake for data transmission is provided via this bit. A change of state in TR causes the data set defined via OL0-OL2 (5 bytes maximum) to be loaded into the transmission FIFO buffer. The Bus Terminal/module uses TA to signal execution of this command.

Note: When the first data is received there is only one byte in the buffer, because the Bus Terminal/module does not yet know whether other data follows.

Examples

Example of data reception

Note: Evcen in case of the reception of more than 1 byte, there is always the indication for 1 byte in the beginning.

Output Control byte | Input Status byte | Description
0000_0000 | 0xxx_x00x | Start of data transmission
0xxx_000x | 0011_x01x | 3 bytes in the data bytes are ready to be fetched
0xxx_001x | 0011_x01x | Acknowledgement that the data bytes have been fetched
0xxx_001x | 0101_x00x | 5 bytes in the data bytes are ready to be fetched
0xxx_000x | 0101_x00x | Acknowledgement that the data bytes have been fetched

Example of sending data

Output Control byte | Input Status byte | Description
0000_0000 | 0xxx_x0x0 | Start of data transmission
0010_00x1 | 0xxx_x0x0 | 2 bytes in the data bytes are to be sent
0010_00x1 | 0xxx_x0x1 | 2 bytes of data have been loaded into the send FIFO, data is sent
0101_00x0 | 0xxx_x0x1 | 5 bytes in the data bytes are to be sent
0101_00x0 | 0xxx_x0x0 | 5 bytes of data have been loaded into the send FIFO, data is sent

Example of initialisation

Output Control byte | Input Status byte | Description
0xxx_xxxx | 0xxx_xxxx | Start of data transmission
0000_0100 | 0xxx_xxxx | Bus Terminal/module is to be initialised
0000_0100 | 0000_0100 | Bus Terminal/module has completed initialisation
0000_0000 | 0000_0100 | Place Bus Terminal/module once more into data exchange
0000_0000 | 0000_0000 | Bus Terminal/module is ready to operate

Error handling

If a parity, framing or overrun error occurs, the corresponding data is lost in transmission and will not be loaded into the reception FIFO buffer of the Bus Terminal/module.
If the buffer is full, incoming data will be ignored.
The appropriate diagnostic bits in register 6 are set in the event of an error.

Register Communication

Serial data cannot be transmitted during register communication.

Control byte

The control byte is only visible if the Fieldbus Box is operated in complete mode. It is located in the output image, and can be read or written.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Register communication switched on
R/W | 0bin: Read 1bin: Write
Register number | Number of the register that is to be read or written.

Status byte

The status byte is only visible if the Fieldbus Box is operating in complete mode. It is located in the input image, and can only be read.

Bit | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | RegAccess | R/W | Register number

Name | Description
RegAccess | 1bin: Acknowledgement for register access
R/W | 0bin: Read
Register number | Number of the register that was read or written.


Register Overview IP/IE60x2

Register | Denomination | Default value | Read/Write | Memory medium
R0 | Number of data bytes in the send buffer | variable | R | RAM
R1 | Number of data bytes in the receive buffer | variable | R | RAM
R2 | reserved | 0x0000 | R |
... | ... | ... | ... | ...
R5 | reserved | 0x0000 | R |
R6 | Diagnostic register | variable | R | RAM
R7 | reserved | 0x0000 | R |
R8 | Module type | 6002dec | R | ROM
R9 | Software version | 0xXXXX | R | ROM
R10 | Multiplex shift register | 0x0218 | R | ROM
R11 | Signal channels | 0x0230 | R | ROM
R12 | Minimum data length | 0x5050 | R | ROM
R13 | Data structure | 0x0000 | R | ROM
R14 | reserved | 0x0000 | R |
R15 | Alignment register | variable | R/W | RAM
R16 | Hardware version number | 0xXXXX | R/W | SEEROM
R17 | reserved | 0x0000 | R/W | SEEROM
R18 | Buffer size | 0x0080 | R/W | SEEROM
R19 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R30 | reserved | 0x0000 | R/W | SEEROM
R31 | Code word register | variable | R/W | RAM
R32 | Baud rate register | 0x0006 | R/W | SEEROM
R33 | Data frame register | 0x0003 | R/W | SEEROM
R34 | Feature register | 0x0000 | R/W | SEEROM
R35 | Data byte register | 0x0005 | R/W | SEEROM
R36 | reserved | 0x0000 | R/W | SEEROM
... | ... | ... | ... | ...
R63 | reserved | 0x0000 | R/W | SEEROM

R6: Diagnostic register

Bit no. | Value | Meaning
Bit 0 | 1 | The receive buffer has overflowed, incoming data is lost.
Bit 1 | 1 | A parity error has occurred
Bit 2 | 1 | A framing error has occurred
Bit 3 | 1 | An overrun has occurred
Bit 4 | 1 | Buffer is full
Bits 5-16 | - | reserved

R18: Buffer Size

Buffer size [0x0080]
Register R18 specifies the quantity of data in the receive FIFO above which the BUF_F bit in the status byte is to be set.
Low byte: If this value is reached, BUF_F is set in the status
High byte: reserved


Baud Rate Register (R32) IP/IE60x2

The desired transmission rate can be set in the baud rate register (default 9600 baud).

Bit | Value | Baud Rate | Default
0-3 | 0011bin | 1200 baud | 0110bin
 | 0100bin | 2400 baud
 | 0101bin | 4800 baud
 | 0110bin | 9600 baud
 | 0111bin | 19200 baud
 | 1000bin | 38400 baud (as from hardware status D.XX XX XX X1)
 | 1001bin | 56600 baud (as from hardware status D.XX XX XX X1)
 | 1010bin | 115000 baud (as from hardware status D.XX XX XX X1)
4 | - | reserved | 0bin
... | ... | ... | ...
15 | - | reserved | 0bin

The baud rate is set in accordance with the following equation:
Baud rate = 4 MHz/(16*(HB+1))
It is necessary for 0xFF to be written into the low byte here, while the high byte (HB) provides the operator.


Data Frame Register (R33) IP/IE60x2

The desired transmission frame can be set in the data frame register
Default: 0x0003.

Bit | Value | Data frame | default
0-2 | 001bin | 7 data bits, even parity | 011bin
 | 010bin | 7 data bits, odd parity
 | 011bin | 8 data bits, no parity
 | 100bin | 8 data bits, even parity
 | 101bin | 8 data bits, odd parity
3 | 0bin | 1 stop bit | 0bin
 | 1bin | 2 stop bits
4 | - | reserved | 0bin
... | ... | ... | 0bin
15 | - | reserved | 0bin


Feature Register (R34) IP/IE60x2

The feature register in the IP/IE6002 and IP/IE6012 specifies the module's operating mode.
Default: 0x0000

Bit | Value | Description | Default
0 | - | reserved | 0bin
1 | - | reserved | 0bin
2 | 0bin | not active | 0bin
 | 1bin | active: The module writes the status byte into the IP-Link shift register one cycle later than the higher value data bytes. This reduces the rate of data transmission to the controller.
3 | 0bin | not active | 0bin
 | 1bin | active: The XON/XOFF protocol is supported by the module for sending data. In other words, the module sends the data received from the controller until the XOFF character (DC3==0x13) is received from the communication partner. Once this has occurred, transmission is halted until the XON character (DC1==0x11) is received.
4 | 0bin | not active | 0bin
 | 1bin | active: The XON/XOFF protocol is supported by the module for data reception. The module sends the XOFF control character when 118 characters are available in the Bus Terminal/module's buffer. XON is sent if XOFF has previously been sent, and if the buffer limit falls below 18 bytes.
5 | - | reserved | 0bin
6 | 0bin | not active | 0bin
 | 1bin | active: Continuous transmission of data out of the FIFO. The send buffer is filled (up to 16 bytes) through the controller. A rising edge in control_byte.3 leads to the contents of the filled buffer being transmitted. When the data has been transmitted, the module acknowledges this to the controller by setting the status_byte.2 bit. Status_byte.2 is cleared in response to control_byte.3.
7 | - | reserved | 0bin
... | ... | ... | ...
15 | - | reserved | 0bin

The feature register in the IP/IE6002 specifies the module's operating mode.

Bit | Value | Description | Default
0 | 0bin | Half duplex: reception of the transmitted data is suppressed. | 0bin
 | 1bin | Full duplex: data transmitted in RS485 mode is also listened to
1 | - | reserved | 0bin
2 | 0bin | not active | 0bin
 | 1bin | active: The module writes the status byte into the IP-Link shift register one cycle later than the higher value data bytes. This reduces the rate of data transmission to the controller.
3 | 0bin | not active | 0bin
 | 1bin | active: The XON/XOFF protocol is supported by the module for sending data. In other words, the module sends the data received from the controller until the XOFF character (DC3==0x13) is received from the communication partner. Once this has occurred, transmission is halted until the XON character (DC1==0x11) is received.
4 | 0bin | not active | 0bin
 | 1bin | active: The XON/XOFF protocol is supported by the module for data reception. The module sends the XOFF control character when 118 characters are available in the module's buffer. XON is sent if XOFF has previously been sent, and if the buffer limit falls below 18 bytes.
5 | 0bin | The module is used in a bus structure in accordance with the RS485 standard. | 0bin
 | 1bin | The module is used for point to point connections (RS 422). The module does not present a high impedance to the data line.
6 | 0bin | not active | 0bin
 | 1bin | active: Continuous transmission of data out of the FIFO. The send buffer is filled (up to 16 bytes) through the controller. A rising edge in control_byte.3 leads to the contents of the filled buffer being transmitted. When the data has been transmitted, the module acknowledges this to the controller by setting the status_byte.2 bit. Status_byte.2 is cleared in response to control_byte.3.
7-15 | - | reserved | 0bin


Data Byte Register (R35) IP/IE60x2

Specifies the number of data bytes that are transferred between the controller and the Bus Couplers/Fieldbus Box.

Bit | Value | Description | Default
0-7 | 1hex | 1 bytes | 5hex
 | 2hex | 2 bytes
 | 3hex | 3 bytes
 | 4hex | 4 bytes
 | 5hex | 5 bytes
8 | - | reserved | 0bin
... | ... | ... | ...
15 | - | reserved | 0bin


Signal behavior at Bus Error

IP-Link Error

On IP-Link error

  • the digital Extension Box Modules set their outputs to zero.
  • the analog Extension Box Modules set their outputs to zero or to the user start-up value, if this is parameterized.

Fieldbus Error

On failure of the superior fieldbus, the outputs of the Extension Box Modules behave in the same way like the Coupler Box they are connected to.

The behavior of Coupler Box and Compact Box Modules is fieldbus specific (see Fieldbus Box documentation for the superior fieldbus) and depends on the parameterizing.


Diagnostic LEDs

Error Diagnosis

There are 2 kinds of error:

  • Fieldbus error
  • Local errors in a Compact Box or Coupler Box

Blink Codes

Blinking sequence | Meaning
Fast blinking | Start of the error code
First slow sequence | Error code
Second slow sequence | Error argument
Third slow sequence (optional) | Error argument if more than 20 extensions

Flasching_codes.jpg (2840 Byte)

Start of the error code Error code Error argument


Diagnostic LEDs for local errors

Local error in a Coupler Box (IL230x-Bxxx/Cxxx)

The term local error means that an error has occurred in the Fieldbus Box or the IP-Link. IP-Link errors most often turn out to be a result of inappropriate use of the optical fiber.

LED green | LED red |  |  | Description | Remedy
off | off |  |  | No data exchange | Module in synchronous mode or - activate PROFIBUS cyclic data
off | 1 | 0 |  | EEPROM checksum error | Set manufacturer’s setting with the KS2000 software
off | 2 |  |  | Reserved | -
off | 3 |  |  | Break location has been recognized | interruption before the master's receiver
 | 3 | n |  | Break location has been recognized | n-th module before the master's receiver
 | 3 | n | m | Break location has been recognized | (n*10)+m-th module before the master's receiver
off | 4 | n |  | Too many faulty telegrams have been detected (more than 25%) | The optical fiber wiring in front of the nth extension module should be checked
off | 5 | n |  | Register access to complex modules has failed | Check the nth module
off | 11 | n |  | Complex module working incorrectly | Exchange the nth module
off | 12 | n |  | More than 120 modules in the ring | Connect fewer modules
off | 13 | n |  | nth module unknown | Firmware update required
on | off |  |  | Module is exchanging data | no error
Note At an interruption of the last IP-Link connection in front of the Coupler Box it is possible that instead the real error argument 0 a 1 is reported because of the receiver circuit a clear identification is not possible. If minimum one module before is right at minimum one readable telegram is received.

Local errors in an Extension Box

LED green | LED red | Description
off | on | No data is being received over the IP-Link
off | blinks, flickers | Faulty IP-Link protocols are being received (very poor data connection)
blinks, flickers | blinks, flickers | Faulty IP-Link protocols are being received (poor data connection), does not necessarily lead to an error
on | off | IP-Link protocols are being received, no error

Faulty protocols can occur, because of:

  • bad configured IP-Link connectors
  • IP-Link cable with higher dampening, e.g. because of a sharp curve
  • contaminated sender LED (module before the faulty one)
  • contaminated receiver

The internal IP-Link error counter of the Coupler Box can be read with the KS2000 software.


Fieldbus Box accessories

The necessary accessories for the Fieldbus Box Modules are also available from Beckhoff in protection class IP67. You may get an overview from the Beckhoff catalog or from our internet pages (http://www.beckhoff.com).

Fieldbus Accessories

  • Pre-assembled cable
  • Plug
  • Distributor

Power supply

  • Pre-assembled cable
  • Plug
  • Distributor

Sensor power supply

  • Pre-assembled cable
  • Plug
  • Distributor

IP-Link

  • Pre-assembled cable
  • Plug


Fieldbus Box - Accessories

BECKHOFF Feldnus Box: Product overview

Accessories

Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | Torque socket wrench with ratchet wrench for M8 connectors (over molded)
ZB8800-0001 | ratchet wrench for M8 connectors (field assembly)
ZB8800-0002 | ratchet wrench for M12 connectors (over molded)
Note
Further accessories

Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under www.beckhoff.com.


Power cables

Ordering data

Order designation | Power lead | Screw-in connector | Contacts | Cross- section | Length
ZK2020-3200-0020 | Straight socket, open end | M8 | 4-pin | 0.34 mm2 | 2.00 m
ZK2020-3200-0050 |  |  |  |  | 5.00 m
ZK2020-3200-0100 |  |  |  |  | 10.00 m
ZK2020-3400-0020 | Angled socket, open end |  |  |  | 2.00 m
ZK2020-3400-0050 |  |  |  |  | 5.00 m
ZK2020-3400-0100 |  |  |  |  | 10.00 m
ZK2020-3132-0001 | Straight socket, straight socket |  |  |  | 0.15 m
ZK2020-3132-0005 |  |  |  |  | 0.50 m
ZK2020-3132-0010 |  |  |  |  | 1.00 m
ZK2020-3132-0020 |  |  |  |  | 2.00 m
ZK2020-3132-0050 |  |  |  |  | 5.00 m
ZK2020-3334-0001 | Angled socket, angled socket |  |  |  | 0.15 m
ZK2020-3334-0005 |  |  |  |  | 0.50 m
ZK2020-3334-0010 |  |  |  |  | 1.00 m
ZK2020-3334-0020 |  |  |  |  | 2.00 m
ZK2020-3334-0050 |  |  |  |  | 5.00 m

Further available power cables may be found in the Beckhoff catalog or on our internet pages (http://www.beckhoff.com).

Technical data

Technical data
Rated voltage according to IEC60 664-1 | 60 VAC / 75 VDC
Contamination level according to IEC 60 664-1 | 3/2
Insulation resistance IEC 60 512-2 | >109 W
Current carrying capacity according to IEC 60512-3 | 4 A
Volume resistance according to IEC 60512-2 | < 5 mW
Protection class according to IEC 60529 | IP65/66/67, when screwed together
Ambient temperature | -30°C to +80°C


Third-party Products

Apart from Beckhoff, other manufacturers (third party) also offer products that are compatible with the IP-Ling of the Fieldbus Box system.

Beckhoff does not sell these products. Please contact the respective manufacturer.

Valve terminals

FESTO

CPV10-IL-IP8 and CPV14-IL-IP8 from FESTO are compact valve terminals with direct interface to the IP-Link.

In TwinCAT, these modules are represented as IE4404-0010 or IE4404-0014.

Further information can be found on the internet at http://www.festo.com.

SMC

The EX250 from SMC is a modular valve terminal with direct interface to the IP-Link.

In TwinCAT, this module is represented as IE4414.

Further information can be found on the internet at http://www.smceu.com.


General operating conditions

Protection degrees (IP-Code)

The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.

1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.

*) These protection classes define only protection against water!

Chemical Resistance

The Resistance relates to the Housing of the Fieldbus Box and the used metal parts.

Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key

resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


Approvals

UL E172151

Conformity mark

CE

Type of protection

IP65/66/67 in accordance with EN60529


Fieldbus Box - UL Requirements

BECKHOFF Fieldbus Box: Mounting and cabling

UL Requirements

The installation of the Fieldbus Box Modules certified by UL has to meet the following requirements.

Supply voltage

Warning For the compliance of the UL requirements the Fieldbus Box Modules should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
  • by a 24 VDC power source, that has to satisfy NEC class 2.
    A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
This UL requirements are valid for all supply voltages of all marked Fieldbus Box Modules!
Warning To meet the UL requirements, the Fieldbus Box Modules must not be connected to unlimited power sources!

Networks

Warning To meet the UL requirements, Fieldbus Box Modules must not be connected to telecommunication networks!

Ambient temperature range

Warning To meet the UL requirements, Fieldbus Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!

Marking for UL

All Fieldbus Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.


Test standards for device testing

EMC

Resistance: EN 61000-6-2

Emission: EN 61000-6-4

Resistance to Vibration

EN 60068-2-2 Vibration test, Amplitude 2 g (Standard 1 g)

EN 60068-2-27 Shock Test, Shock count 1000 (Standard 2)


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com


Output current (derating), IP/IE2512

When using the PWM modules with hardware revision D.xxxxxx00, the power loss in the modules has to be taken in account.

The power loss consists of 3 different components and can be 1W max. (P = PI + Pf + PL).

  1. current dependent power loss
    PI = Imax2 x 0,15 Ohm
  2. frequency dependent power loss
    Pf = U x Imax x 10-6sec x f
  3. inductive feed back
    PL = Imax2 x L / (2 x f)

Key
Imax: max output current (duty cycle has to be calculated into it)
U: output voltage
f: frequency
L: inductivity

The inductive component is released via a 39 V internal diode. By an external Schottky diode with the right power loss range and min. 45V, the energy can be released externally. The cathode of the diode has to be connected to Pin 4, the anode to pin 3.

The two diagrams show the possible frequency / output current ratios for different duty cycles.

Derating without inductive components

Derating with 1mH inductive load