FC200x – PCI cards for Lightbus
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Product overview

Product overview
Product overview
Additional information
•
Lightbus System Description
•
Hardware
•
Technical data


Lightbus System Description

Product overview [image] Lightbus System Description
Lightbus System Description
Note
System description for FC200x / EL6720
The following system description is applicable both for the Beckhoff Lightbus PCI interface card FC200x and for the Lightbus master terminal EL6720.
The Lightbus consists of the Lightbus PCI interface card (in short Lightbus card) and an optical fiber-based fieldbus.
Lightbus LWL-Ring
The coupling of the Lightbus with the PC is realized on the Lightbus card via a Dual Ported RAM (DPRAM).
Various I/O modules (Bus Coupler, Bus Terminals, Fieldbus Boxes etc.) are available for input and output of the process images, which are connected through the Lightbus in a ring structure. The use of optical fibers results in low susceptibility to interference and a high transfer rate of 2.5 MBaud. Any errors occurring in the optical fiber ring are detected by the Lightbus card and reported to the PC. TwinCAT provides comprehensive diagnostic functions that support fast detection and correction of any errors.
A communication protocol that is optimized for speed and simplicity is specified for the data transfer between the Lightbus card and the I/O modules. The Lightbus card controls the communication on the optical fiber ring. It sends telegrams that pass through the I/O modules in the optical fiber ring and are then received and checked back at the Lightbus card.
A telegram consists of a telegram frame and the telegram content.
Lightbus telegram structure
The telegram frame is required for serial data communication and consists of 1 start bit, 6 CRC check bits and 2 stop bits. It is generated and checked independently by the hardware of the Lightbus card. No software support is required.
The telegram content is essentially organized byte-wise. AD0 to AD7 form the address field, through which up to 254 I/O modules can be addressed (the addresses 0x00 and 0x0FF are reserved). The bits CR0 to CR3 specify the telegram type. The following functions can be specified in the telegram:
Functions
CR3 | CR2 | CR1 | CR0 | Function | Description
0 | 0 | 0 | 0 | Read | The addressed module inserts the input information into data fields D0 to D3.
0 | 0 | 0 | 1 | Read and write | The addressed module inserts the input information into data fields D0 to D3 and receives the output information.
0 | 0 | 1 | 0 | Address initialization | The addressed module receives the content of D0 as the module address and sets D0 to 0.
0 | 0 | 1 | 1 | RAM | Special telegram type for the BK2000 Bus Coupler.
0 | 1 | 0 | 0 | Address check and count | Each passing module increases the content of D0 by 1. The addressed module moves the content of D0 to D3.
1 | 0 | 0 | 1 | Low intensity | The addressed module reduces the transmission intensity by 20%.
1 | 0 | 1 | 1 | Broadcast | Special telegram type for the BK2000 Bus Coupler.
The bytes D0 to D3 contain the actual user data. The control field specifies the processing of these user data. The last byte in the telegram contains 6 bits for forming a CRC checksum and 2 reserved bits. A user data length of 50 bits thus achieves a hamming distance of d=3.
The Lightbus consists of a physical ring, which can be split into up to 8 logical rings for processing the process image. A logical ring only operates for selected I/O modules, which are specified via communication description lists (CDLs).
The Lightbus card makes the process image available to the PC via the DPRAM. The DPRAM is divided into three areas:
▪
Data:
Input, output and flags
▪
Communication:
Initialization, testing, analysis and configuration of the Beckhoff Lightbus
▪
Process control:
Updating the Process Image
The DPRAM of the Lightbus cards requires 4 kB per channel in the address space of the PC.


Hardware

Product overview [image] Hardware
Hardware
As a Lightbus PCI interface card (in short Lightbus card), the FC200x realizes the connection of the Lightbus to the PC, and therefore provides access for TwinCAT to the sensors and actuators in the automation process. The FC2002 Lightbus card can operate two optical fiber rings. In logical terms, it behaves like two FC2001 cards, i.e. the FC2002 contains two sets of components for the optical fiber ring.
Lightbus card components
Lightbus card components
1. PCI bus interface
11. Lightbus output for connecting the outgoing optical fiber for optical fiber ring A
12. Lightbus input for connecting the return optical fiber for optical fiber ring A
13. Three LEDs for status display for optical fiber ring A
14. Lightbus-LCA for optical fiber ring A
15. 4 KB DP-RAM for optical fiber ring A
16. 512 KB RAM (4 x 128 KB) for optical fiber ring A
17. 256 KB Flash for optical fiber ring A
21. Lightbus output for connecting the outgoing optical fiber for optical fiber ring B
22. Lightbus input for connecting the return optical fiber for optical fiber ring B
23. Three LEDs for status display for optical fiber ring B
24. Lightbus-LCA for optical fiber ring B
25. 4 KB DP-RAM for optical fiber ring B
26. 512 KB RAM (4 x 128 KB) for optical fiber ring B
27. 256 KB Flash for optical fiber ring B
The hatched components for optical fiber ring B are not populated on the FC2001.
Status display
Each Lightbus channel has 3 status LEDs.
Status displays
1.
Optical Err (Lightbus error):
–
If a defect in the optical fiber ring occurs during operation, the red LWL Err LED is activated.
–
If the optical fiber error is of a general nature, the LWL Err LED flashes.
–
If the error has occurred during the resident address test, the LWL Err LED is on continuously.
The update of the process image is interrupted.
The diagnostic functions can be used to determine the cause of the error.
2.
CPU Err (CPU error):
–
If only the red CPU Err LED is on, this indicates a hardware error that cannot be corrected.
–
If the Run LED is also on, a program error is present that may potentially be rectified through a hardware reset.
3.
Run:
–
If only the green Run LED is on, the FC200x was initialized without errors and is ready for operation.


Technical data

Product overview [image] Technical data
Technical data
Technical data | FC2001 | FC2002
Fieldbus | Lightbus (optical fiber)
Data transfer rate | 2.5 Mbit/s (32-bit user information in 25 µs)
Number of Lightbus channels | 1 | 2
Communication | 8 priority-controlled logical communications channels for each Lightbus channel
Bus devices | a maximum of 255 bus devices with a maximum of 65280 I/O points per Lightbus channel
Hardware diagnostics | 1 status LED and 2 diagnostic LEDs (Run, CPU Err, LWL Err) per Lightbus channel
Interface to the PC | 32-bit Plug & Play PCI interface
Address space | 4 kB of DPRAM for 8 communication channels, data, control and status register for each Lightbus channel
Interrupts | Triggering of 2 IRQs is possible
Supply voltage (PCI bus) | 5 V
Current consumption (PCI bus) | typically 385 mA | typically 700 mA
Permissible ambient temperature during operation | 0°C ... +55°C
Dimensions | approx. 106 mm x 187 mm


Installation

Installation
Installation
Additional information
•
Installation in the PC
•
Installation of the PCI driver


Installation in the PC

Installation [image] Installation in the PC
Installation in the PC
Attention
Risk of damage to the device!
The Lightbus cards are supplied in ESD packaging. Follow the usual ESD guidelines for handling PC cards during installation!
1.
Before installing the Lightbus card, switch off the PC and any external power supplies, and separate the PC from the mains.
2.
Open the PC case.
3.
Remove the protective caps of the optical fiber connections of the Lightbus card.
4.
For a free PCI slot on the motherboard, remove the metal plate in the PC case.
5.
Insert the Lightbus card into the free PCI slot and fix it with the screw or device provided.
Ensure that there is sufficient space between the Lightbus card and other PC components, so that the Lightbus card cannot come into contact with other plug-in cards or memory components etc.
6.
Close the PC case.
7.
Connect the cables of the optical fiber ring with the optical fiber connections of the Lightbus card:
–
OUT: outgoing Lightbus
–
IN: returning Lightbus
8.
Connect the PC to the mains and switch it on.
9.
After the PC has booted up, under Windows 2000 and Windows XP the Add Hardware Wizard will install a PCI driver, in order to integrate the Lightbus card into the plug and play interface of the operating system. Under Windows NT 4.0, this driver is not required.
The Lightbus card does not require an external power supply. It is supplied directly from the PC via the PCI bus. The power supply of the PC has to be adequate for meeting the power requirement of the Lightbus cards, particularly if several Lightbus cards are installed.


Installation of the PCI driver

Installation [image] Installation of the PCI driver
Installation of the PCI driver
After installation of the Beckhoff Lightbus card, Windows 2000, for example, comes up with the following message during start-up:
Installation of the PCI driver – new hardware found
The PCI driver for the Lightbus card is supplied with the Beckhoff TwinCAT automation software.
Follow the instructions of the Add Hardware Wizard.
Under Windows XP, the PCI driver is installed in the same way.
Under Windows NT 4.0, the PCI driver is not required.
Example for the resources of an FC200x under Windows2000.
(Control Panel / System / Hardware / Device Manager / TwinCAT PNP drivers / TwinCAT FC2002x PCI driver / Resources):
Installation of the PCI driver – resource settings


Configuration by means of the TwinCAT System Manager

Configuration by means of the TwinCAT System Manager
Configuration by means of the TwinCAT System Manager
Additional information
•
Scanning for the I/O devices
•
FC200x tab
•
DPRAM (online) tab
•
Appending further components


Scanning for the I/O devices

Configuration by means of the TwinCAT System Manager [image] Scanning for the I/O devices
Scanning for the I/O devices
1.
Start the TwinCAT System Manager.
2.
Using the right mouse button, start searching for new devices under the branch I/O Configuration \ I/O devices.
Configuration using the System Manager – scanning for devices
Example: The two Lightbus channels of a FC2002 are displayed as device 1 and device 2.
Configuration using the System Manager – new I/O devices found
I/O devices may be renamed via a slow double-click (e.g. renaming to FC2002 Lightbus A).
Configuration using the System Manager – renaming the I/O devices


FC200x tab

Configuration by means of the TwinCAT System Manager [image] FC200x tab
FC200x tab
Further properties of the I/O devices can be found under their respective entries. Use the mouse to select a Lightbus channel (in the example FC 2002 Lightbus A) and click on the FC200x tab.
TwinCAT System Manager – FC200x tab
PCI bus slot (base address) and optical fiber ring
Logical number of the PCI bus slot (or base address in the memory area) allocated to the Lightbus card in the PC.
For Lightbus card FC2002, the optical fiber ring (-A or -B) used by this device entry is appended to the number of the PCI bus slot.
Search
Searches the computer for existing Lightbus cards and sets the logical number of the PCI bus slot or the address accordingly.
PCI Cfg
In the delivery state, the base address of the Lightbus card is in the range above 1 MB (32-bit address). The PCI configuration dialog can be used to place the base address of the Lightbus card in the range below 1 MB (DOS address). Only use this option if absolutely required by your PC.
Check number of boxes
If this option is selected, during card initialization the number of boxes that are physically present (Bus Couplers, modules) is compared with the number that was entered under this card in the System Manager. If the numbers do not match, an error message is generated.
System Start Despite Optical Fiber Error:
If this option is selected, system start-up is not aborted if a Lightbus error occurs during TwinCAT start-up. Instead, a warning is issued.
K-bus update with broadcast telegram (0xB0)
If this option is selected, the K-bus update via broadcast telegram is carried out simultaneously for all Bus Couplers, instead individually for each Bus Coupler.
Reserved CDLs
Each fieldbus channel has eight priority channels (CDLs), which can also freely be used by the TwinCAT System Manager. If individual CDLs are to be reserved for special applications, they should be marked here. They are then no longer available for the TwinCAT System Manager.
Firmware
Indicates the firmware version of the Lightbus card. For older Lightbus cards (e.g. C1220) only Found is displayed.


DPRAM (online) tab

Configuration by means of the TwinCAT System Manager [image] DPRAM (online) tab
DPRAM (online) tab
If TwinCAT is active, direct read access to the DPRAM of the fieldbus cards is provided for diagnostic purposes.
TwinCAT System Manager – DPRAM (Online) tab


Appending further components

Configuration by means of the TwinCAT System Manager [image] Appending further components
Appending further components
Further components can be added via the right mouse button.
Appending I/O modules
Right-click on the I/O device (FC2002 Lightbus A in the example) to which you would like to add I/O modules and select the menu item Append Box.
TwinCAT System Manager – appending further components
The TwinCAT System Manager now offers various I/O modules for selection.
TwinCAT System Manager – appending a Bus Coupler
In the example, the BK2000 Bus Coupler is selected and inserted as Box 1.
TwinCAT System Manager – BK2000 appended
In the configuration tree of the example, the BK2000 Bus Coupler appears as Box 1, with inputs and outputs and a KL9110 end terminal. The desired Bus Terminals can now be added via the menu item Append terminal after right-clicking on Box 1.
All I/O modules of the Lightbus configuration should be added consecutively to the configuration tree in this way. The resulting order has to match the physical order of the I/O modules in the optical fiber ring!
Please refer to the Beckhoff Information System for details of how to link the inserted I/O modules with the process image of the Lightbus card.


Diagnostics

Diagnostics
Diagnostics
Additional information
•
Diagnostics via the System Manager
•
Status and diagnostic inputs
•
Diagnostics with function blocks


Diagnostics via the System Manager

Diagnostics [image] Diagnostics via the System Manager
Diagnostics via the System Manager
The TwinCAT System Manager provides various test and analysis functions.
Online Reset
Initiates a reset of the Lightbus card.
The controller, the DPRAM and the optical fiber ring are re-initialized. The Lightbus card determines the number of modules in the ring, allocates the module addresses, tests them and checks the attenuation reserve of the optical fiber ring. Any broken lines are also detected and located.
TwinCAT System Manager – online reset
Optical fiber break test
Initiates a break test on the optical fiber ring.
Break test
The test returns the number of I/O modules (boxes) found in the ring
or, in the event of an error, the location of the break point.


Status and diagnostic inputs

Diagnostics [image] Status and diagnostic inputs
Status and diagnostic inputs
The process image of the FC200x contains status registers and error counters, which are displayed in the TwinCAT System Manager.
TwinCAT System Manager – status and diagnostic inputs
Status register
The FC200x has input words for each optical fiber ring that describe the state of the Lightbus card and the optical fiber ring:
DeviceState
General status: contains the value 1 in the event of an error, otherwise the value 0 (device OK).
DeviceIioFunc
In the event of an error this contains the code of the function that has triggered the error, e.g.:
0x01 Optical fiber reset
0x02 Code word request
0x05 Optical fiber attenuation test (intensity check)
0x06 Count I/O modules (counting boxes)
0x07 Test I/O module addresses (address check)
0x09 Software reset
0x0A Optical fiber break test
0x0C Re-initialization of the CDL (CDL ReInit)
0x10 Configuration of the CDL (CDL Config)
DeviceIioFuncArg
In the event of an error this contains the code of the argument that was appended to the function that triggered the error.
BoxWithError
Contains the number of the I/O module (box) in the optical fiber ring at which the error occurred.
Error counter
For each optical fiber ring, the FC200x includes input words for error counters. The Lightbus card does not deal with overflow processing or resetting of the counters!
CdlErrorCount
Error in the CDL (DPRAM offset: 0xE30):
CdlErrorCount [0] .. [7] counts errors in each individual logical ring (CDL).
CdlErrorBit
The bit is set if CDL has an error (DPRAM offset: 0xE40):
this bit is cleared again if the CDL is successfully transmitted.
ErrorCounter
Sum error (DPRAM offset: 0xEE0):
Register for the sum of all error counters with the exception of AddressCheckErrCnt
ErrCntRec1
Counter for errors in receiver 1 (DPRAM offset: 0xEE2):
Received address or control byte not equal transmitted byte.
ErrCntRec2
Counter for errors in receiver 2 (DPRAM offset: 0xEE4):
Received address or control byte not equal transmitted byte.
ErrCntTimeout
Counter for timeout errors (DPRAM offset: 0xEE6):
Timeout during telegram reception
ErrCntParity
Counter for parity errors (DPRAM offset: 0xEE8):
Telegram with CRC error received
AddressCheckErrCnt
Counter for errors during internal address check (DPRAM offset: 0xEEA):
Telegram with logically incorrect content (AD not equal D3) received. This counter does not increment the checksum error!
AddressCheckModule
Module address for errors during internal address check (DPRAM offset: 0xEEC):
Contains the address of the I/O module (box) that caused the error.


Diagnostics with function blocks

Diagnostics [image] Diagnostics with function blocks
Diagnostics with function blocks
The TwinCAT automation software from Beckhoff provides various function blocks (FBs) for diagnostic purposes.
Lightbus-specific function blocks
Function block | Description
IOF_LB_BreakLocationTest | Carries out a break point test in the Lightbus optical fiber ring, in order to locate any break points.
IOF_LB_ParityCheck | Reads the parity error counter of the Lightbus modules (e.g. BK2000).
IOF_LB_ParityCheckWithReset | Reads the parity error counter of the Lightbus modules (e.g. BK2000) and resets the error counters.
General function blocks
Function block | Description
IOF_GetBoxCount | Counts the number of I/O boxes (box = slave, module, station) of an I/O device (e.g. a fieldbus card).
IOF_GetBoxAddrByName | Determines the physical box number in the optical fiber ring through the box identifier and the device ID (no. of the fieldbus card).
IOF_GetBoxNameByAddr | Determines the box identifier via the physical box number in the optical fiber ring and the device ID (no. of the fieldbus card).
The function blocks IOF_LB_BreakLocationTest and IOF_GetBoxCount are described as examples below. Detailed documentation about these and further function blocks can be found in the Beckhoff Information System, which is supplied with the TwinCAT automation software and is also included on the Products & Solutions CD from Beckhoff.
IOF_LB_BreakLocationTest
Function block IOF_LB_BreakLocationTest
The function block IOF_LB_BreakLocationTest carries out a break point test in the Lightbus optical fiber ring in order to locate any break points. If no break location is detected during the test, the output variable BOXNO returns the current number of Lightbus modules in the ring. If a break location is detected before the nth module in front of the receiver input, the BREAK flag is set and the module number is provided via the output variable BOXNO. If the BOXNO variable returns a value of 0xFF the break location is situated immediately in front of the receiver input, and can not be located.
Input variables
NETID | This can be used to transfer the AmsNetId of the computer on which the FB is to be executed. If an empty string is transferred, the FB is executed on the local computer.
DEVICEID | This device ID specifies the device (e.g. the fieldbus card) on which the function is to be executed. The device IDs are specified by the TwinCAT System Manager during hardware configuration.
START | A rising edge at the START input activates the FB.
TMOUT | Used to specify the length of the timeout that may not be exceeded during execution of the ADS command.
Output variables
BUSY | When activated, the FB sets the output BUSY. The output remains set as long as the FB is active.
ERR | If an ADS error occurs during the transfer of the command, the function block resets the BUSY output and sets the ERR output.
ERRID | In the event of an error, the ERRID output returns the ADS error number.
BREAK | This flag is set if a break location is detected in the optical fiber ring.
BOXNO | The module number before the receiver input in front of which the break location has been detected.
Further information for the use of this function block can be found in the Beckhoff Information System.
IOF_GetBoxCount
The function block IOF_GetBoxCount can be used to determine the number of configured and active I/O boxes (modules) of an I/O device (fieldbus card).
Function block IOF_GetBox_Count
Input variables
NETID | This can be used to transfer the AmsNetId of the computer on which the FB is to be executed. If an empty string is transferred, the FB is executed on the local computer.
DEVICEID | This device ID specifies the device (e.g. the fieldbus card) on which the function is to be executed. The device Ids are specified by the TwinCAT System Manager during the hardware configuration.
START | A rising edge at the START input activates the FB.
TMOUT | Used to specify the length of the timeout that may not be exceeded during execution of the ADS command.
Output variables
BUSY | When activated, the FB sets the output BUSY. The output remains set as long as the FB is active.
ERR | If an ADS error occurs during the transfer of the command, the function block resets the BUSY output and sets the ERR output.
ERRID | In the event of an error, the ERRID output returns the ADS error number.
BOXCOUNT | After successful execution of the function block, the output BOXCOUNT returns the number of I/O modules (boxes) found.
Further information for the use of this function block can be found in the Beckhoff Information System.


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com