Infrastructure for EtherCAT/Ethernet
Home


Summary

Summary
Summary
The market is growing for Ethernet as a physical medium for the transport of real time fieldbus protocols in the industrial environment. Unfortunately, knowledge of this technology is not growing at the same rate as the enthusiasm for it, even among EtherCAT users. So that basic network principles from the office area are not applied unreflected to industrial concerns, it is necessary to sensitize planners and users to the technological aspects.
As a real-time protocol, EtherCAT relies on Ethernet as a physical carrier, and is thus dependent on the long-term stable operation of the Ethernet connection.
As with other fast transmission systems, disruptive effects can also occur with the high frequency Ethernet technology in operation or during commissioning if it is used inappropriately. These disruptions are simple to locate or avoid completely if a few basic principles are followed.
This documentation is intended to provide users with a guideline, without any obligatory character or legally binding effect, to enable them to plan, install and check reproducibly reliable Ethernet cabling in the industrial environment.
This document makes no claim to be complete and, in particular, does not replace normative installation directives such as IEC 61784, fundamental communication directives such as IEC11801/EN50173 or specific installation directives. This document is mainly intended for the European market. Therefore, reference is mainly made to European EN standards. The globally important ISO/IEC (International Electrotechnical Commission, www.iec.ch) standards are often identical in content to corresponding EN standards.
Based on the following chapters, the fundamental information can be summarized as follows:
▪
An Ethernet transmission link (channel) is characterized by a (technically related) capability to reliably guarantee a defined data throughput [Mbit/s] under all defined operating conditions and, hence, high service quality.
▪
These performance classes are defined for Europe in the EN50173-1 standard, e.g. ‘Class D’. If a transmission link verifiably corresponds to a performance class, then it conforms to EN50173. A component manufacturer (cable, connector) can certify its products according to the limit values from EN50173 et al. The exclusive use of components certified to EN50173 may be sufficient to ensure the conformity of the transmission link; in individual cases it must be verified by means of suitable measuring methods according to EN50346.
▪
A transmission link for the transmission of Ethernet telegrams can be implemented according to the requirements of these application-independent standards; however, it does not have to be, in which case it is application-specific cabling. Experience has shown that cabling that lies far outside the normative specification also (sometimes) works.
▪
It is recommended that agreement be reached between suppliers and users on the properties and acceptance procedures with regard to the Ethernet cabling used.
▪
Borderline Ethernet cabling can work reliably under acceptance conditions, but fail under operating conditions (aging, EMC, temperature, movement/impact).
▪
Distinction must be made between Ethernet components certified according to
- European standard series: EN50173 (similar to IEC11801)
- US standard series EIA/TIA 568
The two standards differ slightly and also still use the same terms, such as “Cat 5” or “Class D”. But: components certified according to TIA568 may not be used in cabling installed according to EN50173. In most cases no complications arise, but the cabling or the entire installation section is no longer compliant with the EN standard [EN50173-3, chapter 1].
▪
As a globally used communication protocol, the ISO/IEC 61918 standard and the ISO/IEC 61784-5 EtherCAT installation profile are authoritative for EtherCAT. These contain definitions themselves or are based on other ISO standards.
In Europe, the EN standards mainly referred to in this document can be applied. The European member states maintain these EN standards as country-specific standards. Hence, the EN standards are called “DIN EN” in Germany. Since the technical specifications mentioned in the ISO/IEC standards are usually based on the general consensus of the professional technical world, most ISO/IEC specifications are to be found in a similar form in the EN standards. A comparison is not part of this documentation.
▪
Extended standard series (ISO24702, EN51918 et al.) have been drawn up especially for industrial concerns and deal with environmental conditions or with protocol-specific regulations, for example. However, they do not affect the basic electro-technical principles according to EN50173.
▪
The performance (i.e. the reliable transmission of 10/100/1000 Mbit/s) of Ethernet cabling generally depends on the following factors:
- the cable quality (attenuation, cross-section, cable structure, screening) of the individual subsections
- the plug quality (fit, screening, cable suitability)
- the number of intermediate connections
- the ambient temperature (20 to 60 °C, specified with derating according to EN50173)
- Environmental influences (e.g. MICE classification according to EN50173-1, chapter 5: Mechanical/Ingress/Climatic/Electromagnetic rating)
▪
In the EtherCAT application area, only the connection performance of 100 Mbit/s FastEthernet according to EN50173 Class D [up to 100 MHz] is required and is dealt with below. It is permissible for the user to demand connection classes with a higher performance (classes E [up to 250 MHz], EA, F [up to 600MHz MHz], FA), but this is not technically justified.
▪
In order to achieve this performance class, only Ethernet components conforming to EN50173 Cat. 5 (minimum) are permissible; see EN50173-3, chapter 1.2, among others.
Components according to EN50173 Cat. 5 are sufficient, but when using wall feed-throughs/double couplers, these must conform to EN50173 Cat. 6 in order to achieve performance class D.
▪
This document deals at present only with copper-based Ethernet 100Base-TX cabling, not fiber optic cabling according to 100Base-FX.
▪
4-core/2-pair cables are favored in Industrial Fast Ethernet, as opposed to the fully assigned 8-core/4-pair cables normally used in building automation. This is to be considered during the acceptance test (see there).
▪
The recommended assignment of a 4-core/2-pair industrial Ethernet cable is the 1,2,3,6+ screen configuration based on TIA-568A.
▪
The following is recommended for the cable cross-sections:
- Wire structure: stranded or rigid core
- Cross-section: AWG26/7 to AWG22/1 accordingly 7 cores 0.14 mm² (stranded) up to 0.34 mm² rigid.
▪
According to EN50173-1, the maximum permissible configuration for an Ethernet link is 90 meters of permanently installed cable plus 2 device connection cables of 5 metres each, with a maximum of four intermediate connectors. Other configurations, such as a direct 100 m long connection, are to be designed in accordance with EN50173-3, appendix B and tested in the field for conformity to the performance class.
▪
Caution when using expressly patch cables/cords: commercially available patch cables up to approx. 10 m are subject to considerably more generous limit values as per EN50173-1, chapter 9 than cables that are intended for permanent installation as per EN50288. Series connection or an over-length configuration is to be avoided and, if necessary, checked at least by verification – a simple continuity test is not sufficient! Application-specific patch cables manufactured from appropriate goods sold by the meter are also to be checked for their suitability.
▪
The number of plug connections between the end points is to be reduced to the necessary minimum.
▪
It is recommended to use exclusively screened Ethernet cables as per EN50288-2 (STP, SF/UTP). Together with the special twisted pair execution, the cable screen is instrumental in preventing the interspersion of interference into the communication cable and thus ensures the reliable operation of the communication link. The terminal devices must support the screen connection.
In particular when using field-configurable connectors, it must be ensured that there is a technically perfect, state-of-the-art screen connection between the connector and the cable (see also EN50174-2 and general VDE screening regulations). The qualitative testing of the screening effect is only possible in the laboratory at present (2011). Therefore, perfect workmanship must be ensured in the execution.
- There must be 360° screen contact at all transitions. Pigtails (twisting the screen braid together before the contact) are not permitted.
- The screen contact must also be guaranteed on a long-term basis (mechanical or chemical influences).
- Interruptions and small holes in the screen must be avoided.
- The cable screen must not be used for strain relief.
- The screen material must meet the electrical and mechanical requirements. Special cables are to be used for drag chains or garlands.
The instructions of cable and connector manufacturers are to be observed.
▪
The employment of rigid Ethernet cables instead of stranded wires is recommended where possible on account of the better electrical properties (Attenuationstranded > Attenuationrigid).
▪
It is recommended to employ larger core cross-sections if possible, (e.g. AWG22 instead of AWG26) on account of the better electrical characteristics (Attenuationthin core > Attenuationthick core). If the length exceeds 50 meters, too small a cross-section (AWG26) can prevent conformity to the performance class!
▪
It is recommended to check the installed Ethernet cabling before commissioning.
▪
It is recommended to monitor installed Ethernet cabling during operation using a means of software diagnosis (e.g. Beckhoff TwinCAT).
In accordance with the specified standards, a verification decision on a cable section can thus be made as follows:
Verification decision


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version | Comment
2.2 | - Update chapter “Components” - Update chapter “Safety instructions” - Update structure
2.1 | - Update chapter “Summary” - Update structure
2.0 | - Migration in ST4 - Addenda - Update structure
1.8 | - Addenda chapter • "Measurements of the cable section" • "Use of the DTX1800/DSX5000" • "Notes on certification"
1.7 | - Addenda overview of standards
1.6 | - Addenda & corrections
1.5 | - Addenda
1.4 | - Addenda
1.3 | - Addenda
1.2 | - Screening data
1.1 | - Channel adaptor instead of PL adaptor for standard measurement
1.0 | - Public version
0.1 | - Provisional documentation


Basics

Basics
Basics
Additional information
•
Overview of the standard environment
•
Basic Ethernet principles
•
Total transmission link
•
Components
•
Assembly notes
•
Design of an Ethernet cable section


Overview of the standard environment

Basics [image] Overview of the standard environment
Overview of the standard environment
A large number of standards are relevant to Ethernet technology. These standards are concerned with:
▪
Installation
▪
Communication protocols
▪
Mechanical/electrical limit values
▪
Component definitions
This document deals with the subsection:
▪
which components
▪
in which combination
▪
result in a cable section of the desired performance class.
Three normative committees are considered in this introduction:
▪
ISO: International Organization for Standardization: http://www.iso.org
▪
IEC: International Electrotechnical Commission, www.iec.ch
▪
EN/DIN: Committee for European Standards or their German editions through DIN: http://www.cenelec.eu
▪
TIA/EIA: US Standards Committee: http://www.tiaonline.org/
As a globally used communication protocol, the IEC 61918 standard and the IEC 61784-5 EtherCAT installation profile are authoritative for EtherCAT. These contain definitions themselves or are based on other ISO/IEC standards. The corresponding European implementations in EN standards are technically equivalent.
Overview of standards (does not claim to be complete)
The following illustration (Fig.2) shows the context (broad approach) of the requirements of IT cabling, industrial automation, residential buildings and data centers:
Expanded overview of standards, there is no claim for completeness
References
EN50174-2:2000 prEN50174-2:2007 | Information technology installation of communication cabling Part 2: Installation planning and installation practices in buildings
EN50288-2-1:2003 EN50288-2-2:2003 | Multi-core metallic data and control cables for analogue and digital transmission Part 2-1: Framework specification for shielded cables up to 100 MHz Cables for the horizontal and vertical areas Part 2-2: Device connection cables and switchboard cables
EN60603-7-2 EN60603-7-3 | Connectors for electronic facilities Part 7-2: Detail specification for unshielded free and fixed connectors, 8-pin, for data transmissions up to 100 MHz Part 7-3: Detail specification for shielded free and fixed connectors, 8-pin, for data transmissions up to 100 MHz
EN50173-1:2007 EN50173-3:2007 | Information technology Application-independent communication systems Part 1: General Requirements
IEC24702:2006 | Information technology Application-independent cabling Industrially used buildings
IEC61784-5-12/WD | Industrial communication networks Fieldbus installation profiles Installation profiles for communication profile family 12 (EtherCAT)
IEC61918 Ed.2.0 | Industrial communication networks Installation of communication networks in industrial plants
EN61935-1 | Specification for the testing of IT cabling
IEC61156-6 | Framework specification for multi-core symmetrical cables up to 1000 MHz


Basic Ethernet principles

Basics [image] Basic Ethernet principles
Basic Ethernet principles
‘Ethernet’ is used at present in different performance classes, depending on the data transfer rate: 10, 100, 1000 Mbit/s. The 100Mbit FastEthernet exclusively dealt with here as a physical transmission method according to ISO/IEC 8802-3 is known as
▪
type 100Base-TX
▪
full duplex, hence collision avoidance according to CSMA/CD is not necessary
▪
Use of 2 of the 4 possible core pairs: 1-2 and 3-6. A four-core cable is therefore sufficient.
▪
point-to-point connection between 2 intelligent devices, which dynamically negotiate parts of the connection establishment via the connection ICs
The 100 Mbit/s usable data stream is triple-encoded
▪
4-bit/5-bit encoding (ISO9314, for clock recovery) ® 125 Mbit/s gross data stream
▪
NRZI coding (for frequency reduction, a level change means 1bin) ® max. 62.5 MHz “intermediate frequency”
▪
MLT-3 coding (for frequency reduction, 3 instead of 2 voltage states) ® max. 31.25 MHz signal frequency on the cable; the actual frequency depends on the data stream and is thus variable
Taking into account the harmonics generated, a connection performance of the total section as per EN50173-1 Class D/Cat5 for signals up to 100 MHz is thus sufficient for FastEthernet (EtherCAT).
Conversely, 1000 Mbit/1 Gbit Ethernet works with a middle signal frequency of 62.25 MHz and needs all 4 core pairs. In principle, a fully assigned Class D section is suitable for transmission; however, since all four core pairs are used in Gbit Ethernet, and these are also used bidirectionally at the same time, it is recommended to obtain section certification in accordance with the tightened limit values (crosstalk, return loss) as per ANSI/TIA/EIA-TSB-6 (TIA Cat. 5e).
Establishment of a connection
The simplest way of diagnosing an Ethernet connection is to observe the link display at both end points: if an Ethernet cable is connected at each end to a device, both terminals begin to synchronize themselves or to maintain synchronization by the continuous transmission/reception of a special bit sequence (the idle symbol). This idle symbol consists of the maximum possible number of level changes, since the ‘1’ is transmitted 5 times – the transmission of a ‘1’ means a level change in the NRZI process.
Hence, due to the constant exchange of idle symbols, an Ethernet device that is not operative has a higher current consumption than later during normal data traffic!


Total transmission link

Basics [image] Total transmission link
Total transmission link
General Ethernet copper cabling (twisted pair) according to BS EN 50173 is characterized by:
▪
Max. 90 m permanently installed cable (as per EN50288-x-1) + two max. 5 m device connection cables (as per EN50288-x-2), altogether 100 m
▪
Max. 4 plug connections between the end points + 2 terminal connectors
▪
Cable according to EN50288
▪
Double couplers (for the connection of two RJ45 plugs) are treated separately and normally count as 2 plug connections.
▪
All cables must exhibit the same nominal characteristic impedance: 100 ±5 Ω or 120 ±5 Ω @ 100 MHz.
▪
Optionally existing overall cable screen or additional core pair screening. It is recommended that exclusively screened cable be used for EtherCAT.
The sections of a transmission link are discussed on the basis of the following illustration:
Transmission link
Model A:
Model A illustrates the maximum permissible model according to EN50173-1, consisting of
▪
max. 90 m permanent link: permanent link with cable according to EN50288-2-1
▪
Total of 6 plug connections C, including the terminal connection points
▪
max. 2 x device connection cables as per EN50288-2-2, ‘Patch cables’
Decisive for acceptance tests is that
▪
a measurement of the permanent link according to EN50173-1, appendix A includes the two connection points
▪
a measurement of the channel according to EN50173-1, chapter 5 does not include the two connection points
The target market of ISO11801/EN50173 ‘Building network-orientated cabling’ becomes clear from the structure (patch bays, intermediate distributors, floor distributors). The maximum of four plug connections can also be distributed in other ways over the cable section, for example in patch bays; see Model B.
Model B, C:
Models B and C represent more typical transmission links for the industrial area; they are discussed in EN50173-1 or ISO24702.
Connector
A transition point negatively affects the entire transmission link due to attenuation, reflection and crosstalk between the cable pairs. Therefore the number of permissible transition points for a channel conforming to EN50173 is limited to six.
A plug connection (obj. C in Fig. “Transmission link”) represents one transition point between the two elements plug/socket.
Simple plug/socket transition
Pic: Simple plug/socket transition
A double coupler thus represents 2 transition points, unless it is specified by the manufacturer as 1 transition point in the sense of plug connectors.
Double coupler
Double couplers; left Cat. 5, plastic; right: Cat. 6, all metal
Since only double couplers of at least Cat. 6 are permissible (EN50173-3, Appendix B) for the maintenance of the EN50173 Class D performance of a transmission link for which only Cat. 5 components are normally demanded, preference is to be given, for example for wall feed-throughs, to those with a simple plug/socket transition.
Performance of a transmission link
EN50173-1:2007, chapter 5 defines 8 classes according to the permissible frequency range:
Performance classes according to EN50173-1
Class | Frequency range
SRKG | up to 0.1 MHz
A | up to 100 kHz
B | up to 1 MHz
C | up to 16 MHz
D | up to 100 MHz
E | up to 250 MHz
F | up to 600 MHz
RuK-S | up to 1000 MHz
Equations according to which the frequency-dependent limit curves (e.g. within the range 1 to 100 MHz, class D) can be calculated are specified for the Ethernet-relevant performance classes D, E and F. Depending on the parameters, the measured value must remain, if necessary as f(f), under or above the limit value curve.
Examples of measurements: Insertion loss and NEXT – frequency-dependent limit curve shown in red in each case
The following parameters are defined:
Overview of parameters according to EN50173-1:2007
German | English | Abbreviation
Rückflussdämpfung | Return Loss | RL
Einfügedämpfung | Insertion Loss, Coupling Attenuation |
Nahnebensprechdämpfung | nearend crosstalk loss | NEXT
leistungssummierte Nahnebensprechdämpfung | powersum NEXT | PSNEXT
Dämpfungs-Nebensprechdämpfungs-Verhältnis, nahes/fernes Ende | Attenuation to crosstalk ratio near/far | ACR-N ACR-F
Leistungssummiertes ACR | powersum ACR | PSACR
Ausgangsseitige Fernnebensprechdämpfung | equal level far end crosstalk ratio | ELFEXT
Leistungssummiertes ELFEXT | powersum ELFEXT | PSELFEXT
Gleichstrom Schleifenwiderstand | Resistance | -
DC resistance difference | Resistance Difference | -
Laufzeit | Propagation Delay | -
Laufzeitunterschied | Delay skew | -
TCL Unsymmetriedämpfung | Transverse Conversion Loss | TCL
Kopplungsdämpfung |  | -
Not all parameters are obligatory for each performance class; measurements must be performed in accordance with EN50346.
Extract from characteristic values EN50173 Class D
Selected characteristic values for transmission links according to EN50173-1 class D
Characteristic value | Channel | Permanent Link
Length [m] | max. 100 m | max. 90 m
max. insertion loss [dB @ 100 MHz, 100m] | 24 dB | 20.4 dB
NEXT [dB @ 100 MHz, 100m] | 30.1 dB | 32.3 dB
max. propagation delay [ns @ 100MHz] | 548 ns | 491 ns
Remarks:
▪
in the (informative) calculations of the max. limit values in EN50173-1, chapter 5.2, the max. permissible 4 plug connections within the channel are assumed
▪
EN50173 class D permits a max. signal propagation delay of 548 ns at 100 MHz – this limits the use of excessively long cables. The channel length is already limited to 100 m at an assumed NVPcable of 60%.
▪
All limit values are based on an assumed ambient temperature of 20 °C. A derating (0.2%/°C) is defined in EN50173 up to the region of 60 °C: the cable/plug characteristics worsen as the temperature increases; therefore, the max. permissible channel length decreases as the temperature increases.
Deviation from the specifications
The specifications of ISO11801/EN50173 quoted above can be deviated from, e.g. by more plug connections or cable sections than permissible or by non-conforming cable material. In this case the transmission link must be calculated according to ISO11801/EN50173 and verification/certification is recommended after the installation.
Notes on device connection cables
The usual method for the acceptance testing of device connecting cables/patch cords is the patch cord measurement using special patch cord adaptors (e.g. Fluke) and the patch cord limit values according to EN50173.
Max. 20 m are specified; the attenuation is therefore not specified.
Only RL and NEXT are measured; these are worded more strictly than in the channel.


Components

Basics [image] Components
Components
Additional information
•
Notes on Ethernet components – cables
•
Notes on Ethernet components – plug connections
•
Overview of Beckhoff RJ45/M8 cables for EtherCAT systems
•
Overview of Beckhoff plug connectors for EtherCAT systems
•
Remarks regarding shielding


Notes on Ethernet components – cables

Basics [image] Components [image] Notes on Ethernet components – cables
Notes on Ethernet components – cables
For conformity, EN50173-1, chapter 7 requires the use of cables as per EN50288, twisted pairs. This includes both shielded and unshielded cables. Since shielded cables are recommended for EtherCAT cable connections, these will be dealt with exclusively below.
The relevant EN50288-2 standard contains sub-chapters on rigid and flexible cables. Twisted pairs or star quads are allowed as cable structures for both cables. The star quad is more advantageous: mechanically more stable (moving application, transverse compressive strength), lower space requirement, better NEXT values.
These standards contain, for example, the following data:
EN50288-2-1
▪
Purpose: shielded cables -100 MHz, permanently installed for horizontal/vertical areas
▪
‘Rigid wire structure’, solid copper conductors
▪
Cross-section corresponds approx. to AWG24 to 21
▪
Insertion loss max. 21.3 dB/100 m @ 100 MHz
▪
DC loop resistance < 19 Ω / 100m
EN50288-2-2
▪
Purpose: shielded cables -100 MHz, device connection cable
▪
‘Flexible wire structure’, stranded wire – single or multi-strand conductors
must consist of 7 strands
▪
Insertion loss max. 32 dB/100 m @ 100 MHz
▪
DC loop resistance < 29 Ω / 100m
The data are valid for 20 °C.
Cables can be approved by the manufacturer according to the MICE classification as per EN50173-1, chapter 5 or appendix G for the ambient conditions specified therein.
Patch cables & attenuation
As can be seen from the technical data above, it is not possible to achieve an EN50173 Class D channel with its permissible insertion loss of 24 dB/100 m @ 100 MHz using a patch cable certified according to EN50288-2-2.The use of patch cables (according to EN50288-2-2) with a length of over 10 meters or the series connection of such cables is to be provided for only in acknowledgment of the technological restrictions.
For the combination of cable and plug connector, the class of the preconfigured patch cables/cords is defined together with permissible limit values in EN50173-1, chapter 9.
IEC61784-5-12 refers to this in its “Installation profile for EtherCAT networks” by specifying a max. connection length of 100 m using AWG22 cable (note: type EN50288-2-1).
Screening
An existing screen may increase the insertion loss of a cable among other things. This effect will only be noticeable in the case of great lengths. If the acceptance of a cable section fails for this reason, it is preferable, for example, to use larger core cross-sections rather than dispensing with shielded cables.A screen improves the return loss RL.
"Similar to Cat.5"
Since cable development has undergone technological progress since the creation of these standards, there are now numerous cables suitable for Ethernet communication on the market which
• have the required electrical characteristics as per EN50173ff as a specification, but which
• do not meet or exceed individual (mechanical) specifications according to EN50288.
Such cables are identified, for example, by the remark “Similar to Cat.5” in the data sheet and can be used according to the manufacturer’s specifications – this is then a case of application-specific cabling, which should be subjected to a certification test after the installation if necessary.
Cable structure
Diameters dimensioned according to AWG (American Wire Gage) are specified as AWGxx/y: xx = AWG number, y = number of cores
Example:
▪
AWG22/1 means single core, diameter AWG22.
▪
AWG22/7 means 7 cores, overall cross-section corresponds to AWG22.
The cable structure according to ISO/IEC11801 is specified as follows:
Cable structure
Cable structure
The exclusive use of completely shielded transmission links is recommended, e.g. SF/FTP, S/FTP or SF/UTP.Ensure the correct connection of the screen in the end devices. Observe the notes on this.


Notes on Ethernet components – plug connections

Basics [image] Components [image] Notes on Ethernet components – plug connections
Notes on Ethernet components – plug connections
The connection equipment for FastEthernet must meet the electrical and mechanical requirements of EN50173 Class D. This ensures backward compatibility; higher class connection equipment can also be used for achieving Class D.
The plug components can be approved by the manufacturer according to the MICE classification as per EN50173-1, chapter 5 or appendix G for the ambient conditions specified therein.
The plug connection substantially affects the electrical characteristics of the transmission link, in particular the parameters screening effect, attenuation, crosstalk and return loss. For transmission link design, an insertion loss of 0.4 dB (EN50173-1, appendix A) is roughly assumed for a single plug connector.
The following mating faces are in use for Class D:
EN60607: "RJ45"
Connector EN60603-7, field-configurable; left: only FastEthernet compatible, assignment 1-2-3-6; right: GBit compatible, fully assignable
A 4-core assignment according to TIA-568B is sufficient for the support of FastEthernet (100 Mbit/s).
EN61076-2-101: "M12"
The 4-pole pin assignment according to EN61076-2-101 supports only FastEthernet.
Connector EN61076-2-101, type D
EN61076-2-101: M8
The 4-pole pin assignment according to EN61076-2-101 supports only FastEthernet.
Connector EN61076-2-101, type D
Others
Connectors other than those above can be used. These must then meet the electrical and mechanical requirements according to EN50173-1:2007, Appendix D.
The installation profile for EtherCAT IEC61784-5-12 is to be observed.
Core assignment (according to IEC 61918, appendix H)
Connector pin assignment - WH=white, OG=orange, GN=green, BU=blue, BN=brown, YE=yellow
Signal | Function | RJ45 | M12 | M8 | Cable colour as per TIA-568B | Cable colour as per EN61918
TD + | Transmit data + | 1 | 1 | 1 | WH/OG | YE
TD- | Transmit data - | 2 | 3 | 4 | OG | OG
RD+ | Receive data + | 3 | 2 | 2 | WH/GN | WH
RD- | Receive data - | 6 | 4 | 3 | GN | BU
- | 3rd pair + | 4 | - | - | BU | -
- | 3rd pair - | 5 | - | - | WH/BU | -
- | 4th pair + | 7 | - | - | WH/BN | -
- | 4th pair - | 8 | - | - | BN | -
Screen | Screening | Housing | Housing | Housing | n.def. | n.def.
Screening effect
It must be ensured that the screening effect is continued at the transition from the cable material to the connector. Also, in the area of the connector/cable transition, the screening material (braid, foil) must join the body of the connector with a low impedance and a large surface area and must encompass the cable 360°.
The notes on screening and the instructions enclosed with the connectors are to be observed.


Overview of Beckhoff RJ45/M8 cables for EtherCAT systems

Basics [image] Components [image] Overview of Beckhoff RJ45/M8 cables for EtherCAT systems
Overview of Beckhoff RJ45/M8 cables for EtherCAT systems
Beckhoff recommends the following cables for use in EtherCAT systems.
Data sheets and documentation on cables
Please refer to the associated data sheets and documentation for the technical data of the cables recommended here; these are available for download on our website (www.beckhoff.com).
Sold by metre
Designation | Cable
ZB9010 | Industrial Ethernet/EtherCAT cable, fixed installation, CAT 5e, 4-wires
ZB9020 | Industrial Ethernet/EtherCAT cable, suitable for drag chains, CAT 5e, 4-core
ZB9030 | EtherCAT/Ethernet cable, PVC, screened
ZB9031 | EtherCAT/Ethernet cable, PUR, suitable for drag chains, screened
ZB9032 | EtherCAT/Ethernet cable, PUR, suitable for drag chains, Highflex
ZK1090-9191-xxxx
EtherCAT patch cable, 2x RJ45 plug
Designation | Length
ZK1090-9191-0001 | 0,17 m
ZK1090-9191-0002 | 0,26 m
ZK1090-9191-0005 | 0,5 m
ZK1090-9191-0010 | 1,0 m
ZK1090-9191-0020 | 2,0 m
ZK1090-9191-0030 | 3,0 m
ZK1090-9191-0050 | 5,0 m
ZK1090-9191-0100 | 10,0 m
ZK1090-9191-0150 | 15,00 m
ZK1090-9191-0200 | 20,00 m
ZK1090-9191-0250 | 25,00 m
ZK1090-9191-0300 | 30,00 m
ZK1090-9191-0350 | 35,00 m
ZK1090-9191-0400 | 40,00 m
ZK1090-9191-0450 | 45,00 m
ZK1090-9191-0500 | 50,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-6161-xxxx
EtherCAT cable, 2 x M12 connectors (D-coded), fully assembled
Designation | Length
ZK1090-6161-0005 | 0,50 m
ZK1090-6161-0010 | 1,00 m
ZK1090-6161-0015 | 1,50 m
ZK1090-6161-0020 | 2,00 m
ZK1090-6161-0025 | 2,50 m
ZK1090-6161-0030 | 3,00 m
ZK1090-6161-0035 | 3,50 m
ZK1090-6161-0040 | 4,00 m
ZK1090-6161-0045 | 4,50 m
ZK1090-6161-0050 | 5,00 m
ZK1090-6161-0060 | 6,00 m
ZK1090-6161-0100 | 10,00 m
ZK1090-6161-0120 | 12,00 m
ZK1090-6161-0150 | 15,00 m
ZK1090-6161-0200 | 20,00 m
ZK1090-6161-0250 | 25,00 m
ZK1090-6161-0300 | 30,00 m
ZK1090-6161-0400 | 40,00 m
ZK1090-6161-0999 | 100,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-6292-xxxx
EtherCAT cable, M12 flange – RJ45 plug, fully assembled
Designation | Length
ZK1090-6292-0005 | 0,50 m
ZK1090-6292--0020 | 2,00 m
ZK1090-6292--0050 | 5,00 m
ZK1090-6292--0100 | 10,0 m
ZK1090-6292--0300 | 30,0 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3131-3xxx
EtherCAT cable, PVC, fully assembled, 2 x M8 connector
Designation | Length
ZK1090-3131-3010 | 1,00 m
ZK1090-3131-3015 | 1,50 m
ZK1090-3131-3020 | 2,00 m
ZK1090-3131-3030 | 3,00 m
ZK1090-3131-3040 | 4,00 m
ZK1090-3131-3050 | 5,00 m
ZK1090-3131-3075 | 7,50 m
ZK1090-3131-3100 | 10,00 m
ZK1090-3131-3150 | 15,00 m
ZK1090-3131-3200 | 20,00 m
ZK1090-3131-3250 | 25,00 m
ZK1090-3131-3300 | 30,00 m
ZK1090-3131-3350 | 35,00 m
ZK1090-3131-3400 | 40,00 m
ZK1090-3131-3450 | 45,00 m
ZK1090-3131-3500 | 50,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3191-3xxx
EtherCAT cable, PVC, 1 x M8 connector, 1 x RJ45, fully assembled
Designation | Length
ZK1090-3191-3003 | 0,30 m
ZK1090-3191-3005 | 0,50 m
ZK1090-3191-3010 | 1,00 m
ZK1090-3191-3020 | 2,00 m
ZK1090-3191-3050 | 5,00 m
ZK1090-3191-3100 | 10,00 m
ZK1090-3191-3200 | 20,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3100-3xxx
EtherCAT cable, PVC, 1 x M8 connector, 1 x open end
Designation | Length
ZK1090-3100-3010 | 1,00 m
ZK1090-3100-3020 | 2,00 m
ZK1090-3100-3050 | 5,00 m
ZK1090-3100-3080 | 8,00 m
ZK1090-3100-3100 | 10,00 m
ZK1090-3100-3200 | 20,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3131-0xxx
EtherCAT cable, PUR, Highflex, 2 x M8 connector, fully assembled
Designation | Length
ZK1090-3131-0001 | 0,13 m
ZK1090-3131-0002 | 0,20 m
ZK1090-3131-0003 | 0,30 m
ZK1090-3131-0004 | 0,40 m
ZK1090-3131-0005 | 0,50 m
ZK1090-3131-0006 | 0,60 m
ZK1090-3131-0007 | 0,70 m
ZK1090-3131-0010 | 1,00 m
ZK1090-3131-0013 | 1,30 m
ZK1090-3131-0015 | 1,50 m
ZK1090-3131-0020 | 2,00 m
ZK1090-3131-0025 | 2,50 m
ZK1090-3131-0030 | 3,00 m
ZK1090-3131-0040 | 4,00 m
ZK1090-3131-0050 | 5,00 m
ZK1090-3131-0055 | 5,50 m
ZK1090-3131-0060 | 6,00 m
ZK1090-3131-0070 | 7,00 m
ZK1090-3131-0075 | 7,50 m
ZK1090-3131-0090 | 9,00 m
ZK1090-3131-0100 | 10,00 m
ZK1090-3131-0110 | 11,00 m
ZK1090-3131-0150 | 15,00 m
ZK1090-3131-0155 | 15,50 m
ZK1090-3131-0165 | 16,50 m
ZK1090-3131-0200 | 20,00 m
ZK1090-3131-0205 | 20,50 m
ZK1090-3131-0250 | 25,00 m
ZK1090-3131-0285 | 28,50 m
ZK1090-3131-0300 | 30,00 m
ZK1090-3131-0350 | 35,00 m
ZK1090-3131-0400 | 40,00 m
ZK1090-3131-0450 | 45,00 m
ZK1090-3131-0500 | 50,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3191-0xxx
EtherCAT cable, PUR, Highflex, 1 x M8 connector, 1 x RJ45, fully assembled
Designation | Length
ZK1090-3191-0002 | 0,20 m
ZK1090-3191-0004 | 0,40 m
ZK1090-3191-0005 | 0,50 m
ZK1090-3191-0010 | 1,00 m
ZK1090-3191-0015 | 1,50 m
ZK1090-3191-0020 | 2,00 m
ZK1090-3191-0030 | 3,00 m
ZK1090-3191-0035 | 3,50 m
ZK1090-3191-0050 | 5,00 m
ZK1090-3191-0070 | 7,00 m
ZK1090-3191-0080 | 8,00 m
ZK1090-3191-0100 | 10,00 m
ZK1090-3191-0120 | 12,00 m
ZK1090-3191-0125 | 12,50 m
ZK1090-3191-0150 | 15,00 m
ZK1090-3191-0160 | 16,00 m
ZK1090-3191-0165 | 16,50 m
ZK1090-3191-0170 | 17,00 m
ZK1090-3191-0200 | 20,00 m
ZK1090-3191-0205 | 20,50 m
ZK1090-3191-0250 | 25,00 m
ZK1090-3191-0285 | 28,50 m
ZK1090-3191-0300 | 30,00 m
ZK1090-3191-0400 | 40,00 m
ZK1090-3191-0500 | 50,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
ZK1090-3100-0xxx
EtherCAT cable, PUR, Highflex, 1 x M8 connector, 1 x open end
Designation | Length
ZK1090-3100-0020 | 2,00 m
ZK1090-3100-0030 | 3,00 m
ZK1090-3100-0050 | 5,00 m
ZK1090-3100-0070 | 7,00 m
ZK1090-3100-0080 | 8,00 m
ZK1090-3100-0100 | 10,00 m
ZK1090-3100-0150 | 15,00 m
ZK1090-3100-0300 | 30,00 m
ZK1090-3100-0400 | 40,00 m
ZK1090-3100-0500 | 50,00 m
Please refer to the catalogue, the price list or our website (www.beckhoff.com) for the available lengths.
Further cables
Information about further versions and lengths can be found on our website (www.beckhoff.com) and in the price list.


Overview of Beckhoff plug connectors for EtherCAT systems

Basics [image] Components [image] Overview of Beckhoff plug connectors for EtherCAT systems
Overview of Beckhoff plug connectors for EtherCAT systems
Beckhoff recommends the following plug connectors for use in EtherCAT systems.
Recommended plug connectors, overview
Designation | Plug
ZS190-0003 | RJ45 connector, 4-pin, IP 20, for field-assembly
ZS190-0005 | RJ45 connector, 8-pin, IP 20, for field-assembly, suitable for Gigabit Ethernet
ZS190-0004 | M12 connector, 4-pin, IP67, for field-assembly, d-coded
ZS190-0006 | M8 connector, 4-pin, IP67, for field-assembly
Data sheets and documentation on plug connectors
Please refer to the associated data sheets and documentation for the technical data of the plug connectors recommended here; these are available for download on our website (www.beckhoff.com).
ZS1090-0003
RJ45 connector, 4-pin, IP 20, for field-assembly
ZS1090-0005
RJ45 connector, 8-pin, IP 20, for field-assembly, suitable for Gigabit Ethernet
ZS1090-0004
M12 connector, 4-pin, IP67, for field-assembly, d-coded
ZS1090-1006
M8 connector, 4-pin, IP67, for field-assembly
Recommended control cabinet feed-throughs
ZK1090-6292-0000
M12 socket on RJ45 socket, straight outlet
ZK1090-6294-0000
M12 socket on RJ45 socket, 90° angled outlet
Fewest possible transition points
Give preference to control cabinet feed-throughs with only one transition point, i.e. simple plug/socket transition (see ZK1090-6292)


Remarks regarding shielding

Basics [image] Components [image] Remarks regarding shielding
Remarks regarding shielding
The IEC61158-2 standard and in particular the IEC61784-5 EtherCAT installation profile demand a fully shielded cable for EtherCAT transmission links. This also corresponds to the general state of the art for communication cables. Twisting and differential transmission in the so-called twisted pair medium provide for fundamental interference immunity, while an overall shield around the transmission link supports the interference-free transmission of data. Over and above that, even single-pair shielded cables are used in higher connection classes (Cat6, Cat7).
4-pair cable structure: unshielded UTP, overall shielded S (F)/UTP, overall shielded and shielded pairs S (F)/STP
The following notes correspond to the state of the art. VDI guidelines, EN/IEC standards or EMC guidebooks can be consulted as sources.
▪
The overall shield around the core pairs provides for protection against external electromagnetic interference fields for the enclosed communication cores.
It is important for effectiveness that the shield coverage has a low impedance throughout and that it is also implemented without interruption or holes at transition points (EN50174-2:2009, chapter 4.7). Holes in the sense of this documentation are uncovered areas of the order of centimeters.
▪
The shield should be connected at each end of the cable to the machine earth via an electrically conducting connection with a large surface area and low impedance. A pigtail, i.e. the twisting together and point contact of the shield, must be avoided.
Recommended shield connection
▪
If the shield is not earthed, there is no protection against the influence of magnetic fields.
▪
It must be ensured by means of sufficient parallel earthing in the plant that no equalizing current flows via the shields of the communication cables. This can destroy connected devices.
Ethernet devices can therefore connect the shield to ground internally with an RC combination. Static equalizing currents are this prevented, while high frequency interference is eliminated.
To support this, therefore, the shield of the communication cable should additionally be earthed with a low impedance at the control cabinet entry point and, if necessary, on the device itself by suitable means.
Beckhoff offers appropriate installation material in the ZB8500 product group.
Correct shield connection
▪
Shield contacting should also be present at transition points (e.g. plug -> cable, couplings) and should encompass them 360°.
▪
The shield material is not to be used for strain relief.
▪
Suitable materials, preferably copper, are to be used as shield material. If aluminum is used, the special characteristics of aluminum must be considered.
Note: in the case of foiled versions, the foils for Industrial Ethernet are always made of aluminum.
▪
The “coupling attenuation” shielding effect, i.e. the qualitative effectiveness or implementation, cannot generally be measured in the field or on installed cables at present (2011). The usual measuring instruments/certifiers are limited to a static continuity measurement. Beyond that, however, there are well-known and standardized laboratory-assisted measuring methods, such as the pipe-in-pipe or drain wire methods, which can also determine the high frequency characteristics and the attenuating behavior of the shield and in this way make it possible to check adherence to a coupling attenuation of >40dB (EN50174-2:2009, 30-100 MHz). However, these are not economical for series use in industry. Therefore, perfect workmanship must be ensured in the execution from the outset.
An inadequate shielding effect may become visible by transmission errors. The diagnostic means in the EtherCAT Master TwinCAT and the EtherCAT Slaves permit the continuous, in-depth location of such defects. Observe the notes in the EtherCAT system documentation regarding this.
Optical fiber cables/optocouplers
The use of Ethernet optical fiber cables between the components may provide a solution in difficult EMC environments.


Assembly notes

Basics [image] Assembly notes
Assembly notes
The ‘EtherCAT’ assembly guideline is currently being edited by Beckhoff. Among other things, it will deal with
▪
EMC-compliant assembly, interference suppression measures
▪
Conductor spacing
▪
Screening concepts
▪
Bending radii (can impair screening effect!)


Design of an Ethernet cable section

Basics [image] Design of an Ethernet cable section
Design of an Ethernet cable section
An EtherCAT network usually consists of a master device and up to 65535 slave devices. The master alone manages the slaves and can be replaced by a 2nd master if necessary in the case of redundancy.
The electrical communication between the devices can be accomplished
▪
on an Ethernet basis as a point-to-point connection (discussed here) – recognizable by a cable connection
▪
on an LVDS basis – ‘E-bus’ – between stackable modular devices; a cable connection is usually dispensed with here
When designing the EtherCAT network, the following must be taken into account with regard to the cycle time(s) used
▪
the maximum number of devices (max. 65535)
▪
the max. permissible cables length for Ethernet cabling between individual devices (see below).
Propagation delays due to the cable length are of secondary importance; 100 m Ethernet cables with approx. 550 ns can be used.
▪
the cycle time of the Ethernet frame(s) through all real slaves on the outward and return path. The following can be assumed as an order of magnitude per slave:
- for an Ethernet device: approx. 1 µs
- for an E-bus device: approx. 300 ns
▪
the sum of the Ethernet frame lengths with which the configured devices are addressed.
Hubs and switches retarding the cycle time (ISO Layer 2) are dispensed with entirely in an EtherCAT network; there is no segmenting by routers (ISO Layer 3).
Design rules
The sum of frame length and cycle timetotal should be shorter than the available timeframe to the next transmission point.
Detailed information about the current frame configuration is given, for example, by the Beckhoff system manager. Depending on the real-time quality and the scope of the process data, it may be necessary to remain well under the value specified above.
Please take note of the comments on the Distributed Clocks settings!
The individual cable lengths for the Ethernet cabling can be designed as follows.
A Ethernet cable section is in each case a point-to-point connection between 2 intelligent end devices, of which the transmitter sends a newly generated frame to the receiver. FastEthernet/100Mbit generally works in duplex mode, hence both participants can receive and transmit at the same time on different cables. In terms of topology there are few differences between EtherCAT cabling in an industrial environment and cabling in an office. However, the number of patch bays or transition points between two Ethernet terminal devices is usually reduced in the field in favour of increased operational reliability, but at the cost of flexibility.
The boundary conditions relevant to the transmission performance are:
▪
the environmental/operating temperature
▪
the number of plug connections (single/double) between the end points
▪
the types of cable used (rigid/flexible core or their electrical characteristics; data sheets should be available)
▪
external influences on the cable section (electromagnetic fields, cables installed in parallel, garland or drag chain installation, chemical influences etc.)
▪
100 m maximum total link length permissible for 100Base-TX Ethernet; note: depending on the cable material used, the link length attainable may remain well below this value or even above it – but the application may then have to cope with longer propagation delays
▪
the design methods mentioned below refer to EN50173-1 and 3 and also apply to the industrial sector.
▪
the installed cable section should be tested; the individual testing methods are described in prEN50346:2001
Theoretical implementation:
For information: For the ‘exact’ dimensioning of a cable section according to EN50173, equations are specified in the standard in accordance with the following sequence:
▪
Sought: remaining permissible flexible cable section [m]
▪
Given: known number of plug connections, known cable lengths of permanently installed cable section, technical data of all components used (in particular attenuation)
Two sections are to be used for this, depending on the topology:
▪
Standard building cabling with up to 4 patch bays within the transmission link: EN50173-1, chapter 5 or Appendix A
▪
Direct cabling without patch bays: EN50173-3, Appendix B
▪
Combinations of these and the use of double couplers/wall feed-throughs: EN50173-3, Appendix B
Note: When using wall feed-throughs (double coupler version), Category 6 components are specified for the attainment of an EN50173 Class D connecting link! A wall feed-through (single plug connector version) is not subject to this restriction.
Practical implementation:
The exact calculation of permissible cable lengths using the equations from EN50173 is barely usable in the field. For that reason it will not be shown here. It is recommended that you adhere to the topological specifications as per EN50173 (see chapter Transmission link); you must certify differently designed cabling yourself. These specifications according to EN50173 with regard to EtherCAT are as follows:
▪
at least EN50173 Class D components (cables + connectors/sockets)
▪
max. 90 m permanently installed cable (better transmission characteristics), plus max. 2 x 5 m flexible device connection cord (poorer transmission characteristics)
▪
max. 4 plug connections within the channel (1 connector = plug/socket transition) + 2 end plug connectors
▪
temperature range up to 60°C
▪
further environmental conditions according to component manufacturer releases
Note on the cable used
The above specification can make the use of flexible cables > 5 m more difficult, for example for use in drag chains. As experience shows, real transmission links as per EN50288-2-2 ‘Patch cables’ will suffer attenuation problems from a length of around 50 m. Therefore Beckhoff offers cables suitable for drag chains/flexible cables which, despite the stranded execution, come very close to meeting the requirements of EN50173 for permanently installed/rigid cable as per EN50288-2-1.
Hence, channel lengths of 100 m that comply with the channel limit values from EN50173 are also possible using flexible cable. An acceptance test is nevertheless recommended.


Commissioning

Commissioning
Commissioning
Additional information
•
Measurements of the cable section
•
Notes on certification
•
Measurement devices
•
Troubleshooting


Measurements of the cable section

Commissioning [image] Measurements of the cable section
Measurements of the cable section
Notes on the recommended acceptance of an Ethernet section for use with EtherCAT
An acceptance measurement of the cable section, consisting of cables including connectors, can be performed in several steps, depending on the available test equipment:
1. Validation using a continuity tester
 indicates incorrect assignment, lack of screen contact, poor contacting, dirty contacts
Continuity test
2. Link control
Ethernet devices feature an optical LINK display (usually directly on the socket), which indicates directly whether a point-to-point connection could be established between the two end points by exchanging the idle symbol
Link LED on Ethernet devices
3. Certification
Broadband measurement using a certifier: indicates incorrect assignment, lack of screen contact, poor contacting, dirty contacts, damaged cables/plugs, poor attachment of field-configured plugs.
It must be ensured that the device is correctly adjusted!
Example illustration of a cable certifier
4. TwinCAT operating test
Several fault patterns can be discovered at software level using TwinCAT:
- Link LED on couplers, link check of the EtherCAT Slaves or link status in the EtherCAT Device Status:
incomplete contacting, incorrect core assignment
- Lost frames/CRC error: intermittent contacts, screening effect in operation, aging, EMC influences
TwinCAT diagnosis
Notes on measurement
• The “screen measurement” is usually only a static continuity measurement. It is not possible to test the effectiveness of the cable screen in the field at present (2011); see screening notes.
• The measuring devices/cable should not be moved during the high frequency measurement
• Poor plug contacts/cable breakages should be sought purposefully using continuity testers
Test equipment
The testing of Ethernet cabling is possible in the form of validation, qualification or certification. Various test devices for laboratory and field use are available on the market for this.
Test | Scope | Price range
Validation | low-frequency/static test of continuity, breakage, short-circuit and wiring | < 100€
Qualification | ‘narrow-band’ test of whether a certain network technology (e.g. 100Base-TX) can be implemented |
Certification | wideband measurement against the standards; reproducibly high measuring accuracy in the measuring device is necessary | approx. €8000 to any
In the handicraft installation sector, acceptance test measurements are usually carried out using certifiers that can check an Ethernet cable in 10 to 20 seconds.
Accuracy of the field checker
Field checkers of the accuracy class IIE or better (III, IIIE, IV) are to be used as per EN61935-1 for the certification of transmission links of performance class D as per EN50173-1. Note that the measurement uncertainty achieved/assured by the measuring device typically lies within the range from 1 to 5 dB, depending on the frequency and measurement (see corresponding information from the device manufacturer). The measurement statement is to be regarded critically as soon as the measured value determined by the measuring device lies within the respective +/- limit value range of the measuring accuracy. The results are not to be evaluated by the measuring device as definitely “good” or “bad”, but as possibly “good” or “bad”.


Notes on certification

Commissioning [image] Notes on certification
Notes on certification
Independent of the certification device used, the following practically orientated approach is suggested for the certification of a field-configured FastEthernet cabling section for EtherCAT (including end connector test):
▪
Limit values: the use of the channel limit values EN50173-1 Class D for signals up to 100 MHz over the entire section is recommended. Following the normative specifications, however, the respective end plug is excluded from the calculation during a channel measurement by the measuring device and the use of appropriate channel adaptors on the measuring device – ‘connector compensation’. Since the end plugs can represent significant sources of error, especially in the case of field-configured cables with no intermediate patch bays/transition points, these should be taken into account in the measurement.
▪
Tip: Depending on the measuring device used, this checks the end plugs at the beginning of the measurement and only masks them out, or continues with the channel measurement if the characteristics of the end plugs are sufficient for the performance class.
▪
Less recommendable, but possible as an alternative, is the use of permanent link measuring adaptors. In the case of a permanent link measurement, the end plug connections are included in accordance with the standards; 2 double couplers are then required for the connection of the cable section/DuT.
▪
If the combination of permanent link adaptor and channel limit values is not possible in your measuring device, the permanent link limit values EN50173-1, Appendix B Class D for signals up to 100 MHz can be used as an alternative. Since permanent link limit values are several dB ‘stricter’ than channel limit values, the channel limit values are usually complied with if the test according to permanent link limit values is passed, despite the use of 2 double couplers.
▪
If Ethernet double couplers have to be used when using permanent link adaptors on the measuring device, high-quality all-metal executions must be used (at least EN50173 Cat. 6), in order to be as transparent as possible for the measurement.
▪
Patch cable adaptors have been available for some certifiers since around 2012. These allow short point-to-point connections (“patch cables”) to be certified directly without masking out the end plugs. The TIA/SIO patch cord limit values must then be used in the measuring device.
Please note: in the case of patch cord measurements, some measurements are only informative according to TIA/ISO and no longer contribute to the PASS/FAIL decision.
▪
Accordingly M12-CAT5e adaptors can be used for the measurement of M12-M12 patch cables.
▪
For certification, the measuring device employed should attain at least accuracy level III according to IEC61935-1.
Explanations concerning certifier measurements for twisted pair cables
For specifications of the electrical limit values, refer to Cable specifications.
Measurements of Ethernet cables must take place in accordance with prEN50346:2001.
Set limit values/limit value data record
✓
A limit value data record consists of several different limit value curves, e.g. resistance, delay, NEXT, etc.
Depending upon the set limit value data record
1.
the individual measurements are active
2.
a measurement serves only for informative purposes (e.g. the length measurement in the EN50173 channel specification)
3.
or must be fulfilled (e.g. the attenuation measurement of the EN50173 channel specification)
⇨
Each data record will trigger complex measurements and thereby produce multicolored diagrams; it is the user’s duty to select the correct limit values for its specific case.
Frequency dependence of the parameters
Most of the parameters shown below are measured over a given frequency range. In evaluating the result curves f(f), it must be taken into account that FastEthernet does not work at a constant frequency, see Basic Ethernet principles.
Measurement
Explanations
Wiremap
Continuity test of all connected cores 1-8, screen
If, for example, a 4-core cable is measured, but an 8-core cable is specified in the device, the wiremap test and thus all subsequent tests will fail.
Resistance
DC resistance/loop resistance, given in Ω/100 m
normal: 12 Ω/100m @AWG22, 19 Ω/100m @AWG26
Length
Normally measured via NVP, which must therefore be entered correctly in the cable data for the test.
NVP (Normal Velocity of Propagation): ratio of the signal propagation speed in the cable to the speed of light; usually 60 – 80% and to be taken from the cable data sheet. Mainly results from the ‘length of lay’ and degree of twisting, e.g. where 2 m of Ethernet cable contain 2+x m stranded wires per core. The larger the NVP value, the less the cable elements are twisted.
The cable length as such is not actually a critical value according to EN50173, but leads via length-dependent characteristic values (such as attenuation) to electrical problems or via propagation-delay-dependent processes to protocol problems.
Propagation Delay
Results from the propagation delay of the signal in the cable. Leads to problems if a permanent link measurement (specified at max. 90 m » usually 498 ns) is to be performed on a 100 m Ethernet cable.
Differential signal delay
Time delay in the signal propagation delay of a core pair. Should be 0 ns if possible.
Insertion Loss
Attenuation
The parameter for the evaluation of the cable characteristics:
▪
the attenuation reduces the signal amplitude per meter of cable
▪
the attenuation is given as a positive value in [dB/100m] – SMALLER values are better here
▪
the attenuation is frequency-dependent: the higher the frequency, the higher the (real) attenuation is in the cable. As a result, the originally square signal from the transmitter is smoothed to the well-known ‘eye’ shape – the receiver must recover the signal by the use of equalizers
▪
an attenuation of 3 dB corresponds to a power loss of approx. 50%
▪
the attenuation increases
- if the cable becomes thinner (AWG number increases)
- if the cable is shielded (parasitic capacitances)
- if stranded cores are used instead of rigid cores
EN50173 permits different attenuation classes depending on the purpose (permanently installed or device connection = patch cable), see Limit value records. For orientation (according to EN50288-2:2003)
▪
Permanently installed cable: 21.3 dB/100m @ 100MHz (cable in stranded wire execution for moving operation is also available according to this specification!)
▪
Patch cable/device connection: 32 dB/100m @ 100MHz
CAUTION: these are not the limit values according to which a complete cable section is specified in accordance with EN50173!
Return Loss
Waves transmitted into the cable are partly reflected back to the transmitter by defects. Defects may be in the material or at the plug transitions. The return loss is the difference between the signal transmitted into the cable and the signal reflected back.
▪
The higher the measured return loss the better; the attenuation is high and the value (re-)received signal is thus smaller
▪
Order of magnitude: 10 dB/100m @ 100 MHz for the EN50173 Channel Class D measurement.
NEXT
PS NEXT
NEXT (Near End Cross Talk) describes the extent of the crosstalk from one pair of cores to a neighboring pair. For the measurement, a signal of a known strength is transmitted via pair X and the irradiation is measured on all neighboring pairs.
▪
6 combinations are thus possible with 4 pairs.
▪
NEXT is measured at both ends (NEXT, FEXT); hence, 12 result curves f(f) are determined.
▪
NEXT has a negative measured value in [dB/100m]: the value describes the ‘volume’ of the received signal on the neighboring pairs of conductors in relation to the transmitted power – the more negative the value, the better.
▪
NEXT is usually applied positively without a sign for illustration purposes; positive LARGER values are then better than smaller ones.
▪
The longer a cable is, the more sensitive it is to NEXT.
▪
Since good twisting protects against NEXT, plug connections are particularly critical: a few mm of untwisted core pair in a plug significantly affect the measured value.
Note: one plug/socket transition already creates an untwisted section of 1-2 cm!
▪
NEXT depends on the orientation of the cable section: a coiled cable will deliver a different NEXT result to an uncoiled and stretched cable. It is therefore preferable to carry out the NEXT measurement on the completed installation.
PSNEXT (PowerSum NEXT) is calculated for each pair of cores as the sum of the crosstalk from all other pairs.
▪
If PSNEXT is also applied positively for illustration purposes, then LARGER values are better.
▪
the PSNEXT curves are typically a few dB worse than the NEXT results.
ACR-N
ACR-F, ELFEXT
PS ACR-N, PS ACR-F
ACR-N (Attenuation to Crosstalk Ratio, Near End) is calculated as the difference per cable pair between the worst results of the NEXT measurements and the attenuation measurements as a function of the frequency f(f). It therefore approximates to the worst signal-to-noise ratio and is thus an outstanding parameter with which to evaluate the quality of a transmission link. It is calculated for each core pair.
▪
The larger the value, the better – the receiver can then distinguish the wanted signal more clearly from interference.
▪
An ACR-N of 10 dB can be described as a well recognizable signal.
ACR-F (Attenuation to Crosstalk Ratio, Far End) is subject to the length-dependent attenuation and is normalized from NEXT including the attenuation on length-independent values. It is also called ELFEXT (Equal Level Far End Crosstalk).
▪
The larger the value, the better.
PS ACR is calculated as the difference between PS NEXT and the insertion loss and means the entire signal-to-noise ratio of a pair of cables.
▪
The larger the value, the better.


Measurement devices

Commissioning [image] Measurement devices
Measurement devices
Additional information
•
Explanations concerning measuring devices
•
Use of the DTX1800/DSX5000


Explanations concerning measuring devices

Commissioning [image] Measurement devices [image] Explanations concerning measuring devices
Explanations concerning measuring devices
Practice-orientated hints on the specific use of cable measuring devices are given below.
Changing the settings
A product from a third party manufacturer is described in the following chapter. The respective operating manual is to be given priority. The data given below for the measuring device settings were valid at the time of preparing this documentation – it is possible, however, that the manufacturer of the measuring device may have changed the firmware/program user interface at short notice. The notes below should be considered to be supplementary to the manufacturer’s own operating manual.
Fluke DTX1800
Device tested: Fluke DTX1800, year of manufacture 2008, software 2.1200, hardware 12, DTX limits 1.3400.
The following settings need to be made on this cable certifier before the test commences:
▪
Adaptor: hardware with which the cable to be measured can be connected to the measuring device: permanent link, channel and patch adaptor.
▪
Cable limit value: limit value data records are available for various standards (ISO, TIA, China etc.) and connections (channel, permanent link, patch etc.).
Such a limit value record (‘Limits’) consists of equations that are stored in the test device for various measurements (return loss, NEXT, ACR etc.) according to frequency (1 – 100 MHz for Class D) as per EN50173.
▪
Cable type: 2 or 4 pairs, NVP
▪
Connector Pin Assignment: TIA568A/B, 2pair, POE etc.
In EtherCAT applications, a normal test object (CuT – Cable under Test) can be accepted as follows:
▪
Ethernet cable section 0.5 – 100 m
▪
Max. 6 connectors in between or max. 3 double couplers
▪
Shielded 4-core cable as per EN50288-2
▪
RJ45 plug at both ends
▪
Core assignment 1,2,3,6+ screen as per TIA-568B
▪
Arbitrary mixture of rigid and permanently installed cables (observe design notes)
The following settings have proven to be standard-compliant and usable for the certification of a (possibly field-configured) Ethernet-EtherCAT cable section:
▪
Adaptor: channel adaptor DTX-CHA001A
Reason: unlike the patch cable adaptor, the screen continuity can be tested with the CHA001A. Since Nov 2008, according to Fluke, the connector compensation provided for in the channel measurement only takes place if the end plugs meet the electrical requirements for the performance class. Therefore, permanent link adaptors and double couplers need not be used.
▪
Cable limit values: ‘POE 2 pair Cat5e Channel’
Reason: the cable limit values according to EN50173-1 Channel Class D and a 2-pair assignment are required. This combination is possible in the DTX1800 via this limit value record. The specified limit value record corresponds in its data in all relevant frequency ranges to ‘EN50173, Channel Class D’, but allows reduced cable assignment according to 1-2-3-6.
The limit value record (DTX limits) 1.34 from the Nov 2008 is used.
▪
Cable
- for the Beckhoff ZB90x0 cables, a ‘user-defined’ cable must be created with
# 2 pairs/4 cores
# NVP = 62% (according to cable supplier’s data)
- if necessary, select a 4-pair/8-core cable from the manufacturer’s database
▪
Connector Pin Assignment
- ‘Ethernet 2 pair’ (already defined in the database) or user-defined ‘TIA568B’ without contacts 4-5 and 7-8.
- or normal TIA568B pin assignment for fully assigned cable
Fluke DTX1800 screenshots
Detection of interference
In the operating mode ‘Monitor’, the DTX1800 can detect interspersed interference on the transmission link. To do this, the link must be taken out of operation and a test device connected at both ends.


Use of the DTX1800/DSX5000

Commissioning [image] Measurement devices [image] Use of the DTX1800/DSX5000
Use of the DTX1800/DSX5000
Changing the settings
A product from a third party manufacturer is described in the following chapter. The respective operating manual is to be given priority. The data given below for the measuring device settings were valid at the time of preparing this documentation – it is possible, however, that the manufacturer of the measuring device may have changed the firmware/program user interface at short notice.The notes below should be considered to be supplementary to the manufacturer’s own operating manual.
The use of the FLUKE DTX1800 for the certification of Ethernet transmission links is described below as an example.
Measuring
▪
Connect the main and remote device with the cable section
–
channel adaptor DTX-CHA001A or
–
patch adaptor DTX-PC5ES recommended
▪
switch both on; charge up beforehand if necessary or operate with the power supply units
▪
Selector switch to AutoTest
▪
Press Test
▪
Save after the test if necessary
Changing the settings
▪
Selector switch to Setup
▪
Change settings, e.g. test limit, see manufacturer documentation
▪
Selector switch to AutoTest
Measuring the irradiation
▪
Connect the main and remote device with the cable section
▪
switch both on; charge up beforehand if necessary or operate with the power supply units
▪
Selector switch to Monitor
▪
irradiations on the section can now be observed
The successor device DSX-5000 should be used accordingly.
4 dB rule/ 4 dB rule for NEXT/ACR
It can sometimes be observed that a section is declared as a PASS, although there is obviously a LIMIT violation for NEXT (or its ACR and PS).
Evaluation NEXT/ACR from 4 dB insertion loss
The reason for this could be the 4 dB rule. This is contained only in tests according to ISO11801/EN50173; this rule is not known to TIA.
The wording of this rule is as follows: NEXT/ACR is not evaluated as long as the insertion loss of the section is < 4 dB. For identification the limit line is shown in black as long as the insertion loss is < 4 dB. Only if it exceeds 4 dB is the limit line coloured red and referred to for PASS/FAIL.
NEXT measured value indicated as “I” (informatively)
The NEXT measured value is only indicated informatively “i”. Refer also to the Fluke Knowledge Base http://www.flukenetworks.com/knowledge-base
Recommendation:
▪
Agreement should be reached for the specific project as to whether certification is to take place according to TIA or ISO/EN, i.e. without or with the 4 dB rule,
▪
NEXT/crosstalk is a functionally relevant section property. Since it is technically possible to create sections that do not violate NEXT, a measurement without the 4 dB rule can be useful.
3 dB rule for return loss
In same way as with the above 4 dB rule, return loss violations are also ignored as long as the insertion loss is < 3 dB (frequency dependent). This applies to TIA, ISO and EN tests.
http://www.flukenetworks.com/knowledge-base


Troubleshooting

Commissioning [image] Troubleshooting
Troubleshooting
If there are errors on the cable length, we recommend the following procedure:
1.
Install a substitute cable instead of the installation cable and test the operation.
The substitute cable should have a proven and renowned quality and should be handled carefully.
The substitute cable must not lay parallel to the investigated installation cable, an appropriate distance to the former conduit should be kept.
The shielding of the substitute cable should be new, and, if applicable, connected to other connection points.
The max. allowable length of cable relating to the line attenuation must be noted.
2.
If you can establish an operation with the substitute wire, a stepwise localization of the error cause is possible:
- post-measurement of the installation cable -> certification
- cable routing
- transition points
- shielding/shielding connection
Interpretation of certification results
▪
‘Attenuation’ errors usually come from the cable: too long/attenuation too high.
▪
‘NEXT’ errors usually come from the plug: not correctly contacted, untwisted too far.
▪
Differences in the DC resistance between individual pairs --> cables damaged, poor contacting
▪
‘RL’ errors can come from a poorly contacted plug.
▪
RL errors can come from an internally damaged cable in a moving application.
▪
Knots in the Ethernet cable affect the characteristic impedance!
FastEthernet & cable parameters
In the case of 100 Mbit Ethernet, only one of 4 pairs (if available) is in operation for transmission and one for receiving, and not often at the same time – crosstalk effects depend among other things on the extent of utilization (no. of frames, frame lengths vs. cable lengths). In particular in the case of 1 GBit Ethernet and upwards, the specified parameters become important due to the simultaneous and bidirectional operation of the pairs.
Practical experience
▪
Incomplete cable screen
The cable is only shielded in sections ex-works or is manufactured with insufficient coverage according to EN50288/EN50290.
▪
Field-configurable plug does not fit the cable used
If the core diameter is too small, the insulation displacement contact may not penetrate to the metal conductor and may only cut a little into the insulation.
▪
Compatibility
RJ45 plugs and sockets are not functionally compatible despite normative requirements and are prone to intermittent contacts.
▪
Wall feed-throughs without earth contact
if a metallic double coupler is used as a wall feed-through into a painted housing, the screen contact for system earthing is missing.
▪
Wrong assembly tool
Crimping tool and RJ45 plugs should be approved together by the manufacturer.
▪
Cable damage
An unsuitable cable can be damaged by repetitive movement; this may not be outwardly visible.
Example – incompatible plug connection leads to intermittent contact
In the following example, the contacts in the plug are so short that the spring contacts in the socket are pushed beyond the reliable contact point when the plug/socket connection is pushed fully together. This may already be noticeable during the WireMap measurement as a broken core.
Field-configurable plug, double coupler
Effect of the intermittent contact during the return loss measurement
WireMap error due to the double coupler after 1 m of device connection cable
Example 2 - fixture for diagnostic testing
In the following example, a fixture was built in order to specifically generate transmission errors in the Ethernet cable for test purposes. The setup is, however, most disadvantageous for the transmission performance due to the disregard of the high frequency aspects addressed and the use of components not suitable for HF, and is immediately noticeable in the test. It is thus possible that the transmission link may not work even with short cable lengths. In detail:
▪
Interruption of the screen, construction is not in a screened housing
▪
Parallel untwisted routing of the cores over many centimetres
▪
Plug connection and switching elements unsuitable for HF
▪
Solder track layout unsuitable for HF
▪
No fixing of the cores, measurement results not reproducible
Fixture for insertion into the transmission cable
Change of the transmission link
Exclusively suitable components that have been correctly installed/connected according to the manufacturer’s instructions should be used in Ethernet transmission links. The transmission link should be certified in each case.
Example 3 – poor execution of the cable/connector connection
In the following example, the core pairs are untwisted over an unnecessarily long distance contrary to the manufacturer’s instructions; therefore local crosstalk is very much facilitated. In the test, such a connector is noticeable by a high crosstalk and/or a low crosstalk attenuation “NEXT”.
Result of the NEXT test
X-ray picture of an RJ45 connector


Appendix

Appendix
Appendix
Additional information
•
AWG conversion
•
Support and Service


AWG conversion

Appendix [image] AWG conversion
AWG conversion
The table below according to ISO/IEC61918 Ed. 2.0 Appendix F can be used to convert American AWG diameters to the metric format. The AWG number refers to the number of times the wire concerned has to be drawn through the drawing in order to manufacture it – the thinner the wire, the more drawing procedures are necessary.
mm² | AWG
0,05 | 30
0,08 | 28
0,14 | 26
0,20 | 24
0,28 | 23
0,34 | 22
0,38 | 21
0,50 | 20
0,75 | 18
1,0 | 17
1,5 | 16
2,5 | 14
4 | 12
6 | 10
10 | 8
16 | 6
25 | 4
35 | 2
50 | 1
55 | 1/0
70 | 2/0
95 | 3/0
120 | 4/0


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com