ET2000 - Industrial Ethernet multichannel probe
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the following notes and explanations are followed when installing and commissioning these components.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH & Co. KG.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version | Comment
2.2 | - Update chapter “Basic Function Principles” - Update structure
2.1 | - Update chapter “Basic Function Principles” - Update structure
2.0 | - 1st public issue in PDF
1.8 | - Technical data updated
1.7 | - Technical advice changed
1.6 | - Technical advice added
1.5 | - Technical description added, new safety instructions added
1.4 | - Technical description added
1.3 | - Changing "Wireshark" support
1.2 | - Technical description added
1.1 | - Technical data added (SoF)
1.0 | - Technical data added
0.1 | - first provisional documentation for ET2000


Product overview

Product overview
Product overview
Additional information
•
ET2000 - Introduction
•
Technical data
•
Basic Function Principles
•
Analysis of EtherCAT telegrams
•
LED Displays


ET2000 - Introduction

Product overview [image] ET2000 - Introduction
ET2000 - Introduction
ET2000
Industrial Ethernet multi channel probe
With the ET2000 multi channel probe Beckhoff introduces a versatile piece of hardware for analyzing any Industrial Ethernet solution. With eight ports this device enables unlimited synchronized recording of up to four independent channels at a speed of 100 Mbit/s. All realtime Ethernet standards such as EtherCAT, PROFINET, etc. and conventional office Ethernet networks are supported.
Through its compact and rugged design the ET2000 is ideal both for the local application at machines or in the laboratory. The four channels enable recording and analysis of separate networks or different points within the same network. All frames in transit – in both directions – are furnished with a high-precision timestamp in the probe hardware and copied to the Gbit uplink port.
The high timestamp resolution of 1 ns enables very precise timing analysis of the connected network segments. The ET2000 probe is transparent for the connected buses. Thanks to the low cycle delay of < 1 μs the influence on the system is very small. The device can be connected to any Gbit Ethernet interfaces on the PC side.
It is supplied with a Windows driver based on the open WinPcap software interface. This means that the versatile ET2000 probe can be used with freely available network monitors such as Wireshark (Ethereal).


Technical data

Product overview [image] Technical data
Technical data
Technical data | ET2000
Bus system | Ethernet (all Ethernet based protocols (IEEE 802.3)
Number of ports/channels | 8/4
Ethernet interface | 100BASE-TX Ethernet with RJ45
Uplink port | 1 GBit/s
Baud rate | Probe ports: 100 MBit/s, Uplink port: 1 GBit/s
Delay | < 1 µs
Resolution time stamp | 1 ns
Accuracy time stamp | 40 ns
Acquisition moment of EtherCAT frame | Start of Frame (SoF)
Diagnosis | 2 LEDs per channel - Link/Activity 8 Status LED for future diagnostics
Power Supply | by three-pole terminal (+, -, PE)
Supply voltage | 24 VDC (18 VDC ... 30 VDC)
Software interface | "Wireshark" extension currently required "Wireshark" version: see chapter Basic Function Principles
Current consumption | typ. 250 mA
Weight | ca. 300 g
Dimensions without plugs (w x h x d) | ca. 100 mm x 150 mm x 40 mm
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27
EMC resistance burst / ESD | according to EN 61000-6-2 / EN 61000-6-4
Protection class | IP 20
Installation position | variable
Approvals | CE


Basic Function Principles

Product overview [image] Basic Function Principles
Basic Function Principles
The ET2000 is ready to operate when it is shipped. No hardware settings need to be made. The ET2000 is inserted into an Ethernet line, and then mirrors all the Ethernet frames via a 1 Gbit port to a PC that records the data. The ET2000 does not have any memory of its own, which means that using a 1 Gbit uplink connection is obligatory.
The ET2000 attaches a time stamp to every recorded frame. The time stamps can be used to analyze the network traffic closely. The acquisition moment is the "Start of frame". (SoF)
Commissioning – hardware
▪
Connect the ET2000 in accordance with the labels to a 24 V DC power supply.
▪
LEDs 3 and 4 light up (see LED Status).
Power supply for the ET2000
▪
Connect the 1 Gbit/s uplink to a network port on your PC; this must also be capable of operating at 1 Gbit. The operation at a 100MBit-Port is not possible.
▪
Now pass the network traffic that is to be analyzed through one of the four lines (channels) in the ET2000. All four channels can be used simultaneously. The respective activity LED indicates data traffic. The left one of the ports (IN) is to be understood as the input in forward direction, the port on the right (OUT) is the output, s. Fig. "Top view ET2000".
Top view ET2000
Note
Mirrored frames (from firmware 02)
For optimum application of the ET2000 in an EtherCAT network, the ET2000 operates as follows: if only one port is connected on a channel, the ET2000 mirrors all the incoming frames back to this port. This function makes it possible for an EtherCAT branch to continue operating without losing any frames even during the connection process. In networks that are not designed to cope with mirrored frames, this function can result in a conflict! This can, for instance, occur on manageable switches with loopback monitoring. In order to avoid this effect, the network device that can process the reflected frames must be connected first to the ET2000.
Note
Application in Proninet IRT systems
The delay of a single frame while passing a line of the ET2000 is around typ. 540 +/- 40 ns. You have to consider this if Profinet IRT systems are implemented.
Application example in the EtherCAT System
Fig. "Exemplary connection of the ET2000" exemplifies the usage in a EtherCAT system for recording the protocol data.
Exemplary connection of the ET2000
Commissioning - software
16 bytes of data are added to every Ethernet frame captured by the ET2000, containing information about the port used, the data integrity and the time stamp. This addendum is attached on the user data as a postfix, the data format is a so called ESL (EtherCAT Switch Link). The point of receiving time of the EtherCAT frame at the ET2000 (Start of Frame, SoF) is captured as a 64 bit time stamp value and is contained in the user data. It is this extended frame that is now transmitted to the PC over the 1 Gbit uplink connection. The continuously incoming Ethernet frames could be recorded there by suitable software. This software is not included in the scope of supply but can, for instance, be downloaded free of charge from the Internet. For currently best performance, at least "Wireshark" version 1.0.2 is suitable.
During sending the ET2000 creates a new checksum/CRC and a new header.
▪
Operation without ESL evaluation
The parser ..\Wireshark\plugins\ethercat.dll integrated in Wireshark > 1.0.2 as standard only decodes EtherCAT frames and makes them readable. The additional 16-byte data (ESL) are referred to as padding byte. It is not possible to filter the information that they contain.
▪
Operation with ESL evaluation
The ESL information can be decoded by replacing ethercat.dll with a version that can be downloaded from the Beckhoff website:
- CRC Error in the original frame
- Alignment Error
- Time stamp of ET2000
Note
Display of EtherCAT frames with ESL information
In the case described above Wireshark can only display Ethernet frames sent by the ET2000, i.e. frames containing ESL information! To enable reading of Ethernet frames without ESL information, delete/rename ethercat.dll and restart Wireshark.
Only software for Windows operating systems will be considered in these instructions.
Operation without ESL time stamp evaluation
Generally speaking, any appropriate software, such as Microsoft Network Monitor (NetMon), or Wireshark/Etherreal Network Analyser can be used to record the Ethernet frames. It may be necessary to use additional tools in order to analyze the information contained in the frames, and such tools are not necessarily available for any software whatsoever. The further processes are therefore described using the Wireshark network analysis software as an example.
Note
Etherreal vs. Wireshark
At present, Etherreal, unlike Wireshark, is not being further developed. Wireshark is the continuation and further development of the well-known Etherreal network analysis program, under a new name. Both are available free, and both (as well as NetMon) can be automated with scripts.
▪
Install the current version of Wireshark (www.wireshark.org) on your PC. Wireshark thus provides the user interface and the data management for the recorded frames. The current WinPcap driver will be installed at the same time, if it does not already exist. This takes the Ethernet frames from the network port at the PC, and passes them on to Wireshark.
▪
Following installation, select Wireshark, choose Capture --> Interfaces to select the 1 Gbit network port to which the ET2000 is transmitting, and start recording.
Note
Process data
Large quantities of data can sometimes accumulate in a very short time, depending on the EtherCAT cycle time and process data range
Screenshot of a Wireshark recording
Fig. "Screenshot of a Wireshark recording" shows a log of EtherCAT frames from the TwinCAT EtherCAT master; in the windows underneath, the content of a frame is broken down (if possible). The "Time" column shows the time at which the frame transmitted by the ET2000 arrived at the PC's Gbit port. Because this involves passage through a number of Windows protocol layers, the accuracy of these values must be considered carefully.
Operation with ESL/time stamp evaluation
If no other actions are taken, the data in the "Time" column gives the approximate arrival time of the Ethernet frame transmitted by the ET2000 on the PC's Gbit port. This value may deviate significantly from the pass-through time of the original frames through the ET2000. Evaluation of the time stamp added by the ET2000 requires a Wireshark extension made available by Beckhoff for Wireshark version 1.0.2 and above. This is a modified EtherCAT parser "ethercat.dll", which ensures that Wireshark can break down an Ethernet frame with EtherCAT datagrams into its components (see Fig. "Screenshot of a Wireshark recording").
Replacing the standard ethercat.dll enables Wireshark to read the ESL information, although Ethernet frames not containing ESL will no longer be recorded.
This dll file is available for download from http://www.beckhoff.com under Download --> Software --> Development products. The Wireshark installation already contains a EtherCAT.dll, as the case may be, this file does not support the ESL protocol yet. Once the existing Ethercat.dll in folder Wireshark/plugins/<build>/ has been replaced, this dissector (for breakdown) can be activated under Edit/Preferences (see Fig. "Activation of the ESL Dissector in "Wireshark""). The "Time" column of the Wireshark interface then displays the time stamp applied by the ET2000; otherwise the time at which the frame arrived at the PC's Gbit port is displayed.
Note
File versions EtherCAT.dll
• before release 1.0.2: modification of the WinPcap´driver necessary no support.
• from release 1.0.2: download at http://www.beckhoff.com
• from release 1.2.0: download at http://www.beckhoff.com
• from release 1.6: already integrated in Wireshark, no futher re-installation necessary.
The display resolution can be increased up to 1 ns under View/TimeDisplayFormat/.
Activation of the ESL Dissector in "Wireshark"
Note
Additional data (16 bytes)
The ET2000 adds 16 additional bytes of data to the mirrored frame that is transferred to the recording PC. If the original frame already had the maximum length permitted by the Ethernet standard of 1500 bytes, it is possible that the PC's Gbit port might discard the frame, as it is now 1516 bytes long. It may be necessary to change settings for JumboPackets in the driver properties of the network port.
From the ET2000 appended additional data in the ESL (EtherCAT Switch Link) protocol
Constitution of the16 additional bytes of data
The 16 byte additional data of the ET2000 have the following meaning (in serialization), see Fig. "From the ET2000 appended additional data in the ESL (EtherCAT Switch Link) protocol":
6 Byte | Identifier 01 01 05 10 00 00 (symbolic MAC address)
1 Byte | Port designation 0 ..7 of arriving frame
1 Byte | bit 0..2 reserved, bit 3: alignment error, bit 4: CRC error in recorded frame
8 Byte | Timestamp in ns (accuracy: 10 ns) - x000003EF4FDB83E0 (reading direction backwards)
Note
ET2000 extensions
This is not a final description. Future development can cause a modification of the constitution of the additional data. In this case a corresponding version of the "ethercat.dll" will be provided on the Beckhoff website (http://www.beckhoff.com)
Note
Compensation of the minimal Ethernet frame length
If there are only little process data in the EtherCAT protocol, e.g. in a small network with only a few participants, the rate of the user data is correspondingly low. Therefore, the EtherCAT frame is filled up with dummy bytes (x00) between the regular end of the frame and the ET2000 extension (16 bytes), to reach the minimal Ethernet frame length.
Note
Alignment error
The ESL header indicates an alignment error if the recorded frame did not end on a byte boundary.
The last byte of the frame data before the ESL header has to be ignored if the alignment error bit is set.
Analysing EtherCAT datagrams
Fig. "Screenshot of a Wireshark recording" shows a log of EtherCAT frames from the TwinCAT EtherCAT master. Frame 348 is highlighted, and its content is broken down in the fields underneath. In the lower section of the central window, the EtherCAT datagrams contained in frame 348 are broken down with explanations.
Note
Parser
A specific parser is required in the <Wireshark installation directory>\plugins\<Version> directory for every network protocol that is to be analysed. These parsers can usually be obtained from the respective user organizations.
Parser versions for Microsoft NetMon, Wireshark and Etherreal are available at present. Copy it to the directory mentioned above, and start Wireshark again. Wireshark can now display the EtherCAT datagrams as in Fig. "Screenshot of a Wireshark recording" .
Examples for filter settings and their effect
▪
"(esl.crcerror == 1) or malformed": Ethernet frames identified by the ET2000 as defective are displayed
▪
"ecat.adp==0x03ed and (ecat.ado==0x120 or ecat.ado==0x130)": State transitions of the EtherCAT slave are checked 0x03EDhex/1005d.
▪
"ecat_mailbox": only mailbox commands are displayed
▪
"((ecat.cmd==4)&&(frame.number>110)): all FPRD datagrams from the 110th Ethernet frame are displayed.
Please refer to the separate example.


Analysis of EtherCAT telegrams

Product overview [image] Analysis of EtherCAT telegrams
Analysis of EtherCAT telegrams
Below, examples of logged telegrams will be analyzed and compared with the configuration used.
Logging
Line 1 of the ET2000 being used is placed between the IPC and the EK1100 coupler, because the aim of this examination is to determine the extent to which all slaves change the transmitted frames. This can best be logged directly on the EtherCAT Master.
The ET2000 uplink is connected to the Gbit interface of a CP6920.
Note
Information on data logging
Logs >> 100,000 frames may under certain circumstances overload the RAM of the PC being used. It may be necessary to insert filters in order to reduce the amount of accumulated data. A PC with a conventional hard disk should be used for logging, not one with a CF card.
Note
Position of the data log
A meaningful interpretation of the logged data is usually only sensible or possible if the place of connection is known. Hence, a connection between the master and the first slave, between Ethernet devices or even at the end of a topology can be meaningful, depending on the aim of the examination. Since 4 lines are available in the ET2000, Ethernet telegrams can be recorded at up to 4 different places simultaneously.
Interpretation
Configuration
The TwinCAT configuration shown in fig. "Configuration and transmitted EtherCAT datagrams" is used here.
Configuration and transmitted EtherCAT datagrams
The EtherCAT Master (A) transmits an Ethernet frame with the process data (B) cyclically every 1 ms. This frame contains 5 EtherCAT datagrams (C). These datagrams are automatically calculated in the TwinCAT-EtherCAT Master. The calculation can be influenced in the 'Advanced Settings' or by SyncUnits.
The 2nd datagram, ‘LWR’, will be taken here as an example. This “Logical Write” is 1 byte long (Len = 1) and is located in the 4.2 GB EtherCAT address space at the logical address 0x10800 (D). One or more EtherCAT slaves must process this datagram in passing. After all slaves have done this successfully, the datagram must come back with a WorkingCounter = 1 (E).
The entire Ethernet frame encompasses 94 bytes (F) and, in the 1 ms cycle used with a length/duration of 9.44 µs, still allows a great deal of space for further process data or acyclic/queued telegrams.
Whereas the acyclic telegrams can change during the application runtime, the cyclic telegrams in the TwinCAT-EtherCAT Master are unchangeable as a rule. This simplifies the interpretation of the logs.
Information about the slave
We shall now consider the EL2008 slave. From its “Advanced Settings” -->FMMU/SM, fig. "EL2008 mapping settings", we can see:
▪
that it uses only 1 FMMU (Fieldbus Memory Management Unit) (B),
▪
which transfers 1 byte (length = 1)
▪
from the logical address space at byte 0x10800 (C)
▪
from bit 0 (L Start: “.0”)
▪
to bit 7 (L EndBit = 7)
▪
into the Slave’s physical RAM memory after address 0x0F00 (D).
These settings are made automatically by the TwinCAT-EtherCAT Master.
The LWR at log. 0x10800 must now be sought in the telegram logs.
EL2008 mapping settings
Logs
The EtherCAT datagrams can be found again immediately in the Wireshark log, fig. "Wireshark log". Several thousand frames have been logged here; we will take as examples frame no. 4855 (output from the Master with a clock time of approx. 1 ms) and no. 4856 (returning from the field several µs later, depending on the scope of the configuration).
Note
Time column display
It is often helpful to have the interval between two consecutive packets displayed in the Time column, see fig. "Wireshark log". This can be set under View --> TimeDisplayFormat.
Note
Usability of the Time column
The information in the “Time” column can only be evaluated meaningfully if the frames were logged by the ET2000, since it gives each frame an HW time stamp – if the Wireshark .dll is installed as described, then this time stamp will also be displayed in the Time column. The time of arrival of the frame will otherwise be used at software level in the Ethernet driver of the logging PC on the basis of the operating system time in an ms raster. In addition, the order in the log will in this case usually be changed to a massive extent – the user must then first of all determine the correct order, e.g. using the index field in the EtherCAT datagrams.Therefore, the use of the ET2000 simplifies/accelerates the interpretation of the data considerably.
Wireshark log
The outgoing frame no. 4855 carries 5 commands/datagrams (C). The ET2000 suffixes the ESL/EtherCatSwitchLink information (16 bytes) with the time stamp (D). As a result, the frame grows to a length of 110 bytes (B).
Of interest is now the LWR at 0x10800, which is the second datagram according to fig. "EL2008 mapping settings" (B). The EtherCAT parser integrated in Wireshark allows the information to be represented as in fig. "Datagram interpretation" – the 2nd datagram is marked, as a result of which the bytes associated with it are highlighted in the 100 byte raw data field. The datagram begins with the datagram type (LWR = x0B); the sequential index follows, in this case x02. Further information on the EtherCAT protocol can be found in the documentation at www.ethercat.org.
Of particular interest here is also the WorkingCounter = 0 – all datagrams output from the Master carry Wc=0.
Datagram interpretation
The EL2008 process data, 1 byte, can also be found in the datagram, see fig. "EL2008 process data".
EL2008 process data
In frame no. 4856 (A), when it returns from the field after 2 µs, all WorkingCounters have changed; these must now correspond to the expected values from fig. "Configuration and transmitted EtherCAT datagrams".
WorkingCounter in returning frame


LED Displays

Product overview [image] LED Displays
LED Displays
Ethernet
RJ45 connector
For each channel 1 LED show the current status.
LED display per channel
LED | Display
Link Act | off | no connection
 | on | connection established (Link)
 | flashing | data transmission active (Act)
Status
The Status LEDs 1 - 8 are intended for future diagnosis functions.
In standard operate mode the LED 3 and 4 glow permanently.
Status LEDs


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com