ES2008, ES2016 - Ethernet Switches

BECKHOFF Fieldbus Components

Documentation for

ES2008 and ES2016 (no longer available)

8 and 16 Port Ethernet Switches

ES2008 and ES2016 are substituted by CU2008 and CU2016

Version: 1.1
Date: 2005-10-25


Notes on the documentation

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards. It is essential that the following notes and explanations are followed when installing and commissioning these components.

Liability Conditions

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

The documentation has been prepared with care. The products described are, however, constantly under development. For that reason the documentation is not in every case checked for consistency with performance data, standards or other characteristics. None of the statements of this manual represents a guarantee (Garantie) in the meaning of § 443 BGB of the German Civil Code or a statement about the contractually expected fitness for a particular purpose in the meaning of § 434 par. 1 sentence 1 BGB. In the event that it contains technical or editorial errors, we retain the right to make alterations at any time and without warning. No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.

Copyright

© This documentation is copyrighted. Any reproduction or third party use of this publication, whether in whole or in part, without the written permission of Beckhoff Automation GmbH, is forbidden.


Safety Instructions

Safety Rules

The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.

State at Delivery

All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH.

Personnel Qualification

This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.

Description of safety symbols

The following safety symbols are used in this operating manual. They are intended to alert the reader to the associated safety instructions.

Danger This symbol is intended to highlight risks for the life or health of personnel.

Warning This symbol is intended to highlight risks for equipment, materials or the environment.

Note This symbol indicates information that contributes to better understanding.


ES20xx - Documentation Issue Status

BECKHOFF ES2008 and ES2016: Foreword

Documentation Issue Status

Version | Comment
1.1 | Notes for UL added
1.0 | first Release
0.1 | internal version


Einführung

BECKHOFF ES2008 and ES2016: Product Overview

Introduction

The Beckhoff Ethernet switches offer 8 or 16 RJ45 Ethernet ports. Switches relay incoming Ethernet frames to the destination ports. In full duplex mode, they prevent collisions. They can be used universally in automation and office networks. User-friendly installation via integrated top hat rail adapter.

The switches meet the special requirements of real-time-capable Industrial Ethernet solutions through several outstanding features:

  • Optional broadcast filtering supports the integration of any Ethernet devices in real-time environments
  • Optional packet-based or port-based prioritization (QoS, VLAN)

Further benefits underline the particular suitability for the application in industrial environments:

  • Compact design in metal housing
  • 10/100 MBaud with automatic baud rate detection
  • half or full duplex operation
  • Cross-over detection: automatic detection and correction of crossover and straight-through Ethernet cables
  • Clear LED field for quick diagnosis, 3 LEDs for each Ethernet port
  • easy top hat rail mounting
  • Industrial design


Basic Function Principles

Store and Forward

The switch operates according to the store-and-forward principle. Frames that are faulty (CRC error), too short (< 64 bytes) or too long (> 1536 bytes) are not passed on.

Address Memory

The switch learns the MAC addresses of the connected devices for each port. Only frames that have these addresses, broadcast/or multi-cast addresses, or which have unknown addresses are passed on to this port. Because the switch remembers more than 1000 addresses for each port, it is also suitable for connecting entire network segments. After approx. 5 minutes (Aging Time) unused addresses are removed from the memory – if required, they are re-learnt again later.

Throughput

The switch can pass through up to 148800 Ethernet frames per second (Wire Speed).

Port-Based Filtering (FLTR)

It is a characteristic of pure master-slave network architectures that all the slave devices only communicate with one or more masters. The switch supports these architectures through switchable port filtering. When this is active, devices that are connected to the slave ports can only communicate with devices connected to the master port (or ports). Lateral communication between the slave ports is suppressed. This reduces the network loading from, for instance, broadcast frames transmitted by slave devices, and implements access protection between the slaves. This function is activated by means of the FLTR on DIP switch.

Prioritization

Under conditions of heavy network loading, it can happen that time-critical frames are held up by less important frames. In order to avoid this, the switch has two transmit buffers (queues), for high-priority frames and for low priority frames. Assignment to these queues is carried out

  • on the basis of the port (port based QoS - ES2016 only) or

  • on the basis of the VLAN priority transmitted with the frame (VLAN tag in accordance with IEEE 802.3Q).

The sequence in which the queues are emptied is specified by means of DIP switches QP0 and QP1.

Port-Based Prioritization (ES2016 only)

This function permits selected ports to be classified as high priority – regardless of the data transmitted through these ports. Depending on the application, it is then possible, for instance, for the ports to which time-critical devices (PLC, drives or input/output modules) are connected to be assigned a high priority, while the connection to the company network or to the visualization units can be made through low priority ports. This function is activated by means of the QoS0 and QoS1 DIP switches.

VLAN-Based Prioritization

This function evaluates the 3-bit VLAN-tag in the Ethernet frame (IEEE 802.3). VLAN priorities 4..7 are classified as high priority, while priorities 0..3 are assigned to the low priority queue. This function is activated by means of the VLAN on DIP switch.

Flow Control

The switch supports the flow control for full duplex Ethernet standardized in IEEE 802.3x. This mechanism operates between two devices that are connected point-to-point – in this case, between the switch and the PC. If the receiver is overloaded, it can return a pause frame, and the sender is then prompted to wait for the desired pause time. A pause of 0 causes the switch to resume transmission even before the original pause period has elapsed. The pause request is not passed on by the switch.

Automatic Flow Control

After a high priority frame has been received, the switch can suppress the flow control of the low priority transmission queue for approx. 1 or 2 seconds. This prevents the high priority frame from also been delayed. This function is activated by means of the AFC DIP switch.


ES20xx - Technical Data

BECKHOFF ES2008 and ES2016: Product Overview

Technical Data

Technical Data | ES2008 | ES2016
Bus system | all Ethernet based protocols (IEEE 802.3) Store-and-Forward switching mode
Number of Ethernet-Ports | 8 | 16
Ethernet Interface | 10BASE-T/100BASE-TX Ethernet with RJ45
Cable length | up to 100 m Twisted-Pair, switches cascadable without restriction
Baud rate | 10/100 Mbit/s, IEEE 802.3u auto-negotiation, half or full duplex at 10 and 100 Mbit/s possible, automatic settings
Diagnosis | 3 LEDs per channel: - Link/Activity - 10/100 MBit - Collision / Full duplex
Power Supply | by three-pole supply plug (+, -, PE), is included
Supply voltage | 24 VDC (18 VDC to 30 VDC), protected against polarity reversal. To meet the UL requirements use 4 A fuse or class 2 power supply (see chapter power supply)!
Current consumption | typically 100 mA | typically 150 mA
Weight | app. 340 g | app. 540 g
Dimensions without plugs (w x h x d) | app. 85mm x 100mm x 38mm | app. 146,5mm x 100mm x 38mm
Mounting | on 35 mm top-hat rail (C-rail according to EN 50022)
Permissible ambient temperature range during operation | 0°C ... + 55°C
Permissible ambient temperature range during storage | -25°C ... + 85°C
Permissible relative humidity | 95%, no condensation
Vibration / shock resistance | according to EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMC resistance burst / ESD | according to EN 61000-6-2 (EN 50082) / EN 61000-6-4 (EN 50081)
Protection class | IP 20
Installation position | variable
Approvals | CE UL


Abmessungen

BECKHOFF ES2008 and ES2016: Mounting and Commissioning

Dimensions

Dimensions without plugs (w x h x d):

  • ES2008: app. 85mm x 100mm x 38mm
  • ES2016: app. 146,5mm x 100mm x 38mm
Note Required space in control cabinet:
  • The connector for power supply (24 VDC) and the feeder cable extends the depth by app. 25 mm.
  • The RJ45 Plugs extends the depth depending to their design and the used Ethernet cable.
  • You have to add app. 10 mm extra space above the c-rail for snapping the switch onto the c-rail.
ES2008

ES2016


ES20xx - Mounting and Removal

BECKHOFF ES2008 and ES2016: Mounting and Commissioning

Mounting and Removal

The ES2008 and ES2016 switches are fastened to the assembly surface with the aid of a 35 mm top-hat rail (a C mounting rail according to EN 50022).

Assembly
  • Fit the mounting rail to the planned assembly location.
  • Suspend the switch on the mounting rail with the spring on the lower side of its latching flange.
  • Press the switch upwards (1).
  • Press the upper side of the switch (2) against the assembly surface until it latches in the mounting rail.
  • Attach the cable.

Removal
  • Remove all the cables.
  • Press the switch upwards (3).
  • Pull the other side of the switch (4) away from the assembly surface.


ES20xx - Cabling

BECKHOFF ES2008 and ES2016: Mounting and Commissioning

Cabling

Power Supply

Pinning of the supply connector

Danger For the compliance of the UL requirements the EtherCAT components should only be supplied
  • by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp.
  • by a 24 VDC power source, that has to satisfy NEC class 2.

A class 2 power supply shall not be connected in series or parallel with another (class 2) power source! This requirements are valid for the supply of all Bus Couplers, Power Supply Unit Terminals, Bus Terminals and their Power Contacts.

Danger To meet the UL requirements, the EtherCAT components must not be connected to unlimited power sources!

Ethernet

Pinning of the RJ45 socket


DIP Switch

Switch settings (ES2008 and ES2016)
DIP switch |  | Function |  | default
No | Name
1 | FLTR on | off | Port-based filtering for master/slave networks is switched off. | off
 |  | on | Port-based filtering for master/slave networks is switched on: All the devices connected to the slave ports can only communicate with other devices on the master port!
2 | FLTR Type | Select the number of master ports for port-based filtering (only significant if FLTR is switched on). |  | off
 |  | off | ES2008: Port 1 is the master port, all others are slave ports.
 |  |  | ES2016: Port 9 is the master port, all others are slave ports.
 |  | on | ES2008: Ports 1 and 2 are master ports, all others are slave ports.
 |  |  | ES2016: Ports 9 and 10 are master ports, all others are slave ports.
3 4 | QoS0 QoS1 | Activates port-based prioritization (only for the ES2016) and selects the high-priority ports. |  | off/off
 |  | off/off | Port-based prioritization is switched off: All ports have the same priority
 |  | off/on | Port-based prioritization is switched on: Ports 7 and 8 have high priority
 |  | on/off | Port-based prioritization is switched on: Ports 5 to 8 have high priority
 |  | on/on | Port-based prioritization is switched on: Ports 1 to 8 have high priority
5 | VLAN on | off | VLAN-based prioritization is switched off | off
 |  | on | VLAN-based prioritization is switched on
6 7 | Qp0 Qp1 | Specifies the sequence in which the high and low priority queues are emptied. |  | off/off
 |  | off/off | The high priority queue is always emptied first
 |  | off/on | Transmission ratio 4:1: After every 4 high priority frames, one frame is sent from the low priority queue
 |  | on/off | Transmission ratio 2:1: After every 2 high priority frames, one frame is sent from the low priority queue
 |  | on/on | Transmission ratio 8:1: After every 8 high priority frames, one frame is sent from the low priority queue
8 | AFC (Auto Flow Control) | Automatic flow control: Switches off the flow control of the low priority queue for between 1 and 2 seconds after receipt of a high priority frame. |  | off
 |  | off | AFC switched off (flow control for the low priority queue is always active)
 |  | on | AFC switched on (flow control for the low priority queue is switched off for between 1 and 2 seconds after receipt of a high priority frame).


ES20xx - LED Displays

BECKHOFF ES2008 and ES2016: Mounting and Commissioning

LED Displays

Ethernet

For each channel 3 LEDs show the current status.

LED display per channel
LED | Display
Link Act | off | no connection
 | on | connection established (Link)
 | flashing | data transmission active (Act)
100M | on | connection with 100 MBit/s
Full Col | off | Half duplex operation
 | on | Full duplex operation
 | flashing | Collision

Power Supply

Present supply voltage (24 VDC) is shown by the green power LED.


Support and Service

Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.

Beckhoff's branch offices and representatives

Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!

The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com

You will also find further documentation for Beckhoff components there.

Beckhoff Headquarters

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Germany

Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support

Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:

  • support
  • design, programming and commissioning of complex automation systems
  • and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service

The Beckhoff Service Center supports you in all matters of after-sales service:

  • on-site service
  • repair service
  • spare parts service
  • hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com