EPP9022-0060 - EtherCAT P Box with diagnostics
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.1
▪
Front page updated
1.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT P Box modules

Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Scope of supply
•
Process image


Introduction

Product overview [image] Introduction
Introduction
Inventarbild Website DE -0060
EPP9022-0060
EPP9022-0060 | EtherCAT P Box with diagnostics
The EPP9022-0060 EtherCAT P Box can be used for diagnosing and measuring the voltages US and UP and currents IS and IP, both temporarily during commissioning and permanently during operation. Even without an EtherCAT master, the voltage range is displayed on the box by LEDs (green, yellow and red). In a running EtherCAT network, the values of US, UP, IS and IP can also be read out as process data in the master. The voltage levels for the LED displays can be adjusted by CoE.
In addition the EtherCAT P Box is equipped with an M8 power socket to which an external multimeter can be connected for measuring the voltages.
The EtherCAT P Box modules are characterised by their small and space-saving form factor.
Quick links


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EPP9022-0060
Fieldbus
Fieldbus
EtherCAT
Connection
EtherCAT P: Combined connection for EtherCAT and supply voltages
Input: 1 x M8 socket, 4-pin, P-coded
Downstream connection: 1 x M8 socket, 4-pin, P-coded
Supply voltages
Connection
See Fieldbus connection
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 3 A
Current consumption from US
100 mA at 24 VDC
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 3 A
Measured voltage values
Measuring range
0 .. 32 V 1)
Resolution
10 mV
Representation
Adjustable
▪
1 mV per LSB (factory setting)
▪
1 µV per LSB
Measured current values
Measuring range
0 .. 8 A 1)
Resolution
10 mA
Representation
Adjustable
▪
1 mA per LSB (factory setting)
▪
1 µA per LSB
Voltage measurement output
Input resistance of the measuring device
min. 1 MΩ
Short-circuit proof
yes
Environmental conditions
Ambient temperature during operation
-25…+60 °C
-25…+55 °C according to cULus
Ambient temperature during storage
-40…+85 °C
Vibration / shock resistance
conforms to EN 60068-2-6 / EN 60068-2-27
Additional checks
EMC immunity / emission
conforms to EN 61000-6-2 / EN 61000-6-4
Protection class
IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Installation position
variable
Weight
approx. 90 g
Approvals and conformity
Approvals
CE, cULus
1) The measuring ranges are larger than the permissible voltage and current ranges for continuous operation. However, continuous operation is permitted only within the limits of nominal voltage and sum current.


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP9022-0060 EtherCAT P Box
▪
1x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
1x protective cap for supply voltage output, M8, black (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product overview [image] Process image
Process image
Process image
The process image contains two process data objects:
Process data object | Contents
EPM Inputs Channel 1 | Measured values and status information for the control voltage US
EPM Inputs Channel 2 | Measured values and status information for the peripheral voltage UP
The content of the process data objects is described on the following pages.
EPM Inputs Channel 1
EPP9022-x060 Prozessabbild, EPM Inputs Channel 1, "Voltage"+"Current" ausgegraut
Status
The status bits indicate warnings and errors:
▪
TC3 InputVariable Symbol Voltage min error
Error message in case of undervoltage.
This bit is TRUE if the supply voltage US is lower than CoE index 8000:11 "Voltage min error limit" (unit: mV).
Requirement: CoE parameter 8000:02 "Enable voltage min error" is TRUE.
▪
TC3 InputVariable Symbol Voltage max error
Error message in case of overvoltage.
This bit is TRUE if the supply voltage US is higher than CoE parameter 8000:12 "Voltage max error limit" (unit: mV).
Requirement: CoE parameter 8000:03 "Enable voltage max error" is TRUE.
▪
TC3 InputVariable Symbol Current max error
Error message in case of overcurrent.
This bit is TRUE if the output current IS is higher than CoE parameter 8000:13 "Current max error limit" (unit: mA).
Requirement: CoE parameter 8000:04 "Enable current max Error" is TRUE (default).
▪
TC3 InputVariable Symbol Voltage min warning
Warning message in case of undervoltage.
This bit is TRUE if the supply voltage US is lower than CoE parameter 8000:14 "Voltage min warning limit" (unit: mV).
Requirement: CoE parameter 8000:05 "Enable voltage min warning" is TRUE (default).
▪
TC3 InputVariable Symbol Voltage max warning
Warning message in case of overvoltage.
This bit is TRUE if the supply voltage US is higher than CoE parameter 8000:15 "Voltage max warning limit" (unit: mV).
Requirement: CoE parameter 8000:06 "Enable voltage max warning" is TRUE (default).
▪
TC3 InputVariable Symbol Current max warning
Warning message in case of overcurrent.
This bit is TRUE if the output current IS is higher than CoE parameter 8000:16 "Current max warning limit" (unit: mV).
Requirement: CoE parameter 8000:07 "Enable current max warning" is TRUE (default).
▪
TC3 InputVariable Symbol Channel error
This bit is TRUE if at least one status bit of "EPM Inputs Channel 1" that signals an error message is TRUE:
Voltage min error
Voltage max error
Current max error
▪
TC3 InputVariable Symbol Channel warning
This bit is TRUE if at least one Status bit of "EPM Inputs Channel 1" that signals a warning message is TRUE:
Voltage min warning
Voltage max warning
Current max warning
▪
TC3 InputVariable Symbol TxPDO State
This bit is TRUE if an internal error occurs. The current measured values of "EPM Inputs Channel 1" are invalid if this bit is TRUE.
▪
TC3 InputVariable Symbol TxPDO Toggle
This bit is inverted on each update of the measured values.
EPP9022-x060 Prozessabbild, EPM Inputs Channel 1, "Status" ausgegraut
Voltage
Contents: The measured value of the supply voltage US.
Data type: DINT
Presentation:
Default: 1 mV per LSB (factory setting)
Adjustable in the CoE parameter 8000:17 "Voltage scaling".
Current
Contents: The measured value of the output current IS.
Data type: DINT
Presentation:
1 mA per LSB (factory setting)
Adjustable in the CoE parameter 8000:18 "Current scaling".
EPM Inputs Channel 2
EPP9022-x060 Prozessabbild, EPM Inputs Channel 2, "Voltage"+"Current" ausgegraut
Status
The status bits indicate warnings and errors:
▪
TC3 InputVariable Symbol Voltage min error
Error message in case of undervoltage.
This bit is TRUE if the supply voltage UP is lower than CoE index 8010:11 "Voltage min error limit" (unit: mV).
Requirement: CoE index 8010:02 "Enable voltage min error" is TRUE.
▪
TC3 InputVariable Symbol Voltage max error
Error message in case of overvoltage.
This bit is TRUE if the supply voltage UP is higher than CoE index 8010:12 "Voltage max error limit" (unit: mV).
Requirement: CoE index 8010:03 "Enable voltage max error" is TRUE.
▪
TC3 InputVariable Symbol Current max error
Error message in case of overcurrent.
This bit is TRUE if the output current IP is higher than CoE index 8010:13 "Current max error limit" (unit: mA).
Requirement: CoE index 8010:04 "Enable current max Error" is TRUE (default).
▪
TC3 InputVariable Symbol Voltage min warning
Warning message in case of undervoltage.
This bit is TRUE if the supply voltage UP is lower than CoE index 8010:14 "Voltage min warning limit" (unit: mV).
Requirement: CoE index 8010:05 "Enable voltage min warning" is TRUE (default).
▪
TC3 InputVariable Symbol Voltage max warning
Warning message in case of overvoltage.
This bit is TRUE if the supply voltage UP is higher than CoE index 8010:15 "Voltage max warning limit" (unit: mV).
Requirement: CoE index 8010:06 "Enable voltage max warning" is TRUE (default).
▪
TC3 InputVariable Symbol Current max warning
Warning message in case of overcurrent.
This bit is TRUE if the output current IP is higher than CoE index 8010:16 "Current max warning limit" (unit: mV).
Requirement: CoE index 8010:07 "Enable current max warning" is TRUE (default).
▪
TC3 InputVariable Symbol Channel error
This bit is TRUE if at least one status bit of "EPM Inputs Channel 2" that signals an error message is TRUE:
Voltage min error
Voltage max error
Current max error
▪
TC3 InputVariable Symbol Channel warning
This bit is TRUE if at least one Status bit of "EPM Inputs Channel 2" that signals a warning message is TRUE:
Voltage min warning
Voltage max warning
Current max warning
▪
TC3 InputVariable Symbol TxPDO State
This bit is TRUE if an internal error occurs. The current measured values of "EPM Inputs Channel 2" are invalid if this bit is TRUE.
▪
TC3 InputVariable Symbol TxPDO Toggle
This bit is inverted on each update of the measured values.
EPP9022-x060 Prozessabbild, EPM Inputs Channel 2, "Status" ausgegraut
Voltage
Contents: The measured value of the supply voltage UP.
Data type: DINT
Presentation:
Default: 1 mV per LSB (factory setting)
Adjustable in the CoE index 8010:17 "Voltage scaling".
Current
Contents: The measured value of the output current IP.
Data type: DINT
Presentation:
1 mA per LSB (factory setting)
Adjustable in the CoE index 8010:18 "Current scaling".


Mounting and connections

Mounting and connections
Mounting and connections
Additional information
•
Mounting
•
Connections
•
UL Requirements


Mounting

Mounting and connections [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)


Dimensions

Mounting and connections [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 86 x 30 x 22 mm
Weight | approx. 90 g


Fixing

Mounting and connections [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Mounting and connections [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


Connections

Mounting and connections [image] Connections
Connections
Additional information
•
Connector overview
•
EtherCAT P
•
Voltage measurement output


Connector overview

Mounting and connections [image] Connections [image] Connector overview
Connector overview
Connector overview
Name | Connector type | Tightening torque | Function
X50 | M8 socket, p-coded | 0.4 Nm | EtherCAT P input
X51 | M8 socket, p-coded | 0.4 Nm | EtherCAT P downstream connection
X61 | M8 socket | 0.4 Nm 1) | Voltage measurement output
1) Mount connectors on these plug connectors using a torque wrench, e.g. ZB8801 from Beckhoff.
Protective caps
▪
Seal unused connectors with protective caps.
▪
Ensure the correct seating of pre-assembled protective caps.
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.


EtherCAT P

Mounting and connections [image] Connections [image] EtherCAT P
EtherCAT P
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connections [image] Connections [image] EtherCAT P [image] Connectors
Connectors
Plug connectors for EtherCAT P
1 - input
2 - downstream connection
Connection
M8 socket EPP connection
M8 socket, P-coded
Contact | Signal | Voltage | Core color 1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: Control voltage, +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.


Status LEDs

Mounting and connections [image] Connections [image] EtherCAT P [image] Status LEDs
Status LEDs
Additional information
•
Supply voltages
•
EtherCAT


Supply voltages

Mounting and connections [image] Connections [image] EtherCAT P [image] Status LEDs [image] Supply voltages
Supply voltages
Status LEDs for the supply voltages
EtherCAT P Box Modules have two LEDs that display the status of the supply voltages. The status LEDs are labelled with the designations of the supply voltages: Us and Up.
A status LED lights up green when the respective supply voltage is present.
A Status LED lights up red if the respective supply voltage is short-circuited.


EtherCAT

Mounting and connections [image] Connections [image] EtherCAT P [image] Status LEDs [image] EtherCAT
EtherCAT
ECAT P interface
Status LEDs for EtherCAT
L/A (Link/Act)
A green LED labelled "L/A" or “Link/Act” is located next to each EtherCAT/EtherCAT P socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Conductor losses

Mounting and connections [image] Connections [image] EtherCAT P [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Use the planning tool for EtherCAT P in TwinCAT.
Voltage drop on the supply line
Leitungsverluste M8-EPP 3A
Voltage drop on the supply line


Voltage measurement output

Mounting and connections [image] Connections [image] Voltage measurement output
Voltage measurement output
You can check the supply voltages manually at the voltage measurement output, for example using a multimeter.
An unsuitable measuring device can falsify the measurement.
The measurement will be falsified if the input resistance of the connected measuring device is too small.
•
Use a measuring device that meets the requirements in the technical data.
The measurement output cannot be used as a supply voltage output
The output voltages will collapse if they are loaded.
•
Do not use the measurement output as a supply voltage output.
If you wish to decouple the supply voltages from an EtherCAT P signal, use an EPP9001-0060, for example.
M8 socket, 4-pin – connection
Voltage measurement output, M8 socket
Contact | Potential | Description | Core color 1)
1 | US1 | Control voltage | Brown
2 | UP1 | Peripheral voltage | White
3 | GNDS | Reference ground to US1 | Blue
4 | GNDP | Reference ground to UP1 | Black
1) The core colors apply to cables of the type: Beckhoff ZK2020-xxxx-xxxx


UL Requirements

Mounting and connections [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning and configuration

Commissioning and configuration
Commissioning and configuration
Additional information
•
Integration in TwinCAT
•
Measured values
•
Warning and error messages
•
LEDs
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning and configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Measured values

Commissioning and configuration [image] Measured values
Measured values
Additional information
•
Representation
•
Filter


Representation

Commissioning and configuration [image] Measured values [image] Representation
Representation
▪
All measured voltage values are represented in mV / LSB in the factory setting.
They can optionally also be represented in µV / LSB.
▪
All measured current values are represented in mA / LSB in the factory setting.
They can optionally also be represented in µA / LSB.
The type of representation has no effect on the resolution of the measured values.
You can set the representation of the measured values individually for each measured value:
Input channel |  | CoE parameters for setting the representation
 |  | for the measured voltage value | for the measured current value
1 | Control voltage US | 8000:17 "Voltage scaling" | 8000:18 "Current scaling"
2 | Peripheral voltage UP | 8010:17 "Voltage scaling" | 8010:18 "Current scaling"


Filter

Commissioning and configuration [image] Measured values [image] Filter
Filter
The measured value of each input channel can be filtered with a digital filter.
Enable filter
Note
Measured value jumps when enabling or disabling filters
When filters are enabled or disabled, short-term measured value jumps can occur in the process data that do not correspond to the physical values.
You can enable the filter individually for each input channel. All filters are disabled in the factory setting.
Enable the filters by setting the following CoE parameters to TRUE:
Input channel |  | CoE parameters for enabling the filter
1 | Control voltage US | 8000:01 "Enable filter"
2 | Peripheral voltage UP | 8010:01 "Enable filter"
Select filter characteristic
You can select the filter characteristic individually for each input. Factory setting: "50 Hz FIR".
Input channel |  | CoE parameter for selecting the filter characteristic
1 | Control voltage US | 8000:19 "Filter characteristic"
2 | Peripheral voltage UP | 8010:19 "Filter characteristic"
There is a choice of two filter types:
FIR filter
The filter works as a notch filter and determines the conversion time of the module. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies.
The FIR filter operates as a non-recursive filter.
IIR filter
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter)
The IIR can be understood to be a moving average value calculation after a low-pass filter.


Warning and error messages

Commissioning and configuration [image] Warning and error messages
Warning and error messages
Warning messages and error messages inform you of potentially critical operating states. EPP9022 signals warning messages and error messages in two ways:
▪
Status bits
▪
LEDs
There are two categories of messages:
▪
A warning message is output if a measured value (current, voltage) is borderline. However, continuous operation is still possible under unchanged conditions.
▪
An error message is output if continuous operation under unchanged conditions could lead to a defect or to the tripping of a safety device.
The following diagrams show the threshold values for warning messages and error messages in the factory setting.
Threshold values for supply voltages (factory setting)
Threshold values for supply voltages (factory setting)
Threshold values for output currents (factory setting)
Threshold values for output currents (factory setting)
Additional information
•
Set the threshold values
•
Disabling messages


Set the threshold values

Commissioning and configuration [image] Warning and error messages [image] Set the threshold values
Set the threshold values
Note
Critical operating states may not be reported under certain circumstances.
If you set the threshold values for warning messages and error messages incorrectly, EPP9022 may not inform you of critical operating states:
overcurrent, overvoltage, undervoltage.
•
Be very careful when changing the threshold values.
•
Enlarge the permissible range only if you have good reasons to do so.
You can set the threshold values for warning messages and error messages via the CoE parameters shown in the following tables. Observe the recommended value range.
Input channel 1: Control voltage US
Reason for message | Type of message | CoE parameters for setting the threshold value | Unit | Recommended value range | Factory setting
Undervoltage | Warning message | 8000:14 "Voltage min warning limit" | mV | min. 20400dec | 20400dec
 | Error message | 8000:11 "Voltage min error limit" | mV | min. 18000dec | 18000dec
Overvoltage | Warning message | 8000:15 "Voltage max warning limit" | mV | max. 28800dec | 28800dec
 | Error message | 8000:12 "Voltage max error limit" | mV | max. 30000dec | 30000dec
Overcurrent | Warning | 8000:16 "Current max warning limit" | mA | 0 .. 2500dec | 2500dec
 | Error message | 8000:13 "Current max error limit" | mA | 0 .. 3000dec | 3000dec
Input channel 2: Peripheral voltage UP
Reason for message | Type of message | CoE parameters for setting the threshold value | Unit | Recommended value range | Factory setting
Undervoltage | Warning message | 8010:14 "Voltage min warning limit" | mV | min. 20400dec | 20400dec
 | Error message | 8010:11 "Voltage min error limit" | mV | min. 18000dec | 18000dec
Overvoltage | Warning message | 8010:15 "Voltage max warning limit" | mV | max. 28800dec | 28800dec
 | Error message | 8010:12 "Voltage max error limit" | mV | max. 30000dec | 30000dec
Overcurrent | Warning | 8010:16 "Current max warning limit" | mA | 0 .. 2500dec | 2500dec
 | Error message | 8010:13 "Current max error limit" | mA | 0 .. 3000dec | 3000dec


Disabling messages

Commissioning and configuration [image] Warning and error messages [image] Disabling messages
Disabling messages
Note
Critical operating states may not be reported under certain circumstances.
If you disable warning messages or error messages, EPP9022 will no longer inform you of critical operating states:
overcurrent, overvoltage, undervoltage.
•
Disable warning messages or error messages only if you have good reasons to do so.
You can disable the corresponding warning message/error message for each threshold value. All warning messages and error messages are enabled in the factory setting.
To disable a warning message or error message, search for the CoE parameter for the desired message in the tables below and set it to FALSE:
Input channel 1: Control voltage US
Reason for message | Type of message | CoE parameter for enabling/ disabling the message
Undervoltage | Warning message | 8000:05 "Enable voltage min warning"
 | Error message | 8000:02 "Enable voltage min error"
Overvoltage | Warning message | 8000:06 "Enable voltage max warning"
 | Error message | 8000:03 "Enable voltage max error"
Overcurrent | Warning message | 8000:07 "Enable current max warning"
 | Error message | 8000:04 "Enable current max error"
Input channel 2: Peripheral voltage UP
Reason for message | Type of message | CoE parameter for enabling/ disabling the message
Undervoltage | Warning message | 8010:05 "Enable voltage min warning"
 | Error message | 8010:02 "Enable voltage min error"
Overvoltage | Warning message | 8010:06 "Enable voltage max warning"
 | Error message | 8010:03 "Enable voltage max error"
Overcurrent | Warning message | 8010:07 "Enable current max warning"
 | Error message | 8010:04 "Enable current max error"


LEDs

Commissioning and configuration [image] LEDs
LEDs
LEDs signal warning messages and error messages. There are three LEDs for each input channel (US / UP):
▪
Green = no message
▪
Yellow = warning message. At least one warning threshold value has been exceeded.
▪
Red = error message. At least one error threshold value has been exceeded.
Assignment of the LEDs
Precisely one LED lights up per input channel at any one time. If warning messages and error messages are present simultaneously, only the red LED lights up.
Check the Status bits in order to further localize the cause of the warning message or error message.
You can also use the LEDs for offline diagnostics: The LEDs are also active if no EtherCAT Master is present.
You can influence the behavior of the LEDs:
▪
Change threshold values.
▪
Disable individual warning messages and error messages.
▪
Limit LED display to currents or voltages: LED filter.
Additional information
•
LED filter


LED filter

Commissioning and configuration [image] LEDs [image] LED filter
LED filter
Note
Critical operating states may not be displayed under certain circumstances.
If you filter out messages with the LED filter, critical operating states may no longer be displayed by the LEDs under certain circumstances.
•
Only use the LED filter if you have good reasons to do so.
Use the LED filter if you do not wish certain messages to be displayed by the LEDs. The LED filter can filter out two types of message:
▪
Messages that concern currents.
▪
Messages that concern voltages.
The LED filter can be set individually for each input channel:
Input channel |  | CoE parameters for setting the LED filter
1 | Control voltage US | 8000:1A "LED filter"
2 | Peripheral voltage UP | 8010:1A "LED filter"
The following options are available:
Value | Enum | Description
0 | "Voltage and current" | The LEDs signal all messages.
1 | "Voltage only" | The LEDs signal only messages that concern currents.
2 | "Current only" | The LEDs signal only messages that concern voltages.
255dec | "LEDs off" | All LEDs are off.


Restoring the delivery state

Commissioning and configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning and configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


CoE parameters

CoE parameters
CoE parameters
Additional information
•
Introduction
•
Object overview
•
Object description


Introduction

CoE parameters [image] Introduction
Introduction
Additional information
•
Accessing CoE parameters with TwinCAT
•
Data format of CoE parameters


Accessing CoE parameters with TwinCAT

CoE parameters [image] Introduction [image] Accessing CoE parameters with TwinCAT
Accessing CoE parameters with TwinCAT
Manueller Zugriff auf das Parameter-Verzeichnis
Accessing CoE parameters with TwinCAT
➢
Requirement: EPP9022-0060 exists as an IO module in the Solution Explorer under the menu item "IO".
1.
Click the IO module of the EPP9022-0060 in the Solution Explorer.
2.
Click on the "CoE - Online" tab.
⇨
You will see the parameter directory of the EPP9022-0060, where you can check and adjust parameters.


Data format of CoE parameters

CoE parameters [image] Introduction [image] Data format of CoE parameters
Data format of CoE parameters
CoE parameters have different data formats.
The data format of the CoE parameters is specified by data type identifiers in the chapter Object description:
Data type identifier | Format | Size
BOOL | True / false | 8-bit
SINT | Short integer | 8-bit
USINT | Unsigned short integer | 8-bit
INT | Integer | 16-bit
UINT | Unsigned integer | 16-bit
DINT | Double integer | 32-bit
UDINT | Unsigned double integer | 32-bit
STRING | String | max. 255 characters, 1 byte per character
The data type identifiers correspond to the data types that can also be used in TwinCAT in a PLC program.


Object overview

CoE parameters [image] Object overview
Object overview
Index (hex) | Name
1000 | Device type
1008 | Device name
1009 | Hardware version
100A | Software version
100B | Bootloader version
1011 | Restore default parameters
1018 | Identity
10F0 | Backup parameter handling
1A00 | EPM TxPDO-Map Inputs Ch.1
1A01 | EPM TxPDO-Map Inputs Ch.2
1C00 | Sync manager type
1C12 | RxPDO assign
1C13 | TxPDO assign
1C33 | SM input parameter
6000 | EPM Inputs Ch.1
6010 | EPM Inputs Ch.2
8000 | EPM Settings Ch.1
800F | EPM Vendor data Ch.1
8010 | EPM Settings Ch.2
801F | EPM Vendor data Ch.2
A000 | EPM Diag data Ch.1
A010 | EPM Diag data Ch.2
F000 | Modular device profile
F008 | Code word
F010 | Module list
FB00 | Command


Object description

CoE parameters [image] Object description
Object description
Additional information
•
Objects to be parameterized during commissioning
•
Profile-specific objects
•
Standard objects


Objects to be parameterized during commissioning

CoE parameters [image] Object description [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 8000 EPM Settings Ch.1
Access rights: read/write
Subindex (hex) | Name | Description | Unit | Data type | Default
01 | Enable Filter | Enables the measured value filter | - | BOOL | FALSE
02 | Enable voltage min error | Enables the error message in case of undervoltage | - | BOOL | TRUE
03 | Enable voltage max error | Enables the error message in case of overvoltage | - | BOOL | TRUE
04 | Enable current max error | Enables the error message in case of overcurrent | - | BOOL | TRUE
05 | Enable voltage min warning | Enables the warning message in case of undervoltage | - | BOOL | TRUE
06 | Enable voltage max warning | Enables the warning message in case of overvoltage | - | BOOL | TRUE
07 | Enable current max warning | Enables the warning message in case of overcurrent | - | BOOL | TRUE
11 | Voltage min error limit | Threshold value for the undervoltage error message | mV | UDINT | 18000dec
12 | Voltage max error limit | Threshold value for the overvoltage error message | mV | UDINT | 30000dec
13 | Current max error limit | Threshold value for the overcurrent error message | mA | UDINT | 3000dec
14 | Voltage min warning limit | Threshold value for the undervoltage warning message | mV | UDINT | 20400dec
15 | Voltage max warning limit | Threshold value for the overvoltage warning message | mV | UDINT | 28800dec
16 | Current max warning limit | Threshold value for the overcurrent warning message | mA | UDINT | 2500dec
17 | Voltage scaling | Representation of the measured voltage value. 0: 1 mV per LSB (factory setting) 1: 1 µV per LSB | - | UINT | 0
18 | Current scaling | Representation of the measured current value. 0: 1 mA per LSB (factory setting) 1: 1 µA per LSB | - | UINT | 0
19 | Filter characteristic | Filter characteristic of the measured value filter. 0: 50 Hz FIR (factory setting) 1: 60 Hz FIR 2: IIR1 3: IIR2 4: IIR3 5: IIR4 6: IIR5 7: IIR6 8: IIR7 9: IIR8 | - | UINT | 0
1A | LED filter | LED filter 0: "Voltage and current" (factory setting) 1: “Voltage only” 2: “Current only” 255dec: “LEDs off” | - | UINT | 0
Index 8010 EPM Settings Ch.2
Access rights: read/write
Subindex (hex) | Name | Description | Unit | Data type | Default
01 | Enable Filter | Enables the measured value filter | - | BOOL | FALSE
02 | Enable voltage min error | Enables the error message in case of undervoltage | - | BOOL | TRUE
03 | Enable voltage max error | Enables the error message in case of overvoltage | - | BOOL | TRUE
04 | Enable current max error | Enables the error message in case of overcurrent | - | BOOL | TRUE
05 | Enable voltage min warning | Enables the warning message in case of undervoltage | - | BOOL | TRUE
06 | Enable voltage max warning | Enables the warning message in case of overvoltage | - | BOOL | TRUE
07 | Enable current max warning | Enables the warning message in case of overcurrent | - | BOOL | TRUE
11 | Voltage min error limit | Threshold value for the undervoltage error message | mV | UDINT | 18000dec
12 | Voltage max error limit | Threshold value for the overvoltage error message | mV | UDINT | 30000dec
13 | Current max error limit | Threshold value for the overcurrent error message | mA | UDINT | 3000dec
14 | Voltage min warning limit | Threshold value for the undervoltage warning message | mV | UDINT | 20400dec
15 | Voltage max warning limit | Threshold value for the overvoltage warning message | mV | UDINT | 28800dec
16 | Current max warning limit | Threshold value for the overcurrent warning message | mA | UDINT | 2500dec
17 | Voltage scaling | Representation of the measured voltage value. 0: 1 mV per LSB (factory setting) 1: 1 µV per LSB | - | UINT | 0
18 | Current scaling | Representation of the measured current value. 0: 1 mA per LSB (factory setting) 1: 1 µA per LSB | - | UINT | 0
19 | Filter characteristic | Filter characteristic of the measured value filter. 0: 50 Hz FIR (factory setting) 1: 60 Hz FIR 2: IIR1 3: IIR2 4: IIR3 5: IIR4 6: IIR5 7: IIR6 8: IIR7 9: IIR8 | - | UINT | 0
1A | LED filter | LED filter 0: "Voltage and current" (factory setting) 1: “Voltage only” 2: “Current only” 255dec: “LEDs off” | - | UINT | 0


Profile-specific objects

CoE parameters [image] Object description [image] Profile-specific objects
Profile-specific objects
Index 6000 EPM Inputs Ch.1
Access rights: read only
Subindex (hex) | Name | Description | Data type
01 | Voltage min error | Input process data. See Process image. | BOOL
02 | Voltage max error |  | BOOL
03 | Current max error |  | BOOL
04 | Voltage min warning |  | BOOL
05 | Voltage max warning |  | BOOL
06 | Current max warning |  | BOOL
07 | Channel error |  | BOOL
11 | Channel warning |  | BOOL
12 | TxPDO State |  | BOOL
13 | TxPDO Toggle |  | BOOL
14 | Voltage |  | DINT
15 | Current |  | DINT
Index 6010 EPM Inputs Ch.2
Access rights: read only
Subindex (hex) | Name | Description | Data type
01 | Voltage min error | Input process data. See Process image. | BOOL
02 | Voltage max error |  | BOOL
03 | Current max error |  | BOOL
04 | Voltage min warning |  | BOOL
05 | Voltage max warning |  | BOOL
06 | Current max warning |  | BOOL
07 | Channel error |  | BOOL
11 | Channel warning |  | BOOL
12 | TxPDO State |  | BOOL
13 | TxPDO Toggle |  | BOOL
14 | Voltage |  | DINT
15 | Current |  | DINT
Index 800F EPM Vendor data Ch.1
Access rights: read only
Subindex (hex) | Name | Description | Data type
01 | Voltage calibration offset | Calibration coefficients of the vendor calibration. | INT
02 | Voltage calibration gain |  | INT
03 | Current calibration offset |  | INT
04 | Current calibration gain |  | INT
Index 801F EPM Vendor data Ch.2
Access rights: read only
Subindex (hex) | Name | Description | Data type
01 | Voltage calibration offset | Calibration coefficients of the vendor calibration. | INT
02 | Voltage calibration gain |  | INT
03 | Current calibration offset |  | INT
04 | Current calibration gain |  | INT
Index A000 EPM Diag data Ch.1
Access rights: read only
Subindex (hex) | Name | Description | Unit | Data type
01 | Voltage ADC raw value | Raw value of the voltage measurement | - | UINT
02 | Current ADC raw value | Raw value of the current measurement | - | UINT
Index A010 EPM Diag data Ch.2
Access rights: read only
Subindex (hex) | Name | Description | Unit | Data type
01 | Voltage ADC raw value | Raw value of the voltage measurement | - | UINT
02 | Current ADC raw value | Raw value of the current measurement | - | UINT
Index F000 Modular device profile
Access rights: read only
Subindex (hex) | Name | Description | Data type | Value
01 | Module index distance | Offset between the indices of the parameter objects of two channels | UINT | 0x0010
02 | Maximum number of modules | Number of channels | UINT | 2
Index F010 Module list
Access rights: read/write
Subindex (hex) | Name | Description | Data type | Default
01 | SubIndex 001 | Module profile of input channel 1 | UDINT | 380dec
02 | SubIndex 002 | Module profile of input channel 1 | UDINT | 380dec


Standard objects

CoE parameters [image] Object description [image] Standard objects
Standard objects
Index 1000 Device type
Access rights: read only
Subindex (hex) | Name | Description | Unit | Data type | Value
- | Device type | Bit 0 .. 15: Device profile number Bit 16 .. 31: Module profile number (Device profile number 5001: Modular Device Profile MDP) | - | UDINT | 5001dec
Index 1008 Device name
Access rights: read only
Subindex (hex) | Name | Description | Data type | Value
- | Device name | Name of the EtherCAT device | STRING | EPP9022-0060
Index 1009 Hardware version
Access rights: read only
Subindex (hex) | Name | Description | Unit | Data type | Value
- | Hardware version | Hardware version of the EtherCAT device | - | STRING | 1)
1) Refer to Firmware and hardware versions.
Index 100A Software version
Access rights: read only
Subindex (hex) | Name | Description | Unit | Data type | Value
- | Software version | Firmware version of the EtherCAT device | - | STRING | 1)
1) Refer to Firmware and hardware versions.
Index 1011 Restore default parameters
Access rights: read/write
Subindex (hex) | Name | Description | Data type | Default
1 | Subindex 001 | Resets the CoE parameters to the factory settings. To do this, write the value 0x64616F6C in this parameter. | UDINT | 0
Index 1018 Identity
Access rights: read only
Subindex (hex) | Name | Description | Data type | Value
01 | Vendor ID | Vendor identifier (2 = Beckhoff Automation) | UDINT | 2
02 | Product code | Product code | UDINT | 1685584361dec
03 | Revision | Bit 0 .. 15: Index number of the product variant Bit 16 .. 31: Revision of the device description (ESI) | UDINT | Bit 0 .. 15: 0060dec
04 | Serial number | (not used) | UDINT | 0
Index 10F0 Backup parameter handling
Access rights: read only
Subindex (hex) | Name | Description | Data type | Value
01 | Checksum | Checksum of the backup parameters. Backup parameters are the CoE objects whose content is reset to the factory setting by the CoE index 1011. | UDINT | 11102dec


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Ordering information | Description
ZK2020-3xxx-xxxx | Power cable M8, 4-pin link to the website
ZK700x-xxxx-xxxx | EtherCAT P cable M8 Link to website
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com