EPP6228-0022 - IO-Link master
Home
EPP 150dpi (default)


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.1
▪
Titelseite aktualisiert
1.0
▪
Erste Veröffentlichung
0.1
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Weitere Informationen zu diesem Thema: Versionsidentifikation von EtherCAT-Geräten.


Produktgruppe: EtherCAT-P-Box-Module

Produktgruppe: EtherCAT-P-Box-Module
Produktgruppe: EtherCAT-P-Box-Module
EtherCAT P
EtherCAT P ergänzt die EtherCAT-Technologie um ein Verfahren, bei dem Kommunikation und Versorgungsspannungen auf einer gemeinsamen Leitung übertragen werden. Alle Eigenschaften von EtherCAT bleiben bei diesem Verfahren erhalten.
Es werden zwei Versorgungsspannungen pro EtherCAT-P-Leitung übertragen. Die Versorgungsspannungen sind galvanisch voneinander getrennt und sind somit einzeln schaltbar. Die Nennspannung der Versorgungsspannungen ist 24 VDC.
EtherCAT P verwendet den gleichen Leitungs-Aufbau wie EtherCAT: eine 4-adrige Ethernet-Leitung mit M8-Steckverbindern. Die Steckverbinder sind mechanisch codiert, so dass ein Vertauschen von EtherCAT-Steckverbindern und EtherCAT-P-Steckverbindern nicht möglich ist.
EtherCAT-P-Box-Module
EtherCAT-P-Box-Module sind EtherCAT-P-Slaves in Schutzart IP67. Sie sind vorgesehen für den Betrieb in nassen, schmutzigen oder staubigen Industrie-Umgebungen.
EtherCAT P Einführung
EtherCAT P
EtherCAT Grundlagen
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der EtherCAT System-Dokumentation.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
IO-Link Master Grundlagen
•
Technische Daten
•
Lieferumfang
•
Prozessabbild


Einführung

Produktübersicht [image] Einführung
Einführung
Inventarbild Website EPP6228
EPP6228-0022
IO-Link-Master
Das IO-Link-Modul EPP6228 ermöglicht den Anschluss von bis zu acht IO-Link-Teilnehmern, den sogenannten IO-Link-Devices. Dies können IO-Link-Box-Module, Aktoren, Sensoren oder Kombinationen aus beiden sein. Die Verbindung zwischen dem Modul und dem Teilnehmer erfolgt als Punkt-zu-Punkt-Verbindung. Die EtherCAT-P-Box wird über den EtherCAT-Master parametriert. IO-Link ist als intelligentes Bindeglied zwischen der Feldbusebene und dem Sensor angelegt, wobei Parametrierungsinformationen über die IO-Link-Verbindung bidirektional ausgetauscht werden können. Die Parametrierung der IO-Link-Devices mit Servicedaten kann aus TwinCAT heraus über ADS erfolgen oder sehr komfortabel über das integrierte IO-Link-Konfigurationstool. Neben den IO-Link-Kanälen verfügt die EPP6228 über acht digitale Eingänge auf dem Pin 2 der jeweiligen M12-Buchse. In der Standardeinstellung akzeptieren die IO-Link-Kanäle C/Qx der EPP6228 sowohl IO-Link-Devices als auch Standardsensoren mit 24 V DC.
Quick Links


IO-Link Master Grundlagen

Produktübersicht [image] IO-Link Master Grundlagen
IO-Link Master Grundlagen
Weiterführende Informationen
•
Topologie
•
Parameter-Speicher


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte über den gesamten Temperaturbereich, wenn nicht anders angegeben.
Technische Daten | EPP6228-0022
Feldbus
Feldbus | EtherCAT
Anschluss | EtherCAT P: Kombinierter Anschluss für EtherCAT und Versorgungsspannungen Einspeisung: 1 x M8-Buchse, P-kodiert, rot Weiterleitung: 1 x M8-Buchse, P-kodiert, rot
Versorgungsspannungen
Anschluss | Siehe Feldbus-Anschluss
Steuerspannung US
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 3 A 1)
Verbraucher | • Modulelektronik: 100 mA • IO-Link Devices
Peripheriespannung UP
Nennspannung | 24 VDC (-15 % / +20 %)
Summenstrom | max. 3 A 1)
Verbraucher | -
IO-Link
Anzahl Ports | 8x Class A
Anschluss | 8x M12-Buchse
Kabellänge | max. 20 m
Spezifikation | IO-Link V1.1
Datenrate | COM1: 4,8 kbit/s COM2: 38,4 kbit/s COM3: 230,4 kbit/s
Device-Versorgung | 24 VDC aus der Steuerspannung US max. 1,4 A pro Port, kurzschlussfest max. 3,0 A in Summe
Digitaler Eingang I/Q
Charakteristik | Typ 3 gemäß EN 61131-2, kompatibel mit Typ 1
Filter | 10 µs
Eingangsstrom | 3,0 mA
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25…+60°C -25…+55°C gemäß cURus
Umgebungstemperatur bei Lagerung | -40…+85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung.
Technische Daten | EPP6228-0022
Mechanik
Gewicht | ca. 250 g
Einbaulage | beliebig
Zulassungen und Konformität
Zulassungen | CE, cULus
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT P Box EPP6228-0022
▪
2x Schutzkappe für EtherCAT-P-Buchse, M8, rot (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Zuordnung von IO-Link Ports zu Prozessdaten
Prozessabbild in TwinCAT | IO-Link Port | Status-Variable | Prozessdaten des IO-Link Device | Digitaler Eingang
EP6228-0022 Prozessabbild | 1 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch1 | TC3 IO-Link-Modul Symbol Module 3 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch1
 | 2 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch2 | TC3 IO-Link-Modul Symbol Module 4 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch2
 | 3 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch3 | TC3 IO-Link-Modul Symbol Module 5 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch3
 | 4 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch4 | TC3 IO-Link-Modul Symbol Module 6 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch4
 | 5 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch5 | TC3 IO-Link-Modul Symbol Module 7 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch5
 | 6 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch6 | TC3 IO-Link-Modul Symbol Module 8 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch6
 | 7 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch7 | TC3 IO-Link-Modul Symbol Module 9 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch7
 | 8 | TC3 IO-Link-Modul Symbol Module 2 TC3 InputPDO Symbol indent DeviceState Inputs TC3 InputVariable Symbol indent-indent State Ch8 | TC3 IO-Link-Modul Symbol Module 10 1) | TC3 IO-Link-Modul Symbol Module 11 TC3 InputPDO Symbol indent Digital Inputs TC3 InputVariable Symbol indent-indent Pin2 Ch8
1) Die Module „Module 3“ bis „Module 10“ sind nur in den Prozessdaten vorhanden, wenn die entsprechenden IO-Link Ports konfiguriert wurden.


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
Funktionserdung
•
Verkabelung
•
UL-Anforderungen


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 60 x 26,5 mm
Gewicht | ca. 250 g


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern.


Funktionserdung

Montage und Verkabelung [image] Funktionserdung
Funktionserdung
Die Befestigungslöcher dienen gleichzeitig als Anschluss für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über die Anschlüsse für die Funktionserdung (FE) niederimpedant geerdet ist. Das erreichen Sie z.B., indem Sie die Box an einem geerdeten Maschinenbett montieren.
Anschluss für die Funktionserdung (FE)


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Anzugsdrehmomente für Steckverbinder
Schrauben Sie Steckverbinder mit einem Drehmomentschlüssel fest. (z.B. ZB8801 von Beckhoff)
Steckverbinder-Durchmesser | Anzugsdrehmoment
M8 | 0,4 Nm
M12 | 0,6 Nm
Weiterführende Informationen
•
EtherCAT P
•
IO-Link


EtherCAT P

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P
EtherCAT P
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Steckverbinder
Steckverbinder
Hinweis
Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT/EtherCAT-P-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung von EtherCAT P, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 3 A nicht überschritten wird!
Die Einspeisung und Weiterleitung von EtherCAT P erfolgt über zwei M8-Buchsen am oberen Ende der Module:
▪
IN: linke M8-Buchse zur Einspeisung von EtherCAT P
▪
OUT: rechte M8-Buchse zur Weiterleitung von EtherCAT P
Steckverbinder für EtherCAT P
M8-Buchse EPP Kontaktbelegung
M8-Buchse, P-kodiert
Kontakt | Signal | Spannung | Aderfarben1)
1 | Tx + | GNDS | gelb
2 | Rx + | GNDP | weiß
3 | Rx - | UP: Peripheriespannung, +24 VDC | blau
4 | Tx - | US: Steuerspannung, +24 VDC | orange
Gehäuse | Schirm | Schirm | Schirm
1) Die Aderfarben gelten für EtherCAT-P-Leitungen und ECP-Leitungen von Beckhoff.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs
Status-LEDs
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT


Versorgungsspannungen

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs [image] Versorgungsspannungen
Versorgungsspannungen
Status-LEDs für die Spannungsversorgung
EtherCAT-P-Box-Module haben zwei LEDs, die den Status der Versorgungsspannungen anzeigen. Die Status-LEDs sind mit den Bezeichnungen der Versorgungsspannungen beschriftet: Us und Up.
Eine Status-LED leuchtet grün, wenn die jeweilige Versorgungsspannung vorhanden ist.
Eine Status-LED leuchtet rot, wenn die jeweilige Versorgungsspannung kurzgeschlossen ist.


EtherCAT

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Status-LEDs [image] EtherCAT
EtherCAT
Status-LEDs für EtherCAT
L/A (Link/Act)
Neben jeder EtherCAT-/EtherCAT-P-Buchse befindet sich eine grüne LED, die mit „L/A“ oder „Link/Act“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungsverluste

Montage und Verkabelung [image] Verkabelung [image] EtherCAT P [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Nutzen Sie das Planungstool für EtherCAT-P in TwinCAT.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8-EPP 3A
Spannungsabfall an der Versorgungs-Zuleitung


IO-Link

Montage und Verkabelung [image] Verkabelung [image] IO-Link
IO-Link
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs


Steckverbinder

Montage und Verkabelung [image] Verkabelung [image] IO-Link [image] Steckverbinder
Steckverbinder
Die IO-Link Ports sind als M12-Buchsen ausgeführt.
M12-Buchse
Kontakt | Funktion | Beschreibung | Aderfarbe 1)
1 | L+ | Versorgungsspannung (US1) | braun
2 | DI | Digitaler Eingang | weiß
3 | L- | GND | blau
4 | C/Q | IO-Link Datenleitung | schwarz
5 | - | - | grau
1) Die Aderfarben gelten für M12-Sensorleitungen von Beckhoff:
▪
ZK2000-5xxx
▪
ZK2000-6xxx
▪
ZK2000-7xxx.


Status-LEDs

Montage und Verkabelung [image] Verkabelung [image] IO-Link [image] Status-LEDs
Status-LEDs
IO-Link Port LEDs
Status-LEDs eines IO-Link Ports
1 - IO-Link
LED-Signal
Bedeutung
aus
Möglichkeiten:
▪
Port nicht konfiguriert
▪
Logikpegel Low 1)
leuchtet rot
blinkt vereinzelt grün
Möglichkeiten:
▪
IO-Link Verbindungsversuch
▪
Kein IO-Link Device angeschlossen
▪
Falsches IO-Link Device angeschlossen
▪
IO-Link Device defekt
blinkt grün
IO-Link Kommunikation aktiv
leuchtet grün
Logikpegel High 1)
1) Port konfiguriert als digitaler Eingang oder Ausgang
2 - Digitaler Eingang DI
Die LED leuchtet, wenn ein High-Pegel am digitalen Eingang DI anliegt.


UL-Anforderungen

Montage und Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Einbinden in ein TwinCAT-Projekt
•
IO-Link Konfiguration
•
Diagnose


Einbinden in ein TwinCAT-Projekt

Inbetriebnahme und Konfiguration [image] Einbinden in ein TwinCAT-Projekt
Einbinden in ein TwinCAT-Projekt
Die Vorgehensweise zum Einbinden in ein TwinCAT-Projekt ist in dieser Schnellstartanleitung beschrieben.


IO-Link Konfiguration

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration
IO-Link Konfiguration
Weiterführende Informationen
•
Konfigurationstool öffnen
•
Devices zu Ports zuweisen
•
Device-Katalog ergänzen
•
Einen Port parametrieren
•
Ein Device parametrieren
•
Einen Port als digitalen Eingang/Ausgang konfigurieren
•
Konfiguration aktivieren


Konfigurationstool öffnen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Konfigurationstool öffnen
Konfigurationstool öffnen
➢
Voraussetzung: ein IO-Link Master ist im Solution Explorer unter dem Eintrag „I/O“ angefügt.
1.
Doppelklicken Sie auf den IO-Link Master.
⇨
Der Geräte-Editor für den IO-Link Master öffnet sich.
2.
Klicken Sie auf den Karteireiter „IO-Link“.
⇨
Das IO-Link Konfigurationstool öffnet sich.
IO-Link Konfigurationstool mit Markierung
Übersicht
Das Konfigurationstool enthält zwei Felder:
▪
„Ports“
Das linke Feld „Ports“ zeigt eine Liste der Ports des IO-Link Masters. Wenn einem Port ein Device zugewiesen ist, steht neben dem Port die Bezeichnung des Device.
▪
„Catalog“
Das rechte Feld „Catalog“ zeigt den Device-Katalog. Der Device-Katalog enthält eine Liste der IO-Link Devices, für die in der lokalen TwinCAT-Installation eine Gerätebeschreibung vorhanden ist.
Änderungen im IO-Link Konfigurationstool werden erst wirksam, wenn Sie die IO-Link Konfiguration aktivieren.


Devices zu Ports zuweisen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Devices zu Ports zuweisen
Devices zu Ports zuweisen
Es gibt vier Möglichkeiten, Devices zu Ports zuzuweisen:
Ein Device aus dem Device-Katalog auswählen
1.
Suchen Sie das gewünschte Device im Feld „Catalog“.
Nicht vorhanden? Device-Katalog ergänzen.
2.
Weisen Sie das Device einem Port zu. Dazu gibt es zwei Möglichkeiten:
- Ziehen Sie das Device per Drag-and-drop auf den gewünschten Port.
- Klicken Sie mit der rechten Maustaste auf das Device
Klicken Sie im Kontextmenü auf „Add to Port n“.
⇨
Das Device wird dem Port zugewiesen
Eine Gerätebeschreibungs-Datei IODD importieren
1.
Device-Katalog ergänzen > „Import aus dem Dateisystem“
2.
Ein Device aus dem Device-Katalog auswählen
⇨
Das Device wird dem Port zugewiesen
Devices scannen
➢
Voraussetzung: der Master und die Devices sind verkabelt und mit Spannung versorgt.
1.
Klicken Sie auf die Schaltfläche „Scan Devices“.
⇨
Der IO-Link Master fordert alle angeschlossenen Devices auf, sich zu identifizieren. Jedes erkannte Device wird automatisch dem Port zugewiesen, an dem es angeschlossen ist.
Eine Gerätebeschreibung manuell eintragen
1.
Klicken Sie mit der rechten Maustaste auf einen Port.
2.
Klicken Sie im Kontextmenü auf „Create Device“.
⇨
Ein Dialogfenster öffnet sich.
3.
Tragen Sie die Informationen ein, die das IO-Link Device beschreiben.


Device-Katalog ergänzen

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Device-Katalog ergänzen
Device-Katalog ergänzen
Der Device-Katalog enthält nach der Installation von TwinCAT nur die Gerätebeschreibungen von IO-Link Devices von Beckhoff. Es gibt zwei Möglichkeiten, den Katalog zu ergänzen:
Import aus der Online-Datenbank „IODDfinder“
➢
Voraussetzung: der PC kann auf das Internet zugreifen
1.
Klicken Sie auf die Schaltfläche „IODD Finder“.
2.
Suchen Sie das gewünschte Device.
3.
Klicken Sie auf das Bild in der Spalte „Picture“.
⇨
Die Gerätebeschreibung wird heruntergeladen und in den Device-Katalog eingefügt.
Import aus dem Dateisystem
1.
Klicken Sie auf die Schaltfläche „Import Devicedescription“
2.
Öffnen Sie in dem erscheinenden Dialogfenster eine Gerätebeschreibungs-Datei (IODD)
⇨
Die Gerätebeschreibung wird in den Device-Katalog eingefügt.


Einen Port parametrieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Einen Port parametrieren
Einen Port parametrieren
➢
Voraussetzung: Dem Port ist ein Device zugewiesen. Devices zu Ports zuweisen.
1.
Klicken Sie im Feld „Ports“ mit der rechten Maustaste auf den Port
2.
Klicken Sie im Kontextmenü auf „Settings“
⇨
Die Registerkarte „Settings“ öffnet sich


Ein Device parametrieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Ein Device parametrieren
Ein Device parametrieren
➢
Voraussetzung: Das Device ist einem Port zugewiesen. Devices zu Ports zuweisen.
1.
Klicken Sie im Feld „Ports“ mit der rechten Maustaste auf das Device
2.
Klicken Sie auf „Parameter“
⇨
Die Registerkarte „Parameter“ öffnet sich
Schaltflächen
▪
„Read“
Werte der Parameter aus dem Device auslesen.
▪
„Write“
Werte der Parameter in das Device schreiben.
▪
„Set default“
Die Werte der Device-Parameter auf die Standardwerte zurücksetzen. Die Standardwerte werden aus der Gerätebeschreibung im Device-Katalog übernommen.
▪
„Store“
Die aktuellen Werte der Device-Parameter im Master speichern. Funktion „Data Storage“.


Einen Port als digitalen Eingang/Ausgang konfigurieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Einen Port als digitalen Eingang/Ausgang konfigurieren
Einen Port als digitalen Eingang/Ausgang konfigurieren
IO-Link Ports können auch als digitaler Eingang oder digitaler Ausgang konfiguriert werden. So können digitale Sensoren und Aktoren ohne IO-Link-Funktionalität an IO-Link Ports angeschlossen werden.
1.
Klappen Sie im Feld „Catalog“ den Baumknoten „Std-I/O“ auf
⇨
Die Betriebs-Modi „dig in“ und „dig out“ werden sichtbar
2.
Konfigurieren Sie den gewünschten Port. Dazu gibt es zwei Möglichkeiten:
1. Drag-and-drop: ziehen Sie „dig in“ oder „dig out“ auf den Port im Feld „Ports“
2. Rechtsklick auf „dig in“ oder „dig out“ und Klick auf „Add to Port n“


Konfiguration aktivieren

Inbetriebnahme und Konfiguration [image] IO-Link Konfiguration [image] Konfiguration aktivieren
Konfiguration aktivieren
Änderungen im IO-Link Konfigurationstool werden erst wirksam, wenn Sie die IO-Link Konfiguration aktivieren.
Es gibt zwei Möglichkeiten, die IO-Link Konfiguration zu aktivieren:
▪
Klicken Sie auf die Schaltfläche „Reload Devices“
TC3 Button Reload Devices
▪
Aktivieren Sie die TwinCAT-Konfiguration:
Klicken Sie auf die Schaltfläche „Activate Configuration“
TC3 Button Activate Configuration


Diagnose

Inbetriebnahme und Konfiguration [image] Diagnose
Diagnose
Weiterführende Informationen
•
IO-Link Events
•
ADS Error Codes


IO-Link Events

Inbetriebnahme und Konfiguration [image] Diagnose [image] IO-Link Events
IO-Link Events
Einige der IO-Link Sensoren leiten auftretende Ereignisse an der Master weiter. Diese Events können Informationen, Warnungen oder auch Fehlermeldungen sein, z. B. Kurzschluss oder Überhitzung.
Der IO-Link Master meldet diese Events durch Setzen des Device Diag Bits. Weiterführende Informationen zu den Events können über das CoE Verzeichnis oder auch über den Karteireiter DiagHistory ausgelesen werden.
Karteireiter DiagHistory
Die auftretenden Ereignisse werden nach Typ (Information, Warnung, Fehler), Flag, Auftreten des Ereignisses (Zeitstempel) und Nachricht (Port-Nummer & Eventcode) aufgegliedert.
Die Bedeutung der einzelnen Meldungen ist der Herstellerdokumentation zu entnehmen. Anhand der Portnummer kann das IO-Link Device direkt zugeordnet werden. Eine Verwaltung der eintreffenden Ereignisse kann über die verschiedenen Buttons erfolgen.
▪
Update History: ist das Feld "Auto Update" nicht ausgewählt, so können über den Button "Update History" die aktuellen Ereignisse angezeigt werden
▪
Auto Update: ist das Feld ausgewählt, so wird die Liste der auftretenden Ereignisse automatisch aktualisiert
▪
Only new Messages: ist das Feld ausgewählt, so werden nur die Meldungen angezeigt, die noch nicht bestätigt wurden
▪
Ack. Messages: ein auftretendes Ereignis wird über das Bit Device Diag gemeldet. Eine Bestätigung der Meldung setzt das Bit wider auf 0.
▪
Export Diag History: die aufgetretenen Ereignisse können als "txt"- Datei exportiert und somit archiviert werden.
▪
Advanced: dieses Feld hat zurzeit (3 Qu./2015) noch keine Funktion.


ADS Error Codes

Inbetriebnahme und Konfiguration [image] Diagnose [image] ADS Error Codes
ADS Error Codes
Beim Auftreten eines Fehlers über ADS-Zugriff auf einen IO-Link Teilnehmer werden Fehlercodes generiert.
Der Fehlercode enthält Informationen über die Fehlerkategorie, Herkunft und Instanz. Die möglichen Fehlercodes sind in der nachfolgenden Tabelle aufgeführt.
In der darauffolgenden Tabelle sind zusätzliche Informationen zu einem bestimmten Fehler aufgelistet (S_APP_DEV):
Beispiel eines AdsReturnCode
AdsReturnCode 0x80110700
80: Device Application Error (IO-Link Spec),
11: Index not Available (IO-Link Spec),
0700: General ADS Error
Error Codes (IO-Link Spec)
Type | Herkunft | Name | Kategorie | Mode | Instanz | Wert (Hi Byte, hex) | Bemerkung
PDU buffer overflow | remote | S_PDU_BUFFER | ERROR | SiNGLE SHOT | DL | 52 | Device buffer is too small for storing the complete PDU
PDU checksum error (master) | local | M_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in master does not match actual received SPDU
PDU checksum error (device) | remote | S_PDU_CHECK | ERROR | SiNGLE SHOT | DL | 56 | Calculated PDU checksum in device does not match actual received SPDU
PDU flow control error | remote | S_PDU_FLOW | ERROR | SiNGLE SHOT | DL | 56 | Violation of flow control rule during transfer of SPDU between master and device
Illegal PDU service primitive (master) | local | M_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 57 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Illegal PDU service primitive (device) | local / remote | S_PDU_ILLEGAL | ERROR | SiNGLE SHOT | AL | 58 | Unknown service primitive e.g. different protocol revision
Communication error | remote | COM_ERR |  | SiNGLE SHOT | unknown | 10 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Device application error | remote | S_APP_DEV** | ERROR | SiNGLE SHOT | APP | 80 | Service PDU transferred, but not processed due to device error. See error details in Additional Code**
Additional Code (IO-Link Spec)
Type | Wert (Lo Byte, hex) | Beschreibung
No details | 00 | Device buffer is too small for storing the complete PDU
Index not available | 11 | Calculated PDU checksum in master does not match actual received SPDU
Subindex not available | 12 | Calculated PDU checksum in device does not match actual received SPDU
Service temporarily not available | 20 | Violation of flow control rule during transfer of SPDU between master and device
Service temporarily not available, local control | 21 | Unknown service primitive or wrong response e.g. Read Response on Write Request
Service temporarily not available, device control | 22 | Unknown service primitive e.g. different protocol revision
Access denied | 23 | Negative service response initiated by a communication error, eg. IO-Link connection interrupted
Parameter value out of range | 30 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value above limit | 31 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Parameter value below limit | 32 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Interfering parameter | 40 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application failure | 81 | Service PDU transferred, but not processed due to device error. See error details in Additional Code
Application not ready | 82 | Service PDU transferred, but not processed due to device error. See error details in Additional Code


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zubehör
•
Versionsidentifikation von EtherCAT-Geräten
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zubehör

Anhang [image] Zubehör
Zubehör
Befestigung
Bestellangabe | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Leitungen
Eine vollständige Übersicht von vorkonfektionierten Leitungen für EtherCAT-Box-Module finden sie hier.
Bestellangabe | Beschreibung
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensorleitung M12 5-polig Link zur Website
ZK2000-6xxx-xxxx | Sensorleitung M12 4-polig Link zur Website
ZK700x-xxxx-xxxx | EtherCAT-P-Leitung M8 Link zur Website
Beschriftungsmaterial, Schutzkappen
Bestellangabe | Beschreibung
ZS5000-0010 | Schutzkappe für M8-Buchsen, IP67 (50 Stück)
ZS5000-0020 | Schutzkappe M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5000-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangabe | Beschreibung
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker, 0,4…1,0 Nm
ZB8801-0001 | Wechselklinge für M8 / SW9 für ZB8801-0000
ZB8801-0002 | Wechselklinge für M12 / SW13 für ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar / SW18 für ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet auf https://www.beckhoff.de.


Versionsidentifikation von EtherCAT-Geräten

Anhang [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Anhang [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Topologie

Produktübersicht [image] IO-Link Master Grundlagen [image] Topologie
Topologie
Der IO-Link Master dient als Gateway zwischen einem Automatisierungssystem (EtherCAT) und den IO-Link Devices. Er hat mehrere IO-Link Ports, an die jeweils ein IO-Link Device angeschlossen werden kann.
IO-Link Grundlagen Beispiel
IO-Link Topologie


Parameter-Speicher

Produktübersicht [image] IO-Link Master Grundlagen [image] Parameter-Speicher
Parameter-Speicher
Der IO-Link Master hat einen Parameter-Speicher. Der Parameter-Speicher kann eine Kopie der Parameter von angeschlossenen Devices nichtflüchtig speichern.
Wenn ein Device ausfällt, bleiben seine Parameter im Parameter-Speicher erhalten.
Wenn ein defektes Device durch ein neues, baugleiches Device ersetzt wird, kann der Master das neue Device automatisch mit den gespeicherten Parametern parametrieren.