EP/EPP3752-0000 - 2 x 3-axis accelerometers
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
Documentation | Firmware | Hardware
1.0 | 02 | 00
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT P Box modules

Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Product overview

Product overview
Product overview
Additional information
•
Introduction
•
Technical data
•
Process image


Introduction

Product overview [image] Introduction
Introduction
2 x 3-axis accelerometers
The EPP3752-0000 EtherCAT P Box has two internal 3-axis accelerometers with 10 bits and a selectable measuring range of ±2 g, ±4 g, ±8 g and ±16 g. The sampling frequency is 1 Hz to 5 kHz. Possible applications include the recording of vibrations and shocks/oscillations, and furthermore inclination measurements in all three axes. Since measurement is carried out with two sensors that are positioned at an angle of 90° to each other, the control system can check measured data for plausibility. Extended integrated filter functions allow measured data to be pre-processed and appropriately scaled in order to filter disturbances and to relieve the workload of the control system.


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data | EP3752-0000
Fieldbus
Fieldbus | EtherCAT
Connection | EtherCAT P: Combined connection for EtherCAT and supply voltages Input: 1 x M8 socket, 4-pin, P-coded Downstream connection: 1 x M8 socket, 4-pin, P-coded
Minimum cycle time | 200 µs
Distributed Clocks | no
Supply voltages
Connection | See Fieldbus connection
Control voltage US
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A
Current consumption from US | 100 mA at 24 VDC
Peripheral voltage UP
Nominal voltage | 24 VDC (-15 % / +20 %)
Sum current | max. 3 A
Current consumption from UP | None. UP is only forwarded.
Acceleration sensors
Sensor type | Two 3-axis sensors / offset by 90°
Resolution 1) 2) | Measured values: 4 mg (default) Raw values: 10-bit (default)
Representation 1) | Measured values: 1 mg / LSB Raw values: 10-bit in 16-bit (left-aligned)
Measuring range 1) | ±2 g / ±4 g / ±8 g / ±16 g selectively
Sampling rate | 200 Hz to 5 kHz
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cULus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27 Additional checks
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Mechanics
Dimensions | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus in preparation
1) Unit of measurement: 1 g = 9.81 m/s2 (acceleration of gravity). 1 mg = 1/1000 g.
2) The resolution depends on the parameterization of the box. See section Resolution.
Resolution
The resolution of measured values and raw values depends on the parameters "Measuring range" and "Sampling rate". The table below shows how these parameters influence the resolution:
Measuring range | Sampling rate / EtherCAT cycle time | Resolution
 |  | Raw values | Measured values
±2 g | ≤ 1 kHz / ≥ 1 ms | 10-bit | 4 mg
±4 g |  |  | 8 mg
±8 g |  |  | 16 mg
±16 g |  |  | 48 mg
±2 g | > 1 kHz / < 1 ms | 8-bit | 16 mg
±4 g |  |  | 32 mg
±8 g |  |  | 64 mg
±16 g |  |  | 192 mg
The setting of the "Measuring range" and "Sampling rate" parameters is described in the chapter Settings.
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Process image

Product overview [image] Process image
Process image
The data for the two accelerometers can be found under AI Inputs Channel.
▪
Status Error: An error occurred during communication with the accelerometer.
▪
Value: 16-bit acceleration value
The assignment of the process values to the sensor axes can be found in the chapter Acceleration sensors.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT P


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)
•
Nut torque for connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Mounting and cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


Nut torque for connectors

Mounting and cabling [image] Mounting [image] Nut torque for connectors
Nut torque for connectors
Screw M8 connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Torque: 0.4 Nm.


EtherCAT P

Mounting and cabling [image] EtherCAT P
EtherCAT P
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] EtherCAT P [image] Connectors
Connectors
Plug connectors for EtherCAT P
1 - input
2 - downstream connection
Connection
M8 socket EPP connection
M8 socket, P-coded
Contact | Signal | Voltage | Core color 1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: Control voltage, +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.


Status LEDs

Mounting and cabling [image] EtherCAT P [image] Status LEDs
Status LEDs
Additional information
•
Supply voltages
•
EtherCAT


Supply voltages

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] Supply voltages
Supply voltages
Status LEDs for the supply voltages
EtherCAT P Box Modules have two LEDs that display the status of the supply voltages. The status LEDs are labelled with the designations of the supply voltages: Us and Up.
A status LED lights up green when the respective supply voltage is present.
A Status LED lights up red if the respective supply voltage is short-circuited.


EtherCAT

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] EtherCAT
EtherCAT
ECAT P interface
Status LEDs for EtherCAT
L/A (Link/Act)
A green LED labelled "L/A" or “Link/Act” is located next to each EtherCAT/EtherCAT P socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Conductor losses

Mounting and cabling [image] EtherCAT P [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Use the planning tool for EtherCAT P in TwinCAT.
Voltage drop on the supply line
Leitungsverluste M8-EPP 3A
Voltage drop on the supply line


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
Acceleration sensors
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Acceleration sensors

Commissioning/Configuration [image] Acceleration sensors
Acceleration sensors
EPP3752-0000 has two accelerometers. Each accelerometer measures the acceleration in all three spatial directions.
The accelerometers are offset by 90°. This enables a plausibility check of the measured values.
The measured acceleration values can be converted to inclination angles: see chapter on Inclination measurement.
Assignment of the acceleration axes to the process variables
Acceleration axes
Additional information
•
Settings
•
Filter
•
Inclination measurement


Settings

Commissioning/Configuration [image] Acceleration sensors [image] Settings
Settings
Scaling of the measured values
The measured values from the accelerometers – X, Y and Z-axis in each case - are output by default scaled to 1 mg / LSB. This representation is preferable, as the measured values are always scaled the same as a result (irrespective of the other settings in the CoE).
Index 0xF800:1D (default)
The data can also be output as raw values, i.e. just as they are transmitted from the sensors. The relevant setting needs to be made in index 0xF800:1D in order to do this.
Setting of the representation via index 0xF800:0D "Presentation"
When selecting "Channel setting" in index 0xF800:0D, the representation is set individually for each axis via the indices 0x80n0:1A.
Measuring range
The measuring range can be selected in index 0xF800:11 "Range".
Setting the measuring range via index 0xF800:11 "Range"
When selecting "Channel setting" in index 0xF800:11, the measuring range is set individually for each sensor:
▪
Measuring range for sensor 1: Index 0x8000:19 "Range"
▪
Measuring range for sensor 2: Index 0x8030:19 "Range"
This setting applies to all axes of the respective sensor. An individual setting for individual axes is not possible.
Sampling rate and synchronization modes
The sampling rate depends on whether the box's filters are activated. The filters are deactivated by default. They are described in the chapter Filter.
▪
The box operates SM-synchronously
if no filters are active. In this mode the EtherCAT cycle time determines the sampling rate: The measured values are read from the sensors in each EtherCAT cycle.
The sensor operates internally with 10-bit resolution up to a cycle time of 1 ms. Below that the resolution is reduced to 8-bit. The minimum cycle time is 200 µs.
▪
If at least one filter is active,
the box runs in free run with a sampling rate set by CoE index 0xF800:0D "Filter sampling rate".
The resolution is reduced to 8-bit if the sampling rate is increased to 2500 Hz or 5000 Hz.


Filter

Commissioning/Configuration [image] Acceleration sensors [image] Filter
Filter
Filter mode (FIR and IIR)
EPP3752-0000 is equipped with digital filters which, depending on their settings, can adopt the characteristics of a Finite Impulse Response filter (FIR filter), or of an Infinite Impulse Response filter (IIR-Filter). The filters are deactivated by default. The activation takes place
▪
individually for each channel via the indices 0x80n0:06 from Firmware 02.
▪
centrally via the 1st channel (index 0x8000:06) with Firmware 01.
The filter characteristic is selected individually for each channel via the indices 0x80n0:15 "Filter Settings":
FIR
The mean value of the last 32 measurements is calculated. The internal sampling rate (time interval between the individual measured values) can be parameterized via index 0xF800:0D "Filter sampling rate".
IIR1…8
The filter with IIR characteristic can be set to one of 8 levels. The higher the level, the higher the attenuation of the present signal by the filter. The internal sampling rate can be set via index 0xF800:0D "Filter sampling rate" (unlike other analog boxes in which a fixed cycle time of 1 ms is specified).
Setting of the internal sampling rate via index 0xF800:0D
Setting of the internal sampling rate (index 0xF8000:0D)
The internal sampling rate with filters switched on is set via the index 0xF800:0D. On delivery this is set to 1000 Hz.
Changing the update rate at 2000 Hz and 5000 Hz
The resolution is reduced to 8-bit if the rate is increased to 2500 Hz or 5000 Hz. This is necessary due to the sensors used.


Inclination measurement

Commissioning/Configuration [image] Acceleration sensors [image] Inclination measurement
Inclination measurement
The calculation of an angle with higher resolution and accuracy should take place on a PC. The sensors used are capable of an accuracy of less than 0.1°.
Since the angle values are derived from the acceleration values, which are subject to certain noise, they have to be filtered via suitable algorithms.
In simple cases this could be a sliding average value, for example.
Angle measurement, process data as acceleration values, calculation on a PC
Signal noise in detail
Color | Meaning
Red | Angle measured with 1024-step encoder / 4-way analysis for reference
Green | Angle trigonometrically calculated on a PC, without noise suppression
blue | Fast algorithm
yellow | Arithmetic mean (1000 sliding values)
Sample
Equation for calculating the angle α:
EP3752 inclined equation
Implementation in TwinCAT:
alpha := ATAN(a_y1 / (SQRT(a_x1 * a_x1 + a_z1 * a_z1))) * 360/(2*3.14);
Sample Program
Note
Using the sample program
This document contains sample applications of our products for certain areas of application. The application notices provided here are based on typical features of our products and only serve as samples. The notices contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
To download the sample program from this documentation please click on the following link:
( )


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning/Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


CoE parameters

CoE parameters
CoE parameters
Additional information
•
Object overview
•
Object description and parameterization


Object overview

CoE parameters [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EPP3752-0000
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 00
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0EA84052 (245907538dec)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x06 (6dec)
 | 1A00:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A00:02 | SubIndex 002 | RO | 0x6000:07, 1
 | 1A00:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A00:04 | SubIndex 004 | RO | 0x6000:0F, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:10, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x06 (6dec)
 | 1A01:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A01:02 | SubIndex 002 | RO | 0x6010:07, 1
 | 1A01:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A01:04 | SubIndex 004 | RO | 0x6010:0F, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:10, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:11, 16
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x06 (6dec)
 | 1A02:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A02:02 | SubIndex 002 | RO | 0x6020:07, 1
 | 1A02:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A02:04 | SubIndex 004 | RO | 0x6020:0F, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6020:10, 1
 | 1A02:06 | SubIndex 006 | RO | 0x6020:11, 16
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x06 (6dec)
 | 1A03:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A03:02 | SubIndex 002 | RO | 0x6030:07, 1
 | 1A03:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A03:04 | SubIndex 004 | RO | 0x6030:0F, 1
 | 1A03:05 | SubIndex 005 | RO | 0x6030:10, 1
 | 1A03:06 | SubIndex 006 | RO | 0x6030:11, 16
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.5 | RO | 0x06 (6dec)
 | 1A04:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A04:02 | SubIndex 002 | RO | 0x6040:07, 1
 | 1A04:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A04:04 | SubIndex 004 | RO | 0x6040:0F, 1
 | 1A04:05 | SubIndex 005 | RO | 0x6040:10, 1
 | 1A04:06 | SubIndex 006 | RO | 0x6040:11, 16
Index (hex) |  | Name | Flags | Default value
1A05:0 | Subindex | AI TxPDO-Map Inputs Ch.6 | RO | 0x06 (6dec)
 | 1A05:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A05:02 | SubIndex 002 | RO | 0x6050:07, 1
 | 1A05:03 | SubIndex 003 | RO | 0x0000:00, 7
 | 1A05:04 | SubIndex 004 | RO | 0x6050:0F, 1
 | 1A05:05 | SubIndex 005 | RO | 0x6040:10, 1
 | 1A05:06 | SubIndex 006 | RO | 0x6050:11, 16
 | 1A05:02 | AI TxPDO-Map Inputs Ch.5 | RO | 0x06 (6dec)
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x06 (6dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A03 (6659dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A04 (6660dec)
 | 1C13:05 | SubIndex 005 | RW | 0x1A05 (6661dec)
 | 1C13:06 | SubIndex 006 | RW | 0x1A06 (6662dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0x0003 (3dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00030D40 (200000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
6040:0 | Subindex | AI Inputs Ch.5 | RO | 0x11 (17dec)
 | 6040:07 | Error | RO | 0x00 (0dec)
 | 6040:0F | TxPDO State | RO | 0x00 (0dec)
 | 6040:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6040:11 | Value | RO | 0x0000 (0dec)
6050:0 | Subindex | AI Inputs Ch.6 | RO | 0x11 (17dec)
 | 6050:07 | Error | RO | 0x00 (0dec)
 | 6050:0F | TxPDO State | RO | 0x00 (0dec)
 | 6050:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6050:11 | Value | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings Ch.1 | RW | 0x1A (26dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:15 | Filter settings | RW | 0x0002 (2dez)
 | 8000:19 | Range | RW | 0x0000 (0dez)
 | 8000:1A | Presentation | RW | 0x0001 (1dez)
8010:0 | Subindex | AI Settings Ch.2 | RW | 0x1A (26dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:15 | Filter settings | RW | 0x0002 (2dez)
 | 8010:19 | Range | RW | 0x0000 (0dez)
 | 8010:1A | Presentation | RW | 0x0001 (1dez)
8020:0 | Subindex | AI Settings Ch.3 | RW | 0x1A (26dec)
 | 8020:06 | Enable filter | RW | 0x00 (0dec)
 | 8020:15 | Filter settings | RW | 0x0002 (2dez)
 | 8020:19 | Range | RW | 0x0000 (0dez)
 | 8020:1A | Presentation | RW | 0x0001 (1dez)
8030:0 | Subindex | AI Settings Ch.4 | RW | 0x1A (26dec)
 | 8030:06 | Enable filter | RW | 0x00 (0dec)
 | 8030:15 | Filter settings | RW | 0x0002 (2dez)
 | 8030:19 | Range | RW | 0x0000 (0dez)
 | 8030:1A | Presentation | RW | 0x0001 (1dez)
8040:0 | Subindex | AI Settings Ch.5 | RW | 0x1A (26dec)
 | 8040:06 | Enable filter | RW | 0x00 (0dec)
 | 8040:15 | Filter settings | RW | 0x0002 (2dez)
 | 8040:19 | Range | RW | 0x0000 (0dez)
 | 8040:1A | Presentation | RW | 0x0001 (1dez)
8050:0 | Subindex | AI Settings Ch.6 | RW | 0x1A (26dec)
 | 8050:06 | Enable filter | RW | 0x00 (0dec)
 | 8050:15 | Filter settings | RW | 0x0002 (2dez)
 | 8050:19 | Range | RW | 0x0000 (0dez)
 | 8050:1A | Presentation | RW | 0x0001 (1dez)
8060:0 (FW01) | Subindex | SAI Settings | RW | 0x1D (29dec)
 | 8060:0D | Filter sampling rate | RW | 0x0002 (2dez)
 | 8060:11 | Range | RW | 0x0000 (0dez)
 | 8060:1D | Presentation | RW | 0x0001 (1dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0002 (2dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x02 (2dec)
 | F010:01 | SubIndex 001 | RW | 0x00000258 (600dec)
 | F010:02 | SubIndex 002 | RW | 0x00000258 (600dec)
F800:0 (from FW02) | Subindex | SAI Settings | RW | 0x1D (29dec)
 | F800:0D | Filter sampling rate | RW | 0x0002 (2dec)
 | F800:11 | Range | RW | 0x0000 (0dec)
 | F800:1D | Presentation | RW | 0x0001 (1dec)
Key
Flags: |
RO (Read Only): | This object can only be read.
RW (Read/Write): | This object can be read and written to.


Object description and parameterization

CoE parameters [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default settings | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the Set Value Dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI Settings Ch.1
Index (hex)
Name
Meaning
Data type
Flags
Default
8000:0
AI Settings Ch.1
UINT8
RO
0x1A (26dec)
8000:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8000:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8000:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8000:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8010 AI Settings Ch.2
Index (hex)
Name
Meaning
Data type
Flags
Default
8010:0
AI Settings Ch.2
UINT8
RO
0x1A (26dec)
8010:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8010:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8010:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8010:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8020 AI Settings Ch.3
Index (hex)
Name
Meaning
Data type
Flags
Default
8020:0
AI Settings Ch.3
UINT8
RO
0x1A (26dec)
8020:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8020:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8020:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8020:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8030 AI Settings Ch.4
Index (hex)
Name
Meaning
Data type
Flags
Default
8030:0
AI Settings Ch.4
UINT8
RO
0x11 (21dec)
8030:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8030:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8030:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8030:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8040 AI Settings Ch.5
Index (hex)
Name
Meaning
Data type
Flags
Default
8040:0
AI Settings Ch.5
UINT8
RO
0x1A (26dec)
8040:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8040:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8040:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8040:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8050 AI Settings Ch.6
Index (hex)
Name
Meaning
Data type
Flags
Default
8050:0
AI Settings Ch.6
UINT8
RO
0x1A (26dec)
8050:06
Enable filter
Activates the filter.
BOOLEAN
RW
0x00 (0dec)
8050:15
Filter settings
This object determines the filter settings of all channels of the module when it is activated via Enable filter index 0x80n0:06.
UINT16
RW
0x0002 (2dec)
0
FIR
2
IIR1
3
IIR2
4
IIR3
5
IIR4
6
IIR5
7
IIR6
8
IIR7
9
IIR8
8050:19
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8050:1A
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index 8060 SAI Settings (Firmware 01)
The object with index 8060 is invisible in the object directory from Firmware 02. However, it can still be read and written via SDO access. This ensures backward compatibility with PLC programs that were written prior to the release of Firmware 02.
The content of index 8060 is mirrored in index F800 from Firmware 02.
Index (hex)
Name
Meaning
Data type
Flags
Default
8060:0
SAI Settings
UINT8
RO
0x1D (29dec)
8060:0D
Filter sampling rate
Selection of the internal sampling rate:
▪
0dec: 200 Hz
▪
1dec: 500 Hz
▪
2dec: 1000 Hz
▪
3dec: 2500 Hz
▪
4dec: 5000 Hz
▪
The sensor resolution is reduced to 8-bit if the rate is increased to 2500 Hz or 5000 Hz.
UINT16
RW
0x0002 (2dec)
8060:11
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
UINT16
RW
0x0000 (0dec)
8060:1D
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
UINT16
RW
0x0001 (1dec)
Index F800 SAI Settings (from Firmware 02)
Index (hex)
Name
Meaning
Data type
Flags
Default
F800:0
SAI Settings
UINT8
RO
0x1D (29dec)
F800:0D
Filter sampling rate
Selection of the internal sampling rate:
▪
0dec: 200 Hz
▪
1dec: 500 Hz
▪
2dec: 1000 Hz
▪
3dec: 2500 Hz
▪
4dec: 5000 Hz
▪
The sensor resolution is reduced to 8-bit if the rate is increased to 2500 Hz or 5000 Hz.
UINT16
RW
0x0002 (2dec)
F800:11
Range
Setting the measuring range:
▪
0dec: +-2G
▪
1dec: +-4G
▪
2dec: +-8G
▪
3dec: +-16G
▪
255dec: Channel setting: The measuring range is set individually for each channel via the indices 0x80n0:19.
UINT16
RW
0x0000 (0dec)
F800:1D
Presentation
Representation of the data
▪
0dec: Raw values
▪
1dec: milli G (mG)
▪
255dec: Channel setting: The representation is set channel-wise via the indices 0x80n0:1A.
UINT16
RW
0x0001 (1dec)
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP3752-0000
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 00
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 00
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0000:00, 7
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0010:00, 7
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02 AI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0000:00, 7
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 AI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0000:00, 7
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A04 AI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x07 (Error)) | UINT32 | RO | 0x6040:07, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0000:00, 7
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6040:0F, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 16
Index 1A05 AI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (6 bit align) | UINT32 | RO | 0x0000:00, 6
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (AI Inputs Ch.6), entry 0x07 (Error)) | UINT32 | RO | 0x6050:07, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (7 bit align) | UINT32 | RO | 0x0000:00, 7
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.6), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6050:0F, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.6), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (AI Inputs Ch.6), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Free Run: Cycle time of the local timer
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0x0003 (3dec)
1C33:05
Minimum cycle time
Minimum cycle time supported (in ns)
UINT32
RO
0x0003D040 (20000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
With this entry the real required process data provision time can be measured.
0: Measurement of the local cycle time is stopped
1: Measurement of the local cycle time is started
The entries 0x1C33:03, 0x1C33:06, 0x1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
BOOLEAN
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6000:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6000:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6010:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6010:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6020 AI Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
6020:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
6030:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6040 AI Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | AI Inputs Ch.5 |  | UINT8 | RO | 0x11 (17dec)
6040:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6040:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6050 AI Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
6050:0 | AI Inputs Ch.6 |  | UINT8 | RO | 0x11 (17dec)
6050:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6050:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dec)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000258 (600dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000258 (600dec)


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Ordering information | Description
ZK700x-xxxx-xxxx | EtherCAT P cable M8 Link to website
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com