EPP3314-0002 - 4-Kanal-Analog-Eingang Thermoelement
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentlichte Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.1
▪
CoE-Parameter aktualisiert
1.0
▪
Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation | Firmware | Hardware
1.0 | 06 | 04
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01
Weitere Informationen zu diesem Thema: Versionsidentifikation von EtherCAT-Geräten.


Produktgruppe: EtherCAT-P-Box-Module

Produktgruppe: EtherCAT-P-Box-Module
Produktgruppe: EtherCAT-P-Box-Module
EtherCAT P
EtherCAT P ergänzt die EtherCAT-Technologie um ein Verfahren, bei dem Kommunikation und Versorgungsspannungen auf einer gemeinsamen Leitung übertragen werden. Alle Eigenschaften von EtherCAT bleiben bei diesem Verfahren erhalten.
Es werden zwei Versorgungsspannungen pro EtherCAT-P-Leitung übertragen. Die Versorgungsspannungen sind galvanisch voneinander getrennt und sind somit einzeln schaltbar. Die Nennspannung der Versorgungsspannungen ist 24 VDC.
EtherCAT P verwendet den gleichen Leitungs-Aufbau wie EtherCAT: eine 4-adrige Ethernet-Leitung mit M8-Steckverbindern. Die Steckverbinder sind mechanisch codiert, so dass ein Vertauschen von EtherCAT-Steckverbindern und EtherCAT-P-Steckverbindern nicht möglich ist.
EtherCAT-P-Box-Module
EtherCAT-P-Box-Module sind EtherCAT-P-Slaves in Schutzart IP67. Sie sind vorgesehen für den Betrieb in nassen, schmutzigen oder staubigen Industrie-Umgebungen.
EtherCAT P Einführung
EtherCAT P
EtherCAT Grundlagen
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der EtherCAT System-Dokumentation.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Prozessabbild
•
Lieferumfang
•
Grundlagen der Thermoelement-Technologie


Einführung

Produktübersicht [image] Einführung
Einführung
EPP3314-0002 Inventarbild Website
EPP3314-0002
4-Kanal-Analog-Eingang Thermoelement
Die EtherCAT-P-Box EPP3314 mit analogen Eingängen erlaubt den direkten Anschluss von vier Thermoelementen. Die Schaltung der Baugruppe kann Thermoelementsensoren in 2-Leitertechnik betreiben. Die Linearisierung über den gesamten Temperaturbereich wird durch einen Mikroprozessor realisiert. Der Temperaturbereich ist frei wählbar. Die Error-LEDs zeigen Drahtbruch an. Die Kaltstellenkompensation erfolgt durch Temperaturmessung in den Anschlusssteckern. Somit können Standardverlängerungsleitungen angeschlossen werden. Mit der EPP3314 ist auch mV-Messung möglich.
Die Baugruppe verfügt über vielfältige Features, wobei die Defaultwerte so gewählt wurden, dass eine Konfiguration meist nicht erforderlich ist. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar, mehrere Datenausgabeformate stehen zur Wahl. Die Skalierung der Eingänge kann bei Bedarf verändert werden, eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert. Für die Temperaturkompensation wird ein PT1000-Element benötigt. Beckhoff bietet einen Stecker mit Temperaturkompensation an (ZS2000-3712).
Quick Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Alle Werte sind typische Werte über den gesamten Temperaturbereich, wenn nicht anders angegeben.
Technische Daten
EPP3314-0002
Feldbus
Feldbus
EtherCAT
Anschluss
EtherCAT P: Kombinierter Anschluss für EtherCAT und Versorgungsspannungen
Eingang: 1 x M8-Buchse, 4-polig, P-kodiert
Weiterleitung: 1 x M8-Buchse, 4-polig, P-kodiert
Versorgungsspannungen
Anschluss
Siehe Feldbus-Anschluss
Steuerspannung US
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Stromaufnahme aus US
100 mA bei 24 VDC
Peripheriespannung UP
Nennspannung
24 VDC (-15 % / +20 %)
Summenstrom
max. 3 A 1)
Stromaufnahme aus UP
Keine. UP wird nur weitergeleitet.
Thermoelement-Eingänge
Anzahl
4
Steckverbinder
4 x M12-Buchse
Leitungslänge zum Thermoelement
max. 30 m
Sensor-Typen
▪
Thermoelemente
▪
Sensoren mit Spannungs-Ausgang bis ±75 mV
Potentialtrennung
Die Messkanäle haben ein gemeinsames, isoliertes Massepotential.
Messbereiche
Thermoelemente: je nach Typ.
Spannungsmessung: ±30 mV, ±60 mV, ±75 mV
Messfehler
Thermoelement Typ K: max. ±0,3 %,
bezogen auf den Messbereichsendwert
Digitale Auflösung
16 Bit
Wert eines LSB
Thermoelement: 0,1 °C
Spannungsmessung:
Messbereich 30 mV: 1 µV
Messbereich 60 mV: 2 µV
Messbereich 75 mV: 4 µV
Filter
Digitales Filter. Filter-Frequenz einstellbar 5 Hz … 30 kHz
Wandlungszeit
ca. 2,5 s bis 20 ms, je nach Konfiguration und Filtereinstellung.
Default: ca. 250 ms
Diagnose
▪
Drahtbruch-Erkennung
▪
Grenzwert-Überwachung
1) Summenstrom von Verbrauchern und Spannungs-Weiterleitung.
Technische Daten | EPP3314-0002
Mechanik
Abmessungen | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)
Gewicht | ca. 165 g
Einbaulage | beliebig
Umgebungsbedingungen
Umgebungstemperatur im Betrieb | -25…+60 °C -25…+55 °C gemäß cULus
Umgebungstemperatur bei Lagerung | -40…+85 °C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 Zusätzliche Prüfungen
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Zulassungen und Konformität
Zulassungen | CE, cULus
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms
Übersicht geeigneter Thermoelemente
Folgende Thermoelemente sind für die Temperaturmessung geeignet:
Typ (nach EN60584-1) | Element | Implementierter Temperaturbereich | Farbcodierung (Mantel - Pluspol - Minuspol)
B | Pt30%Rh-Pt6Rh | 600°C bis 1800°C | grau - grau -weiß
C * | W5%Re-W25%Re | 0°C bis 2320°C | n.d.
E | NiCr-CuNi | -100°C bis 1000°C | violett - violett - weiß
J | Fe-CuNi | -100°C bis 1200°C | schwarz - schwarz - weiß
K | NiCr-Ni | -200°C bis 1370°C | grün - grün - weiß
L ** | Fe-CuNi | 0°C bis 900°C | blau - rot - blau
N | NiCrSi-NiSi | -100°C bis 1300°C | rosa - rosa - weiß
R | Pt13%Rh-Pt | 0°C bis 1767°C | orange - orange - weiß
S | Pt10%Rh-Pt | 0°C bis 1760°C | orange - orange - weiß
T | Cu-CuNi | -200°C bis 400°C | braun - braun - weiß
U ** | Cu-CuNi | 0°C bis 600°C | braun - rot - braun
*nicht genormt nach EN60584-1
**nach DIN 43710


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Prozessabbild
TC Inputs Channel 1
EPP3314-0002 Prozessabbild - TC Inputs Channel 1
▪
TC3 InputVariable Symbol Underrange
Messbereich unterschritten
▪
TC3 InputVariable Symbol Overrange
Messbereich überschritten
▪
TC3 InputVariable Symbol Limit 1
Status-Variable der Grenzwert-Überwachung
0: Die Grenzwert-Überwachung ist deaktiviert
1: Der Messwert ist kleiner als der Grenzwert
2: Der Messwert ist größer als der Grenzwert
3: Der Messwert ist genauso groß wie der Grenzwert
▪
TC3 InputVariable Symbol Limit 2
Status-Variable der Grenzwert-Überwachung
▪
TC3 InputVariable Symbol Error
Der aktuelle Messwert „Value“ ist ungültig.
Mögliche Gründe: Leitungsbruch, Underrange, Overrange
▪
TC3 InputVariable Symbol TxPDO State
Wenn dieses Bit TRUE ist, ist der aktuelle Messwert „Value“ ungültig.
▪
TC3 InputVariable Symbol TxPDO Toggle
Die Box invertiert dieses Bit jedes Mal, wenn sie den Messwert „Value“ in den Prozessdaten aktualisiert.
Dies lässt einen Rückschluss auf die aktuell benötigte Wandlungszeit zu.
TC3 InputVariable Symbol Value
Der aktuelle Messwert. Einheit: 1/10 °C.
TC Inputs Channel 2 bis 4
Die Prozessdatenobjekte von Kanal 2…4 sind genauso aufgebaut wie die von Kanal 1.


Lieferumfang

Produktübersicht [image] Lieferumfang
Lieferumfang
Vergewissern Sie sich, dass folgende Komponenten im Lieferumfang enthalten sind:
▪
1x EtherCAT-P-Box EPP3314-0002
▪
2x Schutzkappe für EtherCAT-P-Buchse, M8, rot (vormontiert)
▪
10x Beschriftungsschild unbedruckt (1 Streifen à 10 Stück)
Vormontierte Schutzkappen gewährleisten keinen IP67-Schutz
Schutzkappen werden werksseitig vormontiert, um Steckverbinder beim Transport zu schützen. Sie sind u.U. nicht fest genug angezogen, um die Schutzart IP67 zu gewährleisten.
Stellen Sie den korrekten Sitz der Schutzkappen sicher, um die Schutzart IP67 zu gewährleisten.


Grundlagen der Thermoelement-Technologie

Produktübersicht [image] Grundlagen der Thermoelement-Technologie
Grundlagen der Thermoelement-Technologie
Thermoelemente sind Temperatursensoren. Die Anwendungsbereiche von Thermoelementen sind aufgrund der geringen Kosten, der schnellen Erfassung von Temperaturunterschieden, weiten Temperaturbereichen, hohen Temperaturgrenzen und ihrer Verfügbarkeit in vielen unterschiedlichen Typen und Größen sehr vielfältig.
Messprinzip und Aufbau
Die Temperaturmessung mit einem Thermoelement basiert auf dem Seebeck-Effekt, der in den 1820er Jahren von dem deutschen Physiker Thomas Johann Seebeck entdeckt wurde. Dieser Seebeck-Effekt, auch bezeichnet als thermoelektrischer Effekt, beschreibt eine Ladungsverschiebung in einem leitenden Material durch ein Temperaturgefälle entlang des Leiters. Die Größe der Ladungsverschiebung ist dabei abhängig von der Größe des Temperaturunterschieds und dem betrachteten Leitermaterial.
Bei Thermoelementen wird diese Ladungsverschiebung zur Erzeugung einer Spannung genutzt. Zwei unterschiedliche Leitermaterialien werden an einem Ende miteinander verbunden. Das ist die Messstelle, an der die Temperatur ermittelt werden soll. An dem anderen Ende sind die Leiter nicht verbunden. Dieses offene Ende, an dem der Übergang auf die Messelektronik ist, ist die Vergleichsstelle. Zwischen der Vergleichsstelle und der Messstelle ist eine Temperaturdifferenz, die über die Spannung zwischen den Leitern am offenen Ende gemessen werden kann. Die Spannung ist abhängig von den verwendeten Leitermaterialien und der Temperaturdifferenz, sie liegt im Bereich einiger mV.
Aufbau und Prinzip eines Thermoelements
Würde für ein Thermoelement nur ein Material genutzt werden, wäre die Ladungsverschiebung in beiden Leitern identisch, sodass keine Potentialdifferenz zwischen den beiden Leitern am offenen Ende messbar wäre.
Bei der Temperaturmessung mit Thermoelementen handelt es sich also eigentlich um eine Spannungsmessung, mit der dann aus der bekannten Kennlinie eine Temperatur ermittelt werden kann. Außerdem ist das Messverfahren nicht absolut, sondern differentiell, da keine absolute Temperatur (mit dem Bezugspunkt 0 °C) ermittelt wird, sondern die Temperaturdifferenz zwischen der Mess- und der Vergleichsstelle.
Zur Auswertung von Thermoelementen wird eine Messelektronik benötigt, die kleine Spannungen im mV Bereich mit einer ausreichend hohen Auflösung und Genauigkeit auswerten kann. Thermoelemente sind aktive Sensoren, was bedeutet, dass zur Messung der Temperatur keine Versorgung der Sensorik nötig ist.
Arten von Thermoelementen
Es gibt verschiedene Arten von Thermoelementen, die aus unterschiedlichen Kombinationen von Leitermaterialien bestehen. Jede Material-Kombination hat spezielle Eigenschaften und eignet sich für bestimmte Anwendungsbereiche. Die verschiedenen Arten bzw. Thermoelementtypen werden mit Buchstaben benannt.
Aufgrund der unterschiedlichen Materialpaarung haben die verschiedenen Thermoelementtypen unterschiedliche Kennwerte. Sie unterscheiden sich in der Temperaturgrenzen und der Spannungs-Temperatur-Kennlinie. Um die Thermoelementtypen unterscheiden zu können sind die Farbcodierungen für den Mantel, den Pluspol und den Minuspol in verschiedenen Normen festgelegt.
Die folgende Tabelle zeigt gängige Thermoelementtypen mit dem Angeben zu den verwendeten Materialien, den definierten Temperaturbereichen und der Farbcodierung.
Typ (nach EN60584-1) | Element | Messbereich * |  | Mittlerer Temperatur-koeffizient | Spannung am MBE | Farbcodierung (Mantel - Pluspol - Minuspol)
 |  | Min | Max
B | Pt30%Rh-Pt6Rh | 600 °C | 1820 °C | 6 µV/K | 13,820 mV | grau - grau -weiß
C ** | W5%Re-W25%Re | -18 °C | 2316 °C | 15 µV/K | 37,070 mV | n.d.
E | NiCr-CuNi | -270 °C | 1000 °C | 65 µV/K | 76,373 mV | violett - violett - weiß
J | Fe-CuNi | -210 °C | 1200 °C | 54 µV/K | 69,553 mV | schwarz - schwarz - weiß
K | NiCr-Ni | -270 °C | 1372 °C | 42 µV/K | 54,886 mV | grün - grün - weiß
L *** | Fe-CuNi | -200 °C | 900 °C | 54 µV/K | 53,140 mV | blau - rot - blau
N | NiCrSi-NiSi | -270 °C | 1300 °C | 27 µV/K | 47,513 mV | rosa - rosa - weiß
R | Pt13%Rh-Pt | -50 °C | 1768 °C | 10 µV/K | 21,101 mV | orange - orange - weiß
S | Pt10%Rh-Pt | -50 °C | 1768 °C | 10 µV/K | 18,693 mV | orange - orange - weiß
T | Cu-CuNi | -270 °C | 400 °C | 40 µV/K | 20,872 mV | braun - braun - weiß
U *** | Cu-CuNi | -200 °C | 600 °C | 40 µV/K | 34,310 mV | braun - rot - braun
*Der angegebene Messbereich bezieht sich auf den maximal möglichen Messbereich des angegebenen Thermoelementtyps. Der mögliche Messbereich mit den Thermoelementmodulen kann eingeschränkt sein. Die Angabe zum möglichen Messbereich der Thermoelementmodule sind den technischen Daten in der Dokumentation zu entnehmen.
**nicht genormt nach EN60584-1
***nach DIN 43710
Ausgewählt werden muss das Thermoelement nach den Einsatzbedingungen. Dabei muss also nicht nur auf die Unsicherheit geachtet werden, sondern auch auf die anderen Eigenschaften der verschiedenen Thermoelementtypen. Bei einer Anwendung mit geringen Temperaturschwankungen ist es von Vorteil, einen Thermoelementtyp mit einer hohen Thermospannung pro Temperaturänderung zu wählten. In einem Anwendungsfall, wo die zu messende Temperatur sehr hoch ist, ist es wichtig die maximale Einsatztemperatur zu beachten.
Kennlinie
Zur Ermittlung der Temperaturdifferenz zu einer gemessenen Thermospannung gibt es typenspezifische Referenztabellen. Eine einfache Umrechnung der Spannung in eine Temperatur mit einem Temperaturkoeffizienten, wie bei Widerstandsthermometern oft näherungsweise üblich, ist nicht möglich, da das Verhältnis von Spannung und Temperatur deutlich nicht-linear über den gesamten Messbereich ist. Durch den sich ändernden Temperaturkoeffizienten ergibt sich eine nichtlineare Spannungs-Temperatur-Kennlinie. Diese Kennlinie ist wiederum abhängig vom Thermoelementtyp, sodass sich für jeden Typ eine eigene nichtlineare Spannungs-Temperatur-Kennlinie ergibt. Beispielhaft sind die Kennlinien für typische Thermoelementtypen in der folgenden Abbildung dargestellt. Die beschriebene Nichtlinearität ist vor allem im Temperaturbereich < 0°C deutlich zu erkennen.
Spannungs-Temperatur-Kennlinien verschiedener Thermoelementtypen
Thermoelemente unterliegen im Anwendungsbetrieb unumgänglichen und irreversiblen Veränderungen, wodurch es mit der Zeit zu immer größer werdenden Messunsicherheiten kommt. Oder ganz deutlich: die Messung wird mit der Zeit immer falscher. Diese Änderungen werden auch als Alterung bezeichnet und sind abhängig von verschiedenen Einflussfaktoren. Beispiele für diese Einflüsse sind mechanische und chemische Beanspruchungen der Thermoelemente. Bei mechanischen Beanspruchungen handelt es sich um Verformungen der Leiter, wodurch die Kristallstruktur der Metalle verändert wird. Dies führt zu fehlerhaften Thermospannungen. Bei chemischen Beanspruchungen handelt es sich ebenfalls um Veränderungen in der Kristallstruktur der Metalle oder Oxidation, wodurch sich die thermischen Eigenschaften der Leiter verändern, sodass es zu einer Kennlinienveränderung kommt. Dieser Einfluss kann durch den Einbau in gasdichten Schutzrohren gemindert werden.
Steckbare Verbindungen
Zum Anschluss von Thermoelementen an Messgeräte und Auswertelektronik oder zur Verbindung eines Thermoelements mit Thermo- oder Ausgleichsleitungen kann mit offenen Drahtenden oder geeigneten Thermoelement-Steckverbindern gearbeitet werden.
Idealerweise sind die Kontakte eines solchen Thermoelement-Steckverbinders aus dem Material des jeweiligen Thermoelements ausgeführt. Dadurch ergibt sich ein thermospannungsfreier Übergang an den Verbindungsstellen. Die Stecker haben festgelegte Farben je nach Typ, z.B. Typ K: grün. Durch eine Kennzeichnung auf dem Gehäuse und die unterschiedliche Form der Kontakte ist eine Verwechselung der Polarität schwer möglich.
Verlängerungen und Anschluss von Thermoelementen.png
Es gibt mehrere übliche Größen: Standard, Mini, Micro.
Eine Besonderheit ist der weiße Steckverbinder, der mit normalen Kupferkontakten ausgeführt ist, quasi wie ein normaler Nicht-Thermoelement-Stecker. Dadurch ist er für alle Thermoelement Typen universell einsetzbar, wenn auch mit dem Nachteil daß er dann genau keinen thermospannungsfreien Übergang schafft. Weitaus häufiger als der weiße Stecker ist die weiße Buchse „universal“ am Messgerät. Dadurch können alle Thermoelement -Stecker in das Gerät gesteckt werden, das Messgerät muß dann die Kaltstellentemperatur in diesem Steckerübergang ermitteln.
Verlängerungen und Anschluss von Thermoelementen
In einigen Fällen ist es sinnvoll das Thermoelement zu verlängern und die Vergleichsstelle so an einen ausgewählten Ort zu verlegen, da dort beispielsweise die Temperatur konstant gehalten oder mit einfachen Mitteln gemessen werden kann. Dazu muss das Thermoelement verlängert werden. Dies kann mit einer Thermo- oder Ausgleichsleitung geschehen. Thermoleitungen sind aus demselben Material gefertigt, wie das Thermoelement selbst. Ausgleichsleitungen hingegen sind meistens aus günstigeren Werkstoffen mit ähnlichen thermischen Eigenschaften hergestellt. Beide Arten sind somit für die Verlängerung eines Thermoelements zu einer entfernten Kaltstelle geeignet. Bei Ausgleichsleitungen muss darauf geachtet werden, dass es sich bei dem verwendeten Material nur um ähnliche thermische Eigenschaften handelt und nicht um dieselben. Die thermischen Eigenschaften gelten nur in einem eng eingeschränkten Temperaturbereich. Am Übergang von Thermoelement auf die Ausgleichsleitung ergibt sich dann ein weiteres Thermoelement. Daher ergeben sich kleine fehlerhafte Thermospannungen, die das Messergebnis beeinflussen. Werden die Ausgleichsleitungen außerhalb des spezifizierten Temperaturbereichs verwendet, wird die Genauigkeit der Temperaturmessung weiter beeinflusst und so das Messergebnis verschlechtert.
Sensorstrecke
Eine Veränderung des Sensorkreises durch zusätzliche Elemente wie z. B. Umschalter oder Multiplexer kann die Messgenauigkeit beeinträchtigen. In solchen Schaltern können lokal kleine Thermospannungen entstehen, die die Messung verfälschen. Falls dennoch applikativ nötig, sollte der Einfluss solcher Komponenten genau beleuchtet werden.
Max. Leitungslänge zum Thermoelement
Die Leitungslänge vom Messmodul (Klemme, Box) bis zum Thermoelement darf ohne weitere Schutzmaßnahmen max. 30 m betragen. Bei größeren Kabellängen ist ein geeigneter Überspannungsschutz (Surge-Protection) vorzusehen.
Bestimmung der absoluten Temperatur
Bei der Temperaturmessung mit einem Thermoelement handelt es sich um eine differentielle Temperaturmessung, bei der der Temperaturunterschied zwischen der Messstelle und der Vergleichsstelle, auch als Kaltstelle („Cold Junction“) bezeichnet, ermittelt wird. Um die absolute Temperatur an der Messstelle zu ermitteln muss die gemessene Thermospannung daher um die Thermospannung an der Kaltstelle korrigiert werden. Mit der korrigierten Thermospannung kann dann die Temperatur an der Messstelle aus geeigneten Tabellen oder Kennlinien ermittelt werden. Aufgrund der Nichtlinearität der Kennlinie ist es zwingend notwendig, dass diese Verrechnung mit den Spannungen und nicht mit der Temperatur durchgeführt wird. Andernfalls würde sich ein wesentlicher Fehler in der Messung ergeben.
Allgemein wird die absolute Temperatur über folgende Beziehung berechnet:
UMessstelle = Uthermo + UKaltstelle
TMessstelle = f(UMessstelle)
Nachfolgend wird die Bestimmung der absoluten Temperatur beispielhaft mit der Korrektur der Thermospannungen und mit der Korrektur der Temperatur durchgeführt. Anhand der Beispielrechnung kann der bei falscher Korrektur entstehende Fehler gezeigt werden.
Gesucht: TMessstelle
Bekannt: Thermoelementtyp K, Uthermo = 24,255 mV, TKaltstelle = 22 °C
1. Möglichkeit: Korrektur der Thermospannungen – RICHTIG
Die Thermospannung an der Kaltstelle UKaltstelle muss aus anhand der bekannten Temperatur TKaltstelle aus der Spannungs-Temperatur-Kennlinie oder –Tabelle für den Thermoelementtyp K bestimmt werden:
UKaltstelle = U(22 °C) = 0,879 mV
Anschließend kann die Thermospannung der Messstelle bezogen auf 0 °C ermittelt werden:
UMesstelle = Uthermo + UKaltstelle = 24,255 mV + 0,879 mV = 25,134 mV
Aus der ermittelten Thermospannung kann dann aus der Spannungs-Temperatur-Kennlinie oder –Tabelle für den Thermoelementtyp K der zugehörige Temperaturwert ermittelt werden:
TMessstelle = T(25,134 mV) ≈ 605,5 °C
2. Möglichkeit: Korrektur der Temperatur – FALSCH
Die Temperaturdifferenz zwischen der Kaltstelle und der Messstelle Tthermo könnte anhand der bekannten Thermospannung Uthermo aus der Spannungs-Temperatur-Kennlinie oder ‑Tabelle für den Thermoelementtyp K bestimmt werden:
Tthermo = T(24,255 mV) = 585 °C
Anschließend könnte die Temperatur der Messstelle bezogen auf 0 °C ermittelt werden:
TMesstelle = Tthermo + TKaltstelle = 585 °C + 22 °C = 607 °C
Es ist zu erkennen, dass zwischen dem Wert mit der richtigen Korrekt (Spannungskorrektur, 1. Möglichkeit) und dem Wert mit der falschen Korrektur (Temperaturkorrektur, 2. Möglichkeit) eine Temperaturdifferenz von 1,5 °C liegt.
Vergleichsstelle / Kaltstellenkompensation / Cold Junction Compensation / CJC
Die Korrektur des Thermospannungswerts, um den absoluten Temperaturwert zu ermitteln, wird auch als Kaltstellenkompensation bezeichnet. Um einen möglichst genauen absoluten Temperaturwert zu ermitteln muss die Temperatur an der Kaltstelle entweder konstant auf einem bekannten Wert gehalten werden oder kontinuierlich im während der Messung mit möglichst geringer Unsicherheit gemessen werden. In einigen Anwendungen kann sich die Kaltstelle beispielsweise in einem Eisbad (0 °C) befinden. Dann entspricht die über die Thermospannung ermittelte Temperatur sowohl der Temperaturdifferenz, als auch der absoluten Temperatur. In vielen Anwendung ist diese Möglichkeit jedoch nicht umsetzbar, sodass eine Kaltstellenkompensation erforderlich ist.
Als Kaltstelle bei der Thermoelementauswertung mit Busklemmen wird die Kaltstellentemperatur am Übergang vom Thermoelement auf die Kupferkontakte gemessen. Dieser Wert wird im Betrieb kontinuierlich gemessen, um so die ermittelten Werte intern zu korrigieren.
Auswertung von Thermoelementen mit Thermoelementklemmen
Beckhoff Thermoelementmodule (Klemmen, Box) können Thermoelemente der verschiedenen Typen auswerten. Die Linearisierung der Kennlinien und die Ermittlung der Vergleichstemperatur erfolgt direkt im Modul. Über den Buskoppler bzw. die Steuerung ist das Modul vollständig konfigurierbar. Dabei kann zwischen verschiedenen Ausgabeformaten gewählt und auch eigene Skalierungen aktiviert werden. Zusätzlich sind die Linearisierung der Kennlinie und die Ermittlung und Verrechnung der Vergleichstemperatur (Temperatur an den Anschlusskontakten des Moduls) abschaltbar, so kann das Modul als [mV]-Messgerät oder auch mit externer Vergleichsstelle verwendet werden. So kann neben der internen Auswertung der gemessenen Spannung zur Umrechnung in eine Temperatur auch der reine Spannungswert von der Klemme an die Steuerung übergeben und dort weiterverarbeitet werden.
Die Temperaturmessung mit Thermoelementen umfasst generell 3 Schritte:
▪
Messung der elektrischen Spannung
▪
Optional: Temperaturmessung der internen Kaltstelle
▪
Konvertierung (Umrechnung) der Spannung per Software in einen Temperaturwert nach eingestelltem Thermoelement -Typ (K, J, …)
Alle 3 Schritte können lokal im Beckhoff Messmodul stattfinden. Die Transformation im Modul kann auch deaktiviert werden, wenn sie übergeordnet in der Steuerung gerechnet werden soll. Je nach Modultyp können mehrere Thermoelement -Konvertierungen implementiert sein, die sich dann nur in Software unterscheiden.
Unsicherheiten bei der Auswertung von Thermoelementen mit Thermoelementklemmen
Die Thermoelement -Messung umfasst eine Verkettung von Mess- und Rechenelementen die auf die erzielbare Messabweichung einwirken:
Verkettung der Unsicherheiten in der Temperaturmessung mit Thermoelementen
Bei der Messung einer Temperatur gibt es verschiedene Einflussfaktoren auf die Genauigkeit, aus denen sich dann die Gesamtungenauigkeit (Gesamtunsicherheit) ergibt.
Unsicherheit der Spannungsmessung
In erster Linie ist die Messung einer Temperatur mit Thermoelementen keine wirkliche Temperaturmessung, sondern eine Spannungsmessung mit anschließender Umrechnung in eine Temperatur. Die Genauigkeit der Spannungsmessung ist also Grundlage für die Genauigkeit der Temperaturbestimmung. Da eine Änderung von 1 °C am Sensor je nach Thermoelementtyp eine Änderung im einstelligen µV Bereich bewirkt, hat schon eine geringe Unsicherheit der Spannungsmessung einen großen Einfluss auf das Endergebnis.
Unsicherheit der Temperaturumrechnung
Die Umrechnung der gemessenen Spannung in eine Temperatur erfolgt bei der Auswertung entweder über Wertetabellen aus der Spannungs-Temperatur-Kennlinie eines Thermoelementtyps oder über die Näherung durch ein Polynom. Aufgrund der Nichtlinearität der Spannungs-Temperatur-Kennlinie sind beide Möglichkeiten nur Näherungen an den realen Verlauf, sodass sich durch die Umrechnung eine weitere (kleine) Unsicherheitskomponente aus der Mathematik ergibt.
Unsicherheit der Kaltstellenerfassung
Die Kaltstellenkompensation in Thermoelementklemmen muss am Übergang vom Thermoelement auf die Kupferkontakte der Elektronik erfolgen. Dabei ist häufig das Problem, dass die Temperatur an diesem Punkt aus mechanischen Gründen nicht direkt erfassbar ist. Die Temperatur der Kaltstelle muss häufig mit einigen Millimetern Abstand oder durch einen Mittelwert der Temperaturen im Gehäuse angenähert werden. Da der genaue Wert aber häufig nicht bestimmt werden kann, ergibt sich auch daraus eine Unsicherheit.
Unsicherheit des Sensors
Die drei beschriebenen Einflussfaktoren auf die Unsicherheit beschreiben nur die Unsicherheiten in der Auswertung der Thermoelemente. Die Genauigkeit des Thermoelements selbst kommt noch dazu und muss einzeln betrachtet werden.
Da es sich bei der Temperaturmessung mit Thermoelementen eigentlich um eine Spannungsmessung handelt und die Thermoelemente eine nichtlineare Spannungs-Temperatur-Kennlinie haben ist es nicht möglich, die einzelnen Temperaturunsicherheiten einfach zu addieren, um die Gesamtunsicherheit zu erhalten. Zur Berechnung der Gesamtunsicherheit müssen alle Temperaturwerte in den zugehörigen Spannungswert des Thermoelementtyps umgerechnet werden. Bei einer Addition der Temperaturen ergibt sich ein Fehler, wie in dem Beispiel im Kapitel „Bestimmung der absoluten Temperatur“ beschrieben.
Eine Beispielhafte Auswertung der Unsicherheiten der Auswertung eines Thermoelements für eine Thermoelementklemme EL331x mit interner Kaltstellenkompensation und Umrechnung der Spannung in eine Temperatur über ein Polynom zweiten Grades ist in der folgenden Abbildung dargestellt. In der Abbildung wird nicht die Unsicherheit des Thermoelements selber betrachtet, diese kommt noch dazu!
Beispielhafte Unsicherheitsbetrachtung der Auswertung von Thermoelementen mit Thermoelementklemmen
Es ist anhand der Abbildung deutlich zu erkennen, dass die Unsicherheit der gemessenen Temperatur abhängig von der zu messenden Temperatur sind. Vor allem im unteren Temperaturbereich, dort wo eine starke Nichtlinearität von Spannung und Temperatur besteht, steigt die Unsicherheit der Temperaturmessung deutlich an.
Beckhoff bietet einige Produkte zur Auswertung von Thermoelementen an, u.a.
▪
EL331x: EtherCAT Eingangsklemmen mit 1-8 Kanälen
▪
EL3314-0002: hochpräzise EtherCAT Eingangsklemme, galvanisch getrennt
▪
EL3314-0010: hochpräzise EtherCAT Eingangsklemme
▪
EL3314-0030: hochpräzise EtherCAT Eingangsklemme, mit externem Kalibrierzertifikat
▪
EL3314-0090: EtherCAT Eingangsklemme, TwinSAFE SC
▪
ELM370x-xxxx: EtherCAT Messtechnikserie, Multifunktionseingang, 24 Bit, 10 kSps
▪
ELM334x: EtherCAT Messtechnikserie, Thermoelementeingang, Mini-Thermoelement -Stecker
▪
EP3314, EPP3314: EtherCAT IP67 Box
▪
KL331x: K-Bus Eingangsklemmen mit 1-4 Kanälen
▪
EJ3318: EtherCAT Steckmodul
Die aktuelle Übersicht ist zu finden auf www.beckhoff.de


Montage und Anschlüsse

Montage und Anschlüsse
Montage und Anschlüsse
Weiterführende Informationen
•
Montage
•
Anschlüsse
•
UL-Anforderungen


Montage

Montage und Anschlüsse [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Funktionserdung (FE)
•
Anzugsdrehmomente für Steckverbinder


Abmessungen

Montage und Anschlüsse [image] Montage [image] Abmessungen
Abmessungen
EPP 30mm 4xM12
Abmessungen
Alle Maße sind in Millimeter angegeben.
Gehäuseeigenschaften
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3,5 mm für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm (ohne Steckverbinder)
Gewicht | ca. 165 g


Befestigung

Montage und Anschlüsse [image] Montage [image] Befestigung
Befestigung
Hinweis
Verschmutzung bei der Montage
Verschmutzte Steckverbinder können zu Fehlfunktion führen. Die Schutzart IP67 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind.
•
Schützen Sie die Steckverbinder bei der Montage vor Verschmutzung.
Montieren Sie das Modul mit zwei M3-Schrauben an den Befestigungslöchern in den Ecken des Moduls. Die Befestigungslöcher haben kein Gewinde.


Funktionserdung (FE)

Montage und Anschlüsse [image] Montage [image] Funktionserdung (FE)
Funktionserdung (FE)
Das obere Befestigungsloch dient gleichzeitig als Anschluss für die Funktionserdung (FE).
Stellen Sie sicher, dass die Box über den Anschluss für die Funktionserdung (FE) niederimpedant geerdet ist. Das erreichen Sie z.B., indem Sie die Box an einem geerdeten Maschinenbett montieren.
Anschluss für die Funktionserdung (FE)


Anzugsdrehmomente für Steckverbinder

Montage und Anschlüsse [image] Montage [image] Anzugsdrehmomente für Steckverbinder
Anzugsdrehmomente für Steckverbinder
Schrauben Sie Steckverbinder mit einem Drehmomentschlüssel fest. (z.B. ZB8801 von Beckhoff)
Steckverbinder-Durchmesser | Anzugsdrehmoment
M8 | 0,4 Nm
M12 | 0,6 Nm


Anschlüsse

Montage und Anschlüsse [image] Anschlüsse
Anschlüsse
Weiterführende Informationen
•
EtherCAT P
•
Thermoelemente


EtherCAT P

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P
EtherCAT P
Hinweis
Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT/EtherCAT-P-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung von EtherCAT P, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 3 A nicht überschritten wird!
Weiterführende Informationen
•
Steckverbinder
•
Status-LEDs
•
Leitungsverluste


Steckverbinder

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P [image] Steckverbinder
Steckverbinder
Steckverbinder für EtherCAT P
1 - Eingang
2 - Weiterleitung
Kontaktbelegung
M8-Buchse EPP Kontaktbelegung
M8-Buchse, P-kodiert
Kontakt | Signal | Spannung | Aderfarbe 1)
1 | Tx + | GNDS | gelb
2 | Rx + | GNDP | weiß
3 | Rx - | UP: Peripheriespannung, +24 VDC | blau
4 | Tx - | US: Steuerspannung, +24 VDC | orange
Gehäuse | Schirm | Schirm | Schirm
1) Die Aderfarben gelten für EtherCAT-P-Leitungen und ECP-Leitungen von Beckhoff.


Status-LEDs

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P [image] Status-LEDs
Status-LEDs
Weiterführende Informationen
•
Versorgungsspannungen
•
EtherCAT


Versorgungsspannungen

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P [image] Status-LEDs [image] Versorgungsspannungen
Versorgungsspannungen
Status-LEDs für die Versorgungsspannungen
EtherCAT-P-Box-Module haben zwei LEDs, die den Status der Versorgungsspannungen anzeigen. Die Status-LEDs sind mit den Bezeichnungen der Versorgungsspannungen beschriftet: Us und Up.
Eine Status-LED leuchtet grün, wenn die jeweilige Versorgungsspannung vorhanden ist.
Eine Status-LED leuchtet rot, wenn die jeweilige Versorgungsspannung kurzgeschlossen ist.


EtherCAT

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P [image] Status-LEDs [image] EtherCAT
EtherCAT
Status-LEDs für EtherCAT
L/A (Link/Act)
Neben jeder EtherCAT-/EtherCAT-P-Buchse befindet sich eine grüne LED, die mit „L/A“ oder „Link/Act“ beschriftet ist. Die LED signalisiert den Kommunikationsstatus der jeweiligen Buchse:
LED | Bedeutung
aus | keine Verbindung zum angeschlossenen EtherCAT-Gerät
leuchtet | LINK: Verbindung zum angeschlossenen EtherCAT-Gerät
blinkt | ACT: Kommunikation mit dem angeschlossenen EtherCAT-Gerät
Run
Jeder EtherCAT-Slave hat eine grüne LED, die mit „Run“ beschriftet ist. Die LED signalisiert den Status des Slaves im EtherCAT-Netzwerk:
LED | Bedeutung
aus | Slave ist im Status „Init“
blinkt gleichmäßig | Slave ist im Status „Pre-Operational“
blinkt vereinzelt | Slave ist im Status „Safe-Operational“
leuchtet | Slave ist im Status „Operational“
Beschreibung der Stati von EtherCAT-Slaves


Leitungsverluste

Montage und Anschlüsse [image] Anschlüsse [image] EtherCAT P [image] Leitungsverluste
Leitungsverluste
Beachten Sie bei der Planung einer Anlage den Spannungsabfall an der Versorgungs-Zuleitung. Vermeiden Sie, dass der Spannungsabfall so hoch wird, dass die Versorgungsspannungen an der Box die minimale Nennspannung unterschreiten.
Berücksichtigen Sie auch Spannungsschwankungen des Netzteils.
Nutzen Sie das Planungstool für EtherCAT-P in TwinCAT.
Spannungsabfall an der Versorgungs-Zuleitung
Leitungsverluste M8-EPP 3A
Spannungsabfall an der Versorgungs-Zuleitung


Thermoelemente

Montage und Anschlüsse [image] Anschlüsse [image] Thermoelemente
Thermoelemente
Die Temperaturkompensation ist bei den Modulen nach außen geführt. Das heißt im Stecker wird die Temperaturkompensation direkt an der Anschlussstelle gemessen. Dies erlaubt ein wesentlich besseres Messergebnis der Temperatur. Beckhoff bietet hierfür einen Stecker (ZS2000-3712) an. Die Temperaturkompensation kann auch entfernt von der Feldbus Box durchgeführt werden. Sie müssen dann ein PT1000 zwischen Pin 1 und Pin 3 schalten. Je länger Sie die Leitung wählen, desto größer wird der gemessene Fehler durch Leitungslänge, Leitungsverluste und Störungen.
Signalanschluss - Thermoelement
Weiterführende Informationen
•
Status-LEDs an den Signalanschlüssen


Status-LEDs an den Signalanschlüssen

Montage und Anschlüsse [image] Anschlüsse [image] Thermoelemente [image] Status-LEDs an den Signalanschlüssen
Status-LEDs an den Signalanschlüssen
Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error.
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status-LEDs an den Signalanschlüssen
Anschluss
LED
Anzeige
Bedeutung
M12-Buchse Nr. 1-4
R
links
aus
keine Datenübertragung zum A/D-Wandler
grün
Datenübertragung zum A/D-Wandler
E
rechts
aus
einwandfreie Funktion
rot
Fehler:
▪
Drahtbruch oder
▪
Messwert außerhalb des Messbereichs oder
▪
Temperaturkompensation außerhalb des Gültigkeitsbereich


UL-Anforderungen

Montage und Anschlüsse [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Einbinden in ein TwinCAT-Projekt
•
Einstellungen
•
Objektübersicht
•
Objektbeschreibung und Parametrierung
•
Wiederherstellen des Auslieferungszustandes
•
Außerbetriebnahme


Einbinden in ein TwinCAT-Projekt

Inbetriebnahme/Konfiguration [image] Einbinden in ein TwinCAT-Projekt
Einbinden in ein TwinCAT-Projekt
Die Vorgehensweise zum Einbinden in ein TwinCAT-Projekt ist in dieser Schnellstartanleitung beschrieben.


Einstellungen

Inbetriebnahme/Konfiguration [image] Einstellungen
Einstellungen
Weiterführende Informationen
•
Darstellung (Presentation), Index 0x80n0:02
•
Siemens Bits, Index 0x80n0:05
•
Underrange, Overrange
•
Filter
•
Limit 1 und Limit 2
•
Kalibrierung


Darstellung (Presentation), Index 0x80n0:02

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Darstellung (Presentation), Index 0x80n0:02
Darstellung (Presentation), Index 0x80n0:02
Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (Signed Integer).
Index 0x80n0:02 bietet die Möglichkeit zur Veränderung der Darstellungsweise des Messwertes.
Messwert | Ausgabe (hexadezimal) | Ausgabe (Signed Integer, dezimal)
-200,0 °C | 0nF830 | -2000
-100,0 °C | 0nFC18 | -1000
-0,1 °C | 0nFFFF | -1
0,0 °C | 0n0000 | 0
0,1 °C | 0n0001 | 1
100,0 °C | 0n03E8 | 1000
200,0 °C | 0n07D0 | 2000
500,0 °C | 0x1388 | 5000
850,0 °C | 0x2134 | 8500
1000,0 °C | 0x2170 | 10000
Tab. 2: Messwert und Prozessdatenausgabe
▪
Signed Integer:
Der Messwert wird im Zweierkomplement dargestellt.
Maximaler Darstellungsbereich bei 16 Bit = -32768 .. +32767
–
Beispiel:
–
1000 0000 0000 0000bin = 0x8000hex = - 32768dez
–
1111 1111 1111 1110bin = 0nFFFEhex = - 2dez
–
1111 1111 1111 1111bin = 0nFFFFhex = - 1dez
–
0000 0000 0000 0001bin = 0n0001hex = +1dez
–
0000 0000 0000 0010bin = 0n0002hex = +2dez
–
0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
▪
Absolute value with MSB as sign:
Der Messwert wird in der Betrag-Vorzeichendarstellung ausgegeben.
Maximaler Darstellungsbereich bei 16 Bit = -32767 .. +32767
–
Beispiel:
–
1111 1111 1111 1111bin = 0nFFFFhex = - 32767dez
–
1000 0000 0000 0010bin = 0x8002hex = - 2dez
–
1000 0000 0000 0001bin = 0x8001hex = - 1dez
–
0000 0000 0000 0001bin = 0n0001hex = +1dez
–
0000 0000 0000 0010bin = 0n0002hex = +2dez
–
0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
▪
High resolution (1/100 C°):
Der Messwert wird in 1/100 °C Schritten ausgegeben.


Siemens Bits, Index 0x80n0:05

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Siemens Bits, Index 0x80n0:05
Siemens Bits, Index 0x80n0:05
Mit Setzen des Bits in Index 0x80n0:05 werden auf den niedrigsten 3 Bits Statusanzeigen eingeblendet. Im Fehlerfall "Overrange" bzw. "Underrange" wird Bit 0 gesetzt.


Underrange, Overrange

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Underrange, Overrange
Underrange, Overrange
Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:02, 0x60n0:03
▪
Uk > Ukmax: Index 0x60n0:02 und Index 0x60n0:07 (Overrange- und Error-Bit) werden gesetzt. Die Linearisierung der Kennlinie wird mit den Koeffizienten der oberen Bereichsgrenze bis zum Endanschlag des A/D-Wandlers bzw. bis zum Maximalwert 0x7FFF fortgesetzt.
▪
Uk < Ukmax: Index 0x60n0:01 und Index 0x60n0:07 (Underrange- und Error-Bit) werden gesetzt. Die Linearisierung der Kennlinie wird mit den Koeffizienten der unteren Bereichsgrenze bis zum Endanschlag des A/D-Wandlers bzw. bis minimal 0x8000 fortgesetzt.
Bei Overrange bzw. Underrange wird die rote Error-LED eingeschaltet.


Filter

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Filter
Filter
Jeder analoge Eingang hat einen digitalen Filter. Der Filter ist ein Notch-Filter (Kerbfilter).
Der Filter ist immer aktiv, er kann nicht deaktiviert werden. Alle Parameter „Enable Filter“ sind wirkungslos:
0x8000:06, 0x8010:06, 0x8020:06, 0x8030:06.
Filter konfigurieren
Sie können die Filter-Frequenz im Parameter 0x8000:15 „Filter Settings“ einstellen. Dieser Parameter betrifft alle Kanäle. Die Parameter „Filter Settings“ der anderen Kanäle sind wirkungslos:
0x8010:15, 0x8020:15, 0x8030:15.
Einfluss auf die Wandlungszeit
Je höher die Filter-Frequenz ist, desto niedriger ist die Wandlungszeit.


Limit 1 und Limit 2

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Limit 1 und Limit 2
Limit 1 und Limit 2
Limit 1 und Limit 2, Index 0x80n0:13, Index 0x80n0:14
Es kann ein Temperaturbereich eingestellt werden, der von den Werten in den Indizes 0x80n0:13 und 0x80n0:14 begrenzt wird. Beim Überschreiten der Grenzwerte werden die Bits in den Indizes 0x80n0:07 und 0x80n0:08 gesetzt.
Der Temperaturwert wird um in 0,1 °C Auflösung eingegeben.
Beispiel:
Limit 1= 30 °C
Wert Index 0x80n0:13 = 300


Kalibrierung

Inbetriebnahme/Konfiguration [image] Einstellungen [image] Kalibrierung
Kalibrierung
Hersteller-Kalibrierung , Index 0x80n0:0B
Die Freigabe des Hersteller-Abgleichs erfolgt über den Index 0x80n0:0B. Die Parametrierung erfolgt über die Indizes
▪
0x80nF:01
Offset Thermoelement (Herstellerabgleich)
▪
0x80nF:02
Gain Thermoelement (Herstellerabgleich)
▪
0x80nF:03
Offset Vergleichsstelle [PT1000] (Herstellerabgleich)
▪
0x80nF:04
Gain Vergleichsstelle [PT1000] (Herstellerabgleich)
Hersteller- und Anwender-Kalibrierung
Die Aktivierung der Anwender-Kalibrierung (Index 0x80n0:0A) sollte nur anstatt der Herstellerkalibrierung (Index 0x80n0:0B) durchgeführt werden und ist in der Regel nur in Ausnahmefällen notwendig!
Anwender-Kalibrierung , Index 0x80n0:0A
Die Freigabe der Anwender-Kalibrierung erfolgt über den Index 0x80n0:0A. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:17
Offset Thermoelement (Index 0x80nF:01, Anwenderabgleich)
▪
0x80n0:18
Gain Thermoelement (Index 0x80nF:02, Anwenderabgleich)
Anwender Skalierung, Index 0x80n0:01
Die Freigabe der Anwender-Skalierung erfolgt über den Index 0x80n0:01. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:11
Offset Anwender Skalierung

Der Offset beschreibt eine vertikale Verschiebung der Kennlinie um einen linearen Betrag.
Bei einer Auslösung von 0,1° entspricht 1 Digit(dez) einer Messwerterhöhung von 0,1°
Bei einer Auflösung von 0,01° entspricht 1 Digit(dez) einer Messwerterhöhung von 0,01
▪
0x80n0:12
Gain Anwender Skalierung
▪

Der Default-Wert 65536(dez) entspricht Gain = 1.
Bestimmung des neuen Gain-Wertes für 2-Punkt-Abgleich durch Anwender, nach erfolgtem Offset-Abgleich:

Gain_neu = Referenztemperatur / Messwert x 65536(dez)
Berechnung der Prozessdaten
Der bei Beckhoff historisch begründete Begriff „Kalibrierung“ wird hier verwendet, auch wenn er nichts mit Abweichungsaussagen eines Kalibrierungszertifikates zu tun hat. Es werden hier faktisch die hersteller- oder kundenseitigen Abgleichdaten/Justagedaten beschrieben die das Gerät im laufenden Betrieb verwendet um die zugesicherte Messgenauigkeit einzuhalten.
Die Box nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins ADC raw value-Objekten 0x80nE:01, 0x80nE:02. Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Hersteller- und Anwender Abgleichdaten sowie der Anwenderskalierung wenn diese aktiviert sind (s. folgendes Bild).
Berechnung der Prozessdaten
Berechnung | Bezeichung
XADC | Ausgabe des A/D Wandlers
XF | Ausgabe Wert nach dem Filter
YH = (XADC – BH) x AH x 2-14 | Messwert nach Hersteller-Abgleich,
YA = (YH – BA) x AA x 2-14 | Messwert nach Hersteller- und Anwender -Abgleich
YS= YA x AS x 2-16 + BS | Messwert nach Anwender-Skalierung
Legende
Name | Bezeichnung | Index
XADC | Ausgabe Wert des A/D Wandlers | 0x80nE:01
XF | Ausgabe Wert nach dem Filter | -
BH | Offset der Hersteller-Abgleich (nicht veränderbar) | 0x80nF:01
AH | Gain der Hersteller-Abgleich (nicht veränderbar) | 0x80nF:02
BA | Offset der Anwender-Abgleich (aktivierbar über Index 0x80n0:0A) | 0x80n0:17
AA | Gain der Anwender-Abgleich (aktivierbar über Index 0x80n0:0A) | 0x80n0:18
BS | Offset der Anwender-Skalierung (aktivierbar über Index 0x80n0:01) | 0x80n0:11
AS | Gain der Anwender-Skalierung (aktivierbar über Index 0x80n0:01) | 0x80n0:12
YS | Prozessdaten zur Steuerung | -
Messergebnis
Die Genauigkeit des Ergebnisses kann sich verringern, wenn durch eine oder mehrere Multiplikationen der Messwert kleiner als 32767 / 4 beträgt.


Objektübersicht

Inbetriebnahme/Konfiguration [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default-Wert
1000 |  | Device type | RO | 0x014A1389 (21631881dez)
1008 |  | Device name | RO | EPP3314-0002
1009 |  | Hardware version | RO | 04
100A |  | Software version | RO | 06
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x64769529 (1685493033dez)
 | 1018:03 | Revision | RO | 0x00120002 (1179650dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | TC RxPDO-Map Outputs Ch.1 | RO | 0x01 (1dez)
 | 1600:01 | SubIndex 001 | RO | 0x7000:11, 16
1601:0 | Subindex | TC RxPDO-Map Outputs Ch.2 | RO | 0x01 (1dez)
 | 1601:01 | SubIndex 001 | RO | 0x7010:11, 16
1602:0 | Subindex | TC RxPDO-Map Outputs Ch.3 | RO | 0x01 (1dez)
 | 1602:01 | SubIndex 001 | RO | 0x7020:11, 16
1603:0 | Subindex | TC RxPDO-Map Outputs Ch.4 | RO | 0x01 (1dez)
 | 1603:01 | SubIndex 001 | RO | 0x7030:11, 16
1A00:0 | Subindex | TC TxPDO-Map TCInputs Ch.1 | RO | 0x0A (10dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A00:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0F, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:10, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 16
1A01:0 | Subindex | TC TxPDO-Map TCInputs Ch.2 | RO | 0x0A (10dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A01:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0F, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:10, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 16
Index (hex) |  | Name | Flags | Default-Wert
1A02:0 | Subindex | TC TxPDO-Map TCInputs Ch.3 | RO | 0x0A (10dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x6020:0F, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6020:10, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6020:11, 16
1A03:0 | Subindex | TC TxPDO-Map TCInputs Ch.4 | RO | 0x0A (10dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A03:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A03:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A03:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A03:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A03:08 | SubIndex 008 | RO | 0x6030:0F, 1
 | 1A03:09 | SubIndex 009 | RO | 0x6030:10, 1
 | 1A03:0A | SubIndex 010 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dez)
 | 1C12:01 | SubIndex 001 | RW | 0x0000 (0dez)
 | 1C12:02 | SubIndex 002 | RW | 0x0000 (0dez)
 | 1C12:03 | SubIndex 003 | RW | 0x0000 (0dez)
 | 1C12:04 | SubIndex 004 | RW | 0x0000 (0dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0000 (0dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x00002710 (10000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | TC Inputs Ch.1 | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | TC Inputs Ch.2 | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0E | Sync error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
6020:0 | Subindex | TC Inputs Ch.3 | RO | 0x11 (17dez)
 | 6020:01 | Underrange | RO | 0x00 (0dez)
 | 6020:02 | Overrange | RO | 0x00 (0dez)
 | 6020:03 | Limit 1 | RO | 0x00 (0dez)
 | 6020:05 | Limit 2 | RO | 0x00 (0dez)
 | 6020:07 | Error | RO | 0x00 (0dez)
 | 6020:0E | Sync error | RO | 0x00 (0dez)
 | 6020:0F | TxPDO State | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Value | RO | 0x0000 (0dez)
6030:0 | Subindex | TC Inputs Ch.4 | RO | 0x11 (17dez)
 | 6030:01 | Underrange | RO | 0x00 (0dez)
 | 6030:02 | Overrange | RO | 0x00 (0dez)
 | 6030:03 | Limit 1 | RO | 0x00 (0dez)
 | 6030:05 | Limit 2 | RO | 0x00 (0dez)
 | 6030:07 | Error | RO | 0x00 (0dez)
 | 6030:0E | Sync error | RO | 0x00 (0dez)
 | 6030:0F | TxPDO State | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Value | RO | 0x0000 (0dez)
7000:0 | Subindex | TC Outputs Ch.1 | RO | 0x11 (17dez)
 | 7000:11 | CJCompensation | RO | 0x0000 (0dez)
7010:0t | Subindex | TC Outputs Ch.2 | RO | 0x11 (17dez)
 | 7010:11 | CJCompensation | RO | 0x0000 (0dez)
7020:0 | Subindex | TC Outputs Ch.3 | RO | 0x11 (17dez)
 | 7020:11 | CJCompensation | RO | 0x0000 (0dez)
7030:0 | Subindex | TC Outputs Ch.4 | RO | 0x11 (17dez)
 | 7030:11 | CJCompensation | RO | 0x0000 (0dez)
8000:0 | Subindex | TC Settings Ch.1 | RW | 0x1B (27dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x00 (0dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0C | Coldjunction compensation | RW | 0x00 (0dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8000:19 | Sensor Type | RW | 0x0000 (0dez)
 | 8000:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
800E:0 | Subindex | TC Internal data Ch.1 | RO | 0x05 (5dez)
 | 800E:01 | ADC raw value TC | RO | 0x00000000 (0dez)
 | 800E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dez)
 | 800E:03 | CJ temperature | RO | 0x0000 (0dez)
 | 800E:04 | CJ voltage | RO | 0x0000 (0dez)
 | 800E:05 | CJ resistor | RO | 0x0000 (0dez)
800F:0 | Subindex | TC Vendor data Ch.1 | RW | 0x04 (4dez)
 | 800F:01 | Calibration offset TC | RW | 0x0000 (0dez)
 | 800F:02 | Calibration gain TC | RW | 0x4000 (16384dez)
 | 800F:03 | Calibration offset CJ | RW | 0x0000 (0dez)
 | 800F:04 | Calibration gain CJ | RW | 0x4000 (16384dez)
8010:0 | Subindex | TC Settings Ch.2 | RW | 0x1B (27dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0C | Coldjunction compensation | RW | 0x00 (0dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8010:19 | Sensor Type | RW | 0x0000 (0dez)
 | 8010:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
801E:0 | Subindex | TC Internal data Ch.2 | RO | 0x05 (5dez)
 | 801E:01 | ADC raw value TC | RO | 0x00000000 (0dez)
 | 801E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dez)
 | 801E:03 | CJ temperature | RO | 0x0000 (0dez)
 | 801E:04 | CJ voltage | RO | 0x0000 (0dez)
 | 801E:05 | CJ resistor | RO | 0x0000 (0dez)
801F:0 | Subindex | TC Vendor data Ch.2 | RW | 0x04 (4dez)
 | 801F:01 | Calibration offset TC | RW | 0x0000 (0dez)
 | 801F:02 | Calibration gain TC | RW | 0x4000 (16384dez)
 | 801F:03 | Calibration offset CJ | RW | 0x0000 (0dez)
 | 801F:04 | Calibration gain CJ | RW | 0x4000 (16384dez)
8020:0 | Subindex | TC Settings Ch.3 | RW | 0x1B (27dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Siemens bits | RW | 0x00 (0dez)
 | 8020:06 | Enable filter | RW | 0x00 (0dez)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:0C | Coldjunction compensation | RW | 0x00 (0dez)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8020:15 | Filter settings | RW | 0x0000 (0dez)
 | 8020:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8020:19 | Sensor Type | RW | 0x0000 (0dez)
 | 8020:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
802E:0 | Subindex | TC Internal data Ch.3 | RO | 0x05 (5dez)
 | 802E:01 | ADC raw value TC | RO | 0x00000000 (0dez)
 | 802E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dez)
 | 802E:03 | CJ temperature | RO | 0x0000 (0dez)
 | 802E:04 | CJ voltage | RO | 0x0000 (0dez)
 | 802E:05 | CJ resistor | RO | 0x0000 (0dez)
802F:0 | Subindex | TC Vendor data Ch.3 | RW | 0x04 (4dez)
 | 802F:01 | Calibration offset TC | RW | 0x0000 (0dez)
 | 802F:02 | Calibration gain TC | RW | 0x4000 (16384dez)
 | 802F:03 | Calibration offset CJ | RW | 0x0000 (0dez)
 | 802F:04 | Calibration gain CJ | RW | 0x4000 (16384dez)
8030:0 | Subindex | TC Settings Ch.4 | RW | 0x1B (27dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Siemens bits | RW | 0x00 (0dez)
 | 8030:06 | Enable filter | RW | 0x00 (0dez)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:0C | Coldjunction compensation | RW | 0x00 (0dez)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8030:15 | Filter settings | RW | 0x0000 (0dez)
 | 8030:16 | Calibration intervall | RW | 0x0000 (0dez)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 8030:19 | Sensor Type | RW | 0x0000 (0dez)
 | 8030:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dez)
803E:0 | Subindex | TC Internal data Ch.4 | RO | 0x05 (5dez)
 | 803E:01 | ADC raw value TC | RO | 0x00000000 (0dez)
 | 803E:02 | ADC raw value PT1000 | RO | 0x00000000 (0dez)
 | 803E:03 | CJ temperature | RO | 0x0000 (0dez)
 | 803E:04 | CJ voltage | RO | 0x0000 (0dez)
 | 803E:05 | CJ resistor | RO | 0x0000 (0dez)
803F:0 | Subindex | TC Vendor data Ch.4 | RW | 0x04 (4dez)
 | 803F:01 | Calibration offset TC | RW | 0x0000 (0dez)
 | 803F:02 | Calibration gain TC | RW | 0x4000 (16384dez)
 | 803F:03 | Calibration offset CJ | RW | 0x0000 (0dez)
 | 803F:04 | Calibration gain CJ | RW | 0x4000 (16384dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x0000014A (330dez)
 | F010:02 | SubIndex 002 | RW | 0x0000014A (330dez)
 | F010:03 | SubIndex 003 | RW | 0x0000014A (330dez)
 | F010:04 | SubIndex 004 | RW | 0x0000014A (330dez)
F080:0 | Subindex | Channel Enable | RO | 0x04 (4dez)
 | F080:01 | SubIndex 001 | RW | 0xFF (255dez)
 | F080:02 | SubIndex 002 | RW | 0xFF (255dez)
 | F080:03 | SubIndex 003 | RW | 0xFF (255dez)
 | F080:04 | SubIndex 004 | RW | 0xFF (255dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011: Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000: TC Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | TC Settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8000:01 | Enable user scale | Aktiviert die Benutzerskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8000:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Enable filter | Dieser Parameter ist wirkungslos. Der Filter ist immer aktiv. |  | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Cold junction compensation | Kaltstellenkompensation |  | BIT2 | RW | 0x00 (0dez)
 |  | 0 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker.
 |  | 1 | Die Kaltstellenkompensation ist nicht aktiv.
 |  | 2 | Die Kaltstellenkompensation erfolgt über die Prozessdaten.
 |  | 3 | Bewirkt das gleiche wie der Wert 0.
8000:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8000:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Anwenderskalierung: Gain |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Filtereinstellungen (Ch1. gilt für alle Kanäle) |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3,75 kHz
 |  | 7 | 7,5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8000:17 | User calibration offset | Anwenderkalibrierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwenderkalibrierung: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8000: TC Settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:19 | Sensor Type | Thermoelement |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Typ K -200°C bis 1370°C
 |  | 1 | Typ J -100°C bis 1200°C
 |  | 2 | Typ L 0°C bis 900°C
 |  | 3 | Typ E -100°C bis 1000°C
 |  | 4 | Typ T -200°C bis 400°C
 |  | 5 | Typ N -100°C bis 1300°C
 |  | 6 | Typ U 0°C bis 600°C
 |  | 7 | Typ B 600°C bis 1800°C
 |  | 8 | Typ R 0°C bis 1767°C
 |  | 9 | Typ S 0°C bis 1760°C
 |  | 10 | Typ C 0°C bis 2320°C
 |  | 100 | ± 30 mV (1 µV Auflösung)
 |  | 101 | ± 60 mV (2 µV Auflösung)
 |  | 102 | ± 75 mV (4 µV Auflösung)
8000:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8010: TC Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | TC Settings Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8010:01 | Enable user scale | Aktiviert die Benutzerskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8010:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Enable filter | Dieser Parameter ist wirkungslos. Der Filter ist immer aktiv. |  | BOOLEAN | RW | 0x00 (0dez)
8010:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8010:0C | Cold junction compensation | Kaltstellenkompensation |  | BIT2 | RW | 0x00 (0dez)
 |  | 0 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker.
 |  | 1 | Die Kaltstellenkompensation ist nicht aktiv.
 |  | 2 | Die Kaltstellenkompensation erfolgt über die Prozessdaten.
 |  | 3 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker von Kanal 1.
8010:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8010:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Anwenderskalierung: Gain |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
Index 8010: TC Settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:15 | Filter settings | Dieser Parameter ist wirkungslos. Der entsprechende Parameter von Kanal 1 gilt für alle Kanäle: 0x8000:15 „Filter Settings“. |  | UINT16 | RW | 0x0000 (0dez)
8010:16 | Calibration intervall | Reserviert |  | UINT16 | RW | 0x0000 (0dez)
8010:17 | User calibration offset | Anwenderkalibrierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwenderkalibrierung: Gain |  | UINT16 | RW | 0x4000 (16384dez)
8010:19 | Sensor Type | Thermoelement |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Typ K -200°C bis 1370°C
 |  | 1 | Typ J -100°C bis 1200°C
 |  | 2 | Typ L 0°C bis 900°C
 |  | 3 | Typ E -100°C bis 1000°C
 |  | 4 | Typ T -200°C bis 400°C
 |  | 5 | Typ N -100°C bis 1300°C
 |  | 6 | Typ U 0°C bis 600°C
 |  | 7 | Typ B 600°C bis 1800°C
 |  | 8 | Typ R 0°C bis 1767°C
 |  | 9 | Typ S 0°C bis 1760°C
 |  | 10 | Typ C 0°C bis 2320°C
 |  | 100 | ± 30 mV (1 µV Auflösung)
 |  | 101 | ± 60 mV (2 µV Auflösung)
 |  | 102 | ± 75 mV (4 µV Auflösung)
8010:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8020: TC Settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | TC Settings Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8020:01 | Enable user scale | Aktiviert die Benutzerskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8020:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8020:06 | Enable filter | Dieser Parameter ist wirkungslos. Der Filter ist immer aktiv. |  | BOOLEAN | RW | 0x00 (0dez)
8020:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
Index 8020: TC Settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0C | Cold junction compensation | Kaltstellenkompensation |  | BIT2 | RW | 0x00 (0dez)
 |  | 0 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker.
 |  | 1 | Die Kaltstellenkompensation ist nicht aktiv.
 |  | 2 | Die Kaltstellenkompensation erfolgt über die Prozessdaten.
 |  | 3 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker von Kanal 1.
8020:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8020:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain | Anwenderskalierung: Gain |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8020:15 | Filter settings | Dieser Parameter ist wirkungslos. Der entsprechende Parameter von Kanal 1 gilt für alle Kanäle: 0x8000:15 „Filter Settings“. |  | UINT16 | RW | 0x0000 (0dez)
8020:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8020:17 | User calibration offset | Anwenderkalibrierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain | Anwenderkalibrierung: Gain |  | UINT16 | RW | 0x4000 (16384dez)
8020:19 | Sensor Type | Thermoelement |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Typ K -200°C bis 1370°C
 |  | 1 | Typ J -100°C bis 1200°C
 |  | 2 | Typ L 0°C bis 900°C
 |  | 3 | Typ E -100°C bis 1000°C
 |  | 4 | Typ T -200°C bis 400°C
 |  | 5 | Typ N -100°C bis 1300°C
 |  | 6 | Typ U 0°C bis 600°C
 |  | 7 | Typ B 600°C bis 1800°C
 |  | 8 | Typ R 0°C bis 1767°C
 |  | 9 | Typ S 0°C bis 1760°C
 |  | 10 | Typ C 0°C bis 2320°C
 |  | 100 | ± 30 mV (1 µV Auflösung)
 |  | 101 | ± 60 mV (2 µV Auflösung)
 |  | 102 | ± 75 mV (4 µV Auflösung)
8020:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)
Index 8030: TC Settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | TC Settings Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x1B (27dez)
8030:01 | Enable user scale | Aktiviert die Benutzerskalierung |  | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | Darstellung des Messwertes |  | BIT3 | RW | 0x00 (0dez)
 |  | 0 | mit Vorzeichen im Zweierkomplement
 |  | 1 | Höchstwertiges Bit als Vorzeichen
 |  | 2 | Hochauflösend (1/100°C Schritte)
8030:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8030:06 | Enable filter | Dieser Parameter ist wirkungslos. Der Filter ist immer aktiv. |  | BOOLEAN | RW | 0x00 (0dez)
8030:07 | Enable limit 1 | Aktiviert die Limitprüfung für Limit 1 |  | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | Aktiviert die Limitprüfung für Limit 2 |  | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration | Aktiviert die Anwenderkalibrierung |  | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | Aktiviert die Herstellerkalibrierung |  | BOOLEAN | RW | 0x01 (1dez)
8030:0C | Cold junction compensation | Kaltstellenkompensation |  | BIT2 | RW | 0x00 (0dez)
 |  | 0 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker.
 |  | 1 | Die Kaltstellenkompensation ist nicht aktiv.
 |  | 2 | Die Kaltstellenkompensation erfolgt über die Prozessdaten.
 |  | 3 | Die Kaltstellenkompensation erfolgt über den PT-1000 im Stecker von Kanal 1.
8030:0E | Swap limit bits | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. |  | BOOLEAN | RW | 0x00 (0dez)
8030:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain | Anwenderskalierung: Gain |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Limit 1 | Wert für das Limit 1 |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Wert für das Limit 2 |  | INT16 | RW | 0x0000 (0dez)
8030:15 | Filter settings | Dieser Parameter ist wirkungslos. Der entsprechende Parameter von Kanal 1 gilt für alle Kanäle: 0x8000:15 „Filter Settings“. |  | UINT16 | RW | 0x0000 (0dez)
8030:16 | Calibration intervall | reserviert |  | UINT16 | RW | 0x0000 (0dez)
8030:17 | User calibration offset | Anwenderkalibrierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain | Anwenderkalibrierung: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8030: TC Settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:19 | Sensor Type | Thermoelement |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Typ K -200°C bis 1370°C
 |  | 1 | Typ J -100°C bis 1200°C
 |  | 2 | Typ L 0°C bis 900°C
 |  | 3 | Typ E -100°C bis 1000°C
 |  | 4 | Typ T -200°C bis 400°C
 |  | 5 | Typ N -100°C bis 1300°C
 |  | 6 | Typ U 0°C bis 600°C
 |  | 7 | Typ B 600°C bis 1800°C
 |  | 8 | Typ R 0°C bis 1767°C
 |  | 9 | Typ S 0°C bis 1760°C
 |  | 10 | Typ C 0°C bis 2320°C
 |  | 100 | ± 30 mV (1 µV Auflösung)
 |  | 101 | ± 60 mV (2 µV Auflösung)
 |  | 102 | ± 75 mV (4 µV Auflösung)
8030:1B | Wire calibration 1/32 Ohm | Nur für 2-Draht-Messungen: Enthält den Widerstandswert der Zuleitung des Temperatursensors (in 1/32 Ohm). |  | INT16 | RW | 0x0000 (0dez)


Objekte für den regulären Betrieb

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
Die EP3314 verfügt über keine solchen Objekte.


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000: Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Low-Word enthält das verwendete CoE Profil (5001). Das High-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x014A1389 (21631881dez)
Index 1008: Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EPP3314-0002
Index 1009: Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 04
Index 100A: Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 06
Index 1018: Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x64769529 (1685493033dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00120002 (1179650dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0: Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600: TC RxPDO-Map Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | TC RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (TC Outputs Ch.1), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7000:11, 16
Index 1601: TC RxPDO-Map Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | TC RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (TC Outputs Ch.2), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7010:11, 16
Index 1602: TC RxPDO-Map Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | TC RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (TC Outputs Ch.3), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7020:11, 16
Index 1603: TC RxPDO-Map Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | TC RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (TC Outputs Ch.4), entry 0x11 (CJCompensation)) | UINT32 | RO | 0x7030:11, 16
Index 1A00: TC TxPDO-Map TCInputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TC TxPDO-Map TCInputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x07) | UINT32 | RO | 0x1800:07, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (TC Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01: TC TxPDO-Map TCInputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TC TxPDO-Map TCInputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1801, entry 0x07) | UINT32 | RO | 0x1801:07, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1801, entry 0x09) | UINT32 | RO | 0x1801:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (TC Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02: TC TxPDO-Map TCInputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TC TxPDO-Map TCInputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1802, entry 0x07) | UINT32 | RO | 0x1802:07, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (TC Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03: TC TxPDO-Map TCInputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | TC TxPDO-Map TCInputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0A (10dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1803, entry 0x07) | UINT32 | RO | 0x1803:07, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1803, entry 0x09) | UINT32 | RO | 0x1803:09, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (TC Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00: Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12: RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13: TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C32: SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00002710 (10000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33: SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000: TC Inputs Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6000:0 | TC Inputs Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Analoges Eingangsdatum (Auflösung in 1/10 °C) |  | INT16 | RO | 0x0000 (0dez)
Index 6010: TC Inputs Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6010:0 | TC Inputs Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Analoges Eingangsdatum (Auflösung in 1/10 °C) |  | INT16 | RO | 0x0000 (0dez)
Index 6020: TC Inputs Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6020:0 | TC Inputs Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value | Analoges Eingangsdatum (Auflösung in 1/10°C) |  | INT16 | RO | 0x0000 (0dez)
Index 6030: TC Inputs Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6030:0 | TC Inputs Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit erreicht
 |  | 3 | Eingestelltes Limit überschritten
6030:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit erreicht
 |  | 3 | Eingestelltes Limit überschritten
6030:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6030:0E | Sync error | Nur in DC: Bit wird gesetzt, wenn der Slave nicht im Stande ist, Synchron zum Master zu arbeiten da er die Zykluszeit nicht einhalten kann. |  | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value | Analoges Eingangsdatum (Auflösung in 1/10°C) |  | INT16 | RO | 0x0000 (0dez)
Index 7000: TC Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | TC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:11 | CJCompensation | Temperatur der Vergleichsstelle (Auflösung in 1/10°C) (Index 0x8000:0C, Vergleich erfolgt über die Prozessdaten) | INT16 | RO | 0x0000 (0dez)
Index 7010: TC Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | TC Outputs Ch.2 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7010:11 | CJCompensation | Temperatur der Vergleichsstelle (Auflösung in 1/10°C) (Index 0x8010:0C, Vergleich erfolgt über die Prozessdaten) | INT16 | RO | 0x0000 (0dez)
Index 7020: TC Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | TC Outputs Ch.3 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7020:11 | CJCompensation | Temperatur der Vergleichsstelle (Auflösung in 1/10°C) (Index 0x8020:0C, Vergleich erfolgt über die Prozessdaten) | INT16 | RO | 0x0000 (0dez)
Index 7030: TC Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | TC Outputs Ch.4 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7030:11 | CJCompensation | Temperatur der Vergleichsstelle (Auflösung in 1/10°C) (Index 0x8030:0C, Vergleich erfolgt über die Prozessdaten) | INT16 | RO | 0x0000 (0dez)
Index 800E: TC Internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | TC Internal data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
800E:01 | ADC raw value TC | Rohwert des Analog/Digital-Wandlers für das Thermoelement | INT32 | RO | 0x00000000 (0dez)
800E:02 | ADC raw value PT1000 | Rohwert des Analog/Digital-Wandlers für den PT1000 | INT32 | RO | 0x00000000 (0dez)
800E:03 | CJ temperature | Vergleichsstellen-Temperatur (Auflösung 1/10 °C) | INT16 | RO | 0x0000 (0dez)
800E:04 | CJ voltage | Vergleichsstellen-Spannung (Auflösung 1 µV) | INT16 | RO | 0x0000 (0dez)
800E:05 | CJ resistor | Vergleichsstellen-Widerstand für PT1000 Temperatursensor (Auflösung 1/10 Ohm) | UINT16 | RO | 0x0000 (0dez)
Index 800F: TC Vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | TC Vendor data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
800F:01 | Calibration offset TC | Herstellerkalibrierung für Thermoelement: Offset | INT16 | RW | 0x0000 (0dez)
800F:02 | Calibration gain TC | Herstellerkalibrierung für Thermoelement: Gain | UINT16 | RW | 0x4000 (16384dez)
800F:03 | Calibration offset CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Offset | INT16 | RW | 0x0000 (0dez)
800F:04 | Calibration gain CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Gain | UINT16 | RW | 0x4000 (16384dez)
Index 801E: TC Internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | TC Internal data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
801E:01 | ADC raw value TC | Rohwert des Analog/Digital-Wandlers für das Thermoelement | INT32 | RO | 0x00000000 (0dez)
801E:02 | ADC raw value PT1000 | Rohwert des Analog/Digital-Wandlers für den PT1000 | INT32 | RO | 0x00000000 (0dez)
801E:03 | CJ temperature | Vergleichsstellen-Temperatur (Auflösung 1/10 °C) | INT16 | RO | 0x0000 (0dez)
801E:04 | CJ voltage | Vergleichsstellen-Spannung (Auflösung 1 µV) | INT16 | RO | 0x0000 (0dez)
801E:05 | CJ resistor | Vergleichsstellen-Widerstand für PT1000 Temperatursensor (Auflösung 1/10 Ohm) | UINT16 | RO | 0x0000 (0dez)
Index 801F: TC Vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | TC Vendor data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
801F:01 | Calibration offset TC | Herstellerkalibrierung für Thermoelement: Offset | INT16 | RW | 0x0000 (0dez)
801F:02 | Calibration gain TC | Herstellerkalibrierung für Thermoelement: Gain | UINT16 | RW | 0x4000 (16384dez)
801F:03 | Calibration offset CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Offset | INT16 | RW | 0x0000 (0dez)
801F:04 | Calibration gain CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Gain | UINT16 | RW | 0x4000 (16384dez)
Index 802E: TC Internal data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | TC Internal data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
802E:01 | ADC raw value TC | Rohwert des Analog/Digital-Wandlers für das Thermoelement | INT32 | RO | 0x00000000 (0dez)
802E:02 | ADC raw value PT1000 | Rohwert des Analog/Digital-Wandlers für den PT1000 | INT32 | RO | 0x00000000 (0dez)
802E:03 | CJ temperature | Vergleichsstellen-Temperatur (Auflösung 1/10°C) | INT16 | RO | 0x0000 (0dez)
802E:04 | CJ voltage | Vergleichsstellen-Spannung (Auflösung 1 µV) | INT16 | RO | 0x0000 (0dez)
802E:05 | CJ resistor | Vergleichsstellen-Widerstand für PT1000 Temperatursensor (Auflösung 1/10 Ohm) | UINT16 | RO | 0x0000 (0dez)
Index 802F: TC Vendor data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | TC Vendor data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
802F:01 | Calibration offset TC | Herstellerkalibrierung für Thermoelement: Offset | INT16 | RW | 0x0000 (0dez)
802F:02 | Calibration gain TC | Herstellerkalibrierung für Thermoelement: Gain | UINT16 | RW | 0x4000 (16384dez)
802F:03 | Calibration offset CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Offset | INT16 | RW | 0x0000 (0dez)
802F:04 | Calibration gain CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Gain | UINT16 | RW | 0x4000 (16384dez)
Index 803E: TC Internal data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | TC Internal data Ch.4 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
803E:01 | ADC raw value TC | Rohwert des Analog/Digital-Wandlers für das Thermoelement | INT32 | RO | 0x00000000 (0dez)
803E:02 | ADC raw value PT1000 | Rohwert des Analog/Digital-Wandlers für den PT1000 | INT32 | RO | 0x00000000 (0dez)
803E:03 | CJ temperature | Vergleichsstellen-Temperatur (Auflösung 1/10°C) | INT16 | RO | 0x0000 (0dez)
803E:04 | CJ voltage | Vergleichsstellen-Spannung (Auflösung 1 µV) | INT16 | RO | 0x0000 (0dez)
803E:05 | CJ resistor | Vergleichsstellen-Widerstand für PT1000 Temperatursensor (Auflösung 1/10 Ohm) | UINT16 | RO | 0x0000 (0dez)
Index 803F: TC Vendor data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | TC Vendor data Ch.4 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
803F:01 | Calibration offset TC | Herstellerkalibrierung für Thermoelement: Offset | INT16 | RW | 0x0000 (0dez)
803F:02 | Calibration gain TC | Herstellerkalibrierung für Thermoelement: Gain | UINT16 | RW | 0x4000 (16384dez)
803F:03 | Calibration offset CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Offset | INT16 | RW | 0x0000 (0dez)
803F:04 | Calibration gain CJ | Herstellerkalibrierung für Vergleichsstelle (PT1000): Gain | UINT16 | RW | 0x4000 (16384dez)
Index F000: Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand für die Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008: Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010: Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000014A (330dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000014A (330dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000014A (330dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000014A (330dez)
Index F080: Channel Enable
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
F080:0 | Channel Enable | Maximaler Subindex |  |  | UINT8 | RO | 0x04 (4dez)
F080:01 | SubIndex 001 | 0 | Kanal 1 deaktiviert | (ab Hardware-Version 01 werden deaktivierte Kanäle nicht gemessen und die grüne LED R dieser Kanäle erlischt) | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 1 aktiviert
F080:02 | SubIndex 002 | 0 | Kanal 2 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 2 aktiviert
F080:03 | SubIndex 003 | 0 | Kanal 3 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 3 aktiviert
F080:04 | SubIndex 004 | 0 | Kanal 4 deaktiviert |  | BOOLEAN | RW | 0x01 (1dez)
 |  | 1 | Kanal 5 aktiviert


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Außerbetriebnahme

Inbetriebnahme/Konfiguration [image] Außerbetriebnahme
Außerbetriebnahme
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Setzen Sie das Bus-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Demontage der Geräte beginnen!
Entsorgung
Zur Entsorgung muss das Gerät ausgebaut werden.
Gemäß der WEEE-Richtlinie 2012/19/EU nimmt Beckhoff Altgeräte und Zubehör in Deutschland zur fachgerechten Entsorgung zurück. Die Transportkosten werden vom Absender übernommen.
Senden Sie die Altgeräte mit dem Vermerk „zur Entsorgung“ an:
Beckhoff Automation GmbH & Co. KG
Abteilung Service
Stahlstraße 31
D-33415 Verl


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Zubehör
•
Versionsidentifikation von EtherCAT-Geräten
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der IP-67-Module und die verwendeten Metallteile. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Zubehör

Anhang [image] Zubehör
Zubehör
Befestigung
Bestellangabe | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Schutzkappen
Bestellangabe | Beschreibung
ZS5000-0010 | Schutzkappe für M8-Buchsen, IP67 (50 Stück)
ZS5000-0020 | Schutzkappe M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5000-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Leitungen
Eine vollständige Übersicht von vorkonfektionierten Leitungen für EtherCAT-Box-Module finden sie hier.
Bestellangabe | Beschreibung
ZK700x-xxxx-xxxx | EtherCAT-P-Leitung M8 Link zur Website
ZK2000-6xxx-xxxx | Sensorleitung M12 4-polig Link zur Website
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensorleitung M12 5-polig Link zur Website
Werkzeug
Bestellangabe | Beschreibung
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker, 0,4…1,0 Nm
ZB8801-0001 | Wechselklinge für M8 / SW9 für ZB8801-0000
ZB8801-0002 | Wechselklinge für M12 / SW13 für ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar / SW18 für ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet auf https://www.beckhoff.de.


Versionsidentifikation von EtherCAT-Geräten

Anhang [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät hat eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Anhang [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.