EPP3204-0002 - 4x Resistance thermometer
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.1
▪
Front page updated
▪
Structure update
1.0
▪
First release
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product overview

Product overview
Product overview
Additional information
•
Product group: EtherCAT P Box modules
•
Introduction
•
Technical data
•
Scope of supply
•
Process image


Product group: EtherCAT P Box modules

Product overview [image] Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Introduction

Product overview [image] Introduction
Introduction
EPP3204 Inventarbild Website EN
EPP3204-0002
EPP3204-0002 | 4-channel analog input Pt100 (RTD)
The EPP3204 EtherCAT P Box with analog inputs allows resistance sensors to be connected directly. The module’s circuitry can operate the sensors using 2-, 3- or 4-wire connection techniques. Linearisation over the full temperature range is realised with the aid of a microprocessor. The temperature range can be selected freely. The module can also be used for simple resistance measurement with the output in ohms. The module’s standard settings are: resolution 0.1°C in the temperature range of PT100 sensors in 2-wire connection. Sensor malfunctions such as broken wires are indicated by error LEDs. The module is quite versatile, but the default values are selected in such a way that in most cases it is not necessary to perform configuration. The input filter and associated conversion times can be set within a wide range; several data output formats may be chosen. If required, the inputs can be scaled differently. Automatic limit monitoring is also available. Parameterisation is carried out via EtherCAT.
Quick links


Technical data

Product overview [image] Technical data
Technical data
All values are typical values over the entire temperature range, unless stated otherwise.
Technical data
EPP3204-0002
Fieldbus
Fieldbus
EtherCAT
Connection
EtherCAT P: Combined connection for EtherCAT and supply voltages
Input: 1 x M8 socket, 4-pin, P-coded
Downstream connection: 1 x M8 socket, 4-pin, P-coded
Supply voltages
Connection
See Fieldbus connection
Control voltage US
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 3 A 1)
Consumers
Module electronics: 100 mA
Peripheral voltage UP
Nominal voltage
24 VDC (-15 % / +20 %)
Sum current
max. 3 A 1)
Consumers
-
RTD inputs
Number
4
Connector
4 x M12 socket
Sensor types
▪
Platinum RTD: Pt100, Pt200, Pt500, Pt1000
▪
Nickel RTD: Ni100, Ni120, Ni1000
▪
Resistance/potentiometer up to 4095 Ω
Connection technology
▪
2-wire connection
▪
3-wire connection
▪
4-wire connection
Electrical isolation
The measuring channels have a common isolated ground potential.
Measuring current RL+, RL-
Max. 0.5 mA, load-dependent
Measuring range
Platinum RTD: -200 .. +850 °C
Nickel RTD: -60 .. +250 °C (Ni120: -60 .. +320 °C)
Resistance: 0 .. 4095 Ω
Measuring error
Max. ±0.5 K (Pt sensors in 4-wire connection)
Digital resolution
16-bit
Value of an LSB
Temperature measurement:
Standard: 0.1 °C
High-precision: 0.01 °C
Resistance measurement:
Measuring range 1023 Ω: 1/64 Ω
Measuring range 4095 Ω: 1/16 Ω
Filter
Digital filter. Cut-off frequency parameterizable: 5 Hz .. 30 kHz.
Conversion time
2 .. 800 ms, depending on the parameterization.
Default: approx. 85 ms
Diagnostics
▪
Open-circuit recognition
▪
Limit value monitoring
1) Sum current of consumers and power transmission.
Technical data | EPP3204-0002
Environmental conditions
Ambient temperature during operation | -25…+60 °C -25…+55 °C according to cURus
Ambient temperature during storage | -40…+85 °C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 conforms to EN 60529
Mechanics
Weight | approx. 165 g
Installation position | variable
Approvals and conformity
Approvals | CE, cULus
Additional checks
The boxes have been subjected to the following checks:
Verification | Explanation
Vibration | 10 frequency sweeps in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EPP3204-0002
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product overview [image] Process image
Process image
Additional information
•
Assignment of connectors to the process data objects
•
Contents of process data objects


Mounting and connection

Mounting and connection
Mounting and connection
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)
•
EtherCAT P
•
RTD inputs
•
UL Requirements


Dimensions

Mounting and connection [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g


Fixing

Mounting and connection [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Mounting and connection [image] Functional earth (FE)
Functional earth (FE)
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


EtherCAT P

Mounting and connection [image] EtherCAT P
EtherCAT P
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and connection [image] EtherCAT P [image] Connectors
Connectors
Plug connectors for EtherCAT P
1 - input
2 - downstream connection
Connection
M8 socket EPP connection
M8 socket, P-coded
Contact | Signal | Voltage | Core color 1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: Control voltage, +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.


Status LEDs

Mounting and connection [image] EtherCAT P [image] Status LEDs
Status LEDs
Additional information
•
Supply voltages
•
EtherCAT


Supply voltages

Mounting and connection [image] EtherCAT P [image] Status LEDs [image] Supply voltages
Supply voltages
Status LEDs for the supply voltages
EtherCAT P Box Modules have two LEDs that display the status of the supply voltages. The status LEDs are labelled with the designations of the supply voltages: Us and Up.
A status LED lights up green when the respective supply voltage is present.
A Status LED lights up red if the respective supply voltage is short-circuited.


EtherCAT

Mounting and connection [image] EtherCAT P [image] Status LEDs [image] EtherCAT
EtherCAT
ECAT P interface
Status LEDs for EtherCAT
L/A (Link/Act)
A green LED labelled "L/A" or “Link/Act” is located next to each EtherCAT/EtherCAT P socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Conductor losses

Mounting and connection [image] EtherCAT P [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Use the planning tool for EtherCAT P in TwinCAT.
Voltage drop on the supply line
Leitungsverluste M8-EPP 3A
Voltage drop on the supply line


RTD inputs

Mounting and connection [image] RTD inputs
RTD inputs
Additional information
•
Connector
•
Cabling
•
Status LEDs


Connector

Mounting and connection [image] RTD inputs [image] Connector
Connector
M12 sockets
M12 socket
Contact | Core color 1) | 4-wire |  | 3-wire |  | 2-wire
1 | brown | RL+ | Measuring current + | RL+ | Measuring current + | RL+ R+ | Measuring current + Measurement input +
2 | white | R+ | Measurement input + | R+ | Measurement input + | - | -
3 | blue | RL- | Measuring current - | RL- R- | Measuring current – Measurement input - | RL- R- | Measuring current - Measurement input -
4 | black | R- | Measurement input - | - | - | - | -
5 | - | Shield |  | Shield |  | Shield
1) The core colors apply to shielded M12 sensor cables from Beckhoff: ZK2000-7xxx
Connection technology


Cabling

Mounting and connection [image] RTD inputs [image] Cabling
Cabling
▪
Connect each sensor with a shielded, sheathed cable in which the cable shield is connected to contact 5 of the M12 plug. e.g. Beckhoff ZK2000-7xxx.
▪
Two-conductor measurement: use cables with the lowest possible resistance.
▪
Three-conductor measurement: Make sure that the resistances of the conductors for RL+ and RL- are as equal as possible.


Status LEDs

Mounting and connection [image] RTD inputs [image] Status LEDs
Status LEDs
There is a green Run LED and a red Error LED for each channel.
Correct function is indicated if the green Run LED is on and the red Error is off.
Status LEDs at the signal connections
Connection
LED
Display
Meaning
M12 socket no. 1-4
R
left
off
No data transfer to the A/D converter
green
Data transfer to A/D converter
E
right
off
Function OK
red
Error:
▪
Broken wire or
▪
measured value outside measuring range or
▪
temperature compensation outside the valid range


UL Requirements

Mounting and connection [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
SmallWarningYellow CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
SmallWarningYellow CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Integration in TwinCAT
•
Measured value processing
•
Two-point user calibration
•
Limit value monitoring
•
CoE objects
•
Restoring the delivery state
•
Decommissioning


Integration in TwinCAT

Commissioning/Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Measured value processing

Commissioning/Configuration [image] Measured value processing
Measured value processing
Measured value processing
Additional information
•
Vendor calibration
•
User calibration and linearization
•
Scaling, limits and formatting
•
Summary


Vendor calibration

Commissioning/Configuration [image] Measured value processing [image] Vendor calibration
Vendor calibration
Additional information
•
2 and 4-wire resistance measurement
•
3-wire resistance measurement


2 and 4-wire resistance measurement

Commissioning/Configuration [image] Measured value processing [image] Vendor calibration [image] 2 and 4-wire resistance measurement
2 and 4-wire resistance measurement
Whether a measurement is executed as a 2 or 4-wire measurement is determined by the connection points at which the measurement takes place. A comparison value is stored in the firmware for both measuring methods.
▪
With the 2-wire measurement
–
a current is applied between the contact points RL+ und RL- and the voltage drop is measured in order to determine the resistance.
–
The parasitic line resistance cannot be determined by the box itself, but must be entered as a correction value in the CoE register 0x80n0:1B.
▪
With the 4-wire measurement
–
the sensor current is applied between the contact points RL+ und RL- of the M12 socket and the voltage drop at the contact points R+ and R- is used to measure the resistance.
–
The conducting wire is thus not part of the measuring circuit and is not incorporated into the measurement as a source of error.
Resistance measurement with a 4-wire, 3-wire and 2-wire connection technique
The box uses the following calculation rule:
Data flow: resistance measurement with a 2 and 4-wire connection technique
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X: Raw value | 0x80nE:01
 | PT100 |  | PT1000
 | 2-wire | 4-wire | 2-wire | 4-wire
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
YR: Output value in 1/256 Ω | 0x80nE:02
Overflow YR after 16 bits
This value is only for fault finding. The register overflows after 16 bits, i.e. at 65536.


3-wire resistance measurement

Commissioning/Configuration [image] Measured value processing [image] Vendor calibration [image] 3-wire resistance measurement
3-wire resistance measurement
▪
With the 3-wire measurement
–
a defined current is initially applied between the contact points RL+ und RL- and the resistance between them is determined on the basis of the voltage drop.
–
The same procedure is subsequently carried out at the contact points RL+ und R-.
–
The difference between the two measurements is the line resistance of one of the cores of the sensor cable. By knowing the line resistance the resulting measuring error can be compensated.
–
The cores of the sensor cable must have the same resistance in order for the method to work.
Resistance measurement with a 4-wire, 3-wire and 2-wire connection technique
The box uses the following calculation rule
Data flow: resistance measurement with a 3-wire connection technique
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X1: raw value of the 1st measurement | 0x80nE:01
X2: raw value of the 2nd measurement | 0x80nE:03
 | PT100 | PT1000
Gv1: Vendor gain, 1st measurement | 0x80nF:04 | 0x80nF:0A
Ov1: Vendor offset, 1st measurement | 0x80nF:03 | 0x80nF:09
Gv2: Vendor gain, 2nd measurement | 0x80nF:02 | 0x80nF:08
Ov2: Vendor offset, 2nd measurement | 0x80nF:01 | 0x80nF:07
YR1: Output value in 1/256 Ω | 0x80nE:02
YR2: Output value in 1/256 Ω | 0x80nE:04
YR: Output value in 1/256 Ω
Overflow YR1 and YR2 after 16 bits
These values are only for fault finding. The registers overflow after 16 bits, i.e. at 65536.


User calibration and linearization

Commissioning/Configuration [image] Measured value processing [image] User calibration and linearization
User calibration and linearization
▪
The calibrated measured value may also be modified by the user calibration values.
▪
The result of the resistance measurement is mapped onto a temperature value. The fundamental linearization function cannot be modified by the user.
▪
The user scaling is only included after the linearization.
The box uses the following calculation rule
Data flow: user compensation and linearization
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
XV: Output value of the vendor calibration
GU: User Gain | 0x80n0:18
OU: User Offset | 0x80n0:17
Yint: Output value in 1/256 Ω prior to the linearization


Scaling, limits and formatting

Commissioning/Configuration [image] Measured value processing [image] Scaling, limits and formatting
Scaling, limits and formatting
▪
Following the calculation of the resistance value, the scaling and the limit bits are evaluated.
▪
The result is formatted in accordance with the set presentation and copied into the process image.
The box uses the following calculation rule
Data flow: user scaling, limit evaluation, error bits and formatting
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
Ylin: Output value in 1/100 °C
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
Y: Output value PDO


Summary

Commissioning/Configuration [image] Measured value processing [image] Summary
Summary
Summary of the calculation rules:
With the values:
 | Index in the CoE directory with n: channel number with 0 ≤ n ≤ 3 (channel 1 - 4)
X1: Raw value of the 1st measurement | 0x80nE:01
X2: Raw value of the 2nd measurement | 0x80nE:03
 | PT100 |  | PT1000
 | 2-wire | 4-wire | 2-wire | 4-wire
Gv: Vendor Gain | 0x80nF:04 | 0x80nF:06 | 0x80nF:0A | 0x80nF:0C
Ov: Vendor Offset | 0x80nF:03 | 0x80nF:05 | 0x80nF:09 | 0x80nF:0B
 | 3-wire
Gv1: Vendor gain, 1st measurement | 0x80nF:04 |  | 0x80nF:0A
Ov1: Vendor offset, 1st measurement | 0x80nF:03 |  | 0x80nF:09
Gv2: Vendor gain, 2nd measurement | 0x80nF:02 |  | 0x80nF:08
Ov2: Vendor offset, 2nd measurement | 0x80nF:01 |  | 0x80nF:07
GU: User Gain | 0x80n0:18
OU: User Scale Offset | 0x80n0:17
GS: User Scale Gain | 0x80n0:12
OS: User Scale Offset | 0x80n0:11
ƒlin: Function for mapping to the selected method of representation |
ƒpres: Linearization function |
YR1: Output value in 1/256 Ω | 0x80nE:02
YR2: Output value in 1/256 Ω | 0x80nE:04
Y: Output value PDO |
Overflow YR1 and YR2 after 16 bits
These values are only for fault finding. The registers overflow after 16 bits, i.e. at 65536.


Two-point user calibration

Commissioning/Configuration [image] Two-point user calibration
Two-point user calibration
The vendor calibration is to be deactivated via index (0x80n0:0B).
Up to FW version 07 the deactivation of the vendor calibration only results in the vendor gain being set to 214 (fixed-point representation for 1.0). The vendor offset remains unchanged and is still included. This results in the following with vendor calibration deactivated:
Since the last part of the term is constant, a user calibration can be performed despite the unavoidable influence of the vendor offset. The influence of the vendor offset can thereby be fully compensated.
The following method is to be applied:
Carry out two reference measurements with Y1(X1) and Y2(X2). Then the following applies:
GU and OU are to be rounded to the nearest whole number and entered in index 0x80n0:18 and index 0x80n0:17.
X | Raw value (0x80nE:01)
OV: | Vendor Offset (index depends on the mode, see chapter Vendor calibration)
GU: | User Gain (0x80n0:18)
OU: | User Offset (0x80n0:17)
gf: | Gain as a floating value
OR: | Offset as a raw value
Xn: | Measured raw value with reference measurement n
Yn: | Reference value in 1/256 Ω
Yint: | Output value in 1/256 Ω prior to the linearization
Note
Yn: Use of the raw value
Since the resistance value in index 0x8xxE:02 overflows, the raw value in index 0x8xxE:01 is used for Yn.
Additional information
•
Example


Example

Commissioning/Configuration [image] Two-point user calibration [image] Example
Example
Channel 1 is to be calibrated with four-wire connection at two points with 100 Ω and 350 Ω. The vendor offset for the 2-wire calibration is -2607 (taken from index 0x800F:03).
The following measured values are recorded:
100 Ω through precision resistor | X1 = 25600 (1/256 Ω)
171125, read in index 0x800E:01 | Y1 = 171125
350 Ω through precision resistor | X2 = 89600 (1/256 Ω)
592224, read in index 0x800E:01 | Y2 = 592224
With the equations (1) - (3):
the resulting values for gf, GU and OU are:
The indices accept only integer values. The following entries are to be made in the CoE:
Index 0x8000:17 = -12
Index 0x8000:18 = 9960
Subsequently the vendor calibration is to be deactivated (0x8000:0B) and the user calibration activated (0x8000:0A).


Limit value monitoring

Commissioning/Configuration [image] Limit value monitoring
Limit value monitoring
You can define two limit values for each measured value. A variable indicates whether the measured value lies above or below the limit value.
Defining a limit value
Enter the limit value in the appropriate CoE object.
Data format: the same data format as that of the measured value to be monitored.
CoE Index | Name
80n0:13 | Limit 1
80n0:14 | Limit 2
(n = 0 .. 3 for the RTD inputs X01 .. X04)
Activating the monitoring
Set the CoE object for the respective limit value to TRUE:
CoE Index | Name
80n0:07 | Enable limit 1
80n0:08 | Enable limit 2
Evaluation
Evaluate the input variables "Limit 1" and "Limit 2" in the process data:
Value | Meaning
0 | Monitoring is not activated for this limit value.
1 | The measured value is smaller than the limit value.
2 | The measured value is greater than the limit value.


CoE objects

Commissioning/Configuration [image] CoE objects
CoE objects
Additional information
•
Object overview
•
Object description and parameterization


Object overview

Commissioning/Configuration [image] CoE objects [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x01401389 (20976521dec)
1008 |  | Device name | RO | EPP3204-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C844052 (209993810dec)
 | 1018:03 | Revision | RO | 0x00120002 (1179650dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.1 | RO | 0x0A (10dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 2
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 2
 | 1A00:05 | SubIndex 005 | RO | 0x6000:07, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0F, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:10, 1
 | 1A00:09 | SubIndex 009 | RO | 0x1800:11, 16
1A01:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.2 | RO | 0x0A (10dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0F, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:10, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:11, 16
1A02:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.3 | RO | 0x0A (10dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A02:07 | SubIndex 007 | RO | 0x6020:0F, 1
 | 1A02:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6020:11, 16
Index (hex) |  | Name | Flags | Default value
1A03:0 | Subindex | RTD TxPDO-Map RTDInputs Ch.4 | RO | 0x0A (10dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A03:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A03:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A03:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A03:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A03:07 | SubIndex 007 | RO | 0x6030:0F, 1
 | 1A03:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 1A03:09 | SubIndex 009 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dec)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | RTD Inputs Ch.1 | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | 0x00 (0dec)
 | 6000:05 | Limit 2 | RO | 0x00 (0dec)
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | RTD Inputs Ch.2 | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | 0x00 (0dec)
 | 6010:05 | Limit 2 | RO | 0x00 (0dec)
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
6020:0 | Subindex | RTD Inputs Ch.3 | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | 0x00 (0dec)
 | 6020:05 | Limit 2 | RO | 0x00 (0dec)
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | RTD Inputs Ch.4 | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | 0x00 (0dec)
 | 6030:05 | Limit 2 | RO | 0x00 (0dec)
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
8000:0 | Subindex | RTD Settings Ch.1 | RW | 0x1B (27dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x00 (0dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:16 | Calibration intervall | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8000:19 | RTD Element | RW | 0x0000 (0dec)
 | 8000:1A | Connection technology | RW | 0x0000 (0dec)
 | 8000:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
800E:0 | Subindex | RTD Internal data Ch.1 | RO | 0x04 (4dec)
 | 800E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 800E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 800E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 800E:04 | Resistor 2 | RO | 0x0000 (0dec)
800F:0 | Subindex | RTD Vendor data Ch.1 | RW | 0x07 (7dec)
 | 800F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 800F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 800F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 800F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 800F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 800F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 800F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8010:0 | Subindex | RTD Settings Ch.2 | RW | 0x1B (27dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:16 | Calibration intervall | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8010:19 | RTD Element | RW | 0x0000 (0dec)
 | 8010:1A | Connection technology | RW | 0x0000 (0dec)
 | 8010:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
801E:0 | Subindex | RTD Internal data Ch.2 | RO | 0x04 (4dec)
 | 801E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 801E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 801E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 801E:04 | Resistor 2 | RO | 0x0000 (0dec)
801F | Subindex | RTD Vendor data Ch.2 | RW | 0x07 (7dec)
 | 801F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 801F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 801F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 801F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 801F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 801F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 801F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
8020:0 | Subindex | RTD Settings Ch.3 | RW | 0x1B (27dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x00 (0dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:16 | Calibration intervall | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8020:19 | RTD Element | RW | 0x0000 (0dec)
 | 8020:1A | Connection technology | RW | 0x0000 (0dec)
 | 8020:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
802E:0 | Subindex | RTD Internal data Ch.3 | RO | 0x04 (4dec)
 | 802E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 802E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 802E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 802E:04 | Resistor 2 | RO | 0x0000 (0dec)
802F:0 | Subindex | RTD Vendor data Ch.3 | RW | 0x07 (7dec)
 | 802F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 802F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 802F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 802F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 802F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 802F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 802F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
8030:0 | Subindex | RTD Settings Ch.4 | RW | 0x1B (27dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x00 (0dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:16 | Calibration intervall | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
 | 8030:19 | RTD Element | RW | 0x0000 (0dec)
 | 8030:1A | Connection technology | RW | 0x0000 (0dec)
 | 8030:1B | Wire calibration 1/32 Ohm | RW | 0x0000 (0dec)
803E:0 | Subindex | RTD Internal data Ch.4 | RO | 0x04 (4dec)
 | 803E:01 | ADC raw value 1 | RO | 0x00000000 (0dec)
 | 803E:02 | Resistor 1 | RO | 0x0000 (0dec)
 | 803E:03 | ADC raw value 2 | RO | 0x00000000 (0dec)
 | 803E:04 | Resistor 2 | RO | 0x0000 (0dec)
803F:0 | Subindex | RTD Vendor data Ch.4 | RW | 0x07 (7dec)
 | 803F:01 | Calibration offset 3-wire | RW | 0x0000 (0dec)
 | 803F:02 | Calibration gain 3-wire | RW | 0x4000 (16384dec)
 | 803F:03 | Calibration offset 2-wire | RW | 0x0000 (0dec)
 | 803F:04 | Calibration gain 2-wire | RW | 0x4000 (16384dec)
 | 803F:05 | Calibration offset 4-wire | RW | 0x0000 (0dec)
 | 803F:06 | Calibration gain 4-wire | RW | 0x4000 (16384dec)
 | 803F:07 | PGA Gain Correction | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x00000140 (320dec)
 | F010:02 | SubIndex 002 | RW | 0x00000140 (320dec)
 | F010:03 | SubIndex 003 | RW | 0x00000140 (320dec)
 | F010:04 | SubIndex 004 | RW | 0x00000140 (320dec)
Index (hex) |  | Name | Flags | Default value
F080:0 | Subindex | Channel Enable | RO | 0x04 (4dec)
 | F080:01 | SubIndex 001 | RW | 0xFF (255dec)
 | F080:02 | SubIndex 002 | RW | 0xFF (255dec)
 | F080:03 | SubIndex 003 | RW | 0xFF (255dec)
 | F080:04 | SubIndex 004 | RW | 0xFF (255dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


Object description and parameterization

Commissioning/Configuration [image] CoE objects [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access.
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Objects for regular operation
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning/Configuration [image] CoE objects [image] Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011: Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to "0x64616F6C" in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | RTD Settings Ch.1 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8000:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8000:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8000:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8000:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8000:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8000:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8000:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
Index 8000: RTD Settings Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8000:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | RTD Settings Ch.2 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8010:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8010:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8010:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | Activates manufacturer calibration |  | BOOLEAN | RW | 0x01 (1dec)
8010:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8010:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8010:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
Index 8010: RTD Settings Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8010:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is cancelled and no longer set.
8010:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | RTD Settings Ch.3 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8020:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8020:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8020:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8020:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
Index 8020: RTD Settings Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8020:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8020:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8020:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8020:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8020:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | RTD Settings Ch.4 | Maximum subindex |  | UINT8 | RO | 0x1B (27dec)
8030:01 | Enable user scale | Activates user scaling |  | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | Presentation of the measured value |  | BIT3 | RW | 0x00 (0dec)
 |  | 0 | Signed, in two's complement
 |  | 1 | Most significant bit as sign
 |  | 2 | High-resolution (1/100 °C steps)
8030:05 | Siemens bits | The S5 bits are displayed in the three low-order bits |  | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary |  | BOOLEAN | RW | 0x00 (0dec)
8030:07 | Enable limit 1 | Activates limit check for limit 1 |  | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | Activates limit check for limit 2 |  | BOOLEAN | RW | 0x00 (0dec)
Index 8030: RTD Settings Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0A | Enable user calibration | Activates user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | Activates vendor calibration |  | BOOLEAN | RW | 0x01 (1dec)
8030:0E | Swap limit bits | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset | User scaling offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | Gain of the user scaling |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | Value for limit 1 |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Value for limit 2 |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | Filter settings |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz
 |  | 1 | 60 Hz
 |  | 2 | 100 Hz
 |  | 3 | 500 Hz
 |  | 4 | 1 kHz,
 |  | 5 | 2 kHz
 |  | 6 | 3.75 kHz
 |  | 7 | 7.5 kHz
 |  | 8 | 15 kHz
 |  | 9 | 30 kHz
 |  | 10 | 5 Hz
 |  | 11 | 10 Hz
8030:16 | Calibration interval | reserved |  | UINT16 | RW | 0x0000 (0dec)
8030:17 | User calibration offset | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | Gain of the user calibration |  | UINT16 | RW | 0x4000 (16384dec)
8030:19 | RTD element | Sensor type |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | PT100
 |  | 1 | Ni100
 |  | 2 | PT1000
 |  | 3 | PT500
 |  | 4 | PT200
 |  | 5 | Ni1000
 |  | 6 | Ni1000 (Siemens)
 |  | 7 | Ni120
 |  | 8 | Resistance measurement with 1/16 ohm resolution
 |  | 9 | Resistance measurement with 1/64 ohm resolution
8030:1A | Connection technology | Connection technology: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 2-wire
 |  | 1 | 3-wire
 |  | 2 | 4-wire
 |  | 3 | No sensor connected (only supported by hardware version 00): This setting skips the whole measurement, thus speeding up the data acquisition for the other channels. The green status LED of the respective channel remains lit. The error bit of a deactivated channel is canceled and no longer set.
8030:1B | Wire calibration 1/32 Ohm | Only for 2-wire measurements: contains the resistance of the supply line for the temperature sensor (in 1/32 ohm). |  | INT16 | RW | 0x0000 (0dec)


Objects for regular operation

Commissioning/Configuration [image] CoE objects [image] Object description and parameterization [image] Objects for regular operation
Objects for regular operation
EPP3204 has no such objects.


Standard objects (0x1000-0x1FFF)

Commissioning/Configuration [image] CoE objects [image] Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000: Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Low-Word contains the CoE profile used (5001). The High-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01401389 (20976521dec)
Index 1008: Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EPP3204-0002
Index 1009: Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 05
Index 100A: Software version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 07
Index 1018: Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x0C844052 (209993810dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00120002 (1179650dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0: Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00: RTD TxPDO-Map RTDInputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | RTD TxPDO-Map RTDInputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6000:0, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6000:10, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6000:11, 16
Index 1A01: RTD TxPDO-Map RTDInputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | RTD TxPDO-Map RTDInputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6010:0F, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6010:10, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6010:11, 16
Index 1A02: RTD TxPDO-Map RTDInputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | RTD TxPDO-Map RTDInputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6020:0F, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6020:10, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6020:11, 16
Index 1A03: RTD TxPDO-Map RTDInputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | RTD TxPDO-Map RTDInputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry | UINT32 | RO | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry | UINT32 | RO | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry | UINT32 | RO | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry | UINT32 | RO | 0x6030:0F, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry | UINT32 | RO | 0x6030:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry | UINT32 | RO | 0x6030:11, 16
Index 1C00: Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12: RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13: TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A03 (6659dec)
Index 1C33: SM input parameter
Index (hex) | Name | Meaning | Data type | Flags | Default
1C33:0 | SM input parameter | Maximum subindex | UINT8 | RO | 0x20 (32dec)
1C33:01 | Sync mode |  | UINT16 | RW | 0x0000 (0dec)
1C33:02 | Cycle time |  | UINT32 | RW | 0x000F4240 (1000000dec)
1C33:03 | Shift time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:04 | Sync modes supported |  | UINT16 | RO | 0xC007 (49159dec)
1C33:05 | Minimum cycle time |  | UINT32 | RO | 0x00002710 (10000dec)
1C33:06 | Calc and copy time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:08 | Command |  | UINT16 | RW | 0x0000 (0dec)
1C33:09 | Maximum Delay time |  | UINT32 | RO | 0x00000000 (0dec)
1C33:0B | SM event missed counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:0C | Cycle exceeded counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:0D | Shift too short counter |  | UINT16 | RO | 0x0000 (0dec)
1C33:20 | Sync error |  | BOOLEAN | RO | 0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning/Configuration [image] CoE objects [image] Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000: RTD Inputs Ch.1
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | RTD Inputs Ch.1 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6010: RTD Inputs Ch.2
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | RTD Inputs Ch.2 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6020: RTD Inputs Ch.3
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6020:0 | RTD Inputs Ch.3 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if the process data is invalid (cable break, overrange, underrange) |  | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6030: RTD Inputs Ch.4
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6030:0 | RTD Inputs Ch.4 | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process record contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process record contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error | Only in DC: bit is set if the slave is not able to operate synchronous with master, because it cannot keep up with the cycle time. |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 800E: RTD Internal data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | RTD Internal data Ch.1 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
800E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
800E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
800E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
800E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 800F: RTD Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | RTD Vendor data Ch.1 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
800F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
800F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
800F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 801E: RTD Internal data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | RTD Internal data Ch.2 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
801E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
801E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
801E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
801E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 801F: RTD Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | RTD Vendor data Ch.2 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
801F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
801F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
801F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 802E: RTD Internal data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | RTD Internal data Ch.3 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
802E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
802E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
802E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
802E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 802F: RTD Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | RTD Vendor data Ch.3 | Maximum subindex | UINT8 | RO | 0x07 (7dec)
802F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
802F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
802F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index 803E: RTD Internal data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | RTD Internal data Ch.4 | Maximum subindex | UINT8 | RO | 0x04 (4dec)
803E:01 | ADC raw value 1 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
803E:02 | Resistor 1 | Resistance value of the first measurement | UINT16 | RO | 0x0000 (0dec)
803E:03 | ADC raw value 2 | Raw value of the analog/digital converter | INT32 | RO | 0x00000000 (0dec)
803E:04 | Resistor 2 | Resistance value of the second measurement | UINT16 | RO | 0x0000 (0dec)
Index 803F: RTD Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | RTD Vendor data Ch.4 |  | UINT8 | RO | 0x07 (7dec)
803F:01 | Calibration offset 3-wire | Calibration for 3-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration gain 3-wire | Calibration for 3-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:03 | Calibration offset 2-wire | Calibration for 2-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:04 | Calibration gain 2-wire | Calibration for 2-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:05 | Calibration offset 4-wire | Calibration for 4-wire measurement: Offset | INT16 | RW | 0x0000 (0dec)
803F:06 | Calibration gain 4-wire | Calibration for 4-wire measurement: Gain | UINT16 | RW | 0x4000 (16384dec)
803F:07 | PGA Gain Correction | Gain correction for PT1000 measurement | INT16 | RW | 0x0000 (0dec)
Index F000: Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | Maximum subindex | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index spacing for the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008: Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010: Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x04 (4dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000140 (320dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000140 (320dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000140 (320dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000140 (320dec)
Index F080: Channel Enable
Index (hex) | Name | Meaning |  |  | Data type | Flags | Default
F080:0 | Channel Enable | Maximum subindex |  |  | UINT8 | RO | 0x04 (4dec)
F080:01 | SubIndex 001 | 0 | Channel 1 disabled | (from hardware version 01 deactivated channels are not measured, and the green LED R for these channels goes out) | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 1 enabled
F080:02 | SubIndex 002 | 0 | Channel 2 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 2 enabled
F080:03 | SubIndex 003 | 0 | Channel 3 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 3 enabled
F080:04 | SubIndex 004 | 0 | Channel 4 disabled |  | BOOLEAN | RW | 0x01 (1dec)
 |  | 1 | Channel 5 enabled


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Decommissioning

Commissioning/Configuration [image] Decommissioning
Decommissioning
SmallWarningYellow WARNING
Risk of electric shock!
Bring the bus system into a safe, de-energized state before starting disassembly of the devices!
Disposal
In order to dispose of the device, it must be removed.
In accordance with the WEEE Directive 2012/19/EU, Beckhoff takes back old devices and accessories in Germany for proper disposal. Transport costs will be borne by the sender.
Return the old devices with the note "for disposal" to:
Beckhoff Automation GmbH & Co. KG
Service Department
Stahlstraße 31
D-33415 Verl


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Ordering information | Description
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
ZK700x-xxxx-xxxx | EtherCAT P cable M8 Link to website
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com


Assignment of connectors to the process data objects

Product overview [image] Process image [image] Assignment of connectors to the process data objects
Assignment of connectors to the process data objects
Process image in TwinCAT | Connector | Process data object
EPP3204-0002 Prozessabbild zugeklappt | X01 | TC3 InputPDO Symbol RTD RTDInputs Channel 1
 | X02 | TC3 InputPDO Symbol RTD RTDInputs Channel 2
 | X03 | TC3 InputPDO Symbol RTD RTDInputs Channel 3
 | X04 | TC3 InputPDO Symbol RTD RTDInputs Channel 4


Contents of process data objects

Product overview [image] Process image [image] Contents of process data objects
Contents of process data objects
The structure of the content of all process data objects is the same. The content of the process data object of channel 1 is described here by way of example.
EPP3204 process image 1 channel expanded
Process data object "RTD RTDInputs Channel 1"
Status
Variable
Description
TC3 InputVariable Symbol Underrange
TRUE if the measured value falls below the measuring range.
TC3 InputVariable Symbol Overrange
TRUE if the measured value exceeds the measuring range.
TC3 InputVariable Symbol Limit 1
Limit value monitoring
TC3 InputVariable Symbol Limit 2
Limit value monitoring
TC3 InputVariable Symbol Error
TRUE if the measured value is invalid. Possible reasons:
▪
open circuit
▪
Measured value outside of the measuring range
TC3 InputVariable Symbol TxPDO State
TRUE if an internal error occurs.
TC3 InputVariable Symbol TxPDO Toggle
This bit is inverted on each update of the measured value.
You can determine the present conversion time from the time between two edges of this bit.
Value
The measured value.