EPP31xx - EtherCAT P Box Modules with configurable analog inputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® and XPlanar® are registered trademarks of and licensed by Beckhoff Automation GmbH. Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of instructions
In this documentation the following instructions are used.
These instructions must be read carefully and followed without fail!
SmallWarningYellow DANGER
Serious risk of injury!
Failure to follow this safety instruction directly endangers the life and health of persons.
SmallWarningYellow WARNING
Risk of injury!
Failure to follow this safety instruction endangers the life and health of persons.
SmallWarningYellow CAUTION
Personal injuries!
Failure to follow this safety instruction can lead to injuries to persons.
Note
Damage to environment/equipment or data loss
Failure to follow this instruction can lead to environmental damage, equipment damage or data loss.
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Comment
1.1
▪
Front page updated
▪
Scope of supply added
▪
Structure update
1.0.0
▪
1st public issue
0.1.0
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number)
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01
Further information on this topic: Version identification of EtherCAT devices.


Product group: EtherCAT P Box modules

Product group: EtherCAT P Box modules
Product group: EtherCAT P Box modules
EtherCAT P
EtherCAT P supplements the EtherCAT technology with a process in which communication and supply voltages are transmitted on a common line. All EtherCAT properties are retained with this process.
Two supply voltages are transmitted per EtherCAT P line. The supply voltages are electrically isolated from each other and can therefore be switched individually. The nominal supply voltage for both is 24 VDC.
EtherCAT P uses the same cable structure as EtherCAT: a 4-core Ethernet cable with M8 connectors. The connectors are mechanically coded so that EtherCAT connectors and EtherCAT P connectors cannot be interchanged.
EtherCAT P Box modules
EtherCAT P Box modules are EtherCAT P slaves with IP67 protection. They are designed for operation in wet, dirty or dusty industrial environments.
EtherCAT P Einführung
EtherCAT P
EtherCAT basics
A detailed description of the EtherCAT system can be found in the EtherCAT system documentation.


Product overview

Product overview
Product overview
Additional information
•
EPP3174-0002 - Introduction
•
EPP3184-0002 - Introduction
•
Technical data
•
Additional checks
•
Scope of supply
•
Process image


EPP3174-0002 - Introduction

Product overview [image] EPP3174-0002 - Introduction
EPP3174-0002 - Introduction
The EPP3174 EtherCAT P Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10 to +10 V range or the 0 mA/4 mA…20 mA range. The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The four input channels have differential inputs and possess a common, internal ground potential. The input filter and therefore the conversion times are configurable in a wide range. The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available.
EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick links
Technical data
Process image
Signal connection


EPP3184-0002 - Introduction

Product overview [image] EPP3184-0002 - Introduction
EPP3184-0002 - Introduction
The EPP3184 EtherCAT P Box has four analog inputs which can be individually parameterized, so that they process signals either in the -10 V/0 V to +10 V range or the 0 mA/4 mA…20 mA range. The voltage or input current is digitized with a resolution of 16 bits, and is transmitted (electrically isolated) to the higher-level automation device.
The four input channels are single-ended inputs and share a common internal ground potential. The input filter and therefore the conversion times are configurable in a wide range. The inputs can, if required, be scaled differently, and automatic limit value monitoring is also available.
EtherCAT is used for parameterization purposes. The parameters are stored in the module.
Quick links
Technical data
Process image
Signal connection


Technical data

Product overview [image] Technical data
Technical data
Technical data | EPP3174-0002 | EPP3184-0002
Fieldbus | EtherCAT P
Bus interface | 2 x M8 sockets, shielded, screwable, EtherCAT P-coded
Number of inputs | 4 |
Connection technology | two-wire, four-wire | single ended
Input connections | M12, screw type | M12, screw type
Signal type | Configurable: 0 V…+10 V -10 V…+10 V 0 mA…20 mA 4 mA…20 mA
Internal resistance | > 200 kΩ (typ. 85 Ω + diode voltage)
Common-mode voltage UCM | max. 35 V
Resolution | 16 bit (including sign)
Input filter | configurable
Input filter limit frequency | 5 kHz
Conversion time | ~ 100 μs
Measuring error | < ±0.3 % (relative to full scale value)
Nominal voltage | 24 VDC (-15 %/+20 %)
Distributed clocks | yes
Supply of the module electronics | from the control voltage US
Current consumption of the module electronics | typ. 100 mA
Sensor supply | from load voltage UP
Power supply connection | not required
Process image | Inputs: 4 x 16 bit, status: 4 x 8 bit
Electrical isolation | 500 V
Special features | Current or voltage parameterizable
Weight | approx. 165 g
Permissible ambient temperature during operation | -25°C ... +60°C
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE


Additional checks

Product overview [image] Additional checks
Additional checks
The boxes have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


Scope of supply

Product overview [image] Scope of supply
Scope of supply
Make sure that the following components are included in the scope of delivery:
▪
1x EtherCAT P Box EPP31x4-0002
▪
2x protective cap for EtherCAT P socket, M8, red (pre-assembled)
▪
10x labels, blank (1 strip of 10)
Pre-assembled protective caps do not ensure IP67 protection
Protective caps are pre-assembled at the factory to protect connectors during transport. They may not be tight enough to ensure IP67 protection.
Ensure that the protective caps are correctly seated to ensure IP67 protection.


Process image

Product overview [image] Process image
Process image
The process data of the EPP3174-0002 and EPP3184-0002 modules are identical in the default setting and are illustrated here taking the EPP3174-0002 as an example.
A detailed explanation of the meaning of the status bits can be found in the chapters EPP31xx - Settings and Object description and parameterization.
AI Standard Channel 1
You will find the data of the 1st analog channel under AI Standard Channel 1.
AI Standard Channel 2 bis 4
The data of analog channels 2 to 4 have the same structure as those of the 1st channel.


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT P
•
Status LEDs at the M12 connections


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Functional earth (FE)
•
Tightening torques for plug connectors


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions
All dimensions are given in millimeters.
Housing features
Housing material | PA6 (polyamide)
Sealing compound | polyurethane
Mounting | two fastening holes Ø 3.5 mm for M3
Metal parts | brass, nickel-plated
Contacts | CuZn, gold-plated
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | approx. 126 x 30 x 26.5 mm (without connectors)
Weight | approx. 165 g


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Dirt during assembly
Dirty connectors can lead to malfunctions. Protection class IP67 can only be guaranteed if all cables and connectors are connected.
•
Protect the plug connectors against dirt during the assembly.
Mount the module with two M3 screws on the fastening holes in the corners of the module. The fastening holes have no thread.


Functional earth (FE)

Mounting and cabling [image] Mounting [image] Functional earth (FE)
Functional earth (FE)
The upper fastening hole also serves as a connection for functional earth (FE).
Make sure that the box is grounded to low impedance via the functional earth (FE) connection. You can achieve this, for example, by mounting the box on a grounded machine bed.
Connection for functional earth (FE)


Tightening torques for plug connectors

Mounting and cabling [image] Mounting [image] Tightening torques for plug connectors
Tightening torques for plug connectors
Screw connectors tight with a torque wrench. (e.g. ZB8801 from Beckhoff)
Connector diameter | Tightening torque
M8 | 0.4 Nm
M12 | 0.6 Nm


EtherCAT P

Mounting and cabling [image] EtherCAT P
EtherCAT P
Note
Risk of damage to the device!
Bring the EtherCAT/EtherCAT P system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
Note
Pay attention to the maximum permissible current!
Pay attention also for the redirection of EtherCAT P, the maximum permissible current for M8 connectors of 3 A must not be exceeded!
Additional information
•
Connectors
•
Status LEDs
•
Conductor losses


Connectors

Mounting and cabling [image] EtherCAT P [image] Connectors
Connectors
Plug connectors for EtherCAT P
1 - input
2 - downstream connection
Connection
M8 socket EPP connection
M8 socket, P-coded
Contact | Signal | Voltage | Core color 1)
1 | Tx + | GNDS | yellow
2 | Rx + | GNDP | white
3 | Rx - | UP: Peripheral voltage, +24 VDC | blue
4 | Tx - | US: Control voltage, +24 VDC | orange
Housing | Shield | Shield | Shield
1) The core colors apply to EtherCAT P cables and ECP cables from Beckhoff.


Status LEDs

Mounting and cabling [image] EtherCAT P [image] Status LEDs
Status LEDs
Additional information
•
Supply voltages
•
EtherCAT


Supply voltages

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] Supply voltages
Supply voltages
Status LEDs for the supply voltages
EtherCAT P Box Modules have two LEDs that display the status of the supply voltages. The status LEDs are labelled with the designations of the supply voltages: Us and Up.
A status LED lights up green when the respective supply voltage is present.
A Status LED lights up red if the respective supply voltage is short-circuited.


EtherCAT

Mounting and cabling [image] EtherCAT P [image] Status LEDs [image] EtherCAT
EtherCAT
ECAT P interface
Status LEDs for EtherCAT
L/A (Link/Act)
A green LED labelled "L/A" or “Link/Act” is located next to each EtherCAT/EtherCAT P socket. The LED indicates the communication state of the respective socket:
LED | Meaning
off | no connection to the connected EtherCAT device
lit | LINK: connection to the connected EtherCAT device
flashes | ACT: communication with the connected EtherCAT device
Run
Each EtherCAT slave has a green LED labelled "Run". The LED signals the status of the slave in the EtherCAT network:
LED | Meaning
off | Slave is in "Init" state
flashes uniformly | Slave is in "Pre-Operational“ state
flashes sporadically | Slave is in "Safe-Operational" state
lit | Slave is in "Operational" state
Description of the EtherCAT slave states


Conductor losses

Mounting and cabling [image] EtherCAT P [image] Conductor losses
Conductor losses
Take into account the voltage drop on the supply line when planning a system. Avoid the voltage drop being so high that the supply voltage at the box lies below the minimum nominal voltage.
Variations in the voltage of the power supply unit must also be taken into account.
Use the planning tool for EtherCAT P in TwinCAT.
Voltage drop on the supply line
Leitungsverluste M8-EPP 3A
Voltage drop on the supply line


Status LEDs at the M12 connections

Mounting and cabling [image] Status LEDs at the M12 connections
Status LEDs at the M12 connections
Status LEDs an den M12-Anschlüssen_grün
Status LEDs at the M12 connections
Connection | LED | Display | Meaning
M12 socket no. 1-4 | R left | off | No data transfer to the A/D converter
 |  | green | Data transfer to A/D converter
 | E right | off | Function OK
 |  | red | Error: Broken wire or measured value outside the measuring range
Correct function is indicated if the green RUN LED is on and the red Error LED is off.


Configuration

Configuration
Configuration
Additional information
•
Integration in TwinCAT
•
Settings
•
Operating modes
•
Data stream
•
Measuring ranges
•
Calibration
•
Calculation of process data
•
Object overview
•
Object description and parameterization
•
Restoring the delivery state


Integration in TwinCAT

Configuration [image] Integration in TwinCAT
Integration in TwinCAT
The procedure for integration in TwinCAT is described in this Quick start guide.


Settings

Configuration [image] Settings
Settings
Additional information
•
Selection of the analog signal type
•
Representation
•
Siemens bits
•
Underrange, Overrange
•
Limit 1 and Limit 2


Selection of the analog signal type

Configuration [image] Settings [image] Selection of the analog signal type
Selection of the analog signal type
Selection of the analog signal type, index 0xF800:0n
In delivery state, all channels of the EPP31xx are set for analog voltage measurement (-10 V … +10 V).
Note
Setting the correct signal type before connecting the sensors
Set the correct signal type before connecting the sensors!
This setting can be made individually for each channel in the CoE object 0xF800:0n. Changes are immediately effective.
EP3174-0002 Auswahl des Eingangssignals
EPP3174-0002, EPP3184-0002: Selection of the signal type


Representation

Configuration [image] Settings [image] Representation
Representation
Presentation, index 0x80n0:02
The measured value output is set in factory to two's complement representation (signed integer).
Index 0x80n0:02 offers the possibility to change the method of representation of the measured value.
▪
Signed integer representation
The negative output value is represented in two’s complement (negated + 1).
Maximum representation range with 16-bit = -32768 .. +32767dec
Input signal |  |  |  | Value
+/- 10 V | 0...20 mA | 4...20 mA | 0...10 V | decimal | hexadecimal
10 V | 20 mA | 20 mA | 10 V | 32767 | 0x7FFF
5 V | 10 mA | 12 mA | 5 V | 16383 | 0x3FFF
0 V | 0 mA | 4 mA | 0 V | 0 | 0x0000
-5 V | - | - | - | -16383 | 0xC001
-10 V | - | - | - | -32767 | 0x8000
Overview of further representations
▪
Unsigned integer representation
The output value is represented with 15-bit resolution without sign, therefore polarity detection is no longer possible.
Maximum representation range with 16-bit = 0 .. +32767dec
▪
Absolute value with MSB as sign - representation
The output value is displayed in magnitude-sign format: MSB=1 (highest bit) in the case of negative values.
Maximum representation range with 16-bit = -32768 .. +32767dec
Input values (+/- 10 V) | Representation (values dec. / values hex.)
 | unsigned integer | Absolute value with MSB as sign
10 | 32767 / 0x7FFF | 32767 / 0x7FFF
5 V | 16383 / 0x3FFF | 16383 / 0x3FFF
0 V | 0 / 0x0000 | 0 / 0x0000
-5 | 16384 / 0x4000 | [-16384] / 0xC000
-10 | 32767 / 0x7FFF | [-32767] / 0xFFFF
Presentation types
The presentation types Unsigned integer and Absolute value with MSB as sign have no function for unipolar modules. There is no change in the presentation in the positive range.


Siemens bits

Configuration [image] Settings [image] Siemens bits
Siemens bits
Siemens bits, index 0x80n0:05
If this bit is set, status displays are superimposed on the lowest three bits. In the error case "overrange" or "underrange", bit 0 is set.


Underrange, Overrange

Configuration [image] Settings [image] Underrange, Overrange
Underrange, Overrange
Undershoot and overshoot of the measuring range (underrange, overrange), index 0x60n0:01, 0x60n0:02
Chapter Data stream and correction calculation contains a clear description of the correction calculation between the raw values and the output values if the limit ranges are exceeded.
The underrange bit is set if, based on the raw value, a value of 0x1300 is undershot by 1 bit.
The overrange bit is set if the value of 0x7FFF is exceeded by 1 bit.
Error bit (index 0x60n0:07), Error LED
The Error bit and the Error LED are set if, based on the raw value,
a value of approx. 0.5 mA below 4 mA is undershot or
a value of approx. 0.5 mA above 20 mA is exceeded.
•
This prevents the triggering of the Error LED if the sensor transmits a little more than 20 mA.


Limit 1 and Limit 2

Configuration [image] Settings [image] Limit 1 and Limit 2
Limit 1 and Limit 2
Limit 1 ad Limit 2, index 0x80n0:13, index 0x80n0:14
If the limits of the values that can be entered in indices 0x80n0:13 and 0x80n0:14 are violated, the bits in indices 0x60n0:03 and 0x60n0:05 are set accordingly (see sample below). The indices 0x80n0:07 or 0x80n0:08 serve to activate the limit value monitoring.
Output limit n (2-bit):
▪
0: not active
▪
1: Value < limit value
▪
2: Value > limit value
▪
3: Value = limit value
Limit evaluation
The limit evaluation assumes a signed representation. The conversion to the desired representation (index 0x80n0:02) only takes place after the limit evaluation.
Linking in the PLC with 2-bit values
•
PLC:
IEC61131-PLC contains no 2-bit data type that can be linked with this process data directly. In order to transmit the limit information, therefore, define an input byte, e.g.

and link the limit to the VariableSizeMismatch dialog as described in the chapter Process data.
•
Additional task
2-bit variables can be created in the System Manager.

Linking of 2-bit variable to additional task
Sample
Channel 1; Limit 1 and Limit 2 enabled, Limit 1 = 2.8 V, Limit 2 = 7.4 V, representation: signed integer
Entry in index (Limit 1): 0x8000:13
(2.8 V / 10 V) x 216 / 2 - 1 = 9,174dec
Entry in index (Limit 2): 0x8000:14
(7.4 V / 10 V) x 216 / 2 - 1 = 24,247dec
Output:
Input channel 1 | Index 0x6000:03 | Index 60x6000:05
1.8 V | 0x01hex, (Limit 1, limit value undershot) | 0x01hex, (Limit 2, limit value undershot)
2.8 V | 0x03hex, (Limit 1, limit value reached) | 0x01hex, (Limit 2, limit value undershot)
4.2 V | 0x02hex, (Limit 1, limit value exceeded) | 0x01hex, (Limit 2, limit value undershot)
8.5 V | 0x02hex, (Limit 1, limit value exceeded) | 0x02hex, (Limit 2, limit value exceeded)
Swap Limit index 0x80n0:0E
The limit function can be inverted by SwapLimitBits in index 0x80n0:0E.
Output Limit n (2-bit):
SwapLimitBits setting
Value
FALSE (default setting)
▪
0: not active
▪
1: value < limit value
▪
2: value > limit value
▪
3: Value is equal to the limit value
TRUE
▪
0: not active
▪
1: value > limit value
▪
2: value < limit value
▪
3: Value is equal to the limit value


Operating modes

Configuration [image] Operating modes
Operating modes
The EPP31xx supports three different operation modes:
▪
Freerun (filter on, timer interrupt)
▪
Synchronous (filter off, SyncManager interrupt) and
▪
DC (DC-Sync-Interrupt)
Fig. 3: Relationship of operation modes
The module switches between the Freerun (filter on) and Synchron modes by activating/deactivating the filter via the index. This takes place while the module is in OP mode. The changeover may result in longer sampling times and step changes in the process data until the filters have assumed a steady state.
DC mode can only be used when the filters are switched off. Likewise, it is not possible to switch the filters on in DC mode. The DC mode is parameterized via the DC tab in the TwinCAT System Manager.
Synchron mode
In synchronous operation process data are generated frame-triggered, so that a new value is available with each PLC cycle. Synchronous mode is used automatically with the EPP31xx modules (filter off, no DC). The minimum cycle times are 80 µs (EL31x1/EL31x2), and 120 µs (EL31x4) for standard IPCs.
DC operation
In DC mode the analog sampling is triggered by DC-interrupt. As a result, the temporal jitter between two frames is no longer important and the sampling point is the same across the entire system.
The "input-based" mode shifts the sync-interrupt in such a way that the process data are ready for collection shortly before the current process data cycle.
If the frame jitter is too large, it is possible that data may be collected twice or there may be interruptions in the transmission. In that case the jitter is to be reduced through TwinCAT system measures or a slower cycle time is to be chosen.
Filter operation (FIR and IIR), index 0x80n0:06, 0x80n0:15
The EPP31xx modules incorporate a digital filter which, depending on its settings, can adopt the characteristics of a Finite Impulse Response filter (an FIR filter), or an Infinite Impulse Response filter (an IIR filter). The filter is deactivated by default. Please observe the following note regarding activation with index 0x8000:06.
Activation of the filter (index 0x8000: 06), setting of the filter properties (index 0x8000:15)
The filter frequencies are set centrally for all channels of the EPP3xxx modules via index 0x8000:15 (channel 1). The corresponding indices 0x80n0:15 of the other channels have no parameterization function.
FIR filter
The filter works as a notch filter and determines the conversion time of the module. It is parameterized via the index 0x8000:15. The higher the filter frequency, the faster the conversion time. A 50 Hz and a 60 Hz filter are available.
Notch filter means that the filter has zeros (notches) in the frequency response at the filter frequency and multiples thereof, i.e. it attenuates the amplitude at these frequencies.
The FIR filter operates as a non-recursive filter.
typical attenuation curve of notch filter at 50 Hz
Filter data FIR filter (1- to 4-channel modules)
Filter | Attenuation | Limit frequency (-3 dB) | Conversion time
50 Hz FIR | > 50 dB | 22 Hz | 625 µs
60 Hz FIR | > 45 dB | 26 Hz | 521 µs
IIR filter
The filter with IIR characteristics is a discrete time, linear, time invariant filter that can be set to eight levels (level 1 = weak recursive filter, up to level 8 = strong recursive filter)
The IIR can be understood to be a moving average value calculation after a low-pass filter.
Through the synchronization mode FreeRun the IIR filter operates with an internal cycle time of 180 µs (1 or 2 channels) or 500 µs (4 channels).
Filter characteristics for IIR filters
IIR filter | -3 dB cut-off frequency with 500 µs sampling time
IIR 1 | 400 Hz
IIR 2 | 220 Hz
IIR 3 | 100 Hz
IIR 4 | 50 Hz
IIR 5 | 24 Hz
IIR 6 | 12 Hz
IIR 7 | 6.2 Hz
IIR 8 | 3.0 Hz


Data stream

Configuration [image] Data stream
Data stream
The following flow chart illustrates the data stream of the EPP31xx (processing of raw data).
Diagram showing the data stream in the EPP31xx


Measuring ranges

Configuration [image] Measuring ranges
Measuring ranges
The following diagrams show the output values of the measuring ranges as well as the behavior when the limits ranges are exceeded.
EPP3174-0002, EPP3184-0002 (0…20 mA)
Data flow with correction calculation for 0…20 mA
EPP3174-0002, EPP3184-0002 (4…20 mA)
Data flow with correction calculation for 4…20 mA
EPP3174-0002, EPP3184-0002 (+/- 10 V)
Data flow with correction calculation for +/- 10 V
EPP3174-0002, EPP3184-0002 (0…10 V)
Data flow with correction calculation for 0…10 V


Calibration

Configuration [image] Calibration
Calibration
The concept "calibration", which has historical roots at Beckhoff, is used here even if it has nothing to do with the deviation statements of a calibration certificate.
▪
Vendor calibration, index 0x80n0:0B
The vendor calibration is enabled via index 0x80n0:0B. The parameterization takes place via the indices:
–
0x80nF:01 vendor calibration: Offset
–
0x80nF:02 vendor calibration: Gain
▪
User calibration, index 0x80n0:0A
The user calibration is enabled via index 0x80n0:0A. The parameterization takes place via the indices:
–
0x80n0:17 User calibration: Offset
–
0x80n0:18 User calibration: Gain
▪
User scaling, index 0x80n0:01
The user scaling is enabled via index 0x80n0:01. The parameterization takes place via the indices:
–
0x80n0:11 User scaling: Offset
–
0x80n0:12 User scaling: Gain
Vendor calibration
The vendor reserves the right to carry out the basic calibration of the terminal/box modules. Therefore, the vendor calibration cannot be changed.


Calculation of process data

Configuration [image] Calculation of process data
Calculation of process data
The terminal/box constantly records measured values and saves the raw values from its A/D converter in the ADC raw value object 0x80nE:01. The calculation of the correction with the vendor calibration values takes place after each acquisition of the analog signal. This is followed (optionally) by user scaling:
YH= (XADC-BH) * AH measured value after vendor calibration (corresponds to XADC if index 0x80n0:0B inactive)
YA= (YH-BA) * AA measured value after user calibration (corresponds to YH if index 0x80n0:0A inactive)
YS= YA * AS * 22-16 + BS measured value after user scaling (corresponds to YA if index 0x80n0:01 is inactive)
Key
Name | Name | Index
XADC | Output value of the A/D converter | 0x80nE:01
BH | Vendor calibration offset (can only be changed if the object Producer codeword 0xF008 is set) | 0x80nF:01
AH | Vendor calibration gain (can only be changed if the object Producer codeword 0xF008 is set) | 0x80nF:02
YH | Measured value after vendor calibration | -
BA | User calibration offset | 0x80n0:11
AA | User calibration gain | 0x80n0:12
YS | Measured value after user calibration | -
BS | User scaling offset (can be activated via index 0x80x0:0A) | 0x80n0:17
AS | User scaling gain (can be activated via index 0x80x0:0A) | 0x80n0:18
YS | Process data for control, measured value after user scaling | -


Object overview

Configuration [image] Object overview
Object overview
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x012C1389 (19665801dec)
1008 |  | Device name | RO | EPP3174-0002
1009 |  | Hardware version | RO | -
100A |  | Software version | RO | -
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dec)
 | 1018:03 | Revision | RO | 0x00000000 (0dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1800:0 | Subindex | AI TxPDO-Par Standard Ch. 1 | RO | 0x06 (6dec)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par-Compact Ch.1 | RO | 0x06 (6dec)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dec)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
Index (hex) |  | Name | Flags | Default value
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dec)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x06 (6dec)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dec)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x06 (6dec)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dec)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0B (11dec)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6010:0F:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dec)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0B (11dec)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A04:08 | SubIndex 008 | RO | 0x6020:0E, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6020:0F, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:10, 1
 | 1A04:0B | SubIndex 011 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dec)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0B (11dec)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A06:08 | SubIndex 008 | RO | 0x6030:0E, 1
 | 1A06:09 | SubIndex 009 | RO | 0x6030:0F, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:10, 1
 | 1A06:0B | SubIndex 011 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dec)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dec)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dec)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dec)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dec)
1C33:0 | Subindex | SM output parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dec)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dec)
 | 1C33:04 | Sync modes supported | RO | 0xC00B (49163dec)
 | 1C33:05 | Minimum cycle time | RO | 0x0003D090 (250000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dec)
 | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6000:01 | Underrange | RO | 0x00 (0dec)
 | 6000:02 | Overrange | RO | 0x00 (0dec)
 | 6000:03 | Limit 1 | RO | -
 | 6000:05 | Limit 2 | RO | -
 | 6000:07 | Error | RO | 0x00 (0dec)
 | 6000:0E | Sync error | RO | 0x00 (0dec)
 | 6000:0F | TxPDO State | RO | 0x00 (0dec)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6000:11 | Value | RO | 0x0000 (0dec)
6010:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6010:01 | Underrange | RO | 0x00 (0dec)
 | 6010:02 | Overrange | RO | 0x00 (0dec)
 | 6010:03 | Limit 1 | RO | -
 | 6010:05 | Limit 2 | RO | -
 | 6010:07 | Error | RO | 0x00 (0dec)
 | 6010:0E | Sync error | RO | 0x00 (0dec)
 | 6010:0F | TxPDO State | RO | 0x00 (0dec)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6010:11 | Value | RO | 0x0000 (0dec)
6020:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6020:01 | Underrange | RO | 0x00 (0dec)
 | 6020:02 | Overrange | RO | 0x00 (0dec)
 | 6020:03 | Limit 1 | RO | -
 | 6020:05 | Limit 2 | RO | -
 | 6020:07 | Error | RO | 0x00 (0dec)
 | 6020:0E | Sync error | RO | 0x00 (0dec)
 | 6020:0F | TxPDO State | RO | 0x00 (0dec)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs | RO | 0x11 (17dec)
 | 6030:01 | Underrange | RO | 0x00 (0dec)
 | 6030:02 | Overrange | RO | 0x00 (0dec)
 | 6030:03 | Limit 1 | RO | -
 | 6030:05 | Limit 2 | RO | -
 | 6030:07 | Error | RO | 0x00 (0dec)
 | 6030:0E | Sync error | RO | 0x00 (0dec)
 | 6030:0F | TxPDO State | RO | 0x00 (0dec)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 6030:11 | Value | RO | 0x0000 (0dec)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8000:01 | Enable user scale | RW | 0x00 (0dec)
 | 8000:02 | Presentation | RW | 0x00 (0dec)
 | 8000:05 | Siemens bits | RW | 0x00 (0dec)
 | 8000:06 | Enable filter | RW | 0x01 (1dec)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8000:11 | User scale offset | RW | 0x0000 (0dec)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8000:15 | Filter settings | RW | 0x0000 (0dec)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dec)
800E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dec)
800F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 800F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 800F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 800F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 800F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 800F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 800F:06 | R2 Gain | RW | 0x4000 (16384dec)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8010:01 | Enable user scale | RW | 0x00 (0dec)
 | 8010:02 | Presentation | RW | 0x00 (0dec)
 | 8010:05 | Siemens bits | RW | 0x00 (0dec)
 | 8010:06 | Enable filter | RW | 0x00 (0dec)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8010:11 | User scale offset | RW | 0x0000 (0dec)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8010:15 | Filter settings | RW | 0x0000 (0dec)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dec)
801E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dec)
801F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 801F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 801F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 801F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 801F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 801F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 801F:06 | R2 Gain | RW | 0x4000 (16384dec)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 8020:02 | Presentation | RW | 0x00 (0dec)
 | 8020:05 | Siemens bits | RW | 0x00 (0dec)
 | 8020:06 | Enable filter | RW | 0x01 (1dec)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8020:15 | Filter settings | RW | 0x0000 (0dec)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dec)
802E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dec)
802F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 802F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 802F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 802F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 802F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 802F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 802F:06 | R2 Gain | RW | 0x4000 (16384dec)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dec)
 | 8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 8030:02 | Presentation | RW | 0x00 (0dec)
 | 8030:05 | Siemens bits | RW | 0x00 (0dec)
 | 8030:06 | Enable filter | RW | 0x01 (1dec)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dec)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dec)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dec)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dec)
 | 8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dec)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dec)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dec)
 | 8030:15 | Filter settings | RW | 0x0000 (0dec)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dec)
803E:0 | Subindex | AI Internal data | RO | 0x01 (1dec)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dec)
803F:0 | Subindex | AI Vendor data | RW | 0x06 (6dec)
 | 803F:01 | R0 Offset | RW | 0x0000 (0dec)
 | 803F:02 | R0 Gain | RW | 0x4000 (16384dec)
 | 803F:03 | R1 Offset | RW | 0x0000 (0dec)
 | 803F:04 | R1 Gain | RW | 0x4000 (16384dec)
 | 803F:05 | R2 Offset | RW | 0x0000 (0dec)
 | 803F:06 | R2 Gain | RW | 0x4000 (16384dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x04 (4dec)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dec)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dec)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
F800:0 | Subindex | AI Range Settings (neue Module) | RW | 0x04 (4dec)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dec)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dec)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dec)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dec)
 | F800:05 | Enable Filter Settings Per Channel | RW | -
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


Object description and parameterization

Configuration [image] Object description and parameterization
Object description and parameterization
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Parameterization via the CoE list (CAN over EtherCAT)
The EtherCAT device is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to “0x64616F6C” in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Index 8000 AI Settings (parameterization of channel 1)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8000:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8000:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8000:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8000:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8000:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8000:0A | Enable user calibration | 1 | Enabling of the user calibration | BOOLEAN | RW | 0x00 (0dec)
8000:0B | Enable vendor calibration | 1 | Enabling of the vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8000:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8000:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8000:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8000:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8000:15 | Filter settings | This object determines the digital filter settings for all channels of the module, if it is activated via Enable filter (index 0x80n0:06). The possible settings are sequentially numbered. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8000:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8010 AI Settings (parameterization of channel 2)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8010:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8010:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8010:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8010:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8010:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8010:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8010:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8010:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8010:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8010:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8010:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8010:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8010:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8020 AI Settings (parameterization of channel 3)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8020:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8020:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8020:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8020:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8020:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8020:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8020:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8020:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8030 AI Settings (parameterization of channel 4)
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8030:0 | AI Settings | Maximum subindex |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale | 1 | User scale is active. | BOOLEAN | RW | 0x00 (0dec)
8030:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dec)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (signed amount representation)
8030:05 | Siemens bits | 1 | Status indicators are displayed on the lowest 3 bits in the status word. | BOOLEAN | RW | 0x00 (0dec)
8030:06 | Enable filter | 1 | Enable filter, which makes PLC-cycle-synchronous data exchange unnecessary | BOOLEAN | RW | 0x01 (1dec)
8030:07 | Enable limit 1 | 1 | Limit 1 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:08 | Enable limit 2 | 1 | Limit 2 enabled | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration | 1 | Enables user calibration | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration | 1 | Enable vendor calibration | BOOLEAN | RW | 0x01 (1dec)
8030:0E | Swap limit bits | 1 | Swaps the two limit bits, in order to achieve compatibility with older hardware versions. | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain | User scale gain. The gain is represented in fixed-point format, with the factor 2-16. The value 1 corresponds to 65535dec (0x00010000hex) and is limited to +/- 0x7FFFF |  | INT32 | RW | 0x00010000 (65536dec)
8030:13 | Limit 1 | First limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:14 | Limit 2 | Second limit value for setting the status bits |  | INT16 | RW | 0x0000 (0dec)
8030:15 | Filter settings | This object shows the digital filter settings. The filter settings can only be read here. They are set via channel 1 for all channels of the module. |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset | User calibration: Offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain | User calibration: Gain |  | INT16 | RW | 0x0000 (0dec)
Index F800 AI Range Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x04 (4dec)
F800:01 | Input type Ch1 | Input signal range for channel 1 |  | UINT16 | RW | 0x0000 (0dec)
 |  | 0 | -10 V...+10 V
 |  | 1 | 0 mA...20 mA
 |  | 2 | 4 mA...20 mA
 |  | 6 | 0 V...10 V
F800:02 | Input type Ch2 | Input signal range for channel 2 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:03 | Input type Ch3 | Input signal range for channel 3 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:04 | Input type Ch4 | Input signal range for channel 4 (values see channel 1) |  | UINT16 | RW | 0x0000 (0dec)
F800:05 | Enable Filter Settings Per Channel |  |  | BOOLEAN | RW | -
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x012C1389 (19665801dec)
Index 1008 Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EPP3174-0002, EPP3184-0002,
Index 1009 Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO | 01
Index 100A Software Version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | EPP3174-0002 0x0C664052 (208027730dec) EPP3184-0002 0x64768D09 (168540953dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the Low Word (bit 0-15) indicates the special terminal number, the High Word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the Low Byte (bit 0-7) of the Low Word contains the year of production, the High Byte (bit 8-15) of the Low Word contains the week of production, the High Word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1800 AI TxPDO-Par Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO parameter TxPDO 1 | UINT8 | RO | 0x06 (6dec)
1800:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 1 | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO parameter TxPDO 2 | UINT8 | RO | 0x06 (6dec)
1801:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 2 | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO parameter TxPDO 3 | UINT8 | RO | 0x06 (6dec)
1802:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 3 | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO parameter TxPDO 4 | UINT8 | RO | 0x06 (6dec)
1803:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 4 | OCTET-STRING[2] | RO | 02 1A
Index 1804 AI TxPDO-Par Standard Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO parameter TxPDO 5 | UINT8 | RO | 0x06 (6dec)
1804:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 5 | OCTET-STRING[2] | RO | 05 1A
Index 1805 AI TxPDO-Par Compact Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO parameter TxPDO 6 | UINT8 | RO | 0x06 (6dec)
1805:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 6 | OCTET-STRING[2] | RO | 04 1A
Index 1806 AI TxPDO-Par Standard Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.4 | PDO parameter TxPDO 7 | UINT8 | RO | 0x06 (6dec)
1806:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 7 | OCTET-STRING[2] | RO | 07 1A
Index 1807 AI TxPDO-Par Compact Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO parameter TxPDO 8 | UINT8 | RO | 0x06 (6dec)
1807:06 | Exclude TxPDOs | Specifies the TxPDOs (index of TxPDO mapping objects) that must not be transferred together with TxPDO 8 | OCTET-STRING[2] | RO | 06 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (AI TxPDO-Par Standard Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (AI TxPDO-Par Standard Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A04 AI TxPDO-Map Standard Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0B (11dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 AI TxPDO-Map Compact Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A06 AI TxPDO-Map Standard Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0B (11dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x07 (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A07 AI TxPDO-Map Compact Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the Sync Managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A02 (6658dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A04 (6660dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RW | 0x1A06 (6662dec)
Index 1C33 SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchron with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchron with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input Shift through local event (outputs available)
▪
Bit 4-5 = 10: Input Shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C33:08)
UINT16
RO
0xC00B (49163dec)
1C33:05
Minimum cycle time
UINT32
RO
0x0003D090 (250000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00002710 (10000dec)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dec)
1C33:08
Command
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00001388 (5000dec)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6000:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6000:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6000:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6000:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6000:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6010 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6010:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6010:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6010:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6010:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6010:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6020 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6020:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6020:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6020:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6020:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6020:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6020:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs
Index (hex) | Name | Meaning |  | Data type | Flags | Default
6030:0 | AI inputs | Maximum subindex |  | UINT8 | RO | 0x11 (17dec)
6030:01 | Underrange | Is set if the value falls below the operating range of the sensor or the process data contains the lowest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:02 | Overrange | Is set if the value exceeds the operating range of the sensor or the process data contains the highest possible value. |  | BOOLEAN | RO | 0x00 (0dec)
6030:03 | Limit 1 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:05 | Limit 2 | Only when limit check is active |  | BIT2 | RO | 0x00 (0dec)
 |  | 1 | Value below set limit
 |  | 2 | Set limit exceeded
 |  | 3 | Set limit reached
6030:07 | Error | The error bit is set if the process data is invalid (wire breakage, overrange, underrange). |  | BOOLEAN | RO | 0x00 (0dec)
6030:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dec)
6030:0F | TxPDO State | Validity of the data of the associated TxPDO |  | BOOLEAN | RO | 0x00 (0dec)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO toggle is toggled by the slave when the data of the associated TxPDO is updated. |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value | Analog input date |  | INT16 | RO | 0x0000 (0dec)
Index 800E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
800E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
800E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 800F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
800F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
800F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
800F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
800F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 801E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
801E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
801E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 801F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
801F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
801F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
801F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
801F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 802E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
802E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
802E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 802F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
802F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
802F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
802F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index 803E AI Internal data
Index (hex) | Name | Meaning | Data type | Flags | Default
803E:0 | AI internal data | Maximum subindex | UINT8 | RO | 0x01 (1dec)
803E:01 | ADC raw value | Raw value of the analog/digital converter | INT16 | RO | 0x0000 (0dec)
Index 803F AI Vendor data
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AI vendor data | Maximum subindex | UINT8 | RO | 0x06 (6dec)
803F:01 | R0 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:02 | R0 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:03 | R1 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:04 | R1 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
803F:05 | R2 Offset | Offset (vendor calibration) | INT16 | RW | 0x0000 (0dec)
803F:06 | R2 Gain | Gain (vendor calibration) | INT16 | RW | 0x4000 (16384dec)
Index F000 Modular device profile
Index (hex) | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0004 (4dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word | reserved | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list | Maximum subindex | UINT8 | RW | 0x05 (5dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)


Restoring the delivery state

Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx- and EPPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
Notices on analog specifications
•
Accessories
•
Version identification of EtherCAT devices
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12.5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2.5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the IP 67 modules and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
▪
resistant: Lifetime several months
▪
non inherently resistant: Lifetime several weeks
▪
not resistant: Lifetime several hours resp. early decomposition


Notices on analog specifications

Appendix [image] Notices on analog specifications
Notices on analog specifications
Beckhoff I/O devices (terminals, boxes) with analog inputs are characterized by a number of technical characteristic data; refer to the technical data in the respective documents.
Some explanations are given below for the correct interpretation of these characteristic data.
Full scale value
An I/O device with an analog input measures over a nominal measuring range that is limited by an upper and a lower limit (initial value and end value); these can usually be taken from the terminal/box designation. The range between the two limits is called the measuring span and corresponds to the equation (end value - initial value). Analogous to pointing devices this is the measuring scale (see IEC 61131) or also the dynamic range. For analog I/O devices from Beckhoff the rule is that the limit with the largest value is chosen as the full scale value of the respective product (also called the reference value) and is given a positive sign. This applies to both symmetrical and asymmetrical measuring spans.
Measuring range
For the above examples this means:
▪
Measuring range 0 to 10 V: asymmetric unipolar, full scale value = 10 V, measuring span = 10 V
▪
Measuring range 4 to 20 mA: asymmetric unipolar, full scale value = 20 mA, measuring span = 16 mA
▪
Measuring range -200 to 1370 °C: asymmetric bipolar, full scale value = 1370 °C, measuring span = 1570 °C
▪
Measuring range -10 to +10 V: symmetric bipolar, full scale value = 10 V, measuring span = 20 V
This applies equally for analog output terminals/boxes.
± Measuring error [% of the full scale value] (also: measurement error)
The relative measuring error is referenced to the full scale value and is calculated as the quotient of the largest numerical deviation from the true value (‘measuring error’) referenced to the full scale value.
The measuring error is generally valid for the entire permitted operating temperature range, also called the ‘usage error limit’ and contains random and systematic portions of the referred device (i.e. ‘all’ influences such as temperature, inherent noise, aging, etc.).
It always to be regarded as a positive/negative span with ±, even if it is specified without ± in some cases.
The maximum deviation can also be specified directly.
Example: Measuring range 0 to 10 V and measuring error < ± 0.3 % full scale value → maximum deviation ± 30 mV in the permissible operating temperature range.
Notice: since this specification also includes the temperature drift, a significantly lower measuring error can usually be assumed in case of a constant ambient temperature and thermal stabilization of the device. This applies equally for analog output terminals/boxes.
Single-ended/differential typification
For analog inputs Beckhoff makes a basic distinction between two types: single-ended (SE) and differential (DIFF), referring to the difference in electrical connection with regard to the potential difference.
The diagram shows two-channel versions of an SE module and a DIFF module as examples for all multi-channel versions.
Single-ended/differential typification
Notice: Dashed lines indicate that the respective connection may not necessarily be present in each SE or DIFF module.
The basic rule:
▪
Analog measurements always take the form of voltage measurements between two potential points. For voltage measurements a large R is used, in order to ensure a high impedance. For current measurements a small R is used as shunt. If the purpose is resistance measurement, corresponding considerations are applied.
–
Beckhoff generally refers to these two points as input+/signal potential and input-/reference potential.
–
For measurements between two potential points two potentials have to be supplied.
–
Regarding the terms "single-wire connection" or "three-wire connection", please note the following for pure analog measurements: three- or four-wire connections can be used for sensor supply, but are not involved in the actual analog measurement, which always takes place between two potentials/wires. In particular this also applies to SE, even though the term suggest that only one wire is required.
▪
The term "electrical isolation" should be clarified in advance. Beckhoff IO modules feature 1…8 or more analog channels; with regard to the channel connection a distinction is made in terms of:
–
how the channels WITHIN a module relate to each other, or
–
how the channels of SEVERAL modules relate to each other.
The property of electrical isolation indicates whether the channels are directly connected to each other.
▪
Beckhoff terminals/boxes always feature electrical isolation between the field/analog side and the bus/EtherCAT side. In other words, if two analog terminals/boxes are not connected via the power contacts, the modules are effectively electrically isolated.
▪
If channels within a module are electrically isolated, or if a single-channel module has no power contacts, the channels are effectively always differential. See also explanatory notes below. Differential channels are not necessarily electrically isolated.
▪
Analog measuring channels are subject to technical limits, both in terms of the recommended operating range (continuous operation) and the destruction limit. Please refer to the respective terminal documentation for further details.
Explanation
▪
Differential
–
Differential measurement is the most flexible concept. The user can freely choose both connection points, input+/signal potential and input-/reference potential, within the framework of the technical specification.
–
A differential channel can also be operated as SE, if the reference potential of several sensors is linked. This interconnection may take place via the system GND.
–
Since a differential is configured symmetrically internally (see diagram), there will be a mid-potential (X) between the two supplied potentials that is the same as the internal ground/reference ground for this channel. If several DIFF channels are used in a module without electrical isolation, the technical property VCM (common-mode voltage) indicates the degree to which the mean voltage of the channels may differ.
–
The internal reference ground may be accessible as connection point at the terminal/box, in order to stabilize a defined GND potential in the terminal/box. In this case it is particularly important to pay attention to the quality of this potential (noiselessness, voltage stability). At this GND point a wire may be connected to make sure that VCM,max is not exceeded in the differential sensor cable. If differential channels are not electrically isolated, usually only one VCM,max is permitted. If the channels are electrically isolated this limit should not apply, and the channels voltages may differ up to the specified separation limit.
–
Differential measurement in combination with correct sensor wiring has the special advantage that any interference affecting the sensor cable (ideally the feed and return line are arranged side by side, so that interference signals have the same effect on both wires) has very little effect on the measurement, since the potential of both lines varies jointly (hence the term common mode). In simple terms: Common-mode interference has the same effect on both wires in terms of amplitude and phasing.
–
Nevertheless, the suppression of common-mode interference within a channel or between channels is subject to technical limits, which are specified in the technical data.
▪
Single Ended
–
If the analog circuit is designed as SE, the input/reference wire is internally fixed to a certain potential that cannot be changed. This potential must be accessible from outside on at least one point for connecting the reference potential, e.g. via the power contacts.
–
In other words, in situations with several channels SE offers users the option to avoid returning at least one of the two sensor cables to the terminal/box (in contrast to DIFF). Instead, the reference wire can be consolidated at the sensors, e.g. in the system GND.
–
A disadvantage of this approach is that the separate feed and return line can result in voltage/current variations, which a SE channel may no longer be able to handle. See common-mode interference. A VCM effect cannot occur, since the module channels are internally always 'hard-wired' through the input/reference potential.
Typification of the 2/3/4-wire connection of current sensors
Current transducers/sensors/field devices (referred to in the following simply as ‘sensor’) with the industrial 0/4-20 mA interface typically have internal transformation electronics for the physical measured variable (temperature, current, etc.) at the current control output. These internal electronics must be supplied with energy (voltage, current). The type of cable for this supply thus separates the sensors into self-supplied or externally supplied sensors:
▪
Self-supplied sensors
–
The sensor draws the energy for its own operation via the sensor/signal cable + and -. So that enough energy is always available for the sensor’s own operation and open-circuit detection is possible, a lower limit of 4 mA has been specified for the 4-20 mA interface; i.e. the sensor allows a minimum current of 4 mA and a maximum current of 20 mA to pass.
–
For a 2-wire connection; see IEC60381-1
–
Such current transducers generally represent a current sink and thus like to sit between + and – as a ‘variable load’. Refer also to the sensor manufacturer’s information.
Therefore, they are to be connected according to the Beckhoff terminology as follows:
▪
preferably to ‘single-ended’ inputs if the +Supply connections of the terminal/box are also to be used - connect to +Supply and Signal
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
Externally supplied sensors
▪
3- and 4-wire connection see Fig. Connection of externally supplied sensors, cf. IEC60381-1
▪
the sensor draws the energy/operating voltage for its own operation from 2 supply cables of its own. One or two further sensor cables are used for the signal transmission of the current loop:
1.
sensor cable: according to the Beckhoff terminology such sensors are to be connected to ‘single-ended’ inputs in 3 cables with +/-/Signal lines and if necessary FE/shield
2.
sensor cables: In the case of sensors with 4-wire connection according to +-/+Signal/-Signal, you must check whether +Signal may be connected to +Supply or –Signal to –Supply.
–
Yes: then you can connect accordingly to a Beckhoff ‘single-ended’ input.
–
the Beckhoff ‘differential’ input for +Signal and –Signal is to be selected; +Supply and –Supply are to be connected via additional cables.
Notice: expert organizations such as NAMUR demand a usable measuring range <4 mA/>20 mA for error detection and adjustment, see also NAMUR NE043.
The Beckhoff device documentation must be consulted in order to see whether the respective device supports such an extended signal range.
In general the polarity/direction of current is to be observed due to the internal diode!
2/3/4-wire connection as single-ended or differential connection technology


Accessories

Appendix [image] Accessories
Accessories
Mounting
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Cables
A complete overview of pre-assembled cables for EtherCAT Box modules can be found here.
Ordering information | Description
ZK2000-5xxx-xxxx ZK2000-71xx-xxxx | Sensor cable M12 5-wire Link to website
ZK2000-6xxx-xxxx | Sensor cable M12 4-wire Link to website
ZK700x-xxxx-xxxx | EtherCAT P cable M8 Link to website
Labeling material, protective caps
Ordering information | Description
ZS5000-0010 | Protective cap for M8 sockets, IP67 (50 pieces)
ZS5000-0020 | Protective cap M12, IP67 (50 pieces)
ZS5100-0000 | Inscription labels, unprinted, 4 strips of 10
ZS5000-xxxx | Printed inscription labels on enquiry
Tools
Ordering information | Description
ZB8801-0000 | Torque wrench for plugs, 0.4…1.0 Nm
ZB8801-0001 | Torque cable key for M8 / wrench size 9 for ZB8801-0000
ZB8801-0002 | Torque cable key for M12 / wrench size 13 for ZB8801-0000
ZB8801-0003 | Torque cable key for M12 field assembly / wrench size 18 for ZB8801-0000
Further accessories
Further accessories can be found in the price list for fieldbus components from Beckhoff and online at https://www.beckhoff.com.


Version identification of EtherCAT devices

Appendix [image] Version identification of EtherCAT devices
Version identification of EtherCAT devices
Designation
A Beckhoff EtherCAT device has a 14-digit designation, made up of
▪
family key
▪
type
▪
version
▪
revision
Example | Family | Type | Version | Revision
EL3314-0000-0016 | EL terminal (12 mm, non-pluggable connection level) | 3314 (4-channel thermocouple terminal) | 0000 (basic type) | 0016
ES3602-0010-0017 | ES terminal (12 mm, pluggable connection level) | 3602 (2-channel voltage measurement) | 0010 (high-precision version) | 0017
CU2008-0000-0000 | CU device | 2008 (8-port fast ethernet switch) | 0000 (basic type) | 0000
Notes
▪
The elements mentioned above result in the technical designation. EL3314-0000-0016 is used in the example below.
▪
EL3314-0000 is the order identifier, in the case of “-0000” usually abbreviated to EL3314. “-0016” is the EtherCAT revision.
▪
The order identifier is made up of
- family key (EL, EP, CU, ES, KL, CX, etc.)
- type (3314)
- version (-0000)
▪
The revision -0016 shows the technical progress, such as the extension of features with regard to the EtherCAT communication, and is managed by Beckhoff.
In principle, a device with a higher revision can replace a device with a lower revision, unless specified otherwise, e.g. in the documentation.
Associated and synonymous with each revision there is usually a description (ESI, EtherCAT Slave Information) in the form of an XML file, which is available for download from the Beckhoff web site.
From 2014/01 the revision is shown on the outside of the IP20 terminals, see Fig. “EL5021 EL terminal, standard IP20 IO device with batch number and revision ID (since 2014/01)”.
▪
The type, version and revision are read as decimal numbers, even if they are technically saved in hexadecimal.
Identification number
Beckhoff EtherCAT devices from the different lines have different kinds of identification numbers:
Production lot/batch number/serial number/date code/D number
The serial number for Beckhoff IO devices is usually the 8-digit number printed on the device or on a sticker. The serial number indicates the configuration in delivery state and therefore refers to a whole production batch, without distinguishing the individual modules of a batch.
Structure of the serial number: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with
Ser. no.: 12063A02: 12 - production week 12 06 - production year 2006 3A - firmware version 3A 02 - hardware version 02
Exceptions can occur in the IP67 area, where the following syntax can be used (see respective device documentation):
Syntax: D ww yy x y z u
D - prefix designation
ww - calendar week
yy - year
x - firmware version of the bus PCB
y - hardware version of the bus PCB
z - firmware version of the I/O PCB
u - hardware version of the I/O PCB
Example: D.22081501 calendar week 22 of the year 2008 firmware version of bus PCB: 1 hardware version of bus PCB: 5 firmware version of I/O PCB: 0 (no firmware necessary for this PCB) hardware version of I/O PCB: 1
Unique serial number/ID, ID number
In addition, in some series each individual module has its own unique serial number.
See also the further documentation in the area
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Terminals with factory calibration certificate and other measuring terminals
Examples of markings
EL5021 EL terminal, standard IP20 IO device with serial/ batch number and revision ID (since 2014/01)
EK1100 EtherCAT coupler, standard IP20 IO device with serial/ batch number
CU2016 switch with serial/ batch number
EL3202-0020 with serial/ batch number 26131006 and unique ID-number 204418
EP1258-00001 IP67 EtherCAT Box with batch number/ date code 22090101 and unique serial number 158102
EP1908-0002 IP67 EtherCAT Safety Box with batch number/ date code 071201FF and unique serial number 00346070
EL2904 IP20 safety terminal with batch number/ date code 50110302 and unique serial number 00331701
ELM3604-0002 terminal with unique ID number (QR code) 100001051 and serial/ batch number 44160201
Additional information
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Appendix [image] Version identification of EtherCAT devices [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
The Beckhoff Identification Code (BIC) is increasingly being applied to Beckhoff products to uniquely identify the product. The BIC is represented as a Data Matrix Code (DMC, code scheme ECC200), the content is based on the ANSI standard MH10.8.2-2016.
Beckhoff Identification Code
BIC as data matrix code (DMC, code scheme ECC200)
The BIC will be introduced step by step across all product groups.
Depending on the product, it can be found in the following places:
▪
on the packaging unit
▪
directly on the product (if space suffices)
▪
on the packaging unit and the product
The BIC is machine-readable and contains information that can also be used by the customer for handling and product management.
Each piece of information can be uniquely identified using the so-called data identifier (ANSI MH10.8.2-2016). The data identifier is followed by a character string. Both together have a maximum length according to the table below. If the information is shorter, spaces are added to it. The data under positions 1 to 4 are always available.
The following information is contained:
Item no. | Type of information | Explanation | Data identifier | Number of digits incl. data identifier | Example
1 | Beckhoff order number | Beckhoff order number | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Unique serial number, see note below | S | 12 | SBTNk4p562d7
3 | Article description | Beckhoff article description, e.g. EL1008 | 1K | 32 | 1KEL1809
4 | Quantity | Quantity in packaging unit, e.g. 1, 10, etc. | Q | 6 | Q1
5 | Batch number | Optional: Year and week of production | 2P | 14 | 2P401503180016
6 | ID/serial number | Optional: Present-day serial number system, e.g. with safety products | 51S | 12 | 51S678294104
7 | Variant number | Optional: Product variant number on the basis of standard products | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Further types of information and data identifiers are used by Beckhoff and serve internal processes.
Structure of the BIC
Example of composite information from item 1 to 4 and 6. The data identifiers are marked in red for better display:
BTN
An important component of the BIC is the Beckhoff Traceability Number (BTN, item no. 2). The BTN is a unique serial number consisting of eight characters that will replace all other serial number systems at Beckhoff in the long term (e.g. batch designations on IO components, previous serial number range for safety products, etc.). The BTN will also be introduced step by step, so it may happen that the BTN is not yet coded in the BIC.
Note
This information has been carefully prepared. However, the procedure described is constantly being further developed. We reserve the right to revise and change procedures and documentation at any time and without prior notice. No claims for changes can be made from the information, illustrations and descriptions in this information.


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49 5246 963 0
Fax: | +49 5246 963 198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49 5246 963 157
Fax: | +49 5246 963 9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49 5246 963 460
Fax: | +49 5246 963 479
e-mail: | service@beckhoff.com